代码编辑框支持库1

代码编辑框支持库 帮助手册20080808版 返回支持库手册 返回首页

本支持库提供了一个可以对代码进行风格处理的编辑框。

操作系统支持： Windows

窗口组件数据类型：

代码编辑框

其它数据类型：

代码编辑框常量

适用版本，代码编辑框支持库 （1.0#10版）


代码编辑框 窗口组件 操作系统支持：Windows 跳至：代码编辑框支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
只读模式 | 滚动条 | 空白区域填充模式 | 空白区域前景颜色
空白区域背景颜色 | 光标类型 | 行结束标志 | 显示行结束标志
选择文本前景色 | 选择文本背景色 | 光标颜色 | 光标所在行颜色模式
光标所在行背景颜色 | 光标闪烁间隔 | 光标宽度 | 编码
显示缩进向导 | 自动换行 |  |

方法：

取文本 | 置文本 | 取行文本 | 替换文本
取指定范围文本 | 取指定范围风格文本 | 保存点 | 加入文本
加入风格文本 | 追加文本 | 插入文本 | 清空编辑框
清除文档风格 | 取字符 | 取风格字符 | 置风格位
取风格位 | 查找文本 | 搜索标记 | 搜索下一个
搜索上一个 | 剪切 | 拷贝 | 粘贴
删除 | 是否能粘贴 | 拷贝指定范围 | 拷贝指定文本
撤消 | 重复 | 是否撤消 | 是否重复
清空撤消重复缓冲 | 置撤消重复操作 | 取撤消重复操作 | 取长度
取行数 | 取首个可视行行号 | 取可视行行数 | 取更改模式
选择文本 | 到指定位置 | 到指定行 | 取当前位置
取选择位置 | 选择所有文本 | 取位置所在行 | 取行开始位置
取行结束位置 | 取行长度 | 移动滚动条 | 转换行结束符
置旁注栏类型 | 取旁注栏类型 | 置旁注栏宽度 | 取旁注栏宽度
置旁注栏掩码 | 取旁注栏掩码 | 置旁注栏响应鼠标 | 取旁注栏响应鼠标
置旁注栏左像素长 | 取旁注栏左像素长 | 置旁注栏右像素长 | 取旁注栏右像素长
置折叠旁注栏主颜色 | 置折叠旁注栏加亮区颜色 | 置默认风格 | 清除所有风格
置风格字体 | 置风格字体大小 | 置风格粗体 | 置风格斜体
置风格下划线 | 置风格前景色 | 置风格背景色 | 置风格结束符填充
取位置所在列 | 取文本宽度 | 取文本高度 | 置词法分析器
取词法分析器 | 置关键字 | 取结束风格位置 | 开始风格
置文本风格 | 置扩展风格文本 | 置行状态 | 取行状态
取行状态总数 | 置TAB宽度 | 取TAB宽度 | 置TAB类型
取TAB类型 | 置缩进 | 取缩进 | 置TAB缩进
取TAB缩进 | 置退格去缩进 | 取退格去缩进 | 置行缩进
取行缩进 | 取行缩进位置 | 匹配括号加亮 | 不匹配括号加亮
查找匹配括号 | 置高亮向导 | 取高亮向导 | 定义标志
置标志前景色 | 置标志背景色 | 增加标志 | 删除标志
删除所有标志 | 取标志 | 下一个标志 | 上一个标志
取指定标志行 | 删除标志句柄 | 置指示器风格 | 取指示器风格
置指示器前景色 | 取指示器前景色 | 右键菜单 | 取文档指针
置文档指针 | 创建文档 | 增加文档引用 | 释放文档引用
显示自动完成 | 取消自动完成 | 自动完成活动 | 自动完成起点
自动完成 | 自动完成停止 | 置自动完成分隔符 | 取自动完成分隔符
自动完成选择 | 取自动完成当前项 | 置在开始时取消自动完成 | 取在开始时取消自动完成
置自动完成填充字符 | 置自动完成单选 | 取自动完成单选 | 置自动完成区分大小写
取自动完成区分大小写 | 置自动完成隐藏 | 取自动完成隐藏 | 置自动完成最大行数
取自动完成最大行数 | 置自动完成最大宽度 | 取自动完成最大宽度 | 显示用户列表
显示提示块 | 取消提示块 | 提示块活动 | 提示块开始位置
提示块高亮 | 提示块背景色 | 提示块前景色 | 提示块高亮色
取可视线 | 取文档线 | 显示行 | 隐藏行
行是否隐藏 | 置折叠层 | 取折叠层 | 置折叠标志
取最后子行 | 取父行 | 置折叠扩展 | 取折叠扩展
确保可见 | 着色 | 置属性 | 取属性
行折叠 | 取SC窗口句柄 | UTF8位置到字节位置 | 字节位置到UTF8位置
取UTF8字符串字节长度 |  |  |

自有事件：

更新界面 | 处理新字符 | 保存点开始 | 保存点结束
错误写操作 | 旁注栏被单击 | 显示完成 | 用户列表被选择
提示块被单击 | 自动完成项被选择 |  |

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


只读模式 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：逻辑型； 只读模式为“真”是代码风格编辑框只能读，不可以编辑。为“假”时可以编辑。

例程

说明

设定只读属性，代码编辑框内容不会被改变。

参见：例程


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 设置滚动条模式。

可供选择的属性值：
0、无
1、横向滚动条
2、纵向滚动条
3、横向及纵向滚动条

例程

说明

四种参数改变滚动条属性，纵向滚动条只有在文本超过代码编辑框高度时才会显示出来。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

空白区域填充模式 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 设置空白区域填充模式，空白区域指输入的空格字符或是Tab字符所造成的无可视字符区域，使用点填充空格字符，使用尖头填充Tab字符。

可供选择的属性值：
0、无
1、总是填充
2、首字符使用后填充

例程

说明

把代码编辑框里的空格符都用点来代替，首字符使用后填充是用点代替，（除空格外）第一个字符后面的空格符。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

空白区域前景颜色 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 设置空白区域前景颜色。

例程

说明

选择用来代替空格符号的点的颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

空白区域背景颜色 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 设置空白区域前景颜色。

例程

说明

选择代替空格符的位置使用的背景的颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

光标类型 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 光标类型。

可供选择的属性值：
0、普通
1、忙

例程

说明

普通光标为竖线，忙时为沙漏型。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

行结束标志 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 设置行结束标志，注：Mac使用\r，Unix使用\n，DOS，WINDOWS使用\r\n。

可供选择的属性值：
0、CRLF模式
1、CR模式
2、LF模式

例程

说明

“显示行结束标志”属性为真时，改变参数后直接在代码编辑框中显示出来。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示行结束标志 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：逻辑型； 显示行结束标志。

例程

说明

属性为真时显示结束标志，为假时不显示。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

选择文本前景色 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 选择文本后，文本的前景色。

例程

说明

选中一段文本后，设定被选中文本的颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

选择文本背景色 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 选择文本后，文本的背景色。

例程

说明

被选择文本区域的背景颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

光标颜色 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 光标的颜色。

例程

说明

光标颜色根据赋值不同，显示不同的颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

光标所在行颜色模式 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：逻辑型； 光标所在行的背景颜色。

例程

说明

属性为真时改变“光标所在行背景颜色”属性，所在行背景跟着改变。为假时不会改变。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

光标所在行背景颜色 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 光标所在行背景颜色，“光标所在行颜色模式”为真时有效。

例程

说明

“光标所在行背景颜色”属性为真时改变“光标所在行背景颜色”属性，所在行背景跟着改变。为假时不会改变。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

光标闪烁间隔 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 光标闪烁的间隔周期。

例程

说明

该整数属性为1000时，光标闪烁间隔为1秒。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

光标宽度 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 光标的宽度，单位为像素。

可供选择的属性值：
0、 0像素
1、 1像素
2、 2像素
3、 3像素

例程

说明

随着数值增大光标逐渐加宽。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

编码 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：整数型； 设置字符编码。

可供选择的属性值：
0、ANSI
1、UNICODE

例程

说明

更换编码属性，显示不同的文本格式。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示缩进向导 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：逻辑型； 显示缩进向导，缩进向导是缩进边缘的一条虚线。

例程

说明

为真时显示缩进向导，为假时隐藏虚线。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动换行 属性 所属对象：代码编辑框 操作系统支持：Windows

数据类型：逻辑型； 自动换行。

例程

说明

自动换行为真时，代码超出代码编辑框宽度时自动换行。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取文本 方法 操作系统支持：Windows 所属对象：代码编辑框

从代码风格编辑框中的第一个字符开始，取回指定长度的文本。

语法： 文本型 代码编辑框．取文本 （长度）

参数名 | 描 述
长度 | 必需的； 整数型。待取回文本的长度。

例程

说明

要取出全部文本，使用“取长度”方法取出文本长度做参数。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置文本 方法 操作系统支持：Windows 所属对象：代码编辑框

向代码风格编辑框中加入文本，用来替换原有的文本。

语法： 无返回值 代码编辑框．置文本 （文本）

参数名 | 描 述
文本 | 必需的； 文本型。置到代码风格编辑框中文本。

例程

说明

清空所有原有的文本，置入新文本。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行文本 方法 操作系统支持：Windows 所属对象：代码编辑框

取代码风格编辑框中的指定行的文本。

语法： 文本型 代码编辑框．取行文本 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。待取行行号。

例程

说明

取出一行文本，行号从0开始。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

替换文本 方法 操作系统支持：Windows 所属对象：代码编辑框

替换当前选择的文本，如果没有选择文本则插入到当前光标所在位置。

语法： 无返回值 代码编辑框．替换文本 （文本）

参数名 | 描 述
文本 | 必需的； 文本型。用来替换的文本。

例程

说明

用参数中的文本替换已经选中的文本，如果没有选中文本则把参数文本加到代码编辑框文本的末尾。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取指定范围文本 方法 操作系统支持：Windows 所属对象：代码编辑框

取代码风格编辑框中的从指定开始位置到指定结束位置之间的文本，位置从0开始。

语法： 文本型 代码编辑框．取指定范围文本 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。获得文本的开始位置。
结束位置 | 必需的； 整数型。获得文本的结束位置。

例程

说明

开始位置为0，结束位置为1，取出的是位置为0的文本。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取指定范围风格文本 方法 操作系统支持：Windows 所属对象：代码编辑框

取代码风格编辑框中的指定开始及结束范围的风格文本。

语法： 字节集 代码编辑框．取指定范围风格文本 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。获得文本的开始位置。
结束位置 | 必需的； 整数型。获得文本的结束位置。

例程

说明

取出的风格为字节集型，可以在“加入风格文本”方法中作为参数使用。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

保存点 方法 操作系统支持：Windows 所属对象：代码编辑框

设置文档的保存点，“撤消”或“重做”时以二次保存点之间的操作为单位进行恢复。

语法： 无返回值 代码编辑框．保存点 （）

例程

说明

每一次进行撤销会退回到上一个保存点设置的位置，重复则补充文本内容到当前位置下一个保存点。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

加入文本 方法 操作系统支持：Windows 所属对象：代码编辑框

在当前光标位置插入文本。

语法： 无返回值 代码编辑框．加入文本 （文本， 插入长度）

参数名 | 描 述
文本 | 必需的； 文本型。待插入的文本。
插入长度 | 必需的； 整数型，初始值为“-1”。插入到当前光标位置的文本长度，为-1时插入完整文本。

例程

说明

根据“插入长度”参数的数值取出“待插入的文本”从开始到相应长度的文本。插入到光标所在位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

加入风格文本 方法 操作系统支持：Windows 所属对象：代码编辑框

在当前光标位置插入风格文本。

语法： 无返回值 代码编辑框．加入风格文本 （字节集， 插入长度）

参数名 | 描 述
字节集 | 必需的； 字节集。待插入的风格文本。
插入长度 | 必需的； 整数型，初始值为“-1”。插入到当前光标位置的文本长度，为-1时插入完整风格文本。

例程

说明

根据给定的长度取出对应的风格文本，插入光标处。

参见： 例程


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

追加文本 方法 操作系统支持：Windows 所属对象：代码编辑框

在文档结尾追加文本。

语法： 无返回值 代码编辑框．追加文本 （文本， 追加长度）

参数名 | 描 述
文本 | 必需的； 文本型。待追加的文本。
追加长度 | 必需的； 整数型，初始值为“-1”。追加到结尾的文本长度，为-1时追加完整文本。

例程

说明

取出“待追加的文本”相应长度，添加到代码编辑框文本的最后面。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

插入文本 方法 操作系统支持：Windows 所属对象：代码编辑框

在指定位置插入文本。

语法： 无返回值 代码编辑框．插入文本 （插入位置， 文本）

参数名 | 描 述
插入位置 | 必需的； 整数型。插入文本的位置，如果为-1则插入到当前位置。
文本 | 必需的； 文本型。待插入文本。

例程

说明

在指定位置插入“待插入文本”。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

清空编辑框 方法 操作系统支持：Windows 所属对象：代码编辑框

如果不是只读模式，则清空编辑框中所有文本。

语法： 无返回值 代码编辑框．清空编辑框 （）

例程

说明

使编辑框内容为空。在只读属性时无效。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

清除文档风格 方法 操作系统支持：Windows 所属对象：代码编辑框

清除编辑框中文档的风格。

语法： 无返回值 代码编辑框．清除文档风格 （）

例程

说明

清除所有文档的风格，不会清除文本本身。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取字符 方法 操作系统支持：Windows 所属对象：代码编辑框

返回指定位置上的字符，出错返回空。

语法： 文本型 代码编辑框．取字符 （位置）

参数名 | 描 述
位置 | 必需的； 整数型。指定获取字符的位置。

例程

说明

取代码编辑框指定位置的一个字符。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取风格字符 方法 操作系统支持：Windows 所属对象：代码编辑框

返回指定位置上的风格字符，出错返回0。

语法： 字节型 代码编辑框．取风格字符 （位置）

参数名 | 描 述
位置 | 必需的； 整数型。指定获取风格字符的位置。

例程

说明

取出指定位置上的一个风格字符，汉字占两个字符取出为乱码。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格位 方法 操作系统支持：Windows 所属对象：代码编辑框

设置风格位的位长度，最大可以使用7位作为风格位，剩下的作为指示器位。默认使用5位作为风格位。

语法： 无返回值 代码编辑框．置风格位 （位长度）

参数名 | 描 述
位长度 | 必需的； 整数型。指定风格位位长度。

例程

说明

设定整个代码编辑框风格位的长度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取风格位 方法 操作系统支持：Windows 所属对象：代码编辑框

取风格位的位长度。

语法： 整数型 代码编辑框．取风格位 （）

例程

说明

取出代码编辑框之前设置的风格位长度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

查找文本 方法 操作系统支持：Windows 所属对象：代码编辑框

在文档中根据指定的查找方式查找文本，查找结果保存在“符合文本开始位置”及“符合文本结束位置”中，查找失败返回假，上述2个变量无意义。

语法： 逻辑型 代码编辑框．查找文本 （查找方式， 开始查找位置， 结束查找位置， 待查找文本， ［符合文本开始位置］， ［符合文本结束位置］）

参数名 | 描 述
查找方式 | 必需的； 整数型。查找文本的方式，可以为“#代码编辑框常量.全字匹配”或“#代码编辑框常量.区分大小写”或“#代码编辑框常量.正则表达式”。
开始查找位置 | 必需的； 整数型。开始查找的字符位置。
结束查找位置 | 必需的； 整数型。结束查找的字符位置。
待查找文本 | 必需的； 文本型。待查找的文本。
符合文本开始位置 | 可选的； 整数型，参数数据只能提供变量。匹配到的符合要求的文本在文档中的开始位置。
符合文本结束位置 | 可选的； 整数型，参数数据只能提供变量。匹配到的符合要求的文本在文档中的结束位置。

例程

说明

查找匹配的字符或字符段，获得一个合格的结果的开始位置和结束位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

搜索标记 方法 操作系统支持：Windows 所属对象：代码编辑框

以当前光标位置作为“搜索下一个”与“搜索上一个”命令开始搜索的位置标记。

语法： 逻辑型 代码编辑框．搜索标记 （）

例程

说明

以光标位置作为定位前后的基本位置，查询上一个符合内容和下一个符合内容的分界点。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

搜索下一个 方法 操作系统支持：Windows 所属对象：代码编辑框

以指定查找方式查找已被找到文本的下一个指定文本，返回符合的文本的开始位置，失败返回-1。

语法： 整数型 代码编辑框．搜索下一个 （查找方式， 待查找文本）

参数名 | 描 述
查找方式 | 必需的； 整数型。查找文本的方式，可以为“#代码编辑框常量.全字匹配”或“#代码编辑框常量.区分大小写”或“#代码编辑框常量.正则表达式”。
待查找文本 | 必需的； 文本型。待查找的文本。

例程

说明

查找在标记后第一个符合条件的文本的开始位置。根据参数不同查询的结果也不同。

全字匹配，必须待查文本与空格间的一串字符完全一样。

区分大小写，在区分大小写的基础上，在一长串文本中一个连续段符合条件也会返回开始位置。

正则表达式，必须符合正则表达式的格式。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

搜索上一个 方法 操作系统支持：Windows 所属对象：代码编辑框

以指定查找方式查找已被找到文本的上一个指定文本，返回符合的文本的开始位置，失败返回-1。

语法： 整数型 代码编辑框．搜索上一个 （查找方式， 待查找文本）

参数名 | 描 述
查找方式 | 必需的； 整数型。查找文本的方式，可以为“#代码编辑框常量.全字匹配”或“#代码编辑框常量.区分大小写”或“#代码编辑框常量.正则表达式”。
待查找文本 | 必需的； 文本型。待查找的文本。

例程

说明

查找在标记前第一个符合条件的文本的开始位置。根据参数不同查询的结果也不同。

全字匹配，必须待查文本与空格间的一串字符完全一样。

区分大小写，在区分大小写的基础上，在一长串文本中一个连续段符合条件也会返回开始位置。

正则表达式，必须符合正则表达式的格式。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

剪切 方法 操作系统支持：Windows 所属对象：代码编辑框

对选定文本进行剪切。

语法： 无返回值 代码编辑框．剪切 （）

例程

说明

剪切选中的文本区域，在代码编辑框和其他组件都可以使用。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

拷贝 方法 操作系统支持：Windows 所属对象：代码编辑框

把选中的数据拷贝到剪切板中。

语法： 无返回值 代码编辑框．拷贝 （）

例程

说明

复制代码编辑框被选中的内容，不改变原内容。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

粘贴 方法 操作系统支持：Windows 所属对象：代码编辑框

把剪切板中的数据粘贴到当前位置。

语法： 无返回值 代码编辑框．粘贴 （）

例程

说明

把剪切或复制的内容，粘贴到当前位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

删除 方法 操作系统支持：Windows 所属对象：代码编辑框

删除选中数据。

语法： 无返回值 代码编辑框．删除 （）

例程

说明

删除选中的代码编辑框中的文本。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

是否能粘贴 方法 操作系统支持：Windows 所属对象：代码编辑框

是否允许粘贴。

语法： 逻辑型 代码编辑框．是否能粘贴 （）

例程

说明

如果有复制或剪切过的内容返回真，否则返回假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

拷贝指定范围 方法 操作系统支持：Windows 所属对象：代码编辑框

拷贝指定范围内的数据到剪切板。

语法： 无返回值 代码编辑框．拷贝指定范围 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。开始拷贝位置。
结束位置 | 必需的； 整数型。结束拷贝位置。

例程

说明

结束位置与开始位置的差为1时，只拷贝一个单位的字符。同理差为2时是两个。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

拷贝指定文本 方法 操作系统支持：Windows 所属对象：代码编辑框

拷贝指定文本到剪切板。

语法： 无返回值 代码编辑框．拷贝指定文本 （文本）

参数名 | 描 述
文本 | 必需的； 文本型。拷贝到剪切板中的文本。

例程

说明

拷贝一段文本，用“粘贴”方法可以把它加入到代码编辑框当前位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

撤消 方法 操作系统支持：Windows 所属对象：代码编辑框

撤消操作，撤消上一个保存点。

语法： 无返回值 代码编辑框．撤消 （）

例程

说明

取消至上一个保存点之后的所有操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

重复 方法 操作系统支持：Windows 所属对象：代码编辑框

重复操作，重复到下一个保存点。

语法： 无返回值 代码编辑框．重复 （）

例程

说明

执行过撤销后，用于恢复撤销时进行的操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

是否撤消 方法 操作系统支持：Windows 所属对象：代码编辑框

是否允许撤消操作，允许返回真，不允许返回假。

语法： 逻辑型 代码编辑框．是否撤消 （）

例程

说明

是否还有可以撤销的内容，如果还有返回真，否则返回假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

是否重复 方法 操作系统支持：Windows 所属对象：代码编辑框

是否允许重复操作，允许返回真，不允许返回假。

语法： 逻辑型 代码编辑框．是否重复 （）

例程

说明

如果还有可以重复的步骤返回真，否则返回假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

清空撤消重复缓冲 方法 操作系统支持：Windows 所属对象：代码编辑框

清空撤消重复缓冲。

语法： 无返回值 代码编辑框．清空撤消重复缓冲 （）

例程

说明

用了此方法后所有保存点都被取消，撤销重复操作都不会有效果。再次改变内容后才可以进行相应操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置撤消重复操作 方法 操作系统支持：Windows 所属对象：代码编辑框

设置撤消重复操作 真为记录撤消重复操，假为不记录撤消重复操作。

语法： 无返回值 代码编辑框．置撤消重复操作 （是否记录）

参数名 | 描 述
是否记录 | 必需的； 逻辑型。是否记录撤消重复操作。

例程

说明

在参数为负的时候所有的操作都是不可撤销和重复的，但可以对赋值为负时之前的操作进行撤销和重复。

从赋值为真时开始之后的操作可以进行撤销和重复。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取撤消重复操作 方法 操作系统支持：Windows 所属对象：代码编辑框

取撤消重复操作 返回真为记录撤消重复操，返回假为不记录撤消重复操作。

语法： 逻辑型 代码编辑框．取撤消重复操作 （）

例程

说明

判断当前是否可以进行撤销重复操作，以确认和修改属性进行相应的操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取长度 方法 操作系统支持：Windows 所属对象：代码编辑框

取所有文本长度。

语法： 整数型 代码编辑框．取长度 （）

例程

说明

取出代码编辑框所有文本长度


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行数 方法 操作系统支持：Windows 所属对象：代码编辑框

取总行数，代码风格编辑框为空时行数为1。

语法： 整数型 代码编辑框．取行数 （）

例程

说明

取出当前代码。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取首个可视行行号 方法 操作系统支持：Windows 所属对象：代码编辑框

取得代码风格编辑框可视区内的首个可是行行号，行号从0开始。

语法： 整数型 代码编辑框．取首个可视行行号 （）

例程

说明

隐藏的行将被忽略，取得可视的第一行的行号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取可视行行数 方法 操作系统支持：Windows 所属对象：代码编辑框

取得代码风格编辑框可视区内的行数。

语法： 整数型 代码编辑框．取可视行行数 （）

例程

说明

统计所有属性为可视的行数，返回整数值。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取更改模式 方法 操作系统支持：Windows 所属对象：代码编辑框

取文档更改模式，根据“保存点”后是否进行更改来判断。如果文档更改过返回真，否则返回假。

语法： 逻辑型 代码编辑框．取更改模式 （）

例程

说明

此命令是判断如果保存以后没有再更改过，就不用再一次的运行保存命令。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

选择文本 方法 操作系统支持：Windows 所属对象：代码编辑框

选取文本，如果“结束位置”为负数则选择到文本结束。

语法： 无返回值 代码编辑框．选择文本 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。开始选取的位置。
结束位置 | 必需的； 整数型。结束选取的位置。

例程

说明

在代码中实现选中一部分文本，对文本进行操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

到指定位置 方法 操作系统支持：Windows 所属对象：代码编辑框

移动到指定位置。

语法： 无返回值 代码编辑框．到指定位置 （目标位置）

参数名 | 描 述
目标位置 | 必需的； 整数型。移动到的目标位置。

例程

说明

光标移动到代码编辑框指定的位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

到指定行 方法 操作系统支持：Windows 所属对象：代码编辑框

移动到指定行。

语法： 无返回值 代码编辑框．到指定行 （目标行）

参数名 | 描 述
目标行 | 必需的； 整数型。移动到的目标行。

例程

说明

把光标移动到指定行的开头位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取当前位置 方法 操作系统支持：Windows 所属对象：代码编辑框

取当前位置。

语法： 整数型 代码编辑框．取当前位置 （）

例程

说明

获取当前光标所在的位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取选择位置 方法 操作系统支持：Windows 所属对象：代码编辑框

取选择位置。

语法： 无返回值 代码编辑框．取选择位置 （［开始位置］， ［结束位置］）

参数名 | 描 述
开始位置 | 可选的； 整数型，参数数据只能提供变量。开始选择位置。
结束位置 | 可选的； 整数型，参数数据只能提供变量。结束选择位置。

例程

说明

给两个参数赋值，代码编辑框被选择的文本区域的开始位置和结束位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

选择所有文本 方法 操作系统支持：Windows 所属对象：代码编辑框

选择所有文本。

语法： 无返回值 代码编辑框．选择所有文本 （）

例程

说明

选中代码编辑框里所有的文本。隐藏的行业能被复制并显示出来。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取位置所在行 方法 操作系统支持：Windows 所属对象：代码编辑框

取指定位置所在的行。

语法： 整数型 代码编辑框．取位置所在行 （位置）

参数名 | 描 述
位置 | 必需的； 整数型。指定待转换到行的位置。

例程

说明

取当前光标所在行号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行开始位置 方法 操作系统支持：Windows 所属对象：代码编辑框

取行开始位置，如果行号为负数则取当前所在行的开始位置。

语法： 整数型 代码编辑框．取行开始位置 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。待取行行号。

例程

说明

行号从0开始。给行号为负返回零；超出行数范围返回-1。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行结束位置 方法 操作系统支持：Windows 所属对象：代码编辑框

取指定行结束位置。

语法： 整数型 代码编辑框．取行结束位置 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。待取行行号。

例程

说明

取出指定行数的结束位置，在整个代码编辑框中所在处位置。如果参数行数超过当前已有的行数范围，则取出所有文本的最后一个字符的位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行长度 方法 操作系统支持：Windows 所属对象：代码编辑框

取指定行长度。

语法： 整数型 代码编辑框．取行长度 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行行号。

例程

说明

取参数所表示的行的所有文本数目。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

移动滚动条 方法 操作系统支持：Windows 所属对象：代码编辑框

移动滚动条，向右或向下移动指定的行与列，如果为负数则向相反的方向移动。

语法： 整数型 代码编辑框．移动滚动条 （列号， 行号）

参数名 | 描 述
列号 | 必需的； 整数型。指定列号。
行号 | 必需的； 整数型。指定行号。

例程

说明

用参数控制光标上下左右移动。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

转换行结束符 方法 操作系统支持：Windows 所属对象：代码编辑框

转换当前文档的行结束符，“0”为CRLF模式，“1”为CR模式，“2”为LF模式。

语法： 无返回值 代码编辑框．转换行结束符 （行结束模式）

参数名 | 描 述
行结束模式 | 必需的； 整数型。指定行结束模式。

例程

说明

三种结束Windows格式, UNIX格式,MAC格式.


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置旁注栏类型 方法 操作系统支持：Windows 所属对象：代码编辑框

设置旁注栏类型，旁注栏：从0到2，类型：0 为符号，1为数字。

语法： 无返回值 代码编辑框．置旁注栏类型 （旁注号， 类型号）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。
类型号 | 必需的； 整数型。0为符号，1为数字。

例程

说明

旁注栏类型为数字时会根据代码行进行自动编号。从1开始。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取旁注栏类型 方法 操作系统支持：Windows 所属对象：代码编辑框

取置旁注栏类型，旁注栏：从0到2，类型：0 为符号，1为数字。

语法： 整数型 代码编辑框．取旁注栏类型 （旁注号）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。

例程

说明

取出设置过的旁注号对应的旁注栏类型


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置旁注栏宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

设置旁注栏宽度，单位为像素。

语法： 无返回值 代码编辑框．置旁注栏宽度 （旁注号， 宽度）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。
宽度 | 必需的； 整数型。单位为像素。

例程

说明

根据所给参数设置0到2号旁注栏的宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取旁注栏宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

取得旁注栏宽度，单位为像素。

语法： 整数型 代码编辑框．取旁注栏宽度 （旁注号）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。

例程

说明

取出相应旁注号的旁注栏宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置旁注栏掩码 方法 操作系统支持：Windows 所属对象：代码编辑框

为高级用户提供，初级用户无需掌握；
设置指定旁注栏掩码。

语法： 无返回值 代码编辑框．置旁注栏掩码 （旁注号， 掩码）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。
掩码 | 必需的； 整数型。掩码。

例程

说明

设定一个旁注号相对应的掩码。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取旁注栏掩码 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定旁注栏掩码。

语法： 整数型 代码编辑框．取旁注栏掩码 （旁注号）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。

例程

说明

取出设定过的一个旁注号相对应的掩码。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置旁注栏响应鼠标 方法 操作系统支持：Windows 所属对象：代码编辑框

设置旁注栏可以响应鼠标单击，并触发“旁注栏被单击”事件。

语法： 无返回值 代码编辑框．置旁注栏响应鼠标 （旁注号， 是否响应）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。
是否响应 | 必需的； 逻辑型。是否响应鼠标单击。

例程

说明

“是否响应”为真的时候，鼠标点击旁注栏会触发相应事件。否则点击将不出现任何效果。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取旁注栏响应鼠标 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定旁注栏是否支持鼠标响应，支持返回真，不支持返回假。

语法： 逻辑型 代码编辑框．取旁注栏响应鼠标 （旁注号）

参数名 | 描 述
旁注号 | 必需的； 整数型。旁注号从0到2。

例程

说明

取出旁注栏是否会对鼠标的点击做出反应，然后进行下一步操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置旁注栏左像素长 方法 操作系统支持：Windows 所属对象：代码编辑框

设置旁注栏左边到文档的象素距离。

语法： 无返回值 代码编辑框．置旁注栏左像素长 （像素长）

参数名 | 描 述
像素长 | 必需的； 整数型。像素长度。

例程

说明

设置旁注栏与每行代码第一个字符之间的长度。数值越大间隔越大。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取旁注栏左像素长 方法 操作系统支持：Windows 所属对象：代码编辑框

取旁注栏左边到文档的象素距离。

语法： 整数型 代码编辑框．取旁注栏左像素长 （）

例程

说明

取出当前旁注栏左边与为文本第一个字符之间的像素长度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置旁注栏右像素长 方法 操作系统支持：Windows 所属对象：代码编辑框

设置旁注栏右边到文档的象素距离。

语法： 无返回值 代码编辑框．置旁注栏右像素长 （像素长）

参数名 | 描 述
像素长 | 必需的； 整数型。像素长度。

例程

说明

设置旁注栏右边到文档右边的像素长度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取旁注栏右像素长 方法 操作系统支持：Windows 所属对象：代码编辑框

取得旁注栏右边到文档的象素距离。

语法： 整数型 代码编辑框．取旁注栏右像素长 （）

例程

说明

取出设置好的旁注栏右边与文档右边的像素长度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置折叠旁注栏主颜色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置折叠旁注栏主颜色。

语法： 无返回值 代码编辑框．置折叠旁注栏主颜色 （是否设置， 颜色）

参数名 | 描 述
是否设置 | 必需的； 逻辑型。是否设置折叠旁注栏主颜色。
颜色 | 必需的； 整数型。颜色值。

例程

说明

设定折叠旁注栏主颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置折叠旁注栏加亮区颜色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置折叠旁注栏加亮区颜色。

语法： 无返回值 代码编辑框．置折叠旁注栏加亮区颜色 （是否设置， 颜色）

参数名 | 描 述
是否设置 | 必需的； 逻辑型。是否设置折叠旁注栏加亮区颜色。
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置折叠旁注加亮区的颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置默认风格 方法 操作系统支持：Windows 所属对象：代码编辑框

使用默认风格。

语法： 无返回值 代码编辑框．置默认风格 （）

例程

说明

设置代码编辑框的风格为默认。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

清除所有风格 方法 操作系统支持：Windows 所属对象：代码编辑框

清除所有风格。

语法： 无返回值 代码编辑框．清除所有风格 （）

例程

说明

清除所有已经设置过的风格。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格字体 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的字体。

语法： 无返回值 代码编辑框．置风格字体 （风格号， 字体名称）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
字体名称 | 必需的； 文本型。字体的名称。

例程

说明

设置指定风格号文本在代码编辑框显示的字体。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格字体大小 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的字体大小。

语法： 无返回值 代码编辑框．置风格字体大小 （风格号， 字体大小）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
字体大小 | 必需的； 整数型。字体的大小。

例程

说明

设置指定风格号文本在编辑框中显示的字的大小。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格粗体 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的文本是否为粗体。

语法： 无返回值 代码编辑框．置风格粗体 （风格号， 是否粗体）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
是否粗体 | 必需的； 逻辑型。是否为粗体。

例程

说明

根据逻辑参数设置指定风格号字体是否加粗。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格斜体 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的文本是否为斜体。

语法： 无返回值 代码编辑框．置风格斜体 （风格号， 是否斜体）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
是否斜体 | 必需的； 逻辑型。是否为斜体。

例程

说明

根据逻辑值参数设置指定风格号字体是否是斜体。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格下划线 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的文本是否带下划线。

语法： 无返回值 代码编辑框．置风格下划线 （风格号， 是否下划线）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
是否下划线 | 必需的； 逻辑型。是否为下划线。

例程

说明

根据逻辑参数设置指定风格的字体的下划线。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格前景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的前景色。

语法： 无返回值 代码编辑框．置风格前景色 （风格号， 颜色）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
颜色 | 必需的； 整数型。颜色值。

例程

说明

调用支持库常量定义指定风格，进行颜色设定。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格背景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定风格的背景色。

语法： 无返回值 代码编辑框．置风格背景色 （风格号， 颜色）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
颜色 | 必需的； 整数型。颜色值。

例程

说明

调用支持库常量定义指定风格，进行颜色设定。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置风格结束符填充 方法 操作系统支持：Windows 所属对象：代码编辑框

设置风格结束符填充。

语法： 无返回值 代码编辑框．置风格结束符填充 （风格号， 颜色）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置风格结束符填充。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取位置所在列 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定位置所在的列。

语法： 整数型 代码编辑框．取位置所在列 （指定位置）

参数名 | 描 述
指定位置 | 必需的； 整数型。指定的位置。

例程

说明

取出光标当前位置所在的列数。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取文本宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

取得取文本宽度。

语法： 整数型 代码编辑框．取文本宽度 （风格号， 文本）

参数名 | 描 述
风格号 | 必需的； 整数型。指定风格号，风格号范围从0-127，其中32-39系统保留为“风格_*”常量使用。
文本 | 必需的； 文本型。任意文本。

例程

说明

根据风格参数的来取得一种风格下某文本的宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取文本高度 方法 操作系统支持：Windows 所属对象：代码编辑框

取得取文本高度。

语法： 整数型 代码编辑框．取文本高度 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。

例程

说明

取某一行风格文本的高度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置词法分析器 方法 操作系统支持：Windows 所属对象：代码编辑框

设置词法分析器，词法分析器为“词法分析器_*”常量，设置词法分析器后系统会对输入的文本进行语法加量的处理。

语法： 无返回值 代码编辑框．置词法分析器 （分析器编号）

参数名 | 描 述
分析器编号 | 必需的； 整数型。分析器的编号。

例程

说明

设置一种词法分析器，配合该分析器对应的常量，进行代码的风格设置。

参见： 例程


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取词法分析器 方法 操作系统支持：Windows 所属对象：代码编辑框

取得当前使用的词法分析器。

语法： 整数型 代码编辑框．取词法分析器 （）

例程

说明

取出已经设置的词法分析器的类型，值与常量值对应。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置关键字 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定的关键字用于词法处理，经过系统处理后这些关键字会使用指定的风格加亮。

语法： 无返回值 代码编辑框．置关键字 （关键字序号， 关键字列表）

参数名 | 描 述
关键字序号 | 必需的； 整数型。关键字的序号。
关键字列表 | 必需的； 文本型。关键字的列表。

例程

说明

设定一个风格的关键字，进行高亮颜色设置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取结束风格位置 方法 操作系统支持：Windows 所属对象：代码编辑框

取得结束风格处理的位置。

语法： 整数型 代码编辑框．取结束风格位置 （）

例程

说明

取得风格文本结束的位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

开始风格 方法 操作系统支持：Windows 所属对象：代码编辑框

开始进行风格处理。

语法： 无返回值 代码编辑框．开始风格 （位置， 掩码）

参数名 | 描 述
位置 | 必需的； 整数型。指定位置。
掩码 | 必需的； 整数型。掩码。

例程

说明

指定一个文本位置,开始进行风格文本的设置.


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置文本风格 方法 操作系统支持：Windows 所属对象：代码编辑框

设置文本风格。

语法： 无返回值 代码编辑框．置文本风格 （位置， 风格）

参数名 | 描 述
位置 | 必需的； 整数型。指定位置。
风格 | 必需的； 字节型。风格。

例程

说明

查出一个风格常量的整数值，根据位置和风格编号设置文本风格。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置扩展风格文本 方法 操作系统支持：Windows 所属对象：代码编辑框

设置扩展风格文本。

语法： 无返回值 代码编辑框．置扩展风格文本 （长度， 风格数组）

参数名 | 描 述
长度 | 必需的； 整数型。指定长度。
风格数组 | 必需的； 字节型，参数数据只能提供变量数组。风格数组。

例程

说明


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置行状态 方法 操作系统支持：Windows 所属对象：代码编辑框

设置行状态。

语法： 无返回值 代码编辑框．置行状态 （行号， 值）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。
值 | 必需的； 整数型。行上所附加的值。

例程

说明

给指定的行号加一个附加值。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行状态 方法 操作系统支持：Windows 所属对象：代码编辑框

取得行状态。

语法： 整数型 代码编辑框．取行状态 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。

例程

说明

取得设置好的指定行状态。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行状态总数 方法 操作系统支持：Windows 所属对象：代码编辑框

取得行状态总数。

语法： 整数型 代码编辑框．取行状态总数 （）

例程

说明

取得从0行到已设置行状态的最大编号的行的总数。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置TAB宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

设置TAB键的宽度。

语法： 无返回值 代码编辑框．置TAB宽度 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。

例程

说明

设置按下TAB键间隔的像素单位。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取TAB宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

取得TAB键的宽度。

语法： 整数型 代码编辑框．取TAB宽度 （）

例程

说明

取得设置的按下TAB键的宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置TAB类型 方法 操作系统支持：Windows 所属对象：代码编辑框

设置TAB键的类型，为假时所有的TAB与缩进使用空格填充，默认为真。

语法： 无返回值 代码编辑框．置TAB类型 （使用TAB）

参数名 | 描 述
使用TAB | 必需的； 逻辑型。使用TAB键。

例程

说明

根据逻辑值参数设置TAB键的类型，改变设置对之前的输入没有效果。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取TAB类型 方法 操作系统支持：Windows 所属对象：代码编辑框

取得TAB键的类型。

语法： 逻辑型 代码编辑框．取TAB类型 （）

例程

说明

取得表示TAB键类型的逻辑值。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

设置缩进宽度。

语法： 无返回值 代码编辑框．置缩进 （缩进宽度）

参数名 | 描 述
缩进宽度 | 必需的； 整数型。缩进的宽度。

例程

说明

设置按下一次TAB键的像素宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

取得缩进宽度。

语法： 整数型 代码编辑框．取缩进 （）

例程

说明

取得设置的TAB键缩进像素宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置TAB缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

设置是否使用TAB缩进。

语法： 无返回值 代码编辑框．置TAB缩进 （是否使用TAB缩进）

参数名 | 描 述
是否使用TAB缩进 | 必需的； 逻辑型。是否使用TAB缩进。

例程

说明

根据逻辑值设定是否使用TAB缩进。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取TAB缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

取得是否使用TAB缩进。

语法： 逻辑型 代码编辑框．取TAB缩进 （）

例程

说明

取得设定的是否使用TAB缩进。返回“真”代表使用，“假”代表不使用。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置退格去缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

设置是否按退格键时去掉完整缩进，为真是设置，为假则按TAB键处理。

语法： 无返回值 代码编辑框．置退格去缩进 （使用缩进）

参数名 | 描 述
使用缩进 | 必需的； 逻辑型。使用缩进。

例程

说明

此方法参数为真时，空格键将按照TAB键缩紧，为假时按空格键退去一格。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取退格去缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

取得是否按退格键时去掉完整缩进。

语法： 逻辑型 代码编辑框．取退格去缩进 （）

例程

说明

取出现在状态是否使用了“退格去缩进”。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置行缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定行缩进。

语法： 无返回值 代码编辑框．置行缩进 （行号， 缩进）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。
缩进 | 必需的； 整数型。缩进。

例程

说明

根据行号设置该行的从第一个字符位置到代码编辑框左边的距离。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行缩进 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定行缩进。

语法： 整数型 代码编辑框．取行缩进 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。

例程

说明

取行号参数指定的行的行缩进长度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取行缩进位置 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定行缩进的结束位置。

语法： 整数型 代码编辑框．取行缩进位置 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。

例程

说明

取出指定行第一个不是TAB缩进的字符之前（包括缩进位在内）所存在的字符之和。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

匹配括号加亮 方法 操作系统支持：Windows 所属对象：代码编辑框

对一对匹配的括号进行加亮处理，使用“#代码编辑框常量.风格_匹配括号”风格。

语法： 无返回值 代码编辑框．匹配括号加亮 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。开始的位置。
结束位置 | 必需的； 整数型。结束的位置。

例程

说明

设置好匹配括号风格的颜色，然后调用此命令就会出现高亮效果。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

不匹配括号加亮 方法 操作系统支持：Windows 所属对象：代码编辑框

对不匹配的括号进行加亮处理，使用“#代码编辑框常量.风格_不匹配括号”风格。

语法： 无返回值 代码编辑框．不匹配括号加亮 （位置）

参数名 | 描 述
位置 | 必需的； 整数型。指定位置。

例程

说明

先设置不匹配的括号风格，然后调用此命令显示高亮效果。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

查找匹配括号 方法 操作系统支持：Windows 所属对象：代码编辑框

根据给定的括号开始位置查找它所对应的括号的结束的位置，支持括号类型为“(, [, {, <”。

语法： 整数型 代码编辑框．查找匹配括号 （开始位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。开始的位置。

例程

说明

指定一个括号的位置，返回它对应的另一个半所在的位置。失败返回-1。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置高亮向导 方法 操作系统支持：Windows 所属对象：代码编辑框

当选种匹配括号时，使用本命令可以使括号之间的缩进向导高亮显示，使用“#代码编辑框常量.风格_匹配括号”风格。设置0为取消高亮。

语法： 无返回值 代码编辑框．置高亮向导 （列号）

参数名 | 描 述
列号 | 必需的； 整数型。列号。

例程

说明

设置某一列的高亮向导。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取高亮向导 方法 操作系统支持：Windows 所属对象：代码编辑框

取高亮向导。

语法： 整数型 代码编辑框．取高亮向导 （）

例程

说明

取出设置过得高亮向导。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

定义标志 方法 操作系统支持：Windows 所属对象：代码编辑框

系统内部设有32个标记槽，标志号范围0-31，其中25-31保留给了“折叠状态_*”常量用做折叠标志。其他的可以自行定不同的标志，范围为“标志样式_*”常量。

语法： 无返回值 代码编辑框．定义标志 （标志号， 标志类型）

参数名 | 描 述
标志号 | 必需的； 整数型。标志号。
标志类型 | 必需的； 整数型。标志类型。

例程

说明

指定一个标志号所显示的标志的类型，在代码编辑框中显示不同的图形。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置标志前景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定标志号的前景色。

语法： 无返回值 代码编辑框．置标志前景色 （标志号， 颜色）

参数名 | 描 述
标志号 | 必需的； 整数型。指定标志号。
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置指定的标志号的前景颜色，在代码编辑框中显示出来。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置标志背景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定标志号的背景色。

语法： 无返回值 代码编辑框．置标志背景色 （标志号， 颜色）

参数名 | 描 述
标志号 | 必需的； 整数型。指定标志号。
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置指定的标志号的背景颜色，在代码编辑框中显示出来。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

增加标志 方法 操作系统支持：Windows 所属对象：代码编辑框

在指定位置增加指定标志号的标志。

语法： 整数型 代码编辑框．增加标志 （行号， 标志号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。
标志号 | 必需的； 整数型。指定标志号。

例程

说明

在对应行上增加一个标志。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

删除标志 方法 操作系统支持：Windows 所属对象：代码编辑框

删除指定行的指定标志。

语法： 无返回值 代码编辑框．删除标志 （行号， 标志号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。
标志号 | 必需的； 整数型。指定标志号。

例程

说明

删除指定行上的标志。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

删除所有标志 方法 操作系统支持：Windows 所属对象：代码编辑框

删除所有指定标志。

语法： 无返回值 代码编辑框．删除所有标志 （标志号）

参数名 | 描 述
标志号 | 必需的； 整数型。指定标志号。

例程

说明

删除代码编辑框所有已经设置过的标志。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取标志 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定行的标志。

语法： 整数型 代码编辑框．取标志 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。

例程

说明

取出该行设定标志的标志号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

下一个标志 方法 操作系统支持：Windows 所属对象：代码编辑框

取得下一个标志的行号。

语法： 整数型 代码编辑框．下一个标志 （行号， 标志掩码）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。
标志掩码 | 必需的； 整数型。标志掩码。

例程

说明

以参数行号为基准，返回第一个大于这个行号并有标志的的行的行号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

上一个标志 方法 操作系统支持：Windows 所属对象：代码编辑框

取得上一个标志的行号。

语法： 无返回值 代码编辑框．上一个标志 （行号， 标志掩码）

参数名 | 描 述
行号 | 必需的； 整数型。指定行号。
标志掩码 | 必需的； 整数型。标志掩码。

例程

说明

以参数行号为基准，返回第一个小于这个行号并有标志的的行的行号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取指定标志行 方法 操作系统支持：Windows 所属对象：代码编辑框

根据句柄取得指定标志行，句柄为“增加标志”命令的返回值。

语法： 整数型 代码编辑框．取指定标志行 （句柄）

参数名 | 描 述
句柄 | 必需的； 整数型。句柄。

例程

说明

根据增加标志时返回的句柄，确定该标志在哪一行。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

删除标志句柄 方法 操作系统支持：Windows 所属对象：代码编辑框

删除指定句柄的标志，句柄为“增加标志”命令的返回值。

语法： 无返回值 代码编辑框．删除标志句柄 （句柄）

参数名 | 描 述
句柄 | 必需的； 整数型。句柄。

例程

说明

根据增加标志时返回的句柄，确定标志然后删除标志。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置指示器风格 方法 操作系统支持：Windows 所属对象：代码编辑框

风格数据中有3位用来表示指示器风格，即指示器有7个槽，指示器号范围0-6。本命令可以指定指示器号所对应的指示器风格类型。指示器风格类型为“指示器风格_*”。

语法： 无返回值 代码编辑框．置指示器风格 （指示器号， 指示器风格）

参数名 | 描 述
指示器号 | 必需的； 整数型。指示器号。
指示器风格 | 必需的； 整数型。指示器的风格。

例程

说明

设定指示器风格。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取指示器风格 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指示器的风格。

语法： 整数型 代码编辑框．取指示器风格 （指示器号）

参数名 | 描 述
指示器号 | 必需的； 整数型。指示器号。

例程

说明

取出设定的指示器的风格。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置指示器前景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置指定指示器的前景色。

语法： 无返回值 代码编辑框．置指示器前景色 （指示器号， 颜色）

参数名 | 描 述
指示器号 | 必需的； 整数型。指示器号。
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置指定指示器的前景色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取指示器前景色 方法 操作系统支持：Windows 所属对象：代码编辑框

取得指定指示器的前景色。

语法： 整数型 代码编辑框．取指示器前景色 （指示器号）

参数名 | 描 述
指示器号 | 必需的； 整数型。指示器号。

例程

说明

取出设定好的指示器前景颜色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

右键菜单 方法 操作系统支持：Windows 所属对象：代码编辑框

是否允许弹出右键菜单。

语法： 无返回值 代码编辑框．右键菜单 （右键菜单）

参数名 | 描 述
右键菜单 | 必需的； 逻辑型。是否使用右键菜单。

例程

说明

逻辑值参数为真，代码编辑框上点击鼠标右键弹出菜单，否则没有效果。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取文档指针 方法 操作系统支持：Windows 所属对象：代码编辑框

为高级用户提供，初级用户无需掌握；
取当前文档的文档指针。

语法： 整数型 代码编辑框．取文档指针 （）

例程

说明

取得代码编辑框文档的指针，进行相应的操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置文档指针 方法 操作系统支持：Windows 所属对象：代码编辑框

为高级用户提供，初级用户无需掌握；
设置当前文档的文档指针，原有文档的引用记数会被减1，新置入的文档的引用记数会被加1，注意：当文档的引用记数为0时文档资源会被释放。

语法： 无返回值 代码编辑框．置文档指针 （文档指针）

参数名 | 描 述
文档指针 | 必需的； 整数型。文档指针。

例程

说明

文档指针数值错误时会导致程序推出。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

创建文档 方法 操作系统支持：Windows 所属对象：代码编辑框

为高级用户提供，初级用户无需掌握；
创建一个新文档，返回文档指针，并且文档的引用记数加1。

语法： 整数型 代码编辑框．创建文档 （）

例程

说明

获得一个新建文档的指针。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

增加文档引用 方法 操作系统支持：Windows 所属对象：代码编辑框

为高级用户提供，初级用户无需掌握；
增加文档的引用记数，返回增加后的引用记数。

语法： 整数型 代码编辑框．增加文档引用 （文档指针）

参数名 | 描 述
文档指针 | 必需的； 整数型。文档指针。

例程

说明

如果出错很容易造成程序退出。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

释放文档引用 方法 操作系统支持：Windows 所属对象：代码编辑框

为高级用户提供，初级用户无需掌握；
释放文档的引用记数，返回释放后的引用记数，注意：当文档的引用记数为0时文档资源会被释放。

语法： 整数型 代码编辑框．释放文档引用 （文档指针）

参数名 | 描 述
文档指针 | 必需的； 整数型。文档指针。

例程

说明

命令使用错误很容易导致程序退出。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示自动完成 方法 操作系统支持：Windows 所属对象：代码编辑框

显示自动完成列表框。

语法： 无返回值 代码编辑框．显示自动完成 （进入长度， 列表）

参数名 | 描 述
进入长度 | 必需的； 整数型。进入长度。
列表 | 必需的； 文本型。列表。

例程

说明

进步长度的作用，选择列表后去掉选项的前几位字符后把该文本输入到代码编辑框中.


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取消自动完成 方法 操作系统支持：Windows 所属对象：代码编辑框

取消自动完成列。

语法： 无返回值 代码编辑框．取消自动完成 （）

例程

说明

取消已经弹出的自动完成列表。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动完成活动 方法 操作系统支持：Windows 所属对象：代码编辑框

检验自动完成是否活动，活动返回真，不活动返回假。

语法： 逻辑型 代码编辑框．自动完成活动 （）

例程

说明

如果自动完成是显示状态返回真，否则返回假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动完成起点 方法 操作系统支持：Windows 所属对象：代码编辑框

返回列表显示时文档光标当时的位置。

语法： 整数型 代码编辑框．自动完成起点 （）

例程

说明

返回自动完成显示时光标当前的位置，自动完成不显示时返回0。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动完成 方法 操作系统支持：Windows 所属对象：代码编辑框

将文本自动添入文档中，与按下TAB键的效果相同。

语法： 无返回值 代码编辑框．自动完成 （）

例程

说明

使用本方法后在自动完成列表被选择后会把列表内容输入到代码编辑框.


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动完成停止 方法 操作系统支持：Windows 所属对象：代码编辑框

设置停止字符列表，当遇到这些字符时，自动完成将被取消，开始编辑时这个列表是空的。

语法： 无返回值 代码编辑框．自动完成停止 （列表）

参数名 | 描 述
列表 | 必需的； 文本型。列表。

例程

说明

自定义一个字符列表，列表中字符将控制自动完成的结束。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成分隔符 方法 操作系统支持：Windows 所属对象：代码编辑框

设置自动完成分隔符，用来分割“显示自动完成”命令中设置的字符列表。

语法： 无返回值 代码编辑框．置自动完成分隔符 （分隔字符）

参数名 | 描 述
分隔字符 | 必需的； 字节型。指定分隔字符。

例程

说明

自定义自动显示列表的分隔符，默认分隔符为空格。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成分隔符 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成分隔符。

语法： 字节型 代码编辑框．取自动完成分隔符 （）

例程

说明

取出设置的分隔自动完成列表的分隔符，默认为空格符。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动完成选择 方法 操作系统支持：Windows 所属对象：代码编辑框

在自动完成列表中匹配指定的文本，默认情况区分大小写的，可以使用“取自动完成当前项”命令取回选择的项。

语法： 无返回值 代码编辑框．自动完成选择 （选择文本）

参数名 | 描 述
选择文本 | 必需的； 文本型。指定选择文本。

例程

说明

如果自动完成列表中有一项，则把该项设置为选中。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成当前项 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成当前项。

语法： 整数型 代码编辑框．取自动完成当前项 （）

例程

说明

返回当前选择的列表项在列表中的位置，位置从0开始。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置在开始时取消自动完成 方法 操作系统支持：Windows 所属对象：代码编辑框

设置在文档光标等于自动完成列表显示时的位置相等时，是否取消自动完成列表，为真则取消，为假则不取消，默认为真。

语法： 无返回值 代码编辑框．置在开始时取消自动完成 （是否删除）

参数名 | 描 述
是否删除 | 必需的； 逻辑型。是否删除。

例程

说明

在文档光标等于自动列表开始显示的位置时，是否显示自动列表。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取在开始时取消自动完成 方法 操作系统支持：Windows 所属对象：代码编辑框

取得是否在开始时取消自动完成。

语法： 逻辑型 代码编辑框．取在开始时取消自动完成 （）

例程

说明

取出“置在开始时取消自动完成”所设置的值，如果没有设置，则取出的是默认值真。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成填充字符 方法 操作系统支持：Windows 所属对象：代码编辑框

如果在自动完成列表显示时输入了填充字符，当前被选择的文本将被增加到文档中，并且填充字符也被增加进文档中。一些通用的填充字符是“(”，“[”，“.”。根据语言的不同还有一些其它的字符可以作为填充字符。默认情况下不设置填充字符。

语法： 无返回值 代码编辑框．置自动完成填充字符 （列表）

参数名 | 描 述
列表 | 必需的； 文本型。指定列表。

例程

说明

如果在自动完成列表显示时输入了填充字符，当前被选择的文本将被增加到文档中，并且填充字符也被增加进文档中。一些通用的填充字符是“(”，“[”，“.”。根据语言的不同还有一些其它的字符可以作为填充字符。默认情况下不设置填充字符。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成单选 方法 操作系统支持：Windows 所属对象：代码编辑框

如果本命令设置为真时，自动完成列表框中只有一个选项，系统将自动把这个选项中的文本增加到文档中，同时列表框被隐藏。默认情况下即使只有一条选项也不隐藏自动完成列表框。

语法： 无返回值 代码编辑框．置自动完成单选 （单一选定）

参数名 | 描 述
单一选定 | 必需的； 逻辑型。是否单一选定。

例程

说明

如果本命令设置为真时，即使自动完成列表中有多个选项，也只显示一个选项，系统将自动把这个选项中的文本增加到文档中，同时列表框被隐藏。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成单选 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成单选。

语法： 逻辑型 代码编辑框．取自动完成单选 （）

例程

说明

该方法取出的是“置自动完成单选”方法所设置的值真或假，如果没有设置“置自动完成单选”，则取出的是默认值假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成区分大小写 方法 操作系统支持：Windows 所属对象：代码编辑框

本命令用来设置是否区分大小写。默认情况下，输入文本与自动完成列表框中的文本成员匹配时是区分大小写的。

语法： 无返回值 代码编辑框．置自动完成区分大小写 （忽略大小写）

参数名 | 描 述
忽略大小写 | 必需的； 逻辑型。是否忽略大小写。

例程

说明

用来设置输入文本与列表框中的文本对应时是否区分大小写。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成区分大小写 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成是否区分大小写。

语法： 逻辑型 代码编辑框．取自动完成区分大小写 （）

例程

说明

取出是否自动完成区分大小写，在没有使用“置自动完成区分大小写”命令设置自动完成区分大小写时，取出的是默认值假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成隐藏 方法 操作系统支持：Windows 所属对象：代码编辑框

设置是否隐藏，默认情况下，如果用户输入的文本不能与列表中的文本匹配，列表会被隐藏。如果不想隐藏而是继续显示，可以通过使用本命令并把参数设为假来实现。

语法： 无返回值 代码编辑框．置自动完成隐藏 （自动隐藏）

参数名 | 描 述
自动隐藏 | 必需的； 逻辑型。是否自动隐藏。

例程

说明

设置用户输入的文本与列表框中的文本匹配时，列表框显示。不匹配时列表框隐藏。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成隐藏 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成隐藏。

语法： 逻辑型 代码编辑框．取自动完成隐藏 （）

例程

说明

取得自动完成隐藏。返回逻辑值真或假。如果没有置自动完成隐藏，则返回的是默认值真。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成最大行数 方法 操作系统支持：Windows 所属对象：代码编辑框

本命令用来设置自动完成列表框中最多显示的行数，如果多出最大行数则显示一个滚动条，默认为5。

语法： 无返回值 代码编辑框．置自动完成最大行数 （最大高度）

参数名 | 描 述
最大高度 | 必需的； 整数型。最大高度。

例程

说明

设置自动完成列表中最多显示的行数。最少显示一行。如果设置要显示的行数多出列表中的行数，则只显示列表中已有的行。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成最大行数 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成最大行数。

语法： 整数型 代码编辑框．取自动完成最大行数 （）

例程

说明

取得自动完成最大行数。如果没有置自动完成最大行数，将取出置自动完成最大行数的默认值5。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置自动完成最大宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

设置自动完成列表中每行显示的最大宽度，为0时系统将计算一个合适的宽度，默认为0。

语法： 无返回值 代码编辑框．置自动完成最大宽度 （最大宽度）

参数名 | 描 述
最大宽度 | 必需的； 整数型。最大宽度。

例程

说明

设置自动完成列表中每行显示的最大宽度。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取自动完成最大宽度 方法 操作系统支持：Windows 所属对象：代码编辑框

取得自动完成最大宽度。

语法： 无返回值 代码编辑框．取自动完成最大宽度 （）

例程

说明

取得设置好的自动完成列表的显示宽度


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示用户列表 方法 操作系统支持：Windows 所属对象：代码编辑框

本命令用来显示用户自定义列表，“列表类型”参数会在“用户列表被选择”事件中通过“列表类型”参数传回给用户。用户可以根据此类型区分不同的列表，从而实现不同的列表。用户定义列表与自动完成列表的内部结构是一样的，所以你可以使用自动完成列表相关的命令来控制用户列表。不同在于：1 “置自动完成单选”命令无效。2 用户选择某项后将触发“用户列表被选择”消息。注意：如果设置了“填充字符”或“停止字符”，那么它们还是有效的。

语法： 无返回值 代码编辑框．显示用户列表 （列表类型， 列表）

参数名 | 描 述
列表类型 | 必需的； 整数型。列表类型。
列表 | 必需的； 文本型。列表。

例程

说明

本命令用来显示用户自定义的列表。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示提示块 方法 操作系统支持：Windows 所属对象：代码编辑框

显示提示块，如果已经有一个显示的提示块则本次调用无效果。开始位置指定了在文档中指定字符位置显示提示块。提示块是一个在用户输入函数名后用来提示函数参数的小窗口，它与自动完成列表是有冲突的，它们之间只有一个可是活动状态即只能有一个是可见的。如果提示块被显示出来自动完成列表将隐藏，如果显示一个自动完成列表框，显示的提示块同样将隐藏。

语法： 无返回值 代码编辑框．显示提示块 （开始位置， 提示文本）

参数名 | 描 述
开始位置 | 必需的； 整数型。指定开始位置。
提示文本 | 必需的； 文本型。指定提示文本。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取消提示块 方法 操作系统支持：Windows 所属对象：代码编辑框

隐藏显示的提示块。

语法： 无返回值 代码编辑框．取消提示块 （）

例程

说明

将已经显示的提示块隐藏。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块活动 方法 操作系统支持：Windows 所属对象：代码编辑框

返回提示块是否为活动状态，返回真表示获得，返回假表示不活动。

语法： 逻辑型 代码编辑框．提示块活动 （）

例程

说明

取得提示块的活动状态，显示提示块返回真，不显示提示块返回假。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块开始位置 方法 操作系统支持：Windows 所属对象：代码编辑框

返回“显示提示块”命令设置的开始位置。

语法： 无返回值 代码编辑框．提示块开始位置 （）

例程

说明

取得显示提示块所设置的开始位置。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块高亮 方法 操作系统支持：Windows 所属对象：代码编辑框

在提示块中指定区域内的文本被高亮显示，指定的区域从0开始。

语法： 无返回值 代码编辑框．提示块高亮 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。指定开始位置。
结束位置 | 必需的； 整数型。指定结束位置。

例程

说明

高亮显示提示块中指定区域内的文本，指定的区域从0开始。如果没有选择提示块高亮色，则默认色为蓝色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块背景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置提示块背景色，默认为白色。

语法： 无返回值 代码编辑框．提示块背景色 （颜色）

参数名 | 描 述
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置提示块的背景颜色（可与显示提示块配合使用）。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块前景色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置提示块前景色，即文本颜色，默认为灰色。

语法： 无返回值 代码编辑框．提示块前景色 （颜色）

参数名 | 描 述
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置提示块中文本的颜色。默认为灰色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块高亮色 方法 操作系统支持：Windows 所属对象：代码编辑框

设置提示块高亮文本色，即被选择文本的颜色，默认为深蓝色。

语法： 无返回值 代码编辑框．提示块高亮色 （颜色）

参数名 | 描 述
颜色 | 必需的； 整数型。颜色值。

例程

说明

设置提示块高亮文本色（此方法可以与显示提示块、提示块高亮配合使用）。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取可视线 方法 操作系统支持：Windows 所属对象：代码编辑框

如果没有折叠线，返回“文档线”，否则返回可视线，（可视线从0开始）如果“文档线”超出文档范围，则返回-1。

语法： 整数型 代码编辑框．取可视线 （文档行）

参数名 | 描 述
文档行 | 必需的； 整数型。文档行。

例程

说明

如果没有折叠线，返回“文档线”，否则返回可视线（可视线从0开始）。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取文档线 方法 操作系统支持：Windows 所属对象：代码编辑框

返回可视线所对应的文档线，如果可视线小于等于0，返回0。否则返回文档线。

语法： 整数型 代码编辑框．取文档线 （显示行）

参数名 | 描 述
显示行 | 必需的； 整数型。显示行。

例程

说明

返回可视线所对应的文档线（显示行的是否折叠，将影响所对应的文档线）。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示行 方法 操作系统支持：Windows 所属对象：代码编辑框

显示指定范围的线，本命令引起重画，本消息不影响折叠行层次及标志。

语法： 无返回值 代码编辑框．显示行 （开始行， 结束行）

参数名 | 描 述
开始行 | 必需的； 整数型。开始行。
结束行 | 必需的； 整数型。结束行。

例程

说明

显示指定的行。行索引从0开始。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

隐藏行 方法 操作系统支持：Windows 所属对象：代码编辑框

隐藏指定范围的线，本命令引起重画，本消息不影响折叠行层次及标志。

语法： 无返回值 代码编辑框．隐藏行 （开始行， 结束行）

参数名 | 描 述
开始行 | 必需的； 整数型。开始行。
结束行 | 必需的； 整数型。结束行。

例程

说明

隐藏指定的行（其中代码编辑框的第一行不能隐藏）。行号索引从0开始。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

行是否隐藏 方法 操作系统支持：Windows 所属对象：代码编辑框

如果指定行可视返回，隐藏返回0，本消息不影响折叠行层次及标志。

语法： 整数型 代码编辑框．行是否隐藏 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。

例程

说明

指定行可视返回1,隐藏返回0。如果指定的行号不存在也返回0。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置折叠层 方法 操作系统支持：Windows 所属对象：代码编辑框

置折叠层。

语法： 无返回值 代码编辑框．置折叠层 （行号， 层号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。
层号 | 必需的； 整数型。层号。

例程

说明

将指定的行置为折叠层。其中“行号”参数的值必须小于或等于代码编辑框中的总行数。否则将会失败。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取折叠层 方法 操作系统支持：Windows 所属对象：代码编辑框

取折叠层。

语法： 整数型 代码编辑框．取折叠层 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。

例程

说明

取出指定行的折叠层号。如果该行未设置折叠层，则返回1024。如果预取的行号不存在，则同样返回1024。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置折叠标志 方法 操作系统支持：Windows 所属对象：代码编辑框

置折叠标志。折叠标志控制了当设置折叠属性为1，并且当前词法分析器支持折叠时正文中折叠线的显示类型。1 当折叠展开时，画出折叠框架。2 当折叠展开时，在折叠处上方画折叠线。4 当折叠收缩时，在折叠处上方画折叠线。8 当折叠展开时，在折叠处下方画折叠线。16 当折叠收缩时，在折叠处下方画折叠线。64 在旁注栏显示16进制的折叠层号。本命令为初级对象成员命令。

语法： 无返回值 代码编辑框．置折叠标志 （标志）

参数名 | 描 述
标志 | 必需的； 整数型。标志。

例程

说明

置折叠标志。可以设置折叠展开或折叠收缩时，折叠线的显示位置以及折叠层号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取最后子行 方法 操作系统支持：Windows 所属对象：代码编辑框

取最后子行。

语法： 整数型 代码编辑框．取最后子行 （行号， 层号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。
层号 | 必需的； 整数型。层号。

例程

说明

取出最后子行的函数


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取父行 方法 操作系统支持：Windows 所属对象：代码编辑框

取父行。

语法： 整数型 代码编辑框．取父行 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。

例程

说明

取父行的行号。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置折叠扩展 方法 操作系统支持：Windows 所属对象：代码编辑框

置折叠扩展。

语法： 无返回值 代码编辑框．置折叠扩展 （行号， 是否展开）

参数名 | 描 述
行号 | 必需的； 整数型。行号。
是否展开 | 必需的； 逻辑型。是否展开。

例程

说明

该方法用于设置指定行是否可以扩展。当设置“是否展开”参数为真时，指定行可以扩展，为假则不可以扩展。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取折叠扩展 方法 操作系统支持：Windows 所属对象：代码编辑框

取折叠扩展。

语法： 逻辑型 代码编辑框．取折叠扩展 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。

例程

说明

取出该行是否可以折叠扩展，返回值为真，则可以折叠扩展；返回值为假，则不可以折叠扩展。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

确保可见 方法 操作系统支持：Windows 所属对象：代码编辑框

确保可见。

语法： 无返回值 代码编辑框．确保可见 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。行号。

例程

说明

将指定的行设置为确保可见行。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

着色 方法 操作系统支持：Windows 所属对象：代码编辑框

对“开始位置”到“结束位置”内的文本调用当前设置的词法分析器进行着色，如果结束位置为-1则从“开始位置”到全文结束位置。如果设置了缩进属性，即：使用“置属性”把“fold”设置为1，并且缩进层次也已经设置，则会使用缩进功能，本命令将引发重画。

语法： 无返回值 代码编辑框．着色 （开始位置， 结束位置）

参数名 | 描 述
开始位置 | 必需的； 整数型。指定开始位置。
结束位置 | 必需的； 整数型。指定结束位置。

例程

说明

调用当前设置的词法分析器，对文本进行着色，从“开始位置”开始到“结束位置”为止。如果结束位置为-1则从“开始位置”到全文结束位置都进行着色。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

置属性 方法 操作系统支持：Windows 所属对象：代码编辑框

本命令可以用与和“词法分析器”通信，它本质上是一个散列，即一个键名对应一个键值。比如：使用“fold”键名来控制缩进，当键值为1时，开启缩进功能。

语法： 无返回值 代码编辑框．置属性 （键名， 键值）

参数名 | 描 述
键名 | 必需的； 文本型。散列的键名。
键值 | 必需的； 文本型。散列的键值。

例程

说明

一个健名对应一个键值，编辑框21中的内容对应编辑框20中的内容。

（其中键名和键值都不可以为空，如果为空，则置属性失败。）


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

取属性 方法 操作系统支持：Windows 所属对象：代码编辑框

取指定键名的键值，如果不存在返回空文本。

语法： 文本型 代码编辑框．取属性 （键名）

参数名 | 描 述
键名 | 必需的； 文本型。散列的键名。

例程

说明

将指定键名的键值取出。如果返回空文本，则表示该键名不存在。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

行折叠 方法 操作系统支持：Windows 所属对象：代码编辑框

对指定行进行折叠操作，如果为折叠状态则转换到展开状态，如果为展开状态则转换到折叠状态。

语法： 文本型 代码编辑框．行折叠 （行号）

参数名 | 描 述
行号 | 必需的； 整数型。指定的行号。

例程

说明

折叠状态互相转换。


取SC窗口句柄 方法 操作系统支持：Windows 所属对象：代码编辑框

因为Scintilla窗口有一个与它大小完全一样的父窗口，使用“取窗口句柄”命令取出来的是SC窗口的父窗口的句柄，而本命令可以取出SC窗口的句柄。

语法： 整数型 代码编辑框．取SC窗口句柄 （）

例程

说明

对比两个命令可以看出组件窗口与sc窗口之间的关系。


UTF8位置到字节位置 方法 操作系统支持：Windows 所属对象：代码编辑框

Scintilla内部对数据的存储采用了UTF8编码格式英文字母数字占用1个字节，中文占用3个字节。并且它本身提供的涉及位置的API所使用的位置单位都是字节，所以这就对处理中文（以及其它亚洲国家的语言，比如日文，韩文等）造成了很多不便。本命令的功能就是处理UTF8位置转换到字节位置。当需要对多语言混合的数据进行定位时，可以把它们的位置单位看成UFT8，然后使用本命令转换为字节单位，接下来就可以使用其它命令进行处理了。位置从0开始，如果位置超出数据长度返回0。

语法： 整数型 代码编辑框．UTF8位置到字节位置 （UTF8位置）

参数名 | 描 述
UTF8位置 | 必需的； 整数型。以UTF8作为单位长度的位置。

例程

说明

给出一个UTF8位单位的位置，返回一个以字节为单位的位置。


字节位置到UTF8位置 方法 操作系统支持：Windows 所属对象：代码编辑框

把字节位置转换为UTF8位置既无论是中文还是英文位置单位都是1，详细信息见上。

语法： 整数型 代码编辑框．字节位置到UTF8位置 （字节位置）

参数名 | 描 述
字节位置 | 必需的； 整数型。以字节作为单位长度的位置。

例程

说明

参数给出一个以字节为单位的位置，返回一个以UTF8位单位的位置。


取UTF8字符串字节长度 方法 操作系统支持：Windows 所属对象：代码编辑框

把SBCS及DBCS转换到UTF8编码格式并返回它的字节长度，本命令一般用在“处理新字符”事件中确定输入字符的开始位置。

语法： 整数型 代码编辑框．取UTF8字符串字节长度 （字符串）

参数名 | 描 述
字符串 | 必需的； 文本型。SBCS及DBCS字符串。

例程

说明

取出一段UTF8字符串的字节长度返回整数值。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

更新界面 事件 所属对象：代码编辑框 操作系统支持：Windows

系统允许更新界面时，触发本事件。

语法： 无返回值 _代码编辑框_更新界面 （）

例程

说明

代码编辑框有字符操作时可以触发此事件。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

处理新字符 事件 所属对象：代码编辑框 操作系统支持：Windows

系统处理输入字符后触发本事件，一般使用本事件处理自动完成或提示块。

语法： 无返回值 _代码编辑框_处理新字符 （接收到的字符）

参数名 | 描 述
接收到的字符 | 整数型； 参数值为接收到的字符。

例程

说明

代码编辑框内容被改变时出发本事件，进行相应的操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

保存点开始 事件 所属对象：代码编辑框 操作系统支持：Windows

保存点开始时触发本事件。

语法： 无返回值 _代码编辑框_保存点开始 （）

例程

说明

调用“保存点”方法设置保存点时触发这个事件，进行操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

保存点结束 事件 所属对象：代码编辑框 操作系统支持：Windows

保存点结束时触发本事件。

语法： 无返回值 _代码编辑框_保存点结束 （）

例程

说明

在指定位置设置保存点结束后，触发该事件进行相应的操作。

参见: 例程


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

错误写操作 事件 所属对象：代码编辑框 操作系统支持：Windows

只读模式下，试图改变编辑框中内容时触发本事件。

语法： 无返回值 _代码编辑框_错误写操作 （）

例程

说明

在不同的属性下(错误的状态)进行代码编辑框的操作,会出发本事件.如:在“只读”情况下进行输入操作


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

旁注栏被单击 事件 所属对象：代码编辑框 操作系统支持：Windows

旁注栏被单击时触发本事件。

语法： 无返回值 _代码编辑框_旁注栏被单击 （功能键状态， 单击位置， 旁注号）

参数名 | 描 述
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
单击位置 | 整数型； 与旁注栏被单击处相关联的行的开始位置。
旁注号 | 整数型； 被单击旁注的旁注号。

例程

说明

“置旁注栏响应鼠标”方法参数为真时，点击旁注栏才会触发本事件。为假时不会触发。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

显示完成 事件 所属对象：代码编辑框 操作系统支持：Windows

系统显示完成时触发本事件，用于选择性的更新一些其它的相关窗口。

语法： 无返回值 _代码编辑框_显示完成 （）

例程

说明

在代码编辑框完成更新显示后触发本事件，进行相应的操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

用户列表被选择 事件 所属对象：代码编辑框 操作系统支持：Windows

用户定义列表中的某项被选择时触发本事件。

语法： 无返回值 _代码编辑框_用户列表被选择 （列表类型， 文本）

参数名 | 描 述
列表类型 | 整数型； 显示列表命令中所指定的类型。
文本 | 文本型； 被选择的文本。

例程

说明

用户列表弹出，被点击选择后触发本事件。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

提示块被单击 事件 所属对象：代码编辑框 操作系统支持：Windows

提示块被单击时触发，本事件主要用于在函数名过载或函数不同时显示下一个函数原形。

语法： 无返回值 _代码编辑框_提示块被单击 （位置）

参数名 | 描 述
位置 | 整数型； 返回1，表示在上箭头处单击， 返回2，表示在下箭头处单击， 返回0，表示在其它位置单击。

例程

说明

“显示提示块”方法显示以后，点击提示块后触发本事件。进行相应的操作。


滚动条 属性 所属对象：代码编辑框 操作系统支持：Windows

自动完成项被选择 事件 所属对象：代码编辑框 操作系统支持：Windows

自动完成列表中某项被选择时触发本事件，本事件在被选择的文本插入到文档之前被触发，可以使用“取消自动完成”命令在事件处理子程序返回之前取消被选择文本插入到文档中。

语法： 无返回值 _代码编辑框_自动完成项被选择 （位置， 文本）

参数名 | 描 述
位置 | 整数型； 在被匹配的文本中的开始位置。
文本 | 文本型； 被选择的文本。

例程

说明

设置自动完成方法后触发本事件，进行相应的操作。

参见： 例程


代码编辑框常量 枚举常量集合类型 操作系统支持：Windows 跳至：代码编辑框支持库

本数据类型包括了代码编辑框用到的常量。

成员 | 描 述
全字匹配 | 常量值为 2 。匹配使用空格分割的字符串，只有字符串全部字符匹配成功时才认为匹配成功。
区分大小写 | 常量值为 4 。匹配时区分大小写。
正则表达式 | 常量值为 2097152 。使用正则表达式进行匹配。
词法分析器_CONTAINER | 常量值为 0 。CONTAINER的词法分析器。
词法分析器_NULL | 常量值为 1 。NULL的词法分析器。
词法分析器_PYTHON | 常量值为 2 。PYTHON的词法分析器。
词法分析器_CPP | 常量值为 3 。CPP的词法分析器。
词法分析器_HTML | 常量值为 4 。HTML的词法分析器。
词法分析器_XML | 常量值为 5 。XML的词法分析器。
词法分析器_PERL | 常量值为 6 。PERL的词法分析器。
词法分析器_SQL | 常量值为 7 。SQL的词法分析器。
词法分析器_VB | 常量值为 8 。VB的词法分析器。
词法分析器_MAKEFILE | 常量值为 11 。MAKEFILE的词法分析器。
词法分析器_BATCH | 常量值为 12 。BATCH的词法分析器。
词法分析器_LUA | 常量值为 15 。LUA的词法分析器。
词法分析器_DIFF | 常量值为 16 。DIFF的词法分析器。
词法分析器_LISP | 常量值为 21 。LISP的词法分析器。
词法分析器_RUBY | 常量值为 22 。RUBY的词法分析器。
词法分析器_VBSCRIPT | 常量值为 28 。VBSCRIPT的词法分析器。
词法分析器_MATLAB | 常量值为 32 。MATLAB的词法分析器。
词法分析器_ASM | 常量值为 34 。ASM的词法分析器。
词法分析器_FORTRAN | 常量值为 36 。FORTRAN的词法分析器。
词法分析器_CSS | 常量值为 38 。CSS的词法分析器。
词法分析器_BASIC | 常量值为 51 。BASIC的词法分析器。
词法分析器_HASKELL | 常量值为 68 。HASKELL的词法分析器。
词法分析器_PHPSCRIPT | 常量值为 69 。PHPSCRIPT的词法分析器。
词法分析器_SMALLTALK | 常量值为 72 。SMALLTALK的词法分析器。
词法分析器_ASP | 常量值为 29 。ASP的词法分析器。
词法分析器_PHP | 常量值为 30 。PHP的词法分析器。
风格_PYTHON_默认 | 常量值为 0 。PYTHON的默认关键字风格。
风格_PYTHON_注释行 | 常量值为 1 。PYTHON的注释行风格。
风格_PYTHON_数字 | 常量值为 2 。PYTHON的数字风格。
风格_PYTHON_字符串 | 常量值为 3 。PYTHON的字符串风格。
风格_PYTHON_字符 | 常量值为 4 。PYTHON的字符风格。
风格_PYTHON_关键字 | 常量值为 5 。PYTHON的关键字风格。
风格_PYTHON_三单引号 | 常量值为 6 。PYTHON的三单引号风格。
风格_PYTHON_三双引号 | 常量值为 7 。PYTHON的三双引号风格。
风格_PYTHON_类名 | 常量值为 8 。PYTHON的类名风格。
风格_PYTHON_函数名 | 常量值为 9 。PYTHON的函数名风格。
风格_PYTHON_操作符 | 常量值为 10 。PYTHON的操作符风格。
风格_PYTHON_标识符 | 常量值为 11 。PYTHON的标识符风格。
风格_PYTHON_注释块 | 常量值为 12 。PYTHON的注释块风格。
风格_PYTHON_串结束符 | 常量值为 13 。PYTHON的串结束符风格。
风格_CPP_默认 | 常量值为 0 。CPP的默认风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_注释 | 常量值为 1 。CPP的注释风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_注释行 | 常量值为 2 。CPP的注释行风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_注释文档 | 常量值为 3 。CPP的注释文档风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_数字 | 常量值为 4 。CPP的数字风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_关键字 | 常量值为 5 。CPP的关键字风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_字符串 | 常量值为 6 。CPP的字符串风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_字符 | 常量值为 7 。CPP的字符风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_UUID | 常量值为 8 。CPP的UUID风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_预处理程序 | 常量值为 9 。CPP的预处理程序风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_操作符 | 常量值为 10 。CPP的操作符风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_标识符 | 常量值为 11 。CPP的标识符风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_字符结束 | 常量值为 12 。CPP的字符结束风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_VERBATIM | 常量值为 13 。CPP的VERBATIM风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_正则表达式 | 常量值为 14 。CPP的正则表达式风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_注释行文档 | 常量值为 15 。CPP的注释行文档风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_关键字二 | 常量值为 16 。CPP的关键字二风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_注释关键字文档 | 常量值为 17 。CPP的注释文档关键字风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_注释错误关键字文档 | 常量值为 18 。CPP的注释错误关键字文档风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_CPP_全局类 | 常量值为 19 。CPP的全局类风格，与CPP语法风格相近的语言也可以使用本风格，如C语言。
风格_HTML_默认 | 常量值为 0 。HTML的默认风格。
风格_HTML_标志 | 常量值为 1 。HTML的标志风格。
风格_HTML_未知标志 | 常量值为 2 。HTML的未知标志风格。
风格_HTML_属性 | 常量值为 3 。HTML的属性风格。
风格_HTML_未知属性 | 常量值为 4 。HTML的未知属性风格。
风格_HTML_数字 | 常量值为 5 。HTML的数字风格。
风格_HTML_双引号字符串 | 常量值为 6 。HTML的双引号字符串风格。
风格_HTML_单引号字符串 | 常量值为 7 。HTML的单引号字符串风格。
风格_HTML_其它 | 常量值为 8 。HTML的其它风格。
风格_HTML_注释 | 常量值为 9 。HTML的注释风格。
风格_HTML_实体 | 常量值为 10 。HTML的实体风格。
风格_HTML_标志结束 | 常量值为 11 。HTML的标志结束风格。
风格_HTML_XML开始 | 常量值为 12 。HTML的XML开始风格。
风格_HTML_XML结束 | 常量值为 13 。HTML的XML结束风格。
风格_HTML_脚本 | 常量值为 14 。HTML的脚本风格。
风格_HTML_ASP | 常量值为 15 。HTML的ASP风格。
风格_HTML_询问 | 常量值为 18 。HTML的询问风格。
风格_HTML_值 | 常量值为 19 。HTML的值风格。
风格_JS_开始标志 | 常量值为 40 。JS的开始标志风格。
风格_JS_默认 | 常量值为 41 。JS的默认风格。
风格_JS_注释 | 常量值为 42 。JS的注释风格。
风格_JS_注释行 | 常量值为 43 。JS的注释行风格。
风格_JS_注释文档 | 常量值为 44 。JS的注释文档风格。
风格_JS_数字 | 常量值为 45 。JS的数字风格。
风格_JS_其它字符 | 常量值为 46 。JS的变量风格。
风格_JS_关键字 | 常量值为 47 。JS的关键字风格。
风格_JS_双引号字符串 | 常量值为 48 。JS的双引号字符串风格风格。
风格_JS_单引号字符串 | 常量值为 49 。JS的单引号字符串风格。
风格_JS_操作符 | 常量值为 50 。JS的操作符风格。
风格_JS_串结束符 | 常量值为 51 。JS的串结束符风格。
风格_JS_正则表达式 | 常量值为 52 。JS的正则表达式风格。
风格_VBS_开始标志 | 常量值为 70 。VBS的开始标志风格。
风格_VBS_默认 | 常量值为 71 。VBS的默认风格。
风格_VBS_注释行 | 常量值为 72 。VBS的注释行风格。
风格_VBS_数字 | 常量值为 73 。VBS的数字风格。
风格_VBS_关键字 | 常量值为 74 。VBS的关键字风格。
风格_VBS_字符串 | 常量值为 75 。VBS的字符串风格。
风格_VBS_标识符 | 常量值为 76 。VBS的标识符风格。
风格_VBS_串结束符 | 常量值为 77 。VBS的串结束符风格。
风格_PHP_联合变量 | 常量值为 104 。PHP的联合变量风格。
风格_PHP_默认 | 常量值为 118 。PHP的默认风格。
风格_PHP_字符串 | 常量值为 119 。PHP的字符串风格。
风格_PHP_单引号字符串 | 常量值为 120 。PHP的单引号字符串风格。
风格_PHP_关键字 | 常量值为 121 。PHP的关键字风格。
风格_PHP_数字 | 常量值为 122 。PHP的数字风格。
风格_PHP_变量 | 常量值为 123 。PHP的变量风格。
风格_PHP_注释 | 常量值为 124 。PHP的注释风格。
风格_PHP_注释行 | 常量值为 125 。PHP的注释行风格。
风格_PHP_串变量 | 常量值为 126 。PHP的串变量风格。
风格_PHP_操作符 | 常量值为 127 。PHP的操作符风格。
风格_PERL_默认 | 常量值为 0 。PERL的默认风格。
风格_PERL_错误 | 常量值为 1 。PERL的错误风格。
风格_PERL_注解行 | 常量值为 2 。PERL的注解行风格。
风格_PERL_POD | 常量值为 3 。PERL的POD风格。
风格_PERL_数字 | 常量值为 4 。PERL的数字风格。
风格_PERL_关键字 | 常量值为 5 。PERL的关键字风格。
风格_PERL_字符串 | 常量值为 6 。PERL的字符串风格。
风格_PERL_字符 | 常量值为 7 。PERL的字符风格。
风格_PERL_预处理程序 | 常量值为 9 。PERL的预处理程序风格。
风格_PERL_操作符 | 常量值为 10 。PERL的操作符风格。
风格_PERL_标识符 | 常量值为 11 。PERL的标识符风格。
风格_PERL_标量 | 常量值为 12 。PERL的标量风格。
风格_PERL_数组 | 常量值为 13 。PERL的数组风格。
风格_PERL_散列 | 常量值为 14 。PERL的散列风格。
风格_PERL_符号表 | 常量值为 15 。PERL的符号表风格。
风格_PERL_变量索引 | 常量值为 16 。PERL的变量索引风格。
风格_PERL_正则匹配 | 常量值为 17 。PERL的正则匹配风格。
风格_PERL_正则替换 | 常量值为 18 。PERL的正则替换风格。
风格_PERL_外部调用 | 常量值为 20 。PERL的外部调用风格。
风格_PERL_数据节 | 常量值为 21 。PERL的数据节风格。
风格_SQL_默认 | 常量值为 0 。SQL的默认风格。
风格_SQL_注释 | 常量值为 1 。SQL的注释风格。
风格_SQL_注释行 | 常量值为 2 。SQL的注释行风格。
风格_SQL_注释文档 | 常量值为 3 。SQL的注释文档风格。
风格_SQL_数字 | 常量值为 4 。SQL的数字风格。
风格_SQL_关键字 | 常量值为 5 。SQL的关键字风格。
风格_SQL_字符串 | 常量值为 6 。SQL的字符串风格。
风格_SQL_字符 | 常量值为 7 。SQL的字符风格。
风格_SQL_操作符 | 常量值为 10 。SQL的操作符风格。
风格_SQL_标识符 | 常量值为 11 。SQL的标识符风格。
风格_Basic_默认 | 常量值为 0 。Basic的默认风格。
风格_Basic_注解 | 常量值为 1 。Basic的注解风格。
风格_Basic_数字 | 常量值为 2 。Basic的数字风格。
风格_Basic_关键字 | 常量值为 3 。Basic的关键字风格。
风格_Basic_字符串 | 常量值为 4 。Basic的字符串风格。
风格_Basic_预处理 | 常量值为 5 。Basic的预处理风格。
风格_Basic_操作符 | 常量值为 6 。Basic的操作符风格。
风格_Basic_标识符 | 常量值为 7 。Basic的标识符风格。
风格_Basic_日期 | 常量值为 8 。Basic的日期风格。
风格_MakeFile_默认 | 常量值为 0 。MakeFile的默认风格。
风格_MakeFile_注释 | 常量值为 1 。MakeFile的注释风格。
风格_MakeFile_预处理 | 常量值为 2 。MakeFile的预处理风格。
风格_MakeFile_标识符 | 常量值为 2 。MakeFile的标识符风格。
风格_MakeFile_操作符 | 常量值为 4 。MakeFile的操作符风格。
风格_MakeFile_目标 | 常量值为 5 。MakeFile的目标风格。
风格_Batch_默认 | 常量值为 0 。Batch的默认风格。
风格_Batch_注释 | 常量值为 1 。Batch的注释风格。
风格_Batch_关键字 | 常量值为 2 。Batch的关键字风格。
风格_Batch_标志 | 常量值为 3 。Batch的标志风格。
风格_Batch_隐藏 | 常量值为 4 。Batch的隐藏风格。
风格_Batch_命令 | 常量值为 5 。Batch的命令风格。
风格_Batch_标识符 | 常量值为 6 。Batch的标识符风格。
风格_Batch_操作符 | 常量值为 7 。Batch的操作符风格。
风格_LUA_默认 | 常量值为 0 。LUA的默认风格。
风格_LUA_注释 | 常量值为 1 。LUA的注释风格。
风格_LUA_注释行 | 常量值为 2 。LUA的注释行风格。
风格_LUA_注释文档 | 常量值为 3 。LUA的注释文档风格。
风格_LUA_数字 | 常量值为 4 。LUA的数字风格。
风格_LUA_关键字 | 常量值为 5 。LUA的关键字风格。
风格_LUA_字符串 | 常量值为 6 。LUA的字符串风格。
风格_LUA_字符 | 常量值为 7 。LUA的字符风格。
风格_LUA_文本串 | 常量值为 8 。LUA的文本串风格。
风格_LUA_预处理 | 常量值为 9 。LUA的预处理风格。
风格_LUA_操作符 | 常量值为 10 。LUA的操作符风格。
风格_LUA_标识符 | 常量值为 11 。LUA的标识符风格。
风格_LUA_关键字2 | 常量值为 13 。LUA的关键字2风格。
风格_LUA_关键字3 | 常量值为 14 。LUA的关键字3风格。
风格_LUA_关键字4 | 常量值为 15 。LUA的关键字4风格。
风格_DIFF_默认 | 常量值为 0 。DIFF的默认风格。
风格_DIFF_注释 | 常量值为 1 。DIFF的注释风格。
风格_DIFF_命令 | 常量值为 2 。DIFF的命令风格。
风格_DIFF_头 | 常量值为 3 。DIFF的头风格。
风格_DIFF_位置 | 常量值为 4 。DIFF的位置风格。
风格_DIFF_删除 | 常量值为 5 。DIFF的删除风格。
风格_DIFF_增加 | 常量值为 6 。DIFF的增加风格。
风格_LIST_默认 | 常量值为 0 。LIST的默认风格。
风格_LIST_注释 | 常量值为 1 。LIST的注释风格。
风格_LIST_数字 | 常量值为 2 。LIST的数字风格。
风格_LIST_关键字 | 常量值为 3 。LIST的关键字风格。
风格_LIST_关键字2 | 常量值为 4 。LIST的关键字2风格。
风格_LIST_符号 | 常量值为 5 。LIST的符号风格。
风格_LIST_字符串 | 常量值为 6 。LIST的字符串风格。
风格_LIST_标识符 | 常量值为 9 。LIST的标识符风格。
风格_LIST_操作符 | 常量值为 10 。LIST的操作符风格。
风格_LIST_专用符 | 常量值为 11 。LIST的专用符风格。
风格_LIST_多行注解 | 常量值为 12 。LIST的多行注解风格。
风格_RUBY_默认 | 常量值为 0 。RUBY的默认风格。
风格_RUBY_错误 | 常量值为 1 。RUBY的错误风格。
风格_RUBY_注释行 | 常量值为 2 。RUBY的注释行风格。
风格_RUBY_POD文档 | 常量值为 3 。RUBY的POD文档风格。
风格_RUBY_数字 | 常量值为 4 。RUBY的数字风格。
风格_RUBY_关键字 | 常量值为 5 。RUBY的关键字风格。
风格_RUBY_字符串 | 常量值为 6 。RUBY的字符串风格。
风格_RUBY_字符 | 常量值为 7 。RUBY的字符风格。
风格_RUBY_类名 | 常量值为 8 。RUBY的类名风格。
风格_RUBY_定义名 | 常量值为 9 。RUBY的定义名风格。
风格_RUBY_操作符 | 常量值为 10 。RUBY的操作符风格。
风格_RUBY_标识符 | 常量值为 11 。RUBY的标识符风格。
风格_RUBY_正则表达式 | 常量值为 12 。RUBY的正则表达式风格。
风格_RUBY_全局 | 常量值为 13 。RUBY的全局风格。
风格_RUBY_符号 | 常量值为 14 。RUBY的符号风格。
风格_RUBY_模块名 | 常量值为 15 。RUBY的模块名风格。
风格_RUBY_实例变量 | 常量值为 16 。RUBY的实例变量风格。
风格_RUBY_类变量 | 常量值为 17 。RUBY的类变量风格。
风格_RUBY_数据节 | 常量值为 19 。RUBY的数据节风格。
风格_RUBY_标准输入 | 常量值为 30 。RUBY的标准输入风格。
风格_RUBY_标准输出 | 常量值为 31 。RUBY的标准输出风格。
风格_RUBY_标准错误 | 常量值为 40 。RUBY的标准错误风格。
风格_MATLAB_默认 | 常量值为 0 。MATLAB的默认风格。
风格_MATLAB_注释 | 常量值为 1 。MATLAB的注释风格。
风格_MATLAB_命令 | 常量值为 2 。MATLAB的命令风格。
风格_MATLAB_数字 | 常量值为 3 。MATLAB的数字风格。
风格_MATLAB_关键字 | 常量值为 4 。MATLAB的关键字风格。
风格_MATLAB_字符串 | 常量值为 5 。MATLAB的字符串风格。
风格_MATLAB_操作符 | 常量值为 6 。MATLAB的操作符风格。
风格_MATLAB_标识符 | 常量值为 6 。MATLAB的标识符风格。
风格_MATLAB_双引号字符串 | 常量值为 8 。MATLAB的双引号字符串风格。
风格_ASM_默认 | 常量值为 0 。ASM的默认风格。
风格_ASM_注释 | 常量值为 1 。ASM的注释风格。
风格_ASM_数字 | 常量值为 2 。ASM的数字风格。
风格_ASM_字符串 | 常量值为 3 。ASM的字符串风格。
风格_ASM_操作符 | 常量值为 4 。ASM的操作符风格。
风格_ASM_标识符 | 常量值为 5 。ASM的标识符风格。
风格_ASM_指令 | 常量值为 6 。ASM的指令风格。
风格_ASM_CPU指令 | 常量值为 6 。ASM的CPU指令风格。
风格_ASM_数学指令 | 常量值为 7 。ASM的数学指令风格。
风格_ASM_寄存器 | 常量值为 8 。ASM的寄存器风格。
风格_ASM_指示 | 常量值为 9 。ASM的指示风格。
风格_ASM_操作数 | 常量值为 10 。ASM的操作数风格。
风格_ASM_注释块 | 常量值为 11 。ASM的注释块风格。
风格_ASM_字符 | 常量值为 11 。ASM的字符风格。
风格_ASM_扩展指令 | 常量值为 14 。ASM的扩展指令风格。
风格_FORTRAN_默认 | 常量值为 0 。FORTRAN的默认风格。
风格_FORTRAN_注释 | 常量值为 1 。FORTRAN的注释风格。
风格_FORTRAN_数字 | 常量值为 2 。FORTRAN的数字风格。
风格_FORTRAN_字符串1 | 常量值为 3 。FORTRAN的字符串1风格。
风格_FORTRAN_字符串2 | 常量值为 4 。FORTRAN的字符串2风格。
风格_FORTRAN_操作符 | 常量值为 6 。FORTRAN的操作符风格。
风格_FORTRAN_标识符 | 常量值为 7 。FORTRAN的标识符风格。
风格_FORTRAN_关键字 | 常量值为 8 。FORTRAN的关键字风格。
风格_FORTRAN_关键字2 | 常量值为 9 。FORTRAN的关键字2风格。
风格_FORTRAN_关键字3 | 常量值为 10 。FORTRAN的关键字3风格。
风格_FORTRAN_预处理 | 常量值为 11 。FORTRAN的预处理风格。
风格_FORTRAN_操作符2 | 常量值为 12 。FORTRAN的预处理风格。
风格_FORTRAN_标志 | 常量值为 13 。FORTRAN的标志风格。
风格_FORTRAN_扩展 | 常量值为 14 。FORTRAN的扩展风格。
风格_CSS_默认 | 常量值为 0 。CSS的默认风格。
风格_CSS_标记 | 常量值为 1 。CSS的标记风格。
风格_CSS_类 | 常量值为 2 。CSS的类风格。
风格_CSS_假类 | 常量值为 3 。CSS的假类风格。
风格_CSS_未知假类 | 常量值为 4 。CSS的未知假类风格。
风格_CSS_操作符 | 常量值为 5 。CSS的操作符风格。
风格_CSS_标识符 | 常量值为 6 。CSS的标识符风格。
风格_CSS_未知标识符 | 常量值为 7 。CSS的未知标识符风格。
风格_CSS_值 | 常量值为 8 。CSS的值风格。
风格_CSS_注释 | 常量值为 9 。CSS的注释风格。
风格_CSS_ID | 常量值为 10 。CSS的ID风格。
风格_CSS_重要类型 | 常量值为 11 。CSS的重要类型风格。
风格_CSS_指示 | 常量值为 12 。CSS的指示风格。
风格_CSS_双引号字符串 | 常量值为 13 。CSS的双引号字符串风格。
风格_CSS_单引号字符串 | 常量值为 14 。CSS的单引号字符串风格。
风格_CSS_标识符2 | 常量值为 15 。CSS的标识符2风格。
风格_CSS_属性 | 常量值为 16 。CSS的属性风格。
风格_HASKELL_默认 | 常量值为 0 。HASKELL的默认风格。
风格_HASKELL_标识符 | 常量值为 1 。HASKELL的标识符风格。
风格_HASKELL_关键字 | 常量值为 2 。HASKELL的关键字风格。
风格_HASKELL_数字 | 常量值为 3 。HASKELL的数字风格。
风格_HASKELL_字符串 | 常量值为 4 。HASKELL的字符串风格。
风格_HASKELL_字符 | 常量值为 5 。HASKELL的字符风格。
风格_HASKELL_类 | 常量值为 6 。HASKELL的类风格。
风格_HASKELL_模块 | 常量值为 7 。HASKELL的模块风格。
风格_HASKELL_大写 | 常量值为 8 。HASKELL的大写风格。
风格_HASKELL_数据 | 常量值为 9 。HASKELL的数据风格。
风格_HASKELL_引入 | 常量值为 10 。HASKELL的引入风格。
风格_HASKELL_操作符 | 常量值为 11 。HASKELL的操作符风格。
风格_HASKELL_实例 | 常量值为 12 。HASKELL的实例风格。
风格_HASKELL_注释行 | 常量值为 13 。HASKELL的注释行风格。
风格_HASKELL_注释块 | 常量值为 14 。HASKELL的注释行块风格。
风格_SMALLTALK_默认 | 常量值为 0 。SMALLTALK的默认风格。
风格_SMALLTALK_字符串 | 常量值为 1 。SMALLTALK的字符串风格。
风格_SMALLTALK_数字 | 常量值为 2 。SMALLTALK的数字风格。
风格_SMALLTALK_注释 | 常量值为 3 。SMALLTALK的注释风格。
风格_SMALLTALK_符号 | 常量值为 4 。SMALLTALK的符号风格。
风格_SMALLTALK_二进制 | 常量值为 5 。SMALLTALK的二进制风格。
风格_SMALLTALK_布尔 | 常量值为 6 。SMALLTALK的布尔风格。
风格_SMALLTALK_自我 | 常量值为 7 。SMALLTALK的自我风格。
风格_SMALLTALK_大写 | 常量值为 8 。SMALLTALK的大写风格。
风格_SMALLTALK_空 | 常量值为 9 。SMALLTALK的空风格。
风格_SMALLTALK_全局 | 常量值为 10 。SMALLTALK的全局风格。
风格_SMALLTALK_返回 | 常量值为 11 。SMALLTALK的返回风格。
风格_SMALLTALK_专用 | 常量值为 12 。SMALLTALK的专用风格。
风格_SMALLTALK_分派 | 常量值为 14 。SMALLTALK的分派风格。
风格_SMALLTALK_字符 | 常量值为 15 。SMALLTALK的字符风格。
风格_ASP_开始 | 常量值为 80 。ASP的开始风格。
风格_ASP_默认 | 常量值为 81 。ASP的默认风格。
风格_ASP_数字 | 常量值为 83 。ASP的数字风格。
风格_ASP_关键字 | 常量值为 84 。ASP的关键字风格。
风格_ASP_字符串 | 常量值为 85 。ASP的字符串风格。
风格_ASP_字符串 | 常量值为 85 。ASP的字符串风格。
风格_默认 | 常量值为 32 。默认的风格。
风格_行号 | 常量值为 33 。行号旁注中使用的风格。
风格_匹配括号 | 常量值为 34 。匹配括号使用的风格。
风格_不匹配括号 | 常量值为 35 。不匹配括号使用的风格。
风格_缩进向导 | 常量值为 37 。缩进向导使用的风格。
标志样式_圆形 | 常量值为 0 。标志样式为原形。
标志样式_圆角矩形 | 常量值为 1 。标志样式为圆角矩形。
标志样式_箭头 | 常量值为 2 。标志样式为箭头。
标志样式_矩形 | 常量值为 3 。标志样式为矩形。
标志样式_省略箭头 | 常量值为 4 。标志样式为省略箭头。
标志样式_空 | 常量值为 5 。标志样式为空。
标志样式_下箭头 | 常量值为 6 。标志样式为下箭头。
标志样式_减号 | 常量值为 7 。标志样式为减号。
标志样式_加号 | 常量值为 8 。标志样式为加号。
标志样式_竖线 | 常量值为 9 。标志样式为竖线。
标志样式_左拐角线 | 常量值为 10 。标志样式为左拐角线。
标志样式_T型线 | 常量值为 11 。标志样式为T型线。
标志样式_加号框 | 常量值为 12 。标志样式为加号框。
标志样式_连接式加号框 | 常量值为 13 。标志样式为连接式加号框。
标志样式_减号框 | 常量值为 14 。标志样式为减号框。
标志样式_连接式减号框 | 常量值为 15 。标志样式为连接式减号框。
标志样式_左折角线 | 常量值为 16 。标志样式为左折角线。
标志样式_T型折角线 | 常量值为 17 。标志样式为T型折角线。
标志样式_加号圈 | 常量值为 18 。标志样式为加号圈。
标志样式_连接式加号圈 | 常量值为 19 。标志样式为连接式加号圈。
标志样式_减号圈 | 常量值为 20 。标志样式为减号圈。
标志样式_连接型减号圈 | 常量值为 21 。标志样式为连接型减号圈。
标志样式_背景 | 常量值为 22 。标志样式为背景。
标志样式_3点 | 常量值为 23 。标志样式为3个点。
标志样式_3箭头 | 常量值为 23 。标志样式为3个箭头。
折叠器 | 常量值为 -33554432 。折叠器。
折叠状态_中间折叠 | 常量值为 25 。程序中间可折叠语句折叠状态。
折叠状态_中间展开 | 常量值为 26 。程序中间可折叠语句展开状态。
折叠状态_中间结束位置 | 常量值为 27 。程序中间可折叠语句结束位置状态。
折叠状态_结束位置 | 常量值为 28 。可折叠语句结束位置状态。
折叠状态_子语句 | 常量值为 29 。不可折叠的子语句状态。
折叠状态_折叠状态 | 常量值为 30 。可折叠语句折叠状态。
折叠状态_展开状态 | 常量值为 31 。可折叠语句展开状态。
指示器风格_直线型下划线 | 常量值为 0 。指示器的风格为直线型下划线。
指示器风格_曲线型下划线 | 常量值为 1 。指示器的风格为曲线型下划线。
指示器风格_T型线 | 常量值为 2 。指示器的风格为曲线型下划线。
指示器风格_对角线 | 常量值为 3 。指示器的风格为对角线。
指示器风格_删除线 | 常量值为 4 。指示器的风格为删除线。
指示器风格_隐藏 | 常量值为 5 。指示器的风格为隐藏。
指示器风格_方框 | 常量值为 6 。指示器的风格为把文字包围起来的方框。
指示器掩码 | 常量值为 224 。在“开始风格”命令中使用，从而使用指示器。
指示器0 | 常量值为 32 。在“置文本风格”命令中使用，表示0型指示器。
指示器1 | 常量值为 64 。在“置文本风格”命令中使用，表示1型指示器。
指示器2 | 常量值为 128 。在“置文本风格”命令中使用，表示2型指示器。
基础折叠层 | 常量值为 1024 。设置折叠时从本层开始。
空行折叠标志 | 常量值为 4096 。空白行使用本标志。
首层折叠标志 | 常量值为 8192 。通过本标志判断是否为首层折叠。
折叠层号掩码 | 常量值为 4095 。折叠层号掩码。

参见：基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。