数据图表支持库

数据图表支持库 帮助手册20080814版 返回支持库手册 返回首页

本支持库实现了对柱状图,饼形图,曲线图显示的支持。

操作系统支持： Windows

窗口组件数据类型：

柱状图控件

饼形图控件

曲线图控件

例程列表：

例程名称 | 下载 | 说明
图表控件打印测试程序 | 图表打印.e | 对柱状图，饼形图，曲线图新增“打印”方法的测试。

适用版本，数据图表支持库 （1.6#2版）


柱状图控件

柱状图控件 窗口组件 操作系统支持：Windows 跳至：数据图表支持库

提供柱状图数据显示的支持。

属性：

有无边框 | 边框颜色 | 背景颜色 | 背景图片
拉伸底图 | 三维图形 | 显示标题 | 标题文字
标题字体 | 标题颜色 | X轴单位 | Y轴单位
标注字体 | 标注颜色 | Y轴最大值 | Y轴刻度数
显示图例 | 图例字体 | 图例文字颜色 | 图例数量
当前图例索引 | 当前图例文字 | 当前图例颜色 | X轴标注数量
当前X轴标注索引 | 当前X轴标注文字 | 当前数据值 | 显示小数位
显示标注 | 提示文本 |  |

方法：

打印


有无边框 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：逻辑型；指定图表控件是否拥有边框。

语法： 对象.有无边框 = 逻辑型

例程

说明：

设置柱状图组件是否有边框。

参见：例程


边框颜色 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件边框的颜色,该属性在“有无边框”属性为真的情况下才有效。

语法：对象.边框颜色 = 整数型

例程

说明：

设置柱状图组件的边框颜色为“边框颜色选择器”的颜色。有边框才能设置颜色，没有边框本属性无效。


背景颜色 属性 所属对象：柱状图控件

背景颜色 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；指定图表控件所使用的背景颜色。

  语法：对象.背景颜色 = 整数型

例程

说明：

将柱状图的背景颜色设为背景颜色选择器的颜色。如果设置了背景图片本属性无效。


背景图片 属性 所属对象：柱状图控件

背景图片 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：字节集；

指定图表控件所使用的背景图片文件。

  语法：对象.背景图片 = 字节集

例程

说明：

打开柱状图对话框，浏览文件夹，读入图片文件，设置柱状图的背景图片。


拉伸底图 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件所使用的背景图片是否拉伸或压缩为控件大小,该项属性在背景图片为有数据的情况下才有效。

  语法：对象.拉伸底图 = 逻辑型

例程

说明：

将柱状图控件的背景图拉伸，前提是必须有背景图存在，否则无效。


三维图形 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否为三维图形。

  语法：对象.三维图形 = 逻辑型

例程

说明：

设置柱状图控件的图形是平面图还是三维立体图。


显示标题 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否显示标题的文字。

  语法：对象.显示标题 = 逻辑型

例程

说明：

设置柱状图控件的标题是否显示。


标题文字 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的标题文字。

  语法：对象.标题文字 = 文本型

例程

说明：

用输入框输入柱状图控件的新标题。


标题字体 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件标题所使用的字体。

  语法：对象.标题字体 = 字体

例程

说明：

设置柱状图控件的标题字体的属性。字体的颜色属性无效。


标题颜色 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件标题文字的颜色。

  语法：对象.标题颜色 = 整数型

例程

说明：

将柱状图控件的标题颜色设为“标题颜色选择器”的颜色。


X轴单位 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件横坐标轴的单位。

  语法：对象.X轴单位 = 文本型

例程

说明：

设置表示柱状图控件X轴数值的单位。


Y轴单位 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件纵坐标轴的单位。

  语法：对象.Y轴单位 = 文本型

例程

说明：

弹出输入框来输入“柱状图控件”Y轴数值的单位。


标注字体 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件横坐标轴和纵坐标轴标注的字体。

  语法：对象.标注字体 = 字体

例程

说明：

弹出字体选择通用对话框设置“柱状图控件”的标注字体的属性。通用对话框的字体颜色设置无效。


标注颜色 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；指定图表控件横坐标轴和纵坐标轴标注文字的颜色。

  语法：对象.标注颜色 = 整数型

例程

说明：

将柱状图控件的标注颜色设为“标注颜色选择器”的颜色。


Y 轴最大值 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件纵坐标轴的标注的最大值,和“Y轴刻度数”共同使用确定Y轴的刻度。

  语法：对象.Y轴最大值 = 整数型

例程

说明：

弹出输入框来输入“柱状图控件”Y轴的最大数值。


Y轴刻度数 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件纵坐标轴标注的刻度个数,和“Y轴最大值”共同使用确定Y轴的刻度。

  语法：对象.Y轴刻度数 = 整数型

例程

说明：

设置柱状图控件Y轴刻度的数量。


显示图例 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否显示图例部分。

  语法：对象.显示图例 = 逻辑型

例程

说明：

设置是否显示柱状图控件的图例。


图例字体 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件的图例所使用的字体。

  语法：对象.图例字体 = 字体

例程

说明：

使用字体选择通用对话框设置“柱状图控件” 的图例字体属性。通用对话框字体的颜色设置无效。


图例文字颜色 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的图例文字的颜色。

  语法：对象.图例文字颜色 = 整数型

例程

说明：

将柱状图控件的图例文字颜色设为“图例文字颜色选择器”的颜色。


图例数量 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的图例数量,该项数据值等于图例数组的大小,该属性默认值为1,并且该属性不能小于1该属性值等于在横坐标的一个单位范围内有柱状图的数量。

  语法：对象.图例数量 = 整数型

例程

说明：

设置柱状图控件图例的数量。


当前图例索引 属性 所属对象：柱状图控件

当前图例索引 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的当前图例索引。

  语法：对象.当前图例索引 = 整数型

例程

说明：

设置柱状图控件当前的图例是第几个图例。


当前图例文字 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的当前图例文字,由“当前图例索引”属性确定当前图例在图例数组中的索引。

  语法：对象. 当前图例文字 =文本型

例程

说明：

弹出输入框输入欲设置的柱状图控件的当前图例的名称。


当前图例颜色 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的当前图例颜色,由“当前图例索引”属性确定当前图例在图例数组中的索引。

  语法：对象.当前图例颜色 = 整数型

例程

说明：

将柱状图控件的当前图例颜色设为“图例颜色选择器”的颜色。


X轴标注数量 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件横坐标轴标注的数量,该项数据值等于横坐标轴标注数组的大小,该属性默认值为1,并且该属性不能小于1。

  语法：对象.X轴标注数量 = 整数型

例程

说明：

设置柱状图控件X轴标注的数量，即柱状图控件的X轴有几组图例。


当前X轴标注索引 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的横坐标轴当前标注的索引。

  语法：对象.当前X轴标注索引 =整数型

例程

说明：

用输入框要设置的当前X轴标注的索引，即当前要使用X轴的第几组图例。


当前X轴标注文字 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的当前横坐标轴标注的文字,由“当前X轴标注索引”属性确定当前横坐标轴标注在横坐标轴标注数组中的索引。

  语法：对象名.当前X轴标注文字 = 文本型

例程

说明：

设置柱状图控件当前X轴的标注文字，即当前使用的这一组图例的名称。


当前数据值 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：双精度小数型；

指定图表控件的当前数据值。所有的数据值保存在一个二维的数组中,第一个维数是“图例数量”属性值,第二个维数是“X轴标注数量”属性值当前数据值在二维数组中的索引由“当前图例索引”和“当前X轴标注索引”两个属性值确定。

  语法：对象.当前数据值 = 双精度小数型

例程

说明：

设置柱状图控件当前的数据值。


显示小数位 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：整数型；柱状图的标注在显示时保留的小数位,该值的区间为 [0,10]。

语法：对象.显示小数位 = 整数型

例程

说明：

设置柱状图控件当前数据值的小数的位数。


显示标注 (柱状图控件)

显示标注 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：逻辑型； 是否显示图标主体中的数据值标注。

例程

说明

是否显示图标主体中的数据值标注

参考： 例程1


提示文本 (柱状图控件)

提示文本 属性 所属对象：柱状图控件 操作系统支持：Windows

数据类型：文本型； 指定提示文本模版，其中“${v}”表示当前鼠标所在的数据值。如果本属性为空，提示窗口不会出现。

例程

说明

设置提示文本。

参考： 例程1


打印 方法 操作系统支持：Windows 所属对象：柱状图控件

打印柱状图。

语法： 无返回值 柱状图控件．打印 （打印对象，［起始点横坐标］，［起始点纵坐标］，［图表宽度］，［图表高度］）

参数名 | 描 述
打印对象 | 必需的；打印机。打印机的设备对象。
起始点横坐标 | 可选的；整数型。图形在打印纸上的起始打印点的逻辑横坐标，默认为纸的左上顶点横坐标。
起始点纵坐标 | 可选的；整数型。图形在打印纸上的起始打印点的逻辑纵坐标，默认为纸的左上顶点纵坐标。
图表宽度 | 可选的；整数型。打印图表的宽度值，默认为图表窗口宽度。
图表高度 | 可选的；整数型。打印图表的高度值，默认为图表窗口高度。

例程:

说明：

将柱状图的内容通过打印机打印或者打印到文件

参见：例程1


饼形图控件

饼形图控件 窗口组件 操作系统支持：Windows 跳至：数据图表支持库

提供饼形图数据显示的支持。

属性：

有无边框 | 边框颜色 | 背景颜色 | 背景图片
拉伸底图 | 三维图形 | 显示饼图边界线 | 显示标题
标题文字 | 标题字体 | 标题颜色 | 单位
饼图立体厚度 | 表面长短轴比 | 显示图例 | 图例字体
图例字体颜色 | 图例数量 | 当前图例索引 | 当前图例文字
当前图例颜色 | 当前数据值 | 显示小数位 |

方法：

打印


有无边框 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否拥有边框。

语法：对象.有无边框 = 逻辑型

例程

说明：

将饼形图控件的有无边框属性设为有无边框选择框的选中属性。


边框颜色 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件边框的颜色,该属性在“有无边框”属性为真的情况下才有效。

  语法：对象.边框颜色 = 逻辑型

例程

说明：

将饼形图控件的边框颜色属性设为颜色选择器的颜色值。有边框本属性才有效。


背景颜色 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件所使用的背景颜色。

  语法：对象.背景颜色 = 整数型

例程

说明：

将饼形图控件的背景颜色设为颜色选择器的颜色值。在有背景图片的情况下无效。


背景图片 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：字节集；

指定图表控件所使用的背景图片文件。

  语法：对象.背景图片 = 字节集

例程

说明：

打开饼形图控件对话框，读入图片文件，并设置为饼形图控件的背景图片。


拉伸底图 属性 所属对象：饼形图控件

数据类型：逻辑型；

指定图表控件所使用的背景图片是否拉伸或压缩为控件大小,该项属性在背景图片为有数据的情况下才有效。

  语法：对象.拉伸底图 = 逻辑型

例程

说明：

将饼形图控件的拉伸底图属性设为拉伸底图选择框的选中属性。


三维图形 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否为三维图形。

  语法：对象.三维图形 = 逻辑型

例程：

说明：

将饼形图控件的三维图形属性设为与三维图形选择框的选中属性相同的值。


显示饼图边界线 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件的饼形边缘是否显示黑色边框线。

  语法：对象.显示饼形图边界线 = 逻辑型

例程：

说明：

将饼形图控件的显示饼图边界线属性设为与饼图边界线选择框的选中属性相同的值。


显示标题 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否显示标题。

  语法：对象.显示标题 = 逻辑型

例程

说明：

将饼形图控件的显示标题属性设为与显示标题选择框的选中属性相同的值。


标题文字 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的标题文字。

  语法：对象.标题文字 = 文本型

例程

说明：

将饼形图控件的标题设为与文本型属性编辑框的内容相同的值。


标题字体 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件的标题所使用的字体。

  语法：对象.标题字体 = 字体

例程

说明：

将饼形图控件的标题字体属性的字体名称设为与字体类型组合框的现行选中项的项目文本相同的内容。字体的颜色属性无效。


标题颜色 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件标题文字的颜色。

  语法：对象.标题颜色 = 整数型

例程

说明：

将饼形图控件的标题颜色设为颜色选择器的颜色值。


单位 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的单位。

  语法：对象.单位 = 文本型

例程

说明：

将饼形图控件的单位设为与文本型属性编辑框的内容相同的内容。


饼图立体厚度 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定饼形图表控件的立体厚度,大于0时为自定义厚度,小于等于0时为自动调整的厚度,该项数据的单位是0.01mm,该项属性在控件被设置为非三维图形时无效。

  语法：对象.饼图立体厚度 = 整数型

例程

说明：

将饼形图控件的饼图立体厚度设为数值属性编辑框的内容。


表面长短轴比 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定饼形图表控件的椭圆表面长短轴的比值,该项属性在控件被设置为非三维图形时无效。

可供选择的属性值：
0、自适应
1、一倍
2、二倍
3、三倍
4、四倍
5、五倍

语法：对象名.表面长短轴比 = 整数型

例程

说明：

将饼形图控件的表面长短轴比设为数值属性编辑框的内容。

长短轴比，即经过饼形图中心点的，水平线段和垂直线段之间的比例。


显示图例 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件的图例部分是否被显示。

  语法：对象.显示图例 = 逻辑型

例程

说明：

将饼形图控件的显示图例设为与显示图例选择框的选中属性相同的值。


图例字体 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件的图例所使用的字体。

  语法：对象.图例字体 = 字体

例程

说明：

将饼形图控件的图例字体属性的字体名称设为与“字体类型组合框”　现行选中项的项目文本相同的值。

字体的颜色属性无效。


图例字体颜色 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的图例文字的颜色。

  语法：对象.图例字体颜色 = 整数型

例程

说明：

将饼形图控件的图例字体颜色属性设为颜色选择器的颜色。


图例数量 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的图例数量,该项数据值等于图例数组的大小,该属性默认值为1,并且该属性不能小于1该属性值等于饼形图被分成的份数。

  语法：对象.图例数量 = 整数型

例程

说明：

将饼形图控件的图例数量设为数值属性编辑框的内容。即将饼形图分成几份。


当前图例索引 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的当前图例索引。

  语法：对象.当前图例索引 = 整数型

例程

说明：

将饼形图控件的当前图例索引属性设为数值属性编辑框的内容。即当前使用第几个图例。


当前图例文字 属性 所属对象：饼形图控件

数据类型：文本型；

指定图表控件的当前图例文字,由“当前图例索引”属性确定当前图例在图例数组中的索引。

  语法：对象.当前图例文字 = 文本型

例程

说明：

将饼形图控件的当前图例名称设为文本型属性编辑框的内容 。


当前图例颜色 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的当前图例颜色,由“当前图例索引”属性确定当前图例在图例数组中的索引。

  语法：对象.当前图例颜色 = 整数型

例程

说明：

将饼形图控件的当前图例颜色设为颜色选择器的颜色值。


当前数据值 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：双精度小数型；

指定图表控件的当前数据值,所有的数据值被保存在一个一维的数组中,数组的大小为“图例数量”的属性值当前的数据值在数组中的索引为“当前图例索引”的属性值。

  语法：对象.当前数据值 = 双精度小数型

例程

说明：

将饼形图控件的当前数据值属性设为数值属性编辑框的内容。即当前图例的数据是多少。


显示小数位 属性 所属对象：饼形图控件 操作系统支持：Windows

数据类型：整数型；饼形图的标注在显示时保留的小数位,该值的区间为 [0,10]。

语法：对象.显示小数位 = 整数型

例程

说明：

将饼形图控件的显示小数位设为数值属性编辑框的内容。即在显示的数据中，保留几位小数的位数。


打印 方法 操作系统支持：Windows 所属对象：饼形图控件

打印饼形图。

语法： 无返回值 饼形图控件．打印 （打印对象，［起始点横坐标］，［起始点纵坐标］，［图表宽度］，［图表高度］）

参数名 | 描 述
打印对象 | 必需的；打印机。打印机的设备对象。
起始点横坐标 | 可选的；整数型。图形在打印纸上的起始打印点的逻辑横坐标，默认为纸的左上顶点横坐标。
起始点纵坐标 | 可选的；整数型。图形在打印纸上的起始打印点的逻辑纵坐标，默认为纸的左上顶点纵坐标。
图表宽度 | 可选的；整数型。打印图表的宽度值，默认为图表窗口宽度。
图表高度 | 可选的；整数型。打印图表的高度值，默认为图表窗口高度。

例程:

说明:

可以把饼形图里的内容打印到纸上或打印到某个文件里。

参见:例程


曲线图控件

曲线图控件 窗口组件 操作系统支持：Windows 跳至：数据图表支持库

提供曲线图数据显示的支持。

属性：

有无边框 | 边框颜色 | 背景颜色 | 背景图片
拉伸底图 | 显示标题 | 标题文字 | 标题字体
标题颜色 | X轴单位 | Y轴单位 | 标注字体
标注颜色 | Y轴最大值 | Y轴刻度数 | 显示图例
图例字体 | 图例字体颜色 | 图例数量 | 当前图例索引
当前图例文字 | 当前图例颜色 | X轴标注数量 | 当前X轴标注索引
当前X轴标注文字 | 当前数据值 | 显示小数位 | 显示标注
提示文本 |  |  |

方法：

打印


有无边框 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否拥有边框。

  语法：对象.有无边框 = 逻辑型

例程

说明：

将曲线图控件的有无边框属性设为与“有无边框选择框”的选中属性相同的值。


边框颜色 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件边框的颜色,该属性在“有无边框”属性为真的情况下才有效。

  语法：对象.边框颜色 = 整数型

例程

说明：

将曲线图控件的边框颜色设为颜色选择器的颜色。无边框时无效。


背景颜色 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件所使用的背景颜色。

  语法：对象.背景颜色 = 整数型

例程

说明：

将曲线图控件的背景颜色设为颜色选择器的颜色。


背景图片 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：字节集；

指定图表控件所使用的背景图片文件。

  语法：对象.背景图片 = 字节集

例程

说明：

打开背景图片对话框，读入图片文件，并设置为曲线图控件的背景图片。


拉伸底图 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件所使用的背景图片是否拉伸或压缩为控件大小,该项属性在背景图片为有数据的情况下才有效。

  语法：对象.拉伸底图 = 逻辑型

例程

说明：

将曲线图控件的拉伸底图属性设为与拉伸底图选择框的选中属性相同的值。


显示标题 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：逻辑型；

指定是否显示图表控件的标题。

  语法：对象.显示标题 = 逻辑型

例程

说明：

将曲线图控件的显示标题属性设为显示标题选择框的选中属性的值。


标题文字 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的标题文字。

  语法：对象.标题文字 = 文本型

例程

说明：

将曲线图控件的标题设为与文本属性编辑框的内容相同的值。


标题字体 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件标题所使用的字体。

  语法：对象.标题字体 = 字体

例程

说明：

将曲线图控件的标题字体属性的字体名称设为与“字体类型组合框”的现行选中项的项目文本相同的值。字体的颜色属性无效。


标题颜色 属性 所属对象：曲线图控件

标题颜色 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件标题文字的颜色。

  语法：对象.标题颜色 = 整数型

例程

说明：

将曲线图控件的标题颜色设为颜色选择器的颜色值。


X轴单位 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件横坐标轴的单位。

  语法：对象.X轴单位 = 文本型

例程

说明：

将曲线图控件的X轴单位设为与文本属性编辑框的内容相同的值。


Y轴单位 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件纵坐标轴的单位。

  语法：对象.Y轴单位 = 文本型

例程

说明：

将曲线图控件的Y轴单位设为与文本属性编辑框的内容相同的值。


标注字体 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件横坐标轴和纵坐标轴标注的字体。

  语法：对象.标注字体 = 字体

例程

说明：

将曲线图控件的标注字体属性的字体名称设为字体类型组合框的现行选中项的项目文本。字体的颜色属性无效。


标注颜色 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件横坐标轴和纵坐标轴标注文字的颜色。

  语法：对象.标注颜色 = 整数型

例程

说明：

将曲线图控件的标注字体的颜色属性设为颜色选择器的颜色。


Y 轴最大值 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件纵坐标轴的标注的最大值,和“Y轴刻度数”共同使用确定Y轴的刻度。

  语法：对象名.Y轴最大值 =整数型

例程

说明：

将曲线图控件的Y轴最大值设为数值属性编辑框的内容。


Y轴刻度数 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件纵坐标轴标注的刻度个数,和“Y轴最大值”共同使用确定Y轴的刻度。

  语法：对象.Y轴刻度数 = 整数型

例程

说明：

将曲线图控件的Y轴刻度数设为数值属性编辑框中的内容。


显示图例 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：逻辑型；

指定图表控件是否显示图例部分。

  语法：对象.显示图例 = 逻辑型

例程：

说明：

将曲线图控件的显示图例属性设为与显示图例选择框的选中属性相同的值。


图例字体 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：字体；

指定图表控件的图例所使用的字体。

  语法：对象.图例字体 = 字体

例程

说明：

将曲线图控件的图例字体属性的字体名称设为与“字体类型组合框”中的现行选中项的项目文本。字体的颜色属性无效。


图例字体颜色 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件图例文字的颜色。

  语法：对象.图例字体颜色 = 整数型

例程

说明：

将曲线图空间的图例字体颜色设为颜色选择器的颜色。


图例数量 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的图例数量,该项数据值等于图例数组的大小,该属性默认值为1,并且该属性不能小于1该数据值等于在图表控件中所拥有的曲线条数。

  语法：对象.图例数量 = 整数型

例程

说明：

将曲线图控件的图例数量属性设为数值属性编辑框中的内容。即要设置的曲线数目。


当前图例索引 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的当前图例索引。

  语法：对象.当前图例索引 = 整数型

例程

说明：

将曲线图控件的当前图例索引设为数值属性编辑框中的内容。即当前的曲线表示的是第几个图例的数据。


当前图例文字 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的当前图例文字,由“当前图例索引”属性确定当前图例在图例数组中的索引。

  语法：对象.当前图例文字 = 文本型

例程

说明：

将曲线图控件的当前图例的名称设为文本属性编辑框中的内容。


当前图例颜色 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的当前图例颜色,由“当前图例索引”属性确定当前图例在图例数组中的索引。

  语法：对象.当前图例颜色 = 整数型

例程

说明：

将曲线图控件的当前图例颜色设为颜色选择器所选择的颜色。


X轴标注数量 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件横坐标轴标注的数量,该项数据值等于横坐标轴标注数组的大小,该属性默认值为1,并且该属性不能小于1。

  语法：对象.X轴标注数量 =整数型

例程

说明：

将曲线图控件的X轴标注数量设为数值属性编辑框中的内容。即在X轴上要标注出的数据点的数目。


当前X轴标注索引 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；

指定图表控件的横坐标轴当前标注索引。

  语法：对象.当前X轴标注索引 = 整数型

例程

说明：

将曲线图控件的当前X轴标注索引属性设为数值属性编辑框中的内容。即当前X轴上标注的数据点。


当前X轴标注文字 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：文本型；

指定图表控件的当前横坐标轴标注的文字,由“当前X轴标注索引”属性确定当前横坐标轴标注在横坐标轴标注数组中的索引。

  语法：对象.当前X轴标注文字 = 文本型

例程

说明：

将曲线图控件的当前X轴标注文字设为与文本属性编辑框的内容相同的值。即当前X轴标注的数据点的名称。


当前数据值 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：双精度小数型；

指定图表控件的当前数据值。所有的数据值保存在一个二维的数组中,第一个维数是“图例数量”属性值,第二个维数是“X轴标注数量”属性值当前数据值在二维数组中的索引由“当前图例索引”和“当前X轴标注索引”两个属性值确定。

  语法：对象.当前数据值 = 双精度小数型

例程

说明：

将曲线图控件的当前数据值设为数值属性编辑框中的内容。即设置当前X轴标注的数据点的数值。


显示小数位 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：整数型；曲线图的标注在显示时保留的小数位,该值的区间为 [0,10]。

语法：对象.显示小数位 = 整数型

例程

说明：

将曲线图控件的显示小数位属性设为数值属性编辑框中的内容。即当前X轴标注的数据点的数据保留的小数的位数。


显示标注 (曲线图控件)

显示标注 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：逻辑型； 是否显示图标主体中的数据值标注。

例程

说明

是否显示图标主体中的数据值标注。

参考： 例程1


提示文本 (曲线图控件)

提示文本 属性 所属对象：曲线图控件 操作系统支持：Windows

数据类型：文本型； 指定提示文本模版，其中“${v}”表示当前鼠标所在的数据值。如果本属性为空，提示窗口不会出现。

例程

说明

指定提示文本模版，其中“${v}”表示当前鼠标所在的数据值。如果本属性为空，提示窗口不会出现。

注:只有鼠标放在数据柱上方弹出提示框才能显示鼠标所在的数据值!

参考： 例程1


打印 方法 操作系统支持：Windows 所属对象：曲线图控件

打印线图。

语法： 无返回值 曲线图控件．打印 （打印对象，［起始点横坐标］，［起始点纵坐标］，［图表宽度］，［图表高度］）

参数名 | 描 述
打印对象 | 必需的；打印机。打印机的设备对象。
起始点横坐标 | 可选的；整数型。图形在打印纸上的起始打印点的逻辑横坐标，默认为纸的左上顶点横坐标。
起始点纵坐标 | 可选的；整数型。图形在打印纸上的起始打印点的逻辑纵坐标，默认为纸的左上顶点纵坐标。
图表宽度 | 可选的；整数型。打印图表的宽度值，默认为图表窗口宽度。
图表高度 | 可选的；整数型。打印图表的高度值，默认为图表窗口高度。

例程:

说明:

可以把曲线图里的内容打印到纸上或打印到某个文件里。

参见:例程