数据结构支持库

数据结构支持库 帮助手册20080813版 返回支持库手册 返回首页

提供节点，链表，栈，队列，树，二叉树、表(Map)等数据类型。

操作系统支持： Windows、Linux

命令类别：

出错信息

其它数据类型：

节点 | 链表 | 栈 | 队列
二叉树 | 树 | 表 |

适用版本，数据结构支持库 （1.2#0版）


出错信息

出错信息 类别 跳至：数据结构支持库

取失败原因


取失败原因 命令 操作系统支持：Windows、Linux 所属类别：出错信息

得到上次方法执行失败的原因信息。该方法必须在方法执行失败后马上执行，才能正确取出失败原因。

语法： 文本型 取失败原因 （）

例程

说明：

通过“取失败原因”命令获取在使用数据结构支持库中的命令时的错误原因。

参见：例程


节点

节点 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种带有属性数据的节点数据类型，一个节点可以拥有零个或多个属性数据。

方法：

加入属性 | 删除属性 | 修改属性 | 取全部属性名
取属性类型 | 取数值 | 取逻辑值 | 取日期值
取文本值 | 取字节集值 |  |

参见： 基本数据类型


加入属性 方法 操作系统支持：Windows、Linux 所属对象：节点

在节点中加入属性。成功加入返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．加入属性 （属性名称，属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“加入属性”方法中欲加入的新的属性名称。
属性值 | 必需的；通用型。“加入属性”方法中欲加入的新的属性值。

例程

说明：

通过“加入属性”命令在节点中加入属性。


删除属性 方法 操作系统支持：Windows、Linux 所属对象：节点

从节点中删除属性。成功删除返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．删除属性 （属性名称）

参数名 | 描 述
属性名称 | 必需的；文本型。“删除属性”方法中欲删除的属性名称。

例程

说明：

通过“删除属性”命令从节点中删除属性。


修改属性 方法 操作系统支持：Windows、Linux 所属对象：节点

修改节点的属性值。成功修改返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．修改属性 （属性名称，新属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“修改属性”方法中欲修改的属性名称。
新属性值 | 必需的；通用型。“修改属性”方法中欲修改的新的属性值。

例程

说明：

通过“修改属性”命令修改节点的属性值。


取全部属性名 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点的全部属性名称。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取全部属性名 （属性名称数组）

参数名 | 描 述
属性名称数组 | 必需的；文本型，参数数据只能提供变量数组。“取全部属性名”方法的填充参数。方法执行完毕后，该参数的内容为全部属性名称的数组。如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取全部属性名”命令取出节点的全部属性名称。


取属性类型 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点属性值的数据类型。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取属性类型 （属性名称，类型值）

参数名 | 描 述
属性名称 | 必需的；文本型。“取属性类型”方法中欲取类型的属性名称。
类型值 | 必需的；整数型，参数数据只能提供变量。“取属性类型”方法的填充参数。方法执行完毕后，该参数的内容为属性类型的代表数值。0代表数值型，1代表逻辑型，2代表日期型，3代表文本型，4代表字节集型。如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取属性类型”命令取出节点属性值的数据类型。


取数值 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点的数值型属性值。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取数值 （属性名称，属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“取数值”方法中欲取值的属性名称。
属性值 | 必需的；通用型，参数数据只能提供变量。“取数值”方法的填充参数。该参数必须为数值型，否则“取数值”方法返回假。方法执行完毕后，该参数的内容为属性的数值，如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取数值”命令取出节点的数值型属性值。


取逻辑值 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点的逻辑型属性值。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取逻辑值 （属性名称，属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“取逻辑值”方法中欲取值的属性名称。
属性值 | 必需的；逻辑型，参数数据只能提供变量。“取逻辑值”方法的填充参数。方法执行完毕后，该参数的内容为属性的逻辑值，如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取逻辑值”命令取出节点的逻辑型属性值。


取日期值 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点的日期型属性值。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取日期值 （属性名称，属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“取日期值”方法中欲取值的属性名称。
属性值 | 必需的；日期时间型，参数数据只能提供变量。“取日期值”方法的填充参数。方法执行完毕后，该参数的内容为属性的日期值，如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取日期值”命令取出节点的日期型属性值。


取文本值 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点的文本型属性值。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取文本值 （属性名称，属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“取文本值”方法中欲取值的属性名称。
属性值 | 必需的；文本型，参数数据只能提供变量。“取文本值”方法的填充参数。方法执行完毕后，该参数的内容为属性的文本值，如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取文本值”命令取出节点的文本型属性值。


取字节集值 方法 操作系统支持：Windows、Linux 所属对象：节点

取出节点的字节集型属性值。成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 节点．取字节集值 （属性名称，属性值）

参数名 | 描 述
属性名称 | 必需的；文本型。“取字节集值”方法中欲取值的属性名称。
属性值 | 必需的；字节集，参数数据只能提供变量。“取字节集值”方法的填充参数。方法执行完毕后，该参数的内容为属性的字节集值，如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取字节集值”命令取出节点的字节集型属性值。


链表

链表 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种数据容器，其中可以保存“节点”型数据，在内存中以数据链形式存在。

方法：

是否为空 | 取大小 | 加入节点 | 删除首节点
删除尾节点 | 全部删除 | 删除当前节点 | 删除节点
修改节点 | 修改当前节点 | 向下移动 | 向上移动
到首节点 | 到尾节点 | 搜索节点 | 取当前节点键值
取当前节点 | 取节点 |  |

参见： 基本数据类型


是否为空 方法 操作系统支持：Windows、Linux 所属对象：链表

判断链表中是否存有数据。如果链表为空返回真，如果链表非空返回假。

语法： 逻辑型 链表．是否为空 （）

例程

说明：

通过“是否为空”命令判断链表中是否存有数据。


取大小 方法 操作系统支持：Windows、Linux 所属对象：链表

取出链表中节点的数量。

语法： 整数型 链表．取大小 （）

例程

说明：

通过“取大小” 取出链表中节点的数量。


加入节点 方法 操作系统支持：Windows、Linux 所属对象：链表

在链表中加入新的节点。加入链表中自动根据键值参数进行从小到大的排序。键值参数可以省略，如果省略，默认键值为链表中最大的键值加一。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．加入节点 （节点值，［键值］）

参数名 | 描 述
节点值 | 必需的；节点。“加入节点”方法中欲加入到链表中的节点数据。
键值 | 可选的；整数型。“加入节点”方法中欲加入到链表中的节点数据的键值。这个值也是节点在链表中的唯一标识，节点在链表中存在的过程中键值是不允许改变的。该键值必须大于等于0。

例程

说明：

通过“加入节点”命令在链表中加入新的节点。


删除首节点 方法 操作系统支持：Windows、Linux 所属对象：链表

删除链表的首节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．删除首节点 （）

例程

说明：

通过“删除首节点”命令删除链表的首节点。


删除尾节点 方法 操作系统支持：Windows、Linux 所属对象：链表

删除链表的尾节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．删除尾节点 （）

例程

说明：

通过“删除尾节点”命令删除链表的尾节点。


全部删除 方法 操作系统支持：Windows、Linux 所属对象：链表

删除链表的全部节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．全部删除 （）

例程

说明：

通过“全部删除”命令删除链表的全部节点。


删除当前节点 方法 操作系统支持：Windows、Linux 所属对象：链表

删除链表的当前节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．删除当前节点 （）

例程

说明：

通过“删除当前节点”命令删除链表的当前节点。


删除节点 方法 操作系统支持：Windows、Linux 所属对象：链表

删除链表中指定键值的节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．删除节点 （键值）

参数名 | 描 述
键值 | 必需的；整数型。“删除节点”方法中欲删除节点数据的键值。

例程

说明：

通过“删除节点”命令删除链表中指定键值的节点。


修改节点 方法 操作系统支持：Windows、Linux 所属对象：链表

使用参数节点替换链表中指定键值的节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．修改节点 （节点值，键值）

参数名 | 描 述
节点值 | 必需的；节点。“修改节点”方法中链表节点被更改后的新节点数据。
键值 | 必需的；整数型。“修改节点”方法中欲更改的节点数据的键值。

例程

说明：

通过“修改节点”命令使用参数节点替换链表中指定键值的节点。


修改当前节点 方法 操作系统支持：Windows、Linux 所属对象：链表

修改链表中的当前节点为参数节点。该方法执行成功返回真，失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．修改当前节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点。“修改当前节点”方法中链表节点被更改后的新节点数据。

例程

说明：

通过“修改当前节点”命令修改链表中的当前节点为参数节点。


向下移动 方法 操作系统支持：Windows、Linux 所属对象：链表

链表中的当前节点向下移动一个节点。该方法执行成功返回真，执行失败返回假。如果是链表尾节点执行“向下移动”，返回假。

语法： 逻辑型 链表．向下移动 （）

例程

说明：

通过“向下移动”命令将链表中的当前节点向下移动一个节点。


向上移动 方法 操作系统支持：Windows、Linux 所属对象：链表

链表中的当前节点向上移动一个节点。该方法执行成功返回真，执行失败返回假。如果是链表首节点执行“向上移动”，返回假。

语法： 逻辑型 链表．向上移动 （）

例程

说明：

通过“向上移动”命令将链表中的当前节点向上移动一个节点。


到首节点 方法 操作系统支持：Windows、Linux 所属对象：链表

链表中的当前节点移动到首节点。

语法： 无返回值 链表．到首节点 （）

例程

说明：

通过“到首节点”命令将链表中的当前节点移动到首节点。


到尾节点 方法 操作系统支持：Windows、Linux 所属对象：链表

链表中的当前节点移动到尾节点。

语法： 无返回值 链表．到尾节点 （）

例程

说明：

通过“到尾节点”命令将链表中的当前节点移动到尾节点。


搜索节点 方法 操作系统支持：Windows、Linux 所属对象：链表

链表中的当前节点移动到参数键值指定的节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．搜索节点 （键值）

参数名 | 描 述
键值 | 必需的；整数型。“搜索节点”方法中欲搜索节点数据的键值。

例程

说明：

通过“搜索节点”命令将链表中的当前节点移动到参数键值指定的节点。


取当前节点键值 方法 操作系统支持：Windows、Linux 所属对象：链表

取链表中当前节点的键值。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．取当前节点键值 （键值）

参数名 | 描 述
键值 | 必需的；整数型，参数数据只能提供变量。“取当前节点键值”方法的填充参数。方法成功执行，该参数的内容为链表中当前节点的键值。

例程

说明：

通过“取当前节点键值”命令获取链表中当前节点的键值。


取当前节点 方法 操作系统支持：Windows、Linux 所属对象：链表

取链表中的当前节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．取当前节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“取当前节点”方法的填充参数。方法成功执行，该参数的内容为链表中当前节点。如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取当前节点”命令获取链表中的当前节点。


取节点 方法 操作系统支持：Windows、Linux 所属对象：链表

根据参数键值取链表中的节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 链表．取节点 （节点值，键值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“取节点”方法的填充参数。方法成功执行，该参数的内容为链表中的节点数据。如果方法执行失败，该参数内容无意义。
键值 | 必需的；整数型。“取节点”方法中欲取得节点数据的键值。

例程

说明：

通过“取节点”命令根据参数键值取链表中的节点。


栈

栈 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种数据容器，其中可以保存“节点”型数据，该容器以“后进先出”的顺序存取数据。

方法：

是否为空 | 取大小 | 清空 | 取栈顶节点
压入 | 弹出 |  |

参见： 基本数据类型


是否为空 方法 操作系统支持：Windows、Linux 所属对象：栈

判断栈中是否存有数据。如果栈为空返回真，如果栈非空返回假。

语法： 逻辑型 栈．是否为空 （）

例程

说明：

通过“是否为空”命令判断栈中是否存有数据。


取大小 方法 操作系统支持：Windows、Linux 所属对象：栈

取出栈中节点的数量。

语法： 整数型 栈．取大小 （）

例程

说明：

通过“取大小命令”命令取出栈中节点的数量。


清空 方法 操作系统支持：Windows、Linux 所属对象：栈

删除栈中的所有节点。

语法： 无返回值 栈．清空 （）

例程

说明：

通过“清空”命令删除栈中的所有节点。


取栈顶节点 方法 操作系统支持：Windows、Linux 所属对象：栈

取栈顶端的节点值，与“弹出”方法不同的是栈顶的节点并不出栈。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 栈．取栈顶节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“取栈顶节点”方法的填充参数，该方法执行完毕，该参数的内容为栈顶的节点值。如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取栈顶节点”命令取出栈的顶节点。


压入 方法 操作系统支持：Windows、Linux 所属对象：栈

向栈中压入一个节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 栈．压入 （节点值）

参数名 | 描 述
节点值 | 必需的；节点。“压入”方法中欲压到栈中节点。

例程

说明：

通过“压入”命令向栈中压入一个节点。


弹出 方法 操作系统支持：Windows、Linux 所属对象：栈

从栈中弹出一个节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 栈．弹出 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“弹出”方法的填充参数，该方法执行完毕，该参数的内容为从栈顶弹出的节点值。如果方法执行失败，该参数内容无意义。

例程

说明：

通过“弹出”命令从栈中弹出一个节点。


队列

队列 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种数据容器，其中可以保存“节点”型数据，该容器以“先进先出”的顺序存取数据。

方法：

是否为空 | 取大小 | 清空 | 取队列首节点
压入 | 弹出 |  |

参见： 基本数据类型


是否为空 方法 操作系统支持：Windows、Linux 所属对象：队列

判断队列中是否存有数据。如果栈为空返回真，如果栈非空返回假。

语法： 逻辑型 队列．是否为空 （）

例程

说明：

通过“是否为空”命令判断队列中是否存有数据。


取大小 方法 操作系统支持：Windows、Linux 所属对象：队列

取出队列中节点的数量。

语法： 整数型 队列．取大小 （）

例程

说明：

通过“取大小”命令取出队列中节点的数量。


清空 方法 操作系统支持：Windows、Linux 所属对象：队列

删除队列中的所有节点。

语法： 无返回值 队列．清空 （）

例程

说明：

通过“清空”命令删除队列中的所有节点。


取队列首节点 方法 操作系统支持：Windows、Linux 所属对象：队列

取队列的首节点，与“弹出”方法不同的是对列的首节点并不弹出，仍保留在对列中。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 队列．取队列首节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“取队列首节点”方法的填充参数，该方法执行完毕，该参数的内容为队列首节点值。如果方法执行失败，该参数内容无意义。

例程

说明：

通过“取队列首节点”命令获取队列中第一个节点。


压入 方法 操作系统支持：Windows、Linux 所属对象：队列

向队列的尾部压入一个节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 队列．压入 （节点值）

参数名 | 描 述
节点值 | 必需的；节点。“压入”方法中欲压到队列尾的节点。

例程

说明：

通过“压入”命令向队列的尾部压入一个节点。


弹出 方法 操作系统支持：Windows、Linux 所属对象：队列

从队列的首部弹出一个节点。该方法执行成功返回真，执行失败返回假。如果失败，可以通过“取失败原因”方法得到出错信息。

语法： 逻辑型 队列．弹出 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“弹出”方法的填充参数，该方法执行完毕，该参数的内容为从队列首弹出的节点值。

例程

说明：

通过“弹出”命令从队列的首部弹出一个节点。


二叉树

二叉树 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种数据容器，其中可以保存“节点”型数据，该容器以二叉树结构存取数据。该二叉树是根据每个节点的键值组织成为二叉排序树，该二叉树的上的任何一个节点的键值一定大于它的左子树节点的键值并且小于右子树节点的键值。

方法：

是否为空 | 取大小 | 取二叉树深度 | 清空
到左子树 | 到右子树 | 搜索节点 | 到根节点
到父节点 | 取当前节点 | 取当前节点键值 | 插入节点
修改节点 | 修改当前节点 | 删除节点 | 删除当前节点

参见： 基本数据类型


是否为空 方法 操作系统支持：Windows、Linux 所属对象：二叉树

判断二叉树中是否存有数据。如果二叉树为空返回真，如果二叉树非空返回假。

语法： 逻辑型 二叉树．是否为空 （）

例程

说明：

通过“是否为空”命令判断“二叉树”数据类型的变量中是否为空。


取大小 方法 操作系统支持：Windows、Linux 所属对象：二叉树

取出二叉树中节点的数量。

语法： 整数型 二叉树．取大小 （）

例程

说明：

通过“取大小”命令取出二叉树中节点的数量。


取二叉树深度 方法 操作系统支持：Windows、Linux 所属对象：二叉树

取出二叉树的深度。

语法： 整数型 二叉树．取二叉树深度 （）

例程

说明：

通过“取二叉树深度”命令获取“二叉树”数据类型的变量的二叉树深度。


清空 方法 操作系统支持：Windows、Linux 所属对象：二叉树

删除二叉树中的所有节点。

语法： 无返回值 二叉树．清空 （）

例程

说明：

通过“清空”命令将“二叉树”数据类型变量中的所有节点清空。


到左子树 方法 操作系统支持：Windows、Linux 所属对象：二叉树

移动二叉树的当前节点到它的左子树节点上。成功返回真，如果失败或者二叉树的左子树为空，返回假。

语法： 逻辑型 二叉树．到左子树 （）

例程

说明：

通过“到左子树”命令移动二叉树的当前节点到它的左子树节点上。


到右子树 方法 操作系统支持：Windows、Linux 所属对象：二叉树

移动二叉树的当前节点到它的右子树节点上。成功返回真，如果失败或者二叉树的右子树为空，返回假。

语法： 逻辑型 二叉树．到右子树 （）

例程

说明：

通过“到右子树”命令移动二叉树的当前节点到它的右子树节点上。


搜索节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

移动二叉树的当前节点到指定键值的节点上。成功返回真，失败返回假。

语法： 逻辑型 二叉树．搜索节点 （节点键值）

参数名 | 描 述
节点键值 | 必需的；整数型。欲搜索二叉树中节点的键值。

例程

说明：

通过“搜索节点”命令移动二叉树的当前节点到指定键值的节点上。


到根节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

移动二叉树的当前节点到根节点上。成功返回真，失败返回假。

语法： 逻辑型 二叉树．到根节点 （）

例程

说明：

通过“到根节点”命令移动二叉树的当前节点到根节点上。


到父节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

移动二叉树的当前节点到其父节点上。成功返回真，失败返回假。如果当前节点为根节点，执行该方法返回假。

语法： 逻辑型 二叉树．到父节点 （）

例程

说明：

通过“到父节点”命令移动二叉树的当前节点到其父节点上。


取当前节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

取二叉树的当前节点。成功返回真，失败返回假。

语法： 逻辑型 二叉树．取当前节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“取当前节点”方法的填充参数，该方法执行完毕，该参数的内容为二叉树的当前节点值。

例程

说明：

通过“取当前节点”命令取二叉树的当前节点。


取当前节点键值 方法 操作系统支持：Windows、Linux 所属对象：二叉树

取二叉树的当前节点的键值。成功返回真，失败返回假。

语法： 逻辑型 二叉树．取当前节点键值 （键值）

参数名 | 描 述
键值 | 必需的；整数型，参数数据只能提供变量。“取当前节点键值”方法的填充参数，该方法执行完毕，该参数的内容为二叉树的当前节点的键值。

例程

说明：

通过“取当前节点键值”命令取二叉树的当前节点的键值。


插入节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

向二叉树中插入节点。成功返回真，失败返回假。

语法： 逻辑型 二叉树．插入节点 （节点值，［键值］）

参数名 | 描 述
节点值 | 必需的；节点。“插入节点”方法中欲插入到二叉树中的节点值。
键值 | 可选的；整数型。“插入节点”方法中欲插入到二叉树中的节点的键值。该键值不能为负数。该参数可以省略，如果省略，则新插入节点的键值为二叉树中的最大键值加一。

例程

说明：

通过“插入节点”命令向二叉树中插入节点。


修改节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

修改二叉树中指定键值的节点。成功返回真，失败返回假。

语法： 逻辑型 二叉树．修改节点 （节点值，键值）

参数名 | 描 述
节点值 | 必需的；节点。“修改节点”方法中修改后的节点值。
键值 | 必需的；整数型。“修改节点”方法中欲修改节点的键值。

例程

说明：

通过“修改节点”命令修改二叉树中指定键值的节点。


修改当前节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

修改二叉树中当前节点。成功返回真，失败返回假。

语法： 逻辑型 二叉树．修改当前节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点。“修改当前节点”方法中修改后的节点值。

例程

说明：

通过“修改当前节点”命令修改二叉树中当前节点。


删除节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

删除二叉树中指定键值的节点。如果参数“删除标记”为假，仅删除一个节点的情况下分为以下几种不同的情形和执行结果：一，欲删除节点没有子节点，直接删除节点。二，欲删除节点仅有左子节点，删除节点后，把删除节点的左子节点连接到删除节点的双亲上。三，欲删除节点仅有右子节点，删除节点后，把删除节点的右子节点连接到删除节点的双亲上。四，欲删除节点有左子节点和右子节点，删除节点后，把删除节点的左子树上键值最大的节点（也是最右边的节点）连接到删除节点的双亲上，也就是提升到删除节点的位置，然后把它的左子树连接到它以前位置的双亲上。成功删除后，二叉树的当前节点值恢复为根节点值。该方法成功返回真，失败返回假。

语法： 逻辑型 二叉树．删除节点 （键值，［删除标记］）

参数名 | 描 述
键值 | 必需的；整数型。“删除节点”方法中欲删除节点的键值。
删除标记 | 可选的；逻辑型。该标记为真时表示删除节点及其所有的子节点，为假时表示仅删除单个节点。该参数可以省略，默认为假。

例程

说明：

通过“删除节点”命令删除二叉树中指定键值的节点。


删除当前节点 方法 操作系统支持：Windows、Linux 所属对象：二叉树

删除二叉树中当前节点。删除原则和“删除节点”方法相同。成功删除后，二叉树的当前节点值恢复为根节点值。该方法成功返回真，失败返回假。

语法： 逻辑型 二叉树．删除当前节点 （［删除标记］）

参数名 | 描 述
删除标记 | 可选的；逻辑型。该标记为真时表示删除节点及其所有的子节点，为假时表示仅删除单个节点。该参数可以省略，默认为假。

例程

说明：

通过“删除当前节点”命令删除二叉树中当前节点。


树

树 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种数据容器，其中可以保存“节点”型数据，该容器以普通树结构存取数据。

方法：

是否为空 | 取大小 | 清空 | 到子节点
到兄弟节点 | 到根节点 | 到父节点 | 取当前节点
取子节点数 | 插入节点 | 修改当前节点 | 删除当前节点
取节点索引 |  |  |

参见： 基本数据类型


是否为空 方法 操作系统支持：Windows、Linux 所属对象：树

判断树中是否存有数据。如果树为空返回真，如果树非空返回假。

语法： 逻辑型 树．是否为空 （）

例程

说明：

通过“是否为空”命令判断“树”数据类型变量中是否存有数据。


取大小 方法 操作系统支持：Windows、Linux 所属对象：树

取出树中节点的数量。

语法： 整数型 树．取大小 （）

例程

说明：

通过“取大小”命令取出树中节点的数量。


清空 方法 操作系统支持：Windows、Linux 所属对象：树

删除树中的所有节点。

语法： 无返回值 树．清空 （）

例程

说明：

通过“清空”命令删除“树”数据类型变量中所有节点。


到子节点 方法 操作系统支持：Windows、Linux 所属对象：树

移动当前节点到它的第一个子节点。成功返回真，失败或者当前节点没有子节点返回假。树的一个节点可以有多个子节点，该方法仅能移动当前节点到它的第一个子节点，其他节点的遍历可以通过“到兄弟节点”方法实现。

语法： 逻辑型 树．到子节点 （）

例程

说明：

通过“到子节点” 将“树”类型变量中标记位置移动到当前节点到它的第一个子节点。


到兄弟节点 方法 操作系统支持：Windows、Linux 所属对象：树

移动当前节点到它的下一个兄弟节点。成功返回真，失败或者当前节点没有下一个兄弟节点返回假。父节点的所有子节点以链表的形态存在，该方法仅能向一个方向移动，在其中的一个子节点可以通过该方法移动到下一个兄弟节点，但是无法反向移动。

语法： 逻辑型 树．到兄弟节点 （）

例程

说明：

通过“到兄弟节点”命令将“树”数据类型变量中的标记位置移动当前节点到它的下一个兄弟节点。


到根节点 方法 操作系统支持：Windows、Linux 所属对象：树

移动当前节点到树的根节点。成功返回真，失败返回假。

语法： 逻辑型 树．到根节点 （）

例程

说明：

通过“到根节点” 移动当前节点到树的根节点。


到父节点 方法 操作系统支持：Windows、Linux 所属对象：树

移动当前节点到其父节点。成功返回真，失败返回假。

语法： 逻辑型 树．到父节点 （）

例程

说明：

通过“到父节点”命令移动当前节点到其父节点。


取当前节点 方法 操作系统支持：Windows、Linux 所属对象：树

取树的当前节点。成功返回真，失败返回假。

语法： 逻辑型 树．取当前节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点，参数数据只能提供变量。“取当前节点”方法的填充参数，该方法执行完毕，该参数的内容为树的当前节点值。

例程

说明：

通过“取当前节点”命令获取“树”数据类型变量的当前节点。


取子节点数 方法 操作系统支持：Windows、Linux 所属对象：树

取当前节点的子节点数量。

语法： 整数型 树．取子节点数 （）

例程

说明：

通过“取子节点数”命令获得“树”数据类型变量中当前节点的子节点数。


插入节点 方法 操作系统支持：Windows、Linux 所属对象：树

向树中插入节点，插入位置为当前节点的子节点链表的末端。成功返回真，失败返回假。如果树是一个空的树，则把插入的节点作为树的根节点。

语法： 逻辑型 树．插入节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点。“插入节点”方法中欲插入到树中的节点值。

例程

说明：

通过“插入节点”命令向“树”数据类型变量中插入一个新节点。


修改当前节点 方法 操作系统支持：Windows、Linux 所属对象：树

修改树中当前节点的值为参数节点的值。成功返回真，失败返回假。

语法： 逻辑型 树．修改当前节点 （节点值）

参数名 | 描 述
节点值 | 必需的；节点。“修改当前节点”方法中修改后的节点值。

例程

说明：

通过“修改当前节点”命令将树中当前节点的值为参数节点的值。


删除当前节点 方法 操作系统支持：Windows、Linux 所属对象：树

删除树中当前节点。成功删除后，树的当前节点值恢复为根节点值。成功返回真，失败返回假。

语法： 逻辑型 树．删除当前节点 （［删除标记］）

参数名 | 描 述
删除标记 | 可选的；逻辑型。该标记为真时表示删除节点及其所有的子节点，为假时表示仅删除单个节点。如果该节点有子节点，该参数同时为假，该方法不执行删除操作，返回假。该参数可以省略，默认为假。

例程

说明：

通过“删除当前节点”命令删除树中当前节点。


取节点索引 方法 操作系统支持：Windows、Linux 所属对象：树

取当前节点在其父节点的所有子节点数组中的索引。如果失败将返回-1。

语法： 整数型 树．取节点索引 （）

例程

说明：

通过“取节点索引”命令或取当前节点在其父节点的所有子节点数组中的索引。


表

表 普通类型 操作系统支持：Windows、Linux 跳至：数据结构支持库

该数据类型是一种数据容器，其数据为多个“键-值”对，其中“键”为字节集类型，“值”为“节点”数据。表（Map）的主要用途是在大批量数据中快速查找相应的数据（根据“键”查找“值”）。

方法：

加入键值对 取键值 取键值数 取所有键

参见： 基本数据类型


加入键值对 方法 操作系统支持：Windows、Linux 所属对象：表

将“键”和“值”两者配对加入到对象中。如果已存在相同的“键”，则新“值”将覆盖旧“值”。执行成功返回真，失败返回假。

语法： 逻辑型 表．加入键值对 （键， 值）

参数名 | 描 述
键 | 必需的； 字节集。
值 | 必需的； 节点。

例程

说明：

向“表”中加入一对“键”和“值”。


取键值 方法 操作系统支持：Windows、Linux 所属对象：表

如果对象中没有指定的键，则返回假。

语法： 逻辑型 表．取键值 （键， 值）

参数名 | 描 述
键 | 必需的； 字节集。
值 | 必需的； 节点，参数数据只能提供变量。

例程

说明：

根据“键名”取“键值”


取键值数 方法 操作系统支持：Windows、Linux 所属对象：表

返回对象中“键-值”对的个数。

语法： 整数型 表．取键值数 （）

例程

说明：

取“表”中键值的对数。


取所有键 方法 操作系统支持：Windows、Linux 所属对象：表

返回由所有键组合的字节集数组。

语法： 字节集数组 表．取所有键 （）

例程

说明：

取得“表”中所有键值对的健名。


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。