易Logo支持库

易Logo支持库 帮助手册20080819版 返回支持库手册 返回首页

本支持库实现与Logo语言中绘图命令相同的功能。

操作系统支持： Windows

窗口组件数据类型：

Logo对象

适用版本, 易Logo支持库 （1.0#105版）


Logo对象

Logo对象 窗口组件 操作系统支持：Windows 跳至：易Logo支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
画笔颜色 | 背景颜色 | 画笔尺寸 | 绘图模式
底图 | 底图方式 | 系统内部对象图片组索引 | 自定义对象图片组
播放间隔 | 指定对象图片索引 | 置当前对象 |

方法：

前进 | 后退 | 左转 | 右转
落笔 | 抬笔 | 清屏 | 回家
橡皮 | 填充颜色 | 置对象角度 | 置横坐标
置竖坐标 | 置坐标 | 画椭圆 | 画实心椭圆
画矩形 | 画实心矩形 | 画圆 | 画实心圆
显示对象 | 隐藏对象 | 取横坐标 | 取竖坐标
取坐标 | 取对象角度 | 取点角度 | 激活对象
取当前对象号 | 取激活对象数 | 写文字 | 设置字体
取字体 | 载入图片 | 取对象显示状态 |

基本事件：


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


画笔颜色 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 画笔使用的颜色。

例程：

说明：

用此方法可以修改当前对象的颜色，可以使用颜色选择器的返回值。

参见： 例程


背景颜色 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 背景使用的颜色。

例程：

说明：

设定背景的颜色，如果不知道颜色的整数值可以在颜色选择器中提取。

参见：例程


画笔尺寸 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 画笔的尺寸，最大65535。

例程：

说明：

这个方法可以设置对象走过路径后留下痕迹及画出图形时的线条粗细。

参见： 例程


绘图模式 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 环绕模式：围绕对象窗口作图，围绕模式：围绕对象窗口作图，窗口模式：在对象窗口范围内作图，切换到“围绕”模式时，系统会清屏。

可供选择的属性值：
0、环绕
1、围绕
2、窗口

例程：

说明：

修改绘图模式，可以改变图形在界面里的显示。如：超出边界的状态，不同的模式会出现不同的效果。


底图 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：字节集； 本属性指定显示在画板背景上的图片。

例程：

说明：

给此属性赋一个图像的字节集数据，在画板的底层根据“底图方式”属性控制显示。


底图方式 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 如果设定了底图，本属性指定画板背景上底图的显示方式。

可供选择的属性值：
0、图片拉伸
1、图片居中
2、图片平铺

例程：

说明：

三个属性相当于windows设置背景图案时选择不同产生的效果不同。


系统内部对象图片组索引 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 本属性指定系统内部对象头部使用的图片组索引。

可供选择的属性值：
0、自定义
1、海龟
2、蝴蝶
3、坦克
4、红飞机
5、蓝飞机
6、汽车
7、机器人
8、蓝机器人
9、瓢虫
10、轻气球

例程：

说明：

支持库已经自带了10个图标，可以修改这个属性改变不同的图标，属性值为0时可以使用自定义的图片组。


自定义对象图片组 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：字节集； 如果“系统内部对象图片组索引”为“自定义”，本属性指定自定义对象图片组。

例程：

说明：

在“系统内部对象图片组索引”为0时通过这个属性可以确定自定义的图片组。


播放间隔 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 播放对象图片组中图片的间隔时间，单位为毫秒，为0时表示停止播放。

例程：

说明：

如果本属性不为零时，可以循环的显示图片组中所有图片，产生如动画的效果。


指定对象图片索引 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 显示对象图片组中本属性所指定的图片，当“播放间隔”为0时本属性有意义。

例程：

说明：

在自定义图片组后通过设定这个属性，指定图片组中某一个。


置当前对象 属性 所属对象：Logo对象 操作系统支持：Windows

数据类型：整数型； 设计时作用为，只显示被选择对象的变化，运行时作用为，选择指定对象为当前使用的对象，范围与“激活对象”所指定范围相同，如果所置的对象没有激活则使用“激活对象”命令的方式激活，注意：设计时只选择对象，而不激活。

可供选择的属性值：
0、第0个对象
1、第1个对象
2、第2个对象
3、第3个对象
4、第4个对象
5、第5个对象
6、第6个对象
7、第7个对象
8、第8个对象
9、第9个对象
10、第10个对象
11、第11个对象
12、第12个对象
13、第13个对象
14、第14个对象
15、第15个对象
16、第16个对象
17、第17个对象
18、第18个对象
19、第19个对象

例程：

说明：

改变该属性，根据所给整数指定一个对象，进行操作。如果没有此对象，则新创建从0号开始到整数号中没有被创建的对象。


前进 方法 操作系统支持：Windows 所属对象：Logo对象

向前走指定步。

语法： 无返回值 Logo对象．前进 （步数）

参数名 | 描 述
步数 | 必需的； 双精度小数型。前进的步数。

例程：

说明：

根据给方法传的参数不同，控制图标前进不同的步数。


后退 方法 操作系统支持：Windows 所属对象：Logo对象

后退指定步。

语法： 无返回值 Logo对象．后退 （步数）

参数名 | 描 述
步数 | 必需的； 双精度小数型。后退的步数。

例程：

说明：

根据给方法传的参数不同，控制图标后退不同的步数。


左转 方法 操作系统支持：Windows 所属对象：Logo对象

向左转指定的度数。

语法： 无返回值 Logo 对象．左转 （度数）

参数名 | 描 述
度数 | 必需的； 双精度小数型。向左转的度数。

例程：

说明：

根据给方法传的参数不同，控制图标左转不同的角度。


右转 方法 操作系统支持：Windows 所属对象：Logo对象

向右转指定的度数。

语法： 无返回值 Logo对象．右转 （度数）

参数名 | 描 述
度数 | 必需的； 双精度小数型。向右转的度数。

例程：

说明：

根据给方法传的参数不同，控制图标右转不同的角度。


落笔 方法 操作系统支持：Windows 所属对象：Logo对象

对象走过的地方会留下痕迹。

语法： 无返回值 Logo对象．落笔 （）

例程：

说明：

选择抬笔方法后对象走过的地方不会留下痕迹，如果想重新显示对象痕迹则使用此方法。


抬笔 方法 操作系统支持：Windows 所属对象：Logo对象

对象走过的地方不会留下痕迹。

语法： 无返回值 Logo对象．抬笔 （）

例程：

说明：

使用此方法后，当前选定对象移动后不会留下痕迹。不影响其他对象的属性。


清屏 方法 操作系统支持：Windows 所属对象：Logo对象

清空屏幕，回到初始状态。

语法： 无返回值 Logo对象．清屏 （）

例程：

说明：

清空所有图案和对象，回到初始状态只保留一个对象在（0,0）坐标上。


回家 方法 操作系统支持：Windows 所属对象：Logo对象

回到开始位置。

语法： 无返回值 Logo对象．回家 （）

例程：

说明：

当前选择的对象是用“回家”命令后回到初始位置，也就是（0,0）坐标点上。


橡皮 方法 操作系统支持：Windows 所属对象：Logo对象

如果参数为真，则对象走过的地方的图案会被清除，如果参数为假，则恢复画笔。

语法： 无返回值 Logo对象．橡皮 （是否为橡皮）

参数名 | 描 述
是否为橡皮 | 必需的； 逻辑型。是否为橡皮模式。

例程：

说明：

参数传递的逻辑值为真，所有对象走过的地方将被清空。如果为假所有对象恢复成走过的地方会留下痕迹。

参见： 例程


填充颜色 方法 操作系统支持：Windows 所属对象：Logo对象

在对象所在的最小闭合图形中填充颜色，填充时使用画笔颜色。注意：使用本命令时需要把画笔尺寸设为1，否则系统会认为画笔所画图形为最小闭合图形。

语法： 无返回值 Logo对象．填充颜色 （）

例程：

说明：

没有图形时填充全屏。此方法使用的颜色就是设置的画笔颜色。


置对象角度 方法 操作系统支持：Windows 所属对象：Logo对象

设置对象的角度。

语法： 无返回值 Logo 对象．置对象角度 （度数）

参数名 | 描 述
度数 | 必需的； 双精度小数型。对象头部的度数。

例程：

说明：

设置对象头部的度数，一周为360度。头部垂直向上时为0度。


置横坐标 方法 操作系统支持：Windows 所属对象：Logo对象

设置对象的横坐标。

语法： 无返回值 Logo对象．置横坐标 （横坐标）

参数名 | 描 述
横坐标 | 必需的； 双精度小数型。对象所在的横坐标。

例程：

说明：

设置当前选择的对象的横坐标，运行此方法后该对象出现的位置竖坐标为原来值，横坐标为设置值。


置竖坐标 方法 操作系统支持：Windows 所属对象：Logo对象

设置对象的竖坐标。

语法： 无返回值 Logo对象．置竖坐标 （竖坐标）

参数名 | 描 述
竖坐标 | 必需的； 双精度小数型。对象所在的竖坐标。

例程：

说明：

设置当前选择的对象的竖坐标，运行此方法后该对象出现的位置横坐标为原来值，竖坐标为设置值。


置坐标 方法 操作系统支持：Windows 所属对象：Logo对象

设置对象的坐标。

语法： 无返回值 Logo对象．置坐标 （横坐标， 竖坐标）

参数名 | 描 述
横坐标 | 必需的； 双精度小数型。对象所在的横坐标。
竖坐标 | 必需的； 双精度小数型。对象所在的竖坐标。

例程：

说明：

设置当前选择的对象的坐标，运行此方法后该对象出现设置的横竖坐标位置。


画椭圆 方法 操作系统支持：Windows 所属对象：Logo对象

画椭圆形。

语法： 无返回值 Logo 对象．画椭圆 （横向半径， 纵向半径）

参数名 | 描 述
横向半径 | 必需的； 双精度小数型。X轴上的半径。
纵向半径 | 必需的； 双精度小数型。Y轴上的半径。

例程：

说明：

以当前对象为中心点，根据参数画出一个空心的椭圆。


画实心椭圆 方法 操作系统支持：Windows 所属对象：Logo对象

画实心的椭圆，椭圆内部的颜色通过“置填充颜色”设置, 注意本命令只支持“窗口”模式。

语法： 无返回值 Logo对象．画实心椭圆 （横向半径， 纵向半径）

参数名 | 描 述
横向半径 | 必需的； 双精度小数型。X轴上的半径。
纵向半径 | 必需的； 双精度小数型。Y轴上的半径。

例程：

说明：

以当前对象为中心点，根据参数画出一个实心的椭圆。


画矩形 方法 操作系统支持：Windows 所属对象：Logo对象

画矩形。

语法： 无返回值 Logo对象．画矩形 （高度， 宽度）

参数名 | 描 述
高度 | 必需的； 双精度小数型。矩形的高度，负数无效。
宽度 | 必需的； 双精度小数型。矩形的宽度，负数无效。

例程：

说明：

以当前对象为中心点，根据参数画出一个空心的矩形。


画实心矩形 方法 操作系统支持：Windows 所属对象：Logo对象

画实心的矩形，矩形内部的颜色通过“置填充颜色”设置，注意本命令只支持“窗口”模式。

语法： 无返回值 Logo对象．画实心矩形 （高度， 宽度）

参数名 | 描 述
高度 | 必需的； 双精度小数型。矩形的高度。
宽度 | 必需的； 双精度小数型。矩形的宽度。

例程：

说明：

以当前对象为中心点，根据参数画出一个实心的矩形。


画圆 方法 操作系统支持：Windows 所属对象：Logo对象

画圆。

语法： 无返回值 Logo对象．画圆 （半径）

参数名 | 描 述
半径 | 必需的； 双精度小数型。圆的半径。

例程：

说明：

以当前对象为中心点，根据参数(半径)画出一个空心的圆形。


画实心圆 方法 操作系统支持：Windows 所属对象：Logo对象

画实心的圆，圆内部的颜色通过“置填充颜色”设置，注意本命令只支持“窗口”模式。

语法： 无返回值 Logo对象．画实心圆 （半径）

参数名 | 描 述
半径 | 必需的； 双精度小数型。圆的半径。

例程：

说明：

以当前对象为中心点，根据参数(半径)画出一个实心的圆形。


显示对象 方法 操作系统支持：Windows 所属对象：Logo对象

显示当前操作的对象。

语法： 无返回值 Logo对象．显示对象 （）

例程：

说明：

设置当前选择的对象属性为可视，与隐藏对象相对应。


隐藏对象 方法 操作系统支持：Windows 所属对象：Logo对象

隐藏当前操作的对象。

语法： 无返回值 Logo对象．隐藏对象 （）

例程：

说明：

设置当前选择的对象属性为不可见，与显示对象相对应。


取横坐标 方法 操作系统支持：Windows 所属对象：Logo对象

取得横坐标。

语法： 双精度小数型 Logo对象．取横坐标 （）

例程：

说明：

取出当前所选择的对象的横坐标。


取竖坐标 方法 操作系统支持：Windows 所属对象：Logo对象

取得竖坐标。

语法： 双精度小数型 Logo对象．取竖坐标 （）

例程：

说明：

取出当前所选择的对象的纵坐标。


取坐标 方法 操作系统支持：Windows 所属对象：Logo对象

取得横坐标与竖坐标。

语法： 双精度小数型数组 Logo对象．取坐标 （）

例程：

说明：

取出当前所选择的对象的横坐标与纵坐标。结果存于一个有两个成员的一维数组中。数组类型为双精度小数型。


取对象角度 方法 操作系统支持：Windows 所属对象：Logo对象

取得对象的角度。

语法： 双精度小数型 Logo对象．取对象角度 （）

例程：

说明：

取得当前选择对象角度。


取点角度 方法 操作系统支持：Windows 所属对象：Logo对象

取得指定点到当前对象位置的角度。

语法： 双精度小数型 Logo对象．取点角度 （横向半径， 纵向半径）

参数名 | 描 述
横向半径 | 必需的； 双精度小数型。X轴上的半径。
纵向半径 | 必需的； 双精度小数型。Y轴上的半径。

例程：

说明：

根据参数定义一个点的位置,取出该点与当前对象之间的角度.


激活对象 方法 操作系统支持：Windows 所属对象：Logo对象

激活指定个数的对象，如参数为5，则激活从0到5的对象，并且5号对象为当前使用的对象，范围是从0到19。

语法： 无返回值 Logo对象．激活对象 （激活数）

参数名 | 描 述
激活数 | 必需的； 整数型。激活对象的个数。

例程：

说明：

激活一定数量的对象，最多只能激活20个。使用这个方法后默认选择的是最后一个对象。


取当前对象号 方法 操作系统支持：Windows 所属对象：Logo对象

取得当前对象的代号。

语法： 整数型 Logo对象．取当前对象号 （）

例程：

说明：

取得当前对象的编号，返回一个整数型的编号。


取激活对象数 方法 操作系统支持：Windows 所属对象：Logo对象

取得被激活对象的数目。

语法： 整数型 Logo对象．取激活对象数 （）

例程：

说明：

返回一个整数，代表当前所激活的对象的个数。


写文字 方法 操作系统支持：Windows 所属对象：Logo对象

沿着对象的方向写文字, 最多写出255个字符。

语法： 无返回值 Logo对象．写文字 （文本）

参数名 | 描 述
文本 | 必需的； 文本型。待写出文本。

例程：

说明：

以当前对象方向为直线，依次写出一行文本。


设置字体 方法 操作系统支持：Windows 所属对象：Logo对象

设置写文字使用的字体。

语法： 整数型 Logo对象．设置字体 （字体）

参数名 | 描 述
字体 | 必需的； 字体。写出文字的字体，注意字体中的角度参数无效，字体的角度与对象的角度相同。

例程：

说明：

设置当前对象使用“写文字”方法时所使用的字体。


取字体 方法 操作系统支持：Windows 所属对象：Logo对象

取得写文字使用的字体。

语法： 字体 Logo对象．取字体 （）

例程：

说明：

取得当前对象所使用的字体，返回一个类型为“字体”的变量。


载入图片 方法 操作系统支持：Windows 所属对象：Logo对象

载入一幅图片，并在指定位置显示。

语法： 逻辑型 Logo对象．载入图片 （图片， 图片画出横坐标， 图片画出竖坐标， ［图片画出宽度］， ［图片画出高度］， 方式）

参数名 | 描 述
图片 | 必需的； 通用型。参数名称为“图片数据”，数据类型为“通用型（all）”。注明：参数值可以为 .JPG、.GIF、.BMP、.DIB 等等被支持格式的图片数据、图片资源或图片文件名。
图片画出横坐标 | 必需的； 整数型，初始值为“0”。图片画出横坐标。
图片画出竖坐标 | 必需的； 整数型，初始值为“0”。图片画出竖坐标。
图片画出宽度 | 可选的； 整数型。如果本参数被省略，则使用图片本身的宽度。
图片画出高度 | 可选的； 整数型。如果本参数被省略，则使用图片本身的高度。
方式 | 必需的； 整数型，初始值为“0”。0 为拉伸，1 为居中，2 为平铺。

例程：

说明：

在logo对象中加入一幅图片，用参数指定它的位置，大小，显示方式。


取对象显示状态 方法 操作系统支持：Windows 所属对象：Logo对象

取指定对象的显示状态，索引为空则返回当前对象，可视返回真，隐藏返回假。

语法： 逻辑型 Logo对象．取对象显示状态 （［对象索引］）

参数名 | 描 述
对象索引 | 可选的； 整数型。待获得状态的对象的索引。

例程：

说明：

通过此对象可以知道给定的索引的对象，当前是显示状态还是隐藏状态。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。