矢量动画框

矢量动画框支持库 帮助手册20080904版 返回首页

本支持库实现了对矢量动画的支持。

操作系统支持： Windows

命令类别：

全局命令

窗口组件数据类型：

矢量动画框

其它数据类型：

精灵 | 帧 | 层 | 矢量图形
矢量编辑框 | 矢量按钮 | 矢量组件类型 |

例程列表：

注：以下所有例程已连同Flash文件一起打包，用户在运行时请载入flash文件。

例程名称 | 下载 | 说明
转换为易动画框 | 转换为易动画框.e | 此例程用作演示将SWF格式转换成EVA格式（附带Flash文件）。
矢量动画框_属性 | 矢量动画框_属性.e | 此例程用作演示矢量动画框的基本属性（附带Flash文件）。
矢量动画框_自有事件 | 矢量动画框_自有事件.e | 用作演示矢量动画框的字自有事件（附带Flash文件）。
复制组件操作 | 复制组件操作.e | 此例程用作演示矢量动画框属性中的方法的基本操作（附带Flash文件）。
精灵操作 | 精灵操作.e | 此例程用作演示精灵中所有组件的基本操作（附带Flash文件）。
图形操作 | 图形操作.e | 演示如何使用图形操作（附带Flash文件）。
矢量编辑框 | 矢量编辑框.e | 演示如何使用矢量编辑框操作（附带Flash文件）。
矢量按钮 | 矢量按钮.e | 演示如何使用矢量按钮操作（附带Flash文件）。
田忌赛马 | 综合例程.e | 此程序作为演示矢量动画框的综合例程。

适用版本，矢量动画框 （1.1#0版）


全局命令

全局命令 类别 跳至：矢量动画框

转换为易动画


转换为易动画

转换为易动画 命令 操作系统支持：Windows 所属类别：全局命令

将SWF格式转换成EVA格式。如果成功返回值为空文本，否则返回出错信息。

语法： 文本型 转换为易动画 （源数据， 目的数据）

参数名 | 描 述
源数据 | 必需的； 字节集。本参数表示源数据，必须为SWF文件格式。
目的数据 | 必需的； 字节集，参数数据只能提供变量。本参数表示目的数据，存放转换后的EVA文件数据。

例程：

说明：

此命令是将 SWF格式文件转换成EVA格式文件。

参见： 例程


矢量动画框

矢量动画框 窗口组件 操作系统支持：Windows 跳至：矢量动画框

实现了对矢量动画的控制。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
动画文件名 | 时钟周期 |  |

方法：

取根精灵 | 取精灵 | 取图形 | 取编辑框
取按钮 | 置动画数据 | 复制组件 | 删除组件
改变层次 |  |  |

自有事件：

组件鼠标左键被按下 | 组件鼠标左键被放开 | 组件鼠标左键被双击 | 组件鼠标右键被按下
组件鼠标右键被放开 | 组件鼠标被移动 | 组件鼠标进入 | 组件鼠标离开
组件获得焦点 | 组件失去焦点 | 组件按下某键 | 组件放开某键
组件字符输入 | 一帧被加载后 |  |


左边 (矢量动画框)

左边 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的左边为0。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


顶边 (矢量动画框)

顶边 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的顶边为0。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


宽度 (矢量动画框)

宽度 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的宽度。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


高度 (矢量动画框)

高度 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的高度。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


标记 (矢量动画框)

标记 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：文本型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的标记。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


可视 (矢量动画框)

可视 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：逻辑型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的可视属性。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


禁止 (矢量动画框)

禁止 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：逻辑型；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的禁止属性。

参见：例程


鼠标指针 (矢量动画框)

鼠标指针 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：字节集；

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件、矢量动画框…

例程：

说明：

设置矢量动画框的鼠标指针属性。

注意：下载时要附带例程里面的*.swf文件。

参见：例程


动画文件名 (矢量动画框)

动画文件名 属性 所属对象：矢量动画框 操作系统支持：Windows

数据类型：文本型； 指定动画数据文件名，可以为EVA或SWF文件。

例程：

说明：

指定动画数据的文件名。

参见：例程


时钟周期 (矢量动画框)

时钟周期 属性 所属对象：矢量动画框 操作系统支持：Windows

数据类型：整数型； 指定播放动画的时钟周期。-1表示系统自动设置。

例程：

说明：

指定播放动画的时钟周期。

参见：例程


取根精灵 (矢量动画框)

取根精灵 方法 操作系统支持：Windows 所属对象：矢量动画框

取当前动画的根精灵。

语法： 精灵 矢量动画框．取根精灵 （）

例程：

说明：

取出当前动画的根精灵。

参见：例程


取精灵 (矢量动画框)

取精灵 方法 操作系统支持：Windows 所属对象：矢量动画框

取指定标识的精灵。

语法： 精灵 矢量动画框．取精灵 （标识）

参数名 | 描 述
标识 | 必需的； 通用型。标识精灵的索引或实例名称。

例程：

说明：

取出指定标识“操作成功”的精灵。


取图形 (矢量动画框)

取图形 方法 操作系统支持：Windows 所属对象：矢量动画框

取指定标识的图形。

语法： 矢量图形 矢量动画框．取图形 （标识）

参数名 | 描 述
标识 | 必需的； 通用型。标识图形的索引或实例名称。

例程：

说明：

取出“操作成功”标识的图形。


取编辑框 (矢量动画框)

取编辑框 方法 操作系统支持：Windows 所属对象：矢量动画框

取指定标识的编辑框。

语法： 矢量编辑框 矢量动画框．取编辑框 （标识）

参数名 | 描 述
标识 | 必需的； 通用型。标识编辑框的索引或实例名称。

例程：

说明：

取出指定标识的编辑框。


取按钮 (矢量动画框)

取按钮 方法 操作系统支持：Windows 所属对象：矢量动画框

取指定标识的按钮。

语法： 矢量按钮 矢量动画框．取按钮 （标识）

参数名 | 描 述
标识 | 必需的； 通用型。标识按钮的索引或实例名称。

例程：

说明：

取出指定标识的按钮。


置动画数据 (矢量动画框)

置动画数据 方法 操作系统支持：Windows 所属对象：矢量动画框

设置当前要播放的EVA动画数据。

语法： 逻辑型 矢量动画框．置动画数据 （动画数据）

参数名 | 描 述
动画数据 | 必需的； 字节集。要播放的EVA动画数据。

例程：

说明：

设置要播放的EVA动画数据。

参见：例程


复制组件 (矢量动画框)

复制组件 方法 操作系统支持：Windows 所属对象：矢量动画框

复制组件到指定精灵的指定帧。返回复制后的新组件索引。

语法： 整数型 矢量动画框．复制组件 （矢量组件， ［精灵索引］， ［帧索引］， ［层索引］）

参数名 | 描 述
矢量组件 | 必需的； 通用型。要复制的矢量组件。
精灵索引 | 可选的； 整数型。要复制到的精灵索引。-1表示复制到根精灵。默认值为-1。
帧索引 | 可选的； 整数型。要复制到的帧索引。默认值为0。
层索引 | 可选的； 整数型。要复制到的层索引。默认值为0。

例程：

说明：

复制矢量组件编辑框中的内容。


删除组件 (矢量动画框)

删除组件 方法 操作系统支持：Windows 所属对象：矢量动画框

删除指定的组件。成功返回真，失败返回假。

语法： 逻辑型 矢量动画框．删除组件 （标识， ［精灵索引］， ［帧索引］， ［层索引］）

参数名 | 描 述
标识 | 必需的； 通用型。标识要删除组件的索引或实例名称。
精灵索引 | 可选的； 整数型。要删除的组件所在的精灵索引。0表示所有精灵，-1表示根精灵。默认值为0。
帧索引 | 可选的； 整数型。要删除的组件所在的帧索引。-1表示所有帧，默认值为-1。
层索引 | 可选的； 整数型。要删除的组件所在的层索引。-1表示所有层，默认值为-1。

例程：

说明：

删除前面复制的组件。


改变层次 (矢量动画框)

改变层次 方法 操作系统支持：Windows 所属对象：矢量动画框

改变指定元素的现行所处层次。

语法： 逻辑型 矢量动画框．改变层次 （标识， ［精灵索引］， ［帧索引］， ［欲调整到的层次］）

参数名 | 描 述
标识 | 必需的； 通用型。标识要调整层次组件的索引或实例名称。
精灵索引 | 可选的； 整数型。要调整层次的组件所在的精灵索引。-1表示根精灵。默认值为-1。
帧索引 | 可选的； 整数型。要调整层次的组件所在的帧索引。默认值为1。
欲调整到的层次 | 可选的； 整数型。可以为以下常量之一： 1、移至顶层； 2、上移一层； 3、下移一层； 4、移至底层。如果被省略，默认为1。

例程：

说明：

改变“名称”的现行所处层次。


组件鼠标左键被按下 (矢量动画框)

组件鼠标左键被按下 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标左键被按下时触发此事件。如果返回真，系统将继续产生左键被按下事件。

语法： 逻辑型 _矢量动画框_组件鼠标左键被按下 （横向位置， 纵向位置， 功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

例程：

说明：

当鼠标左键被按下时触发此事件。


组件鼠标左键被放开 (矢量动画框)

组件鼠标左键被放开 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标左键被放开时触发此事件。如果返回真，系统将继续产生左键被放开事件。

语法： 逻辑型 _矢量动画框_组件鼠标左键被放开 （横向位置， 纵向位置， 功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

说明：

当鼠标左键被放开时触发此事件；此事件与鼠标左键被按下相同，可以参照鼠标左键被按下例程。


组件鼠标左键被双击 (矢量动画框)

组件鼠标左键被双击 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标左键被双击时触发此事件。如果返回真，系统将继续产生左键被双击事件。

语法： 逻辑型 _矢量动画框_组件鼠标左键被双击 （横向位置， 纵向位置， 功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

说明：

当鼠标左键被双击时触发此事件；此事件与鼠标左键被按下相同，可以参照鼠标左键被按下例程。


组件鼠标右键被按下 (矢量动画框)

组件鼠标右键被按下 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标右键被按下时触发此事件。如果返回真，系统将继续产生右键被按下事件。

语法： 逻辑型 _矢量动画框_组件鼠标右键被按下 （横向位置， 纵向位置， 功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

说明：

当鼠标右键被按下时触发此事件；此事件与鼠标左键被按下相同，可以参照鼠标左键被按下例程。


组件鼠标右键被放开 (矢量动画框)

组件鼠标右键被放开 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标右键被放开时触发此事件。如果返回真，系统将继续产生右键被放开事件。

语法： 逻辑型 _矢量动画框_组件鼠标右键被放开 （横向位置， 纵向位置， 功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

说明：

当鼠标右键被放开时触发此事件；此事件与鼠标左键被按下相同，可以参照鼠标左键被按下例程。


组件鼠标被移动 (矢量动画框)

组件鼠标被移动 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标移动时触发此事件。如果返回真，系统将继续产生被移动事件。

语法： 逻辑型 _矢量动画框_组件鼠标被移动 （横向位置， 纵向位置， 功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

例程：

说明：

当功能键状态为#Ctrl键状态移动鼠标时触发此事件。


组件鼠标进入 (矢量动画框)

组件鼠标进入 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标指针进入组件后触发此事件。本事件只对“矢量按钮”有效。如果返回真，系统将继续产生进入事件。

语法： 逻辑型 _矢量动画框_组件鼠标进入 （功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示当前所处矢量组件的实例名称。

例程：

说明：

当鼠标指针进入组件后触发此事件。本事件只对“矢量按钮”有效。


组件鼠标离开 (矢量动画框)

组件鼠标离开 事件 所属对象：矢量动画框 操作系统支持：Windows

当鼠标指针离开组件后触发此事件。本事件只对“矢量按钮”有效。如果返回真，系统将继续产生离开事件。

语法： 逻辑型 _矢量动画框_组件鼠标离开 （功能键状态， 矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示当前所处矢量组件的实例名称。

例程：

说明：

当鼠标指针离开组件后触发此事件。本事件只对“矢量按钮”有效。


组件获得焦点 (矢量动画框)

组件获得焦点 事件 所属对象：矢量动画框 操作系统支持：Windows

当获得焦点时触发此事件。本事件只对“矢量编辑框”有效。如果返回真，系统将继续产生获得焦点事件。

语法： 逻辑型 _矢量动画框_组件获得焦点 （矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

例程：

说明：

当组件获得焦点时触发该事件，本事件只对“矢量编辑框”有效。


组件失去焦点 (矢量动画框)

组件失去焦点 事件 所属对象：矢量动画框 操作系统支持：Windows

当失去焦点时触发此事件。本事件只对“矢量编辑框”有效。如果返回真，系统将继续产生失去焦点事件。

语法： 逻辑型 _矢量动画框_组件失去焦点 （矢量组件类型， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
矢量组件类型 | 矢量组件类型； 指示鼠标在当前所处矢量组件的类型。可以为“矢量组件类型”数据类型中的常量值。
矢量组件索引 | 整数型； 指示鼠标在当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示鼠标在当前所处矢量组件的实例名称。

例程：

说明：

当组件失去焦点时触发该事件。本事件只对“矢量编辑框”有效。


组件按下某键 (矢量动画框)

组件按下某键 事件 所属对象：矢量动画框 操作系统支持：Windows

当按下某键时触发此事件。本事件只对“矢量编辑框”有效。如果返回真，系统将继续产生按下某键事件。

语法： 逻辑型 _矢量动画框_组件按下某键 （键代码， 功能键状态， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
键代码 | 整数型； 为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件索引 | 整数型； 指示当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示当前所处矢量组件的实例名称。

例程：

说明：

当按下F1键时触发该事件，本事件只对“矢量编辑框”有效。


组件放开某键 (矢量动画框)

组件放开某键 事件 所属对象：矢量动画框 操作系统支持：Windows

当放开某键时触发此事件。本事件只对“矢量编辑框”有效。如果返回真，系统将继续产生放开某键事件。

语法： 逻辑型 _矢量动画框_组件放开某键 （键代码， 功能键状态， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
键代码 | 整数型； 为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。
矢量组件索引 | 整数型； 指示当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示当前所处矢量组件的实例名称。

例程：

说明：

当放开F2键时触发该事件。本事件只对“矢量编辑框”有效。


组件字符输入 (矢量动画框)

组件字符输入 事件 所属对象：矢量动画框 操作系统支持：Windows

当在编辑框中输入字符时触发此事件。本事件只对“矢量编辑框”有效。如果返回真，系统将继续产生字符输入事件。

语法： 逻辑型 _矢量动画框_组件字符输入 （字符代码， 矢量组件索引， 矢量组件名称）

参数名 | 描 述
字符代码 | 整数型； 输入的字符代码值。
矢量组件索引 | 整数型； 指示当前所处矢量组件的索引。
矢量组件名称 | 文本型； 指示当前所处矢量组件的实例名称。

例程：

说明：

在编辑框中输入7时触发此事件。本事件只对“矢量编辑框”有效。


一帧被加载后 (矢量动画框)

一帧被加载后 事件 所属对象：矢量动画框 操作系统支持：Windows

当一帧被加载后触发此事件。

语法： 逻辑型 _矢量动画框_一帧被加载后 （精灵索引， 帧索引）

参数名 | 描 述
精灵索引 | 整数型； 指示当前被加载的精灵索引。-1表示根精灵。
帧索引 | 整数型； 指示被加载的帧索引。

例程：

说明：

当一帧被加载后触发此事件。


精灵

精灵 普通类型 操作系统支持：Windows、Linux 跳至：矢量动画框

实现了对精灵的控制。

方法：

取索引 | 取名称 | 置名称 | 取横向位置
置横向位置 | 取纵向位置 | 置纵向位置 | 取宽度
置宽度 | 取高度 | 置高度 | 取是否可视
置可视 | 取横向缩放比例 | 置横向缩放比例 | 取纵向缩放比例
置纵向缩放比例 | 取旋转角度 | 置旋转角度 | 取透明度
置透明度 | 是否有效 | 取帧数 | 是否根精灵
播放 | 停止 | 跳到帧 | 取当前帧索引
取帧 | 取重复次数 | 置重复次数 | 取播放速率
置播放速率 | 是否正在播放 |  |

参见： 基本数据类型


取索引 (精灵)

取索引 方法 操作系统支持：Windows 所属对象：精灵

取组件的索引。

语法： 整数型 精灵．取索引 （）

例程：

说明：

取出组件按钮的索引。


取名称 (精灵)

取名称 方法 操作系统支持：Windows 所属对象：精灵

取组件的名称。

语法： 文本型 精灵．取名称 （）

例程：

说明：

取组件精灵的名称。


置名称 (精灵)

置名称 方法 操作系统支持：Windows 所属对象：精灵

设置组件的名称。成功返回真，失败返回假。

语法： 逻辑型 精灵．置名称 （名称）

参数名 | 描 述
名称 | 必需的； 文本型。要设置的组件名称。

例程：

说明：

设置精灵的名称。


取横向位置 (精灵)

取横向位置 方法 操作系统支持：Windows 所属对象：精灵

取组件位于窗口的横向位置。成功返回横向位置，失败返回-1。

语法： 整数型 精灵．取横向位置 （）

例程：

说明：

取精灵位于窗口的横向位置。


置横向位置 (精灵)

置横向位置 方法 操作系统支持：Windows 所属对象：精灵

设置组件位于窗口的横向位置。成功返回真，失败返回假。

语法： 逻辑型 精灵．置横向位置 （横向位置， ［是否重画］）

参数名 | 描 述
横向位置 | 必需的； 整数型。要设置的组件横向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置精灵位于窗口的横向位置。


取纵向位置 (精灵)

取纵向位置 方法 操作系统支持：Windows 所属对象：精灵

取组件位于窗口的纵向位置。成功返回纵向位置，失败返回-1。

语法： 整数型 精灵．取纵向位置 （）

例程：

说明：

取出精灵位于窗口的纵向位置。


置纵向位置 (精灵)

置纵向位置 方法 操作系统支持：Windows 所属对象：精灵

设置组件位于窗口的纵向位置。成功返回真，失败返回假。

语法： 逻辑型 精灵．置纵向位置 （纵向位置， [是否重画］）

参数名 | 描 述
纵向位置 | 必需的； 整数型。要设置的组件纵向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置精灵位于窗口的纵向位置。


取宽度 (精灵)

取宽度 方法 操作系统支持：Windows 所属对象：精灵

取组件的宽度。成功返回宽度，失败返回-1。

语法： 整数型 精灵．取宽度 （）

例程：

说明：

取组件精灵的宽度。


置宽度 (精灵)

置宽度 方法 操作系统支持：Windows 所属对象：精灵

设置组件的宽度。成功返回真，失败返回假。

语法： 逻辑型 精灵．置宽度 （宽度， ［是否重画］）

参数名 | 描 述
宽度 | 必需的； 整数型。要设置的组件宽度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件精灵的宽度。


取高度 (精灵)

取高度 方法 操作系统支持：Windows 所属对象：精灵

取组件的高度。成功返回高度，失败返回-1。

语法： 整数型 精灵．取高度 （）

例程：

说明：

取组件精灵的高度。


置高度 (精灵)

置高度 方法 操作系统支持：Windows 所属对象：精灵

设置组件的高度。成功返回真，失败返回假。

语法： 逻辑型 精灵．置高度 （高度， ［是否重画］）

参数名 | 描 述
高度 | 必需的； 整数型。要设置的组件高度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件精灵的高度。


取是否可视 (精灵)

取是否可视 方法 操作系统支持：Windows 所属对象：精灵

取组件是否可视。可视返回真，不可视返回假。

语法： 逻辑型 精灵．取是否可视 （）

例程：

说明：

取组件精灵是否可视。


置可视 (精灵)

置可视 方法 操作系统支持：Windows 所属对象：精灵

设置组件是否可视。成功返回真，失败返回假。

语法： 逻辑型 精灵．置可视 （[是否可视］， [是否重画］）

参数名 | 描 述
是否可视 | 可选的； 逻辑型。组件是否可视。真为可视，假为不可视。默认值为真。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置精灵是否可视。


取横向缩放比例 (精灵)

取横向缩放比例 方法 操作系统支持：Windows 所属对象：精灵

取组件的横向缩放比例（单位为：%）。

语法： 整数型 精灵．取横向缩放比例 （）

例程：

说明：

取组件的横向缩放比例，单位为：%


置横向缩放比例 (精灵)

置横向缩放比例 方法 操作系统支持：Windows 所属对象：精灵

设置组件的横向缩放比例。成功返回真，失败返回假。

语法： 逻辑型 精灵．置横向缩放比例 （横向缩放比例， ［是否重画］）

参数名 | 描 述
横向缩放比例 | 必需的； 整数型。要设置的组件宽度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的横向缩放比例。


取纵向缩放比例 (精灵)

取纵向缩放比例 方法 操作系统支持：Windows 所属对象：精灵

取组件的纵向缩放比例（单位为：%）。

语法： 整数型 精灵．取纵向缩放比例 （）

例程：

说明：

取组件的纵向缩放比例，单位为：%。


置纵向缩放比例 (精灵)

置纵向缩放比例 方法 操作系统支持：Windows 所属对象：精灵

设置组件的纵向缩放比例。失败返回真，失败返回假。

语法： 逻辑型 精灵．置纵向缩放比例 （纵向缩放比例， ［是否重画］）

参数名 | 描 述
纵向缩放比例 | 必需的； 整数型。要设置的组件纵向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的纵向缩放比例。

参见：例程


取旋转角度 (精灵)

取旋转角度 方法 操作系统支持：Windows 所属对象：精灵

取组件的旋转角度。只对矢量图形有效。

语法： 小数型 精灵．取旋转角度 （）

例程：

说明：

取精灵的旋转角度。


置旋转角度 (精灵)

置旋转角度 方法 操作系统支持：Windows 所属对象：精灵

置组件的旋转角度。只对矢量图形有效。成功返回真，失败返回假。

语法： 逻辑型 精灵．置旋转角度 （旋转角度， ［是否重画］）

参数名 | 描 述
旋转角度 | 必需的； 小数型。要设置的组件旋转角度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

置精灵的旋转角度；只对矢量图形有效。


取透明度 (精灵)

取透明度 方法 操作系统支持：Windows 所属对象：精灵

取图形组件的透明度。对矢量编辑框无效。值为透明度的百分比(%)，取值范围为0 - 100。

语法： 整数型 精灵．取透明度 （）

例程：

说明：

取图形组件的透明度；对矢量编辑框无效。


置透明度 (精灵)

置透明度 方法 操作系统支持：Windows 所属对象：精灵

设置图形组件的透明度。对矢量编辑框无效。成功返回真，失败返回假。

语法： 逻辑型 精灵．置透明度 （透明度， ［是否重画］）

参数名 | 描 述
透明度 | 必需的； 整数型。要设置的组件透明度百分比。取值范围为：0 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置精灵的透明度；对矢量编辑框无效。


是否有效 (精灵)

是否有效 方法 操作系统支持：Windows 所属对象：精灵

判断对象是否有效。有效返回真，无效返回假。

语法： 逻辑型 精灵．是否有效 （）

例程：

说明：

判断精灵是否有效。


取帧数 (精灵)

取帧数 方法 操作系统支持：Windows 所属对象：精灵

取本精灵所包含的帧数。

语法： 整数型 精灵．取帧数 （）

例程：

说明：

取本精灵所包含的帧数。


是否根精灵 (精灵)

是否根精灵 方法 操作系统支持：Windows 所属对象：精灵

取本精灵是否根精灵。

语法： 逻辑型 精灵．是否根精灵 （）

例程：

说明：

取本精灵是否根精灵。


播放 (精灵)

播放 方法 操作系统支持：Windows 所属对象：精灵

从当前帧开始播放本动画(精灵)。

语法： 无返回值 精灵．播放 （）

例程：

说明：

播放精灵。


停止 (精灵)

停止 方法 操作系统支持：Windows 所属对象：精灵

停止本动画(精灵)的播放。

语法： 无返回值 精灵．停止 （）

例程：

说明：

停止动画（精灵）的播放。


跳到帧 (精灵)

跳到帧 方法 操作系统支持：Windows 所属对象：精灵

跳到某一帧。

语法： 逻辑型 精灵．跳到帧 （索引）

参数名 | 描 述
索引 | 必需的； 整数型。帧的索引。

例程：

说明：

跳到精灵的当前帧。


取当前帧索引 (精灵)

取当前帧索引 方法 操作系统支持：Windows 所属对象：精灵

取当前帧的索引。

语法： 整数型 精灵．取当前帧索引 （）

例程：

说明：

取当前精灵帧的索引。


取帧 (精灵)

取帧 方法 操作系统支持：Windows 所属对象：精灵

返回帧数据类型。

语法： 帧 精灵．取帧 （索引）

参数名 | 描 述
索引 | 必需的； 整数型。帧的索引。

例程：

说明：

返回当前精灵的帧数据类型。


取重复次数 (精灵)

取重复次数 方法 操作系统支持：Windows 所属对象：精灵

取精灵播放的重复次数，-1一表示一直重复。

语法： 整数型 精灵．取重复次数 （）

例程：

说明：

取当前精灵播放的重复次数。


置重复次数 (精灵)

置重复次数 方法 操作系统支持：Windows 所属对象：精灵

置精灵播放的重复次数，-1一表示一直重复。

语法： 无返回值 精灵．置重复次数 （次数）

参数名 | 描 述
次数 | 必需的； 整数型。重复播放的次数，-1表示无限循环播放。

例程：

说明：

置当前精灵播放的重复次数。


取播放速率 (精灵)

取播放速率 方法 操作系统支持：Windows 所属对象：精灵

获取当前精灵的播放速率。

语法： 整数型 精灵．取播放速率 （）

例程：

说明：

获取当前精灵的播放速率。


置播放速率 (精灵)

置播放速率 方法 操作系统支持：Windows 所属对象：精灵

设置当前精灵的播放速率。

语法： 无返回值 精灵．置播放速率 （速率）

参数名 | 描 述
速率 | 必需的； 整数型。播放的速率。

例程：

说明：

设置当前精灵的播放速率。


是否正在播放 (精灵)

是否正在播放 方法 操作系统支持：Windows 所属对象：精灵

取当前精灵是否正在播放。正在播放返回真，已停止返回假。

语法： 逻辑型 精灵．是否正在播放 （）

例程：

说明：

获取当前精灵是否正在播放。


帧

帧 普通类型 操作系统支持：Windows、Linux 跳至：矢量动画框

实现了对动画帧的控制。

方法：

取层数 取层

参见： 基本数据类型


取层数 (帧)

取层数 方法 操作系统支持：Windows 所属对象：帧

取本帧所包含的层数。

语法： 整数型 帧．取层数 （）

例程：

说明:

取当前帧所包含的层数。


取层 (帧)

取层 方法 操作系统支持：Windows 所属对象：帧

取指定的层。

语法： 层 帧．取层 （索引）

参数名 | 描 述
索引 | 必需的； 整数型。层的索引。

例程：

说明：

取出指定的层。


层

层 普通类型 操作系统支持：Windows、Linux 跳至：矢量动画框

实现了对动画帧的控制。

方法：

取元素数 取深度 置深度

参见： 基本数据类型


取元素数 (层)

取元素数 方法 操作系统支持：Windows 所属对象：层

取本层所包含的矢量元素的个数。

语法： 整数型 层．取元素数 （）

例程：

说明：

取返回层所包含的矢量元素的个数。


取深度 (层)

取深度 方法 操作系统支持：Windows 所属对象：层

取本层所在的深度。

语法： 整数型 层．取深度 （）

例程：

说明：

取返回层所在的深度。


置深度 (层)

置深度 方法 操作系统支持：Windows 所属对象：层

设置本层的深度。

语法： 无返回值 层．置深度 （深度）

参数名 | 描 述
深度 | 必需的； 整数型。要设置的深度。

例程：

说明：

设置返回层的深度。


矢量图形

矢量图形 普通类型 操作系统支持：Windows、Linux 跳至：矢量动画框

实现了对矢量图形的控制。

方法：

取索引 | 取名称 | 置名称 | 取横向位置
置横向位置 | 取纵向位置 | 置纵向位置 | 取宽度
置宽度 | 取高度 | 置高度 | 取是否可视
置可视 | 取横向缩放比例 | 置横向缩放比例 | 取纵向缩放比例
置纵向缩放比例 | 取旋转角度 | 置旋转角度 | 取透明度
置透明度 | 是否有效 |  |

参见： 基本数据类型


取索引 (矢量图形)

取索引 方法 操作系统支持：Windows 所属对象： 矢量图形

取组件的索引。

语法： 整数型 矢量图形．取索引 （）

例程：

说明：

取出矢量图形的索引。


取名称 (矢量图形)

取名称 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的名称。

语法： 文本型 矢量图形．取名称 （）

例程：

说明：

取出矢量图形的名称。


置名称 (矢量图形)

置名称 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件的名称。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置名称 （名称）

参数名 | 描 述
名称 | 必需的； 文本型。要设置的组件名称。

例程：

说明：

设置图形的名称。


取横向位置 (矢量图形)

取横向位置 方法 操作系统支持：Windows 所属对象：矢量图形

取组件位于窗口的横向位置。成功返回横向位置，失败返回-1。

语法： 整数型 矢量图形．取横向位置 （）

例程：

说明：

取组件位于窗口的横向位置。


置横向位置 (矢量图形)

置横向位置 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件位于窗口的横向位置。成功返回真，失败返回假。

语法： 整数型 矢量图形．置横向位置 （横向位置，［是否重画］）

参数名 | 描 述
横向位置 | 必需的； 整数型。要设置的组件横向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件位于窗口的横向位置。


取纵向位置 (矢量图形)

取纵向位置 方法 操作系统支持：Windows 所属对象：矢量图形

取组件位于窗口的纵向位置。成功返回纵向位置，失败返回-1。

语法： 整数型 矢量图形．取纵向位置 （）

例程：

说明：

取组件位于窗口的纵向位置。


置纵向位置 (矢量图形)

置纵向位置 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件位于窗口的纵向位置。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置纵向位置 （纵向位置，［是否重画］）

参数名 | 描 述
纵向位置 | 必需的； 整数型。要设置的组件纵向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件位于窗口的纵向位置。


取宽度 (矢量图形)

取宽度 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的宽度。成功返回宽度，失败返回-1。

语法： 整数型 矢量图形．取宽度 （）

例程：

说明：

取图形的宽度。


置宽度 (矢量图形)

置宽度 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件的宽度。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置宽度 （宽度，[是否重画］）

参数名 | 描 述
宽度 | 必需的； 整数型。要设置的组件宽度
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的宽度。


取高度 (矢量图形)

取高度 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的高度。成功返回高度，失败返回-1。

语法： 整数型 矢量图形．取高度 （）

例程：

说明：

取组件的高度。


置高度 (矢量图形)

置高度 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件的高度。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置高度 （高度，[是否重画］）

参数名 | 描 述
高度 | 必需的； 整数型。要设置的组件高度
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的高度。


取是否可视 (矢量图形)

取是否可视 方法 操作系统支持：Windows 所属对象：矢量图形

取组件是否可视。可视返回真，不可视返回假。

语法： 逻辑型 矢量图形．取是否可视 （）

例程：

说明：

取组件是否可视。


置可视 (矢量图形)

置可视 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件是否可视。成功返回真，失败返回假。

语法： 逻辑型 精灵．置可视 （[是否可视］，[是否重画］）

参数名 | 描 述
是否可视 | 可选的； 逻辑型。组件是否可视。真为可视，假为不可视。默认值为真。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件是否可视。


取横向缩放比例 (矢量图形)

取横向缩放比例 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的横向缩放比例（单位为：%）。

语法： 整数型 矢量图形．取横向缩放比例 （）

例程：

说明：

取组件的横向缩放比例


置横向缩放比例 (矢量图形)

置横向缩放比例 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件的横向缩放比例。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置横向缩放比例 （横向缩放比例，[是否重画］）

参数名 | 描 述
横向缩放比例 | 必需的； 整数型。要设置的组件横向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的横向缩放比例。


取纵向缩放比例 (矢量图形)

取纵向缩放比例 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的纵向缩放比例（单位为：%）。

语法： 整数型 矢量图形．取纵向缩放比例 （）

例程：

说明：

取组件的纵向缩放比例。


置纵向缩放比例 (矢量图形)

置纵向缩放比例 方法 操作系统支持：Windows 所属对象：矢量图形

设置组件的纵向缩放比例。失败返回真，失败返回假。

语法： 逻辑型 矢量图形．置纵向缩放比例 （纵向缩放比例，[是否重画］）

例程：

说明：

设置组件的纵向缩放比例。


取旋转角度 (矢量图形)

取旋转角度 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的旋转角度。只对矢量图形有效。

语法： 小数型 矢量图形．取旋转角度 （）

例程：

说明：

取组件的旋转角度。


置旋转角度 (矢量图形)

置旋转角度 方法 操作系统支持：Windows 所属对象：矢量图形

置组件的旋转角度。只对矢量图形有效。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置旋转角度 （旋转角度，[是否重画］）

参数名 | 描 述
旋转角度 | 必需的； 小数型。要设置的组件旋转角度
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

置组件的旋转角度。


取透明度 (矢量图形)

取透明度 方法 操作系统支持：Windows 所属对象：矢量图形

取图形组件的透明度。对矢量编辑框无效。值为透明度的百分比(%)，取值范围为0 - 100。

语法： 整数型 矢量图形．取透明度 （）

例程：

说明：

取图形组件的透明度。


置透明度 (矢量图形)

置透明度 方法 操作系统支持：Windows 所属对象：矢量图形

设置图形组件的透明度。对矢量编辑框无效。成功返回真，失败返回假。

语法： 逻辑型 矢量图形．置透明度 （透明度，[是否重画］）

参数名 | 描 述
透明度 | 必需的； 整数型。要设置的组件透明度百分比。取值范围为：0 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置图形组件的透明度。


是否有效 (矢量图形)

是否有效 方法 操作系统支持：Windows 所属对象：矢量图形

判断对象是否有效。有效返回真，无效返回假。

语法： 逻辑型 矢量图形．是否有效 （）

例程：

说明：

判断对象是否有效。


矢量编辑框

矢量编辑框 普通类型 操作系统支持：Windows、Linux 跳至：矢量动画框

实现了对矢量编辑框的控制。

方法：

取索引 | 取名称 | 置名称 | 取横向位置
置横向位置 | 取纵向位置 | 置纵向位置 | 取宽度
置宽度 | 取高度 | 置高度 | 取是否可视
置可视 | 取横向缩放比例 | 置横向缩放比例 | 取纵向缩放比例
置纵向缩放比例 | 取旋转角度 | 置旋转角度 | 取透明度
置透明度 | 是否有效 | 取文本 | 置文本
取文本颜色 | 置文本颜色 | 置字体 | 取字体名称
取字体尺寸 | 取字体属性 | 是否只读 | 置只读
是否可选择文本 | 置可选择 | 是否自动换行 | 置自动换行
是否允许多行 | 置允许多行 | 取对齐方式 | 置对齐方式
取光标位置 | 置光标位置 | 取起始选择位置 | 置起始选择位置
取被选择文本 | 获取焦点 |  |

参见： 基本数据类型


取索引 (矢量编辑框)

取索引 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的索引。

语法： 整数型 矢量编辑框．取索引 （）

例程：

说明：

取组件的索引。


取名称 (矢量编辑框)

取名称 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的名称。

语法： 文本型 矢量编辑框．取名称 （）

例程：

说明：

取组件的名称。


置名称 (矢量编辑框)

置名称 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件的名称。成功返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置名称 （名称）

参数名 | 描 述
名称 | 必需的； 文本型。要设置的组件名称。

例程：

说明：

设置组件的名称。


取横向位置 (矢量编辑框)

取横向位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件位于窗口的横向位置。成功返回横向位置，失败返回-1。

语法： 整数型 矢量编辑框．取横向位置 （）

例程：

说明：

取组件位于窗口的横向位置。


置横向位置 (矢量编辑框)

置横向位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件位于窗口的横向位置。成功返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置横向位置 （横向位置，[是否重画］）

参数名 | 描 述
横向位置 | 必需的； 整数型。要设置的组件横向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件位于窗口的横向位置。


取纵向位置 (矢量编辑框)

取纵向位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件位于窗口的纵向位置。成功返回纵向位置，失败返回-1。

语法： 整数型 矢量编辑框．取纵向位置 （）

例程：

说明：

取组件位于窗口的纵向位置。


置纵向位置 (矢量编辑框)

置纵向位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件位于窗口的纵向位置。成功返回纵向位置，失败返回-1。

语法： 逻辑型 矢量编辑框．置纵向位置 （纵向位置，［是否重画］）

参数名 | 描 述
纵向位置 | 必需的； 整数型。要设置的组件纵向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

取组件位于窗口的纵向位置。


取宽度 (矢量编辑框)

取宽度 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的宽度。成功返回宽度，失败返回-1。

语法： 整数型 矢量编辑框．取宽度 （）

例程：

说明：

取组件的宽度。


置宽度 (矢量编辑框)

置宽度 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件的宽度。成功返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置宽度 （宽度，［ 是否重画］）

参数名 | 描 述
宽度 | 必需的； 整数型。要设置的组件宽度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的宽度。


取高度 (矢量编辑框)

取高度 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的高度。成功返回高度，失败返回-1。

语法： 整数型 矢量编辑框．取高度 （）

例程：

说明：

取组件的高度。


置高度 (矢量编辑框)

置高度 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件的高度。成功返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置高度 （高度，［是否重画］）

参数名 | 描 述
高度 | 必需的； 整数型。要设置的组件高度
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的高度。


取是否可视 (矢量编辑框)

取是否可视 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件是否可视。可视返回真，不可视返回假。

语法： 逻辑型 矢量编辑框．置高度 （高度，［是否重画］）

参数名 | 描 述
高度 | 必需的； 整数型。要设置的组件高度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

取组件是否可视。


置可视 (矢量编辑框)

置可视 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件是否可视。成功返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置可视 （［是否可视］，［是否重画］）

参数名 | 描 述
是否可视 | 可选的； 逻辑型。真为可视，假为不可视。默认值为真。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件是否可视。


取横向缩放比例 (矢量编辑框)

取横向缩放比例 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的横向缩放比例（单位为：%）。

语法： 整数型 矢量编辑框．取横向缩放比例 （）

例程：

说明：

取组件的横向缩放比例。


置横向缩放比例 (矢量编辑框)

置横向缩放比例 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件的横向缩放比例。成功返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置横向缩放比例 （横向缩放比例，［是否重画］）

参数名 | 描 述
横向缩放比例 | 必需的； 整数型。要设置的组件横向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的横向缩放比例。


取纵向缩放比例 (矢量编辑框)

取纵向缩放比例 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的纵向缩放比例（单位为：%）。

语法： 整数型 矢量编辑框．取纵向缩放比例 （）

例程：

说明：

取组件的纵向缩放比例。


置纵向缩放比例 (矢量编辑框)

置纵向缩放比例 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置组件的纵向缩放比例。失败返回真，失败返回假。

语法： 逻辑型 矢量编辑框．置纵向缩放比例 （纵向缩放比例，［是否重画］）

参数名 | 描 述
纵向缩放比例 | 必需的； 整数型。要设置的组件纵向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。要设置的组件纵向缩放比例（单位为：%）。取值范围为1 - 100。

例程：

说明：

设置组件的纵向缩放比例。


取旋转角度 (矢量编辑框)

取旋转角度 方法 操作系统支持：Windows 所属对象：矢量编辑框

取组件的旋转角度。只对矢量图形有效。

语法： 小数型 对象．取旋转角度 （）

说明：

只对矢量图形有效。


置旋转角度 (矢量编辑框)

置旋转角度 方法 操作系统支持：Windows 所属对象：矢量编辑框

置组件的旋转角度。只对矢量图形有效。成功返回真，失败返回假。

语法： 小数型 对象．置旋转角度 （旋转角度，［是否重画］）

参数名 | 描 述
旋转角度 | 必需的； 小数型。要设置的组件旋转角度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

说明：

只对矢量图形有效。

参见：例程


取透明度 (矢量编辑框)

取透明度 方法 操作系统支持：Windows 所属对象：矢量编辑框

取图形组件的透明度。对矢量编辑框无效。值为透明度的百分比(%)，取值范围为0 - 100。

语法： 整数型 对象．取透明度 （）

说明：

对矢量编辑框无效。


置透明度 (矢量编辑框)

置透明度 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置图形组件的透明度。对矢量编辑框无效。成功返回真，失败返回假。

语法： 逻辑型 对象．置透明度 （透明度，［是否重画］）

参数名 | 描 述
透明度 | 必需的； 整数型。要设置的组件透明度百分比。取值范围为：0 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

说明：

对矢量编辑框无效。


是否有效 (矢量编辑框)

是否有效 方法 操作系统支持：Windows 所属对象：矢量编辑框

判断对象是否有效。有效返回真，无效返回假。

语法： 逻辑型 矢量编辑框．是否有效 （）

例程：

说明：

判断对象是否有效。


取文本 (矢量编辑框)

取文本 方法 操作系统支持：Windows 所属对象：矢量编辑框

取编辑框的文本。成功返回编辑框文本，失败返回空文本。

语法： 文本型 矢量编辑框．取文本 （）

例程：

说明：

取编辑框的文本。


置文本 (矢量编辑框)

置文本 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框的显示文本。

语法： 无返回值 矢量编辑框．置文本 （文本）

参数名 | 描 述
文本 | 必需的； 文本型。要设置的编辑框文本。

例程：

说明：

设置编辑框的显示文本。


取文本颜色 (矢量编辑框)

取文本颜色 方法 操作系统支持：Windows 所属对象：矢量编辑框

取编辑框文本的显示颜色。

语法： 整数型 矢量编辑框．取文本颜色 （）

例程：

说明：

取编辑框文本的显示颜色


置文本颜色 (矢量编辑框)

置文本颜色 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的显示颜色。

语法： 无返回值 矢量编辑框．置文本颜色 （文本颜色）

参数名 | 描 述
文本颜色 | 必需的； 整数型。要设置的编辑框文本颜色。

例程：

说明：

设置编辑框文本的显示颜色


置字体 (矢量编辑框)

置字体 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的字体名称、字体尺寸、字体属性。

语法： 无返回值 矢量编辑框．置字体 （字体名称， 字体大小， ［字体属性］）

参数名 | 描 述
字体名称 | 必需的； 文本型。设置编辑框文本在显示时使用的字体名称。
字体大小 | 必需的； 整数型。设置编辑框文本在显示时使用的字体大小。
字体属性 | 可选的； 整数型。设置编辑框文本在显示时使用的字体属性。可以为以下常量值之一或之和：1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。

例程：

说明：

设置编辑框文本的字体名称、字体尺寸、字体属性。


取字体名称 (矢量编辑框)

取字体名称 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本在显示时所使用的字体名称。成功返回字体名称，失败返回空文本。

语法： 文本型 矢量编辑框．取字体名称 （）

例程：

说明：

返回编辑框文本在显示时所使用的字体名称。


取字体尺寸 (矢量编辑框)

取字体尺寸 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本在显示是所使用的字体尺寸。成功返回字体尺寸，失败返回-1。

语法： 整数型 矢量编辑框．取字体尺寸 （）

例程：

说明：

返回编辑框文本在显示是所使用的字体尺寸。


取字体属性 (矢量编辑框)

取字体属性 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本在显示时所使用字体的属性。返回值为以下常量值之一或之和：1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。失败返回 -1。

语法： 整数型 矢量编辑框．取字体属性 （）

例程：

说明：

返回编辑框文本在显示时所使用字体的属性。


是否只读 (矢量编辑框)

是否只读 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本的只读属性。真为只读、假为可写。

语法： 逻辑型 矢量编辑框．是否只读 （）

例程：

说明：

返回编辑框文本的只读属性


置只读 (矢量编辑框)

置只读 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的只读属性。

语法： 无返回值 矢量编辑框．置只读 （［只读属性］）

参数名 | 描 述
只读属性 | 可选的； 逻辑型。要设置的编辑框文本的只读属性。真为只读属性，假为取消只读属性。默认值为真。

例程：

说明：

设置编辑框文本的只读属性。


是否可选择文本 (矢量编辑框)

是否可选择文本 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本的可选择属性。真为可选择文本、假为不可选择文本。

语法： 逻辑型 矢量编辑框．是否可选择文本 （）

例程：

说明：

返回编辑框文本的可选择属性。


置可选择 (矢量编辑框)

置可选择 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的可选择属性。

语法： 无返回值 矢量编辑框．置可选择 （［可选择文本属性］）

参数名 | 描 述
可选择文本属性 | 可选的； 逻辑型。要设置的编辑框文本的可选择属性。真为可选择文本，假为不可选择属性。默认值为真。

例程：

说明：

设置编辑框文本的可选择属性。


是否自动换行 (矢量编辑框)

是否自动换行 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本的自动换行属性。真为自动换行、假为不自动换行。

语法： 逻辑型 矢量编辑框．是否自动换行 （）

例程：

说明：

返回编辑框文本的自动换行属性。


置自动换行 (矢量编辑框)

置自动换行 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的自动换行属性。

语法： 无返回值 矢量编辑框．置自动换行 （［自动换行属性］）

参数名 | 描 述
自动换行属性 | 可选的； 逻辑型。要设置的编辑框文本的自动换行属性。真为自动换行，假为不自动换行。默认值为真。

例程：

说明：

设置编辑框文本的自动换行属性。


是否允许多行 (矢量编辑框)

是否允许多行 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本的是否允许多行属性。真为允许多行显示、假为允许单行显示。

语法： 逻辑型 矢量编辑框．是否允许多行 （）

例程：

说明：

返回编辑框文本的是否允许多行属性。


置允许多行 (矢量编辑框)

置允许多行 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的允许多行属性。

语法： 无返回值 矢量编辑框．置允许多行 （［是否允许多行］）

参数名 | 描 述
是否允许多行 | 可选的； 逻辑型。要设置的编辑框文本的是否允许多行属性。真为允许多行显示，假为不允许多行显示。默认值为真。

例程：

说明：

设置编辑框文本的允许多行属性。


取对齐方式 (矢量编辑框)

取对齐方式 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框文本的对齐方式。可以为以下常量值之一：0、左对齐；1、右对齐；2、居中对齐。失败返回-1。

语法： 整数型 矢量编辑框．取对齐方式 （）

例程：

说明：

返回编辑框文本的对齐方式。


置对齐方式 (矢量编辑框)

置对齐方式 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框文本的对齐方式。

语法： 无返回值 矢量编辑框．置对齐方式 （对齐方式）

参数名 | 描 述
对齐方式 | 必需的； 整数型。要设置的编辑框文本的对齐方式。可以为以下常量值之一：0、左对齐；1、右对齐；2、居中对齐。

例程：

说明：

设置编辑框文本的对齐方式。


取光标位置 (矢量编辑框)

取光标位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框当前光标的位置。

语法： 整数型 矢量编辑框．取光标位置 （）

例程：

说明：

返回编辑框当前光标的位置。


置光标位置 (矢量编辑框)

置光标位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框的当前光标位置。

语法： 无返回值 矢量编辑框．置光标位置 （光标位置）

参数名 | 描 述
光标位置 | 必需的； 整数型。要设置的编辑框光标位置。

例程：

说明：

设置编辑框的当前光标位置。


取起始选择位置 (矢量编辑框)

取起始选择位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框选择区域的起始选择位置。如当前没有选择区域，则返回当前光标位置。

语法： 整数型 矢量编辑框．取起始选择位置 （）

例程：

说明：

返回编辑框选择区域的起始选择位置。


置起始选择位置 (矢量编辑框)

置起始选择位置 方法 操作系统支持：Windows 所属对象：矢量编辑框

设置编辑框选择区域的起始选择位置。

语法： 无返回值 矢量编辑框．置起始选择位置 （起始选择位置）

参数名 | 描 述
起始选择位置 | 必需的； 整数型。要设置的编辑框选择起始位置。

例程：

说明：

设置编辑框选择区域的起始选择位置。


取被选择文本 (矢量编辑框)

取被选择文本 方法 操作系统支持：Windows 所属对象：矢量编辑框

返回编辑框被选择区域的文本。如当前没有选择区域，返回空文本。

语法： 文本型 矢量编辑框．取被选择文本 （）

例程：

说明：

返回编辑框被选择区域的文本。


获取焦点 (矢量编辑框)

获取焦点 方法 操作系统支持：Windows 所属对象：矢量编辑框

将焦点移动到文本编辑上。

语法： 无返回值 对象．获取焦点 （）

说明：

将焦点移动到文本编辑上。


取索引 (精灵)

取索引 方法 操作系统支持：Windows 所属对象：矢量图形

取组件的索引。

语法： 整数型 矢量图形．取索引 （）

例程：

说明：

取出组件图形的索引。


矢量按钮

矢量按钮 普通类型 操作系统支持：Windows、Linux 跳至：矢量动画框

实现了对矢量按钮的控制。

方法：

取索引 | 取名称 | 置名称 | 取横向位置
置横向位置 | 取纵向位置 | 置纵向位置 | 取宽度
置宽度 | 取高度 | 置高度 | 取是否可视
置可视 | 取横向缩放比例 | 置横向缩放比例 | 取纵向缩放比例
置纵向缩放比例 | 取旋转角度 | 置旋转角度 | 取透明度
置透明度 | 是否有效 | 取图形 | 置图形
取编辑框 | 置编辑框 |  |

参见： 基本数据类型


取索引 (矢量按钮)

取索引 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的索引。

语法： 整数型 矢量按钮．取索引 （）

例程：

说明：

取按钮的索引。


取名称 (矢量按钮)

取名称 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的名称。

语法： 文本型 矢量按钮．取名称（）

例程：

说明：

取组件的名称。

参见：例程


置名称 (矢量按钮)

置名称 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件的名称。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置名称 （名称）

参数名 | 描 述
名称 | 必需的； 文本型。要设置的组件名称。

例程：

说明：

设置按钮的名称。


取横向位置 (矢量按钮)

取横向位置 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件位于窗口的横向位置。成功返回横向位置，失败返回-1。

语法： 整数型 矢量按钮．取横向位置 （）

例程：

说明：

取按钮位于窗口的横向位置。


置横向位置 (矢量按钮)

置横向位置 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件位于窗口的横向位置。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置横向位置 （横向位置，［是否重画］）

参数名 | 描 述
横向位置 | 必需的； 整数型。要设置的组件横向位置。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置按钮位于窗口的横向位置。


取纵向位置 (矢量按钮)

取纵向位置 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件位于窗口的纵向位置。成功返回纵向位置，失败返回-1。

语法： 整数型 矢量按钮．取纵向位置（）

例程：

说明：

取按钮位于窗口的纵向位置。


置纵向位置 (矢量按钮)

置纵向位置 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件位于窗口的纵向位置。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置纵向位置 （ 纵向位置，［是否重画］）

例程：

说明：

设置组件位于窗口的纵向位置。


取宽度 (矢量按钮)

取宽度 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的宽度。成功返回宽度，失败返回-1。

语法： 整数型 矢量按钮．取宽度（）

例程：

说明：

取组件的宽度。


置宽度 (矢量按钮)

置宽度 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件的宽度。成功返回真，失败返回假。本命令为初级对象成员命令。

语法： 逻辑型 矢量按钮．置宽度 （宽度，［是否重画］）

参数名 | 描 述
宽度 | 必需的； 整数型。要设置的组件横向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的宽度。


取高度 (矢量按钮)

取高度 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的高度。成功返回高度，失败返回-1。

语法： 整数型 矢量按钮．取高度（）

例程：

说明：

取组件的高度。


置高度 (矢量按钮)

置高度 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件的高度。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置高度 （高度，［是否重画］）

参数名 | 描 述
高度 | 必需的； 整数型。要设置的组件高度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的高度。


取是否可视 (矢量按钮)

取是否可视 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件是否可视。可视返回真，不可视返回假。

语法： 逻辑型 矢量按钮．取是否可视（）

例程：

说明：

取组件是否可视。


置可视 (矢量按钮)

置可视 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件是否可视。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置可视 （［是否可视］，［是否重画］）

参数名 | 描 述
是否可视 | 可选的； 逻辑型。组件是否可视。真为可视，假为不可视。默认值为真。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件是否可视。


取横向缩放比例 (矢量按钮)

取横向缩放比例 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的横向缩放比例（单位为：%）。

语法： 整数型 矢量按钮．取横向缩放比例（）

例程：

说明：

取组件的横向缩放比例。


置横向缩放比例 (矢量按钮)

置横向缩放比例 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件的横向缩放比例。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置横向缩放比例 （横向缩放比例，［是否重画］）

参数名 | 描 述
横向缩放比例 | 必需的； 整数型。要设置的组件横向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的横向缩放比例。


取纵向缩放比例 (矢量按钮)

取纵向缩放比例 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的纵向缩放比例（单位为：%）。

语法： 整数型 矢量按钮．取纵向缩放比例（）

例程：

说明：

取组件的纵向缩放比例。


置纵向缩放比例 (矢量按钮)

置纵向缩放比例 方法 操作系统支持：Windows 所属对象：矢量按钮

设置组件的纵向缩放比例。失败返回真，失败返回假。

语法：逻辑型 矢量按钮．置纵向缩放比例 （纵向缩放比例，［是否重画］）

参数名 | 描 述
纵向缩放比例 | 必需的； 整数型。要设置的组件纵向缩放比例（单位为：%）。取值范围为1 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置组件的纵向缩放比例。


取旋转角度 (矢量按钮)

取旋转角度 方法 操作系统支持：Windows 所属对象：矢量按钮

取组件的旋转角度。只对矢量图形有效。

语法：小数型 矢量按钮．取旋转角度 （）

例程：

说明：

取组件的旋转角度。


置旋转角度 (矢量按钮)

置旋转角度 方法 操作系统支持：Windows 所属对象：矢量按钮

置组件的旋转角度。只对矢量图形有效。成功返回真，失败返回假。

语法：逻辑型 矢量按钮．置旋转角度 （旋转角度，［是否重画］）

参数名 | 描 述
旋转角度 | 必需的； 小数型。要设置的组件旋转角度。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

置组件的旋转角度。


取透明度 (矢量按钮)

取透明度 方法 操作系统支持：Windows 所属对象：矢量按钮

取图形组件的透明度。对矢量编辑框无效。值为透明度的百分比(%)，取值范围为0 - 100。

语法：整数型 矢量按钮．取透明度 （）

例程：

说明：

取图形组件的透明度。


置透明度 (矢量按钮)

置透明度 方法 操作系统支持：Windows 所属对象：矢量按钮

设置图形组件的透明度。对矢量编辑框无效。成功返回真，失败返回假。

语法： 逻辑型 矢量按钮．置透明度 （透明度，［是否重画］）

参数名 | 描 述
透明度 | 必需的； 整数型。要设置的组件透明度百分比。取值范围为：0 - 100。
是否重画 | 可选的； 逻辑型。组件是否需要重画。真为重画，假为不重画。默认值为真。

例程：

说明：

设置图形组件的透明度。


是否有效 (矢量按钮)

是否有效 方法 操作系统支持：Windows 所属对象：矢量按钮

判断对象是否有效。有效返回真，无效返回假。

语法： 逻辑型 矢量按钮．是否有效 （）

例程：

说明：

判断对象是否有效。


取图形 (矢量按钮)

取图形 方法 操作系统支持：Windows 所属对象：矢量按钮

返回指定状态序号按钮中指定序号的图形。

语法： 矢量图形 矢量按钮．取图形 （状态序号，元素序号）

参数名 | 描 述
状态序号 | 必需的； 整数型。按钮的状态序号。可以为以下值之一：0 - 弹起；1 - 指针经过；2 - 按下；3 - 点击。
元素序号 | 必需的； 整数型。要取得的矢量元素的序号。

例程：

说明：

返回指定序号的图形。


置图形 (矢量按钮)

置图形 方法 操作系统支持：Windows 所属对象：矢量按钮

设置指定状态序号按钮中指定序号的图形。

语法： 逻辑型 矢量按钮．置图形 （状态序号，元素序号， 图形）

参数名 | 描 述
状态序号 | 必需的； 整数型。按钮的状态序号。可以为以下值之一：0 - 弹起；1 - 指针经过；2 - 按下；3 - 点击。
元素序号 | 必需的； 整数型。要设置的矢量元素的序号。
图形 | 必需的； 矢量图形。要设置的图形。

例程：

说明：

设置指定状态序号按钮中指定序号的图形，元素序号从0开始。


取编辑框 (矢量按钮)

取编辑框 方法 操作系统支持：Windows 所属对象：矢量按钮

返回指定状态序号按钮中指定序号的编辑框。

语法： 矢量编辑框 矢量按钮．取编辑框 （状态序号， 元素序号）

参数名 | 描 述
状态序号 | 必需的； 整数型。按钮的状态序号。可以为以下值之一：0 - 弹起；1 - 指针经过；2 - 按下；3 - 点击。
元素序号 | 必需的； 整数型。要取得的矢量元素的序号。

例程：

说明：

返回指定状态序号按钮中指定序号的编辑框，元素序号从0开始。


置编辑框 (矢量按钮)

置编辑框 方法 操作系统支持：Windows 所属对象：矢量按钮

设置指定状态序号按钮中指定序号的编辑框。

语法： 逻辑型 矢量按钮．置编辑框 （状态序号，编辑框序号，编辑框）

参数名 | 描 述
状态序号 | 必需的； 整数型。按钮的状态序号。可以为以下值之一：0 - 弹起；1 - 指针经过；2 - 按下；3 - 点击。
编辑框序号 | 必需的； 整数型。编辑框的序号。
编辑框 | 必需的； 矢量编辑框。要设置的编辑框。

例程：

说明：

设置指定状态序号按钮中指定序号的编辑框。


矢量组件类型 （枚举常量集合类型）

矢量组件类型 枚举常量集合类型 操作系统支持：Windows、Linux 跳至：矢量动画框

定义了矢量组件类型常量。

参数名 | 描 述
矢量精灵 | 常量值为 1 。矢量精灵类型。
矢量按钮 | 常量值为 2 。矢量按钮类型。
矢量图形 | 常量值为 3 。矢量图形类型。
矢量编辑框 | 常量值为 4 。矢量编辑框类型。

参见：基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。