自定义图形支持库

自定义图形支持 库帮助手册20080917版 返回首页

操作系统支持： Windows

窗口组件数据类型：

图形窗口

其它数据类型：

图形操作接口

图形类型

常量表...

适用版本，自定义图形支持库 （1.0#2版）


图形窗口

图形窗口 窗口组件 操作系统支持：Windows 跳至：自定义图形支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
文档属性 | 文档索引 | 文档个数 | 图形个数
背景颜色 | 边框 | 允许滚动 | 显示比例
允许编辑文本 | 允许右键菜单 |  |

方法：

加入文档 | 删除文档 | 取操作接口 | 加入图形
取实际宽度 | 取实际高度 | 取所有图形索引 | 取选中图形索引
刷新显示 |  |  |

自有事件：

图形鼠标位置被移动 图形鼠标进入 图形鼠标离开 图形鼠标左键被单击

基本事件：


左边 基本属性

左边 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

顶边 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

宽度 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

高度 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

标记 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

可视 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

禁止 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

鼠标指针 基本属性 操作系统支持：Windows、Linux、Unix

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


文档属性 (图形窗口)

文档属性 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：字节集；

参见：例程2


文档索引 (图形窗口)

文档索引 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：整数型； 指定当前显示的文档，索引从0开始。

参见： 基本数据类型


文档个数 (图形窗口)

文档个数 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：整数型； 本控件中可能包含多个文档，但同一时刻只能显示其中之一。本属性为只读属性。

参见： 基本数据类型


图形个数 (图形窗口)

图形个数 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：整数型； 当前文档中的图形个数。本属性为只读属性。

参见： 基本数据类型


背景颜色 (图形窗口)

背景颜色 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：整数型；

参见：例程2


边框 (图形窗口)

边框 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

参见：例程2


允许滚动 (图形窗口)

允许滚动 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：逻辑型； 如果本属性为真，则视需要显示滚动条，并允许滚动显示文档内容；否则不显示滚动条，超出控件区域的文档内容将被剪切。

参见：例程2


显示比例 (图形窗口)

显示比例 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：整数型； 本属性值为100时，表示按正常比例显示。

参见：例程2


允许编辑文本 (图形窗口)

允许编辑文本 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：逻辑型； 本属性指定是否允许用户在运行时通过双击图形修改其显示文本。

参见：例程2


允许右键菜单 (图形窗口)

允许右键菜单 属性 所属对象：图形窗口 操作系统支持：Windows

数据类型：逻辑型； 本属性决定了用户在运行时用鼠标右键单击控件时是否显示内置的右键操作菜单。

参见：例程2


加入文档 (图形窗口)

加入文档 方法 操作系统支持：Windows 所属对象：图形窗口

在指定位置加入新的文档。本控件可以包含多个文档，但同一时刻只能显示其中之一。当前显示的文档由“文档索引”属性决定。加入成功返回加入后的文档索引，加入失败返回-1。

语法： 整数型 图形窗口．加入文档 （［文档名称］， ［文档索引］）

参数名 | 描 述
文档名称 | 可选的； 文本型。如果被省略，将自动对其命名。
文档索引 | 可选的； 整数型。指定文档加入位置，索引从0开始。如果被省略或索引不合法，默认为在所有文档之前加入新文档。

参见：语法的描述规则、基本数据类型


删除文档 (图形窗口)

删除文档 方法 操作系统支持：Windows 所属对象：图形窗口

删除指定位置处的文档。

语法： 逻辑型 图形窗口．删除文档 （欲删除的文档索引）

参数名 | 描 述
欲删除的文档索引 | 必需的； 整数型。索引从0开始。

参见：语法的描述规则、基本数据类型


取操作接口 (图形窗口)

取操作接口 方法 操作系统支持：Windows 所属对象：图形窗口

通过本方法所返回的接口对象，可获取或设置图形的属性，或进行其它操作。通过该接口修改了图形属性后，必要时可调用“刷新显示()”方法刷新界面显示。

语法： 图形操作接口 图形窗口．取操作接口 （图形索引）

参数名 | 描 述
图形索引 | 必需的； 整数型，参数数据可以同时提供数组或非数组数据。只能指定当前文档中的图形索引。

参见：例程2


加入图形 (图形窗口)

加入图形 方法 操作系统支持：Windows 所属对象：图形窗口

在当前文档的左上角加入指定类型的图形。添加成功返回添加后的图形索引，添加失败返回-1。

语法： 整数型 图形窗口．加入图形 （［图形类型］）

参数名 | 描 述
图形类型 | 可选的； 图形类型。可以为枚举类型“图形类型”中的常量值之一。如果被省略，默认为“#图形类型.矩形”。

参见：例程2


取实际宽度 (图形窗口)

取实际宽度 方法 操作系统支持：Windows 所属对象：图形窗口

取本窗口用户区域的实际宽度，单位为 0.1 毫米。可能有误差。

语法： 整数型 图形窗口．取实际宽度 （）

参见： 语法的描述规则、基本数据类型


取实际高度 (图形窗口)

取实际高度 方法 操作系统支持：Windows 所属对象：图形窗口

取本窗口用户区域的实际高度，单位为 0.1 毫米。可能有误差。

语法： 整数型 图形窗口．取实际高度 （）

参见： 语法的描述规则、基本数据类型


取所有图形索引 (图形窗口)

取所有图形索引 方法 操作系统支持：Windows 所属对象：图形窗口

返回由当前文档中所有图形的索引组成的整数数组。第一个图形的索引值为0。

语法： 整数型数组 图形窗口．取所有图形索引 （）

参见： 语法的描述规则、基本数据类型


取选中图形索引 (图形窗口)

取选中图形索引 方法 操作系统支持：Windows 所属对象：图形窗口

返回由当前文档中所有被选中图形的索引组成的整数数组。

语法： 整数型数组 图形窗口．取选中图形索引 （）

参见： 语法的描述规则、基本数据类型


刷新显示 (图形窗口)

刷新显示 方法 操作系统支持：Windows 所属对象：图形窗口

语法： 无返回值 图形窗口．刷新显示 （）

参见：例程2


取图形接口 (图形)

取图形接口 方法 操作系统支持：Windows 所属对象：图形

通过本方法所返回的接口对象，可以获取或设置图形属性。通过该接口修改图形的属性后，必要时可调用“刷新显示()”方法刷新界面显示。

语法： 图形操作接口 图形．取图形接口 （）

参见： 语法的描述规则、基本数据类型


刷新显示 (图形)

刷新显示 方法 操作系统支持：Windows 所属对象：图形

语法： 无返回值 图形．刷新显示 （）

参见： 语法的描述规则、基本数据类型


图形鼠标位置被移动 (图形窗口)

图形鼠标位置被移动 事件 所属对象：图形窗口 操作系统支持：Windows

当鼠标指针在某个图形区域内移动时产生本事件。

语法： 无返回值 _图形窗口_图形鼠标位置被移动 （图形索引）

参数名 | 描 述
图形索引 | 整数型； 表示触发事件的图形。索引值从0开始。该图形必然位于当前文档中。

参见：例程2


图形鼠标进入 (图形窗口)

图形鼠标进入 事件 所属对象：图形窗口 操作系统支持：Windows

当鼠标指针进入某个图形区域内时产生本事件。

语法： 无返回值 _图形窗口_图形鼠标进入 （图形索引）

参数名 | 描 述
图形索引 | 整数型； 表示触发事件的图形。索引值从0开始。该图形必然位于当前文档中。

参见：例程2


图形鼠标离开 (图形窗口)

图形鼠标离开 事件 所属对象：图形窗口 操作系统支持：Windows

当鼠标指针离开某个图形区域内时产生本事件。

语法： 无返回值 _图形窗口_图形鼠标离开 （图形索引）

参数名 | 描 述
图形索引 | 整数型； 表示触发事件的图形。索引值从0开始。该图形必然位于当前文档中。

参见：例程2


图形鼠标左键被单击 (图形窗口)

图形鼠标左键被单击 事件 所属对象：图形窗口 操作系统支持：Windows

当在某个图形区域内按下鼠标左键时产生本事件。

语法： 无返回值 _图形窗口_图形鼠标左键被单击 （图形索引）

参数名 | 描 述
图形索引 | 整数型； 表示触发事件的图形。索引值从0开始。该图形必然位于当前文档中。

参见：例程2


图形操作接口

图形操作接口 普通类型 操作系统支持：Windows 跳至：自定义图形支持库

本对象用于提供设置或读取图形属性值以及其它操作的接口。请通过“图形窗口.取操作接口()”获取本对象。本对象中可能包含一个或多个图形对象的引用，设置属性时针对所有图形，读取属性时只针对第一个图形。

方法：

刷新显示 | 置位置和大小 | 取位置和大小 | 移动
取图形区域 | 置边线 | 取边线 | 置文本对齐方式
取文本对齐方式 | 置文本 | 取文本 | 置文本字体
置文本字体属性 | 取文本字体属性 | 置旋转角度 | 取旋转角度
置阴影 | 取阴影 | 置填充风格 | 置填充底纹类型
置填充色 | 置填充图片 | 取填充属性 | 置图形类型
取图形类型 | 置自定义图形 | 取绘图数据 | 刷新
选中 | 是否已选中 | 复制 | 粘贴
删除 | 剪切 | 锁定 | 取消锁定
调整层次 | 排列 | 微调 | 翻转
跳转 | 组合 | 分解 |

参见： 基本数据类型


刷新显示 (图形操作接口)

刷新显示 方法 操作系统支持：Windows 所属对象：图形操作接口

刷新显示被本对象所引用的图形。

语法： 无返回值 图形操作接口．刷新显示 （）

参见：例程2


置位置和大小 (图形操作接口)

置位置和大小 方法 操作系统支持：Windows 所属对象：图形操作接口

改变图形位置和大小。单位为0.1毫米。

语法： 逻辑型 图形操作接口．置位置和大小 （［左边］， ［底边］， ［宽度］， ［高度］）

参数名 | 描 述
左边 | 可选的； 整数型。
底边 | 可选的； 整数型。
宽度 | 可选的； 整数型。
高度 | 可选的； 整数型。

参见：语法的描述规则、基本数据类型


取位置和大小 (图形操作接口)

取位置和大小 方法 操作系统支持：Windows 所属对象：图形操作接口

取图形位置和大小。单位为0.1毫米。

语法： 逻辑型 图形操作接口．取位置和大小 （［左边］， ［底边］， ［宽度］， ［高度］）

参数名 | 描 述
左边 | 可选的； 整数型，参数数据只能提供变量。
底边 | 可选的； 整数型，参数数据只能提供变量。
宽度 | 可选的； 整数型，参数数据只能提供变量。
高度 | 可选的； 整数型，参数数据只能提供变量。

参见：语法的描述规则、基本数据类型


移动 (图形操作接口)

移动 方法 操作系统支持：Windows 所属对象：图形操作接口

改变图形位置和大小。单位为象素。

语法： 逻辑型 图形操作接口．移动 （［左边］， ［底边］， ［宽度］， ［高度］）

参数名 | 描 述
左边 | 可选的； 整数型。
底边 | 可选的； 整数型。
宽度 | 可选的； 整数型。
高度 | 可选的； 整数型。

参见：例程3


取图形区域 (图形操作接口)

取图形区域 方法 操作系统支持：Windows 所属对象：图形操作接口

取图形位置和大小。单位为象素。

语法： 逻辑型 图形操作接口．取图形区域 （［左边］， ［底边］， ［宽度］， ［高度］）

参数名 | 描 述
左边 | 可选的； 整数型，参数数据只能提供变量。
底边 | 可选的； 整数型，参数数据只能提供变量。
宽度 | 可选的； 整数型，参数数据只能提供变量。
高度 | 可选的； 整数型，参数数据只能提供变量。

参见：语法的描述规则、基本数据类型


置边线 (图形操作接口)

置边线 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置边线 （［线的类型］， ［线的颜色］， ［线的宽度］）

参数名 | 描 述
线的类型 | 可选的； 整数型。线的类型：0: 空线; 1: 圆头实线; 2: 方头实线; 3: 虚线; 4: 点线; 5: 点划线; 6: 双点划线;。
线的颜色 | 可选的； 整数型。
线的宽度 | 可选的； 整数型。单位：“磅”。如果此值为0，则线的宽度为一个象素宽度。如果不想显示边线，请设置“线的类型”参数为0（空线）。

参见：语法的描述规则、基本数据类型


取边线 (图形操作接口)

取边线 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．取边线 （［线的类型］， ［线的颜色］， ［线的宽度］）

参数名 | 描 述
线的类型 | 可选的； 整数型，参数数据只能提供变量。0: 空线; 1: 圆头实线; 2: 方头实线; 3: 虚线; 4: 点线; 5: 点划线; 6: 双点划线;。
线的颜色 | 可选的； 整数型，参数数据只能提供变量。
线的宽度 | 可选的； 整数型，参数数据只能提供变量。单位：“磅”。如果此值为0，则线的宽度为一个象素宽度。如果不想显示边线，请设置“线的类型”参数为0（空线）。

参见：语法的描述规则、基本数据类型


置文本对齐方式 (图形操作接口)

置文本对齐方式 方法 操作系统支持：Windows 所属对象：图形操作接口

设置图形中文本的水平对齐方式和垂直对齐方式。

语法： 逻辑型 图形操作接口．置文本对齐方式 （［水平对齐方式］， ［垂直对齐方式］）

参数名 | 描 述
水平对齐方式 | 可选的； 整数型。0：默认；1：左对齐；2：居中；3：右对齐。
垂直对齐方式 | 可选的； 整数型。0：默认；1：顶对齐；2：居中；3：底对齐。

参见：语法的描述规则、基本数据类型


取文本对齐方式 (图形操作接口)

取文本对齐方式 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．取文本对齐方式 （［水平对齐方式］， ［垂直对齐方式］）

参数名 | 描 述
水平对齐方式 | 可选的； 整数型，参数数据只能提供变量。0：默认；1：左对齐；2：居中；3：右对齐。
垂直对齐方式 | 可选的； 整数型，参数数据只能提供变量。0：默认；1：顶对齐；2：居中；3：底对齐。

参见：语法的描述规则、基本数据类型


置文本 (图形操作接口)

置文本 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置文本 （文本）

参数名 | 描 述
文本 | 必需的； 文本型。

参见：例程2


取文本 (图形操作接口)

取文本 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 文本型 图形操作接口．取文本 （）

参见： 语法的描述规则、基本数据类型


置文本字体 (图形操作接口)

置文本字体 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置文本字体 （［字体］， ［文本颜色］）

参数名 | 描 述
字体 | 可选的； 字体。
文本颜色 | 可选的； 整数型。

参见：语法的描述规则、基本数据类型


置文本字体属性 (图形操作接口)

置文本字体属性 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置文本字体属性 （［字体名称］， ［字体大小］， ［文本颜色］， ［加粗］， ［倾斜］， ［下划线］， ［删除线］）

参数名 | 描 述
字体名称 | 可选的； 文本型。
字体大小 | 可选的； 整数型。
文本颜色 | 可选的； 整数型。
加粗 | 可选的； 逻辑型。
倾斜 | 可选的； 逻辑型。
下划线 | 可选的； 逻辑型。
删除线 | 可选的； 逻辑型。

参见：例程2


取文本字体属性 (图形操作接口)

取文本字体属性 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．取文本字体属性 （［字体名称］， ［字体大小］， ［文本颜色］， ［加粗］， ［倾斜］， ［下划线］， ［删除线］）

参数名 | 描 述
字体名称 | 可选的； 文本型，参数数据只能提供变量。
字体大小 | 可选的； 整数型，参数数据只能提供变量。
文本颜色 | 可选的； 整数型，参数数据只能提供变量。
加粗 | 可选的； 逻辑型，参数数据只能提供变量。
倾斜 | 可选的； 逻辑型，参数数据只能提供变量。
下划线 | 可选的； 逻辑型，参数数据只能提供变量。
删除线 | 可选的； 逻辑型，参数数据只能提供变量。

参见：语法的描述规则、基本数据类型


置旋转角度 (图形操作接口)

置旋转角度 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置旋转角度 （［角度］）

参数名 | 描 述
角度 | 可选的； 整数型。以0.1度为单位。

参见：例程2


取旋转角度 (图形操作接口)

取旋转角度 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．取旋转角度 （［角度］）

参数名 | 描 述
角度 | 可选的； 整数型，参数数据只能提供变量。以0.1度为单位。

参见：例程2


置阴影 (图形操作接口)

置阴影 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置阴影 （［阴影方向］， ［阴影颜色］， ［阴影宽度］）

参数名 | 描 述
阴影方向 | 可选的； 整数型。可取以下值之一：0：无阴影；1：左上；2：上；3：右上；4：右；5：右下；6：下；7：左下；8：左。
阴影颜色 | 可选的； 整数型。
阴影宽度 | 可选的； 整数型。

参见：语法的描述规则、基本数据类型


取阴影 (图形操作接口)

取阴影 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．取阴影 （［阴影方向］， ［阴影颜色］， ［阴影宽度］）

参数名 | 描 述
阴影方向 | 可选的； 整数型，参数数据只能提供变量。可取以下值之一：0：无阴影；1：左上；2：上；3：右上；4：右；5：右下；6：下；7：左下；8：左。
阴影颜色 | 可选的； 整数型，参数数据只能提供变量。
阴影宽度 | 可选的； 整数型，参数数据只能提供变量。

参见：语法的描述规则、基本数据类型


置填充风格 (图形操作接口)

置填充风格 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置填充风格 （［填充风格］）

参数名 | 描 述
填充风格 | 可选的； 整数型。0:默认; 1:填充颜色; 2:填充底纹; 3:填充底图; 4:透明。

参见：语法的描述规则、基本数据类型


置填充底纹类型 (图形操作接口)

置填充底纹类型 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置填充底纹类型 （［底纹类型］）

参数名 | 描 述
底纹类型 | 可选的； 整数型。0：右斜线；1：直交叉线；2：斜交叉线；3：左斜线；4：横线；5：竖线；6：%5色点；7：10%色点；8：20%色点；9：25%色点；10：30%色点；11：40色点；12：50色点；13：60%色点；14：70%色点；15：75%色点；16：80%色点；17：90%色点；18：浅色上对角线；19：浅色下对角线；20：深色上对角线；21：深色下对角线；22：宽上对角线；23：宽下对角线；24：浅色竖线；25：浅色横线；26：窄竖线；27：窄横线；28：深色竖线；29：深色横线；30：上对角虚线；31：下对角虚线；32：横虚线；33：竖虚线；34：小纸屑；35：大纸屑；36：之字形；37：波浪形；38：对角砖形；39：横向砖形；40：纺织物；41：方格呢；42：草皮；43：虚格线；44：点式菱形；45：瓦形；46：棚架；47：球体；48：小网格；49：大网格；50：小棋盘；51：大棋盘；52：轮廓式菱形；53：实心菱形。

参见：语法的描述规则、基本数据类型


置填充色 (图形操作接口)

置填充色 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置填充色 （［填充色］， ［底纹背景色］）

参数名 | 描 述
填充色 | 可选的； 整数型。当填充类型为“颜色”时，本参数作为背景色；当填充类型为“底纹”时，本参数作为底纹前景色。
底纹背景色 | 可选的； 整数型。当填充类型为“底纹”时，本参数作为底纹背景色。

参见：语法的描述规则、基本数据类型


置填充图片 (图形操作接口)

置填充图片 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．置填充图片 （［图片填充类型］， ［图片文件名或图片数据］）

参数名 | 描 述
图片填充类型 | 可选的； 整数型。0：缩放；1：上边左；2：上边中；3：上边右；4：中间左；5：中间；6：中间右；7：下边左；8：下边中；9：下边右；10：平铺；11：无变形缩放平铺；12：无变形缩放居中。
图片文件名或图片数据 | 可选的； 通用型。

参见：语法的描述规则、基本数据类型


取填充属性 (图形操作接口)

取填充属性 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 逻辑型 图形操作接口．取填充属性 （［填充风格］， ［填充颜色］， ［底纹类型］， ［底纹背景颜色］， ［底图填充类型］）

参数名 | 描 述
参数名 | 描 述
填充风格 | 可选的； 整数型，参数数据只能提供变量。0:默认; 1:填充颜色; 2:填充底纹; 3:填充底图; 4:透明。
填充颜色 | 可选的； 整数型，参数数据只能提供变量。
底纹类型 | 可选的； 整数型，参数数据只能提供变量。0：右斜线；1：直交叉线；2：斜交叉线；3：左斜线；4：横线；5：竖线；6：%5色点；7：10%色点；8：20%色点；9：25%色点；10：30%色点；11：40色点；12：50色点；13：60%色点；14：70%色点；15：75%色点；16：80%色点；17：90%色点；18：浅色上对角线；19：浅色下对角线；20：深色上对角线；21：深色下对角线；22：宽上对角线；23：宽下对角线；24：浅色竖线；25：浅色横线；26：窄竖线；27：窄横线；28：深色竖线；29：深色横线；30：上对角虚线；31：下对角虚线；32：横虚线；33：竖虚线；34：小纸屑；35：大纸屑；36：之字形；37：波浪形；38：对角砖形；39：横向砖形；40：纺织物；41：方格呢；42：草皮；43：虚格线；44：点式菱形；45：瓦形；46：棚架；47：球体；48：小网格；49：大网格；50：小棋盘；51：大棋盘；52：轮廓式菱形；53：实心菱形。
底纹背景颜色 | 可选的； 整数型，参数数据只能提供变量。

参见：语法的描述规则、基本数据类型


置图形类型 (图形操作接口)

置图形类型 方法 操作系统支持：Windows 所属对象：图形操作接口

为高级用户提供，初级用户无需掌握；

语法： 逻辑型 图形操作接口．置图形类型 （图形类型）

参数名 | 描 述
图形类型 | 必需的； 图形类型。

参见：语法的描述规则、基本数据类型


取图形类型 (图形操作接口)

取图形类型 方法 操作系统支持：Windows 所属对象：图形操作接口

为高级用户提供，初级用户无需掌握；
如果图形是组合图形，返回值为-1；其它情况下返回值是枚举常量类型“图形类型”中的常量值之一。

语法： 整数型 图形操作接口．取图形类型 （）

参见： 语法的描述规则、基本数据类型


置自定义图形 (图形操作接口)

置自定义图形 方法 操作系统支持：Windows 所属对象：图形操作接口

为高级用户提供，初级用户无需掌握；
设置自定义绘图数据，以令图形显示为自定义样式的图形。如果参数“绘图数据”的数据格式不合法，将返回假。

语法： 逻辑型 图形操作接口．置自定义图形 （绘图数据）

参数名 | 描 述
绘图数据 | 必需的； 字节集。需提供符合特定规范的绘图数据（可由易公司提供的工具生成）。

参见：例程2


取绘图数据 (图形操作接口)

取绘图数据 方法 操作系统支持：Windows 所属对象：图形操作接口

为高级用户提供，初级用户无需掌握；

语法： 字节集 图形操作接口．取绘图数据 （）

参见：例程2


刷新 (图形操作接口)

刷新 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．刷新 （）

参见：例程2


选中 (图形操作接口)

选中 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．选中 （）

参见：例程2


是否已选中 (图形操作接口)

是否已选中 方法 操作系统支持：Windows 所属对象：图形操作接口

判断本对象中所引用的第一个图形是否已被选中。

语法： 逻辑型 图形操作接口．是否已选中 （）

参见： 语法的描述规则、基本数据类型


复制 (图形操作接口)

复制 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．复制 （）

参见：例程2


粘贴 (图形操作接口)

粘贴 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．粘贴 （）

参见：例程2


删除 (图形操作接口)

删除 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．删除 （）

参见：例程2


剪切 (图形操作接口)

剪切 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．剪切 （）

参见：例程2


锁定 (图形操作接口)

锁定 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．锁定 （）

参见：例程2


取消锁定 (图形操作接口)

取消锁定 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．取消锁定 （）

参见：例程2


调整层次 (图形操作接口)

调整层次 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．调整层次 （欲调整到的层次）

参数名 | 描 述
欲调整到的层次 | 必需的； 整数型。可以为以下常量之一： 1、#顶层； 2、#底层。

参见：例程2


排列 (图形操作接口)

排列 方法 操作系统支持：Windows 所属对象：图形操作接口

对多个图形按特定方式进行排列。

语法： 无返回值 图形操作接口．排列 （排列方式）

参数名 | 描 述
排列方式 | 必需的； 整数型。可以为以下常量之一：#顶边对齐、#底边对齐、#左边对齐、#右边对齐、#等宽、#等高。

参见：例程2


微调 (图形操作接口)

微调 方法 操作系统支持：Windows 所属对象：图形操作接口

对图形的位置或大小进行微调。

语法： 无返回值 图形操作接口．微调 （调整方式）

参数名 | 描 述
调整方式 | 必需的； 整数型。可以为以下常量之一：#上移、#下移、#左移、#右移、#底边上移、#底边下移、#右边左移、#右边右移。

参见：例程2


翻转 (图形操作接口)

翻转 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．翻转 （翻转方式）

参数名 | 描 述
翻转方式 | 必需的； 整数型。可以为以下常量之一：#水平翻转、#垂直翻转。

参见：例程2


跳转 (图形操作接口)

跳转 方法 操作系统支持：Windows 所属对象：图形操作接口

跳转到第一个图形所链接的文档。

语法： 无返回值 图形操作接口．跳转 （）

参见： 语法的描述规则、基本数据类型


组合 (图形操作接口)

组合 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．组合 （）

参见：例程2


分解 (图形操作接口)

分解 方法 操作系统支持：Windows 所属对象：图形操作接口

语法： 无返回值 图形操作接口．分解 （）

参见：例程2


图形类型

图形类型 枚举常量集合类型 操作系统支持：Windows 跳至：自定义图形支持库

成员 | 描 述
自定义 | 常量值为 0 。
简单文本框 | 常量值为 1 。
曲线 | 常量值为 2 。
矩形 | 常量值为 3 。
平形四边形 | 常量值为 4 。
梯形 | 常量值为 5 。
菱形 | 常量值为 6 。
圆角矩形 | 常量值为 7 。
八边形 | 常量值为 8 。
等腰三角形 | 常量值为 9 。
右三角 | 常量值为 10 。
椭圆 | 常量值为 11 。
六边形 | 常量值为 12 。
十字形 | 常量值为 13 。
正五边形 | 常量值为 14 。
圆柱形 | 常量值为 15 。
圆锥形 | 常量值为 16 。
立方体 | 常量值为 17 。
棱台 | 常量值为 18 。
折角形 | 常量值为 19 。
笑脸 | 常量值为 20 。
同心圆 | 常量值为 21 。
禁止符 | 常量值为 22 。
闪电形 | 常量值为 23 。
缺角矩形 | 常量值为 24 。
弧 | 常量值为 25 。
饼 | 常量值为 26 。
弦 | 常量值为 27 。
尺寸线 | 常量值为 28 。
过程 | 常量值为 29 。
可选过程 | 常量值为 30 。
决策 | 常量值为 31 。
数据 | 常量值为 32 。
预定义过程 | 常量值为 33 。
内部存贮 | 常量值为 34 。
文档 | 常量值为 35 。
多文档 | 常量值为 36 。
终止 | 常量值为 37 。
准备 | 常量值为 38 。
人工输入 | 常量值为 39 。
人工操作 | 常量值为 40 。
联系 | 常量值为 41 。
离页连接符 | 常量值为 42 。
卡片 | 常量值为 43 。
资料带 | 常量值为 44 。
汇总连接 | 常量值为 45 。
或者 | 常量值为 46 。
对照 | 常量值为 47 。
排序 | 常量值为 48 。
摘录 | 常量值为 49 。
合并 | 常量值为 50 。
库存数据 | 常量值为 51 。
延期 | 常量值为 52 。
顺序访问存贮器 | 常量值为 53 。
磁盘 | 常量值为 54 。
直接访问存贮器 | 常量值为 55 。
显示 | 常量值为 56 。
矩形标注 | 常量值为 57 。
圆角矩形标注 | 常量值为 58 。
爆炸形1 | 常量值为 59 。
爆炸形2 | 常量值为 60 。
十字星 | 常量值为 61 。
五角星 | 常量值为 62 。
八角星 | 常量值为 63 。
左箭头 | 常量值为 64 。
右箭头 | 常量值为 65 。
上箭头 | 常量值为 66 。
下箭头 | 常量值为 67 。
左右箭头 | 常量值为 68 。
上下箭头 | 常量值为 69 。
十字箭头 | 常量值为 70 。
丁字箭头 | 常量值为 71 。
圆角右箭头 | 常量值为 72 。
直角上箭头 | 常量值为 73 。
虚尾箭头 | 常量值为 74 。
燕尾箭头 | 常量值为 75 。
五边形箭头 | 常量值为 76 。
燕尾 | 常量值为 77 。
斜线 | 常量值为 78 。
横线 | 常量值为 79 。
竖线 | 常量值为 80 。
左箭头横线 | 常量值为 81 。
右箭头横线 | 常量值为 82 。
双向箭头横线 | 常量值为 83 。
上箭头竖线 | 常量值为 84 。
下箭头竖线 | 常量值为 85 。
双向箭头竖线 | 常量值为 86 。
左上直角线 | 常量值为 87 。
左下直角线 | 常量值为 88 。
右上直角线 | 常量值为 89 。
右下直角线 | 常量值为 90 。
左上箭头直角线 | 常量值为 91 。
左下箭头直角线 | 常量值为 92 。
右上箭头直角线 | 常量值为 93 。
右下箭头直角线 | 常量值为 94 。
左上箭头横环线 | 常量值为 95 。
左下箭头横环线 | 常量值为 96 。
右上箭头横环线 | 常量值为 97 。
右下箭头横环线 | 常量值为 98 。
左上箭头竖环线 | 常量值为 99 。
左下箭头竖环线 | 常量值为 100 。
右上箭头竖环线 | 常量值为 101 。
右下箭头竖环线 | 常量值为 102 。
左上箭头横折线 | 常量值为 103 。
左下箭头横折线 | 常量值为 104 。
右上箭头横折线 | 常量值为 105 。
右下箭头横折线 | 常量值为 106 。
左上箭头竖折线 | 常量值为 107 。
左下箭头竖折线 | 常量值为 108 。
右上箭头竖折线 | 常量值为 109 。
右下箭头竖折线 | 常量值为 110 。

参见： 基本数据类型


常量 | 常量值 | 描 述
#顶边对齐 | 1 |
#底边对齐 | 2 |
#左边对齐 | 3 |
#右边对齐 | 4 |
#等宽 | 5 |
#等高 | 6 |
#上移 | 1 |
#下移 | 2 |
#左移 | 3 |
#右移 | 4 |
#底边上移 | 5 |
#底边下移 | 6 |
#右边左移 | 7 |
#右边右移 | 8 |
#水平翻转 | 1 |
#垂直翻转 | 2 |


鼠标左键被按下

鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置， 纵向位置， 功能键状态）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


鼠标左键被放开

鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置， 纵向位置， 功能键状态）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


被双击

被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置， 纵向位置， 功能键状态）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


鼠标右键被按下

鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置， 纵向位置， 功能键状态）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


鼠标右键被放开

鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置， 纵向位置， 功能键状态）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


鼠标位置被移动

鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置， 纵向位置， 功能键状态）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


获得焦点

获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

参见： 语法的描述规则、基本数据类型


失去焦点

失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

参见： 语法的描述规则、基本数据类型


按下某键

按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码， 功能键状态）

参数名 | 描 述
键代码 | 整数型； 为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型； 用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


放开某键

放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码， 功能键状态）

参数名 | 描 述
键代码 | 整数型； 为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型； 用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型


字符输入

字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型； 表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

参见：语法的描述规则、基本数据类型


滚轮被滚动

滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离， 功能键状态）

参数名 | 描 述
滚动距离 | 整数型； 表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型； 用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

参见：语法的描述规则、基本数据类型