超文本浏览框

超文本浏览框 帮助手册20080801版 返回支持库手册 返回首页

本支持库实现了对超文本浏览框窗口单元的支持。

操作系统支持： Windows

窗口组件数据类型：

超文本浏览框

常量表...

例程列表：

例程名称 | 下载 | 说明
易浏览器 | 易浏览器.e | 演示了工具条、超文本浏览框、状态条的使用方法，可以浏览超文本网页。

适用版本，超文本浏览框支持库 （1.1#51版）


超文本浏览框

超文本浏览框 窗口组件 操作系统支持：Windows 跳至：超文本浏览框

提供对HTML页面的浏览支持。

属性：

字体大小 | 离线浏览 | 静默 | 地址
状态条文本 | 标题 |  |

方法：

执行命令 | 跳转 | 取文档类型 | 是否正在下载
是否就绪 |  |  |

自有事件：

即将跳转 | 跳转完毕 | 载入开始 | 载入进度改变
载入完毕 | 已就绪 | 状态文本被改变 | 标题被改变
命令状态被改变 | 即将打开新窗口 |  |

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动


字体大小 属性 所属对象：超文本浏览框 操作系统支持：Windows

数据类型：整数型；指定浏览页面时所使用的字体尺寸。

可供选择的属性值：
0、最小
1、较小
2、中等
3、较大
4、最大

语法： 对象.字体大小 = 整数型

应用对象：

超文本浏览框

例程

说明：

改变超文本浏览框中字体的大小。

注：如果更改了此属性，IE浏览器的默认字体大小也将被改变。

参见：例程


离线浏览 属性 数据类型：逻辑型；

离线浏览 属性 所属对象：超文本浏览框 操作系统支持：Windows

数据类型：逻辑型；

指定浏览器是否从缓存里面读取超文本页面数据。

语法： 对象.离线浏览 = 逻辑型

应用对象：

超文本浏览框

例程

说明：

设置浏览器是否从网页中直接读取网页数据。如果为真，则将网页数据输入到缓存中，再从缓存中读取网页数据。


静默 属性 数据类型：逻辑型；

静默 属性 所属对象：超文本浏览框 操作系统支持：Windows

数据类型：逻辑型；

本属性如果为真，则浏览过程中不允许浏览器显示自己的对话框。

语法： 对象.静默 = 逻辑型

应用对象：

超文本浏览框

例程

说明：

设置浏览过程中静默的状态，即是否显示浏览器自己的网页。


地址 属性 数据类型：文本型；

地址 属性 所属对象：超文本浏览框 操作系统支持：Windows

数据类型：文本型；

指定欲显示的网络或本机超文本页面地址。

语法： 对象.地址 = 文本型

应用对象：

超文本浏览框

例程

说明：

指定要打开的网址。


状态条文本 属性 数据类型：文本型；

状态条文本 属性 所属对象：超文本浏览框 操作系统支持：Windows

数据类型：文本型；

只读；用作在运行时提供浏览器的当前状态条文本。

语法： 对象.状态条文本

应用对象：

超文本浏览框

例程

说明：

读取当前正在打开的网页的状态文本，显示在网页状态条上。


标题 属性 数据类型：文本型；

标题 属性 所属对象：超文本浏览框 操作系统支持：Windows

数据类型：文本型；

只读；用作在运行时提供浏览器的当前标题文本。

语法： 对象.标题 = 文本型

应用对象：

超文本浏览框

例程

说明：

设置启动窗口的标题为打开的网页的标题。


执行命令 方法 操作系统支持：Windows 所属对象：超文本浏览框

执行指定的浏览器命令。

语法： 无返回值 超文本浏览框．执行命令 （欲执行的命令）

参数名 | 描 述
欲执行的命令 | 必需的；整数型。指定欲执行命令的类型，为以下常量值之一： 0: #前进； 1: #后退； 2: #到首页； 3: #到搜索页； 4: #刷新； 5: #停止； 6: #另存为； 7: #打印； 8: #打印预览； 9: #页面设置。

例程

说明：

执行浏览器自身存在的命令。


跳转 方法 操作系统支持：Windows 所属对象：超文本浏览框

打开互联网或者本机上指定位置处的文档。

语法： 无返回值 超文本浏览框．跳转 （欲打开文档地址，［CHM文件名称］，［目标窗口名称］）

参数名 | 描 述
欲打开文档地址 | 必需的；文本型。指定文档位于互联网或本机上的地址。
CHM文件名称 | 可选的；文本型。如果欲打开文档处于 .CHM 文件内，本参数提供该 CHM 文件的名称。如果本参数被省略，默认值为空文本。
目标窗口名称 | 可选的；文本型。指定文档是否在单独窗口中打开，相同的名称指定相同的窗口。如果欲在浏览框内部打开，提供空文本参数值即可。如果本参数被省略，默认值为空文本。

例程

说明：

打开网页或类似网页的文档，如果是打开网页则与地址属性功能等同。


取文档类型 方法 操作系统支持：Windows 所属对象：超文本浏览框

返回超文本浏览框中现行文档的类型文本。

语法： 文本型 超文本浏览框．取文档类型 （）

例程

说明：

取得打开的网页或文档的类型，在网页状态条上显示出来。


是否正在下载 方法 操作系统支持：Windows 所属对象：超文本浏览框

如果当前正在下载文档或执行页面跳转，返回真，否则返回假。

语法： 逻辑型 超文本浏览框．是否正在下载 （）

例程

说明：

判断超文本浏览框是否正在打开网页或文档。强调的是打开的过程。


是否就绪 方法 操作系统支持：Windows 所属对象：超文本浏览框

如果浏览框当前已经准备就绪，返回真，否则返回假。

语法： 逻辑型 超文本浏览框．是否就绪 （）

例程

说明：

判断超文本浏览框是否把网页或文档全部打开，强调的是打开的结果。


即将跳转 事件 所属对象：超文本浏览框 操作系统支持：Windows

在浏览器即将跳转到另一个页面之前产生此事件，在事件处理子程序中读取“地址”属性即可得知即将跳转到的地址，返回假不允许跳转，返回真或不返回值允许跳转。

语法： 逻辑型 _超文本浏览框_即将跳转 （）

例程

说明：

在浏览器开始发生跳转时触发此事件。只有在跳转时才有效，用地址属性打开网页该事件无效。


跳转完毕 事件 所属对象：超文本浏览框 操作系统支持：Windows

当浏览器已跳转到另一个页面之后产生此事件，在事件处理子程序中读取“地址”属性即可得知已跳转到的地址。

语法： 无返回值 _超文本浏览框_跳转完毕 （）

例程

说明：

在浏览器跳转完毕后触发此事件。即要打开的网页或文档全部被打开。


载入开始 事件 所属对象：超文本浏览框 操作系统支持：Windows

本事件在“即将跳转”事件之后触发，表示浏览器已开始载入将要显示的文档。

语法： 无返回值 _超文本浏览框_载入开始 （）

例程

说明：

当超文本浏览框在开始载入一个网页或文档时就触发此事件。


载入进度改变 事件 所属对象：超文本浏览框 操作系统支持：Windows

在浏览器载入文档的过程中，每当文档被载入一部分即触发本事件，用作通知载入进度。

语法： 无返回值 _超文本浏览框_载入进度改变 （进度百分比）

参数名 | 描 述
进度百分比 | 整数型；参数值指示当前文档已经被载入的百分比。

例程

说明：

在载入网页或文档的过程中触发此事件。


载入完毕 事件 所属对象：超文本浏览框 操作系统支持：Windows

当将要显示在浏览器内的文档被载入完毕后触发本事件。注意文档可能会被分批载入，此事件发生时并不一定意味着整个文档被已载入完毕。另请参考“已就绪”事件。

此事件的用户处理子程序不需要返回数据。

语法： 无返回值 _超文本浏览框_载入完毕 （）

例程

说明：

载入完毕是将网页或文档中的数据储存到缓存中，而不是在超文本浏览框中显示出来。


已就绪 事件 所属对象：超文本浏览框 操作系统支持：Windows

当浏览器已经将所需显示的文档处理完毕后发送本事件，在事件处理子程序中读取“地址”属性即可得知已就绪文档的地址。

此事件的用户处理子程序不需要返回数据。

语法： 无返回值 _超文本浏览框_已就绪 （）

例程

说明：

将网页或文档中的数据载入到缓存中，然后在超文本浏览框中显示出来，这样才触发到已就绪事件。


状态文本被改变 事件 所属对象：超文本浏览框 操作系统支持：Windows

当浏览器的状态条文本被改变后发送本事件，在事件处理子程序中读取“状态条文本”属性即可得知其内容。

语法： 无返回值 _超文本浏览框_状态文本被改变 （）

例程

说明：

浏览器打开网页或文档的状态发生改变就出发此事件。


标题被改变 事件 所属对象：超文本浏览框 操作系统支持：Windows

当浏览器的标题文本被改变后发送本事件，在事件处理子程序中读取“标题”属性即可得知其内容。

语法： 无返回值 _超文本浏览框_标题被改变 （）

例程

说明：

只要浏览器的标题发生改变就触发此事件，一般情况下，打开新的网页或文档标题都会改变。


命令状态被改变 事件 所属对象：超文本浏览框 操作系统支持：Windows

当“前进”、“后退”等命令的允许状态被改变后发送此事件，用户程序应该根据状态值允许或禁止对应的按钮或菜单项。

语法： 无返回值 _超文本浏览框_命令状态被改变 （命令，是否被允许）

参数名 | 描 述
命令 | 整数型；参数值指示允许状态被改变的命令类型，为以下常量值之一：0: #前进； 1: #后退。
是否被允许 | 逻辑型；参数值指示该命令当前是否被允许。

例程

说明：

当浏览器执行的命令发生改变的时候就触发此事件。


即将打开新窗口 事件 所属对象：超文本浏览框 操作系统支持：Windows

在浏览器即将打开新窗口浏览另一个页面之前产生此事件，事件处理子程序返回假不允许打开，返回真或不返回值允许打开。

语法： 逻辑型 _超文本浏览框_即将打开新窗口 （）

例程

说明：

在原来窗口的基础上，再弹出一个新的窗口时，就触发到此事件。


常量 | 常量值 | 描 述
#前进 | 0 |
#后退 | 1 |
#到首页 | 2 |
#到搜索页 | 3 |
#刷新 | 4 |
#停止 | 5 |
#另存为 | 6 |
#打印 | 7 |
#打印预览 | 8 |
#页面设置 | 9 |


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。