局域网操作支持库

局域网操作支持库 20080811版 返回支持库手册 返回首页

该支持库实现了Windows局域网(Windows Networking)操作的支持。

操作系统支持： Windows

其它数据类型：

局域网操作

资源类型

例程列表：

例程名称 | 下载 | 说明
局域网操作支持库例程 | 局域网操作支持库例程.e |

适用版本，局域网操作支持库 （1.0#3版）


局域网操作

局域网操作 普通类型 操作系统支持：Windows 跳至：局域网操作支持库

该组件实现对Windows局域网(Windows Netwroking)相关操作的封装。

方法：

取共享资源 | 取所有主机名 | 取连接速度 | 映射资源
断开映射 | 打开映射对话框 | 打开中断对话框 | 取对应资源
取资源路径 | 取错误信息 |  |

参见： 基本数据类型


启动 方法 操作系统支持：Windows、Linux 所属对象：安全服务器

取共享资源 命令 操作系统支持：Windows 所属类别：局域网操作

取出当前局域网中指定类型的共享资源（包括共享目录和共享文件夹）的路径。返回取得的资源个数。本命令为初级对象成员命令。

语法： 〈整数型〉 对象．取共享资源 （欲取的资源类型，取得的资源，［取得的资源类型］）

参数名 | 描 述
欲取的资源类型 | 必需的；类型为“资源类型（ResType）”。本参数指定欲取出的资源的类型。该参数可以为“资源类型”枚举常量集合中的一个常量值。
取得的资源 | 必需的；类型为“文本型（text）”，提供参数数据时只能提供变量数组。命令执行完毕后本变量数组中依次存放取得的资源的路径。
取得的资源类型 | 可省略；类型为“整数型（int）”，可以被省略，提供参数数据时只能提供变量数组。命令执行完毕后本变量数组中依次存放取得的资源的类型，并与取得的资源路径一一对应。该数组成员值可以为以下常量之一：“#资源类型.共享文件夹”或“#资源类型.共享打印机”。

例程:

说明:注意取回的数据是资源路径的数组而返回值是共享资源的数量。

参见:例程


调用格式： 〈整数型〉 对象

取所有主机名 命令 操作系统支持：Windows 所属类别：局域网操作

取出当前局域网中所有的主机名称。返回取得的主机个数。本命令为初级对象成员命令。

语法： 〈整数型〉 对象．取所有主机名 （取得的主机名）

参数名 | 描 述
取得的主机名 | 必需的；类型为“文本型（text）”，提供参数数据时只能提供变量数组。命令执行完毕后本变量数组中依次存放取得的主机名。

例程:

说明:注意返回的是主机个数，想调用取得的主机名，可以调用取得的主机名数组中的元素。

参见:例程


调用格式： 〈长整数型〉 对象

取连接速度 命令 操作系统支持：Windows 所属类别：局域网操作

取出与局域网内指定的共享资源（共享目录或共享打印机等）之间的连接速度。以“字节/秒”为单位。如果该命令执行出错，返回-1；如果无法取出连接速度，返回0。本命令为初级对象成员命令。

语法： 〈长整数型〉 对象．取连接速度 （欲测试的资源路径）

参数名 | 描 述
欲测试的资源路径 | 必需的；类型为“文本型（text）”。可以为局域网中的共享文件夹路径，比如“\\Prog5\共享测试”，也可以为映射到本地的网络驱动器名称，比如“Y:”。

例程:

说明: 注意，该命令取出的速度为大概值，可能有误差，仅供参考。

参见: 例程


调用格式： 〈文本型〉 对象

映射资源 命令 操作系统支持：Windows 所属类别：局域网操作

映射一个局域网内的共享资源到本地驱动器。成功返回映射到本地的驱动器名称（比如“X:”），失败返回空文本。本命令为初级对象成员命令。

语法： 〈文本型〉 对象．映射资源 （欲映射的资源路径，［欲映射到的本地设备名称］，［用户名］，［密码］，［是否提示错误］，［是否自动重新连接］）

参数名 | 描 述
欲映射的资源路径 | 必需的；类型为“文本型（text）”。该参数可以为局域网中的共享文件夹或共享打印机的路径，比如“\\Prog5\共享测试”，“\\Prog5\惠普打印机”。
欲映射到的本地设备名称 | 可省略；类型为“文本型（text）”，可以被省略。比如“Y:”，“LPT1”。如果本参数省略，系统将自动选择一个可用的设备名称。
用户名 | 可省略；类型为“文本型（text）”，可以被省略。访问指定的共享使用的用户名。如果本参数省略，将使用系统默认值。
密码 | 可省略；类型为“文本型（text）”，可以被省略。访问指定的共享使用的密码。如果本参数省略，将使用系统默认值。
是否提示错误 | 可省略；类型为“逻辑型（bool）”，可以被省略。本参数指定当用户名或密码错误时，是否提示重新输入。如果提供的用户名或密码有误，且本参数为假，该命令将失败。如果本参数省略，默认值为“真”。
是否自动重新连接 | 可省略；类型为“逻辑型（bool）”，可以被省略。本参数指定是否在下次登陆计算机时自动重新连接该映射驱动器。如果本参数省略，默认值为“真”。

例程:

说明: 成功返回映射到本地的驱动器名称（比如“X:”），失败返回空文本。


调用格式： 〈逻辑型〉 对象

断开映射 命令 操作系统支持：Windows 所属类别：局域网操作

断开一个映射到本地驱动器的共享资源。成功返回“真”，失败返回“假”。本命令为初级对象成员命令。

语法： 〈逻辑型〉 对象．断开映射 （欲断开的映射驱动器，是否永久断开，是否强制断开）

参数名 | 描 述
欲断开的映射驱动器 | 必需的；类型为“文本型（text）”。本参数指定欲断开连接的映射驱动器（或打印机）名称。比如“X:”或“LPT1”。
是否永久断开 | 必需的；类型为“逻辑型（bool）”，初始值为“真”。本参数指定是否永久断开该映射驱动器。永久断开的映射驱动器在下次登录时不会自动重新连接。
是否强制断开 | 必需的；类型为“逻辑型（bool）”，初始值为“假”。如果本参数为“真”，即使本映射驱动器正在使用，也立即强制断开。

例程:

说明:断开本地被映射的网络驱动器。


调用格式： 〈文本型〉 对象

打开映射对话框 命令 操作系统支持：Windows 所属类别：局域网操作

打开系统“映射网络驱动器”对话框。如果通过该对话框成功映射了一个网络驱动器，返回该驱动器的名称，否则返回空文本。本命令为初级对象成员命令。

语法： 〈文本型〉 对象．打开映射对话框 （网络路径初始值，网络路径可否输入，重新连接是否可选，是否自动连接，［父窗口句柄］）

参数名 | 描 述
网络路径初始值 | 必需的；类型为“文本型（text）”，初始值为“”。本参数指定出现在“映射网络驱动器”对话框中网络路径编辑框中的初始值。
网络路径可否输入 | 必需的；类型为“逻辑型（bool）”，初始值为“真”。本参数指定对话框中的网络路径编辑框是否可用。
重新连接是否可选 | 必需的；类型为“逻辑型（bool）”，初始值为“真”。本参数指定对话框中“登录时重新连接”复选框是否可用。
是否自动连接 | 必需的；类型为“逻辑型（bool）”，初始值为“真”。本参数指定对话框中“登录时重新连接”复选框是否被选中。
父窗口句柄 | 可省略；类型为“整数型（int）”，可以被省略。本参数指定打开的对话框的父窗口。

例程:

说明:调用系统的映射驱动器对话框 ，XP与WIN98各不相同，但返回值是一样的。


调用格式： 〈无返回值〉 对象

打开中断对话框 命令 操作系统支持：Windows 所属类别：局域网操作

打开系统“中断网络驱动器”对话框。本命令为初级对象成员命令。

语法：〈无返回值〉 对象．打开中断对话框 （［父窗口句柄］）

参数名 | 描 述
父窗口句柄 | 可省略；类型为“整数型（int）”，可以被省略。本参数指定打开的对话框的父窗口。

例程:

说明:打开系统的中断对话框，由用户选择执行什么样的操作，此命令无返回值。


调用格式： 〈文本型〉 对象

取对应资源 命令 操作系统支持：Windows 所属类别：局域网操作

取得指定的网络驱动器所对应的共享资源路径。失败返回空文本。本命令为初级对象成员命令。

语法：〈文本型〉 对象．取对应资源 （网络驱动器名称）

参数名 | 描 述
网络驱动器名称 | 必需的；类型为“文本型（text）”。本参数指定欲取其对应的资源路径的网络驱动器，比如“X:”。

例程:

说明:指定被映射的网络驱动器，返回的是该指定驱动器对应的局域网地址。


调用格式： 〈逻辑型〉 对象

取资源路径 命令 操作系统支持：Windows 所属类别：局域网操作

取得指定的网络驱动器的路径所对应的局域网资源路径、连接名称和相对路径。

语法：〈逻辑型〉 对象．取资源路径 （网络驱动器路径，取得的资源路径，［取得的连接名称］，［取得的相对路径］）

参数名 | 描 述
网络驱动器路径 | 必需的；类型为“文本型（text）”。
取得的资源路径 | 必需的；类型为“文本型（text）”，提供参数数据时只能提供变量。
取得的连接名称 | 可省略；类型为“文本型（text）”，可以被省略，提供参数数据时只能提供变量。
取得的相对路径 | 可省略；类型为“文本型（text）”，可以被省略，提供参数数据时只能提供变量。

例程:

说明: 比如将“\\Prog5\共享测试”映射到了驱动器“X:”，那么“X:\易语言教程.doc”所对应的资源路径为“\\Prog5\共享测试\易语言教程.doc”，连接名称为“\\Prog5\共享测试”，相对路径为“\易语言教程.doc”。本命令为初级对象成员命令。


调用格式： 〈文本型〉 对象

取错误信息 命令 操作系统支持：Windows 所属类别：局域网操作

当调用“局域网操作”的成员命令失败后，可以立即调用该命令来取出相关的错误信息。

语法：〈逻辑型〉 对象．取资源路径 （网络驱动器路径，取得的资源路径，［取得的连接名称］，［取得的相对路径］）

例程:

说明: 请仅在调用“局域网操作”的成员命令失败后调用本命令，否则取得的信息没有意义。本命令为初级对象成员命令。


资源类型

资源类型 枚举常量集合类型 操作系统支持：Windows 跳至：局域网操作支持库

成员 | 描 述
全部 | 常量值为 0 。共享文件夹和共享打印机。
共享文件夹 | 常量值为 1 。共享文件夹。
共享打印机 | 常量值为 2 。共享打印机。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。