应用接口支持库

应用接口支持库 帮助手册20080819版 返回支持库手册 返回首页

本支持库封装了常用的Windows API功能。

操作系统支持： Windows

命令类别：

系统处理

网络通信

窗口操作

杂项

其它数据类型：

接口常量 | 矩形数据 | CPU信息 | 系统信息
文件版本信息 | BIOS信息 | 硬盘信息 | 网卡信息
进程信息 | 显示模式信息 | 打印信息 |

适用版本，应用接口支持库 （1.1#5版）


系统处理

系统处理 类别 跳至：应用接口支持库

取键盘指示灯状态 | 模拟按键 | 模拟鼠标点击 | 取硬盘信息
取驱动器数量 | 取驱动器列表 | 弹出光驱 | 关闭光驱
取光驱盘符 | 光驱中是否有盘 | 取系统进程列表 | 终止进程
取正在使用DLL列表 | 取没有响应程序列表 | 取系统信息 | 取BIOS信息
取文件版本信息 | 取CPU信息 | 取CPU占用率 | 取内存容量信息
取声卡名称 | 打开监视器 | 关闭监视器 | 添加右键菜单
删除右键菜单 | 设置自动运行 | 删除临时文件 | 清除历史记录
取系统字体列表 | 安装字体 | 删除字体 | 取图片宽度
取图片高度 | 提取资源文件图标 | 取IE版本号 | 添加IE工具条按钮
删除IE工具条按钮 | 创建程序组 | 删除程序组 | 创建程序项
删除程序项 | 取快捷方式目标 | 取消自动运行 | 格式化文本
取打印机列表 | 取默认打印机 | 设置默认打印机 | 打开打印机对话框


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取得三个键盘提示灯当前状态。开返回真；关返回假。

语法： 逻辑型 取键盘指示灯状态 （［指示灯类别］）

参数名 | 描 述
指示灯类别 | 可选的；整数型。键盘指示灯类别，为以下常量值之一：0、#接口常量.数字锁定键盘灯； 1、#接口常量.大小写锁定键盘灯； 2、#接口常量.滚动锁定键盘灯。

例程:

说明:

判断数字锁定键盘灯、大小写锁定键盘灯、滚动锁定键盘灯是否打开。

参见:例程


模拟按键 命令 操作系统支持：Windows 所属类别：系统处理

模拟键盘的输入。

语法： 无返回值 模拟按键 （虚拟键值1，［虚拟键值2］，［虚拟键值3］）

参数名 | 描 述
虚拟键值1 | 必需的；通用型。
虚拟键值2 | 可选的；通用型。
虚拟键值3 | 可选的；通用型。

例程:

说明:

模拟键盘输入a键，并判断a键是否被按下。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

模拟鼠标点击 命令 操作系统支持：Windows 所属类别：系统处理

模拟模拟鼠标的点击。

语法： 无返回值 模拟鼠标点击 （X坐标，Y坐标，［点击类型］）

参数名 | 描 述
X坐标 | 必需的；整数型。
Y坐标 | 必需的；整数型。
点击类型 | 可选的；整数型。模拟鼠标点击的类型，可以为以下常量值之一：0、#接口常量.左键单击；1、#接口常量.左键双击；2、#接口常量.右键单击；3、#接口常量.右键双击。

例程:

说明:

模拟鼠标被单击，并判断鼠标被单击时，显示信息框的内容。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取硬盘信息 命令 操作系统支持：Windows 所属类别：系统处理

取硬件出厂信息。Win95/98/Me中可能无效。

语法： 逻辑型 取硬盘信息 （硬盘信息，［硬盘序号］）

参数名 | 描 述
硬盘信息 | 必需的；硬盘信息。待取得的硬盘信息。
硬盘序号 | 可选的；整数型。待取得的硬盘信息的硬盘序号。可以为以下常量之一：0、#接口常量.磁盘0；1、#接口常量.磁盘1；2、#接口常量.磁盘2；3、#接口常量.磁盘3。

例程:

说明:

取出硬盘的所有信息，最多可以取出四块硬盘的所有信息。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取驱动器数量 命令 操作系统支持：Windows 所属类别：系统处理

取当前指定类型的驱动器数量。

语法： 整数型 取驱动器数量 （［驱动器类型］）

参数名 | 描 述
驱动器类型 | 可选的；整数型。驱动器的类型，可以为以下常量值之一：0、#接口常量.所有驱动器；1、#接口常量.硬盘驱动器；2、#接口常量.光盘驱动器；3、#接口常量.可移动驱动器；4、#接口常量.网络驱动器。

例程:

说明:

取出所有的驱动器的个数，注意取出的驱动器为以下类型、所有驱动器、硬盘驱动器、光盘驱动器、可移动驱动器、网络驱动器。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取驱动器列表 命令 操作系统支持：Windows 所属类别：系统处理

取当前指定类型的驱动器列表。成功返回驱动器列表数组；失败返回空。

语法： 文本型数组 取驱动器列表 （［驱动器类型］）

参数名 | 描 述
驱动器类型 | 可选的；整数型。驱动器的类型，可以为以下常量值之一：0、#接口常量.所有驱动器；1、#接口常量.硬盘驱动器；2、#接口常量.光盘驱动器；3、#接口常量.可移动驱动器；4、#接口常量.网络驱动器。

例程:

说明:

取出所有的驱动器的名称，注意取出的驱动器为以下类型、所有驱动器、硬盘驱动器、光盘驱动器、可移动驱动器、网络驱动器。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

弹出光驱 命令 操作系统支持：Windows 所属类别：系统处理

弹出光驱门。

语法： 无返回值 弹出光驱 （）

例程:

说明:

弹出光驱门。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

关闭光驱 命令 操作系统支持：Windows 所属类别：系统处理

关闭光驱门。

语法： 无返回值 关闭光驱 （）

例程:

说明:

关闭光驱门。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取光驱盘符 命令 操作系统支持：Windows 所属类别：系统处理

取光驱盘符。失败返回空。

语法： 文本型 取光驱盘符 （）

例程:

说明:

取光驱盘符。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

光驱中是否有盘 命令 操作系统支持：Windows 所属类别：系统处理

光驱中是否有盘。有盘返回真；否则返回假。

语法： 逻辑型 光驱中是否有盘 （）

例程:

说明:

判断光驱中是否有盘。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取系统进程列表 命令 操作系统支持：Windows 所属类别：系统处理

取所有正在运行的程序列表。成功返回程序列表数组；失败返回空。

语法： 进程信息数组 取系统进程列表 （）

例程:

说明:

取所有正在运行的程序。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

终止进程 命令 操作系统支持：Windows 所属类别：系统处理

终止指定进程。成功返回真，失败返回假。

语法： 逻辑型 终止进程 （进程标识）

参数名 | 描 述
进程标识 | 必需的；通用型。要终止进程的进程ID、进程名称或窗口标题。

例程:

说明:

终止指定进程。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取正在使用DLL列表 命令 操作系统支持：Windows 所属类别：系统处理

取所有正在使用的DLL列表。成功返回DLL列表数组；失败返回空。

语法： 文本型数组 取正在使用DLL列表 （［进程标识符］）

参数名 | 描 述
进程标识符 | 可选的；整数型。要取得正在使用DLL列表的进程标识符。置-1则取所有正在使用DLL列表。

例程:

说明:

取所有正在使用的DLL列表。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取没有响应程序列表 命令 操作系统支持：Windows 所属类别：系统处理

取没有响应程序列表。成功返回程序标题数组，失败返回空。

语法： 文本型数组 取没有响应程序列表 （）

例程:

说明:

取没有响应程序列表。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取系统信息 命令 操作系统支持：Windows 所属类别：系统处理

取系统信息。

语法： 无返回值 取系统信息 （系统信息）

参数名 | 描 述
系统信息 | 必需的；系统信息。待取得的系统信息。

例程:

说明:

取系统信息。注意取的系统信息只能是以下内容：版本、代码、国家、时区、操作系统、建立号码、当前用户、系统目录、本地语言、国家代码、货币符号、日期格式、时间格式、最后服务包、系统安装目录。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取BIOS信息 命令 操作系统支持：Windows 所属类别：系统处理

取BIOS信息。

语法： 无返回值 取BIOS信息 （BIOS信息）

参数名 | 描 述
BIOS信息 | 必需的；BIOS信息。待取得的BIOS信息。

例程:

说明:

取BIOS信息。取BIOS信息只能为以下内容：名称、制造商、版权信息、日期、序列号、OEM信息。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取文件版本信息 命令 操作系统支持：Windows 所属类别：系统处理

取文件版本信息。

语法： 无返回值 取文件版本信息 （文件名，文件版本信息）

参数名 | 描 述
文件名 | 必需的；文本型。要取得版本信息的文件名。
文件版本信息 | 必需的；文件版本信息。待取得的文件版本信息。

例程:

说明:

取文件版本信息。取文件版本信息只能为以下内容：语言、备注、文件版本、文件描述、内部名称、公司名称、合法版权、合法商标、源文件名、产品名称、产品版本。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取CPU信息 命令 操作系统支持：Windows 所属类别：系统处理

取CPU信息。

语法： 无返回值 取CPU信息 （CPU信息）

参数名 | 描 述
CPU信息 | 必需的；CPU信息。待取得的CPU信息。

例程:

说明:

取CPU信息。取CPU信息只能为以下内容：制造商、名称、时钟频率、描述、一级缓存大小、二级缓存大小、序列号、数据宽度。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取CPU占用率 命令 操作系统支持：Windows 所属类别：系统处理

取当前CPU占用率。成功返回CPU占用率；失败返回-1。

语法： 整数型 取CPU占用率 （）

例程:

说明:

取当前CPU占用率。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取内存容量信息 命令 操作系统支持：Windows 所属类别：系统处理

取内存容量信息，单位为M（兆）。

语法： 整数型 取内存容量信息 （［内存类型］）

参数名 | 描 述
内存类型 | 可选的；整数型。要取得的内存类型，可以为以下常量值之一：0、#接口常量.总物理内存；1、#接口常量.可用物理内存；2、#接口常量.总虚拟内存；3、#接口常量.可用虚拟内存；4、#接口常量.总页面文件；5、#接口常量.可用页面文件。

例程:

说明:

取内存容量信息。要取得的内存类型，可以为以下常量值之一：0、#接口常量.总物理内存；1、#接口常量.可用物理内存；2、#接口常量.总虚拟内存；3、#接口常量.可用虚拟内存；4、#接口常量.总页面文件；5、#接口常量.可用页面文件。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取声卡名称 命令 操作系统支持：Windows 所属类别：系统处理

取系统声卡名称，失败返回空。

语法： 文本型 取声卡名称 （）

例程:

说明:

取系统声卡名称。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

打开监视器 命令 操作系统支持：Windows 所属类别：系统处理

语法： 无返回值 打开监视器 （窗口句柄）

参数名 | 描 述
窗口句柄 | 必需的；整数型。

例程:

说明:

打开监视器。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

关闭监视器 命令 操作系统支持：Windows 所属类别：系统处理

语法： 无返回值 关闭监视器 （窗口句柄）

参数名 | 描 述
窗口句柄 | 必需的；整数型。

例程:

说明:

把打开的监视器关闭。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

添加右键菜单 命令 操作系统支持：Windows 所属类别：系统处理

语法： 逻辑型 添加右键菜单 （扩展名，右键菜单标题，命令行）

参数名 | 描 述
扩展名 | 必需的；文本型。
右键菜单标题 | 必需的；文本型。显示在右键菜单上的标题。
命令行 | 必需的；文本型。

例程:

说明:

和WINDOWS优化大师添加右键菜单功能一样。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

删除右键菜单 命令 操作系统支持：Windows 所属类别：系统处理

语法： 逻辑型 删除右键菜单 （扩展名，右键菜单标题）

参数名 | 描 述
扩展名 | 必需的；文本型。
右键菜单标题 | 必需的；文本型。显示在右键菜单上的标题。

例程:

说明

删除右键菜单。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

设置自动运行 命令 操作系统支持：Windows 所属类别：系统处理

设置程序在开机时自动运行。

语法： 逻辑型 设置自动运行 （程序名称，程序文件名，［位置］）

参数名 | 描 述
程序名称 | 必需的；文本型。程序名称。
程序文件名 | 必需的；文本型。要设置为自动运行的程序文件名（包含绝对路径）。
位置 | 可选的；整数型。为以下常量值之一：0、#接口常量.到注册表；1、#接口常量.到启动组。

例程:

说明

设置程序在开机时自动运行。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

删除临时文件 命令 操作系统支持：Windows 所属类别：系统处理

删除指定位置的临时文件。成功返回真；失败返回假。

语法： 逻辑型 删除临时文件 （［临时文件类型］）

参数名 | 描 述
临时文件类型 | 可选的；整数型。临时文件类型，可以为以下常量值之一：0、#接口常量.系统临时文件；1、#接口常量.IE临时文件；2、#接口常量.回收站；3、#接口常量.存根文件。

例程:

说明

删除临时文件。注意删除的类型为以下类型，系统临时文件、IE临时文件、回收站、存根文件(就是用户系统目录Documents and Settings\用户名\Cookies文件夹里的内容)。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

清除历史记录 命令 操作系统支持：Windows 所属类别：系统处理

清除指定类型的历史记录。成功返回真；失败返回假。

语法： 逻辑型 清除历史记录 （［历史记录类型］）

参数名 | 描 述
历史记录类型 | 可选的；整数型。历史记录类型，可以为以下常量值之一：0、#接口常量.浏览器历史地址记录；1、#接口常量.表单自动完成历史记录；2、#接口常量.自动密码历史记录；3、#接口常量.收藏夹；4、#接口常量.自动拨号历史记录；5、#接口常量.运行中的自动匹配历史记录；6、#接口常量.打开文档历史记录；7、#接口常量.网络连接历史记录；8、#接口常量.远程登录历史记录；9、#接口常量.浏览网址历史记录。

例程:

说明

清除指定类型的历史记录。注意历史记录类型，可以为浏览器历史地址记录、表单自动完成历史记录、自动密码历史记录、收藏夹、自动拨号历史记录、运行中的自动匹配历史记录、打开文档历史记录、网络连接历史记录、远程登录历史记录、浏览网址历史记录。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取系统字体列表 命令 操作系统支持：Windows 所属类别：系统处理

取系统所有字体的列表。成功返回字体数组；失败返回空。

语法： 文本型数组 取系统字体列表 （）

例程:

说明

取系统所有字体。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

安装字体 命令 操作系统支持：Windows 所属类别：系统处理

在Windows系统中添加一种字体资源。添加完毕后，该字体即可由任何Windows应用程序调用。成功返回添加的字体数量；失败返回0。

语法： 整数型 安装字体 （字体文件名）

参数名 | 描 述
字体文件名 | 必需的；文本型。字体资源文件的文件名。可以是.FON，.FNT，.TTF或.FOT文件。

例程:

说明

在Windows系统中添加一种字体。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

删除字体 命令 操作系统支持：Windows 所属类别：系统处理

从Windows系统中删除一种字体资源。如删除的字体目前正由其他应用程序使用，则并不将其立即删除。成功返回真；失败返回假。

语法： 逻辑型 删除字体 （字体文件名）

参数名 | 描 述
字体文件名 | 必需的；文本型。字体资源文件的文件名。可以是.FON，.FNT，.TTF或.FOT文件。

例程:

说明

从Windows系统中删除一种字体, 如删除的字体目前正由其他应用程序使用，则并不将其立即删除。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取图片宽度 命令 操作系统支持：Windows 所属类别：系统处理

取得指定图片的宽度。成功返回图片宽度；失败返回0。

语法： 整数型 取图片宽度 （图片文件名）

参数名 | 描 述
图片文件名 | 必需的；文本型。支持以下几种图片格式：BMP、JPG、GIF、ICO。

例程

取得指定图片的宽度。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取图片高度 命令 操作系统支持：Windows 所属类别：系统处理

取得指定图片的高度。成功返回图片高度；失败返回0。

语法： 整数型 取图片高度 （图片文件名）

参数名 | 描 述
图片文件名 | 必需的；文本型。支持以下几种图片格式：BMP、JPG、GIF、ICO。

例程

取得指定图片的高度。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

提取资源文件图标 命令 操作系统支持：Windows 所属类别：系统处理

从指定的资源文件中提取图标，并保存为ICO、BMP文件或复制到剪贴板。成功返回图标数量；失败返回0。

语法： 整数型 提取资源文件图标 （资源文件名，［提取到］，［保存文件名］，［图标序号］）

参数名 | 描 述
资源文件名 | 必需的；文本型。要提取图标的资源文件名。扩展名为EXE、DLL、ICL、ICO。
提取到 | 可选的；整数型。要提取图标到何处，可以为以下常量值之一：0、#接口常量.到文件； 1、#接口常量.到剪贴板。
保存文件名 | 可选的；文本型。提取的图标要保存的文件名。扩展名为ICO、BMP。
图标序号 | 可选的；整数型。当资源文件中包含多个图标时，表示要提取图标的序号。

例程:

说明

从指定的资源文件中提取图标，并保存为ICO、BMP文件或复制到剪贴板。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取IE版本号 命令 操作系统支持：Windows 所属类别：系统处理

取得IE的版本号。成功返回版本号；失败返回空。

语法： 文本型 取IE版本号 （）

例程:

说明

取得IE的版本号。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

添加IE工具条按钮 命令 操作系统支持：Windows 所属类别：系统处理

向IE工具栏添加自己的按钮。

语法： 逻辑型 添加IE工具条按钮 （按钮文字，图标文件名，执行动作）

参数名 | 描 述
按钮文字 | 必需的；文本型。
图标文件名 | 必需的；文本型。
执行动作 | 必需的；文本型。在IE中按下按钮后执行一个可执行文件或打开网页。

例程

说明

向IE工具栏添加自己的按钮。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

删除IE工具条按钮 命令 操作系统支持：Windows 所属类别：系统处理

删除指定的IE工具栏按钮。

语法： 逻辑型 删除IE工具条按钮 （按钮文字）

参数名 | 描 述
按钮文字 | 必需的；文本型。

例程

说明

删除指定的IE工具栏按钮。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

创建程序组 命令 操作系统支持：Windows 所属类别：系统处理

在指定的位置建立程序组。成功返回真，失败返回假。

语法： 逻辑型 创建程序组 （程序组名称，［位置］）

参数名 | 描 述
程序组名称 | 必需的；文本型。要创建的程序组名称。
位置 | 可选的；整数型。程序组的起始位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

例程

说明

在指定的位置建立程序组, 注意程序组的位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

删除程序组 命令 操作系统支持：Windows 所属类别：系统处理

在指定的位置删除指定的程序组。成功返回真，失败返回假。

语法： 逻辑型 删除程序组 （程序组名称，［位置］）

参数名 | 描 述
程序组名称 | 必需的；文本型。要创建的程序组名称。
位置 | 可选的；整数型。程序组的起始位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

例程

说明

在指定的位置删除指定的程序组, 注意程序组的位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

创建程序项 命令 操作系统支持：Windows 所属类别：系统处理

在指定的程序组中创建程序项。成功返回真，失败返回假。

语法： 逻辑型 创建程序项 （程序组名称，程序项名称，程序文件名，［位置］）

参数名 | 描 述
程序组名称 | 必需的；文本型。程序项所在程序组的名称。
程序项名称 | 必需的；文本型。要创建的程序项名称。
程序文件名 | 必需的；文本型。执行程序文件名。
位置 | 可选的；整数型。程序项的起始位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

例程

说明

在指定的程序组中创建程序项, 注意程序组的位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

删除程序项 命令 操作系统支持：Windows 所属类别：系统处理

在指定的程序组中删除指定的程序项。成功返回真，失败返回假。

语法： 逻辑型 删除程序项 （程序组名称，程序项名称，［位置］）

参数名 | 描 述
程序组名称 | 必需的；文本型。程序项所在程序组的名称。
程序项名称 | 必需的；文本型。要创建的程序项名称。
位置 | 可选的；整数型。程序项的起始位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

例程

说明

在指定的程序组中删除指定的程序项, 注意程序组的位置。可以为以下常量值之一：0、#接口常量.开始菜单；1、#接口常量.开始菜单程序；2、#接口常量.桌面。

参见:例程


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

取快捷方式目标 命令 操作系统支持：Windows 所属类别：系统处理

获取指定快捷方式（.lnk）的目标和参数。成功返回目标，失败返回空。

语法： 文本型 取快捷方式目标 （快捷方式文件名）

参数名 | 描 述
快捷方式文件名 | 必需的；文本型。快捷方式文件名。

例程

说明

获取指定快捷方式（.lnk）的目标和参数。

参见:例程


取消网络驱动器映射 命令 操作系统支持：Windows 所属类别：网络通信

取消自动运行 命令 操作系统支持：Windows 所属类别：系统处理

取消程序的自动运行。

语法： 逻辑型 取消自动运行 （程序名称）

参数名 | 描 述
程序名称 | 必需的；文本型。程序名称。

例程

说明

取消启动组的运行项目。

参考：例程


取消网络驱动器映射 命令 操作系统支持：Windows 所属类别：网络通信

格式化文本 命令 操作系统支持：Windows 所属类别：系统处理

将一个格式化的字符串输出到一个目的字符串中。

语法： 文本型 格式化文本 （格式，参数，… ）

参数名 | 描 述
格式 | 必需的；文本型。转换的格式，以百分比符号 % 开始到转换字符为止。而在转换的格式间依序包括了1. 对齐方式。默认值为向右对齐，负号表向左对齐。2. 字段宽度。为最小宽度。3. 精确度。指在小数点后的浮点数位数。4. 类型: % - 印出百分比符号，不转换； c - 整数转成对应的 ASCII 字符； d - 整数； f - 双精度数字； o - 整数转成八进位； s - 字符串； x - 整数转成小写十六进位； X - 整数转成大写十六进位。
参数 | 必需的；可扩充的；通用型。

例程

说明

将一段文本进行格式化操作，要注意数值型和文本型参数的运用，具体请参见例程中的说明。

参考：例程


取打印机列表 命令 操作系统支持：Windows 所属类别：系统处理

枚举系统打印机列表。

语法： 文本型数组 取打印机列表 （）

例程:

说明:

获取系统内已安装的打印机列表。

参见:例程


取默认打印机 命令 操作系统支持：Windows 所属类别：系统处理

取系统默认打印机。成功返回默认打印机名称，失败返回空。

语法： 文本型 取默认打印机 （）

例程:

说明:

获取系统当前默认打印机。

参见:例程


设置默认打印机 命令 操作系统支持：Windows 所属类别：系统处理

设置系统的默认打印机。

语法： 逻辑型 设置默认打印机 （打印机名称）

参数名 | 描 述
打印机名称 | 必需的； 文本型。要设置为默认打印机的名称。

例程:

说明:

通过“设置默认打印机”命令设置打印文件时默认打印机。

参见:例程


打开打印机对话框 命令 操作系统支持：Windows 所属类别：系统处理

打开打印机设置对话框。返回1：点击了确定按钮；2：点击了取消按钮。

语法： 整数型 打开打印机对话框 （［对话框类型］， ［打印信息］）

参数名 | 描 述
对话框类型 | 可选的； 整数型。要打开的对话框类型。可以为以下两个常量值之一：0、#接口常量.标准打印设置对话框；1、#接口常量.打印对话框；2、#接口常量.打印属性对话框。默认值为0。
打印信息 | 可选的； 打印信息。指定打印机初始信息。当打印对话框关闭后，该信息内容为用户在对话框中设置的数据。

例程:

说明:

打开系统中标准的打印设置对话框。

参见:例程


网络通信

网络通信 类别 跳至：应用接口支持库

取网卡信息列表 | 取本机网卡名 | 取本机网卡物理地址 | 取远程网卡物理地址
取远程机器名 | 取IP地址 | 撰写邮件 | 取网络类型列表
取网络工作组列表 | 取网络计算机列表 | 是否与互联网连接 | 是否登入网络
端口检测 | 映射网络驱动器 | 发送局域网消息 | 取网络共享资源列表
取消网络驱动器映射 |  |  |


取网卡信息列表 命令 操作系统支持：Windows 所属类别：网络通信

取得本地计算机的网卡信息列表。失败返回空。

语法： 网卡信息数组 取网卡信息列表 （）

例程

说明

取出的信息是列表形式，包括网卡的名称，序号，IP地址，MAC地址，子网掩码

默认网关，WINS服务器地址，DHCP服务器地址

参考：例程


取本机网卡名 命令 操作系统支持：Windows 所属类别：网络通信

取得本地计算机指定序号的网卡名称。失败返回空。

语法： 文本型 取本机网卡名 （［网卡序号］）

参数名 | 描 述
网卡序号 | 可选的；整数型。当本机有多块网卡时，指定要对其操作的网卡序号（从1开始）。

例程

说明

将系统正在使用的网卡的名称取出来

参考：例程


取本机网卡物理地址 命令 操作系统支持：Windows 所属类别：网络通信

取得本地计算机指定序号的网卡物理地址。失败返回空。

语法： 文本型 取本机网卡物理地址 （［网卡序号］）

参数名 | 描 述
网卡序号 | 可选的；整数型。当本机有多块网卡时，指定要对其操作的网卡序号（从1开始）。

例程

说明

将系统正在使用的网卡的物理地址取出来

参考：例程


取远程网卡物理地址 命令 操作系统支持：Windows 所属类别：网络通信

根据指定的IP地址取远程机器网卡的物理地址。失败返回空。

语法： 文本型 取远程网卡物理地址 （IP地址）

参数名 | 描 述
IP地址 | 必需的；文本型。

例程

说明

根据指定的IP地址取远程机器网卡的物理地址

参考：例程


取远程机器名 命令 操作系统支持：Windows 所属类别：网络通信

根据指定的IP地址取远程机器名称。失败返回空。

语法： 文本型 取远程机器名 （IP地址）

参数名 | 描 述
IP地址 | 必需的；文本型。

例程

说明

根据指定的IP地址取远程机器名称

参考：例程


取IP地址 命令 操作系统支持：Windows 所属类别：网络通信

根据指定的机器名取IP地址。失败返回空。

语法： 文本型 取IP地址 （［机器名］）

参数名 | 描 述
机器名 | 可选的；文本型。要取得IP地址的机器名。

例程

说明

根据指定的机器名取IP地址

注意：机器名区分大小写

参考：例程


撰写邮件 命令 操作系统支持：Windows 所属类别：网络通信

语法： 无返回值 撰写邮件 （Email地址）

参数名 | 描 述
Email地址 | 必需的；文本型。

例程

说明

根据给定的地址打开邮箱

参考：例程


取网络类型列表 命令 操作系统支持：Windows 所属类别：网络通信

取所有的网络类型。成功返回程序列表数组；失败返回空。

语法： 文本型数组 取网络类型列表 （）

例程

说明

取所有的网络类型

参考：例程


取网络工作组列表 命令 操作系统支持：Windows 所属类别：网络通信

取局域网中指定网络类型的工作组列表。成功返回列表数组；失败返回空。

语法： 文本型数组 取网络工作组列表 （［网络类型］）

参数名 | 描 述
网络类型 | 可选的；文本型。网络类型名，为空则取所有工作组。

例程

说明

取局域网中指定网络类型的工作组列表

参考：例程


取网络计算机列表 命令 操作系统支持：Windows 所属类别：网络通信

取局域网中指定工作组的计算机列表。成功返回列表数组；失败返回空。

语法： 文本型数组 取网络计算机列表 （［工作组］）

参数名 | 描 述
工作组 | 可选的；文本型。工作组名称，为空则取所有计算机。

例程

说明

取局域网中指定工作组的计算机名称列表

参考：例程


是否与互联网连接 命令 操作系统支持：Windows 所属类别：网络通信

检测系统是否与互联网连接。成功返回真；失败返回假。

语法： 逻辑型 是否与互联网连接 （）

例程

说明

检测系统是否与互联网连接

参考：例程


是否登入网络 命令 操作系统支持：Windows 所属类别：网络通信

检测机器是否登入网络。成功返回真；失败返回假。

语法： 逻辑型 是否登入网络 （）

例程

说明

检测机器是否登入网络

参考：例程


端口检测 命令 操作系统支持：Windows 所属类别：网络通信

检测指定的端口是否开放。开放返回真；否则返回假。

语法： 逻辑型 端口检测 （端口，［IP地址］）

参数名 | 描 述
端口 | 必需的；整数型。检测的端口。
IP地址 | 可选的；文本型。置空则检测本机端口。

例程

说明

检测指定的端口是否开放

参考：例程


映射网络驱动器 命令 操作系统支持：Windows 所属类别：网络通信

将指定的网络资源映射到本地驱动器。成功返回真；失败返回假。

语法： 逻辑型 映射网络驱动器 （网络资源路径，驱动器）

参数名 | 描 述
网络资源路径 | 必需的；文本型。要映射到本地的网络资源路径。
驱动器 | 必需的；文本型。映射到本地的驱动器名。

例程

说明

将指定的网络资源映射到本地驱动器

参考：例程


发送局域网消息 命令 操作系统支持：Windows 所属类别：网络通信

发送消息到指定的机器（即Windows信使服务，只有启动了Messenger服务的机器才能收到该命令发送的消息）。成功返回真；失败返回假。

语法： 逻辑型 发送局域网消息 （［发送目标］，消息，［目标类型］）

参数名 | 描 述
发送目标 | 可选的；文本型。将要接收消息的目标机器，可以为机器名、IP地址、工作组名（具体由目标类型决定）。
消息 | 必需的；文本型。将要发送的消息文本。
目标类型 | 可选的；整数型。指定发送目标的类型。为以下常量值之一：0、#接口常量.计算机；1、#接口常量.工作组；2、#接口常量.广播。

例程

说明

发送局域网消息，就是Windows系统中信使服务

参考：例程


取网络共享资源列表 命令 操作系统支持：Windows 所属类别：网络通信

取局域网中指定计算机的共享资源列表。成功返回列表数组；失败返回空。

语法： 文本型数组 取网络共享资源列表 （［计算机］，［共享资源类型］）

参数名 | 描 述
计算机 | 可选的；文本型。计算机名称，为空则取所有计算机的共享资源。
共享资源类型 | 可选的；整数型。共享资源类型，可以为以下常量值之一： 0、#接口常量.所有共享资源； 1、#接口常量.共享目录或文件； 2、#接口常量.共享打印机。

例程

说明

将局域网中的共享资源取出。

参考：例程


取消网络驱动器映射 命令 操作系统支持：Windows 所属类别：网络通信

取消指定的网络驱动器映射。成功返回真；失败返回假。

语法： 逻辑型 取消网络驱动器映射 （驱动器）

参数名 | 描 述
驱动器 | 必需的；文本型。映射到本地的驱动器名。

例程

说明

取消指定的网络驱动器映射

参考：例程


窗口操作

窗口操作 类别 跳至：应用接口支持库

打开特殊系统窗口 | 打开指定网址 | 隐藏桌面图标 | 显示桌面图标
隐藏任务栏 | 显示任务栏 | 隐藏系统时钟 | 显示系统时钟
隐藏开始按钮 | 显示开始按钮 | 设置桌面墙纸 | 设置窗口透明度
取显示模式列表 | 取当前显示模式 | 设置屏幕分辨率 | 屏幕单位转换
取当前鼠标处颜色值 | 捕获鼠标 | 释放鼠标 | 截取屏幕区域
取所有窗口列表 | 取窗口标题 | 取窗口类名 | 取鼠标所在窗口句柄


打开特殊系统窗口 命令 操作系统支持：Windows 所属类别：窗口操作

打开特殊的系统窗口，如控制面板。

语法： 无返回值 打开特殊系统窗口 （窗口类型，［属性页序号］）

参数名 | 描 述
窗口类型 | 必需的；整数型。系统窗口类型，为以下常量值之一：0、#接口常量.控制面板；1、#接口常量.系统属性；2、#接口常量.显示属性；3、#接口常量.辅助功能选项；4、#接口常量.添加打印机向导；5、#接口常量.添加或删除程序；6、#接口常量.日期和时间属性；7、#接口常量.字体文件夹；8、#接口常量.游戏控制器；9、#接口常量.鼠标属性；10、#接口常量.键盘属性；11、#接口常量.声音和音频属性；12、#接口常量.ODBC数据源管理器；13、#接口常量.电源选项属性；14、#接口常量.区域和语言选项；15、#接口常量.互联网属性；16、#接口常量.用户帐号；17、#接口常量.系统信息对话框。
属性页序号 | 可选的；整数型。当有多个属性页时，表示要打开属性页的序号（从0开始）。

例程

说明

参考：例程


打开指定网址 命令 操作系统支持：Windows 所属类别：窗口操作

用系统默认浏览器打开指定的网址。

语法： 无返回值 打开指定网址 （［网址］）

参数名 | 描 述
网址 | 可选的；文本型。

例程

说明：

用系统默认浏览器打开指定的网址。

参考：例程


隐藏桌面图标 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 隐藏桌面图标 （）

例程

说明

参考：例程


显示桌面图标 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 显示桌面图标 （）

例程

说明

将桌面图标的可视效果置为真。

参考：例程


隐藏任务栏 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 隐藏任务栏 （）

例程

说明

将系统桌面任务栏的可视效果置为假。

参考：例程


显示任务栏 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 显示任务栏 （）

例程

说明：

将系统桌面任务栏的可视效果置为真。

参考：例程


隐藏系统时钟 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 隐藏系统时钟 （）

例程

说明

将桌面上系统时钟的可视效果置为假。

参考：例程


显示系统时钟 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 显示系统时钟 （）

例程

说明

将桌面上系统时钟的可视效果置为真。

参考：例程


隐藏开始按钮 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 隐藏开始按钮 （）

例程

说明

将桌面上开始按钮的可视效果置为假。

参考：例程


显示开始按钮 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 无返回值 显示开始按钮 （）

例程

说明

参考：例程


设置桌面墙纸 命令 操作系统支持：Windows 所属类别：窗口操作

成功返回真；失败返回假。

语法： 逻辑型 设置桌面墙纸 （文件名，［样式］）

参数名 | 描 述
文件名 | 必需的；文本型。墙纸文件名（bmp格式）。将文件名置为空可以取消墙纸。
样式 | 可选的；整数型。墙纸样式，可以为以下常量值之一：0、#接口常量.居中；1、#接口常量.平铺；2、#接口常量.拉伸。

例程

说明

将当前的桌面背景设置为所选择的图片效果。（只应用于 [* .bmp] 文件）

参考：例程


设置窗口透明度 命令 操作系统支持：Windows 所属类别：窗口操作

该命令在Windows 95/98下无效。

语法： 无返回值 设置窗口透明度 （窗口句柄，［透明度］）

参数名 | 描 述
窗口句柄 | 必需的；整数型。要设置透明度的窗口句柄。
透明度 | 可选的；整数型。为0-255之间的整数。0 - 整个窗口透明, 255 - 完全不透明。

例程

说明

设置当前操作窗口的透明化效果。

参考：例程


取显示模式列表 命令 操作系统支持：Windows 所属类别：窗口操作

取系统支持的显示模式列表(Win95/98/Me下无法取得刷新频率)。成功返回显示模式信息数组，失败返回空。

语法： 显示模式信息数组 取显示模式列表 （）

例程

说明

取出系统所有打开窗口的显示模式信息。类型为显示模式信息数组。成员有（宽度，高度，颜色值，分辨率）

参考：例程


取当前显示模式 命令 操作系统支持：Windows 所属类别：窗口操作

取系统当前的显示模式(Win95/98/Me下无法取得刷新频率)。

语法： 显示模式信息 取当前显示模式 （）

例程

说明

取出系统当前窗口的显示模式信息。类型为显示模式信息数组。成员有（宽度，高度，颜色值，分辨率）

参考：例程


设置屏幕分辨率 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 逻辑型 设置屏幕分辨率 （宽度，高度，［位数］，［刷新频率］）

参数名 | 描 述
宽度 | 必需的；整数型。屏幕显示区域的宽度，单位为像素点。
高度 | 必需的；整数型。屏幕显示区域的高度，单位为像素点。
位数 | 可选的；整数型。每像素的位数。
刷新频率 | 可选的；整数型。屏幕的刷新频率。

例程

说明

设置系统当前的像素单位。（800*600分辨率为800乘600像素点）

参考：例程


屏幕单位转换 命令 操作系统支持：Windows 所属类别：窗口操作

语法： 双精度小数型 屏幕单位转换 （源单位值，［源单位］，［目的单位］）

参数名 | 描 述
源单位值 | 必需的；双精度小数型。要转换的源单位值。
源单位 | 可选的；整数型。单位类型，为以下常量值之一：0、#接口常量.像素；1、#接口常量.英寸；2、#接口常量.毫米；3、#接口常量.厘米。
目的单位 | 可选的；整数型。单位类型，为以下常量值之一：0、#接口常量.像素；1、#接口常量.英寸；2、#接口常量.毫米；3、#接口常量.厘米。

例程

说明

转换屏幕的显示单位。失败返回0。单位有（像素.毫米.厘米.英寸 四项）

参考：例程


取当前鼠标处颜色值 命令 操作系统支持：Windows 所属类别：窗口操作

取当前鼠标所在位置的RGB值。

语法： 逻辑型 取当前鼠标处颜色值 （R值，G值，B值）

参数名 | 描 述
R值 | 必需的；整数型，参数数据只能提供变量。要取得的R值。
G值 | 必需的；整数型，参数数据只能提供变量。要取得的G值。
B值 | 必需的；整数型，参数数据只能提供变量。要取得的B值。

例程

说明

取出当前鼠标按下时，所在位置的RGB值。

参考：例程


捕获鼠标 命令 操作系统支持：Windows 所属类别：窗口操作

将鼠标捕获设置到指定的窗口。在鼠标按钮按下的时候，这个窗口会为当前应用程序或整个系统接收所有鼠标输入。返回值为之前拥有鼠标捕获的窗口的句柄，如没有这样的窗口则返回空。

语法： 整数型 捕获鼠标 （窗口句柄）

参数名 | 描 述
窗口句柄 | 必需的；整数型。要接收所有鼠标输入的窗口的句柄。

例程

说明

将鼠标捕获设置到指定的窗口。若在当前窗口捕获鼠标时，鼠标支持此窗口当前操作的组件，即获得焦点的组件，概不支持其他组件。

参考：例程


释放鼠标 命令 操作系统支持：Windows 所属类别：窗口操作

为当前的应用程序释放鼠标捕获。成功返回真、失败返回假。

语法： 逻辑型 释放鼠标 （）

例程

说明

释放程序所捕获的鼠标。即：当前所有窗口都支持鼠标操作。

参考：例程


截取屏幕区域 命令 操作系统支持：Windows 所属类别：窗口操作

将选定的屏幕区域拷贝到位图文件、剪贴板或字节集中。如拷贝到位图文件或剪贴板，则成功返回真；失败返回假。如拷贝到字节集，则成功返回位图字节集；失败返回空。

语法： 通用型 截取屏幕区域 （［屏幕区域］，［截取到］，［位图文件名］）

参数名 | 描 述
屏幕区域 | 可选的；矩形数据。要截取的屏幕区域，为空则截取整个屏幕。
截取到 | 可选的；整数型。要截取屏幕区域到何处，可以为以下常量值之一：0、#接口常量.到文件； 1、#接口常量.到剪贴板； 2、#接口常量.到字节集。
位图文件名 | 可选的；文本型。

例程

说明

将选定的屏幕区域拷贝到位图文件、剪贴板或字节集中。

参考：例程


取所有窗口列表 命令 操作系统支持：Windows 所属类别：窗口操作

取当前打开的所有窗口列表。成功返回窗口句柄数组，失败返回空。

语法： 文本型数组 取所有窗口列表 （）

例程

说明

取出当前打开的所有窗口的窗口句柄。类型为文本型数组。

参考：例程


取窗口标题 命令 操作系统支持：Windows 所属类别：窗口操作

取指定窗口的标题。成功返回窗口标题，失败返回空。

语法： 文本型 取窗口标题 （窗口句柄）

参数名 | 描 述
窗口句柄 | 必需的；整数型。

例程

说明

取出指定窗口的标题。需提供该窗口的窗口句柄。

参考：例程


取窗口类名 命令 操作系统支持：Windows 所属类别：窗口操作

取指定窗口的类名。成功返回窗口类名，失败返回空。

语法： 文本型 取窗口类名 （窗口句柄）

参数名 | 描 述
窗口句柄 | 必需的；整数型。

例程

说明

取出指定窗口的类名。如： ENewFrame ，Shell_TrayWnd 。

参考：例程


取鼠标所在窗口句柄 命令 操作系统支持：Windows 所属类别：窗口操作

取鼠标所在窗口句柄。

语法： 整数型 取鼠标所在窗口句柄 （）

例程

说明

取出鼠标所在窗口的窗口句柄。失败返回空。

参考：例程


杂项

杂项 类别 跳至：应用接口支持库


接口常量

接口常量 枚举常量集合类型 操作系统支持：Windows 跳至：应用接口支持库

提供应用接口支持库中所要使用的常量枚举值。

成员 | 描 述
控制面板 | 常量值为 0 。
系统属性 | 常量值为 1 。
显示属性 | 常量值为 2 。
辅助功能选项 | 常量值为 3 。
添加打印机向导 | 常量值为 4 。
添加或删除程序 | 常量值为 5 。
日期和时间属性 | 常量值为 6 。
字体文件夹 | 常量值为 7 。
游戏控制器 | 常量值为 8 。
鼠标属性 | 常量值为 9 。
键盘属性 | 常量值为 10 。
声音和音频属性 | 常量值为 11 。
ODBC数据源管理器 | 常量值为 12 。
电源选项属性 | 常量值为 13 。
区域和语言选项 | 常量值为 14 。
互联网属性 | 常量值为 15 。
用户帐号 | 常量值为 16 。
系统信息对话框 | 常量值为 17 。
左键单击 | 常量值为 0 。
左键双击 | 常量值为 1 。
右键单击 | 常量值为 2 。
右键双击 | 常量值为 3 。
总物理内存 | 常量值为 0 。
可用物理内存 | 常量值为 1 。
总虚拟内存 | 常量值为 2 。
可用虚拟内存 | 常量值为 3 。
总页面文件 | 常量值为 4 。
可用页面文件 | 常量值为 5 。
居中 | 常量值为 0 。
平铺 | 常量值为 1 。
拉伸 | 常量值为 2 。
所有驱动器 | 常量值为 0 。
硬盘驱动器 | 常量值为 1 。
光盘驱动器 | 常量值为 2 。
可移动驱动器 | 常量值为 3 。
系统临时文件 | 常量值为 0 。
IE临时文件 | 常量值为 1 。
回收站 | 常量值为 2 。
存根文件 | 常量值为 3 。
浏览器历史地址记录 | 常量值为 0 。
表单自动完成历史记录 | 常量值为 1 。
自动密码历史记录 | 常量值为 2 。
收藏夹 | 常量值为 3 。
自动拨号历史记录 | 常量值为 4 。
运行中的自动匹配历史记录 | 常量值为 5 。
打开文档历史记录 | 常量值为 6 。
网络连接历史记录 | 常量值为 7 。
远程登录历史记录 | 常量值为 8 。
浏览网址历史记录 | 常量值为 9 。
数字锁定键盘灯 | 常量值为 0 。
大小写锁定键盘灯 | 常量值为 1 。
滚动锁定键盘灯 | 常量值为 2 。
像素 | 常量值为 0 。
英寸 | 常量值为 1 。
毫米 | 常量值为 2 。
厘米 | 常量值为 3 。
到文件 | 常量值为 0 。
到剪贴板 | 常量值为 1 。
到字节集 | 常量值为 2 。
磁盘0 | 常量值为 0 。
磁盘1 | 常量值为 1 。
磁盘2 | 常量值为 2 。
磁盘3 | 常量值为 3 。
开始菜单 | 常量值为 0 。
开始菜单程序 | 常量值为 1 。
桌面 | 常量值为 2 。
到注册表 | 常量值为 0 。
到启动组 | 常量值为 1 。
计算机 | 常量值为 0 。
工作组 | 常量值为 1 。
广播 | 常量值为 2 。
所有共享资源 | 常量值为 0 。
共享目录或文件 | 常量值为 1 。
共享打印机 | 常量值为 2 。
网络驱动器 | 常量值为 4 。
标准打印设置对话框 | 常量值为 0。
打印对话框 | 常量值为 1。
打印属性对话框 | 常量值为 2。

参见：基本数据类型


矩形数据

矩形数据 普通类型 操作系统支持：Windows 跳至：应用接口支持库

成员 | 描 述
左边 | 整数型；初始值为 0 。
顶边 | 整数型；初始值为 0 。
右边 | 整数型；初始值为 0 。
底边 | 整数型；初始值为 0 。

参见： 基本数据类型


CPU信息

CPU信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

CPU详细信息。

成员 | 描 述
制造商 | 文本型；初始值为“”。
名称 | 文本型；初始值为“”。
时钟频率 | 整数型；初始值为 0 。单位：MHz。
描述 | 文本型；初始值为“”。
一级缓存大小 | 整数型；初始值为 0 。单位：KB。
二级缓存大小 | 整数型；初始值为 0 。单位：KB。
序列号 | 文本型；初始值为“”。
数据宽度 | 整数型；初始值为 0 。单位：位。

参见： 基本数据类型


系统信息

系统信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

System详细信息。

成员 | 描 述
操作系统 | 文本型；初始值为“”。
版本 | 文本型；初始值为“”。
建立号码 | 整数型；初始值为 0 。
最后服务包 | 文本型；初始值为“”。
当前用户 | 文本型；初始值为“”。
系统安装目录 | 文本型；初始值为“”。
系统目录 | 文本型；初始值为“”。
代码 | 整数型；初始值为 0 。
本地语言 | 文本型；初始值为“”。
国家代码 | 整数型；初始值为 0 。
国家 | 文本型；初始值为“”。
货币符号 | 文本型；初始值为“”。
日期格式 | 文本型；初始值为“”。
时间格式 | 文本型；初始值为“”。
时区 | 文本型；初始值为“”。

参见： 基本数据类型


文件版本信息

文件版本信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

文件版本详细信息。

成员 | 描 述
文件版本 | 文本型；初始值为“”。
文件描述 | 文本型；初始值为“”。
内部名称 | 文本型；初始值为“”。
公司名称 | 文本型；初始值为“”。
合法版权 | 文本型；初始值为“”。
合法商标 | 文本型；初始值为“”。
源文件名 | 文本型；初始值为“”。
产品名称 | 文本型；初始值为“”。
产品版本 | 文本型；初始值为“”。
语言 | 文本型；初始值为“”。
备注 | 文本型；初始值为“”。

参见： 基本数据类型


BIOS信息

BIOS信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

BIOS详细信息。

成员 | 描 述
名称 | 文本型；初始值为“”。
制造商 | 文本型；初始值为“”。
版权信息 | 文本型；初始值为“”。
日期 | 文本型；初始值为“”。
序列号 | 文本型；初始值为“”。
OEM信息 | 文本型；初始值为“”。

参见： 基本数据类型


硬盘信息

硬盘信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

硬盘详细信息。

成员 | 描 述
型号 | 文本型；初始值为“”。
版本号 | 文本型；初始值为“”。
序列号 | 文本型；初始值为“”。
容量 | 整数型；初始值为 0 。单位: MB。
缓存大小 | 整数型；初始值为 0 。单位: MB。
每磁道扇区数 | 整数型；初始值为 0 。
磁头数 | 整数型；初始值为 0 。
柱面数 | 整数型；初始值为 0 。

参见： 基本数据类型


网卡信息

网卡信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

网卡详细信息。

成员 | 描 述
网卡名称 | 文本型；初始值为“”。
序号 | 整数型；初始值为 0 。
物理地址 | 文本型；初始值为“”。
IP地址 | 文本型；初始值为“”。
子网掩码 | 文本型；初始值为“”。
默认网关 | 文本型；初始值为“”。
Wins服务器地址 | 文本型；初始值为“”。
DHCP服务器地址 | 文本型；初始值为“”。

参见： 基本数据类型


进程信息

进程信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

进程详细信息。

成员 | 描 述
进程标识符 | 整数型；初始值为 0 。
进程名称 | 文本型；初始值为“”。
进程模块标识符 | 整数型；初始值为 0 。
父进程标识符 | 整数型；初始值为 0 。
线程优先权 | 整数型；初始值为 0 。
线程数 | 整数型；初始值为 0 。

参见： 基本数据类型


显示模式信息

显示模式信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

显示模式详细信息。

成员 | 描 述
宽度 | 整数型；初始值为 0 。
高度 | 整数型；初始值为 0 。
颜色位数 | 整数型；初始值为 0 。
刷新频率 | 整数型；初始值为 0 。

参见： 基本数据类型


打印信息

打印信息 普通类型 操作系统支持：Windows 跳至：应用接口支持库

打印详细信息。

成员 | 描 述
打印机名称 | 文本型； 初始值为“”。打印设备的名称。
纸张方向 | 整数型； 初始值为 0 。指定打印纸的放置方向。可以为以下常量值之一： 1、#纵向； 2、#横向。如省略本参数，默认为“#纵向”。
纸张类型 | 整数型； 初始值为 9 。指定所使用的打印纸类型。可以为以下常量值之一：-1、自定义纸张（必须在后面参数中指定自定义纸张的大小）； 0、#默认纸； 1、#A3纸(297x420毫米)； 2、#A4纸(210x297毫米)； 3、#A5纸(148x210毫米)； 4、#B4纸(250x354毫米)； 5、#B5纸(182x257毫米)； 6、#四开(215x275毫米)； 7、#十六开(146x215毫米)； 8、#三十二开(97x151毫米)； 9、#信纸(216x279毫米)； 10、#法律用纸(216x355毫米)； 11、#行政用纸(184x266毫米)； 12、#声明(140x216毫米)； 13、#小报(279x432毫米)； 14、#笔记(216x279毫米)； 15、#帐本(432x279毫米)； 16、#对开纸(216x330毫米)。
纸张宽度 | 整数型； 初始值为 0 。指定自定义纸张的宽度，单位为0.1毫米。只有当前面的“纸张”参数给定值为-1时，本参数才有作用且必须提供具体值。
纸张高度 | 整数型； 初始值为 0 。指定自定义纸张的高度，单位为0.1毫米。只有当前面的“纸张”参数给定值为-1时，本参数才有作用且必须提供具体值。
打印份数 | 整数型； 初始值为 1 。指定打印的份数。


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。