压缩解压支持库

压缩解压支持库 帮助手册20080819版 返回支持库手册 返回首页

本库用来压缩/解压缩文件，目前支持.zip格式。本库可以解压缩用WINZIP或者WINRAR等压缩软件生成的.zip文件,同时用本库压缩的.zip文件也可以被其他压缩软件使用!如果您在使用本库中出现错误或者异常,请您将出错时候的相关文件和出错描述等信息,通过电子邮件或者其他方式发给我公司,谢谢您的使用！。

操作系统支持： Windows

窗口组件数据类型：

ZIP压缩

常量表...

例程名称 | 下载 | 说明
压缩解压例程 | 文件解压缩.e | 本程序演示了ZIP压缩解压支持库的使用方法。

适用版本，压缩解压支持库 （1.1#0版）


ZIP压缩

ZIP压缩 功能型窗口组件 操作系统支持：Windows

跳至：压缩解压支持库本数据类型支持ZIP格式的文件压缩/解压缩。

方法：

压缩 字节集压缩 解压 取进度提示

自有事件：


压缩 方法 操作系统支持：Windows 所属对象：ZIP压缩

将任意一个文件或者文件夹压缩到ZIP文件。返回1为成功，0为失败，-1为参数错误。

语法： 整数型 ZIP 压缩．压缩 （源文件夹或文件名，ZIP文件名）

参数名 | 描 述
源文件夹或文件名 | 必需的；文本型。本参数指定欲压缩文件夹或文件的名称，如果不存在将出错。
ZIP文件名 | 必需的；文本型。本参数指定要压缩到的ZIP文件名。

例程

说明

将一个文件或一个文件夹压缩为ZIP格式，源文件名和目标文件名都要提供全路径文件名。

参考：例程1


字节集压缩 方法 操作系统支持：Windows 所属对象：ZIP压缩

将字节集压缩到ZIP文件。返回1为成功，0为失败，-1为参数错误。

语法： 整数型 ZIP 压缩．字节集压缩 （字节集，ZIP文件名，压缩包内文件名）

参数名 | 描 述
字节集 | 必需的；字节集。本参数提供需要压缩的数据。
ZIP文件名 | 必需的；文本型。本参数指定要压缩到的ZIP文件名。
压缩包内文件名 | 必需的；文本型。本参数提供被压缩数据在 ZIP 压缩包文件内的记录文件名。

例程

说明

将图片框中图片（字节集数据）压缩为ZIP格式。


解压 方法 操作系统支持：Windows 所属对象：ZIP压缩

将ZIP文件解压缩到一个文件夹中。返回1为成功，0为失败，-1为参数错误。

语法： 整数型 ZIP 压缩．解压 （ZIP文件名，文件夹名）

参数名 | 描 述
ZIP文件名 | 必需的；文本型。本参数提供欲解压缩的ZIP文件名，如果该文件不存在将出错。
文件夹名 | 必需的；文本型。本参数提供欲将ZIP压缩包内文件解压缩到的文件夹名称。

例程

说明

将指定的ZIP压缩格式的文件解压。


取进度提示 方法 操作系统支持：Windows 所属对象：ZIP压缩

当压缩进度或解压缩进度事件被触发的时候，可以使用这个方法获得压缩/解压缩过程中的文字提示信息。

语法： 文本型 ZIP 压缩．取进度提示 （）

例程

说明

取出压缩时或解压缩时所操作进度。本命令只有写在压缩进度和解压缩进度事件内才有效。


压缩进度 事件 所属对象：ZIP压缩 操作系统支持：Windows

本事件用作提供当前压缩的进度值，如果想获取文字信息请调用“取进度提示”命令。用户事件处理子程序如果返回“假”，则中止压缩工作，返回“真”或不返回值继续压缩。

语法： 逻辑型 _ZIP 压缩_压缩进度 （已完成百分比）

参数名 | 描 述
已完成百分比 | 整数型；当前已完成压缩工作的百分比。

例程

说明

当此事件的拥有者调用“压缩”命令时触发此事件。

注：当使用“压缩”命令压缩单个文件或压缩一个没有文件的文件夹时不会触发此事件。


解压缩进度 事件 所属对象：ZIP压缩 操作系统支持：Windows

本事件用作提供当前解压缩的进度值，如果想获取文字信息请调用“取进度提示”命令。用户事件处理子程序如果返回“假”，则中止解压缩工作，返回“真”或不返回值继续解压缩。

语法： 逻辑型 _ZIP 压缩_解压缩进度 （已完成百分比）

参数名 | 描 述
已完成百分比 | 整数型；当前已完成解压缩工作的百分比。

例程

说明

调用“解压”命令后将触发此事件。


常量 | 常量值 | 描 述
#压缩成功 | 1 |
#压缩失败 | 0 |
#压缩参数错误 | -1 |
#解压缩成功 | 1 |
#解压缩失败 | 0 |
#解压缩参数错误 | -1 |