多媒体支持库

多媒体支持库 帮助手册20080811版 返回支持库手册 返回首页

操作系统支持： Windows

窗口组件数据类型：

系统音量 | 录音 | MIDI演奏 | 录音音波
CD播放 | 媒体播放 | 音频转换 |

其它数据类型：

音量类型

例程列表：

例程名称 | 下载 | 说明
MIDI制作 | Midi制作.e | 实现了MIDI乐谱的制作和演奏
录音 | 录音.e | 实现了对声音的录制.
媒体播放器 | 媒体播放器.e | 实现了对媒体音乐的播放功能。
音量控制 | 音量控制.E | 本程序可以调整计算机或多媒体应用程序（例如 CD 唱机、DVD 播放机和录音机）播放的声音。

适用版本，多媒体支持库 （2.4#8版）


系统音量

系统音量 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供对控制Windows系统音量的支持。

方法：

打开 | 是否打开 | 关闭 | 取静音
置静音 | 取最大音量 | 取最小音量 | 取音量
置音量 | 取设备号 | 取设备名 |

自有事件：

音量改变

静音改变


打开 方法 操作系统支持：Windows 所属对象：系统音量

同时打开系统的一个音量类型的音量控制和静音控制，返回值为下列之一：1、#全部打开成功；0、全部打开失败；-1、音量控制打开失败；-2、#静音打开失败。

语法： 整数型 系统音量．打开 （设备标识）

参数名 | 描 述
设备标识 | 必需的；整数型。该参数必须提供合法的设备标识，标识只能为本支持库的"音量类型"下的常量之一。

例程

说明

主音量常量值为 4 。波形常量值为 4104 。麦克常量值为 4099 。CD常量值为 4101 。电话线常量值为 4102 。线路输入常量值为 4098 。软件合成器常量值为 4100 。其他相关常量可以在MSDN中查到。

参考：例程1


是否打开 方法 操作系统支持：Windows 所属对象：系统音量

判断音量控制或静音控制是否打开，如打开返回真,否则返回假。

语法： 逻辑型 系统音量．是否打开 （类型）

参数名 | 描 述
类型 | 必需的；整数型，初始值为“2”。0、#音量；1、#静音； 其他值、#全部。

例程

说明

判断当前控制音量及静音是否打开，如果没有打开将不能操作。


关闭 方法 操作系统支持：Windows 所属对象：系统音量

关闭音量控制或静音控制。

语法： 逻辑型 系统音量．关闭 （类型）

参数名 | 描 述
类型 | 必需的；整数型，初始值为“2”。0、#音量；1、#静音； 其他值、#全部。

例程

说明

关闭与当前控制的音量及静音的连接。


取静音 方法 操作系统支持：Windows 所属对象：系统音量

如果当前处于静音状态返回真，否则返回假。

语法： 逻辑型 系统音量．取静音 （）

例程

说明

取得当前控制的声音类型是否为静音。


置静音 方法 操作系统支持：Windows 所属对象：系统音量

设置是否静音。

语法： 逻辑型 系统音量．置静音 （静音）

参数名 | 描 述
静音 | 必需的；逻辑型。该参数设定是否静音。

例程

说明

设置当前控制的声音设备的静音。


取最大音量 方法 操作系统支持：Windows 所属对象：系统音量

获取当前音量控制可能被调整到的最大值。

语法： 整数型 系统音量．取最大音量 （）

例程

说明

取得当前控制的音频设备的最大支持音量。


取最小音量 方法 操作系统支持：Windows 所属对象：系统音量

获取当前音量控制可能被调整到的最小值。

语法： 整数型 系统音量．取最小音量 （）

例程

说明

取得当前音频设备的最小音量。


取音量 方法 操作系统支持：Windows 所属对象：系统音量

获取左声道和右声道的音量，成功返回真，失败返回假。

语法： 逻辑型 系统音量．取音量 （左声道音量，右声道音量）

参数名 | 描 述
左声道音量 | 必需的；整数型，参数数据只能提供变量。该参数接收左声道的音量。
右声道音量 | 必需的；整数型，参数数据只能提供变量。该参数接收右声道的音量。

例程

说明

取得当前音频设备的音量，如果某些设备如麦克风等只支持单声道，那么返回值中其中的一个变量将永远是0。


置音量 方法 操作系统支持：Windows 所属对象：系统音量

设置左声道和右声道的音量。

语法： 逻辑型 系统音量．置音量 （左声道音量，右声道音量）

参数名 | 描 述
左声道音量 | 必需的；整数型。要设置的左声道的音量。
右声道音量 | 必需的；整数型。要设置的右声道的音量。

例程

说明

设置当前音频设备的音量，如果该设备如麦克风等只支持单声道，那么其中一个参数设置将无效。


取设备号 方法 操作系统支持：Windows 所属对象：系统音量

获取音量控制或静音控制的标识号。

语法： 整数型 系统音量．取设备号 （设备标识）

参数名 | 描 述
设备标识 | 必需的；整数型，初始值为“0”。0表示音量，非0表示静音。

例程

说明

取得指定设备的设备号。


取设备名 方法 操作系统支持：Windows 所属对象：系统音量

获取设备的名称。

语法： 文本型 系统音量．取设备名 （设备标识）

参数名 | 描 述
设备标识 | 必需的；整数型，初始值为“0”。0表示音量，非0表示静音。

例程

说明

取得指定设备的设备名。


音量改变 事件 所属对象：系统音量 操作系统支持：Windows

当前对象所控制的音量被改变后触发此事件。

语法： 无返回值 _系统音量_音量改变 （）

例程

说明

当前所操作的音频设备音量被改变时，将触发此事件。


静音改变 事件 所属对象：系统音量 操作系统支持：Windows

当前对象所控制的静音被改变后触发此事件。

语法： 无返回值 _系统音量_静音改变 （）

例程

说明

当前音频设备的静音状态被改变时，将触发此事件。


录音

录音 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供对Wave格式录音的支持。

方法：

录制 | 是否在录制 | 暂停 | 继续
停止 | 置格式 | 取格式 | 保存文件
取位置 |  |  |


录制 方法 操作系统支持：Windows 所属对象：录音

开始录制。

语法： 逻辑型 录音．录制 （）

例程

说明

开始进行录音，一般用于录音的设备为麦克风。


是否在录制 方法 操作系统支持：Windows 所属对象：录音

判断是否正在录制。

语法： 逻辑型 录音．是否在录制 （）

例程

说明

判断当前是否正在录音。


暂停 方法 操作系统支持：Windows 所属对象：录音

暂停录制。

语法： 逻辑型 录音．暂停 （）

例程

说明

暂停正在进行的录音。


继续 方法 操作系统支持：Windows 所属对象：录音

恢复一个被暂停的录制。

语法： 逻辑型 录音．继续 （）

例程

说明

恢复有暂停命令停止的录音。


停止 方法 操作系统支持：Windows 所属对象：录音

停止录制。

语法： 逻辑型 录音．停止 （）

例程

说明

停止录音。停止的录音将不能继续。


置格式 (录音)

置格式 方法 操作系统支持：Windows 所属对象：录音

设置录音的格式，注意参数的正确性，成功返回真，失败返回假。注意：本方法必须在使用"录音"方法前使用。

语法： 逻辑型 录音．置格式 （线路数，采样率，采样大小）

参数名 | 描 述
线路数 | 必需的；整数型，初始值为“1”。本参数为录音的线路数，为以下常量值之一：1、#单声道；2、立体声双声道。
采样率 | 必需的；整数型，初始值为“8000”。本参数为每秒采样率(hertz)，为以下常量值之一：8000、#8000HZ；11025、#11025HZ；22050、#22050HZ；44100、#44100HZ。
采样大小 | 必需的；整数型，初始值为“16”。本参数为采样大小，以字节为单位，为以下常量值之一：8、#8字节；16、#16字节。

例程

说明

设置录音格式。


取格式 (录音)

取格式 方法 操作系统支持：Windows 所属对象：录音

获取录音格式。

语法： 逻辑型 录音．取格式 （线路数，采样率，采样大小）

参数名 | 描 述
线路数 | 必需的；整数型，参数数据只能提供变量。本参数为录音的线路数，为以下常量值之一：1、#单声道；2、立体声双声道。
采样率 | 必需的；整数型，参数数据只能提供变量。本参数为每秒采样率(hertz)，为以下常量值之一：11025、#11025HZ；22050、#22050HZ；44100、#44100HZ。
采样大小 | 必需的；整数型，参数数据只能提供变量。本参数为采样大小，以字节为单位，为以下常量值之一：8、#8字节；16、#16字节。

例程

说明

取得录音的格式。


保存文件 方法 操作系统支持：Windows 所属对象：录音

以*.wav格式保存当前录制的声音到指定文件中，成功返回真，失败返回假。

语法： 逻辑型 录音．保存文件 （保存文件名，覆盖已有文件）

参数名 | 描 述
保存文件名 | 必需的；文本型。
覆盖已有文件 | 必需的；逻辑型，初始值为“真”。

例程

说明

保存录制的音频。格式为wav音频格式。


取位置 方法 操作系统支持：Windows 所属对象：录音

获取当前录制的采样(Sample)位置。

语法： 整数型 录音．取位置 （）

例程

说明

取得当前正在录音使用的时间，单位为1/8000 Sample=1秒


MIDI演奏

MIDI演奏 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供对MIDI演奏的基本支持。

方法：

取设备数量 | 取设备名 | 打开 | 是否打开
关闭 | 置乐器 | 取乐器 | 取乐器数量
取乐器名 | 奏 | 停奏 |


取设备数量 方法 操作系统支持：Windows 所属对象：MIDI演奏

获取当前可以使用MIDI设备的数量。

语法： 整数型 MIDI 演奏．取设备数量 （）

例程

说明

取得当前系统支持的MIDI设备数量。


取设备名 方法 操作系统支持：Windows 所属对象：MIDI演奏

获取指定MIDI设备的名称。

语法： 文本型 MIDI 演奏．取设备名 （设备序号）

参数名 | 描 述
设备序号 | 必需的；整数型。设备序号从0 ~ 最大设备数减1，最大设备数可以用"取设备数量"命令获取。

例程

说明

取得当前系统支持的MIDI设备名称。


打开 方法 操作系统支持：Windows 所属对象：MIDI演奏

通过MIDI设备序号打开指定的MIDI设备，成功返回真，失败返回假。

语法： 逻辑型 MIDI 演奏．打开 （设备序号）

参数名 | 描 述
设备序号 | 必需的；整数型。设备序号从0 ~ 最大设备数减1，最大设备数可以用"取设备数量"命令获取。

例程

说明

打开指定MIDI设备。序列号从0开始。


是否打开 方法 操作系统支持：Windows 所属对象：MIDI演奏

判断MIDI设备是否打开，如打开返回真，否则返回假。

语法： 逻辑型 MIDI 演奏．是否打开 （）

例程

说明

判断当前打开的设备是否打开成功。


关闭 方法 操作系统支持：Windows 所属对象：MIDI演奏

关闭当前MIDI设备，成功返回真，否则返回假。

语法： 逻辑型 MIDI 演奏．关闭 （）

例程

说明

关闭当前使用的MIDI设备。


置乐器 方法 操作系统支持：Windows 所属对象：MIDI演奏

以指定的乐器序号设置当前MIDI设置要演奏的乐器，成功返回真，失败返回假。

语法： 逻辑型 MIDI 演奏．置乐器 （乐器序号，［通道］）

参数名 | 描 述
乐器序号 | 必需的；整数型。乐器序号范围为1至最大支持乐器数，最大支持乐器数可以通过"取乐器数量"方法取得。
通道 | 可选的；整数型。该参数指定设置乐器序号的通道，从0 ~ 15。

例程

说明

设置当前演奏需要的乐器。


取乐器 方法 操作系统支持：Windows 所属对象：MIDI演奏

取乐器序号 方法 操作系统支持：Windows 所属对象：MIDI演奏

获取指定通道当前使用的乐器序号，乐器序号从1开始。

语法： 整数型 MIDI 演奏．取乐器序号 （［通道］）

参数名 | 描 述
通道 | 可选的；整数型。该参数指定乐器序号的通道，从0 ~ 15。

例程

说明

取得当前使用的乐器序号。


取乐器数量 方法 操作系统支持：Windows 所属对象：MIDI演奏

获取当前所有支持的乐器的数量。

语法： 整数型 MIDI 演奏．取乐器数量 （）

例程

说明

取得当前系统支持的乐器数量。


取乐器名 方法 操作系统支持：Windows 所属对象：MIDI演奏

通过指定乐器序号获取乐器名称。

语法： 文本型 MIDI 演奏．取乐器名 （乐器序号）

参数名 | 描 述
乐器序号 | 必需的；整数型。乐器序号范围为1 ~ 最大支持乐器数，最大支持乐器数可以通过"取乐器数量"方法取得。

例程

说明

取得当前系统支持的乐器的名称。


奏 方法 操作系统支持：Windows 所属对象：MIDI演奏

演奏一个音符。成功返回真，失败返回假。

语法： 逻辑型 MIDI 演奏．停奏 （音符，［通道］）

参数名 | 描 述
音符 | 必需的；字节型。该参数范围为0至127。0表示音C，1表示C#，依次类推，127表示第10个8度的127。
通道 | 可选的；整数型。该参数指定音符停止演奏的通道，从0 ~ 15。

例程

说明

使用指定音阶演奏一个音符。


停奏 方法 操作系统支持：Windows 所属对象：MIDI演奏

停止演奏一个音符。成功返回真，失败返回假。

语法： 逻辑型 MIDI 演奏．停奏 （音符，［通道］）

参数名 | 描 述
音符 | 必需的；字节型。该参数范围为0至127。0表示音C，1表示C#，依次类推，127表示第10个8度的127。
通道 | 可选的；整数型。该参数指定音符停止演奏的通道，从0 ~ 15。

例程

说明

停奏指定音阶。即使不使用停奏，音符也会自动结束，结束时间视不同设备而不同。


录音音波

录音音波 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供对获取录音音波的支持。

方法：

打开 | 是否打开 | 关闭 | 取上限
取声波值 |  |  |


打开 方法 操作系统支持：Windows 所属对象：录音音波

打开设备接收声波输入，成功返回真，失败返回假。

语法： 逻辑型 录音音波．打开 （）

例程

说明

打开设备，如果不打开将不能接收声波。由于98系统环境下MCI设备的问题，使用该组件可能会和其他设备产生冲突。


是否打开 方法 操作系统支持：Windows 所属对象：录音音波

判断设备是否打开，如打开返回真，否则返回假。

语法： 逻辑型 录音音波．是否打开 （）

例程

说明

判断录音音波是否打开。由于98系统环境下MCI设备的问题，使用该组件可能会和其他设备产生冲突。


关闭 方法 操作系统支持：Windows 所属对象：录音音波

关闭已打开设备，成功返回真，失败返回假。

语法： 逻辑型 录音音波．关闭 （）

例程

说明

关闭录音音波设备。由于98系统环境下MCI设备的问题，使用该组件可能会和其他设备产生冲突。


取上限 方法 操作系统支持：Windows 所属对象：录音音波

取可以接收的声波值的最大频段（也可以理解为数组上限）。

语法： 整数型 录音音波．取上限 （）

例程

说明

取可以接收的声波值的最大频段。由于98系统环境下MCI设备的问题，使用该组件可能会和其他设备产生冲突。


取声波值 方法 操作系统支持：Windows 所属对象：录音音波

获取指定频段的声波值。

语法： 逻辑型 录音音波．取声波值 （声波值，复制序号）

参数名 | 描 述
声波值 | 必需的；短整数型，参数数据只能提供变量。接收声波值的变量。
复制序号 | 必需的；整数型。要声波值的序号，序号的范围为0 ~ 最大频段减1，最大频段可以通过"取上限"方法获取。

例程

说明

获取指定频段的声波值。由于98系统环境下MCI设备的问题，使用该组件可能会和其他设备产生冲突。


CD播放

CD播放 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供对CD播放的支持。注意：本对象是架构在Windows MCI基础之上的，本对象提供了"取别名"方法，您可以通过该方法所得的文本，通过Windows API mciSendString等命令和本对象一起控制MCI播放。

方法：

打开 | 关闭 | 开仓门 | 关仓门
是否有CD | 取状态 | 播放 | 暂停
恢复 | 停止 | 跳到 | 取位置
取曲目数 | 取长度 | 取总长度 | 取起始时间
取别名 |  |  |


打开 方法 操作系统支持：Windows 所属对象：CD播放

打开指定的光驱。成功返回真，失败返回假。

语法： 逻辑型 CD 播放．打开 （光驱盘符）

参数名 | 描 述
光驱盘符 | 必需的；文本型。该参数指定要控制的光驱的盘符，必须为如下格式: "H:\"，以下格式是非法的： "H", "H:"。

例程

说明

打开指定光驱设备，如果给参数给“”表示打开默认光驱。


关闭 方法 操作系统支持：Windows 所属对象：CD播放

关闭光驱。

语法： 逻辑型 CD 播放．关闭 （）

例程

说明

关闭与指定光驱的连接。


开仓门 方法 操作系统支持：Windows 所属对象：CD播放

打开光驱仓门。成功返回真，失败返回假。

语法： 逻辑型 CD 播放．开仓门 （）

例程

说明

弹出连接光驱的仓门。


关仓门 方法 操作系统支持：Windows 所属对象：CD播放

关闭光驱仓门。成功返回真，失败返回假。

语法： 逻辑型 CD 播放．关仓门 （）

例程

说明

关闭连接光驱的仓门。


是否有CD 方法 操作系统支持：Windows 所属对象：CD播放

判断当前光驱中是否有光盘，如果有返回真，否则返回假。

语法： 逻辑型 CD 播放．是否有CD （）

例程

说明

判断光驱中是否有光盘。


取状态 方法 操作系统支持：Windows 所属对象：CD播放

返回当前光驱的状态，为以下常量值之一：0、#未知状态；1、#播放状态；2、#停止状态；3、#弹出状态。

语法： 整数型 CD 播放．取状态 （）

例程

说明

取得当前光驱的状态。


播放 方法 操作系统支持：Windows 所属对象：CD播放

开始播放，成功返回真，失败返回假。

语法： 逻辑型 CD 播放．播放 （）

例程

说明

播放CD。


暂停 方法 操作系统支持：Windows 所属对象：CD播放

暂停播放，成功返回真，失败返回假。

语法： 逻辑型 CD 播放．暂停 （）

例程

说明

暂停播放。


恢复 方法 操作系统支持：Windows 所属对象：CD播放

恢复播放，成功返回真，失败返回假。

语法： 逻辑型 CD 播放．恢复 （）

例程

说明

恢复播放状态。


停止 方法 操作系统支持：Windows 所属对象：CD播放

停止播放，成功返回真，失败返回假。

语法： 逻辑型 CD 播放．停止 （）

例程

说明

停止播放，停止的播放不能恢复。


跳到 方法 操作系统支持：Windows 所属对象：CD播放

跳到指定曲目的指定位置。成功返回真，失败返回假。

语法： 逻辑型 CD 播放．跳到 （曲目号）

参数名 | 描 述
曲目号 | 必需的；整数型。该参数为要转到的曲目号。

例程

说明

跳到指定曲目。


取位置 方法 操作系统支持：Windows 所属对象：CD播放

获取当前的播放位置，成功返回真，失败返回假。

语法： 逻辑型 CD 播放．取位置 （曲目号，位置）

参数名 | 描 述
曲目号 | 必需的；整数型，参数数据只能提供变量。该参数接收曲目号。
位置 | 必需的；整数型，参数数据只能提供变量。该参数为当前播放在相应曲目中的位置，以毫秒为单位。

例程

说明

取得当前播放位置。


取曲目数 方法 操作系统支持：Windows 所属对象：CD播放

获取当前CD光盘中的曲目数量。

语法： 整数型 CD 播放．取曲目数 （）

例程

说明

取得当前光盘的曲目数量。


取长度 方法 操作系统支持：Windows 所属对象：CD播放

获取指定曲目的时间长度，以毫秒为单位。

语法： 整数型 CD 播放．取长度 （曲目号）

参数名 | 描 述
曲目号 | 必需的；整数型。该参数为要取长度的曲目号。

例程

说明

取得当前曲目的长度。


取总长度 方法 操作系统支持：Windows 所属对象：CD播放

获取全部曲目的时间长度的总和，以毫秒为单位。

语法： 整数型 CD 播放．取总长度 （）

例程

说明

取得指定光盘的总长度。


取起始时间 方法 操作系统支持：Windows 所属对象：CD播放

获取指定曲目的起始时间。

语法： 整数型 CD 播放．取起始时间 （曲目号）

参数名 | 描 述
曲目号 | 必需的；整数型，初始值为“-1”。该参数为曲目的序号。

例程

说明

取得当前曲目的起始时间。


取别名 方法 操作系统支持：Windows 所属对象：CD播放

获取当前对象使用的MCI控制别名。

语法： 文本型 CD 播放．取别名 （）

例程

说明

取得当前使用MCI控件的别名。


媒体播放

媒体播放 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供对媒体播放的支持，注意：本对象是架构在Windows MCI基础之上的，本对象提供了"取别名"方法，您可以通过该方法所得的文本，通过Windows API mciSendString等命令和本对象一起控制MCI播放。如果有媒体文件不能播放，请安装相应解码器。

方法：

打开 | 是否视频 | 取句柄 | 置句柄
取状态 | 取长度 | 取位置 | 取总时间
取比率 | 播放 | 暂停 | 停止
取别名 | 关闭 |  |


打开 方法 操作系统支持：Windows 所属对象：媒体播放

打开指定媒体文件。成功返回真，失败返回假。

语法： 逻辑型 媒体播放．打开 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。该参数为要打开的媒体文件名。

例程

说明

打开指定媒体格式包括wav,mid,avi,mpg,mp3,wmv等。


是否视频 (媒体播放)

是否视频 方法 操作系统支持：Windows 所属对象：媒体播放

判断当前播放的内容是否是视频。如果是返回真，否则返回假。

语法： 逻辑型 媒体播放．是否视频 （）

例程

说明

判断当前打开的文件是否为视频文件。


取句柄 方法 操作系统支持：Windows 所属对象：媒体播放

获取当前视频播放窗口的Windows 窗口句柄。

语法： 整数型 媒体播放．取句柄 （）

例程

说明

获得当前播放窗口的句柄。


置句柄 方法 操作系统支持：Windows 所属对象：媒体播放

设置当前视频播放窗口的Windows 窗口句柄成功返回真，失败返回假。

语法： 逻辑型 媒体播放．置句柄 （窗口句柄）

参数名 | 描 述
窗口句柄 | 必需的；整数型。要设置的窗口句柄。

例程

说明

设置当前播放文件的窗口句柄，随着句柄改变当前文件的播放窗口也跟着改变。


取状态 方法 操作系统支持：Windows 所属对象：媒体播放

获取当前的播放状态，为以下常量值之一：0、#未知状态；1、#播放状态；2、#停止状态；3、#暂停状态。

语法： 整数型 媒体播放．取状态 （）

例程

说明

取得当前播放文件的状态。


取长度 方法 操作系统支持：Windows 所属对象：媒体播放

获取当前媒体文件的长度。

语法： 整数型 媒体播放．取长度 （）

例程

说明

取得当前播放文件长度。


取位置 方法 操作系统支持：Windows 所属对象：媒体播放

获取当前的播放位置。

语法： 整数型 媒体播放．取位置 （）

例程

说明

取得当前播放的位置。


取总时间 方法 操作系统支持：Windows 所属对象：媒体播放

以秒为单位获取总播放时间。

语法： 整数型 媒体播放．取总时间 （）

例程

说明

获取当前播放文件的总时间。


取比率 方法 操作系统支持：Windows 所属对象：媒体播放

获取每一帧的比率。

语法： 整数型 媒体播放．取比率 （）

例程

说明

获得当前播放文件每一帧的比率。


播放 方法 操作系统支持：Windows 所属对象：媒体播放

从指定位置开始播放。成功返回真，失败返回假。

语法： 逻辑型 媒体播放．播放 （播放位置）

参数名 | 描 述
播放位置 | 必需的；整数型，初始值为“-1”。该参数为播放位置，以毫秒为单位。默认为-1，表示从当前处播放。

例程

说明

播放当前打开的媒体文件，可以指定位置。


暂停 方法 操作系统支持：Windows 所属对象：媒体播放

暂停播放。成功返回真，失败返回假。

语法： 逻辑型 媒体播放．暂停 （）

例程

说明

暂停当前播放的媒体文件。


停止 方法 操作系统支持：Windows 所属对象：媒体播放

停止播放。成功返回真，失败返回假。

语法： 逻辑型 媒体播放．停止 （）

例程

说明

停止当前播放的媒体文件，停止后不能恢复。


取别名 方法 操作系统支持：Windows 所属对象：媒体播放

获取当前对象使用的MCI别名。

语法： 文本型 媒体播放．取别名 （）

例程

说明

获得当前使用MCI的别名。


关闭 (媒体播放)

关闭 方法 操作系统支持：Windows 所属对象：媒体播放

关闭当前播放的媒体。成功返回真，失败返回假。

语法： 逻辑型 媒体播放．关闭 （）

例程

说明

关闭当前播放的媒体。成功返回真，失败返回假。

参考： 例程1


音频转换

音频转换 功能型窗口组件 操作系统支持：Windows 跳至：多媒体支持库

本对象提供了对音频格式转换的支持。目前支持wav到mp3，mp3到wav以及wav到其他支持格式的转换。部分功能需要DirectX支持，转换的成功与否依赖于您Windows系统中关于音频的编码器和解码器。

方法：

初始化 | 取编码器数 | 取编码器名 | 取当前编码器
置当前编码器 | 取编码数 | 取编码信息 | 转换


初始化 方法 操作系统支持：Windows 所属对象：音频转换

初始化音频转换。成功返回真，失败返回假。在使用本对象前，必须保证成功调用过本方法。

语法： 逻辑型 音频转换．初始化 （）

例程：

说明：

通过“初始化”命令，初始化音频转换。

参见：例程1


取编码器数 方法 操作系统支持：Windows 所属对象：音频转换

获取当前可用的编码器的数量；失败返回0。

语法： 整数型 音频转换．取编码器数（）

例程：

说明：

通过“取编码器数”获取可用编码数目。

参见：例程1


取编码器名 方法 操作系统支持：Windows 所属对象：音频转换

获取指定编码器索引对应的编码器名称；失败返回空文本。

语法： 文本型 音频转换．取编码器名 （编码器索引）

参数名 | 描 述
编码器索引 | 必需的；整数型。编码器索引从0 ~ 编码器数量 -1。

例程：

说明：

通过“取编码器名”获取指定编码器索引对应的编码器名称。

参见：例程1


取当前编码器 方法 操作系统支持：Windows 所属对象：音频转换

获取当前使用的编码器的名称。

语法： 文本型 音频转换．取当前编码器 （）

例程：

说明：

通过“取当前编码器”获取当前使用的编码器的名称。

参见：例程1


置当前编码器 方法 操作系统支持：Windows 所属对象：音频转换

设置当前使用的编码器的名称。

语法： 逻辑型 音频转换．置当前编码器 （编码器名称）

参数名 | 描 述
编码器名称 | 必需的；文本型。编码器的名称。

例程：

说明：

成功返回真，失败返回假。

参见：例程1


取编码数 方法 操作系统支持：Windows 所属对象：音频转换

获取当前编码器可用的编码格式数量。

语法： 整数型 音频转换．取编码数 （）

例程：

说明：

通过“取编码数”获取当前编码器可用的编码格式数量。

参见：例程1


取编码信息 方法 操作系统支持：Windows 所属对象：音频转换

根据当前编码器的指定编码格式索引获取编码格式的相关信息。

语法： 逻辑型 音频转换．取编码信息 （编码索引， 是否为单声道，采样频率， 音频大小）

参数名 | 描 述
编码索引 | 必需的；整数型，编码格式的索引，从0 ~ 编码数量 - 1。
是否为单声道 | 必需的；逻辑型，提供参数数据时只能提供变量。判断是否为单声道，如不是则是双声道。
采样频率 | 必需的；逻辑型，提供参数数据时只能提供变量。每秒的采样频率，以kHz为单位。
音频大小 | 必需的；整数型，提供参数数据时只能提供变量。每秒音频的大小，以kbps为单位。

例程：

说明：

通过“取编码信息”获取编码格式的相关信息。

参见：例程1


转换 方法 操作系统支持：Windows 所属对象：音频转换

转换音频文件。成功返回真，失败返回假。

语法： 逻辑型 音频转换．转换（源文件名， 目标文件名， 编码索引）

参数名 | 描 述
源文件名 | 必需的； 文本型。要转换的源文件文件名。
目标文件名 | 必需的； 文本型。要转换的目的文件文件名，先前的文件将被复写。
编码索引 | 必需的； 整数型。编码格式的索引，从0 ~ 编码数量 - 1。

例程：

说明：

通过“转换”命令将音频文件进行转换。

参见：例程1


音量类型

音量类型 枚举常量集合类型 操作系统支持：Windows 跳至：多媒体支持库

成员 | 描 述
主音量 | 常量值为 4 。
波形 | 常量值为 4104 。
麦克 | 常量值为 4099 。
CD | 常量值为 4101 。
电话线 | 常量值为 4102 。
线路输入 | 常量值为 4098 。
软件合成器 | 常量值为 4100 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。