网络拦截支持库

网络拦截支持库 帮助手册20080818版 返回支持库手册 返回首页

本支持库在Win9x/ME/NT/2000/XP环境下实现了对WinSock2的函数拦截（包括如下函数：socket/closesocket/bind/listen/connect/accept/send/sendto/recv/recvfrom）。

系统中任何程序使用WinSock2的函数都会被本支持库所拦截，并使用易语言事件触发的方式处理，您可以在被触发的事件中按照相应事件的规则自由的处理其他程序的WinSock调用。如果您对WinSock或Windows网络编程不是很了解，建议您在使用本支持库前阅读WinSock等其他相关文档或教程。

注意：在使用本支持库前，您必须先正确安装网络服务提供者(ESPINN.dll(NN为当前版本))文件。网络服务提供者(ESPINN.dll(NN为当前版本))文件必须是随本支持库一起附带的网络服务提供者(ESPINN.dll(NN为当前版本))，否则安装将失败。当前本支持库对应的网络服务提供者版本是1.1。

安装方法：使用"网络服务安装"中的"安装"命令(注意该命令的参数一定要填写正确)。

卸载方法：首先您必须确定系统中和本支持库类似的拦截/过滤软件已正确卸载或没有卸载，否则请千万不要使用卸载方法！使用"网络服务安装"中的"卸载"命令，如果本方法没有执行成功，请千万不要删除已成功安装到系统路径下的网络服务提供者(ESPINN.dll(NN为当前版本))文件，原因请见下列警告。 [ 警告 ]如果网络服务提供者(ESPINN.dll(NN为当前版本))已经安装成功，并且"卸载"命令没有成功执行,(注意：只有"卸载"命令返回"真"才代表真正成功卸载了)，或根本没有使用"卸载"命令，系统路径下的网络服务提供者(ESPINN.dll(NN为当前版本))文件不可以改名、删除或移动路径，否则很有可能导致整个系统的WinSock瘫痪。如果上述情况真的发生了也不要紧，您可以将随本支持库附带的网络服务提供者(ESPINN.dll(NN为当前版本))文件再次复制到系统路径中(推荐使用此方法，因为后面的方法在某些特定情况下可能不保险)，或者直接执行"卸载"命令，并确定该命令是执行成功了。

操作系统支持： Windows

窗口组件数据类型：

网截

其它数据类型：

调用者信息 | 网址信息 | 网络数据 | 网络服务安装
拦截操作 |  |  |

适用版本，网络拦截支持库 （1.1#6版）


网截

网截 功能型窗口组件 操作系统支持：Windows 跳至：网络拦截支持库

该类型用来拦截WinSock2的socket/closesocket/bind/listen/accept/connect/send/send/recv/recvfrom函数。

方法：

打开 关闭 取版本

自有事件：


打开 命令 操作系统支持：Windows 所属类别：网截

打开 方法 操作系统支持：Windows 所属对象：网截

开始网络拦截。注意：在执行本命令前，您必须保证已经正确安装了随本支持库提供的网络服务提供者ESPI.dll文件到系统路径下。成功返回真，失败返回假，失败可由以下原因引起：1，网络服务提供者ESPI.dll没有安装；2，网络服务提供者已安装，但ESPI.dll文件在系统路径下并不存在3，Windows系统其他原因。

语法： 逻辑型 网截．打开 （）

  例程:

说明:

开始对某一个程序进行网络拦截。注意：在执行本命令前，您必须保证已经正确安装了随本支持库提供的网络服务提供者ESPI.dll文件到系统路径下。成功返回真，失败返回假，失败可由以下原因引起：1，网络服务提供者ESPI.dll没有安装；2，网络服务提供者已安装，但ESPI.dll文件在系统路径下并不存在3，Windows系统其他原因。

注：使用网截例程_命令.e时不要开传输数据量大的程序。否则会令程序非法操作。

参见:例程 网络服务安装文件1.1版


关闭 命令 操作系统支持：Windows 所属类别：网截

关闭 方法 操作系统支持：Windows 所属对象：网截

结束当前网络拦截。成功返回真，失败返回假。注意：在您不需要继续进行网络拦截前必须使用本命令结束当前的网络拦截。

语法： 逻辑型 网截．关闭 （）

  例程:

说明:

结束对某一个程序进行网络拦截。注意：在您不需要继续进行网络拦截前必须使用本命令结束当前的网络拦截。

注：使用网截例程_命令.e时不要开传输数据量大的程序。否则会令程序非法操作。

参见:例程 网络服务安装文件1.1版


取版本 命令 操作系统支持：Windows 所属类别：网截

取版本 方法 操作系统支持：Windows 所属对象：网截

获取网络服务提供者版本,10表示1.0,20表示2.0以此类推。

语法： 整数型 网截．取版本 （）

例程:

说明:

获取网络服务提供者版本,10表示1.0,20表示2.0以此类推. 注：使用网截例程_命令.e时不要开传输数据量大的程序。否则会令程序非法操作。

参见:例程 网络服务安装文件1.1版


调Socket 事件 所属对象：网截 操作系统支持：Windows

调创建套接字 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用socket函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截；除此之外返回其他任何值，都按默认调用处理。

语法： 整数型 _网截_调创建套接字 （调用者信息，地址族，格式，协议）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
地址族 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"socket"函数 "af"参数的使用方法。
格式 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"socket"函数 "type"参数的使用方法。
协议 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"socket"函数 "protocol"参数的使用方法。

例程:

说明:

当Windows系统中WinSock使用程序调用socket函数时执行如下内容，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截；除此之外返回其他任何值，都按默认调用处理。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调关闭套接字 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用CloseSocket函数时触发此事件，您可以在本事件中读取此次被调用函数的参数。

语法： 无返回值 _网截_调关闭套接字 （调用者信息，套接字句柄）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄

例程:

说明:

当Windows系统中WinSock使用程序调用CloseSocket函数时执行如下内容，，您可以在本事件中读取此次被调用函数的参数。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调绑定 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用bind函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调绑定 （调用者信息，套接字句柄，网址）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网址 | 网址信息；传址；要绑定的IP、端口等其他信息。

例程:

说明:

当Windows系统中WinSock使用程序调用bind函数时执行如下内容，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调侦听 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用listen函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调侦听 （调用者信息，套接字句柄，等待队列长度）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
等待队列长度 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"listen"函数 "backlog"参数的使用方法。

例程:

说明:

当Windows系统中WinSock使用程序调用listen函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调连接 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用connect函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调连接 （调用者信息，套接字句柄，网址）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网址 | 网址信息；传址；要连接的IP、端口等其他信息。

例程:

说明:

当Windows系统中WinSock使用程序调用connect函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调许可连接 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用accept函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket，注意关闭的是默认调用此accept返回的SOCKET句柄)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调许可连接 （调用者信息，套接字句柄，网址）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网址 | 网址信息；传址；要准许连接的IP、端口等其他信息。

例程:

说明:

当Windows系统中WinSock使用程序调用accept函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket，注意关闭的是默认调用此accept返回的SOCKET句柄)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调发送 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用send函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调发送 （调用者信息，套接字句柄，网络数据，调用方式）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网络数据 | 网络数据；传址；要发送的网络数据。
调用方式 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"send"函数 "flags"参数的使用方法。

例程:

说明:

当Windows系统中WinSock使用程序调用send函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调定向发送 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用sendto函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调定向发送 （调用者信息，套接字句柄，网络数据，调用方式，网址）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网络数据 | 网络数据；传址；要发送的网络数据。
调用方式 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"sendto"函数 "flags"参数的使用方法。
网址 | 网址信息；传址；数据发送目的地IP、端口等其他信息。

例程:

说明:

当Windows系统中WinSock使用程序调用sendto函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调接收 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用recv函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调接收 （调用者信息，套接字句柄，网络数据，调用方式）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网络数据 | 网络数据；传址；接收的网络数据。
调用方式 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"recv"函数 "flags"参数的使用方法。

例程:

说明:

当Windows系统中WinSock使用程序调用recv函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


取键盘指示灯状态 命令 操作系统支持：Windows 所属类别：系统处理

调定向接收 事件 所属对象：网截 操作系统支持：Windows

当Windows系统中WinSock使用程序调用recvfrom函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

语法： 整数型 _网截_调定向接收 （调用者信息，套接字句柄，网络数据，调用方式，网址）

参数名 | 描 述
调用者信息 | 调用者信息；传址；调用者的进程及当前使用线程的相关信息。
套接字句柄 | 整数型；传址；WinSock的SOCKET句柄。
网络数据 | 网络数据；传址；接收的网络数据。
调用方式 | 整数型；传址；该参数使用方法请参见WinSock2文档(建议参考MSDN)中关于"recvfrom"函数 "flags"参数的使用方法。
网址 | 网址信息；传址；数据来源的IP、端口等其他信息。

例程:

说明:

当Windows系统中WinSock使用程序调用recvfrom函数时触发此事件，您可以在本事件中读取或更改此次被调用函数的参数。如不更改任何参数并保持处理默认调用，返回0、#拦截操作.默认调用；如要处理本次调用为无效，返回1、#拦截操作.无效调用；如要更改本次调用的任何参数，返回2、#拦截操作.更改调用；如要关闭连接(closesocket)，返回3、#拦截操作.关闭拦截。

参见:例程 网络服务安装文件1.1版


调用者信息

调用者信息 普通类型 操作系统支持：Windows 跳至：网络拦截支持库

本类型用来保存WinSock函数调用者的相关信息，包括：进程名、进程标识(ProcessID)、线程标识(ThreadID)。

方法：

取进程名 取进程标识 取线程标识

参见： 基本数据类型


取进程名 方法 操作系统支持：Windows 所属对象：调用者信息

返回进程名。

语法： 文本型 调用者信息．取进程名 （）

例程：

说明：

返回用户选中的进程名称

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


取进程标识 方法 操作系统支持：Windows 所属对象：调用者信息

返回进程标识(ProcessID)。

语法： 整数型 调用者信息．取进程标识 （）

例程：

说明：

返回用户选择用户选择程序的进程标识

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


取线程标识 方法 操作系统支持：Windows 所属对象：调用者信息

返回线程标识(ThreadID)。

语法： 整数型 调用者信息．取线程标识 （）

例程：

说明：

返回用户选择程序的线程标识

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


网址信息

网址信息 普通类型 操作系统支持：Windows 跳至：网络拦截支持库

本类型用来保存网络IP地址和端口等信息，对应WinSock中的sockaddr_in(同时兼容sockaddr)。

方法：

取族 置族 取IP端口 置IP端口

参见： 基本数据类型


取族 方法 操作系统支持：Windows 所属对象：网址信息

获取地址族。

语法： 短整数型 网址信息．取族 （）

例程：

说明：

获取地址族。注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


置族 方法 操作系统支持：Windows 所属对象：网址信息

设置地址族。成功返回真，失败返回假。

语法： 逻辑型 网址信息．置族 （族）

参数名 | 描 述
族 | 必需的；短整数型。地址组，必须为2(既:AF_INET)。

例程：

说明：

设置地址组. 注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


取IP端口 方法 操作系统支持：Windows 所属对象：网址信息

获取IP和端口的信息。

语法： 逻辑型 网址信息．取IP端口 （IP1，IP2，IP3，IP4，端口）

参数名 | 描 述
IP1 | 必需的；字节型，参数数据只能提供变量。IP地址1。
IP2 | 必需的；字节型，参数数据只能提供变量。IP地址2。
IP3 | 必需的；字节型，参数数据只能提供变量。IP地址3。
IP4 | 必需的；字节型，参数数据只能提供变量。IP地址4。
端口 | 必需的；整数型，参数数据只能提供变量。端口号。

例程：

说明：

获取用户选定程序的IP和端口信息

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


置IP端口 方法 操作系统支持：Windows 所属对象：网址信息

设置IP和端口等信息。成功返回真，失败返回假。

语法： 逻辑型 网址信息．置IP端口 （IP1，IP2，IP3，IP4，端口）

参数名 | 描 述
IP1 | 必需的；字节型。IP地址1。
IP2 | 必需的；字节型。IP地址2。
IP3 | 必需的；字节型。IP地址3。
IP4 | 必需的；字节型。IP地址4。
端口 | 必需的；整数型。端口号

例程：

说明：

设置IP和端口等信息. 注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


网络数据

网络数据 普通类型 操作系统支持：Windows 跳至：网络拦截支持库

本类型用来保存网络发送和接收的数据，被用于对recv/recvfrom/send/sendto函数的拦截中。

方法：

取长度 | 分配 | 从文本分配 | 从字节集分配
释放 | 取数据 | 到文本 | 到字节集

参见： 基本数据类型


取长度 方法 操作系统支持：Windows 所属对象：网络数据

获取网络数据的长度。

语法： 整数型 网络数据．取长度 （）

例程

说明：

取得拦截到网络数据的长度。

注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。

参考：例程 网络服务安装文件1.1版


取长度 方法 操作系统支持：Windows 所属对象：网络数据

分配 方法 操作系统支持：Windows 所属对象：网络数据

分配网络数据的空间，原数据将被删除。成功返回真，失败返回假。

语法： 逻辑型 网络数据．分配 （数据大小）

参数名 | 描 述
数据大小 | 必需的；整数型。要分配的数据大小，必须大于等于1。

例程

说明：

分配网络数据的空间，拦截到的原数据将被删除。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


取长度 方法 操作系统支持：Windows 所属对象：网络数据

从文本分配 方法 操作系统支持：Windows 所属对象：网络数据

根据指定文本分配并复制新的网络数据，原数据将被删除。成功返回真，失败返回假。

语法： 逻辑型 网络数据．从文本分配 （文本）

参数名 | 描 述
文本 | 必需的；文本型。要分配并复制的文本。

例程

说明：

把指定的文本分配并复制到新的网络数据，原有的数据将被删除。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


取长度 方法 操作系统支持：Windows 所属对象：网络数据

从字节集分配 方法 操作系统支持：Windows 所属对象：网络数据

根据指定字节集分配并复制新的网络数据，原数据将被删除。成功返回真，失败返回假。

语法： 逻辑型 网络数据．从字节集分配 （字节集）

参数名 | 描 述
字节集 | 必需的；字节集，参数数据只能提供变量。要分配并复制的字节集。

例程

说明：

把指定的字节集分配并复制到新的网络数据，原有的数据将被删除。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


取长度 方法 操作系统支持：Windows 所属对象：网络数据

释放 方法 操作系统支持：Windows 所属对象：网络数据

删除现有的网络数据。成功返回真，失败返回假。

语法： 逻辑型 网络数据．释放 （）

例程

说明：

删除现有的网络数据。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


取长度 方法 操作系统支持：Windows 所属对象：网络数据

取数据 方法 操作系统支持：Windows 所属对象：网络数据

获取指定位置的网络数据，注意：指定的位置必须合法，否则将引起程序或系统崩溃。成功返回真，失败返回假。

语法： 逻辑型 网络数据．取数据 （序号，数据）

参数名 | 描 述
序号 | 必需的；整数型。数据的序号(相当于内存偏移)，该参数必须大于等于0且小于数据长度。
数据 | 必需的；字节型，参数数据只能提供变量。要获取的数据。

例程

说明：

获取指定位置的网络数据。成功返回真，失败返回假。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


取长度 方法 操作系统支持：Windows 所属对象：网络数据

到文本 方法 操作系统支持：Windows 所属对象：网络数据

将现有网络数据转换到文本并返回该文本，注意:字符值等于0的值将被转换为空格' '。

语法： 文本型 网络数据．到文本 （）

例程

说明：

将现有网络数据转换成文本并返回该文本数据，如果字符值等于0的数据值将被转换为空格' '。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


到字节集 方法 操作系统支持：Windows 所属对象：网络数据

将现有网络数据转换到字节集并返回该字节集。

语法： 字节集 网络数据．到字节集 （）

例程

说明：

将现有网络数据转换成字节集并返回该字节集。

参考：例程 网络服务安装文件1.1版

（注：使用“网截例程_命令.e”时，不要传输数据量过大的程序，否则会令程序非法操作。）


网络服务安装

网络服务安装 普通类型 操作系统支持：Windows 跳至：网络拦截支持库

本类型用来安装/卸载本支持库所必须网络服务提供者(ESPINN.dll(NN为当前版本))，[警告]该文件必须是随支持库一起附带的网络服务提供者(ESPINN.dll(NN为当前版本))。

方法：

是否已安装 安装 卸载

参见： 基本数据类型


是否已安装 方法 操作系统支持：Windows 所属对象：网络服务安装

判断当前系统中是否已安装了网络服务提供者ESPI.dll和已安装到系统路径下的ESPI.dll是否是合法的网络服务提供者并且是否存在。

语法： 逻辑型 网络服务安装．是否已安装 （）

例程：

说明：

判断当前系统中是否已安装了网络服务

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


安装 方法 操作系统支持：Windows 所属对象：网络服务安装

安装网络服务提供者ESPI.dll到系统路径下，例如："C:\Windows\System32\ESPI.dll"。成功返回真，失败返回假，失败通常会由以下原因引起：1，要安装的文件不存在；2，要安装的文件是非法的(不是随支持库附带的ESPI.dll)；3，低一层的网络服务是非法的；4，Windows系统其他原因。 [ 警告 ]如果ESPI.dll已经安装成功，并且"卸载"命令没有成功执行,(注意：只有"卸载"命令返回"真"才代表真正成功卸载了)，或根本没有使用"卸载"命令，系统路径下的ESPI.dll文件不可以改名、删除或移动路径，否则很有可能将导致整个系统的WinSock瘫痪。如果上述情况真的发生了也不要紧，您可以将随本支持库附带的ESPI.dll文件再次复制到系统路径中(推荐使用此方法，因为后面的方法在某些特定情况下可能不保险)，或者直接执行"卸载"命令，并确定该命令是执行成功了。

语法： 逻辑型 网络服务安装．安装 （文件全名）

参数名 | 描 述
文件全名 | 必需的；文本型。要安装的文件全名，警告：该文件必须是随本支持库一起提供的ESPI.dll，该文件将会复制到系统路径下并安装。

例程：

说明：

安装网络服务提供者ESPI.dll到系统路径下

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


卸载 方法 操作系统支持：Windows 所属对象：网络服务安装

删除网络服务提供者在系统中已注册信息，但是并不实际删除系统路径下的ESPI.dll文件。成功返回真，失败返回假，失败可由以下原因引起：1，低一层网络服务是非法的；2，安装后的注册信息有损坏；3，Windows系统其他原因[警告]要删除/改名/移动系统路径下的ESPI.dll，必须先使用本命令成功卸载，详细信息请参见本支持库的解释。

语法： 逻辑型 网络服务安装．卸载 （）

例程：

说明：

删除网络服务提供者在系统中已注册信息。只是删除注册信息。

注：使用网截例程_命令.e 时不要开传输数据量大的程序。否则会令程序非法操作。

参见: 例程 网络服务安装文件1.1版


拦截操作

拦截操作 枚举常量集合类型 操作系统支持：Windows 跳至：网络拦截支持库

本类型枚举"网截"中对每个WinSock函数拦截的处理。

成员 | 描 述
默认调用 | 常量值为 0 。调用默认的处理，不更改本次调用的任何参数。
无效调用 | 常量值为 1 。将本次调用处理为无效。
更改调用 | 常量值为 2 。如更改了本次调用的参数，必须在事件或其他处理的场合返回或使用本值。
关闭连接 | 常量值为 3 。关闭当前WinSock连接(SOCKET s)。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。