办公组件支持库

办公组件支持库 帮助手册20080807版 返回支持库手册 返回首页

该支持库实现了对易语言办公组件的支持。

操作系统支持： Windows

窗口组件数据类型：

办公组件

其它数据类型：

页面接口 | 工作表接口 | 对象接口 | 表格接口
修订接口 | 页面边距 | 中文字号 | 位置
对象种类 | 文本位置 | 文字类型 | 横向对齐
纵向对齐 | 图表类型 | 填充类型 |

例程列表：

例程名称 | 下载 | 说明
易语言办公组件例程 | 办公组件例程.e | 演示如何使用易语言的办公组件

适用版本，办公组件支持库 （3.9#0版）


办公组件

办公组件 窗口组件 操作系统支持：Windows 跳至：办公组件支持库

一个类似Microsoft Word的办公组件，实现了日常办公所需的基本文档处理功能。本组件目前可以识别并读取下列文档格式：*.txt、*.doc（部分格式）、*.rtf，并可以保存为本组件特有的文档格式*.ewd。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
右键菜单 | 工作表菜单 | 水平标尺 | 垂直标尺

方法：

打开文件 | 保存文件 | 新建文件 | 另存为
另存为文本文件 | 保存到FTP | 保存到临时文件 | 取文件内容
置文件内容 | 保护文档 | 置文档保护类型 | 设置密码
置修改状态 | 是否已修改 | 取文件路径 | 查找
替换 | 替换文本 | 插入时间 | 插入页码
插入符号 | 复制 | 粘贴 | 剪切
撤消 | 重复 | 全选 | 清除
取选择区字体 | 置选择区字体 | 取选择区文本颜色 | 置选择区文本颜色
取选择区文本底纹 | 置选择区文本底纹 | 增大字体 | 减小字体
字体设置 | 插入文本 | 取段落对齐 | 置段落对齐
是否首行缩进 | 置首行缩进 | 取文字类型 | 置文字类型
取当前用户 | 置当前用户 | 禁止刷新 | 恢复刷新
导入数据 | 文本菜单 | 取可用字体 | 段落设置
取显示比例 | 置显示比例 | 打印 | 打印预览
打印设置 | 置字体预览文本 | 取页面接口 | 取工作表接口
取对象接口 | 取表格接口 | 取修订接口 | 置程序名称

自有事件：

组件鼠标左键被按下 | 组件被双击 | 组件鼠标左键被放开 | 即将打开文件
打开文件完毕 | 即将保存文件 | 保存文件完毕 | 单元格被单击
组件按下某键 | 右键菜单被弹出 |  |

基本事件：


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


右键菜单 (办公组件)

右键菜单 属性 所属对象：办公组件 操作系统支持：Windows

数据类型：逻辑型；

例程:

说明:

决定工作表是否需要右键菜单。

参见: 例程


工作表菜单 (办公组件)

工作表菜单 属性 所属对象：办公组件 操作系统支持：Windows

数据类型：逻辑型；

例程:

说明:

是决定工作表上是否使用工作表菜单。

参见: 例程


水平标尺 (办公组件)

水平标尺 属性 所属对象：办公组件 操作系统支持：Windows

数据类型：逻辑型；

例程:

说明:

决定他是否使用水平标尺。

参见: 例程


垂直标尺 (办公组件)

垂直标尺 属性 所属对象：办公组件 操作系统支持：Windows

数据类型：逻辑型；

例程:

说明:

设置工作表的垂直的标尺是否显示。

参见: 例程


打开文件 方法 操作系统支持：Windows 所属对象：办公组件

打开一个该组件可识别的文档。成功返回真，失败返回假。该组件可识别的文档格式包括：*.ewd(该组件的默认保存格式)、*.txt、*.doc、*.rtf。可打开远程文件,如“http:\\www.domainname.com\文档.ewd”。

语法： 逻辑型 办公组件．打开文件（文件名，［密码］，［是否显示打开文件对话框］，［是否显示密码对话框］）

参数名 | 描 述
文件名 | 必需的；文本型。包含全路径。
密码 | 可选的；文本型。如果没有密码请保持该参数为空。
是否显示打开文件对话框 | 可选的；逻辑型。如果没有提供文件名且该参数为真，则打开一个对话框以供选择文件名。默认值为真。
是否显示密码对话框 | 可选的；逻辑型。如果没有提供密码或密码错误且本参数为真，则打开一个对话框以供输入密码。默认值为真。

例程:

说明:

打开一个该组件可识别的文档。

参见:例程


保存文件 (办公组件)

保存文件 方法 操作系统支持：Windows 所属对象：办公组件

保存当前文档内容到指定的文件。注意：使用本命令保存文件时，可以根据需要指定任意扩展名，但保存后的文件数据格式全部为ewd格式（即本组件的文档格式），本格式目前只能被本组件识别读取。所以请不要指定其他文档处理程序的默认扩展名（比如.txt, .doc等），以免被其他程序意外打开而不能正确读取。

语法： 逻辑型 办公组件．保存文件 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。包含全路径。

例程:

说明:

保存组件的所有数据。只能保存成ewd格式，如果打开的文件非ewd格式，将破坏原文件。

参见: 例程


新建文件 (办公组件)

新建文件 方法 操作系统支持：Windows 所属对象：办公组件

新建一个空文件，此前已打开的文件将被自动关闭。

语法： 无返回值 办公组件．新建文件 （）

例程:

说明:

新建一个文件，和其他一样他也会提醒你是否保存当前的被改动文件。

参见: 例程


另存为 (办公组件)

另存为 方法 操作系统支持：Windows 所属对象：办公组件

将当前文件另存到另一个文件。注意：使用本命令保存文件时，可以根据需要指定任意扩展名，但保存后的文件数据格式全部为ewd格式（即本组件的文档格式），本格式目前只能被本组件识别读取。所以请不要指定其他文档处理程序的默认扩展名（比如.txt, .doc等），以免被其他程序意外打开而不能正确读取。

语法： 无返回值 办公组件．另存为 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。包含全路径。

例程:

说明:

把组件当前打开的或新建的文件数据保存到另一个地方。

参见: 例程


另存为文本文件 (办公组件)

另存为文本文件 方法 操作系统支持：Windows 所属对象：办公组件

将当前文件另存为一个文本文件。

语法： 逻辑型 办公组件．另存为文本文件 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。包含全路径。

例程:

说明:

保存工作表里的文本到文件。

参见: 例程


保存到FTP (办公组件)

保存到FTP 方法 操作系统支持：Windows 所属对象：办公组件

将当前文件保存到指定的FTP服务器的指定目录。

语法： 逻辑型 办公组件．保存到FTP （FTP服务器地址，［用户名］，［密码］，文件名）

参数名 | 描 述
FTP服务器地址 | 必需的；文本型。
用户名 | 可选的；文本型。本参数提供用作通过FTP服务器用户验证的用户名称，如果被省略，默认值为匿名用户名“anonymous”。
密码 | 可选的；文本型。本参数提供用作通过FTP服务器用户验证的密码，如果被省略，默认值为空文本。
文件名 | 必需的；文本型。包含全路径。例如文件ABC.ewd，保存到根目录请指定参数：“ABC.wed”；保存到目录MyFiles下请指定参数：“/MyFiles/ABC.ewd”。

例程:

说明:

把数据保存到FTP服务器上。


保存到临时文件 (办公组件)

保存到临时文件 方法 操作系统支持：Windows 所属对象：办公组件

根据参数提供的文件名称（如Abc.ewd）将文件保存到Windows临时目录下,并且返回文件全名（如:C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\ABC.ewd）。

语法： 文本型 办公组件．保存到临时文件 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。包含全路径。

例程:

说明:

将组件上的数据保存到临时文件目录下。

参见: 例程


取文件内容 方法 操作系统支持：Windows 所属对象：办公组件

返回一个代表当前文件全部内容的字节集。

语法： 字节集 办公组件．取文件内容（）

例程:

说明:

取出打开的文件的数据返回字节集。


置文件内容 方法 操作系统支持：Windows 所属对象：办公组件

将指定文件内容数据写到临时文件并打开，返回该临时文件名。

语法： 文本型 办公组件．置文件内容（文件内容）

参数名 | 描 述
文件内容 | 必需的；字节集。该参数的值应该为该组件的“取文件内容”成员命令的返回值。

例程:

说明:

与“取文件内容”方法配合使用，将办公组件里的数据写到临时文件。


保护文档 (办公组件)

保护文档 方法 操作系统支持：Windows 所属对象：办公组件

打开设置文档保护对话框。

语法： 无返回值 办公组件．保护文档 （）

例程:

说明:

权限一些用户的使用限制。

参见: 例程


置文档保护类型 (办公组件)

置文档保护类型 方法 操作系统支持：Windows 所属对象：办公组件

语法： 逻辑型 办公组件．置文档保护类型 （保护类型）

参数名 | 描 述
保护类型 | 必需的；整数型。0:不保护； 1:只读保护； 2:填表保护。

例程:

说明:

指定文档保护的类型。

参见: 例程


设置密码 (办公组件)

设置密码 方法 操作系统支持：Windows 所属对象：办公组件

打开设置文件密码对话。

语法： 无返回值 办公组件．设置密码 （）

例程:

说明:

设置这个文件的访问密码。

参见: 例程


置修改状态 方法 操作系统支持：Windows 所属对象：办公组件

设置当前文档的修改状态。

语法： 无返回值 办公组件．置修改状态（是否已修改）

参数名 | 描 述
是否已修改 | 必需的；逻辑型。真，置当前文档为已修改状态；假，置当前文档为未修改状态。

例程:

说明:

设置修改状态。


是否已修改 (办公组件)

是否已修改 方法 操作系统支持：Windows 所属对象：办公组件

返回当前文档的修改状态。如果文档已修改，返回真；否则返回假。

语法： 逻辑型 办公组件．是否已修改 （）

例程:

说明:

判断打开的文档内容是否被改变。

参见: 例程


取文件路径 (办公组件)

取文件路径 方法 操作系统支持：Windows 所属对象：办公组件

返回当前编辑文件的全路径。

语法： 文本型 办公组件．取文件路径 （）

例程:

说明:

获取组件当前打开的ewd文件的全路径名。

参见: 例程


查找 (办公组件)

查找 方法 操作系统支持：Windows 所属对象：办公组件

打开“查找”对话框进行查找。

语法： 无返回值 办公组件．查找 （）

例程:

说明:

弹出组件的文本查找对话框。

参见: 例程


替换 (办公组件)

替换 方法 操作系统支持：Windows 所属对象：办公组件

打开“替换”对话框进行替换。

语法： 无返回值 办公组件．替换 （）

例程:

说明:

打开一个查找替换的对话框。


删除当前对象 (对象接口)

删除当前对象 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．删除当前对象 （）

例程:

说明:

删除当前选中的对象。

参见: 例程


替换文本 (办公组件)

替换文本 方法 操作系统支持：Windows 所属对象：办公组件

替换当前页面的指定文本。

语法： 无返回值 办公组件．替换文本 （欲被替换的文本，用作替换的文本，是否区分大小写）

参数名 | 描 述
欲被替换的文本 | 必需的；文本型。
用作替换的文本 | 必需的；文本型。
是否区分大小写 | 必需的；逻辑型。

例程:

说明:

使用命令方式查找替换。

参见: 例程


插入时间 (办公组件)

插入时间 方法 操作系统支持：Windows 所属对象：办公组件

打开“时间和日期”对话框来插入当前日期和时间到当前光标位置。

语法： 无返回值 办公组件．插入时间 （）

例程:

说明:

向工作表插入一个时间，他是你在一个日期格式的选择对话框里选出的。

参见: 例程


插入页码 (办公组件)

插入页码 方法 操作系统支持：Windows 所属对象：办公组件

打开“页号”对话框给当前文档添加页码。

语法： 无返回值 办公组件．插入页码 （）

例程:

说明:

插入一个页码，这个页码决定这个工作表的所有的页码的格式。

参见: 例程


插入符号 (办公组件)

插入符号 方法 操作系统支持：Windows 所属对象：办公组件

打开“符号”对话框插入特殊符号到当前光标处。

语法： 无返回值 办公组件．插入符号 （）

例程:

说明:

插入工作表的段落符号。

参见: 例程


复制 (办公组件)

复制 方法 操作系统支持：Windows 所属对象：办公组件

复制当前选中内容到剪贴板。

语法： 无返回值 办公组件．复制 （）

例程:

说明:

复制当前工作表上的被选择数据。

参见: 例程


粘贴 (办公组件)

粘贴 方法 操作系统支持：Windows 所属对象：办公组件

粘贴当前剪贴板的内容到当前光标位置。

语法： 无返回值 办公组件．粘贴 （）

例程:

说明:

粘贴到当前位置某个数据。

参见: 例程


剪切 (办公组件)

剪切 方法 操作系统支持：Windows 所属对象：办公组件

剪切当前选中内容到剪贴板。

语法： 无返回值 办公组件．剪切 （）

例程:

说明:

剪切工作表对象上的被选择的数据。

参见: 例程


撤消 (办公组件)

撤消 方法 操作系统支持：Windows 所属对象：办公组件

撤消所做的修改。

语法： 无返回值 办公组件．撤消 （）

例程:

说明:

撤消一个工作表里的一步操作，它与普通的文本撤消不一样不是撤消上一次的操作，而是撤消一步在未记录时的前一次的记录。

参见: 例程


重复 (办公组件)

重复 方法 操作系统支持：Windows 所属对象：办公组件

重新执行已撤消的操作。

语法： 无返回值 办公组件．重复 （）

例程:

说明:

重复前次的操作。可能会失败。

参见: 例程


全选 (办公组件)

全选 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．全选 （）

例程:

说明:

选择全部的文本数据。

参见: 例程


清除 (办公组件)

清除 方法 操作系统支持：Windows 所属对象：办公组件

清除所选内容中的全部文本。

语法： 无返回值 办公组件．清除 （）

例程:

说明:

清除组件上选择的文本数据。

参见: 例程


取选择区字体 (办公组件)

取选择区字体 方法 操作系统支持：Windows 所属对象：办公组件

返回当前选中文本的字体。如果当前没有选中文字，则返回默认字体。

语法： 字体 办公组件．取选择区字体 （）

例程:

说明:

取得被选择的文本的字体属性。

参见: 例程


置选择区字体 (办公组件)

置选择区字体 方法 操作系统支持：Windows 所属对象：办公组件

设置当前选中文本的字体。

语法： 无返回值 办公组件．置选择区字体 （字体）

参数名 | 描 述
字体 | 必需的；字体。

例程:

说明:

设置选择区的文本字体。

参见: 例程


取选择区文本颜色 (办公组件)

取选择区文本颜色 方法 操作系统支持：Windows 所属对象：办公组件

返回当前选中文字的颜色。

语法： 整数型 办公组件．取选择区文本颜色 （）

例程:

说明:

取得选择区的文本颜色。

参见: 例程


置选择区文本颜色 (办公组件)

置选择区文本颜色 方法 操作系统支持：Windows 所属对象：办公组件

设置当前选中文本的颜色。

语法： 无返回值 办公组件．置选择区文本颜色 （文本颜色）

参数名 | 描 述
文本颜色 | 必需的；整数型。

例程:

说明:

设置选择区的文本的文本颜色。

参见: 例程


取选择区文本底纹 (办公组件)

取选择区文本底纹 方法 操作系统支持：Windows 所属对象：办公组件

如果当前选中文字已设置了底纹，则返回真；否则返回假。

语法： 逻辑型 办公组件．取选择区文本底纹 （）

例程:

说明:

判断选择的文本是否设置了底纹。

参见: 例程


置选择区文本底纹 (办公组件)

置选择区文本底纹 方法 操作系统支持：Windows 所属对象：办公组件

设置当前选中文本的底纹。

语法： 无返回值 办公组件．置选择区文本底纹 （是否设置底纹）

参数名 | 描 述
是否设置底纹 | 必需的；逻辑型。真，设置底纹；假，取消底纹。

例程:

说明:

设置选择区的文本底纹。

参见: 例程


增大字体 (办公组件)

增大字体 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．增大字体 （）

例程:

说明:

增大选择区的文本的字体尺寸。

参见: 例程


减小字体 (办公组件)

减小字体 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．减小字体 （）

例程:

说明:

减小被选择的文字的字体大小。

参见: 例程


字体设置 (办公组件)

字体设置 方法 操作系统支持：Windows 所属对象：办公组件

打开“字体”对话框进行字体设置。

语法： 无返回值 办公组件．字体设置 （）

例程:

说明:

打开“字体”对话框进行字体设置


插入文本 (办公组件)

插入文本 方法 操作系统支持：Windows 所属对象：办公组件

在指定的位置插入文本。

语法： 无返回值 办公组件．插入文本 （［对象名］，插入位置，文本）

参数名 | 描 述
对象名 | 可选的；文本型。指定文本插入的对象。可以指定文本框或单元格的名称（别名）。如果本参数为空，则默认插入到当前页面。
插入位置 | 必需的；文本位置。指定文本插入的位置，可以为“文本位置”枚举常量集合中的常量之一。
文本 | 必需的；文本型。欲插入的文本。

例程:

说明:

在工作表里一个指定的位置插入一个文本。

参见: 例程


取段落对齐 (办公组件)

取段落对齐 方法 操作系统支持：Windows 所属对象：办公组件

返回当前段落的横行对齐方式。返回值为“横行对齐”枚举常量集合中的常量之一。

语法： 整数型 办公组件．取段落对齐 （）

例程:

说明:

取得当前的插入符位置的段落对其方式。

参见: 例程


置段落对齐 (办公组件)

置段落对齐 方法 操作系统支持：Windows 所属对象：办公组件

设置当前段落的横行对齐方式。

语法： 无返回值 办公组件．置段落对齐 （对齐方式）

参数名 | 描 述
对齐方式 | 必需的；横向对齐。可以为“横行对齐”枚举常量集合中的常量之一。

例程:

说明:

设置当前选择区的段落对齐方式。

参见: 例程


是否首行缩进 (办公组件)

是否首行缩进 方法 操作系统支持：Windows 所属对象：办公组件

如果当前段落有首行缩进，则返回真，否则返回假。

语法： 逻辑型 办公组件．是否首行缩进 （）

例程:

说明:

判断是否允许首行缩进。

参见: 例程


置首行缩进 (办公组件)

置首行缩进 方法 操作系统支持：Windows 所属对象：办公组件

设置当前段落是否首行缩进。

语法： 无返回值 办公组件．置首行缩进 （是否首行缩进）

参数名 | 描 述
是否首行缩进 | 必需的；逻辑型。

例程:

说明:

决定首行缩进是否使用。

参见: 例程


取文字类型 (办公组件)

取文字类型 方法 操作系统支持：Windows 所属对象：办公组件

返回当前选定文字的类型。返回值为“文字类型”枚举常量集合中的常量之一。

语法： 整数型 办公组件．取文字类型 （）

例程:

说明:

取出插入符的位置的字符的类型。

参见: 例程


置文字类型 (办公组件)

置文字类型 方法 操作系统支持：Windows 所属对象：办公组件

设置当前选定文字的类型。

语法： 文字类型 办公组件．置文字类型 （文字类型。可以为“文字类型”枚举常量集合中的常量之一）

参数名 | 描 述
文字类型。可以为“文字类型”枚举常量集合中的常量之一 | 必需的；文字类型。

例程:

说明:

设置选择文本的文字类型。

参见: 例程


取当前用户 (办公组件)

取当前用户 方法 操作系统支持：Windows 所属对象：办公组件

语法： 文本型 办公组件．取当前用户 （）

例程:

说明:

取得组件当前的使用用户。

参见: 例程


置当前用户 (办公组件)

置当前用户 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．置当前用户 （用户名）

参数名 | 描 述
用户名 | 必需的；文本型。

例程:

说明:

设置当前的使用用户。

参见: 例程


禁止刷新 (办公组件)

禁止刷新 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．禁止刷新 （）

例程:

说明:

禁止当前状态工作表刷新。

参见: 例程


恢复刷新 (办公组件)

恢复刷新 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．恢复刷新 （）

例程:

说明:

恢复工作表的刷新情况。

参见: 例程


导入数据 (办公组件)

导入数据 方法 操作系统支持：Windows 所属对象：办公组件

打开“导入数据”对话框。

语法： 无返回值 办公组件．导入数据 （）

例程:

说明:

导入数据是指导入一个数据库的数据，他会让你选择ADO的DSN（数据源）打开，如果无这个数据库的驱动器会打开失败。

参见: 例程


文本菜单 (办公组件)

文本菜单 方法 操作系统支持：Windows 所属对象：办公组件

在当前光标处,将用一对花括号括起来的里面用“,”号分开的项目变成下拉菜单样式，或从下拉菜单恢复文本样式。

语法： 无返回值 办公组件．文本菜单 （）

例程:

说明:

设置一种用户自定义菜单。它是将插入符的位置的文本，安照一个特定的格式设置成菜单样式。
例如： {1234，asdf} -〉 在插入符的位置 -〉初始文本为‘1234’，一个高亮链接文本的菜单按钮。

参见: 例程


取可用字体 (办公组件)

取可用字体 方法 操作系统支持：Windows 所属对象：办公组件

取得系统中所有可用的字体名称。

语法： 文本型数组 办公组件．取可用字体 （）

例程:

说明:

枚举系统中可用的字体。

参见: 例程


段落设置 (办公组件)

段落设置 方法 操作系统支持：Windows 所属对象：办公组件

打开“段落”对话框，进行段落设置。

语法： 无返回值 办公组件．段落设置 （）

例程:

说明:

是一个工作表的段落格式设置的对话框。

参见: 例程


取显示比例 (办公组件)

取显示比例 方法 操作系统支持：Windows 所属对象：办公组件

语法： 整数型 办公组件．取显示比例 （）

例程:

说明:

取得当前的工作表的显示比例。

参见: 例程


置显示比例 (办公组件)

置显示比例 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．置显示比例 （显示比例）

参数名 | 描 述
显示比例 | 必需的；整数型。百分比。10 ~ 400。

例程:

说明:

设置当前的工作表的显示比例。

参见: 例程


打印 (办公组件)

打印 方法 操作系统支持：Windows 所属对象：办公组件

打印当前文档。

语法： 无返回值 办公组件．打印 （［是否设置打印参数］）

参数名 | 描 述
是否设置打印参数 | 可选的；逻辑型。如果该参数为真, 在打印前将弹出“打印参数设置”对话框；否则不弹出该对话框而直接打印。如果该参数为空，默认值为假。

例程:

说明:

打印当前文档的内容。

参见: 例程


打印预览 (办公组件)

打印预览 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．打印预览 （）

例程:

说明:

进入打印前的预览，可以设置打印的参数。

参见: 例程


打印设置 (办公组件)

打印设置 方法 操作系统支持：Windows 所属对象：办公组件

语法： 无返回值 办公组件．打印设置 （）

例程:

说明:

调用系统默认的打印机的打印设置对话框。

参见: 例程


置字体预览文本 (办公组件)

置字体预览文本 方法 操作系统支持：Windows 所属对象：办公组件

设置“字体对话框”中的预览文本。该设置对以后在办公组件中打开的所有“字体”对话框均有效。

语法： 无返回值 办公组件．置字体预览文本 （预览文本）

参数名 | 描 述
预览文本 | 必需的；文本型，初始值为“办公组件 Ewd”。

例程:

说明:

设置字体设置对话框中字体预览框的文本。


取页面接口 (办公组件)

取页面接口 方法 操作系统支持：Windows 所属对象：办公组件

取得该组件的页面方法接口，通过该接口可以调用该组件的页面方法。

语法： 页面接口 办公组件．取页面接口 （）

例程:

说明:

工作表，表格，修订，页面，对象的操作需要知道组件的这些的接口，通过这个操作各个对象。


取工作表接口 (办公组件)

取工作表接口 方法 操作系统支持：Windows 所属对象：办公组件

取得该组件的工作表方法接口，通过该接口可以调用该组件的工作表方法。

语法： 工作表接口 办公组件．取工作表接口 （）

例程:

说明:

工作表，表格，修订，页面，对象的操作需要知道组件的这些的接口，通过这个操作各个对象。


取对象接口 方法 操作系统支持：Windows 所属对象：办公组件

取得该组件的对象方法接口，通过该接口可以调用该组件的对象方法。

语法： 对象接口 办公组件．取对象接口（）

例程:

说明:

取得组件的对象的接口。


取表格接口 (办公组件)

取表格接口 方法 操作系统支持：Windows 所属对象：办公组件

取得该组件的表格方法接口，通过该接口可以调用该组件的表格方法。

语法： 表格接口 办公组件．取表格接口 （）

例程:

说明:

工作表，表格，修订，页面，对象的操作需要知道组件的这些的接口，通过这个操作各个对象。


取修订接口 (办公组件)

取修订接口 方法 操作系统支持：Windows 所属对象：办公组件

取得该组件的修订方法接口，通过该接口可以调用该组件的修订方法，对文档进行修订。

语法： 修订接口 办公组件．取修订接口 （）

例程:

说明:

工作表，表格，修订，页面，对象的操作需要知道组件的这些的接口，通过这个操作各个对象。


置程序名称 (办公组件)

置程序名称 方法 操作系统支持：Windows 所属对象：办公组件

设置使用了办公组件的易语言程序的名称，该名称文本将作为办公组件所有提示信息框的标题。在调用本命令之前，默认的程序名称为“办公组件”。

语法： 无返回值 办公组件．置程序名称 （程序名称）

参数名 | 描 述
程序名称 | 必需的；文本型。该名称文本将作为办公组件所有提示信息框的标题。

例程:

说明:

程序创建时用户可以指定程序名称。


组件鼠标左键被按下 (办公组件)

组件鼠标左键被按下 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_组件鼠标左键被按下 （）

例程:

说明:

组件里按下左键时引发此事件

参见: 例程


组件被双击 (办公组件)

组件被双击 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_组件被双击 （）

例程:

说明:

组件接收到双击的信息引发此事件。

参见: 例程


组件鼠标左键被放开 (办公组件)

组件鼠标左键被放开 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_组件鼠标左键被放开 （）

例程:

说明:

当左键从组件放开，引发此事件。

参见: 例程


即将打开文件 (办公组件)

即将打开文件 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_即将打开文件 （）

例程:

说明:

在工作表要打开文件时首先引发的事件。

参见: 例程


打开文件完毕 (办公组件)

打开文件完毕 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_打开文件完毕 （）

例程:

说明:

打开文件后引发的事情。

参见: 例程


即将保存文件 (办公组件)

即将保存文件 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_即将保存文件 （）

例程:

说明:

在工作表要保存文件后，首先引发的事件。

参见: 例程


保存文件完毕 (办公组件)

保存文件完毕 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_保存文件完毕 （）

例程:

说明:

当组件的数据保存到文件后会引发此事件。

参见: 例程


单元格被单击 (办公组件)

单元格被单击 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_单元格被单击 （单元格别名，单元格内容）

参数名 | 描 述
单元格别名 | 文本型；
单元格内容 | 文本型；

例程:

说明:

单元格是指标表格对象的单元格，描述一样单击就引发了这个事件。

参见: 例程


组件按下某键 (办公组件)

组件按下某键 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_组件按下某键 （键代码，Ctrl键被按下）

参数名 | 描 述
键代码 | 整数型；
Ctrl键被按下 | 逻辑型；

例程:

说明:

在这里按下键盘时引发的事件。

参见: 例程


右键菜单被弹出 (办公组件)

右键菜单被弹出 事件 所属对象：办公组件 操作系统支持：Windows

语法： 无返回值 _办公组件_右键菜单被弹出 （）

例程:

说明:

当右键菜单被弹出，就引发此事件。

参见: 例程


页面接口

页面接口 普通类型 操作系统支持：Windows 跳至：办公组件支持库

方法：

是否为空 | 取大小 | 置大小 | 取边距
置边距 | 取方向 | 显示边距标志 | 插入页眉
插入页脚 | 取页眉 | 置页眉 | 取页脚
置页脚 | 删除页眉 | 删除页脚 | 添加页
删除尾空页 | 可否删除当前页 | 取页数 | 置当前页
置光标位置 | 置背景色 | 置底图 | 输出页面图像
页面设置 | 删除当前页 |  |

参见： 基本数据类型


是否为空 方法 操作系统支持：Windows 所属对象：表格接口

是否为空 方法 操作系统支持：Windows 所属对象：页面接口

如果该接口为空（没有被赋值），返回真；否则返回假。注意，如果调用一个空接口的其他成员命令将引发运行时错误。

语法： 逻辑型 页面接口．是否为空 （）

例程:

说明:

如果取出该接口，在不空的情况向才可以操作他。

参见:例程

©版权所有 大连大有吴涛易语言软件开发有限公司　　电话:86-0411-88995831 传真:86-0411-88995834


取大小 方法 操作系统支持：Windows 所属对象：页面接口

取得当前文档的页面大小。

语法： 无返回值 页面接口．取大小 （［宽度］，［高度］）

参数名 | 描 述
宽度 | 可选的；整数型，参数数据只能提供变量。本成员命令调用结束后，该参数变量内存放当前文件的页面宽度，以0.1毫米为单位。变量内原有数据被覆盖。如果不需要取得页面宽度，请保持该参数为空。
高度 | 可选的；整数型，参数数据只能提供变量。本成员命令调用结束后，该参数变量内存放当前文件的页面高度，以0.1毫米为单位。变量内原有数据被覆盖。如果不需要取得页面高度，请保持该参数为空。

例程:

说明:

取出当前页的大小和边距页面的方向。


置大小 方法 操作系统支持：Windows 所属对象：页面接口

设置当前文档的页面大小。可以直接设置纸型（请参看该命令的参数说明信息）。

语法： 无返回值 页面接口．置大小 （［宽度］，［高度］）

参数名 | 描 述
宽度 | 可选的；整数型。指定当前文件的页面宽度，以0.1毫米为单位。如果不需要指定宽度，请保持该参数为空。如果该参数为-1，“高度”参数为核心支持库中的纸型常量（比如“#A3纸”），则可以直接页面大小为指定的纸型。
高度 | 可选的；整数型。指定当前文件的页面高度，以0.1毫米为单位。如果不需要指定高度，请保持该参数为空。如果“宽度”参数为－1，则可以在此参数中直接指定纸型。

例程:

说明:

设置页面的编辑区尺寸和页面尺寸背景色并让它显示边距标志。


取边距 方法 操作系统支持：Windows 所属对象：页面接口

返回当前文档的页面边距。

语法： 页面边距 页面接口．取边距 （）

例程:

说明:

取出当前页的大小和边距页面的方向。


置边距 方法 操作系统支持：Windows 所属对象：页面接口

设置当前文档的页面边距。

语法： 无返回值 页面接口．置边距 （边距）

参数名 | 描 述
边距 | 必需的；页面边距。

例程:

说明:

设置页面的编辑区尺寸和页面尺寸背景色并让它显示边距标志。


取方向 方法 操作系统支持：Windows 所属对象：页面接口

取得当前文档的页面方向。如果为纵向，返回真；否则返回假。

语法： 逻辑型 页面接口．取方向 （）

例程:

说明:

取出当前页的大小和边距页面的方向。


显示边距标志 方法 操作系统支持：Windows 所属对象：页面接口

显示或取消显示页面边距标志。

语法： 无返回值 页面接口．显示边距标志 （是否显示）

参数名 | 描 述
是否显示 | 必需的；逻辑型，初始值为“真”。真，显示页边距标志；假，不显示。

例程:

说明:

设置页面的编辑区尺寸和页面尺寸背景色并让它显示边距标志。


插入页眉 方法 操作系统支持：Windows 所属对象：页面接口

插入或删除页眉。如果当前页面没有页眉，可以调用本命令来添加页眉；如果当前页面已有页眉，可以调用本命令来删除页眉。

语法： 无返回值 页面接口．插入页眉 （）

例程:

说明:

插入页眉，并置页眉的文本。（置页眉单独用便可，插入页眉是进入编辑状态）


插入页脚 方法 操作系统支持：Windows 所属对象：页面接口

插入或删除页脚。如果当前页面没有页脚，可以调用本命令来添加页脚；如果当前页面已有页脚，可以调用本命令来删除页脚。

语法： 无返回值 页面接口．插入页脚 （）

例程:

说明:

插入页脚，并置页脚的文本。（置页脚单独用便可，插入页脚是进入编辑状态）


取页眉 方法 操作系统支持：Windows 所属对象：页面接口

返回当前文档的页眉文本。

语法： 文本型 页面接口．取页眉 （）

例程:

说明:

取出页眉和页脚的文本。


置页眉 方法 操作系统支持：Windows 所属对象：页面接口

设置当前文档的页眉文本。

语法： 无返回值 页面接口．置页眉 （页眉文本，页眉对齐方式）

参数名 | 描 述
页眉文本 | 必需的；文本型。
页眉对齐方式 | 必需的；整数型，初始值为“0”。0、左对齐； 1、居中； 2，右对齐。

例程:

说明:

插入页眉，并置页眉的文本。（置页眉单独用便可，插入页眉是进入编辑状态）


取页脚 方法 操作系统支持：Windows 所属对象：页面接口

返回当前文档的页脚文本。

语法： 文本型 页面接口．取页脚 （）

例程:

说明:

取出页眉和页脚的文本。


置页脚 方法 操作系统支持：Windows 所属对象：页面接口

设置当前文档的页脚文本。

语法： 无返回值 页面接口．置页脚 （页脚文本，页脚对齐方式）

参数名 | 描 述
页脚文本 | 必需的；文本型。
页脚对齐方式 | 必需的；整数型，初始值为“0”。0、左对齐； 1、居中； 2、右对齐。

例程:

说明:

插入页脚，并置页脚的文本。（置页脚单独用便可，插入页脚是进入编辑状态）


删除页眉 方法 操作系统支持：Windows 所属对象：页面接口

语法： 无返回值 页面接口．删除页眉 （）

例程:

说明:

删除页眉。（页眉是页顶部的表示这个页的文字）


删除页脚 方法 操作系统支持：Windows 所属对象：页面接口

语法： 无返回值 页面接口．删除页脚 （）

例程:

说明:

删除页脚。（页脚是页底部的表示这个页的文字）


添加页 方法 操作系统支持：Windows 所属对象：页面接口

在当前文档的结尾添加一个新页。

语法： 无返回值 页面接口．添加页 （）

例程:

说明:

添加页在办公组件的工作区中。


删除尾空页 方法 操作系统支持：Windows 所属对象：页面接口

删除位于文档尾部的所有空白页。

语法： 无返回值 页面接口．删除尾空页 （）

例程:

说明:

删除尾空页，是除去底部的未用上的页。


可否删除当前页 方法 操作系统支持：Windows 所属对象：页面接口

语法： 逻辑型 页面接口．可否删除当前页 （）

例程:

说明:

判断如果当前页可以删除，便把他删掉。


取页数 方法 操作系统支持：Windows 所属对象：页面接口

返回当前文档的总页数。

语法： 整数型 页面接口．取页数 （）

例程:

说明:

输出页面的图像，判断给定的页号不存在，信息框提示错误返回。


置当前页 方法 操作系统支持：Windows 所属对象：页面接口

设置当前页。

语法： 无返回值 页面接口．置当前页 （页码）

参数名 | 描 述
页码 | 必需的；整数型。

例程:

说明:

设置办公组件当前页。(他不会因为越界而缩到最后页)


置光标位置 方法 操作系统支持：Windows 所属对象：页面接口

设置光标（输入点）的位置。

语法： 无返回值 页面接口．置光标位置 （页码，文本框索引，行，列）

参数名 | 描 述
页码 | 必需的；整数型。从1开始。
文本框索引 | 必需的；整数型。从1开始。
行 | 必需的；整数型。从1开始。
列 | 必需的；整数型。从1开始。

例程:

说明:

设置光标的位置。(是根据文本框的出现次序的索引指定的)


置背景色 方法 操作系统支持：Windows 所属对象：页面接口

设置页面背景色。

语法： 无返回值 页面接口．置背景色 （背景色）

参数名 | 描 述
背景色 | 必需的；整数型。背景颜色值。

例程:

说明:

设置页面的编辑区尺寸和页面尺寸背景色并让他显示边距标志。


置底图 方法 操作系统支持：Windows 所属对象：页面接口

设置页面背景图。

语法： 逻辑型 页面接口．置底图 （图片文件名，图片显示方式）

参数名 | 描 述
图片文件名 | 必需的；文本型。目前仅接受“*.bmp”和“*.jpeg(jpg)”文件。请包含全路径。
图片显示方式 | 必需的；短整数型。0、居中； 1、平铺； 2、拉伸。

例程:

说明:

置底图是指定一个工作表的页面底图。


输出页面图像 方法 操作系统支持：Windows 所属对象：页面接口

把指定页面显示的内容输出到BMP文件。

语法： 逻辑型 页面接口．输出页面图像 （文件名，页号，输出比例，是否镜像）

参数名 | 描 述
文件名 | 必需的；文本型。请包含全路径。
页号 | 必需的；整数型。从1开始。
输出比例 | 必需的；整数型，初始值为“100”。输入的图像大小与页面大小之间的比例。如“50”代表“50%”,即输出的图像是原页面图像的一半大小。
是否镜像 | 必需的；逻辑型，初始值为“假”。是否输出镜像图像。

例程:

说明:

把页面的底图输出到文件。


页面设置 方法 操作系统支持：Windows 所属对象：页面接口

打开“页面设置”对话框进行页面设置。

语法： 无返回值 页面接口．页面设置 （）

例程:

说明:

页面设置是组件本身的设置对话框


删除当前页 方法 操作系统支持：Windows 所属对象：页面接口

语法： 无返回值 页面接口．删除当前页 （）

例程:

说明:

判断如果当前页可以删除，便把他删掉。


工作表接口

工作表接口 普通类型 操作系统支持：Windows 跳至：办公组件支持库

方法：

是否为空 | 插入 | 新建 | 删除
重命名 | 取当前 | 置当前 | 重命名当前
取文本 | 取字符数 | 清空当前 | 删除当前
复制 | 粘贴 | 取个数 | 取索引
取名称 |  |  |

参见： 基本数据类型


是否为空 (工作表接口)

是否为空 方法 操作系统支持：Windows 所属对象：工作表接口

如果该接口为空（没有被赋值），返回真；否则返回假。注意，如果调用一个空接口的其他成员命令将引发运行时错误。

语法： 逻辑型 工作表接口．是否为空 （）

例程:

说明:

如果取出该接口，在不空的情况下才可以操作它。


插入 方法 操作系统支持：Windows 所属对象：工作表接口

新建一个工作表，插入到指定工作表之前。

语法： 逻辑型 工作表接口．插入 （位置索引，名称）

参数名 | 描 述
位置索引 | 必需的；短整数型。新工作表将插入到该工作表之前。位置索引从1开始，至左向右依次递增。
名称 | 必需的；文本型。新工作表名称。

例程:

说明:

插入一个工作表它是通过存在的那个位置的页向前插入的。


新建 方法 操作系统支持：Windows 所属对象：工作表接口

新建一个工作表，插入到指定位置。

语法： 无返回值 工作表接口．新建 （位置）

参数名 | 描 述
位置 | 必需的；位置。指定新工作表的位置。可以为枚举集合类型“位置”中的常量之一。

例程:

说明:

向一个方向插入一个工作表。


删除 方法 操作系统支持：Windows 所属对象：工作表接口

根据名称删除一个工作表。成功返回真，失败返回假。

语法： 逻辑型 工作表接口．删除 （工作表名称）

参数名 | 描 述
工作表名称 | 必需的；文本型。欲删除的工作表的名称。

例程:

说明:

删除指定的这一个工作表，用索引变量判断这个值是否越界没有就把这个表删掉。


重命名 方法 操作系统支持：Windows 所属对象：工作表接口

重命名一个工作表。成功返回真，失败返回假。

语法： 逻辑型 工作表接口．重命名 （原工作表名称，新工作表名称）

参数名 | 描 述
原工作表名称 | 必需的；文本型。欲更名的原工作表的名称。
新工作表名称 | 必需的；文本型。欲更改为的新工作表的名称。

例程:

说明:

为一个指定的工作表重新命一个名。


取当前 方法 操作系统支持：Windows 所属对象：工作表接口

返回当前工作表的名称。

语法： 文本型 工作表接口．取当前 （）

例程:

说明:

取出当前的工作表的名称,再取出这个表索引。


置当前 方法 操作系统支持：Windows 所属对象：工作表接口

成功返回真，失败返回假。

语法： 逻辑型 工作表接口．置当前 （工作表名称）

参数名 | 描 述
工作表名称 | 必需的；文本型。欲置为当前的工作表的名称。

例程:

说明:

设置当前的工作表。


重命名当前 方法 操作系统支持：Windows 所属对象：工作表接口

打开一个对话框重命名当前工作表。

语法： 无返回值 工作表接口．重命名当前 （）

例程:

说明:

把当前的工作表，重新命名。


取文本 方法 操作系统支持：Windows 所属对象：工作表接口

返回当前工作表中所有的文本内容。

语法： 文本型 工作表接口．取文本 （）

例程:

说明:

取文本会把当前的工作表的文本取出来。


取字符数 方法 操作系统支持：Windows 所属对象：工作表接口

返回当前工作表中的字符总数。

语法： 整数型 工作表接口．取字符数 （）

例程:

说明:

取出当前的工作表里的字符长度。


清空当前 方法 操作系统支持：Windows 所属对象：工作表接口

清除当前工作表中的所有文本内容。

语法： 无返回值 工作表接口．清空当前 （）

例程:

说明:

把当前的工作表的内容清空。


删除当前 方法 操作系统支持：Windows 所属对象：工作表接口

语法： 无返回值 工作表接口．删除当前 （）

例程:

说明:

把当前的表删除掉。


复制 方法 操作系统支持：Windows 所属对象：工作表接口

把当前工作表复制到系统剪贴板上。

语法： 无返回值 工作表接口．复制 （）

例程:

说明:

复制会把当前的工作表复制到剪辑区。


粘贴 方法 操作系统支持：Windows 所属对象：工作表接口

把复制到系统剪贴板上的工作表粘贴到指定位置。

语法： 无返回值 工作表接口．粘贴 （欲粘贴到的位置）

参数名 | 描 述
欲粘贴到的位置 | 必需的；位置。可以为本支持库中“位置”枚举常量集合中的常量值之一。

例程:

说明:

如果先前复制了一个工作表，现在会将这个工作表插入到最后。


取个数 方法 操作系统支持：Windows 所属对象：工作表接口

返回当前文档中工作表的总个数。

语法： 整数型 工作表接口．取个数 （）

例程:

说明:

删除指定的这一个工作表，用索引变量判断这个值是否越界没有就取得这个表的名称。


取索引 方法 操作系统支持：Windows 所属对象：工作表接口

返回指定的工作表的索引。索引从1开始。失败返回0。

语法： 整数型 工作表接口．取索引 （工作表名称）

参数名 | 描 述
工作表名称 | 必需的；文本型。欲取其索引的工作表的名称。

例程:

说明:

取出当前的工作表的名称,再取出这个表的索引。


取名称 方法 操作系统支持：Windows 所属对象：工作表接口

返回指定的工作表的名称。失败返回空文本。

语法： 文本型 工作表接口．取名称 （工作表索引）

参数名 | 描 述
工作表索引 | 必需的；整数型。欲取其名称的工作表的索引。索引从1开始。

例程:

说明:

删除指定的这一个工作表，用索引变量判断这个值是否越界没有就取得这个表的名称。


对象接口

对象接口 普通类型 操作系统支持：Windows 跳至：办公组件支持库

方法：

是否为空 | 插入 | 重命名 | 取当前类型
取当前名称 | 取大小 | 置大小 | 取位置
可否衬于文字下方 | 显示别名 | 别名是否显示 | 取所在页
可否右对齐 | 可否顶对齐 | 可否底对齐 | 可否左对齐
可否置于底层 | 可否水平居中 | 可否垂直居中 | 可否置于顶层
可否等高 | 可否上移一层 | 可否下移一层 | 可否等宽
衬于文字下方 | 可否等大小 | 可否水平等距 | 可否垂直等距
右对齐 | 顶对齐 | 底对齐 | 左对齐
置于底层 | 水平居中 | 垂直居中 | 置于顶层
等高 | 上移一层 | 下移一层 | 等宽
可否组合 | 等大小 | 水平等距 | 垂直等距
取消组合 | 可否取消组合 | 可否锁定当前对象 | 组合
选定对象 | 锁定对象 | 锁定当前对象 | 绝对锁定当前对象
置水印颜色 | 属性设置 | 删除当前对象 | 取水印颜色
置水印输出方向 | 取水印字体 | 置水印字体 | 取水印输出方向
置文本框文本 | 取水印文本 | 置水印文本 | 取文本框文本
取方形印章编号 | 取方形印章文本 | 置方形印章文本 | 取圆形印章编号
画椭圆 | 取圆形印章密码 | 取方形印章密码 | 画圆线
插入图片 | 画矩形 | 画圆角矩形 | 画直线
删除菜单项 | 插入图表 | 置图表类型 | 添加菜单项
取菜单项目数 |  |  |

参见：基本数据类型


是否为空 方法 操作系统支持：Windows 所属对象：对象接口

如果该接口为空（没有被赋值），返回真；否则返回假。注意，如果调用一个空接口的其他成员命令将引发运行时错误。

语法： 逻辑型 页面接口．是否为空 （）

例程:

说明:

一个查找替换的对话框，是以模式方式打开的。


替换 方法 操作系统支持：Windows 所属对象：办公组件

插入 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．插入 （对象种类）

参数名 | 描 述
对象种类 | 必需的；对象种类。

例程:

说明:

插入某个类型的对象。


重命名 (对象接口)

重命名 方法 操作系统支持：Windows 所属对象：对象接口

语法： 逻辑型 对象接口．重命名 （旧名称，新名称）

参数名 | 描 述
旧名称 | 必需的；文本型。
新名称 | 必需的；文本型。

例程:

说明:

为一个已有名称的对象从新指定一个名称。


取当前类型 (对象接口)

取当前类型 方法 操作系统支持：Windows 所属对象：对象接口

返回当前选中的对象的类型。可以为以下值之一：1、文本框（或方形印章）； 2、表格； 3、图片； 4、圆形印章； 0、其他类型或没有选中对象。

语法： 整数型 对象接口．取当前类型 （）

例程:

说明:

在组件左键按下时取出当前被选中的对象的名称和类型。


取当前名称 (对象接口)

取当前名称 方法 操作系统支持：Windows 所属对象：对象接口

返回当前选中的对象的名称。

语法： 文本型 对象接口．取当前名称 （）

例程:

说明:

在组件左键按下时取出当前被选中的对象的名称和类型。


取大小 (对象接口)

取大小 方法 操作系统支持：Windows 所属对象：对象接口

取得指定对象的宽度和高度。

语法： 无返回值 对象接口．取大小 （对象名称，［宽度］，［高度］）

参数名 | 描 述
对象名称 | 必需的；文本型。欲取其大小的对象的名称。
宽度 | 可选的；整数型，参数数据只能提供变量。本成员命令调用结束后，该参数变量内存放指定对象的宽度，以0.1毫米为单位；变量内原有数据被覆盖。如果不需要取得对象宽度，请保持该参数为空。
高度 | 可选的；整数型，参数数据只能提供变量。本成员命令调用结束后，该参数变量内存放指定对象的高度，以0.1毫米为单位；变量内原有数据被覆盖。如果不需要取得对象高度，请保持该参数为空。

例程:

说明:

取得指定对象的宽度和高度。


置大小 (对象接口)

置大小 方法 操作系统支持：Windows 所属对象：对象接口

设置指定对象的宽度和高度。

语法： 逻辑型 对象接口．置大小 （对象名称，［宽度］，［高度］）

参数名 | 描 述
对象名称 | 必需的；文本型。欲置其大小的对象的名称。
宽度 | 可选的；整数型。以0.1毫米为单位。可以设置的最小值为10。如果不需要改变对象宽度，请保持该参数为空。
高度 | 可选的；整数型。以0.1毫米为单位。可以设置的最小值为10。如果不需要改变对象高度，请保持该参数为空。

例程:

说明:

设置指定对象的宽度和高度。


取位置 (对象接口)

取位置 方法 操作系统支持：Windows 所属对象：对象接口

取得指定对象的左边和顶边位置。

语法： 无返回值 对象接口．取位置 （对象名称，［左边］，［顶边］）

参数名 | 描 述
对象名称 | 必需的；文本型。欲取其位置的对象的名称。
左边 | 可选的；整数型，参数数据只能提供变量。本成员命令调用结束后，该参数变量内存放指定对象的左边位置，以0.1毫米为单位；变量内原有数据被覆盖。如果不需要取得对象左边位置，请保持该参数为空。
顶边 | 可选的；整数型，参数数据只能提供变量。本成员命令调用结束后，该参数变量内存放指定对象的顶边位置，以0.1毫米为单位；变量内原有数据被覆盖。如果不需要取得对象顶边位置，请保持该参数为空。

例程:

说明:

取得指定对象的左边和顶边位置。


显示别名 (对象接口)

显示别名 方法 操作系统支持：Windows 所属对象：对象接口

设置是否显示对象的别名（如果有）。

语法： 无返回值 对象接口．显示别名 （是否显示）

参数名 | 描 述
是否显示 | 必需的；逻辑型。真，显示； 假，不显示。

例程:

说明:

决定对象是否显示别名。

参见: 例程


别名是否显示 (对象接口)

别名是否显示 方法 操作系统支持：Windows 所属对象：对象接口

语法： 逻辑型 对象接口．别名是否显示 （）

例程:

说明:

获取对象别名是否显示，用信息框表示。

参见: 例程


取所在页 (对象接口)

取所在页 方法 操作系统支持：Windows 所属对象：对象接口

返回指定对象所在的页。页号从1开始。

语法： 整数型 对象接口．取所在页 （对象名）

参数名 | 描 述
对象名 | 必需的；文本型。页面中所插入的对象的名称。

例程:

说明:

取得某个对象在当前工作表中的所在页。


可否衬于文字下方 (对象接口)

可否衬于文字下方 方法 操作系统支持：Windows 所属对象：对象接口

如果当前选中对象可以衬于文字下方，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否衬于文字下方 （）

例程:

说明:

判断当前的对象可否衬于文字下方。(未选择对象是无效的)


可否顶对齐 (对象接口)

可否顶对齐 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象顶端对齐操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否顶对齐 （）

例程:

说明:

判断他们可否顶对齐，并让他们顶对齐。（必须选中不止一个）


可否底对齐 (对象接口)

可否底对齐 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象底端对齐操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否底对齐 （）

例程:

说明:

判断他们可否底对齐，并让他们底对齐。（必须选中不止一个）


可否左对齐 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象左对齐操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否左对齐（）

例程:

说明:

判断当前的对象是否可以左对齐，如果可以就让他左对齐。


可否右对齐 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象右对齐操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否右对齐（）

例程:

说明:

判断当前的对象是否可以右对齐，如果可以就让他右对齐。


可否水平居中 方法 操作系统支持：Windows 所属对象：对象接口

如果当前对象可以在页面上水平居中，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否水平居中（）

例程:

说明:

判断当前的对象是否可以水平居中，如果可以就让他水平居中。


可否垂直居中 方法 操作系统支持：Windows 所属对象：对象接口

如果当前对象可以在页面上垂直居中，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否垂直居中（）

例程:

说明:

判断如果当前的对象可否垂直居中，可以的话让他垂直居中。


可否置于顶层 方法 操作系统支持：Windows 所属对象：对象接口

如果可以将当前选中对象置于最顶层，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否置于顶层（）

例程:

说明:

判断当前对象可否置于顶部，如果可以他就可以执行置于顶层的命令。


可否置于底层 方法 操作系统支持：Windows 所属对象：对象接口

如果可以将当前选中对象置于最底层，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否置于底层（）

例程:

说明:

判断当前对象可否置于底部，如果可以他就可以执行置于底层的命令。


可否上移一层 方法 操作系统支持：Windows 所属对象：对象接口

如果可以将当前选中对象上移一层，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否上移一层（）

例程:

说明:

把当前对象的叠放层次上移一层。


可否下移一层 方法 操作系统支持：Windows 所属对象：对象接口

如果可以将当前选中对象下移一层，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否下移一层（）

例程:

说明:

把当前对象叠放层次下移一层，它对跟随文字的对象是无效的。


可否等宽 (对象接口)

可否等宽 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象等宽操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否等宽 （）

例程:

说明:

判断被选中的对象可否等高，条件是同一类型，如果成功，让他们等高。（必须选中不止一个）


可否等高 (对象接口)

可否等高 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象等高操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否等高 （）

例程:

说明:

判断当前选中的对象可否等高，通过就让他们等高，必须选中不止一个。


可否等大小 (对象接口)

可否等大小 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象等大小（等宽高）操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否等大小 （）

例程:

说明:

判断选中的一些的对象是否可以等大小。


可否水平等距 (对象接口)

可否水平等距 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象水平等距（平均分布）操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否水平等距 （）

例程:

说明:

可否选定的一些的对象可否水平等距。


可否垂直等距 (对象接口)

可否垂直等距 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象垂直等距（平均分布）操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否垂直等距 （）

例程:

说明:

可否选定的一些的对象可否垂直等距。


衬于文字下方 (对象接口)

衬于文字下方 方法 操作系统支持：Windows 所属对象：对象接口

将当前选中对象衬于文字下方。

语法： 无返回值 对象接口．衬于文字下方 （）

例程:

说明:

把当前对象置于文字之下。这个对象就成了一个图案。


顶对齐 (对象接口)

顶对齐 方法 操作系统支持：Windows 所属对象：对象接口

对象顶对齐。

语法： 无返回值 对象接口．顶对齐 （）

例程:

说明:

判断他们可否顶对齐，并让他们顶对齐。（必须选中不止一个）


底对齐 (对象接口)

底对齐 方法 操作系统支持：Windows 所属对象：对象接口

对象底对齐。

语法： 无返回值 对象接口．底对齐 （）

例程:

说明:

判断他们可否底对齐，并让他们底对齐。（必须选中不止一个）


左对齐 (对象接口)

左对齐 方法 操作系统支持：Windows 所属对象：对象接口

对象左对齐。

语法： 无返回值 对象接口．左对齐 （）

例程:

说明:

判断当前的对象是否可以左对齐，如果可以就让他左对齐。


右对齐 (对象接口)

右对齐 方法 操作系统支持：Windows 所属对象：对象接口

对象右对齐。

语法： 无返回值 对象接口．右对齐 （）

例程:

说明:

判断当前的对象是否可以右对齐，如果可以就让他右对齐。


水平居中 (对象接口)

水平居中 方法 操作系统支持：Windows 所属对象：对象接口

对象在页面中水平居中。

语法： 无返回值 对象接口．水平居中 （）

例程:

说明:

判断当前的对象是否可以水平居中，如果可以就让他水平居中。


垂直居中 (对象接口)

垂直居中 方法 操作系统支持：Windows 所属对象：对象接口

对象在页面中垂直居中。

语法： 无返回值 对象接口．垂直居中 （）

例程:

说明:

判断如果当前的对象可否垂直居中，可以的话让他垂直居中。


置于顶层 (对象接口)

置于顶层 方法 操作系统支持：Windows 所属对象：对象接口

将当前选中对象置于最顶层。

语法： 无返回值 对象接口．置于顶层 （）

例程:

说明:

判断当前对象可否置于顶部，如果可以他就可以执行置于顶层的命令。


置于底层 (对象接口)

置于底层 方法 操作系统支持：Windows 所属对象：对象接口

将当前选中对象置于最底层。

语法： 无返回值 对象接口．置于底层 （）

例程:

说明:

判断当前对象可否置于底部，如果可以他就可以执行置于底层的命令。


上移一层 (对象接口)

上移一层 方法 操作系统支持：Windows 所属对象：对象接口

将当前选中对象上移一层。

语法： 无返回值 对象接口．上移一层 （）

例程:

说明:

把当前对象的叠放层次上移一层。


下移一层 (对象接口)

下移一层 方法 操作系统支持：Windows 所属对象：对象接口

将当前选中对象下移一层。

语法： 无返回值 对象接口．下移一层 （）

例程:

说明:

把当前对象叠放层次下移一层，它对跟随文字的对象是无效的。


可否拆分单元格 方法 操作系统支持：Windows 所属对象：表格接口

等宽 方法 操作系统支持：Windows 所属对象：对象接口

对象等宽。

语法： 无返回值 对象接口．等宽 （）

例程:

说明:

设置当前选中的对象等高，必须选中不止一个。


等高 (对象接口)

等高 方法 操作系统支持：Windows 所属对象：对象接口

对象等高。

语法： 无返回值 对象接口．等高 （）

例程:

说明:

判断当前选中的对象可否等高，通过就让他们等高，必须选中不止一个。


等大小 (对象接口)

等大小 方法 操作系统支持：Windows 所属对象：对象接口

对象等大小。

语法： 无返回值 对象接口．等大小 （）

例程:

说明:

设置选中的一些的对象大小相等。


水平等距 (对象接口)

水平等距 方法 操作系统支持：Windows 所属对象：对象接口

对象水平等距（平均分布）。

语法： 无返回值 对象接口．水平等距 （）

例程:

说明:

让选中的一些对象水平等距。

参见: 例程


垂直等距 (对象接口)

垂直等距 方法 操作系统支持：Windows 所属对象：对象接口

对象垂直等距（平均分布）。

语法： 无返回值 对象接口．垂直等距 （）

例程:

说明:

对象接口执行垂直等距让被选中的对象。

参见: 例程


可否组合 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象“组合”操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否组合 （）

例程:

说明:

组合几个对象，如果有一个是跟随文字的，他就会复制一个再组合。


可否取消组合 (对象接口)

可否取消组合 方法 操作系统支持：Windows 所属对象：对象接口

如果当前可以进行对象“取消组合”操作，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否取消组合 （）

例程:

说明:

取消一个被组合的物体。


可否锁定当前对象 方法 操作系统支持：Windows 所属对象：对象接口

如果可以锁定当前选定，则返回真，否则返回假。

语法： 逻辑型 对象接口．可否锁定当前对象 （）

例程:

说明:

判断当前对象可否锁定，如果可以他就可以执行锁定当前对象的命令。


组合 方法 操作系统支持：Windows 所属对象：对象接口

组合对象。

语法： 无返回值 对象接口．组合 （）

例程:

说明:

组合几个对象，如果有一个是跟随文字的，他就会复制一个再组合。


取消组合 方法 操作系统支持：Windows 所属对象：对象接口

取消组合对象。

语法： 无返回值 对象接口．取消组合 （）

例程:

说明:

取消一个被组合的物体。


锁定对象 (对象接口)

锁定对象 方法 操作系统支持：Windows 所属对象：对象接口

锁定对象。

语法： 无返回值 对象接口．锁定对象 （对象名称，锁定类型）

参数名 | 描 述
对象名称 | 必需的；文本型。
锁定类型 | 必需的；整数型。0、不锁定； 1、位置锁定； 2、不允许编辑。

例程:

说明:

可以取得当前的对象的别名。对象如果被锁定之后的操作就只能设置他的内容。


锁定当前对象 方法 操作系统支持：Windows 所属对象：对象接口

锁定当前选中对象。

语法： 无返回值 对象接口．锁定当前对象 （是否锁定）

参数名 | 描 述
是否锁定 | 必需的；逻辑型。真，锁定；假，取消锁定。

例程:

说明:

执行锁定当前对象的命令。


绝对锁定当前对象 (对象接口)

绝对锁定当前对象 方法 操作系统支持：Windows 所属对象：对象接口

★注意，绝对锁定的对象不能解锁。

语法： 无返回值 对象接口．绝对锁定当前对象 （）

例程:

说明:

绝对锁定当前对象是要当前必须选择一个对象。

参见: 例程


选定对象 (对象接口)

选定对象 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．选定对象 （对象名称）

参数名 | 描 述
对象名称 | 必需的；文本型。

例程:

说明:

按名称找到这个对象选定他，如果名称相同取得的是第一个的。

参见: 例程


属性设置 (对象接口)

属性设置 方法 操作系统支持：Windows 所属对象：对象接口

打开“xx属性”对话框，设置当前选中对象的属性。

语法： 无返回值 对象接口．属性设置 （）

例程:

说明:

载入当前选中的对象的属性设置对话框。（如果选中不止一个，他会认首先选中的）

参见: 例程


取水印颜色 (对象接口)

取水印颜色 方法 操作系统支持：Windows 所属对象：对象接口

返回当前文档中绘画水印时所使用的颜色值。

语法： 整数型 对象接口．取水印颜色 （）

例程:

说明:

水印文字的颜色可以用户设置和取得。


置水印颜色 (对象接口)

置水印颜色 方法 操作系统支持：Windows 所属对象：对象接口

设置当前文档中绘画水印时所使用的颜色值。

语法： 无返回值 对象接口．置水印颜色 （颜色值）

参数名 | 描 述
颜色值 | 必需的；整数型。

例程:

说明:

水印文字的颜色可以用户设置和取得。


取水印字体 (对象接口)

取水印字体 方法 操作系统支持：Windows 所属对象：对象接口

返回当前文档中绘画水印时所使用的字体。

语法： 字体 对象接口．取水印字体 （）

例程:

说明:

水印的字体可以用户设置和取得。


置水印字体 (对象接口)

置水印字体 方法 操作系统支持：Windows 所属对象：对象接口

设置当前文档中绘画水印时所使用的字体。

语法： 无返回值 对象接口．置水印字体 （字体）

参数名 | 描 述
字体 | 必需的；字体。注意，本命令仅使用“字体”类型的最后两个成员。

例程:

说明:

水印的字体可以用户设置和取得。


取水印输出方向 (对象接口)

取水印输出方向 方法 操作系统支持：Windows 所属对象：对象接口

返回当前文档中的水印的输出方向，水平返回真，倾斜返回假。

语法： 逻辑型 对象接口．取水印输出方向 （）

例程:

说明:

水印可以有不同方向的排列。可以取得排列的方向。


置水印输出方向 (对象接口)

置水印输出方向 方法 操作系统支持：Windows 所属对象：对象接口

设置当前文档中的水印的输出方向。

语法： 逻辑型 对象接口．置水印输出方向 （是否水平输出）

参数名 | 描 述
是否水平输出 | 必需的；逻辑型。真，水平； 假，倾斜。

例程:

说明:

水印可以有不同方向的排列。可以取得排列的方向。


取水印文本 (对象接口)

取水印文本 方法 操作系统支持：Windows 所属对象：对象接口

返回当前文档中的水印的文本。

语法： 文本型 对象接口．取水印文本 （）

例程:

说明:

显示是一个水印的文本，他不是图像，也可取得他的文本。


置水印文本 (对象接口)

置水印文本 方法 操作系统支持：Windows 所属对象：对象接口

设置当前文档中的水印的文本。

语法： 无返回值 对象接口．置水印文本 （文本）

参数名 | 描 述
文本 | 必需的；文本型。

例程:

说明:

设置水印的文本。


取文本框文本 (对象接口)

取文本框文本 方法 操作系统支持：Windows 所属对象：对象接口

语法： 文本型 对象接口．取文本框文本 （文本框名称）

参数名 | 描 述
文本框名称 | 必需的；文本型。

例程:

说明:

取得某个文本框的文本。可以通过文本框的名称设置他的文本数据。


置文本框文本 (对象接口)

置文本框文本 方法 操作系统支持：Windows 所属对象：对象接口

语法： 逻辑型 对象接口．置文本框文本 （文本框名称，欲置的文本）

参数名 | 描 述
文本框名称 | 必需的；文本型。
欲置的文本 | 必需的；文本型。

例程:

说明:

取得某个文本框的文本。可以通过文本框的名称设置他的文本数据。


取方形印章文本 (对象接口)

取方形印章文本 方法 操作系统支持：Windows 所属对象：对象接口

语法： 文本型 对象接口．取方形印章文本 （印章名称）

参数名 | 描 述
印章名称 | 必需的；文本型。

例程:

说明:

放行印章几乎和文本框相同。他们的置取内容数据相同


置方形印章文本 (对象接口)

置方形印章文本 方法 操作系统支持：Windows 所属对象：对象接口

语法： 逻辑型 对象接口．置方形印章文本 （印章名称，印章文本）

参数名 | 描 述
印章名称 | 必需的；文本型。
印章文本 | 必需的；文本型。

例程:

说明:

放行印章几乎和文本框相同。他们的置取内容数据相同


取圆形印章编号 (对象接口)

取圆形印章编号 方法 操作系统支持：Windows 所属对象：对象接口

取得印章的唯一编号，可用于防伪。

语法： 整数型 对象接口．取圆形印章编号 （印章名称）

参数名 | 描 述
印章名称 | 必需的；文本型。

例程:

说明:

取得圆形印章的编号。(这是用户手动设置的)


取方形印章编号 (对象接口)

取方形印章编号 方法 操作系统支持：Windows 所属对象：对象接口

取得印章的唯一编号，可用于防伪。

语法： 整数型 对象接口．取方形印章编号 （印章名称）

参数名 | 描 述
印章名称 | 必需的；文本型。

例程:

说明:

取得方形印章的编号。(这个编号是系统指定的)

参见: 例程


取圆形印章密码 (对象接口)

取圆形印章密码 方法 操作系统支持：Windows 所属对象：对象接口

取得印章的密码，可用于防伪。

语法： 整数型 对象接口．取圆形印章密码 （印章名称）

参数名 | 描 述
印章名称 | 必需的；文本型。

例程:

说明:

程序创建时会有个程序名称需要，可以用户指定。工作表，表格，修订，页面，对象的操作需要知道组件的这些的接口，通过这个操作各个对象。

参见: 例程


取方形印章密码 (对象接口)

取方形印章密码 方法 操作系统支持：Windows 所属对象：对象接口

取得印章的密码，可用于防伪。

语法： 整数型 对象接口．取方形印章密码 （印章名称）

参数名 | 描 述
印章名称 | 必需的；文本型。

例程:

说明:

取得叫这个方形印章的密码，这个密码是对象的右键菜单设置的。

参见: 例程


画圆线 (对象接口)

画圆线 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．画圆线 （圆心横坐标，圆心纵坐标，半径，起始角度，结束角度，类型）

参数名 | 描 述
圆心横坐标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
圆心纵坐标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
半径 | 必需的；整数型。以0.1毫米为单位。
起始角度 | 必需的；整数型。以度（°）为单位。
结束角度 | 必需的；整数型。以度（°）为单位。
类型 | 必需的；整数型。0、画弧线；1、画扇形；2、画弧。

例程:

说明:

设置画圆弧命令的参数，之后命令画圆线。


画椭圆 (对象接口)

画椭圆 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．画椭圆 （左上角横坐标，左上角纵座标，右下角横座标，右下角纵座标）

参数名 | 描 述
左上角横坐标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
左上角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
右下角横座标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
右下角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。

例程:

说明:

画椭圆，他的左上和右下要被指定。


画矩形 (对象接口)

画矩形 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．画矩形 （左上角横坐标，左上角纵座标，右下角横座标，右下角纵座标）

参数名 | 描 述
左上角横坐标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
左上角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
右下角横座标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
右下角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。

例程:

说明:

绘画一个矩形的对象。


画圆角矩形 (对象接口)

画圆角矩形 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．画圆角矩形 （左上角横坐标，左上角纵座标，右下角横座标，右下角纵座标，圆角宽度，圆角高度）

参数名 | 描 述
左上角横坐标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
左上角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
右下角横座标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
右下角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
圆角宽度 | 必需的；整数型。
圆角高度 | 必需的；整数型。

例程:

说明:

画圆角矩形会格外指定他角的高度宽度。


画直线 (对象接口)

画直线 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．画直线 （起始点横坐标，起始点纵座标，结束点横座标，结束点纵座标）

参数名 | 描 述
起始点横坐标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
起始点纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
结束点横座标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
结束点纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。

例程:

说明:

和画椭圆一样根据左上角和右下角，定位出这个线的位置。


插入图片 (对象接口)

插入图片 方法 操作系统支持：Windows 所属对象：对象接口

语法： 无返回值 对象接口．插入图片 （左上角横座标，左上角纵座标，右下角横座标，右下角纵座标，图片文件名）

参数名 | 描 述
左上角横座标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
左上角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
右下角横座标 | 必需的；整数型。相当于页面左边，以0.1毫米为单位。
右下角纵座标 | 必需的；整数型。相当于页面顶边，以0.1毫米为单位。
图片文件名 | 必需的；文本型。全路径。

例程:

说明:

浏览打开文件，对象接口插入图像。（图片大的话会退出程序）


插入图表 (对象接口)

插入图表 方法 操作系统支持：Windows 所属对象：对象接口

使用该命令前，请先在表格中选中一个或多个包含数值数据的单元格，否则该命令将失败。

语法： 逻辑型 对象接口．插入图表 （左，顶，名称，值，分组，标题，类型，示例文字）

参数名 | 描 述
左 | 必需的；双精度小数型。
顶 | 必需的；双精度小数型。
名称 | 必需的；文本型。
值 | 必需的；文本型。
分组 | 必需的；整数型。
标题 | 必需的；文本型。
类型 | 必需的；整数型。
示例文字 | 必需的；文本型。

例程:

说明:

设置图表的各个属性，命令插入如果失败，信息框提示错误。


置图表类型 (对象接口)

置图表类型 方法 操作系统支持：Windows 所属对象：对象接口

设置指定图表的类型。

语法： 无返回值 对象接口．置图表类型 （图表名称，类型）

参数名 | 描 述
图表名称 | 必需的；文本型。
类型 | 必需的；图表类型。

例程:

说明:

设置某个图表的图标图表类型。


添加菜单项 (对象接口)

添加菜单项 方法 操作系统支持：Windows 所属对象：对象接口

向文本框或单元格的弹出菜单中添加一个菜单项。

语法： 逻辑型 对象接口．添加菜单项 （文本框或单元格的名称，菜单项文本）

参数名 | 描 述
文本框或单元格的名称 | 必需的；文本型。
菜单项文本 | 必需的；文本型。

例程:

说明:

添加菜单项是在文本框之类的编辑区的快捷写标题的菜单。


删除菜单项 (对象接口)

删除菜单项 方法 操作系统支持：Windows 所属对象：对象接口

删除文本框或单元格的弹出菜单中的一个菜单项。

语法： 逻辑型 对象接口．删除菜单项 （文本框或单元格的名称，欲删除的菜单项索引）

参数名 | 描 述
文本框或单元格的名称 | 必需的；文本型。
欲删除的菜单项索引 | 必需的；整数型。索引从1开始，自上而下依次递增。

例程:

说明:

删除弹出菜单中的一个菜单项。

参见: 例程


取菜单项目数 (对象接口)

取菜单项目数 方法 操作系统支持：Windows 所属对象：对象接口

取得某个文本框或单元格的弹出菜单的项目数。

语法： 整数型 对象接口．取菜单项目数 （文本框或单元格的名称）

参数名 | 描 述
文本框或单元格的名称 | 必需的；文本型。

例程:

说明:

取得弹出菜单的项目数。

参见: 例程


表格接口

表格接口 普通类型 操作系统支持：Windows 跳至：办公组件支持库

方法：

是否为空 | 是否为表格 | 取行数 | 取列数
取外观格式 | 置外观格式 | 取所在表格 | 外观格式设置
可否删除当前行 | 可否删除当前列 | 可否横向分割 | 可否纵向分割
可否向前插入行 | 可否向后插入行 | 可否向前插入列 | 可否向后插入列
可否横向合并 | 可否纵向合并 | 可否拆分单元格 | 可否合并单元格
可否各行等高 | 可否各列等宽 | 删除当前行 | 删除当前列
画表格线 | 擦除表格线 | 横向分割 | 纵向分割
横向合并 | 纵向合并 | 插入行 | 插入列
置行高 | 置列宽 | 各行等高 | 各列等宽
排序 | 拆分单元格 | 合并单元格 | 添加候选别名
删除所有别名 | 取所在行 | 取所在列 | 取单元格背景色
取单元格数值 | 取单元格文本 | 是否已锁定 | 取表格单元格文本
取单元格批注 | 取单元格纵向对齐方式 | 取已选择单元格数 | 取候选菜单文本
取单元格别名 | 插入批注 | 置当前单元格线形 | 置单元格字体
置单元格背景色 | 置单元格数值 | 置单元格文本 | 置单元格批注
置单元格文本颜色 | 置单元格图片 | 置单元格纵向对齐方式 | 置当前单元格横向对齐方式
置候选菜单文本 | 锁定单元格 | 锁定当前单元格 | 取单元格类型
置单元格类型 | 置光标位置 | 可否填充 | 填充
填充表格 | 输入公式 | 置单元格别名 | 置表格单元格文本

参见： 基本数据类型


是否为空 (表格接口)

是否为空 方法 操作系统支持：Windows 所属对象：表格接口

如果该接口为空（没有被赋值），返回真；否则返回假。注意，如果调用一个空接口的其他成员命令将引发运行时错误。

语法： 逻辑型 表格接口．是否为空 （）

例程:

说明:

如果取出该接口，在不空的情况向才可以操作它。

参见: 例程


是否为表格 (表格接口)

是否为表格 方法 操作系统支持：Windows 所属对象：表格接口

如果当前选中对象为表格，返回真；否则返回假。

语法： 逻辑型 表格接口．是否为表格 （）

例程:

说明:

判断被选中对象是不是表格。


取行数 (表格接口)

取行数 方法 操作系统支持：Windows 所属对象：表格接口

取一个表格的行数。

语法： 整数型 表格接口．取行数 （表格名称）

参数名 | 描 述
表格名称 | 必需的；文本型。

例程:

说明:

按名称取得一个表格的行数。


取列数 (表格接口)

取列数 方法 操作系统支持：Windows 所属对象：表格接口

取一个表格的列数。

语法： 整数型 表格接口．取列数 （表格名称）

参数名 | 描 述
表格名称 | 必需的；文本型。

例程:

说明:

按名称取得一个表格的列数。


取外观格式 (表格接口)

取外观格式 方法 操作系统支持：Windows 所属对象：表格接口

返回指定表格的外观格式。0 ~ 35。

语法： 整数型 表格接口．取外观格式 （表格名称）

参数名 | 描 述
表格名称 | 必需的；文本型。

例程:

说明:

按名称取得一个表格的外观格式，根据返回值得到相对的中文格式名称。


置外观格式 (表格接口)

置外观格式 方法 操作系统支持：Windows 所属对象：表格接口

设置指定表格的外观格式。

语法： 无返回值 表格接口．置外观格式 （表格名称，欲设置的格式）

参数名 | 描 述
表格名称 | 必需的；文本型。
欲设置的格式 | 必需的；整数型。0 ~ 35。

例程:

说明:

设置一种外观格式到指定名称的表格。


取所在表格 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格所在的表格的名称。

语法： 文本型 表格接口．取所在表格（表元名称）

参数名 | 描 述
表元名称 | 必需的；文本型。

例程:

说明:

按表元名称取得所在表格的名称。

参见:例程

©版权所有 大连大有吴涛易语言软件开发有限公司　　电话:86-0411-88995831 传真:86-0411-88995834


外观格式设置 (表格接口)

外观格式设置 方法 操作系统支持：Windows 所属对象：表格接口

语法： 无返回值 表格接口．外观格式设置 （）

例程:

说明:

设置一个被选中表格的外观格式。


可否删除当前行 (表格接口)

可否删除当前行 方法 操作系统支持：Windows 所属对象：表格接口

如果可以删除当前表格的当前行,返回真,否则返回假。

语法： 逻辑型 表格接口．可否删除当前行 （）

例程:

说明:

判断表格被选行是否可以被删除。


可否删除当前列 (表格接口)

可否删除当前列 方法 操作系统支持：Windows 所属对象：表格接口

如果可以删除当前表格的当前列,返回真,否则返回假。

语法： 逻辑型 表格接口．可否删除当前列 （）

例程:

说明:

判断表格被选列是否可以被删除。


可否横向分割 (表格接口)

可否横向分割 方法 操作系统支持：Windows 所属对象：表格接口

如果可以对当前选定表格进行横行分割,返回真,否则返回假。

语法： 逻辑型 表格接口．可否横向分割 （）

例程:

说明:

判断被选表元所在行的顶边是否可以将表格分割成两个独立的表格。


可否纵向分割 (表格接口)

可否纵向分割 方法 操作系统支持：Windows 所属对象：表格接口

如果可以对当前选定表格进行纵向分割,返回真,否则返回假。

语法： 逻辑型 表格接口．可否纵向分割 （）

例程:

说明:

判断被选表元所在列的左边是否可以将表格分割成两个独立的表格。


可否向前插入行 (表格接口)

可否向前插入行 方法 操作系统支持：Windows 所属对象：表格接口

如果可以在当前选定表格中向前插入表格行,则返回真,否则返回假。

语法： 逻辑型 表格接口．可否向前插入行 （）

例程:

说明:

判断被选行的上方是否可以被插入新行。


可否向后插入行 (表格接口)

可否向后插入行 方法 操作系统支持：Windows 所属对象：表格接口

如果可以在当前选定表格中向后插入表格行,则返回真,否则返回假。

语法： 逻辑型 表格接口．可否向后插入行 （）

例程:

说明:

判断被选行的下方是否可以被插入新行。


可否向前插入列 (表格接口)

可否向前插入列 方法 操作系统支持：Windows 所属对象：表格接口

如果可以在当前选定表格中向前插入表格列,则返回真,否则返回假。

语法： 逻辑型 表格接口．可否向前插入列 （）

例程:

说明:

判断被选列的左边是否可以被插入新列。


可否向后插入列 (表格接口)

可否向后插入列 方法 操作系统支持：Windows 所属对象：表格接口

如果可以在当前选定表格中向后插入表格列,则返回真,否则返回假。

语法： 逻辑型 表格接口．可否向后插入列 （）

例程:

说明:

判断被选列的右边是否可以插入新列。


可否横向合并 (表格接口)

可否横向合并 方法 操作系统支持：Windows 所属对象：表格接口

如果当前可以进行两个表格的横向合并操作,返回真,否则返回假。

语法： 逻辑型 表格接口．可否横向合并 （）

例程:

说明:

判断两个被选表格是否可以左右首尾相连进行合并。


可否纵向合并 (表格接口)

可否纵向合并 方法 操作系统支持：Windows 所属对象：表格接口

如果当前可以进行两个表格的纵向合并操作,返回真,否则返回假。

语法： 逻辑型 表格接口．可否纵向合并 （）

例程:

说明:

判断两个被选表格是否可以上下首尾相连进行合并。


可否拆分单元格 (表格接口)

可否拆分单元格 方法 操作系统支持：Windows 所属对象：表格接口

语法： 逻辑型 表格接口．可否拆分单元格 （）

例程:

说明:

判断被选单元格是否可以拆分，如果可以，就调用拆分命令进行拆分。


可否合并单元格 (表格接口)

可否合并单元格 方法 操作系统支持：Windows 所属对象：表格接口

语法： 逻辑型 表格接口．可否合并单元格 （）

例程:

说明:

判断两个或多个单元格是否可以被合并成一个单元格。


可否各行等高 (表格接口)

可否各行等高 方法 操作系统支持：Windows 所属对象：表格接口

如果当前可以进行表格各行等高操作,返回真,否则返回假。

语法： 逻辑型 表格接口．可否各行等高 （）

例程:

说明:

判断被选各行是否可以进行等高操作。


可否各列等宽 (表格接口)

可否各列等宽 方法 操作系统支持：Windows 所属对象：表格接口

如果当前可以进行表格各列等宽操作,返回真,否则返回假。

语法： 逻辑型 表格接口．可否各列等宽 （）

例程:

说明:

判断被选各列是否可以进行等宽操作。


删除当前行 (表格接口)

删除当前行 方法 操作系统支持：Windows 所属对象：表格接口

删除当前表格的当前行。

语法： 逻辑型 表格接口．删除当前行 （）

例程:

说明:

删除被选中的一行。


删除当前列 (表格接口)

删除当前列 方法 操作系统支持：Windows 所属对象：表格接口

删除当前表格的当前列。

语法： 逻辑型 表格接口．删除当前列 （）

例程:

说明:

删除被选中的一列。


画表格线 (表格接口)

画表格线 方法 操作系统支持：Windows 所属对象：表格接口

调用该方法后，鼠标指针会变成笔的形状，可以在当前表格中画表格线。

语法： 无返回值 表格接口．画表格线 （）

例程:

说明:

使用铅笔工具在单元格中画表格线。


擦除表格线 (表格接口)

擦除表格线 方法 操作系统支持：Windows 所属对象：表格接口

调用该方法后，鼠标指针会变成橡皮擦的形状，可以在当前表格中擦除表格线。

语法： 无返回值 表格接口．擦除表格线 （）

例程:

说明:

使用擦除工具擦除表格线。


横向分割 (表格接口)

横向分割 方法 操作系统支持：Windows 所属对象：表格接口

语法： 无返回值 表格接口．横向分割 （）

例程:

说明:

以被选单元格所在行的顶边，将表格分割成两个独立的表格。


纵向分割 (表格接口)

纵向分割 方法 操作系统支持：Windows 所属对象：表格接口

语法： 无返回值 表格接口．纵向分割 （）

例程:

说明:

以被选单元格所在列的左边，将表格分割成两个独立的表格。


横向合并 (表格接口)

横向合并 方法 操作系统支持：Windows 所属对象：表格接口

将当前选中的两个表格横行合并为一个表格。注：按Shift键来选定两个表格。

语法： 无返回值 表格接口．横向合并 （）

例程:

说明:

两个被选表格左右首尾相连合并。


纵向合并 (表格接口)

纵向合并 方法 操作系统支持：Windows 所属对象：表格接口

将当前选中的两个表格纵行合并为一个表格。注：按Shift键来选定两个表格。

语法： 无返回值 表格接口．纵向合并 （）

例程:

说明:

被选两个表格上下首尾相连合并。


插入行 (表格接口)

插入行 方法 操作系统支持：Windows 所属对象：表格接口

在当前表格中插入一行。

语法： 无返回值 表格接口．插入行 （［插入位置］）

参数名 | 描 述
插入位置 | 可选的；位置。可以为本支持库中“位置”枚举常量集合中的常量值之一。如果该参数省略，默认向后插入。*注意：常量“#位置.最后”在本命令中无效。

例程:

说明:

在指定位置处插入新的一行。


插入列 (表格接口)

插入列 方法 操作系统支持：Windows 所属对象：表格接口

在当前表格中插入一列。

语法： 无返回值 表格接口．插入列 （［插入位置］）

参数名 | 描 述
插入位置 | 可选的；位置。可以为本支持库中“位置”枚举常量集合中的常量值之一。如果该参数省略，默认向后插入。*注意：常量“#位置.最后”在本命令中无效。

例程:

说明:

在指定位置处插入新的一列。


置行高 (表格接口)

置行高 方法 操作系统支持：Windows 所属对象：表格接口

设置表格指定行的高度。

语法： 无返回值 表格接口．置行高 （表格名称，行号，行高）

参数名 | 描 述
表格名称 | 必需的；文本型。
行号 | 必需的；整数型。行号从1开始。
行高 | 必需的；整数型。以0.1毫米（mm）为单位。

例程:

说明:

根据表格名称设置指定行的高度。


置列宽 (表格接口)

置列宽 方法 操作系统支持：Windows 所属对象：表格接口

设置表格指定列的宽度。

语法： 无返回值 表格接口．置列宽 （表格名称，列号，列宽）

参数名 | 描 述
表格名称 | 必需的；文本型。
列号 | 必需的；整数型。列号从1开始。
列宽 | 必需的；整数型。以0.1毫米（mm）为单位。

例程:

说明:

根据表格名称设置指定列的宽度。


各行等高 (表格接口)

各行等高 方法 操作系统支持：Windows 所属对象：表格接口

使当前表格的各行等高。

语法： 无返回值 表格接口．各行等高 （）

例程:

说明:

设置一个被选表格的各行高度相等。


各列等宽 (表格接口)

各列等宽 方法 操作系统支持：Windows 所属对象：表格接口

使当前表格的各列等宽。

语法： 无返回值 表格接口．各列等宽 （）

例程:

说明:

设置一个被选表格的各列宽度相等。


排序 (表格接口)

排序 方法 操作系统支持：Windows 所属对象：表格接口

打开“排序”对话框对当前选中表格进行排序操作。

语法： 无返回值 表格接口．排序 （）

例程:

说明:

调用“排序”对话框进行排序。


拆分单元格 (表格接口)

拆分单元格 方法 操作系统支持：Windows 所属对象：表格接口

拆分选中的单元格。

语法： 无返回值 表格接口．拆分单元格 （）

例程:

说明:

将被选单元格拆分成多行和多列。


合并单元格 (表格接口)

合并单元格 方法 操作系统支持：Windows 所属对象：表格接口

合并选中的单元格。

语法： 无返回值 表格接口．合并单元格 （）

例程:

说明:

将被选中的两个或多个单元格合并成一个单元格。


添加候选别名 (表格接口)

添加候选别名 方法 操作系统支持：Windows 所属对象：表格接口

被添加的别名将会显示在单元格的“设置别名”对话框中的别名列表中。

语法： 无返回值 表格接口．添加候选别名 （欲添加的别名）

参数名 | 描 述
欲添加的别名 | 必需的；文本型。指定欲添加的别名，如“别名1”。可以一次添加多个别名，各个别名之间用“|”分割，比如“别名1|别名2|别名3”。

例程:

说明:

为被选单元格添加多个候选别名。


删除所有别名 (表格接口)

删除所有别名 方法 操作系统支持：Windows 所属对象：表格接口

删除所有单元格的别名。

语法： 无返回值 表格接口．删除所有别名 （）

例程:

说明:

删除同一工作表中所有表格的别名。


取所在行 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格在表格中的行号。行号从1开始，失败返回0。

语法： 整数型 表格接口．取所在行（单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称，取得其所在的行号。


取所在列 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格在表格中的列号。列号从1开始，失败返回0。

语法： 整数型 表格接口．取所在列（单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称，取得其所在的列号。


取单元格背景色 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格的背景色。

语法： 整数型 表格接口．取单元格背景色（单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

取得指定表格中指定单元格的背景颜色值。


取单元格数值 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格内的双精度数值。

语法： 双精度小数型 表格接口．取单元格数值 （单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称取得被设置过的数值。


取单元格文本 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格的文本内容。

语法： 文本型 表格接口．取单元格文本（单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

取得指定位置处单元格的文本内容。


取表格单元格文本 (表格接口)

取表格单元格文本 方法 操作系统支持：Windows 所属对象：表格接口

语法： 文本型 表格接口．取表格单元格文本 （表格名，行号，列号）

参数名 | 描 述
表格名 | 必需的；文本型。
行号 | 必需的；整数型。
列号 | 必需的；整数型。

例程:

说明:

根据表格名称取出指定位置单元格的文本内容。


取单元格批注 (表格接口)

取单元格批注 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格的批注。

语法： 文本型 表格接口．取单元格批注 （单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称取得设置过的批准内容。


取单元格纵向对齐方式 (表格接口)

取单元格纵向对齐方式 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格内文本的纵向对齐方式。0、顶对齐；1、居中；2、底对齐。

语法： 整数型 表格接口．取单元格纵向对齐方式 （单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称设置其内容的对齐方式。


取已选择单元格数 (表格接口)

取已选择单元格数 方法 操作系统支持：Windows 所属对象：表格接口

返回当前选中的单元格数目。

语法： 整数型 表格接口．取已选择单元格数 （）

例程:

说明:

取得被选中单元格的数量。


取候选菜单文本 (表格接口)

取候选菜单文本 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格的候选菜单文本。各个项目之间以“|”分割。

语法： 文本型 表格接口．取候选菜单文本 （单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称取得其中候选菜单的文本内容。


取单元格别名 (表格接口)

取单元格别名 方法 操作系统支持：Windows 所属对象：表格接口

返回指定单元格的别名。

语法： 文本型 表格接口．取单元格别名 （表格名称，行号，列号）

参数名 | 描 述
表格名称 | 必需的；文本型。单元格所在的表格名称。
行号 | 必需的；整数型。单元格所在的行。
列号 | 必需的；整数型。单元格所在的列。

例程:

说明:

根据指定的表格名称取出指定位置处的单元格的名称。


插入批注 (表格接口)

插入批注 方法 操作系统支持：Windows 所属对象：表格接口

打开“单元格批注”对话框插入批注。

语法： 无返回值 表格接口．插入批注 （）

例程:

说明:

设置被选中单元格的批注内容。


置当前单元格线形 (表格接口)

置当前单元格线形 方法 操作系统支持：Windows 所属对象：表格接口

设置当前单元格线条类型。

语法： 无返回值 表格接口．置当前单元格线形 （线条类型）

参数名 | 描 述
线条类型 | 必需的；整数型。可以为0 ~ 14的任何一个整数。

例程:

说明:

设置被选中单元格外框的线条样式。


置单元格字体 (表格接口)

置单元格字体 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的字体。

语法： 无返回值 表格接口．置单元格字体 （单元格别名，字体）

参数名 | 描 述
单元格别名 | 必需的；文本型。
字体 | 必需的；字体。

例程:

说明:

根据单元格名称为其文本内容设置字体。


置单元格背景色 (表格接口)

置单元格背景色 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的背景色。

语法： 逻辑型 表格接口．置单元格背景色 （单元格别名，颜色值）

参数名 | 描 述
单元格别名 | 必需的；文本型。
颜色值 | 必需的；整数型。

例程:

说明:

根据单元格名称为其设置背景颜色。


置单元格数值 (表格接口)

置单元格数值 方法 操作系统支持：Windows 所属对象：表格接口

以数值的形式设置指定单元格的内容。

语法： 无返回值 表格接口．置单元格数值 （单元格别名，数值）

参数名 | 描 述
单元格别名 | 必需的；文本型。
数值 | 必需的；双精度小数型。

例程:

说明:

按单元格名称为其设置数值，并取出刚设置过的数值。


置单元格文本 (表格接口)

置单元格文本 方法 操作系统支持：Windows 所属对象：表格接口

以文本的形式设置指定单元格的内容。

语法： 无返回值 表格接口．置单元格文本 （单元格别名，文本）

参数名 | 描 述
单元格别名 | 必需的；文本型。
文本 | 必需的；文本型。

例程:

说明:

根据单元格名称设置其文本内容。


置单元格批注 (表格接口)

置单元格批注 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的批注文本。

语法： 逻辑型 表格接口．置单元格批注 （单元格别名，批注文本）

参数名 | 描 述
单元格别名 | 必需的；文本型。
批注文本 | 必需的；文本型。

例程:

说明:

根据单元格名称为其设置批注内容。


置单元格文本颜色 (表格接口)

置单元格文本颜色 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的文本颜色。

语法： 逻辑型 表格接口．置单元格文本颜色 （单元格别名，文本颜色）

参数名 | 描 述
单元格别名 | 必需的；文本型。
文本颜色 | 必需的；整数型。

例程:

说明:

根据单元格名称为其设置文本内容的颜色。


置单元格图片 (表格接口)

置单元格图片 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的图片。

语法： 无返回值 表格接口．置单元格图片 （单元格别名，图片文件全路径，图片显示类型）

参数名 | 描 述
单元格别名 | 必需的；文本型。
图片文件全路径 | 必需的；文本型。

例程:

说明:

使用“通用对话框”选择指定的图片文件到指定表格的指定单元格中。


置单元格纵向对齐方式 (表格接口)

置单元格纵向对齐方式 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的纵向对齐方式。

语法： 逻辑型 表格接口．置单元格纵向对齐方式 （［单元格别名］，对齐方式）

参数名 | 描 述
单元格别名 | 可选的；文本型。如果此参数省略，则设置当前单元格的纵向对齐方式。
对齐方式 | 必需的；整数型。可以为以下常数之一：0、顶对齐；1、居中；2、底对齐。

例程:

说明:

使用随机的方法取得数值，并将相对的文本对齐方式设置到指定的单元格中。


置当前单元格横向对齐方式 (表格接口)

置当前单元格横向对齐方式 方法 操作系统支持：Windows 所属对象：表格接口

设置指定单元格的横向对齐方式。

语法： 无返回值 表格接口．置当前单元格横向对齐方式 （对齐方式）

参数名 | 描 述
对齐方式 | 必需的；整数型。可以为以下常数之一：0、左对齐；1、居中对齐；2、右对齐；3、匀齐；4、全匀齐。

例程:

说明:

设置被选单元格中内容的横向对齐方式。


置候选菜单文本 (表格接口)

置候选菜单文本 方法 操作系统支持：Windows 所属对象：表格接口

向单元格候选菜单添加文本项目。

语法： 逻辑型 表格接口．置候选菜单文本 （单元格别名，文本）

参数名 | 描 述
单元格别名 | 必需的；文本型。
文本 | 必需的；文本型。指定欲添加的文本，如“项目1”。可以一次添加多个别名，各个别名之间用“|”分割，比如“项目1|项目2|项目3”。

例程:

说明:

根据单元格名称设置其候选菜单中的文本内容。


锁定单元格 (表格接口)

锁定单元格 方法 操作系统支持：Windows 所属对象：表格接口

语法： 逻辑型 表格接口．锁定单元格 （单元格名称，是否锁定）

参数名 | 描 述
单元格名称 | 必需的；文本型。
是否锁定 | 必需的；逻辑型。真，锁定；假，解锁。

例程:

说明:

按名称锁定或解锁单元格。


锁定当前单元格 (表格接口)

锁定当前单元格 方法 操作系统支持：Windows 所属对象：表格接口

锁定或解锁当前单元格。

语法： 无返回值 表格接口．锁定当前单元格 （是否锁定）

参数名 | 描 述
是否锁定 | 必需的；逻辑型。真，锁定； 假，解锁。

例程:

说明:

根据参数的设置，锁定或解锁被选单元格。


取单元格类型 (表格接口)

取单元格类型 方法 操作系统支持：Windows 所属对象：表格接口

返回指定的单元格的类型。返回值可以为以下常数：0、文本：可输入和文本；2、选择框；3、单选框。

语法： 整数型 表格接口．取单元格类型 （单元格别名）

参数名 | 描 述
单元格别名 | 必需的；文本型。

例程:

说明:

根据单元格名称取得其功能的常量的值。


置单元格类型 (表格接口)

置单元格类型 方法 操作系统支持：Windows 所属对象：表格接口

设置指定的单元格的类型。

语法： 无返回值 表格接口．置单元格类型 （单元格别名，类型）

参数名 | 描 述
单元格别名 | 必需的；文本型。
类型 | 必需的；整数型。0、文本：可输入和文本；2、选择框；3、单选框。

例程:

说明:

根据单元格的名称设置其不同的功能类型。


置光标位置 (表格接口)

置光标位置 方法 操作系统支持：Windows 所属对象：表格接口

设置光标到指定表格的指定行、列。

语法： 无返回值 表格接口．置光标位置 （表格名称，行号，列号）

参数名 | 描 述
表格名称 | 必需的；文本型。
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程:

说明:

设置光标到当前被选表格的第三行的第三列的单元格处。


可否填充 方法 操作系统支持：Windows 所属对象：表格接口

如果当前可以进行单元格填充，则返回真，否则返回假。

语法： 逻辑型 表格接口．可否填充（）

例程:

说明:

判断被选单元格是否可以填充。


是否已锁定 方法 操作系统支持：Windows 所属对象：表格接口

如果当前选定对象已经被锁定，返回真，否则返回假。

语法： 逻辑型 表格接口．是否已锁定（）

例程:

说明:

判断被选表格是否被锁定。


填充 方法 操作系统支持：Windows 所属对象：表格接口

对当前选中单元格进行填充。

语法： 无返回值 表格接口．填充（填充类型）

参数名 | 描 述
填充类型 | 必需的；填充类型。可以为“填充类型”枚举常量集合中的常量之一。

例程:

说明:

设置被选中单元格的填充类型。


填充表格 (表格接口)

填充表格 方法 操作系统支持：Windows 所属对象：表格接口

打开“填充序列”对话框对当前选中单元格进行填充。

语法： 无返回值 表格接口．填充表格 （）

例程:

说明:

填充被选单元格。


输入公式 (表格接口)

输入公式 方法 操作系统支持：Windows 所属对象：表格接口

打开“单元格公式输入”窗口输入单元格公式。

语法： 无返回值 表格接口．输入公式 （）

例程:

说明:

为选中的单元格设置显示数据的公式。


置单元格别名 方法 操作系统支持：Windows 所属对象：表格接口

设置指定表格中指定单元格的别名。成功返回真，失败返回假。

语法： 逻辑型 表格接口．置单元格别名 （所在表格别名，行号，列号，单元格别名）

参数名 | 描 述
所在表格别名 | 必需的；文本型。
行号 | 必需的；整数型。单元格所在的行。从1开始。
列号 | 必需的；整数型。单元格所在的列。从1开始。
单元格别名 | 必需的；文本型。欲置的别名。

例程:

说明:

设置单元格的别名。


置表格单元格文本 方法 操作系统支持：Windows 所属对象：表格接口

设置指定表格中指定单元格的文本。

语法： 无返回值 表格接口．置表格单元格文本 （所在表格别名，行号，列号，单元格文本）

参数名 | 描 述
所在表格别名 | 必需的；文本型。
行号 | 必需的；整数型。单元格所在的行。从1开始。
列号 | 必需的；整数型。单元格所在的列。从1开始。
单元格文本 | 必需的；文本型。欲置的文本。

例程:

说明:

设置单元格的内容。


修订接口

修订接口 普通类型 操作系统支持：Windows 跳至：办公组件支持库

方法：

是否为空 | 取修订状态 | 置修订状态 | 取插入修订色
置插入修订色 | 取删除修订色 | 置删除修订色 | 向后查找
向前查找 | 接受 | 接受所有 | 拒绝
拒绝所有 | 显示对话框 |  |

参见： 基本数据类型


是否为空 (修订接口)

是否为空 方法 操作系统支持：Windows 所属对象：修订接口

如果该接口为空（没有被赋值），返回真；否则返回假。注意，如果调用一个空接口的其他成员命令将引发运行时错误。

语法： 逻辑型 修订接口．是否为空 （）

例程:

说明:

如果取出该接口，在不空的情况向才可以操作他。

参见: 例程


取修订状态 方法 操作系统支持：Windows 所属对象：修订接口

如果当前处于修订状态，返回真，否则返回假。

语法： 逻辑型 修订接口．取修订状态 （）

例程

说明：

判断当前的修订状态。

参见：例程


置修订状态 方法 操作系统支持：Windows 所属对象：修订接口

语法： 无返回值 修订接口．置修订状态 （是否置为修订状态）

参数名 | 描 述
是否置为修订状态 | 必需的；逻辑型。

例程

说明：

设置当前的修订状态。

参见：例程


取插入修订色 方法 操作系统支持：Windows 所属对象：修订接口

返回指定用户修订状态下插入的文本的颜色。

语法： 整数型 修订接口．取插入修订色 （用户名）

参数名 | 描 述
用户名 | 必需的；文本型。

例程

说明：

获取指定的用户在插入修订时文本的颜色。

参见：例程


置删除修订色 方法 操作系统支持：Windows 所属对象：修订接口

置插入修订色 方法 操作系统支持：Windows 所属对象：修订接口

设置指定用户在修订状态下插入的文本的颜色。

语法： 无返回值 修订接口．置删除修订色 （用户名，文字颜色）

参数名 | 描 述
用户名 | 必需的；文本型。
文字颜色 | 必需的；整数型。

例程

说明：

设置指定用户在修订状态下插入的文本的颜色。

参见：例程


取删除修订色 方法 操作系统支持：Windows 所属对象：修订接口

返回指定用户修订状态下标记为已删除的文本的颜色。

语法： 整数型 修订接口．取删除修订色 （用户名）

参数名 | 描 述
用户名 | 必需的；文本型。

例程

说明：

获取指定用户在修订状态下做删除标记的文本的颜色。

参见：例程


置删除修订色 方法 操作系统支持：Windows 所属对象：修订接口

设置指定用户在修订状态下标记为已删除的文本的颜色。

语法： 无返回值 修订接口．置删除修订色 （用户名，文字颜色）

参数名 | 描 述
用户名 | 必需的；文本型。
文字颜色 | 必需的；整数型。

例程

说明：

设置指定的用户在做删除标记时被删除的文本的颜色。

参见：例程


向后查找 方法 操作系统支持：Windows 所属对象：修订接口

向后查找下一处修订。

语法： 无返回值 修订接口．向后查找 （）

例程

说明：

从当前光标处向后查找下一处修订。

参见：例程


向前查找 方法 操作系统支持：Windows 所属对象：修订接口

向前查找下一处修订。

语法： 无返回值 修订接口．向前查找 （）

例程

说明：

从当前光标处向前查找下一处修订。

参见：例程


接受 方法 操作系统支持：Windows 所属对象：修订接口

接受当前修订。

语法： 无返回值 修订接口．接受 （）

例程

说明：

接受当前选择的修订。如果当前选择的是插入修订，那么插入的文本将设置为正式的文件内容；如果当前选择的是删除修订，那么做删除标记的文本将被删除。

参见：例程


接受所有 方法 操作系统支持：Windows 所属对象：修订接口

接受所有修订。

语法： 无返回值 修订接口．接受所有 （）

例程

说明：

接受当前文件内容中的所有修订。那么所有插入的文本将设置为正式的文件内容；所有做了删除标记的文本将被删除。

参见：例程


拒绝 方法 操作系统支持：Windows 所属对象：修订接口

拒绝当前修订。

语法： 无返回值 修订接口．拒绝 （）

例程

说明：

拒绝当前选择的修订。如果当前选择的是插入修订，那么插入的文本将被删除；如果当前选择的是删除修订，那么做删除标记的文本将被恢复。

参见：例程


拒绝所有 方法 操作系统支持：Windows 所属对象：修订接口

拒绝所有修订。

语法： 无返回值 修订接口．拒绝所有 （）

例程

说明：

拒绝所有的修订。那么所有插入的文本将被删除；所有做删除标记的文本将被恢复。

参见：例程


显示对话框 方法 操作系统支持：Windows 所属对象：修订接口

显示“接受或拒绝修订”对话框。

语法： 无返回值 修订接口．显示对话框 （）

例程

说明：

显示“接受或拒绝修订”对话框。

参见：例程


页面边距

页面边距 普通类型 操作系统支持：Windows 跳至：办公组件支持库

参看“办公组件”的“取页边距”和“置页边距”成员命令。

成员 | 描 述
左边距 | 整数型；以0.1毫米为单位。
上边距 | 整数型；以0.1毫米为单位。
右边距 | 整数型；以0.1毫米为单位。
下边距 | 整数型；以0.1毫米为单位。

参见： 基本数据类型


中文字号

中文字号 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

成员 | 描 述
初号 | 常量值为 42 。
小初 | 常量值为 36 。
一号 | 常量值为 26 。
小一 | 常量值为 24 。
二号 | 常量值为 22 。
小二 | 常量值为 18 。
三号 | 常量值为 16 。
小三 | 常量值为 15 。
四号 | 常量值为 14 。
小四 | 常量值为 12 。
五号 | 常量值为 11 。
小五 | 常量值为 9 。
六号 | 常量值为 8 。
小六 | 常量值为 7 。
七号 | 常量值为 6 。
八号 | 常量值为 5 。

参见： 基本数据类型


位置

位置 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

参看“工作表接口”的“新建”和“粘贴”成员命令。

成员 | 描 述
最后 | 常量值为 0 。所有现有项目之后。
之后 | 常量值为 2 。当前项目项目之后。

参见： 基本数据类型


对象种类

对象种类 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

参看“对象接口”的“插入对象”成员命令。

成员 | 描 述
圆 | 常量值为 1 。
圆型印章 | 常量值为 2 。
圆锥 | 常量值为 3 。
曲线 | 常量值为 4 。
折线 | 常量值为 5 。
十字多边形 | 常量值为 6 。
立方体 | 常量值为 7 。
圆柱 | 常量值为 8 。
椭圆 | 常量值为 9 。
四角星 | 常量值为 10 。
图片 | 常量值为 11 。打开对话框，插入一图片对象。
直线 | 常量值为 12 。
五角星 | 常量值为 13 。
多边形 | 常量值为 14 。
正多边形 | 常量值为 15 。
棱锥 | 常量值为 16 。
矩形 | 常量值为 17 。
方形印章 | 常量值为 18 。
旋转字 | 常量值为 19 。
圆角矩形 | 常量值为 20 。
表格 | 常量值为 21 。
文字圆 | 常量值为 22 。
文本框 | 常量值为 23 。
水印 | 常量值为 24 。
图表 | 常量值为 25 。
OLE对象 | 常量值为 26 。

参见： 基本数据类型


文本位置

文本位置 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

参看“办公组件”的“插入文本”成员命令。

成员 | 描 述
最前 | 常量值为 0 。现有文字之前。
最后 | 常量值为 1 。现有文字之后。
当前位置 | 常量值为 2 。当前光标位置。

参见： 基本数据类型


文字类型

文字类型 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

参看“办公组件”的“取文字类型”和“置文字类型”成员命令。

成员 | 描 述
正常 | 常量值为 0 。
上标 | 常量值为 1 。
下标 | 常量值为 2 。

参见： 基本数据类型


横向对齐

横向对齐 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

成员 | 描 述
左对齐 | 常量值为 0 。
居中 | 常量值为 1 。
右对齐 | 常量值为 2 。
均齐 | 常量值为 3 。
全均齐 | 常量值为 4 。

参见： 基本数据类型


纵向对齐

纵向对齐 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

成员 | 描 述
顶边对齐 | 常量值为 0 。
居中 | 常量值为 1 。
底边对齐 | 常量值为 2 。

参见： 基本数据类型


图表类型

图表类型 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

参看“办公组件”的“置图表类型”成员命令。

成员 | 描 述
三维柱型 | 常量值为 0 。
柱型 | 常量值为 1 。
圆柱型 | 常量值为 2 。
棱锥型 | 常量值为 3 。
圆锥型 | 常量值为 4 。
折线型 | 常量值为 5 。
散点型 | 常量值为 6 。

参见： 基本数据类型


填充类型

填充类型 枚举常量集合类型 操作系统支持：Windows 跳至：办公组件支持库

参看“表格接口”的“填充”成员命令。

成员 | 描 述
自动 | 常量值为 0 。
复制 | 常量值为 1 。
等差 | 常量值为 2 。
等比 | 常量值为 3 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。

参见：例程