WORD2000支持库

WORD2000支持库 帮助手册20080807版 返回支持库手册 返回首页

本库用来操作Microsoft WORD 2000/XP/2003或以上版本,您的机器中必须装有WORD本支持库的设计目标是针对常用及简单的Word操作,如果您想使用更多的Word操作功能,请使用易语言3.7所提供的"对象"与本支持库交互操作,本支持库的各对象与核心支持库中的"对象"完全兼容。

操作系统支持： Windows

窗口组件数据类型：

Word程序

Word文档集

Word图形

其它数据类型：

度量单位

例程名称 | 下载 | 说明
Word2000例程 | Word2000例程.rar | 本程序演示了Word2000支持库的使用方法。
Word2000例程 | Word2000.e | 本程序演示了Word2000支持库的使用方法。

适用版本，WORD2000支持库 （1.1#1版）


Word程序

Word程序 功能型窗口组件 操作系统支持：Windows 跳至：WORD2000支持库

本对象用来创建并操作Word程序。

属性：

左 | 顶 | 宽 | 高
窗口标题 | 窗口状态 | 显示 | 版本
打印机 | 全屏显示 | 显示比例 | 网格线
是否已创建 |  |  |

方法：

创建 | 释放 | 取程序对象 | 退出
激活窗口 |  |  |

自有事件：

文档即将关闭 | 文档即将打印 | 文档即将保存 | 文档打开
新文档 | 退出 |  |


左 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；以磅为单位返回或设置Word程序窗口的左坐标。

例程

说明

本属性用与取出和设置使用Word程序创建的Word的左边。在所关联的Word最大化和最小化时无效。

参考：例程1


顶 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；以磅为单位返回或设置Word程序窗口的顶坐标。

例程

说明

本属性用于取得和设置使用Word程序所创建的Word距离屏幕顶边的距离，相当与窗口的顶边属性。本属性在Word最小化和最大化时无效。


宽 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；以磅为单位返回或设置Word程序窗口的宽度。

例程

说明

本属性用于取得和设置使用Word程序所创建的Word窗口的宽度。当Word窗口的状态是最大化和最小化时，设置本属性无效。


高 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；以磅为单位返回或设置Word程序窗口的高度。

例程

说明

本属性用于取得和设置使用Word程序所创建的Word窗口的高度。当Word窗口状态为最大化和最小化时设置本属性无效。


窗口标题 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：文本型；设计时不可用；Word程序窗口的标题。

例程

说明

本属性用于取得和设置使用Word程序所创建的Word窗口的标题。


窗口状态 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；Word程序窗口的状态，为以下常量之一：0、#正常；1、#最大化；2、最小化；。

例程

说明

本属性用于取得和设置使用Word程序创建的Word窗口的状态。


显示 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；Word程序窗口的可见，相当于可视(Visible)。

例程

说明

本属性用于显示和隐藏使用Word程序创建的Word窗口。当使用Word程序创建窗口后，须使用本属性将其显示。


版本 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：文本型；只读；Word程序的版本。

例程

说明

本属性用于取出所安装的Word的版本号。


打印机 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：文本型；设计时不可用；活动打印机名称。

例程

说明

本属性用于取得和设置使用Word程序创建的Word的默认打印机。在使用打印命令前最好使用本属性确定一下当前打印机。


全屏显示 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；窗口的全屏显示。

例程

说明

本属性用于取得和设置使用Word程序所创建的Word窗口是否全屏显示。


显示比例 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；显示对象大小的变化范围,100为正常,200为2倍大小。

例程

说明

本属性用于取得和更改word文档的显示比例，显示比例修改时，word文档的窗口大小不会变化，只是内部版面放大，放大率按照百分比计算，即100为100%（原始大小），200为200%（两倍大小），数值越大放大比率越大。在Word中按住Ctrl然后滚动鼠标滚轮可以快速设置本属性。


网格线 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；如果此值为真，则 Microsoft Word 将显示文档网格。

例程

说明

本属性用于取得和设置使用Word程序所创建的Word窗口内是否有网格线。

注意，当Word中没有文档时，设置此属性没有效果。


是否已创建 属性 所属对象：Word程序 操作系统支持：Windows

数据类型：逻辑型；只读；检查本对象是否已经创建。

例程

说明

本属性用于判断Word程序是否已经创建Word窗口。


创建 方法 操作系统支持：Windows 所属对象：Word程序

创建Word程序对象，本对象原有内容将被释放。成功返回真，否则返回假。注意：在本支持库的任何操作前，必须要先使用本方法创建。

语法： 逻辑型 Word 程序．创建 （）

例程

说明

通过“创建”命令启动Word并创建一个名为WINWORD的进程。将Word程序与Word关联，但这时的Word是隐藏的，要想显示打开的Word需要将Word程序的显示属性设为“真”。


释放 方法 操作系统支持：Windows 所属对象：Word程序

将本对象释放。再次使用的时候需再次使用“创建”方法。

语法： 无返回值 Word 程序．释放 （）

例程

说明

通过“释放”命令断开与Word之间的关联。这样会释放先前与Word之间的联系所占用的内存，但使用这条命令不会退出程序所创建的WORD。


取程序对象 方法 操作系统支持：Windows 所属对象：Word程序

获取Word提供的Application对象，与3.7版的“对象”兼容。

语法： 对象 Word 程序．取程序对象 （）

例程

说明

通过“取程序对象”命令将“Word程序”的对象保存在“对象”变量中。


退出 方法 操作系统支持：Windows 所属对象：Word程序

退出 Word。

语法： 无返回值 Word 程序．退出 （）

例程

说明

通过“退出”命令关闭“Word程序”所关联的Word。在使用退出命令之后，所有本程序启动的word程序都将被关闭，但是通过其他方式运行的word程序不会被关闭。


激活窗口 方法 操作系统支持：Windows 所属对象：Word程序

激活Word程序的窗口。

语法： 无返回值 Word 程序．激活窗口 （）

例程

说明

通过“激活窗口”命令来激活“Word程序”所关联的Word。


文档即将关闭 事件 所属对象：Word程序 操作系统支持：Windows

该事件在打开的文档关闭之前发生。

语法： 无返回值 _Word 程序_文档即将关闭 （要关闭的文档对象，取消）

参数名 | 描 述
要关闭的文档对象 | 对象；提供Word的Document对象，与3.7版的"对象"兼容。
取消 | 逻辑型；传址；如果事件处理程序将该参数设为 真，则过程完成后文档不会关闭。

例程

说明

在文档即将关闭时，显示一个信息框。本事件在Word程序所关联的Word中有文档退出时会触发。


文档即将打印 事件 所属对象：Word程序 操作系统支持：Windows

该事件在打开的文档打印之前发生。

语法： 无返回值 _Word 程序_文档即将打印 （要打印的文档对象，取消）

参数名 | 描 述
要打印的文档对象 | 对象；提供Word的Document对象,与3.7版的"对象"兼容。
取消 | 逻辑型；传址；如果事件处理程序将该参数设为真，则过程完成后文档不会打印。

例程

说明

在文档即将打印时，显示一个信息框。当在使用Word程序创建的Word里即将打印和在易语言中调用打印命令时，会触发此事件。


文档即将保存 事件 所属对象：Word程序 操作系统支持：Windows

该事件在打开的文档保存之前发生。

语法： 无返回值 _Word 程序_文档即将保存 （要保存的文档对象，取消）

参数名 | 描 述
要保存的文档对象 | 对象；提供Word的Document对象,与3.7版的"对象"兼容。
取消 | 逻辑型；传址；如果事件处理程序将该参数设为真，则过程完成后文档不会保存。

例程

说明

在文档即将保存时，显示一个信息框。当在使用Word程序创建的Word中要保存时会触发此事件。


文档打开 事件 所属对象：Word程序 操作系统支持：Windows

该事件在文档打开时发生。

语法： 无返回值 _Word 程序_文档打开 （打开的文档对象）

参数名 | 描 述
打开的文档对象 | 对象；提供Word的Document对象,与3.7版的"对象"兼容。

例程

说明

在文档打开时，显示一个信息框。当在Word程序所创建的Word中打开了一个Word文档时会触发此事件。


新文档 事件 所属对象：Word程序 操作系统支持：Windows

该事件在创建新文档时发生。

语法： 无返回值 _Word 程序_新文档 （新建的文档对象）

参数名 | 描 述
新建的文档对象 | 对象；提供Word的Document对象,与3.7版的"对象"兼容。

例程

说明

在创建新文档是显示一个信息框。当在Word程序所创建的Word中添加新文档时，会触发此事件。


退出 事件 所属对象：Word程序 操作系统支持：Windows

该事件在用户退出 Word 时发生。

语法： 无返回值 _Word 程序_退出 （）

例程

说明

在“Word程序”所关联的Word退出时，显示一个信息框。当在Word程序所创建的Word要关闭时，会触发此事件。


Word文档集

Word文档集 功能型窗口组件 操作系统支持：Windows 跳至：WORD2000支持库

本对象用来操作Word文档集、Word文档及Word选定。

属性：

文档数量 | 文档索引 | 内容 | 内容总长度
首选定 | 尾选定 | 字体 | 大写格式
字体动态效果 | 字体加粗 | 字体颜色 | 双删除线
着重号 | 阳文 | 阴文 | 字体隐藏
倾斜 | 最小字号 | 字体名 | 字体大小
东亚字体名 | 空心 | 文字位置 | 字体缩放比
阴影 | 小写字母 | 字符间距 | 删除线
下标 | 上标 | 下划线 | 下划线颜色
对齐方式 | 页面设置 | 下页边距 | 行字符数
首页送纸盒 | 其他页送纸盒 | 页脚距离 | 额外页边距
装订线位置 | 装订线风格 | 页眉距离 | 版式模式
左边界距离 | 右边界距离 | 顶边界距离 | 页行数
页面方向 | 页高 | 页宽 | 纸张大小
阅读顺序 | 分节符类型 | 打印两页 | 垂直对齐方式

方法：

置程序 | 释放 | 运行宏 | 取文档集对象
取文档对象 | 取选择区对象 | 添加文档 | 打开
保存 | 打印预览 | 关闭打印预览 | 打印
输入文本 | 全选 | 转到 | 左移
右移 | 上移 | 下移 | 关闭


文档数量 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；只读；文档集中文档的数量。

例程

说明

本属性用于判断Word文档集中所包含的文档数量。


文档索引 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型： 整数型 本属性在设计时不可用，在运行时可读可写。

例程

说明

文档在文档集中的索引，注意：不可读，只可写；如果想操作多个文档，请使用多个文档集控件。


内容 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：文本型；设计时不可用；当前选定区的内容。

例程

说明

本属性用于取得和更改Word文档集所关联的Word文档中以选中的内容。


内容总长度 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；只读；选定区内容的总长度。

例程

说明

本属性用于判断Word文档集所关联的Word文档中已被选中的内容的长度。


首选定 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；选定区起始字符的位置。

例程

说明

本属性用于取得和更改Word文档集所关联的文档内已选中的内容的第一个选择位置。


尾选定 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；选定区结束字符的位置。

例程

说明

本属性用于取得和设置Word文档集所关联的文档中已选中内容的最后一个选择位置。


字体 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。

字体类包括以下属性：

字体动态效果 | 字体加粗 | 字体颜色 | 双删除线
着重号 | 阳文 | 阴文 | 字体隐藏
倾斜 | 最小字号 | 字体名 | 字体大小
东亚字体名 | 空心 | 文字位置 | 字体缩放比
阴影 | 小写字母 | 字符间距 | 删除线
下标 | 上标 | 下划线 | 下划线颜色
大写格式 |  |  |

说明

此属性只是作归类用途，没有实际用途。


大写格式 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；如果为真，则字体设置为全部大写字母格式。返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中所选中的内容设为大写。本属性与Word中字体的全部大写字母相对应。


字体动态效果 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；应用于字体的动态效果，为以下 WdAnimation 常量之一：0、#无效果；1、#拉斯维加斯灯光；2、#闪烁背景；3、#火花文本；4、#黑蚂蚁；5、#红蚂蚁；6、#闪光；。

例程

说明

将“Word文档集”所关联的Word文档中的已选中的内容加上动态效果。本属性与Word中效果对应如下：没有效果=0、赤水深情=5、礼花绽放=3、七彩霓红=1、闪烁背景=2、乌龙绞柱=4、亦真亦幻=6。


字体加粗 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；设置字体或范围的格式为加粗格式，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中的被选中的内容加粗。本属性与Word中字体里的加粗选项对应。


字体颜色 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；24 位RGB颜色。

例程

说明

将“Word文档集“所关联的Word稳当中的字体颜色设为“字体颜色选择器“的颜色。本属性与Word中字体里的字体颜色对应。


双删除线 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体是否使用双删除线格式，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集“所关联的Word文档中的已选中的内容加上双删除线。本属性与Word中字体里双删除线选项对应。


着重号 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字符或指定的字符串的着重号。可取下列 WdEmphasisMark(参阅Word开发文档)常量之一：0、#无；1、#圆圈；2、#逗点；3、#顶圆圈；4、#底圆圈；。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容加上着重号。本属性与Word中字体里的着重号选项对应。


阳文 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定字体的格式设为阳文，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中的已选中的内容设为阳文效果。本属性与Word中字体里阳文选项对应。


阴文 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体的格式是否为阴文，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容设为阴文效果。本属性与Word中字体里的阴文选项对应。


字体隐藏 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体的格式是否使用隐藏文本。返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容设为隐藏。本属性与Word中字体里的隐藏文字选项对应。


倾斜 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体是否倾斜，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容设为倾斜效果。本属性与Word中字体里的倾斜选项对应。


最小字号 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；Word 根据字号调整字间距时的最小字号。

例程

说明

将“Word文档”的“最小字号“属性设为“最小字号编辑框”中的内容。本属性与Word中字体里字符间距选项卡的为字符调整字符间距对应。


字体名 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：文本型；设计时不可用；字体的名称，例如"宋体"。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容的字体设为“字体名组合框中”的内容。本属性与Word中字体里的字体选项对应。


字体大小 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体的大小。

例程

说明

将“Word文档集”所对应的Word文档中已选中的内容的字体大小设为“字体大小编辑框”中的内容。本属性与Word中字体里的字体大小对应。


东亚字体名 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：文本型；设计时不可用；一种东亚字体名称。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容的字体设为“东亚字体名编辑框”的内容。本属性与Word中字体里西文字体选项对应。


空心 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体格式是否为镂空，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中的已选中内容设为空心效果。本属性与Word中字体里空心选项对应。


文字位置 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；返回或设置相对于基线的文字的位置（以磅为单位）。如果返回值为正数则提升文字，返回值为负数则降低文字。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容的字体位置设为“位置编辑框”的内容。本属性与Word中字体里字符间距选项卡里的位置对应。


字体缩放比 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；用于字体的缩放比例。本属性水平拉长或压缩文字，根据与当前字体大小的一定比例（缩放范围从 1 到 600）进行缩放。

例程

说明

设置“Word文档集”所关联的Word文档中已选中内容的字体缩放比为200%。


阴影 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体格式是否带阴影，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word稳当集”所关联的Word文档中已选中的内容设为阴影效果。本属性与Word中字体里阴影选项对应。


小写字母 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体是否为小型大写字母，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word 文档中已选中的内容里的小写字母全部改为小型大写字母。本属性与Word中字体里小型大写字母对应。


字符间距 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字符间距（以磅为单位）。

例程

说明

将“Word文档集”所关联的Word文档中已选中内容的字符间距设为“间距编辑框中”的内容。本属性与Word中字体里字符间距选项卡中的间距对应。


删除线 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体为是否有删除线，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容加上删除线效果。本属性与Word中字体里删除线属性对应。


下标 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体是否有下标，返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容加上下标效果。本属性与Word中字体里下标选项对应。


上标 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体是否有上标。返回1、#真；-1、#真；0、假；9999999、#没定义（当返回值既可为 真 也可为 假 时取该值）。该属性可设置为 真或假。

例程

说明

将“Word文档”集所关联的Word文档中已选中的内容加上上标效果。本属性与 Word中字体里上标选项对应。


下划线 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；返回或设置字体或区域所设置的下划线的类型。为以下 WdUnderline 常量之一：0、#无；1、#单下划线；2、#文字线；3、#双下划线；4、#点式下划线；6、#粗下划线；7、#冲撞线；9、#点冲撞线；10、#点点冲撞线；11、#波浪线；27、#重波浪线；20、#重点线；23、#重冲撞线；25、#重冲撞点线；26、#重冲撞点点线；39、#长冲撞线；55、#重长冲撞线；43、#双波浪线；。

例程

说明

将“Word文档集”所关联的Word文档中已选中的内容加上下划线。本属性与Word中字体里下划线选项对应。


下划线颜色 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；下划线的 24 位RGB颜色。

例程

说明

将“Word文档集”所对应的Word文档中已选中内容的下划线颜色设为“下划线颜色选择器”的颜色。本属性与Word中字体里下划线颜色选项对应。


对齐方式 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；返回或设置指定段落的对齐方式。可选下列 WdParagraphAlignment 常量之一：0、#居左；1、#居中；2、#居右；3、#两端对齐；4、#分散对齐；5、#两端居中对齐；7、#两端居上对齐；8、#两端居下对齐；。

例程

说明

将“Word文档集”的“对齐方式”属性写入“属性编辑框”中。本属性与Word中工具栏的对齐方式按钮对应。


页面设置 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。

页面设置类属性：

首页送纸盒 | 其他页送纸盒 | 页脚距离 | 额外页边距
装订线位置 | 装订线风格 | 页眉距离 | 版式模式
左边界距离 | 右边界距离 | 顶边界距离 | 页行数
页面方向 | 页高 | 页宽 | 纸张大小
阅读顺序 | 分节符类型 | 打印两页 | 垂直对齐方式
下页边距 | 行字符数 |  |

说明

本属性只是作分类用，并没有实际用途。


下页边距 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；下页边距，即页底边与正文文本边界之间的距离（以磅为单位）。

例程

说明

将“Word文档集”所对应的Word文档的下页边距设为“下页边距编辑框”的内容。本属性与Word中页面设置里页边距对应。


行字符数 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；文档网格中每行的字符数。

例程

说明

将“Word文档集”所关联的Word文档的每行显示的字符数设为“行字符数编辑框”的内容。


首页送纸盒 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；文档首节或首页的送纸盒，为以下WdPaperTray 常量之一：0、#默认纸盒；1、#wdPrinterUpperBin；1、#wdPrinterOnlyBin；2、#wdPrinterLowerBin；3、#wdPrinterMiddleBin；4、#wdPrinterManualFeed；5、#wdPrinterEnvelopeFeed；6、#wdPrinterManualEnvelopeFeed；7、#wdPrinterAutomaticSheetFeed；8、#wdPrinterTractorFeed；9、#wdPrinterSmallFormatBin；10、#wdPrinterLargeFormatBin；11、#wdPrinterLargeCapacityBin；14、#wdPrinterPaperCassette；15、#wdPrinterFormSource；。

例程

说明

将“Word文档集”所关联的Word文档的首页纸盒设为默认纸盒。本属性与Word中页面设置里打印选项卡里的纸张来源对应。


其他页送纸盒 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；用于文档或某节除了第一页的其他所有页的送纸盒，取值范围同上一属性"首页送纸盒"一样。

例程

说明

将“Word文档集”所关联的Word文档的其他页纸盒设为默认纸盒。本属性与Word中页面设置里打印选项卡里的纸张来源对应。


页脚距离 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；下页边距，即页脚与页底边之间的距离（以磅为单位）。

例程

说明

将“Word文档集”所对应的Word文档的页脚距离设为“页脚距离编辑框”的内容。本属性与Word中页面设置里版式选项卡中的页脚边距对应。


额外页边距 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；文档或节的每一页的额外页边距的大小（以磅为单位），以备装订需要。

例程

说明

将“Word文档集”所关联的Word文档的额外页边距设为“额外页边距编辑框”的内容。在Word中对应“装订线”属性。


装订线位置 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；在文档哪一侧显示装订线。为以下常量之一：0、#左边；1、#顶边；2、#右边；。

例程

说明

将“Word文档集”所关联的Word文档的装订线位置设为左边。本属性与Word中页面设置里装订线位置对应。


装订线风格 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；是否对从右向左语言或从左向右语言使用装订线，为以下常量之一：-10、#Latin（拉丁)；2、#Bidi(印度)；。

例程

说明

将“Word文档集”所关联的Word文档的装订线风格设为印度风格。


页眉距离 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；页眉与页面顶边之间的距离（以磅为单位）。

例程

说明

将“Word文档集”所关联的Word文档的页眉距离设为“页眉边距编辑框”的内容。本属性与Word中页面设置里版式选项卡中的页眉边距对应。


版式模式 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；当前文档的版式模式，为以下常量之一：0、#无网格；1、#指定行网格；2、#指定行网格和字符网格；3、文字对齐字符网格；。

例程

说明

设置Word中文字与网络的对齐方式。对应Word中页面设置中的文档网络选项。本属性与Word中页面设置里文档网络选项卡中的网络对应。


左边界距离 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；页左边与正文文本左边界之间的距离（以磅为单位）。

例程

说明

本属性用于取得和更改文档集所关联的文档的左边界距离。本属性与Word中页面设置里的边距对应。


右边界距离 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；正文文字右边界与页面右边之间的距离（以磅为单位）。

例程

说明

本属性用于取得和更改文档集所关联的文档的右边界距离。本属性与Word中页面设置里的页边距选项对应。


顶边界距离 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；页上边与正文文字上边之间的距离（以磅为单位）。

例程

说明

本属性用于取得和更改Word文档集所关联的Word文档的上边距。本属性与Word中页面设置里的页边距对应。


页行数 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；文档网格中每页的行数。

例程

说明

将“Word文档”集所关联的Word文档的页行数设为“页行数编辑框”的内容。


页面方向 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；页面方向，为以下常量之一：0、#横向；1、#纵向。

例程

说明

将“Word文档集”所关联的Word文档的页面方向设为纵向。本属性与Word中页面设置里页边距里方向选项对应。


页高 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；页高（以磅为单位）。

例程

说明

本属性用于取得和更改Word文档集所关联的文档的页高。这里的页高与Word程序的高属性不同，Word程序中的高是整个Word窗口的高度，这里的高是指文档的高度。


页宽 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；页宽（以磅为单位）。

例程

说明

本属性用于取得和更改Word文档集所关联的文档的页宽。这里的页宽与Word程序的宽属性不同，Word程序里的宽是指整个Word窗口的宽度，这里的页宽指文档的宽度。


纸张大小 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；纸张大小，为以下WdPaperSize常量之一：0、#wdPaper10x14；1、#wdPaper11x17；2、#wdPaperLetter；3、#wdPaperLetterSmall；4、#wdPaperLegal；5、#wdPaperExecutive；6、#wdPaperA3；7、#wdPaperA4；8、#wdPaperA4Small；9、#wdPaperA5；10、#wdPaperB4；11、#wdPaperB5；12、#wdPaperCSheet；13、#wdPaperDSheet；14、#wdPaperESheet；15、#wdPaperFanfoldLegalGerman；16、#wdPaperFanfoldStdGerman；17、#wdPaperFanfoldUS；18、#wdPaperFolio；19、#wdPaperLedger；20、#wdPaperNote；21、#wdPaperQuarto；22、#wdPaperStatement；23、#wdPaperTabloid；24、#wdPaperEnvelope9；25、#wdPaperEnvelope10；26、#wdPaperEnvelope11；27、#wdPaperEnvelope12；28、#wdPaperEnvelope14；29、#wdPaperEnvelopeB4；30、#wdPaperEnvelopeB5；31、#wdPaperEnvelopeB6；32、#wdPaperEnvelopeC3；33、#wdPaperEnvelopeC4；34、#wdPaperEnvelopeC5；35、#wdPaperEnvelopeC6；36、#wdPaperEnvelopeC65；37、#wdPaperEnvelopeDL；38、#wdPaperEnvelopeItaly；39、#wdPaperEnvelopeMonarch；40、#wdPaperEnvelopePersonal；41、#wdPaperCustom；。

例程

说明

将“Word文档集”所关联的Word文档的纸张大小设为“纸张大小编辑框”的内容。


阅读顺序 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定节的阅读顺序和对齐方式，为以下常量之一：0、#从右到走；1、#从左到右。

例程

说明

将“Word文档集”所关联的Word文档的阅读顺序设为从右到左。


分节符类型 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；特定的 PageSetup 对象的分节符类型，为以下常量之一：0、#连续的；1、#新列；2、#新页；3、偶数页；4、奇数页；。

例程

说明

将“Word文档集”所关联的Word 文档的分节符类型设为新页。本属性与Word中的页面设置里的版式里的节起始位置对应。


打印两页 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定文档的两页是否打印在同一张纸中。

例程

说明

将“Word文档集”所关联的Word文档的打印两页设为和“打印两页选择框.选中”相同的值。


垂直对齐方式 属性 所属对象：Word文档集 操作系统支持：Windows

数据类型：整数型；设计时不可用；文档或节中每一页文本或表格中一个或多个单元格的垂直对齐方式，为以下常量之一：0、#顶部；1、#中间；2、#合适位置；3、#底部；。

例程

说明

将“Word文档集”所关联的Word文档的垂直对齐方式设为顶部对齐。本属性与Word中页面设置里版式选项卡里的垂直对齐方式对应。


置程序 方法 操作系统支持：Windows 所属对象：Word文档集

设置Word程序，成功返回真，失败返回假，注意：在使用本对象的任何方法及属性前必须先使用本方法。

语法： 逻辑型 Word 文档集．置程序 （对象名，是否添加文档）

参数名 | 描 述
对象名 | 必需的；Word程序。本参数提供要设置的Word程序对象。
是否添加文档 | 必需的；逻辑型，初始值为“真”。是否自动添加新的文档。

例程

说明

将Word文档集与Word程序绑定。在对Word中的文档进行操作前须使用此操作，但所关联的Word程序必须已创建，否则无效。


清除 方法 操作系统支持：Windows 所属对象：Word文档集

释放 方法 操作系统支持：Windows 所属对象：Word文档集

将本对象释放。再次使用的时候需再次使用"置程序"方法。

语法： 无返回值 Word 文档集．释放 （）

例程

说明

释放与Word程序关联所使用的内存，但这样对先前添加的文档将再无法操作。


运行宏 方法 操作系统支持：Windows 所属对象：Word文档集

运行Word中的宏(Macro),注意：你所提供的参数的数据类型必须与宏中的一致，且该宏必须在Word文档中存在。

语法： 逻辑型 Word 文档集．运行宏 （宏名，… ）

参数名 | 描 述
宏名 | 必需的；可扩充的；文本型。宏的名称，必须是文本型，切该宏必须在Word文档中存在。

例程

说明

通过“运行宏”命令来运行变量“宏名称”中保存的宏名。运行在已存在的宏。


取文档集对象 方法 操作系统支持：Windows 所属对象：Word文档集

获取Word提供的Documents对象，与3.7版的"对象"兼容。

语法： 对象 Word 文档集．取文档集对象 （）

例程

说明

通过“取文档集对象”命令取出文档集对象保存在变量“文档集对象”中。


取文档对象 方法 操作系统支持：Windows 所属对象：Word文档集

获取Word提供的Document对象，与3.7版的"对象"兼容。

语法： 对象 Word 文档集．取文档对象 （）

例程

说明

通过“取文档对象”命令取出“Word文档集”中的文档对象，将取出的对象保存在变量“文档对象中”。


取选择区对象 方法 操作系统支持：Windows 所属对象：Word文档集

获取Word提供的Selection对象，与3.7版的"对象"兼容。

语法： 对象 Word 文档集．取选择区对象 （）

例程

说明

通过“取选择区对象”命令取出“Word文档集中”已被选择的区域的对象，将取出的对象保存在变量“选择区对象”中。


添加文档 方法 操作系统支持：Windows 所属对象：Word文档集

向已打开文档的集合中添加一篇新的空白文档，成功返回真，失败返回假。

语法： 逻辑型 Word 文档集．添加文档 （）

例程

说明

通过“添加文档”命令，向“Word文档集”所关联的文档添加一个空文档。相当与在Word中的新建一个Word文档。


打开 方法 操作系统支持：Windows 所属对象：Word文档集

打开指定的Word文档，成功返回真，失败返回假。

语法： 逻辑型 Word 文档集．打开 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。要打开的Word文件名。

例程

说明

通过“打开”命令，来打开“打开文件通用对话框”打开的文件。打开一个已存在的Word文档。


添加艺术字 方法 操作系统支持：Windows 所属对象：Word图形

关闭 方法 操作系统支持：Windows 所属对象：Word文档集

关闭当前文档。

语法： 逻辑型 Word 文档集．关闭 （）

例程

说明

通过“关闭”命令关闭当前已打开的 Word文档。


保存 方法 操作系统支持：Windows 所属对象：Word文档集

用一个新的文件名及默认格式来保存指定文档。

语法： 无返回值 Word 文档集．保存 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。要保存的Word文件名。

例程

说明

通过“Word文档集”的“保存”命令，保存“Word文档集”对应的Word文档。保存对使用程序创建的Word中的内容。注意保存时需要“.doc”扩展名。


打印预览 方法 操作系统支持：Windows 所属对象：Word文档集

在打印预览和视图方式之间进行切换。

语法： 无返回值 Word 文档集．打印预览 （）

例程

说明

通过“打印预览”命令预览“Word文档集”所对应的文档。预览打印效果，对应Word中的打印预览。


关闭打印预览 方法 操作系统支持：Windows 所属对象：Word文档集

将指定文档从打印预览状态切换回在此之前的视图方式。如果指定文档未处于打印预览状态，将导致一个错误。

语法： 无返回值 Word 文档集．关闭打印预览 （）

例程

说明

通过“Word文档集”的“关闭打印预览”命令关闭打印预览。关闭已打开的预览，对应Word中的关闭打印预览。


打印 方法 操作系统支持：Windows 所属对象：Word文档集

可用此方法打印全部或部分指定文档。此方法的参数与“文件”菜单中“打印”对话框中的选项相对应。

语法： 无返回值 Word 文档集．打印 （运行宏，文件追加，页面范围，输出文件名，起始页，结束页，打印项目，打印份数，打印页码，页面类型，打印到文件，副本，水平页数，垂直页数，缩放宽度，缩放高度）

参数名 | 描 述
运行宏 | 必需的；逻辑型，初始值为“真”。如果此参数为真，则 Microsoft Word 在打印文档的同时继续运行宏。
文件追加 | 必需的；逻辑型，初始值为“假”。如果该参数为真，则将指定文档添至由输出文件参数所指定的文件中。如果为假，则覆盖输出文件所指定文件的内容。
页面范围 | 必需的；整数型，初始值为“0”。页面范围。可为下列WdPrintOutRange常量之一：0、#打印全部文档；1、#打印选择区域；2、#打印当前页；3、#指定范围打印；4、#打印多页行列；。
输出文件名 | 必需的；文本型，初始值为“”。如果打印到文件的值为真，则用此参数指定输出文件的路径及文件名。
起始页 | 必需的；文本型，初始值为“1”。当页面范围参数被设置为3、#指定范围打印时，用此参数指定起始页码。
结束页 | 必需的；文本型，初始值为“1”。当页面范围参数被设置为3、#指定范围打印时，用此参数指定结束页码。
打印项目 | 必需的；整数型，初始值为“0”。指定要打印的项目。可为下列WdPrintOutItem常量之一：0、#文档内容；1、#文档属性；2、#批注；3、#样式；4、#自动图文集词条；5、#按键指定方案；6、#包裹；。
打印份数 | 必需的；整数型，初始值为“1”。要打印的份数。
打印页码 | 必需的；文本型。要打印的页码和页码范围，以逗号分隔各项。例如，“2，6-10”表示打印第 2 页和第 6 至 10 页
页面类型 | 必需的；整数型，初始值为“0”。要打印的页面类型。可为下列WdPrintOutPages常量之一：0、#所有页；1、#只有奇数页；2、#只有偶数页；。
打印到文件 | 必需的；逻辑型，初始值为“假”。如该参数值为真，则将打印指令发送到文件。请确保由输出文件参数指定了文件名。
副本 | 必需的；逻辑型，初始值为“假”。在打印文档的多份副本时，若此参数为真，则打印完一份副本之后再打印下一份副本。
水平页数 | 必需的；整数型，初始值为“1”。在一页纸中水平放置的页数。可以是 1、2、3 或 4。
垂直页数 | 必需的；整数型，初始值为“1”。Word 在一页纸中垂直放置的页数。可以是 1、2、3 或 4。
缩放宽度 | 必需的；整数型。指定 Word 将待打印页面缩放到的宽度，以缇为单位（20 缇 =1 磅；72 磅 = 1 英寸）。
缩放高度 | 必需的；整数型。指定 Word 将待打印页面缩放到的高度，以缇为单位（20 缇 = 1 磅；72 磅 = 1 英寸）。

例程

说明

通过“Word文档集”的“打印“命令打印文档集所对应的文档的第一页。用来打印Word中的指定文件，对应Word中的打印。打印前确认打印机是否设置正确。


输入文本 方法 操作系统支持：Windows 所属对象：Word文档集

插入指定的文本，或者输入键盘命令。

语法： 无返回值 Word 文档集．输入文本 （输入类型，输入内容）

参数名 | 描 述
输入类型 | 必需的；整数型，初始值为“0”。输入的类型，为以下常量值之一：0、输入字符(后面的文本参数起作用)；1、输入回车；2、输入BackSpace。
输入内容 | 必需的；文本型，初始值为“”。如果输入类型等于0，那本参数为实际输入的文本内容。

例程

说明

通过“Word文档集”的“输入文本”命令向“Word文档集”所关联的文档写入一段文本。本命令还可以用来在Word中换行和退格。


全选 方法 操作系统支持：Windows 所属对象：Word文档集

选定文档里全部内容。

语法： 无返回值 Word 文档集．全选 （）

例程

说明

通过“Word文档集”的“全选”命令，将“Word文档集”所关联的文档里的所有内容选中。相当与在Word中使用组合键Ctrl+A。


转到 方法 操作系统支持：Windows 所属对象：Word文档集

转到文档中的某一位置。

语法： 无返回值 Word 文档集．转到 （项目类型，项目位置，项数，项名称）

参数名 | 描 述
项目类型 | 必需的；整数型。区域或所选内容将移至的项的类型。可以取下列 WdGoToItem(参阅Word开发文档) 常量之一：-1、#标签；0、#段落；1、#页面；2、#表格；3、#线；4、#脚注；5、#尾注；6、#注解；7、#域；8、#图形；9、#对象；10、#等式；11、#标题；12、#百分比；13、#拼写错误；14、#语法错误；15、#阅读错误；。
项目位置 | 必需的；整数型。区域或所选内容要移至的项。可以取下列 WdGoToDirection(参阅Word开发文档) 常量之一：1、#首；-1、#尾；2、#下一个；2、#关联；3、#上一个；1、#绝对位置；。
项数 | 必需的；整数型。文档中的项数。
项名称 | 必需的；文本型，初始值为“”。如果 "项目类型" 参数是 标签、注解、域 或 对象，则本参数指定名称。

例程

说明

通过“Word文档集”的“转到”命令，转到第一页的第一行的第一个位置。将光标移动到指定的位置，一般用于快速定位。


左移 方法 操作系统支持：Windows 所属对象：Word文档集

将所选内容向左移动。

语法： 无返回值 Word 文档集．左移 （度量单位，单位数，延伸）

参数名 | 描 述
度量单位 | 必需的；整数型，初始值为“1”。移动所选内容的距离的度量单位，使用枚举常量"度量单位"，注意：只有以下常量可用于此参数,"单元","字符","词","句子"。
单位数 | 必需的；整数型，初始值为“1”。所选内容移动距离的单位数。
延伸 | 必需的；整数型，初始值为“0”。可以是 0、#移动 或 1、#延伸。如果是 0，则所选内容折叠到结束位置，并向左移动。如果是 1，则所选内容向左扩展。

例程

说明

通过“Word文档集”的“左移”命令将“Word文档集”所对应的Word文档中的光标向左移一个位置。相当与在Word按下←键。


右移 方法 操作系统支持：Windows 所属对象：Word文档集

将所选内容向右移动。

语法： 无返回值 Word 文档集．右移 （度量单位，单位数，延伸）

参数名 | 描 述
度量单位 | 必需的；整数型，初始值为“1”。移动所选内容的距离的度量单位,使用枚举常量"度量单位"，注意：只有以下常量可用于此参数,"单元","字符","词","句子"。
单位数 | 必需的；整数型，初始值为“1”。所选内容移动距离的单位数。
延伸 | 必需的；整数型，初始值为“0”。可以是 0、#移动 或 1、#延伸。如果是 0，则所选内容折叠到结束位置，并向右移动。如果是 1，则所选内容向右扩展。

例程

说明

通过“Word文档集”的“右移”命令，将“Word文档集”关联的Word文档中的光标向右移一个字符。相当与在Word中按→键。


上移 方法 操作系统支持：Windows 所属对象：Word文档集

将所选内容向上移动。

语法： 无返回值 Word 文档集．上移 （度量单位，单位数，延伸）

参数名 | 描 述
度量单位 | 必需的；整数型，初始值为“5”。移动所选内容的距离的度量单位，使用枚举常量"度量单位"，注意：只有以下常量可用于此参数,"线","段落","屏幕窗口","屏幕"。
单位数 | 必需的；整数型，初始值为“1”。所选内容移动距离的单位数。
延伸 | 必需的；整数型，初始值为“0”。可以是 0、#移动 或 1、#延伸。如果是 0，则所选内容折叠到结束位置，并向上移动。如果是 1，则所选内容向上扩展。

例程

说明

通过“Word文档集”的“上移”命令，将“Word文档集”所关联的Word文档的光标向上移一个屏幕。一般用于快速定位。


下移 方法 操作系统支持：Windows 所属对象：Word文档集

将所选内容向下移动。

语法： 无返回值 Word 文档集．下移 （度量单位，单位数，延伸）

参数名 | 描 述
度量单位 | 必需的；整数型，初始值为“5”。移动所选内容的距离的度量单位，使用枚举常量"度量单位"，注意：只有以下常量可用于此参数,"线","段落","屏幕窗口","屏幕"。
单位数 | 必需的；整数型，初始值为“1”。所选内容移动距离的单位数。
延伸 | 必需的；整数型，初始值为“0”。可以是 0、#移动 或 1、#延伸。如果是 0，则所选内容折叠到结束位置，并向下移动。如果是 1，则所选内容向下扩展。

例程

说明

通过“Word文档集”的“下移”命令，将“Word文档集”所关联的Word文档的光标向下移一个屏幕。一般用于快速定位。


Word图形

Word图形 功能型窗口组件 操作系统支持：Windows 跳至：WORD2000支持库

本对象提供了添加Word图形的相关功能。

方法：

置文档 | 释放 | 取图形对象 | 添加图片
添加图形 | 添加文本框 | 添加艺术字 |


置文档 方法 操作系统支持：Windows 所属对象：Word图形

设置Word文档，成功返回真，失败返回假，注意：在使用本对象的任何方法及属性前必须先使用本方法。

语法： 逻辑型 Word 图形．置文档 （Word文档集对象）

参数名 | 描 述
Word文档集对象 | 必需的；Word文档集。本参数提供要设置的Word文档集对象。

例程

说明

将“Word图形”与“Word文档集”关联起来。所关联的文档集中必须有文档，否则无效。


清除 方法 操作系统支持：Windows 所属对象：Word图形

释放 方法 操作系统支持：Windows 所属对象：Word图形

将本对象释放。再次使用的时候需再次使用"置文档"方法。

语法： 无返回值 Word 图形．释放 （）

例程

说明

释放先前与文档集关联所使用的内存，减少占用的内存资源。


取图形对象 方法 操作系统支持：Windows 所属对象：Word图形

获取Word提供的Shapes对象，与3.7版的"对象"兼容。

语法： 对象 Word 图形．取图形对象 （）

例程

说明

通过“取图形对象”命令，取出“Word图形”的图形对象。


添加图片 方法 操作系统支持：Windows 所属对象：Word图形

向文档中的指定位置添加一张图片。

语法： 逻辑型 Word 图形．添加图片 （图片文件名，链接到文件，文档中存储，左，顶，宽度，高度）

参数名 | 描 述
图片文件名 | 必需的；文本型。指定要添加图片的文件名。
链接到文件 | 必需的；逻辑型，初始值为“假”。如果此属性设置为真，则将 OLE 对象与创建该对象的文件链接。如果设置为假，则令该 OLE 对象成为该文件的独立副本。默认值为假。
文档中存储 | 必需的；逻辑型，初始值为“真”。如果此属性为真，则将链接的图片与文档一起保存。默认值为假。
左 | 必需的；小数型，初始值为“0”。左坐标。
顶 | 必需的；小数型，初始值为“0”。顶坐标。
宽度 | 必需的；小数型，初始值为“100”。宽度。
高度 | 必需的；小数型，初始值为“100”。高度。

例程

说明

通过“添加图片”命令将使用“打开文件通用对话框”打开的图片添加的Word文档中。


添加图形 方法 操作系统支持：Windows 所属对象：Word图形

向文档中的指定位置添加一个图形。

语法： 逻辑型 Word 图形．添加图形 （图形类型，左，顶，宽，高）

参数名 | 描 述
图形类型 | 必需的；整数型，初始值为“1”。指定要创建的自选图形的类型。其值可取任意的 MsoAutoShapeType 常量(请参阅Word开发文档),可以是-2以及1~138共139个图形。
左 | 必需的；小数型，初始值为“0”。左坐标。
顶 | 必需的；小数型，初始值为“0”。顶坐标。
宽 | 必需的；小数型，初始值为“100”。宽度。
高 | 必需的；小数型，初始值为“100”。高度。

例程

说明

通过“添加图形”命令向Word文档中添加一个100X100的矩形。本命令还可以在Word中添加多种图形，只要在Word中带有的图形这里都可以加入。


添加文本框 方法 操作系统支持：Windows 所属对象：Word图形

向文档中的指定位置添加一个文本框。

语法： 逻辑型 Word 图形．添加文本框 （内容，方向，左，顶，宽，高）

参数名 | 描 述
内容 | 必需的；文本型。文本框中的文本。
方向 | 必需的；整数型，初始值为“3”。指定文本的方向。其值可取下列 MsoTextOrientation(参阅Word开发文档)常量之一：-2、#混合方向；1、#水平；2、#向上；3、#向下；4、#远东垂直；5、#垂直；6、#远东水平旋转；。
左 | 必需的；小数型，初始值为“0”。左坐标。
顶 | 必需的；小数型，初始值为“0”。顶坐标。
宽 | 必需的；小数型，初始值为“100”。宽度。
高 | 必需的；小数型，初始值为“100”。高度。

例程

说明

通过“添加文本框”命令，向Word文档中添加一个内容为“易语言帮助文档例程-Word图形文本框”的文本框。


添加艺术字 方法 操作系统支持：Windows 所属对象：Word图形

向文档中的指定位置添加一个Word艺术字。

语法： 逻辑型 Word 图形．添加艺术字 （内容，PresetTextEffect，字体名，字体大小，粗细，倾斜，左，顶）

参数名 | 描 述
内容 | 必需的；文本型。艺术字的内容。
PresetTextEffect | 必需的；整数型，初始值为“0”。预设的文本效果。其值可取MsoPresetTextEffect(参阅Word开发文档) 常量,为-2及0~29共31个文本效果。
字体名 | 必需的；文本型，初始值为“宋体”。字体的名称，默认为宋体。
字体大小 | 必需的；小数型，初始值为“36”。字体的大小，默认为36号。
粗细 | 必需的；逻辑型，初始值为“假”。字体的粗细,默认为细。
倾斜 | 必需的；逻辑型，初始值为“假”。字体的倾斜，默认为不倾斜。
左 | 必需的；小数型，初始值为“0”。左坐标。
顶 | 必需的；小数型，初始值为“0”。顶坐标。

例程

说明

通过“添加艺术字”命令向Word文档中添加内容为“易语言帮助文档例程-Word图形艺术字”的艺术字。艺术字的效果和Word中所列出的艺术字效果相同。


度量单位

度量单位 枚举常量集合类型 操作系统支持：Windows 跳至：WORD2000支持库

移动时候的度量单位。

成员 | 描 述
字符 | 常量值为 1 。
词 | 常量值为 2 。
句子 | 常量值为 3 。
段落 | 常量值为 4 。
线 | 常量值为 5 。
故事 | 常量值为 6 。
屏幕 | 常量值为 7 。
片段 | 常量值为 8 。
列 | 常量值为 9 。
行 | 常量值为 10 。
窗口 | 常量值为 11 。
单元 | 常量值为 12 。
格式化字符 | 常量值为 13 。
格式化段落 | 常量值为 14 。
表格 | 常量值为 15 。
项目 | 常量值为 16 。

参见：基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。