拖放支持库

拖放支持库 帮助手册20080815版 返回支持库手册 返回首页

本支持库实现了对文本，超文本，URL，文件等对象的拖放的支持。

操作系统支持： Windows

窗口组件数据类型：

拖放对象

例程列表：

例程名称 | 下载 | 说明
拖放文件演示 | 拖放文件.e | 演示拖放文件支持库,关于超级编辑框不支持拖放的问题：超级编辑框和超文本浏览框等本身就支持拖放，所以不支持本支持库。

适用版本，拖放支持库 （1.0#2版）


拖放对象

拖放对象 功能型窗口组件 操作系统支持：Windows 跳至：拖放支持库

提供对文本，超文本，URL，文件等对象的拖放支持。注意：(1) 某些被拖放对象具有多种属性，比如，URL既是URL又是超文本，如果“接收超文本”与“接收URL”都设为真，有URL被拖入时“得到超文本”与“得到URL”都会被激发。(2) 一个本控件的实例只能注册一个其它控件。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
接收文本 | 接收超文本 | 接收URL | 接收文件

方法：

注册拖放控件 撤消拖放控件

自有事件：


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


接收文本 (拖放对象)

接收文本 属性 所属对象：拖放对象 操作系统支持：Windows

数据类型：逻辑型；是否接收文本拖收，真为接收，假为不接收。

例程:

说明:

允许窗口接收文本拖拽支持。

参见：例程


接收超文本 (拖放对象)

接收超文本 属性 所属对象：拖放对象 操作系统支持：Windows

数据类型：逻辑型；是否接收超文本拖收，真为接收，假为不接收。

例程:

说明:

允许窗口接收超文本拖拽支持。

参见：例程


接收URL (拖放对象)

接收URL 属性 所属对象：拖放对象 操作系统支持：Windows

数据类型：逻辑型；是否接收URL拖收，真为接收，假为不接收。

例程:

说明:

允许窗口接收网页链接拖拽支持。

参见：例程


接收文件 (拖放对象)

接收文件 属性 所属对象：拖放对象 操作系统支持：Windows

数据类型：逻辑型；是否接收文件拖收，真为接收，假为不接收。

例程:

说明:

允许窗口接收文件拖拽支持。

参见：例程


注册拖放控件 方法 操作系统支持：Windows 所属对象：拖放对象

注册一个控件，使其可以接收拖放，成功返回真，失败返回假。

语法： 逻辑型 拖放对象．注册拖放控件 （接收拖放控件句柄）

参数名 | 描 述
接收拖放控件句柄 | 必需的；整数型。接收拖放控件句柄。

例程

说明

通过注册一个控件，使该控件可以接收拖放事件，需要提供控件句柄。

参考：例程1


撤消拖放控件 方法 操作系统支持：Windows 所属对象：拖放对象

撤消一个控件，使其不可以接收拖放。

语法： 无返回值 拖放对象．撤消拖放控件 （接收拖放控件句柄）

参数名 | 描 述
接收拖放控件句柄 | 必需的；整数型。接收拖放控件句柄。

例程

说明

取消对某控件的拖放支持，取消之后该控件将不能接收拖放事件，需要提供控件句柄。

参考：例程1


得到文本 (拖放对象)

得到文本 事件 所属对象：拖放对象 操作系统支持：Windows

有文本被拖放到放置本控件的窗体且“接收文本”属性为真时产生本事件。

语法： 无返回值 _拖放对象_得到文本 （接收到的文本）

参数名 | 描 述
接收到的文本 | 文本型；参数值为接收到的文本。

例程:

说明:

当在超文本框拖拽一块文本到这时，便引发这事件。

参见：例程


得到超文本 (拖放对象)

得到超文本 事件 所属对象：拖放对象 操作系统支持：Windows

有超文本被拖放到放置本控件的窗体且“接收超文本”属性为真时产生本事件。

语法： 无返回值 _拖放对象_得到超文本 （接收到的超文本）

参数名 | 描 述
接收到的超文本 | 文本型；参数值为接收到的超文本。

例程:

说明:

当在超文本框拖拽一块丰富文本到这时，便引发这事件。

参见：例程


得到URL (拖放对象)

得到URL 事件 所属对象：拖放对象 操作系统支持：Windows

有URL被拖放到放置本控件的窗体且“接收URL”属性为真时产生本事件。

语法： 无返回值 _拖放对象_得到URL （接收到的URL）

参数名 | 描 述
接收到的URL | 文本型；参数值为接收到的URL。

例程:

说明:

当在超文本框拖拽一块连接文本到这时，便引发这事件。

参见：例程


得到文件 (拖放对象)

得到文件 事件 所属对象：拖放对象 操作系统支持：Windows

有文件被拖放到放置本控件的窗体且“接收文件”属性为真时产生本事件。

语法： 无返回值 _拖放对象_得到文件 （接收到的文件路径）

参数名 | 描 述
接收到的文件路径 | 文本型；参数值为接收到的文件名文本，如果拖放多个文件，那么每个文件路径通过“#换行符”分隔。

例程:

说明:

当在把文件拖拽到窗口时，引发此事件。

参见：例程