PowerPoint2000支持库

PowerPoint2000支持库 帮助手册20080805版 返回支持库手册 返回首页

本库用来操作MS PowerPoint 2000/XP/2003或以上版本,您的机器中必须装有PowerPoint2000或以上版本 。

操作系统支持： Windows

窗口组件数据类型：

PPT程序

PPT文稿

PPT播放

其它数据类型：

PPT格式 | 幻灯版式 | 文本方向 | 文本水平定位
文本垂直定位 | 过渡样式 | 视图类型 | PPT对齐方式
基准线对齐 | 打印方向 | 音效 | 动画高级模式
播放后效果 | 动画方式 | 文字动画级别 | 文字组效果
放映方式 | 放映类型 | 指针类型 |

适用版本，PowerPoint2000支持库 （1.0#28版）


PPT程序

PPT程序 功能型窗口组件 操作系统支持：Windows 跳至：PowerPoint2000支持库

本对象用来创建并操作PowerPoint程序。

属性：

左 | 顶 | 宽 | 高
标题 | 位置 | 显示 | 版本
显示比例 | 是否已创建 |  |

方法：

创建 | 释放 | 取程序对象 | 退出
激活窗口 |  |  |

自有事件：

新文稿 | 文稿被关闭 | 新建幻灯片 | 文稿被打开
文稿被打印 | 文稿被保存 | 开始放映 | 结束放映
动画执行前 | 下一幻灯片 | 窗口被激活 | 双击前
右键单击前 | 窗口取消激活 | 选择区被改变 |


左 (PPT程序)

左 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；PPT程序窗口的左坐标。

例程

说明

设ppt程序左边（相对屏幕）的位置

参见：例程1


顶 (PPT程序)

顶 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；PPT程序窗口的顶坐标。

例程

说明

设置ppt程序顶部（相对屏幕）

参见：例程


宽 (PPT程序)

宽 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；PPT程序窗口的宽度。

例程

说明

设置ppt的程序宽度


高 (PPT程序)

高 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；PPT程序窗口的高度。

例程

说明

Ppt程序的高为高度编辑框的内容


标题 (PPT程序)

标题 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：文本型；设计时不可用；PPT程序窗口的标题。

例程

说明

设置ppt程序窗口的标题


位置 (PPT程序)

位置 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；窗口的位置状态，为以下常量之一：1、#正常；2、#最小化；3、#最大化。

例程

说明

设置ppt的程序创建位置


显示 (PPT程序)

显示 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；PPT程序窗口是否可见。

例程

说明

设置ppt程序是否显示程序窗口


版本 (PPT程序)

版本 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：文本型；设计时不可用；PPT程序的版本。

例程

说明

设置ppt程序创建出的程序窗口的版本


显示比例 (PPT程序)

显示比例 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；设计时不可用；显示对象大小的变化范围，100表示100%,50表示50%。

例程

说明

设置ppt程序的显示幻灯窗口比例


是否已创建 (PPT程序)

是否已创建 属性 所属对象：PPT程序 操作系统支持：Windows

数据类型：整数型；只读属性；判断PPT程序是否已创建。

例程

说明

显示ppt程序是否创建出。(如果为1就意味已创建0为失败)


创建 (PPT程序)

创建 方法 操作系统支持：Windows 所属对象：PPT程序

创建PowerPoint程序对象，本对象原有内容将被释放。成功返回真，否则返回假。注意：在支持库的任何操作前，必须要先使用本方法创建。

语法： 逻辑型 PPT 程序．创建 （）

ppt程序创建出程序窗口（窗口不可视）

参见：例程


释放 (PPT程序)

释放 方法 操作系统支持：Windows 所属对象：PPT程序

将本对象释放，再次使用的时候需再次使用"创建"方法创建。

语法： 无返回值 PPT 程序．释放 （）

例程

说明

释放ppt程序关联

参见：例程


取程序对象 (PPT程序)

取程序对象 方法 操作系统支持：Windows 所属对象：PPT程序

获取PowerPoint提供的Application对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 程序．取程序对象 （）

例程

说明

ppt程序取出程序的对象。

参见：例程


退出 (PPT程序)

退出 方法 操作系统支持：Windows 所属对象：PPT程序

退出PowerPoint程序。

语法： 无返回值 PPT 程序．退出 （）

例程

说明

ppt退出程序关联

参见：例程


激活窗口 (PPT程序)

激活窗口 方法 操作系统支持：Windows 所属对象：PPT程序

激活PowerPoint程序的窗口。

语法： 无返回值 PPT 程序．激活窗口 （）

例程

说明

激活ppt程序窗口

参见：例程


新文稿 (PPT程序)

新文稿 事件 所属对象：PPT程序 操作系统支持：Windows

在新建一个演示文稿后随即发生。

语法： 无返回值 _PPT 程序_新文稿 （文稿对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。

例程

说明

新文稿时信息框显示文稿对象是否存在


文稿被关闭 (PPT程序)

文稿被关闭 事件 所属对象：PPT程序 操作系统支持：Windows

一旦关闭任意打开的演示文稿即发生此事件。

语法： 无返回值 _PPT 程序_文稿被关闭 （文稿对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示文稿对象是否存在


新建幻灯片 (PPT程序)

新建幻灯片 事件 所属对象：PPT程序 操作系统支持：Windows

当在任意打开的演示文稿中新建幻灯片时将发生此事件。

语法： 无返回值 _PPT 程序_新建幻灯片 （幻灯片对象）

参数名 | 描 述
幻灯片对象 | 对象；PowerPoint提供的Slide对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示幻灯片对象是否存在


文稿被打开 (PPT程序)

文稿被打开 事件 所属对象：PPT程序 操作系统支持：Windows

打开已有演示文稿时即发生此事件。

语法： 无返回值 _PPT 程序_文稿被打开 （文稿对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示文稿对象是否存在


文稿被打印 (PPT程序)

文稿被打印 事件 所属对象：PPT程序 操作系统支持：Windows

打印演示文稿前发生此事件。

语法： 无返回值 _PPT 程序_文稿被打印 （文稿对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示文稿对象是否存在


文稿被保存 (PPT程序)

文稿被保存 事件 所属对象：PPT程序 操作系统支持：Windows

保存任意打开的演示文稿前将发生此事件。

语法： 无返回值 _PPT 程序_文稿被保存 （文稿对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示文稿对象是否存在


开始放映 (PPT程序)

开始放映 事件 所属对象：PPT程序 操作系统支持：Windows

当启动一个幻灯片放映时将发生此事件。Microsoft PowerPoint 会创建幻灯片放映窗口并将其传递给此事件。如果从某个幻灯片放映切换到另一个幻灯片放映，那么此时第二个幻灯片放映再次显示时，该事件将不会发生。

语法： 无返回值 _PPT 程序_开始放映 （播放窗对象）

参数名 | 描 述
播放窗对象 | 对象；PowerPoint提供的SlideShowWindow对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示播放窗对象是否存在


结束放映 (PPT程序)

结束放映 事件 所属对象：PPT程序 操作系统支持：Windows

在幻灯片放映结束后发生此事件。

语法： 无返回值 _PPT 程序_结束放映 （文稿对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示播放窗对象是否存在


动画执行前 (PPT程序)

动画执行前 事件 所属对象：PPT程序 操作系统支持：Windows

一旦鼠标单击或定时动画启动即发生此事件，但此事件在动画对象可见前发生。

语法： 无返回值 _PPT 程序_动画执行前 （播放窗对象）

参数名 | 描 述
播放窗对象 | 对象；PowerPoint提供的SlideShowWindow对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示播放窗对象是否存在


下一幻灯片 (PPT程序)

下一幻灯片 事件 所属对象：PPT程序 操作系统支持：Windows

一旦切换到下一张幻灯片即发生此事件。对于第一张幻灯片，此事件会在 SlideShowBegin 事件之后发生。

语法： 无返回值 _PPT 程序_下一幻灯片 （播放窗对象）

参数名 | 描 述
播放窗对象 | 对象；PowerPoint提供的SlideShowWindow对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示播放窗对象是否存在


窗口被激活 (PPT程序)

窗口被激活 事件 所属对象：PPT程序 操作系统支持：Windows

当激活某个应用程序窗口或任意文档窗口时发生此事件。

语法： 无返回值 _PPT 程序_窗口被激活 （文稿对象，文档窗对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。
文档窗对象 | 对象；PowerPoint提供的DocumentWindow对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框先后显示文稿对象和文档窗对象是否存在


双击前 (PPT程序)

双击前 事件 所属对象：PPT程序 操作系统支持：Windows

当双击下表列出的视图中的项目时发生此事件，形状/幻灯片/幻灯片图像。

语法： 无返回值 _PPT 程序_双击前 （选择区对象，取消）

参数名 | 描 述
选择区对象 | 对象；PowerPoint提供的Selection对象，与3.7版的对象兼容，可组合操作。
取消 | 逻辑型；传址；当此事件发生时，为"假"。如果事件过程将此参数设置为"真"，则当此过程完成后，默认的双击动作将不会执行

例程

说明

信息框显示选择区对象是否存在和取消是否成功


右键单击前 (PPT程序)

右键单击前 事件 所属对象：PPT程序 操作系统支持：Windows

当用鼠标右键单击某个形状、幻灯片、备注页或某些文本时将发生此事件。

语法： 无返回值 _PPT 程序_右键单击前 （选择区对象，取消）

参数名 | 描 述
选择区对象 | 对象；PowerPoint提供的Selection对象，与3.7版的对象兼容，可组合操作。
取消 | 逻辑型；传址；当此事件发生时，为"假"。如果事件过程将此参数设置为"真"，则当此过程完成后，默认的右键单击动作将不会执行

例程

说明

信息框显示选择区对象是否存在和取消是否成功


窗口取消激活 (PPT程序)

窗口取消激活 事件 所属对象：PPT程序 操作系统支持：Windows

当应用程序窗口或任意文档窗口变为非激活状态时发生此事件。

语法： 无返回值 _PPT 程序_窗口取消激活 （文稿对象，文档窗对象）

参数名 | 描 述
文稿对象 | 对象；PowerPoint提供的Presentation对象，与3.7版的对象兼容，可组合操作。
文档窗对象 | 对象；PowerPoint提供的DocumentWindow对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示文稿对象是否为空和文档窗对象是否存在


选择区被改变 (PPT程序)

选择区被改变 事件 所属对象：PPT程序 操作系统支持：Windows

当活动文档窗口中选定的文本、形状或幻灯片发生变化时（无论通过用户界面或通过代码），此事件将发生。

语法： 无返回值 _PPT 程序_选择区被改变 （选择区对象）

参数名 | 描 述
选择区对象 | 对象；PowerPoint提供的Selection对象，与3.7版的对象兼容，可组合操作。

例程

说明

信息框显示选择区对象是否存在


PPT文稿

PPT文稿 功能型窗口组件 操作系统支持：Windows 跳至：PowerPoint2000支持库

本对象用来操作PowerPoint常用对象：Presentations、Presentation、Slides、Slide、Shapes、Shape。

属性：

幻灯片数量 | 幻灯片索引 | 隐藏幻灯片 | 幻灯片版式
图形索引 | 黑白视图 | 视图类型 | 对齐方式
基准线对齐方式 | 字体 | 侧面压缩 | 基准线偏移
字体加粗 | 字体颜色 | 字体可否嵌入 | 字体已嵌入
阳文 | 字体倾斜 | 字体名 | 远东字体名
字体大小 | 下标 | 上标 | 下划线
页面设置 | 首幻灯片索引 | 备注打印方向 | 幻灯片打印方向
幻灯片宽度 | 幻灯片高度 | 幻灯片大小 | 切换方式
单击切换 | 定时切换 | 切换间隔 | 切换效果
切换隐藏 | 切换速度 | 循环播放声音 | 切换音效
切换音效名 | 切换声音文件名 | 动画效果 | 动画高级模式
动画延迟时间 | 动画播放后效果 | 动画是否放映 | 动画影响背景
动画逆序创建 | 动画顺序 | 形状组动画方式 | 渐变目的颜色
形状动画效果 | 剪辑隐藏 | 剪辑循环 | 剪辑暂停
激活播放 | 剪辑重新显示 | 剪辑幻灯片数 | 动画音效类型
动画音效名 | 动画声音文件名 | 文字动画级别 | 文字组效果

方法：

置程序 | 释放 | 运行宏 | 取文稿集对象
取文稿对象 | 取幻灯集对象 | 取幻灯对象 | 取图形集对象
取图形对象 | 打开 | 保存 | 关闭
打印 | 应用模板 | 插入幻灯片 | 删除幻灯片
删除全部幻灯片 | 添加媒体 | 添加图片 | 添加图形
添加艺术字 | 添加文本框 | 添加单色背景 | 添加双色背景
添加预设背景 | 添加图案背景 | 添加预设纹理 | 添加背景图


幻灯片数量 (PPT文稿)

幻灯片数量 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；当前文稿(Presentation)中幻灯片的数量。

例程

说明

取得幻灯片的数量，并保存到变量中去


幻灯片索引 (PPT文稿)

幻灯片索引 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；当前指向的幻灯片的索引。

例程

说明

设置幻灯片的索引


隐藏幻灯片 (PPT文稿)

隐藏幻灯片 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；当前"幻灯片索引"所指向的幻灯片是否隐藏。

例程

说明

设置幻灯片隐藏


幻灯片版式 (PPT文稿)

幻灯片版式 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；当前"幻灯片索引"所指向的幻灯片的幻灯片版式，使用枚举常量"幻灯版式"。

例程

说明

设置当前幻灯片的版式


图形索引 (PPT文稿)

图形索引 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；当前指向的图形(Shape)的索引。

例程

说明

设置幻灯片的当前设置图形对象的图形索引


黑白视图 (PPT文稿)

黑白视图 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；文档窗口是否为为黑白显示模式。

例程

说明

设置当前幻灯片黑白视图模式


视图类型 (PPT文稿)

视图类型 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；使用枚举常量"视图类型"。

例程

说明

设置幻灯片播放的视图类型


对齐方式 (PPT文稿)

对齐方式 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；文字的对齐方式,使用枚举常量"PPT对齐方式"。

例程

说明

设置幻灯片字体的对齐方式


基准线对齐方式 (PPT文稿)

基准线对齐方式 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；文字基准线对齐方式，使用枚举常量"基准线对齐"。

例程

说明

设置幻灯片的基准线对齐方式


字体 (PPT文稿)

字体 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。

例程

说明

显示文稿设置的幻灯片的字体。


侧面压缩 (PPT文稿)

侧面压缩 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体是否侧面压缩。

例程

说明

设置字体侧面压缩。


基准线偏移 (PPT文稿)

基准线偏移 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定的上标或下标字符的基准线偏移。可为 -1 到 1 之间的浮点数。-1 代表 - 100 % 的偏移，1 代表 100 %的偏移。

例程

说明

设置文稿的基准线偏移的量


字体加粗 (PPT文稿)

字体加粗 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体是否加粗。

例程

说明

设置文稿的字体的字体加粗效果


字体颜色 (PPT文稿)

字体颜色 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体的RGB颜色。

例程

说明

设置文稿的对象字体的字体颜色


字体可否嵌入 (PPT文稿)

字体可否嵌入 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；只读；字体是否可以嵌入到演示文稿中。

例程

说明

显示文稿设置的字体可否嵌入。


字体已嵌入 (PPT文稿)

字体已嵌入 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；只读；字体是否已经嵌入到文稿中。

例程

说明

显示文稿设置的字体是否已嵌入。


阳文 (PPT文稿)

阳文 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体是否使用阳文。

例程

说明

设置文稿字体使用阳文。


字体倾斜 (PPT文稿)

字体倾斜 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体倾斜。

例程

说明

设置字体是否倾斜显示。


字体名 (PPT文稿)

字体名 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：文本型；设计时不可用；字体的名称，例如："宋体"。

例程

说明

设置ppt文稿的字体名为字体变量的字体名成员


远东字体名 (PPT文稿)

远东字体名 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：文本型；设计时不可用；远东字体的名称。

例程

说明

设置文稿的字体的远东字体名为字体的远东字体名的成员。


字体大小 (PPT文稿)

字体大小 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；字体的大小。

例程

说明

设置文稿的字体大小属性。


下标 (PPT文稿)

下标 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体是否使用下标。

例程

说明

设置文稿的字体使用下标的属性。


上标 (PPT文稿)

上标 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体是否使用上标。

例程

说明

设置文稿字体的使用上标的属性。


下划线 (PPT文稿)

下划线 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；字体是否使用下划线。

例程

说明

设置文稿字体使用下划线的属性。


页面设置 (PPT文稿)

页面设置 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。

例程

说明

显示文稿设置的幻灯的页面设置的值。


首幻灯片索引 (PPT文稿)

首幻灯片索引 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；文稿中第一张幻灯片的编号。

例程

说明

设置文稿的幻灯片的首张的幻灯编号，为幻灯编号编辑框的内容。


备注打印方向 (PPT文稿)

备注打印方向 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；备注的打印方向，使用枚举常量"打印方向"。

例程

说明

设置文稿的备注的打印方向为垂直打印。


幻灯片打印方向 (PPT文稿)

幻灯片打印方向 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；幻灯片的打印方向，使用枚举常量"打印方向"。

例程

说明

设置幻灯片的打印方向为水平。


幻灯片宽度 (PPT文稿)

幻灯片宽度 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用；幻灯片的宽度，磅为单位。

例程

说明

设置文稿的当前幻灯的幻灯片的宽度为300


幻灯片高度 (PPT文稿)

幻灯片高度 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用；幻灯片的高度，磅为单位。

例程

说明

设置当前幻灯的幻灯片的高度为300


幻灯片大小 (PPT文稿)

幻灯片大小 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；幻灯片的大小，为以下常量之一：1、#屏幕大小；2、#Letter纸张(8.5 x 11)英寸；3、#A4纸张；4、#35毫米；5、#投影仪幻灯片；6、#横幅；7、#自定义；。

例程

说明

设置幻灯片的大小为7（用户定义）


切换方式 (PPT文稿)

切换方式 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。

例程

说明

显示文稿设置的幻灯切换方式的值。


单击切换 (PPT文稿)

单击切换 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；幻灯片是否被单击时换片。

例程

说明

设置幻灯片被单击时换片到下一张幻灯


定时切换 (PPT文稿)

定时切换 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；幻灯片是否在指定时间后自动换片。

例程

说明

设置幻灯片在指定时间后自动换片到下一张的幻灯


切换间隔 (PPT文稿)

切换间隔 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定的幻灯片切换在多长时间后发生，以秒计。

例程

说明：

设置一张幻灯切换来的间隔时间。


切换效果 (PPT文稿)

切换效果 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；

幻灯片转换的特殊效果，PpEntryEffect常数之一(参见PowerPoint2000开发文档)，为以下常数之一：-2、#ppEffectMixed；0、#ppEffectNone；257、#ppEffectCut；258、#ppEffectCutThroughBlack；513、#ppEffectRandom；769#ppEffectBlindsHorizontal；770、#ppEffectBlindsVertical；1025、#ppEffectCheckerboardAcross；1026、#ppEffectCheckerboardDown；1281、#ppEffectCoverLeft；1282、#ppEffectCoverUp；1283、#ppEffectCoverRight；1284、#ppEffectCoverDown；1285、#ppEffectCoverLeftUp；1286、#ppEffectCoverRightUp；1287、#ppEffectCoverLeftDown；1288、#ppEffectCoverRightDown；1537、#ppEffectDissolve；1793、#ppEffectFade；2049、#ppEffectUncoverLeft；2050、#ppEffectUncoverUp；2051、#ppEffectUncoverRight；2052、#ppEffectUncoverDown；2053、#ppEffectUncoverLeftUp；2054、#ppEffectUncoverRightUp；2055、#ppEffectUncoverLeftDown；2056、#ppEffectUncoverRightDown；2305、#ppEffectRandomBarsHorizontal；2306、#ppEffectRandomBarsVertical；2561、#ppEffectStripsUpLeft；2562、#ppEffectStripsUpRight；2563#ppEffectStripsDownLeft；2564、#ppEffectStripsDownRight；2565、#ppEffectStripsLeftUp；2566、#ppEffectStripsRightUp；2567、#ppEffectStripsLeftDown；2568、#ppEffectStripsRightDown；2817、#ppEffectWipeLeft；2818、#ppEffectWipeUp；2819、#ppEffectWipeRight；2820、#ppEffectWipeDown；3073、#ppEffectBoxOut；3074、#ppEffectBoxIn；3329、#ppEffectFlyFromLeft；3330、#ppEffectFlyFromTop；3331、#ppEffectFlyFromRight；3332、#ppEffectFlyFromBottom；3333、#ppEffectFlyFromTopLeft；3334、#ppEffectFlyFromTopRight；3335、#ppEffectFlyFromBottomLeft；3336、#ppEffectFlyFromBottomRight；3337、#ppEffectPeekFromLeft；3338、#ppEffectPeekFromDown；3339、#ppEffectPeekFromRight；3340、#ppEffectPeekFromUp；3341、#ppEffectCrawlFromLeft；3342、#ppEffectCrawlFromUp；3343、#ppEffectCrawlFromRight；3344、#ppEffectCrawlFromDown；3345、#ppEffectZoomIn；3346、#ppEffectZoomInSlightly；3347、#ppEffectZoomOut；3348、#ppEffectZoomOutSlightly；3349、#ppEffectZoomCenter；3350、#ppEffectZoomBottom；3351、#ppEffectStretchAcross；3352、#ppEffectStretchLeft；3353、#ppEffectStretchUp；3354、#ppEffectStretchRight；3355、#ppEffectStretchDown；3356、#ppEffectSwivel；3357、#ppEffectSpiral；3585、#ppEffectSplitHorizontalOut；3586、#ppEffectSplitHorizontalIn；3587、#ppEffectSplitVerticalOut；3588、#ppEffectSplitVerticalIn；3841、#ppEffectFlashOnceFast；3842、#ppEffectFlashOnceMedium；3843、#ppEffectFlashOnceSlow；3844、#ppEffectAppear；。

例程

说明

指定幻灯片切换时的动画效果。


切换隐藏 (PPT文稿)

切换隐藏 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；幻灯片放映中"幻灯片索引"指向的幻灯片是否隐藏。

例程

说明

文稿的切换隐藏置为名称切换隐藏选择的选择框的选中状态


切换速度 (PPT文稿)

切换速度 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；切换到指定幻灯片的速度，为以下常量之一：-2、#默认；1、#慢速；2、#中速；3、#快速；。

例程

说明

文稿的当前幻灯的切换（一个的幻灯的切换来时）速度为2（正常速度）


循环播放声音 (PPT文稿)

循环播放声音 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定的换片声音是否为循环播放直到下一声音开始。

例程

说明

设置幻灯片切换时，是否循化播放切换音效或音效名


切换音效 (PPT文稿)

切换音效 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；切换的音效，使用枚举常量"音效"。

例程

说明

文稿的属性切换音效。（此时切换音效文件无效）


切换音效名 (PPT文稿)

切换音效名 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：文本型；设计时不可用；出现在“幻灯片切换”对话框（位于“幻灯片放映”菜单）的“声音”框中的演示文稿的可用名称集。

例程

说明

置文稿的切换音效名为文件名变量地址的内容


切换声音文件名 (PPT文稿)

切换声音文件名 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：文本型；设计时不可用；设置切换时声音文件名，*.wav格式。

例程

说明

设文稿的切换声音文件名为运行目录的ne.wav的文件


动画效果 (PPT文稿)

动画效果 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。

例程

说明

显示出文稿设置的播放动画效果的值。


动画高级模式 (PPT文稿)

动画高级模式 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定的形状动画是仅当被单击时播放还是在一段指定时间后自动播放，使用枚举常量"动画高级模式"。

例程

说明

设置幻灯片的播放对象的播放时的高级模式属性


动画延迟时间 (PPT文稿)

动画延迟时间 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定形状自动播放动画的延迟时间，以秒计。

例程

说明

设置幻灯片的播放对象的动画延迟播放的时间


动画播放后效果 (PPT文稿)

动画播放后效果 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定形状在创建后是显示为变暗、隐藏、还是保持不变，使用枚举常量"播放后效果"。

例程

说明

置幻灯片的播放对象的播放后的显示效果


动画是否放映 (PPT文稿)

动画是否放映 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定形状在幻灯片放映中是否显示动画。

例程

说明

置幻灯片的播放对象的动画是否放映。


动画影响背景 (PPT文稿)

动画影响背景 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；如果指定对象是自选图形，则图形与其所含的文本分别动画时该属性值为"真"；如果指定形状是图表对象，则指定图表对象的背景（坐标轴和网格线）动画时该属性值为"真"。仅应用于包含可多步创建的文本的自选图形或者图表对象。

例程

说明
设置幻灯片中的几个图形对象的切换播放时是否影响背景


动画逆序创建 (PPT文稿)

动画逆序创建 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定形状是否按逆序创建。

例程

说明

设置幻灯片的图形创建时是否按逆序创建。


动画顺序 (PPT文稿)

动画顺序 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；指定形状在设为动画的形状集合中的位置。

例程

说明

设置幻灯片中的当前的创建的形状的动画顺序索引


形状组动画方式 (PPT文稿)

形状组动画方式 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；该形状组动画是按序列、按类别、还是按元素激活，使用枚举常量"动画方式"。

例程

说明

设置幻灯片中的当前的图形的动画时的播放的显示的方式。


渐变目的颜色 (PPT文稿)

渐变目的颜色 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；形状创建后的颜色，为RGB格式。

例程

说明

设置幻灯片中的图形对象的动画后的渐变的目的颜色（只有属性动画播放后效果设置为

渐变目的颜色时才有效）


形状动画效果 (PPT文稿)

形状动画效果 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；

形状播放动画时的效果，为以下常量之一：-2、#ppEffectMixed；0、#ppEffectNone；257、#ppEffectCut；258、#ppEffectCutThroughBlack；513、#ppEffectRandom；769、#ppEffectBlindsHorizontal；770、#ppEffectBlindsVertical；1025、#ppEffectCheckerboardAcross；1026、#ppEffectCheckerboardDown；1281、#ppEffectCoverLeft；1282、#ppEffectCoverUp；1283、#ppEffectCoverRight；1284、#ppEffectCoverDown；1285、#ppEffectCoverLeftUp；1286、#ppEffectCoverRightUp；1287、#ppEffectCoverLeftDown；1288、#ppEffectCoverRightDown；1537、#ppEffectDissolve；1793、#ppEffectFade；2049、#ppEffectUncoverLeft；2050、#ppEffectUncoverUp；2051、#ppEffectUncoverRight；2052、#ppEffectUncoverDown；2053、#ppEffectUncoverLeftUp；2054、#ppEffectUncoverRightUp；2055、#ppEffectUncoverLeftDown；2056、#ppEffectUncoverRightDown；2305、#ppEffectRandomBarsHorizontal；2306、#ppEffectRandomBarsVertical；2561、#ppEffectStripsUpLeft；2562、#ppEffectStripsUpRight；2563、#ppEffectStripsDownLeft；2564、#ppEffectStripsDownRight；2565、#ppEffectStripsLeftUp；2566、#ppEffectStripsRightUp；2567、#ppEffectStripsLeftDown；2568、#ppEffectStripsRightDown；2817、#ppEffectWipeLeft；2818、#ppEffectWipeUp；2819、#ppEffectWipeRight；2820、#ppEffectWipeDown；3073、#ppEffectBoxOut；3074、#ppEffectBoxIn；3329、#ppEffectFlyFromLeft；3330、#ppEffectFlyFromTop；3331、#ppEffectFlyFromRight；3332、#ppEffectFlyFromBottom；3333、#ppEffectFlyFromTopLeft；3334、#ppEffectFlyFromTopRight；3335、#ppEffectFlyFromBottomLeft；3336、#ppEffectFlyFromBottomRight；3337、#ppEffectPeekFromLeft；3338、#ppEffectPeekFromDown；3339、#ppEffectPeekFromRight；3340、#ppEffectPeekFromUp；3341、#ppEffectCrawlFromLeft；3342、#ppEffectCrawlFromUp；3343、#ppEffectCrawlFromRight；3344、#ppEffectCrawlFromDown；3345、#ppEffectZoomIn；3346、#ppEffectZoomInSlightly；3347、#ppEffectZoomOut；3348、#ppEffectZoomOutSlightly；3349、#ppEffectZoomCenter；3350、#ppEffectZoomBottom；3351、#ppEffectStretchAcross；3352、#ppEffectStretchLeft；3353、#ppEffectStretchUp；3354、#ppEffectStretchRight；3355、#ppEffectStretchDown；3356、#ppEffectSwivel；3357、#ppEffectSpiral；3585、#ppEffectSplitHorizontalOut；3586、#ppEffectSplitHorizontalIn；3587、#ppEffectSplitVerticalOut；3588、#ppEffectSplitVerticalIn；3841、#ppEffectFlashOnceFast；3842、#ppEffectFlashOnceMedium；3843、#ppEffectFlashOnceSlow；3844、#ppEffectAppear；。

例程

说明

设置幻灯片中的当前的图形的动画时的播放的显示的效果。


剪辑隐藏 (PPT文稿)

剪辑隐藏 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；幻灯片放映中指定的媒体剪辑在不播放时是否隐藏。

例程

说明

设置幻灯中的播放时的剪辑是否隐藏


剪辑循环 (PPT文稿)

剪辑循环 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定的影片或声音循环播放是否直到下一个影片或声音开始、用户单击鼠标，或发生幻灯片切换。

例程

说明

设置幻灯中的剪辑是否循环发生。


剪辑暂停 (PPT文稿)

剪辑暂停 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；如果幻灯片放映在指定媒体播放时暂停，则该属性值为"真"。如果媒体播放时幻灯片在背景上继续放映，则该属性值为"假"。

例程

说明

设置幻灯（某一张）中播放时是否暂停剪辑。


激活播放 (PPT文稿)

激活播放 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定的影片或声音是否在激活后自动播放。

例程

说明

设置幻灯的指定的影音是否在激活幻灯时就自动放映。


剪辑重新显示 (PPT文稿)

剪辑重新显示 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定影片的第一帧在影片播放完毕后是否重新显示。

例程

说明

设置幻灯播放的媒体，是否在播放完毕后，画面回到初始播放时的画面。


剪辑幻灯片数 (PPT文稿)

剪辑幻灯片数 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；媒体剪辑播放完毕前要放映的幻灯片数目。

例程

说明

设置媒体剪辑播放完毕前要放映的幻灯片数目。


动画音效类型 (PPT文稿)

动画音效类型 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；动画播放的音效类型，使用枚举常量"音效"。

例程

说明

设置幻灯片播放时的动画的音效类型。


动画音效名 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：文本型；设计时不可用；出现在“幻灯片切换”对话框（位于“幻灯片放映”菜单）的“声音”框中的演示文稿的可用名称集。

例程

说明

设置已有的音效菜单上的使用的音效名。


动画声音文件名 (PPT文稿)

动画声音文件名 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：文本型；设计时不可用；动画声音文件名，*wav格式。

例程

说明

设置幻灯播放的用户定义音效。


文字动画级别 (PPT文稿)

文字动画级别 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；该值指示指定形状中的文本动画是由第一级段落，第二级段落，还是其他级（最多到第五级）段落激活,使用枚举常量"文字动画级别"。

例程

说明

设置幻灯播放文字对象的，文字动画的播放级别。


文字组效果 (PPT文稿)

文字组效果 属性 所属对象：PPT文稿 操作系统支持：Windows

数据类型：整数型；设计时不可用；该值指示指定形状中的文本是逐段、逐字、还是逐字符地显示动画，使用枚举常量"文字组效果"。

例程

说明

设置幻灯片的文字对象的文字组的动画显示效果。


置程序 (PPT文稿)

置程序 方法 操作系统支持：Windows 所属对象：PPT文稿

设置PowerPoint程序。成功返回"真"，失败返回"假"。注意：在使用本对象的任何方法及属性前必须先使用本方法。

语法： 逻辑型 PPT 文稿．置程序 （PPT程序对象，新文稿）

参数名 | 描 述
PPT程序对象 | 必需的；窗口。PPT程序对象。
新文稿 | 必需的；逻辑型，初始值为“真”。在置程序后，本对象自动新见一个文稿集(Presentations)对象如果本参数为"真"，那将在文稿集的基础上新见一个文稿。

例程

说明

设置和ppt程序对象之间的连接。


清除 (PPT文稿)

释放 方法 操作系统支持：Windows 所属对象：PPT文稿

将本对象释放。再次使用的时候需再次使用"置程序"方法。

语法： 无返回值 PPT 文稿．释放 （）

例程

说明

将用完的ppt对象连接释放，否则会占用很大的内存资源。


运行宏 (PPT文稿)

运行宏 方法 操作系统支持：Windows 所属对象：PPT文稿

运行PowerPoint"宏(marco)",要运行的宏必须在PowerPoint文档中事先定义。

语法： 逻辑型 PPT 文稿．运行宏 （宏名，… ）

参数名 | 描 述
宏名 | 必需的；可扩充的；文本型。指定宏的名称，该名称所对应的宏必须在PowerPoint的文档中存在。

例程

说明

ppt文稿运行宏宏命令名编辑框的内容


取文稿集对象 (PPT文稿)

取文稿集对象 方法 操作系统支持：Windows 所属对象：PPT文稿

获取PowerPoint提供的Presentations对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 文稿．取文稿集对象 （）

例程

说明

取得文稿集的对象放入到对象类型变量中


取文稿对象 (PPT文稿)

取文稿对象 方法 操作系统支持：Windows 所属对象：PPT文稿

获取PowerPoint提供的Presentation对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 文稿．取文稿对象 （）

例程

说明

取得ppt的文稿对象，并放入到对象类型变量中


取幻灯集对象 (PPT文稿)

取幻灯集对象 方法 操作系统支持：Windows 所属对象：PPT文稿

获取PowerPoint提供的Slides对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 文稿．取幻灯集对象 （）

例程

说明

取得幻灯集的对象并保存到一个对象类型的变量中去


取幻灯对象 (PPT文稿)

取幻灯对象 方法 操作系统支持：Windows 所属对象：PPT文稿

获取PowerPoint提供的Slide对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 文稿．取幻灯对象 （）

例程

说明

取得ppt的幻灯对象保存在对象类型的变量中


取图形集对象 (PPT文稿)

取图形集对象 方法 操作系统支持：Windows 所属对象：PPT文稿

获取PowerPoint提供的Shapes对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 文稿．取图形集对象 （）

例程

说明

取得ppt的图形集对象放入到对象类型的变量中


取图形对象 (PPT文稿)

取图形对象 方法 操作系统支持：Windows 所属对象：PPT文稿

获取PowerPoint提供的Shape对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 文稿．取图形对象 （）

例程

说明

取得ppt的图形对象保存到对象类型的变量中


打开 (PPT文稿)

打开 方法 操作系统支持：Windows 所属对象：PPT文稿

打开一个PowerPoint2000支持打开的文件。

语法： 逻辑型 PPT 文稿．打开 （文件名，只读方式，无标题方式，可见打开）

参数名 | 描 述
文件名 | 必需的；文本型。要打开的文件的完整文件名，PowerPoint所支持打开的文件，请参见PowerPoint应用程序 "文件/打开"菜单命令。
只读方式 | 必需的；逻辑型，初始值为“假”。是否以只读方式打开文件。
无标题方式 | 必需的；逻辑型，初始值为“假”。该参数为"真"时，将以无标题方式打开文件，此时相当于创建该文件的一份副本。如果该参数为"假"，则将该文件名自动定为演示文稿的标题。
可见打开 | 必需的；逻辑型，初始值为“真”。该参数为"真"时，将在可见窗口中打开文件。设为"假"将隐藏打开的演示文稿。

说明

打开ppt2000的相关文件，在原基础上创建一个窗口打开


保存 (PPT文稿)

保存 方法 操作系统支持：Windows 所属对象：PPT文稿

用一个新的文件名来保存当前文档。

语法： 逻辑型 PPT 文稿．保存 （文件名，格式，嵌入字体）

参数名 | 描 述
文件名 | 必需的；文本型。指定文件的存盘名称。如果不指定路径名则 PowerPoint 将文件存于当前文件夹。
格式 | 必需的；整数型，初始值为“11”。指定文件的保存格式，使用枚举常量中的"PPT格式"。
嵌入字体 | 必需的；逻辑型，初始值为“假”。该参数指定是否在保存的演示文稿中嵌入 TrueType 字体

例程

说明

保存一个ppt文档的记录


关闭 (PPT文稿)

关闭 方法 操作系统支持：Windows 所属对象：PPT文稿

关闭文稿集(Presentations)对象，但是不关闭程序。

语法： 逻辑型 PPT 文稿．关闭 （）

例程

说明

关闭ppt程序的文稿对象


打印 (PPT文稿)

打印 方法 操作系统支持：Windows 所属对象：PPT文稿

打印文稿。

语法： 逻辑型 PPT 文稿．打印 （开始页码，终止页码，打印文件名，打印份数，逐份打印）

参数名 | 描 述
开始页码 | 必需的；整数型。打印的开始页码。
终止页码 | 必需的；整数型。打印的终止页码。
打印文件名 | 必需的；文本型，初始值为“”。如果指定此参数，则要打印的文件将被输出到文件而非打印机。省略此参数时(空文本)，文件被传送至打印机。
打印份数 | 必需的；整数型，初始值为“1”。需要打印的份数。
逐份打印 | 必需的；逻辑型，初始值为“真”。此参数设为"真"时，将逐份地打印演示文稿，否则多份并行打印。

例程

说明

打印ppt文稿的幻灯或备注等


应用模板 (PPT文稿)

应用模板 方法 操作系统支持：Windows 所属对象：PPT文稿

对当前文稿应用设计模板。

语法： 逻辑型 PPT 文稿．应用模板 （模板名称）

参数名 | 描 述
模板名称 | 必需的；文本型。指定设计模板的名称。

例程

说明

对当前操作的文档使用模板


插入幻灯片 (PPT文稿)

插入幻灯片 方法 操作系统支持：Windows 所属对象：PPT文稿

插入一张新的幻灯片。

语法： 逻辑型 PPT 文稿．插入幻灯片 （索引，版式）

参数名 | 描 述
索引 | 必需的；整数型，初始值为“-1”。要入的位置，如果为默认值-1，则将插入到最后的位置。
版式 | 必需的；整数型，初始值为“12”。新插入幻灯片的样式，使用枚举常量"幻灯版式"。

例程

说明

ppt文稿插入新的幻灯片


删除幻灯片 (PPT文稿)

删除幻灯片 方法 操作系统支持：Windows 所属对象：PPT文稿

删除指定的幻灯片。

语法： 逻辑型 PPT 文稿．删除幻灯片 （索引）

参数名 | 描 述
索引 | 必需的；整数型。要删除的幻灯片的索引。

例程

说明

删除文稿中存在的指定的幻灯片（索引起始为1）


删除全部幻灯片 (PPT文稿)

删除全部幻灯片 方法 操作系统支持：Windows 所属对象：PPT文稿

删除当前文稿中的全部幻灯片。

语法： 逻辑型 PPT 文稿．删除全部幻灯片 （）

例程

说明

删除文稿中全部的幻灯片


添加媒体 (PPT文稿)

添加媒体 方法 操作系统支持：Windows 所属对象：PPT文稿

添加一个Windows Media支持的音频或视频文件(*.mpg,*.avi,*.mp3,*.cda...)，并且可以在幻灯片中播放。

语法： 逻辑型 PPT 文稿．添加媒体 （文件名，左边，顶边，宽度，高度）

参数名 | 描 述
文件名 | 必需的；文本型。媒体文件名。
左边 | 必需的；整数型。左坐标，磅为单位。
顶边 | 必需的；整数型。顶坐标，磅为单位。
宽度 | 必需的；整数型。宽度，磅为单位。
高度 | 必需的；整数型。高度，磅为单位。

例程

说明

在幻灯片中添加媒体文件


添加图片 (PPT文稿)

添加图片 方法 操作系统支持：Windows 所属对象：PPT文稿

向幻灯片中添加一张PowerPoint支持的图形/图象文件(*.jpg,*.bmp,*.png,*.emf/wmf,*.gif,*.eps,*.pcx,*.pcd,*.tiff...)，具体支持的格式列表请参见PowerPoint应用程序 "插入/图片/来自文件" 菜单命令。

语法： 逻辑型 PPT 文稿．添加图片 （文件名，链接到文件，保存图片，左边，顶边，宽度，高度）

参数名 | 描 述
文件名 | 必需的；文本型。图片文件名。
链接到文件 | 必需的；逻辑型，初始值为“假”。如果设该参数为"真"会将图片链接到创建它的文件；如果该参数为"假"则将图片制成该文件的一个独立副本。
保存图片 | 必需的；逻辑型，初始值为“真”。如果设该参数为"真"会将链接的图片与插入到的文档一起保存；如果设该参数为"假"则仅保存该文档中的链接信息。如果"链接到文件"为"假"则此参数必须为"真"。
左边 | 必需的；整数型。左坐标，磅为单位。
顶边 | 必需的；整数型。顶坐标，磅为单位。
宽度 | 必需的；整数型。宽度，磅为单位。
高度 | 必需的；整数型。高度，磅为单位。

例程

说明

用文稿在幻灯片中添加图片


添加图形 (PPT文稿)

添加图形 方法 操作系统支持：Windows 所属对象：PPT文稿

向幻灯片中添加一个自选图形，目前PowerPoint支持近100多种图形。

语法： 逻辑型 PPT 文稿．添加图形 （类型，左边，顶边，宽度，高度）

参数名 | 描 述
类型 | 必需的；整数型。指定要创建的自选图形的类型，可为MsoAutoShapeType常数之一(可参见PowerPoint2000开发文档)，数字范围为-2 ~ 138(无0)，共140种。
左边 | 必需的；整数型。左坐标，磅为单位。
顶边 | 必需的；整数型。顶坐标，磅为单位。
宽度 | 必需的；整数型。宽度，磅为单位。
高度 | 必需的；整数型。高度，磅为单位。

例程

说明

在幻灯中添加图形对象


添加艺术字 (PPT文稿)

添加艺术字 方法 操作系统支持：Windows 所属对象：PPT文稿

向幻灯片中添加Office艺术字。

语法： 逻辑型 PPT 文稿．添加艺术字 （预设效果，文本，字体名称，字体大小，加粗，倾斜，左边，顶边）

参数名 | 描 述
预设效果 | 必需的；整数型。预设文本效果可为以下 MsoPresetTextEffect 常数之一(参见PowerPoint2000开发文档)，为-2 ~ 39的整数型常量 。
文本 | 必需的；文本型。艺术字的文本。
字体名称 | 必需的；文本型，初始值为“宋体”。艺术字的字体名称。
字体大小 | 必需的；整数型，初始值为“32”。艺术字的字体大小。
加粗 | 必需的；逻辑型，初始值为“假”。艺术字是否加粗。
倾斜 | 必需的；逻辑型，初始值为“假”。艺术字是否倾斜。
左边 | 必需的；整数型。左坐标，磅为单位。
顶边 | 必需的；整数型。顶坐标，磅为单位。

例程

说明

在幻灯片中添加艺术字


添加文本框 (PPT文稿)

添加文本框 方法 操作系统支持：Windows 所属对象：PPT文稿

向幻灯片中添加一个文本框。

语法： 逻辑型 PPT 文稿．添加文本框 （文本，方向，左边，顶边，宽度，高度，自动调整大小，左边界距离，右边界距离，顶边界距离，底边界距离，自动折行，水平定位类型，垂直定位类型）

参数名 | 描 述
文本 | 必需的；文本型。文本框的文本。
方向 | 必需的；整数型。标签中的文本方向，使用枚举常量"文本方向"，注意：部分常量可能无法使用。
左边 | 必需的；整数型。左坐标，磅为单位。
顶边 | 必需的；整数型。顶左边，磅为单位。
宽度 | 必需的；整数型。宽度，磅为单位。
高度 | 必需的；整数型。高度，磅为单位。
自动调整大小 | 必需的；逻辑型，初始值为“真”。是否自动调整大小以显示其完整的内容。
左边界距离 | 必需的；整数型。以磅为单位指定从文本框左边界到包含文本的形状中内接矩形左边界的距离。
右边界距离 | 必需的；整数型。以磅为单位指定从文本框右边界到包含文本的形状中内接矩形右边界的距离。
顶边界距离 | 必需的；整数型。以磅为单位指定从文本框架顶端到包含文本的形状中内接矩形顶端的距离。
底边界距离 | 必需的；整数型。以磅为单位指定从文本框底端到包含文本的形状中内接矩形底端的距离。
自动折行 | 必需的；逻辑型，初始值为“真”。指定文本是否自动折行以容纳于形状中。
水平定位类型 | 必需的；整数型。指定文本的水平定位类型，使用枚举常量"文本水平定位"。
垂直定位类型 | 必需的；整数型。指定文本的垂直定位类型，使用枚举常量"文本垂直定位"。

例程

说明

在幻灯片中添加文本框


添加单色背景 (PPT文稿)

添加单色背景 方法 操作系统支持：Windows 所属对象：PPT文稿

将幻灯片背景改变为单色背景。

语法： 逻辑型 PPT 文稿．添加单色背景 （颜色，过渡样式，过渡变量，过渡程度）

参数名 | 描 述
颜色 | 必需的；整数型。RGB颜色。
过渡样式 | 必需的；整数型。过渡样式，使用枚举常量"过渡样式"。
过渡变量 | 必需的；整数型。可为 1 到 4 之间的值。
过渡程度 | 必需的；小数型。过渡的程度。可为 0.0（暗）到 1.0（亮）之间的值。

例程

说明

为当前幻灯添加一个单色背景


添加双色背景 (PPT文稿)

添加双色背景 方法 操作系统支持：Windows 所属对象：PPT文稿

将幻灯片背景改变为双色背景。

语法： 逻辑型 PPT 文稿．添加双色背景 （过渡样式，颜色1，颜色2，过渡变量）

参数名 | 描 述
过渡样式 | 必需的；整数型。过渡样式，使用枚举常量"过渡样式"。
颜色1 | 必需的；整数型。颜色1，RGB颜色。
颜色2 | 必需的；整数型。颜色2，RGB颜色。
过渡变量 | 必需的；整数型。可为 1 到 4 之间的值。

例程

说明

为幻灯片添加双色背景


添加预设背景 (PPT文稿)

添加预设背景 方法 操作系统支持：Windows 所属对象：PPT文稿

将幻灯片背景改变为预设背景。

语法： 逻辑型 PPT 文稿．添加预设背景 （过渡样式，预设过渡，过渡变量）

参数名 | 描 述
过渡样式 | 必需的；整数型。过渡样式，使用枚举常量"过渡样式"。
预设过渡 | 必需的；整数型。预设过渡样式，可为以下 MsoPresetGradientType 常数之一(参见PowerPoint2000开发文档)，为-2 ~ 24(无0)的整数。
过渡变量 | 必需的；整数型。可为 1 到 4 之间的值。

例程

说明

将幻灯片的背景改变为预制的背景


添加图案背景 (PPT文稿)

添加图案背景 方法 操作系统支持：Windows 所属对象：PPT文稿

将幻灯片背景改变为指定预设图案。

语法： 逻辑型 PPT 文稿．添加图案背景 （图案）

参数名 | 描 述
图案 | 必需的；整数型。指定填充使用的图案。可为任意的 MsoPatternType 常数(参阅PowerPoint2000开发文档)，为-2 ~ 48(无0)的整数。

例程

说明

为幻灯片添加图案背景


添加预设纹理 (PPT文稿)

添加预设纹理 方法 操作系统支持：Windows 所属对象：PPT文稿

将幻灯片背景改变为指定预设纹理。

语法： 逻辑型 PPT 文稿．添加预设纹理 （图案）

参数名 | 描 述
图案 | 必需的；整数型。指定填充使用的图案。可为任意的 MsoPatternType 常数(参阅PowerPoint2000开发文档)，为-2 ~ 48(无0)的整数。

例程

说明

为幻灯片添加预设的纹理


添加背景图 (PPT文稿)

添加背景图 方法 操作系统支持：Windows 所属对象：PPT文稿

将幻灯片背景改变为指定图片，支持的图片格式请参见PowerPoint应用程序 "格式/背景/填充效果/图片/选择图片"菜单命令，支持大部分流行的图片格式。

语法： 逻辑型 PPT 文稿．添加背景图 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。图片文件名。

例程

说明

为幻灯片添加背景图


PPT播放

PPT播放 功能型窗口组件 操作系统支持：Windows 跳至：PowerPoint2000支持库

本对象用来操作PowerPoint播放相关对象：SlideShowSettings、SlideShowView、SlideShowWindow。

属性：

高级模式 | 起始幻灯片 | 结束幻灯片 | 循环放映
画笔颜色 | 放映类型 | 显示动画 | 旁白方式

方法：

置文稿 | 释放 | 取播放设置对象 | 取播放视图对象
取播放窗对象 | 放映 | 结束 | 切换
到首张 | 到尾张 | 下一张 | 上一张
设放映指针 | 擦除笔迹 | 画线 |


高级模式 (PPT播放)

高级模式 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：整数型；设计时不可用；指示幻灯片放映方式，使用枚举常量"放映方式"。

例程

说明

设置幻灯播放的高级模式的幻灯效果。


起始幻灯片 (PPT播放)

起始幻灯片 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：整数型；设计时不可用；幻灯片放映中第一个显示的幻灯片的索引。

例程

说明

设置幻灯播放的起始幻灯片索引


结束幻灯片 (PPT播放)

结束幻灯片 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：整数型；设计时不可用；幻灯片放映中最后显示的幻灯片的索引。

例程

说明

设置幻灯播放的结束的幻灯片的索引。


循环放映 (PPT播放)

循环放映 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；指定的幻灯片放映循环是否直到用户按 ESC 键。

例程

说明

设置幻灯片是否循环播放。


画笔颜色 (PPT播放)

画笔颜色 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：整数型；设计时不可用；画笔的颜色,RGB格式。

例程

说明

设置播放对象的播放时的画笔颜色。


放映类型 (PPT播放)

放映类型 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：整数型；设计时不可用；幻灯片放映的放映类型，使用枚举常量"放映类型"。

例程

说明

设置幻灯播放时的放映的类型。


显示动画 (PPT播放)

显示动画 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；幻灯片放映是否以预定的动画设置显示形状。

例程

说明

让ppt文稿设置的动画效果失效

参见：例程


旁白方式 (PPT播放)

旁白方式 属性 所属对象：PPT播放 操作系统支持：Windows

数据类型：逻辑型；设计时不可用；幻灯片放映是否以有旁白方式放映。

例程

说明

设置幻灯播放时是否有旁白方式。

参见： 例程1


置文稿 (PPT播放)

置文稿 方法 操作系统支持：Windows 所属对象：PPT播放

设置文稿，成功返回真，失败返回假，注意：在使用本对象的任何方法及属性前必须先使用本方法。

语法： 逻辑型 PPT 播放．置文稿 （PPT文稿对象）

参数名 | 描 述
PPT文稿对象 | 必需的；报表。PPT文稿对象。

例程

说明

变量装入返回播放对象的置文稿的成功结果

参见：例程


清除 (PPT播放)

释放 方法 操作系统支持：Windows 所属对象：PPT播放

将本对象释放，注意：下次使用的时候需要再次使用"置文稿"方法。

语法： 无返回值 PPT 播放．释放 （PPT文稿对象）

参数名 | 描 述
PPT文稿对象 | 必需的；报表。PPT文稿对象。

例程

说明

用完后要释放关联的播放对象，否则会占用很大的内存资源。


取play对象 (PPT播放)

取播放设置对象 方法 操作系统支持：Windows 所属对象：PPT播放

获取PowerPoint提供的SlideShowSettings对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 PPT 播放．取播放设置对象 （）

例程

说明

取出的播放设置窗口放入对象变量中


取播放视图对象 (PPT播放)

取播放视图对象 方法 操作系统支持：Windows 所属对象：PPT播放

获取PowerPoint提供的SlideShowView对象，与3.7版的"对象"兼容，可组合操作。

语法： 对象 PPT 播放．取播放视图对象 （）

例程

说明

命令取播放视图对象返回值放入对象变量


取播放窗对象 (PPT播放)

取播放窗对象 方法 操作系统支持：Windows 所属对象：PPT播放

获取PowerPoint提供的SlideShowWindow对象，与3.7版提供的"对象"兼容，可组合操作。

语法： 对象 PPT 播放．取播放窗对象 （）

例程

说明

取播放窗对象返回值放入对象变量


放映 (PPT播放)

放映 方法 操作系统支持：Windows 所属对象：PPT播放

放映幻灯片。

语法： 逻辑型 PPT 播放．放映 （）

例程

说明

播放对象放映幻灯片


结束 (PPT播放)

结束 方法 操作系统支持：Windows 所属对象：PPT播放

结束放映幻灯片。

语法： 无返回值 PPT 播放．结束 （）

例程

说明

播放对象销毁


切换 (PPT播放)

切换 方法 操作系统支持：Windows 所属对象：PPT播放

使用幻灯片索引切换到指定的幻灯片。

语法： 逻辑型 PPT 播放．切换 （索引）

参数名 | 描 述
索引 | 必需的；整数型。要切换的数字索引，该索引必须为指向一个已存在的幻灯片。

例程

说明

播放对象切换到编辑框1.内容


到首张 (PPT播放)

到首张 方法 操作系统支持：Windows 所属对象：PPT播放

切换到第一张幻灯片。

语法： 逻辑型 PPT 播放．到首张 （）

例程

说明

播放对象的播放的幻灯片到首张

参见： 例程1


到尾张 (PPT播放)

到尾张 方法 操作系统支持：Windows 所属对象：PPT播放

切换到最后一张幻灯片。

语法： 逻辑型 PPT 播放．到尾张 （）

例程

说明

播放对象的播放的幻灯片到尾张


下一张 (PPT播放)

下一张 方法 操作系统支持：Windows 所属对象：PPT播放

切换到下一张幻灯片。

语法： 逻辑型 PPT 播放．下一张 （）

例程

说明

播放对象的播放的幻灯片到下一张


上一张 (PPT播放)

上一张 方法 操作系统支持：Windows 所属对象：PPT播放

切换到上一张幻灯片。

语法： 逻辑型 PPT 播放．上一张 （）

例程

说明

播放对象的播放的幻灯片到上一张


设放映指针 (PPT播放)

设放映指针 方法 操作系统支持：Windows 所属对象：PPT播放

设幻灯片片放映时的指针。

语法： 逻辑型 PPT 播放．设放映指针 （指针类型，指针颜色）

参数名 | 描 述
指针类型 | 必需的；整数型。指针类型，使用枚举常量"指针类型"。
指针颜色 | 必需的；整数型。RGB颜色。

例程

说明

播放对象使用设放映指针参数一为箭头，参数二为黑色


擦除笔迹 (PPT播放)

擦除笔迹 方法 操作系统支持：Windows 所属对象：PPT播放

插入幻灯片放映时画入的笔迹。

语法： 逻辑型 PPT 播放．擦除笔迹 （）

例程

说明

命令播放对象画的笔迹擦除绘画的笔迹


画线 (PPT播放)

画线 方法 操作系统支持：Windows 所属对象：PPT播放

在幻灯片放映的时候在当前幻灯片上画线。

语法： 逻辑型 PPT 播放．画线 （起点横坐标，起点纵坐标，终点横坐标，终点纵坐标，宽度）

参数名 | 描 述
起点横坐标 | 必需的；整数型。线的起点相对于幻灯片左上角的横坐标，磅为单位。
起点纵坐标 | 必需的；整数型。线的起点相对于幻灯片左上角的纵坐标，磅为单位。
终点横坐标 | 必需的；整数型。线的终点相对于幻灯片左上角的横坐标，磅为单位。
终点纵坐标 | 必需的；整数型。线的终点相对于幻灯片左上角的纵坐标，磅为单位。
宽度 | 必需的；整数型。线条的宽度，磅为单位。

例程

说明

播放对象在幻灯播放时在幻灯播放窗上画线


PPT格式

PPT格式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

PowerPoint文件的保存格式。

成员 | 描 述
文稿格式 | 常量值为 1 。
PowerPoint7格式 | 常量值为 2 。
PowerPoint4格式 | 常量值为 3 。
PowerPoint3格式 | 常量值为 4 。
模板格式 | 常量值为 5 。
RTF格式 | 常量值为 6 。
Show格式 | 常量值为 7 。
AddIn格式 | 常量值为 8 。
PowerPoint4远东格式 | 常量值为 10 。
默认格式 | 常量值为 11 。
HTML格式 | 常量值为 12 。
HTMLv3格式 | 常量值为 13 。
HTMLDual格式 | 常量值为 14 。
MetaFile格式 | 常量值为 15 。
Gif格式 | 常量值为 16 。
JPEG格式 | 常量值为 17 。
PNG格式 | 常量值为 18 。
BMP格式 | 常量值为 19 。

参见： 基本数据类型


幻灯版式

幻灯版式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

幻灯片的版式。

成员 | 描 述
Mixed版式 | 常量值为 -2 。
Title版式 | 常量值为 1 。
Text版式 | 常量值为 2 。
TwoColumnText版式 | 常量值为 3 。
Table版式 | 常量值为 4 。
TextAndChart版式 | 常量值为 5 。
ChartAndText版式 | 常量值为 6 。
OrgChart版式 | 常量值为 7 。
Chart版式 | 常量值为 8 。
TextAndClipart版式 | 常量值为 9 。
ClipartAndText版式 | 常量值为 10 。
TitleOnly版式 | 常量值为 11 。
Blank版式 | 常量值为 12 。
TextAndObject版式 | 常量值为 13 。
ObjectAndText版式 | 常量值为 14 。
LargeObject版式 | 常量值为 15 。
Object版式 | 常量值为 16 。
TextAndMediaClip版式 | 常量值为 17 。
MediaClipAndText版式 | 常量值为 18 。
ObjectOverText版式 | 常量值为 19 。
TextOverObject版式 | 常量值为 20 。
TextAndTwoObjects版式 | 常量值为 21 。
TwoObjectsAndText版式 | 常量值为 22 。
TwoObjectsOverText版式 | 常量值为 23 。
FourObjects版式 | 常量值为 24 。
VerticalText版式 | 常量值为 25 。
ClipArtAndVerticalText版式 | 常量值为 26 。
VerticalTitleAndText版式 | 常量值为 27 。
VerticalTitleAndTextOverChart版式 | 常量值为 28 。

参见： 基本数据类型


文本方向

文本方向 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文本的方向。

成员 | 描 述
混合 | 常量值为 -2 。
水平 | 常量值为 1 。
向上 | 常量值为 2 。
向下 | 常量值为 3 。
远东垂直 | 常量值为 4 。
垂直 | 常量值为 5 。
远东水平旋转 | 常量值为 6 。

参见： 基本数据类型


文本水平定位

文本水平定位 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文本的水平定位方式。

成员 | 描 述
居中 | 常量值为 2 。
无 | 常量值为 1 。
混合 | 常量值为 -2 。

参见： 基本数据类型


文本垂直定位

文本垂直定位 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文本的垂直定位方式。

成员 | 描 述
混合 | 常量值为 -2 。
顶部 | 常量值为 1 。
顶部基线 | 常量值为 2 。
中部 | 常量值为 3 。
底部 | 常量值为 4 。
底部基线 | 常量值为 1 。

参见： 基本数据类型


过渡样式

过渡样式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

颜色的过度样式。

成员 | 描 述
混合 | 常量值为 -2 。
水平 | 常量值为 1 。
垂直 | 常量值为 2 。
斜上 | 常量值为 3 。
斜下 | 常量值为 4 。
角部辐射 | 常量值为 5 。
从标题 | 常量值为 6 。
从中央 | 常量值为 7 。

参见： 基本数据类型


视图类型

视图类型 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

PPT程序界面的视图类型。

成员 | 描 述
幻灯片浏览 | 常量值为 1 。
幻灯片大纲 | 常量值为 2 。
备注页 | 常量值为 3 。
分发大纲 | 常量值为 4 。
备注大纲 | 常量值为 5 。
大纲视图 | 常量值为 6 。
幻灯片排列 | 常量值为 7 。
标题大纲 | 常量值为 8 。
正常视图 | 常量值为 9 。

参见： 基本数据类型


PPT对齐方式

PPT对齐方式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文字对齐方式。

成员 | 描 述
混合 | 常量值为 -2 。
居左 | 常量值为 1 。
居中 | 常量值为 2 。
居右 | 常量值为 3 。
自适应 | 常量值为 4 。
分散 | 常量值为 5 。

参见： 基本数据类型


基准线对齐

基准线对齐 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文字的基准线对齐方式。

成员 | 描 述
混合对齐 | 常量值为 -2 。
基准对齐 | 常量值为 1 。
居顶 | 常量值为 2 。
居中 | 常量值为 3 。
远东50度 | 常量值为 4 。

参见： 基本数据类型


打印方向

打印方向 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

打印方向。

成员 | 描 述
混合 | 常量值为 -2 。
水平 | 常量值为 1 。
垂直 | 常量值为 2 。

参见： 基本数据类型


音效

音效 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

音效类型。

成员 | 描 述
混合 | 常量值为 -2 。
无声音 | 常量值为 0 。
停止前一声音 | 常量值为 1 。
外部声音文件 | 常量值为 2 。

参见： 基本数据类型


动画高级模式

动画高级模式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

动画高级模式。

成员 | 描 述
混合 | 常量值为 -2 。
单击 | 常量值为 1 。
时间间隔 | 常量值为 2 。

参见： 基本数据类型


播放后效果

播放后效果 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

动画播放后效果。

成员 | 描 述
混合 | 常量值为 -2 。
不变暗 | 常量值为 0 。
隐藏 | 常量值为 1 。
目的颜色 | 常量值为 2 。
单击后隐藏 | 常量值为 3 。

参见： 基本数据类型


动画方式

动画方式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

动画播放方式。

成员 | 描 述
混合 | 常量值为 -2 。
按系列 | 常量值为 1 。
按分类 | 常量值为 2 。
按系列元素 | 常量值为 3 。
按分类元素 | 常量值为 4 。

参见： 基本数据类型


文字动画级别

文字动画级别 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文字动画级别。

成员 | 描 述
混合 | 常量值为 -2 。
无级别 | 常量值为 0 。
第一级 | 常量值为 1 。
第二级 | 常量值为 2 。
第三级 | 常量值为 3 。
第四级 | 常量值为 4 。
第五级 | 常量值为 5 。
所有级别 | 常量值为 16 。

参见： 基本数据类型


文字组效果

文字组效果 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

文字组效果。

成员 | 描 述
混合 | 常量值为 -2 。
逐段 | 常量值为 0 。
逐字 | 常量值为 1 。
逐字符 | 常量值为 2 。

参见： 基本数据类型


放映方式

放映方式 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

幻灯片的放映方式。

成员 | 描 述
人工 | 常量值为 1 。
幻灯片时间 | 常量值为 2 。
排练时间 | 常量值为 3 。

参见： 基本数据类型


放映类型

放映类型 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

幻灯片的放映类型。

成员 | 描 述
演讲者放映 | 常量值为 1 。
自行浏览 | 常量值为 2 。
展览 | 常量值为 3 。

参见： 基本数据类型


指针类型

指针类型 枚举常量集合类型 操作系统支持：Windows 跳至：PowerPoint2000支持库

幻灯片放映时的指针类型。

成员 | 描 述
无指针 | 常量值为 0 。
箭头 | 常量值为 1 。
画笔 | 常量值为 2 。
隐藏 | 常量值为 3 。
自动箭头 | 常量值为 4 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。