易向导支持库

易向导支持库 帮助手册20080819版 返回支持库手册 返回首页

本支持库用作支持易语言向导程序的开发。

操作系统支持： Windows

命令类别：

易向导

其它数据类型：

程序项类型

程序项属性

程序项数据类型

例程列表：

例程名称 | 下载 | 说明
API助手 | API助手.e | 能够自动在程序中加入指定DLL命令声明的向导程序
易语言框架程序向导 | 应用程序向导.e | 能够自动生成通用易语言程序框架的向导程序
应用程序模板 | 应用程序模板.e | 由“应用程序向导.e”向导程序所使用的模板源程序

适用版本，易向导支持库 （1.0#50版）


易向导

易向导 类别 跳至：易向导支持库

复制程序 | 复制程序段 | 删除程序 | 删除程序段
删除标记程序 | 修改程序 | 置组件属性 | 置语句备注
置程序信息 | 置作者信息 | 定义模板变量 | 删除模板变量
清除修改记录 | 写出程序 | 添加模块引用 | 删除模块引用


复制程序 命令 操作系统支持：Windows 所属类别：易向导

通过复制的方式建立指定程序项。

语法： 无返回值 复制程序 （欲复制项类型，欲复制项名称，新项目名称）

参数名 | 描 述
欲复制项类型 | 必需的；程序项类型。
欲复制项名称 | 必需的；文本型。
新项目名称 | 必需的；文本型。必须确保该名称合法且不重复。

  例程：

说明：

通过“复制程序”命令复制欲写出文件内的“程序项类型”枚举常量中所包含的类型。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。

参见：例程1


复制程序段 命令 操作系统支持：Windows 所属类别：易向导

通过复制的方式在指定子程序中建立一段程序代码，请一定注意确保欲复制的代码块完整，不交叉跨越分枝及循环语句，否则将导致系统出错。

语法： 无返回值 复制程序段 （子程序名称，标记名，复制到标记名）

参数名 | 描 述
子程序名称 | 必需的；文本型。可以“子程序名称”或“程序集名.子程序名”格式来表示。
标记名 | 必需的；文本型。标记可以在易语言程序中任何可以输入备注的地方设置，譬如程序语句、变量、窗口组件、自定义数据类型等等，所设置标记在易向导最终所生成的程序中将被自动删除。标记的定义格式为“$(标记名称)”或“$(标记名称/)”加“$(/标记名称)”，后两个只能在程序语句中成对使用，用作定义具有多行语句的代码块标记，定义方法为在所选定程序块首语句的备注中加上“$(标记名称/)”，在所选定程序块末语句的备注中加上“$(/标记名称)”，两者名称必须相同。在程序语句备注中使用“$(标记名称)”格式设置标记，可定义该单行语句为一个代码块。同一个地方可以连续设置多个标记，譬如“$(标记名称1)$(标记名称2)”。标记可以与正常备注信息混合排放。
复制到标记名 | 必需的；文本型。本标记提供所选择程序段在本子程序内的目的复制位置。

  例程：

说明：

通过“复制程序段”命令将欲输出程序中指定标记的一段代码，复制到指定标记位置。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


删除程序 命令 操作系统支持：Windows 所属类别：易向导

删除程序中的指定程序项。

语法： 无返回值 删除程序 （欲删除项类型，欲删除项名称）

参数名 | 描 述
欲删除项类型 | 必需的；程序项类型。
欲删除项名称 | 必需的；文本型。

  例程：

说明：

通过“删除程序”命令删除欲输出程序中的内容。此内容包括在“程序项类型”枚举常量中。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


删除程序段 命令 操作系统支持：Windows 所属类别：易向导

删除指定子程序中的一段程序代码，必须确保待删除的代码块完整，不交叉跨越分枝及循环语句，否则将导致系统出错。

语法： 无返回值 删除程序段 （子程序名称，标记名）

参数名 | 描 述
子程序名称 | 必需的；文本型。可以“子程序名称”或“程序集名.子程序名”格式来表示。
标记名 | 必需的；文本型。标记可以在易语言程序中任何可以输入备注的地方设置，譬如程序语句、变量、窗口组件、自定义数据类型等等，所设置标记在易向导最终所生成的程序中将被自动删除。标记的定义格式为“$(标记名称)”或“$(标记名称/)”加“$(/标记名称)”，后两个只能在程序语句中成对使用，用作定义具有多行语句的代码块标记，定义方法为在所选定程序块首语句的备注中加上“$(标记名称/)”，在所选定程序块末语句的备注中加上“$(/标记名称)”，两者名称必须相同。在程序语句备注中使用“$(标记名称)”格式设置标记，可定义该单行语句为一个代码块。同一个地方可以连续设置多个标记，譬如“$(标记名称1)$(标记名称2)”。标记可以与正常备注信息混合排放。

  例程：

说明：

通过“删除程序段”命令删除指定位置，指定标记的程序代码段。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


删除标记程序 命令 操作系统支持：Windows 所属类别：易向导

删除程序中所有注释内包含指定标记的各类程序项目（不包括程序代码段）。

语法： 无返回值 删除标记程序 （标记名）

参数名 | 描 述
标记名 | 必需的；文本型。标记可以在易语言程序中任何可以输入备注的地方设置，譬如程序语句、变量、窗口组件、自定义数据类型等等，所设置标记在易向导最终所生成的程序中将被自动删除。标记的定义格式为“$(标记名称)”或“$(标记名称/)”加“$(/标记名称)”，后两个只能在程序语句中成对使用，用作定义具有多行语句的代码块标记，定义方法为在所选定程序块首语句的备注中加上“$(标记名称/)”，在所选定程序块末语句的备注中加上“$(/标记名称)”，两者名称必须相同。在程序语句备注中使用“$(标记名称)”格式设置标记，可定义该单行语句为一个代码块。同一个地方可以连续设置多个标记，譬如“$(标记名称1)$(标记名称2)”。标记可以与正常备注信息混合排放。

  例程：

说明：

通过“删除标记程序”命令删除欲输出程序中所有有指定标记的代码。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


修改程序 命令 操作系统支持：Windows 所属类别：易向导

语法： 无返回值 修改程序 （欲修改项类型，欲修改项名称，欲修改属性，修改值）

参数名 | 描 述
欲修改项类型 | 必需的；程序项类型。
欲修改项名称 | 必需的；文本型。
欲修改属性 | 必需的；程序项属性。合法的修改属性与与修改项类型相关，具体如下：程序集： 名称、备注子程序： 名称、备注、数据类型、公开、收缩全局变量、程序集变量、局部变量、子程序参数、数据类型成员、DLL命令参数： 名称、备注、数据类型、数组类型、静态、参考、可空数据类型： 名称、备注 DLL命令： 名称、备注、DLL库文件名、DLL库命令名、数据类型窗口： 名称、备注窗口组件： 名称、备注常量或资源： 名称、备注、常量或资源值
修改值 | 必需的；通用型。修改值的数据类型必须与指定欲修改属性的数据类型一致，修改值具体所需要的数据类型请见“程序项属性”中各成员常量的解释。

  例程：

说明：

通过“修改程序”命令修改欲输出程序中的内容。修改的内容为“程序项类型”枚举常量中包含的类型。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


置组件属性 命令 操作系统支持：Windows 所属类别：易向导

语法： 无返回值 置组件属性 （组件属性名，属性值）

参数名 | 描 述
组件属性名 | 必需的；文本型。组件属性名以“窗口名.组件名.属性名”或“窗口名.属性名”格式表示。
属性值 | 必需的；通用型。属性值的数据类型必须与指定组件属性的数据类型一致。

  例程：

说明：

通过“置组件属性”命令修改欲输出程序中指定组件的属性。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


置语句备注 命令 操作系统支持：Windows 所属类别：易向导

设置子程序中指定语句的备注信息。

语法： 无返回值 置语句备注 （子程序名称，标记名，［备注］）

参数名 | 描 述
子程序名称 | 必需的；文本型。可以“子程序名称”或“程序集名.子程序名”格式来表示。
标记名 | 必需的；文本型。标记可以在易语言程序中任何可以输入备注的地方设置，譬如程序语句、变量、窗口组件、自定义数据类型等等，所设置标记在易向导最终所生成的程序中将被自动删除。标记的定义格式为“$(标记名称)”或“$(标记名称/)”加“$(/标记名称)”，后两个只能在程序语句中成对使用，用作定义具有多行语句的代码块标记，定义方法为在所选定程序块首语句的备注中加上“$(标记名称/)”，在所选定程序块末语句的备注中加上“$(/标记名称)”，两者名称必须相同。在程序语句备注中使用“$(标记名称)”格式设置标记，可定义该单行语句为一个代码块。同一个地方可以连续设置多个标记，譬如“$(标记名称1)$(标记名称2)”。标记可以与正常备注信息混合排放。
备注 | 可选的；文本型。如果本参数被省略，默认值为空文本。

  例程：

说明：

通过“置语句备注”命令在欲输出程序中的指定标记处添加备注文本。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


置程序信息 命令 操作系统支持：Windows 所属类别：易向导

设置程序整体的相关信息。

语法： 无返回值 置程序信息 （［程序名称］，［程序类型］，［备注］，［版本］，［图标］）

参数名 | 描 述
程序名称 | 可选的；文本型。如果本参数被省略，则不改动此项。
程序类型 | 可选的；整数型。具体值为： 1、Windows窗口程序； 2、Windows控制台程序； 3、Windows动态链接库； 4、Windows易语言模块； 5、Linux控制台程序； 6、Linux易语言模块。 如果本参数被省略，则不改动此项。
备注 | 可选的；文本型。如果本参数被省略，则不改动此项。
版本 | 可选的；文本型。版本文本格式为“主版本号.次版本号”，如果本参数被省略，则不改动此项。
图标 | 可选的；字节集。如果本参数被省略，则不改动此项。

  例程：

说明：

通过“置程序信息”命令设置输出后程序的程序信息。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


置作者信息 命令 操作系统支持：Windows 所属类别：易向导

设置程序与作者相关的信息。

语法： 无返回值 置作者信息 （［作者名称］，［邮政编码］，［联系地址］，［电话］，［传真］，［电子信箱］，［主页地址］，［其它信息］）

参数名 | 描 述
作者名称 | 可选的；文本型。如果本参数被省略，则不改动此项。
邮政编码 | 可选的；文本型。如果本参数被省略，则不改动此项。
联系地址 | 可选的；文本型。如果本参数被省略，则不改动此项。
电话 | 可选的；文本型。如果本参数被省略，则不改动此项。
传真 | 可选的；文本型。如果本参数被省略，则不改动此项。
电子信箱 | 可选的；文本型。如果本参数被省略，则不改动此项。
主页地址 | 可选的；文本型。如果本参数被省略，则不改动此项。
其它信息 | 可选的；文本型。如果本参数被省略，则不改动此项。

  例程：

说明：

通过“置作者信息”命令设置输出后程序的作者信息。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


定义模板变量 命令 操作系统支持：Windows 所属类别：易向导

设置模板变量的值，模板变量可以用作自动程序替换。可以在模板易语言程序中使用模板变量与模板变量条件表达式，具体使用方法为： 一、在子程序代码中使用模板变量条件表达式： 在相应程序语句备注中加上以下指令以定义生成条件（符合该条件此段程序块将被包含到生成后的易语言程序中，否则会被自动抛弃）： 1、$如果(条件) 或 $if(条件)，后者为前者的英文方式。 2、$否则(条件) 或 $else(条件) 3、$否则 或 $else 4、$结束 或 $end 其中，“条件”参数可以使用以下表达式之一： 1、模板变量 如果指定模板变量已被定义则为真，否则为假。 2、!模板变量 如果指定模板变量未被定义则为真，否则为假。 3、模板变量 = "xxx" 如果指定模板变量的内容等于指定文本内容则为真，否则为假，其中“xxx”为任意文本。 4、模板变量 = xxx 如果指定模板变量的内容等于指定数值则为真，否则为假，其中“xxx”为任意数值。 5、模板变量1 = 模板变量2 如果模板变量1的内容等于模板变量2则为真，否则为假。 6、模板变量 <> "xxx" 如果指定模板变量的内容不等于指定文本内容则为真，否则为假，其中“xxx”为任意文本。 7、模板变量 <> xxx 如果指定模板变量的内容不等于指定数值则为真，否则为假，其中“xxx”为任意数值。 8、模板变量1 <> 模板变量2 如果模板变量1的内容不等于模板变量2则为真，否则为假。 注意：必须确保模板变量条件语句代码块完整，不交叉跨越分枝及循环语句，否则将导致系统出错。另外不要将模板变量条件表达式设置在分枝和循环代码块的首尾语句上，最好单独设置在一条空白语句上，该空白语句在生成后会被自动删除。 简例1，其中“使用数据源1”和“使用数据源2”为模板变量： ※备注：$如果 (使用数据源1) 数据源1.刷新 () ※备注：$否则 (使用数据源2) 数据源2.刷新 () ※备注：$否则 数据源3.刷新 () ※备注：$结束 简例2，其中“欲使用数据源”为模板变量： ※备注：$如果 (欲使用数据源 = "1") 数据源1.刷新 () ※备注：$否则 (欲使用数据源 = "2") 数据源2.刷新 () ※备注：$否则 数据源3.刷新 () ※备注：$结束 二、在其它位置使用模板变量条件表达式： 在任何其它程序项目的备注中加入以下指令以定义生成条件（符合该条件此程序项将被包含到生成后的易语言程序中，否则会被自动抛弃）： $如果(条件) 或 $if(条件)，后者为前者的英文方式，有关此指令的具体解释见前。 简例，在模板易语言程序的“数据源1”窗口组件的备注中加入“$如果 (使用数据源1)”指令即可达到只有定义了“使用数据源1”模板变量，在最终生成的易语言程序中才包含此组件的目的： 三、在子程序代码中使用模板变量替换参数： 在程序语句中使用如下格式的参数会在生成易语言程序时自动被替换： "$(模板变量名)" 简例，如果“变量1”模板变量的内容为文本型数据“单位1”，则下述语句 程序变量 = "$(变量1)" 在最终程序生成后将变为： 程序变量 = "单位1" 而当“变量1”模板变量的内容为数值型数据123时，则此语句将被替换为： 程序变量 = 123

语法： 无返回值 定义模板变量 （模板变量名称，［模板变量值］）

参数名 | 描 述
模板变量名称 | 必需的；文本型。
模板变量值 | 可选的；通用型。只能是系统基本数据类型数据。如果本参数被省略，默认值为空文本。

  例程：

说明：

通过“定义模板变量”命令定义一个模板变量以用于在欲输出程序中进行判断；当在欲输出程序中的判断满足条件，判断块中的代码将会被输出时加入输出程序中。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


删除模板变量 命令 操作系统支持：Windows 所属类别：易向导

删除先前所定义的模板变量。

语法： 无返回值 删除模板变量 （模板变量名称）

参数名 | 描 述
模板变量名称 | 必需的；文本型。

  例程：

说明：

通过“删除模板变量”命令，删除先前定义的指定模板变量。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


清除修改记录 命令 操作系统支持：Windows 所属类别：易向导

清除先前所有修改或设置命令所记录下来的模板程序修改记录。

语法： 无返回值 清除修改记录 （）

  例程：

说明：

通过“清除修改记录”命令，清除执行本命令之前通过易向导支持库命令所对欲输出程序中做的更改。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


写出程序 命令 操作系统支持：Windows 所属类别：易向导

根据已有的模板程序修改记录对模板程序进行实际修改。如果修改成功返回空文本，否则返回具体的错误信息。修改成功后的结果在向导程序退出后将被易系统自动载入编辑。无论写出成功或者失败，本命令退出时都会自动清除所有模板程序修改信息。

语法： 文本型 写出程序 （模板程序数据，［是否关闭源程序］）

参数名 | 描 述
模板程序数据 | 必需的；字节集。此数据为用作模板程序的完整易源程序。
是否关闭源程序 | 可选的；逻辑型。如果本参数为真，则当执行写出程序时，先将现行易语言编辑环境中的源程序关闭，然后将所写出程序作为新的完整程序载入。如果本参数为假，当执行写出程序时，会将所生成程序与现行易语言编辑环境中的源程序合并（合并前“_启动窗口”及其窗口程序集、“启动子程序”代码将被抛弃）。如果本参数被省略，默认值为真。

  例程：

说明：

通过“写出程序”命令将欲输出的程序输出。所有易向导支持库中的命令要在输出文件中体现功能均需要执行此命令。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


添加模块引用 命令 操作系统支持：Windows 所属类别：易向导

调用格式： 〈无返回值〉 添加模块引用 （文本型 模块文件路径名）

参数名 | 描 述
模块文件路径名 | 必需的； “文本型（text）”。本参数提供欲添加引用的模块文件路径名。如果以“$”字符开始，表示后面是基于易语言系统模块目录的相对路径。如：$classlib\d3d.ec，代表在易语言系统模块目录下classlib子目录中的d3d.ec模块文件。

例程：

说明：

增加对指定易模块文件的引用到程序中。本命令为初级命令。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


添加模块引用 命令 操作系统支持：Windows 所属类别：易向导

删除模块引用 命令 操作系统支持：Windows 所属类别：易向导

调用格式： 〈无返回值〉 删除模块引用 （文本型 模块文件名）

参数名 | 描 述
模块文件路径名 | 必需的； “文本型（text）”。本参数提供欲删除引用的不带路径易模块文件名

例程：

说明：

删除程序中对指定易模块文件的引用。本命令为初级命令。

注意：要想看到例程效果须将包内所有文件解压至易语言安装目录中“wizard”文件夹里。然后在易语言中新建程序，选择模版打开既可看到向导运行效果。


程序项类型

程序项类型 枚举常量集合类型 操作系统支持：Windows 跳至：易向导支持库

本类型用作提供所有可用的程序项类型。

成员 | 描 述
程序集 | 常量值为 1 。
子程序 | 常量值为 2 。子程序可以“子程序名称”或“程序集名.子程序名”格式来表示。
全局变量 | 常量值为 4 。
程序集变量 | 常量值为 8 。程序集变量以“程序集名.变量名”格式来表示。
局部变量 | 常量值为 16 。局部变量以“子程序名.局部变量名”或“程序集名.子程序名.局部变量名”格式来表示。
子程序参数 | 常量值为 32 。子程序参数以“子程序名.参数名”或“程序集名.子程序名.参数名”格式来表示。
数据类型 | 常量值为 64 。
数据类型成员 | 常量值为 128 。数据类型成员以“数据类型名.成员名”格式来表示。
DLL命令 | 常量值为 256 。
DLL命令参数 | 常量值为 512 。DLL命令参数以“DLL命令名.参数名”格式来表示。
窗口 | 常量值为 1024 。
窗口组件 | 常量值为 2048 。窗口组件以“窗口名.窗口组件名”格式来表示。
常量或资源 | 常量值为 4096 。

参见： 基本数据类型


程序项属性

程序项属性 枚举常量集合类型 操作系统支持：Windows 跳至：易向导支持库

本类型用作提供所有可用的程序项属性。

成员 | 描 述
名称 | 常量值为 1 。文本型数据。
备注 | 常量值为 2 。文本型数据。
常量或资源值 | 常量值为 3 。数据类型根据具体常量或资源数据类型定。
数据类型 | 常量值为 4 。譬如变量的数据类型、子程序和DLL命令的返回值数据类型等，数据类型为本支持库中所提供的“程序项数据类型”。
数组类型 | 常量值为 5 。使用形如“xxx”或“xxx, xxx, ...”的格式文本分别提供单维和多维数组定义，其中“xxx”为数值，代表对应维的上限值。
静态 | 常量值为 6 。逻辑型数据。
参考 | 常量值为 7 。譬如变量的“参考”类型，DLL命令的“传址”类型等，为逻辑型数据。
可空 | 常量值为 8 。逻辑型数据。
公开 | 常量值为 9 。逻辑型数据。
收缩 | 常量值为 10 。提供子程序的收缩隐藏状态，为逻辑型数据。
DLL库文件名 | 常量值为 11 。文本型数据。
DLL库命令名 | 常量值为 12 。文本型数据。

参见： 基本数据类型


程序项数据类型

程序项数据类型 枚举常量集合类型 操作系统支持：Windows 跳至：易向导支持库

本类型用作提供程序项的数据类型值。

成员 | 描 述
空白型 | 常量值为 0 。
字节型 | 常量值为 1 。
短整数型 | 常量值为 2 。
整数型 | 常量值为 3 。
长整数型 | 常量值为 4 。
小数型 | 常量值为 5 。
双精度小数型 | 常量值为 6 。
逻辑型 | 常量值为 7 。
日期时间型 | 常量值为 8 。
文本型 | 常量值为 9 。
字节集型 | 常量值为 10 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。