扩展界面支持库一

扩展界面支持库一 帮助手册20080731版 返回支持库手册 返回首页

本支持库用作实现对扩展界面元素的支持，需要 Internet Explorer 4.0 或以上版本的支持。

操作系统支持： Windows

窗口组件数据类型：

树型框 | 状态条 | 工具条 | 超级列表框
透明标签 |  |  |

常量表...

例程列表：

例程名称 | 下载 | 说明
工具条和状态条演示 | 工具及状态条.e | 本程序用作演示工具条和状态条的使用方法.
超级列表框演示 | 超级列表框演示.e | 演示超级列表框的使用方法.另外,在互联网支持库的例程"易之FTP"中也可以找到报表方式超级列表框的使用方法.

适用版本，扩展界面支持库一 （1.3#0版）


树型框

树型框 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库一

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 文本颜色 | 背景颜色 | 显示加减框
显示连线 | 显示根部线 | 允许编辑 | 始终显示选择项
现行选中项 | 行高 | 字体 | 图片组
项目 | 结束编辑文本 |  |

方法：

取项目数 | 取缩进层次 | 取项目文本 | 取图片
取选中图片 | 取项目数值 | 置项目文本 | 置图片
置选中图片 | 置项目数值 | 加粗 | 取消加粗
扩展 | 收缩 | 保证显示 | 进入编辑
加入项目 | 删除项目 | 清空 | 取父项目
是否有子项目 | 是否已扩展 |  |

自有事件：

项目被选择 | 双击项目 | 开始编辑 | 结束编辑
即将扩展 | 即将收缩 |  |

基本事件：


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


边框 属性 数据类型：整数型；

本属性指定对象边框的类型。

语法： 对象.边框 = 整数型

应用对象：

窗口、编辑框、图片框、画板、标签、列表框、选择列表框、进度条、滑块条、日期框、月历、目录框、文件框、超级链接框、树型框、超级列表框、超级编辑框

例程

说明

此属性初始值为凹入式。

参见：例程1


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

编辑框、画板、分组框、标签、选择框、单选框、组合框、列表框、月历、驱动器框、文件框、超级链接框、打印机、树型框、超级列表框、透明标签

例程

说明

此属性初始值为黑色。

参见：例程1


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

编辑框、图片框、外形框、分组框、标签、选择框、单选框、组合框、列表框、月历、驱动器框、目录框、文件框、超级链接框、表格、树型框、状态条、工具条、超级列表框、高级影像框、分隔条、超级编辑框

例程：

说明：

树形框项目被清空后，其背景设置为灰色。

参见：例程1


显示加减框 属性 所属对象：树型框

显示加减框 属性 数据类型：逻辑型

本属性指定是否显示加减框。

语法： 树型框.显示加减框 = 逻辑型

应用对象：

树型框

例程

说明

此属性初始值为真。有子项目的父项目文本前显示的提示框，扩展后为减框，收缩后为加框。

参见：例程1


显示连线 属性 所属对象：树型框

显示连线 属性 数据类型：逻辑型

本属性指定是否显示连接线。

语法： 树型框.显示连线 = 逻辑型

应用对象：

树型框

例程

说明：

此属性初始值即为真。显示顶级项目与子项目以及子项目与子项目之间的连线。

参见：例程1


显示根部线 属性 所属对象：树型框

显示根部线 属性 数据类型：逻辑型

本属性指定是否从根部显示连接线。

语法： 树型框.显示根部线 = 逻辑型

应用对象：

树型框

例程：

说明：

程序启动即可显示根部线，也就是顶级项目与顶级项目之间的连线。

参见：例程1


允许编辑 属性 所属对象：超级列表框

允许编辑 属性 数据类型：逻辑型

本属性指定是否允许编辑表项标题，仅在“热点跟踪”属性为假时才有效。

语法： 对象.允许编辑 = 逻辑型

应用对象：

日期框、树型框、超级列表框

例程：

说明：

项目被选中，即可进入编辑状态。

参见：例程


始终显示选择项 属性 所属对象：树型框

始终显示选择项 属性 数据类型：逻辑型

本属性指定是否始终显示当前被选择项目，即使树型框失去焦点。

语法： 树型框.始终显示选择项 = 逻辑型

应用对象：

树型框

例程：

说明：

程序启动时设置此属性为真。当前选中项目即使失去焦点，其项目文本的背景被设置为灰色。

参见：例程1


现行选中项 属性 数据类型：整数型；

本属性指定对象中现行被选中的列表项目的位置，位置值从 0 开始， -1 表示现行没有被选中的列表项。

语法： 对象.现行选中项 = 整数型

应用对象：

组合框、列表框、选择列表框、树型框、超级列表框

例程：

说明：

使用此属性可取出当前被选中项目的索引，并通过其项目索引取得其他相关数据。

参见：例程1


行高 属性 所属对象：树型框

行高 属性 数据类型：整数型

本属性指定树型框中项目行的显示高度，单位为像素， -1 表示使用系统默认值。

例程：

说明：

设置项目行高为20。

参见：例程1


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

编辑框、组合框、树形框

例程：

说明：

设置树形框中的项目文本的字体大小为20。

参见：例程1


图片组 属性 所属对象：树型框

图片组 属性 数据类型：字节集

为树型框提供标志图片。

语法： 树型框.图片组 = 字节集型

应用对象：

树型框

说明：

可以直接在属性面板中的图片组属性中导入图片数据；第二种方法是先将图片保存为图片资源，然后使用代码调用：树形框.图片组= #图片资源；另一种方法是读入图片组文件：数型框.图片组=读入文件（“c:\图片组.eil”）。

注：通过“图片组设置”可以“导出”*.eil文件。

参见：例程1


项目 属性 所属对象：树型框

项目 属性 数据类型：字节集

本属性指定各树型框项目。

说明：

在属性窗口设置项目属性。


结束编辑文本 属性 所属对象：树型框

结束编辑文本 属性 数据类型：文本型

只读；本属性仅在运行时有效，用作为“结束编辑”事件的处理子程序提供标题被编辑后的内容。

语法： 树型框.结束编辑文本 = 文本型

应用对象：

树型框,超级列表框

例程：

说明：

最里面的条件语句，使用此属性的文本与各个项目的文本进行比较。

参见：例程1


取项目数 方法 所属对象：树型框

返回树型框中所有项目的数目。

语法： 整数型 树型框．取项目数 （）

例程：

说明：

当此子程序每次被调用时，就取出树形框中全部项目的数量作为循环的次数（包括所有的顶级项目和子项目）。

参见：例程1


取缩进层次 方法 所属对象：树型框

返回指定项目所处缩进层次，层次值从1开始。如果未找到指定项目，返回 0 。

语法： 整数型 树型框．取缩进层次 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取出树形框中当前被选中项目的缩进层次。也就是从顶级项目开始到当前项目的层数。

参见：例程1


取项目文本 方法 所属对象：树型框

返回指定项目的文本。如果该项目不存在，将返回空文本。

语法： 文本型 树型框．取项目文本 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取出当前被选中项目的项目文本。也可以用循环将树形框中的所有项目文本取出。

参见：例程1


取图片 方法 所属对象：树型框

返回指定项目的图片索引。如果该项目不存在，将返回 -1 。

语法： 整数型 树型框．取图片 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取出当前选中项目的图片索引。

参见：例程1


取选中图片 方法 所属对象：树型框

返回指定项目被选中后的图片索引。如果该项目不存在，将返回 -1 。

语法： 整数型 树型框．取选中图片 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取树形框中当前选中项目的被选中后的图片索引。

参见：例程1


取项目数值 方法 所属对象：树型框

返回与指定项目相关联的数值。如果该项目不存在，将返回 0 。

语法： 整数型 树型框．取项目数值 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

由于设置项目数值是从1 开始的，而树形框的项目索引从0 开始，所以树形框的项目索引必需先用取到的项目数值减1。删除项目后，调用“置项目数值子程序（）”重新设置树形框中所有项目的项目数值。

注：取项目数值前需对每项设置项目数值，否则取出的数值都为0。

参见：例程1


置项目文本 方法 所属对象：树型框

设置指定项目的文本。成功返回真，失败返回假。

语法： 逻辑型 树型框．置项目文本 （项目索引，欲置入的项目文本）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目文本 | 必需的；文本型。

例程：

说明：

修改当前选中项目的文本为编辑框中的文本内容。树形框项目必须存在才可以设置成功。

参见：例程1


置图片 方法 所属对象：树型框

设置在指定项目首部所显示图片的索引。成功返回真，失败返回假。

语法： 逻辑型 树型框．置图片 （项目索引，图片索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
图片索引 | 必需的；整数型。图片索引用于指定图片组属性中的某张图片，从 0 开始。

例程：

说明：

通过条件语句判断，提供图片索引的编辑框的内容是否为空。内容为空就将程序返回，不执行下一行代码，否则修改当前选中项目的图片。由于图片索引为数值型，必需将文本内容转换到数值。

参见：例程1


置选中图片 方法 所属对象：树型框

设置指定项目被选中后所显示图片的索引。成功返回真，失败返回假。

语法： 逻辑型 树型框．置选中图片 （项目索引，图片索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
图片索引 | 必需的；整数型。图片索引用于指定图片组属性中的某张图片，从 0 开始。

例程：

说明：

通过条件语句判断，提供图片索引的编辑框的内容是否为空。内容为空就将程序返回，不执行下一行代码，否则修改当前选中项目的选中后图片。由于图片索引为数值型，必需将文本内容转换到数值。

参见：例程1


置项目数值 方法 所属对象：树型框

设置与指定项目相关联的数值。成功返回真，失败返回假。

语法： 逻辑型 树型框．置项目数值 （项目索引，［欲置入的项目数值］）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目数值 | 可选的；整数型。该数值与指定项目相关联。如果本参数被省略，默认值为 0 。

例程：

说明：

此子程序每次被调用时，通过循环依次设置每个项目的项目数值。由于项目索引是从0 开始，而循环的计次变量从1 开始，所以树形框项目索引就等于循环中的计次变量减1 。这样树形框的第0 项的项目数值为1 ，依次类推。

参见：例程1


加粗 方法 所属对象：树型框

将指定项目的标题加粗显示。

语法： 无返回值 树型框．加粗 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

条件语句判断选择框的选中状态，如果选择框被选中，就将当前被选中项目文本的字体加粗。

参见：例程1


取消加粗 方法 所属对象：树型框

将指定项目的标题取消加粗显示。

语法： 无返回值 树型框．取消加粗 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

条件语句判断选择框的选中状态，如果选择框未被选中，就将当前被选中项目文本的字体取消加粗。如果项目字体未被加粗过，使用此方法也不会产生错误。

参见：例程1


扩展 方法 所属对象：树型框

打开指定项目的下属分枝。

语法： 无返回值 树型框．扩展 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

条件语句判断当前选中项目是否有子项目。如果有就执行扩展方法，展开被选中项目，显示其下级项目，否则用信息框提示。

参见：例程1


收缩 方法 所属对象：树型框

缩回指定项目的下属分枝。

语法： 无返回值 树型框．收缩 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

条件语句判断当前选中项目是否有子项目。如果有就执行收缩方法，隐藏被选中项目的子项，否则用信息框提示。

参见：例程1


保证显示 方法 所属对象：树型框

确保指定项目能够显示出来，如果不能显示，则自动滚动并显示该项目。

语法： 无返回值 树型框．保证显示 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

当前事件子程序被触发，树形框项目自动扩展或收缩。由于树形框的高度和树形框项目的数量，会有项目在树形框中无法显示。使用此方法可以始终显示参数中提供的项目并且被收缩的子项目也会自动展开。

参见：例程1


进入编辑 方法 所属对象：树型框

让指定项目进入编辑状态，执行本命令成功的前提是“允许编辑”属性为真。

语法： 无返回值 树型框．进入编辑 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

项目被选中后，进入编辑状态。可以直接对项目文本进行修改。

参见：例程1


加入项目 方法 所属对象：树型框

将指定项目加入到树型框中，成功返回加入后该项目所处的位置，失败返回 -1 。

语法： 整数型 树型框．加入项目 （［父项目索引］，项目文本，［图片索引］，［选中图片索引］，［项目数值］）

参数名 | 描 述
父项目索引 | 可选的；整数型。指定欲加入项目所处的父项目，0 为项目一，1 为项目二，如此类推。如果没有父项目（即欲加入项目为顶层项目），请提供值 -1 。如果本参数被省略，默认值为 -1 。
项目文本 | 必需的；文本型。
图片索引 | 可选的；整数型。图片索引用于指定图片组属性中的某张图片，从 0 开始。如果本参数被省略，默认值为 0 。
选中图片索引 | 可选的；整数型。选中图片索引用于指定项目被选中后所显示的图片，-1 表示与图片索引一致。如果本参数被省略，默认值为 -1 。
项目数值 | 可选的；整数型。指定与本项目相关联的数值。如果本参数被省略，默认值为 0 。

例程：

说明：

“项目索引”变量为程序集变量，其值为树形框现行选中项的项目数值（可以直接使用项目索引）。而设置的项目数值与相对的项目索引有一个位置的差别，所以此方法的第一个参数必需用取到的项目数值减1 ，才是相对项目的项目索引。通过添加，树形框的项目数量发生改变，项目数值的依次顺序被改变，调用另一个子程序重新按顺序设置项目数值（项目数值并不一定要按顺序对应树形框项目）。

参见：例程1


删除项目 方法 所属对象：树型框

删除树型框中的指定项目。成功返回真，失败返回假。

语法： 逻辑型 树型框．删除项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

由于此方法第一个参数取的是当前选中项目的项目数值，而设置的项目数值与当前项目索引相差一位，所以用项目数值减1 得到正确的项目索引。被选中项目以及其子项目全部被删除，项目数值相对项目的项目索引发生改变，调用另一个子程序重新按依次顺序设置各项目的项目数值。

参见：例程1


清空 方法 所属对象：树型框

删除树型框中的所有项目。

语法： 无返回值 树型框．清空 （）

例程：

参见：例程1


取父项目 方法 所属对象：树型框

返回指定项目的父项目索引。如果该项目为顶层项目，将返回 -1 。

语法： 整数型 树型框．取父项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

说明：

用一个信息框查看现行选中项的父项目索引，如下图左，现行选中项是“项目2子项”运行完上面代码后，跳出信息框显示2，即“项目2子项”的父项“项目2”的索引是2。

参见：例程1


是否有子项目 方法 所属对象：树型框

如果指定项目存在子项目，返回真，否则返回假。如果本命令返回真，意味着指定项目的下一项即为此项目的第一个子项目。

语法： 逻辑型 树型框．是否有子项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程

说明：

查看项目索引是0的项目，即树型框中的第一个项目，是否有子项目，如果有子项目则返回真，没有子项则返回假。可以用信息框查看。

参见：例程1


是否已扩展 方法 所属对象：树型框

如果树型框中的指定项目具有子项目并已扩展显示，返回真，否则返回假。

语法： 逻辑型 树型框．是否已扩展 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

说明：

用信息框查看项目索引是0的项目，既下图“项目1”，是否已扩展，已扩展返回真，未扩展返回假，如图：

参见：例程1


项目被选择 事件 所属对象：树型框

如果当前选择项目被改变即产生此事件。

语法： 无返回值 _树型框_项目被选择 （选择方式）

参数名 | 描 述
选择方式 | 整数型；指示是如何操作导致当前选择项目被改变的： 0：键盘； 1：鼠标； 2：未知。

例程：

说明：

通过方法或鼠标、键盘改变选中项目时触发此事件。

项目被选中，直接进入编辑状态。

参见：例程1


双击项目 事件 所属对象：树型框

当使用鼠标左键在某项目上双击时产生此事件。

语法： 无返回值 _树型框_双击项目 （）

例程：

说明：

此事件被触发，选中项目被展开后，取出选中项目的缩进层次。

参见：例程1


开始编辑 事件 所属对象：树型框

当项目进入标题编辑状态前产生此事件，要产生本事件“允许编辑”属性必须为真。事件处理子程序返回假则不允许进入编辑状态，返回真或不返回值允许进入。

语法： 逻辑型 _树型框_开始编辑 （项目索引）

参数名 | 描 述
项目索引 | 整数型；指示即将进入或结束编辑状态的项目的索引，从 0 开始。

例程：

说明：

使用鼠标、键盘操作树形框项目文本时，此事件被触发。

开始编辑时保存现行选中项目的文本。在“编辑结束（）”时判断项目文本是否与其他项目文本有重复。

参见：例程1


结束编辑 事件 所属对象：树型框

当项目结束标题编辑状态前产生此事件，要产生本事件“允许编辑”属性必须为真。在事件处理子程序中读取“结束编辑文本”属性可以得知标题被编辑后的内容，事件处理子程序返回假不允许使用编辑后的内容替换原有标题，返回真或不返回值则允许替换。

语法： 逻辑型 _树型框_结束编辑 （项目索引）

参数名 | 描 述
项目索引 | 整数型；指示即将进入或结束编辑状态的项目的索引，从 0 开始。

例程：

说明：

使用鼠标、键盘操作树形框项目后，此事件被触发。

通过多个条件语句判断被编辑项目文本与同级项目文本是否相同。使用开始编辑时保存的项目文本设置条件将当前被编辑项目排除与“项目文本”进行比较。最后一个条件语句没有后一个条件，如果进入编辑而没有修改项目文本，条件也将成立，并弹出信息框提示，这样就有些没必要了。然后返回假，不修改项目文本。

参见：例程1


即将扩展 事件 所属对象：树型框

当某项目即将被扩展以显示出下属子项目时产生本事件，返回真或不返回值允许扩展，否则将中止扩展。

语法： 逻辑型 _树型框_即将扩展 （项目索引）

参数名 | 描 述
项目索引 | 整数型；指示即将扩展或收缩显示下属子项目的项目索引，从 0 开始。

例程：

说明：

使用方法或直接使用鼠标、键盘扩展树形框项目时，此事件被触发。

条件语句判断当前选中项目的项目索引。条件成立信息框提示，返回假禁止项目展开，否则项目被展开。

参见：例程1


即将收缩 事件 所属对象：树型框

当某项目即将被收缩以隐藏下属子项目时产生本事件，返回真或不返回值允许收缩，否则将中止收缩。

语法： 逻辑型 _树型框_即将收缩 （项目索引）

参数名 | 描 述
项目索引 | 整数型；指示即将扩展或收缩显示下属子项目的项目索引，从 0 开始。

例程：

说明：

使用方法或直接使用鼠标、键盘收缩树形框项目时，此事件被触发。

条件语句判断当前选中项目的项目索引。条件成立信息框提示，返回假禁止项目收缩，否则返回真收缩项目。

参见：例程1


状态条

状态条 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库一不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
背景颜色 | 位置 | 尺寸调节器 | 字体
图片组 | 项目 |  |

方法：

清空 | 加入栏目 | 删除栏目 | 取栏目数
取文本 | 取提示文本 | 取宽度 | 取类型
取图片 | 取栏目左边 | 取栏目顶边 | 取栏目宽度
取栏目高度 | 置文本 | 置提示文本 | 置宽度
置类型 | 置图片 |  |

基本事件：


背景颜色 属性 所属对象：超级列表框

背景颜色 属性 所属对象：状态条

数据类型：整数型；

指定状态夹的背景颜色。

例程

说明

设置状态条的背景颜色为粉红色。

参见：例程


位置 属性 所属对象：状态条

数据类型：整数型；本属性指定工具条的显示位置。

可供选择的属性值：
0、底边
1、顶边
2、自由

语法： 状态条.位置 = 整数型

应用对象：

工具条，状态条

例程

说明

设置状态条的位置为位置组合框的现行选中项（设置为自由后状态条的起初时位置为前次的位置）

参见；例程1


尺寸调节器 属性 所属对象：状态条

数据类型：逻辑型；本属性指定是否在状态条右边提供用于调节窗口尺寸的调节器，注意尺寸调节器仅当窗口的边框可调（即为非固定边框）并且状态条位置在底边时才有效。

语法： 状态条.尺寸调节器 = 逻辑型

应用对象：

尺寸调节器

例程

说明
把状态条的尺寸调节器打开（就是窗口的右下角的可调节的那个三角形，外窗口无法调节时状态条的调节器无效）

参见：例程1


字体 属性 数据类型：字体；

字体 属性 所属对象：状态条

数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

编辑框、组合框、状态条

例程：

说明：

修改状态条的“字体”属性。

参见：例程1


图片组 属性 所属对象：状态条

数据类型：字节集；为状态条各栏目提供标志图片。

语法： 对象.内容 = 字节集型

应用对象：

状态条 工具条 超级列表框

例程

说明

设置状态条1的图片组为资源的#状态条图片组（此数据必须为易语言的图片组文件的格式数据）

参见：例程1


项目 属性 所属对象：状态条

数据类型：字节集；

本属性设置状态条各栏目的信息。

说明：

在属性窗口中设置状态条的项目。


清空 方法 所属对象：状态条

删除状态条中的所有栏目。

语法： 无返回值 状态条．清空 （）

例程

说明

清空将把状态条的所有项目清除掉

参见：例程1


加入栏目 方法 所属对象：状态条

将指定栏目加入到状态条中，返回加入后该项目所处的位置。

语法： 整数型 状态条．加入栏目 （［栏目文本］，［宽度］，［动态提示文本］，［图片索引］，［外观类型］）

参数名 | 描 述
栏目文本 | 可选的；文本型。栏目文本指定栏目中的文本内容。如果本参数被省略，默认值为空文本。
宽度 | 可选的；整数型。单位为像素，如果为 -1 ，表示一直到窗口的最右边。如果被省略，默认值为 50 。
动态提示文本 | 可选的；文本型。动态提示文本仅当栏目只有图片但没有内容文本或者内容文本不能被全部显示的情况下才有效。如果本参数被省略，默认值为空文本。
图片索引 | 可选的；整数型。图片索引用于指定图片组属性中的某张图片，该图片将被显示在栏目的首部。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。
外观类型 | 可选的；整数型。外观类型指定栏目的显示外观，可以为以下常量值之一： 0: #凹入； 1: #无边框； 2: #凸出。如果本参数被省略，默认值为“#凹入”。

例程

说明

向状态条的后面插入新的项目

参见：例程1


删除栏目 方法 所属对象：状态条

删除指定的栏目。

语法： 无返回值 状态条．删除栏目 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

删除状态条的索引2的项目(如果不存在命令失败)

参见：例程1


取栏目数 方法 所属对象：状态条

取回状态条中栏目的总数。

语法： 整数型 状态条．取栏目数 （）

例程

说明

显示出状态条1的栏目数量（此为只读属性）

参见：例程1


取文本 方法 所属对象：状态条

取回指定栏目的内容文本。

语法： 文本型 状态条．取文本 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

取出状态条的索引2的栏目（即第三个栏目）中的文本，并用信息框显示出来。

参见：例程1


取提示文本 方法 所属对象：状态条

取回指定栏目的提示文本。

语法： 文本型 状态条．取提示文本 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

取得状态条1的索引2的项目的提示标签的提示文本

参见：例程1


取宽度 方法 所属对象：状态条

取回指定栏目的宽度(单位为像素)。

语法： 整数型 状态条．取宽度 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

取出状态条1索引2的项目的宽度。

参见：例程1


取类型 方法 所属对象：状态条

取回指定栏目的外观类型，返回值为以下常量值之一： 0: #凹入； 1: #无边框； 2: #凸出。

语法： 整数型 状态条．取类型 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

显示出状态条1的索引2的项目的外观类型

参见：例程1


取图片 方法 所属对象：状态条

取回指定栏目的图片索引，图片索引指向图片组属性中的某一图片，从 0 开始，-1 表示本栏目无图片标志。

语法： 整数型 状态条．取图片 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

取出状态条1的索引2的项目的图片的索引

参见：例程1


取栏目左边 方法 所属对象：状态条

取回指定栏目在状态条中显示区域的左边位置，单位为像素。

语法： 整数型 状态条．取栏目左边 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

取出栏目索引是2的栏目位置的左边。即该栏目的左边在窗口中的位置。

参见：例程1


取栏目顶边 方法 所属对象：状态条

取回指定栏目在状态条中显示区域的顶边位置，单位为像素。

语法： 整数型 状态条．取栏目顶边 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

取出状态条1的索引2的项目的宽度

参见：例程1


取栏目宽度 方法 所属对象：状态条

取回指定栏目在状态条中显示区域的宽度，单位为像素。

语法： 整数型 状态条．取栏目宽度 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

显示出状态条1的索引2的项目宽度

参见：例程1


取栏目高度 方法 所属对象：状态条

取回指定栏目在状态条中显示区域的高度，单位为像素。

语法： 整数型 状态条．取栏目高度 （栏目索引）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。

例程

说明

显示出状态条1的索引2的项目的宽度

参见：例程1


置文本 方法 所属对象：状态条

设置指定栏目的文本。

语法： 无返回值 状态条．置文本 （栏目索引，［栏目文本］）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。
栏目文本 | 可选的；文本型。栏目文本指定栏目中的文本内容。如果本参数被省略，默认值为空文本。

例程

说明

设置状态条1的索引0的项目的标题文本（不存在将会失败）

参见：例程1


置提示文本 方法 所属对象：状态条

设置指定栏目的提示文本。

语法： 无返回值 状态条．置提示文本 （栏目索引，［动态提示文本］）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。
动态提示文本 | 可选的；文本型。动态提示文本仅当栏目只有图片但没有内容文本或者内容文本不能被全部显示的情况下才有效。如果本参数被省略，默认值为空文本。

例程

说明

设置状态条1的索引1的项目的提示标签的提示文本

参见：例程1


置宽度 方法 所属对象：状态条

设置指定栏目的宽度(单位像素)。

语法： 无返回值 状态条．置宽度 （栏目索引，［宽度］）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。
宽度 | 可选的；整数型。单位为像素，如果为 -1 ，表示一直到窗口的最右边。如果被省略，默认值为 50 。

例程

说明

设置状态条1的索引1的栏目（第二个栏目）的宽度

参见：例程1


置类型 方法 所属对象：状态条

设置指定栏目的外观类型。

语法： 无返回值 状态条．置类型 （栏目索引，［外观类型］）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。
外观类型 | 可选的；整数型。外观类型指定栏目的显示外观，可以为以下常量值之一： 0: #凹入； 1: #无边框； 2: #凸出。如果本参数被省略，默认值为“#凹入”。

例程

说明

设置状态条的项目1的第二个栏目外观类型为凸出

参见：例程1


置图片 方法 所属对象：状态条

设置指定栏目的图片索引，图片索引指向图片组属性中的某一图片，从 0 开始，-1 表示本栏目无图片标志。

语法： 无返回值 状态条．置图片 （栏目索引，［图片索引］）

参数名 | 描 述
栏目索引 | 必需的；整数型。0 为栏目一，1 为栏目二，如此类推。
图片索引 | 可选的；整数型。图片索引用于指定图片组属性中的某张图片，该图片将被显示在栏目的首部。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。

例程

说明

设置状态条1的项目图片(图片索引为状态条1的图片组表中的图片)。

参见：例程1


工具条

工具条 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库一不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
背景颜色 | 位置 | 平面 | 上边线
列表方式 | 允许多行 | 起始空白 | 字体
图片组 | 热点图片组 | 禁止图片组 | 按钮

方法：

插入按钮 | 删除按钮 | 取按钮数 | 取标题
取提示文本 | 取类型 | 取状态 | 取图片
置提示文本 | 加入状态 | 去除状态 |

自有事件：

被单击 被下拉

基本事件：


背景颜色 属性 所属对象：工具条

数据类型：整数型；

指定超级列表框的背景颜色。

例程

说明

参见：例程


位置 属性 所属对象：状态条

位置 属性 所属对象：工具条

数据类型：整数型；本属性指定工具条的显示位置。

可供选择的属性值：
0、顶边
1、底边
2、自由

语法： 工具条.位置 = 整数型

应用对象：

工具条，状态条

例程

说明

设置工具条1的位置为位置组合框的现行选中项

参见:例程1


平面 属性 数据类型：逻辑型；

平面 属性 所属对象：工具条

数据类型：逻辑型；

将对象的样式改为平面样式。

语法： 对象.平面 = 逻辑型

应用对象：

选择框、单选框、工具条

例程

说明

将选择框1的外观样式改为平面。

参见：例程1


上边线 属性 所属对象：工具条

数据类型：逻辑型；本属性指定是否在工具条的顶部显示上边分隔线。

语法： 工具条.上边线 = 逻辑型

应用对象：

工具条

例程

说明

设置工具条1的上面显示一条边界线

参见：例程1


列表方式 属性 所属对象：工具条

数据类型：逻辑型；本属性指定在显示按钮时是否将标题文本显示在图片的右边。

语法： 工具条.列表方式 = 逻辑型

应用对象：

工具条

例程

说明

将工具条1的标题和图标排列为一行（如有文字便会起效，它会自动空出一个图标的位置）

参见：例程1


允许多行 属性 所属对象：工具条

数据类型：逻辑型；本属性指定是否允许多行显示按钮。

语法： 工具条.允许多行 = 逻辑型

应用对象：

工具条

例程

说明

使工具条1的按钮排列不折行

参见：例程1


起始空白 属性 所属对象：工具条

数据类型：整数型；本属性指定在工具条首部所预留空白的尺寸，单位为像素。

语法： 工具条.起始空白 = 整数型

应用对象：

工具条

例程

说明

让工具条1的左边空出50像素的位置

参见：例程1


字体 属性 数据类型：字体；

字体 属性 所属对象：工具条

数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

编辑框、组合框

例程

说明

设置编辑框的字体的加粗属性为真

参见：例程1


图片组 属性 所属对象：工具条

数据类型：字节集；为工具条各按钮提供标志图片。

语法： 对象.图片组 = 字节集型

应用对象：

状态条 工具条 超级列表框

例程

说明

为工具条1设置按钮使用的图片组（加入图片组后要调用才能看见）

参见：例程1


热点图片组 属性 所属对象：工具条

数据类型：字节集；为工具条各按钮提供当鼠标移动到此按钮上时所显示的标志图片，仅当“平面”属性为真时才有效。

语法： 工具条.热点图片组= 字节集型

应用对象：

工具条

例程

说明

设置工具条1的焦点的图片组（为按钮设置图片时‘通常’和‘热点’使用一个索引）

参见：例程1


禁止图片组 属性 所属对象：工具条

数据类型：字节集；为工具条各按钮提供当此按钮被禁止时所显示的标志图片。

语法： 工具条.禁止图片组 = 字节集型

应用对象：

工具条

例程

说明

和热点图片组一样，如果无禁止图片组图片的默认禁止是把图片变成灰阶

参见：例程1


按钮 属性 数据类型：字节集型；

按钮 属性 所属对象：工具条

数据类型：字节集型；

本属性设置工具条各按钮的信息。

选中工具条，单击属性表中“按钮”行右边的省略号按钮，在所弹出来的按钮设置对话框中设置各个按钮的信息，然后回车关闭对话框。运行后，您现在可以看到工具条的按钮样式。

应用对象：

工具条

例程

说明

打开工具条的按钮编辑对话框（属于设计属性）


插入按钮 方法 所属对象：工具条

将指定按钮插入到工具条中，返回插入后该按钮所处的位置。

语法： 整数型 工具条．插入按钮 （［插入位置］，［类型］，［图片索引］，［标题］，［动态提示文本］，［按钮状态］）

参数名 | 描 述
插入位置 | 可选的；整数型。指定新按钮插入的位置索引，0 为栏目一，1 为栏目二，如此类推。如果提供 -1 ，则插入到工具条的尾部。如果本参数被省略，默认值为 -1 。
类型 | 可选的；整数型。按钮的类型可以为以下常量值之一： 0: #普通按钮； 1: #多选按钮； 2: #单选按钮； 3: #下拉按钮； 4: #分隔条。 如果本参数被省略，默认值为“#普通按钮”。
图片索引 | 可选的；整数型。图片索引用于指定图片组属性中的某张图片，该图片将被显示在按钮表面。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。
标题 | 可选的；文本型。本参数指定显示在按钮下的标题文本。如果被省略，默认值为空文本。
动态提示文本 | 可选的；文本型。本参数指定当鼠标移动到按钮上并停留一段时间后所动态显示的提示文本。如果被省略，默认值为空文本。
按钮状态 | 可选的；整数型。本参数指定按钮的存在状态。状态值为 0 或者以下常量值任意组合(相加)： 1: #选中； 2: #按下； 4: #禁止； 8: #隐藏； 16: #变灰。 其中“选中”状态在类型为多选按钮或单选按钮时有效，“按下”状态在类型为普通按钮时有效。如果本参数被省略，默认值为 0 。

例程

说明

为工具条1的第2个按钮之后插入按钮（如不存在此位置，会在最后插入）

参见：例程1


删除按钮 方法 所属对象：工具条

删除指定的按钮。

语法： 无返回值 工具条．删除按钮 （按钮索引）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。

例程

说明

删除工具条1的索引2的按钮（如果不存在命令作废）

参见：例程1


取按钮数 方法 所属对象：工具条

取回工具条中按钮的总数。

语法： 整数型 工具条．取按钮数 （）

例程

说明

显示出工具条1的按钮的数量（包括分割条）

参见：例程1


取标题 方法 所属对象：工具条

取回指定按钮的标题文本。

语法： 文本型 工具条．取标题 （按钮索引）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。

例程

说明

取出工具条1的第3个按钮的标题（取出的标题是先前定义的，有快捷方式连接的标题是会取出‘&’）

参见：例程1


取提示文本 方法 所属对象：工具条

取回指定按钮的提示文本。

语法： 文本型 工具条．取提示文本 （按钮索引）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。

例程

说明

编辑框1显示出工具条1的索引3的按钮的提示标签标题

参见：例程1


取类型 方法 所属对象：工具条

取回指定按钮的类型，返回值为以下常量值之一： 0: #普通按钮； 1: #多选按钮； 2: #单选按钮； 3: #下拉按钮； 4: #分隔条。

语法： 整数型 工具条．取类型 （按钮索引）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。

例程

说明：

显示出工具条1的索引2的按钮的类型

参见：例程1


取状态 方法 所属对象：工具条

取回指定按钮的状态，状态值为 0 或者以下常量值任意组合(相加)： 1: #选中； 2: #按下； 4: #禁止； 8: #隐藏； 16: #变灰。 可以用“位与”命令来判断指定的状态值是否被置位，如：“如果真 (位与 (工具条1.取状态 (0)，#禁止) = #禁止)”语句即可判断工具条1的第一个按钮是否已被禁止。

语法： 整数型 工具条．取状态 （按钮索引）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。

例程

说明

显示出工具条1的索引3的按钮的类型

参见：例程1


取图片 方法 所属对象：工具条

取回指定按钮的图片索引，图片索引指向图片组属性中的某一图片，从 0 开始，-1 表示本按钮无图片标志。

语法： 整数型 工具条．取图片 （按钮索引）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。

例程

说明

显示出工具条1的索引3的按钮的图片索引

参见：例程1


置提示文本 方法 所属对象：工具条

设置指定按钮的提示文本。

语法： 无返回值 工具条．置提示文本 （按钮索引，［动态提示文本］）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。
动态提示文本 | 可选的；文本型。本参数指定当鼠标移动到按钮上并停留一段时间后所动态显示的提示文本。如果被省略，默认值为空文本。

例程

说明

设置工具条1的索引2的提示文本（如不存在命令作废）

参见：例程1


加入状态 方法 所属对象：工具条

将指定状态值加入到按钮的存在状态中。

语法： 无返回值 工具条．加入状态 （按钮索引，［按钮状态］）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。
按钮状态 | 可选的；整数型。本参数指定按钮的存在状态。状态值为 0 或者以下常量值任意组合(相加)： 1: #选中； 2: #按下； 4: #禁止； 8: #隐藏； 16: #变灰。 其中“选中”状态在类型为多选按钮或单选按钮时有效，“按下”状态在类型为普通按钮时有效。如果本参数被省略，默认值为 0 。

例程

说明

设置工具条的按钮1状态为按钮按下状态。

参见：例程1


去除状态 方法 所属对象：工具条

从按钮的存在状态中去除指定状态值。

语法： 无返回值 工具条．去除状态 （按钮索引，［按钮状态］）

参数名 | 描 述
按钮索引 | 必需的；整数型。0 为按钮一，1 为按钮二，如此类推。
按钮状态 | 可选的；整数型。本参数指定按钮的存在状态。状态值为 0 或者以下常量值任意组合(相加)： 1: #选中； 2: #按下； 4: #禁止； 8: #隐藏； 16: #变灰。 其中“选中”状态在类型为多选按钮或单选按钮时有效，“按下”状态在类型为普通按钮时有效。如果本参数被省略，默认值为 0 。

例程

说明

去除工具条1的按钮4的禁止的状态（只有此状态才会有效，有按下的状态去除一下选中状态不会变成选中状态）

参见：例程1


被单击 事件 所属对象：工具条

当工具条按钮被单击时即产生此事件。

语法： 无返回值 _工具条_被单击 （按钮索引）

参数名 | 描 述
按钮索引 | 整数型；提供被单击或被下拉按钮的索引。0 为按钮一，1 为按钮二，如此类推。

例程

说明

判断在单击是索引1时打开通用对话框1（会忽略分割条）

参见：例程1


被下拉 事件 所属对象：工具条

当下拉型按钮右侧向下箭头被单击时即产生此事件。

语法： 无返回值 _工具条_被下拉 （按钮索引，下拉横座标，下拉纵座标）

参数名 | 描 述
按钮索引 | 整数型；提供被单击或被下拉按钮的索引。0 为按钮一，1 为按钮二，如此类推。
下拉横座标 | 整数型；提供按钮被下拉的屏幕座标位置，如果在事件处理子程序中需要弹出菜单或弹出子窗口，可以直接使用此座标。具体请见本支持库附带的工具条相关例程。
下拉纵座标 | 整数型；提供按钮被下拉的屏幕座标位置，如果在事件处理子程序中需要弹出菜单或弹出子窗口，可以直接使用此座标。具体请见本支持库附带的工具条相关例程。

例程

说明

在按钮索引3时下拉出菜单（如此时要操作的是同级的控件（列表框...）下拉按钮不会一直按下到取消时）

参见：例程1


超级列表框

超级列表框 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库一

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 文本颜色 | 文本背景色 | 背景颜色
字体 | 类型 | 图标对齐方式 | 自动排列图标
标题自动换行 | 报表列 | 无表头 | 表头图片组
表头可单击 | 整行选择 | 显示表格线 | 表列可拖动
图片组 | 状态图片组 | 热点跟踪 | 手形指针
标注非热点 | 标注热点 | 允许编辑 | 排序方式
是否有检查框 | 平面滚动条 | 单一选择 | 现行选中项
始终显示选择项 | 表项 | 结束编辑文本 |

方法：

取标题 | 取图片 | 取当前状态图片 | 取缩进数目
取表项数值 | 置标题 | 置图片 | 置状态图片
置缩进数目 | 置表项数值 | 取被选择表项 | 取已选择表项数
是否被选择 | 选择表项 | 取消表项选择 | 取表项数
插入表项 | 删除表项 | 全部删除 | 查找表项
查找表项数值 | 保证显示 | 排列图标 | 取列标题
取列对齐方式 | 取列宽 | 取列图片 | 图片是否居右
置列标题 | 置列宽 | 置列图片 | 取列数
插入列 | 删除列 | 进入编辑 |

自有事件：

当前表项被改变 | 表项被激活 | 表头被单击 | 表项跟踪
左键单击表项 | 右键单击表项 | 开始编辑 | 结束编辑

基本事件：


边框 属性 数据类型：整数型；

边框 属性 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

语法： 对象.边框 = 整数型

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

例程

说明

设置超级列表框的边框为边框样式组合框现行选中的项目。

参见：例程


文本颜色 属性 所属对象：超级列表框

文本颜色 属性 操作系统支持：Windows

数据类型：整数型；

语法：对象.文本颜色 = 颜色值

例程

说明

设置超级列表框的文本颜色为文本颜色选择器所选择的颜色。

参见：例程


文本背景色 属性 所属对象：超级列表框

文本背景色 属性 操作系统支持：Windows

数据类型：整数型；

  语法：对象名.文本背景色=颜色值

例程

说明

设置超级列表框文本的背景颜色为文本背景颜色选择器所选择的颜色。

参见：例程


背景颜色 属性 所属对象：超级列表框

背景颜色 属性 操作系统支持：Windows

数据类型：整数型；

指定窗口单元的背景色。

例程

说明

设置超级列表框的背景颜色为背景颜色选择器所选择的颜色。

参见：例程


字体 属性 所属对象：超级列表框

字体 属性 操作系统支持：Windows

数据类型：字体；

例程

说明

设置超级列表框字体的属性。

参见：例程


类型 属性 所属对象：超级列表框

类型 属性 操作系统支持：Windows

数据类型：整数型；本属性指定列表框的类型。

可供选择的属性值：
0、大图标列表框
1、小图标列表框
2、普通列表框
3、报表列表框

例程

说明

设置超级列表框的列表类型为类型组合框现行选中的项目。

参见：例程


图标对齐方式 属性 所属对象：超级列表框

图标对齐方式 属性 操作系统支持：Windows

数据类型：整数型；本属性指定小图标列表框中的图标对齐方式。

可供选择的属性值：
0、顶部对齐
1、左边对齐

例程

说明

设置超级列表框的图标的对齐方式。只在小图标列表框有效。

参见：例程


自动排列图标 属性 所属对象：超级列表框

自动排列图标 属性 操作系统支持：Windows

数据类型：逻辑型；本属性指定在大图标和小图标列表框中是否自动排列图标。

例程

说明

让超级列表框的图标在长度不够时会折到下一行

参见：例程


标题自动换行 属性 所属对象：超级列表框

标题自动换行 属性 操作系统支持：Windows

数据类型：逻辑型；本属性指定在大图标和小图标列表框中如果标题过长是否自动换行。

例程

说明

使超过一定长度的超级列表框图标的标题折行显示。

参见：例程


报表列 属性 所属对象：超级列表框

报表列 属性 操作系统支持：Windows

数据类型：字节集；

本属性设置报表列表框中各列的信息。注意：必须在类型里选择报表列表框后本属性才有效，报表列表框只有在设置了列后才能显示出其中的内容。

例程

设置报表列的结果

说明

这是个设置的属性，只有在类型报表列表框时才有效。

参见：例程


无表头 属性 所属对象：超级列表框

无表头 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定报表列表框中是否没有表头。

例程

说明

设置超级列表框表头的可见性。

参见：例程


表头图片组 属性 所属对象：超级列表框

表头图片组 属性 操作系统支持：Windows

数据类型：字节集；

本属性为报表列表框的表头提供图标图片。

例程

说明

设置超级列表框的表头图片。

参见: 例程


表头可单击 属性 所属对象：超级列表框

表头可单击 属性 操作系统支持：Windows

数据类型：逻辑型；

如果报表列表框中有表头，本属性指定表头列是否可以被作为按钮单击。

例程

说明

设置超级列表框的表头是否可单击。

参见: 例程


整行选择 属性 所属对象：超级列表框

整行选择 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定当在报表列表框中选中一行时是否高亮度显示整行。

例程

说明

让超级列表框的子项可同时被选中

参见: 例程


显示表格线 属性 所属对象：超级列表框

显示表格线 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定在报表列表框中是否显示表格线。

例程

说明

设置超级列表框是否显示表格线。

参见: 例程


表列可拖动 属性 所属对象：超级列表框

表列可拖动 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定在报表列表框中是否允许用户拖动表头列以改变列位置。

例程

说明

设置超级列表框的表头可左右拖动，改变列所在的位置。

参见: 例程


图片组 属性 所属对象：超级列表框

图片组 属性 操作系统支持：Windows

数据类型：字节集；

本属性为各列表框项目提供图标图片。

例程

说明

为超级列表框添加图片组数据

参见: 例程


状态图片组 属性 所属对象：超级列表框

状态图片组 属性 操作系统支持：Windows

数据类型：字节集；

本属性为列表框中的表项提供状态图片。

例程

说明

为超级列表框设置状态图片组。状态图片只有放在检查框中才有明显的变化：状态图片的变化

随着状态图片被单击而依次显示状态图片组中的所有图片。状态图片通常显示在表项图标的左

侧。本图片组中的图片最多只能有前 15 幅（索引为 0 到 14）可用于表项状态图标。

索引不能大于14(Windows的局限)

参见: 例程


热点跟踪 属性 所属对象：超级列表框

热点跟踪 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定在列表框中是否跟踪并高亮度显示当前鼠标所处表项，此表项称为“热点表项”。

例程

说明

设置超级列表框的表项可跟随鼠标移动热点

参见：例程


手形指针 属性 所属对象：超级列表框

手形指针 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定在列表框中当鼠标移动到热点表项时是否将鼠标指针改为手形。

注意：只有当热点跟踪属性为真时，本属性才有效果。

例程

说明

设置超级列表框的热点手型指针。

参见：例程


标注非热点 属性 所属对象：超级列表框

标注非热点 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定在列表框中当鼠标移动到热点表项时是否将所有非此表项的标题加上下划线显示。

例程

说明：

设置超级列表框在热点跟踪时对非热点表项的标注线（如无热点跟踪设置无效）

参见：例程


标注热点 属性 所属对象：超级列表框

标注热点 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定在列表框中当鼠标移动到热点表项时是否将此表项的标题加上下划线显示。

例程

说明

设置超级列框在热点跟踪时是否显示热点标注线（对所选择的表项的标题加下划线）。

参见：例程


允许编辑 属性 所属对象：超级列表框

允许编辑 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定是否允许编辑表项标题，仅在“热点跟踪”属性为假时才有效。

例程

说明

设置超级列表框的表项的标题是否可以被编辑。

参见：例程


排序方式 属性 所属对象：超级列表框

排序方式 属性 操作系统支持：Windows

数据类型：整数型；本属性指定列表框表项的标题排序方式。

可供选择的属性值：
0、不排序
1、正向排序
2、逆向排序

例程

说明

设置超级列表框的标题排列顺序。按照数字（0-9），字母（a-z,字母相同，小写在前，大写在后），汉字（比较拼音）顺序排序。

例如：正向排序：0，1，2，a，A，b,好，易，音；逆向排序就是反过来，从后向前排序。

参见：例程


是否有检查框 属性 所属对象：超级列表框

是否有检查框 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定是否在表项前加上检查框，注意如果“状态图片组”属性被设置，则默认的检查框图片将被“状态图片组”中的图片代替，并且当用户单击表项中的状态图片时，将自动遍历显示“状态图片组”中的所有图片。

例程

说明

设置超级列表框的表项多选框的按钮，如果设为假，原有的状态也便消失

参见：例程


平面滚动条 属性 所属对象：超级列表框

平面滚动条 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定是否以平面方式显示列表框滚动条。

例程

说明

设置超级列表框滚动条的平面显示方式。

参见：例程


单一选择 属性 所属对象：超级列表框

单一选择 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定列表框中是否同时只允许选择一个表项。

例程

说明

设置超级列表框的表项可否多项选择。

参见：例程


现行选中项 属性 所属对象：超级列表框

现行选中项 属性 操作系统支持：Windows

数据类型：整数型；

本属性指定列表框中现行被选中项目的位置，位置值从 0 开始， -1 表示现行没有被选中的项目。注意如果“单一选择”属性为假，则本属性只可读。

例程

说明

显示超级列表框的现行选中项。

参见：例程


始终显示选择项 属性 所属对象：超级列表框

始终显示选择项 属性 操作系统支持：Windows

数据类型：逻辑型；

本属性指定是否始终显示当前被选择项目，即使列表框失去焦点。

例程

说明

设置超级列表框是否在失去焦点时还显示选中的项目。

参见：例程


表项 属性 所属对象：超级列表框

表项 属性 操作系统支持：Windows

数据类型：字节集；本属性指定列表框中的各表项。

例程

设置后的结果

说明

这是个设置的属性，在对话框中设置超级列表框的项目和各种样式。设置的图片在图片组属性中。

参见：例程


结束编辑文本 属性 所属对象：超级列表框

结束编辑文本 属性 操作系统支持：Windows

数据类型：文本型；

只读；本属性仅在运行时有效，用作为“结束编辑”事件的处理子程序提供标题被编辑后的内容。

例程

说明

显示出超级列表框在结束编辑后新的文本。

参见：例程


取标题 方法 所属对象：超级列表框

取标题 方法 所属对象：超级列表框 操作系统支持：Windows

取指定表项或子项的标题。

语法： 文本型 超级列表框．取标题 （表项索引，［列索引］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
列索引 | 可选的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始，如果当前列表框类型不是报表型列表框，提供 0 值即可。如果本参数被省略，默认值为 0 。

例程

说明

显示出超级列表框中被左键单击的表项名称。

参见：例程


取图片 方法 所属对象：超级列表框

取图片 方法 所属对象：超级列表框 操作系统支持：Windows

取回指定表项或子项的图片索引，图片索引指向图片组属性中的某一图片，从 0 开始，-1 表示无图片。

语法： 整数型 超级列表框．取图片 （表项索引，［列索引］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
列索引 | 可选的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始，如果当前列表框类型不是报表型列表框，提供 0 值即可。如果本参数被省略，默认值为 0 。

例程

说明

将超级列表框中表项的图片互换。

参见：例程


取当前状态图片 方法 所属对象：超级列表框

取当前状态图片 方法 所属对象：超级列表框 操作系统支持：Windows

取回指定表项的当前状态图片索引，图片索引指向状态图片组属性中的某一图片，从 0 开始，-1 表示无图片。如果“是否有检查框”属性为真，返回值是当前检查框的选中状态，1表示被选中，0表示未选中。

语法： 整数型 超级列表框．取当前状态图片 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

设置超级列表框第三个表项的状态图片。

参见：例程


取缩进数目 方法 所属对象：超级列表框

取缩进数目 方法 所属对象：超级列表框 操作系统支持：Windows

取回指定表项的缩进数目。

语法： 整数型 超级列表框．取缩进数目 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

取出超级列表框1的当前可显项中的第几个位置。

参见：例程


取表项数值 方法 所属对象：超级列表框

取表项数值 方法 所属对象：超级列表框 操作系统支持：Windows

返回与指定表项相关联的数值。如果该表项不存在，返回 0 。

语法： 整数型 超级列表框．取表项数值 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

显示出超级列表框项目数值

参见：例程


置标题 方法 所属对象：超级列表框

置标题 方法 所属对象：超级列表框 操作系统支持：Windows

设置指定表项或子项的标题。

语法： 无返回值 超级列表框．置标题 （表项索引，［列索引］，［标题］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
列索引 | 可选的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始，如果当前列表框类型不是报表型列表框，提供 0 值即可。如果本参数被省略，默认值为 0 。
标题 | 可选的；文本型。本参数指定表项或子项的标题文本。如果被省略，默认值为空文本。

例程

说明

设置超级列表框表项的标题（在可编辑时置的文本无效，这只是一种遮掩不是真正的标题）

参见：例程


置图片 方法 所属对象：超级列表框

置图片 方法 所属对象：超级列表框 操作系统支持：Windows

设置指定表项或子项的图片。

语法： 无返回值 超级列表框．置图片 （表项索引，［列索引］，［图片索引］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
列索引 | 可选的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始，如果当前列表框类型不是报表型列表框，提供 0 值即可。如果本参数被省略，默认值为 0 。
图片索引 | 可选的；整数型。图片索引用于指定“图片组”属性中的某张图片。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。

例程

说明

改变超级列表框表项的图片（图片是从超级列表框的图片组中提取出的）

参见：例程


置状态图片 方法 所属对象：超级列表框

置状态图片 方法 所属对象：超级列表框 操作系统支持：Windows

设置指定表项的状态图片。如果“是否有检查框”属性为真，调用“置状态图片 (0)”或“置状态图片 (1)”可以设置表项检查框的选中状态。

语法： 无返回值 超级列表框．置状态图片 （表项索引，［状态图片索引］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
状态图片索引 | 可选的；整数型。状态图片索引用于指定“状态图片组”属性中的某张图片。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。

例程

说明

设置超级列表框表项的状态图片（在表项左边的一个小图标，是检查框的自定义图片）

本属性为列表框中的表项提供状态图片。状态图片通常显示在表项图标的左侧。本图片

组中的图片最多只能有前 15 幅（索引为 0 到 14）可用于表项状态图标。索引不能大于14(Windows的局限)

参见：例程


置缩进数目 方法 所属对象：超级列表框

置缩进数目 方法 所属对象：超级列表框 操作系统支持：Windows

设置指定表项的缩进数目。

语法： 无返回值 超级列表框．置缩进数目 （表项索引，［缩进数目］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
缩进数目 | 可选的；整数型。“缩进数目”仅在报表型列表框才有效，用作指定显示时在表项首部增加的空白数。如果本参数被省略，默认值为 0 。

例程

说明

设置超级列表框表项的缩进位置（只有在报表时才有效）

参见：例程


置表项数值 方法 所属对象：超级列表框

置表项数值 方法 所属对象：超级列表框 操作系统支持：Windows

设置与指定表项相关联的数值。

语法： 无返回值 超级列表框．置表项数值 （表项索引，［表项数值］）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。
表项数值 | 可选的；整数型。该数值与指定表项相关联。如果本参数被省略，默认值为 0 。

例程

说明

设置超级列表框的表项数值

参见：例程


取被选择表项 方法 所属对象：超级列表框

取被选择表项 方法 所属对象：超级列表框 操作系统支持：Windows

返回一个整数数组，內含所有当前被选择表项的位置索引。如果当前没有被选择表项，返回空数组。

语法： 整数型数组 超级列表框．取被选择表项 （）

例程

说明

在允许多选的情况下，取出超级列表框所选的项目，根据索引数组中的索引值取得所选择的表项名称。

参见：例程


取已选择表项数 方法 所属对象：超级列表框

取已选择表项数 方法 所属对象：超级列表框 操作系统支持：Windows

返回当前已被选择表项的数目。

语法： 整数型 超级列表框．取已选择表项数 （）

例程

说明

取出超级列表框现在所选中的项目的数量（是在多选的时候用的）

参见：例程


是否被选择 方法 所属对象：超级列表框

是否被选择 方法 所属对象：超级列表框 操作系统支持：Windows

判断指定表项是否已经被选择，如已被选择，返回真，否则返回假。

语法： 逻辑型 超级列表框．是否被选择 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

判断超级列表框的项目是否被选中（不是选择检查框）

参见：例程


选择表项 方法 所属对象：超级列表框

选择表项 方法 所属对象：超级列表框 操作系统支持：Windows

选择指定表项。

语法： 无返回值 超级列表框．选择表项 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

让超级列表框的项目0被选中。

参见：例程


取消表项选择 方法 所属对象：超级列表框

取消表项选择 方法 所属对象：超级列表框 操作系统支持：Windows

取消对指定表项的选择。

语法： 无返回值 超级列表框．取消表项选择 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

使超级列表框的项目0取消选中。

参见：例程


取表项数 方法 所属对象：超级列表框

取表项数 方法 所属对象：超级列表框 操作系统支持：Windows

返回列表框中所有表项的数目。

语法： 整数型 超级列表框．取表项数 （）

例程

说明：

取出超级列表框的现有的项目的数量。不包括表项的子项。

参见：例程


插入表项 方法 所属对象：超级列表框

插入表项 方法 所属对象：超级列表框 操作系统支持：Windows

在指定的位置插入新表项，成功返回新表项的位置索引，失败返回 -1 。

语法： 整数型 超级列表框．插入表项 （［插入位置］，［标题］，［图片索引］，［状态图片索引］，［缩进数目］，［表项数值］）

参数名 | 描 述
插入位置 | 可选的；整数型。指定新表项插入时的位置索引，索引值从 0 开始。如果提供 -1 ，则插入到列表框的尾部。如果本参数被省略，默认值为 -1 。
标题 | 可选的；文本型。本参数指定表项的标题文本。如果被省略，默认值为空文本。
图片索引 | 可选的；整数型。图片索引用于指定“图片组”属性中的某张图片。索引值从 0 开始，索引不能大于14(Windows的局限)。-1 表示无图片。如果本参数被省略，默认值为 -1 。
状态图片索引 | 可选的；整数型。状态图片索引用于指定“状态图片组”属性中的某张图片。索引值从 0 开始，索引不能大于14(Windows的局限)。-1 表示无图片。如果本参数被省略，默认值为 -1 。
缩进数目 | 可选的；整数型。“缩进数目”仅在报表型列表框才有效，用作指定显示时在表项首部增加的空白数。如果本参数被省略，默认值为 0 。
表项数值 | 可选的；整数型。该数值与指定表项相关联。如果本参数被省略，默认值为 0 。

例程

说明：

向超级列表框中插入项目。在报表列表框和普通列表框中可以在中间插入表项；“类型”属性为“大图标列表框”或“小图标列表框”的情况下，将始终在所有表项的最后插入新的表项

参见：例程


删除表项 方法 所属对象：超级列表框

删除表项 方法 所属对象：超级列表框 操作系统支持：Windows

删除指定位置的表项。

语法： 无返回值 超级列表框．删除表项 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

删除超级列表框中的项目（不存在命令作废）

参见：例程


全部删除 方法 所属对象：超级列表框

全部删除 方法 所属对象：超级列表框 操作系统支持：Windows

删除所有的表项。

语法： 无返回值 超级列表框．全部删除 （）

例程

说明

把超级列表框中的所有项目全部删除

参见：例程


查找表项 方法 所属对象：超级列表框

查找表项 方法 所属对象：超级列表框 操作系统支持：Windows

查找具有指定标题的表项，成功返回被找到表项的位置索引，失败返回 -1 。

语法： 整数型 超级列表框．查找表项 （标题，［起始查找位置］，［是否精确匹配］）

参数名 | 描 述
标题 | 必需的；文本型。本参数指定欲查找表项的标题文本。
起始查找位置 | 可选的；整数型。本参数指定查找表项的起始位置。如果本参数被省略，默认值为 0 ，即从首项开始查找。
是否精确匹配 | 可选的；逻辑型。本参数指定匹配标题文本时是否为精确匹配，如果本参数为假，则只要表项标题首部包含指定文本即认为匹配成功。如果本参数被省略，默认值为真。

例程

说明

显示要查找的项目。

参见：例程


查找表项数值 方法 操作系统支持：Windows 所属对象：超级列表框

查找具有指定关联数值的表项，成功返回被找到表项的位置索引，失败返回 -1 。

语法： 整数型 超级列表框．查找表项数值 （［起始查找位置］，［表项数值］）

参数名 | 描 述
起始查找位置 | 可选的；整数型。本参数指定查找表项的起始位置。如果本参数被省略，默认值为 0 ，即从首项开始查找。
表项数值 | 可选的；整数型。该数值与指定表项相关联。如果本参数被省略，默认值为 0 。

例程

说明

显示要查找的表项。

参见：例程


保证显示 方法 操作系统支持：Windows 所属对象：超级列表框

确保指定表项能够显示出来，如果不能显示，则自动滚动并显示该表项。

语法： 无返回值 超级列表框．保证显示 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

保证所要查找的表项在超级列表框中显示出来。

参见：例程


排列图标 方法 所属对象：超级列表框

排列图标 方法 所属对象：超级列表框 操作系统支持：Windows

自动排列大图标或小图标列表框中的图标。

语法： 无返回值 超级列表框．排列图标 （）

例程

说明

将超级列表框中的图标排列的整齐一点。

参见：例程


取列标题 方法 所属对象：超级列表框

取列标题 方法 所属对象：超级列表框 操作系统支持：Windows

返回报表型列表框中指定列的标题。

语法： 文本型 超级列表框．取列标题 （列索引）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。

例程

说明

取出超级列表框被单击的列的标题。

参见：例程


取列对齐方式 方法 所属对象：超级列表框

取列对齐方式 方法 所属对象：超级列表框 操作系统支持：Windows

取回报表型列表框中指定列的对齐方式。返回值为以下常量之一： 0：#左对齐； 1：#中间对齐； 2：#右对齐。

语法： 整数型 超级列表框．取列对齐方式 （列索引）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。

例程

说明

显示报表型超级列表框的列的对齐方式

参见：例程


取列宽 方法 所属对象：超级列表框

取列宽 方法 所属对象：超级列表框 操作系统支持：Windows

返回报表型列表框中指定列的宽度，如指定列不存在，返回 0 。

语法： 整数型 超级列表框．取列宽 （列索引）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。

例程

说明

显示超级列表框被单击的列的宽度。

参见：例程


取列图片 方法 所属对象：超级列表框

取列图片 方法 所属对象：超级列表框 操作系统支持：Windows

返回报表型列表框中指定列的图片索引。

语法： 整数型 超级列表框．取列图片 （列索引）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。

例程

说明

显示超级列表框被单击的列的表头图片。

参见：例程


图片是否居右 方法 所属对象：超级列表框

图片是否居右 方法 所属对象：超级列表框 操作系统支持：Windows

如果报表型列表框中指定列的图片居右显示，返回真，否则返回假。

语法： 逻辑型 超级列表框．图片是否居右 （列索引）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。

例程

说明

判断超级列表框被单击的列的图片是否居右。

参见：例程


置列标题 方法 所属对象：超级列表框

置列标题 方法 所属对象：超级列表框 操作系统支持：Windows

设置报表型列表框中指定列的标题。

语法： 无返回值 超级列表框．置列标题 （列索引，［标题］）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。
标题 | 可选的；文本型。本参数指定报表列的标题文本。如果被省略，默认值为空文本。

例程

说明

设置超级列表框被单击的列的标题。

参见：例程


置列宽 方法 所属对象：超级列表框

置列宽 方法 所属对象：超级列表框 操作系统支持：Windows

设置报表型列表框中指定列的宽度。

语法： 无返回值 超级列表框．置列宽 （列索引，［列宽］）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。
列宽 | 可选的；整数型。本参数指定报表列的宽度，单位为像素。如果参数值提供为 -1 ，则根据列数据最大宽度自动调整列尺寸，如果参数值提供为 -2 ，则根据列标题宽度自动调整列尺寸。如果本参数被省略，默认值为 -1 。

例程

说明

设置超级列表框被单击的列的宽度。

参见：例程


置列图片 方法 所属对象：超级列表框

置列图片 方法 所属对象：超级列表框 操作系统支持：Windows

设置报表型列表框中指定列的标志图片。

语法： 无返回值 超级列表框．置列图片 （列索引，［图片索引］）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。
图片索引 | 可选的；整数型。图片索引用于指定“表头图片组”属性中的某张图片。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。

例程

说明

设置超级列表框的列的图片。

参见：例程


取列数 方法 所属对象：超级列表框

取列数 方法 所属对象：超级列表框 操作系统支持：Windows

返回报表型列表框中列的总数。

语法： 整数型 超级列表框．取列数 （）

例程

说明

显示超级列表框的列数。

参见：例程


插入列 方法 所属对象：超级列表框

插入列 方法 所属对象：超级列表框 操作系统支持：Windows

在报表型列表框中指定位置插入新的列，成功返回新列的位置索引，失败返回 -1 。

语法： 整数型 超级列表框．插入列 （［插入位置］，［标题］，［列宽］，［对齐方式］，［图片索引］，［图片是否居右］）

参数名 | 描 述
插入位置 | 可选的；整数型。指定新列插入时的位置索引，索引值从 0 开始。如果提供 -1 ，则插入到尾部。如果本参数被省略，默认值为 -1 。
标题 | 可选的；文本型。本参数指定报表列的标题文本。如果被省略，默认值为空文本。
列宽 | 可选的；整数型。本参数指定报表列的宽度，单位为像素。如果被省略，默认值为 50 。
对齐方式 | 可选的；整数型。参数可以为以下常量之一： 0：#左对齐； 1：#中间对齐； 2：#右对齐。如果本参数被省略，默认值为“#左对齐”。
图片索引 | 可选的；整数型。图片索引用于指定“表头图片组”属性中的某张图片。索引值从 0 开始，-1 表示无图片。如果本参数被省略，默认值为 -1 。
图片是否居右 | 可选的；逻辑型。指定图片是否显示在右边，如果本参数被省略，默认值为假。

例程

说明

在超级列表框被单击的表头处插入列。

参见：例程


删除列 方法 所属对象：超级列表框

删除列 方法 所属对象：超级列表框 操作系统支持：Windows

删除报表型列表框中指定位置处的列。

语法： 无返回值 超级列表框．删除列 （列索引）

参数名 | 描 述
列索引 | 必需的；整数型。用作指定报表型列表框中项目所处的列，索引值从 0 开始。

例程

说明

删除超级列表框中被单击的列

参见：例程


进入编辑 方法 所属对象：超级列表框

进入编辑 方法 所属对象：超级列表框 操作系统支持：Windows

让指定表项进入编辑状态，执行本命令成功的前提是“允许编辑”属性为真。

语法： 无返回值 超级列表框．进入编辑 （表项索引）

参数名 | 描 述
表项索引 | 必需的；整数型。用于指定列表框中的某一项目，索引值从 0 开始。

例程

说明

使超级列表框被选择的项目进入编辑状态。

参见：例程


当前表项被改变 事件 所属对象：超级列表框

当前表项被改变 事件 所属对象：超级列表框 操作系统支持：Windows

如果当前焦点所处表项被改变即产生此事件，接收到此事件后读取“现行选中项”属性即可获得当前表项的索引。

语法： 无返回值 _超级列表框_当前表项被改变 （）

例程

说明

当前选择的表项被改变，就触发此事件 。

参见：例程


表项被激活 事件 所属对象：超级列表框

表项被激活 事件 所属对象：超级列表框 操作系统支持：Windows

在下列情况下会产生本事件： 1、双击某表项； 2、选中某表项后按回车； 3、当“热点跟踪”属性为真时单击某表项。 接收到此事件后读取“现行选中项”属性即可获得当前被激活表项的索引。

语法： 无返回值 _超级列表框_表项被激活 （）

例程

说明

显示被激活的表项的名称。

参见：例程


表头被单击 事件 所属对象：超级列表框

表头被单击 事件 所属对象：超级列表框 操作系统支持：Windows

当使用鼠标左键在报表型列表框的某表头列上单击时产生此事件。

语法： 无返回值 _超级列表框_表头被单击 （被单击列索引）

参数名 | 描 述
被单击列索引 | 整数型；指示被单击表头列的索引，从 0 开始。

例程

说明

根据事件中的参数值取出超级列表框被单击的表头的名称。

参见：例程


表项跟踪 事件 所属对象：超级列表框

表项跟踪 事件 所属对象：超级列表框 操作系统支持：Windows

当“热点跟踪”属性为真时移动鼠标到某表项上后即产生本事件，注意如果鼠标不处于任何表项上，“表项索引”参数将传递值 -1 。

语法： 无返回值 _超级列表框_表项跟踪 （表项索引）

参数名 | 描 述
表项索引 | 整数型；指示当前鼠标位置所处表项的索引，从 0 开始。

例程

说明

当鼠标移动到表项上时，就触发此事件，根据事件的参数取得该表项的名称。

参见：例程


左键单击表项 事件 所属对象：超级列表框

左键单击表项 事件 所属对象：超级列表框 操作系统支持：Windows

当用鼠标左键单击某表项时即产生此事件，接收到此事件后读取“现行选中项”属性即可获得被单击表项的索引。

语法： 无返回值 _超级列表框_左键单击表项 （）

例程

说明

当鼠标左键单击超级列表框中的某一表项时，就触发此事件。

参见：例程


右键单击表项 事件 所属对象：超级列表框

右键单击表项 事件 所属对象：超级列表框 操作系统支持：Windows

当用鼠标右键在某表项上单击时产生此事件，接收到此事件后读取“现行选中项”属性即可获取被单击表项的索引，调用系统核心支持库中的“取鼠标水平位置”、“取鼠标垂直位置”命令可获取当前鼠标单击位置。

语法： 无返回值 _超级列表框_右键单击表项 （）

例程

说明

当鼠标右键单击某一表项时，就触发此事件。

参见：例程


开始编辑 事件 所属对象：超级列表框

开始编辑 事件 所属对象：超级列表框 操作系统支持：Windows

当表项进入标题编辑状态前产生此事件，要产生本事件“允许编辑”属性必须为真。事件处理子程序返回假则不允许进入编辑状态，返回真或不返回值允许进入。

语法： 逻辑型 _超级列表框_开始编辑 （表项索引）

参数名 | 描 述
表项索引 | 整数型；指示即将进入或结束编辑状态的表项的索引，从 0 开始。

例程

说明

当超级列表框中某一表项进入编辑状态时，就触发此事件。

参见：例程


结束编辑 事件 所属对象：超级列表框

结束编辑 事件 所属对象：超级列表框 操作系统支持：Windows

当表项结束标题编辑状态前产生此事件，要产生本事件“允许编辑”属性必须为真。在事件处理子程序中读取“结束编辑文本”属性可以得知标题被编辑后的内容，事件处理子程序返回假不允许使用编辑后的内容替换原有标题，返回真或不返回值则允许替换。

语法： 逻辑型 _超级列表框_结束编辑 （表项索引）

参数名 | 描 述
表项索引 | 整数型；指示即将进入或结束编辑状态的表项的索引，从 0 开始。

例程

说明

当超级列表框中的某一表项结束编辑时，显示编辑后的新文本。

参见：例程


透明标签

透明标签 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库一不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
标题 | 效果 | 字体 | 文本颜色
横向对齐方式 | 是否自动折行 | 纵向对齐方式 |

基本事件：


标题 属性 数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

例程

说明

设置透明标签的标题。

参见：例程


效果 属性 数据类型：整数型； 操作系统支持：Windows

效果 属性 操作系统支持：Windows

数据类型：整数型

可供选择的属性值：
0、通常
1、凹入
2、凸出
3、阴影

语法： 对象.透明标签= 整数型

例程

说明

设置透明标签标题文本的显示效果。

参见：例程


字体 属性 数据类型：字体；

字体 属性 操作系统支持：Windows

数据类型：整数型

数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程

说明

设置透明标签中标题字体的属性。

参见：例程


文本颜色 属性 数据类型：整数型；

文本颜色 属性 操作系统支持：Windows

数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

例程

说明

设置透明标签的文本颜色为文本颜色选择器所选择的颜色。

参见：例程


横向对齐方式 属性 所属对象：透明标签

横向对齐方式 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、左对齐
1、居中
2、右对齐

语法： 对象.横向对齐方式 = 整数型

例程

说明

设置透明标签的横向对齐方式。

参见：例程


是否自动折行 属性 所属对象：透明标签

是否自动折行 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设定当文本内容超出右界后是否自动转到下一行显示。

语法： 对象.是否自动折行 = 逻辑型

例程

说明

启用透明标签的自动折行功能。

参见：例程


纵向对齐方式 属性 所属对象：透明标签

纵向对齐方式 属性 操作系统支持：Windows

数据类型：整数型；如果选用自动折行则本属性无效。

可供选择的属性值：
0、顶对齐
1、居中
2、底对齐

语法： 对象.纵向对齐方式= 整数型

例程

说明

设置透明标签的纵向对齐方式。

参见：例程


常量 | 常量值 | 描 述
#凹入 | 0 |
#无边框 | 1 |
#凸出 | 2 |
#普通按钮 | 0 |
#多选按钮 | 1 |
#单选按钮 | 2 |
#下拉按钮 | 3 |
#分隔条 | 4 |
#选中 | 1 |
#按下 | 2 |
#禁止 | 4 |
#隐藏 | 8 |
#变灰 | 16 |
#左对齐 | 0 |
#中间对齐 | 1 |
#右对齐 | 2 |


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1