扩展界面支持库二

扩展界面支持库二 帮助手册20080731版 返回支持库手册 返回首页

本支持库用作实现对扩展界面组件的支持。

操作系统支持： Windows

命令类别：

文档格式转换

图片组处理

窗口组件数据类型：

超级按钮 | 高级影像框 | 分隔条 | 超级编辑框
IP编辑框 |  |  |

其它数据类型：

字符格式

段落格式

常量表...

例程列表：

例程名称 | 下载 | 说明
AVI播放器 | AVI播放器.e | 演示高级影像框的使用方法
超级按钮演示 | 超级按钮.e | 演示超级按钮的使用方法
分隔条演示 | 分隔条演示.e | 本程序用做演示分隔条的使用方法
可执行文件浏览器 | 可执行文件浏览器.e | 演示动态管理图片组的方法
文档转换 | 文档转换.e | 演示如何进行文档格式转换。

适用版本，扩展界面支持库二 （1.2#0版）


文档格式转换

文档格式转换 类别 跳至：扩展界面支持库二


转换文档 命令 所属类别：文档格式转换

显示对话框打开指定文档并将其转换到RTF格式(RTF是国际标准丰富文本格式)，成功返回被转换文档的文件名且将转换结果存放到指定容器，失败或被用户中止返回空文本。本命令可以自动调用当前Windows系统中已登记的所有文档转换器以读入各种其它类型文档，譬如Word文档、Excel表格等等。

语法： 文本型 转换文档 （转换结果存放变量）

参数名 | 描 述
转换结果存放变量 | 必需的；文本型，参数数据只能提供变量。本参数提供用作存放转换后的RTF结果文本的变量。

例程：

说明：

将用户所选择的文本文档转换成RTF格式文本。

参见：例程


RTF到纯文本 命令 操作系统支持：Windows 所属类别：文档格式转换

取出并返回指定RTF丰富格式文本数据中的纯文本内容。

语法： 文本型 RTF到纯文本 （RTF文本）

参数名 | 描 述
RTF文本 | 必需的；文本型。本参数提供欲转换的RTF文本数据。

例程

说明：

将RTF文档内容超级编辑框中的RTF丰富文本内容转换成纯文本型的数据。

参见：例程


图片组处理

图片组处理 类别 跳至：扩展界面支持库二


加入图片 命令 所属类别：图片组处理

将图片加入到指定图片组数据中，成功返回所加入图片在被加入图片组中的位置索引，该索引值从 0 开始。如果失败，返回 -1 。注意如果欲加入图片的尺寸与图片组的单一图片尺寸参数不一致，该图片会被自动分解或缩放后加入。

语法： 整数型 加入图片 （图片组数据变量，欲加入图片，［图片透明色］）

参数名 | 描 述
图片组数据变量 | 必需的；字节集，参数数据只能提供变量。本参数提供即将被处理的图片组数据，处理后的图片组数据也被存放回此变量中。
欲加入图片 | 必需的；字节集。本参数提供即将被加入的图片数据，可以是JPG、BMP、GIF、ICO、CUR等各种格式。
图片透明色 | 可选的；整数型。本参数指定图片的背景透明色，如果为常量值“#默认色”，则系统自动取该图片最左上角一点的颜色值为透明色。如果本参数被省略，默认值为常量值“#默认色”。

例程：

说明：

根据图片组中图片的数量，依次循环加入到图片组变量A中。图片组的储存原理与数组的储存原理相似。

要注意图片组的首位索引是0，用计次循环时要减1。

参见：例程


合并图片组 命令 所属类别：图片组处理

将两份图片组数据合并到一起形成新的图片组数据，成功返回合并后的图片组数据，失败返回空字节集。

语法： 字节集 合并图片组 （图片组数据1，图片组数据2）

参数名 | 描 述
图片组数据1 | 必需的；字节集。本参数提供即将被合并的图片组数据。
图片组数据2 | 必需的；字节集。本参数提供即将被合并的图片组数据。

例程

说明：

将图片组变量A和图片组变量B中的数据合并到图片组变量中去。

合并前各图片组图片的大小不限，但是最后图片的大小都是图片组变量的大小。

参见：例程


提取加入图片 命令 所属类别：图片组处理

从指定文件中提取其中的某一图标，并将其加入到图片组中。成功返回所加入图标在被加入图片组中的位置索引，该索引值从 0 开始。如果失败，返回 -1 。

语法： 整数型 提取加入图片 （图片组数据容器，图标所在文件，［图标索引］，[提取小图标]）

参数名 | 描 述
图片组数据变量 | 必需的；字节集，参数数据只能提供变量。本参数提供即将被处理的图片组数据，处理后的图片组数据也被存放回此变量中。
图标所在文件 | 必需的；文本型。本参数提供图标所在的EXE、DLL或ICO文件名。
图标索引 | 可选的；整数型。本参数提供被提取图标在指定文件内所有图标中的索引位置，从 0 开始。如果本参数被省略，默认值为 0 。
提取小图标 | 可选；逻辑型。如果本参数为真，将从图标所在文件中提取小图标（通常为16*16大小）；如果为假，则提供大图标（通常为32*32大小）。如果本参数为真但没有相应小图标，自动提取相同索引处的大图标。如果本参数被省略，默认为假。

例程

说明：

打开提取图标对话框，选择含有图标的文件，将文件中的图标用计次循环依次取出，放到图片组变量中。

要注意图片组的索引从0开始，计次循环时要减1。

参见：例程


取文件内图标数 命令 所属类别：图片组处理

返回指定文件中所包含的图标数目。

语法： 整数型 取文件内图标数 （图标所在文件）

参数名 | 描 述
图标所在文件 | 必需的；文本型。本参数提供图标所在的EXE、DLL或ICO文件名。

例程

说明

取出文件中包含的图标数。可以根据图标的数量，用计次循环依次取出文件中的图标。

参见：例程


删除图片组图片 命令 所属类别：图片组处理

删除图片组数据中指定位置处的图片，成功返回真，失败返回假。

语法： 逻辑型 删除图片组图片 （图片组数据变量，欲删除图片位置，［欲删除图片数目］）

参数名 | 描 述
图片组数据变量 | 必需的；字节集，参数数据只能提供变量。本参数提供即将被处理的图片组数据，处理后的图片组数据也被存放回此变量中。
欲删除图片位置 | 必需的；整数型。本参数提供即将被删除图片所处的索引位置，位置值从 0 开始。
欲删除图片数目 | 可选的；整数型。如果本参数被省略，默认值为 1 。

例程

说明：

删除图片组变量中的图片。可以根据图片组变量的索引值删除某个图片，

也可以根据图片组的数量用计次循环依次删除图片组变量中的图片。

参见：例程


取图片组图片数 命令 所属类别：图片组处理

返回指定图片组数据中所包含图片的数目。

语法： 整数型 取图片组图片数 （图片组数据）

参数名 | 描 述
图片组数据 | 必需的；字节集。本参数提供希望获得其中图片数目的图片组数据。

例程

说明：

取得图片组变量中所包含图片的数目。可以用在依次取出图片的计次循环中。

参见：例程


建空图片组 命令 所属类别：图片组处理

根据指定参数创建一份空白的图片组数据，成功返回所创建图片组的数据，失败返回空字节集。

语法： 字节集 建空图片组 （单一图片宽度，单一图片高度）

参数名 | 描 述
单一图片宽度 | 必需的；整数型。本参数指定图片组中单一图片的宽度，单位为像素。
单一图片高度 | 必需的；整数型。本参数指定图片组中单一图片的高度，单位为像素。

例程

说明：

创建空的图片组。注意创建时定义的图片大小与实际载入的图片的大小要一致。

参见：例程


取图片组图片 命令 所属类别：图片组处理

返回图片组数据中所包含的指定图片，成功返回所获取图片的数据，失败返回空字节集。

语法： 字节集 取图片组图片 （图片组数据，欲获取图片位置，［透明填充色］）

参数名 | 描 述
图片组数据 | 必需的；字节集。本参数提供希望获得其中图片的图片组数据。
欲获取图片位置 | 必需的；整数型。本参数提供希望被获取图片在图片组中所处的索引位置，位置值从 0 开始。
透明填充色 | 可选的；整数型。本参数指定用作填充图片透明背景部分的颜色。如果被省略，默认值为常量值“#白色”。

例程

说明：

根据图片组中图片的索引，可以将图片组中的图片取出来。在取图片时要注意图片索引从0开始。

参见：例程


超级按钮

超级按钮 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库二

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
按钮风格 | 选择框方式 | 选中 | 对齐方式
压入方式 | 绘制边框 | 绘制焦点 | 通常图片
通常图片透明色 | 点燃图片 | 点燃图片透明色 | 禁止图片
禁止图片透明色 | 字体 | 标题 | 使用默认色
通常前景色 | 通常背景色 | 点燃前景色 | 点燃背景色
焦点前景色 | 焦点背景色 | 标准音提示 | 经过提示音
单击提示音 | 提示文本 | 默认类型 |

自有事件：

被单击

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 |


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


按钮风格 属性 数据类型：整数型；

可供选择的属性值：
0、平面风格
1、立体风格
2、XP风格

语法： 对象.按钮风格= 整数型

例程

说明：

设置风格超级按钮为XP风格。超级按钮不支持命令XP风格（）。

参见：例程


选择框方式 属性 数据类型：逻辑型；

本属性指定按钮是否以选择框方式工作。

语法： 对象. 选择框方式= 逻辑型

例程：

说明：

设置选择框超级按钮为选择框方式。它的作用就是可以清楚地显示按钮按下或放开的状态。

参见：例程


选择框方式 属性 数据类型：逻辑型；

选中 属性 数据类型：逻辑型；

当“选择框方式”属性为真时，本属性说明当前是否已被选中。

语法： 对象.选中= 逻辑型

例程：

说明：

在选中为真的情况下，超级按钮是被按下的状态；在选中为假的情况下，超级按钮是被放开的状态。

参见：例程


对齐方式 属性 数据类型：整数型；

本属性指定按钮中图片和文本的对齐方式。

可供选择的属性值：
0、图左文右
1、图上文下
2、图右文左
3、图文混排

语法： 对象.对齐方式= 整数型

例程：

说明：

设置超级按钮中图片和标题的位置。前三种情况图片和标题是分开的；

图文混排是图片覆盖整个超级按钮，标题在超级按钮的正中。

注意图片颜色和标题颜色一定要有大的区分，否则标题将被模糊显示。

参见：例程


压入方式 属性 数据类型：整数型；

本属性指定按钮压入后的显示方式。

可供选择的属性值：
0、从左到右
1、从上到下

语法： 对象.压入方式 = 整数型

例程：

说明：

本属性的显示效果不是太明显，在单击超级按钮时，要仔细的观察。

因为没有太大作用，一般情况下不设置其压入的方式。

参见：例程


绘制边框 属性 数据类型：逻辑型；

本属性指定非立体风格按钮是否绘制边框线。

语法： 对象.绘制边框 = 逻辑型

例程：

说明：

设置超级按钮在非立体风格的情况下，是否绘制边框。

参见：例程


绘制焦点 属性 数据类型：逻辑型；

本属性指定非立体风格按钮获得焦点后是否绘制焦点边框线。

语法： 对象.绘制焦点= 逻辑型

例程：

说明：

设置超级按钮在获得焦点时，是否显示出焦点的虚线框。如果不设置边框线，也不

设置焦点线，那么对于窗口中哪个是超级按钮，哪个是图片将分不清楚，因此最少要设置一种

虚线框，以便看得清楚。

参见：例程


通常图片 属性 数据类型：字节集；

本属性指定当鼠标位于按钮外时显示的图片。

语法： 对象.通常图片 = 字节集

例程：

说明：

打开图片对话框，读入图片文件，设置图片超级按钮的通常图片。

通常图片就是在什么也不做的情况下，正常显示的图片。

参见：例程


通常图片 属性 数据类型：字节集；

通常图片透明色 属性 数据类型：整数型；

本属性指定通常图片中透明部分的颜色，如果属性值为默认背景色则自动以图片左上角第一点的颜色值作为透明色。

语法： 对象.通常图片透明色 = 整数型

例程：

说明：

打开图片对话框，读入图片文件，设置图片超级按钮的通常图片，将通常图片中的红色

设置为透明色。

参见：例程


点燃图片 属性 数据类型：字节集；

本属性指定当鼠标位于按钮上时显示的图片，如果不提供，系统将会自动使用通常图片。

语法： 对象.点燃图片= 字节集

例程：

说明：

打开图片对话框，读入图片文件，设置图片超级按钮的点燃图片。点燃图片就是当鼠标

移动到图片超级按钮上时显示的图片。

。

参见：例程


点燃图片 属性 数据类型：字节集；

点燃图片透明色 属性 数据类型：整数型；

本属性指定点燃图片中透明部分的颜色，如果属性值为默认背景色则自动以图片左上角第一点的颜色值作为透明色。

语法： 对象.点燃图片透明色 ＝ 整数型

例程：

说明：

打开图片对话框，读入图片文件，设置图片超级按钮的点燃图片，将点燃图片中的黑色

设置为透明色。

。

参见：例程


禁止图片 属性 数据类型：字节集；

本属性指定当按钮被禁止时显示的图片，如果不提供，系统将会自动生成。

语法： 对象.禁止图片 = 字节集

例程

说明：

打开图片对话框，读入图片文件，设置图片超级按钮的禁止图片。禁止图片

就是当图片超级按钮被禁止时显示的图片。

参见：例程


禁止图片 属性 数据类型：字节集；

禁止图片透明色 属性 数据类型：整数型；

本属性指定禁止图片中透明部分的颜色，如果属性值为默认背景色则自动以图片左上角第一点的颜色值作为透明色。

语法： 对象.禁止图片透明色 = 整数型

例程：

说明：

打开图片对话框，读入图片文件，设置图片超级按钮的禁止图片，将禁止图片中的黄色

设置为透明色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程：

说明：

将超级按钮的字体的加粗属性设置为“真”。

参见：例程


标题 属性 数据类型：文本型；

本属性指定按钮标题文本的内容。

语法： 对象.标题 = 文本型

例程：

说明：

在单击图片变化超级按钮后，让图片变化超级按钮的标题为“看看按钮被禁止后图片的变化”。

标题就是在超级按钮上显示的文字部分。

参见：例程


使用默认色 属性 数据类型：逻辑型；

本属性指定是否使用操作系统默认配色方案来对按钮进行配色。

语法： 对象. 使用默认色= 逻辑型

例程：

说明：

设置前景色超级按钮是否使用默认的颜色。如果不是用默认的颜色，就可以对

前景色超级按钮在被单击前后可以设置前景色和背景色。

参见：例程


使用默认色 属性 数据类型：逻辑型；

通常前景色 属性 数据类型：整数型；

本属性指定当鼠标位于按钮外时文本标题所使用的显示颜色。

语法： 对象. 通常前景色 = 整数型

例程：

说明：

设置前景色超级按钮的通常前景色为艳情色。通常前景色是指在什么也不做的情况下，

前景色超级按钮中标题的颜色。

参见：例程


使用默认色 属性 数据类型：逻辑型；

通常背景色 属性 数据类型：整数型；

本属性指定当鼠标位于按钮外时显示的背景颜色。

语法： 对象. 通常背景色 = 整数型

例程：

说明：

设置前景色超级按钮的通常背景色为默认的底色。通常背景色是指在什么也不做的情况下，

前景色超级按钮中标题的背景颜色。

参见：例程


使用默认色 属性 数据类型：逻辑型；

点燃前景色 属性 数据类型：整数型；

本属性指定当鼠标位于按钮上时文本标题所使用的显示颜色。

语法： 对象. 点燃前景色 = 整数型

例程：

说明：

设置前景色超级按钮的点燃前景色为红色。点燃前景色是指在鼠标移动到

前景色超级按钮上时，前景色超级按钮中标题的颜色。

参见：例程


使用默认色 属性 数据类型：逻辑型；

点燃背景色 属性 数据类型：整数型；

本属性指定当鼠标位于按钮上时显示的背景颜色。

语法： 对象. 点燃背景色 = 整数型

例程:

说明：

设置前景色超级按钮的点燃背景色为默认的底色。点燃背景色是指在鼠标移动到

前景色超级按钮上时，前景色超级按钮中标题的背景颜色。

参见：例程


使用默认色 属性 数据类型：逻辑型；

焦点前景色 属性 数据类型：整数型；

本属性指定当按钮获得输入焦点时文本标题所使用的显示颜色。

语法： 对象. 焦点前景色 = 整数型

例程：

说明：

设置前景色超级按钮的焦点前景色为绿色。焦点前景色是指在前景色超级按钮获得焦点时，

前景色超级按钮中标题的颜色。

参见：例程


使用默认色 属性 数据类型：逻辑型；

焦点背景色 属性 数据类型：整数型；

本属性指定当按钮获得输入焦点时显示的背景颜色。

语法： 对象. 焦点背景色 = 整数型

例程：

说明：

设置前景色超级按钮的焦点背景色为默认的底色。焦点背景色是指在前景色超级按钮获得焦点时，

前景色超级按钮中标题的背景颜色。

参见：例程


标准音提示 属性 数据类型：逻辑型；

本属性指定当鼠标单击按钮或移动到非立体风格按钮上时是否同时发出标准的“哒哒”音。

语法： 对象. 标准音提示= 逻辑型

例程：

说明：

设置在对提示音超级按钮操作时是否使用系统默认的标准声音。如果不使用标准声音，

就可以设置其它的WAV格式的声音文件了。

参见：例程


标准音提示 属性 数据类型：逻辑型；

经过提示音 属性 数据类型：字节集；

本属性指定当鼠标移动到非立体风格按钮上时所发出的声音，注意仅支持WAV格式。

语法： 对象. 经过提示音 = 字节集

例程：

说明：

设置当鼠标在提示音超级按钮上移动时，所发出的声音。此声音常量在资源表中可以找到。

参见：例程


标准音提示 属性 数据类型：逻辑型；

单击提示音 属性 数据类型：字节集；

本属性指定当鼠标单击按钮时所发出的声音，注意仅支持WAV格式。

语法： 对象. 单击提示音 = 字节集

例程：

说明：

设置当鼠标单击提示音超级按钮时，所发出的声音。此声音常量在资源表中可以找到

参见：例程


提示文本 属性 数据类型：文本型；

本属性指定当鼠标停留在按钮上时动态显示的提示文本。

语法： 对象.提示文本 = 文本型

例程：

说明：

设置提示框超级按钮的提示文本为“关闭”。当鼠标移动到超级按钮上时，会出现一个四边形，

此四边形中会有简短的对超级按钮进行注释的文本内容；当鼠标离开超级按钮时，此四边形消失。

参见：例程


默认类型 属性 数据类型：整数型；

当在窗口上按下Enter键时，如果没有将窗口的“回车下移输入点”属性设置为真，则等同于按下了具有“默认”类型的按钮。因此具有“默认”类型的按钮在同一窗口上应当只有一个。“通常”类型的按钮无对应的操作默认键。

可供选择的属性值：
0、通常
1、默认

语法： 对象.默认类型 = 整数型

例程：

说明：

在窗口上按下回车键（窗口属性“回车下移输入点“为假），等同于单击了默认类型的柴继按钮。

注：超级按钮的风格属性的值为 2(立体风格) 时才有效。

参见：例程


被单击 事件 所属对象：超级按钮

被单击 事件 所属对象：超级按钮 操作系统支持：Windows

当单击按钮后即产生此事件。

语法： 无返回值 _超级按钮_被单击 （）

例程

说明：

超级按钮被单击就触发此事件，运行此事件下的代码。

参见：例程


高级影像框

高级影像框 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库二相比起基本影像框，本组件可以播放更多格式的AVI文件。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
播放位置 | 影像文件名 | 播放速度 | 背景颜色
透明颜色 | 播放 | 仅播放一次 | 当前帧
全部帧数 |  |  |

基本事件：


播放位置 属性 数据类型：整数型；

本属性指定影像在窗口中的播放位置。仅在播放前设置有效。

可供选择的属性值：
0、窗口内居中
1、扩展到窗口
2、自动调整窗口

语法: 对象.播放位置 ＝整数型

例程：

说明:

本属性可以设置正在播放的影像文件在高级影像框中的位置。

窗口内居中：是在高级影像框的正中间播放；
扩展到窗口：是在高级影像框中全屏显示：
自动调整窗口：是根据窗口大小自动调整播放窗口。

参考：例程


影像文件名 属性 数据类型：文本型；

本属性指定欲播放影像文件的名称。

语法: 对象.影像文件名 ＝文本型

例程：

说明:

把影像文件对话框的文件名放入高级影像框的影像文件名中，之后高级影像框就会自动播放。

在子程序中让高级影像框的播放属性等于1（即停止播放）。

参考：例程


播放速度 属性 数据类型：双精度小数型；

本属性值可以设置为大于 0 的小数，数值越小播放速度越快，数值为 1 则保持原定播放速度。具体计算公式为：实际播放速度 = 此属性值 X 影像文件内原定速度。仅在播放前设置有效。

语法: 对象.播放速度 ＝双精度小数型

例程：

说明:

设置播放影像文件的速度。注意：要在播放前设置。

参考：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

例程：

说明：

设置高级影像框的背景颜色。

参见：例程


透明颜色 属性 数据类型：整数型；

本属性指定影像中透明部分的颜色，如果属性值为默认背景色则自动以影像内第一帧左上角第一点的颜色值作为透明色。仅在播放前设置有效。

语法: 对象.透明颜色 ＝整数型

例程：

说明:

设置影像中被透明的颜色。注意：要在播放前设置。

参考：例程


播放 属性 所属对象：高级影像框

播放 属性 数据类型：整数型

在设计阶段，指定本属性值为“播放”可使运行时影像文件在影像框被创建后自动开始播放。在运行阶段，通过改变此属性值可控制影像的播放、停止、暂停或继续。在运行阶段读取本属性值将始终得到0（播放）或1（停止），用作提供当前的播放状态。

可供选择的属性值：
0、播放
1、停止
2、暂停
3、继续

语法: 对象.播放 ＝整数型

例程：

说明:

设置高级影像框的播放属性。在播放影像文件时可以设置播放，暂停，继续，停止等功能。

参考：例程


仅播放一次 属性 数据类型：逻辑型；

如果本属性值为真，则仅播放一次，否则无限次地循环播放。仅在播放前设置有效。

语法: 对象.仅播放一次 ＝逻辑型

例程：

说明:

设置高级影像框的播放次数是一次还是多次。注意：要在播放前设置。

参考：例程


当前帧 属性 数据类型：整数型；

当前帧 属性 所属对象：高级影像框 操作系统支持：Windows

数据类型：整数型；

本属性返回或设置当前播放帧的帧号，属性值范围为从 1 到当前影像文件全部帧数，支持在播放前设置。

语法: 对象.当前帧 ＝整数型

应用对象:

高级影像框

例程：

说明:

当前帧的意思就是当前影像文件播放的长度。注意：要在播放前设置。

参考：例程


全部帧数 属性 数据类型：整数型；

只读；本属性返回当前影像文件所包含的全部帧数。

语法: 对象.全部帧数 ＝整数型

例程：

说明:

本属性返回当前影像文件的长度。如果播放的当前帧数等于全部帧数，那么当前影响文件就播放完了。

参考：例程


分隔条

分隔条 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库二可以用作动态调整窗口布局。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
背景颜色 | 方向 |  |

自有事件：

被拖动

基本事件：


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

例程：

说明：

设置分割条的背景颜色为背景颜色选择器选择的颜色。

参见：例程


方向 属性 数据类型：整数型；

可供选择的属性值：
0、横向
1、纵向

语法： 对象.方向 = 整数型

例程：

说明：

在子程序中，改变编辑框分割条原有的方向，同时也要设置左分割编辑框，右分割编辑框，编辑框分割条的位置。

参见：例程


被拖动 事件 所属对象：分隔条

被拖动 事件 所属对象：分隔条 操作系统支持：Windows

当分隔条被拖动到一个新的位置后即产生此事件。

语法： 无返回值 _分隔条_被拖动 （原位置，目的位置）

参数名 | 描 述
原位置 | 整数型；本参数值提供分隔条被拖动前的原位置坐标，单位为像素。该坐标值相对于其所在窗口用户区的左上角。如果分隔条的方向为横向，则本参数提供分隔条顶边纵坐标值，否则为分隔条左边横坐标值。
目的位置 | 整数型；本参数值提供分隔条被拖动到的目的位置坐标，单位为像素。该坐标值相对于其所在窗口用户区的左上角。如果分隔条的方向为横向，则本参数提供分隔条顶边纵坐标值，否则为分隔条左边横坐标值。

例程

说明：

当编辑框分割条被拖动时触发此事件。一般情况下都是根据分割条的原位置和目的位置进行组件的上下或左右的移动。

参见：例程


超级编辑框

超级编辑框 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库二具有对丰富格式文本的编排和处理支持。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
内容格式 | 内容 | 边框 | 背景颜色
是否允许多行 | 自动换行 | 只读 | 隐藏选择
最大允许长度 | 起始选择位置 | 被选择字符数 | 被选择文本
是否已更改 |  |  |

方法：

取文本长度 | 取行数 | 取行文本 | 取首可视行
取行首位置 | 取字符所在行 | 滚动 | 取默认字符格式
置默认字符格式 | 取选择区字符格式 | 置选择区字符格式 | 取选择区段落格式
置选择区段落格式 | 撤消 | 可否撤消 | 清空撤消数据
寻找 | 复制 | 剪切 | 删除
粘贴 | 可否粘贴 | 读入文档 |

自有事件：

内容被改变 选择区被改变

基本事件：


内容格式 属性 数据类型：整数型；

本属性指定对编辑框的内容进行读写时所使用的文本格式。

可供选择的属性值：
0、纯文本
1、RTF丰富文本

语法： 对象.格式内容 = 整数型

例程：

说明：

设置超级编辑框的内容格式，如果是纯文本格式，将不能显示RTF文本，同样如果是RTF文本，也不能显示纯文本。

参见：例程1


内容 属性 数据类型：文本型；

本属性所使用的文本格式由“内容格式”属性决定。

语法： 对象.内容= 文本型

例程：

说明：

根据内容格式的不同，内容也不同，内容可以为纯文本和RTF丰富文本。

参见：例程1


边框 属性 数据类型：整数型；

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 ＝ 整数型

例程：

说明：

设置超级编辑框的边框，默认边框为凹入式。

参见：例程1


背景颜色 属性 数据类型：整数型；

语法： 对象.选中= 逻辑型

例程：

说明：

改变超级编辑框的背景颜色，具体颜色通过颜色值来选择。

参见：例程1


是否允许多行 属性 数据类型：逻辑型；

本属性设置编辑框是否允许输入多行文本。

语法： 对象.是否允许多行 = 逻辑型

例程：

说明：

改变超级编辑框的显示行属性，如果是否允许多行为真，读入多行文本的时候可以全部显示，如果为假只显示一行。

参见：例程1


自动换行 属性 数据类型：逻辑型；

本属性设置编辑框是否支持自动换行。

语法： 对象.自动换行 = 逻辑型

例程：

说明：

如果自动换行为真，只好超出超级编辑框宽度的内容都会写到下一行，如果为假，只要在文本中没有换行符，将一直显示下去。

参见：例程1


只读 属性 数据类型：逻辑型；

本属性设置编辑框是否只能读取而不能写入。

语法： 对象.只读 = 逻辑型

例程：

说明：

只读的时候可以通过代码改变超级编辑框中的内容，但是不能使用任何输入设备输入。

参见：例程1


隐藏选择 属性 数据类型：逻辑型；

本属性指定失去输入焦点后是否还显示当前被选择的区域。

语法： 对象.隐藏选择 = 逻辑型

例程：

说明：

在隐藏选择为假的时候，如果超级编辑框中有被选择内容，在超级编辑框失去焦点后，还可以看到被选择，如果隐藏选择为真，在超级编辑框失去焦点之后，将不能看到被选中内容，当超级编辑框再次获得较点之后，被选择内容才会继续被选择，注意：只是看上去不同，不管是否选中，在失去焦点之后，被选择内容还是被选中的。

参见：例程1


最大允许长度 属性 数据类型：整数型；

本属性设置最大允许输入到编辑框中的字符数目，如为0则输入字符数目不受限制。

语法： 对象.最大允许长度 = 整数型

例程：

说明：

设置超级编辑框的最大允许输入长度，当输入的文本超过规定的长度，将不能再输入内容。

参见：例程1


起始选择位置 属性 数据类型：整数型；

返回或设置所选择文本的起始点；0 为位置 1 ，1 为位置 2，如此类推。如果没有文本被选中，则提供当前光标位置。

语法： 对象.起始选择位置 = 整数型

例程：

说明：

改变超级编辑框的起始选择位置，可以同过这个来完成从一个位置到另一个位置的区域性选择字符。

参见：例程1


被选择字符数 属性 数据类型：整数型；

返回或设置所选择的字符数。如果设置字符数时使用值 -1，则选择编辑框内的所有字符。

语法： 对象.被选择字符数 = 整数型

例程：

说明：

如果超级编辑框中有被选择的字符，可以通过这个命令来取得选中了多少字符。

参见：例程1


被选择文本 属性 数据类型：文本型；

设计时不可用；返回或替换当前所选择的文本，文本格式由“内容格式”属性决定。

语法： 对象.被选择文本 = 文本型

例程：

说明：

如果有被选中的文本，可以通过本命令取得。

参见：例程1


是否已更改 属性 数据类型：逻辑型；

设计时不可用；读取本属性可获知编辑框的内容是否已被用户手工更改，运行时写入本属性可以设置其值。

语法： 对象. 是否以更改 = 逻辑型

例程：

说明：

只要超级编辑框的内容被改变过，通过这个属性都可以取出来。

参见：例程1


取文本长度 方法 所属对象：超级编辑框

返回编辑框中现行所有文本内容的长度。

语法： 整数型 超级编辑框．取文本长度 （）

例程：

说明：

取得超级编辑框中的所有文本的长度，不包括表格等其他内容。

参见：例程1


取行数 方法 所属对象：超级编辑框

返回编辑框中当前内容的行数。

语法： 整数型 超级编辑框．取行数 （）

例程：

说明：

取得超级编辑框中的内容一共有多少行，在是否自动折行参数改变后，行数可能会不一样。

参见：例程1


取行文本 方法 所属对象：超级编辑框

返回编辑框中指定行的文本内容。

语法： 文本型 超级编辑框．取行文本 （行号）

参数名 | 描 述
行号 | 必需的；整数型。行号从 0 开始，用作指定编辑框中的某一行。即：0 指定第一行，1 指定第二行，依此类推。

例程：

说明：

取得指定行的文本内容，在改变是否自动折行参数后，指定行文本内容可能会改变。

参见：例程1


取首可视行 方法 所属对象：超级编辑框

返回编辑框中当前顶部可见第一行的行号，行号值从 0 开始。

语法： 整数型 超级编辑框．取首可视行 （）

例程：

说明：

取得当前超级编辑框显示的第一行的行号，并不是指整个超级编辑框内容的第一行。

参见：例程1


取行首位置 方法 所属对象：超级编辑框

返回编辑框中指定行的首字符在编辑框全部内容中的索引位置，该索引位置从 0 开始。

语法： 整数型 超级编辑框．取行首位置 （［行号］）

参数名 | 描 述
行号 | 可选的；整数型。行号从 0 开始，用作指定编辑框中的某一行。即：0 指定第一行，1 指定第二行，依此类推。如果为 -1 ，则自动取当前光标所在行行号。如果本参数被省略，则默认值为 -1 。

例程：

说明：

取得指定行的第一个字符在整个超级编辑框内容中所在的位置。

参见：例程1


取字符所在行 方法 所属对象：超级编辑框

返回编辑框中指定位置字符所在行的行号，行号值从 0 开始。

语法： 整数型 超级编辑框．取字符所在行 （［字符位置］）

参数名 | 描 述
字符位置 | 可选的；整数型。字符位置为指定字符在编辑框全部内容中的索引位置，该索引位置从 0 开始。如果为 -1 ，则自动取当前光标所在字符位置。如果本参数被省略，则默认值为 -1 。

例程：

说明：

取得被选择字符所在行的行号，行号从0开始。

参见：例程1


滚动 方法 所属对象：超级编辑框

垂直滚动多行编辑框中的内容显示区域。

语法： 无返回值 超级编辑框．滚动 （行数）

参数名 | 描 述
行数 | 必需的；整数型。本参数指定欲滚动行数，可以为负数。

例程：

说明：

让超级编辑框的内容滚动，滚动方向根据当前行来决定，如果滚动到的行在当前行之上，则象上滚动，否则像下滚动。

参见：例程1


取默认字符格式 方法 所属对象：超级编辑框

返回当前默认字符格式，默认字符格式影响编辑框中所有未曾明确设置其字符格式的文本。

语法： 字符格式 超级编辑框．取默认字符格式（）

例程：

说明：

取得超级编辑框中默认字体的格式，返回字体格式类型变量。

参见：例程1


置默认字符格式 方法 所属对象：超级编辑框

设置当前默认字符格式，默认字符格式影响编辑框中所有未曾明确设置其字符格式的文本。

语法： 无返回值 超级编辑框．置默认字符格式（字符格式）

参数名 | 描 述
字符格式 | 必需的；字符格式。本参数提供欲设置的字符格式。

例程：

说明：

改变超级编辑框的默认字体格式，改变之后再用取默认字体格式取出的字体格式，就是这次设置的格式了。

参见：例程1


取选择区字符格式 方法 所属对象：超级编辑框

返回当前选择区内首字符文本的字符格式。

语法： 字符格式 超级编辑框．取选择区字符格式（）

例程：

说明：

取得被选择区域的字符格式，返回字符格式变量。

参见：例程1


置选择区字符格式 方法 所属对象：超级编辑框

设置当前选择区内所有文本的字符格式。

语法： 无返回值 超级编辑框．置选择区字符格式（字符格式）

参数名 | 描 述
字符格式 | 必需的；字符格式。本参数提供欲设置的字符格式。

例程：

说明：

设置被选择区域的字符格式，参数必须为字符格式变量。

参见：例程1


取选择区段落格式 方法 所属对象：超级编辑框

返回当前选择区内首段落的段落格式。

语法： 段落格式 超级编辑框．取选择区段落格式（）

例程：

说明：

取得当前选择区域的段落格式，返回段落格式类型变量。

参见：例程1


置选择区段落格式 方法 所属对象：超级编辑框

设置当前选择区内所有段落的段落格式。

语法： 无返回值 超级编辑框．置选择区段落格式（段落格式）

参数名 | 描 述
段落格式 | 必需的；段落格式。本参数提供欲设置的段落格式。

例程：

说明：

设置被选择区域的段落格式，参数必须为段落格式类型变量。

参见：例程1


撤消 方法 所属对象：超级编辑框

撤消编辑框中最后一次的更改操作。

语法： 无返回值 超级编辑框．撤消 （）

例程：

说明：

撤销最后一个操作，撤销可以无限制的。撤销到没有操作为止。

参见：例程1


可否撤消 方法 所属对象：超级编辑框

如果当前编辑框中存在可以被撤消的更改操作，返回真，否则返回假。

语法： 逻辑型 超级编辑框．可否撤消 （）

例程：

说明：

判断当前超级编辑框的内容是否有可以被撤销的操作。

参见：例程1


清空撤消数据 方法 所属对象：超级编辑框

清除编辑框中为支持撤消上次更改操作所保存的所有数据，本命令执行后无法再撤消上次所更改的操作。

语法： 无返回值 超级编辑框．清空撤消数据 （）

例程：

说明：

清空撤销操作，在清空之后，没有对超级编辑框操作之前，无法在执行撤销命令。

参见：例程1


寻找 方法 所属对象：超级编辑框

在编辑框中寻找指定的文本，如找到则返回该文本首字符所处的位置索引（从0开始），未找到则返回-1。

语法： 整数型 超级编辑框．寻找 （［起始寻找位置］，［是否区分大小写］，［是否匹配单词］，欲寻找文本）

参数名 | 描 述
起始寻找位置 | 可选的；整数型。参数值为以 0 开始的字符位置索引，如果被省略，则默认值为 0 。
是否区分大小写 | 可选的；逻辑型。指定寻找时是否区分大小写英文字母，如果被省略，则默认值为真。
是否匹配单词 | 可选的；逻辑型。指定寻找时是否只允许单词才能匹配，如果被省略，则默认值为假。
欲寻找文本 | 必需的；文本型。

例程：

说明：

寻找指定文本，如果找到，光标就会停在找到位置之后，并选中找到的内容。

参见：例程1


复制 方法 所属对象：超级编辑框

将现行被选择文本复制到剪辑板。

语法： 无返回值 超级编辑框．复制 （）

例程：

说明：

复制当前选中的区域的内容，这里不光包括文本内容，如果有表格等，也会被复制。

参见：例程1


剪切 方法 所属对象：超级编辑框

将现行被选择文本剪切到剪辑板。

语法： 无返回值 超级编辑框．剪切 （）

例程：

说明：

剪切当前选中的区域的内容，当前选择区域被剪切后，会被删除掉。

参见：例程1


删除 方法 所属对象：超级编辑框

删除现行被选择文本。

语法： 无返回值 超级编辑框．删除 （）

例程：

说明：

删除当前选择区域的内容，如果误操作可以用撤销命令来恢复。

参见：例程1


粘贴 方法 所属对象：超级编辑框

将剪辑板中的现行内容粘贴到光标位置。

语法： 无返回值 超级编辑框．粘贴 （）

例程：

说明：

把剪贴板中的内容复制到当前光标位置。

参见：例程1


可否粘贴 方法 所属对象：超级编辑框

如果当前剪辑板中具有可以粘贴到编辑框中的数据，返回真，否则返回假。

语法： 逻辑型 超级编辑框．可否粘贴 （）

例程：

说明：

判断当前剪辑板中的内容是否符合超级编辑框的标准。

参见：例程1


读入文档 方法 所属对象：超级编辑框

显示对话框打开指定文档并读入到编辑框中，成功返回所读入文档的文件名，失败或被用户中止返回空文本。本命令可以自动调用当前Windows系统中已登记的所有文档转换器以读入各种其它类型文档，譬如Word文档、Excel表格等等。

语法： 文本型 超级编辑框．读入文档 （）

例程：

说明：

本命令直接把选中的内容放入到超级编辑框中，返回值为选中文件的路径。

参见：例程


内容被改变 事件 所属对象：超级编辑框

当编辑框的内容被修改后即产生此事件。

语法： 无返回值 _超级编辑框_内容被改变 （）

例程：

说明：

只要超级编辑框内容被改变的时候就会触发本事件，可以根据输入内容的不同来进行需要的操作。

参见：例程1


选择区被改变 事件 所属对象：超级编辑框

当编辑框的当前选择区被改变后即产生此事件。

语法： 无返回值 _超级编辑框_选择区被改变 （）

例程：

说明：

只要选择的区域被改变了，就会触发本事件，可以根据选择区域不同来进行判断，进行不同操作。

参考：例程1


IP编辑框

IP编辑框 窗口组件 操作系统支持：Windows

跳至：扩展界面支持库二本编辑框支持对IP地址的输入和编辑。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
字体 | 地址 |  |

自有事件：

地址被改变

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 |


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

IP编辑框等许多组件

例程

说明：

将IP编辑框的字体的加粗属性设置为“真”。

参见：例程


地址 属性 所属对象：IP编辑框 操作系统支持：Windows

地址 属性 数据类型：文本型

指定IP编辑框中的IP地址值。

例程：

说明：

IP编辑框是非常精简的特定输入编辑组件。本属性专门应对网页的IP地址。

打开一个网页可以用网页的网址，也可以用网页的IP地址。 网址和IP地址之间可以相互转化。

参见：例程


内容被改变 事件 所属对象：超级编辑框

地址被改变 事件 所属对象：IP编辑框

当IP编辑框内的地址被修改后即产生此事件。

语法： 无返回值 _IP 地址编辑框_地址被改变 （）

例程：

说明：

只要IP编辑框地址被改变的时候就会触发本事件，可以根据输入内容的不同来进行需要的操作。

参见：例程


字符格式

字符格式 数据类型 操作系统支持：Windows

跳至：扩展界面支持库二本数据类型被超级编辑框的成员命令使用，用作指定字符文本的表现格式。

成员 | 描 述
字体名称 | 文本型；初始值为“宋体”。
字体大小 | 整数型；初始值为 9 。单位为点（1 / 72 英寸）。
纵向偏移 | 整数型；指定字符相对于基线的纵向偏移值，单位为点（1 / 72 英寸）。如果为正值，则字符表现为上标，如果为负值，则字符表现为下标。
效果 | 整数型；可以为以下常量值之一或之和： 1、#粗体；2、#斜体；4、#下划线；8、#删除线；16、#禁止更改。
文本颜色 | 整数型；初始值为 -16777216 。指定字符显示时使用的前景颜色，如果为“#默认色”常量值，则自动使用 Windows 系统默认文本颜色。

参见： 基本数据类型


段落格式

段落格式 数据类型 操作系统支持：Windows

跳至：扩展界面支持库二本数据类型被超级编辑框的成员命令使用，用作指定文本段落的表现格式。

成员 | 描 述
项目符引导 | 逻辑型；
首行缩进 | 整数型；指定段落首行相对于编辑框左边框的缩进量，单位为点（1 / 72 英寸）。
非首行缩进 | 整数型；指定段落中所有非首行相对于首行的缩进量，单位为点（1 / 72 英寸）。
右边缩进 | 整数型；指定段落右边相对于编辑框右边框的缩进量，单位为点（1 / 72 英寸）。
对齐方式 | 整数型；指定段落的对齐方式，可以为以下常量值之一： 1、#段落居左；2、#段落居中；3、#段落居右。

参见： 基本数据类型


常量 | 常量值 | 描 述
#禁止更改 | 16 | 用作保护编辑框中的某段指定内容不被更改。
#段落居左 | 1 |
#段落居中 | 2 |
#段落居右 | 3 |


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1