扩展界面支持库五

扩展界面支持库五 帮助手册20080812版 返回支持库手册 返回首页

提供“汽球提示框”组件，可制作出汽球形式的信息提示框(ToolTip)；提供“简单超文本框”组件，可用于显示简化的HTML文本。 本库中的“汽球提示框”和“简单超文本框”使用了网友Eugene Pustovoyt的CPPTooltip2.0代码，特此感谢！。

操作系统支持： Windows

窗口组件数据类型：

汽球提示框

简单超文本框

为易语言系统提供的工具功能：

名称 | 说明
扩展界面支持库五: 关于简单超文本(HTML)的说明文档 | 简单超文本说明文档

例程列表：

例程名称 | 下载 | 说明
扩展界面支持库五演示程序 | 汽球提示框.e | 演示了“汽球提示框”和“简单超文本框”两个控件的基本功能。

适用版本，扩展界面支持库五 （1.5#1版）


汽球提示框

汽球提示框 功能型窗口组件 操作系统支持：Windows 跳至：扩展界面支持库五

支持HTML的超强提示控件，提示窗口形似汽球，提示内容可包含图标、图片、各种字体以及超链接，支持多种效果的背景色渐变。 可用以下两种方法之一使用本控件： 1、在程序初始化时调用“关联组件()”方法，将需要自动弹出提示信息的组件（比如按钮等）关联到提示框控件； 2、在需要手工弹出提示信息时，调用“弹出提示框()”方法。 一个程序中的多个窗口可共用一个“汽球提示框”控件（节省系统资源，提示框风格统一），同一个窗口中也可同时使用多个“汽球提示框”控件（可同时拥有不同风格的提示框）。

属性：

背景_ | 背景颜色一 | 背景颜色二 | 背景颜色三
背景效果 | 粒度值 | 手柄方位 | 透明度
图标图片组 | 图片图片组 | 层叠样式表 | 行为_
可多次显示 | 跟随鼠标 | 鼠标离开时隐藏 | 鼠标悬停时隐藏
禁止自动隐藏 | 尺寸_ | 圆角横向尺寸 | 圆角纵向尺寸
水平边距 | 垂直边距 | 手柄宽度 | 手柄高度
手柄边距 | 延时_ | 显示前延时 | 自动停留时间
淡入时间 | 淡出时间 | 边线_ | 边线颜色
水平边线宽度 | 垂直边线宽度 | 阴影_ | 阴影是否渐变
阴影灰度 | 阴影水平偏移量 | 阴影垂直偏移量 | 阴影水平深度
阴影垂直深度 |  |  |

方法：

关联组件

关联工具条

批量关联组件

弹出提示框

自有事件：

自定义超链接被单击

提示框即将弹出

提示框即将隐藏


背景_ (汽球提示框)

背景_ 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集；

参见： 基本数据类型


背景颜色一 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

设置气球提示框的背景颜色。

参见：例程1


背景颜色一 属性 所属对象：汽球提示框 操作系统支持：Windows

背景颜色二 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

设置气球提示框的背景颜色。


背景颜色一 属性 所属对象：汽球提示框 操作系统支持：Windows

背景颜色三 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

设置气球提示框的背景颜色。


背景效果 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、填充背景色
1、水平渐变
2、垂直渐变
3、双向水平渐变
4、双向垂直渐变
5、三色水平渐变
6、三色垂直渐变
7、杂乱
8、特殊阴影
9、水平阴影
10、垂直阴影
11、水平振荡
12、垂直振荡
13、轻微振荡
14、剧烈振荡
15、金属

例程：

说明：气球提示框的背景样式。


粒度值 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 此值最好介于5到20之间。

例程：

说明：

气球提示框的粒度值。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 指定手柄出现在提示框的哪个方位。

可供选择的属性值：
0、上左
1、上中
2、上右
3、左上
4、左中
5、左下
6、右上
7、右中
8、右下
9、下左
10、下中
11、下右

例程：

说明：

设置提示框小箭头的指向。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

透明度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 0表示不透明，100表示完全透明。

例程：

说明：

设置汽球提示框的透明度。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

图标图片组 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集； 使用方法见“关联组件()”方法。

例程：

说明：

为汽球提示框的图标图片组添加数据。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

图片图片组 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集； 使用方法见“关联组件()”方法。

例程：

说明：

为汽球提示框的图标图片组添加数据。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

层叠样式表 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集； 指定提示文本HTML中使用的CSS(层叠样式表)。

例程：

说明：

为汽球提示框的层叠样式表添加数据。


行为_ (汽球提示框)

行为_ 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集；

参见： 基本数据类型


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

可多次显示 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

为汽球提示框的可多次显示设置为真。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

跟随鼠标 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

为汽球提示框的跟随鼠标设置为假。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

鼠标离开时隐藏 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

为汽球提示框的鼠标离开时隐藏设置为假。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

鼠标悬停时不隐藏 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

为汽球提示框的鼠标悬停时隐藏设置为真。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

禁止自动隐藏 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：逻辑型； 如果本属性为“真”，在鼠标不动的情况下，提示框不会自动消失。

例程：

说明：

为汽球提示框的禁止自动隐藏设置为假。


尺寸_ (汽球提示框)

尺寸_ 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集；

参见： 基本数据类型


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

圆角横向尺寸 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的圆角横向尺寸设置为16。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

圆角横向尺寸 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的圆角纵向尺寸设置为16。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

水平边距 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的水平边距设置为12。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

垂直边距 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的垂直边距设置为12。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

手柄宽度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的手柄宽度设置为12。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

手柄高度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的手柄高度设置为16。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

手柄边距 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的手柄边距设置为16。


延时_ (汽球提示框)

延时_ 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集；

参见： 基本数据类型


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

显示前延时 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为毫秒。

例程：

说明：

为汽球提示框的显示前延时设置为600。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

自动停留时间 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为毫秒。

例程：

说明：

为汽球提示框的自动停留时间设置为3000。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

淡入时间 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为毫秒。

例程：

说明：

为汽球提示框的淡入时间设置为0。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

淡出时间 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为毫秒。

例程：

说明：

为汽球提示框的淡出时间设置为0。


边线_ (汽球提示框)

边线_ 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集；

参见： 基本数据类型


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

边线颜色 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

为汽球提示框的边线颜色设置为黑色。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

水平边线宽度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的水平边线宽度设置为1。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

垂直边线宽度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的垂直边线宽度设置为1。


阴影_ (汽球提示框)

阴影_ 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：字节集；

参见： 基本数据类型


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

阴影是否渐变 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

为汽球提示框的阴影是否渐变设置为真。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

阴影灰度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 为0-100之间的数值，0表示没有灰度，100表示灰度最深。

例程：

说明：

为汽球提示框的阴影灰度设置为60。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

阴影水平偏移量 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的阴影水平偏移量设置为5。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

阴影垂直偏移量 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的阴影垂直偏移量设置为5。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

阴影水平深度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的阴影水平深度设置为7。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

阴影垂直深度 属性 所属对象：汽球提示框 操作系统支持：Windows

数据类型：整数型； 单位为象素。

例程：

说明：

为汽球提示框的阴影垂直深度设置为7。


关联组件 方法 操作系统支持：Windows 所属对象：汽球提示框

为指定组件添加提示信息。调用本方法后，当鼠标移动到组件客户区域时，提示框将自动弹出。本方法的后四个参数为可选参数，用于指定热点区域，如果提供这四个参数，则只有鼠标移动到该区域之上时，提示框才会弹出。

语法： 逻辑型 汽球提示框．关联组件 （窗口组件， 提示文本， 图标索引， ［热点区域横坐标］， ［热点区域纵坐标］， ［热点区域宽度］， ［热点区域高度］）

参数名 | 描 述
窗口组件 | 必需的； 通用型。
提示文本 | 必需的； 文本型。可以使用经过简化后的HTML语言，如“简单HTML演示：红色加粗倾斜，超链接：易语言网站。“更详细内容，请参考易语言“工具”菜单中的“扩展界面支持库五: 关于简单超文本(HTML)的说明文档”。
图标索引 | 必需的； 整数型，初始值为“-1”。指定图标在“图标图片组”属性中的索引，-1表示不使用图标。如果指定了图标，该图标将显示于提示文本的左边。
热点区域横坐标 | 可选的； 整数型。相对第一个参数“窗口组件”客户区左上角而言。
热点区域纵坐标 | 可选的； 整数型。相对第一个参数“窗口组件”客户区左上角而言。
热点区域宽度 | 可选的； 整数型。
热点区域高度 | 可选的； 整数型。

例程：

说明：

使用该方法以后当鼠标移动到被关联的组件上时，提示框将自动弹出。


关联工具条 方法 操作系统支持：Windows 所属对象：汽球提示框

将信息提示框关联到工具条上，当鼠标移动到工具栏按钮方上时，信息框会自动弹出。信息框中的提示文本将自动使用在“工具条”控件的“工具条按钮”属性中设置的“动态提示”文本。

语法：逻辑型 汽球提示框．关联工具条 （工具栏）

参数名 | 描 述
工具栏 | 必需的； 通用型。

例程：

说明：

与工具条建立关联。


批量关联组件 (气球提示框)

批量关联组件 方法 操作系统支持：Windows 所属对象：气球提示框

将多个窗口组件关联到气球提示框控件上。当被关联的窗口组件需要弹出提示窗口之前，会触发“提示框即将弹出”事件，用户可在此事件中指定提示文本（如果不指定提示文本，提示框不会弹出）；本方法主要用于需要动态指定提示文本的情形。

语法： 逻辑型 气球提示框．批量关联组件 （窗口组件）

参数名 | 描 述
窗口组件 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。目前已知不支持“分组框”组件。

例程

说明

将多个窗口组件关联到气球提示框控件上。当被关联的窗口组件需要弹出提示窗口之前，会触发“提示框即将弹出”事件，用户可在此事件中指定提示文本（如果不指定提示文本，提示框不会弹出）。本方法主要用于需要动态指定提示文本的情形。

参考： 例程1


弹出提示框 方法 操作系统支持：Windows 所属对象：汽球提示框

在屏幕指定位置立刻显示提示框。

语法： 逻辑型 汽球提示框．弹出提示框 （横向坐标， 纵向坐标， 提示文本， 图标索引，[自动关闭]）

参数名 | 描 述
横向坐标 | 必需的； 整数型。相对屏幕左上角而言。
纵向坐标 | 必需的； 整数型。相对屏幕左上角而言。
提示文本 | 必需的； 文本型。
图标索引 | 必需的； 整数型。初始值为“-1”；指定图标在“图标图片组”属性中的索引，-1表示不使用图标。如果指定了图标，该图标将显示于提示文本的左边。
自动关闭 | 可选的；逻辑型。如果为“真”，则提示框在一段时间（由“自动停留时间”属性决定）后自动关闭；如果为“假”，则只有用户点击鼠标或按下键盘任意键后才关闭。如果本参数被省略，默认为“假”。

例程：

说明：

通过命令来设置弹出的提示框的内容文本与弹出位置和图片。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

自定义超链接被单击 事件 所属对象：汽球提示框 操作系统支持：Windows

当用户单击了“显示文本”超链接（详见“关联组件()”方法），将产生本事件。在本事件的处理子程序，需区分不同的“标识文本”参数，以做不同的处理。

语法： 无返回值 _汽球提示框_自定义超链接被单击 （标识文本）

参数名 | 描 述
标识文本 | 文本型；

例程：

说明：

用户点击汽球提示框上面的超链接会触发该事件，前提是汽球提示框上面有超链接。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

提示框即将弹出 事件 所属对象：汽球提示框 操作系统支持：Windows

返回“假”或设置“提示文本”参数为空，可以阻止提示框显示。

语法： 逻辑型 _汽球提示框_提示框即将弹出 （窗口组件句柄， 手柄横向坐标， 手柄纵向坐标， 提示文本）

参数名 | 描 述
窗口组件句柄 | 整数型； 为将要在其上方显示提示框的窗口组件的句柄。
手柄横向坐标 | 整数型； 传址；坐标相对于屏幕左上角而言，单位为象素。
手柄纵向坐标 | 整数型； 传址；坐标相对于屏幕左上角而言，单位为象素。
提示文本 | 文本型； 传址；将要弹出的提示文本。

例程：

说明：

汽球提示框即将弹出会触发该事件。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

提示框即将隐藏 事件 所属对象：汽球提示框 操作系统支持：Windows

语法： 无返回值 _汽球提示框_提示框即将隐藏 （）

例程：

说明：

汽球提示框即将隐藏会触发该事件。


简单超文本框

简单超文本框 窗口组件 操作系统支持：Windows 跳至：扩展界面支持库五

超文本浏览框的简化版，可用于显示简化的HTML文本。

属性：

边框 | 超文本 | 层叠样式表 | 背景颜色
图标图片组 | 图片图片组 |  |

自有事件：

自定义超链接被单击

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

边框 属性 所属对象：简单超文本框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框

例程：

说明：

简单超文本框的边框设置为浅凹入式。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

超文本 属性 所属对象：简单超文本框 操作系统支持：Windows

数据类型：字节集； 欲显示在窗口中的超文本，可以使用经过简化后的HTML语言来描述，如“简单HTML演示：红色加粗倾斜，超链接：易语言网站。”更详细内容，请参考易语言“工具”菜单中的“扩展界面支持库五: 关于简单超文本(HTML)的说明文档。”。

例程：

说明：

简单超文本框的超文本属性的超文本设置为 #超文本。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

层叠样式表 属性 所属对象：简单超文本框 操作系统支持：Windows

数据类型：字节集； 指定提示文本HTML中使用的CSS(层叠样式表)。

例程：

说明：

简单超文本框的层叠样式表设置为 #层叠样式表。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

背景颜色 属性 所属对象：简单超文本框 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

简单超文本框的背景颜色设置为 #默认色。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

图标图片组 属性 所属对象：简单超文本框 操作系统支持：Windows

数据类型：字节集；

例程：

说明：

简单超文本框的图标图片组设置为 #图标图片组。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

图片图片组 属性 所属对象：简单超文本框 操作系统支持：Windows

数据类型：字节集；

例程：

说明：

简单超文本框的图片图片组设置为 #图片图片组。


手柄方位 属性 所属对象：汽球提示框 操作系统支持：Windows

自定义超链接被单击 事件 所属对象：简单超文本框 操作系统支持：Windows

当用户单击了“显示文本”超链接，将产生本事件。在本事件的处理子程序中，需区分不同的“标识文本”参数，以做不同的处理。

语法： 无返回值 _简单超文本框_自定义超链接被单击 （标识文本）

参数名 | 描 述
标识文本 | 文本型；

例程：

说明：

单击简单超文本框的自定义超链接后触发该事件。


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。

参见：例程