扩展界面支持库六

扩展界面支持库六 帮助手册20080813版 返回支持库手册 返回首页

提供“多功能条”等控件，可用于制作具有更好用户体验的程序界面。

操作系统支持： Windows

窗口组件数据类型：

多功能条

适用版本，扩展界面支持库六 （1.1#1版）


多功能条

多功能条 窗口组件 操作系统支持：Windows 跳至：扩展界面支持库六

属性：

类型 | 方向 | 风格 | 页改变值
行改变值 | 最小位置 | 最大位置 | 位置
允许用户调节 | 自动背景高度 | 两端_ | 显示两端按钮
两端按钮图片组 | 后台_ | 后台图片组 | 后台图片显示方式
显示后台两端 | 显示后台中间 | 缩进后台两端 | 前台_
显示前台 | 前台图片组 | 前台图片显示方式 | 显示前台两端
显示前台中间 | 中台_ | 显示中台 | 中台图片组
中台图片显示方式 | 显示中台两端 | 显示中台中间 | 自动伸缩中台

方法：

自有事件：

位置被改变

左按钮被单击

右按钮被单击

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动


类型 属性 数据类型：整数型；

类型 属性 数据类型：整数型； 所属对象：多功能条

本属性用于批量修改本组件的其它属性，以简化用户操作。注意如果相应的属性被用户修改，本属性值将重置为“0.自定义类型”。

可供选择的属性值：

0. 自定义类型

1. 滚动条

2. 进度条

3. 滑块条

4. 图形按钮

语法： 对象. 类型= 整数型

例程：

说明：

设置多功能条的类型。

参见：例程


类型 属性 数据类型：整数型；

方向 属性 数据类型：整数型； 所属对象：多功能条

可供选择的属性值：

0. 水平

1. 垂直

语法： 对象. 方向= 整数型

例程：

说明：

设置多功能条的方向。


类型 属性 数据类型：整数型；

风格 属性 数据类型：整数型； 所属对象：多功能条

本属性用于批量修改本组件的其它属性，以简化用户操作。注意如果相应的属性被用户修改，本属性值将重置为“0.自定义风格”。

可供选择的属性值：

0. 自定义风格

1. 风格1

2. 风格2

3. 风格3

语法： 对象. 风格= 整数型

例程：

说明：

设置多功能条的风格，可以使用预订的风格，也可以根据自己的需要自定义风格。


类型 属性 数据类型：整数型；

页改变值 属性 数据类型：整数型； 所属对象：多功能条

本属性指定当用户在滚动条的空隙处单击后滚动条位置的增减数值。

语法： 对象. 页改变值 = 整数型

例程：

说明：

将多功能条的页改变值设定为编辑框3种输入的数值。即在每次空隙处单击后，滚动条的位置改变值


类型 属性 数据类型：整数型；

行改变值 属性 数据类型：整数型； 所属对象：多功能条

本属性指定当用户按下滚动条的上下箭头按钮后滚动条位置的增减数值。

语法： 对象. 行改变值 = 整数型

例程：

说明：

将多功能条的行改变值设定为编辑框3种输入的数值。即当单击多功能条两边的箭头时，滚动条的位置改变值


类型 属性 数据类型：整数型；

最小位置 属性 数据类型：整数型； 所属对象：多功能条

指定对象的起始点的最小数值。必须小于“最大位置”属性值。

语法： 对象. 最小位置 = 整数型

例程：

说明：

将多功能条的最小位置设定为编辑框1中的数值。多功能条只是起点的位置发生改变，本身的位置没变。


类型 属性 数据类型：整数型；

最大位置 属性 数据类型：整数型； 所属对象：多功能条

指定对象的起始点的最小数值。必须大于“最小位置”属性值。

语法： 对象. 最大位置 = 整数型

例程：

说明：

将多功能条的最大位置设定为编辑框2中的数值。多功能条只是终点位置发生改变，本身位置没变。


类型 属性 数据类型：整数型；

位置 属性 数据类型：整数型； 所属对象：多功能条

指定对象的现行位置。必须介于“最小位置”和“最大位置”之间。

语法： 对象. 位置 = 整数型

例程：

说明：

在多功能条被拖动的情况下，将多功能条当前的位置显示出来。


类型 属性 数据类型：整数型；

允许用户调节 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否允许用户通过鼠标或键盘调节“位置”属性。

语法： 对象. 允许用户调节 = 逻辑型

例程：

说明：

指定是否允许用户通过鼠标或键盘调节“位置”属性。


类型 属性 数据类型：整数型；

自动背景高度 属性 数据类型：逻辑型； 所属对象：多功能条

如果本属性为“真”，则根据两端按钮的大小和中台图片组图片的大小，自动确定背景图片显示区域的高度（水平方向时）或宽度（垂直方向时）。如果本属性为“假”，则背景图片显示区域为整个窗口大小。

语法： 对象. 自动背景高度 = 逻辑型

例程：

说明：

设置多功能条背景的显示方式。


两端_ (多功能条)

两端_ 属性 操作系统支持：Windows 所属对象：多功能条

数据类型：字节集；

参见：基本数据类型


类型 属性 数据类型：整数型；

显示两端按钮 属性 数据类型：逻辑型； 所属对象：多功能条

设置是否显示对象的两端的图片。

语法： 对象. 显示两端按钮 = 逻辑型

例程：

说明：

设置是否显示多功能条两端的图片按钮。


类型 属性 数据类型：整数型；

两端按钮图片组 属性 数据类型：字节集； 所属对象：多功能条

图片组中的图片被分别两部分，依次是“左(上)按钮图片”和“右(下)按钮图片”，其中每部分各有四张图片，依次为“正常”“点燃”“按下”“禁止”状态下所需显示的图片。共需8张图片，允许部分提供（比如只提供一张图片）。提供图片时，请总是使用水平方向上的图片样式；当组件变为纵向时，将自动旋转图片。如果本属性值为空，将自动使用内部默认的图片组。

语法： 对象. 两端按钮图片组 = 字节集

例程：

说明：

设置多功能条两端按钮图片组，注意，图片组共需8张图片。


后台_ (多功能条)

后台_ 属性 操作系统支持：Windows 所属对象：多功能条

数据类型：字节集；

参见：基本数据类型


类型 属性 数据类型：整数型；

后台图片组 属性 数据类型：字节集； 所属对象：多功能条

图片组中的图片被分为四部分，依次是“背景图片”“左(上)端图片”“右(下)端图片”“中间图片”，其中每部分各有四张图片，依次为“正常”“点燃”“按下”“禁止”状态下所需显示的图片。共需图片16张，允许部分提供（比如只提供一张图片）。提供图片时，请总是使用水平方向上的图片样式；当组件变为纵向时，将自动旋转图片。如果本属性值为空，将自动使用内部默认的图片组。

语法： 对象. 后台图片组 = 字节集

例程：

说明：

设置多功能条后台的图片组，注意共需16张图片，允许部分提供。


类型 属性 数据类型：整数型；

后台图片显示方式 属性 数据类型：整数型； 所属对象：多功能条

指定后台背景图片的显示方式。“后台背景图片”即“后台图片组”属性中的前四张图片，索引为0到3。图片居中、居左上仅适用于特殊状态，一般情况下不推荐使用（因为可能导致整个组件显示不正常）。

可供选择的属性值：

0. 居左上

1. 居中

2. 拉伸

3. 平铺

语法： 对象. 后台图片显示方式 = 整数型

例程：

说明：

设置多功能条后台图片的显示方式。


类型 属性 数据类型：整数型；

显示后台两端 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否显示后台两端图片。“后台两端图片”即“后台图片组”属性中的中间8张图片，索引为4到11。

语法： 对象. 显示后台两端 = 逻辑型

例程：

说明：

设置是否显示多功能条后台两端的图片。


类型 属性 数据类型：整数型；

显示后台中间 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否显示后台中间图片。“后台中间图片”即“后台图片组”属性中的最后4张图片，索引为12到15。

语法： 对象. 显示后台中间 = 逻辑型

例程：

说明：

设置是否显示多功能条后台中间的图片。


类型 属性 数据类型：整数型；

缩进后台两端 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否缩进显示后台两端图片，缩进量将根据两端按钮的大小自动确定。如果本属性为“真”，则后台两端图片总是显示在两端按钮的内侧。“后台两端图片”即“后台图片组”属性中的中间8张图片，索引为4到11。

语法： 对象. 缩进后台两端 = 逻辑型

例程：

说明：

设置是否缩进显示多功能条后台两端图片。


前台_ (多功能条)

前台_ 属性 操作系统支持：Windows 所属对象：多功能条

数据类型：字节集；

参见：基本数据类型


类型 属性 数据类型：整数型；

显示前台 属性 数据类型：逻辑型； 所属对象：多功能条

设置是否显示前台。

语法： 对象. 显示前台 = 逻辑型

例程：

说明：

可以修改此属性，改变多功能条的外观。


类型 属性 数据类型：整数型；

前台图片组 属性 数据类型：字节集； 所属对象：多功能条

图片组中的图片被分为四部分，依次是“背景图片”“左(上)端图片”“右(下)端图片”“中间图片”，其中每部分各有四张图片，依次为“正常”“点燃”“按下”“禁止”状态下所需显示的图片。共需图片16张，允许部分提供（比如只提供一张图片）。提供图片时，请总是使用水平方向上的图片样式；当组件变为纵向时，将自动旋转图片。如果本属性值为空，将自动使用内部默认的图片组。

语法： 对象. 前台图片组 = 字节集

例程：

说明：

设置多功能条前台的图片组，注意共需16张图片，允许部分提供。


类型 属性 数据类型：整数型；

前台图片显示方式 属性 数据类型：整数型； 所属对象：多功能条

指定后台背景图片的显示方式。“后台背景图片”即“后台图片组”属性中的前四张图片，索引为0到3。图片居中、居左上仅适用于特殊状态，一般情况下不推荐使用（因为可能导致整个组件显示不正常）。

可供选择的属性值：

0. 居左上

1. 居中

2. 拉伸

3. 平铺

语法： 对象. 前台图片显示方式 = 整数型

例程：

说明：

设置多功能条前台图片的显示方式。


类型 属性 数据类型：整数型；

显示前台两端 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否显示前台两端图片。“前台两端图片”即“前台图片组”属性中的中间8张图片，索引为4到11。

语法： 对象. 显示前台两端 = 逻辑型

例程：

说明：

设置是否显示多功能条前台两端的图片。


类型 属性 数据类型：整数型；

显示前台中间 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否显示前台中间图片。“前台中间图片”即“前台图片组”属性中的最后4张图片，索引为12到15。

语法： 对象. 显示前台中间 = 逻辑型

例程：

说明：

设置是否显示多功能条前台中间的图片。


中台_ (多功能条)

中台_ 属性 操作系统支持：Windows 所属对象：多功能条

数据类型：字节集；

参见：基本数据类型


类型 属性 数据类型：整数型；

显示中台 属性 数据类型：逻辑型； 所属对象：多功能条

设置是否显示前台。

语法： 对象. 显示中台 = 逻辑型

例程：

说明：

可以修改此属性，改变多功能条的外观。


类型 属性 数据类型：整数型；

中台图片组 属性 数据类型：字节集； 所属对象：多功能条

图片组中的图片被分为四部分，依次是“背景图片”“左(上)端图片”“右(下)端图片”“中间图片”，其中每部分各有四张图片，依次为“正常”“点燃”“按下”“禁止”状态下所需显示的图片。共需图片16张，允许部分提供（比如只提供一张图片）。提供图片时，请总是使用水平方向上的图片样式；当组件变为纵向时，将自动旋转图片。如果本属性值为空，将自动使用内部默认的图片组。

语法： 对象. 中台图片组 = 字节集

例程：

说明：

设置多功能条中台的图片组，注意共需16张图片，允许部分提供。


类型 属性 数据类型：整数型；

中台图片显示方式 属性 数据类型：整数型； 所属对象：多功能条

指定后台背景图片的显示方式。“后台背景图片”即“后台图片组”属性中的前四张图片，索引为0到3。图片居中、居左上仅适用于特殊状态，一般情况下不推荐使用（因为可能导致整个组件显示不正常）。

可供选择的属性值：

0. 居左上

1. 居中

2. 拉伸

3. 平铺

语法： 对象. 中台图片显示方式 = 整数型

例程：

说明：

设置多功能条中台图片的显示方式。


类型 属性 数据类型：整数型；

显示中台两端 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否显示中台两端图片。“中台两端图片”即“中台图片组”属性中的中间8张图片，索引为4到11。

语法： 对象. 显示中台两端 = 逻辑型

例程：

说明：

设置是否显示多功能条中台两端的图片。


类型 属性 数据类型：整数型；

显示中台中间 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否显示中台中间图片。“前台中间图片”即“前台图片组”属性中的最后4张图片，索引为12到15。

语法： 对象. 显示中台中间 = 逻辑型

例程：

说明：

设置是否显示多功能条中台中间的图片。


自动伸缩中台 属性 数据类型：整数型；

自动伸缩中台 属性 数据类型：逻辑型； 所属对象：多功能条

指定是否允许自动调整中台大小（根据“最小值”“最大值”及组件尺寸）。

语法： 对象. 自动伸缩中台 = 逻辑型

例程：

说明：

设置是否允许多功能条中台自动伸缩。


类型 属性 数据类型：整数型；

位置被改变 事件 所属对象：多功能条 操作系统支持：Windows

当“位置”属性被改变时产生本事件；此事件的用户处理子程序不需要返回数据。

语法： 无返回值 _多功能条_位置被改变 （）

例程：

说明：

通过此事件滚动显示画板2中的图片。


类型 属性 数据类型：整数型；

左按钮被单击 事件 所属对象：多功能条 操作系统支持：Windows

当左按钮被单击时产生本事件。如果返回真或不返回值，“位置”属性会在原来的基础上自动减小“行改变值”；如果返回假，该单击动作将被忽略；此事件的用户处理子程序所需返回数据的类型为“逻辑型（bool）”。

语法： 逻辑型 _多功能条_左按钮被单击 （）

例程：

说明：

通过此事件在标签8上显示多功能条的现行位置。


类型 属性 数据类型：整数型；

右按钮被单击 事件 所属对象：多功能条 操作系统支持：Windows

当右按钮被单击时产生本事件。如果返回真或不返回值，“位置”属性会在原来的基础上自动增加“行改变值”；如果返回假，该单击动作将被忽略；此事件的用户处理子程序所需返回数据的类型为“逻辑型（bool）”。

语法： 逻辑型 _多功能条_右按钮被单击 （）

例程：

说明：

通过此事件在标签8上显示多功能条的现行位置。


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。