汉字编码转换支持库

文字编码转换支持库 帮助手册20080826版 返回支持库手册 返回首页

本支持库实现了各种编码方式汉字文本之间的转换。

操作系统支持： Windows、Linux

命令类别：

内码转换

常量表...

适用版本，文字编码转换支持库 （1.0#50版）


内码转换

内码转换 类别 跳至：文字编码转换支持库

内码转换


内码转换 命令 操作系统支持：Windows、Linux 所属类别：内码转换

将指定汉字编码的文本转换为另外一种编码方式，其中的非汉字部分不受影响，返回转换结果文本。

语法： 文本型 内码转换 （待转换文本，转换方式）

参数名 | 描 述
待转换文本 | 必需的；文本型。本参数用作提供需要转换的文本。
转换方式 | 必需的；整数型。可以为以下常量值之一： 1、#GBK到BIG5； 2、#BIG5到GBK； 3、#GBK繁体到简体； 4、#GBK简体到繁体； 5、#BIG5到GBK简体； 6、#GBK到SJIS； 7、#SJIS到GBK。

例程：

说明：

对不同内码的汉字进行转换，但是内码转换命令不会判断你需要转换的汉字的编码，如果参数给的不正确本命令一样会转换，但是转换出的内容就会出错。

参考：例程1


常量 | 常量值 | 描 述
#GBK到BIG5 | 1 |
#BIG5到GBK | 2 |
#GBK繁体到简体 | 3 |
#GBK简体到繁体 | 4 |
#BIG5到GBK简体 | 5 |