控制台操作支持库

控制台操作支持库 帮助手册20080822版 返回支持库手册 返回首页

控制台操作支持库。

操作系统支持： Windows、Linux

其它数据类型：

控制台对象

控制台颜色

适用版本，控制台操作支持库 （1.0#1版）


控制台对象

控制台对象 普通类型 操作系统支持：Windows、Linux 跳至：控制台操作支持库

方法：

清屏 | 输入 | 输出 | 置光标位置
取光标位置 | 取显示区大小 | 显示光标 | 隐藏光标
填充背景颜色 | 填充字符 |  |

参见： 基本数据类型


清屏 (控制台对象)

清屏 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

清空屏幕。

语法： 无返回值 控制台对象．清屏 （）

例程：

说明：

清除控制台屏幕内的所有内容。

参见：例程


输入 (控制台对象)

输入 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

从控制台接收输入的数据，如果“横坐标”或“纵坐标”为空，那么从当前光标位置开始输入。

语法： 文本型 控制台对象．输入 （［横坐标］， ［纵坐标］， 保存当前光标， 是否回显， ［回显数据］， 回车结束， 最大接收长度）

参数名 | 描 述
横坐标 | 可选的； 整数型。指定输入数据时光标的横坐标。
纵坐标 | 可选的； 整数型。指定输入数据时光标的纵坐标。
保存当前光标 | 必需的； 逻辑型，初始值为“假”。是否保存当前光标位置。
是否回显 | 必需的； 逻辑型，初始值为“真”。是否把输入的数据回显到控制台设备。
回显数据 | 可选的； 文本型。回显的数据，如果忽略，则使用输入的字符，在”是否回显“为真时有意义。
回车结束 | 必需的； 逻辑型，初始值为“真”。是否以回车结束输入。
最大接收长度 | 必需的； 整数型，初始值为“1024”。最大接收数据长度，“输入结束”为真时有意义。

例程：

说明：

接收控制台中输入的内容。


输出 (控制台对象)

输出 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

向控制台输出数据，如果“横坐标”或“纵坐标”为空，那么从当前光标位置开始输出。

语法： 逻辑型 控制台对象．输出 （［横坐标］， ［纵坐标］， 保存当前光标， 前景颜色， 背景颜色， 输出数据）

参数名 | 描 述
横坐标 | 可选的； 整数型。指定输出数据时光标的横坐标。
纵坐标 | 可选的； 整数型。指定输出数据时光标的纵坐标。
保存当前光标 | 必需的； 逻辑型，初始值为“假”。是否保存当前光标位置。
前景颜色 | 必需的； 整数型，初始值为“8”。前景即字体的颜色，颜色值为“控制台颜色”数据类型中定义的值。
背景颜色 | 必需的； 整数型，初始值为“1”。背景的颜色，颜色值为“控制台颜色”数据类型中定义的值。
输出数据 | 必需的； 文本型。待输出的数据。

例程：

说明：

在控制台指定的位置输出内容。


置光标位置 (控制台对象)

置光标位置 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

设置光标位置。

语法： 逻辑型 控制台对象．置光标位置 （横坐标， 纵坐标）

参数名 | 描 述
横坐标 | 必需的； 整数型。光标的新横坐标。
纵坐标 | 必需的； 整数型。光标的新纵坐标。

例程：

说明：

设置光标的位置。


取光标位置 (控制台对象)

取光标位置 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

获得光标位置。

语法： 逻辑型 控制台对象．取光标位置 （横坐标， 纵坐标）

参数名 | 描 述
横坐标 | 必需的； 整数型，参数数据只能提供变量。光标的横坐标。
纵坐标 | 必需的； 整数型，参数数据只能提供变量。光标的新纵坐标。

例程：

说明：

取光标的位置。


取显示区大小 (控制台对象)

取显示区大小 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

取显示区大小。

语法： 无返回值 控制台对象．取显示区大小 （长度， 宽度）

参数名 | 描 述
长度 | 必需的； 整数型，参数数据只能提供变量。显示区长度。
宽度 | 必需的； 整数型，参数数据只能提供变量。显示区宽度。

例程：

说明：

获取控制台屏幕的大小。


显示光标 (控制台对象)

显示光标 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

显示光标。

语法： 逻辑型 控制台对象．显示光标 （）

例程：

说明：

将光标显示出来。


隐藏光标 (控制台对象)

隐藏光标 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

隐藏光标。

语法： 逻辑型 控制台对象．隐藏光标 （）

例程：

说明：

将光标隐藏。


填充背景颜色 (控制台对象)

填充背景颜色 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

填充背景颜色，返回实际填充的长度，失败返回-1。

语法： 整数型 控制台对象．填充背景颜色 （横坐标， 纵坐标， 背景颜色， 填充长度）

参数名 | 描 述
横坐标 | 必需的； 整数型。开始填充的横坐标。
纵坐标 | 必需的； 整数型。开始填充的纵坐标。
背景颜色 | 必需的； 整数型。背景颜色。
填充长度 | 必需的； 整数型。填充区域的长度。

例程：

说明：

设置控制台的背景颜色。


填充字符 (控制台对象)

填充字符 方法 操作系统支持：Windows、Linux 所属对象：控制台对象

填充字符。

语法： 整数型 控制台对象．填充字符 （横坐标， 纵坐标， 填充字符， 填充长度）

参数名 | 描 述
横坐标 | 必需的； 整数型。开始填充的横坐标。
纵坐标 | 必需的； 整数型。开始填充的纵坐标。
填充字符 | 必需的； 文本型。本参数是一个文本，但只有第一个字符有效。
填充长度 | 必需的； 整数型。填充区域的长度。

例程：

说明：

设置输出的字符。注意：输出的字符的颜色为白色或者黑色，由控制台的背景颜色决定。


控制台颜色

控制台颜色 枚举常量集合类型 操作系统支持：Windows、Linux 跳至：控制台操作支持库

本数据类型包括了控制台颜色常量。

成员 | 描 述
黑色 | 常量值为 1 。黑色。
红褐 | 常量值为 2 。红褐色。
墨绿 | 常量值为 3 。墨绿色。
褐绿 | 常量值为 4 。褐绿色。
藏青 | 常量值为 5 。藏青色。
紫红 | 常量值为 6 。紫红色。
深青 | 常量值为 7 。深青色。
银白 | 常量值为 8 。银白色。
灰色 | 常量值为 9 。灰色。
红色 | 常量值为 10 。红色。
绿色 | 常量值为 11 。绿色。
黄色 | 常量值为 12 。黄色。
蓝色 | 常量值为 13 。蓝色。
品红 | 常量值为 14 。品红色。
艳青 | 常量值为 15 。艳青。
白色 | 常量值为 16 。白色。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。