系统核心支持库

系统核心支持库 帮助手册20080825版 返回支持库手册 返回首页

本支持库是易语言的核心库，为系统本身和每个易程序提供必需的功能支持。

操作系统支持： Windows、Linux

命令类别：

流程控制 | 算术运算 | 逻辑比较 | 位运算
变量操作 | 数组操作 | 环境存取 | 拼音处理
文本操作 | 字节集操作 | 数值转换 | 时间操作
磁盘操作 | 文件读写 | 系统处理 | 程序调试
其他 | 控制台操作 |  |

常量表...

适用版本，系统核心支持库 （4.5#63版）


流程控制

流程控制 类别 跳至：系统核心支持库


如果 命令 所属类别：流程控制

如果 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否改变程序的执行位置，如果提供的逻辑参数值为真，程序继续顺序向下执行，否则跳转到左侧箭头线指向的命令处去执行。

语法： 无返回值 如果 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

如果命令的条件参数必须为逻辑型，可以为一个或多个逻辑型条件语句组成，多个逻辑型条件语句之间可以用“或”或者“且”连接，

如果输入的字符符合 “123456”的条件，就执行输出 “欢迎使用易语言”的命令，否则，就会输出“您好“。

注：可用或者、并且命令连接多个条件

例1：如果 (条件1 ＝条件2 且 条件3 ＝条件4)

例2：如果 (条件1 ＝条件2 或 条件3 ＝条件4)

参见：例程


如果真 命令 所属类别：流程控制

如果真 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否改变程序的执行位置，如果提供的逻辑参数值为真，程序继续顺序向下执行，否则跳转到左侧箭头线指向的命令处去执行。同“如果”命令相比，本命令没有为假时的程序部分。

语法： 无返回值 如果真 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

如果真命令和如果命令相似，如果真的条件也必须是逻辑型，可以用“或者”“并且”连接多个条件。

此段语句运行时，如果输入的字符为“y”，就运行如果真命令下面的所有命令，

最后将输出“您好！欢迎使用易语言！” ；如果真命令中的条件不成立，将输出“欢迎使用易语言！”。

注：如果真语句的条件，可以用或者、并且连接多个条件

例：如果真（条件1=条件2 或 条件2≠条件3）

例：如果真（条件1=条件2 且 条件2≠条件3）

参见：例程


判断 命令 所属类别：流程控制

判断 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否改变程序的执行位置，如果提供的逻辑参数值为真，程序继续顺序向下执行，否则跳转到下一分支处去继续判断。

语法： 无返回值 判断 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

此命令和如果命令可以互换，用法和如果命令相似，条件必须是逻辑型，可以多条件

判断命令的条件参数必须为逻辑型，可以为一个或多个逻辑型条件语句组成，多个逻辑型条件语句之间可以用“或”或者“且”连接，

如果输入的字符为 “a”，就执行输出 “欢迎使用易语言”的命令，否则，就会输出“您好“。

注：判断语句的条件，可以用或、且连接多个条件

例：判断（条件1=条件2 或 条件2≠条件3）

例：判断（条件1=条件2 且 条件2≠条件3）

参见：例程


判断循环首 命令 所属类别：流程控制

判断循环首 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否进入循环。如果提供的逻辑参数值为真，程序顺序执行下一条命令进入循环，否则跳转到本命令所对应的“判断循环尾”命令的下一条命令处以跳出循环。

语法： 无返回值 判断循环首 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

判断循环首的条件是逻辑型，是先判断再循环。首先判断是否符合条件，如果符合条件，就执行一次循环中的代码；再判断是否符合条件，如果符合条件，就再执行一次循环中的代码；如此反复，直到不符合条件就停止循环。

注意：此命令编写时，只需要输入pdxhs()，就会自动出现：不用单独输入判断循环尾。

参见：例程


循环判断首 命令 所属类别：流程控制

循环判断首 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

执行本命令后将顺序执行下一条命令进入程序循环。

语法： 无返回值 循环判断首 （）

例程

说明：

此命令和判断循环首命令相似，不同在于，此命令是先循环再判断，是在循环尾部判断，

如果条件成立，则跳到循环判断首，顺序执行循环中的命令。

参见：例程


计次循环首 命令 所属类别：流程控制

计次循环首 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

执行本命令将把循环体内的命令重复执行指定的次数。提供的整数参数值决定将重复执行的次数。

语法： 无返回值 计次循环首 （循环次数，［已循环次数记录变量］）

参数名 | 描 述
循环次数 | 必需的；整数型。本数值指定执行计次循环体内所有命令的次数，必须大于等于零。
已循环次数记录变量 | 可选的；整数型，参数数据只能提供变量。本数值型变量用作记录当前循环首已经被进入过的次数（从 1 开始），程序可以直接取用此变量中的值。

例程

说明：

第一个参数，给出将要循环的次数，是整数型，第二个参数可选的，可以给出一个整数型的变量，用来记录已经循环的次数。

例程中是将10以内的整数显示出来，首先运行 计次循环首 (10, 计次变量) 的命令，此命令规定此循环循环10次，把循环的次数记录在了计次变量中，这样，第一次循环，计次变量是1，第二次循环，计次变量是2，依此类推。最后就显示为“1 2 3 4 5 6 7 8 9 10”。

参考：例程


容器循环首 命令 所属类别：流程控制

变量循环首 命令 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

执行本命令将利用变量对循环体内的命令进行循环执行。第一次执行此命令时将使用“变量起始值”参数初始化“循环变量”参数所指定的变量。每次（包括第一次）执行到此命令处都将判断循环变量内的值是否已经超过“变量目标值”参数所指定的值，如已超过，则跳转到对应的“变量循环尾”命令的下一条命令处继续执行，否则顺序执行下一条语句继续进行循环。

语法： 无返回值 变量循环首 （变量起始值，变量目标值，变量递增值，［循环变量］）

参数名 | 描 述
变量起始值 | 必需的；整数型，初始值为“1”。定义循环变量的起始数值。
变量目标值 | 必需的；整数型。定义循环变量的目标数值，在循环首部如果发现变量值已超出此目标值时将跳出循环。
变量递增值 | 必需的；整数型，初始值为“1”。每次执行到循环尾部时都将把此值加入到循环变量中去，此值可为正数或负数，如为正数则递增，为负数则递减。
循环变量 | 可选的；整数型，参数数据只能提供变量。本数值型变量将用作控制循环执行次数，在循环尾部将自动递增或递减该变量内的数值。如果被省略，命令将自动使用内部临时变量。

例程

说明：

此命令可以在变量内进行循环，并能把每次内部循环的值取出。

变量起始值：是进行内部变量循环的起始值，并用这个参数的值初始化循环变量，即循环刚开始时循环变量的值；

变量目标值：是变量起始值最终达到的数值，当到达变量目标值时，循环结束；

变量递增值：它的初始值是1，可以按照需要规定它的值，是变量起始值向变量目标值递增时每次所要增加的数值；

循环变量：可以省略，如果省略，将自动使用内部临时变量，它记录了递增的过程，是记录变量起始值向变量目标值每次递增后的数值。

注意：循环变量不同于计次循环首中“已循环次数记录变量“，它的初始值可以自定义，循环刚开始时，循环变量的初始值是由变量起始值决定的，变量起始值的数值，就是循环变量的初始值。

此段代码，可以显示10以下的整数值，循环开始时，循环变量的初始值是1，这是由第一个参数变量起始值决定的，每次循环，循环变量的值都递增1，直到循环变量的值达到变量的目标值10，循环结束。

参见：例程


到循环尾 命令 所属类别：流程控制

到循环尾 命令 所操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令转移当前程序执行位置到当前所处循环体的循环尾语句处。

语法： 无返回值 到循环尾 （）

例程

说明：

这个命令可以在循环中，直接运行到循环尾（循环判断尾；判断循环尾；计次循环尾）。

此例是显示1-10的整数，但不包括5，在循环中，如果符合计次变量= 5的条件，就运行 到循环尾 () 的命令，直接跳到计次循环尾 ()，也就不运行 标准输出 (, 到文本 (计次变量) ＋ #换行符) 命令，跳过了5这个数。

参见：例程


跳出循环 命令 所属类别：流程控制

跳出循环 命令 所操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令转移当前程序执行位置到当前所处循环体循环尾语句的下一条语句处。

语法： 无返回值 跳出循环 （）

例程

说明：

跳出循环命令，是要终止一个循环的使用，在一定条件下，想停止一个循环的运行，

就可以使用跳出循环命令，此循环就会停止，继续运行循环尾句下面的语句。

如果是双重循环，即一个循环里面还有另一个循环，那么用跳出循环命令只是终止跳出循环命令所在的那个循环。

参见：例程


返回 命令 所属类别：流程控制

返回 命令 所操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令转移当前程序执行位置到调用本子程序语句的下一条语句处,并可根据需要返回一个值到子程序调用处。

语法： 无返回值 返回 （［返回到调用方的值］）

参数名 | 描 述
返回到调用方的值 | 可选的；通用型。

例程

说明：

返回命令使用比较普遍，返回命令不但可以返回给调用方各种类型的数据，也可以终止一系列代码的运行。

当然，返回命令可以返回任何通用型的数据，下有3例：

例：返回（100）

返回一段整数

例：返回 ([1998年11月12日])

返回一段日期时间型数据

例：返回 ({ 201 })

返回一段字节集

参考：例程


结束 命令 所属类别：流程控制

结束 命令 所操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令结束当前易程序的运行。

语法： 无返回值 结束 （）

例程

说明：

结束命令，可以用来结束当前的易程序的运行，可以用做结束程序或关闭程序。

参考：例程


算术运算

算术运算 类别 跳至：系统核心支持库

相乘 | 相除 | 整除 | 求余数
相加 | 相减 | 负 | 取符号
取绝对值 | 取整 | 绝对取整 | 四舍五入
求次方 | 求平方根 | 求正弦 | 求余弦
求正切 | 求反正切 | 求自然对数 | 求反对数
是否运算正确 | 置随机数种子 | 取随机数 |


相乘 命令 所属类别：算术运算

相乘 命令 操作系统支持：Windows、Linux、Unix 所属类别：算术运算

返回两个数值的乘积，运算符号为“*”或“×”。

语法： 双精度小数型 相乘 （被乘数，乘数，… ）

参数名 | 描 述
被乘数 | 必需的；双精度小数型。
乘数 | 必需的；可扩充的；双精度小数型。

例程

说明：

将被乘数和乘数转换到数值型，然后将两个转换后的数值相乘，

再把返回的数值型结果转换到文本型，显示出来。

参见：例程


相除 命令 所属类别：算术运算

相除 命令 操作系统支持：Windows、Linux、Unix 所属类别：算术运算

返回两个数值的商，运算符号为“/”或“÷”。

语法： 双精度小数型 相除 （被除数，除数，… ）

参数名 | 描 述
被除数 | 必需的；双精度小数型。
除数 | 必需的；可扩充的；双精度小数型。

例程

说明：

先将被除数和除数转换到数值型，再将两个转换的内容相除，

把返回的结果转换到文本型，显示出来。

参见：例程


整除 命令 所属类别：算术运算

整除 命令 操作系统支持：Windows、Linux 所属类别：算术运算

求出两个数值的商，并返回其整数部分，运算符号为“\”。

语法： 双精度小数型 整除 （被除数，除数，… ）

参数名 | 描 述
被除数 | 必需的；双精度小数型。
除数 | 必需的；可扩充的；双精度小数型。

例程

说明：

得到的结果是两个数值的商，去掉小数部分后剩下的整数部分的值。小数部分全部去掉，不四舍五入。

参见：例程


求余数 命令 所属类别：算术运算

求余数 命令 操作系统支持：Windows、Linux 所属类别：算术运算

求出两个数值的商，并返回余数部分，运算符号为“%”或“Mod”。

语法： 双精度小数型 求余数 （被除数，除数，… ）

参数名 | 描 述
被除数 | 必需的；双精度小数型。
除数 | 必需的；可扩充的；双精度小数型。

例程

说明：

当计算到被除数小于除数时，就不再计算，剩余的被除数就是余数。

参见：例程


相加 命令 所属类别：算术运算

相加 命令 操作系统支持：Windows、Linux、Unix 所属类别：算术运算

运算符号为“+”，用途为：1、返回两个数值的和；2、将两个文本首尾连接起来，返回连接后的文本；3、将两个字节集首尾连接起来，返回连接后的字节集。

语法： 通用型 相加 （被加数或文本或字节集，加数或文本或字节集，… ）

参数名 | 描 述
被加数或文本或字节集 | 必需的；通用型。
加数或文本或字节集 | 必需的；可扩充的；通用型。

例程

说明：

注：数值相加，返回两个数值的和。

注：文本相加，将两个文本首尾连接起来，返回连接后的文本。

注：字节集相加，将两个字节集首尾连接起来，返回连接后的字节集。

参见：例程


相减 命令 所属类别：算术运算

相减 命令 操作系统支持：Windows、Linux、Unix 所属类别：算术运算

返回两个数值的差，运算符号为“-”。

语法： 双精度小数型 相减 （被减数，减数，… ）

参数名 | 描 述
被减数 | 必需的；双精度小数型。
减数 | 必需的；可扩充的；双精度小数型。

例程

说明：

将被减数和减数转换到数值型，再将两个数值相减。

把返回的结果转换成文本型，显示出来。

参见：例程


负 命令 所属类别：算术运算

负 命令 操作系统支持：Windows、Linux、Unix 所属类别：算术运算

反转一个数值的正负符号并返回反转后的值，运算符号为“-”（放在表达式首）。

语法： 双精度小数型 负 （数值）

参数名 | 描 述
数值 | 必需的；双精度小数型。

例程

说明：

把数值转换到数值型，然后取它的负值，再转换到文本型，显示出来。

参见：例程


取符号 命令 所属类别：算术运算

取符号 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回一个整数，如果小于零，表明给定数值为负；如果等于零，表明给定数值为零；如果大于零，表明给定数值为正。

语法： 整数型 取符号（欲取其符号的数值）

参数名 | 描 述
欲取其符号的数值 | 必需的；双精度小数型。

例程

说明：

根据返回的整数值判断数值的正负号。

参见：例程


取绝对值 命令 所属类别：算术运算

取绝对值 命令 操作系统支持：Windows、Linux 所属类别：算术运算

如果所提供数值为字节型，则将直接返回该数值。

语法： 双精度小数型 取绝对值 （欲取其绝对值的数值）

参数名 | 描 述
欲取其绝对值的数值 | 必需的；双精度小数型。

例程

说明：

本命令是把数值的符号都换成正号，零的绝对值是零。

参见：例程


取整 命令 所属类别：算术运算

取整 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回一个小数的整数部分。本命令与“绝对取整”命令不相同之处为：如果给定小数为负数，则本命令返回小于或等于该小数的第一个负整数，而“绝对取整”命令则会返回大于或等于该小数的第一个负整数。例如，本命令将 -7.8 转换成 -8，而“绝对取整”命令将 -7.8 转换成 -7。

语法： 整数型 取整 （欲取整的小数）

参数名 | 描 述
欲取整的小数 | 必需的；双精度小数型。

例程

说明：

本命令返回，在小于或等于给定数值的所有数值中，最大的整数值。

在正数的情况下，取整与绝对取整相同。

参见：例程


绝对取整 命令 所属类别：算术运算

绝对取整 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回一个小数的整数部分。本命令与“取整”命令不相同之处为：如果给定小数为负数，则本命令返回大于或等于该小数的第一个负整数，而“取整”命令则会返回小于或等于该小数的第一个负整数。例如，本命令将 -7.8 转换成 -7，而“取整”命令将 -7.8 转换成 -8。

语法： 整数型 绝对取整 （欲取整的小数）

参数名 | 描 述
欲取整的小数 | 必需的；双精度小数型。

例程

说明：

将一个数值的小数部分去掉，只保留整数部分。不四舍五入。

参见：例程


四舍五入 命令 所属类别：算术运算

四舍五入 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回按照指定的方式进行四舍五入运算的结果数值。

语法： 双精度小数型 四舍五入 （欲被四舍五入的数值，［被舍入的位置］）

参数名 | 描 述
欲被四舍五入的数值 | 必需的；双精度小数型。
被舍入的位置 | 可选的；整数型。如果大于0，表示小数点右边应保留的位数；如果等于0，表示舍入到整数；如果小于0，表示小数点左边舍入到的位置。例如：四舍五入 (1056.65, 1) 返回 1056.7； 四舍五入 (1056.65, 0) 返回 1057； 四舍五入 (1056.65, -1) 返回 1060。如果省略本参数，则默认为0。

例程

说明：

把数值变量转换到数值型，然后四舍五入到整数位，再显示出来。

参见：例程


求次方 命令 所属类别：算术运算

求次方 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定数值的指定次方。

语法： 双精度小数型 求次方 （欲求次方数值，次方数）

参数名 | 描 述
欲求次方数值 | 必需的；双精度小数型。参数值指定欲求其某次方的数值。
次方数 | 必需的；双精度小数型。参数值指定对欲求次方数值的运算指数。

例程

说明：

根据输入的数值，求其平方。

参见：例程


求平方根 命令 所属类别：算术运算

求平方根 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定参数的平方根。

语法： 双精度小数型 求平方根 （欲求其平方根的数值）

参数名 | 描 述
欲求其平方根的数值 | 必需的；双精度小数型。参数值如果小于零将导致计算错误。

例程

说明：

将数值变量到数值型，把转换后的数据求平方根，

再把返回的双精度小数型数据转换到文本型，显示出来。

参见：例程


求正弦 命令 所属类别：算术运算

求正弦 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定角的正弦值。

语法： 双精度小数型 求正弦 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。所使用单位为弧度。为了将角度转换成弧度，请将角度乘以 #pi / 180。为了将弧度转换成角度，请将弧度乘以 180 / #pi。如果参数值大于等于 2 的 63 次方，或者小于等于 -2 的 63 次方，将导致计算溢出。

例程

说明：

将输入的角度数值转换到双精度小数型，再将转换后的数值乘以#pi除以180得到弧度后求正弦，

把返回的双精度小数型数据转换到文本型，显示出来。

参见：例程


求余弦 命令 所属类别：算术运算

求余弦 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定角的余弦值。

语法： 双精度小数型 求余弦 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。所使用单位为弧度。为了将角度转换成弧度，请将角度乘以 #pi / 180。为了将弧度转换成角度，请将弧度乘以 180 / #pi。如果参数值大于等于 2 的 63 次方，或者小于等于 -2 的 63 次方，将导致计算溢出。

例程

说明：

将输入的角度数值转换到双精度小数型，再将转换后的数值乘以#pi除以 180得到弧度后求余弦，

将返回的双精度小数型数据转换到文本型，显示出来。

参见：例程


求正切 命令 所属类别：算术运算

求正切 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定角的正切值。

语法： 双精度小数型 求正切 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。所使用单位为弧度。为了将角度转换成弧度，请将角度乘以 #pi / 180。为了将弧度转换成角度，请将弧度乘以 180 / #pi。如果参数值大于等于 2 的 63 次方，或者小于等于 -2 的 63 次方，将导致计算溢出。

例程

说明：

先把输入的角度数值转换到双精度小数型，再把转换后内容乘以 #pi 除以 180得到弧度后求正切，

再把返回的数值转换到文本型，显示出来。

参见：例程


求反正切 命令 所属类别：算术运算

求反正切 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定数的反正切值。

语法： 双精度小数型 求反正切 （欲求其反正切值的数值）

参数名 | 描 述
欲求其反正切值的数值 | 必需的；双精度小数型。

例程

说明：

先把输入的数值转换到双精度小数型，求反正切；得到的数值是弧度，

再把返回的弧度乘以 #pi 除以180的角度值转换到文本型显示出来。

参见：例程


求自然对数 命令 所属类别：算术运算

求自然对数 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回指定参数的自然对数值。自然对数是以 e 为底的对数。常量 #e 的值大约是 2.718282。

语法： 双精度小数型 求自然对数 （欲求其自然对数的数值）

参数名 | 描 述
欲求其自然对数的数值 | 必需的；双精度小数型。

例程

说明：

先把输入的数值转换到双精度小数型，将转换后的内容求自然对数，

再把返回的数值转换到文本型，显示出来。

参见：例程


求反对数 命令 所属类别：算术运算

求反对数 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回 e（自然对数的底）的某次方。

语法： 双精度小数型 求反对数 （欲求其反对数的数值）

参数名 | 描 述
欲求其反对数的数值 | 必需的；双精度小数型。如果参数值超过 709.782712893，将导致计算溢出。

例程

说明：

将输入的数值转换到双精度小数型。再把转换后的数值求反对数，

把返回的数值转换到文本型，显示出来。

参见：例程


是否运算正确 命令 所属类别：算术运算

是否运算正确 命令 操作系统支持：Windows、Linux 所属类别：算术运算

对“求次方”、“求平方根”、“求正弦值”、“求余弦值”、“求正切值”、“求反正切值”、“求自然对数”、“求反对数”等等数学运算命令所计算出来的双精度结果数值进行校验，如果该数值正确有效，返回真。如果该数值是运算错误或运算溢出后的结果，返回假。

语法： 逻辑型 是否运算正确 （欲校验的计算结果）

参数名 | 描 述
欲校验的计算结果 | 必需的；双精度小数型。

例程

说明：

检验求得的正切值是否正确。

参见：例程


置随机数种子 命令 所属类别：算术运算

置随机数种子 命令 操作系统支持：Windows、Linux 所属类别：算术运算

为随机数生成器初始化一个种子值，不同的种子值将导致“取随机数”命令返回不同的随机数系列。

语法： 无返回值 置随机数种子 （［欲置入的种子数值］）

参数名 | 描 述
欲置入的种子数值 | 可选的；整数型。如果省略本参数，将默认使用当前计算机系统的时钟值。

例程

说明：

注：多运行几次取随机数，你会发现一个现象，每次取的数值是有规律的，所以我们要设置一个随机数的种子，种子不一样，取出的随机数也不一样，但是这还是很麻烦，需要每次手动调整随机数种子，这里推荐用现行时间作为种子，因为时间是不会重复的，所以，随机数出现的规律也不会重复。

注：如不使用 置随机数种子，默认用1作为随机数种子

参见：例程


取随机数 命令 所属类别：算术运算

取随机数 命令 操作系统支持：Windows、Linux 所属类别：算术运算

返回一个指定范围内的随机数值。在使用本命令取一系列的随机数之前，应该先使用“置随机数种子”命令为随机数生成器初始化一个种子值。

语法： 整数型 取随机数 （［欲取随机数的最小值］，［欲取随机数的最大值］）

参数名 | 描 述
欲取随机数的最小值 | 可选的；整数型。参数必须大于或等于零。本参数如果被省略，默认为 0 。
欲取随机数的最大值 | 可选的；整数型。参数必须大于或等于零。本参数如果被省略，默认为无限。

例程

说明：

随机取出1-10之间的整数值。

参见：例程


逻辑比较

逻辑比较 类别 跳至：系统核心支持库


等于 命令 所属类别：逻辑比较

等于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值与比较值相同时返回真，否则返回假，运算符号为“=”或“==”。

语法： 逻辑型 等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。
比较值 | 必需的；通用型。比较值的数据类型必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较。

参见：例程


等于 命令 所属类别：逻辑比较

不等于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值与比较值不相同时返回真，否则返回假，运算符号为“<>”或“!=”或“≠”。

语法： 逻辑型 不等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。
比较值 | 必需的；通用型。比较值的数据类型必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较。

参见：例程


等于 命令 所属类别：逻辑比较

小于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值小于比较值时返回真，否则返回假，运算符号为“<”。

语法： 逻辑型 小于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较。

数值文本比较:如，'123' 和 '45' 比较， '45' 大于'123'，

因为第一位的'1'和'4'比较，'4'的代码大于'1'的代码，所以'45'大。

英文字母比较：如,'ab'和'cd'比较，'cd'大于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写字母代码）。

关于代码大小请参阅ASCⅡ码。

参见：例程


等于 命令 所属类别：逻辑比较

大于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值大于比较值时返回真，否则返回假，运算符号为“>”。

语法： 逻辑型 大于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较。

数值文本比较:如，'123' 和 '45' 比较， '45' 大于 '123'，

因为第一位的'1'和'4'比较，'4'的代码大于'1'的代码，所以'45'大。

英文字母比较：如,'ab'和'cd'比较，'cd'大于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写字母代码）。

关于代码的大小请参阅ASCⅡ码。

参见：例程


等于 命令 所属类别：逻辑比较

小于或等于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值小于或等于比较值时返回真，否则返回假，运算符号为“<=”或“≤”。

语法： 逻辑型 小于或等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较。

数值文本比较: 如，'123' 和 '45' 比较， '45' 大于 '123'，

因为第一位的'1'和'4'比较，'4'大于'1'，所以'45'大；

英文字母比较：如,'ab'和'cd'比较，'cd'大于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写代码）。

关于代码的大小请参阅ASCⅡ码。

参见：例程


等于 命令 所属类别：逻辑比较

大于或等于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值大于或等于比较值时返回真，否则返回假，运算符号为“>=”或“≥”。

语法： 逻辑型 大于或等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较。

数值文本比较:如，'123' 和 '45' 比较， '45' 大于或等于'123'，

因为第一位的'1'和'4'比较，'4'大于'1'，所以'45'大。

英文字母比较：如,'ab'和'cd'比较，'cd'大于或等于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写代码）。

关于代码的大小请参阅ASCⅡ码。

参见：例程


等于 命令 所属类别：逻辑比较

近似等于 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

当比较文本在被比较文本的首部被包容时返回真，否则返回假，运算符号为“?=”或“≈”。

语法： 逻辑型 近似等于 （被比较文本，比较文本）

参数名 | 描 述
被比较文本 | 必需的；文本型。
比较文本 | 必需的；文本型。

例程

说明：

此例程为两个文本进行比较。

比较值必须包含在被比较值里，如：被比较值 '11234',比较值'11'。

参见：例程


等于 命令 所属类别：逻辑比较

并且 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

如果所提供的两个参数逻辑值都为真则返回真，否则返回假，运算符号为“&&”或“And”或“且”。

语法： 逻辑型 并且 （逻辑值一，逻辑值二，… ）

参数名 | 描 述
逻辑值一 | 必需的；逻辑型。
逻辑值二 | 必需的；可扩充的；逻辑型。

例程

说明:

判断输入的两个数值是否都大于或等于5。

参见：例程


等于 命令 所属类别：逻辑比较

或者 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

如果所提供的两个参数逻辑值中任意有一个为真则返回真，否则返回假，运算符号为“||”或“Or”或“或”。

语法： 逻辑型 或者 （逻辑值一，逻辑值二，… ）

参数名 | 描 述
逻辑值一 | 必需的；逻辑型。
逻辑值二 | 必需的；可扩充的；逻辑型。

例程

说明：

判断输入的数值是否都大于5

参见：例程


等于 命令 所属类别：逻辑比较

取反 命令 所操作系统支持：Windows、Linux　　所属类别：逻辑比较

如果参数值为真则返回假，如果参数值为假则返回真。

语法： 逻辑型 取反 （被反转的逻辑值）

参数名 | 描 述
被反转的逻辑值 | 必需的；逻辑型。

例程

说明：

当输入“y”时，需要进行循环，但是取反后，就不循环了。而输入“n”时，才循环。

参见：例程


位运算

位运算 类别 跳至：系统核心支持库


位取反 命令 所属类别：位运算

位取反 命令 操作系统支持：Windows、Linux 所属类别：位运算

将指定数值每一个比特位的值取反后返回。

语法： 整数型 位取反 （欲取反的数值）

参数名 | 描 述
欲取反的数值 | 必需的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

参见：例程


位与 命令 所属类别：位运算

位与 命令 操作系统支持：Windows、Linux 所属类别：位运算

如两个数值有某共同比特位为1，则返回值的对应位也为1，否则为0。返回计算后的结果。

语法： 整数型 位与 （位运算数值一，位运算数值二，… ）

参数名 | 描 述
位运算数值一 | 必需的；整数型。
位运算数值二 | 必需的；可扩充的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

参见：例程


位或 命令 所属类别：位运算

位或 命令 操作系统支持：Windows、Linux 所属类别：位运算

如两个数值中有一个数值的某一比特位不为零，则返回值的对应位就为1，否则为0。返回计算后的结果。

语法： 整数型 位或 （位运算数值一，位运算数值二，… ）

参数名 | 描 述
位运算数值一 | 必需的；整数型。
位运算数值二 | 必需的；可扩充的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

参见：例程


位异或 命令 所属类别：位运算

位异或 命令 操作系统支持：Windows、Linux 所属类别：位运算

如两个数值对应比特位的值不相等，则返回值的对应位就为1，否则为0。返回计算后的结果。

语法： 整数型 位异或 （位运算数值一，位运算数值二，… ）

参数名 | 描 述
位运算数值一 | 必需的；整数型。
位运算数值二 | 必需的；可扩充的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

参见：例程


左移

左移 命令 操作系统支持：Windows、Linux 所属类别：位运算

将某整数的数据位左移指定位数，返回移动后的结果。

语法： 整数型 左移 （欲移动的整数， 欲移动的位数）

参数名 | 描 述
欲移动的整数 | 必需的； 整数型。
欲移动的位数 | 必需的； 整数型。

例程：

说明：

将某整数的数据位左移1位。

参见：例程1


右移

右移 命令 操作系统支持：Windows、Linux 所属类别：位运算

将某整数的数据位右移指定位数，返回移动后的结果。

语法： 整数型 右移 （欲移动的整数， 欲移动的位数）

参数名 | 描 述
欲移动的整数 | 必需的； 整数型。
欲移动的位数 | 必需的； 整数型。

例程：

说明：

将某整数的数据位右移1位。

参见：例程1


合并整数

合并整数 命令 操作系统支持：Windows、Linux 所属类别：位运算

将第一个整数的低16位放置到结果整数的低16位，将第二个整数的低16位放置到结果整数的高16位，以此合并成一个整数，并返回合并后的结果。

语法： 整数型 合并整数 （用作合并的整数1， 用作合并的整数2）

参数名 | 描 述
用作合并的整数1 | 必需的； 整数型。
用作合并的整数2 | 必需的； 整数型。

例程：

说明：

合并成一个整数，并返回合并后的结果。

参见：例程1


合并短整数

合并短整数 命令 操作系统支持：Windows、Linux 所属类别：位运算

将第一个整数的低8位放置到结果短整数的低8位，将第二个整数的低8位放置到结果短整数的高8位，以此合并成一个短整数，并返回合并后的结果。

语法： 短整数型 合并短整数 （用作合并的整数1， 用作合并的整数2）

参数名 | 描 述
用作合并的整数1 | 必需的； 整数型。
用作合并的整数2 | 必需的； 整数型。

例程：

说明：

合并成一个短整数，并返回合并后的结果。

参见：例程1


变量操作

变量操作 类别 跳至：系统核心支持库


赋值 命令 所属类别：容器操作

赋值 命令 操作系统支持：Windows、Linux、Unix 所属类别：变量操作

将指定的常数、常数集、常量、资源、对象或者变量赋于到指定的变量或变量数组中去。运算符号为“=”。

语法： 无返回值 赋值 （被赋值的变量或变量数组，用作赋于的值或资源）

参数名 | 描 述
被赋值的变量或变量数组 | 必需的；通用型，参数数据只能提供变量及变量数组。
用作赋于的值或资源 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。

例程

说明：

将指定的常数、常数集、常量、资源、对象或者变量赋予到指定的变量或变量数组中去。运算符号为“=”。

参见：例程


连续赋值 命令 所属类别：容器操作

连续赋值 命令 操作系统支持：Windows、Linux、Unix 所属类别：变量操作

将指定的常数、常数集、常量、资源、对象或者变量赋予到一系列变量或变量数组中去。

语法： 无返回值 连续赋值 （用作赋于的值或资源，被赋值的变量或变量数组，… ）

参数名 | 描 述
用作赋于的值或资源 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。
被赋值的变量或变量数组 | 必需的；可扩充的；通用型，参数数据只能提供变量及变量数组。

例程

说明：

将指定的常数、常数集、常量、资源、对象或者变量分别赋予到一系列不同的变量或变量数组中去。

注：理论上第二个参数可以扩展无限个

参见：例程


数组操作

数组操作 类别 跳至：系统核心支持库


重定义数组 命令 所属类别：数组操作

本命令可以重新定义指定数组的维数及各维的上限值。

语法： 无返回值 重定义数组 （欲重定义的数组变量，是否保留以前的内容，数组对应维的上限值，… ）

参数名 | 描 述
欲重定义的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
是否保留以前的内容 | 必需的；逻辑型，初始值为“假”。
数组对应维的上限值 | 必需的；可扩充的；整数型。

例程：

说明：

重新定义数组的维数。

注：

如果需要保留以前内容需要在第2个参数中为“真”。

参见：例程


取数组成员数 命令 所属类别：数组操作

取指定数组变量的全部成员数目，如果该变量不为数组，返回-1，因此本命令也可以用作检查指定变量是否为数组变量。

语法： 整数型 取数组成员数 （欲检查的变量）

参数名 | 描 述
欲检查的变量 | 必需的；通用型，参数数据只能提供变量及变量数组。参数值指定欲检查其成员数目的数组变量或者欲检查其是否为数组的变量。

例程：

说明：

显示数组变量的当前成员的个数，

参见：例程


取数组下标 命令 所属类别：数组操作

返回指定数组维可用的最大下标（最小下标固定为1）。如果给定变量不为数组变量或指定维不存在，返回 0 。

语法： 整数型 取数组下标 （欲取某维最大下标的数组变量，［欲取其最大下标的维］）

参数名 | 描 述
欲取某维最大下标的数组变量 | 必需的；通用型，参数数据只能提供变量及变量数组。
欲取其最大下标的维 | 可选的；整数型。1 表示第一维，2 表示第二维，如此类推。如果省略本参数，默认值是 1。

例程：

说明：

显示数组第一维的可用下标。

参见：例程


复制数组 命令 所属类别：数组操作

将数组数据复制到指定的数组变量，该数组变量内的所有数据和数组维定义信息将被全部覆盖。

语法： 无返回值 复制数组 （复制到的数组变量，待复制的数组数据）

参数名 | 描 述
复制到的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
待复制的数组数据 | 必需的；通用型，参数数据只能提供数组数据。

例程:

说明：

将数组数据复制到指定的新数组中，该新数组内的所有数据和数组维定义信息将被全部覆盖。

参见：例程


加入成员 命令 所属类别：数组操作

将数据加入到指定数组变量的尾部，并通过重新定义数组维数自动增加其成员数目。数组变量如为多维数组，加入完毕后将被转换为单维数组。

语法： 无返回值 加入成员 （欲加入成员的数组变量，欲加入的成员数据）

参数名 | 描 述
欲加入成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
欲加入的成员数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值所指定成员数据的数据类型必须能够与第一个参数所指定的数组变量相匹配。

例程：

说明：

在数组变量里加入一个成员。成员加入在数组的最后面。

参见：例程


插入成员 命令 所属类别：数组操作

将数据插入到指定数组变量的指定位置，并通过重新定义数组维数自动增加其成员数目。数组变量如为多维数组，插入完毕后将被转换为单维数组。

语法： 无返回值 插入成员 （欲插入成员的数组变量，欲插入的位置，欲插入的成员数据）

参数名 | 描 述
欲插入成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
欲插入的位置 | 必需的；整数型。位置值从 1 开始，如果小于 1 或大于第一个参数所指定数组变量的成员数目 + 1，将不会插入任何数据。
欲插入的成员数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值所指定成员数据的数据类型必须能够与第一个参数所指定的数组变量相匹配。

例程：

说明：

将数据插入到指定数组的指定位置，并通过重新定义数组维数自动增加其成员数目。

数组变量如为多维数组，插入完毕后将被转换为单维数组。

在数组的第一个位置插入成员和它的值。

参见：例程


删除成员 命令 所属类别：数组操作

删除指定数组变量中的成员，并通过重新定义数组维数自动减少其成员数目。数组变量如为多维数组，删除完毕后将被转换为单维数组。返回所实际删除的成员数目。

语法： 整数型 删除成员 （欲删除成员的数组变量，欲删除的位置，［欲删除的成员数目］）

参数名 | 描 述
欲删除成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
欲删除的位置 | 必需的；整数型。位置值从 1 开始，如果小于 1 或大于第一个参数所指定数组变量的成员数目，将不会删除任何数据。
欲删除的成员数目 | 可选的；整数型。本参数如果被省略，默认为 1 。

例程：

说明：

删除数组里的成员。被删除成员以后的其它成员的位置依次向前进一位。

参见：例程


清除数组 命令 所属类别：数组操作

删除指定数组变量中的所有成员，释放这些成员所占用的存储空间，重新定义该变量为单维 0 成员数组变量。

语法： 无返回值 清除数组 （欲删除成员的数组变量）

参数名 | 描 述
欲删除成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。

例程：

说明：

删除所指定的数组变量内的所有成员。

执行成功后数组内的成员将全部被删除，数组的成员数变为0

参见：例程


数组排序 命令 所属类别：数组操作

对指定数值数组变量内的所有数组成员进行快速排序，不影响数组的维定义信息，排序结果存放回该数组变量。

语法： 无返回值 数组排序 （数值数组变量，［排序方向是否为从小到大］）

参数名 | 描 述
数值数组变量 | 必需的；通用型，参数数据只能提供变量数组。
排序方向是否为从小到大 | 可选的；逻辑型。如果参数值为真，排序方向为从小到大，否则为从大到小。如果本参数被省略，默认值为真。

例程

说明：

把数组按成员的数值大小排序，如果第2个参数是“真”，则按从小到大排序，否则反之.。

参见：例程


数组清零 命令 所属类别：数组操作

数组清零 命令 操作系统支持：Windows、Linux 所属类别：数组操作

将指定数值数组变量内的所有成员值全部设置为零，不影响数组的维定义信息。

语法： 无返回值 数组清零 （数值数组变量）

参数名 | 描 述
数值数组变量 | 必需的；通用型，参数数据只能提供变量数组。

例程：

说明：

把数组内所有成员的值设为0。只对数值型数组有效。

参见：例程


环境存取

环境存取 类别 跳至：系统核心支持库


拼音处理

拼音处理 类别 跳至：系统核心支持库


取命令行 命令 操作系统支持：Windows、Linux 所属类别：环境存取

本命令可以取出在启动易程序时附加在其可执行文件名后面的所有以空格分隔的命令行文本段。

语法： 无返回值 取命令行 （存放被取回命令行文本的数组变量）

参数名 | 描 述
存放被取回命令行文本的数组变量 | 必需的；文本型，参数数据只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入在启动易程序时附加在其可执行文件名后面的以空格分隔的命令行文本段。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为命令行文本段数。

例程

说明

通过“取命令行”命令程序启动时的附加参数，根据不同参数自动进入相应的操作窗口。

“取命令行”命令的最经典的例子就是易语言自带的实用程序“数据库管理器”。看一下易语言主菜单“数据库”下的三个子菜单项“结构编辑器”“记录编辑器”“设置数据库密码”，实际上调用的都是同一个程序（tools\dbmanger.exe），只是进入不同的窗口。

参考：例程1


读环境变量 命令 操作系统支持：Windows、Linux 所属类别：环境存取

返回文本，它关连于一个操作系统环境变量。成功时返回所取得的值，失败则返回空文本。

语法： 文本型 读环境变量 （环境变量名称）

参数名 | 描 述
环境变量名称 | 必需的；文本型。

例程

说明

通过“读环境变量”命令读取指定的环境变量。

参考：例程1


写环境变量 命令 操作系统支持：Windows、Linux 所属类别：环境存取

修改或建立指定的操作系统环境变量。成功返回真，失败返回假。

语法： 逻辑型 写环境变量 （环境变量名称，欲写入内容）

参数名 | 描 述
环境变量名称 | 必需的；文本型。
欲写入内容 | 必需的；文本型。

例程

说明

通过“写环境变量”命令更改已存在的环境变量。

参考：例程1


文本操作

文本操作 类别 跳至：系统核心支持库

取文本长度 | 取文本左边 | 取文本右边 | 取文本中间
字符 | 取代码 | 寻找文本 | 倒找文本
到大写 | 到小写 | 到全角 | 到半角
到文本 | 删首空 | 删尾空 | 删首尾空
删全部空 | 文本替换 | 子文本替换 | 取空白文本
取重复文本 | 文本比较 | 分割文本 | 指针到文本


取文本长度 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取文本型数据的长度，不包含结束0。

语法： 整数型 取文本长度 （文本数据）

参数名 | 描 述
文本数据 | 必需的；文本型。参数值指定欲检查其长度的文本数据。

例程

说明

通过“取文本长度”命令获取指定文本的长度。注意，一个汉字的长度为2。

例如：取文本长度 (“易语言eyuyan”) 的返回值为12（“易语言”三个字的长度为6）。

参考：例程1


取文本左边 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定文本中从左边算起指定数量的字符。

语法： 文本型 取文本左边 （欲取其部分的文本，欲取出字符的数目）

参数名 | 描 述
欲取其部分的文本 | 必需的；文本型。
欲取出字符的数目 | 必需的；整数型。

例程

说明

通过“取文本左边”命令获取一段文本从左边数起指定长度的文本。

参考：例程1


取文本右边 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定文本中从右边算起指定数量的字符。

语法： 文本型 取文本右边 （欲取其部分的文本，欲取出字符的数目）

参数名 | 描 述
欲取其部分的文本 | 必需的；文本型。
欲取出字符的数目 | 必需的；整数型。

例程

说明

通过“取文本右边”命令从右起取出2个字符。

参考：例程1


取文本中间 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定文本中从指定位置算起指定数量的字符。

语法： 文本型 取文本中间 （欲取其部分的文本，起始取出位置，欲取出字符的数目）

参数名 | 描 述
欲取其部分的文本 | 必需的；文本型。
起始取出位置 | 必需的；整数型。1为首位置，2为第2个位置，如此类推。
欲取出字符的数目 | 必需的；整数型。

例程

说明

通过“取文本中间”命令从一段文本中的指定位置起取出指定数量的字符。

参考：例程1


字符 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含有与指定字符代码相关的字符。

语法： 文本型 字符 （欲取其字符的字符代码）

参数名 | 描 述
欲取其字符的字符代码 | 必需的；字节型。

例程

说明

通过“字符”命令将键代码转换为字符。关于代码值请查阅ASCⅡ码。

例如：键代码65代表字符A。

参考：例程1


取代码 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回文本中指定位置处字符的代码。如果指定位置超出文本长度，返回0。

语法： 整数型 取代码 （欲取字符代码的文本，［欲取其代码的字符位置］）

参数名 | 描 述
欲取字符代码的文本 | 必需的；文本型。
欲取其代码的字符位置 | 可选的；整数型。1为首位置，2为第2个位置，如此类推。如果本参数被省略，默认为首位置。

例程

说明

通过“取代码”命令得到一段文本中第一个字符的代码。

参考：例程1


寻找文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个整数值，指定一文本在另一文本中最先出现的位置，位置值从 1 开始。如果未找到，返回-1。

语法： 整数型 寻找文本 （被搜寻的文本，欲寻找的文本，［起始搜寻位置］，是否不区分大小写）

参数名 | 描 述
被搜寻的文本 | 必需的；文本型。
欲寻找的文本 | 必需的；文本型。
起始搜寻位置 | 可选的；整数型。位置值从 1 开始。如果本参数被省略，默认为 1 。
是否不区分大小写 | 必需的；逻辑型，初始值为“假”。为真不区分大小写，为假区分。

例程

说明

通过“寻找文本”命令从一段文本中寻找指定文本的第一个出现位置。

参考：例程1


倒找文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个整数值，指定一文本在另一文本中最后出现的位置，位置值从 1 开始。如果未找到，返回-1。

语法： 整数型 倒找文本 （被搜寻的文本，欲寻找的文本，［起始搜寻位置］，是否不区分大小写）

参数名 | 描 述
被搜寻的文本 | 必需的；文本型。
欲寻找的文本 | 必需的；文本型。
起始搜寻位置 | 可选的；整数型。位置值从 1 开始。如果本参数被省略，默认为从被搜寻文本的尾部开始。
是否不区分大小写 | 必需的；逻辑型，初始值为“假”。为真不区分大小写，为假区分。

例程

说明

通过“倒找文本”命令从指定文本中的指定起始位置开始从右向左寻找指定文本在这段文本中的位置。

参考：例程1


到大写 命令 操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的小写英文字母变换为大写，返回变换后的结果文本。

语法： 文本型 到大写 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到大写”命令将一段小写字母文本转换为大写格式。

例如：“Abcde” 转换为大写格式后为“ABCDE”。

参考：例程1


到小写 命令 操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的大写英文字母变换为小写，返回变换后的结果文本。

语法： 文本型 到小写 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到小写”命令将一段文本全部转换为小写。

例如：

“到小写（”ABcd”）”将返回“abcd”；

“到小写（”ABcd易语言”）”将返回“abcd易语言”； 注：对汉字没有影响。

参考：例程1


到全角 命令 操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的半角字母、空格或数字变换为全角，返回变换后的结果文本。

语法： 文本型 到全角 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到全角”命令将指定文本转换为全角。

参考：例程1


到半角 命令 操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的全角字母、空格或数字变换为半角，返回变换后的结果文本。

语法： 文本型 到半角 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到半角”命令将一段全角文本转换为半角。

参考：例程1


到文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，代表指定数值、逻辑值或日期时间被转换后的结果。如果为文本数据，将被直接返回。

语法： 文本型 到文本 （待转换的数据）

参数名 | 描 述
待转换的数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值只能为数值、逻辑值、字节集、日期时间或数值型数组。

例程

说明

通过“到文本”命令将其他数据类型的数据转换为文本型。

参考：例程1


删首空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了首部全角或半角空格的指定文本。

语法： 文本型 删首空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删首空”命令将一段文本中文本前面的空格去掉。

参考：例程1


删尾空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了尾部全角或半角空格的指定文本。

语法： 文本型 删尾空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删尾空”命令将一段文本中文字后面所有空格删掉。

参考：例程1


删首尾空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了首部及尾部全角或半角空格的指定文本。

语法： 文本型 删首尾空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删首尾空”命令将一段文本中文字前和文字后的空格全部删除。

参考：例程1


删全部空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了所有全角或半角空格的指定文本。

语法： 文本型 删全部空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删全部空”命令将一段文本中的空格全部删除。

例如：“　　这里 既有全角　空格， 也有半角 空格。 ”

删除全部空格后的结果是：“这里既有全角空格，也有半角空格。”。

参考：例程1


文本替换 命令 操作系统支持：Windows、Linux 所属类别：文本操作

将指定文本的某一部分用其它的文本替换。

语法： 文本型 文本替换 （欲被替换的文本，起始替换位置，替换长度，［用作替换的文本］）

参数名 | 描 述
欲被替换的文本 | 必需的；文本型。
起始替换位置 | 必需的；整数型。替换的起始位置，1为首位置，2为第2个位置，如此类推。
替换长度 | 必需的；整数型。
用作替换的文本 | 可选的；文本型。如果本参数被省略，则删除文本中的指定部分。

例程

说明

通过“文本替换”命令将输入文本的字符（从第2个字符起取2个字符）替换为“000000”。

注意一个汉字要算作两个字符。

参考：例程1


子文本替换 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，该文本中指定的子文本已被替换成另一子文本，并且替换发生的次数也是被指定的。

语法： 文本型 子文本替换 （欲被替换的文本，欲被替换的子文本，［用作替换的子文本］，［进行替换的起始位置］，［替换进行的次数］，是否区分大小写）

参数名 | 描 述
欲被替换的文本 | 必需的；文本型。
欲被替换的子文本 | 必需的；文本型。
用作替换的子文本 | 可选的；文本型。如果本参数被省略，默认为空文本。
进行替换的起始位置 | 可选的；整数型。参数值指定被替换子文本的起始搜索位置。如果省略，默认从 1 开始。
替换进行的次数 | 可选的；整数型。参数值指定对子文本进行替换的次数。如果省略，默认进行所有可能的替换。
是否区分大小写 | 必需的；逻辑型，初始值为“真”。为真区分大小写，为假不区分。

例程

说明

用“999”替换文本中所有的“aa”。

参考：例程1


取空白文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回具有指定数目半角空格的文本。

语法： 文本型 取空白文本 （重复次数）

参数名 | 描 述
重复次数 | 必需的；整数型。

例程

说明

通过“取空白文本”命令获取指定数目的空白文本（空格）。

参考：例程1


取重复文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定次数的文本重复结果。

语法： 文本型 取重复文本 （重复次数，待重复文本）

参数名 | 描 述
重复次数 | 必需的；整数型。
待重复文本 | 必需的；文本型。该文本将用于建立返回的文本。如果为空，将返回一个空文本。

例程

说明

通过“取重复文本”命令取得指定数量相同内容的文本。

例如：“取重复文本（3，”A”）”将返回“AAA”；

“取重复文本（2，”Abc”）”将返回“AbcAbc”。

参考：例程1


文本比较 命令 操作系统支持：Windows、Linux 所属类别：文本操作

如果返回值小于0，表示文本一小于文本二；如果等于0，表示文本一等于文本二；如果大于0，表示文本一大于文本二。如果比较时区分大小写，也可以使用比较运算符进行同样的操作。

语法： 整数型 文本比较 （待比较文本一，待比较文本二，是否区分大小写）

参数名 | 描 述
待比较文本一 | 必需的；文本型。
待比较文本二 | 必需的；文本型。
是否区分大小写 | 必需的；逻辑型，初始值为“真”。为真区分大小写，为假不区分。

例程

说明

通过“文本比较”命令比较两个文本ASCII码值大小。

参考：例程1


分割文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

将指定文本进行分割，返回分割后的一维文本数组。

语法： 文本型数组 分割文本 （待分割文本，［用作分割的文本］，［要返回的子文本数目］）

参数名 | 描 述
待分割文本 | 必需的；文本型。如果参数值是一个长度为零的文本，则返回一个空数组，即没有任何成员的数组。
用作分割的文本 | 可选的；文本型。参数值用于标识子文本边界。如果被省略，则默认使用半角逗号字符作为分隔符。如果是一个长度为零的文本，则返回的数组仅包含一个成员，即完整的“待分割文本”。
要返回的子文本数目 | 可选的；整数型。如果被省略，则默认返回所有的子文本。

例程

说明

通过“分割文本”命令将一段文本通过指定文本分割。

参考：例程1


指针到文本 命令 操作系统支持：Windows 所属类别：文本操作

指针到文本 命令 　英文命令：pstr　操作系统支持：Windows 所属类别：文本操作

为高级用户提供，初级用户无需掌握；
返回指定内存指针所指向地址处的文本，注意调用本命令前一定要确保所提供的内存指针真实有效，且指向一个以零字符结束的文本串。本命令的最佳使用场合就是在易语言回调子程序和易语言DLL公开子程序用作获取外部数据。

语法： 文本型 指针到文本 （内存文本指针）

参数名 | 描 述
内存文本指针 | 必需的；整数型。本参数提供指向一个以零字符结束的文本串内存指针值。

例程

说明

在动态链接库（DLL）内部的子程序中，通过“指针到文本”读取指针（此处为变量“欲取的拼音”）所指向的文本。

注：标准DLL是不能直接传递文本数据的，需借助于“指针”。

参考：例程1 例程2


字节集操作

字节集操作 类别 跳至：系统核心支持库

取字节集长度 | 到字节集 | 取字节集数据 | 取字节集左边
取字节集右边 | 取字节集中间 | 寻找字节集 | 倒找字节集
字节集替换 | 子字节集替换 | 取空白字节集 | 取重复字节集
分割字节集 | 指针到字节集 |  |


取字节集长度 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取字节集型数据的长度。

语法： 整数型 取字节集长度 （字节集数据）

参数名 | 描 述
字节集数据 | 必需的；字节集。参数值指定欲检查其长度的字节集数据。

例程

说明

获取字节集{25，3454，564，3}的长度。

参考：例程1


到字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

将指定数据转换为字节集后返回转换结果。

语法： 字节集 到字节集 （欲转换为字节集的数据）

参数名 | 描 述
欲转换为字节集的数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值只能为基本数据类型数据或数值型数组。

例程

说明

通过“到字节集命令”将其他数据类型转换为字节集类型。

参考：例程1


取出字节集中指定位置指定数据类型的数据

取字节集数据 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取出字节集中指定位置指定数据类型的数据。

语法： 通用型 取字节集数据 （欲取出其中数据的字节集， 欲取出数据的类型， ［起始索引位置］）

参数名 | 描 述
欲取出其中数据的字节集 | 必需的； 字节集。
欲取出数据的类型 | 必需的； 整数型。参数值可以为以下常量： 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型； 9、#子程序指针型； 10、#文本型。转换后的数据将自动进行有效性校验及转换处理。
起始索引位置 | 可选的； 整数型。指定从字节集的什么地方开始取数据，索引值从1开始。如果被省略，默认为数值1。如果为本参数提供一个整数型变量，则命令执行后将自动修改该变量内容，将其索引值移动到下一个读入位置。如果移动后到达字节集的末尾，将修改该变量的内容为-1。

例程

说明

取出字节集中指定位置指定数据类型的数据。

参考：例程1


取字节集左边 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定字节集中从左边算起指定数量的字节。

语法： 字节集 取字节集左边 （欲取其部分的字节集，欲取出字节的数目）

参数名 | 描 述
欲取其部分的字节集 | 必需的；字节集。
欲取出字节的数目 | 必需的；整数型。

例程

说明

通过“取字节集左边”命令从指定字节集中左起取得指定字节大小的字节集。

参考：例程1


取字节集右边 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定字节集中从右边算起指定数量的字节。

语法： 字节集 取字节集右边 （欲取其部分的字节集，欲取出字节的数目）

参数名 | 描 述
欲取其部分的字节集 | 必需的；字节集。
欲取出字节的数目 | 必需的；整数型。

例程

说明

通过“取字节集右边”命令，从指定字节集中右起取出指定字节长度的字节集。

参考：例程1


取字节集中间 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定字节集中从指定位置算起指定数量的字节。

语法： 字节集 取字节集中间 （欲取其部分的字节集，起始取出位置，欲取出字节的数目）

参数名 | 描 述
欲取其部分的字节集 | 必需的；字节集。
起始取出位置 | 必需的；整数型。1为首位置，2为第2个位置，如此类推。
欲取出字节的数目 | 必需的；整数型。

例程

说明

通过“取字节集中间”命令，从指定字节集中指定位置起取出指定字节大小的字节集。

参考：例程1


寻找字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一字节集在另一字节集中最先出现的位置，位置值从 1 开始。如果未找到，返回 -1。

语法： 整数型 寻找字节集 （被搜寻的字节集，欲寻找的字节集）

参数名 | 描 述
被搜寻的字节集 | 必需的；字节集。
欲寻找的字节集 | 必需的；字节集。
起始搜寻位置 | 可选的；整数型。1为首位置，2为第2个位置，如此类推，如果被省略，则“寻找字节集”命令默认从首部开始，“倒找字节集”命令默认从尾部开始。

例程

说明

通过“寻找字节集”命令在指定字节集中寻找符合条件的字节集。

参考：例程1


倒找字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一字节集在另一字节集中最后出现的位置，位置值从 1 开始。如果未找到，返回 -1。

语法： 整数型 倒找字节集 （被搜寻的字节集，欲寻找的字节集）

参数名 | 描 述
被搜寻的字节集 | 必需的；字节集。
欲寻找的字节集 | 必需的；字节集。
起始搜寻位置 | 可选的；整数型。1为首位置，2为第2个位置，如此类推，如果被省略，则“寻找字节集”命令默认从首部开始，“倒找字节集”命令默认从尾部开始。

例程

说明

通过“倒找字节集”命令从指定字节集中由右向左寻找指定字节集。

参考：例程1


字节集替换 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

将指定字节集的某一部分用其它的字节集替换，然后返回替换后的结果。

语法： 字节集 字节集替换 （欲替换其部分的字节集，起始替换位置，替换长度，［用作替换的字节集］）

参数名 | 描 述
欲替换其部分的字节集 | 必需的；字节集。
起始替换位置 | 必需的；整数型。替换的起始位置，1为首位置，2为第2个位置，如此类推。
替换长度 | 必需的；整数型。
用作替换的字节集 | 可选的；字节集。如果本参数被省略，则删除字节集中的指定部分。

例程

说明

通过“字节集替换”命令将指定字节集中指定起始位置指定长度的字节集替换。

参考：例程1


子字节集替换 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，该字节集中指定的子字节集已被替换成另一子字节集，并且替换发生的次数也是被指定的。

语法： 字节集 子字节集替换 （欲被替换的字节集，欲被替换的子字节集，［用作替换的子字节集］，［进行替换的起始位置］，［替换进行的次数］）

参数名 | 描 述
欲被替换的字节集 | 必需的；字节集。
欲被替换的子字节集 | 必需的；字节集。
用作替换的子字节集 | 可选的；字节集。如果省略本参数，则默认为空字节集。
进行替换的起始位置 | 可选的；整数型。被替换子字节集的起始搜索位置。如果省略，默认从1开始。
替换进行的次数 | 可选的；整数型。对子字节集进行替换的次数。如果省略，默认进行所有可能的替换。

例程

说明

通过“子字节集替换”命令将指定字节集中的字节集替换。

参考：例程1


取空白字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回具有特定数目 0 字节的字节集。

语法： 字节集 取空白字节集 （零字节数目）

参数名 | 描 述
零字节数目 | 必需的；整数型。

例程

说明

通过“取空白字节集”命令获得指定长度的空字节集。

参考：例程1


取重复字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定次数的字节集重复结果。

语法： 字节集 取重复字节集 （重复次数，待重复的字节集）

参数名 | 描 述
重复次数 | 必需的；整数型。
待重复的字节集 | 必需的；字节集。该字节集将用于建立返回的字节集。如果为空，将返回一个空字节集。

例程

说明

通过“取重复字节集”命令获取指定数量的相同字节集。

参考：例程1


分割字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

将指定字节集进行分割，返回分割后的一维字节集数组。

语法： 字节集数组 分割字节集 （待分割字节集，［用作分割的字节集］，［要返回的子字节集数目］）

参数名 | 描 述
待分割字节集 | 必需的；字节集。如果参数值是一个长度为零的字节集，则返回一个空数组，即没有任何成员的数组。
用作分割的字节集 | 可选的；字节集。用于标识子字节集边界。本参数如果被省略，则默认使用字节 0 作为分隔符。
要返回的子字节集数目 | 可选的；整数型。如果被省略，则默认返回所有的子字节集。

例程

说明

通过“分割字节集”命令将指定字节集按一定的标准字节集分割。

参考：例程1


指针到字节集 命令 操作系统支持：Windows 所属类别：字节集操作

指针到字节集 命令 　英文命令：pbin　操作系统支持：Windows 所属类别：字节集操作

为高级用户提供，初级用户无需掌握；
返回指定内存指针所指向地址处的一段数据，注意调用本命令前一定要确保所提供的内存地址段真实有效。本命令的最佳使用场合就是在易语言回调子程序和易语言DLL公开子程序用作获取外部数据。

语法： 字节集 指针到字节集 （内存数据指针，内存数据长度）

参数名 | 描 述
内存数据指针 | 必需的；整数型。本参数提供指向一个内存地址的指针值。
内存数据长度 | 必需的；整数型。本参数提供该内存地址处所需获取的数据长度。

例程

说明

在动态链接库（DLL）内部的子程序中，通过“指针到字节集”命令获取指针（此处为“图标”变量）所指向的字节集。

注：标准DLL是不能直接传递字节集数据的，需借助于“指针”。

参考：例程1


数值转换

数值转换 类别 跳至：系统核心支持库


到数值 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为双精度小数。

语法： 双精度小数型 到数值 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的；通用型。

例程

说明

如果有其它非数值型数据，将转换失败。

参考：例程1


数值到大写 命令 操作系统支持：Windows、Linux 所属类别：数值转换

将数值转换为简体或繁体的大写形式，返回转换后的文本。

语法： 文本型 数值到大写 （欲转换形式的数值，是否转换为简体）

参数名 | 描 述
欲转换形式的数值 | 必需的；双精度小数型。
是否转换为简体 | 必需的；逻辑型，初始值为“假”。如果参数值为假，则转换为繁体。

例程

说明

通过“数值到大写”命令将数值型数据转换为中文数字（大写）。

参考：例程1


数值到金额 命令 操作系统支持：Windows、Linux 所属类别：数值转换

将数值转换为金额的简体或繁体大写形式，返回转换后的文本。

语法： 文本型 数值到金额 （欲转换形式的数值，是否转换为简体）

参数名 | 描 述
欲转换形式的数值 | 必需的；双精度小数型。
是否转换为简体 | 必需的；逻辑型，初始值为“假”。如果参数值为假，则转换为繁体。

例程

说明

通过“数值到金额”命令将数值转换为货币格式。

参考：例程1


数值到格式文本 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回一个文本，代表指定数值被格式转换后的结果。

语法： 文本型 数值到格式文本 （欲转换为文本的数值，［小数保留位数］，是否进行千分位分隔）

参数名 | 描 述
欲转换为文本的数值 | 必需的；双精度小数型。
小数保留位数 | 可选的；整数型。如果大于0，表示小数点右边应四舍五入保留的位数；如果等于0，表示舍入到整数；如果小于0，表示小数点左边舍入到的位置。例如：数值到格式文本 (1056.65, 1, 假) 返回 “1056.7”； 数值到格式文本 (1056.65, 0, 假) 返回 “1056”； 数值到格式文本 (1056.65, -1, 假) 返回 “1060”。如果省略本参数，则默认为保留所有实际存在的小数位。
是否进行千分位分隔 | 必需的；逻辑型，初始值为“假”。如果参数值为真，数值文本的每个千分位上都将被自动插入一个逗号进行分隔。

例程

说明

通过“数值到格式文本”命令将数值转换为指定格式的文本。

参考：例程1


取十六进制文本 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回一个文本，代表指定数值的十六进制形式。

语法： 文本型 取十六进制文本 （欲取进制文本的数值）

参数名 | 描 述
欲取进制文本的数值 | 必需的；整数型。

例程

说明

通过“取十六进制文本”命令将一个十进制数值转换为十六进制文本。

参考：例程1


取八进制文本 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回一个文本，代表指定数值的八进制形式。

语法： 文本型 取八进制文本 （欲取进制文本的数值）

参数名 | 描 述
欲取进制文本的数值 | 必需的；整数型。

例程

说明

通过“取八进制文本”命令将一个十进制数值转换为八进制文本。

参考：例程1


到字节

到字节 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的字节值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为字节。

语法： 字节型 到字节 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为字节。

参见：例程1


到短整数

到短整数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的短整数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为短整数。

语法： 短整数型 到短整数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为短整数。

参见：例程1


到整数

到整数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的整数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为整数。

语法： 整数型 到整数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为整数。

参见：例程1


到长整数

到长整数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的长整数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为长整数。

语法： 长整数型 到长整数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为长整数。

参见：例程1


到小数

到小数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的小数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为小数。

语法： 小数型 到小数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为小数。

参见：例程1


时间操作

时间操作 类别 跳至：系统核心支持库

到时间 | 增减时间 | 取时间间隔 | 取某月天数
时间到文本 | 取时间部分 | 取年份 | 取月份
取日 | 取星期几 | 取小时 | 取分钟
取秒 | 指定时间 | 取现行时间 | 取日期
取时间 |  |


到时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

将指定文本转换为时间并返回。如果给定文本不符合书写格式要求或者时间值错误导致不能进行转换，将返回100年1月1日。如果给定参数本身就是时间数据，将直接返回该时间。

语法： 日期时间型 到时间 （欲转换的文本）

参数名 | 描 述
欲转换的文本 | 必需的；通用型。文本内容应按以下格式之一提供，年份后的时间部分可以省略： 1、1973年11月15日12时30分25秒 2、1973/11/15 12:30:25 3、1973/11/15/12/30/25 4、1973/11/15/12:30:25 5、1973-11-15-12-30-25 6、1973-11-15-12:30:25 7、19731115123025

例程：

说明：

将输入的时间值转换为标准的时间格式。

参见：例程1


增减时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个时间，这一时间被加上或减去了一段间隔。如果改变后的时间无效，将自动靠近最近的有效时间。

语法： 日期时间型 增减时间 （时间，被增加部分，增加值）

参数名 | 描 述
时间 | 必需的；日期时间型。
被增加部分 | 必需的；整数型。参数值指定增加或减少时间的哪一部分，可以为以下常量： 1、#年份； 2、#季度； 3、#月份； 4、#周； 5、#日； 6、#小时； 7、#分钟； 8、#秒。
增加值 | 必需的；整数型。相对于被增加部分的增加或减少数值。

例程

说明

将现行时间增加10年。

参见：例程1


取时间间隔 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个数值，表示“时间1”减去“时间2”之后的间隔数目。注意：每个星期以星期天为第一天。

语法： 双精度小数型 取时间间隔 （时间1，时间2，取间隔部分）

参数名 | 描 述
时间1 | 必需的；日期时间型。
时间2 | 必需的；日期时间型。
取间隔部分 | 必需的；整数型。参数值指定取时间间隔的单位，可以为以下常量： 1、#年份； 2、#季度； 3、#月份； 4、#周； 5、#日； 6、#小时； 7、#分钟； 8、#秒。

例程：

说明：

计算从出生到现在的年份。

参见：例程1


取某月天数 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回指定月份所包含的天数。如果给定的月份无效，返回0。

语法： 整数型 取某月天数 （年份，月份）

参数名 | 描 述
年份 | 必需的；整数型。参数值从 100 到 9999。
月份 | 必需的；整数型。参数值从 1 到 12。

例程

说明

取出所指定的年度月份有多少天。

参见：例程1


时间到文本 命令 操作系统支持：Windows、Linux 所属类别：时间操作

将指定时间转换为文本并返回。

语法： 文本型 时间到文本 （欲转换到文本的时间，［转换部分］）

参数名 | 描 述
欲转换到文本的时间 | 必需的；日期时间型。
转换部分 | 可选的；整数型。参数值可以为以下常量： 1、#全部转换； 2、#日期部分； 3、#时间部分。如果省略了本参数，默认为“#全部转换”。

例程

说明

用“时间到文本”命令，将指定时间的日期部分转换成文本数据。

参见：例程1


取时间部分 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个包含已知时间指定部分的整数。

语法： 整数型 取时间部分 （欲取其部分的时间，欲取的时间部分）

参数名 | 描 述
欲取其部分的时间 | 必需的；日期时间型。
欲取的时间部分 | 必需的；整数型。参数值可以为以下常量： 1、#年份； 2、#季度； 3、#月份； 4、#自年首周数； 5、#日； 6、#小时； 7、#分钟； 8、#秒； 9、#星期几； 10、#自年首天数。其中：自年首周数、自年首天数均从 1 开始。

例程

说明

取得当前是哪一年。

参见：例程1


取年份 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 100 到 9999 之间的整数，表示指定时间中的年份。

语法： 整数型 取年份 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取得当前的年份。

参见：例程1


取月份 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 1 到 12 之间的整数，表示指定时间中的月份。

语法： 整数型 取月份 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取得当前的月份。

参见：例程1


取日 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 1 到 31 之间的整数，表示一个月中的某一日。

语法： 整数型 取日 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取得当前的日期。

参见：例程1


取星期几 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 1 到 7 之间的整数，表示一个星期中的某一日。星期日为 1，星期一为 2，依此类推。

语法： 整数型 取星期几 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取得今天是星期几。

参见：例程1


取小时 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 0 到 23 之间的整数，表示一天中的某一小时。

语法： 整数型 取小时 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

将当前时间的“小时”部分取出来。

参见：例程1


取分钟 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 0 到 59 之间的整数，表示一小时中的某一分钟。

语法： 整数型 取分钟 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取得现在时间中的分钟数。

参见：例程1


取秒 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 0 到 59 之间的整数，表示一分钟中的某一秒。

语法： 整数型 取秒 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

将现行时间的“秒”部分取出。

参见：例程1


指定时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回包含指定年、月、日、小时、分、秒的时间。如果指定了无效时间，将自动使用最相近的有效时间代替。

语法： 日期时间型 指定时间 （年，［月］，［日］，［小时］，［分钟］，［秒］）

参数名 | 描 述
年 | 必需的；整数型。
月 | 可选的；整数型。如果本参数被省略，默认为 1 月。
日 | 可选的；整数型。如果本参数被省略，默认为 1 日。
小时 | 可选的；整数型。如果本参数被省略，默认为 0 时。
分钟 | 可选的；整数型。如果本参数被省略，默认为 0 分钟。
秒 | 可选的；整数型。如果本参数被省略，默认为 0 秒。

  例程

说明

设置新的时间

参见：例程1


取现行时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回当前系统日期及时间。

语法： 日期时间型 取现行时间 （）

例程

说明

取得现在系统的时间。

参见：例程1


取日期 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个日期时间型数据的日期部分，其小时、分钟、秒被固定设置为0时0分0秒。

语法： 日期时间型 取日期 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取出现行时间中的日期部分。

参见：例程1


取时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

返回一个日期时间型数据的时间部分，其年、月、日被固定设置为2000年1月1日。

语法： 日期时间型 取时间 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

用“取时间”命令取出“取现行时间”命令返回的现行时间的时、分、秒部分。

参见：例程1


磁盘操作

磁盘操作 类别 跳至：系统核心支持库

改变目录 | 取当前目录 | 创建目录 | 删除目录
复制文件 | 移动文件 | 删除文件 | 文件更名
文件是否存在 | 取文件时间 | 取文件尺寸 | 读入文件
写到文件 |  |  |


改变目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

改变当前的目录，但不会改变缺省驱动器位置。成功返回真，失败返回假。

语法： 逻辑型 改变目录 （欲改变到的目录）

参数名 | 描 述
欲改变到的目录 | 必需的；文本型。参数值指明哪个目录将成为新的缺省目录，可能会包含驱动器。如果没有指定驱动器，则在当前的驱动器上改变缺省目录。

例程

说明

改变当前目录。

参见 例程1


取当前目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

返回一个文本，用来代表当前的目录。如果失败，返回空文本。

语法： 文本型 取当前目录 （）

例程

说明

显示出系统的当前目录。系统的当前目录是可变的，可以使用“改变目录”命令改变（参见：改变目录）。

参见 例程1


创建目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

创建一个新的目录。成功返回真，失败返回假。

语法： 逻辑型 创建目录 （欲创建的目录名称）

参数名 | 描 述
欲创建的目录名称 | 必需的；文本型。

例程

说明

创建新的目录。要注意的是，该命令只能创建所有父目录都存在的文件夹，如果其中有一级子目录不存在将会创建失败。

参见 例程1


删除目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

删除一个存在的目录。成功返回真，失败返回假。

语法： 逻辑型 删除目录 （欲删除的目录名称）

参数名 | 描 述
欲删除的目录名称 | 必需的；文本型。该目录应实际存在，如果目录中存在文件或子目录，将被一并删除，因此使用本命令请千万慎重。

例程

说明

删除指定的目录。该目录下的所有文件和目录都将被删除，请慎用。

参见 例程1


复制文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

成功返回真，失败返回假。

语法： 逻辑型 复制文件 （被复制的文件名，复制到的文件名）

参数名 | 描 述
被复制的文件名 | 必需的；文本型。
复制到的文件名 | 必需的；文本型。

例程

说明

该命令的两个参数都必须是全路径文件名。

参见 例程1


移动文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

将文件从一个位置移动到另外一个位置。成功返回真，失败返回假。

语法： 逻辑型 移动文件 （被移动的文件，移动到的位置）

参数名 | 描 述
被移动的文件 | 必需的；文本型。
移动到的位置 | 必需的；文本型。

例程

说明

本命令只是路径改变，文件名没变。两个参数都必须是全路径文件名。

参见 例程1


删除文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

成功返回真，失败返回假。

语法： 逻辑型 删除文件 （欲删除的文件名）

参数名 | 描 述
欲删除的文件名 | 必需的；文本型。

例程

说明

删除指定的文件。

参见 例程1


文件更名 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

重新命名一个文件或目录。成功返回真，失败返回假。

语法： 逻辑型 文件更名 （欲更名的原文件或目录名，欲更改为的现文件或目录名）

参数名 | 描 述
欲更名的原文件或目录名 | 必需的；文本型。
欲更改为的现文件或目录名 | 必需的；文本型。

例程

说明

该命令如果给目标文件名与原文件名相同的路径，会将原文件更名，如果是不同的目录，则命令会复制并更名原文件。

参见 例程1


文件是否存在 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

判断指定的磁盘文件是否真实存在。如存在返回真，否则返回假。

语法： 逻辑型 文件是否存在 （欲测试的文件名称）

参数名 | 描 述
欲测试的文件名称 | 必需的；文本型。

例程

说明

判断文件是否存在。

参见 例程1


取文件时间 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

返回指定文件被创建或最后修改后的日期和时间。如果该文件不存在，将返回100年1月1日。

语法： 日期时间型 取文件时间 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

奔命令用来取得文件被修改的时间。

参见 例程1


取文件尺寸 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

返回一个文件的长度，单位是字节。如果该文件不存在，将返回 -1。

语法： 整数型 取文件尺寸 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

取得文件的大小。

参见 例程1


读入文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

返回一个字节集，其中包含指定文件的所有数据。

语法： 字节集 读入文件 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

将指定的文件读入到变量中以便调用，读入后的文件和原文件不发生关系，该变量的一切修改对原文件不会有任何影响。

参见 例程1


写到文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

本命令用作将一个或数个字节集顺序写到指定文件中，文件原有内容被覆盖。成功返回真，失败返回假。

语法： 逻辑型 写到文件 （文件名，欲写入文件的数据，… ）

参数名 | 描 述
文件名 | 必需的；文本型。
欲写入文件的数据 | 必需的；可扩充的；字节集。

例程

说明

将内容写到指定的文件，如果文件存在，原文件中内容将被覆盖。

参见 例程1


文件读写

文件读写 类别 跳至：系统核心支持库

打开文件 | 关闭文件 | 关闭所有文件 | 移动读写位置
移到文件首 | 移到文件尾 | 读入字节集 | 写出字节集
读入文本 | 写出文本 | 读入一行 | 写文本行
读入数据 | 写出数据 | 是否在文件尾 | 取读写位置
取文件长度 | 插入字节集 | 插入文本 | 插入文本行
删除数据 |  |  |


打开文件 命令 操作系统支持：Windows、Linux 所属类别：文件读写

打开一个普通文件，以对文件进行输入或输出。成功返回被打开文件的文件号，失败返回 0。

语法： 整数型 打开文件 （欲打开的文件名称，［打开方式］，［共享方式］）

参数名 | 描 述
欲打开的文件名称 | 必需的；文本型。
打开方式 | 可选的；整数型。参数值说明对文件的操作方式，如果省略本参数，默认为“#读写”。方式值可以为以下常量之一： 1、#读入：从指定文件读入数据，如果该文件不存在则失败； 2、#写出：写出数据到指定文件，如果该文件不存在则失败； 3、#读写：从文件中读入数据或者写出数据到文件，如果该文件不存在则失败； 4、#重写：写出数据到指定文件。如果该文件不存在则先创建一个新文件，如果已经存在就先清除其中的所有数据； 5、#改写：写出数据到指定文件。如果该文件不存在则创建一个新文件，如果已经存在就直接打开； 6、#改读：从文件中读入数据或者写出数据到文件。如果该文件不存在则创建一个新文件，如果已经存在就直接打开。
共享方式 | 可选的；整数型。参数值指定限制其它进程操作此文件的方式。如果省略本参数，默认为“#无限制”。方式值可以为以下常量之一： 1、#无限制：允许其它进程任意读写此文件； 2、#禁止读：禁止其它进程读此文件； 3、#禁止写：禁止其它进程写此文件； 4、#禁止读写：禁止其它进程读写此文件。

例程

说明

打开一个文件，如果该文件不存在将创建它。

“打开文件”命令返回的文件号，是很多文件读写类命令需要使用到的。

参见：例程


关闭文件 命令 操作系统支持：Windows、Linux 所属类别：文件读写

关闭用各种打开命令打开的文件关闭被打开的各种类型文件。

语法： 无返回值 关闭文件 （欲关闭的文件号）

参数名 | 描 述
欲关闭的文件号 | 必需的；整数型。参数值指明欲关闭的文件号，该文件号由“打开文件”命令所返回。

例程

说明

使用“打开文件”命令打开一个文件后，可以使用“关闭文件”命令关闭这个文件。在一个文件不需要再进行任何操作的时候最好关闭它。

参见：例程


关闭所有文件 命令 操作系统支持：Windows、Linux 所属类别：文件读写

关闭所有现行被打开的文件。

语法： 无返回值 关闭所有文件 （）

例程

说明

打开多个文件后，可以使用“关闭所有文件”命令，将当前已经打开的所有文件都关闭。可以在程序关闭前，使用该命令将程序运行过程中打开的文件都进行关闭。

参见：例程


移动读写位置 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

在被打开的文件中，设置下一个读或写操作的位置。成功返回真，失败返回假。

语法： 逻辑型 移动读写位置 （欲进行操作的文件号，［起始移动位置］，移动距离）

参数名 | 描 述
欲进行操作的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
起始移动位置 | 可选的；整数型。参数值指定从文件中开始移动的位置。可以为以下常量之一：1、#文件首； 2、#文件尾； 3、#现行位置。如果本参数被省略，默认值为“#文件首”。
移动距离 | 必需的；整数型。参数值指定相对于起始移动位置的移动长度。

例程

说明

打开一个文本文件，移动其读写位置。

参见：例程


移到文件首 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

在被打开的文件中，设置下一个读或写操作的位置到文件首。成功返回真，失败返回假。

语法： 逻辑型 移到文件首 （欲进行操作的文件号）

参数名 | 描 述
欲进行操作的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。

例程

说明

使用“移到文件首”命令将当前读写位置移动到文件首部。

参见：例程


移到文件尾 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

在被打开的文件中，设置下一个读或写操作的位置到文件尾。成功返回真，失败返回假。

语法： 逻辑型 移到文件尾 （欲进行操作的文件号）

参数名 | 描 述
欲进行操作的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。

例程

说明

使用“移到文件尾”命令将当前读写位置移动到文件尾部。

参见：例程


读入字节集 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作从文件中当前读写位置读取并返回一段字节集数据，实际读入长度（即返回的字节集的尺寸）可能会小于欲读入长度。如果读入失败，将返回一个空字节集并且自动将当前文件读写位置移到文件尾部。

语法： 字节集 读入字节集 （欲读入数据的文件号，欲读入数据的长度）

参数名 | 描 述
欲读入数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲读入数据的长度 | 必需的；整数型。

例程

说明

读入文件的部分内容。数据以字节集类型返回。

参见：例程


写出字节集 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作写出一段或数段字节集数据到文件中当前读写位置处。成功返回真，失败返回假。

语法： 逻辑型 写出字节集 （欲写出数据的文件号，欲写出的字节集数据，… ）

参数名 | 描 述
欲写出数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的字节集数据 | 必需的；可扩充的；字节集。

例程

说明

将一段字节集内容写到文件中。

参见：例程


读入文本 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作从文件中当前读写位置读取并返回一段文本数据，实际读入长度（即返回文本的尺寸）可能会小于欲读入长度。如果该数据中存在字节 0 或 26（文本结束标志），将仅返回该字节之前的数据。如果读入失败，将返回一个空文本并且自动将当前文件读写位置移到文件尾部。

语法： 文本型 读入文本 （欲读入文本数据的文件号，［欲读入文本数据的长度］）

参数名 | 描 述
欲读入文本数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲读入文本数据的长度 | 可选的；整数型。如果本参数被省略，默认读入文件中的所有文本数据。

例程

说明

使用“打开文件”命令打开一个文本文件，并用“读入文本”命令将该文件显示出来。

参见：例程


写出文本 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作写出一段或数段文本数据到文件中当前读写位置处。成功返回真，失败返回假。

语法： 逻辑型 写出文本 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

打开一个文本文件，，然后使用“写出文本”命令，在当前读写位置写出一段文本。

参见：例程


读入一行 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作从文件中当前读写位置读取并返回一行文本数据，行末的回车及换行符将被抛弃。如果读入失败，将返回一个空文本并且自动将当前文件读写位置移到文件尾部。

语法： 文本型 读入一行 （欲读入文本数据的文件号）

参数名 | 描 述
欲读入文本数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。

例程

说明

打开一个文本文件，将该文本文件的第一行读入。

参见：例程


写文本行 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作写出一行或多行文本数据到文件中当前读写位置处，每行的尾部将被自动加上回车及换行符。成功返回真，失败返回假。

语法： 逻辑型 写文本行 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

打开一个文本文件并写入一行文本。

参见：例程


读入数据 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令应该与“写出”命令配合使用，用作从文件中当前读写位置读取格式数据到指定的一系列变量或数组变量中。成功返回真，失败返回假。

语法： 逻辑型 读入数据 （欲读入数据的文件号，存放所读入数据的变量，… ）

参数名 | 描 述
欲读入数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
存放所读入数据的变量 | 必需的；可扩充的；通用型，参数数据只能提供变量及变量数组。如果变量的数据类型为用户自定义或库定义数据类型，命令将会失败。

例程

说明

打开一个文本文件，并用“读入数据”命令读入该文本文件的数据，存放到数据变量中。该命令可以读入通用型的数据，会将数据自动进行转换，例如读入字节集型数据，给一个文本变量存放，则命令会自动将字节集数据转换成文本型后进行存放。

参见：例程


写出数据 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令应该与“读入”命令配合使用，用作写出一系列变量或数组变量的格式数据到文件中当前读写位置处。成功返回真，失败返回假。具体各种数据类型数据的写出格式为： 1、数值型、逻辑型、日期时间型、子程序指针型： 为其所对应的实际数据； 2、文本型：为文本数据 + 字节 0 ； 3、字节集型： 为字节集数据长度（整数） + 字节集实际数据； 4、以上各种数据类型的数组型数据： 为非数组情况下数据格式的顺序排列。

语法： 逻辑型 写出数据 （欲写出数据的文件号，欲写出的数据，… ）

参数名 | 描 述
欲写出数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的数据 | 必需的；可扩充的；通用型，参数数据可以同时提供数组或非数组数据。如果被写出数据的数据类型为用户自定义或库定义数据类型，命令将会失败。

例程

说明

打开一个文本文件并将数据写到文件中。

参见：例程


是否在文件尾 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

如果指定被打开文件的读写位置已经处于该文件数据的尾部，则返回真，否则返回假。

语法： 逻辑型 是否在文件尾 （文件号，［是否为判断文本已读完］）

参数名 | 描 述
文件号 | 必需的；整数型。参数值指明欲操作的文件号，该文件号必须由“打开文件”命令所返回。
是否为判断文本已读完 | 可选的；逻辑型。如果本参数值为真而且下一即将读入的字节为字节值 0 或 26 等文本终止标记符或者当前读写位置已处于该文件数据的尾部，命令将返回真。如果本参数被省略或为假，将不进行此检查。

例程

说明

打开一个文件，判断读写位置是否在文件末尾。

参见：例程


取读写位置 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

返回指定被打开文件的当前读/写位置，位置值从 0 开始。如果给定文件号无效或失败，返回 -1 。

语法： 整数型 取读写位置 （文件号）

参数名 | 描 述
文件号 | 必需的；整数型。参数值指明欲操作的文件号，该文件号必须由“打开文件”命令所返回。

例程

说明

打开一个文件后，移动读写位置，显示当前的读写位置。

参见：例程


取文件长度 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

返回指定被打开文件的尺寸，该尺寸以字节为单位。如果给定文件号无效或失败，返回 -1 。

语法： 整数型 取文件长度 （文件号）

参数名 | 描 述
文件号 | 必需的；整数型。参数值指明欲操作的文件号，该文件号必须由“打开文件”命令所返回。

例程

说明

打开一个文件，取出该文件的大小。

参见：例程


插入字节集 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作插入一段或数段字节集数据到文件中当前读写位置处。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 插入字节集 （欲写出数据的文件号，欲写出的字节集数据，… ）

参数名 | 描 述
欲写出数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的字节集数据 | 必需的；可扩充的；字节集。

例程

说明

将一段字节集插入到文件中。

参见：例程


插入文本 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作插入一段或数段文本数据到文件中当前读写位置处。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 插入文本 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

将一段文本插入到文件的当前读写位置处。

参见：例程


插入文本行 命令 所属类别：文件读写

本命令用作插入一段或数段文本行到文件中当前读写位置处。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 插入文本行 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

在文件的当前读写位置插入一行文本。

参见：例程


删除数据 命令 操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作在文件中当前读写位置处删除一段字节数据，文件后面的数据顺序前移。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 删除数据 （文件号，欲删除数据的字节数）

参数名 | 描 述
文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲删除数据的字节数 | 必需的；整数型。

例程

说明

从文件的当前读写位置开始删除一段数据。

参见：例程


系统处理

系统处理 类别 跳至：系统核心支持库


运行 命令 操作系统支持：Windows、Linux 所属类别：系统处理

本命令运行指定的可执行EXE文件或者外部命令。如果成功，返回真，否则返回假。

语法： 逻辑型 运行 （欲运行的命令行，是否等待程序运行完毕，［被运行程序窗口显示方式］）

参数名 | 描 述
欲运行的命令行 | 必需的；文本型。
是否等待程序运行完毕 | 必需的；逻辑型，初始值为“假”。
被运行程序窗口显示方式 | 可选的；整数型。参数值可以为以下常量之一：1、#隐藏窗口； 2、#普通激活； 3、#最小化激活； 4、#最大化激活； 5、#普通不激活； 6、#最小化不激活。如果省略本参数，默认为“普通激活”方式。

例程：

说明：

运行系统中的程序。

参见： 例程


延时 命令 操作系统支持：Windows 所属类别：系统处理

本命令暂停当前程序的运行并等待指定的时间。

语法： 无返回值 延时 （欲等待的时间）

参数名 | 描 述
欲等待的时间 | 必需的；整数型。本参数指定欲暂停程序执行的时间，单位为毫秒。

例程：

说明：

程序间隔5秒再继续执行。

参见： 例程


取操作系统类别 命令 操作系统支持：Windows 所属类别：系统处理

返回当前操作系统的版本类别。返回值为以下值之一：0、未知； 1、Windows 32S； 2、Windows 9X (包含Win95、Win98、WinME等)； 3、Windows NT (包含WinNT、Win2000、WinXP等)； 4、Linux。

语法： 整数型 取操作系统类别 （）

例程：

说明：

取得代表系统版本类别的数值，通过判断取出系统版本类别。

参见 例程


程序调试

程序调试 类别 跳至：系统核心支持库


输出调试文本 命令 所属类别：程序调试

输出调试文本 命令　　所操作系统支持：Windows、Linux　　所属类别：程序调试

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
使用本命令可以在 E 调试系统中的“输出”窗体内输出指定的文本行以帮助调试，该文本之前被自动加上一个星号，之后被自动加上回车换行符。“输出调试文本”命令支持通用数据类型。

语法： 无返回值 输出调试文本 （准备输出的调试文本信息，… ）

参数名 | 描 述
准备输出的调试文本信息 | 必需的；可扩充的；文本型。

例程：

说明：

只在调试时使用

参见：例程1


暂停 命令 所属类别：程序调试

暂停 命令　　所操作系统支持：Windows、Linux　　所属类别：程序调试

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
可以在子程序中的任何地方放置此命令，使用此命令，就相当于在程序代码中设置断点。

语法： 无返回值 暂停 （）

例程：

说明：使用暂停中断程序，只有再次按“F5”键才会继续运行。。

.参见：例程1


检查 命令 所属类别：程序调试

检查 命令 　　所操作系统支持：Windows、Linux　　所属类别：程序调试

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
执行本命令时，如果给定参数的条件值被计算后结果为假，易程序的执行将被暂停且警示。可以在子程序中的任何地方放置此命令，使用此命令，就相当于在程序代码中设置条件断点。

语法： 无返回值 检查 （被校验的条件）

参数名 | 描 述
被校验的条件 | 必需的；逻辑型。如果此条件不能成立，即参数值为假，易程序的执行将被暂停且警示。

例程：

说明：

当条件为“假”时，程序就自动停止运行。

参见：例程1


是否为调试版 命令 所属类别：程序调试

是否为调试版 命令 所操作系统支持：Windows、Linux　　所属类别：程序调试

如果当前 EXE 易程序执行文件为易语言编辑环境调试运行程序时编译出来的调试版本，返回真。否则表明为发布版本，返回假。

语法： 逻辑型 是否为调试版 （）

例程

说明

判断当前运行的程序是否为调试版本。

参见：例程1


其他

其他 类别 跳至：系统核心支持库

选择 | 多项选择 | 是否为空 | 取系统语言
写到内存 |  |  |


选择 命令 所属类别：其他

选择 命令 操作系统支持：Windows、Linux、Unix 所属类别：其他

根据所提供参数的值，返回两部分中的其中一个。

语法： 通用型 选择 （用作选择的逻辑值，待选择项一，待选择项二）

参数名 | 描 述
用作选择的逻辑值 | 必需的；逻辑型。如果该值为真，将返回第一个待选择项，否则将返回第二个待选择项。
待选择项一 | 必需的；通用型。如果给定逻辑值为真，命令将返回本选择项。
待选择项二 | 必需的；通用型。如果给定逻辑值为假，命令将返回本选择项。

例程：

说明：

在此命令中使用条件语句，取出符合逻辑条件的数据。

参见：例程


多项选择 命令 所属类别：其他

多项选择 命令 操作系统支持：Windows、Linux、Unix 所属类别：其他

从参数列表项目中选择并返回一个值。

语法： 通用型 多项选择 （索引值，待选择项数据，… ）

参数名 | 描 述
索引值 | 必需的；整数型。命令会根据本索引值来返回选择项列表中的某个值。如果索引值是 1，则命令会返回列表中的第 1 个选择项。如果索引值是 2，则会返回列表中的第 2 个选择项，以此类推。如果索引值小于 1 或者大于最大可选择项，将会产生运行错误。
待选择项数据 | 必需的；可扩充的；通用型。

例程：

说明：

根据输入值变量的值，取出对应位置的值。

参见：例程


是否为空 命令 所属类别：其他

是否为空 命令 操作系统支持：Windows、Linux、Unix 所属类别：其他

返回一个逻辑值，指出在调用子程序时是否为指定参数提供了数据（该参数必定有“可空”标志），如未提供，返回真，否则返回假。

语法： 逻辑型 是否为空 （欲测试的参数变量）

参数名 | 描 述
欲测试的参数变量 | 必需的；通用型，参数数据只能提供变量及变量数组。

例程：

说明：

判断所传递的参数是否为空。

参见：例程


取系统语言 命令 所属类别：其他

取系统语言 命令 操作系统支持：Windows 所属类别：其他

返回当前系统运行时环境所支持的语言版本类型，为以下常量值之一： 1、GBK中文； 2、英文； 3、BIG5中文； 4、日文。

语法： 整数型 取系统语言 （）

例程：

说明：

显示系统运行时语言版本类型。

参见：例程1


写到内存 命令 操作系统支持：Windows 所属类别：其他

写到内存 命令 　英文命令：WriteMem　操作系统支持：Windows 所属类别：其他

为高级用户提供，初级用户无需掌握；
将数据写出到指定的内存区域，注意调用本命令前一定要确保所提供的内存区域真实有效。本命令的最佳使用场合就是在易语言回调子程序和易语言DLL公开子程序中用作对外输出数据。

语法： 无返回值 写到内存 （欲写到内存的数据，内存区域指针，［内存区域尺寸］）

参数名 | 描 述
欲写到内存的数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值只能为基本数据类型数据或字节数组。
内存区域指针 | 必需的；整数型。本参数提供欲写向内存区域首地址的指针值。
内存区域尺寸 | 可选的；整数型。本参数提供该内存区域的有效尺寸，如果欲写出数据超出此尺寸值，将被自动切除。参数值如果为 -1 ，则表示此内存区域尺寸不受限制。如果本参数被省略，则默认值为 -1。

例程：

说明：

将文本写到指定内存区域。

参见：例程1 例程2 相关dll


控制台操作

控制台操作 类别 跳至：系统核心支持库


标准输出 命令 操作系统支持：Windows、Linux 所属类别：控制台操作

在标准输出设备或标准错误设备上输出指定的内容，注意本命令只能在控制台程序中使用。

语法： 无返回值 标准输出 （［输出方向］，欲输出内容，… ）

参数名 | 描 述
输出方向 | 可选的；整数型。本参数提供内容所输出到的设备，可以为以下常量值之一： 1、#标准输出设备； 2、#标准错误设备。如果省略本参数，默认为“#标准输出设备”。
欲输出内容 | 必需的；可扩充的；通用型。本参数只能为文本、数值、逻辑值或日期时间。如果内容为文本且包含多行，可在各行之间用回车符 (即“字符 (13)”)、换行符 (即“字符 (10)”) 或回车换行符的组合 (即：“字符 (13) + 字符 (10)”) 来分隔。

例程:

说明：

在控制台窗口中输出信息或接收信息。

将程序设为Windows控制台程序或Linux控制台程序方可看到运行效果。

参见：例程1


标准输入 命令 操作系统支持：Windows、Linux 所属类别：控制台操作

在标准输入设备上请求输入最多包含1020个字符的一行文本，返回用户所输入的内容。注意本命令只能在控制台程序中使用。

语法： 文本型 标准输入 （［是否回显］）

参数名 | 描 述
是否回显 | 可选的；逻辑型。本参数决定输入时是否显示所输入字符，为假不显示，为真显示。如果被省略，默认值为真，即回显。可以通过将本参数设置为假以输入密码等特殊信息。

例程：

说明：

在控制台窗口中输出信息或接收信息。

将程序设为Windows控制台程序或Linux控制台程序方可看到运行效果

参见：例程1


常量 | 常量值 | 描 述
#引号 | “"” | 半角双引号。
#左引号 | ““” | 全角左双引号。
#右引号 | “”” | 全角右双引号。
#换行符 | “字符（13）+字符（10）” | 一个回车符（13）和一个换行符（10）的组合。
#pi | 3.1415926535 |
#e | 2.718282 |
#黑色 | 0 | 常用颜色值。
#藏青 | 8388608 |
#墨绿 | 32768 |
#深青 | 8421376 |
#红褐 | 128 |
#紫红 | 8388736 |
#褐绿 | 32896 |
#浅灰 | 12632256 |
#灰色 | 8421504 |
#蓝色 | 16711680 |
#绿色 | 65280 |
#艳青 | 16776960 |
#红色 | 255 |
#品红 | 16711935 |
#黄色 | 65535 |
#白色 | 16777215 |
#蓝灰 | 16744576 |
#藏蓝 | 14692440 |
#嫩绿 | 57472 |
#青绿 | 8445952 |
#黄褐 | 24768 |
#粉红 | 16754943 |
#嫩黄 | 55512 |
#银白 | 15527148 |
#紫色 | 16711824 |
#天蓝 | 16746496 |
#灰绿 | 8429696 |
#青蓝 | 12607488 |
#橙黄 | 33023 |
#桃红 | 8409343 |
#芙红 | 12615935 |
#深灰 | 6316128 |
#透明 | -16777216 |
#隐藏窗口 | 1 |
#普通激活 | 2 |
#最小化激活 | 3 |
#最大化激活 | 4 |
#普通不激活 | 5 |
#最小化不激活 | 6 |
#读入 | 1 |
#写出 | 2 |
#读写 | 3 |
#重写 | 4 |
#改写 | 5 |
#改读 | 6 |
#无限制 | 1 |
#禁止读 | 2 |
#禁止写 | 3 |
#禁止读写 | 4 |
#文件首 | 1 |
#文件尾 | 2 |
#现行位置 | 3 |
#只读文件 | 1 |
#隐藏文件 | 2 |
#系统文件 | 4 |
#子目录 | 16 |
#存档文件 | 32 |
#无属性文件 | 128 |
#字节型 | 1 |
#短整数型 | 2 |
#整数型 | 3 |
#长整数型 | 4 |
#小数型 | 5 |
#双精度小数型 | 6 |
#逻辑型 | 7 |
#日期时间型 | 8 |
#子程序指针型 | 9 |
#文本型 | 10 |
#年份 | 1 |
#季度 | 2 |
#月份 | 3 |
#周 | 4 |
#自年首周数 | 4 |
#日 | 5 |
#小时 | 6 |
#分钟 | 7 |
#秒 | 8 |
#星期几 | 9 |
#自年首天数 | 10 |
#确认钮 | 0 | “信息框”命令使用。
#确认取消钮 | 1 |
#放弃重试忽略钮 | 2 |
#取消是否钮 | 3 |
#是否钮 | 4 |
#重试取消钮 | 5 |
#错误图标 | 16 |
#询问图标 | 32 |
#警告图标 | 48 |
#信息图标 | 64 |
#默认按钮一 | 0 |
#默认按钮二 | 256 |
#默认按钮三 | 512 |
#默认按钮四 | 768 |
#程序等待 | 0 |
#系统等待 | 4096 |
#位于前台 | 65536 |
#文本右对齐 | 524288 |
#取消钮 | 1 |
#放弃钮 | 2 |
#重试钮 | 3 |
#忽略钮 | 4 |
#是钮 | 5 |
#否钮 | 6 |
#首拼及全拼 | 1 |
#双拼 | 2 |
#自动判别 | 3 |
#Ctrl键状态 | 1 |
#Shift键状态 | 2 |
#Alt键状态 | 4 |
#键0 | 48 | 按键代码值。
#键1 | 49 |
#键2 | 50 |
#键3 | 51 |
#键4 | 52 |
#键5 | 53 |
#键6 | 54 |
#键7 | 55 |
#键8 | 56 |
#键9 | 57 |
#A键 | 65 |
#B键 | 66 |
#C键 | 67 |
#D键 | 68 |
#E键 | 69 |
#F键 | 70 |
#G键 | 71 |
#H键 | 72 |
#I键 | 73 |
#J键 | 74 |
#K键 | 75 |
#L键 | 76 |
#M键 | 77 |
#N键 | 78 |
#O键 | 79 |
#P键 | 80 |
#Q键 | 81 |
#R键 | 82 |
#S键 | 83 |
#T键 | 84 |
#U键 | 85 |
#V键 | 86 |
#W键 | 87 |
#X键 | 88 |
#Y键 | 89 |
#Z键 | 90 |
#F1键 | 112 |
#F2键 | 113 |
#F3键 | 114 |
#F4键 | 115 |
#F5键 | 116 |
#F6键 | 117 |
#F7键 | 118 |
#F8键 | 119 |
#F9键 | 120 |
#F10键 | 121 |
#F11键 | 122 |
#F12键 | 123 |
#F13键 | 124 |
#F14键 | 125 |
#F15键 | 126 |
#F16键 | 127 |
#Break键 | 3 |
#退格键 | 8 |
#Tab键 | 9 |
#回车键 | 13 |
#Shift键 | 16 |
#Ctrl键 | 17 |
#Alt键 | 18 |
#Pause键 | 19 |
#CapsLock键 | 20 |
#NumLock键 | 144 |
#ScrollLock键 | 145 |
#Esc键 | 27 |
#空格键 | 32 |
#PageUp键 | 33 |
#PageDown键 | 34 |
#Home键 | 36 |
#End键 | 35 |
#左光标键 | 37 |
#上光标键 | 38 |
#右光标键 | 39 |
#下光标键 | 40 |
#Ins键 | 45 |
#Del键 | 46 |
#分号键 | 186 |
#等号键 | 187 |
#逗号键 | 188 |
#减号键 | 189 |
#圆点键 | 190 |
#除号键 | 191 |
#反撇号键 | 192 |
#左中括号键 | 219 |
#右中括号键 | 221 |
#斜杠键 | 220 |
#单引号键 | 222 |
#顶层 | 1 | 在窗口 Z 顺序的最前面。
#底层 | 2 | 在窗口 Z 顺序的最后面。
#最高层 | 3 | 在所有现行窗口的最前面并一直保持此位置。
#次高层 | 4 | 在最高层窗口的下面但在其他窗口的前面。
#全部转换 | 1 |
#日期部分 | 2 |
#时间部分 | 3 |
#输入文本 | 1 |
#输入整数 | 2 |
#输入小数 | 3 |
#拷贝 | 1 |
#翻转拷贝 | 2 |
#位异或 | 3 |
#位或 | 4 |
#位与 | 5 |
#从上到下 | 1 |
#从左到右 | 2 |
#从左上到右下 | 3 |
#从右上到左下 | 4 |
#从下到上 | 5 |
#从右到左 | 6 |
#从右下到左上 | 7 |
#从左下到右上 | 8 |
#字节集型 | 11 | 可以存储大量的不定长字节数据。
#备注型 | 12 | 文本型的扩充，可以存储大量的不定长文本数据。
#通常索引 | 1 |
#读音索引 | 2 |
#南方读音索引 | 3 |
#不区分大小写 | 1 |
#忽略所有空格 | 2 |
#取平均值 | 1 |
#求和 | 2 |
#取最大值 | 3 | 取最大数值及日期。
#取最小值 | 4 | 取最小数值及日期。
#禁止修改 | 1 | 如果禁止修改，则自动禁止添加和删除。
#禁止添加 | 2 |
#禁止删除 | 4 |
#禁止自动判断 | 8 |
#根类 | 1 | 具体注册表键名为: HKEY_CLASSES_ROOT。
#现行设置 | 2 | 具体注册表键名为: HKEY_CURRENT_CONFIG。
#现行用户 | 3 | 具体注册表键名为: HKEY_CURRENT_USER。
#本地机器 | 4 | 具体注册表键名为: HKEY_LOCAL_MACHINE。
#所有用户 | 5 | 具体注册表键名为: HKEY_USERS。
#单击左键 | 1 |
#双击 | 2 |
#单击右键 | 3 |
#默认色 | -16777216 |
#文本 | 1 |
#图片文件名 | 2 |
#图片数据 | 3 |
#字节集数据 | 4 |
#上左 | 1 |
#上中 | 2 |
#上右 | 3 |
#中左 | 4 |
#中中 | 5 |
#中右 | 6 |
#下左 | 7 |
#下中 | 8 |
#下右 | 9 |
#缩放图片 | 10 |
#居中图片 | 11 |
#缩放居中图片 | 12 |
#平铺图片 | 13 |
#缩放平铺图片 | 14 |
#粗体 | 1 |
#斜体 | 2 |
#下划线 | 4 |
#删除线 | 8 |
#通常型 | 0 |
#左边框 | 1 |
#上边框 | 2 |
#右边框 | 4 |
#下边框 | 8 |
#水平线 | 16 |
#垂直线 | 32 |
#单斜线 | 64 |
#双斜线 | 128 |
#交叉线 | 256 |
#左单元格 | 1 |
#上单元格 | 2 |
#右单元格 | 3 |
#下单元格 | 4 |
#无页号 | 0 |
#上左页号 | 1 |
#上中页号 | 2 |
#上右页号 | 3 |
#下左页号 | 4 |
#下中页号 | 5 |
#下右页号 | 6 |
#全部页 | 0 |
#仅打印奇数页 | 1 |
#仅打印偶数页 | 2 |
#页范围 | 1 |
#行范围 | 2 |
#纵向 | 0 |
#横向 | 1 |
#默认纸 | 0 |
#A3纸 | 1 | 297 x 420 毫米。
#A4纸 | 2 | 210 x 297 毫米。
#A5纸 | 3 | 148 x 210 毫米。
#B4纸 | 4 | 250 x 354 毫米。
#B5纸 | 5 | 182 x 257 毫米。
#四开 | 6 | 215 x 275 毫米。
#十六开 | 7 | 146 x 215 毫米。
#三十二开 | 8 | 97 x 151 毫米。
#信纸 | 9 | 216 x 279 毫米。
#法律用纸 | 10 | 216 x 355 毫米。
#行政用纸 | 11 | 184 x 266 毫米。
#声明 | 12 | 140 x 216 毫米。
#小报 | 13 | 279 x 432 毫米。
#笔记 | 14 | 216 x 279 毫米。
#帐本 | 15 | 432 x 279 毫米。
#对开纸 | 16 | 216 x 330 毫米。
#输入密码 | 4 |
#缩放到纸宽 | -1 |
#限定到纸宽 | -2 |
#常量 | 0 |
#资源 | 1 |
#清除信号 | 1 |
#发送或置位 | 2 |
#DTR信号 | 1 |
#RTS信号 | 2 |
#Break信号 | 3 |
#GBK中文 | 1 |
#英文 | 2 |
#BIG5中文 | 3 |
#标准输出设备 | 1 |
#标准错误设备 | 2 |
#无法载入的常量 | -1 | 如果源程序中的某一库定义常量由于其所在支持库载入出错而导致无法被载入，将自动被本常量所取代。