端口访问支持库

端口访问支持库 帮助手册20080811版 返回支持库手册 返回首页

本支持库实现了对计算机端口的直接访问支持，注意在执行本支持库内命令前计算机上必须要安装有第三方免费软件 port95nt.exe，下载地址 http://www.eyuyan.com/port95nt.exe ；本库为一般支持库，需要易系统3.0版本的支持，需要系统核心支持库3.0版本的支持，提供了4种命令。

操作系统支持： Windows

命令类别：

端口访问

并口设置

适用版本，端口访问支持库 （1.0#50版）


端口访问

端口访问 类别 跳至：端口访问支持库


端口读入

端口读入 命令 操作系统支持：Windows 所属类别：端口访问

从指定端口读入并返回一个字节数据，注意如果没有安装port95nt.exe，本命令将失败并始终返回0。请在运行本命令的目的机器上下载安装第三方免费软件 http://www.dywt.com.cn/port95nt.exe 。

语法： 字节型 端口读入 （端口号）

参数名 | 描 述
端口号 | 必需的；整数型。本参数提供欲进行读写端口的端口号。

例程

说明

读入端口的地址为到十进制的编辑框2的内容，结果返回编辑框3中。（端口读入前要使用查询并口命令）

参见：例程1


端口写出

端口写出 命令 操作系统支持：Windows 所属类别：端口访问

向指定端口写出一个字节数据，注意如果没有安装port95nt.exe，本命令将失败。请在运行本命令的目的机器上下载安装第三方免费软件 http://www.dywt.com.cn/port95nt.exe 。

语法： 无返回值 端口写出 （端口号，欲写出字节）

参数名 | 描 述
端口号 | 必需的；整数型。本参数提供欲进行读写端口的端口号。
欲写出字节 | 必需的；字节型。本参数提供欲写出到指定端口的字节数据。

例程

说明

端口写出写出的端口号，为到十进制的编辑框4的内容。


并口设置

并口设置 类别 跳至：端口访问支持库


查询并口

查询并口 命令 操作系统支持：Windows 所属类别：并口设置

返回当前计算机上所有并口的配置情况。返回数据是一个整数数组，其中每三个成员描述一个并口的信息。第一个成员记录此并口的端口访问地址，第二个记录该并口的类型，为以下整数值之一： 0: 未定义; 1: SPP; 2: PS2; 3: EPP; 4: ECP 。如果并口类型为ECP，第三个成员记录具体的ECP模式，为以下整数值之一： 0: 未定义; 1: SPP; 2: PS2; 3: FastCentronics; 4: ECP; 5: EPP; 6: Test; 7: Configuration 。如果并口类型不为ECP，则第三个成员始终为0。注意如果没有安装port95nt.exe，本命令将失败并返回空整数数组。请在运行本命令的目的机器上下载安装第三方免费软件 http://www.dywt.com.cn/port95nt.exe 。

语法： 整数型数组 查询并口 （）

例程

说明

检查合并的端口数组保存在变量1中。


置ECP模式

置ECP模式 命令 操作系统支持：Windows 所属类别：并口设置

如果指定并口类型为ECP，则可以使用本命令设置其具体的ECP模式。注意如果没有安装port95nt.exe，本命令将失败。请在运行本命令的目的机器上下载安装第三方免费软件 http://www.dywt.com.cn/port95nt.exe 。

语法： 无返回值 置ECP模式 （并口端口号，ECP模式）

参数名 | 描 述
并口端口号 | 必需的；整数型。本参数提供ECP类型并口的端口号。
ECP模式 | 必需的；整数型。本参数可以为以下值之一: 1: SPP; 2: PS2; 3: FastCentronics; 4: ECP; 5: EPP; 6: Test; 7: Configuration。

例程

说明

设置编辑框1的内容转到十进制的结果为设置的端口号，组合框2的内容的项目索引+1为设置的ECP的模式。