数码设备支持库

数码设备支持库 帮助手册20080815版 返回支持库手册 返回首页

本支持库实现了对数码设备的支持。

操作系统支持： Windows

窗口组件数据类型：

数码设备

视频设备

其它数据类型：

像素类型

例程列表：

例程名称 | 下载 | 说明
视频互动 | 视频互动服务端.e 视频互动客户端.e | 实现了双方视频交流的功能。

适用版本，数码设备支持库 （1.5#1版）


数码设备

数码设备 功能型窗口组件 操作系统支持：Windows 跳至：数码设备支持库

实现了对数码设备(静态图像)的控制。

属性：

来源总数 | 来源名称 | 当前来源 | 错误信息
像素类型 | 横向分辨率 | 图像顶边 | 图像底边
图像左边 | 图像右边 | 纵向分辨率 |

方法：

选定来源

获取图像

保存到文件

初始化

自有事件：

图片传送完毕


来源总数 (数码设备)

来源总数 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：整数型；只读；返回系统中可用的来源的总数。

例程:

说明:

创建窗口后初始化twain组件,并让‘选择来源组合框’加入所有的来源名称。

参见:例程


来源名称 (数码设备)

来源名称 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：文本型；只读；返回当前来源的名称。

例程:

说明:

创建窗口后初始化twain组件,并让‘选择来源组合框’加入所有的来源名称。


当前来源 (数码设备)

当前来源 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：整数型；设计时不可用；设置或返回当前的来源。范围从0至“来源总数”属性所返回的数值之间。

例程:

说明:

创建窗口后初始化twain组件,并让‘选择来源组合框’加入所有的来源名称。


错误信息 (数码设备)

错误信息 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：文本型；只读；返回最后一条错误信息。

例程:

说明:

让标签显示出数码设备的错误描述。


像素类型 (数码设备)

像素类型 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：整数型；设计时不可用；设置或返回像素类型,可以为“像素类型”数据类型中的常量。

例程:

说明:

让所有编辑框和组合框对应显示出数码设备的所有属性。


分辨率 (数码设备)

横向分辨率 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：整数型；设计时不可用；设置或返回分辨率（dpi）。

例程:

说明:

让所有编辑框和组合框对应显示出数码设备的所有属性。


图像顶边 (数码设备)

图像顶边 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用；设置或返回图像顶边，单位为英寸。

例程:

说明:

让所有编辑框和组合框对应显示出数码设备的所有属性。


图像底边 (数码设备)

图像底边 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用；设置或返回图像底边，单位为英寸。

例程:

说明:

让所有编辑框和组合框对应显示出数码设备的所有属性。


图像左边 (数码设备)

图像左边 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用；设置或返回图像左边，单位为英寸。

例程:

说明:

让所有编辑框和组合框对应显示出数码设备的所有属性。


图像右边 (数码设备)

图像右边 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用；设置或返回图像右边，单位为英寸。

例程:

说明:

让所有编辑框和组合框对应显示出数码设备的所有属性。


纵向分辨率 (数码设备)

纵向分辨率 属性 所属对象：数码设备 操作系统支持：Windows

数据类型：整数型；设计时不可用；设置或返回纵向分辨率（dpi）。

例程：

说明：

让所有编辑框和组合框对应显示出数码设备的所有属性。


选定来源 (数码设备)

选定来源 方法 操作系统支持：Windows 所属对象：数码设备

选择用哪个设备来获取图象,返回值:1表示选取了新的来源，2表示取消了选择，-1表示出错。

语法： 整数型 数码设备．选定来源 （是否用默认选择，来源选项）

参数名 | 描 述
否用默认选择 | 必需的；逻辑型。本参数表示是否使用系统默认选择。
来源选项 | 必需的；整数型，初始值为“-1”。-1表示弹出默认的对话框让用户选择,范围从0至“来源总数”属性所返回的数值之间，表示选择哪个来源。

例程:

说明:

根据设置的数码设备的属性获取图像。


获取图像 (数码设备)

获取图像 方法 操作系统支持：Windows 所属对象：数码设备

从所选的设备中获取图象,如果获取成功则会触发图片传送完毕事件。

语法： 逻辑型 数码设备．获取图像 （是否显示用户界面）

参数名 | 描 述
是否显示用户界面 | 必需的；逻辑型。本参数表示是否显示用户界面。

例程:

说明:

让所有编辑框和组合框对应显示出twain的所有属性，然后获取图像


保存到文件 (数码设备)

保存到文件 方法 操作系统支持：Windows 所属对象：数码设备

将捕获到的图片保存到文件中,格式是BMP的。注：此方法需要在“图片发送完毕”事件中调用。

语法： 逻辑型 数码设备．保存到文件 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。本参数表示要保存的文件名。

例程:

说明:

在传送完毕后，把图像保存到文件。


初始化 (数码设备)

初始化 方法 操作系统支持：Windows 所属对象：数码设备

初始化外部设备。

语法： 逻辑型 数码设备．初始化 （）

例程:

说明:

创建窗口后初始化twain组件,并让‘选择来源组合框’加入所有的来源名称。


图片传送完毕 (数码设备)

图片传送完毕 事件 所属对象：数码设备 操作系统支持：Windows

当图片传送完毕时触发此事件。

语法： 无返回值 _数码设备_图片传送完毕 （图片，图片宽度，图片高度）

参数名 | 描 述
图片 | 必需的；字节集。参数值表示本图片的数据。
图片宽度 | 必需的；整数型。参数值表示本图片的宽度。
图片高度 | 必需的；整数型。参数值表示本图片的高度。

例程:

说明:

在传送完毕后，把图像保存到文件。


视频设备

视频设备 窗口组件 操作系统支持：Windows 跳至：数码设备支持库

实现了对数码设备(动态图像)的控制。

属性：

来源总数

来源名称

当前来源

错误信息

方法：

设置视频输入 | 设置视频格式 | 设置视频显示 | 预览
视频重叠 | 捕获视频 | 设置压缩格式 | 保存为图片
结束捕获 | 压缩一帧图像 | 解压缩一帧图像 | 填充一帧图像

自有事件：

收到一帧数据后


来源总数 属性 所属对象：视频设备 操作系统支持：Windows

数据类型：整数型；只读；返回系统中可用的来源的总数。

例程:

说明:

在窗体加载时取出视频设备来源数量并加到组合框中。


来源名称 属性 所属对象：视频设备 操作系统支持：Windows

数据类型：文本型；只读；返回当前来源的名称。

例程:

说明:

循环中将视频的每一来源遍历一遍同时加入当前来源名称到组合框。


当前来源 属性 所属对象：视频设备 操作系统支持：Windows

数据类型：整数型；设计时不可用；设置或返回当前的来源。范围从0至“来源总数”属性所返回的数值之间。

例程:

说明:

循环中将视频的每一来源遍历一遍同时加入当前来源名称到组合框。


错误信息 属性 所属对象：视频设备 操作系统支持：Windows

数据类型：文本型；只读；返回最后一条错误信息。

例程:

说明:

取出错误文本保存在‘错误文本’变量内（这是上次操作的错误信息，所以如果这次操作成功，这个便无效）。


设置视频输入 方法 操作系统支持：Windows 所属对象：视频设备

显示视频输入对话框对当前来源进行设置。注：此对话框是由硬件厂商实现的。有些硬件有可能不支持。

语法： 逻辑型 视频设备．设置视频输入 （）

例程:

说明:

这命令会弹出设备自带的相关功能设置对话框（这个或许硬件不支持）。


设置视频格式 方法 操作系统支持：Windows 所属对象：视频设备

显示视频格式对话框对当前来源进行设置。注：此对话框是由硬件厂商实现的。有些硬件有可能不支持。

语法： 逻辑型 视频设备．设置视频格式 （）

例程:

说明:

这命令会弹出设备自带的相关功能设置对话框（这个或许硬件不支持）。


设置视频显示 方法 操作系统支持：Windows 所属对象：视频设备

显示视频显示对话框对当前来源进行设置。注：此对话框是由硬件厂商实现的。有些硬件有可能不支持。

语法： 逻辑型 视频设备．设置视频显示 （）

例程:

说明:

这命令会弹出设备自带的相关功能设置对话框（这个或许硬件不支持）。


预览 方法 操作系统支持：Windows 所属对象：视频设备

预览视频。

语法： 逻辑型 视频设备．预览 （预览/取消预览，预览速率）

参数名 | 描 述
预览/取消预览 | 必需的；逻辑型。本参数为真表示预览，为假表示取消预览。
预览速率 | 必需的；整数型，初始值为“-1”。本参数表示要预览的速率，单位为毫秒, -1代表取设备默认值。比如设为60,说明60毫秒捕获一帧。

例程:

说明:

设置视频设备的预览状态，并用标签3表示出来。


视频重叠 方法 操作系统支持：Windows 所属对象：视频设备

启用/禁用视频重叠。注：此功能某些硬件可能不支持。

语法： 逻辑型 视频设备．视频重叠 （启用/禁用）

参数名 | 描 述
启用/禁用 | 必需的；逻辑型。本参数为真表示启用视频重叠，为假表示禁用视频重叠。

例程:

说明:

这命令会弹出设备自带的相关功能设置对话框（这个或许硬件不支持）。


捕获视频 方法 操作系统支持：Windows 所属对象：视频设备

捕获视频到文件(avi格式)。

语法： 逻辑型 视频设备．捕获视频 （是否使用默认值，［文件名］，几毫秒一帧，是否显示提示对话框，是否鼠标左键单击时结束，是否鼠标右键单击时结束，捕获时间）

参数名 | 描 述
是否使用默认值 | 必需的；逻辑型。本参数表示是否使用硬件默认的参数。
文件名 | 可选的；文本型。本参数表示捕获的数据存放的文件名。如文件名为空，则表示只捕获不保存为文件。
几毫秒一帧 | 必需的；整数型，初始值为“66”。本参数表示几毫秒捕获一帧数据。
是否显示提示对话框 | 必需的；逻辑型，初始值为“假”。本参数表示是否显示提示对话框让用户来选择是否捕获。
是否鼠标左键单击时结束 | 必需的；逻辑型，初始值为“真”。本参数表示是否鼠标左键单击时结束捕获。
是否鼠标右键单击时结束 | 必需的；逻辑型，初始值为“真”。本参数表示是否鼠标右键单击时结束捕获。
捕获时间 | 必需的；整数型，初始值为“-1”。本参数表示捕获的时间，-1表示不限时间(单位为秒)。

例程:

说明:

视频捕获设备将会开启‘收到一帧数据后’的事件回调，在这里捕获视频是以用户方式捕获捕获时的每帧数据会写到文件名（结束后会录制成AVI文件）无提示框，左右键单击结束，录制时间为长度。


设置压缩格式 方法 操作系统支持：Windows 所属对象：视频设备

显示视频压缩对话框对当前来源进行设置。

语法： 逻辑型 视频设备．设置压缩格式 （）

例程:

说明:

这命令会弹出设备自带的相关功能设置对话框（这个或许硬件不支持）。


保存为图片 方法 操作系统支持：Windows 所属对象：视频设备

保存当前帧为一个bmp文件。

语法： 逻辑型 视频设备．保存为图片 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。本参数表示要保存到的文件名(BMP格式)。

例程:

说明:

预览状态下视频会将当前帧保存到磁盘中，图片类型为位图文件（捕获时无效）


结束捕获 方法 操作系统支持：Windows 所属对象：视频设备

结束当前的捕获。

语法： 逻辑型 视频设备．结束捕获 （）

例程:

说明:

结束视频设备的捕获图像。


压缩一帧图像 方法 操作系统支持：Windows 所属对象：视频设备

对一帧图像进行压缩并返回结果。

语法： 字节集 视频设备．压缩一帧图像（图像）

参数名 | 描 述
图像 | 必需的；字节集。本参数表示要压缩的图像。

例程:

说明:

在录制时视频设备收到一帧数据，如果压缩图像成功就把压缩的图像保存在‘资源’中。


解压缩一帧图像 方法 操作系统支持：Windows 所属对象：视频设备

对一帧图像进行解压缩并返回结果(BMP格式)。

语法： 字节集 视频设备．解压缩一帧图像 （图像）

参数名 | 描 述
图像 | 必需的；字节集。本参数表示要解压缩的图像。

例程:

说明:

设置视频设备的预览状态，并用标签3表示出来。


填充一帧图像 方法 操作系统支持：Windows 所属对象：视频设备

将一帧图像填充到视频窗口。

语法： 逻辑型 视频设备．填充一帧图像 （图像）

参数名 | 描 述
图像 | 必需的；字节集。本参数表示填充的图像，必须为“压缩一帧图像”方法返回的字节集。

例程:

说明:

设置视频设备的预览状态，并用标签3表示出来。


收到一帧数据后 事件 所属对象：视频设备 操作系统支持：Windows

当收到一帧数据后触发此事件。此事件只有在捕获状态下才触发。

语法： 无返回值 _视频设备_收到一帧数据后 （图片）

参数名 | 描 述
图片 | 必需的；字节集。参数值表示这一帧的数据(位图格式)。

例程:

说明:

在录制时视频设备收到一帧数据，如果压缩图像成功就将压缩的图像保存在‘资源’中。


像素类型

像素类型 枚举常量集合类型 操作系统支持：Windows 跳至：数码设备支持库

本数据类型包括了“像素类型”的常量。

成员 | 描 述
黑白 | 常量值为 0 。
GRAY | 常量值为 1 。
RGB | 常量值为 2 。
PALETTE | 常量值为 3 。
CMY | 常量值为 4 。
CMYK | 常量值为 5 。
YUV | 常量值为 6 。
YUVK | 常量值为 7 。
CIEXYZ | 常量值为 8 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。