软件简介以及特点

E-F_Rename

软件简介以及功能特点

E-F_Rename是一款纯绿色的免费软件，能对大批量的文件进行批量更名，使用简单，更名速度快；

提供基本的文件更名（常规方式），可单独对文件名和扩展名进行修改；

提供在原有文件名的基础上进行替换/删除操作；

提供在原有文件名的基础上进行插入操作；

支持MP3标签更名（ID3 V1.0 ID3 V1.1 ID3 V2.3）；

支持MP3标签写入和删除；

支持自动预览；

支持过滤功能；

支持拖放操作；

支持撤消；

软件采用汉语编程工具－－易语言开发，更贴近国人用户，而且源代码是公开的，任何人都可以对其进修改和使用。


安装和卸载

E-F_Rename

安装：

本软件是绿色软件，无需安装，从网上下载后直接解压到本地计算机磁盘的某个目录即可使用。

卸载：

直接删除主程序文件E-F_Rename.exe，以及其所在目录生成的配置文件dir.txt，config.ini以及帮助文档help.chm文件即可彻底删除本软件。


添加文件

E-F_Rename

可以使用三种方法把文件加入到系统中：

1、直接从资源管理器中把文件拖到E-F批量更名器的软件界面上；

2、在软件界面中，在菜单点击 文件－选择目录(D)...或快捷键(Ctrl + D )

3、在软件界面中，在菜单点击 文件－添加文件(N)...或快捷键(Ctrl + F )
(在这种方式下，添加文件的字符总数是有限制的，如果采用此方式打开很多文件时，却没有看到有文件被添加，那一定是超出了字符缓冲区的长度了，建议采用第1、2种方式的打开。)

注意：

系统不会对重复添加的文件进行检测，所以添加的时候不要重复！


常规方式

E-F_Rename

常规方式

常规方式允许你对原文件名和扩展名进行单独的设置，分以下几种情况：

在此方式下，扩展名不允许被改变，如下面的（图－1）所示，扩展名选项框是呈现灰色的；

新的文件名格式为：前缀＋主文件名＋数字序列＋后缀＋"."＋原扩展名

注意：数字序列取决于‘起始量’和 ‘位数’

例如：
有原文件名为： 文本文档1.txt、文本文档2.txt
在该选项夹下进行如下设置(只有文件名选项框可用)，如图所示：

（图－1）

则第一个文件'文本文档1.txt'的新文件名为：[test000].txt
则第二个文件'文本文档2.txt'的新文件名为：[test001].txt

........

依此类推

在此方式下，原文件名将被保留，如下面的（图－2）所示，文件名名选项框是呈现灰色的；

新的文件名格式为：原文件名＋"."＋前缀＋新扩展名＋数字序列＋后缀

一般情况：

例如：
在该选项夹下进行如下设置(只有扩展名选项框可用)，如图所示：

（图－2）

则第一个文件'文本文档1.txt'的新文件名为：文本文档1.[txt000]
则第二个文件'文本文档2.txt'的新文件名为：文本文档2.[txt001]

........

依此类推

特殊情况： 如果 前缀、新扩展名、数字序列（位数＝空）、后缀都为空，那么程序将删除原文件的扩展名

（图－3）

则第一个文件'文本文档1.txt'的新文件名为：文本文档1
则第二个文件'文本文档2.txt'的新文件名为：文本文档2

在此方式下，文件名选项框和扩展名选项框都变得可用，如下面的（图－4）所示；

新的文件名格式为：

前缀＋主文件名＋数字序列＋后缀＋"."＋前缀＋新扩展名＋数字序列＋后缀

仍以上例为例，效果如下图所示：

（图－4）

则第一个文件'文本文档1.txt'的新文件名为：我的文档1.0001
则第二个文件'文本文档2.txt'的新文件名为：我的文档1.0002

在该子夹下，清空按钮可以快速的清空各编辑框的内容


替换/删除

E-F_Rename

替换/删除

在此更名方式下，允许你对原文件名进行替换/删除操作

在‘查找内容’编辑框中输入你要查找的字符串，如果要区分大小写，可将‘区分大小写’复选框选中，

在‘替换为’编辑框中输入你想要替换的内容（为空时表示删除‘查找内容’编辑框中的内容）

在‘应用于’标签下对应着三个单选按钮，根据不同的需要选择不同的作用范围：

如果仅文件名单选按钮被选中，则系统只作用于文件名

如果仅扩展名单选按钮被选中，则系统只作用于扩展名

如果仅全部单选按钮被选中，则系统作用于文件名和扩展名


插入

E-F_Rename

插入

此方式下，允许你对文件名和扩展名进行单独的插入操作；

文件名：将要插入到文件名中的字符串；

扩展名：将要插入到扩展名中的字符串；

如果‘保持一致’复选框被选中，则在文件名和扩展名要插入的字符串保持一致；

插入到文件名：

1、如果插入到第N个位置单选按钮被选择，则可以通过调节按钮调节要插入到文件名的位置，或在编辑框直接填入相应的位置数值也可以；

2、如果文件名尾单选按钮被选择，则插入到文件名尾

插入到扩展名：

1、如果插入到第N个位置单选按钮被选择，则可以通过调节按钮调节要插入到扩展名的位置，或在编辑框直接填入相应的位置数值也可以；

2、如果文件名尾单选按钮被选择，则插入到扩展名尾


大小写

E-F_Rename

大小写

大小写的转换也允许你分别对文件名和扩展名进行单独的设置：

文件名选项框：

如果‘全部大写’单选按钮被选中，则文件名全部转为大写；
如果‘全部小写’单选按钮被选中，则文件名全部转为小写；
如果‘首字母大写’单选按钮被选中，则出现在文件名的第一个字母转为大写；
如果‘首字母小写’单选按钮被选中，则出现在文件名的第一个字母转为小写；

扩展名选项框：

如果‘全部大写’单选按钮被选中，则扩展名全部转为大写；
如果‘全部小写’单选按钮被选中，则扩展名全部转为小写；
如果‘首字母大写’单选按钮被选中，则出现在扩展名的第一个字母转为大写；
如果‘首字母小写’单选按钮被选中，则出现在扩展名的第一个字母转为小写；


MP3标签

E-F_Rename

MP3标签

在预定义方案中，定义了一些常用的方案：

如果选择ID3v1.x优先单选按钮，则系统会优先读取ID3v1.x标签，如果没有发现ID3v1.x标签，则会继续读ID3v2.x标签；

如果选择ID3v2.x优先单选按钮，则系统会优先读取ID3v2.x标签，如果没有发现ID3v2.x标签，则会继续读ID3v1.x标签；

命名规则：

#1 - 艺术家
#2 - 歌曲名
#3 - 专集
#4 - 音轨
#5 - 年代
#6 - 流派

用户可以在命名规则编辑框中输入上面代号的不同组合来符合自己的要求，如：

#1#3#2

代表新的文件名为：艺术家专集歌曲名.mp3

用户也可以在不同代号之间加入一些其他的字符串，如：

#1-#3<#2>

代表新的文件名为：艺术家-专集<歌曲名>.mp3


软件设置

E-F_Rename

软件设置

如果自动预览复选框被选中，那么在用户对命名规则修改的过程中，将实现自动预览；

技巧：如果批量更名的数量很大，可以在预览的项目数设置一个合适的数值，可以提高预览速度；

如果选中了预览全部单选按钮，则预览全部的文件。

如果自动预览复选框没有被选中，那么在用户对命名规则修改的过程中，将不会自动预览；

预览框背景的颜色：单击旁边的颜色选择器，设置预览框中的背景颜色

预览框字体的颜色：单击旁边的颜色选择器，设置预览框字体的颜色

预览框字体的大小：单击旁边的字体...按钮，设置预览框字体的大小


联系作者

E-F_Rename

本软件使用易语言编写，大连大有吴涛易语言软件开发有限公司官方网址:http://www.dywt.com.cn