蜘蛛牌1.1版相对于1.0版的修改：
1,修正了发牌后撤销时程序出现错误问题;
2, 在“游戏”菜单上，添加了“显示可行操作”子菜单;
3,源代码中英文变量名作了大部分的修改。

不足：
1, 调试水平有限，未能解决“多次无规律移动牌桌上的牌会出现 牌的位置错误 也就是不可能出现的排列 并且牌的坐标也会出错”的问题;
2, 未能“更换图片框移动的算法“，也未能“提高运算效率”。

反思后觉得应该是整体设计思路上就有问题。希望有兴趣的朋友能全部重写代码，达到或者超过WINXP自带蜘蛛牌游戏的功能和运行效率。

作者姓名：MGX
公司名称：大连大有吴涛易语言软件开发有限公司
主页地址：http://www.dywt.com.cn


蜘蛛纸牌概述

“蜘蛛纸牌”游戏的目标是以最少的移动次数将十叠牌中所有最前面的牌都移走。

如要将十叠牌中所有最前面的牌都移走，请将牌从一列移到另一列，直到将一牌套从 K 到 A 依次排齐。当一组牌从 K 到 A 依次排齐时，这些牌就会被移走。

蜘蛛纸牌玩法

  1. 在“游戏”菜单上，单击“开局”。

    “蜘蛛纸牌”用两副牌玩。新一局游戏开始时，发有十叠牌，每叠中只有一张正面朝上。其余的牌放在窗口右下角的五叠牌叠中；新一轮发牌时用这些牌。

  2. 移牌的方法是将牌从一个牌叠拖到另一个牌叠。移牌的规则如下：
    • 可以将牌叠最底下的牌移到空牌叠。
    • 可以将牌从牌叠最底下移到牌值仅次于它的牌上，不论牌套或颜色如何。
    • 可以像对待一张牌一样移动一组同样牌套、依序排好的牌。
  3. 准备新一轮发牌时，请单击"游戏"菜单中的“发牌”，或者单击窗口右下角的牌叠。或者

    按F5键，在新一轮发牌之前，每一叠中都必须有牌。

注意

  • 如要以不同的级别开始新一局游戏，请单击“游戏”菜单上的“选择级别”，然后选择某种难易级别。
  • 如要查看或清除游戏记录信息，请单击“游戏”菜单上的“记录”。
  • 如果要打开保存的游戏，请单击“游戏”菜单上的“打开保存的牌局”。
  • 如果要保存当前的游戏，请单击“游戏”菜单上的“保存现在的牌局”。
  • 想设置退出时自动保存等选项，请单击“游戏”菜单上的“游戏选项”。

“蜘蛛纸牌”中的得分

每局“蜘蛛纸牌”开始时有 500 分。根据下列规则可能会加分或减分：

  • 每移动一次牌或者撤消一次丢一分。
  • 每次将整个牌套按顺序从 K 排到 A，则该套牌将从玩牌区移走，并且您会得 100 分。

策略与技巧

并非每一局“蜘蛛纸牌”都可以取胜，但如果细心设计策略，则会有更多的获胜机会。

  • 在发新一行牌之前：
    • 从窗口前面的十叠牌叠中移开一些牌，方法是将它们按从 K 到 A 的顺序依次排到匹配的牌套中。
    • 创建匹配牌套叠。
    • 用非匹配牌套创建牌套以便翻开更多的牌。
    • 将牌移到空牌叠位置以便可以翻开更多的牌。
    • 在“游戏”菜单上，单击“显示可行的操作”以查看是否还有合法的操作。还可单击屏幕底部的得分框。
  • 只要移走了一个牌叠，就要把其余的牌排到匹配的牌套中去。
  • 重新排牌时，用空牌叠做临时存储区。
  • 如果还有新行需要发排，则不要创建多个空牌叠。发新一行牌时，每个牌叠必须至少包含一张牌。因此，单击“发牌”之前空牌叠中必须要有牌。

作者信息

作者姓名：MGX(偶尔死机)
公司名称：大连大有吴涛易语言软件开发有限公司
主页地址：http://www.dywt.com.cn


Easy CHM - http://www.eTextWizard.com

这个CHM由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM - 版本: 1.95 软件出品: 国华软件 中国北京 |  | 截屏图片
更新日期: 2004-10-26 | 文件大小: 1392k - 1.39MB | 软件类型: 共享软件 注册费用: 人民币 99 元
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • 支持导入任意的文件类型；
  • 自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 批量更换CHM目录各项的图标；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件。
  • 内嵌CHM反编译工具。
  • 用户可以保存和打开工程文件。

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。

联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
通过“共享软件注册中心”购买
直接向作者注册（共2种方式）：

1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 汇出行

  • 操作号

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000
安装支持: 支持安装及卸载