系统简介

翠薇书店管理系统

1、系统简介:
这是一套专业的图书出租管理系统，没有花哨的的乱七八糟的无用功能，是为小型图书出租店量身定做的。租金计算方法灵活，设置方便，可以对新旧书分开计算。（^_^,嘻，外甥在学校边开小书店，因手工管理太麻烦还容易出错，想找个图书管理软件来管理，结果我帮他找一堆都不适用，那些软件都是功能太多太杂要的功能没有不要的一堆，所以才下决心写了这个软件。）本系统的最大特点就是一个字——“专”，绝对适用于小型图书出租店。（并且可以按用户需求改动，为你量身定做）

2、推荐配置：

操作系统：中文 Windows XP

屏幕分辨率：1024*768像素 增强色16位以上

其它要求：要绝对地保证无病毒，否则会引起数据错误！切记！(请经常性备份数据库）


用户登录：
您可以选择是书店老板方式还是书店员工方式登录，书店员工不能清算帐簿，也不能对图书管理系统进行设置（可以根据你的要求改动）。为了您测试方便默认是没有密码的，如果投入实际使用，为了您的数据安全请一定要设置好您的登录密码！
注意：在进入系统前一定确保目前的时间是正确的，如果不正常请先调整过来，在“请先校时”里选择正确的时间，再按“调整”按钮就可以调整您的时间了！切记一定要校准了，*_^ 不然钱收少了可不要怪我，嘻嘻！


新书入库：
图书编号和书名是必需填的，图书编号只能是数字且不能重复！默认的图书编号格式为“XXXXX-XX”，比如《三国》有3本，那么它的编号就是：000001-1、000001-2、000001-3 三本，您只要在①处填上000001，②处填上起始编号1（默认就是1），③处填上结束编号3，再把书名和其它信息填好，按一下添加按键，就会自添加000001-1、000001-2、000001-3 这三本书，并且①处的数字将自动变为000002，您就可以断续添加下一本书了。如果您下次又去购入三本《三国》，那么您只要在①处填上000001，②处填上4，③处填上6，再把书名和其它信息填好，按一下添加按键，就会自添加000001-4、000001-5、000001-6 这三本书，以此类推……（哈，方便吧）其它地方按说明填就行了，黄色部份是书名的简写，默认就是书名的首拼音，见意不要改动！如果你想每次添加完图书后就把内容清空，将下面的清除选上就可以了。
说明：因编号的方法可能各不相同，如果方便的话请改用我这种“XXXXX-XX”的方法，如果你已经用另一种方法而且不方便改过来的话，请您联系我为你量身定做，只要您的编号是有规律的，那就没问题！

图书类型管理：
按下④处将出现上图的图书类型管理窗口，在这里您可以对您的图书类型进行管理。添加新类型：在编号处填入编号，类型出填入具体类型内容，按添加就可以添加新的图书类型，虽说编号可以自己随便编，不过为了美观，最好按现在有顺序往下编（编号就是在最上面的图书登记窗口的图书类型框里的显示顺序，您可以根据您书店的实现情况于以更改。修改类型：理更改时请先选中要修改的图书类型，这时其内容会在上面编号和类型框里显示出来，改动后按下修改就可以了（如果这个类型以前已经在使用的，那么修改的时候会将以前的所有此类型的图书的类型都改为现在的新类型名称）。删除类型：选中要删除的类型，按下删除按钮就可以了，不过见意最好不要删除已经使用过的类型！


会员登记：
会员编号可以是数字，也可以是字母加数字等格式。推荐用“0000X”的数字格式！数字格式支持自动编号，要是加了字母，您只能一个一个的改了。如果编号有规律的话也可以联系我帮您改成自动方式。联系号码可以填写QQ号、电话、手机等，有效证件可以填写身份证、学生证等证件号。会员类型目前分为四级（已经足够用了，嘻，多了就乱了）各级会员的优惠政策可以在设置里改。默认初级会员：不打折，每本书还要交5元押金；中级会员：不打折，也不用交押金；高级会员：打8折，不用交押金；VIP会员所有的书租金一律0.5元。
说明：因编号的方法可能各不相同，如果方便的话请改用我这种“0000X”的方法，如果你已经用另一种方法而且不方便改过来的话，请您联系我为你量身定做，只要您的编号是有规律的，那就没问题！


租借管理

租借管理（图书出租）：
在会员编号框①里输入会员编号，如果会员忘了编号可以在按下后面的查找按钮②进入会员查找窗口找到后双击就可以将会员编号自动填写进来，按回车将自动显示此会员的相关信息！图书编号③的用法和会员编号一样，第一次按回车显示图书信息，第二次按回车将自动添加这本书到借书记录框④里（相当于按了一次租借确认）在租借确认前请先看清本书押金框、日租金框、租书日期框里的内空是否正确！（一般情况下是不会错的，嘻）这几个框里的内容都是可以改的，押金请您收多少就填多少！
说明：（ [image] 标记的是旧书！ 标记的是新书。）本系统可以对新书和旧书租金计算方法分开管理（本计费方法是本图书管理系统所独创）具体信息请见设置！

以上为租借管理的图书出租部分！现在请按下⑤转结账操作，系统将进入以下窗口！在借书记录被选中的情况下也会自动转入下面的窗口！

租借管理（图书归还）：
选中客户此次归还的书（在前面的选择框里打上钩），也可以用下面的全选和全清单选框选中全部或清空全部，再按一下结帐归还按钮就可以完成还书的业务了。可以在①处选择是从帐户上扣，还是现金支付，还是欠着先！
注意：借书记录框里显示的是所有帐未清的图书信息，如果书已还帐未清，也主是说还欠着的，那么也会显示出来。下次结帐的时候选上再按结帐归还就可以了。因为有些学生客户一时没我要欠着先，下星期才来结帐，嘻，方便吧！！（又是本系统的一大特色也）

会员（图书）查找：
 上图一张是会员查找窗口，一张是图书查找窗口，都可以选按拼音查，还是按名称查。查出来的效果就是上面那样的！双击某项就会将其内容自动填入调它出来的窗口。在会员充值的时候些窗口也会用到，自己可以试下！


会员充值：
会员充值比较简单，分为充值和退钱，可以对任意会员充值！在还书时如果此类会员要从帐上扣，但是帐上又金额不足的，会自动弹出此窗口。平时可以按下菜单或工具条上的会员充值按钮对其进行操作！


图书管理：
按下图书管理，将出现上面的窗口，在这里将显示您店里的所有图书信息。 标记的为已经借出去的书， [image] 标记的为已经丢失的书； [image] 标记的为在库的书。排行榜显示的出借次数前10位的书，方便您了解哪些书比较受欢迎！国书信息框里显示的您所有图书的统计信息，可以单击相应的文字将在右边列出其明细记录。比如单击“丢失图书XX本”那里就会在右边列出所有丢失的图书。这么多本书，想找某一本怎么办，嘻，当然有办法了。单击①处弹出（见附图1）选中其中的一种查找方式后，将查找内容填入②处，按下查找按钮就可以了，找到后会在右边的列表框中列出来。在右边的列表框中双击某本书，将弹出修改图书信息窗口，可以对这本书进行修改！

附图1：

图书修改（丢失处理）：
先打开图书管理 ，找到您要修改的图书，然后再双击，就会出现上面的窗口！除了编号不能改外，其它的都能改。如果这本书丢了，请选中丢失选择框①，按下修改就可以了，不要用删除！


会员管理：
按下会员管理，将 出现上面的窗口，在这里将显示您店里的所有会员信息。 标记的为初级会员， [image] 标记的为中级会员； [image] 标记的为高级会员 [image] 标记的为VIP会员。排行榜显示的出借书次数前10名的用户，方便您了哪些客户租书比较多！会员信息框里显示您所有会员的统计信息，可以单击相应的文字将在右边列出其明细记录。比如单击“VIP会员”就会在右边列出所有VIP会员的名单。如果想找某位会员可以：单击①处弹出（见附图1）选中一种查找方式后，将查找内容填入②处，按下查找按钮就可以了，找到后会在右边的列表框中列出来。在右边的列表框中双击某个人，将弹出修改会员信息窗口，可以对这位会员进行修改！
附图1：

会员修改：
先打开会员管理 列表，找到您要修改的图书，然后再双击，就会出现上面的窗口！除了编号不能改外，其它的都能改，甚至可以在这里直接改动会员的帐户金额！嘻，不用去打开充值窗口直接在这里改就行了。


租借列表：
按下租借列表，将出现上面的窗口，在这里将显示您上次清算以后到现在的所有图书出租情况。 标记的为帐已结清，也就是说书已经还过来并且收到钱了的借书记录； [image] 标记的为帐没结清的记录；如果此时清理帐簿所有标有 [image] 的记录都将删除，标有 [image] 的一直保留到下次帐结清为止才可以删除。排行榜显示的是出借时间最早的10本书，方便您了解哪些书借出去很早了没还的！租借信息框里显示的是所有借书记录的统计信息，可以单击相应的文字，将在右边列出其明细记录。比如单击“还而未清：X本”那么又边的列表框里就会表出所有书已经还了，帐还没结清的借书记录。如果想找某条借书记录，可以单击①处弹出（见附图1）选中一种查找方式后，将查找内容填入②处，按下查找按钮就可以找到了。选中某条记录双击，将弹出该会员的租借管理窗口，您可以对其进行操作，具体操作方法请参照租借管理说明！

附图1：


修改密码：
在系统维护菜单，如果您是老板，那除了可以修改自己的密码外，还可以修改员工的密码。如果您是员工，那么只能修改自己的密码了。在新口令框里输入新的密码，然后在确认口令框里再输入一次，嘻嘻，就是怕你万一输错了字，安全第一吗。再按下修改按钮就可以了，下次登录的时候请使用新密码、。
说明：如果万一不小心忘了密码，可以找作者处理！


利润统计：
对您使用本系统以来的利润进行统计，分为：以前收入（帐簿清理前的所有收入）；本期收入（还没清理的本期收入）；图书押金（所有客户的押金）；客户帐户（所有先交钱用户的帐户余额和）。


帐簿清算：
按下帐薄结算按钮后，将出提示信息图1，如果按否，将返回不做操作！按是的话就会出现提示信息图2。帐薄结算可以每天进行，也可以一个月，一星期进行一次，当然也可以随时进行，就看你的喜好了。嘻！
说明：帐簿结算后，所有结算前的帐已结清租借记录都将删除，也就是说租借列表中所有带 [image] 的信息都将删除，所以见意一个月或是一星期结一次，不用天天结！


系统设置：
①设置界面风格：可以设为蓝色风格、绿色风格、银色风格三种风格，当然也可以设为无风格，不过不推荐设为无风格，因为那样会很难看，嘻嘻！
②如果您想每次关闭系统前自动备份数据库，那么就把这个选上。为了您的数据安全，默认是选中的！
③设置区分新旧书的时间，这时间以内（包括这时间）的为新书，新旧书可以分开管理！
④设置借书时间超过此天数还没还的，将在进入系统前给于提醒！
⑤到⑧是关于新旧书租金计算的相关设置，⑤处填入1，⑥处填入1，那么客户借1本书，1天后是1元，2天后是2元，3天后是3元；借2本书，1天后是2元，2天后是3元，3天后是6元；⑤处填入2，⑥处填入3，那么客户借1本书，1天后是1元，2天后是2元，3天后是3元；借2本书，1天后是2元，2天后是还是2元，第3、第4天者是4元；第5、6天就是6元，以此类推。默认方案是新书一天翻一倍，旧书一次性借2本或2本以上，那么2天才翻一倍！
⑨如果自动选中，那么旧书的翻倍天数将根据当天所借旧书的本数自动计算！

说明：嘻，算钱方法实在太多，如果您的算钱方法和这些都不一样，可以告诉我一声，帮您改成你所要的！

此设置窗口是设置会员的相关内容的，上面已经写的很清楚了，我就不在废话了！0.8就是打8折的意思，如果还有什么不明白的直接Q我就行了。


如何购买

 本程序由易语言编写,易语言网址为:http://www.dywt.com.cn
易语言公司授权正版用户可以任意使用本程序.