注册 UltraCompare
下一主题

提供给 UltraCompare 的用户名和授权码区分大小写，必须完全按照从 IDM Computer Solutions, Inc. 收到的内容输入。

最方便、最值得推荐的输入注册码的方式，是从 IDM 发来的邮件里使用剪贴板复制（选择它并复制到剪贴板），然后将其粘贴到授权对话框的编辑框内（使用 Ctrl+V）。

请注意，如果用户名包括对用户数的引用，即：

"Acme Printing~ 8 User License"

它是注册名的一部分，必须与“Acme Printing”一道输入。

如果您无法正确注册 UltraCompare，请发送电子邮件到 info@ultraedit.com.cn，说明您准备注册什么版本的 UltraCompare 以及您在用户名和注册码里输入的确切内容。我们将尽快回复您，并提供信息帮助您注册许可。


使用 UltraCompare

UltraCompare 可用于比较两个文件或两个目录的内容（如果选择“循环比较”选项则可以比较更多）。可以使用几种方法调用它，取决于您希望的操作和正在运行哪个版本（参见 打开文件 或 打开文件夹 ）。

请注意：如果正在运行 UltraCompare Lite ，则您只能在 UltraEdit-32 运行的同时运行 UltraCompare。无论 UltraEdit-32 是否运行，UltraCompare Pro 都可以运行。

UltraCompare 的默认视图是分割为上方有菜单和工具栏的两个窗格（以便比较文件）。有关打开和比较文件和文件夹的详情，请参见 打开文件 、 打开文件夹 或 命令行选项 。


差异导航

有两个非常有用的方式可以在比较两个文件时，导航由 UltraCompare 检测到的差异： 查看下一个差异和查看上一个差异 按钮，位于比较窗格左侧显示的工具栏和图形化导航图上。

点击查看下一个差异按钮或按 F3 将把光标定位于活动比较中的下一个差异，而点击查看上一个差异或按 F4 将把光标定位于活动比较中当前光标位置之前的上一个差异。这些给用户提供了简易的方式依次步进浏览差异，而无需手动查找它们。这些可用于导航所有差异，包括文本比较、二进制（智能）比较、二进制（快速）比较和目录比较。

在文本比较模式中，当活动行属于差异文本块中的一部分时，用户可以按 F7 移动到块中的下一个差异，按 F8 将移动到块中的上一个差异。

文本比较中图形化导航图显示在比较窗格的左边。它默认地以可滚动模式显示。如果愿意，可以点击“视图”菜单中的可缩放图/可滚动图来切换到可缩放图，而不是可滚动导航图。该模式里差异显示为两个比较文件的完整视图，而不是显示为可滚动图。

比较文件的匹配区域在导航图里以白色块表示。发生差异的区域以蓝色块（默认）表示。双击图形化导航图将相应地排列比较的文件。它允许非常迅速地在文件内进行点到点导航，而无需依次步进跟踪差异，并提供了比较文件之间差异数量的简捷概述。该空间内的红色矩形框表示正在比较文件的可视部分。


三方差异导航

查看下一差异 [1] 和 查看上一差异 按钮 [2] 位于工具栏和图形化导航图 [3]上（显示于比较窗格的左边和右边），是比较文件时浏览 UltraCompare 检测到的差异的两个有力工具：

点击查看下一个差异按钮 [1] 将光标置于活动比较（文件对之间有高亮栏 [4]）中的下一个差异，而点击查看上一个差异按钮 [2] 将把光标置于活动比较中当前光标位置之前的上一个差异。它们都给用户简易的方式依次步进跟踪差异，而无需手动查找它们。这些可用于浏览所有差异，包括“文本比较”、“二进制（智能）比较”、“二进制（快速）比较”和“目录比较”。

图形化导航图 [3] 在三方文本比较中显示于比较窗格的左边和右边。它默认显示为可滚动模式。如果愿意，您可以点击“视图”菜单里的可缩放图/可滚动图切换选项，以切换到可缩放图而不是可滚动导航图。在该模式里，差异以两个比较文件的全文显示，而不是显示为可滚动的图。

双击图形化导航图 [3] 将相应地排列比较的文件。它允许非常迅速地在文件内进行点到点导航，而无需依次步进跟踪差异，并提供了比较文件之间差异数量的简捷概述。在此区域显示的红色矩形框代表正在比较文件的可视部分。

差异突出显示

重要！注意：在三方文本比较里，用于突出显示比较框背景的颜色，即时提供了关于所有三个文件的有用信息，而在状态栏[5]和附加框里显示的信息仅适用于活动的文件对（表示为框之间的高亮垂直栏和状态栏中的“Pair [1 - 2]”文本）。

背景颜色 | 含义
白 | 这些区域内的数据匹配活动的框
蓝 | 这些区域内的数据不同——指示符参见下列符号
蓝渐褪到白 | 这些区域内的数据与一个比较框不同但匹配另一个比较框——该背景突出显示将仅能在 Frame 2 里看到
垂直的蓝条 | 表示空行（无数据、无硬回车）- 通常由于添加点划线到一个框架而导致，该框架用于容纳在一个文件里出现而在另一个文件里不存在的数据

比较符号 | 含义
!> | 数据存在于右侧框但不在左侧框里
<! | 数据存在于左侧框但不在右侧框里
!! | 此处仅存在空行
* | 数据存在于两个框但却不同


三方文件夹导航

UltraCompare Professional 的 v3.10 版本支持需要时同时比较三个不同的目录。 该模式还可以用于比较 .zip 文档的内容和文件系统上文件夹的内容。

全部、仅差异、仅匹配 [1] 按钮允许用户切换在文件夹比较中显示的内容，并有助于在复杂的比较中聚焦到所需的项目上。

点击查看下一个差异按钮 [2] 将把光标置于活动比较中的下一个差异，而点击查看上一个差异按钮 [3] 将把光标置于活动比较中当前光标位置之前的上一个差异。 它们都给用户简易的方式依次步进跟踪差异，而无需手动查找它们。这些可用于所有比较模式的导航。

点击循环比较 [4] 按钮将切换正在进行比较的文件夹的“深度”。如果选中它，则 UltraCompare 将比较指定根目录下的所有子目录，并说明包含的子目录是否匹配。如果未选中循环比较，则比较结果将显示子目录存在或不存在于比较文件夹里，但不会评论其内容。

单击任何列的标头（文件名、状态、日期、大小、文件类型）将根据该列的内容排列结果。 右键单击列的标头会出现子菜单，用户可以从中选择文件夹比较中要显示的列。

图标窗格 [5] 提供比较项目状态的简捷形象化概述。它说明这些项目是否较新、较旧或包含等同内容，以及在比较文件夹里是否存在或缺少项目。

状态栏 [6] 指示图标面板 [5] 中显示的概要描述（位于最右侧），如“不同”、“匹配”或“没有可供比较的”。

文件夹符号 | 含义
 | 缺少引用的文件
 | 存在引用的文件
 | 引用的文件比主文件旧
 | 引用的文件夹与主文件等同
 | 引用的文件夹比主文件夹新
 | 缺少引用的文件夹
 | 存在引用的文件夹
 | 引用的文件与主文件夹不同
 | 引用的文件与主文件夹等同


命令行选项

UltraCompare Professional 的命令行选项

uc.exe [选项] <path1> <path2>

选项：

-t | 文本比较模式
-3 | 三方文本模式
-p | 快速二进制比较模式
-x | 智能二进制比较模式
-d | 文件夹比较模式
-w | 三方文件夹比较模式
-i | 在文本比较模式中忽略大小写
-b | 在文本比较模式中忽略空格
-B | 在文本比较模式中忽略空行
-lt | 忽略换行符
-r | 在文件夹比较模式中递归比较文件夹
-ft | 强制所有文件在文件夹比较模式下按文本进行比较
-fb | 强制所有文件在文件夹比较模式下按二进制进行比较
-a | 设置“显示全部”
-m | 设置“显示匹配”
-ne | 设置“显示差异”
-o | 创建输出文件
-qc | 执行逐字节的快速差异检查直到检测到第一个差异
-rom | 只读合并模式

可以从命令行调用 UltraCompare，指定提交输出结果的文件并使用以下格式：

uc.exe -o <path1> <path2> <输出文件路径>

例如,如果使用：

uc -t -o "c:\temp\test1\test1.txt" "c:\temp\test2\test2.txt" "c:\temp\output.txt"

那么文件 test1.txt 和 test2.txt 在指定的两个目录中将进行比较，且输出结果将自动写入 output.txt 文件。

如果使用：

uc -3 -o "c:\temp\test1\test1.txt" "c:\temp\test2\test2.txt" "c:\temp\test3\test3.txt" "c:\temp\output.txt"

那么文件 test1.txt, test2.txt 和 test3.txt 在各自的目录中将进行比较，且输出结果将自动写入 output.txt 文件。

针对文本的比较选项

快速差异检查“-qc”和只读合并模式“-rom”操作符是只针对文本的选项，因此不需要“-t”选项。 例如：

uc -qc <path1> <path2>

可以让 UltraCompare Professional 比较指定的两个文件。 在找到第一个差异之前将执行逐字节的检查。 检测到差异后应用程序将返回“差异”状态，否则将返回“相同”。

由于 windows 程序没有 stdin、stout 和 stderr，因此创建了名称为 uc.com 的可执行文件来将信息返回给命令行。 要在 windows shell 中使用该功能，可以输入可执行程序的名称“uc”（或“uc.com”），使用适当的参数，com 文件将执行加载 uc.exe，通过命令行并与应用程序建立联系通道。 这使得用户在执行快速差异命令行选项时能够收到相同或不同的消息。 这与 MSDEV 和命令行交流的方式相同。

对于只读合并模式，必须使用以下语法：

uc -rom <path1> <path2> <path3>

<path1> 和 <path2> 指定要比较的文件，但目的不是为了在比较/合并的过程中修改原始文件。 在 <path1> 中指定的文件将复制到 <path3> 进行比较/合并。 在 <path3> 中指定的文件将显示在左窗格，在 <path2> 中指定的文件显示在右窗格中。 请注意：仅可能合并到 <path3> 指定的文档中。 用于比较的文件将锁定为“只读”。

请注意：无法从命令行调用 UltraCompare Lite。


上下文菜单选项

UltraCompare 中的上下文菜单提供了在文本比较模式和文件夹比较模式下的一些非常有用的特性，用于文件管理、差异合并和目录导航。

在“文本比较”模式中有以下命令：

在 UltraEdit 中打开 | 将选中文件在 UltraEdit 打开进行编辑
合并第一个到第二个 | 将选中的内容从左向右合并
合并第二个到第一个 | 将选中的内容从右向左合并
高级合并 | 从左边到右边（或从右到左）合并选择到有差异的行之上或之下，而不覆盖现有文本
全部接受 | 接受指定文件所有合并的更改
剪切 | 从活动文档中删除选中内容并将其移至剪贴板
复制 | 将选中内容从活动文档复制到剪贴板
复制框架到剪贴板 | 将活动框架中的内容复制到剪贴板（如果应用则遵守筛选）
粘贴 | 从剪贴板将数据粘贴到活动文档中
删除文件 | 从磁盘中删除档案
清除 | 清除活动比较窗格的内容
删除选定的行 | 仅在文件中删除选中的行
添加行到书签 | 将选中的行添加到当前书签导航列表
浏览第一个文件夹 | 打开浏览器查看源目录
浏览第二个文件夹 | 打开浏览器查看目标目录
在浏览器中显示文件 | 在系统默认的浏览器中显示当前文件
刷新 | 重复比较以刷新显示的差异

在二进制（智能或快速）比较模式中，上下文菜单中只有在 UltraEdit 中打开文件、删除文件、浏览第一个/第二个文件夹、在浏览器中显示文件和刷新选项可用。

在“文本夹比较”模式中有以下命令：

在 UltraEdit 中打开 | 将选中文件在 UltraEdit 打开进行编辑
合并第一个到第二个 | 将选中的文件从左侧目录向右侧目录合并
合并第二个到第一个 | 将选中的文件从右侧目录向左侧目录合并
全部接受 | 接受指定文件所有合并的更改
删除选定文件/文件夹 | 从活动目录中删除选中的文件/文件夹
浏览第一个文件夹 | 打开浏览器查看源目录
浏览第二个文件夹 | 打开浏览器查看目标目录
显示预览文件 | 切换比较中活动文件的文本文件预览是否可见
载入第一个文件 | 显示子菜单，可以从中选择进行文本比较的文件要加载到哪个框架
在浏览器中显示文件 | 在系统默认的浏览器中显示当前文件
刷新 | 重复比较以刷新显示的差异

在“三方文本夹比较”模式中有以下命令：

在 UltraEdit 中打开 | 将选中文件在 UltraEdit 打开进行编辑
合并第一个到第二个 | 将选中的文件从第一个目录向第二个目录合并
合并第二个到第一个 | 将选中的文件从第二个目录向第一个目录合并
合并第二个到第三个 | 将选中的文件从第二个目录向第三个目录合并
合并第三个到第二个 | 将选中的文件从第三个目录向第二个目录合并
合并第一个到第三个 | 将选中的文件从第一个目录向第三个目录合并
合并第三个到第一个 | 将选中的文件从第三个目录向第一个目录合并
全部接受 | 接受所有指定的合并更改
删除选择的文件/文件夹 | 从活动目录中删除选中的文件/文件夹
浏览第一个文件夹 | 打开浏览器查看第一个目录
浏览第二个文件夹 | 打开浏览器查看第二个目录
浏览第三个文件夹 | 打开浏览器查看第三个目录
显示排除对话框 | 显示对话框，在此用户可以选择要从活动比较中排除的文件/文件夹
显示预览文件 | 切换比较中活动文件的文本文件预览是否可见
刷新 | 重复比较以刷新显示的差异


UltraCompare 版本

UltraCompare 有 Lite 和 Pro 两个版本。Lite 版本集成到 UltraEdit-32 中，并且只能从 UltraEdit-32 内调用。

下面包含一份特性摘要，显示出两个版本之间的区别：

Lite 版本：

* 需要运行 UltraEdit

* 必需从 UltraEdit 调用

* 仅支持“文本比较”（文件）

* 支持快速二进制比较，逐字节

Pro 版本：

* 是独立的应用程序，并且不需要运行 UltraEdit

* 支持“文件夹比较”（目录）以及“文本比较”（文件）

* 支持智能二进制比较，可以插入字节并重新排列

* 支持合并更改

* 包括 Lite 版本里找不到的附加工具栏项目

UltraCompare Pro 还有几个命令行选项，而 UltraCompare Lite 无法从命令行调用。


文件菜单

文件菜单在文本/二进制/文件夹比较过程中提供了以下命令：

打开第一个 | 调用“打开文件”对话框以指定要在“源”窗格里打开的文件
打开第二个 | 调用“打开文件”对话框以指定要在“目标”窗格里打开的文件
另存为 | 将活动窗格的内容保存为指定的文件名
关闭所有文件 | 关闭所有打开的文档
FTP - 从 FTP 打开 | 从 FTP 站点打开一个已有的文档
FTP - 另存到 FTP | 保存打开的文档到 FTP 站点的指定文件名
收藏 | 提供对话框以指定最常用的比较目录
保存合并的更改 | 保存先前合并操作期间的更改
保存结果 | 保存活动比较的结果摘要为文本文件
打印预览 | 在屏幕上按打印效果来显示结果摘要
打印设置/配置 | 显示“页面设置”对话框以配置打印设置
打印 | 打印结果摘要
打印第一个 | 仅打印左边文件
打印第二个 | 仅打印右边文件
预览第一个 | 在屏幕上按打印效果来显示左边文件
预览第二个 | 在屏幕上按打印效果来显示右边文件
退出 | 退出 UltraCompare

“文件”菜单在三方文本比较过程中提供了以下命令：

打开第一个 | 调用“打开文件”对话框以指定要在“Frame 1”窗格里打开的文件
打开第二个 | 调用“打开文件”对话框以指定要在“Frame 2”窗格里打开的文件
打开第三个 | 调用“打开文件”对话框以指定要在“Frame 3”窗格里打开的文件
另存为 | 将活动窗格的内容保存为指定的文件名
关闭所有文件 | 关闭所有打开的文档
FTP - 从 FTP 打开 | 从 FTP 站点打开一个已有的文档
FTP - 另存到 FTP | 保存打开的文档到 FTP 站点的指定文件名
收藏 | 提供对话框以指定最常用的比较目录
保存合并的更改 | 保存先前合并操作期间的更改
保存结果 | 保存活动比较的结果摘要为文本文件
打印预览 | 在屏幕上按打印效果来显示结果摘要
打印设置/配置 | 显示“页面设置”对话框以配置打印设置
打印 | 打印结果摘要
打印第一个 | 仅打印 Frame 1 文件
打印第二个 | 仅打印 Frame 2 文件
打印第三个 | 仅打印 Frame 3 文件
预览第一个 | 在屏幕上按打印效果来显示 Frame 1 文件
预览第二个 | 在屏幕上按打印效果来显示 Frame 2 文件
预览第三个 | 在屏幕上按打印效果来显示 Frame 3 文件
退出 | 退出 UltraCompare


打开第一个/第二个/第三个

打开第一个/第二个/第三个（文件菜单）

这些命令调用“文件打开”对话框，可以用于指定在 文本比较 模式中打开比较的文件。同样的机制也可以用于 文件夹比较 模式来指定打开比较的目录。


从 FTP 打开

从 FTP 打开（文件菜单）

这个命令会显示一个自定义对话框，允许选择要浏览的站点/帐号。

这个命令显示一个配置帐号的列表，并且可以选择任何帐号。如果从列表中选择了一个新帐号， UltraCompare 将自动尝试连接到站点并浏览该站点。

每个要连接的站点都必须配置一个新帐号，每个站点均可使用不同的名字、密码、目录等。

当这个对话框显示后，使用浏览按钮将显示该已连接站点的文件列表。 双击列表中显示的目录将尝试更改到指定的目录。

T目录列表可以通过在过滤文本对象中指定的过滤来显示过滤后的文件子集。另外，隐藏目录复选框可以使目录不显示。

要打开一个文件，双击文件或选择文件后点击打开按钮。将在文件传输时显示传输进程。

另外，更改目录按钮可以用于更改到自动输入的目录。

当在执行一个操作时，如果尝试开始其它操作，或请求取消该对话框，将显示一个警告。

当文件已经开始传输，或正在连接站点，该对话框将显示当前的状态。

按默认，在文件接收并打开后，如果设置了打开后关闭对话框选项，该对话框将被关闭。 可以取消这个选项使对话框保持打开。

在这个对话框中，还有一些可用的另外 FTP 功能:

刷新 | 从主机服务器刷新 (重新读取) 目录信息 创建目录
创建目录 | 不执行名字或语法检查。 从主机服务器返回的任何错误均会报告。
权限 | 允许在远程文件中设置文件权限。 这只能工作于可接受 FTP 站点命令 chmod 的服务器。通常仅为 UNIX/Linux 服务器。
比较普遍的是在 UNIX/Linux 服务器使用。 | 重命名 重命名主机服务器中的远程文件或目录
删除 | 删除主机服务器中的远程文件或目录
传输类型 | 允许使用 ASCII 或二进制两种传输类型设置帐号。二进制是不修改用字节对字节 方式传输文件。ASCII 会使文件在不同系统之间适当转换换行。
递归下载 | 允许用户指定文件夹模式 FTP 下载是否应从选定目录及其子目录中传输项目
显示日志 | 如果选中这个选项，在窗口中显示发送到 FTP 服务器和从 FTP 服务器接收数据的所有命令的会话日志，不显示目录列表。 用户可以在窗口内部重新配置，这个窗口的内容可以使用剪贴板进行复制。


另存到 FTP

另存到 FTP（文件菜单）

这个命令会打开一个自定义对话框，允许用户指定要浏览的站点/帐号。

这个命令显示一个配置帐号的列表，并且可以选择任何帐号。如果从列表中选择了一个新帐号， UltraCompare 将自动尝试连接到站点并浏览该站点。

每个要连接的站点都必须配置一个新帐号，每个站点均可使用不同的名字、密码、目录等。

当这个对话框显示后，使用浏览按钮将显示该已连接站点的文件列表。 双击列表中显示的目录将尝试更改到指定的目录。

目录列表可以通过在过滤文本对象中指定的过滤来显示过滤后的文件子集。

要保存文件，输入文件名，或点击现有的文件，然后点击另存为按钮。 在文件传输时，将显示传输进度。

当在执行一个操作时，如果尝试开始其它操作，或请求取消该对话框，将显示一个警告。

当文件已经开始传输，或正在连接站点，该对话框将显示当前的状态。

在这个对话框中，还有一些可用的另外 FTP 功能:

刷新 | 从主机服务器刷新 (重新读取) 目录信息 创建目录
创建目录 | 不执行名字或语法检查。 从主机服务器返回的任何错误均会报告。
权限 | 允许在远程文件中设置文件权限。 这只能工作于可接受 FTP 站点命令 chmod 的服务器。通常仅为 UNIX/Linux 服务器。
比较普遍的是在 UNIX/Linux 服务器使用。 | 重命名 重命名主机服务器中的远程文件或目录
删除 | 删除主机服务器中的远程文件或目录
传输类型 | 允许使用 ASCII 或二进制两种传输类型设置帐号。二进制是不修改用字节对字节 方式传输文件。ASCII 会使文件在不同系统之间适当转换换行。
显示日志 | 如果选中这个选项，在窗口中显示发送到 FTP 服务器和从 FTP 服务器接收数据的所有命令的会话日志，不显示目录列表。 用户可以在窗口内部重新配置，这个窗口的内容可以使用剪贴板进行复制。

在文件夹模式，选择“另存到 FTP”将显示“FTP 上传文件/文件夹”对话框，用户可以在其中指定要将哪些项目上传到 FTP 服务器。 通过 FTP 打开的并且包含于活动比较中的文件和文件夹，将在适当窗格的树形结构中列出：

已合并/修改的项目将显示为红色并自动选中用于传输。如果某文件夹有一个带绿色对钩的黑色框，这表示文件夹中的所有项目都被修改，并已选中来传输。如果某文件夹有一个带绿色对钩的绿色框，这表示文件夹中至少有一个项目被修改，并已选中来传输。按下上传按钮将启动传输。已选项目将使用该账户所选的传输类型来上传。


收藏

收藏（文件菜单）

该命令提供对话框，以指定常用的目录和文件。可以手动在列表窗格下面的文本框里输入目录或文件的完整路径，或使用浏览按钮来浏览需要的目录或文件。一旦输入/选择了一个路径，按下添加按钮将添加指定路径到“收藏文件/目录”列表供今后使用，并且您可以按下作为源打开或作为目标打开，在需要的窗格中打开指定的目录或文件。

另外，如果当前正在比较您希望添加到列表中的目录或文件，可以按下添加源或添加目标按钮，将活动的比较项目添加到“收藏文件/目录”列表。


保存合并的更改

保存合并的更改（文件菜单）

该命令保存当前比较会话中进行的所有合并更改，无论该更改是在哪个文件中进行的。它可以从 文件菜单 或工具栏中调用。该命令仅在合并操作之后才可用。

键盘快捷键：Ctrl+S


保存结果

保存结果（文件菜单）

该命令以文本格式保存活动文件比较的 结果摘要 。它可以从 文件菜单 或 工具栏 调用并打开“另存为”对话框，以便用户指定在哪里保存结果摘要，以及应如何命名。该命令在 文本比较 和 文件夹比较 中都活动。

键盘快捷键：Ctrl+R


打印预览

打印预览（文件菜单）

该命令按打印效果显示 结果摘要 。选择该命令时，主窗口将替换为打印预览窗口，结果摘要将在其中以打印格式显示。

打印预览工具栏提供选项用于启动打印作业、在结果摘要里前后移动、每次显示一页或两页、放大和缩小，以及关闭打印预览窗口。


打印设置

页面设置（文件菜单）

可以从文件菜单的打印设置/配置中访问页面设置对话框，该对话框包含可以用于设置页面页眉和页脚的 选项。 页眉（如果配置的话），将在每页的顶部打印出来。 页脚（如果配置的话），将在每页的底部打印出来。 如果配置了页脚或页眉，将在页眉页脚与打印的文本之间印出一条线。

选中相应的复选框，可以禁用页眉或页脚。 如果启用了页眉或页脚，也可以选择 禁用通常在页眉/页脚与页面文本之间打印的分割线。

页眉和页脚可以包含用户定义的文本，并可在页眉/页脚处使用文件名和页码等额外的特殊字符。

这些特殊字符有:

&f | 在页眉或页脚中替换为带路径的完整文件名。
&n | 在页眉或页脚中替换为文件名（不带路径）。
&p | 在页眉或页脚中替换为页码。
&t | 在页眉或页脚中替换为总页数。
&l | 用来使“&l”后面的文本对齐到页眉/页脚区域的左边。
&c | 用来使“&l”后面的文本对齐到页眉/页脚 区域居中。
&r | 用来使“&l”后面的文本对齐到页眉/页脚 区域的右边。

（注意 - 对齐字符不是必需的，它们其中的任何一个或全部都可以显示在单个页眉或页脚中。 但是，如果显示多个字符，则必须按照以上的顺序——“&l”必须在“&c”之前，且“c”必须在“&r”之前）。

此外，页眉或页脚可以包含文件 日期和时间，或系统日期和时间。 两个单选按钮允许选择在页眉或页脚上包含文件日期还是系统日期。 单选按钮选择日期和时间的来源，页眉页脚中使用的其他特殊字符可以指定是否打印日期和时间以及使用的格式。

下面显示的是用于指定时间和日期格式的字符,不使用下面这些字符将无法打印时间和日期。

下面列出的是日期和时间的格式代码：

格式 | 说明
%a | 星期几名称缩写
%A | 完整的星期几名称
%b | 月名称缩写
%B | 完整月名称
%c | 本地日期和时间的正确表示
%d | 用数字显示的每月第几天 (01-31)
%H | 用 24 小时格式显示的小时 (00-23)
%I | 用 12 小时格式显示的小时 (01-12)
%j | 用数字显示的每年第几天 (001-366)
%m | 用数字显示的月份 (01-12)
%M | 数字显示的分钟 (00-59)
%p | 用于 12 小时制的当前本地 AM/PM 标识
%S | 数字显示的秒 (00-59)
%U | 用数字显示的一年中的星期，每星期从星期日开始 (00-51)
%w | 用数字显示的星期 (0-6；星期天为 0)
%W | 用数字显示的一年中的星期，每星期从星期一开始 (00-51)
%x | 当前地理区域的日期表示
%X | 当前地理区域的时间表示
%y | 用数字显示的不带世纪的年 (00-99)
%Y | 用数字显示的带世纪的年
%Z | 时区名字或缩写；如果时区未知，则没有字符
%% | 百分比符号

例如:

日期是 1994 年 7 月 4 日，时间是 9:00pm

“%X , %x”打印为 “21:00 , 07/04/94”

日期是 1994 年 7 月 4 日，时间是 9:00pm

“%c”打印为 07/04/94 21:00

日期是 1991 年1 月10 日。时间为 5:00am

“%A, %B %d, %Y %I:%M%p”打印为 Tuesday, January 10, 1991 05:00:am

启用彩色打印

如果使用彩色打印机，该选项使 UltraCompare 按语法加亮的颜色打印文件。 如果使用 Postscript 单色打印机，则将显示灰色阴影。


打印

打印（文件菜单）

使用该命令打印 结果摘要 。该命令提供“打印”对话框，可以在其中指定打印页面范围、打印份数、目标打印机，以及其它打印机设置选项。

键盘快捷键：Ctrl+P


打印第一个/第二个/第三个

打印第一个/第二个/第三个（文件菜单）

使用该命令打印选定的文件。该命令提供“打印”对话框，可以在其中指定打印页面范围、打印份数、目标打印机，以及其它打印机设置选项。


预览第一个/第二个/第三个

预览第一个/第二个/第三个（文件菜单）

该命令显示按打印的效果显示选定的文件。当您选择该命令时，主窗口将替换为打印预览窗口，选定的文件将在其中以打印格式显示。

打印预览工具栏提供选项用于启动打印作业、在结果摘要里前后移动、每次显示一页或两页、放大和缩小，以及关闭打印预览窗口。


编辑菜单

编辑菜单提供下列命令:

下一差异 | 重新定位到比较文件中的下一个差异
上一差异 | 重新定位到比较文件中的上一个差异
查找 | 在归档文件中搜索指定的字符串
前往行/列号 | 在两个文件中重新定位光标到指定的行/列
剪切 | 从活动文档中删除数据并将其移至剪贴板
复制 | 将数据从活动文档复制到剪贴板
复制框架到剪贴板 | 将数据从活动文档中的已选行复制到剪贴板
粘贴 | 从剪贴板粘贴数据到文档中
删除选定的行 | 从活动文件删除已选行
删除选中的文件/文件夹 | 从活动目录中删除选中的文件/文件夹
书签 | 提供对话框，显示书签标记的行以便导航
添加书签 | 突出显示行号并书签标记活动文件中的活动行
删除书签 | 从已选行删除书签


下一差异

下一个差异（编辑菜单）

该命令将焦点移动到下一组标记为有差异的行中的第一行。

键盘快捷键：F3


上一差异

上一个差异（编辑菜单）

该命令将焦点移动到上一组标记为有差异的行中的第一行。

键盘快捷键：F4


查找

查找（编辑菜单）

查找命令提供“查找”对话框，用户可以在其中指定 UltraCompare 试图在活动文件中匹配的查找字符串。该对话框包括选项“仅匹配整个单词”和“匹配大小写”，以及方向选项允许用户指定 UltraCompare 应当在活动文件里向上搜索还是向下搜索指定的字符串。

键盘快捷键：Alt+F3


转到行号

转到行/列号（编辑菜单）

该命令显示转到行/列号对话框， 此对话框允许用户指定应该重置焦点到哪个行/列号，以及应该位于哪个文件（左边/右边）。 用户可以只输入一个行号，或可以选择在输入的行号后接斜线（/），再跟上一个列号。

只输入行号或按转到按钮将选中/高亮显示指定的行。 输入行号和列号后按转到按钮将选中/高亮显示指定的行,且在指定列的位置放置脱字符号“^”，如果需要则水平滚动。

键盘快捷键：Ctrl+G


书签

书签（编辑菜单）

当进行文件的文本比较时，可以右键单击从上下文菜单某行并选择添加行到书签，将活动行添加到书签列表。可以将多个书签标记的行添加到该列表。

点击“编辑”菜单里的“书签”， 将提供一个对话框列出当前指定的书签，您可以从该列表选择一行，并按下转到按钮跳转到指定的行。


查看菜单

查看菜单包含下列命令：

筛选 - 隐藏共有文件 | 隐藏所有框架共有的文件
筛选 - 隐藏唯一文件 | 隐藏并不是所有框架都有的文件
筛选 - 隐藏差异文件 | 隐藏所有框架不同的文件
筛选 - 隐藏相同文件 | 隐藏所有框架都相同的文件
筛选 - 隐藏带有不同时间戳的相同文件 | 隐藏所有相同但时间戳不同的文件
筛选 - 隐藏共有文件夹 | 隐藏所有框架共有的文件夹
筛选 - 隐藏唯一文件夹 | 隐藏不是所有框架都有的文件夹
筛选 - 隐藏差异文件夹 | 隐藏所有框架不同的文件夹
筛选 - 隐藏相同文件夹 | 隐藏所有框架都相同的文件夹
全部 | 显示比较的两个文件中全部内容
仅差异 | 仅显示有差异的行
仅匹配 | 仅显示完全匹配的行
差异居中 | 重新定位显示，使当前差异居中
差异摘要 | 显示对话框，列出有差异的块数和行数
显示行号 | 在比较文件里显示行号
显示空格/制表符 | 以可见字符显示空格、制表符和换行字符
显示预览文件 | 显示预览文件用于活动文件夹比较
切换自动换行 | 切换活动文档的自动换行状态
关系行模式 | 变化文本比较的形式，为匹配文本块之间有差异的块显示连接线和边框线
浏览器视图 | 显示子菜单，在此用户可以配置用于浏览器视图功能的模式
同步 | 使比较窗格同步以便同时垂直滚动比较中的两个文件
刷新 | 重复活动比较，更新源和目标窗格的显示


全部

全部（视图菜单）

该选项导致显示两个文件中的所有行。

键盘快捷键：Ctrl+A


仅差异

仅差异（视图菜单）

可以选择该选项，仅显示含有差异的行。这在比较与合并时会很有用。

键盘快捷键：Ctrl+D


仅匹配

仅匹配（视图菜单）

该选项仅显示比较文件中相同的行。

键盘快捷键：Ctrl+M


差异居中

差异居中（视图菜单）

该命令重新定位显示的文件，使当前的差异居中。


差异摘要

差异摘要（视图菜单）

该命令提供包含不同数据的信息对话框，取决于正在进行的比较类型。在 文本比较 过程中，这将汇总正在比较的两个文件之间不同的块和行数。

在 文件夹比较 过程中，结果的对话框将统计出比较文件夹里的文件差异及子目录差异。

键盘快捷键：Ctrl+D


显示行号

显示行号（视图菜单）

选择该选项将使比较文件的行号显示于每个文件内容的左边。在标识同样的行出现在两个文件中但在不同位置时此功能尤其有用，并有助于搞清哪些行仅存在于比较文件中的一个文件中（这种情况下行号将不显示于不出现比较的行的文件中）。

键盘快捷键：Ctrl+L


浏览器视图

浏览器视图（视图菜单）

浏览器视图子菜单提供“设置和遗忘选项”，表示不会更改原有的任何视图。 可用的选项有当前、其他和外部。 工具栏按钮在浏览器中显示也可以用于调用浏览器视图功能。 可以用于两方和三方比较模式。

如果按 F12 或在浏览器中显示工具栏按钮并选中当前，则将显示活动框架的浏览器视图。 这允许用户打开每个框架的浏览器视图。 每个框架的浏览器视图将显示该框架的内容。

如果调用浏览器视图并选择其他，则在“非活动”框架中显示浏览器视图。 这使用户可以并排查看源代码和 HTML 文件。对于三方比较模式来说，“其他”窗口总是为次要比较的窗口。 主要比较窗口的合并功能仅在进行三方比较时的其他模式中可用。

如果调用浏览器视图并选中外部，则活动框架的内容将在用户偏爱的浏览器中显示。 该模式不会因再次按 F12 或在浏览器中显示文件工具栏按钮而有所影响。 因此，每次按 F12 键或工具栏按钮都会显示新的浏览器或浏览器标签（如果该浏览器支持标签式浏览）。


同步

同步（视图菜单）

该选项同步比较窗格，以便通过在任一窗格中滚动，两个文件都可以同时垂直滚动。 默认为两个窗格同步。该命令用于重新建立同步，如果在合并过程或其它功能中失去同步。


刷新

刷新（视图菜单）

该命令重复活动比较，以保证显示所有最新的差异。当使用 在 UltraEdit 里编辑 选项在 文本比较 过程中修改一个活动文件之后，该功能非常有用，或者当文件/文件夹在 文件夹比较 过程中被修改时它也很有用。


模式菜单

模式菜单提供以下命令：

文本模式 | 切换活动比较到文本模式比较
三方文本模式 | 切换活动比较到三方文本模式比较
二进制（快速）模式 | 切换活动比较到二进制（快速）模式比较
二进制（智能）模式 | 切换活动比较到二进制（智能）模式比较
文件夹模式 | 切换到文件夹模式（活动的文件比较将丢失）
三方文件夹模式 | 切换活动比较到三方文件夹模式比较
关系行模式 | 将活动文本比较切换到关系行比较格式


文本模式

文本模式（模式菜单）

该选项允许用户切换活动的比较到文本比较，无论该项目选定时哪种模式活动。激活该模式后，将执行比较文件中文本的逐行比较。

如果是 Word 文档（.doc 文件）或 Rich Text Format（.rtf）文件，比较开始时文本字符串将从指定的文件中抽取到临时文件中，然后对这些文件进行比较。 由于 Microsoft Word 和 Rich Text Document 的复杂性，仅能够保存文本信息。 所有以前的格式将丢失。 建议重命名文件，因此点击保存时，UltraCompare Professional 将首先出现“另存为”对话框。


三方文本模式

三方文本模式（模式菜单）

该选项允许用户切换活动比较到三方文本比较，无论该项目选中时哪种模式活动。更多信息请参见 三方差异导航 。


二进制（快速）模式

二进制（快速）模式（模式菜单）

该选项允许用户切换活动比较到逐字节二进制比较（快速），无论该项目选定时哪种模式活动。


二进制（智能）模式

二进制（智能）模式（模式菜单）

该选项允许用户切换活动比较到块二进制比较（智能），无论该项目选定时哪种模式活动。与二进制（快速）模式比较的字节到字节方式相反，该比较模式将显示在有匹配代码块的地方，即使它们被插入/删除的数据偏移且在字节到字节比较中不匹配。


文件夹模式

文件夹模式（模式菜单）

该选项允许用户从活动文件比较模式（文本、快速/智能二进制）切换到目录模式。它首先显示空白的比较， 然后任何活动的文件比较都将被终止。 该模式允许用户比较 .jar、.rar 和 .zip 格式的档案内容以及文件系统中文件夹的内容。


三方文件夹模式

三方文件夹模式（模式菜单）

该选项允许用户切换活动比较到三方文本比较，无论该项目选中时使用哪种模式。更多信息请参见三方文件夹导航。


关系行模式

关系行模式（模式菜单）

该选项在文本模式比较或三方文本模式比较之间切换状态，使其以关系行显示而不是进行逐行比较。普通文本比较在比较的文件之间逐行搜索：

如果选中关系行模式，UltraCompare 将试图查找比较文件内容之间的匹配，并将其从差异比较中排除，同时直观地显示出它们之间的关联块和差异：

在关系行模式里有两种主要的差异需要注意：

图形化导航图 [1] 变化为并排显示两个比较的文件，而不是两个文件的一个复合差异图。这允许每个文件有一个独立的定位块（红色矩形），并图形化地指出两个文件间差异发生的位置。

UltraCompare 标识为比较文件中匹配文本区域之间存在的差异块，将使用与连接关联块的线相同的线作为边框。它们的颜色可以在选项菜单里的颜色下设置。

在不同的块偏移处（未平行显示）双击连接线，将使各文件中关联的块在显示窗格中居中。


选项菜单

选项菜单包含下列命令：

配置 | 提供了带有索引树的“配置”对话框，以便访问分类的配置选项
颜色 | 显示活动模式对应的“颜色和字体”对话框
设置过滤器 | 提供“设置过滤器”对话框，允许用户指定在“文件夹比较”里应该显示哪些文件类型
指定扩展名 | 显示对话框，便于用户指定要转化为文本或二进制文件的文件类型的默认扩展名（仅在 Pro 版本中可用）
比较列范围 | 显示对话框，在此用户可以输入最多四个需要比较的列的范围
忽略列范围 | 显示对话框，在此用户可以输入最多四个需要忽略的列的范围
文件夹模式筛选 | 为文件夹比较显示带有筛选选项的子菜单
文件忽略选项 - 忽略空行 | 在比较活动文件时强制比较忽略仅包含换行符的行
文件忽略选项 - 忽略空格 | 在识别活动文件中的差异时强制比较忽略制表符和空格
文件忽略选项 - 忽略大小写 | 在识别活动文件中的差异时强制比较忽略大小写
文件忽略选项 - 忽略换行符 | 强制比较忽略活动文件中的换行符差异（DOS/UNIX/MAC）
文件夹忽略选项 - 忽略时间戳差异 | 比较活动文件夹时强制比较忽略时间戳差异
十进制偏移 | 将二进制模式中显示的偏移从十六进制切换到十进制
与资源管理器集成 | 将 UltraCompare 选项添加到 Windows 资源管理器中的上下文菜单


配置摘要

当在选项菜单中选择配置时将显示“配置”对话框，对话框中包含按种类划分的配置选项。 可以使用位于对话框左侧的索引框进行轻松导航。

要阅读每个设置的说明，请单击帮助中的“内容”页面，然后双击菜单命令，然后双击选项菜单并双击配置。 将在帮助文件的配置对话框中打开索引树的镜像。 用户可以在帮助中扩展主要的选项：

比较

忽略选项

用户概要文件

显示

应用程序布局

文件处理

备份和保存

工具栏/菜单

键映射

外壳集成

UE/UES 集成

在标题上双击并点击下面包括的主题，将提供相关选项的摘要。


文本

文本（配置 - 比较）

文本分支位于配置 － 比较之下，包含以下用于文本比较的选项：

可缩放/可滚动图

该选项允许用户选择可伸缩的图或可滚动的图以便控制图形导航窗格的显示。

附加的框架

该选项在主比较窗口下显示逐行比较的水平比较框架。 在附加框架中双击其中显示的一行将允许用户编辑该行。 按下回车/返回键将已编辑的行保存到相应的文档中。

差异指示符

该设置决定进行文本比较时是否在行号和文本间显示差异指示符。

比较符号 | 含义
!> | 数据存在于右侧框架，在左侧框架中不存在
<! | 数据存在于左侧框架，在右侧框架中不存在
!! | 此处只存在空行
* | 数据存在于两个框架中但是不同

显示标签

该选项将空格、标签和换行字符显示为可见的符号。

制表站值

该设置可以用于设置由于显示原因，制表符表示的空格数目。

分隔栏上的合并按钮

该选项可以切换在分隔相邻比较框架的栏中显示或不显示“合并”按钮。

使用逐个字符的行比较

通常 UltraCompare 使用的比较方式尝试在一组序列中确定类似的序列——扫描一行中类似的字符和词语以相互匹配。 如果需要，客户可以选择该选项让 UltraCompare 执行逐个字符的比较。 对于一行内容很多或很大的文件，选用该选项后用户可以发现比较时间明显得以减少。


二进制

二进制（配置 - 比较）

二进制分支位于配置 － 比较之下，包含以下用于二进制比较的选项：

十进制偏移

如果选中该选项，则二进制比较的偏移将以十进制显示。 如果未选中该选项则偏移将以十六进制显示。


文件夹

文件夹（配置 - 比较）

文件夹分支位于配置 － 比较之下，包含以下用于文件夹比较的选项：

比较方式

比较模式有三种可用的比较选项：

基本

如果选中该选项，则文件夹比较将仅比较文件夹中包含项目的大小和日期。

完全

如果选中该选项，则文件夹比较将对比较的文件夹包含的所有文件执行逐字节的比较。

智能

如果选中该选项，文件夹比较将包含文件夹中所有文件的文本比较，且也将遵守文本比较配置的选项。

结果显示为文本模式

如果选中该选项，则文件夹比较的输出将包含文件中文件的文本比较结果。

循环比较

如果选中该选项，比较将不仅包括顶层目录的比较，还包括指定要比较的所有文件夹子目录。

显示子文件夹目录

如果选中该选项，则 UltraCompare 将列出所有子目录中的所有目录。 所有子目录内容将按相对路径信息排列。 该功能仅在文件夹比较模式的递归比较中可用。 要使用该选项则必须选中递归比较。

在文本模式中强制加载文件

如果选中该选项，则所有文件都将作为文本文件进行加载，而不考虑文件的内容。

记住文件扩展名的比较模式

如果选中该选项，则给定扩展名的最后模式将确定下次打开相同扩展名文件进行比较时使用的模式。

仅在刷新时扫描

在递归文件夹比较中，加载时文件/文件夹结构存储在内存中。 缺省情况下仅在刷新时扫描选项为选中状态，UltraCompare 将仅在按下刷新按钮（或使用 F5 快捷键）时重复扫描以验证比较的目录内容。

如果未选择该选项，则用户在递归文件夹比较时上移或下移父/子目录时 UltraCompare 将执行快速扫描以检查文件/文件夹是否被更改 - 该方法能够在用户移动到新的目录级别时有效重新绘制目录结构。


文本

文本（配置－忽略选项）

文本分支位于配置－忽略选项之下，包含以下选项：

忽略空白行

该选项可以使早活动文件的比较中忽略仅包含行终止符的行。

忽略大小写

该选项可以使比较在标识活动文件中的差异时忽略大小写

忽略空格

该选项将使得比较在标识活动文件中的差异时忽略制表符和空格

忽略行终止符

该选项使得比较时忽略活动文件中的行终止符（DOS/UNIX/MAC）差异

忽略行

该区段可以用来根据行开头或结尾的字符串定义忽略规则或忽略包含指定字符串的行。

忽略已定义的行号

该选区允许用户定义忽略文件开始或结尾处的若干行以便比较。


文件夹

文件夹（配置 - 比较）

文件夹分支位于配置 － 忽略选项菜单之下，包含以下选项：

忽略文件夹/文件类型

忽略文件夹/文件类型输入字段允许用户添加用分号隔开的文件夹、文件和文件扩展名列表，列表中的内容需要在文件夹比较模式中忽略。 例如，用户可以输入“CVS”，则在文件夹中一旦出现名为 CVS 的文件或文件夹，就会在执行和显示文件夹比较时被忽略。

用户还可以输入需要忽略的文件/文件夹的绝对路径。 可以使用星号 (*) 作为通配符。 为了忽略特定类型的所有文件，可以将星号与文件扩展名一起使用。 例如，用户可以输入“*.txt;*.php;*.asm”，则执行和显示文件夹比较时文件扩展名 .txt、.php 和 .asm 将被忽略。

忽略时间戳差异

该选项使得比较在识别活动文件/文件夹差异时忽略文件/文件夹的时间戳。 选择基本比较模式时该设置仅对文件夹比较模式有效，因为完整和智能比较方法不会检查文件的大小和时间戳。


用户概要文件

用户概要文件（配置）

用户概要文件分支位于配置之下，允许用户指定所有比较模式的设置并将其保存为命名的概要文件。

概要文件管理

首次点击用户概要文件标签时，将显示现有概要文件列表（如果存在）。如果从列表中选择概要文件，则与此概要文件相关的设置将显示在概要文件描述面板中。选中的概要文件可以进行修改（在此情况下将在用户概要文件设置对话框中打开）、删除、导出或激活。如果概要文件已激活，则为此概要文件指定的所有设置将应用于活动会话。导出的概要文件将保存为后缀名为 .prf 的文件。

“用户概要文件设置”对话框

如果用户选择添加配置文件或修改配置文件，则显示用户概要文件设置对话框。这允许用户指定任何比较模式使用的默认设置。

最后，如果选中导入概要文件，将允许用户浏览已保存的概要文件（后缀名为 .prf）并将其导入使用。


颜色和字体

颜色和字体（配置 - 显示 - 文本）

颜色和文本分支位于配置 － 显示 - 文本之下，包含以下选项：

颜色和字体设置

用户可以指定用于文本比较的对比颜色偏好。点击文本标签旁的有色矩形框，将显示一个对话框供用户为显示的项目选择颜色。

加载色彩方案

已预定义两种颜色方案。如果需要，用户可以通过选择下拉菜单中提供的选项，从而进行选择。

字体设置

按下字体设置按钮将显示默认的系统系统字体对话框，用户可以在此定义用于文本比较的字体，包括设置字体样式、大小和脚本的选项。

按使用默认按钮可以恢复文本比较的默认颜色/字体设置。


其它

其他（配置 - 显示 - 文本）

其他分支位于配置 － 显示 - 文本之下，包含以下选项：

标记空行

如果选中该选项，选中的空行将在比较窗格中用蓝白相间的垂直行表示。 如果未选中，则遇到空行时比较窗格的背景色不会改变。

仅高亮显示活动框架

如果选中该选项，则在三方比较中仅两个活动框架将高亮显示字符差异。 如果未选中，则所有的三个框架都将高亮显示以表示字符差异。


二进制

二进制（配置－显示）

二进制分支位于配置－显示下，包含以下选项：

颜色和字体设置

用户可以指定用于二进制比较的偏好的对比颜色。点击文本标签旁的有色矩形框，将显示一个对话框供用户为显示的项目选择颜色。

加载颜色方案

已预定义两种颜色方案。 如果需要，用户可以通过选择下拉菜单中提供的选项，从而进行选择。

字体设置

按下字体设置按钮将显示默认的系统系统字体对话框，用户可以在此定义用于文本比较的字体，包括设置字体样式、大小和脚本的选项。在二进制（智能/快速）比较模式里，只能选择等宽字体。

按使用默认按钮可以恢复二进制比较的默认颜色/字体设置。


颜色

颜色（配置 - 显示 - 文件夹）

颜色分支位于配置 － 显示 - 文件夹之下，包含以下选项：

颜色和字体设置

用户可以指定用于文件夹比较的对比颜色偏好。点击文本标签旁的有色矩形框，将显示一个对话框供用户为显示的项目选择颜色。

加载色彩方案

已预定义两种颜色方案。如果需要，用户可以通过选择下拉菜单中提供的选项，从而进行选择。

按使用默认按钮可以恢复文件夹比较的默认颜色/字体设置。


列

列（配置 - 显示 - 文件夹）

列分支位于配置 － 显示 - 文件夹之下，包含以下选项：

状态显示

文件夹比较模式中的状态列有三种比较选项可用：

显示符号

如果选中该选项，则在状态列中仅显示状态符号。 这是默认设置。

显示文本

如果选中该选项，则在状态列中仅显示文本。

显示符号和文本

如果选中该选项，则在状态列中仅显示状态符号和文本描述。

启用分隔符

如果选中该选项，则在文件夹比较中，主要段落间将显示分隔符。

记住列宽

如果选中该选项，则下一次调用文件夹比较时将记住用户之前设置的列宽（通过点击并拖动标题处的列分隔栏)。

重置列宽

按下该按钮则重新将文件夹比较的列宽设置为缺省值。


其它

其他（配置-显示-文件夹）

其他分支位于配置-显示-文件夹之下，包含以下选项：

并列

如果选中该选项，文件夹比较数据将显示为并排的两个比较目录，而不是标准的混合显示。

显示预览文件

如果选中该选项，将在文件夹比较中在右侧显示附加的面板，且当在文件夹模式输出中选择文件时输出在其中一个比较驱动器活其中的文件是等同的，其内容将显示在附加面板中，以便快速复查文件夹间的比较差异。

启用 Stripe

如果选中该选项，则在文件夹比较的行中将使用替换的背景颜色。

显示文件/文件夹图标

如果选中该选项，则在文件夹模式比较中，Windows 资源管理器使用的相同图标将显示在文件/文件夹名称之前。


设置时间/日期格式

设置日期/时间格式（配置 - 显示 - 文件夹）

设置日期/时间格式分支位于配置 － 显示 - 文件夹之下，包含以下选项：

格式字符串

该字段可以用于指定比较文件时显示日期和时间的字符串的格式。 用户可以在格式字符串字段中直接输入需要的格式，或使用格式元素按钮根据需要选择和插入元素。

对齐

用户可以选择靠左、居中或靠右来控制日期/时间字符串在相关文件夹比较列中显示的位置。

恢复系统格式

如果按此按钮，将日期/时间字符串恢复为缺省的系统格式。

格式元素

按下此按钮将显示弹出菜单，在此用户可以选择要在格式字符串字段中包含的元素。 从格式元素弹出菜单中选择的项目将自动插入到格式字符串字段中。 如果用户喜欢，可以参考下表并在格式字符串字段中直接输入需要的格式。

时间元素

可以用作时间元素的特殊字符如下：

h | 时 (1-12)
hh | 小时 (01-12)
H | 时 (0-23)
HH | 小时 (00-23)
m | 分 (0-59)
mm | 分钟 (00-59)
s | 秒 (0-59)
ss | 秒钟 (00-59)
t | 上/下 A/P
tt | 上午/下午 AM/PM

日期元素

可以用作日期元素的特殊字符如下：

D | 日
DD | 日期（2位数）
DDD | 星期（缩写）
DDDD | 星期（全称）
M | 月
MM | 月份（2位数）
MMM | 月份（缩写）
MMMM | 月份（全称）
YY | 年（2位数）
YYYYY | 年份（4位数）
d | 一年的第几天
ddd | 一年的第几天（3位数）
w | 一年的第几周
ww | 一年的第几周（2位数）

分隔符元素

可以用作分隔符元素的特殊字符如下：

~ | 分隔符（空格）
/ | 日期分隔符
: | 时间分隔符

用户可以根据需要输入其他字符作为分隔符元素。

结果字符串

该字段显示示例字符串，说明采用指定元素后日期/时间字符串的显示结果。


应用程序布局

应用程序布局（配置）

应用程序布局分支位于配置之下，包含以下选项：

允许多个实例

如果选中该选项，则可以同时启动多个 UltraCompare 实例。

显示行号

选择该选项将在每个文件的左侧内容里显示比较文件的行号。这在识别同样的行出现在两个文件中但在不同位置时尤为有用，并且有助于查清这些行存在于比较文件中出现的位置（在这种情况下，行号将不会显示于未进行比较行的文件中）。

显示进程

如果选中该选项，则将在状态栏中显示消息和进程条以指示活动文件夹的比较进程。

启动后导航

如果选中该选项，则活动行/项目将自动移动到比较项目中的第一处差异。

合并后导航

如果选中该选项，则活动行/项目将在合并发生后自动移动到下一处差异。

对设置使用注册表（非 INI 文件）

该设置使编辑器在注册表保存并检索所有设置。 UltraCompare 确定 INI 文件在使用后将在读取任何其他值之前检查该值。 如果设置为 UltraCompare 在注册表中存储所有设置。 如果未选中该选项，注册表中当前的所有设置将被移动到新创建的 INI 文件。

比较后显示差异摘要

如果选中该信息，则在活动的比较完成后将自动显示差异摘要。


File Handling

File Handling (Configuration)

The File Handling branch under Configuration includes the following options:

File change detection

If this option is selected UltraCompare will automatically poll for changes in compared files and allow the user to update the file.


保存和备份选项

备份并保存（配置）

备份和保存分支位于配置之下，包含以下选项：

用 Unicode 保存结果

该选项使得文件/文件夹比较的输出文件用 Unicode 格式保存。

创建备份

可以使用该选项创建比较文件的备份。重复合并命令之前建议进行此操作，以保留“基准”文件供需要时进行还原。

创建 zip 档案备份

该选项使得 UltraCompare 在比较 zip 文档前先创建备份。

并列结果

如果选中该选项，则结果文件将并排显示而不是层叠显示。

上下文结果中的差异

如果选中该选项，则结果文件将显示上下文中的差异（例如，在发生差异前后留出一些空行，以便在结果文件中更加清晰显示差异存在的位置）。

只显示一个框架的结果

如果选中该选项，则结果文件将仅显示当前比较文件的活动窗格中的差异。 该限制结果将遵守所选的比较选项（全部、仅差异、仅匹配）。


定制

自定义（配置 - 工具栏/菜单）

自定义分支位于配置 － 工具栏/菜单之下，包含以下选项：

定制工具栏

按下此按钮将显示工具栏配置对话框，包括标记为工具栏和命令的两个窗格，并带有新工具栏使用的文本输入区域。 对话框中还包含上/下和左/右箭头。 这些项目及其功能如下所述：

工具栏/命令配置窗格

指定的工具栏显示于工具栏窗格中，并在资源管理器界面里显示当前分配给它们的项目。点击工具栏名称左边的“-”将折叠该工具栏，而点击“+”将展开工具栏显示其中包含的项目。如果在工具栏里选中项目，按下上/下箭头将把该项目相应地移动到工具栏列表。无法使用上/下箭头将项目从一个工具栏移动到相邻的其它工具栏。

命令窗格显示当前可供工具栏里使用的所有功能。要将项目从命令窗格移动到工具栏窗格，请点击所需的命令项目并在对话框中央按下左箭头以添加选中的项目。选定的工具栏项目将直接添加到工具栏窗格中当前选定项目之下。如果在“工具栏”窗格没有选择，则该项目将添加到列出的第一个工具栏顶部。一旦添加了项目，就可以在工具栏里使用上下箭头随意移动它们。

新建工具栏

要创建新工具栏，请在“新工具栏”区域输入工具栏名称（例如：“Test1”），并按下“新工具栏”区域右侧的左箭头按钮。这将添加新的空工具栏到工具栏列表底部。移动工具栏可以通过选择工具栏并按下对话框中央的右箭头按钮。

定制菜单

按下此按钮将显示菜单配置对话框，包括标记为菜单和命令的两个窗格，并带有新菜单/子菜单使用的文本输入区域。如果所选菜单使用选中标记，则将为选中的菜单项目显示选中标记而非按下的菜单图标。 该选项有助于解决残障用户的屏幕阅读器上出现的一些问题。 该对话框还包括上/下和左/右箭头以及编辑按钮。 这些项目及其功能如下所述：

工具栏/命令配置窗格

当前活动的菜单将显示在“菜单”窗格之内，并在资源管理器界面里显示当前给它们分配的项目。 每个菜单或子菜单标题均标记为：一行的结尾是菜单/子菜单名称左边的方框。 双击标题符号将适当地展开/折叠所含的项目。

如果选中菜单标题或项目，并按下编辑按钮，则可以修改该菜单/项目的名称。 按下键盘上的回车将保存菜单项目更改，而按下确定按钮将提交这些更改，以便将其反映到菜单中。

选中菜单标题时，可以使用上/下和左/右箭头移动整个菜单到新位置。 选中一个菜单项目时，可以使用上/下按钮将项目移动到当前菜单内的新位置。 菜单项目可以移动到当前菜单的最顶部或最底部。 如果一个菜单项目是子菜单的一部分，则无法将其移到子菜单之外。 如果一个菜单项目是主菜单的一部分，上移或下移它都会使其“跳过”遇到的任何子菜单。

命令窗格显示菜单里当前可以使用的所有功能。 要将项目从命令窗格移动到菜单窗格，请点击所需的命令并在对话框中央按下左箭头以添加选中的项目。选中的菜单项目将直接添加到“菜单”窗格里当前选定的项目之下。如果在菜单窗格里没有选择，则该项目将添加到所列的第一个菜单顶部。一旦添加了项目，就可以使用上下箭头在菜单内随意移动它们。

新建菜单

要创建新的菜单/子菜单，请在“新菜单”区域输入菜单/子菜单名称（例如：Test1”）并按下“新菜单”区域右边的左箭头按钮。它将添加新的空菜单到菜单列表底部。可以选择菜单并按下对话框中央的右箭头按钮，来删除它们。


管理

管理（配置 - 工具栏/菜单）

管理分支位于配置 － 工具栏/菜单之下，包含以下选项：

管理工具栏

按下此按钮将显示工具栏配置对话框。 按下重置按钮将恢复默认的工具栏配置。

管理菜单

按下此按钮将显示菜单配置对话框。 按下重置按钮将恢复默认的菜单配置。


键映射

键映射（选项菜单）

该命令提供“键映射”对话框，可以用来重新分配 UltraCompare Professional 提供的默认键映射，以满足用户的需要。

该对话框显示 UltraCompare Professional 中用户可以映射到其选择的组合键的命令列表。 点击任何命令都将显示现有的键分配（如果有），以及列表下面的命令描述。

要添加或更改一个命令键分配:

1) 请从命令列表里选择希望修改的命令。

2) 在“按下新键”输入窗口区域里点击鼠标，或点击 TAB 到该区域以获得焦点。

3) 按您调用该命令的方式一样地输入新键分配 - 此组合键将被捕获并显示出。

4) 点击“分配”按钮，新键即分配到该命令。 如果现有的键已分配，则将询问您是否希望删除它并用新的分配替换。

要删除键分配:

1) 请从命令列表里选择希望修改的命令。

2) 从“已有键”列表里选择现有的键分配。

3) 点击“删除”按钮，将删除键分配。

要重置键分配为默认值:

1) 点击“默认”按钮，键分配将重置为默认值。 将会提示用户确定该操作。


外壳集成选项

外壳集成（配置）

外壳集成分支位于配置之下，包含以下选项：

与资源管理器集成

如果选中该选项，则在 Windows 资源管理器中将 UltraCompare 选项添加到上下文（右键单击）菜单 。

启用自动选择

如果选中该选项，则在 Windows 资源管理器中 UltraCompare 上下文菜单项将自动导入当前选定的项目。


UE/UES 集成

UE/UES 集成（配置）

UE/UES 集成分支位于配置之下，包含以下选项：

仅加载活动文件

如果选中该选项，则调用外部编辑器时会仅打开活动文件而不是打开正在比较的两个文件。


设置过滤器

设置过滤器（选项菜单）

该选项（仅适用于 文件夹比较 模式）将提供“设置过滤器”对话框，允许用户按文件扩展名指定过滤器来确定“文件夹比较”过程中应显示哪些文件类型。可以定义单独的文件扩展名，即：

*.txt

或者用户可以定义用逗号分隔的多个文件扩展名，即：

*.txt,*.js,*.html

以便显示匹配的文件类型。


指定二进制扩展名

指定扩展名（选项菜单）

该命令显示“指定二进制扩展名”对话框，用户可以在此为文件指定扩展名和描述，这些文件是 UltraCompare 应解释为二进制或文本文件。 UltraCompare 尝试为文件确定合适的模式，但是一些情况中用户可能需要指定使用的模式。

有一个默认列出的文件类型列表，用户可以根据需要从该列表删除项目或添加项目。


比较列范围

比较列范围（选项菜单）

当在“选项”菜单中选中比较列范围命令时， 会出现比较列范围对话框。 用户可以输入最多四个范围， 以分号隔开。 例如，用户可以输入“1-5; 7-10”。 如果用户按“确定”按钮，则 选中菜单项目。 UltraCompare 仅比较 范围 1-5 和 7-10 的列，而忽略其他列。 仅 显示这些范围以内列的差异。 其他列被忽略， 并按非差异的情景显示。 再次选择菜单项目将禁用此比较。 UltraCompare 会记住上次输入的范围。

请注意：比较/忽略列范围的选项是排他的（即每次只能选中一个）。


忽略列范围

忽略列范围（选项菜单）

当在“选项”菜单中选中忽略列范围命令时，将显示忽略列范围对话框。 用户可以输入最多四个范围， 以分号隔开。 例如，用户可以输入“1-5; 7-10”。 如果用户按“确定”按钮，将选中菜单项 。UltraCompare 忽略范围为 1-5 和 7-10 的列，而比较其他内容。 仅显示这些范围以外列的差异。 如果检测到差异，则其他列将显示为正确的差异文本颜色和背景色。 再次选择菜单项目 会禁用此比较。 UltraCompare 将记住上次输入的范围。

请注意：比较/忽略列范围的选项是排他的（即每次只能选中一个）。


忽略空行

忽略空行 (选项菜单)

当确定活动文件之间的差异时，可以选择该选项允许活动比较忽略仅包括换行符的行（依活动文件类型而定）。这不包括含有制表符或空格的行。


忽略空格

忽略空格（选项菜单）

可以选择该项目，在比较文件的差异时，允许活动比较忽略制表符和空格。


忽略大小写

忽略大小写（选项菜单）

可以选择该项目，在比较文件的差异时，允许活动比较忽略大小写。


忽略换行符差异

忽略换行符（选项菜单）

比较文件差异时，可以选择该项目允许活动比较忽略换行符差异（DOS/UNIX/MAC）。


十进制偏移

十进制偏移（选项菜单）

该选项更改比较窗格左边显示的偏移值，可以从十六进制模式更改到十进制模式。


与资源管理器集成

与资源管理器集成（选项菜单）

选择它后，该命令添加 UltraCompare 选项到 Windows 资源管理器上下文（鼠标右键）菜单。 它是个强大的机制，可以快速指定要比较哪些文件/文件夹，并调用 UltraCompare Professional 来执行该任务

如果在“选项”菜单里选择了与资源管理器集成，则以下项目将添加到资源管理器的上下文菜单：

如果需要，用户可以指定每个框架应加载哪些文件/文件夹/zip 文档，只需通过在资源管理器里右键单击一个项目，并在上下文菜单选择它应加载到哪个框架中。

一旦指定了需要的项目，就可以选择 运行 UltraCompare 来运行 UltraCompare。可以从框架到框架保存选择，便于用户从不同的文件夹或驱动器选择文件/文件夹进行比较。

启动 UltraCompare 时，它将自动切换到适当的文本比较或文件夹比较模式。如果选择了三个项目进行比较，则三方模式将启动。

要快速操作，用户可以按住 CTRL 键并从同一目录里选择多个项目进行比较，然后右键单击并选择运行 UltraCompare。UltraCompare Professional 将自动加载选择的项目到框架中进行比较，并在适当的模式中启动。


合并菜单

合并菜单包含下列命令：

行模式合并 | 将合并功能从块合并切换到已选的行合并
合并第一个到第二个 | 将选中内容从第一个文件合并到第二个文件
合并第二个到第一个 | 将选中内容从第二个文件合并到第一个文件
高级合并 | 从左到右（或从右到左）合并选中内容到有差异的行之上或之下，而不覆盖现有文本
全部接受 | 接受指定文件所有合并的更改
撤消合并 | 撤销上一个合并动作
撤销所有更改 | 撤销比较文件/文件夹的所有未保存更改
替换较新的文件时提示 | 如果合并操作将用较新的文件覆盖当前文件时提示用户
合并时提示 | 每个合并完成前提示用户
合并后刷新 | 每次合并完成后刷新比较状态


行模式合并

行模式合并（合并菜单）

该命令将合并功能从块合并切换到选定的行合并。 如果选中该选项，用户可以在不同的块中选择单独的行进行合并。


合并第一个到第二个

合并第一个到第二个(合并菜单)

标记某行准备合并后，该命令可以用来从左边显示的文件到右边显示的文件合并已选的行。 在三方文本模式中，如果选中第二个和第三个文件之间的分隔栏，它将变为“合并第二个到第三个”。

合并的行将用不同的背景颜色标识，以便在保存前快速检查所有合并的更改。

键盘快捷键：Alt+向右箭头


合并第二个到第一个

合并第二个到第一个（合并菜单）

标记某行准备合并后，该命令可以用来从右边显示的文件到左边显示的文件合并已选的行。在三方文本模式中，如果选中第二个和第三个文件之间的分隔栏，它将变为“合并第三个到第二个”。

合并的行将用不同的背景颜色标识，以便在保存前快速检查所有合并的更改。

键盘快捷键：Alt+向左箭头


高级合并

高级菜单（合并菜单）

这些命令可以用于从一个文件到另一个文件合并差异块，而不覆盖接受合并文件的现有内容。要实现此功能，用户需指定要合并的文本是应合并到现有文本之上还是之下。


撤消合并

撤销合并（合并菜单）

该命令可以用来取消上次进行的合并。

键盘快捷键：Ctrl+Z


撤销所有更改

撤销所有更改（合并菜单）

该命令可以用来取消活动文件/目录里的所有更改。


替换较新的文件时提示

替换较新的文件时提示（合并菜单）

在 文件夹比较 模式里，如果用户尝试从一个目录下合并有差异的文件到另一个目录，并且 UltraCompare 检测到用户的操作将覆盖正在合并的接收目录里较新的文件时，将显示提示对话框以确定这是用户真正希望的操作。


合并时提示

合并时提示（合并菜单）

可以设置该选项使 UltraCompare 提示用户每次合并，以确保这是用户真正希望做的合并。


合并后刷新

合并后刷新（合并菜单）

该选项仅适用于“文件夹模式”。 如果选中，无论何时文件/文件夹从一个比较文件夹合并到另一个文件夹，都将强制刷新比较的目录（以及比较状态）。 如果未选择该选项，则不会出现自动刷新/重新比较。

该功能初始情况下启用，以便比较过程中的文件/文件夹在 UltraCompare Professional 之外发生更改时，可以在比较状态中反映出来。 如果知道不会出现这种情况，则可以不选择该选项。


窗口菜单

窗口菜单包含下列命令：

垂直布局 | 并列显示比较的文件
水平布局 | 层叠显示比较的文件
翻转框架 | 切换活动比较中的源/目标窗格
在浏览器中显示文件 | 在操作系统默认的浏览器中显示当前文档
同步垂直滚动 | 使比较窗格同步以便同时垂直滚动比较中的两个文件
同步水平滚动 | 使比较窗格同步以便同时水平滚动比较中的两个文件
同步底边滚动 | 使比较窗格同步以便同时水平滚动比较中的两个文件和其他框架

在三方文本比较中，“窗口”菜单提供以下命令：

垂直布局三方模式 | 并列显示三个比较的文件
水平布局三方模式 | 层叠显示三个比较的文件
翻转第一个<-->第二个 | 切换活动比较中的框架 1 和 2
翻转第二个<-->第三个 | 切换活动比较中的框架 2 和 3
翻转第一个<-->第三个 | 切换活动比较中的框架 1 和 3
在浏览器中显示文件 | 在操作系统默认的浏览器中显示当前文档
同步垂直滚动 | 使比较窗格同步以便同时垂直滚动比较中的两个文件
同步水平滚动 | 使比较窗格同步以便同时水平滚动比较中的两个文件
同步底边滚动 | 使比较窗格同步以便同时水平滚动比较中的两个文件和其他框架


垂直布局

垂直布局（窗口菜单）

该设置使比较的文件并列显示，并且是默认的显示选项。

键盘快捷键：Ctrl+I

三方键盘快捷键：Ctrl+Alt+I


水平布局

水平布局（窗口菜单）

该选项使一个比较文件显示在另一个比较文件之上。

键盘快捷键：Ctrl+H

三方键盘快捷键：Ctrl+Alt+H


翻转框架

翻转框架（窗口菜单）

该选项使源（左）窗格里显示的文件显示到目标（右）窗格，反之亦然。为进行展示，用户可能会选择切换比较文件的初始显示模式。

如果三方文本比较活动，用户将有三个选项切换特定框架中显示的文件：翻转框架第一个 <--> 第二个，翻转第二个 <--> 第三个，并翻转第一个 <--> 第三个。


垂直/水平同步滚动

垂直/水平同步滚动（窗口菜单）

该选项同步比较窗格，以便通过在任一窗格中滚动，两个文件都可以同时垂直/水平滚动。 默认为两个窗格同步。该命令用于重新建立同步，如果在合并过程或其它功能中失去同步。


帮助菜单

帮助菜单提供下列命令:

索引 | 提供索引用于“帮助”文件
用户论坛/支持 | 链接到在线用户交流论坛
检查更新 | 检查是否有当前使用版本的升级或 hotfix
注册 | 提供对话框以输入产品注册信息
关于 UltraCompare | 表示正在运行的版本


索引

索引（帮助菜单）

选择该选项将显示“帮助”文件的索引。


注册

该选项提供“注册”对话框，供输入用户名和注册码来注册该产品。可以通过联系 IDM Computer Solutions Inc. China 订购注册许可，网址：www.ultraedit.com.cn，联系电话：86-21-6212 3939。


关于 UltraCompare

关于 UltraCompare（帮助菜单）

该命令提供“关于”对话框，显示正在运行哪种版本以及该产品目前是否已注册。如果该产品已注册，则其注册的名称将显示在这里。


工具栏命令

主工具栏包含下列可用的命令：

保存结果 | 保存活动比较的结果摘要为文本文件
关闭所有文件 | 关闭所有打开文件
打印 | 打印结果摘要
打印预览 | 在屏幕上按打印效果来显示结果摘要
全部 | 显示两个比较文件的完整内容
仅差异 | 仅显示有差异的行
仅匹配 | 仅显示完全匹配的行
文本模式 | 显示子目录，用户可以在其中选择文本模式或三方文本模式显示选项
二进制模式 | 显示子菜单用户可以从中选择二进制（快速）模式或二进制（智能）模式显示选项
文件夹模式 | 显示子菜单用户可以从中选择文件夹模式或三方文件夹模式显示选项
垂直布局 | 并列显示比较文件
水平布局 | 重叠显示比较文件
配置 | 显示配置对话框
显示行号 | 在比较的文件中显示行号
执行概要文件 | 显示“用户概要文件”对话框，用户可以在此选择比较概要文件
同步 | 同时滚动两个窗口
查看下一个差异 | 重新定位到比较文件的下一个差异
查看上一个差异 | 重新定位到比较文件中的上一个差异
上级目录 | 重置目录比较的两个窗格到上级目录
循环比较 | 比较指定要进行比较的文件夹的所有子文件夹，而不是仅比较顶层目录
在 UltraEdit 中更改 | 在 UltraEdit 中打开要编辑的活动文件
停止比较并退出 | 停止活动的比较并关闭程序
在浏览器中显示文件 | 将活动文档传递到操作系统的默认浏览器
关于 | 显示“关于”对话框
刷新 | 重复比较已刷新标识的差异


合并工具栏

合并工具栏包含以下功能：

合并左边到右边 | 将选区从左边的文件合并到右边文件覆盖活动的块
合并第一个到第二个（块之后） | 从左边文件到右边文件合并选择到选定区块之后
合并第一个到第二个（块之前） | 从左边文件到右边文件合并选择到选定区块之前
合并右边到左边 | 合并选区从左边文件到右边文件覆盖活动的区块
合并第二个到第一个（块之后） | 从右边文件到左边文件合并选择到活动区块之后
合并第一个到第二个（块之前） | 从右边文件到左边文件合并选择到活动区块之前
行模式合并 | 切换行模式/区块模式合并
保存合并的更改 | 保存所有合并的更改
撤销所有更改 | 将两个文件还原到上次保存的状态
撤销上次合并 | 反向上次合并操作


路径工具栏命令

在“文件/文件夹路径”工具栏里可以使用以下命令：

路径组合框 | 用于输入/选择进行比较的文件/文件夹的路径
父文件夹 | 在文件夹比较中将活动窗格切换到父文件夹
打开文件/文件夹 | 在活动窗格里打开指定的文件/文件夹
关闭文件/文件夹 | 关闭活动文件/文件夹
编码 | 提供上下文菜单允许对文本比较中选中的活动文件进行编码（如下）

当按下“路径”工具栏里的编码按钮时，用户可以指定在文本比较模式中比较活动文件使用的编码。


在 UltraEdit 里编辑

该命令在 UltraEdit 里的文本比较中打开当前活动的文件。


打开文件

在 UltraCompare 中打开文件比较有多种方法。所选的方法完全是个人偏好，因为下面描述的所有方法都会导致相同的内部功能——即打开指定的文件并自动开始比较指定的文件。

UltraEdit-32

如果正在运行 UltraCompare Lite ，必须运行 UltraEdit-32 以便在 UltraCompare Lite 里比较文件。如果愿意，可以打开文件在 UltraEdit-32 里比较，并使用“文件”菜单里的“比较文件”命令调用 UltraCompare Lite。默认地，上次打开/编辑的两个文件将填充到“比较文件”对话框里的组合框。如果喜欢，可以使用对话框的“浏览”按钮来浏览并指定希望比较的文件。

除了指定要在 UltraCompare Lite 中打开的文件之外，也可以选择指定的文件是否应作为文本文件或二进制文件来比较，并指定该对话框里三个比较选项中的任意一个（或全选）：

忽略大小写

忽略空格

忽略空白行

请注意，这些选项仅适用于“文本比较”。

命令行

如果正在运行UltraCompare 专业版，可以从命令行指定要打开并比较的文件。如果 UltraCompare 已经添加到 PATH 中，可以从命令行（即：DOS 提示符）如下调用它进行文件比较：

uc c:\temp\test.txt d:\temp\test.txt

这将使 UltraCompare 在左右窗格里从两个不同的驱动器分别打开 test.txt 并自动开始比较它们。比较进行中时，“取消”按钮将在工具栏上活动。状态栏将显示黄色灯和“处理中”标签。

如果 UltraCompare 尚未添加到 PATH，则需要引用到该应用程序的完整路径，以便从命令行调用它，即：

"c:\program files\ultracompare\uc" c:\temp\test.txt d:\temp\test.txt

从命令行调用 UltraCompare 专业版时，有几个命令行选项可以使用。

打开左边/右边

UltraCompare Professional 在文件菜单里还包括打开左边和打开右边命令。选择其中任一命令都将打开标准的打开文件对话框，可以使用它浏览并选择希望在指定比较窗格里打开的文件。

组合框/文本输入

如果愿意，可以在每个比较窗格上方的组合框里直接输入，指定要在下面窗格中打开的文件。每个窗格的文件指定完毕后，按下回车键将开始文件比较。先前比较过的文件路径存储于组合框里，如果愿意可以点击向下箭头并从先前比较的文件中选择。

粘贴文本

如果需要，用户可以复制并粘贴文本到每个空白的比较窗格中。 将创建临时文件路径并显示每个窗格中的内容。 如果用户希望比较其他代码片段，则可以使用“关闭”按钮关闭临时文件。 将第二个文件的内容粘贴到比较窗格后便开始比较。 粘贴的文本也可以与已有的文件进行比较。

浏览按钮

可以点击每个窗格右上角的打开按钮，打开标准的文件打开对话框，并选择希望用它打开的文件。

打开两个文件后 UltraCompare 将立即开始自动比较其内容。 比较完成后，文件比较结果将使用颜色和符号表示。


文本比较

文本比较完成后，本程序将使用符号与颜色的组合来表示比较结果。

<! | 表示该数据在左侧文件里，但不在右侧文件里
!> | 表示该数据在右侧文件里，但不在左侧文件里
* | 表示该数据在比较文件的指定行之间不同

除了以上的项目，检测为差异的行将以指定的颜色高亮显示为颜色对话框（默认为紫色）的“差异背景”，此对话框在选项菜单内。活动行以“导航背景”指定的颜色来显示（默认为桃红色）。

状态栏也会显示比较文件中包含的块数和行数。例如：

38 区块不同 156:204 行不同

表示在比较的文件之间检测到 38 个区块有差异，并且“源”（左侧）文件包含这些差异区块中的 156 行文本，而“目标”（右侧）文件包含这些差异区块中的 204 行。

如果选中上下文结果中的差异选项（位于配置的备份和保存窗格中），则使用下列符号：

+++ | 标识第一个窗格中的文件
--- | 标识第二个窗格中的文件
+ | 标识文本来自于第一个窗格中的文件
- | 标识文本来自于第二个窗格中的文件

@@ +1201,4 -1204,4 @@ 表示差异文本从第一个窗格的第 1201 行和第二个窗格的第 1204 行开始，该段包含的差异行数为 4 行。

词语级别选择、替换和插入

进行文本比较时，用户可以在第一个窗格中选择词语并使用上下文菜单或 CTRL+C 将其复制到剪贴板中。点击另一个比较窗格后，用户可以插入剪贴板中的内容或通过粘贴（使用上下文菜单或 CTRL+V）覆盖指定的词语。


三方文本比较

三方文本比较完成后，本程序将使用符号与颜色的组合来表示比较结果。

!> 表示该数据在右侧文件里，但不在左侧文件里

!! 表示该区域包含两个文件里的空行

* 表示该数据在比较文件的指定行之间不同。

除了以上的项目，检测为差异的行将以指定的颜色高亮显示为颜色对话框（默认为紫色）的“差异背景”，此对话框在选项菜单内。 活动行以指定的颜色表示为“导航背景”（默认为桃红色）。如果在“颜色”对话框中选中标记空行，则空的区域（不包含任何数据和任何硬回车）将在可缩放/可滚动图里表示为白色背景上的蓝色竖条。

可以观察到 Frame 2 中的行突出显示为向正在比较的一个文件蓝区块渐褪到白色，这表示 Frame 2 中的该区块匹配 Frame 1 中相同的区块，但不同于 Frame 3 中相同的区块（反之亦然）。

状态栏也会标识出选定进行比较的文件对中含有差异的块和行数。 例如：

对 [2-3] - 33 块 差异 286 : 395 行 差异

表示（打开比较的三个文件中）活动文件对为 Frame 2 和 Frame 3，并且检测到在比较的文件之间 33 个区块有差异，而 Frame 2 中的文件包含这些有差异区块中的 286 行文本，Frame 3 中的文件包含这些有差异区块中的 395 行。


打印的结果摘要

结果摘要是活动比较的文本输出。它使用下列符号：

文本比较

 | 数据在左边文件里，但不在右边文件里
!> | 数据在右侧文件里，但不在左侧文件里
* | 比较的文件之间在该行上数据不同

文件夹比较

_x | 文件在左边（源）目录里，不在右边（目标）目录里
x_ | 文件在右边（目标）目录里，不在左边（源）目录里


删除文件

从磁盘删除文件

这是在比较两个文件时可以使用的上下文菜单。如果在比较文件中的任一个窗格里右键单击，就会出现含有该选项的上下文菜单。选中该选项将会出现提示对话框，显示活动文件的完整路径，以确定您希望删除活动文件。如果选中“是”该文件将删除，并从活动比较窗格中删除。如果选中“否”，则提示对话框将关闭，焦点返回活动文档窗格。


打开文件夹

希望在 UltraCompare 里打开并比较的目录/文件夹必须在命令行里如下指定：

uc -dc:\temp\testc:\temp\test1

参数 -d 表示应该打开目录/文件夹进行比较，而非文件。

如果 UltraCompare 尚未添加到 PATH，则需要引用该应用程序的完整路径，以便从命令行调用它，即：

"c:\program files\ultracompare\uc" -dc:\temp\testc:\temp\test1

请注意只有 UltraCompare Pro 支持 命令行选项 。 UltraCompare Lite 不支持打开/比较目录/文件夹。


文件夹比较

如果在使用 UltraCompare Professional 要比较的目录/文件夹可以从命令行用以下语法打开：

uc -dc:\temp d:\temp

请注意：如果 UltraCompare 不在 PATH 中，则需要引用 UltraCompare 的完整路径才能使用该命令。

当 UltraCompare 准备显示目录结构时，工具栏上的“取消”按钮为活动并有颜色，可以按下它取消比较。在此期间，状态栏上中间的（黄色）灯将突出显示，并显示“进度”标签以表示 UltraCompare 正在工作。准备好显示目录结构时，将显示红灯和“差异”标签，或显示绿灯和“匹配”标签。（该功能仅适用于 UltraCompare Pro 而不适用于 Lite 版本。）

需要时可以选择 .zip 文档，比较文件系统上的文件夹。支持对 .zip 文档的循环比较和非循环的比较。

如果没有选择循环比较选项，则比较中的“状态”栏将显示子目录是等同还是不同，或者它们是否仅存在于源目录或目标目录中。如果选择了循环比较选项，则“状态”栏将显示子目录是等同还是不同，或者它们是否仅存在于上级目录之一。

如果 UltraCompare Professional 已经运行于文本比较模式，则您可以到视图菜单下选择目录模式切换到文件夹比较界面。如果从目录模式切换回来，当前在文本/二进制比较模式下打开的任何文件都不会记住。

如果需要，用户可以选择名称不同的文件并启动文本比较。要执行此操作，右键单击文件夹比较中引用的文件，从上下文菜单中选择加载第一个文件（或第二个、第三个），然后指定选中的文件应加载到的框架。指定另一个待比较的文件后，双击上一个指定的文件将启动指定文件的文本比较。


文件夹比较的要素

当 UltraCompare 完成指定目录的比较之后，比较结果将显示在主窗口中。可以在以下分类中指定差异：

文件名

比较目录的内容按照正在比较的目录中的文件名来排列。它应该是两个目录混合内容的完整列表。

状态

状态字段标识出比较目录之间找到哪些差异。此处可能的值为：

等同：表示文件内容在两个目录里完全相同。

时间相同，内容不同：表示两个文件的时间戳相同，但比较文件之间的内容有差异。

源较新：表示左边指定的目录包含正在比较文件的较新副本。

目标较新：表示右边指定的目录包含正在比较文件的较新副本。

仅有源：表示该文件仅存在于左边的目录中。

仅有目标：表示该文件仅存在于右边的目录中。

源日期

源日期字段显示左边指定的目录中文件的日期和时间戳。

源大小

源大小字段显示左边指定的目录中以字节表示的文件大小。

目标日期

目标日期字段显示右边指定的目录中文件的日期和时间戳。

目标大小

目标大小字段显示右边指定的目录中以字节表示的文件大小。

文件类型

“文件类型”字段表示一个文件是被标识为文本格式还是二进制格式。如果列出子目录，该字段会将其标识为“目录”而不使用某种文件类型


父目录

该选项将比较的两个目录都重置到其父目录。当进行 循环比较 时，这个功能很有用。如果用户双击子目录查看此处的差异，则可以使用“父目录”按钮来返回到先前比较的父目录。


循环文件夹比较

比较两个目录时，可以按下工具栏中的“循环比较”按钮。选中的目录将再次进行比较，以便提供指定目录下找到的子目录的更多信息。

有了循环选项，状态栏将显示有关列出子目录的以下信息：

等同：表示子目录的内容在两个父目录里相同

差异：表示此子目录在不同的父目录之间有差异

仅有源：表示该子目录仅存在于“源”（左边）目录中

仅有目标：表示该子目录仅存在于“目标”（右边）目录中

如果愿意，可以双击一个子目录文件夹。选中的子目录将在各自的父目录中打开进行比较。您可以按下父目录按钮，浏览上一级的目录结构。


为何我无法比较文件夹？

如果正在运行 UltraCompare Lite 并试图从命令行比较两个文件夹，则会前后看到两个对话框说明指定的目录不是文件。Lite 版本不支持目录/文件夹比较，因此显示该错误信息。


为何 UltraCompare 不运行？

UltraCompare Lite 相当于 UltraCompare Pro ，它的一个限制在于使用前需要运行 UltraEdit 。如果试图在未运行 UltraEdit 的情况下调用 UltraCompare Lite，则会显示一个错误信息，说明 UltraCompare 使用之前必须运行 UltraEdit。


扩展名对话框在哪？

UltraCompare Lite 不包括 扩展名 对话框。因为不能在 Lite 版本里比较目录/文件夹，因此无需定义哪些文件类型默认解释为文本文件（与二进制文件相对）。


销售

订购 UltraCompare 的信息请参见我们的网站：

http://www.ultraedit.com.cn

或者使用下面的电话联系我们：

电话： 86-21-6212 3939

传真： 86-21-5240 0179

如果有关于价格或许可方式的问题，请联系： info@ultraedit.com.cn


技术支持

如果您已注册并购买了许可，就可以获取 UltraCompare 的免费支持。

免费电子邮件支持

要获得免费技术支持，请将任何问题/建议发送电子邮件到 info@ultraedit.com.cn。

免费用户对用户支持论坛

用户可以在我们网站上的 UltraCompare 用户论坛里交流技巧和心得。它不是用来取代技术支持，但用户经常可以互相帮助并有助于创建用户社区。


许可协议（已注册）
上一主题

这是您 (个人或团体) 和 IDM Computer Solutions, Inc 之间的法律协议。您一旦购买安装、复制或以其他方式使用该软件，即表示您同意接受本协议各项条款的约束。

软件许可

1. 许可承诺。如果您属于上述定义的正版软件产品用户，这份许可协议 (许可) 允许您使用单个副本，或多个副本，包括在线提供的用户说明或电子表单 (软件)。该软件作为单一产品许可给单用户、多用户的用户组许可和站点许可。这份协议明确规定每个软件均需获取许可，不管是单用户，或用户组成员。多用户许可提供指定数量的用户同时使用这个软件。我们提供共同使用一个副本的用户许可，但必须有明确授权，并支付了普通许可费用之外的附加费用。这个软件的每个用户必须为单用户许可、或多用户许可中的其中之一。当该软件载入到电脑的临时存贮器 (即 RAM) 或安装到永久存贮器 (例如硬盘)，即说明该软件已在使用。这个软件可以安装到网络中，但必须保证实施了适当的规章，限制该软件仅供注册用户使用。

2. 著作权。 软件的所有物理副本属注册用户所有，但软件的使用受上述条款限制 (许可承诺)。该软件受中华人民共和国法律和国际公约保护。所有的知识产权属 IDM Computer Solutions, Inc. 所有。您不得复制软件附属的可打印内容 (如果有)，也不得打印任何在线提供的用户文档或电子表单，除非上述 (许可承诺) 指定的合法注册用户专用。您不得以任何形式重新发布提供给您的注册码，这些形式包括纸张形式、电子形式或任何其它形式。

3. 其它限制。 这里提供的显示您验证码的注册通知和这份许可，是您有权在此使用该软件的证据，必须由您保留。您不能出租或租赁该软件。您不能进行反向工程、反编译或反汇编该软件。

有限保证

有限保证。本协议提供您自购买日期起一年的免费升级。

免责声明。 上述担保，无论是明示或暗喻的，为担保的全部内容，包括对特殊应用目的的商品性和适应性担保。在适用法律所允许的最大范围内，IDM Computer Solutions, Inc. 或其代理商、销售人绝不就因使用或不能使用本“软件”所引起的或有关的任何间接的、意外的、直接的、非直接的、特殊的、惩罚性的或其它任何损害赔偿（包括但不限于因人身伤害或财产损坏而造成的损害赔偿，因利润损失、营业中断、商业信息的遗失而造成的损害赔偿，因未能履行包括诚信或相当注意在内的任何责任致使隐私泄露而造成的害赔偿，因疏忽而造成的损害赔偿，或因任何金钱上的损失或任何其损它损失而造成的损害赔偿）承担赔偿责任，即使 IDM Computer Solutions, Inc. 或其任何代理商、销售人事先被告知该损害发生的可能性。即使补救措施未能达到预定目的，本损害赔偿排除条款将仍然有效。

本许可协议受中华人民共和国法律和国际公约的保护。本许可协议如与英文版 License Agreement 之间存在任何歧义，以英文版为准。


颜色

颜色（选项菜单）

“颜色”对话框允许用户指定颜色首选项，用作“文本”和“文件夹”比较的对比色。点击文本标签旁的有色矩形框，将显示一个对话框供用户为显示的项目选择颜色。

可以按下“使用默认值”按钮还原为默认的颜色。


创建备份文件

创建备份文件（选项菜单）

该命令可用于创建比较文件的备份。重复合并命令之前建议进行此操作，以保留“基准”文件供需要时进行还原。


文件夹

文件夹（配置－显示）

文件夹分支位于配置－显示之下，包含以下选项：

颜色和字体设置

用户可以指定用于文件夹比较的偏好的对比颜色点击文本标签旁的有色矩形框，将显示一个对话框供用户为显示的项目选择颜色。

加载颜色方案

已预定义两种颜色方案。 如果需要，用户可以通过选择下拉菜单中提供的选项，从而进行选择。

字体设置

按下字体设置按钮将打开默认系统“字体”对话框，在此用户可以定义用于文件夹比较的字体，包括设置字体样式、大小和脚本的选项。

按下使用默认按钮可以恢复文件夹比价的默认颜色/字体设置。


字体

字体（选项菜单）

该选项将提供“设置字体”对话框，允许用户指定字体用于活动显示，包括设置要使用的字体样式、大小和字形的选项。

在二进制（智能/快速）比较模式里，只能选择等宽字体。


FTP/SFTP 帐号管理器

这个对话框可以让用户来配置 FTP/SFTP帐号。 该帐号用于 FTP 打开 和 FTP 另存为 命令。

帐号用来指定连接服务器和将在连接到服务器时使用的用户标识。 新建帐号按钮允许你指定一个新的帐号名字。

新建帐号按钮允许你指定一个新的帐号名称。帐号可以从帐号列表中选择，并进行修改。 如果在帐号中作了任何修改，将会显示一个提示，询问您是否保留更改。

删除帐号按钮可以立即将活动/选中的帐号从帐号列表中删除。

设置默认帐号按钮可以将活动/选中的帐户设置为默认，通过在列表中的帐户名称前添加星号“*”。

FTP/SFTP 帐户管理器的选项位于四个不同的选项卡中：常规、高级、代理服务器和 SSH。

常规选项卡包含以下配置选项：

帐户

这是配置的帐号使用的名称。 保存更改时改名称将出现在配置选项左边的列表中。

协议

该下拉菜单允许用户选择帐号使用 FTP 或 SFTP 协议。 如果选择SFTP，则要求 UltraCompare 仅使用 SSH2 协议连接到 SECURE FTP（SFTP）。所有传送的数据均被加密，并且加密算法已与服务器约定。 如果设置了这个选项，传输对话框将显示一个“锁”符号，表示传输是安全的。

服务器

这是您想连接的 ftp 站点，如 ftp://ftp.idmcomp.com。还可以输入为 ftp.idmcomp.com。如果更喜欢还可以输入 IP 地址，格式为 xxxx.xxxx.xxxx.xxxx。

端口

这是 UltraCompare 用于 FTP/SFTP 协议的端口。FTP 的默认端口是 21，SFTP 的默认端口是 22。如果需要可以进行更改。

用户名

这是用来登录服务器的用户名。

密码

这是用于登录服务器的用户名的密码。可以是站点管理员提供的或用于匿名登录的用户名密码，通常是用户的邮件地址。

用户帐号

如果选择保存密码，它将加密贮存于系统中。 但是，加密方法比较简单，不依赖于安全方法。

初始目录

这是连接到 FTP 服务器的初始路径。不是必须字段。如果尚未指定，则 UltraCompare 将在每次用户连接到服务器时记住帐户上次使用的路径。

默认密码是 @。

该复选框决定 UltraCompare 是否将保存密码以便以后使用。如果否，则在需要时提示用户输入密码。注意：如果保存密码则密码保存在系统中。尽管密码是加密的，但机密机制非常简单且不应作为一种安全的方法。

高级选项卡包含以下配置选项：

本地目录

这允许用户在保存文件时指定文件应该自动保存本地副本的位置。如果留空则不保存本地副本。如果不为空，则进行 FTP 保存（不是另存为）时，文件副本将保存到指定目录。如果存在其他相同名称的文件则会将其覆盖而不进行警告。将在 FTP 保存之前进行本地备份。

如果未保存，则缓存会话密码

如果选中这个选项，那么输入的帐号密码在 UltraCompare 运行期间将被缓存，不需要重新输入密码。 如果密码输入错误，需要进行更改，只要打开帐号对话框，然后关闭，它将清除缓存。

默认传输类型

用户可以指定 ASCII 和 二进制作为默认传输类型。 ASCII 可以在不同系统间适当地转换行中止。 二进制则逐字节地传输文件而不进行转换。

服务器类型

对于多数 FTP 服务器，默认的 Auto 或 Unix 工作应该没有问题。 可是连接到服务器需要特殊处理。支持的服务器列表有待增加。当前已支持:

自动

AIX

VAX/VMS

UNIX

Stratus VOS - “完整路径首位字符”应该设置为“%”以及“路径/节点分隔符”应该设置为“>”。

仅文件名 - 获取第一个返回对象，并以文件名显示它

BS2000

OS9000

AS400

MVS

HP3000/VeSoft Security

会话名称

该字段可以用于定义活动帐号的会话名称。 仅用于 HP3000 帐号。

完整路径首位字符

这允许用户覆盖服务器上完整路径的首字符（通常为“/”）。

路径/节点分隔符

这允许用户覆盖用在服务器目录/节点之间的字符（通常为“/”）。

名称索引

该字段用来指定保存文件名称的列编号。 默认值为“-1”且除非您认为该值错误，否则请勿更改。

大小索引

该字段用来指定保存文件大小的列编号。 默认值为“-1”且除非您认为该值错误，否则请勿更改。

使用 MDTM 和 SIZE

如果文件的修改时间和大小无法正确显示 则应选中该选项，以便在目录列表中强制要求使用这些值。 选中该选项将可能减慢 FTP 的处理速度。

被动传输

在使用某些防火墙的情况下，需要设置为被动模式才能连接。 如果你通过防火墙连接到一个帐号有问题，可能需要启用被动传输模式。

使用服务器返回的 IP 地址

该值仅在选中被动传输时使用。 选中该选项使得连接到服务器时帐号使用防火墙指定的 IP 地址。 请注意：如果无法控制连接到的服务器或无法确定其内容，则选中该选项存在一定的安全风险，

代理服务器标签包含以下配置选项：

使用代理服务器

可以启用代理服务器设置并配置该帐户连接到指定的代理服务器。 如果直接连接到 Internet 则不应启用代理服务器设置。如果在 LAN 中通过代理服务器连接则需要设置代理服务器。

代理服务器

这是代理服务器使用的服务器名称（或 IP 地址）。如果不知道名称 ，请与系统管理员联系。

代理服务器端口

这是 UltraCompare 用于 FTP/SFTP 协议的端口。FTP 的默认端口是 21，SFTP 的默认端口是 22。如果需要可以进行更改。

SSH 选项卡包含以下配置选项：

验证

允许用户指定用于服务器的验证类型。 支持下列方法：

仅密码 | 需要提供用户名/密码，不需要公共/私人密钥成对使用。
仅公共密钥 | 需要使用公共/私人成对密钥。 私人密钥位置必须在私人密钥路径中指定。
密码和公共密钥 | 允许用户指定公共/私人密码和/或用户名/密码。

如果使用的方法需要一个密钥，密钥需要密码选项允许用户指定用密码保存的私人密钥。 如果是这种情况，每次会话或更改帐号设置会提示输入密码。

服务器必须支持该验证方法。 使用的密钥应该是 OpenSSH 格式，也可以是 RSA 或 DSA 类型的密钥。

启用压缩

如果选中该选项则数据传输从/到服务器时将被压缩。 根据服务器配置可能提高传输速度。


忽略选项

忽略选项（选项菜单）

当选择该选项时，显示一个对话框可以用来定义定制规则，忽略比较文件之间的差异。用户可以在此选择默认的忽略选项（空行、空格、大小写、换行符差异）。

忽略这些行

该区域可以用来定义忽略规则，基于行首或行尾的字符串来忽略，或忽略含有特定字符串的行。

忽略定义的行数

该区域允许用户定义文件开头或结尾处要忽略的行数，以进行比较。

忽略空格

该选项在识别活动文件中的差异时强制比较忽略制表符和空格

忽略换行符

该选项强制比较忽略活动文件中的换行符差异（DOS/UNIX/MAC）

忽略行

这一部分可以用来按照行首或行尾的字符串定义忽略规则，或忽略包含指定字符串的行。

忽略定义的行数

这一部分允许用户定义文件开头或结尾要忽略的行，以便进行比较。


Folder

Folder (Configuration - Ignore Options)

The Folder branch under Configuration - Ignore Options has the following options:

Ignore files/folder types

This control may be used to to add a semi-colon delimited list of folders, files, and file extensions to be ignored in Folder Compare Mode. For example, a user may enter ‘CVS’ and any time the file or folder CVS is located in a folder it will be ignored when executing and displaying a folder compare. A user may even enter an absolute path to a file/folder to be ignored. An asterisk (*) can be used as a wild card. In order to ignore all files of a particular type the asterisk will be used with the file extension. For example, a user may enter the line ‘*.txt;*.php;*.asm’ and the file extensions .txt, .php, and .asm will be ignored when executing and displaying a folder compare.


文本

文本（配置－显示）

文本分支位于配置－显示之下，包含以下选项：

颜色和字体设置

用户可以指定用于文本比较的偏好对比颜色。点击文本标签旁的有色矩形框，将显示一个对话框供用户为显示的项目选择颜色。

加载颜色方案

已预定义两种颜色方案。 如果需要，用户可以通过选择下拉菜单中提供的选项，从而进行选择。

标记空行

如果选中该选项，将在比较面板中使用预备的蓝色和白色垂直行表示空行。 如果未选中该选项，则遇到空行时比较面板的背景颜色不会更改。

字体设置

按下字体设置按钮将显示默认系统字体对话框，在此用户可以定义文本比较使用的字体，包括设置字体样式、大小和脚本的选项。

仅高亮显示活动框架

如果选中该选项，则在三方比较中将仅高亮显示两个活动框架中的字符差异。 如果未选中该选项，则高亮显示三个框架以便表示字符差异。

按下使用默认按钮可以恢复文本比较的默认颜色/字体设置。


工具栏/菜单

工具栏/菜单 （配置）

工具栏/菜单分支位于配置－工具栏/菜单下，包含以下选项：

定制工具栏

按下此按钮将显示工具栏配置对话框，包括标记为工具栏和命令的两个窗格，并带有新工具栏使用的文本输入区域。对话框中还包含上/下和左/右箭头。这些项目及其功能如下所述：

工具栏/命令配置窗格

指定的工具栏显示于工具栏窗格中，并在资源管理器界面里显示当前分配给它们的项目。 点击工具栏名称左边的“-”将折叠该工具栏，而点击“+”将展开工具栏显示其中包含的项目。 如果在工具栏里选中项目，按下上/下箭头将把该项目相应地移动到工具栏列表。 无法使用上/下箭头将项目从一个工具栏移动到相邻的其它工具栏。

命令窗格显示当前可供工具栏里使用的所有功能。 要将项目从命令窗格移动到工具栏窗格，请点击所需的命令项目并在对话框中央按下左箭头以添加选中的项目。 选定的工具栏项目将直接添加到工具栏窗格中当前选定项目之下。 如果在“工具栏”窗格没有选择，则该项目将添加到列出的第一个工具栏顶部。 一旦添加了项目，就可以在工具栏里使用上下箭头随意移动它们。

新建工具栏

要创建新工具栏，请在“新工具栏”区域输入工具栏名称（例如：“Test1”），并按下“新工具栏”区域右侧的左箭头按钮。 这将添加新的空工具栏到工具栏列表底部。 移动工具栏可以通过选择工具栏并按下对话框中央的右箭头按钮。

管理工具栏

按下该按钮将显示工具栏配置对话框。

定制菜单

按下该按钮将显示菜单配置对话框，包括两个标记为菜单和命令的窗格，以及新建菜单/子菜单使用的文本输入区域。如果选中菜单上的使用检查标记，则将为选中的菜单项目显示检查标记而非按下的菜单图标。 该选项有助于解决残障用户的屏幕阅读器上出现的一些问题。该对话框还包括上/下和左/右箭头以及编辑按钮。这些项目及其功能如下所述：

工具栏/命令配置窗格

当前活动的菜单将显示在“菜单”窗格之内，并在资源管理器界面里显示当前给它们分配的项目。 每个菜单或子菜单标题均标记为：一行的结尾是菜单/子菜单名称左边的方框。 双击标题符号将适当地展开/折叠所含的项目。

如果选中菜单标题或项目，并按下编辑按钮，则可以修改该菜单/项目的名称。 按下键盘上的回车将保存菜单项目更改，而按下确定按钮将提交这些更改，以便将其反映到菜单中。

选中菜单标题时，可以使用上/下和左/右箭头移动整个菜单到新位置。 选中一个菜单项目时，可以使用上/下按钮将项目移动到当前菜单内的新位置。 菜单项目可以移动到当前菜单的最顶部或最底部。 如果一个菜单项目是子菜单的一部分，则无法将其移到子菜单之外。 如果一个菜单项目是主菜单的一部分，上移或下移它都会使其“跳过”遇到的任何子菜单。

命令窗格显示菜单里当前可以使用的所有功能。 要将项目从命令窗格移动到菜单窗格，请点击所需的命令并在对话框中央按下左箭头以添加选中的项目。 选中的菜单项目将直接添加到“菜单”窗格里当前选定的项目之下。 如果在菜单窗格里没有选择，则该项目将添加到所列的第一个菜单顶部。 一旦添加了项目，就可以使用上下箭头在菜单内随意移动它们。

新建菜单

要创建新的菜单/子菜单，请在“新菜单”区域输入菜单/子菜单名称（例如：Test1”）并按下“新菜单”区域右边的左箭头按钮。 它将添加新的空菜单到菜单列表底部。 可以选择菜单并按下对话框中央的右箭头按钮，来删除它们。

管理菜单

按此按钮将显示菜单配置对话框。