使用帮助
         Next Topic

这些帮助文件是根据 UltraEdit / UEStudio 的菜单功能组织而成的。主要包括下列主标题:

开始

菜单/工具栏

菜单概要

* 编译器配置

* CVS 支持

常见问题解答

许可声明

销售和支持

开始部分 (就是第一个文档) 包含快速运行 UltraEdit 和在 UltraEdit 中进行编辑的有用的信息。

菜单概要段可以通过双击它展开，它由一些在 UltraEdit 菜单中出现的有关命令信息组成。每个菜单标题 (文件菜单，编辑菜单等) 可以通过双击再次展开，并且菜单标题下面的每个主题可能通过单击列表中的主题标题打开。你也可以双击一个段的标题将它折叠。

常见问题解答段包含一些有关 UltraEdit 的功能和用法的常见问题。

许可声明段包括注册版本和未注册版本的 UltraEdit-32 的信息。

销售和支持段包含有关技术支持和购买 UltraEdit-32 的信息。

* 请注意: 这些功能只在 UEStudio 中支持，UltraEdit-32 不支持这些功能。


块选文本

在 列模式 中，对于选择文本的编辑器操作方式已被改变。当选择列模式时，加亮的文本是基于选定文本中第一个选定的字符位置到最后一个字符位置的字符列。在这个模式中选定的文本不会自动包含开始和结束位置的所有文本，但包含选定的第一个字符和最后一个字符之间的列中的所有文本，列模式编辑有时涉及到块模式编辑，表现在选择文本的形状是一个矩形。


ClassViewer

类观察器

可以通过在 UEStudio 里的智能提示工具栏上点击跳转到类观察器按钮来调用类观察器

或者通过点击“工作区管理器”的标签 选项卡

这将会显示已分析的活动方案表示。

在 UEStudio 中“工作区管理器”的标签窗格下显示的项目替换了 Ctags。 双击这些项目中的一个将打开关联的方案文档。

符号 | 含义
 | 结构
 | 类
 | 全局文件夹
 | 全局其它文件夹
 | 全局函数文件夹
 | 全局标号文件夹
 | 全局宏文件夹
 | 全局变量文件夹
 | 枚举（enum）
 | 名称空间
 | 枚举值
 | 变量
 | 受保护的变量
 | 专用变量
 | 全局变量
 | 函数
 | 受保护的函数
 | 专用函数
 | 类型定义（Typedef）
 | 宏


代码折叠

代码折叠是 UltraEdit-32 v11.00 和 UEStudio 中的工具，与以前版本中已有的 隐藏/显示行 功能协同工作。

在 普通配置页 的显示段下有两个配置选项，用来确定是否在 UltraEdit 中启用代码折叠和隐藏/显示行功能支持: 启用显示/隐藏行和代码折叠功能和启用非语法加亮文件的显示/隐藏行功能。

启用显示/隐藏行和代码折叠功能

如果在配置中选中了这个选项，那么可以通过视图菜单选项调用隐藏/显示行命令。选择这个配置选项还可以启用代码折叠，在行号和编辑窗口之间会出现一条小指示带，在那里将显示用于代码折叠的符号 (“+”和“-”)。按默认，代码折叠可以在词语文件中以 /Open Fold Strings 或 /Close Fold Strings 定义的任何字符 (无论是字符 - “{、}” - 或词语 - “if、endif”)。请查阅语法加亮获取有关折叠字符的进一步信息。

如果在折叠提示区中显示“+”或“-”，相关代码的折叠状态可能通过左键单击折叠提示区中的符号进行切换。例如，在下列代码中:

点击“+”展开原选折叠的代码。点击“-”:

将折叠原先展开的代码。

从视图菜单可以选择两个折叠选项: 全部展开和全部折叠。

全部展开

当从视图菜单调用这个命令时，活动文件中所有用活动词语文件中定义的缩进/取消缩进字符区域内的所有块将被展开。如果选择了部分文本，则只影响选定的区域。如果没有选定的文本，这个命令将在整个活动文件中进行操作。

请注意: 当调用这个命令时，使用 隐藏行命令 隐藏的字符将被象折叠的代码段一样展开。

全部折叠

当从视图菜单调用这个命令时，活动文件中所有用活动词语文件中定义的缩进/取消缩进字符区域内的所有块将被折叠。如果选择了部分文本，则只影响选定的区域。如果没有选定的文本，这个命令将在整个活动文件中进行操作。

启用非语法加亮文件的显示/隐藏行功能

如果在配置中选中了这个选项，那么可以通过视图菜单选项调用隐藏/显示行命令，即使该文件没有语法加亮 (例如在标准的文本文件中)。这个好处是用隐藏/显示行命令隐藏的行将在折叠提示区中用“+”指示。如果未选中这个选项，非加亮文件的文本不能隐藏，也不会显示折叠提示区。


创建第一个应用程序

从 UEStudio 里创建，构建，并运行应用程序轻而易举！首先，点击方案菜单并选择 方案管理器 .

接着，在方案管理器里点击创建按钮并从上下文菜单选择使用模板。

从 新方案对话框 .的编译器窗格[1]里选择编译器。（请注意： 必须将选择的编译器安装到系统上，以便从 UEStudio 里调用它）。然后从模板窗格[2]选择希望创建的应用程序。一旦选择了应用程序模板，请在方案名称文本字段[3]里输入方案名称，并指定希望创建该方案的位置[4]或路径，并点击 创建按钮[5]。

一旦按下创建按钮，UEStudio 将启动Windows 应用程序向导对话框，可以在其中指定希望创建的应用程序的一般框架。请注意：以下示例是通过 Microsoft Visual C++ 编译器和 Windows 应用程序模板创建的。在应用程序向导里显示的选项将针对不同的编译器和模板。

选择所需的选项并按下创建按钮，以完成创建第一个方案和应用程序！

现在可以构建应用程序了，只需在 构建工具栏 里按下构建按钮:

UEStudio 将显示 编辑器选项对话框 ，按下确定将生成您的第一个应用程序！请注意：以下显示的选项基于已选的 Microsoft Visual C++ 编译器。在编译器选项对话框里显示的选项将针对不同的编译器。

UEStudio 将构建并分析新的应用程序，而 输出窗口 将显示构建何时完成，并且列出构建过程中遇到的任何错误：

现在应用程序已构建完毕，剩下要做的就是运行该应用程序！可以在 构建工具栏 中按下运行按钮：

UEStudio'05 将启动新创建和构建的应用程序！

请注意：一旦到达这一步，菜单和工具栏按钮（如果您创建和构建的应用程序中包括） 还未发生实际功用。已创建框架，但功能需要另外编程。在 工作区管理器 里双击关联的源文件，将在 UEStudio 里打开源文件，以便添加进一步的功能。


光标箭头 (光标动作)

“上”、“下”、“左”、“右”箭头按钮用来将光标位置按一个字符或一行向各自的方向移动。

在使用“左”、“右”箭头时按下 CTRL 键，使光标位置移动到上一个或下一个单词的词首。

在使用“上”、“下”箭头时按下 CTRL 键，则不影响光标位置，但编辑器窗口的文本分别上下移动。如果最上边或最下边文本已处于编辑器窗口中，那么光标就象普通使用“上”、“下”箭头一样移动一行。

在使用“左”、“右”箭头时按下 ALT 键，则使光标移动到上一段落或下一段落的起始位置。


拖放编辑

UltraEdit 支持鼠标的拖放编辑。

拖放编辑允许用户用普通方式选择文本，然后通过用鼠标拖放到一个新位置的方式来复制或移动选定的文本，不一定需要键盘配合。

开始用户只需要按普通方式选择文本，文本选定后，用户可以在选定的文本上点击鼠标主键 (通常是左键)，此时鼠标的指针变成下部带一个虚的矩形框的指针。这个指针说明当前处于拖放编辑模式，你可以拖动选区到一个新的位置来完成拖放编辑。

当鼠标左键按下并保持按下状态，就可以将选定的文本拖动到新的位置。 当你移动鼠标时，光标将跟随着鼠标，这时光标所处的位置就是在你松开鼠标 (就是“放下”文本) 后文本的新位置。

用户也可以将文本拖放到 UltraEdit 内部的其它文件中。如果鼠标定位在 UltraEdit 内部的其它文件上，该文件将被激活，文本可以放置到该文件中光标所处的位置。

在任何时候，按下 ESC 键将取消拖放模式。

另外，用拖放移动文本也可以改为用拖放复制文件到新位置。如果在拖放编辑模式中按下 CTRL 键，鼠标指针会变成旁边有一个小的“+”符号的指针，说明文本将被复制到新的位置，同时原始文本还保留在原来的位置。

拖放编辑支持普通、 十六进制 和 列 编辑模式。


拖放文件

UltraEdit 支持从文件管理器拖放文件到一个打开的 UltraEdit 窗口中。可以从文件管理器选择文件 (可以选择多个文件) 并拖放到 UltraEdit 窗口。如果将鼠标悬浮在 UltraEdit 上释放鼠标键，选定的文件将自动用 UltraEdit 打开并进行编辑。


Home 和 End 键 (光标动作)

按“Home”键将光标移动到光标所在行的行首。在按“Home”键时按下 CTRL 键，则将光标移动到文档起始位置。

按“End”键将光标移动到光标所在行的行尾。在按“End“键时按下 CTRL 键则将光标移动到文档结尾位置。


文件树视图界面

UltraEdit-32 和 UEStudio 的重要特点是增强的文件树视图。可以通过在视图菜单的“视图/列表”子菜单中选择“文件树视图”来切换其是否可见，或者按 Ctrl+U。

用户可以在方案、打开、资源管理器和列表显示模式之间进行切换。

方案模式：在顶部列出方案名，显示活动方案中的所有文件和文件夹。

如果在方案模式中，没有选择文件树视图中的项目，或只选中了方案名，上下文菜单中将显示下列项目：

资源管理器 | 在资源管理器中显示活动方案目录
刷新 | 更新方案信息（提交更改）并刷新方案列表
添加文件夹 | 显示新建文件夹对话框
添加新文件 | 显示新建文件对话框，在此用户指定要添加的文件
添加活动文件 | 添加当前在编辑窗口打开的文件到活动方案中
添加所有打开文件 | 添加所有打开的文件到活动方案中
添加文件到方案 | 弹出打开对话框，指定或选择要添加到方案的文件。如果在包含的下拉框中没有指定子文件夹，那么文件将添加到方案的根目录。
打开方案中的文件 | 弹出打开方案中的文件对话框。
* 编译器选项 | 显示编译器选项对话框
设置 | 显示方案设置对话框

如果在方案模式中，已选定了文件树视图中一个文件夹或文件，上下文菜单将显示下列项目：

打开 | 打开活动方案中选定的文件/文件夹
资源管理器 | 打开资源管理器，显示选定的文件/文件夹目录
从方案中删除 | 从活动方案中删除选定的文件/文件夹
* 添加到环境 | 显示添加/修改环境变量对话框

打开模式：显示当前打开的所有文件。

打开模式的上下文菜单包含以下项目：

关闭文件 | 关闭选定的文件
保存文件 | 保存选定的文件
打印文件 | 打印选定的文件
水平平铺窗口 | 水平平铺所有打开的文件
垂直平铺窗口 | 垂直平铺所有打开的文件
将文件夹设置为活动文件路径 | 将活动文件路径设置为当前选定的文件路径
只显示名称 | 如果选中则仅显示文件名（不显示路径）
根据扩展名分类 | 根据扩展名对列出的文件分组

资源管理器模式：为本地/网络驱动器和可移动媒体显示文件树视图。

如果在资源管理器模式中没有选中内容，在文件树视图中单击右键将显示下列上下文菜单：

刷新 | 更新所有硬盘驱动器和可移动媒体的列表
设置过滤器 | 显示文件过滤器对话框

如果在资源管理器模式中选中文件，在文件树视图中单击右键将显示下列上下文菜单：

重命名文件 | 将焦点从活动文件名称转到允许重命名
打开文件 | 在编辑窗口打开活动文件
属性 | 显示活动文件的 Windows 属性对话框
删除文件 | 删除选定的文件
将文件夹设为活动文件路径 | 设置选中的文件文件夹作为活动文件路径
Windows 目录 | 切换焦点到 Windows 目录
System 目录 | 切换焦点到 System 目录
My Documents | 切换到用户的 My Documents 目录
应用程序 | 切换到 Application Data 目录

如果在资源管理器模式中选中文件夹，在文件树视图中单击右键将显示下列上下文菜单：

刷新 | 更新所有硬盘驱动器和可移动媒体的列表
设置目录为根目录 | 在编辑窗口打开活动文件
在目录中搜索文件 | 启动“在文件中搜索”对话框，目录设置为选中的目录
在目录中替换文件 | 启动“在文件中替换”对话框，目录设置为选中的目录
重命名文件 | 将焦点从活动文件夹名称转到允许重命名
打开文件 | 扩展选中文件夹的目录列表
属性 | 显示活动文件的 Windows 属性对话框
删除文件 | 删除选定的文件
将文件夹设为活动文件路径 | 设置选中的文件夹作为活动文件路径
Windows 目录 | 切换焦点到 Windows 目录
System 目录 | 切换焦点到 System 目录
My Documents | 切换到用户的 My Documents 目录
应用程序 | 切换到 Application Data 目录

列表模式：为收藏夹和用户创建的组显示树视图。

如果焦点位于组合框中，您可以输入新列表标题的名称（如 Personal），然后按“+”按钮将新标题添加到列表中。 然后需要要添加项目到其中的列表，按浏览按钮“...”显示上下文菜单，其中包含选项添加文件夹和添加文件。 如果在列表窗口中选中项目并按“-”按钮，选中的项目将从列表中删除。

UEStudio 界面

UEStudio 在文件树视图的底部新增了三个标签，UltraEdit-32 不具备这些标签。

当选择 * 文件标签时，显示在顶部的三个默认标签被激活并且可以进行相互选择。在 UEStudio 中，方案、打开和资源管理器模式用彩色的小正方形显示文件/模块，用来表示它们在 CVS 知识库中的相关状态。

颜色 | 含义
绿色 | 文件/模块已是最新且未修改
蓝色 | 文件/模块当前并未在 CVS 控制下
黄色 | 文件/模块已更改
红色 | 文件/模块包含冲突

选中 * 资源标签时，将列出活动方案的资源。 如果在资源模式下的文件树视图中选定一个文件夹，将在上下文菜单中显示以下项目：

保存资源 | 保存活动方案中已修改的资源
插入 | 将所选的资源文件夹插入所选资源文件夹下的活动方案中
导入 | 弹出“文件打开”对话框，可以从中选择要导入的项目
编辑器配置 | 弹出资源编辑器配置对话框，在此用户可以指定位图编辑器、图标编辑器或光标编辑器的路径

如果在资源模式中选中文件，右键单击文件树视图将弹出下列上下文菜单：

打开 | 打开选定的数据、对话框或菜单资源进行编辑。如果选中位图、光标、图标或工具栏资源，将调用相关联的编辑器。如果选中加速器或字串表资源，则显示加速键对话框 或 字符串对话框 ，允许编辑所选资源。
打开二进制数据 | 在二进制/十六进制模式中打开选择的资源
删除资源 | 从活动方案中将所选资源删除
保存资源 | 在活动方案中保存已修改的资源
插入复制 | 将选中的资源插入所选资源下的活动方案中
插入 | 弹出插入资源对话框，在此用户可以选择插入以下项目之一：加速器、位图、光标、对话框、图标、菜单、工具栏、版本、字体、Html
导入 | 弹出“文件打开”对话框，可以从中选择要导入的项目
编辑器配置 | 弹出资源编辑器配置对话框，在此用户可以指定位图编辑器、图标编辑器或光标编辑器的路径

当 * 标签选项卡为选中的类型，则显示在方案内部定义的结构体和其他符号。在这些项目下方也将列出全局（函数、标签、宏和变量）项目。如果双击显示的符号，将打开相应的源文件，并指向定义/声明该符号的行。在 UEStudio 中，该界面取代了在 UltraEdit-32 中使用的 Ctags 机制。

如果选中标签，右键单击文件树视图将弹出下列上下文菜单：

转到定义 | 打开定义符号的文件转到定义的行
在活动文档中查找符号 | 在输出窗口中列出活动文档中符号的出现
在方案文件中查找符号 | 在输出窗口中列出活动方案中符号的出现

* 请注意：这些功能仅在 UEStudio 中支持，在 UltraEdit-32 中不支持。


插入/覆盖模式

UltraEdit 允许在插入或覆盖模式中进行编辑。该操作模式在 UltraEdit 窗口底部的状态栏中显示。插入/覆盖模式用键盘上的 INSERT 键进行切换。当按下 INSERT 键时，该模式被切换。

如果选择了插入模式，状态栏的第二个区域显示“插入”；如果选择了覆盖模式，状态栏的第二个区域显示“覆盖”。

插入模式是将输入的字符插入到文档中的光标位置；覆盖模式是光标右边的字符用输入的字符直接覆盖。

如果编辑器的活动窗口处于 十六进制模式 ，那么活动窗口总是处于覆盖模式。要在十六进制中插入文本，请使用 十六进制插入/删除命令 (在 编辑菜单 )。


插入特殊字符

UltraEdit 添加了一个特殊支持，允许很方便地插入美式键盘中不支持的字符。这些字符为:

Ctrl+Shift+a | 插入 ä 字符
Ctrl+Shift+A | 插入 Ä 字符 (Caps Lock 开)
Ctrl+Shift+o | 插入 ö 字符
Ctrl+Shift+O | 插入 Ö 字符 (Caps Lock 开)
Ctrl+Shift+u | 插入 ü 字符
Ctrl+Shift+U | 插入 Ü 字符 (Caps Lock 开)
Ctrl+Shift+s | 插入 ß 字符
Ctrl+Shift+S | 插入 ß 字符 (Caps Lock 开)

也可以插入任何 ASCII 字符表 (在 视图菜单 ) 中列出的字符。在数字键盘中输入字符的四位数的同时按下 ALT 键就可以输入。例如“¿”可以用按下 ALT 键并输入“0191”的方法插入，“Æ”可以用按下 ALT 键并输入“0198”的方法插入。


键盘命令

UltraEdit 对于一般经常使用的功能可以使用键盘命令，下面是可以使用的键盘命令:

F1 | 帮助 | 显示 UltraEdit 帮助
Shift+F1 | 上下文帮助 | 调用上下文帮助
Ctrl+N | 文件 - 新建 | 创建一个新文档
Ctrl+O | 文件-打开 | 打开一个已有的文档文件
Ctrl+Q | 文件 - 快速打开 | 不显示 文件打开对话框 打开一个已有的文档文件
Ctrl+F4 | 文件 - 关闭 | 关闭一个现有的文档
Ctrl+S | 文件 - 保存 | 保存活动文档
F12 | 文件 - 另存为 | 用一个新的名字保存活动文档
Ctrl+P | 文件 - 打印 | 打印活动文档
Ctrl+X | 编辑 - 剪切 | 从活动文档中剪切文本到剪贴板
Ctrl+C | 编辑 - 复制 | 从活动文档复制文本到剪贴板
Ctrl+V | 编辑 - 粘贴 | 从剪贴板粘贴文本到活动文档中
Ctrl+0-9 | 编辑 - 选择剪贴板 | 选择活动剪贴板
Ctrl+A | 编辑 - 全选 | 选择活动文档中的所有文本
Ctrl+Z | 编辑 - 撤销 | 如果可能，撤销最后一个动作
Ctrl+Y | 编辑 - 重做 | 如果可能，恢复最后一次撤销动作
Ctrl +J | 编辑 - 选择词语 | 选择当前词语 (类似于 双击 )
Ctrl+E | 编辑 - 删除行 | 删除光标所在的行
Ctrl+F11 | 编辑 - 删除到行首 | 删除从光标所处行行首到光标位置的文本
Ctrl+F12 | 编辑 - 删除到行末 | 删除从光标位置到光标所处行行末的文本
Ctrl+W | 切换自动换行 | 打开或关闭自动换行功能
F7 | 编辑 - 插入日期/时间 | 在光标处插入时间/日期
Alt+F3 或 Ctrl+F | 查找 | 查找一个字符串
Ctrl+F3 | 查找上一个 | 反方向 (向文件起始处) 重复最后一次查找动作
F3 | 找下一个 | 向文件末方向重复最后一次查找动作
Ctrl+B | 成对匹配 | 查找成对匹配字符 (,[,{ 或 },],)
Ctrl+R | 替换 | 查找并用其它字符替换找到的字符
Ctrl+G | 转到 | 转到指定行 (或十六进制地址)
Ctrl+U | 文件树视图 | 切换文件树视图
Ctrl+F8 | 标签列表 | 切换标签列表
Ctrl+T | 段落重排 | 重新格式化当前段落或选定的文本
Ctrl+F5 | 格式 - 转为小写字母 | 转换选定的文本到小写字母
Alt+F5 | 格式 - 转为大写字母 | 转换选定的文本到大写字母
F5 | 格式 - 字首大写 | 将选定文本中的每个词语第一个字符转为大写
Shift+F5 | 格式 - 转换大小写 | 转换所有选定文本中的字符的大小写格式
Ctrl+K | 编辑 - 拼写检查 | 调用拼写检查
Alt+C | 列模式 | 打开或关闭列/块模式
Ctrl+Backspace | 删除上一个词语 | 删除光标之前的词语
Ctrl+Delete | 删除下一个词语 | 删除光标之后的词语
Ctrl+I | 插入文字字符 | 在光标位置插入一个文字字符
插入 | 插入/覆盖模式 | 切换插入/覆盖模式
Ctrl+H | 十六进制编辑 | 切换十六进制编辑模式
Ctrl+D | 十六进制插入/删除 | 在十六进制模式插入或删除字符
Ctrl+F2 | 设置书签 | 切换书签的开/关状态
F2 | 转到书签 | 转到下一个书签
Ctrl+M | 运行宏 | 重新运行宏
Ctrl+L | 多次运行宏 | 按指定的次数运行一个宏
Ctrl+F6 | 下一个窗口 | 激活下一个文档窗口
Ctrl+Shift+F6 | 上一个窗口 | 激活上一个文档窗口
Alt+F4 | 退出 UltraEdit | 退出 UltraEdit
Alt+0-9 或 Shift+Alt+0-9 | 插入模板 | 插入用户定义模板
F9 | DOS 命令 | 运行 DOS 窗口命令
Ctrl+F9 | 最后一个 DOS 命令 | 重复最后一次运行的 DOS 窗口命令
F10 | 运行 Windows 程序 | 运行 Windows 程序
Ctrl+Shift+A | 插入 ä 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+A (Caps Lock 开) | 插入 Ä 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+O | 插入 ö 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+O (Caps Lock 开) | 插入 Ö 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+U | 插入 ü 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+U (Caps Lock 开) | 插入 Ü 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+S | 插入 ß 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Shift+S (Caps Lock 开) | 插入 ß 字符 | (根据字体确定 ANSI 或 ASCII 字符)
Ctrl+Up | 向上滚动 | 向上滚动一行，并保持光标在视图中位置
Ctrl+Down | 向下滚动 | 向下滚动一行，并保持光标在视图中位置
F4 | 更改焦点 | 如果树形视图是可见的，在活动文件和树形视图之间切换激活状态
F8 | 显示函数列表 | 显示函数列表
Alt+右箭头 | 下一段落 | 将光标移动到下一个段落的第一个非空格字符位置
Alt+左箭头 | 上一段落 | 将光标移动到当前段落的第一个非空格字符位置 (如果光标位于段落中间)，或上一个段落
Alt+Page Up | 窗口顶部 | 将光标放置到第一个显示行的行首
Alt+Page Down | 窗口底部 | 将光标放置到最后显示行的行首
Alt+'-' (仅数字键盘) | 滚动到顶部 | 将活动行置于窗口顶部
Alt+'+' (仅数字键盘) | 滚动到底部 | 将活动行置于窗口底部
Alt+'center' 或 Alt+'5' (仅数字键盘) | 滚动到中心 | 将活动行置于窗口居中位置
Ctrl+'1' (仅数字键盘 1) | 上一个词语末 | 将光标放置到上一个词语末
Ctrl+'2' (仅数字键盘 2) | 下一个词语末 | 将光标放置到下一个词语末
Ctrl+Insert | 远程复制 | 将远程客户端上选中的文本复制到剪贴板
Shift+Insert | 远程粘贴 | 将剪贴板内容粘贴到远程客户端


输出窗口

UEStudio 支持带四种不同的标签的输出窗口，允许在不覆盖上次函数运行结果的情况下，写入输出并贮存。

这个功能的好处是可以执行多个功能，并动态生成这些函数的可被分别贮存的输出，作为以后的参考 (在活动编辑会话期间)。所有的输出将写入到活动窗口。比如点击标签“1”并运行 在文件中查找 ，那么在文件中查找命令的结果将被写入到标签“1”关联的窗口。点击标签“3”并 构建 活动方案将会导致 STDOUT 和 STDERR 输出 (根据 编译器设置 ) 被写入到标签“3”关联的输出窗口。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。


Page Up 和 Page Down 键 (光标动作)

使用“Page Up”键可以将光标向上移动一页。在使用“Page Up”键按下 CTRL 键，将光标移动到编辑窗口的顶部。

使用“Page Down”键可以将光标向下移动一页。在使用“Page Down”键按下 CTRL 键，将光标移动到编辑窗口的底部。


注册 UltraEdit-32/UEStudio

由 UltraEdit-32/UEStudio 提供的用户名和授权码需要区分大小写，且必须和 IDM Computer Solutions, Inc 提供给您的完全相同。

从 Email 粘贴

用户可以粘贴整个注册邮件来注册产品，而非分别粘贴用户名和验证码。 从“帮助”菜单选择“注册”后显示“授权”对话框被选中，用户可以按从 Email 粘贴按钮，这是注册产品最简单和最推荐的方法。 将显示注册 - 从 Email 粘贴对话框。

如上面对话框所示，整个注册邮件复制到剪贴板并粘贴到注册 - 从 Email 粘贴对话框中。 UltraEdit-32/UEStudio 将自动分析注册消息并相应地注册产品。

手动注册

如果喜欢用户也可以从 IDM 发送的邮件中复制用户名和授权码到剪贴板（选中然后复制到剪贴板），然后粘贴到授权对话框的编辑框中（使用 Ctrl+V）。

请注意，如果用户名包括对用户数的引用，即：

"Acme Printing~ 8 User License"

它是注册名的一部分，必须与“Acme Printing”一道输入。

如果正确注册 UltraEdit-32/UEStudio 遇到任何问题，请发送电子邮件至 info@ultraeditchina.com，写明正尝试注册的 UltraEdit-32/UEStudio 版本以及所输入的确切用户名和授权码。我们将尽快回复您，以帮助您注册该许可。


资源编辑器

UEStudio 提供了资源浏览器和编辑器的特色功能。 添加、删除、浏览资源如您所愿。 编辑对话框、字符串表、菜单等等。 甚至可以配置 UEStudio 通过用户安装的图形编辑器来编辑位图和图标。

可编译方案加载到 UEStudio 之后，“资源编辑器”工具栏即活动。 如果在“工作区管理器”底部选择了“资源”选项卡

关联的对话框源可能已通过双击对话框图标或“工作区管理器”在 UEStudio 中打开。

要编辑的对话框源在编辑窗口可见时，有两个选项可供修改对话框。

1. 可能已直接修改对话框源，而保存的更改将写回方案资源。

2. 可能已点击“资源编辑器”工具栏中的“测试”按钮

以在预览模式下显示对话框。

可能已点击单独的控件并拖拽到对话框中的新位置。 可能已添加新控件，并可能删除了现有控件：

右键单击预览对话框将显示资源编辑器上下文菜单：

提供更直观的方式设计对话框，并且一旦达成期望的结果，即可通过从上下文菜单选择保存并退出来保存对话框的更改。

有广泛的选择可供将新控件添加到正在预览的对话框：


鼠标右键命令

UltraEdit 允许用鼠标键来打开弹出菜单。如果在文档窗口点击鼠标右键，那么将在鼠标点击的位置显示编辑菜单。如果在点击鼠标右键时有选定的文本，那么将在弹出菜单顶部会添加一个打开加亮文件的新的菜单项目，如果选择该菜单项目，将打开该文件 (如果存在)。

如果没有选中的文本，UltraEdit 将检查光标下面的文本，如果找到的内容认为有可能是一个文件，那么将添加到新的菜单项目“打开 ”，后面跟随的是将尝试打开的文件名。如果这是一个 URL，该信息将传递给默认浏览器打开。

如果在 UltraEdit 主窗口和文档窗口外部点击鼠标右键，则在鼠标点击位置显示文件菜单。


脚本演示和指南

UltraEdit/UEStudio 的脚本通过嵌入 JavaScript 引擎启用。 脚本引擎支持 JavaScript 1.7。 有关 JavaScript 1.7 的更多信息，请参考相关的 Mozilla 网站（http://developer.mozilla.org/en/docs/New_in_JavaScript_1.7）。

脚本指南

要查看简短的脚本指南，请点击这里。

演示脚本

演示脚本可以在 UltraEdit 安装目录的 scripts 子目录中找到（通常为 c:\Program Files\IDM Computer Solutions\UltraEdit-32\scripts）。 这些以及其他 JavaScript 脚本都可以在 UltraEdit 中直接打开进行编辑，使用内置的语法高亮，如下所示：

hello.js 脚本演示了支持脚本最简单的格式——写入活动文件的单行脚本：

要调用该脚本，请转到高级菜单中的脚本并点击子菜单中的脚本...条目。 将显示脚本配置对话框。 如果按添加按钮并导航至安装目录下的“scripts”目录，则可以将“hello.js”添加到可以运行的脚本列表中。 您可以通过点击“热键”字段并按所需的键来指定脚本的快捷键。 添加的脚本将在以上提到的脚本...子菜单底部动态更新，且可以通过热键或点击列表中的脚本名称进行调用。

为了完全独立运行，该脚本实际上创建了一个新的编辑文档进行编写，且该脚本可以在不打开任何文档的情况下运行。

stringvar.js 脚本显示了该脚本可以抓取用户的输入并将其存储在变量中以便将来使用：

该脚本可以像上述 hello.js 脚本一样进行调用。 要运行本演示，请打开任意文本文件并指定要搜索的字符串，以及希望查找到的次数。 该脚本随后将打开新的文档，并将匹配行的指定数量写入新文件。

header.js 脚本演示了使用 document JavaScript 阵列对象（UltraEdit 应用程序对象的属性之一）查找打开文件个数的功能 。 这是所有当前同时打开文档的阵列。 UltraEdit 是全部 UltraEdit 操作所基于的应用程序对象。 使用该信息，脚本将在所有打开的文档中重复写入预定义的标题：

有关脚本支持的命令的相关信息，请参见脚本命令帮助主题。


脚本命令

UltraEdit/UEStudio 的脚本通过嵌入 JavaScript 引擎启用。 这允许用户在享受完整 JavaScript 语言的强大和灵活的同时使用以下指定的命令与编辑器（应用程序对象命令），或在编辑器中打开的文档（文档对象命令）进行特别交互。 脚本可以在 UltraEdit/UEStudio 中编辑，在默认词语文件中带有内置 JavaScript 的语法加亮：

脚本引擎支持 JavaScript 1.7 的核心功能。 有关 JavaScript 的更多信息，请参考相关的 Mozilla 网站 (http://developer.mozilla.org/en/docs/JavaScript)。

例如，该脚本将生成一系列数字并将其写入活动的文档：

function recall(num) {

UltraEdit.activeDocument.write(num + "\r\n");

}

function num() {

var i = 0, j = 1, n = 0;

while (n < 10) {

recall(i);

var t = i;

i = j;

j += t;

n++;

}

}

num();

更多演示脚本位于安装目录的“scripts”子目录下。要查看简短的脚本指南，请点击这里。

应用程序对象命令

UltraEdit 是全部 UltraEdit 操作所基于的应用程序对象。以下命令作用于编辑器而非活动文档。 除非注明其他参数，否则所有应用程序对象命令都必须使用下列格式调用：

UltraEdit.commandName();

下表说明了应用程序对象命令：

命令

参数*

说明

clearClipboard

清除活动的剪贴板。

clipboardContent

** 这是只读属性。

返回当前剪贴板内容。例如:

var clip = UltraEdit.clipboardContent;

clipboardIdx

** 这是只读属性。

返回当前剪贴板的索引。例如：

var clip = UltraEdit.clipboardIdx;

closeFile

文件路径

保存模式

0 - 提示保存

1 - 保存并关闭

2 - 关闭不保存

关闭活动的文件。例如：

UltraEdit.closeFile("C:\\temp\\test.txt",2);

*注意：在参数中使用的任何反斜线必须按以上显示进行换码（即使用“\\”而非“\”）。

columnMode

** 这是只读属性。

返回布尔值说明列模式是否活动。例如：

var columnActive = UltraEdit.columnMode;

columnModeOff

关闭列模式。例如：

UltraEdit.columnModeOff();

*注意：脚本处理完成后当前列模式状态将恢复。

columnModeOn

打开列模式。例如：

UltraEdit.columnModeOn();

decryptFilePrompt

显示解密文件对话框。 例如：

UltraEdit.decryptFilePrompt();

encryptFilePrompt

显示加密文件对话框。 例如：

UltraEdit.encryptFilePrompt();

frInFiles

.directoryStart | 字符串 | 搜索开始的
完整路径
.filesToSearch | 整数 | 值：
 | 0 - 列出的文件 1 - 打开的文件 2 - 收藏的文件 3 - 项目文件 4 - 解决方案文件
.matchCase | 布尔值 | true/false
.matchWord | 布尔值 | true/false
.regExp | 布尔值 | true/false
.searchSubs | 布尔值 | true/false
.unicodeSearch | 布尔值 | true/false
.searchInFilesTypes | 字符串 | 搜索的文件/类型
 | 范围
.find ("要搜索的字符串");
.replace ("要搜索的字符串", "替换字符串");
** 仅在替换中使用 **
.logChanges | 布尔值 | true/false
.preserveCase | 布尔值 | true/false
** 仅无法在替换中使用 **
.useOutputWindow | 布尔值 | true/false

在指定的文件中搜索，基于指定的参数查找引号 "" 中的字符串。

在文件中查找示例：

UltraEdit.frInFiles.directoryStart = "c:\\temp\\";

UltraEdit.frInFiles.searchInFilesTypes = "*.txt";

UltraEdit.frInFiles.useOutputWindow = true;

UltraEdit.frInFiles.find("3939");

在文件中替换示例：

UltraEdit.frInFiles.directoryStart = "c:\\temp\\";

UltraEdit.frInFiles.searchInFilesTypes = "*.txt";

UltraEdit.frInFiles.useOutputWindow = true;

UltraEdit.frInFiles.replace("3939", "7878");

getString

在提示对话框中使用的引号 ("") 中的字符串

可选参数：

0 int

1 int 返回值

提示用户在当前位置插入的字符串。 “提示”是指脚本运行时显示给用户的提示或问题。例如:

UltraEdit.getString("What is your name?");

或

var str = UltraEdit.getString("What is your name?",1);

如果使用 int 值“1”，则输入的字符串将不会写入活动文件，但会另存为变量值并在运行的脚本中使用。

getValue

在提示对话框中使用的引号 ("") 中的字符串

可选参数：

0 int

1 int 返回值

提示用户在当前位置插入的值。 “提示”是指脚本运行时显示给用户的提示或问题。例如:

UltraEdit.getValue("How old are you?");

或

var str = UltraEdit.getValue("How old are you?",1);

如果使用 int 值“1”，则输入的字符串将不会写入活动文件，但会另存为变量 int 值并在运行的脚本中使用。

insertMode

更改文本编辑模式中的字符输入为插入模式。

insOvrMode

** 这是只读属性。

返回布尔值说明插入模式是否打开。例如：

var insertActive = UltraEdit.insOvrMode;

messageBox

消息文本位于引号 ("") 中

标题文本位于引号 ("") 中（可选）

显示带有“确定”按钮的消息对话框。例如：

UltraEdit.messageBox("Can't complete process", "Process Abort");

newFile

打开新的空白文件。

open

文件名在引号（""）中

打开指定的文件。文件名必须在引号中。可以使用“^c”且 UltraEdit 会将其替换为剪贴板中的内容。例如：

UltraEdit.open("c:\\temp\\test.txt");

或

UltraEdit.open('^c');

或

UltraEdit.open("c:\\temp\\^c");

或

UltraEdit.open("FTP::myserver.com\\/home/mypath/

public_html|index.html");

overStrikeMode

将文本编辑模式更改为输入字符的改写模式。

perlReOn

将正则表达式切换为符合 Perl 样式的正则表达式。

regexMode

** 这是只读属性。

返回数值表示活动的正则表达式类型。

0 = UltraEdit 表达式

1 = Unix 表达式

2 = Perl 表达式

例如：

var regexType = UltraEdit.regexMode;

runTool

引号 ("") 中的字符指定要运行的工具的区分大小写的菜单名。

运行一个工具。该工具必须从高级菜单中的工具配置进行配置。例如：

UltraEdit.runTool("Script Tool");

save

保存活动文件

saveAll

保存所有活动文件

saveAs

文件名在引号（""）中

将活动文件用指定的文件名保存。文件名必须在引号中。文件名中可以使用“^s”。UltraEdit 将其取代为活动窗口中当前选中的文本。同样可以使用“^c”且 UltraEdit 会将其替换为剪贴板中的内容。

UltraEdit.saveAs("c:\\temp\\test.txt");

或

UltraEdit.saveAs("^s");

或

UltraEdit.saveAs("^c");

selectClipboard

剪贴板号码 (0-9)

选择指定的剪贴板 0 = Windows 剪贴板，1-9 表示用户剪贴板。例如：

UltraEdit.selectClipboard(2);

ueReOn

将正则表达式切换为 UltraEdit 样式的正则表达式。

unixReOn

将正则表达式切换为 Unix 样式的正则表达式。

文档对象命令

document 是 JavaScript 阵列对象，阵列对象是 UltraEdit 应用程序对象的属性。 这是所有当前同时打开文档的阵列。activeDocument 参数可以用来指定要写入活动文件的输出，或者用户可以根据文件选项卡顺序指定文件的索引（即文档 [0], ... 文档 [8]）。 例如：

UltraEdit.activeDocument.write("test");

将“test”写入当前文档，同时以下：

UltraEdit.document[4].write("test");

将允许用户打开多个文件并将指定的文本写入打开待编辑的第五个文件（根据文件标签的顺序）。

脚本中可以使用“//”进行注释，用于测试和文档。

脚本一旦创建后便可以编辑。请注意，“^c”和“^s”可能在很多脚本中应用，使用时将取代剪贴板中的内容（^c）和当前选中的内容（^s）。这允许用户创建引用特定字符串的脚本，并将字符串用 ^c 或 ^s 取代，以便在脚本运行时动态地“指定”字符串。以下命令作用于当前打开的文档进行编辑。 除非注明其他参数，否则所有文档对象命令都必须使用下列格式调用：

UltraEdit.activeDocument.commandName();

下表说明了文档对象命令：

命令

参数*

说明

ansiToOem

将文件从 ANSI 转换为 OEM。例如：

UltraEdit.activeDocument.ansiToOem();

ASCIIToUnicode

转换 ASCII 文件到 Unicode

bottom

跳转到文件结尾。

collapseAll

折叠活动文件中所有可折叠的文本。 例如：

UltraEdit.activeDocument.collapseAll();

columnCenterJustify

将选中的列居中调整。

columnCut

要剪切的列编号数值

在列模式中剪切选中的列或从当前光标位置到文件末尾的指定数量的列。要剪切选中的列必须使用值“0”。

columnDelete

要删除的列编号数值

在列模式中删除选中的列或从当前光标位置到文件末尾的指定数量的列。要删除选中的列必须使用值“0”。

columnInsert

字符串位于引号 ("") 中

将引号中的字符串插入选中的列。

columnInsertNum

起始数字 | 整数 |
增量 | 整数 |
列首补零 | 布尔值 | true/false
十六进制 | 布尔值 | true/false

将数字插入选中的列。 如果没有选中的内容，则插入将从光标位置移至文件的最后一行。例如：

UltraEdit.activeDocument.columnInsertNum(2, 3 , false, true);

columnLeftJustify

将选中的列居左调整。

columnRightJustify

将选中的列居右调整。

copy

将选中的文本复制到剪贴板。如果没有选中的内容，如果配置了当没有活动的选择时，启用当前行复制/追加选项，当前光标位置所在的行将被复制。

copyAppend

复制选中的文本并将其追加到剪贴板。 如果没有选中的内容，如果配置了当没有活动的选择时，启用当前行复制/追加选项，当前光标位置所在的行将被复制。

copyFilePath

将活动文件的路径/名称复制到剪贴板。

currentChar

** 这是活动/指定文档的只读属性。

返回光标处字符的值。例如：

var char = UltraEdit.activeDocument.currentChar;

currentColumnNum

** 这是活动/指定文档的只读属性。

返回当前列号的值。 第一列编号为“0”。例如：

var col = UltraEdit.activeDocument.currentColumnNum;

currentLineNum

** 这是活动/指定文档的只读属性。

返回当前行号的值。例如：

var lineNum = UltraEdit.activeDocument.currentLineNum;

currentPos

** 这是活动/指定文档的只读属性。

返回值为当前位置到文件开头的字节数。例如：

var pos = UltraEdit.activeDocument.currentPos;

cut

将选中内容从文件剪切到剪贴板。 如果没有选中的内容，则将剪切光标位置目前所在的行。

cutAppend

将选中内容从文件中剪切并追加到剪贴板。 如果没有选中的内容，则将剪切光标位置目前所在的行。

deleteText

删除当前字符或选中的文本。

deleteLine

删除当前的行。

deleteToEndOfLine

将从光标位置开始删除一直到行的结尾。

deleteToStartOfLine

将从光标位置开始删除一直到行的开始。

dosToMac

将文件（行终止符）转换为 MAC 格式。

dosToUnix

将文件（行终止符）转换为 UNIX 格式。

dupeLine

在光标下插入活动行的复制。

endSelect

停止选择文本（详细信息请参见 startSelect）。

expandAll

展开活动文件中所有折叠的文本。 例如：

UltraEdit.activeDocument.expandAll();

fileSize

** 这是活动/指定文档的只读属性。

返回引用文件的字节数大小。例如：

var size = UltraEdit.activeDocument.fileSize;

findReplace

.matchCase | 布尔值 | true/false
.matchWord | 布尔值 | true/false
.mode | 整数 | 值：
 | 0 - 当前文件 1 - 在选择中 2 - 所有打开的文件
.regExp | 布尔值 | true/false
.searchAscii | 布尔值 | true/false
.searchDown | 布尔值 | true/false
.searchInColumns | 布尔值 | true/false
.fromCol | 整数 | default: 0
.toCol | 整数 | default: -1
.find ("要搜索的字符串");
.replace ("要搜索的字符串", "替换字符串");
** 仅在替换中使用 **
.preserveCase | 布尔值 | true/false
.replaceAll | 布尔值 | true/false
.replaceInAllOpen | 布尔值 | true/false
*在替换中取代 .mode
.selectText | 布尔值 | true/false
*仅替换选中的文本

根据指定的参数查找引号 "" 中的字符串。例如：

UltraEdit.activeDocument.findReplace.matchWord = true;

UltraEdit.activeDocument.findReplace.find("3939");

或

UltraEdit.document[0].findReplace.matchWord = true;

UltraEdit.document[0].findReplace.matchCase = true;

UltraEdit.document[0].findReplace.replace("Copper", "Silver");

请注意：所有属性一旦设定便应用于之后的所有查找和替换，直到再次被设置为其他值。

fromEBCDIC

将文本转换为 EBCDIC 格式。

gotoBookmark

跳转到的书签索引或 -1 转到下一个书签

跳转到下一个/指定的书签。索引从 0 开始。如果用户输入大于实际书签数的索引，则将自动引导到第一个书签（索引 0）。例如：

UltraEdit.activeDocument.gotoBookmark(0);

gotoBookmarkSelect

跳转到的书签索引或 -1 转到下一个书签

跳转到下一个/指定的书签并选择从光标位置到书签的文本。索引从 0 开始。如果用户输入大于实际书签数的索引，则将自动引导到第一个书签（索引 0）。例如：

UltraEdit.activeDocument.gotoBookmarkSelect(0);

gotoLine

要跳转到的行和列数的数值

跳转到指定的行和列号。使用行号 0 跳转到当前行的指定列。例如：

UltraEdit.activeDocument.gotoLine(1,5);

gotoLineSelect

要跳转到的行和列数的数值

跳转到指定的行号和列号并选择从光标位置到行/列的文本。选择文本时使用行号 0 跳转到当前行的指定列。例如：

UltraEdit.activeDocument.gotoLineSelect(1,5);

gotoPage

要跳转到页面的编号

跳转到指定的页号。例如：

UltraEdit.activeDocument.gotoPage(5);

gotoPageSelect

要跳转到页面的编号

跳转到指定的页号并选择从光标位置到页的文本。例如：

UltraEdit.activeDocument.gotoPageSelect(5);

hexDelete

指定要删除的字节数的数值

从文件中删除指定数量的字节。

hexInsert

指定要插入字节大小的数字值

将指定数量的字节插入文件。这将插入空格 (HEX 20)。

hexMode

** 这是活动/指定文档的只读属性。

返回布尔值说明十六进制模式是否活动。例如：

var hexActive = UltraEdit.activeDocument.hexMode;

hexOff

关闭十六进制模式——切换到文本模式。

hexOn

打开十六进制模式。

hideOrShowLines

隐藏选中的行，或如果隐藏则显示在光标行处隐藏的行。

insertLine

在光标当前位置的下面插入空白行。

insertPageBreak

在文件光标目前所在位置插入换页/分页符。

insertTemplate

模版索引

将指定的模版插入文件。例如：

UltraEdit.activeDocument.insertTemplate(0);

invertCase

转换所选文本的大小写。

isCharGt

"字符"

检查当前光标位置所在的字符是否大于指定的字符。例如：

if (UltraEdit.document[1].isCharGt('k')){

//do these commands...

} else {

//do these commands...

}

isChar

"字符串"

检查当前光标位置所在的字符是否为指定的字符。 例如：

if (UltraEdit.document[1].isChar('k')){

//do these commands...

} else {

//do these commands...

}

isColNum

数字

检查当前光标位置是否为指定的列号。 例如：
if (UltraEdit.activeDocument.isColNum(13)){

//do these commands...

} else {

//do these commands...

}

isColNumGt

数字

检查当前光标位置是否大于指定的列号。 例如：
if (UltraEdit.activeDocument.isColNumGt(13)){

//do these commands...

} else {

//do these commands...

}

isEof

检查当前光标位置是否为文件的结尾。 例如：

if (UltraEdit.document[1].isEof()){

//do these commands...

} else {

//do these commands...

}

isExt

"字符串"

检查活动文件的文件扩展名是否与指定字符串匹配。例如：

if (UltraEdit.document[1].isExt("txt")){

//do these commands...

} else {

//do these commands...

}

isFound

检查脚本中上次找到的命令结果，并根据结果有条件地执行其他命令。例如：

UltraEdit.activeDocument.findReplace.find("string");

if (UltraEdit.activeDocument.isFound()){

//do these commands...

} else {

//do these commands...

}

isFTP

检查当前文件是否为通过 FTP/SFTP 加载的文件，而不是本地/网络文件。

if (UltraEdit.document[1].isFTP()){

//do these commands...

} else {

//do these commands...

}

isHexModeOn

检查当前文件是否设置为十六进制/二进制模式。

if (UltraEdit.activeDocument.isHexModeOn()){

//do these commands...

} else {

//do these commands...

}

isName

"字符串"

检查活动文件的文件名（不是路径或扩展名）是否与指定字符串匹配。例如：

if (UltraEdit.document[1].isName("foo")){

//do these commands...

} else {

//do these commands...

}

isNotFound

检查脚本中上次找到的命令结果，并根据结果有条件地执行其他命令。例如：

UltraEdit.activeDocument.findReplace.find("string");

if (UltraEdit.activeDocument.isNotFound()){

//do these commands...

} else {

//do these commands...

}

isSel

检查活动文件中当前有没有选中的文本。 例如：
if (UltraEdit.document[1].isSel()){

//do these commands...

} else {

//do these commands...

}

key

BACKSPACE
DEL
DOWN ARROW
END
HOME
LEFT ARROW
PGDN
PGUP
RIGHT ARROW
UP ARROW
CTRL+END
CTRL+HOME
CTRL+LEFT ARROW
CTRL+RIGHT ARROW

将键盘命令插入活动文件。通常用于在文件中导航以及退格或删除。“CTRL+”修改符可以用于常规编辑修改命令。

如果要输入文本，则使用“write”命令而非“key”命令。 例如：

UltraEdit.activeDocument.key("BACKSPACE");

UltraEdit.activeDocument.key("CTRL+RIGHT ARROW");

length

** 这是活动/指定文档的只读属性。

返回活动文档的数量。 例如：

var num_of_docs = UltraEdit.document.length;

matchBrace

查找下一个匹配的括号并选择括号中的文本。

moveLineDown

在活动文档中将当前行下移一行。 例如：

UltraEdit.activeDocument.moveLineDown();

moveLineUp

在活动文档中将当前行上移一行。 例如：

UltraEdit.activeDocument.moveLineUp();

oemToAnsi

将文件从 OEM 转换为 ANSI。

paste

将剪贴板中的内容粘贴到文件中。

path

** 这是活动/指定文档的只读属性。

返回指定文件的完整路径。例如：

var text = UltraEdit.activeDocument.path;

previousBookmark

跳到上一个书签。例如：

UltraEdit.activeDocument.previousBookmark();

previousBookmarkSelect

跳转到上一个书签并选择从光标位置到书签的文本。例如：

UltraEdit.document[1].previousBookmarkSelect();

reIndentSelection

重新缩进当前选中的文本。 例如：

UltraEdit.activeDocument.reIndentSelection();

returnToWrap

将当前选中的硬回车转换为自动换行。

selectAll

选中文件中的全部文本。

selection

** 这是活动/指定文档的只读属性。

返回当前选中的文本。例如：

var text = UltraEdit.activeDocument.selection;

selectLine

选择活动行中的所有文本。

selectToBottom

选择从当前位置到文件末尾的所有文本。

selectToTop

选择从当前位置到文件开头的所有文本。

selectWord

选中当前词语（与双击词的作用相同）。

setActive

将指定文档设置为活动文档。例如：

UltraEdit.document[1].setActive();

sortAsc

sortDes

类型归类

0 - 根据字符顺序归类。

1- 根据数字值而非字符顺序归类。

2 - 指定归类必须针对现场。

3 - 指定归类应使用其他归类方法。使用其他归类方法只需使用一个归类键。

忽略大小写 布尔值 true/false

删除重复 布尔值 true/false

归类键 int 可以指定多达四对开始/结束键。

用升序或降序方式排序文件或选定的文本。

例如：

UltraEdit.activeDocument.sortAsc(0, true, true, 1, -1);

例如：

UltraEdit.activeDocument.sortDes(1, true, false, 4, 8);

spacesToTabs

将文件中的空格转换为制表符。这基于配置－自动换行/制表符设置中定义的制表符空格值。 如果制表符空格值设置为 3，则转换为一个制表符需要一组连续的三个空格。小于三个的连续空格都无法转换。

spacesToTabsAll

将文件中的所有空格转换为制表符。这基于配置－自动换行/制表符设置中定义的制表符空格值。 如果制表符空格值设置为 3，则转换为一个制表符需要一组连续的三个空格。小于三个的连续空格都无法转换。

startSelect

开始选择。这将打开选择模式运行。任何光标的移动或放置都伴随选择并选中文本。endSelect 将停止选择模式。已选文本将保持选中状态直到正常编辑时其他命令导致其不被选中。

tabsToSpaces

将文件中的所有制表符转换为空格。

timeDate

将时间和日期插入文件的光标位置。

toCaps

选定文本中的每个词语首字大写。

toEBCDIC

将文本转换为 EBCDIC 格式。

toggleBookmark

在当前行设置或删除书签。

toLower

将选中文本转换为小写。

top

跳转到文件开头。

toUpper

将选中文本转换为大写。

trimTrailingSpaces

切掉当前文件每行尾部的空格。

unicodeToASCII

转换 Unicode 文件到 ASCII。

unixMacToDos

将活动文件（行终止符）从 Mac/Unix 转换为 DOS 格式。

wrapToReturn

执行换行时所在列的列号。列号为 0 则表示换行发生在窗口边缘

将选中内容从换行转换为硬回车。例如：

UltraEdit.activeDocument.wrapToReturn(60);

write

写入的文本位于引号 ("") 中

将指定的文本写入光标位置。例如：

UltraEdit.activeDocument.write("This is a test.");

或

UltraEdit.activeDocument.write("^c");

将在 write 命令中使用剪贴板内容。

xmlConvertToCRLF

将单行的 XML 文件转换为缩进的 XML 格式。

输出窗口对象命令

outputWindow 是 JavaScript 阵列对象，阵列对象是 UltraEdit 应用程序对象的属性。 除非注明其他参数，否则所有输出窗口对象命令都必须使用下列格式调用：

UltraEdit.outputWindow.commandName();

下表说明了输出窗口对象命令：

命令 | 参数* | 说明
clear |  | 清除输出窗口内容。例如： UltraEdit.outputWindow.clear();
copy |  | 复制输出窗口的内容到活动剪贴板。例如： UltraEdit.outputWindow.copy();
showOutput | 布尔值 true/false | 确定是否显示写入输出窗口中的针对用户数据。 现在只包含 outputWindow.write()。例如： UltraEdit.outputWindow.showOutput=false;
showStatus | 布尔值 true/false | 确定是否在输出窗口中显示所有状态信息（脚本名称、脚本成功/失败和错误信息）。例如： UltraEdit.outputWindow.showStatus=true;
showWindow | 布尔值 true/false | 切换输出窗口是否可见。例如： UltraEdit.outputWindow.showWindow(true);
visible | ** 这是只读属性。 | 返回布尔值表示输出窗口是否可见。例如： UltraEdit.outputWindow.visible;
write | 写入的文本位于引号 ("") 中 | 向输出窗口中写入指定的文本。 这将每次仅支持一行且不包含行终止符。例如： UltraEdit.outputWindow.write("This is a test.");


Tab 缩进

UltraEdit 提供用 tab 键来定义多行缩进和反缩进。如果选定了多行，使用 Tab 键将用等于一个制表站的宽度缩进这些行。如果同时还按下 Shift 键，这些行将按一个制表站宽度反缩进。


文本选择/加亮

当使用 箭头键 时按下 Shift 键会加亮光标通过之处的文本，当使用左右箭头键同时按下 CTRL 和 Shift 键可以一次性加亮整个单词，光标移动到上一个/下一个单词的词首。

当使用上下箭头键同时按下 CTRL 和 Shift 键加亮所有光标起始位置和结束位置之间的文本。使用 Home 键同时按下 CTRL 和 Shift 键将加亮所有从光标位置到文档起始位置的文件。

当使用 End 键同时按下 CTRL 和 Shift 键将加亮所有从光标位置到文本末端的文本。在执行下列命令时同时按下 Shift 键，那么当前的选区 (如果有) 将扩展到执行下列命令后的光标位置:

查找下一个/上一个

转到

转到书签

Shift 键应该在按下执行命令动作的按钮同时按下，而不是在按下显示对话框的按钮时按下。例如，如果用 Ctrl+G 显示转到对话框并点击确定来执行 转到 命令，在点击确定同时按下 Shift 键，不是在按 Ctrl+G 显示对话框时按下 Shift 键。


Unicode 和 UTF-8 支持

UltraEdit 提供 Unicode (16 位宽字符) 文件和 UTF-8 文件支持，允许象在 ASCII/ANSI 和 Unicode 或 UTF-8 文件之间转换一样，直接编辑 Unicode 类型的 UTF-8 文件。UltraEdit 会在文件载入时先侦测文件类型。它将查找 Unicode 文件的 FF FE 标记。对于 UTF-8 文件，它将用下列三种情况之一查找:

1) 文件标记 (BOM) EF、BB、BF。

2) 是否有“charset=utf-8”这样的字符

3) 将审视文件，并查找是否有有效的 UTF-8 多字节字符出现

如果发现文件是 Unicode，它将视为该种格式，状态栏中的文件类型前面会用“U-”开头显示，表示是 Unicode 文件。

如果发现文件是 UTF-8，它将视为该种格式，并转换到 Unicode (16 位) 进行编辑。状态栏中的文件类型前面会用“U8-”开头显示，表示是 UTF-8 文件。当保存文件时，它将从 Unicode 到 UTF-8 进行转换，并用该格式保存。

在内部用 Unicode 处理允许在字符输入时使用来自操作系统的 Unicode 字符消息表。另外，在某些 Windows 版本和某些应用程序支持使用 WM_UNICHAR 消息表，用 UltraEdit，允许在一些本身不支持 Unicode 的操作系统 (Windows 95/98/Me) 中输入 Unicode 字符。

下列是一些可用的 Unicode/UTF-8 转换功能:

ASCII 到 Unicode | 从 ASCII 转到到 Unicode
UTF-8 到 Unicode | 从 UTF-8 转换到 Unicode (16 位)
Unicode 到 ASCII | 从 Unicode 转换到 ASCII
UTF-8 到 ASCII | 从 UTF-8 转换到 ASCII
ASCII 到 UTF-8 (Unicode 版本) | 将内部用 UNICODE 格式的文件在编辑时从 ASCII 转换到 UTF-8
Unicode/UTF-8 到 UTF-8 (Unicode) | 将内部用 UNICODE 格式的文件在编辑时从 Unicode 或 UTF-8 (非内在 Unicode 格式) 转换文件到 UTF-8
Unicode/ASCII/UTF-8 到 UTF-8 (ASCII) | 从 Unicode、ASCII 或 UTF-8 (内在 Unicode 格式) 转换到 UTF-8，但保留文件在非 unicode (ASCII 显示) 格式。

UltraEdit 内部提供在 Windows 95、98、Me、NT 和 2000 中的 Unicode 文件支持。

不是所有的操作系统本身就支持 Unicode，某些从多字节编码转换到 Unicode 或从 Unicode 转换到多字节编码不一定好用。如果活动代码页 (查阅 Windows 说明文档/帮助) 不支持这些字符，那么将不能正确转换。

这个功能用于在多字节编码和 Unicode 之间进行转换，包括查找/替换和列插入。


UE3 Functionality

UE3 refers to UltraEdit customized for installation on a U3 smart drive. UE3 supports the functionality of UltraEdit except as follows:

- File associations are not supported.

- Shell integration (context menu access from Windows Explorer) is not supported as the U3 conventions forbid access to the parts of the registry which must be modified to support shell integration.

In nearly all other respects UE3 allows the use of UltraEdit as if it was installed on a standard desktop hard drive allowing users access to the most needed features of UltraEdit - macros, scripting, syntax highlighting, column mode, code folding, UNICODE support, FTP, Telnet and more - all on your U3 smart drive.

The primary difference is that when UE3 is shut down and the U3 smart drive is ejected, any references to files/settings that don't reside on the U3 smart drive are removed from the UE3 INI file (ue3.ini) when this is written back to the U3 smart drive. For example:

- Files added to the Favorite files list during an editing session that belong to the host system will be removed from the application when the U3 drive is ejected.

- Open files (except in the case of files opened via FTP) will not be remembered between sessions.

Note: U3, the U3 smart Logo, and all U3 formative trademarks are trademarks or registered trademarks of U3 LLC worldwide.


菜单配置

UltraEdit 可以通过菜单使用所有工具栏中可用的命令，还允许配置多个用户菜单。如果你右键点击菜单，将出现一个带下列选项的上下文菜单:

基本

高级

管理菜单配置

定制菜单

高级选项是程序初始选项，它提供所有菜单和工具栏。如果选择了基本，将使用显示的默认菜单和工具栏子集。

菜单配置

如果从上下文菜单中选择了管理菜单配置，会弹出菜单配置对话框。如果在新名字对象中输入了一个名字，那么当前活动菜单将被用这个配置名保存。如果选中了已重新配置的菜单名 (比如基本)，并按下重置按钮，这个菜单配置将被恢复到默认状态。如果按下全部重置按钮，所有用 UltraEdit 生成的菜单配置将被恢复到它们默认状态，用户配置的菜单配置将被删除。

用户可以点击右键并选择定制来修改下面描述的菜单配置。如果选中定制菜单，将打开菜单配置对话框，用户可以定制下面描述的当前活动菜单。

菜单配置对话框

菜单配置对话框由有两个标签化的菜单和命令，连同新建菜单/子菜单文本条目对象组成。同时对话框中还包含上/下和左/右箭头以及一个编辑按钮。所有这些项目和它们的功能描述如下:

菜单/命令配置面板

当前活动菜单以当前在资源管理器界面中分配的项目显示在菜单面板。每个菜单或子菜单标题的名字左边有一条带矩形框的行终止符。双击标题将展开或折叠包含的项目。

如果选中了一个菜单标题或项目，并按下编辑按钮，则可以修改菜单或项目的名字。按键盘上的回车键将保存修改后菜单项目，按确定按钮将提交更改，并使其在菜单中反映。

当选中一个菜单标题，使用上/下和左/右箭头，可以将整个菜单移动到一个新的位置。当选中一个菜单项目，那么按上/下按钮，可以将该项目移动到当前菜单内部的新位置。菜单项目可以被移动到当前菜单的顶端和底端。如果菜单项目是子菜单的一部分，它不能被移动到子菜单的外部。如果菜单项目是主菜单的一部分，将它上下移动，它会“跳过”遇到的子菜单。

命令面板显示所有菜单中使用的当前可用的功能。要从命令面板移动一个项目到菜单面板，在你想移动的命令项目上点击，并按下对话框中心的向左箭头来添加选定的项目。选定的菜单项目将直接添加到当前菜单面板中选定项目的下面。如果菜单面板中没有选中的项目，该项目将被添加到第一个列出的菜单的顶部。一旦添加了一个项目，它们可以使用上/下箭头在菜单内部重新定位到你所想的位置。

新建菜单

要创建一个新菜单/子菜单，在新建菜单对象中输入菜单/子菜单名 (例如“Test1”)，然后按新建菜单对象右边的左箭头。这将添加一个新的空菜单到菜单列表的底部。菜单可以通过先选中，然后按对话框中心的向右箭头按钮来删除。

可配置的菜单的数据默认贮存在 %APPDATA% 目录下的 IDM Comp\UltraEdit 中的 uedit32.mnu 文件中。(对于 UEStudio 这个文件在 UEStudio 目录下，而不是 UltraEdit 目录)。


工具栏配置

UltraEdit 允许将菜单中可用的命令转换到工具栏中。也可以配置多用户工具栏。如果你右键点击工具栏，会弹出一个上下文菜单，你可以选择下列选项:

基本

高级

管理工具栏配置

定制工具栏

大按钮

高级选项是初始默认选项，提供所有标准工具栏。如果选择了基本， 将显示一个默认工具栏的子集。

如果选择了管理工具栏配置，那么会打开工具栏配置对话框。如果在新名字对象中输入了一个名字，那么当前活动工具栏将保存为这个配置名。用户可以在工具栏点击并选择定制来修改该工具栏，进行你所想的配置。

如果选择了定制工具栏，将弹出工具栏配置对话框，用户可以根据自己的意愿定制当前活动工具栏。

大按钮项目可以用于切换活动工具栏的按钮大小。

工具栏配置对话框

工具栏配置对话框由工具栏和命令两个面板组成，在它旁边有大按钮选择框和新建工具栏和扩展位图文件对象。对话框中还包含上、下、左、右箭头按钮。这些项目和它们的功能如下:

工具栏/命令配置面板

已被指定的工具栏显示在工具栏面板，并在资源管理器界面已分配了项目。点击工具栏左边的“-”折叠工具栏，点击“+”展开工具栏显示所含的所有项目。如果选中了工具栏中的一个项目，按上/下箭头将移动它们在工具栏列表的位置。不能用上/下箭头从一个工具栏向其它工具栏移动项目。

命令面板显示所有当前可通过工具栏使用的功能。要将一个项目从命令面板移动到工具栏面板，在你想移动的命令项目上点击，并按下对话框中心位置的左箭头来添加选定的项目。选定的工具栏项目将被直接添加到工具栏面板中当前选定项目的下面。如果工具栏面板中没有选择任何内容，该项目将被添加到列出的第一个工具栏顶部。在添加项目后，它们可以在工具栏内部使用上/下箭头重新进行配置。

新建工具栏

要创建一个新工具栏，在新建工具栏对象中输入工具栏名字 (例如“Test1”)，并按下新建工具栏对象右边的左箭头按钮。这将在工具栏列表的底部添加一个新的空工具栏。工具栏可以通过选中并按下对话框居中位置的右箭头按钮删除。

扩展位图

如果你愿意，可以指定与工具栏项目关联的新的位图 (象用户工具栏)，让它们在工具栏中显示。要进行这个操作，选择命令面板选择工具栏项目，并将它添加到上述你想定义的适当的工具栏。选择工具栏面板中的项目，并在扩展位图对象中指定你想使用的位图的路径，如果你知道位图的确切位置，你可以直接输入，然后按回车将这个位图分配到选定的工具栏项目。如果你不能保证位图的具体位置，你可以按“...”按钮浏览你想使用的位图，然后按回车将这个位图分配到选定的工具栏项目。

大按钮

选中大按钮选择框将使所有的工具栏均使用大按钮。

工具栏配置的数据默认贮存在 %APPDATA% 目录下的 IDM Comp\UltraEdit 的 uedit32.tbr 文件中。(对于 UEStudio，它贮存在 UEStudio 目录下，而不是 UltraEdit 目录)。


HTML 工具栏

HTML 工具栏提供快速在 HTML 中插入经常使用的代码的方法。包含下列功能:

查看标签列表 | 切换 HTML 标签列表的显示或隐藏状态
粗体 | 在选定文本两边插入定义文本粗体的标签
斜体 | 在选定文本两边插入定义文本斜体的标签
下划线 | 在选定文本两边插入定义下划线文本的标签
增加缩进 | 在选定文本两边插入 BLOCKQUOTE 标签
列表 | 插入一个创建列表的标签
编号 | 插入一个创建数字列表的标签
前景颜色 | 显示颜色对话框，让用户选择文本的前景颜色。如果没有选择颜色，将为文本添加适当的标签，其中的颜色值可以由用户输入
背景颜色 | 显示颜色对话框让，用户选择文本的背景颜色。如果没有选择颜色，将为文本添加适当的标签，其中的颜色值可以由用户输入
向左排列 | 在选区两边插入文本左排列的标签
居中排列 | 在选区两边插入文本居中排列的标签
向右排列 | 在选区两边插入文本右排列的标签
对齐 | 在选区两边插入文本对齐标签
HTML Div | 插入用来创建文本标签的 DIV 标签
按钮 | 插入按钮输入标签，并设置光标到输入按钮文字的位置
文本字段 | 插入单行文本框
文本区域 | 插入多行文本框 (文本区域)
密码字段 | 插入单行密码文本框
隐藏 | 插入隐藏文本框
选择框 | 插入一个选择框
单选按钮 | 插入一个单选按钮
图像 | 插入图像标签，并将光标放置在让用户输入图像路径的位置
查找图像 | 打开从图像插入的对象框
停驻 | 在选定的文本两旁插入一个标签使其停驻
关闭标签 | 查找最近的一个未关闭标签并关闭它
转换选定文本中的特殊字符到 HTML 条目 | 转换选定文本中的特殊字符到 HTML 条目 (例如“β”变成“&szlig;”
编码/解码 | 转换选区到 %xx，这里的 xx 是等同于十六进制数字表示的字符
HTML Protector | 保护 HTML 代码 (比如内置的 JavaScript) 被反向浏览


工具工具栏

Tools 工具栏

工具工具栏提供在 UltraEdit 中调用工具的快速方法，包含下列功能:

颜色选择器 | 打开颜色选择对话框，可用来插入十进制、十六进制、HTML 或 RGB 格式的颜色值
样式构建 | 打开样式构建对话框，可用来创建与 CSS2 标准一致的样式
HTML 精简 | 打开 HTML 精简对话框，用户可以指定配置文件位置 (如果你希望不使用默认选项)，也可以配置自定义 HTML 精简操作选项
GUID 生成 | 弹出插入一个全球唯一标识到活动文档的上下文菜单，你可以从四种方法中选择一个
数字转换 | 转换选定的非零数字到四种格式之一: 二进制、八进制、十进制或十六进制
艺术样式格式化工具 | 重新格式化源代码 (更多配置选项) 请注意: 因为这个工具不是 UltraEdit 的集成部分，它必须先从主页下载，并复制到 UltraEdit 目录，你可以从下列位置下载这个工具: http://astyle.sf.net 。
* .NET 代码保护 | 打开 .NET Framework 代码保护对话框。这用来保护 .NET 可执行文件的源代码简单反编译。 直接用可执行文件工作，不需要安装 .NET framework。
* 方案转换器 | 转换 Visual Studio 方案到 UEStudio 格式

* 请注意: 这些功能只在 UEStudio 中支持， 在 UltraEdit-32 中不支持。


构建工具栏

如果方案已配置为可编译 ( 方案设置对话框 ) 那么构建工具栏可用于在与活动方案关联的文件中执行编译/构建功能。

构建工具栏包含下列项目:

* 选择编译器 | 打开选择编译器对话框
* 方案设置 | 打开方案设置对话框
* 构建模式 | 设置构建模式为“调试”或“发布”
* 编译 | 如果活动文档未保存，则保存活动文档并编译它。如果未选择编译器，或对于方案的编译器选项未在显示的 选择编译器对话框 中进行设置，那么显示 方案设置对话框 ，然后启动编译进程。
* 构建 | 如果需要，则保存活动文档，并构建方案目标。如果对于该方案未设置编译器，或方案设置未保存，它将与编译命令相同方法进行操作。
* 停止构建 | 停止运行构建进程
* 运行应用程序 | 运行用选定编译器创建的应用程序，如果应用程序还不存在，则先调用构建进程
* 全部重建 | 删除所有用编译器创建的文件，然后构建方案
* 命令 | 这个命令会显示一个弹出菜单，菜单中的项目数量根据使用的编译器设置和这个 编译器配置 设置的命令确定，是可变的。
* 调试器 | 运行调试器 - 如果还未设置调试器，将会显示一个对话框，在那里可以选择用于活动方案的调试器。

* 请注意: 这些功能只在 UEStudio 中支持，UltraEdit-32 不支持这些功能。


智能提示工具栏

智能提示工具栏提供了用 UEStudio 中的智能提示来调用项目的快速方法。包括以下功能：

.source -> .header | 显示上下文菜单允许用户在源文件和关联的页头文件之间切换
文件列表 | 显示文件列表
显示/再显示函数提示 | 显示活动函数的函数提示
符号列表 | 显示活动文件的符号
关键字列表 | 显示活动文件的关键字
显示此文件定义的功能 | 显示活动文件定义的功能
重解析活动文档 | 强制智能提示重解析活动文件
跳转到类观察器 | 切换 文件树视图 到显示标签 窗格
在方案文件中查找符号定义 | 显示智能提示列表显示选中符号定义的位置。双击列表中的项目将打开定义点的相关文件。

* 请注意：这些功能只有 UEStudio 中支持，UltraEdit-32 不支持这些功能。


资源编辑器工具栏

资源编辑器工具栏允许用户编辑此活动方案的资源。包括下列功能：

测试

以 设计模式提供活动对话框

* 请注意：这些功能只有 UEStudio 中支持，UltraEdit-32 不支持这些功能。


脚本工具栏

脚本工具栏显示一系列子菜单，从中可以选择与 Ruby 和 PHP 编码有关的选项。 包括以下功能：

运行 Ruby 命令 | 弹出可以选择下面命令的子菜单 注意：如果尚未安装 ruby.exe，选择以下任一选项都将显示错误对话框，说明找不到 ruby.exe。 Ruby EXE for Windows 的最新版本可以从以下地址下载：http://www.ruby-lang.org/
检查语法 | 检查活动 Ruby 脚本的语法
运行脚本 | 运行活动 Ruby 脚本
命令行选项 | 显示命令行选项说明的对话框（如下）
PHP 命令 | 弹出可以选择下面命令的子菜单 注意：第一次选择下面命令时会显示一个对话框，在这里用户必须浏览定位本地系统的php.exe 文件。 如果你没有在系统中安装 PHP，请转到 http://www.php.net/downloads.php ，下载最新的版本并根据说明安装。 如果您的系统中尚未安装 PHP，下面的功能不能使用，只会提示要求定位 php.exe。
运行脚本 | 运行活动 PHP 脚本
语法检查 | 检查活动 PHP 脚本的语法
检查所有语法 | 检查所有打开 PHP 文件的所有脚本语法
解析文档 | 解析活动文件，并转换为 documentname-parsed.php文件中的脚本化事件等同的 HTML 代码
分离注释 | 从活动文件分离注释和空白区域，并重新格式化，在 documentname-parsed.php 文件中显示结果
加亮源代码 | 转换脚本到用 <code> 和 </code> 括在一起的 HTML 文本，允许用 HTML 文件显示脚本，使它在 UltraEdit 中可以加亮显示
选择 PHP 可执行文件 | 显示一个对话框，让用户浏览查找 php.exe。

Ruby 命令行选项

如果从脚本工具栏子菜单中选择命令行选项，则将显示以下对话框。 熟悉 Ruby 的用户可以使用该界面启动带有指定命令行选项的 Ruby，并在活动脚本上运行。 有关 Ruby 编程语言的其他信息，请参见：http://www.ruby-lang.org/。

* 请注意：这些功能仅在 UEStudio 中支持，在 UltraEdit-32 中不支持。


调试器工具栏

调试器工具栏为在 UEStudio 中调用与 WinDbg 调试器一起使用的命令提供了完整的方法。支持下列功能：

启动 | 自动启动调试器并运行应用程序
重新启动 | 结束调试会话然后重新启动
停止调试 | 结束调试会话
中断 | 暂停目标执行并将控制权返回给调试器
单步执行 | 一次执行一个语句，并跟随执行调用的函数
跳出 | 在当前执行点所在的位置执行函数剩下的语句
逐过程 | 执行代码的下一行但不执行任何调用的函数
运行到光标位置 | 从当前语句恢复代码的执行到选中的语句
设置断点 | 在当前光标位置添加断点
删除断点 | 在当前光标位置删除断点
调用堆栈窗口 | 显示“调用堆栈”窗口以显示当前执行线程的所有活动过程或堆栈框架列表
变量窗口 | 显示“变量”窗口查看在当前堆栈框架中每个过程的本地变量及其值
监控窗口 | 显示“监控”窗口以便查看选中变量的值或监控表达式
寄存器窗口 | 显示“寄存器”窗口以便查看寄存器
内存窗口 | 显示“内存”窗口以便查看一定地址范围的内存内容
分解窗口 | 显示“分解”窗口以便查看正被调试进程的代码字节以及与其关联的汇编说明

* 请注意：这些功能仅在 UEStudio 中支持，在 UltraEdit-32 中不支持。


Web 搜索工具栏

Web 搜索工具栏提供在 UltraEdit 中调用工具的快速方法，包含下列功能:

Google 搜索 | 在 google.com 中搜索当前选中的文本。
Yahoo 搜索 | 在 yahoo.com 中搜索当前选中的文本。
Wikipedia 搜索 | 在 wikipedia.org 中搜索当前选中的文本。
Dictionary.com 搜索 | 在 dictionary.com 中搜索当前选中的文本。
Thesaurus 搜索 | 在 thesaurus.com 中搜索当前选中的文本。
Whois 搜索 | 在 whois.net 中搜索当前选中的文本。
NetworkSolutions Whois 搜索 | 在 networksolutions.com 中搜索当前选中的文本。
PHP.net 搜索 | 在 php.net 中搜索当前选中的文本。
cplusplus.com 搜索 | 在 cplusplus.com 中搜索当前选中的文本。
MSDN 在线搜索 | 在 msdn.microsoft.com 中搜索当前选中的文本。

请注意：

* GOOGLE 和 Google 标志是 Google Inc. 的注册商标

* Yahoo! 和 Yahoo!标志是 Yahoo!Inc. 的财产

* Wikipedia 和 Wikipedia 标志是 Wikimedia Foundation, Inc. 的注册商标

* DICTIONARY.COM、THESAURUS.COM、DICTIONARY.COM 标志、和 THESAURUS.COM 标志是 Lexico Publishing Group, LLC. 及其子公司的商标和注册商标。

* WHOIS.NET 是 WHOIS.NET 的服务标志

* NETWORKSOLUTIONS.com 和 Network Solutions 标志归 Network Solutions 所有。

* PHP 标志版权© 属于 PHP Group。

* cplusplus.com 和 cplusplus.com 标志的版权属于 cplusplus.com。

* search.msdn.microsoft.com 和 Windows 标志归 Microsoft Corporation 所有。

有关定制工具栏的更多信息，或添加/删除工具栏按钮的信息，请单击此处。


文件菜单

文件菜单包含下列命令：

新建 | 创建新文档
打开 | 打开现有文档
快速打开 | 打开现有文档，允许输入名称，不带浏览对话框
关闭 | 关闭已打开的文件
关闭所有文件 | 关闭所有已打开的文档
关闭除此文件外的所有文件 | 关闭除活动文档外的所有已打开的文档
FTP/Telnet - FTP/SFTP 浏览器 | 显示 FTP/SFTP 浏览器
FTP/Telnet - 从 FTP 打开 | 从 FTP 站点打开现有文档
FTP - 另存到 FTP | 以指定文件名保存打开的文档到 FTP 站点
FTP/Telnet - FTP 帐号管理器 | 显示或隐藏 FTP/SFTP 帐号管理器
FTP/Telnet - SSH/Telnet 控制台 | 显示或隐藏 SSH/Telnet 控制台
FTP/Telnet - SSH/Telnet 帐号管理器 | 显示或隐藏 SSH/Telnet 帐号管理器
恢复到已保存 | 恢复到最后一次保存的文件状态
保存 | 用相同的文件名保存打开的文档
另存为 | 用指定的文件名保存打开的文档
全部保存 | 用当前文件名保存所有修改后的文档
选择另存为 | 保存选定区域到新文件
创建副本/备份 | 创建活动文件的副本/备份
加密 - 加密文件 | 使用用户指定的密码短语加密活动文件
加密 - 解密文件 | 使用用户指定的密码短语解密活动文件
重命名文件 | 重命名活动文件
比较文件 | 比较两个 ASCII 文件
排序文件 | 根据当前排序选项排序活动文件
排序 - 高级排序/选项 | 显示高级排序和排序选项对话框
转换 - UNIX/MAC 到 DOS | 转换文件格式，从 UNIX 或 MAC 到 DOS
转换 - DOS 到 MAC | 转换文件格式，从 DOS 到 MAC
转换 - DOS 到 UNIX | 转换文件格式，从 DOS 到 UNIX
转换 - EBCDIC 到 ASCII | 转换文件格式，从 EBCDIC 到 ASCII
转换 - ASCII 到 EBCDIC | 转换文件格式，从 ASCII 到 EBCDIC
转换 - OEM 到 ANSI | 转换文件格式，从 OEM 到 ANSI
转换 - ANSI 到 OEM | 转换文件格式，从 ANSI 到 OEM
转换 - ASCII 到 Unicode | 转换文件格式，从 ASCII 到 Unicode
转换 - UTF-8 到 Unicode | 转换文件格式，从 UTF-8 到 Unicode
转换 - Unicode 到 ASCII | 转换文件格式，从 Unicode 到 ASCII
转换 - UTF-8 到 ASCII | 转换文件格式，从 UTF-8 到 ASCII
转换 - ASCII 到 UTF-8 | 转换文件格式，从 ASCII 到 UTF-8
转换 - Unicode/UTF-8 到 UTF-8 | 转换文件格式，从 Unicode/UTF-8 到 UTF-8
转换 - Unicode/ASCII/UTF-8 到 UTF-8 | 转换文件格式，从 Unicode/ASCII/UTF-8 到 UTF-8
转换 - UNICODE 到 UNICODE Big Endian | 转换文件格式，从 UNICODE 到 UNICODE (Big Endian)
转换 - UNICODE Big Endian 到 UNICODE | 转换文件格式，从 UNICODE (Big Endian) 到 UNICODE
插入文件 | 插入一个文件到活动文档中
删除活动文件 | 删除与活动窗口关联的磁盘文件
发送邮件 | 通过邮件将文件发送给收件人
每个增量处插入字符串 | 在文件中指定的增量处插入字符串
打印 | 打印文档
打印所有文件 | 打印所有打开的文档
打印预览 | 在屏幕上显示文档，且显示效果与打印效果相同
页面设置 | 设置要打印的页眉和页脚
打印设置 | 选择打印机和打印机连接
收藏的文件 | 打开收藏的文件，或管理收藏夹列表
最近打开文件 | 打开最近打开过的文件
最近打开方案/工作区 | 打开最近打开过的方案或工作区
退出 | 退出 UltraEdit


新建命令

新建命令 (文件菜单)

这个命令用来让 UltraEdit 创建一个新文档。你可以用 打开命令 打开一个现有的文档。

快捷键: CTRL+N


打开命令

打开命令 (文件菜单)

这个命令用来在新窗口中打开一个现有的文档 (文件)。你可以一次打开多个文档。用窗口菜单可以在多个打开的文档之间进行切换，查阅 窗口 1, 2, ...命令 。

这个命令会打开文件打开对话框，允许一次性选择并打开多个文件。

文件还可以通过从文件管理器拖到 UltraEdit 窗口并松开鼠标键的方式打开。

你可以用 新建命令 创建一个新文档。

快捷键: CTRL+O


快速打开命令

快速打开命令 (文件菜单)

这个命令用来在不显示浏览对话框的情况下快速打开一个文件。对话框中显示将要从中打开文件的目录。也可以输入带相对路径的文件名。

用这个命令还可以使用通配符来打开文件，比如“*.txt”。

从子目录中打开所有匹配的文件选择框用来告诉 UltraEdit 递归搜索指定路径 (或默认路径) 的所有子目录，并打开所有与指定名字匹配的文件。

选定的文件将被打开，或显示一个错误。

快捷键: CTRL+Q


关闭命令

关闭命令 (文件菜单)

这个命令用来关闭所有包含活动文档的窗口。在你关闭之前，UltraEdit 会建议你保存文档中所作的更改。如果你不保存关闭文档，你最后一次保存后所作的修改将丢失。在关闭未命名文档之前，UltraEdit 会显示另存为对话框，建议你输入名字并保存文档。

快捷键: CTRL+F4


关闭所有文件命令

关闭所有文件命令 (文件菜单)

这个命令用来关闭所有当前在 UltraEdit 中打开进行编辑的文件。UltraEdit 会建议你在关闭之前先保存文档所作的更改。如果你不保存关闭了文档，在你最后一次保存之后所作的更改都将丢失。在关闭未命名的文档之前，UltraEdit 会显示可以让你命名和保存文档的另存为对话框。


关闭除此文件外的所有文件命令

关闭除此文件外的所有文件命令 (文件菜单)

这个命令用来关闭除活动文件外的所有在 UltraEdit 中打开进行编辑的文件。在你关闭之前，UltraEdit 会建议你保存文档中所作的更改。如果你不保存关闭文档，从你最后一次保存后所作的修改将丢失。在关闭未命名文档之前，UltraEdit 会显示 另存为对话框 ，建议你输入名字并保存文档。


FTP 浏览

FTP 浏览（文件菜单/FTP 子菜单）

使用该命令打开 FTP 浏览器。FTP 浏览器主要由三个面板构成。最左边的面板显示本地计算机的目录树。中间的面板显示本地计算机中选定的文件夹的内容。右边的文件夹显示远程系统（FTP 服务器）上活动文件夹的内容。

可以选择多个文件，并使用中间和右侧窗格之间竖直分隔栏上的按钮在本地和远程系统之间移动。 在本地和远程系统窗格上方有一个地址栏，包含上移一个目录的按钮、刷新按钮和指示活动文件夹路径的文本区域。

包含以下按钮：

帐号 | 出现 FTP 帐号管理器 对话框
连接 | 连接到选定的 FTP 帐号
断开连接 | 断开活动 FTP 帐号的连接
关闭 | 关闭 FTP 浏览器
更改 | 提供“更改 FTP 目录”对话框，允许直接指定要在更改到远程系统上的路径
中断 | 终止活动传输进程


从FTP打开

从FTP打开 (文件 菜单/FTP 子菜单)

使用这个命令通过FTP打开文件. 这个命令弹出允许站点或帐户选择浏览的自定义对话框。

The 帐户 [1]按钮可以按下打开FTP帐户管理器指定的新的帐户。 为了每个站点能被连接必须配置一个新的帐户，当然每个站点也许有特定的设置。

配置的帐户列表在中心按钮[2] 并且其中任一个配置的帐户也许被选择。 一旦期望帐户被选择, 连接 [3] 按钮必须按下初始化与服务器的连接。 当连接被建立， 这将被替换为被用于终止连接的 断开 [3] 按钮。

按父目录 [4]按钮将导航到当前目录的父文件夹。 按刷新 [5] 按钮刷新(重读)来自主服务器的目录信息。

双击在列表显示的任何目录将尝试更改具体目录。 另外 更改 目录 [6] combobox 被用于输入目录更改。 这将自动地保存所有路径列表被键入它。

被显示的目录列表可以通过指定在 过滤器[7]文本领域里的过滤器过滤显示文件的一个子集。 过滤器 文本字段支持Perl规则表达式也是标准通配符。 这过滤器只影响在集成FTP客户端从服务器下载和显示的列表。 这将自动地保存所有过滤器列表被键入它。 这列表也可以通过点击在任何列标题[8]列表的(名字、大小、日期，类型)排序。

新的目录在主服务器上可以通过用鼠标右键单击在列表被创建， 并且选择 由帮助菜单[9]生成目录。 另外 隐藏目录[10] 复选框将使目录不显示。

打开一个文件，在文件的任意双击或选择它和点击 打开[13] 按钮。 如果被打开的文件的全路径已知道，这也许输入打开[12]文本字段，并且不需要对文件导航。 传输进程将显示文件被传输。

当操作在过程中警告显示尝试开始另一操作是否做出，或者取消对话框请求。 当传输时文件，或者站点被连接，对话框将显示当前状态[14]。 传输将被执行使用指定的传输类型[11] (ASCII或二进制)。 二进制 传输文件 字节到字节 没有被修改。 ASCII 造成文件 一般被转换 在不同系统之间的行终止。 依赖FTP服务器或客户端，ASCII传输可能误使文件作为7-bit传输。 为此， 二进制 是传输类型的首选。

默认情况下，在文件被检索之后和打开对话将是闭合的，如果设置传输[15]以后 选择关闭对话框。 这个选项可以清除一直打开的对话框。

假如连接到服务器有问题，选择在配置对话框FTP部分下面输出窗口里显示FTP 日志可能是有用的。 这将显示在输出窗口里所有命令会话日志发送和接收FTP服务器数据。 这可能提供有用的诊断信息，并且这个窗口内容可以使用剪贴板复制。

在这个对话框里的帮助菜单包括下面选项:

生成目录 | 创建在主服务器上的一个新目录。 没有执行检查名字或句法。 所有错误从主服务器报告。
删除 | 删除在主服务器上的一个远程文件或目录
重命名 | 重命名在主服务器上的一个远程文件或目录
允许 | 允许在一个远程文件文件允许被设置。 这仅仅在识别FTP服务器 "站点" 命令 chmod. 典型地仅是UNIX/Linux服务器。


另存到FTP

另存到FTP (文件菜单/FTP 子菜单)

使用这个命令通过FTP保存打开的文档/文件 。 这个命令弹出允许站点或帐户选择浏览的自定义对话框。

The 帐户 [1]按钮可以按下打开FTP帐户管理器指定的新的帐户。 为了每个站点能被连接必须配置一个新的帐户，当然每个站点也许有特定的设置。

配置的帐户列表在中心按钮[2] 并且其中任一个配置的帐户也许被选择。 一旦期望帐户被选择, 连接 [3] 按钮必须按下初始化与服务器的连接。 当连接被建立， 这将被替换为被用于终止连接的 断开 [3] 按钮。

按父目录 [4]按钮将导航到当前目录的父文件夹。 按刷新 [5] 按钮刷新(重读)来自主服务器的目录信息。

双击在列表显示的任何目录将尝试更改具体目录。 另外 更改 目录 [6] combobox 被用于输入目录更改。 这将自动地保存所有路径列表被键入它。

被显示的目录列表可以通过指定在 过滤器[7]文本领域里的过滤器过滤显示文件的一个子集。 过滤器 文本字段支持Perl规则表达式也是标准通配符。 这过滤器只影响在集成FTP客户端从服务器下载和显示的列表。 这将自动地保存所有过滤器列表被键入它。 这列表也可以通过点击在任何列标题[8]列表的(名字、大小、日期，类型)排序。

新的目录在主服务器上可以通过用鼠标右键单击在列表被创建， 并且选择 由帮助菜单[9]生成目录。 另外 隐藏目录[10] 复选框将使目录不显示。

默认情况下保存[12] 文本字段将作为当前编辑器文件名字。 保存文件，导航到在主服务器上的期望目录并且点击保存 [13]按钮。 如果目的是替换已经在服务器上的一个文件，在列表里应该选择它。 它的名字将作为保存 [12] 文本字段，并且点击在保存 [13]按钮将初始化传输。 传输进程将在文件传输时显示。

当操作在过程中警告显示尝试开始另一操作是否做出，或者取消对话框请求。 当传输时文件，或者站点被连接，对话框将显示当前状态[14]。 传输将被执行使用指定的传输类型[11] (ASCII或二进制)。 二进制 传输文件 字节到字节 没有被修改。 ASCII 造成文件 一般被转换 在不同系统之间的行终止。 依赖FTP服务器或客户端，ASCII传输可能误使文件作为7-bit传输。 为此， 二进制 是传输类型的首选。

默认情况下，在文件被检索之后和打开对话将是闭合的，如果设置传输[15]以后 选择关闭对话框。 这个选项可以清除一直打开的对话框。

假如连接到服务器有问题，选择在配置对话框FTP部分下面输出窗口里显示FTP 日志可能是有用的。 这将显示在输出窗口里所有命令会话日志发送和接收FTP服务器数据。 这可能提供有用的诊断信息，并且这个窗口内容可以使用剪贴板复制。

在这个对话框里的帮助菜单包括下面选项:

生成目录 | 创建在主服务器上的一个新目录。 没有执行检查名字或句法。 所有错误从主服务器报告。
删除 | 删除在主服务器上的一个远程文件或目录
重命名 | 重命名在主服务器上的一个远程文件或目录
允许 | 允许在一个远程文件文件允许被设置。 这仅仅在识别FTP服务器 "站点" 命令 chmod. 典型地仅是UNIX/Linux服务器。


恢复到最后一次保存状态命令

恢复到最后一次保存状态命令 (文件菜单)

这个命令用来关闭活动文档，放弃你之前所作更改，并重新载入。如果文件是未命名文件，则不能使用这个功能。使用这个命令后，会出现一个提示，确认是否放弃更改。


保存命令

保存命令 (文件菜单)

这个命令用来将活动文档用当前的名字和目录保存。当你第一次保存文档时，UltraEdit 会显示 另存为对话框 ，你可以命名你的文档。如果你想在保存之前更改现有的名字和目录，选择 另存为命令 。

快捷键: CTRL+S


另存为命令

另存为命令 (文件菜单)

这个命令用来保存并命名活动文件。 UltraEdit 会显示 另存为对话框 让你命名文档。

要设置另存为命令使用的默认目录，请使用 默认保存目录 设置。

要用现有的名字和目录保存文档，请使用 保存命令 。

快捷键： F12


全部保存命令

全部保存命令 (文件菜单)

这个命令用来用它们当前的名字和目录保存所有已经修改的文档。当你第一次保存文档，UltraEdit 会显示 另存为对话框 ，你可以命名你的文档。如果你想在保存前更改现有文档的名字和目录，请选择 另存为命令 。


选区另存为命令

选区另存为命令 (文件菜单)

这个命令用来保存当前选区为一个新文件。UltraEdit 会显示 另存为对话框 ，你可以命名你的文档。


创建副本/备份命令

创建副本/备份命令 (文件菜单)

这个命令用来让用户在不影响活动文件的情况下，制作一个活动文件的备份副本 (包括所有当前所作的修改)。

活动文件仍保持当前的文件名，不更改文件的名字，这一点不象 另存为命令 。


加密文件命令

加密文件命令（文件菜单/加密）

该命令可使用高级加密标准（AES）算法加密指定文件（或指定的多个文件）。

加密文件

选中该选项时，会显示对话框提示用户指定要加密的文件并输入密码用作加密秘鈅。 密码区分大小写，长度在8到32个字符之间，可以包括能输入的任意字符。

默认情况下，活动文件的路径将填写在要加密的文件字段中。 用户可以在该字段中指定要加密的另一个（或多个）文件的完整路径。 最简单的方法是按下要加密的文件字段旁的浏览按钮，这会显示“打开”对话框，从中用户可以导航到希望加密的文件。 需要时，可以在“打开”对话框中选择多个文件（使用 CTRL 键和鼠标或 SHIFT 键和鼠标来选择多个项目），然后按下打开按钮将指定文件传回加密文件对话框，从而加密多个文件。

如果手动指定要加密的文件，必须指定完整路径，且多个文件应用分号和空格隔开。 （例如：c:\sample\columnfind.txt; c:\sample\resource.h; c:\sample\main.cpp;"

然后用户必须输入并确认密码用来加密指定文件。

请注意：用户必须记住指定的加密密码或将其记录下来。 指定的密码不保存在系统的任何位置或应用程序文件内。 如果遗忘或丢失了密码，已加密数据将永远无法恢复。

如果选择替换加密文件如果已存在，则任何在指定路径已存在的加密文件，当其拥有与所选要加密文件相同的名称和扩展名时，将被自动覆盖。

一旦指定文件或多个文件完成加密，如果输出窗口当前不可见，则将显示加密状态对话框列出已加密文件。 如果输出窗口可见，这些项目将显示在输出窗口中。


解密文件命令

解密文件命令 (文件菜单/加密)

该命令可使用高级加密标准（AES）算法解密活动文件（或指定文件）的内容。

解密文件

选中该选项时，会显示对话框提示用户指定要解密的文件并输入密码用作解密秘鈅。 密码区分大小写，长度在8到32个字符之间，可以包括能输入的任意字符。

用户可以在要解密的文件字段指定要解密的单个或多个不同文件的完整路径。 最简单的方法是按下要解密的文件字段旁的浏览按钮，这会显示“打开”对话框，从中用户可以导航到希望解密的文件。 需要时，可以在“打开”对话框中选择多个文件（使用 CTRL 键和鼠标或 SHIFT 键和鼠标来选择多个项目），然后按下打开按钮将指定文件传回解密文件对话框，从而解密多个文件。

如果手动指定要解密的文件，必须指定完整路径，且多个文件应用分号和空格隔开。 加密文件用“.uenc”扩展名保存。

然后用户必须输入并确认密码用来解密指定文件。 为解密输入并确认的密码必须与加密时输入的密码精确匹配。

解密时选择如果解密文件已存在，则替换。任何在指定路径（加密文件所在位置）已存在的纯文本文件，当其拥有与所选解密文件相同的名称和扩展名时，将被自动覆盖。


重命名文件命令

重命名文件命令 (文件菜单)

这个命令允许用户重命名活动文件。它会弹出一个可以让用户指定新名字的对话框。你只能输入名字，路径将保持与现有路径相同。

如果该文件不能被重命名，或新的名字无效，将显示一个错误消息。


比较文件命令

比较文件命令 (文件菜单)

这个菜单命令会打开一个对话框，允许用户指定两个文件进行比较。比较后，会在一个单独的窗口中显示被比较文件，有差异的行被加亮，并显示出文件中的差异。

文件比较对话框允许用户选择下列选项:

比较类型

这个选项用来指定比较类型是文本类型还是二进制类型。

忽略大小写 (文本模式)

这个选项用于在进行比较时忽略选定文件中的字符之间的大小写差异。如果选定了这个选项，如果只是大小写的差异，该行被认为是相同的。

忽略空格 (文本模式)

这个选项用于在进行比较时忽略仅不显示字符 (空格、制表符) 的差异。如果选定了这个选项，如果只是白色、不显示内容的差异，该行被认为是相同的。

忽略空行 (文本模式)

这个选项用于在进行比较时忽略有空行时的差异。如果选定了这个选项，空行不进行比较。


排序文件命令

排序文件命令 (文件菜单)

这个命令用来按当前的排序选项排序活动文档的每一行。任何大小的文件都可以进行排列。查阅 高级排序/选项 获取更多信息。

如果已经选定了文件的一部分，那么只排序选定部分。文件的其余部分不会被修改。


高级排序/选项

高级排序/选项 (文件菜单)

该命令用来让你设置排序选项，并执行活动文件排序。排序命令在整个文件中执行，除非选定了部分内容。如果选定了部分内容，只排序选定部分的内容。但如果处于列模式，所有 选定的行均被排序，不仅仅是选定的列。撤销命令不支持排序操作。排序操作中不支持“撤销”命令。

当选择了这个选项时，会打开一个对话框，其中有下列选项：

排列顺序

递增 这个设置是升序排序 (a 到 z，1-9)，这是默认选项。

递减 这个设置是降序排序 (z 到 a，9-1)。

删除重复行

如果选中这个选项，所有找到的相同内容的行将被删除，只保留第一行。如果设置了忽略大小写选项，如果该行中如果只存在大小写差异，则视为相同。

忽略大小写

如果你在搜索中对大小写无所谓，则应该选中这个选项。例如 AT 被视为与 at 相同。如果你考虑 AT 不同于 at，则选中这个选项。

数字排序

如果选中该选项，那么将在选定列执行数字排序。一般来说，排序是非数字性的，比如值 1、11、111 会排在 2、22、222 之前，因为 1 在 2 之前。如果选择了数字排序，那么该值将按数字值进行排序.(1、2、11、12、111、222)。 数字排序在本地指定排序或使用其他排序方式的时候不可用。

列排序

在排序中可以选择 4 个以下的排序键。每个排序键包含将被排序的列的范围。该范围的普通值是从列 1 到 9216。

不想使用的键的起始和结束列应该设为 0。如果使用了多个键，排序顺序是基于第一个键，然后是第二个键，以此类推。

要按完整行排序，将起始列设为 1，结束列设为 -1。如果所有的键结束列都有 -1 值，表示将从第一列到行末进行排序。如果任何一个键设置为排序整行，那么其余的键将被忽略。

如果所有排序键的起始列是 0 (不按行排序)，那么起始列将是光标所在列。

当使用较少的键、排序较少的列时，排序执行性能较好。

排序使用内存映射文件和虚拟内存。在一些场合，它可能需要使用代用排序，允许用户指定要使用的临时文件的位置。如果是这种情况，应该选中不使用虚拟内存的代用排序选项，并且只能使用单个排序键（使用数字排列）。这和只支持单个键的早期版本完全相同。

使用本地位置（较慢）

这用来指定应该按指定的本地位置进行排序。对于一些语言 （比如德语），这是改变默认排序顺序所必需的。本地位置可以在 高级菜单 和 设置代码页/位置 命令下指定。当使用这个设置时，排序可能会比不使用这个选项时慢。

这些选项在 UltraEdit 会话期间保存，被 排序文件命令 使用。


UNIX/MAC 到 DOS 命令

UNIX/MAC 到 DOS 命令 (文件菜单)

这个命令用来修正在 UltraEdit 和其它文本编辑器中显示的行结束字符。

一些从基于 UNIX 系统 (和其它一些系统) 生成的文档不是用回车或换行符终止每一个行。UltraEdit 需要所有的行用回车和换行符终止。

这个命令将转换所有回车和换行符。如果找到旁边没有换行符的回车，将添加一个换行符。如果找到的换行符前面没有找到回车符，那么将插入一个回车符。如果在回车符前面找到换行符，那么将颠倒它们的顺序。

要将文件转换到 UNIX 格式，请使用 DOS 到 UNIX 命令 。

要将文件转换到 MAC 格式，请使用 DOS 到 MAC 命令 。


DOS 到 MAC 命令

DOS 到 MAC 命令 (文件菜单/子菜单)

这个命令用来将文件转换到 Macintosh 格式。该动作会替换文件中回车和换行，并组合到只有回车的格式。

要将文件从 UNIX 或 MAC 格式转换到 DOS，请使用 UNIX/MAC 到 DOS 命令 。


DOS 到 UNIX 命令

DOS 到 UNIX 命令 (文件菜单/转换子菜单)

这个命令用来将文件转换到 UNIX 格式。该动作会替换文件中回车和换行，并组合到只有换行的格式。

要将文件从 UNIX 或 MAC 格式转换到 DOS，请使用 UNIX/MAC 到 DOS 命令 。


EBCDIC 到 ASCII 命令

EBCDIC 到 ASCII 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 EBCDIC 格式转换到 ASCII。这通常在与 EBCDIC 文件格式的文件交换时有用 (通常用于大型电脑系统)。


ASCII 到 EBCDIC 命令

ASCII 到 EBCDIC 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 ASCII 转换到 EBCDIC 格式。这在需要把文件输出到 EBCDIC 文件格式时比较有用 (通常用于大型电脑系统)。


OEM 到 ANSI 命令

OEM 到 ANSI 命令 (文件菜单/转换子菜单)

这个命令用来将使用 OEM 字符集的文件 (通常为 DOS 下生成的文本文件) 转换到使用 ANSI (Windows) 字符集的文件。

要从 ANSI 到 OEM 转换文件，使用 ANSI 到 OEM 命令 。


ANSI 到 OEM 命令

ANSI 到 OEM 命令 (文件菜单/转换子菜单)

这个命令用来将使用 ANSI (Windows) 字符集的文件转换到使用 OEM (DOS) 字符集。

要从 OEM 到 ANSI 转换文件，使用 OEM 到 ANSI 命令 。


ASCII 到 Unicode 命令

ASCII 到 Unicode 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 ASCII 转换到 Unicode (16 位宽字符格式)。

该转换命令使用活动代码页。要获取代码页信息，请查阅 Windows 文档/帮助。

状态栏中的文件类型 (DOS/UNIX/MAC) 前面将显示一个“U-”，表示该文件是 Unicode 格式。

要将文件转换为 ASCII，请使用 Unicode 到 ASCII 命令 。


UTF-8 到 Unicode 命令

UTF-8 到 Unicode 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 UTF-8 转换到 Unicode。当文件保存时，它将保持为 Unicode，除非用户指定了转换到其它格式。状态栏中会在文件类型 (DOS/UNIX/MAC) 前面显示“U-”，表示该文件是 Unicode 格式。


Unicode 到 ASCII 命令

Unicode 到 ASCII 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 Unicode 转换到 ASCII 格式。

该转换使用了活动代码页，要获取代码页信息，查阅 Windows 说明文档/帮助。

对于 Unicode 文件，将在状态栏中的文件类型 (DOS/UNIX/MAC) 前面显示一个“U-”，表示该文件是 Unicode 格式。转换后这个指示不再出现。

文件可以用 ASCII 到 Unicode 命令 转换到 Unicode 格式。


UTF-8 到 ASCII 命令

UTF-8 到 ASCII 命令 (文件菜单)

这个功能将整个文件从 UTF-8 转换为 ASCII。当文件保存时，将保留为 ASCII，除非被用户指定转换到其它格式。它将使用当前代码页进行转换。转换中，可能不是所有的字符都可以正确转换。在这种情况下，将使用默认字符 (?)。


ASCII 到 UTF-8 命令

ASCII 到 UTF-8 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 ASCII 转换到 UTF-8。当文件保存时，它将保持为 UTF-8 格式，除非用户指定转换到其它格式。在状态栏中的文件类型 (DOS/UNIX/MAC) 之前将显示“U8-”，表示该文件是 UTF-8 格式。

在文件内部将是 UNICODE 格式，当文件保存到 UTF-8 编码时被转换。在十六进制模式，该文件将用它当前内部显示方法显示。


Unicode/UTF-8 到 UTF-8 命令

Unicode/UTF-8 到 UTF-8 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 Unicode 或 UTF-8 (ASCII 表示) 转换到 UTF-8 (内在 Unicode 的文件) 格式。当文件保存时将保持为 UTF-8 格式，除非被用户指定转换到其它格式。状态栏中的文件类型指示前面会显示一个“U8-”标记。

在内部该文件将使用 UNICODE 格式，并在文件保存到 UTF-8 编码时转回。在十六进制模式，该文件将用它的当前内在表示方法显示。


Unicode/ASCII/UTF-8 到 UTF-8 命令

Unicode/ASCII/UTF-8 到 UTF-8 命令 (文件菜单/转换子菜单)

这个功能用来将整个文件从 Unicode、ASCII 或 UTF-8 (Unicode 内部表示法) 转换到 UTF-8 编码。该文件尽管不会以 Unicode 贮存，象这样的多字节 UTF-8 字符将显示为 upper ASCII 字符，而不是以 UTF-8 字符显示。当文件贮存后，它将保留为 UTF-8，除非被用户特定转换到其它格式。状态栏将不指示和 ASCII 文件相同结构的文件格式。


UNICODE 到 UNICODE Big Endian 命令

UNICODE 到 UNICODE Big Endian 命令 (文件菜单/转换子菜单)

该功能将整个文件从 Unicode 编码转换到 Unicode (Big Endian) 编码。Endian 是指字节存储的次序。 在 Windows 平台上（多数是小 endian），UTF-16LE 称为“Unicode”而 UTF-16BE 就称为“Unicode (Big Endian)”。 这样，对于那些不在跨平台环境下工作的大多数人来说，不容易混淆。


UNICODE Big Endian 到 UNICODE 命令

UNICODE Big Endian 到 UNICODE 命令 (文件菜单/转换子菜单)

该功能将整个文件从 Unicode (Big Endian) 转换到 Unicode 编码。Endian 是指字节存储的次序。 在 Windows 平台上（多数是小 endian），UTF-16LE 称为“Unicode”而 UTF-16BE 就称为“Unicode (Big Endian)”。 这样，对于那些不在跨平台环境下工作的大多数人来说，不容易混淆。


插入文件命令

插入文件命令 (文件菜单/特殊功能子菜单)

这个命令用来插入一个现有的文档 (文件) 到活动文档中。

这个命令会显示一个对话框，可以选择要插入的文件。选定文件的全部内容将插入到活动文档的光标位置。


删除活动文件命令

删除活动文件命令 (文件菜单/特殊功能子菜单)

这个命令用来关闭活动文档，并从磁盘中删除与之关联的文件。这个命令会提示用户是否确实想删除文件。如果文件从磁盘中删除，它将不能再使用。使用这个命令要特别小心。


发送邮件命令

发送邮件命令 (文件菜单/特殊功能子菜单)

这个命令用来将文件作为邮件附件发送。该文件以及所有的更改均将被发送。这个功能只能在安装了 MS-MAIL 或其它自身带 MAPI 支持的邮件程序中使用。


每隔一个增量插入字符

每隔一个增量插入字符命令命令 (文件菜单/特殊功能子菜单)

在处理大的数据库类型的文件时，有时需要分割文件到“记录”或确定的行长度文件，这些文件可能在记录之间没有任何分隔符。

这个功能允许按用户定义的数字增量将用户定义的字符插入到文件中的指定起始点到结束点。

起始点:

这个操作的起始点可以是文件开头或光标位置。这在文件头部分不应该视为数据部分时比较有用。默认的动作是以文件开头为起始点。

结束点:

结束点可以指定为下面的其中之一:

文件尾 (默认动作)

文件中的已知偏移

在已经转换指定记录数后

当发现一个特殊字符，在这种情况下在找到的字符开头前停止插入，如果未找到，则这个选项继续，或未给出。

示例:

一个有已知记录长度为 2000 个字符的文件。每个记录之间没有分隔符，连续输出记录。

为方便编辑，你想将每个记录单独一行。

用这个功能，你可以指定插入的字符是“^p” (插入换行符 - 段落)，插入字符的增量是每 2000 个字符。

UltraEdit 将在每个记录后面添加换行符，直到文件结尾。


打印命令

打印命令 (文件菜单)

这个命令用来打印文档，使用这个命令后，会弹出 打印对话框 ，在那里你可以指定要打印的页面范围、副本数、目标打印机和其它打印机设置选项。

快捷键: CTRL+P


打印所有文件命令

打印所有文件命令 (文件菜单)

这个命令是使用当前的页面设置和打印机设置打印所有打开的文档。要更改设置，请选择 页面设置 或 打印设置 ( 文件菜单 )。


打印预览命令

打印预览命令 (文件菜单)

这个命令用来以模拟打印后的效果来显示活动文档。当你选择这个命令后，主窗口将用打印预览窗口替换，并用一页或两页的格式显示它们打印的格式。 打印预览工具栏 为你提供一次查看一页或两页、向前或向后移动文档、放大和缩小页面、以及开始进行打印的选项。


页面设置命令

页面设置命令 (文件菜单/打印设置/配置子菜单)

页面设置菜单项目用来打开一个允许用户设置打印时使用的页眉、页脚和页边距等项目的对话框。如果配置了页眉，则会在每页的顶部打印；如果配置了页脚，则会在每页的底部打印；如果配置了页眉和页脚，还会在打印的文本和页脚/页眉之间打印一条横线。

页眉或页脚可以由用户选择适当的选择框来禁用。如果启用了页眉和页脚，在页眉/页脚和页面文本之间的横线打印可以随意禁用。

页眉和页脚可以包含由用户定义的文本，并可在页眉/页脚处使用文件名和页码等附加特殊字符。

这些特殊字符有:

&f 在页眉或页脚中用带路径的完整文件名替换。

&n 在页眉或页脚中用文件名替换 (不带路径)。

&p 在页眉或页脚中用页码替换。

&t 在页眉或页脚中用总计页数替换。

&l 用来使跟随在“&l”后面的文本排列到页眉/页脚范围左边。

&c 用来使跟随在“&l”后面的文本排列到页眉/页脚范围的居中位置。

&r 用来使跟随在“&l”后面的文本排列到页眉/页脚范围的右边。

(注意 - 排列字符不是必需项，它们的部分或全部均可以在单个页眉或页脚中使用。但是，如果使用了不止一个的上述字符，那么它们遵循以下顺序 -- “&l”必须在“&c”之前，“&c”必须在“&r”之前)。

另外，页眉和页脚还可以包含文件日期和时间，或系统的日期和时间。如果在页眉或页脚中包含日期，有两个单选按钮可以用于在文件日期或系统日期之间进行选择。该单选按钮用来选择日期和时间的来源，如果在打印机中使用其它格式的日期和时间，可以在页眉或页脚中用附加特殊符号指定。

下面显示的是用于指定时间和日期格式的字符。不使用下面这些字符表示不打印时间和日期。

下面列出的是日期和时间的格式代码:

格式 描述

%a 星期名简写

%A 完整的星期名

%b 月份名简写

%B 完整的月份名

%c 本地日期和时间的正确表示

%d 用数字显示的月份中的天 (01-31)

%H 用 24 小时格式显示的小时 (00-23)

%I 用 12 小时格式显示的小时 (01-12)

%j 用数字显示的年度中的天 (001-366)

%m 用数字显示的月份 (01-12)

%M 数字显示的分钟 (00-59)

%p 对于 12 小时制的当前本地 AM/PM 标识

%S 用数字显示的秒 (00-59)

%U 用数字显示的一年中的星期，每星期用星期日开始 (00-51)

%w 用数字显示的星期 (0-6；星期天为 0)

%W 用数字显示的一年中的星期，每星期用星期一开始 (00-51)

%x 当前本地的日期表示

%X 当前本地的时间表示

%y 用数字显示的没有世纪的年 (00-99)

%Y 用数字显示的带世纪的年

%Z 时区名字或缩写；如果时区未知，则没有字符

%% 百分比符号

例如:

日期是1994年7月4日，时间是 9:00pm

"%X , %x" 打印成 "21:00 , 07/04/94"

日期是1994年7月4日，时间是 9:00pm

"%c" 打印成 07/04/94 21:00

日期是1991年1月10日，时间是 5:00am

"%A, %B %d, %Y %I:%M%p" 打印成 Tuesday, January 10, 1991 05:00:am

页边距

页边距的单位可以设置为英寸或毫米两种。所有的上、下、左、右边距均可以单独设置。页边距在页眉和页脚生成之前先生成。如果打印机已经设置了最小页边距，且这个页边距大于在 UltraEdit 选定的页边距，将使用打印机设置的页边距。

分页符

分页符可以设置为任何 ASCII 字符。分页符默认是一个换页字符 12 (十六进制中的 0C)。如果需要，可以更改这个字符，但不应该将任何可打印字符设置为换页符，否则会在打印时只要遇到这个字符，就会执行换页。如果选定的字体不可以看到，则你可以更改为这个字符。

打印时文本换行

设置这个选项后，如果打印的数据超出纸张可打印范围，则在打印输出时自动换行继续打印该行。

打印行号

设置这个选项后，会在每张纸的左手边打印行号。如果行是自动换行的，只在该行的第一行中打印行号。这个设置不受显示行号设置的限制。

在一张纸中打印两页

这个选项允许用户在单张纸中打印两个逻辑页面。这个逻辑页面的数据缩小到并排两页打印。在单页中进行打印时，打印的比例会根据适合并排打印的数据的多少进行调整。

这个选项在打印输出时可节省纸张。

打印语法加亮

这个选项告诉 UltraEdit 如果打印机是彩色打印机，则在打印文件时用彩色打印语法加亮的颜色。这也可以在单色打印机中打印成渐变灰色。


打印设置命令

打印设置命令 (文件菜单/打印设置/配置子菜单)

这个命令用来选择一个打印机和打印机连接。使用命令后会弹出 打印设置对话框 ，可以让你指定打印机和打印机连接。


收藏的文件命令

收藏的文件命令 (文件菜单)

收藏的文件功能允许用户贮存经常性要打开的、或想在以后能快速引用和打开的文件的文件名。当选中收藏的文件菜单项目时，会显示一个对话框，允许用户打开一个或多个收藏的文件，以及修改收藏夹文件列表。

这个对话框显示当前在收藏的文件列表中的文件列表。下面控制可以用来管理该列表:

打开

打开按钮用来从列表中打开选定的文件，并关闭对话框。可以同时从列表中选择多个文件并打开它。列表中所作的任何更改被保存。双击文件列表中的任何文件将执行打开命令。如果选定内容中的一个对象是目录，则打开文件打开对话框，显示最初指定的目录。

关闭

关闭按钮用来关闭对话框。并保存列表中所作的所有更改。

添加文件

添加文件按钮用来打开文件打开对话框，在那里允许用户浏览要添加到列表中的文件。如果指定了一个有效的文件，该文件将被添加到列表中。

添加活动文件

添加活动文件按钮用来将编辑器中的活动文件的文件名添加到文件列表中。

+所有打开文件

+所有打开文件按钮用来将编辑器中的所有文件的文件名添加到文件列表中。

添加目录

添加目录按钮用来让用户浏览一个目录，并添加这个目录到列表中，允许用户从收藏的目录快速打开文件。

删除文件

删除文件按钮用来从文件列表中删除任何选定的文件。


最近打开文件命令

最近打开文件命令 (文件菜单)

这个命令用来从最近曾经编辑过的 16 个文档中选择你想编辑的文档。这里的文档数在 普通配置页 (在高级菜单) 中配置。点击最近打开文件子菜单，加亮选择你想编辑的文档，然后点击，就可打开该文件。

注意: 子菜单中显示的文件可以添加到文件菜单中 (在 普通配置页 中选择适当的选项)。这需要重新启动 UltraEdit 才能生效。请查阅普通配置页获取更多信息。


最近打开方案/工作区命令

最近打开方案/工作区命令 (文件菜单)

这个命令用来从许多最近曾经编辑过的方案中选择想编辑的方案。点击最近打开方案子菜单，加亮选择你想编辑的方案，然后点击就可以打开。这里可查看的最近打开方案数在 普通配置页 中设置。

注意: 方案菜单的位置可以移动。通过在 普通配置页 选择适当的选项，将最近打开方案作为子菜单附加到方案菜单的末端。这个设置需要重新启动 UltraEdit 才能生效。请查阅普通配置页获取更多信息。


编辑菜单

编辑菜单包含下列命令:

撤销 | 撤销上一个编辑操作
重做 | 撤销上一个撤销命令
剪切 | 从文档删除数据，并将它移动到剪贴板
复制 | 从文档复制数据到剪贴板
粘贴 | 从剪贴板粘贴数据到文档中
粘贴并复制 | 将剪贴板文本粘贴到选中内容（替换），然后复制选中的文本到剪贴板
粘贴特殊内容 | 显示子菜单，用户可以选择选项粘贴 HTML 源文件或 Raw RTF 文本而非仅为选中的文本
剪切并附加 | 从文档删除数据，并将它移动到剪贴板，附加到剪贴板已有的数据中
复制并附加 | 从文档复制数据到剪贴板，附加到剪贴板已有的数据中
复制文件路径/名字 | 复制活动文件的完整路径和名字到剪贴板
剪贴板 | 让用户选择活动剪贴板
全选 | 选择活动文档中的所有文本
选择行 | 选择光标所在的行
选择词语 | 选择光标位置的词语
选择范围 | 选择一个用户指定的范围
连续选择 | 允许选择文本而无需使用 SHIFT 键
删除 | 删除光标处选定的文本或字符
删除行 | 删除光标所在行
删除到行首 | 删除从光标位置到行首的内容
删除到行末 | 删除从光标位置到行末的内容
复制行 | 复制光标所在位置的活动行副本
插入行命令 | 在光标位置插入空行
日期/时间 | 在活动文件中插入日期/时间
十六进制编辑 | 将当前窗口在十六进制和 ASCII 模式之间进行编辑模式状态切换
十六进制编辑/EBCDIC | 将当前窗口在十六进制/EBCDIC 和 ASCII 模式之间进行编辑模式状态切换
十六进制插入/删除 | 在十六进制模式中，该命令弹出一个对话框，允许在文件中插入或删除字节
十六进制复制选定视图 | 复制十六进制视图中的数据到剪贴板
拼写检查 | 调用拼写检查程序检查整个文件或选定的文本
只读 | 切换活动文档的只读状态
切换自动换行 | 切换活动文档的自动换行状态
添加注释 | 添加行注释到选定的行
删除注释 | 从选定行删除行注释
插入颜色 | 插入一个颜色值到活动文档


撤销命令

撤销命令 (编辑菜单)

使用这个命令会在可能的情况下，撤销最后执行的编辑动作。UltraEdit 支持多级撤销 (指定的数量根据可撤销的项目改变)。重复执行撤销命令将会按一次一个的方式撤销先前执行的命令。 重做命令 则可以在撤销后重做撤销的命令，如果命令已经撤销，然后执行了新建命令，先前撤销的动作将不能再进行重做。

快捷键: CTRL+Z 或 ALT+Backspace


重做命令

重做命令 (编辑菜单)

重做命令用来重做以前用 撤销 命令撤销的动作。如果命令已经撤销，并且执行了新建命令，那么重做命令将不允许重做先前撤销的动作。

快捷键: CTRL+Y


剪切命令

剪切命令 (编辑菜单)

这个命令用来从文档中删除当前选定的数据，并将它放置到剪贴板中。如果当前没有选定的数据，这个命令不能用。

如果选定了剪切并附加到剪贴板，那么数据将附加到剪贴板内容中，否则，剪切到剪贴板的数据会覆盖原来剪贴板以前贮存的内容。

快捷键: CTRL+X


复制命令

复制命令 (编辑菜单)

这个命令用来将选定的数据复制到剪贴板中。如果当前没有选定的数据，这个命令不能用。

如果选定了复制并附加到剪贴板，那么数据将附加到剪贴板的内容中，否则，复制到剪贴板的数据将覆盖剪贴板原先贮存的内容。

快捷键: CTRL+C


粘贴命令

粘贴命令 (编辑菜单)

这个命令用来在光标位置插入剪贴板内容。如果剪贴板是空的，不能使用这个命令。

快捷键: CTRL+V


剪贴板

剪贴板 (编辑菜单)

UltraEdit 提供多达九个的用户剪贴板，象 Windows 标准剪贴板一样，可用于 剪切 、 复制 和 粘贴 命令。活动剪贴板可以从 编辑菜单 进行更改，或右键点击弹出的上下文菜单修改。另外，用 Ctrl+1-9 可以切换用户剪贴板，Ctrl+0 切换到 Windows 剪贴板。

在更改活动剪贴板时，剪贴板的内容不会被修改。除标准的 Windows 剪贴板除外，其它剪贴板内容在关闭 UltraEdit 后消失。

活动剪贴板显示在状态栏中跟随行和列标识后面，用逗号隔开。

快捷键: CTRL+0-9


全选命令

全选命令 (编辑菜单)

全选命令用来加亮整个文件。这可以非常方便地选择整个文件并 剪切 到剪贴板中。

使用 选择行命令 选择单行。

快捷键: CTRL+A


选择行命令

选择行命令 (编辑菜单)

选择行命令用来加亮光标所在位置的行。行结束字符也同时被加亮。这可以非常方便地选择一行文本并 剪切 到剪贴板中。

使用 全选命令 选择整个文件。

连续三次快速点击鼠标也可以选择一行文本。这会使行尾包括硬回车的整个行被选中。


选择范围命令

选择范围命令 (编辑菜单)

这个命令会打开一个对话框，在那里允许用户指定文件内部应该选定/加亮的范围。

用户可以指定选区起始和结束的行和列。当第一次显示这个对话框，各项目对象默认为当前的选区。

如果未在 列模式 ，如果指定的起始和结束列是不同的值，UltraEdit 将自动切换到列模式。


连续选择命令

连续选择行命令（编辑菜单）

该选项允许选中的内容保持活动，并支持在文件的其他部分导航而无需影响活动的选择内容。 一旦启用该模式，用户定义选中的文本（通过键盘命令或光标移动），然后应再次选择菜单选项或再次使用键盘快捷键以确定选择内容的定义。

定义选择内容时无需按住 SHIFT 键。 按下 CTRL 键并在需要的文件位置单击鼠标左键可以更改活动选项的锚点。

一旦定义了连续选择，如果用户将光标移动到其他位置并输入，选择将被关闭并将文本插入当前光标所在的位置。 如果定义了选择且未移动光标，输入的键盘内容将替换选中的文本（或按下 BACKSPACE 或 DELETE 时将删除选中的文本）。

如果需要，用户可以扩展定义的选择内容，只需选择菜单选项并在当前选中的位置以外单击，然后再次选择菜单选项以确定选择的定义。

快捷键： CTRL+P, CTRL+S


删除命令

删除命令 (编辑菜单/删除子菜单)

删除命令用来删除选定的文本，如果没有选定的文本，则删除光标处的字符。


删除行命令

删除行命令 (编辑菜单/删除子菜单)

删除行命令用来删除光标所在位置的行。行结束字符也同时被删除。

使用 选择行命令 选择行。

快捷键: CTRL+E


删除到行首命令

删除到行首命令 (编辑菜单/删除子菜单)

删除到行首命令用来删除从当前光标位置到包含光标的行首中所有内容。

快捷键: CTRL+F11


删除到行末命令

删除到行末命令 (编辑菜单/删除子菜单)

删除到行末命令用来删除当前行中从光标位置到包含光标的行尾的所有内容。

快捷键: CTRL+F12


复制行

复制行 (编辑菜单)

复制行命令用来在当前光标位置下面插入活动行副本。当调用这个功能时，光标可以定位在活动行的任意位置。这个命令可以从 编辑菜单 调用，或者用户可以在配置中的 键映射 中定义快捷键调用。

快捷键： Ctrl+Alt+D


插入行命令

插入行命令 (编辑菜单)

插入行命令用来在当前光标位置下面插入一个新行。在调用这个功能时，光标可以在活动行的任何位置。这个命令可以从 编辑菜单 调用，或用户可以在配置中的 键映射 下定义一个快捷键。

快捷键： Ctrl+Enter


日期/时间命令

日期/时间命令 (编辑菜单)

日期/时间命令用来在光标位置插入日期和时间。该日期和时间的格式是依照控制面板设置的。在日期和时间之间插入一个空格。

如果只想个别插入日期或时间，可以使用 模板 来定义这个功能。

快捷键: F7


十六进制编辑命令

十六进制编辑命令 (编辑菜单)

十六进制编辑命令用来选择活动窗口的编辑模式。就是在十六进制和 ASCII 之间进行切换。ASCII 编辑模式通常用于基于文件的任何 ASCII (文本)。在 ASCII 模式，UltraEdit 允许所有功能的普通操作，并允许输入任何字符。

十六进制编辑模式通常用于非 ASCII 文件，或二进制文件。这些文件一般都包含不可打印的字符，并且不是文本文件。

当选择十六进制模式时，下列应用受到限制:

不支持插入模式。

将屏幕范围分割成如下三个区域:

文件偏移: | 十六进制表示 | ; ASCII 表示
000000h: | 30 31 32 33 34 35 36 37 38 39 30 31 32 33 34 35 | ;123456789012345

每行显示的十六进制数可以在 普通配置页 中指定。

文件偏移范围显示位于行首的字符相对于文件头部的字节偏移。

十六进制表示显示每个文件字节的十六进制值，两上字符对象之用空格 (“ ”) 隔开。

ASCII 表示提供可打印字符的视图。不可打印字符用一个句点 (“.”) 显示。

如果从 搜索菜单 中选择了字符属性，将会出现一个对话框，显示活动字节的十进制和十六进制值，同时也显示该字符 (这可以根据字体和脚本变化)。同这一样，活动字节的偏移也用十进制和十六进制两种格式显示。

在 ASCII 范围或十六进制范围任一一种方式编辑，将在输入有效的字符后自动更新其它范围。

所有的更改均在改写模式进行。要在十六进制模式下插入或删除字符，使用 编辑菜单 中的 十六进制插入/删除命令 。

十六进制模式支持 编辑菜单 中的 剪切 、 复制 和 粘贴 命令。

快捷键: CTRL+H


十六进制编辑/EBCDIC 命令

十六进制编辑/EBCDIC 命令 (编辑菜单)

十六进制/EBCDIC 编辑模式工作方式几乎与十六进制编辑模式一样，除了它因为显示而需要转换 EBCDIC 数据，并以 ASCII 显示。不会修改文件的内容。但是，右边会显示用十六进制模式的 ASCII 表示的内容，用来显示从 EBCDIC 转换到 ASCII 的数据。

要获取十六进制编辑模式的详细资料，请查阅 十六进制编辑命令 。

当处于这个模式时，在 ASCII 区域内编辑允许数据以 ASCII 码输入，并在文件中自动转换到 EBCDIC。在十六进制区域进行编辑允许数据直接以十六进制方式输入，ASCII 显示内容 (从 EBCDIC 转换) 将在 ASCII 区域中显示。

这个模式中的查找/替换允许使用 ASCII 字符，并根据查找/替换对话框中的设置正确进行查找/替换。但是这个模式不能使用 正则表达式 ，否则结果是不确定的。


十六进制插入/删除命令

十六进制插入/删除命令 (编辑菜单)

十六进制插入/删除命令允许插入或删除 十六进制模式 中的当前光标位置处的字符。这个命令会打开一个对话框，在那里用户可以选择是插入还是删除字符，以及指定要插入或删除的字符数。

如果选择了插入，UltraEdit 将在文件中插入指定的字符数，它们的初始十六进制值是 20 (ASCII 码中的空格)。如果需要，则可以修改这些字符。

如果选择了删除，将从文件中从光标位置开始删除指定数量的字符。

快捷键: CTRL+D


十六进制复制选定视图命令

十六进制复制选定视图命令 (编辑菜单)

这个功能在 十六进制模式 编辑时可用。普通的 复制命令 复制文件中的真实数据，不会复制编辑器中显示的十六进制显示内容。这个命令将用格式化剪贴板中的真实数据一样处理十六进制模式中的屏幕中的显示内容。这个命令允许将视图中显示的内容复制到文本文件或简单的文档中。

被复制的数据可以只是局部行，这个命令计算数据起始地址，并将在剪贴板中格式化。

下列是用十六进制模式显示的一行数据 (处理了一个标题):

文件偏移: | 十六进制显示 | ; ASCII 显示
000000h: | 30 31 32 33 34 35 36 37 38 39 30 31 32 33 34 35 | ;123456789012345

如果选定了 4567，并用这个功能复制到剪贴板中，剪贴板中的格式 (准备粘贴到其它文档) 将是:

000004h: 34 35 36 37 ; 4567


拼写检查命令

拼写检查命令 (编辑菜单)

UltraEdit 集成了 Aspell 拼写检查程序。该拼写检查程序从 编辑菜单 调用，它只检查选定的文本 (如果文件中有选定区域)，如果没有选定区域，则检查整个文件。

如果选定的字典中没有找到词语，则会显示带各种选项的 拼写检查对话框 ，允许更改、忽略或添加词语到用户字典中。

拼写检查程序支持各种语言，这些语言可以从 拼写检查配置页 中选择。

快捷键: CTRL+K


只读命令

只读命令（编辑菜单）

只读命令用来切换文件的只读状态。如果设置了只读状态，文件不能进行修改。如果文件已被修改，则保持修改后的状态，文件可以进行保存。

只读状态的默认动作可以在“高级”菜单“配置”的“文件处理”分支的其他主题中找到。该选项用来确定文件在打开时是否处于只读状态。


添加/删除注释命令

添加/删除注释命令 (编辑菜单)

这些命令允许在选定的行添加或删除行注释 (在 语法加亮 中定义)。编辑的文件必须启用语法加亮，以及该语言中必须定义了行注释。

如果已定义了适当的行注释，这些功能将在每行的行首添加行注释字符，或从每行的行首删除行注释字符。当删除注释字符时，该字符只在它们是行中的第一个字符时才会被删除。


插入颜色命令

插入颜色命令 (编辑菜单)

这个功能允许用户选择一个颜色值，并将它插入到文档中。该对话框允许用户查看或选择颜色，和要插入到文档中的颜色值。

颜色值用下面指定的三种格式其中之一显示:

1) 十进制 - 这是 RGB (红、蓝、绿) 颜色值的十进制值。

2) 十六进制 - 这是 RGB (红、蓝、绿) 颜色值的十六进制值。

3) HTML - 这是在 HTML 文档中显示所必需的格式，值必须添加 #。

如果该对话框是第一次显示，颜色值默认为活动文件中选定的颜色 (如果已经有选定的值)。UltraEdit 也将根据选区确定颜色的格式。

当用户点击确定，显示的颜色值将插入的文档中，如果文档中有选定的区域，那么将替换当前选区。


搜索菜单

搜索菜单包含下列命令:

查找 | 搜索活动文件中的文本字符
找下一个 | 搜索活动文件中的下一个出现的文本字符串
查找上一个 | 搜索活动文件中的上一个出现的文本字符串
替换 | 搜索活动文件中的文本字符串，并用其它文本字符串替换
步进搜索 | 搜索活动文件中与输入的字符最靠近的字符
在文件中查找 | 搜索磁盘上的文件中的文本字符串
在文件中替换 | 搜索磁盘上的文件中的文本字符串，并用其它文本字符串替换
成对匹配 | 查找并加亮成对匹配之间的文本
转到行/页 | 将光标定位在指定的行/列号、分页符 (或在十六进制模式中的文件位置)或书签
切换书签 | 在当前行切换书签
上一个书签 | 将光标移动到上一个书签
下一个书签 | 将光标移动到下一个书签
清除所有书签 | 清除活动文件中的所有书签
编辑书签 | 显示可以重命名或删除书签的“编辑书签”对话框
词数统计 | 在活动文件中统计词数
函数列表 | 在活动文件/方案中查找并显示函数列表
查找符号 | 在标签文件中查找符号
符号属性 | 显示活动字节属性
向后 (上一个位置) | 转到上一次编辑/重新配置的位置
向前（上一个位置） | 转到下一次编辑/重新配置的位置（在使用向后命令后）


查找命令

查找命令（搜索菜单）

该命令显示对话框用于在文档中搜索指定文本。

在查找内容 [1] 字段中指定要搜索的字符串。 可以使用单行或多行字符串，最大长度可达 20,000 字节。 以指定的方向进行搜索。如果未找到字符串，搜索绕到文件的另一端继续进行。如果没有匹配的字符串，则显示消息说明未找到字符串。

除搜索可打印字符之外，制表符和换行符 (回车/换行) 也可以用于搜索。要搜索制表符，请在对话框中输入“^t”字符。要搜索换行符，请在对话框中输入“^p”字符表示 CR/LF，输入“^n”表示仅 LF，以及输入“^r”表示仅 CR。要搜索字符“^”，请在对话框中输入“^^”。

另外，当执行查找时，字符“^s”将替换为当前加亮的任何文本，字符“^c”将替换为当前剪贴板的内容（不多于 30,000 个字符）。这在宏执行中特别有用。当录制宏时，可以选择查找指定的字符串，或使用“^s”，宏会录制该符号，并用宏执行期间加亮的文本替换。同样，当使用“^c”时，这些字符将用宏执行时的剪贴板内容替换。

特殊字符摘要:

符号 | 功能
^^ | 搜索字符“^”
^s | 宏执行时搜索选定 (加亮) 的文本
^c | 宏执行时搜索剪贴板的内容
^b | 匹配一个分页符
^p | 匹配一个换行符（CR/LF）（段落）（DOS 文件）
^r | 匹配一个换行符（仅 CR）（段落）（MAC 文件）
^n | 匹配一个换行符（仅 LF）（段落）（UNIX 文件）
^t | 匹配一个制表符

注意 - ^ 表示字符“^”，而不是控制键 + 值。

如果按下 [image] 按钮则显示查找历史记录。

如果按下 [image] 按钮，则显示带下列选项的收藏夹子菜单：

添加到收藏夹 | 将组合框中的当前内容添加到收藏夹列表
从收藏夹中删除 | 将组合框中的当前内容从收藏夹列表中移除
收藏夹 | 打开子菜单显示收藏夹列表。 可以从列表中选择字符串填入组合框

要选择光标位置和搜索目标之间的所有文本，请在用查找下一个按钮开始搜索的同时按下 SHIFT 键。

搜索方向

默认搜索方向是向下（面向文件末尾）。给出了在文件内向上或向下搜索的选项。如果已在文档内进行了搜索，则默认搜索方向是前一个搜索的方向。

总数

总数会显示对话框说明在活动文件内当前搜索字符串出现的次数。

查找位置 [3]

用户可以在查找位置区段指定是否在当前文件、已选择文本或所有打开文件中执行搜索，且替换也将被限制到指定区域。 如果选择所有打开文件，按下查找下一个会自动将焦点移动到下一个打开文件内查找字符串第一次出现的位置。 该功能代替了较早版本中的在所有打开文件中查找下一个选项。

有下列搜索选项 [2]：

只匹配整个词语

默认情况下，搜索不会被限制为只匹配整个词语。该选项允许将搜索限制为只匹配整个词语。这对于查找“a”或“A”而不是所有包含“a”的词语非常有用。如果已经在文档中执行了搜索，则默认的选择将与前一个搜索设置匹配。

匹配大小写

默认情况下，搜索是不区分大小写的。这个选项可以使搜索区分大小写。。如果已经在文档中执行了搜索，区分大小写的默认选择是根据上一次搜索来设置。

正则表达式

如果选择该选项，将使用在高级区段下选择的正则表达式类型执行搜索。

高级选项 [4]

按下高级按钮扩展“在文件中查找”对话框以显示更多搜索选项。

正则表达式

与 Perl 兼容的正则表达式

如果选择该选项，编辑器将使用基于 Boost C++ 库的 Perl 样式正则表达式。

UltraEdit 样式正则表达式

如果选择该选项，编辑器将使用 UltraEdit 样式正则表达式。

Unix 样式正则表达式

如果选择该选项，编辑器将使用 UNIX 样式正则表达式。

有关创建正则表达式的信息，请参见 正则表达式 或 Perl 正则表达式帮助文件。

高亮显示所有找到的项目

该选项可以在按查找下一个按钮时高亮显示所有与搜索字符串匹配的项目（显示为选中的文本）。

列出包含字符串的行

该选项使 UltraEdit 在活动文档中搜索字符串的所有实例，并将其列出在对话框中。双击结果行中的某行（或选中它然后单击转到），UltraEdit 将转到文件中的该行。

在列中搜索

如果选择该选项，搜索将被限制于指定的起始列和终止列。 要搜索整行，应使用“0”和“-1”。

如果编辑器活动窗口处于十六进制模式，会出现另一个选项:

ASCII

默认情况下，在十六进制模式中，将执行十六进制字符搜索。也可以将查找配置为搜索 ASCII 字符。

查找操作完成时会高亮显示文本。

最初执行查找后，会显示简单对话框以方便选择查找和查找下一个。这可以通过更改 INI 设置 来禁用。

快捷键： ALT+F3 或 CTRL+F


查找下一个命令

查找下一个命令 (搜索菜单)

这个命令按朝文件尾方向重复上一个 查找命令 。该方向上的下一处与查找条件匹配的文字将被找到 (如果有)。

要选择光标位置和搜索目标之间的所有文本，在通过菜单或按快捷键执行找下一个命令的同时按下 SHIFT 键。

快捷键: F3


查找上一个

查找上一个 (搜索菜单)

这个命令按朝文件尾相反方向重复上一个 查找命令 该方向上的下一处与查找条件匹配的文字将被找到 (如果有)。

在选择光标位置和搜索目标之间的所有文本，在通过菜单或快捷键执行找上一个命令的同时按下 SHIFT 键。

快捷键: CTRL+F3


替换命令

替换命令 (搜索菜单)

这个命令会显示一个用指定的文本搜索文档、并用其它文本替换的对话框。

要搜索的字符串在 查找内容 [1] 字段中指定，用来替换的字符串在替换内容 [2]字段中定义。 这两个字段支持使用单行或多行字符串，最大为 20,000 字节。 搜索将按指定的方向执行。如果找不到字符串，程序将转到文件另一端继续搜索。找不到字符串将会显示消息。

除了可以搜索替换可打印字符，还可以搜索或替换制表符和换行符（回车/换行）。 要指定制表符，可以在对话框中使用“^t”。 要指定换行符，可以在对话框中使用“^p”表示回车/换行，“^n”仅表示 LF，“^r”仅表示 CR。 要搜索“^”字符，可以在对话框中使用“^^”。 要指定“^”字符，在对话框中使用“^^”。

另外，当执行查找时，字符“^s”将替换为当前加亮的任何文本，字符“^c”将替换为当前剪贴板的内容 (不大于 30,000 个字符)。这在宏执行中特别有用。当录制宏时，可以选择查找指定的字符串，或使用“^s”，宏会录制“^s”，并在宏执行期间用加亮的文本替换。同样，当使用“^c”时，这些字符将用宏执行时的剪贴板内容替换。

如果按 [image] 按钮，将会显示查找内容/ 替换内容历史记录。

如果按下 [image] 按钮，将显示子菜单，其选项如下：

添加到收藏夹 | 将组合框中的当前内容添加到收藏夹列表
从收藏夹中删除 | 将组合框中的当前内容从收藏夹列表中移除
收藏夹 | 打开显示收藏夹列表的子菜单。 可以从列表中选择字符串填入组合框

特殊字符摘要:

符号 | 功能
^^ | 搜索字符“^”
^s | 宏执行时搜索选定 (加亮) 的文本
^c | 宏执行时搜索剪贴板的内容
^b | 匹配一个分页符
^p | 匹配一个换行符 (CR/LF) (段落) (DOS 文件)
^r | 匹配一个换行符 (仅 CR) (段落) (MAC 文件)
^n | 匹配一个换行符 (仅 LF) (段落) (UNIX 文件)
^t | 匹配一个制表符

注意 - ^ 这里所涉及的字符“^”不是控制键 + 值。

查找下一个

查找下一个指查找指定文本的下一个出现。

替换

替换是指查找下一个指定的文本，并用新的文本替换它。用户也可以在替换的地方 [4]指定选定文本或所有打开的文件，替换将被限制为选定文本范围。 如果选择所有打开文件，按下替换会自动将焦点移动到下一个打开文件内查找字符串第一次出现的位置。 该功能取代了以前版本中的在所有打开文件中替换文本选项。

全部替换

全部替换是指查找所有指定文本的实例，并用新文本替换所有找到的文本。

全部替换还提供另外的选项:

在当前文件中替换- 仅替换当前文件中出现的文本。 它将根据这个对话框中的设置决定是否应该从文件顶部开始替换，或从当前光标位置开始替换。

在选定文本内部替换 - 只一次性替换当前选定文本范围内部的文本。

在所有打开文件内替换 - 替换所有当前打开的文件中出现的文本。

最后

最后命令执行单个替换，且不移动到下一个出现的匹配文本直接关闭对话框。

另外还有下列替换选项[3]：

只匹配整个词语

默认情况下，搜索没有限定为只匹配整个词语。该选项允许搜索限制为只匹配整个词语。在搜索“a”或“A”而无需搜索所有包含“a”的词语时，该选项非常有用。如果已经在文档中执行了搜索，默认选项将与前一次搜索的选项相同。

大小写匹配

按默认，搜索是不区分大小写的。 这个选项可以使搜索区分大小写。如果已经在文档中执行了搜索，区分大小写的默认选择是根据上一次搜索设置。

正则表达式

如果选中该选项，则使用在“高级”部分下选中的正则表达式类型执行搜索。

高级选项 [5]

按下高级按钮将展开“在文件中查找”对话框，以显示其他搜索选项。

正则表达式

符合 Perl 的正则表达式

如果选中该选项，编辑器将使用基于 Boost C++ Libraries 的 Perl 样式正则表达式。

UltraEdit 风格正则表达式

如果选中该选项，编辑器将使用 UltraEdit 风格的正则表达式。

Unix 样式正则表达式

如果选中该选项，编辑器将使用 UNIX 风格的正则表达式。

有关创建正则表达式的更多信息，请参见 正则表达式 或 Perl 正则表达式帮助。

保护大小写

保护大小写选项可以让 UltraEdit 在替换中用查找到的字符串的大小写格式来匹配替换字符串的大小写。规则如下:

1) 如果找到的词语全部是小写字母，那么替换后的词语也将全部是小写

2) 如果找到的词语全部是大写字母，那么替换后的词语也将全部是大写

3) 如果找到的词语是大小写混合格式，那么替换后的词语匹配替换词语的大小写格式。

例如：(查找“The”用“Then”替换)

“the”将被替换为“then”

“THE”将被替换为“THEN”

“The”将被替换为“Then”

混合大小写场合下需要替换词语中可以指定大小写混合，并应用到最后结果，因此，即使有多处大小写混合的情况也可以被正确替换，不仅仅是首字大写，如下面:

用“PreviousCharacter”替换“NextCharacter”将执行:

“nextcharacter”用“previouscharacter”替换

“NEXTCHARACTER”用“PREVIOUSCHARACTER”替换

“NextCharacter”用“PreviousCharacter”替换

从文件顶部全部替换

如果选中该选项，则将从活动文件的顶部而非当前光标所在位置执行指定的搜索。

替换后关闭该对话框

如果选中该选项，则在单个替换执行完毕后自动关闭“替换”对话框。

在列中搜索

如果选中该选项，搜索范围将仅限于指定的起始和结束列。 要在整个行中搜索，应使用 "0" 和 "-1"。 注意它是重要的，列编号从"0" 开始;必须被设置到" 0" 搜索从行首开始。

如果编辑器活动窗口处于十六进制模式，会出现一个另外的选项:

ASCII

按默认，在 十六进制模式 中，将执行十六进制字符搜索，你也可以配置为搜索 ASCII 字符。

当查找操作完成，文本是加亮的。在十六进制模式，如果指定的搜索字符串超过一行，另外的字符也可能被加亮。 在这种情况下，所有从第一行中搜索字符串的第一个字符到最后一行中搜索字符串的最后一个字符被加亮，只替换搜索字符串。

在执行替换后，会显示一个简单的对话框，使你能够很方便地选择查找下一个和替换操作。这可以通过更改 INI 设置 来禁用。

全部替换命令支持 撤销 。 可是，如果替换太大，将不支持撤销，并且撤销缓存将溢出。

快捷键： CTRL+R


步进搜索

步进搜索 (搜索菜单)

这个命令类似于 查找命令 。它执行查找命令，但它不等待输入完整的搜索字符，它将搜索最接近输入的字符串，用输入的字符串重新配置到搜索字符串。这可在大多数情况下更快的查找正确的匹配字符串。

如果输入字符错误，可以使用 backspace 键修改已经输入的内容。如果使用了 backspace 键，搜索将再从原始位置开始查找已修改字符串匹配的第一个实例。

在搜索的任何时候，按 Esc 键或光标键将会停止搜索。如果从编辑窗口改变了焦点，也将停止搜索。

当执行搜索时，搜索的字符串显示在状态栏中。

在步进搜索结束后，可以使用返回命令来定位到开始搜索之前的原始位置。


在文件中查找命令

在文件中查找命令(搜索菜单)

该命令显示对话框用于在磁盘上的文件内搜索文本字符串。

在查找内容 [1] 字段中指定要搜索的字符串。 可以使用单行或多行字符串，最大长度可达 20,000 字节。 在文件/类型 [2] 和目录 [3] 字段指定要搜索的文件。目录字段指定搜索的目录，文件/类型字段指定文件名或类型。文件名可以包含通配符，也可以包含用分号隔开的多个文件类型，即：

*.cpp;*.h

目录 [3] 字段可以包含用分号隔开的多个搜索路径，即：

C:\mydir1\; c:mydir2\

请注意：如果查找 [1] 字符串留空，编辑器将返回匹配指定条件的所有文件名列表。这可以用于生成目录列表。

执行查找时，如果将输出结果传送到输出窗口，则将清除现有的输出。如果传送到编辑窗口，则在以查找结果为标题的文件不存在的情况下，将创建新文件。如果该文件存在，查找结果将附加到现有文件末端。

如果按下 [image] 按钮则显示查找历史记录。

如果按下 [image] 按钮，将显示子菜单，其选项如下：

可以将搜索限制为以下的文件组：

搜索 [5]：

列出的文件 - 这将搜索在文件/类型和目录字段中列出的文件（默认选择）。

打开文件 - 这将搜索所有打开的文件。文件/类型和目录字段将被忽略。

收藏的文件 - 这将搜索文件菜单中收藏的文件下列出的所有文件。文件/类型和目录字段将被忽略。

方案文件 - 这将搜索打开的方案内部的所有文件。 文件/类型和目录字段将被忽略。

解决方案文件 - 这将搜索打开的解决方案中的所有文件。文件/类型和目录字段将被忽略。

*只有 UEStudio 支持解决方案文件选项。

可以使用以下搜索选项[4]：

Unicode 搜索

该选项指示 UltraEdit 执行 Unicode 搜索。输入的字符串将以双字节方式输入并转化为 Unicode。搜索的文件将使用 Unicode 字符串进行搜索。

只匹配整个词语

默认情况下，搜索不会被限制为只匹配整个词语。该选项允许将搜索限制为只匹配整个词语。这对于查找“a”或“A”而不是所有包含“a”的词语非常有用。如果已经在文档中执行了搜索，则默认的选择将与前一个搜索设置匹配。

匹配大小写

默认情况下，搜索是不区分大小写的。这个选项可以使搜索区分大小写。

正则表达式

如果选择该选项，将使用在高级区段下选择的正则表达式类型执行搜索。

高级选项 [6]

按下高级按钮扩展“在文件中查找”对话框以显示更多搜索选项。

正则表达式

与 Perl 兼容的正则表达式

如果选择该选项，编辑器将使用基于 Boost C++ 库 的 Perl 样式正则表达式。

UltraEdit 样式正则表达式

如果选择该选项，编辑器将使用 UltraEdit 样式正则表达式。

Unix 样式正则表达式

如果选择该选项，编辑器将使用 UNIX 样式正则表达式。

有关创建正则表达式的信息，请参见 正则表达式 或 Perl 正则表达式帮助文件。

搜索子目录

默认情况下，只搜索指定目录中的指定文件。该选项指示搜索操作对指定目录的所有子目录进行搜索。如果选择忽略隐藏子目录选项，则隐藏的子目录（在 Microsoft 浏览器中作了定义）将排出在搜索之外。

用户可根据需要，在搜索中忽略的子目录名字段指定特定子目录，以将其排出在搜索之外。多个名称应用分号隔开。

返回结果到编辑窗口

该选项指示 UltraEdit 为查找结果创建编辑窗口（新建文件），从而可以编辑、保存或打印结果。默认操作是在列表框窗口（输出窗口）内捕获输出，并允许用户双击结果从而自动打开相应文件。

如果未找到字符串则匹配文件

该选项使 UltraEdit 仅列出不包括指定搜索字符串的文件。


在文件中替换命令

在文件中替换命令 (搜索菜单)

该命令显示对话框用于在磁盘上的文件内搜索文本字符串并用另一个文本字符串替换。

要搜索的字符串在 查找内容 [1] 字段中指定，用来替换的字符串在替换内容 [2]字段中定义。 这两个字段支持使用单行或多行字符串，最大为 20,000 字节。 要搜索的文件可以在文件/类型和目录字段中指定。目录 [4] 字段指定要搜索的目录，文件/类型 [3] 字段指定文件名或类型。文件名可以包含通配符（星号），也可以包含多个文件，互相用分号（:）隔开：

*.cpp;*.h

目录 [4]字段可以包含多个搜索路径，之间用分号（:）隔开

C:\mydir1\; c:mydir2\

如果按 [image] 按钮，则显示查找历史记录。

如果按下 [image] 按钮，将显示子菜单，其选项如下：

替换范围 [6]

用户可以指定是否将更改应用于列出的文件、打开的文件、收藏夹文件、项目文件或解决方案文件。如果选中列出的文件，则会使用文件类型和指定的目录确定替换操作要修改的文件。如果选中项目文件或解决方案文件，则替换将用于活动的项目或解决方案。

执行查找/替换后，包含查找字符串的每个文件将被修改，且每个字符串都将被替换。如果文件属性为 只读 ，则文件不会被修改并显示一个消息框。在操作最后，将显示对话框，说明替换执行的次数以及修改的文件数量。

另外还有下列搜索选项[5]：

Unicode 搜索

该选项告诉 UltraEdit 执行 Unicode 字符搜索。 输入的字符串将以多字节输入并转换到 Unicode 字符。所有搜索的文件将使用 Unicode 字符串进行搜索和替换。

只匹配整个词语

按默认，搜索是不限制只匹配整个词语的。该选项允许搜索限制为只匹配整个词语。这通常在只搜索“ a ”或“A”时有用，不会将词语内部的“a”包含进去。 如果以前已经使用了这个选项并曾找到过，它会记住上一次搜索的选项。

大小写匹配

按默认，搜索是不区分大小写的。 该选项可以使搜索区分大小写。

正则表达式

如果选中该选项，则使用在“高级”部分下选中的正则表达式类型执行搜索。

高级选项 [7]

按下高级按钮将展开“在文件中查找”对话框，以显示其他搜索选项。

正则表达式

符合 Perl 的正则表达式

如果选中该选项，编辑器将使用基于 Boost C++ Libraries 的 Perl 样式正则表达式。

UltraEdit 风格正则表达式

如果选中该选项，编辑器将使用 UltraEdit 风格的正则表达式。

Unix 样式正则表达式

如果选中该选项，编辑器将使用 UNIX 风格的正则表达式。

有关创建正则表达式的更多信息，请参见 正则表达式 或 Perl 正则表达式帮助。

保护大小写

保护大小写选项可以让 UltraEdit 在替换中用查找到的字符串的大小写格式来匹配替换字符串的大小写。规则如下:

1) 如果找到的词语全部是小写字母，那么替换后的词语也将全部是小写

2) 如果找到的词语全部是大写字母，那么替换后的词语也将全部是大写

3) 如果找到的词语是大小写混合格式，那么替换后的词语匹配替换词语的大小写格式。

例如：(查找“The”，用“Then”替换)

“the”将被替换为“then”

“THE”将被替换为“THEN”

“The”将被替换为“Then”

在混合大小写场合下，需要替换词语中可以指定大小写混合，并应用到最后结果，因此，即使有多处大小写混合的情况也可以被正确替换，不仅仅是首字大写。

用“PreviousCharacter”替换“NextCharacter”将执行:

“nextcharacter”用“previouscharacter”替换

“NEXTCHARACTER”用“PREVIOUSCHARACTER”替换

“NextCharacter”用“PreviousCharacter”替换

搜索子目录

默认情况下，仅搜索指定目录中的文件。如果选择搜索子目录，则也将搜索指定目录中的所有子目录。 如果选中忽略隐藏子目录选项，则在搜索范围中将不会包含隐藏的子目录（根据 Microsoft 资源管理器中的定义）。

如果需要，用户可以在搜索中忽略的子目录名字段中指定某些子目录，使其不包含在搜索范围内。 多个名称之间应该用分号隔开。

列出更改的文件

该操作使编辑器在输出窗口中列出所有更改的文件。如果选中，将在输出窗口中显示文件的每个更改，以及找到和更改的次数。

忽略隐藏的子目录

如果选中该选项，在文件中替换操作将不针对隐藏的子目录。

搜索中要忽略的子目录名称

如果选中该选项，在文件中替换操作将不针对隐藏的子目录。


成对匹配命令

成对匹配命令 (搜索菜单)

这个命令用来在文件中从光标位置向前搜索，查找一个打开或关闭成对符。如果找到一个打开的成对符，那么继续向前方向搜索，直到找到最靠近一个的匹配的关闭成对符。如果找到的第一个成对符是关闭成对符，那么将反方向执行搜索，直到找到最靠近一个的匹配的打开成对符。

当找到匹配的成对符时，所有成对符之间的文本，包括两个成对符将被加亮。

按默认，打开成对符是 {、( 和 [，关闭成对符是 }、) 和 ]，用户可以用词语文件中作为 语法加亮 的 Open Brace Strings 和 Close Brace Strings 命令在每种语言中指定其它的字符/字符串用于打开/关闭成对符。

另外，当光标在左或右括号/成对符定位时，UltraEdit 将自动加亮匹配的括号/成对符，但不执行屏幕定位操作，如果括号/成对符在当前视图中，它们只是被加亮。

如果文件已被指定为 HTML 文件 (查阅 语法加亮 ) 匹配“<”和“>”的字符将也被加亮。

快捷键: CTRL+B


转到行/页命令

转到行/页命令（搜索菜单）

转到菜单项目会打开一个对话框，允许用户将光标定位到指定的行/列号、分页符或书签。

在指定了转到分页符时，光标定位到有指定分页符的行。

当选中行/列后，光标将指向指定的行/列，并将该行滚动到视图中。如果指定的行号大于文件中的行数，光标将定位到文件末。如果指定的行号大于文件中的行数，光标将定位到指定的行末。如果指定的列号大于文件中的列数，光标将定位到指定的行末。

在指定了转到书签时，光标定位到有指定书签的行。

当在执行转到命令同时按下 Shift 键，当前选定的文本（如果有）或新的选区将扩展到执行这个命令后光标所在位置。

在 十六进制模式 中，转到对话框允许用户选择要定位光标的文件中的偏移量。如果偏移量大于文件大小，光标将定位到文本末。

快捷键： CTRL+G


切换书签命令

切换书签命令 (搜索菜单)

UltraEdit 允许你设置“书签”，用来标记文件中的位置。如果在某行中设置了书签，你可以使用菜单或键盘命令移动到该行。

要设置书签:

1. 将光标移动到你想设置书签的行中。

2. 从搜索菜单选择切换书签。

快捷键: CTRL+F2

要删除所有书签，用清除所有书签菜单项目。

要移动到插入的下一个书签位置，从 搜索菜单 选择下一个书签。

快捷键: F2

要移动到插入的上一个书签位置，从 搜索菜单 选择上一个书签。

快捷键: ALT+F2

当执行转移书签功能时同时按下 Shift 键，当前的选区 (如果有) 或新的选区将扩展到执行命令后光标位置。


字数命令

字数命令 (搜索菜单)

字数功能用来分析文档和选区中的词语、行和字符 (带空格和不带空格) 数量，并显示分析结果。如果已经选定了文件中的一部分，那么将显示该部分和整个文件的分析结果。

这里所指的行数是指用行终止符换行的行数。如果是自动换行显示的行，不会重复计数为多行。


函数列表命令

函数列表命令 (搜索菜单)

这个命令用来在活动文档中显示函数列表。其结果按字母顺序或按在文档中出现的顺序显示在一个可停驻的窗口中。双击其中一个结果行，UltraEdit 将在文件中定位该行，光标焦点切换到文件中。如果在函数列表中聚集时按 Enter 键，UltraEdit 将定位到该行，光标焦点仍保留在函数列表。按 CTRL+Enter 也可以定位到该行，但光标焦点将切换到文件中。

函数列表可以随意设置为搜索活动方案中的所有文档。这可以通过在函数列表中右键点击并选择适当的菜单项目来设置。

另外，在函数列表中右键点击，用户可以选择按适当的顺序排序 (或不排序) 函数列表。

UltraEdit 通过搜索一个特殊式样来确定行是否被视为一个函数。该搜索的式样是一个可以由用户修改的正则表达式字符。

该正则表达式字符在 wordfile.txt 文件中定义，每种语言都可以有它自己的定义。

注意 - 该正则表达式字符必须使用 UltraEdit 样式的正则表达式。这样可以使函数列表不考虑正则表达式设置进行工作。

查阅 语法加亮 段获取更改用于函数的验证字符的更多信息。

在处理文件时，UltraEdit 将尝试加亮光标所在的当前函数。实际上它将在文件中查找上一个已经验证为函数的函数 (到光标所在位置) 并加亮这个函数。如果光标在函数之间，或在最后一个函数之后，那么上一个通过验证的函数将被加亮。如果在函数列表中设置了显示方案中所有文件的选项，那么光标位置处将不被加亮。


查找符号

查找符号 (搜索菜单)

这个命令用来搜索标签文件中的活动符号，如果只找到一个匹配的条目，那么该文件将在 UltraEdit 中打开，并定位到该符号的位置。如果找到多个匹配条目，将显示一个对话框，让用户选择适当的标签位置。


字符属性

字符属性 (搜索菜单)

使用这个命令会显示一个对话框，该对话框中显示活动字符的十进制值和十六进制值，以及显示的方式 (这会根据字体和脚本改变)。同时还显示用十进制和十六进制格式显示活动字符的偏移。


返回/向前命令

返回/向前命令 (搜索菜单)

UltraEdit 保留用户最后编辑、更改位置或用 查找符号命令 跳到其它文件后的位置列表，这个功能允许用户在文件内部更改位置或更改到其它文件后，快速跳回到原先的位置或文件。

返回命令用来将光标重新定位到上一个位置或列表中的上一个文件中。当用户使用返回命令跳转后，向前命令被启用，可以让用户再次向前跳回到刚才使用返回命令之前的位置。

当文件更改后，或重新定位更新记住位置的列表的情况出现，那么在当前列表位置添加新的位置。这可以让用户继续使用向前/返回命令。

当在文件内部进行编辑，那么只记住最后一次重新定位以后的最后一个编辑位置，不是字符串添加后的每个位置或排序所作的更改都被记住。


方案菜单

方案菜单允许管理方案和工作区。它提供了简捷的方式管理和分组相关的文件。

该功能包括通过 文件对话框 快速访问文件组和保存/恢复打开文件状态。

新建方案/工作区 | 创建和打开一个新的方案文件
打开方案/工作区 | 打开一个现有的方案文件
关闭方案/工作区 | 关闭一个方案
方案设置 | 关闭一个方案
添加到方案 | 提供子菜单插入活动方案的文件/文件夹/组中
* 插入 | 弹出插入 C++、Java 或 C# 类到活动方案的子菜单
备份方案/工作区 | 复制当前方案/工作区中的所有活动文件到压缩的备份文件 (.bup) 中，并贮存于活动方案/文件的 .prj 文件的同一目录
恢复方案/工作区 | 打开恢复方案文件对话框，从以前备份的副本中重新载入方案
* 方案转换器 | 运行 Visual Studio 到 UEStudio 的方案转换对话框
* 方案管理器 | 启动方案管理器对话框，用户可以从中打开、创建、备份、还原、或批量生成方案
* 校验 | 校验储存库中的模块
* 更新 | 不显示任何提示或选项从储存库中提交工作副本
* 提交 | 不显示任何提示或选项从储存库中提交工作副本。
* 更新 (特殊) | 允许使用“CVS 更新”对话框配置多个 CVS 相关选项
* 标签 | 在 CVS 树里创建标签（分支）
* 导入 | 导入新模块到储存库中
* 导出 | 校验除 CVS 信息之外的模块
* 帐号/设置 | 运行 CVS 管理器对话框
创建 CTAG 文件 | 创建 tag 文件
CTAG 选项文件 | 设置 Ctags 选项

* 请注意：这些功能只在 UEStudio 中支持，UltraEdit-32 不支持这些功能。


新建方案/工作区命令

新建方案/工作区命令 (方案菜单)

新建方案命令允许你创建一个新的方案/方案文件。

方案可用来管理你的方案或工作区。它提供一个非常方便地管理和组合相关文件的方法。

在多数场合下，文件组可被关联，当编辑一个特殊文件时，可以编辑或查看其它相关的文件。这些文件可以组合为一个方案/工作区。

将这些文件组合到方案中可用来很方便地在没有搜索到它们的情况下来访问和/或打开所有相关的文件。

方案支持提供组合方案和工具区功能。在多数场合中，它可以很方便地使用下面描述的自动工作区支持:

工作区

工作区功能是用来在方案关闭时，保存方案文件中所有打开的文件的状态，包括窗口位置、光标位置和要打开哪些文件。

当方案打开时，所有以前方案关闭时打开的文件也自动打开。文件不一个要通过 文件对话框 明确添加到方案中。

方案

方案功能是用来切换文件的关联，即使它们当前没有在编辑器打开。文件可以通过 文件对话框 添加到方案或从方案中删除。方案内部的文件可以很方便地通过 文件对话框 打开。


打开方案/工作区命令

打开方案/工作区命令 (方案菜单)

打开方案命令允许你打开一个现有的、必须用 新建方案/工作区命令 创建的方案。当打开一个新方案时，当前方案 (如果已打开) 将被关闭。将会给出关闭当前打开文件的选项。

当打开方案后，该方案最后一次关闭前打开的所有文件将自动打开。


关闭方案/工作区命令

关闭方案/工作区命令 (方案菜单)

关闭方案命令用来关闭当前打开的方案。所有文件的状态将被保存到方案文件中，当下次 打开 方案时，自动打开这些状态。这个选项将关闭当前打开的文件。


方案设置命令

方案设置命令 (方案菜单)

方案设置命令用来打开 方案设置对话框 。这个对话框用于配置活动方案的设置。也可以使用 文件树视图 中的上下文菜单选项将文件/文件夹添加到活动方案，或删除活动文件中删除文件/文件夹。

UltraEdit 允许指定方案目录，与这个选项关联的还是使用相对路径。如果设置了这些选项，UltraEdit 将贮存相对于方案目录的文件名，以后用户如果移动了方案，那么路径还是可以保持 (就算更改了方案目录)。相对路径必须在方案目录之下。另外，如果选中了相对于方案文件，方案文件将被设为方案文件所在目录相关的文件。这个选项允许方案文件和它的文件贮存在相同目录，即使在连同方案目录移动后，也不需要更新。

在某些场合中，这有利于组合聚集在单个方案内部的多个文件集。UltraEdit 提供将这些文件组合到一个已命名的组的功能。这些组可以根据需要添加或删除，以及文件可以添加到每个组中。

该对话框显示一个方案部分的文件列表。下列控件可用来管理该列表:

打开

打开按钮用来从列表打开选定的文件，并关闭对话框。可以一次选定和打开多个文件。所有列表中的更改将被保存。双击文件列表中的任何文件将执行打开命令。

关闭

关闭按钮用来关闭对话框，列表中所作的更改被保存。

更新

这个命令用来更新方案信息 (提交更改)，并刷新方案列表。

新建组

新建组按钮用来打开一个对话框，在那里用户可以指定要添加的组名。允许使用嵌套组。

方案中可以添加 2000 个以下的文件。


插入命令

插入命令 (方案菜单)

这个命令会弹出一个子菜单，允许用户选择插入一个新的 C++ 类或 Java/C# 类。请注意: 这个功能只被 UEStudio 支持，UltraEdit-32 不支持这个功能。

新建 C++ 类

如果选定了“C++ 类”选项，将出现一个新建 C++ 类对话框。这个对话框用于创建一个新的类并自动生成关联的 .h 和 .cpp 文件。

类名

类名对象用于设置新类的名字。该名字用于创建相关的 .h 和 .cpp 文件。

基本类

这个对象用于设置新建类的基本类。

权限

这个下拉框用于设置新建类的修改权限。修改权限是指定访问已经加入到类成员函数的其它类的关键字。可以设置为公共、私人或受保护。

公共 | 在前述一个类成员列表时，公共关键字指定这些成员可以从任何函数访问。这应用到所有已声明的成员，直到下一个访问指定者，或类结束。 在前述基本类名字时，公共关键字指定公共和受保护的基本类成员分别是公共和受保护的源类成员。
私人 | 在前述一个类成员列表时，私人关键字指定这些成员只能从类的成员函数和较亲密的函数访问。这应用到所有已声明的成员，直到下一个访问指定者，或类结束。 在前述基本类名字时，私人关键字指定公共和受保护的基本类成员是源类的私人成员。
受保护 | 受保护的关键字指定成员列表中类成员的权限，直到下一个访问指定者 (公共或私人) 或类定义结束。类成员声明为受保存只能在下列情况下使用: - 最初已声明这些成员的类成员函数。 - 最初已声明这些成员的类关系较亲密的函数。 - 得自来自最初已声明这些成员的类的公共或受保护权限类。 - 直接源自有访问受保护成员的私人类 在前述基本类名字时，受保护关键字指定基本类公共和受保护成员是它源类的受保存成员。

.h 文件

这个对象用于设置新建对象类的头文件名字。按默认，这个名字是根据你在类名中提供的名字生成。

.cpp 文件

这个对象用于设置新建对象的类执行文件的名字。这是用于定义类要贮存的地方。

Inline 类

如果选中了这个选项，类 constructor 和类定义两者将在头文件中以 inline 函数生成。

虚拟 Destructor

这个选项用来指定类 destructor 是否是虚拟的。使用 destructors 有助于在源类实例被删除时确保 destructor 的正确调用。

新建 Java 或 C# 类

如果选中了“新建 Java 或 C# 类”选项，将显示新建 Java 或 C# 类对话框。

Namespace

这个对象用于设置用于声明范围的 namespace 关键字。这个 namespace 范围可以让你管理代码，以及给出创建全局唯一类型的方法。如果声明了 namespace，.java/.cs 对象将根据指定的类名用 C# 文件名加载。

类名

这个对象中指定的类名将被用于在已被定义的类中创建文件。

.java/.cs

为每个新类自动生成一个 .java/.cs 文件。如果已声明 namespace，这个对象将自动根据批定的类名用 C# 文件名加载。如果未声明 namespace，这个对象将自动根据指定的类名用 Java 文件名加载。

基本类

这个对象用于指定来自新建类来源的基本类。


添加到方案命令

该命令提供一个子菜单，供用户选择项目添加到活动方案。请注意： 在 UltraEdit-32 里该子菜单仅包括下述新文件夹和文件选项。

添加到方案子菜单包含下列项目：

新建 | 提供“打开文件”对话框，用户可以浏览所需路径创建新文件添加到活动方案
新建文件夹 | 提供“新建文件夹”对话框，允许用户从当前映射的驱动器选择文件夹添加到方案，或（如果选中了组项目）在活动方案里指定新组以便保留位置。
文件 | 提供“打开文件”对话框，允许用户从当前映射的驱动器里选择文件添加到活动方案
动态链接库 | 提供对话框，允许用户从当前映射的驱动器里选择 DLL 添加到活动方案


备份方案/工作区命令

备份方案/工作区命令 (方案菜单)

这个命令用来复制所有在当前方案/工作区中的文件到一个压缩的备份文件 (用“.bup”作为扩展名)，贮存在与活动方案/工作区的 .prj 文件相同的目录中，并弹出 备份方案文件对话框，显示关于创建的方案备份文件信息。

有了方案/工作区的备份副本，用户可以更安心地进行开发了，如果方案/工作区不能正常工作，可以使用 恢复方案/工作区命令 进行恢复。


恢复方案/工作区命令

恢复方案/工作区命令 (方案菜单)

这个命令会弹出恢复方案文件对话框，可以用来从以前用 备份方案/工作区命令 备份的副本重新载入方案。

恢复方案文件对话框用来从以前的备份中列出所有贮存在方案/工作区的文件。

如果你不需要某些项目，不需要从压缩的备份文件中恢复所有的项目。按“-”按钮会使当前列出的所有项目全部被取消选定。按“+”按钮将会使对话框中列出的项目全部选定。个别文件可以通过用鼠标点击项目来选定或取消选定。

“+”按钮的右边的文本对象是一个过滤文本对象，在那里可以输入文件扩展名。如果指定了一个扩展名 (例如 cgi) 并按下“+”按钮，所有带该扩展名的文件将被选定。如果指定了一个扩展名 (例如 cgi) 并按下“-”按钮，所有带该扩展名的文件将被取消选定。

一旦你选择了方案中你想恢复的项目，并按下恢复按钮，那么将从压缩的备份文件中重新载入。


方案转换命令

方案转换命令 (方案菜单)

这个命令可以用于将一个现有的 Visual Studio 方案转换到 UEStudio 方案格式，使它可以在 UEStudio 内部进行修改/构建。

用户按“...”按钮可以浏览选择要用 UEStudio 进行处理的 Visual Studio 方案、工作区或解法文件。

如果选定了打印转换后的方案/工作区，那么选定的项目将在转换后在 UEStudio 中打开。

按下转换按钮开始进行转换，按下关闭按钮关闭方案转换对话框。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。


方案管理器命令

方案管理器命令（方案菜单）

在“方案”菜单里选择该选项将启动“方案管理器”对话框。

方案列表

“方案管理器”的主要部分是“方案列表”[1]。此列表包括方案名、编译器、工作时间和方案路径。“方案管理器”用于帮助管理当前进行中的所有方案。与“方案”管理有关的功能分为三类：方案[2] - 关系到打开、创建、备份和还原方案文件，方案列表 [3] - 关系到添加方案到“方案列表”或从其中删除方案，以及批处理生成器 [4] - 关系到打开/创建列表以生成批处理。

方案功能

可以通过双击方案名或选择方案名并按下打开按钮来打开方案。这将在 UEStudio 中打开选定的方案。

如果按下创建按钮，会显示一个上下文菜单，供用户从中选择空白或使用模板。

如果选择了空白，会显示一个对话框用于创建新的、空白对话框。

在此可以指定方案名 [1]和位置 [2]。如果未选择创建方案目录 [3]则指定的方案将在指定的目录中创建。如果选择了创建方案目录，则以该方案名称命名的目录将在指定的路径创建。例如，如果指定了方案名“App1”，则到该方案文件的路径将为“C:\Development\Working Group1\App1\App1.prj”。

如果选择了使用模板选项，则会显示一个对话框，允许使用新方案的规范和模板来创建该方案。

方案模板

取决于选择的编译器类型，可以使用 提供的模板 之一。 选择所需的编译器[1]，然后选择希望用[2]来创建方案的“模板”类型，然后在方案名字段[3] 里输入该方案的名称。 不要忘记设置该项目的“位置”[4]，通过输入它并按下浏览按钮再选择它。 推荐在第一次运行方案模板时设置一个位置并始终使用同一个位置。 该位置是您方案的“父”目录，因为 UEStudio 用与该方案相同的名称为其创建自己的目录。 大多数模板自动创建方案，并在 UEStudio 中打开，但有些模板需要在创建方案之前设置一些选项。 包括一个模板用于所有编译器——用户定义的模板。

备份/恢复功能

如果按下备份按钮，则活动方案中的文件将立即进行备份。如果位置文本字段为空，则备份将创建为与活动方案使用相同的名称。如果指定了一个路径，则“方案管理器”将生成带有日期戳的名称，并且如果按下还原，用户可以选择所需的备份版本来还原选定的方案。可以按下删除备份来选择要删除的备份。活动方案的备份将在上下文菜单里列出，以供用户选择要删除的备份。

方案列表功能

如果已创建方案，则可以使用添加按钮来添加单一的方案到“方案列表”。可以使用查找按钮来添加指定目录下找到的所有方案。要从“方案列表”里删除方案，可以使用删除。如果按下删除按钮时选择了一个方案，“方案管理器”将在 Windows 资源管理器里打开方案目录，允许用户在需要时更轻易地从磁盘删除方案文件。如果选择了超过一个方案，“方案管理器”将仅从方案列表里删除这些方案。按下删除按钮将删除整个活动“方案列表”。

批处理生成器功能

在“批处理生成器”部分按下创建按钮并在“方案列表”里选择一个方案，将快速创建“批处理生成器”列表。按下打开按钮将打开 批处理生成器对话框 。


校验命令

校验命令 (方案菜单/CVS 子菜单)

这个命令用到运行 CVS 校验对话框。用户可以创建/修改 CVS 帐号，并通过 CVS 检验对话框检验选项。

你可以从帐号下拉框中选择你想要的帐号。如果 CVS 帐号不存在，按下修改按钮将运行 CVS 管理器对话框 ，在那里用户可以添加/删除帐号。

模块下拉框列出在 CVS 库中的顶层目录。如果 CVS 服务器支持更新功能，按下更新按钮将更新 CVS 中的模块列表。模块将被创建为本地根目录的子目录。

本地根目录用于指定在通过 CVS 文档检验后将要写入的本地目录的路径。“...”按钮用于浏览你想要的首选目录。

校验选项

如果选中用模块名校验文件夹选项，那么模块名将是本地根路径对象定义的本地副本目录写入校验的文件的文件夹名字。如果没有选中这个选项，文件夹对象被激活，并在这里定义要使用的名字。

如果选中了校验默认主分枝，大多数当前指定模块的修订将被作为打开所希望文件的开始点。如果未选中这个选项，分枝/标签对象将被激活，在这里指定你希望打开的分枝。

添加文件到

这些设置只直接关系到 UEStudio 方案，不直接涉及到 CVS。如果选中了新建方案，那么通过这个对话框校验的文件将被添加到一个新的方案中。当按下校验按钮时，将运行 方案设置 对话框，可以在这里定义新的方案参数。如果选中了当前方案，那么指定的文件将被添加到活动方案中。

按下校验按钮将找回指定分枝下的文件。当指定的文件被找回后，每个目录中应该包含一个 CVS 子目录，用来贮存与活动目录中的文件相关的 CVS 信息。信息中包含活动目录中的文件、变量和标签列表。

* 请注意: 这个功能只被 UEStudio 支持，UltraEdit-32 不支持该功能。


更新命令

更新命令 (方案菜单/CVS 子菜单)

方案菜单中的 CVS 子菜单中有两个更新命令。列出的第一个更新命令只在载入 CVS 方案后激活 (如果选择了 CVS 支持选项，并在 方案设置对话框 中指定了一个有效的 CVS 模块，那么该方案被视为 CVS 方案)。如果载入了一个 CVS 方案，并选择了这个选项，那么在没有任何提示情况下执行更新命令，或将它视为使用 CVS 方案指定选项的选项。

如果选择了 CVS 子菜单中的第二个更新选项，那么将打开 CVS 更新对话框。这可以用于更新指定 CVS 模块或文件的参数。

你想使用的帐号可以从帐号下拉框中选择。如果不存在 CVS 帐号，按下修改按钮将运行 CVS 管理器对话框 ，在那里用户可以添加/删除帐号。

模块/文件对象可以用于指定将从 CVS 中更新的模块或文件。你可按“...”按钮浏览选择一个现有的模块或文件。

如果选择了默认的使用最新修订更新，将从 CVS 中接收最近修改。如果未选择这个选面，那么下面的修订选项变成激活状态。

修订选项

按日期接收修订表示在不迟于在合并到对象中指定的日期内接收最新修订。

按修订/标签接收修订表示按合并到对象中指定的修订/标签/分枝接收修订。这个选项将一直保持活动，除非使用了重置粘滞选项覆盖或重置。

合并修订用来启用合并单个修订到当前工作目录，或合并两个各自的修订到当前工作目录。如果选择了从默认原始版本合并，那么在合并到对象中指定的修订与当前工作目录合并。如果未选中在合并从对象中指定的修订，那么将与合并到对象中指定的修订合并。

更新选项

覆盖本地版本将用当前最新的 CVS 修订版本覆盖任何本地修改的文件，并用前缀 .# 创建修改后文件的备份。

重置粘滞选项用来从工作副本保留的 CVS 信息中删除任何标签、修订或日期信息。

删除空文件夹用来删除 CVS 信息库中的空的工作副本中的目录。

创建丢失项目用来找回任何从工作副本中丢失的文件或目录。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。


提交命令

提交命令 (方案菜单/CVS 子菜单)

方案菜单中的 CVS 子菜单中有两个提交命令。如果载入 CVS，第一个提交命令将被激活。( 如果选择了 CVS 支持选项，并在 方案设置对话框 中指定了一个有效的 CVS 模块，则被视为一个方案)。如果载入了 CVS 方案，并且这个选项选定，将在没有任何提示的情况下执行提交，或使用 CVS 方案指定的选项进行。

如果在 CVS 子菜单中选择了第二个提交选项，那么将打开 CVS 提交对话框。在那里可以指定用于提交一个模块或文件到 CVS 的参数。

可以从帐号下拉框中选择你想用的帐号。如果 CVS 帐号不存在，按修改按钮将运行 CVS 管理器对话框 ，在那里用户可以添加/删除帐号。

模块/文件对象可以用于指定将要提交到 CVS 的模块或文件。你可以按“...”按钮浏览选择一个现有的模块或文件。

按默认，提交到 HEAD 选项，将提交指定的模块/文件到大多数 CVS 信息库的分枝。

强制新修订选项用来增加指定模块或文件的修订，即使没有发现任何更改。

强制递归选项只在强制新修订启用时才能使用，选中这个选项将递归增加所有模块和模块下面指定的文件的修订级别。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。


导入命令

导入命令 (方案菜单/CVS 子菜单)

CVS 子菜单中的导入命令会打开 CVS 导入对话框。这可以用于指定用于导入项目到 CVS 的参数。

可以从帐号下拉框中选择你想用的帐号。如果没有 CVS 帐号，按下修改按钮将运行 CVS 管理器对话框 ，在那里用户可以添加/删除帐号。

在导入到 CVS 到文件夹对象中指定路径下的所有文件和目录将被添加到模块名字对象中指定名字下的 CVS 信息库。

作者标签是初始分枝标签，用于标识导入后的模块。

发布标签允许从这里导入唯一的文件标识到 CVS 信息库，并用于以后的导入。

* 请注意: 这个功能只被 UEStudio 支持，UltraEdit-32 不支持这个功能。


导出命令

导出命令 (方案菜单/CVS 子菜单)

这个命令用来运行 CVS 导出对话框。用户可以创建/修改一个 CVS 帐号，并通过 CVS 导出对话框导出选项。

你可以从帐号下拉框中选择你想用的帐号。如果没有 CVS 帐号，按下修改按钮将打开 CVS 管理器对话框 ，在那里用户可以添加/删除帐号。

模块下拉框中列出 CVS 信息库中的顶层目录。按下更新按钮将更新 CVS 信息库中的模块列表。

本地根目录用于指定在通过 CVS 文档检验后将要写入的本地目录的路径。“...”按钮用于浏览你想要的首选目录。

导出选项

如果选中用模块名导出文件夹选项，那么模块名将是本地根路径对象定义的本地副本目录写入校验的文件的文件夹名字。如果没有选中这个选项，文件夹对象被激活，并在这里定义要使用的名字。

如果选择了导出默认主分枝，指定的模块顶层文件夹被用作为打开所希望的文件的起始点。如果未选择这个选项，分枝对象将被激活，在这里指定你想打开的分枝。

添加文件到

这些设置只直接关系到 UEStudio 方案，不直接涉及到 CVS。如果选中了新建方案，那么通过这个对话框校验的文件将被添加到一个新的方案中。当按下导出按钮时，将运行 方案设置 对话框，可以在这里定义新方案的参数。如果选中了当前方案，那么指定的文件将被添加到活动方案中。

按下导出按钮将打开指定分枝下的文件。

请注意: 校验 和导出之间的差异只是: 导出打开指定的不带任何 CVS 信息的文件。如果文件被导出，在导出的目录中不创建带文件名、修订和标签的 CVS 信息库。导出的文件不能更新、编译或用其它方式返回到 CVS 信息库中。

* 请注意: 这个功能只被 UEStudio 支持，UltraEdit-32 不支持该功能。


帐号/设置命令

帐号/设置命令 (方案菜单/CVS 子菜单)

CVS 管理对话框用于创建与 CVS 服务器进行校验的帐号，并设置为使用这些指定的帐号。

如果按下添加帐号按钮，将创建一个新的带下列设置的帐号:

设置项目 | 用法
帐号 | 用于帐号的名字
协议 | 可以是 pserver 或 ext 两者之一。pserver 是使用用户名/密码登录的标准的 CVS 通讯机制，它使用不加密的纯文本方法，不太可靠。ext 是运行一个外部的 SSH (安全外壳) 应用程序，在那里指定用户名和验证码。这个方法是加密的，每次调用时需要输入密码。
服务器 | IP 地址或完整的域名
端口 | 通常留空即可
信息库 | CVS 服务器中的 CVS 信息库路径
用户名 | 登录帐号的用户名。pserver 和 ext 登录时必须使用。
密码 | 密码 - 每次使用 ext 帐号是必须使用 (对于 pserver 帐号则贮存)

如果从 CVS 帐号列表中选择了一个帐号，并按下设为默认帐号按钮，那么指定的帐号将被设置为默认 CVS 帐号。

如果选择了 CVS 设置，那么将显示 CVS 设置面板。按默认，使用默认应用程序选项将被选定。如果这个选项未选定，用户必须指定或浏览你想用的用于 CVS、SSH 和日志编辑器的可执行文件。

默认校验根路径是 CVS 校验或导出的默认路径。这可以在各自的 CVS 命令对话框中覆盖。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持该功能。


Ctags 支持

UltraEdit 支持 Ctags，可作为方案的一部分，或者单独使用。

什么是 Ctags？

Ctags 用来生成一个在 C/C++ 文件头和源文件中发现的 C/C++ 对象和函数的标签文件 (或索引文件)，使这些项目可以在 UltraEdit 内部快速引用。

Ctags EXE

UltraEdit 依靠外部的 Ctag 文件生成器生成 Ctag。现在有许多 Ctags 的版本，我们推荐你使用“Exuberant Ctags”: http://ctags.sourceforge.net/ 。

UltraEdit 可以使用一个现有的标签文件，或者如果有可用的创建 Ctag 文件的 EXE 文件，也可以用它来创建标签文件。请使用来自 Exuberant Ctags 的 ctags.exe，并将这个 exe 放在包含 UltraEdit 的目录中，这样，UltraEdit 默认允许创建标签文件。

请注意: 由于许可限制，UltraEdit 安装后不包含 Ctags EXE 文件。

UltraEdit 内的 Ctags 配置

方案菜单可以用来让用户更改 Ctags 选项，并创建标签文件。Ctags 选项对话框中可以定义下面三个项目:

默认标签文件: 如果没有活动的指定方案标签文件 (在方案设置中定义)，这个选项用来指定要使用的标签文件。如果这不是用来让 UltraEdit 查找符号方案指定的标签文件，就会出现这个选项。

CTAG 可执行文件路径/名字: 这个选项用来指定从 UltraEdit 内部创建标签文件的 Ctag exe 文件的完整路径和名字。如果没有填写这个选项，UltraEdit 仍可以在标签文件中引用符号，但不能创建新的标签文件。这个选项的默认设置是包含 UltraEdit 目录中的“ctags.exe”。

CTAG 参数用来指定传递给 Ctag exe 进行正确函数操作的参数。默认设置是将“Exuberant Ctags”设为上述描述的参数。

当 ctag exe 要从中创建标签的文件列表文件的文件名/路径运行时，参数行中的 %fi 被替换为这个参数。如果方案已在 UltraEdit 中载入，UltraEdit 用方案文件列表创建一个临时文件，并用这个信息替换 %fi。

参数行中的 %fo 用被创建的标签文件的完整文件名/路径替换。这应该是方案中指定的标签文件，或上述定义的默认标签文件。

创建标签文件

标签文件可以直接从 方案菜单 中用创建 CTAG 文件命令来创建，或者，如果方案设置中指定了这个选项，那么打开该方案时可以自动创建标签文件。

查找符号/标签

使用 Ctags 的目的是可以快速查找在文件中其它地方或其它文件中定义的函数或对象。假如已经有了标签文件，从搜索菜单选择查找符号，将搜索标签文件中的符号，如果只找到一个匹配项目，该文件将在 UltraEdit 中打开，并定位到这个符号处。如果发现多个匹配的项目，将显示一个对话框，可以让用户来选择适当的标签文件。

* 请注意: UEStudio 不包含象上述描述的功能一样、可以在 UEStudio 内部进行处理的 Ctags 支持，它通过 文件树视图 中的标签来访问。


构建菜单

请注意:这个菜单和下面描述的选项只能在 UEStudio 中使用，下列信息不能用于 UltraEdit-32。

构建菜单包含可以用于调试、编译或运行活动方案或工作区中的文件的命令。在此之前大多数构建菜单中的选定是可用的。您必须在方案菜单中的 方案文件/设置对话框 中设置该方案为可编译，并选择一个方案中使用的编译器。

构建菜单包含下列命令:

编译 | 在活动文件中运行选定的编译器
构建 | 根据活动目标和和从属关系构建活动工作区中的所有文件
全部构建 | 在不涉及从属关系的情况下重建活动目标的所有文件
批量构建 | 根据目标和从属关系构建文件列表（EXE、DLL）
清除 | 删除中介文件和目标可执行文件
启动调试器 | 在活动文件中启动选定的调试器
调试 - 调试窗口 | 显示用于监控、调用堆栈、内存、分解、寄存器和变量的子菜单窗口。
调试 - 执行 | 自动启动调试器并运行应用程序
调试 - 重新启动 | 结束调试会话然后重新启动
调试 - 停止调试 | 结束调试会话
调试 - 中断 | 暂停目标执行并将控制权返回给调试器
调试 - 单步执行 | 一次执行一个语句，并跟随执行调用的函数
调试 - 逐过程 | 执行代码的下一行但不执行任何调用的函数
调试 - 跳出 | 在当前执行点所在的位置执行函数剩下的语句
调试 - 运行到光标位置 | 从当前语句恢复代码的执行到选中的语句
调试 - 设置断点 | 在当前光标位置添加断点
调试 - 删除断点 | 在当前光标位置删除断点
运行应用程序 | 运行选中的目标可执行程序
运行命令 | 弹出子菜单运行或调试选定目标，或显示 makefile
选择编译器 | 显示选择编译器对话框
设置编译器选项 | 显示编译器选项对话框
高级构建选项 | 显示高级构建选项对话框
设置编译器路径 | 显示编译器路径对话框
重新生成 Makefile | 基于当前配置选项重新创建编译进程的控件文件
显示标签列表 | 为活动方案打开标签列表文件

* 请注意：这些功能仅在 UEStudio 中支持，在 UltraEdit-32 中不支持。


构建命令

构建命令 (构建菜单)

这个使用用来保存活动文档 (如果需要)，然后编译它。如果未选择编译器，或对于方案的编译器选项未设置，将显示 选择编译器对话框 ，然后显示 方案设置对话框 ，最后启动编译进程。


构建命令

构建命令 (构建菜单)

这个命令用来保存活动文档 (如果需要)，并构建方案目标。如果未选择编译器，或者方案的编译器选项未设置，将会显示 选择编译器对话框 ，然后显示 方案设置对话框 ，最后启动构建进程。


全部重建命令

全部重建命令 (构建菜单)

这个命令会删除所有编译器创建的文件，然后构建方案。


批量构建命令

批量构建命令 (构建菜单)

这个命令根据目标和从属关系构建可执行文件列表 (EXE、DLL)。


清除命令

清除命令 (构建菜单)

这个命令用来清除活动方案的中介文件和目标可执行文件。


启动调试器命令

启动调试器命令（构建菜单）

该命令在活动文件上启动已选的调试器。如果未设置调试器，将显示一个对话框，可以在其中选择调试器用于活动方案。

大多数情况下适合使用调试器，因此指定多数编译器与相关的调试器捆绑发货，并且 调试器 键将在 编译器选项 里（ 链接器选项下）显示它（例如：对于 Visual Studio，调试器设置为“msdev”）。

双击调试器键将显示一个对话框，供用户按需要指定使用不同的调试器。

用户可以在“工具”工具栏里点击调试按钮来调用调试器。

UEStudio 将检查是否已设置调试器。 如果未在编译器选项里设置，UEStudio 将显示浏览对话框以便选择调试器。 如果已设置调试器，UEStudio 将提示该调试器是否可以设置为未来方案的默认调试器。 如果选择“是”，则选定的调试器将保存在编译器配置文件里，以便在选定新方案时记住它，且不限于活动的方案。

如果在“选择编译器”对话框里按下“编辑配置”按钮，则编译器配置文件将在此显示，且非常熟悉其编译器/调试器的高级用户可以按需要直接编辑该文件。

例如，用户可以设置依存关系，并确定该调试器将作为控制台调试器（gdb）来运行还是作为窗口调试器（WinDbg）运行。

在配置文件中，用户可以选择调试键并修改 [Start Debugger] 区段。 例如：如果默认值设置为窗口调试器而您希望使用控制台调试器，则可以在该区段里改变/添加键“DisplayConsole=1”。

如果在“选择编译器”对话框里按下使配置成为本地按钮，则编译器配置文件将保存到方案目录，且按下它之后的更改都将与该方案一同保存到本地。

一旦选择了调试器，用户可以从“工具”工具栏里的“命令”子菜单调用该调试器：


运行应用程序命令

运行应用程序命令 (构建菜单)

这个命令用来运行用选定编译器创建的应用程序，如果应用程序还不存在，则调用构建进程。


运行命令

运行命令 (构建菜单)

这个命令会显示一个弹出菜单，菜单中的项目数量根据使用的编译器设置和这个 编译器配置 设置的命令确定，是可变的。


选择编译器命令

选择编译器命令 (构建菜单)

这个命令会打开 选择编译器对话框 ，在那里你可以选择活动方案要使用的编译器。


设置编译器选项命令

设置编译器选项命令 (构建菜单)

这个命令会弹出 编译器选项对话框 ，在那里有选择用于选定活动方案的编译器的配置选项。


高级构建命令

高级构建命令 (构建菜单)

这个命令会打开高级构建选项对话框。这些选项可以让用户更好地控制构建进程。

高级构建选项对话框有下列选项:

选项 | 用法
从工具抓取标准输出 | 大多数编译器只在这里写入信息，但推荐选中这个选项。如果未选中，不会出现来自编译器的分配到 STDOUT 的消息，并且将显示构建工具。
从工具抓取标准错误 | 如上，但对于 STDERR。编译器在这里写入警告和错误。
当执行时显示构建命令 | 按默认，这个选项未选中。如果你想显示当你点击构建、重建等命令时使用了哪些命令，应该选中这个选项。
创建构建日志文件 | 如果选中这个选项，当执行编译、构建、重建和其它命令时，将创建带命令的 HTML 文件。
在隐藏模式运行命令 | 按默认，所有的编译器和其它构建工具在隐藏模式下执行，并且它们的输出会被抓取。如果不选中这个选项，就不会出现这种情况了。
自动显示输出窗口 | 如果你想查看当构建命令执行时来自 STDOUT 或 STDERR 的输出，应该选中这个选项。
自动滚动输出窗口 | 按默认，当 UEStudio 往输出窗口写入时，它总是将活动行位置设置到写入的该行，但在一些配置中，可能会减慢构建进程。
简易捕获方法 (对于老的 DOS 编译器) | 这个选项用来启用一个预选方法从编译器捕获输出。但有可能在用 UEStudio 运行你的编译器或工具时“挂起”，你只能在这种情况下可以选中这个选项。
在 # 错误模块后停止构建 | 当编译器写错误/警告信息输出到窗口，UEStudio 监视到这些信息。假如错误的数量超过了指定的极限, 在当前的编译器完成被超出极限后，构建进程将被停止。
优先权 | 当构建一个大的方案时，但不能接受构建进程显示在其它进程之下，优先权应该设置为 IDLE。如果需要，你可以选择较高的优先权。
包括文件扫描深度(嵌入级) | 当源文件被编译后, UEStudio扫描文件记录检查附件。当搜索的时候，这价值指定搜索应该递归多少级。 请注意:越高级将需要扫瞄的时间越长。


设置编译器路径命令

设置编译器路径命令 (构建菜单)

这个命令会打开设置编译器路径对话框，可用来指定大多数各种编译器的路径。

可以在编译器名字右边的文本对象中直接输入你想用的编译器的路径，或按“...”按钮浏览你想使用的编译器可执行文件。


解法菜单

请注意: 下面描述的菜单和选项只能用于 UEStudio，下面的信息不能用于 UltraEdit-32。

什么是解法？

UEStudio 支持两种不同类型的容器 (解法和方案) 来帮助管理开发资源。解法和方案包含创建你的应用程序所需的项目。

解法是为管理相关已配置、构建和开发方案的方法集设计的。根据你的需求，UEStudio 中的解法可以只包含一个方案，或几个被一个开发团队联合构建的方案。复杂的应用程序可能需要多个解法。

一个解法容器可以包含多个方案，一个方案一般包含多个项目。使用这些容器，你可以利用综合开发环境。

解法菜单

解法菜单包含下列命令:

* 新建解法 | 打开创建一个新的解法 (.prw) 的对话框
* 打开解法 | 弹出一个选择要打开的现有的解法对话框
* 关闭解法 | 关闭当前活动解法
* 添加方案 | 打开一个对话框，允许用户浏览方案并将它添加到活动解法中
* 删除方案 | 从活动的解法中删除当前方案

* 请注意: 这些功能只在 UEStudio 中支持UltraEdit-32 不支持这些功能。


新建解法命令

新建解法命令 (解法菜单)

这个命令会打开另存为对话框，在那里用户可以在与之关联的多个方案文件 (.prj) 中定义新的解法文件 (.prw)。

* 请注意: 这个功能只在 UEStudio 支持，UltraEdit-32 不支持该功能。


打开解法命令

打开解法命令 (解法菜单)

这个命令会弹出一个打开对话框，在那里用户可以选择一个要打开的解法文件 (.prw)。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。


关闭解法命令

关闭解法命令 (解法菜单)

这个命令用来关闭活动解法。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持该功能。


添加方案命令

添加方案命令 (解法菜单)

这个命令会弹出一个打开对话框，在那里用户可以选择要在活动解法中打开的方案文件 (.prj)。

如果在解法中打开了一个方案，这个方案是解法 (基于 ini) 文件的活动集，因此，下一次打开解法时，这个方案也将被打开。

* 请注意: 这些功能只在 UEStudio 中支持，UltraEdit-32 不支持这些功能。


删除方案命令

删除方案命令 (解法菜单)

这个命令会打开解法中方案对话框。

当在这个对话框中按下删除方案按钮时，选定的方案 (.prj) 将从活动解法 (.prw) 中删除。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。


视图菜单

视图菜单包含下列命令：

环境 | 显示环境选择器对话框，用户可以指定活动环境（菜单/工具栏/停靠窗口）
视图/列表 - 工具栏 | 显示或隐藏工具栏
视图/列表 - 状态栏 | 显示或隐藏状态栏
视图/列表 - 打开文件标签 | 显示或隐藏打开文件标签
视图/列表 - 文件树视图 | 显示或隐藏文件树视图
视图/列表 - ASCII 表 | 显示或隐藏可停靠的 ASCII 表
视图/列表 - 函数列表 | 显示或隐藏函数列表
视图/列表 - 宏列表 | 显示或隐藏所有当前加载宏的列表
视图/列表 - 标签列表 | 显示或隐藏标签列表
视图/列表 - 模板列表 | 显示或隐藏模板列表
视图/列表 - 剪贴板历史 | 显示或隐藏剪贴板历史列表。
视图/列表/ - 脚本列表 | 显示或隐藏所有当前指定脚本的列表
视图/列表 - 书签视图 | 显示或隐藏书签视图
视图/列表 - 输出窗口 | 显示或隐藏输出窗口
视图/列表 - SSH/Telnet 控制台 | 显示或隐藏 SSH/Telnet 控制台。 可以使用 SSH/Telnet 帐户管理器指定 SSH/Telent 会话的设置
视图/列表 - 禁用工作区关闭按钮 | 切换外围窗口（文件树视图、函数列表、宏列表、标签列表、模板列表和输出窗口）关闭按钮的状态
查看方式 (加亮文件类型) | 用选定的语法加亮显示文件
设置代码页 | 显示“代码页选择”对话框，允许更改活动文档的代码页
设置十六进制/列模式字体 | 选择用于十六进制和列模式的屏幕显示字体
设置字体 | 选择要使用的屏幕字体
设置打印机字体 | 选择要使用的打印机字体
OEM 字体集 | 强制将字体设为 OEM 字符集
镜像显示字体 | 将显示的字体作为打印机字体
重置字体（默认） | 重置屏幕和打印机字体到默认设置
增大字体 | 增大字体（放大）
缩小字体 | 缩小字体（缩小）
设置颜色 | 设置屏幕颜色用于编辑窗口项目
显示空格/制表符 | 显示空格和制表符为可见的字符
显示行终止符 | 显示换行符为可见的字符
显示分页符为线条 | 显示分页符为线条
设置/显示列标记 | 设置列标记
不滚动标记 1 以左部分 | 切换第一个列标记左边的固定面板/列
显示标尺 | 切换每个窗口顶部的列标尺指示器
显示行号 | 切换每个窗口左边的行号显示
行间距 - 单倍间距 | 用单倍间距显示文档
行间距 - 1.5 倍间距 | 用 1.5 倍间距显示文档
行间距 - 双倍间距 | 用双倍间距显示文档
ASCII 字符表 | 显示 ASCII 字符表
隐藏/显示行 - 隐藏/显示选区 | 隐藏或显示选定的行
隐藏/显示行 - 全部折叠 | 折叠所有原先活动文件中展开的函数或结构
隐藏/显示行 - 全部展开 | 展开所有活动文件中原先折叠的区段
文件更改轮询 | 在配置中定义的时间间隔（秒）内检查活动文件是否被更改
自动滚动轮询的文件 | 当发现文件被更改时滚动到被检测文件的最后一行 （类似于 UNIX 的 tail 命令）
总在最前 | 切换是否将 UltraEdit 显示在其它所有的应用程序前面
全屏模式 | 切换全屏编辑模式
切换浏览器视图 | 将活动文件的视图由 HTML 内容切换到浏览器视图（中断使用 IE 集成）
刷新浏览器视图 | 刷新活动文件的浏览器视图


环境选择器

环境（视图菜单）

该命令显示环境选择器对话框，用户可从中指定活动编辑环境。

环境选择器对话框允许用户选择预定义的编辑环境。 环境包括特定菜单、工具栏和可停靠窗口，以及所选环境的定制模板。 这大大节省了时间，因为用户可以在所有这些项目的不同显示选项间即时切换，而不必分别配置每个项目。

当第一次显示环境选择器时，可在左窗格中选择活动环境，其环境描述和核心特性组显示在右边。

切换环境

通过从列表中选择新环境并按下确定按钮，可以更改活动环境。 当这样操作时，会出现提示框请用户确认他想更改环境。

如果选择是，活动环境将被更改为环境选择器对话框中所选的环境。 如果按下取消，则不作任何更改。 如果选择保存并继续，则将保存用户对当前环境所作的任何更改，同时提示用户命名新建环境，并随意地为该环境输入定义和核心特性组。

定制环境

需要时可定制默认环境。 当环境活动时，用户可以分别定制环境项目。 菜单和工具栏可通过右键单击菜单标题（文件、编辑等）或工具栏，并分别选择定制菜单或定制工具栏进行定制。 可按需打开并放置可停靠窗口以满足用户需求。

一旦定制了活动窗口，应该通过选择视图菜单中的环境选择器对话框或按下 ALT+F8 来调用环境选择器对话框。 然后用户可以在选择列表顶端的文本框中编辑活动环境的名称，并按下保存当前状态为按钮以保存活动环境的定制版本。

或者，用户可以简单的修改环境元素并从环境选择器中选择切换到的环境。 “更改环境吗？”对话框将出现，用户可以选择保存并继续选项。

这将在环境选择器 - 保存对话框中填入活动环境的描述和特性组，并允许用户以其他名称保存修改后的环境，或在需要时覆盖现有环境。

通过在选择列表中选中环境并按下删除选中的环境按钮可以删除任何定义的环境。

如果按下重置内建环境按钮，所有内建环境将还原为其默认状态。 请注意：除了默认环境以外，所有创建的客户环境将以其当前状态保存。

导出/导入环境

如果用户希望导出其创建的环境以便与朋友或同事共享，可以按下导出/导入环境按钮。 将出现包含两个选项的弹出菜单供用户选择：导出所选环境或导入环境。

如果用户选择导出所选环境按钮，将出现浏览文件夹对话框，用户可以从中选择环境文件导出到的目标文件夹或新建目标文件夹。 所选环境将被创建为一个文件，其名称为该环境的名称，且扩展名为 "uee" 。 例如，Power User 环境将被导出为 "Power User.uee" 。

如果按下导入环境按钮，将显示打开对话框以便用户导航到导入期望环境所需的 *.uee 文件。 导入文件中的设置将被自动解析，随后该环境就出现在环境选择器对话框中供选择。


工具栏命令

工具栏命令 (视图菜单/ 视图/列表子菜单)

这个命令用来显示或隐藏包含大多数 UltraEdit 公共命令按钮的工具栏，比如打开文件。当工具栏显示时，在菜单项目旁边会出现一个选中标记。

查阅 配置工具栏 获取修改工具栏的帮助。


状态栏命令

状态栏命令 (视图菜单/ 视图/列表子菜单)

用这个命令可以显示或隐藏状态栏，状态栏可以显示选定菜单项目或按下工具栏按钮执行的动作描述，以及键盘上各个开关的状态。当状态栏标记为显示状态时，菜单项目旁边会出现一个选择菜单项目或按下工具栏按钮所执行动作的描述，以及键盘的开关状态。当状态栏处于显示状态时会在菜单项目旁边出现一个选中标记。

查阅 状态栏 获取使用状态栏的帮助。


打开文件标签命令

打开文件标签命令 (视图菜单/ 视图/列表子菜单)

这个菜单项目用来启用或禁用允许让用户选择打开的文档标签控件。标签控件可以用来非常方便地在打开文档中间选择文件，并保持所有其它窗口的切换和显示功能。

如果你右键点击打开文件标签，将显示一个含有几个文件选项的弹出菜单。

该标签控制可以从它默认的主窗口顶部停驻位置拖放到窗口的底部，或独立于左边。 如果它是独立的窗口，它可以在垂直和水平方向任意调整大小。

另外，可以拖放标签到新的位置。要拖放标签，用左键在你想移动的标签上点击，并按下鼠标按钮，将它移动你想插入的位置时松开鼠标键。拖放时标签总是被插入到你鼠标松开时所处标签的前面。如果你在一个现有的标签之上松开鼠标，将只移动该标签。 如果选中配置 - 应用程序布局中的新文件标签样式选项，则单个标签不会被拖到新的位置。

当标签控件在默认的停驻位置时，如果打开许多文件，标签控件不能显示所有的文件标签时，将出现滚动箭头。

标签控件的大小可以调整。如果在停驻时调整大小，那么将显示多行文件标签，同时滚动箭头将不再显示。

右键点击打开文件标签可以进行文件标签排序。当执行这个命令时，打开文件标签将按字母顺序排序。由于使用了承载控件操作，如果以多行方式显示，承载控件将重新排序标签行，但内部仍保留相同顺序。这表示可以进行排序，但该行可能未被排序，如果从其它行选定，将被更改顺序。

双击文件标签中打开的项目将关闭该文档。

如果光标悬浮在文件标签上面，将显示一个工具提示，显示有关文件的完整路径。

锁定文件标签

在 UltraEdit 中在空白处单击右键打开文件标签将显示无法停靠的提示。 如果选中该项，打开文件标签将从默认停驻的位置被拉到浮动对话框。 双击该对话框的标题栏将使文件标签返回其默认停驻的位置。 如果未选中不可停驻，则文件标签将被“锁定”且无法从其默认停驻的位置移除。


文件树视图命令

文件树视图命令 (视图菜单/ 视图/列表子菜单)

这个菜单项目用来启用或禁用文件树视图。

文件树视图是用一个树形格式显示选定驱动器的文件或目录列表。驱动器/文件列表用来显示可用的驱动器，并允许选择显示的所有打开的文件或当前方案中的文件。

双击树形视图中的任何一个文件，将打开或激活该文件。可以一次选择并打开多个文件。(要选择多个文件，用鼠标左键和 shift 键选择两个文件之间的文件，或用 Ctrl 键和鼠标左键选择非邻近的文件)。

过滤条目框允许用户在查看某个驱动器时，指定应用到显示文件中的文件过滤。对于已显示的方案或已打开文件，不会应用过滤。

右键点击适当文件时，还有几个功能可用。这些功能根据显示的列表会作调整。

打开文件

如果文件列表显示的是当前打开的文件，那么在点击鼠标右键时，显示下列可用的功能:

关闭 | 关闭一个打开的文件
保存 | 用相同的文件名保存打开的文档
打印 | 打印一个文档
水平平铺 | 用非交迭水平平铺方式排列窗口
垂直平铺 | 用非交迭垂直平铺方式排列窗口
只显示名字 | 只显示文件名 (没有路径)
允许停驻 | 允许文件树视图停驻，不使用“浮动”视图
隐藏文件列表 | 隐藏文件树视图
设为文件夹活动路径 | 设置文件树视图为活动文件文件夹

上述所有功能均作用于所有选定的文件。

方案文件/驱动器

如果文件列表中显示的是资源管理器，那么在点击鼠标右键时，显示下列可用的功能:

打开选定的文件 - 将在编辑器中打开选定的文件。

属性 - 显示选定的第一个项目的文件属性。

公共

在任何时候右键点击树形视图，将提供隐藏视图、或禁用停驻的选项。如果视图未停驻，它将与其它窗口一样，用一个独立窗口显示。


函数列表命令

函数列表命令 (视图菜单/ 视图/列表子菜单)

这个命令用来切换函数列表的可见/不可见状态。这个函数与 函数列表命令 (在搜索菜单) 不同，这是根据定义在词语文件中的函数字串加载函数列表 (查阅 语法加亮 获取更多信息)。


宏列表命令

宏列表命令 (视图菜单/ 视图/列表子菜单)

该命令可以切换宏列表的显示和隐藏。 宏列表显示当前所有已加载的宏。 可以从宏菜单加载宏。 双击任何列出的宏将启动宏，与宏菜单中的再次运行命令类似。 在宏列表中单击右键将显示上下文菜单，其中有一则选项为修改宏。 如果选中该选项，将显示编辑/创建宏对话框。


标签列表命令

标签列表命令 (视图菜单/ 视图/列表子菜单)

这个命令用来弹出一个显示预定义“tags”列表的对话框。标签是一个简单的短字符，这个功能一般用于“HTML 标签”。

使用标签列表的目的是提供一种不需要进行输入、用使用的标签/字符插入到文档的简单方法。

右键点击上下文菜单中的 修改命令 允许修改标签列表。 标签由起始标签和结束标签组成。

要插入一个标签，选择你想插入的标签，并双击该标签或按回车键。当该标签插入到活动文档后，起始标签 (如果已定义) 插入在所有选定文本的开头，结束标签 (如果已定义) 则插入到当前选定的末端。 如果没有选区，标签将插入到当前光标位置。

双击标签中的某个标签，UltraEdit 将插入该标签，并且焦点更改到文件中。如果按回车键，焦点仍在标签列表上，UltraEdit 将插入标签，焦点仍保留在标签列表上。CTRL+Enter 也可以插入标签，且焦点将更改到文件上。

可以定义多组标签，并且可以从下拉列表中选择组。

添加新标签

标签的默认文件为安装目录下的 taglist.txt 文件。提供给用户的其他标签列表位于 http://www.ultraedit.com/index.php?name=Content&pa=showpage&pid=40#taglists。 如果用户导航到该页面并选择要添加的标签列表（如 ASP 标签），可以将其保存到本地系统中。

完整标签列表应该粘贴到 taglist.txt 文件中，靠近结尾处的“Group List”部分上面。必须将相同的标题添加到 [Group List]。例如，ASP 标签列表标题为：

[Tag Group - ASP - Active Server Pages]

原来的 [Group List] 应从：

[Group List]
0=COLD FUSION - Tags
1=HTML - Special Characters
2=HTML - Tags
3=UE/UES Macro Commands
4=UE/UES Script Commands
5=

更改为：

[Group List]
0=COLD FUSION - Tags
1=HTML - Special Characters
2=HTML - Tags
3=UE/UES Macro Commands
4=UE/UES Script Commands
5=ASP - Active Server Pages
6=

when adding ASP tags. 群组列表和标签列表结尾的空行非常重要，不得遗忘。


模板列表命令

模板列表命令（视图菜单/ 视图/列表子菜单）

该命令可以切换模板列表的显示和隐藏。 模板列表显示在高级菜单的显示/修改模板中显示的所有模板。 双击任何列出的模板则将该模板插入活动文档的当前光标位置。 右键单击模板并从上下文菜单中选择插入模板将插入选中的模板。 右键单击模板名称并选择修改模板，显示定义模板对话框，在此用户可以定义为指定模板插入的文本。

用户可以选择是否使用全局模板，或针对活动环境的专用模板。 右键单击模板列表，然后选择全局模板，列表中将导入定义为全局使用的模板。 如果使用全局模板，上下文菜单中将显示一个选项，用于选择针对活动环境的模板。 例如，在编程器环境中，将有编程器模板选项可供使用。


剪贴板历史记录命令

剪贴板历史记录命令（视图菜单/视图/列表子菜单）

该命令可以切换剪贴板历史记录的显示和隐藏。 剪贴板历史记录显示历史记录列表活动时复制到剪贴板的文本列表。 双击任何列出的项目则将其插入活动的文档中。

在剪贴板历史记录中单击右键显示上下文菜单，用户如果需要可以选择清除剪贴板历史记录。 选择上下文菜单中的选项将显示剪贴板历史记录选项对话框。

剪贴板历史记录选项对话框用来指定为所有剪贴板项目在剪贴板历史记录中显示的内容。

右键单击历史记录条目并从上下文菜单中选择删除历史记录条目将删除选中的项目。


脚本列表命令

脚本列表命令（视图菜单/ 视图/列表子菜单）

该命令可以切换脚本列表的显示和隐藏。 脚本列表显示当前所有已加载的脚本。 邮件单击脚本列表显示的向下文菜单中包含以下选项：

运行 | 运行选中的脚本
添加脚本 | 显示“文件打开”对话框，在此用户可以指定要添加到列表中的脚本
编辑脚本 | 在编辑器窗口中打开选中的脚本
删除脚本 | 从列表中删除选中的脚本


Bookmark List command

Bookmark Viewer command (View menu/ Views/Lists submenu)

This command toggles the visibility of the Bookmark Viewer. The Bookmark Viewer displays all bookmarks currently specified for the active document. If no bookmarks are defined the list will display "No Bookmarks!". Right-clicking in the Bookmark Viewer presents the context menu which includes the following options:

Columns | presents submenu allowing user to select items visible in list
Columns -> Column Order | presents dialog allowing user to change the order of items visible in list
List Bookmarks for all Files | displays list of bookmarks in all open files. If this option is selected, the name of the file the bookmark exists in will also be displayed.
Delete Bookmarks | deletes currently selected bookmark
Edit Bookmark | opens Edit Bookmark dialog where name of bookmark may be edited

If desired, the bookmark name may be modified using the Edit Bookmark command. If focus is moved to a bookmarked line, that line will automatically be highlighted in the Bookmark Viewer.


输出窗口命令

输出窗口命令 (视图菜单)

这个菜单项目用来启用或禁用输出窗口。输出窗口是用于捕获用户工具的输出 (查阅工具配置) 或来自 在文件中查找 的输出。

当来自工具 (不是 在文件中查找 ) 的行添加到输出窗口，该列表将自动向下滚动，使用户能够不用手动滚动就可以查看输出结果的最后部分。

在包含文件名和行号的行中双击，将会使 UltraEdit 去尝试打开指定的文件，并定位到该行。如果文件名带完整路径，该文件名将被定位，它后面的数字将被用于行号。如果该文件名不带完整路径，UltraEdit 将尝试用包含句点的行中的第一个词语来确定文件名。UltraEdit 将打开活动文件目录中的指定的文件。如果活动文件目录中该文件不存在，如果指定了 方案目录 ，那么 UltraEdit 将在该方案目录中尝试并打开文件。

在结果中的某一行双击，UltraEdit 将在文件中定位到该行，并强制激活该文件。如果在输出窗口聚集时按下 Enter 键，UltraEdit 将定位到该行，焦点保持在输出窗口。按 CTRL+Enter 也用来定位到文件中的该行，焦点将改变到文件中。


查看方式命令

查看方式 (加亮文件类型) 命令 (视图菜单)

这个命令允许用户不考虑 UltraEdit 根据文件扩展名确定的 语法加亮 方式，自定义以某种语言的语法加亮方式查看文件。

这个菜单项目可以选择任何在 语法加亮 内部可用的语言方式进行加亮，或不选择加亮。

如果用户不考虑语法加亮，该选项一直有效，除非文件被关闭，或用新名字保存。


设置十六进制/列模式字体

设置十六进制/列模式字体 (视图菜单)

设置十六进制/列模式字体菜单项目会打开 选择字体对话框 ，在那里可以选择各种字体和字体大小。选择的字体和字体大小将应用到 十六进制模式 或列模式的编辑视图中。当选择十六进制或列模式时，UltraEdit 将自动切换到该字体。

对于普通的字体选择，请使用 设置字体 (在 视图菜单 ) 命令。


设置字体命令

设置字体命令 (视图菜单)

设置字体菜单项目会打开 选择字体对话框 ，在那里允许选择各种字体和字体大小。选择的字体和大小将应用到屏幕字体中，如果选中视图菜单中 镜像显示字体 菜单项目，该字体还将应用于打印机字体。如果该项目未选中，可以单独选择打印机字体。

选择的字体可以通过选择 重置字体 菜单项目重置到默认值。

注意: 如果打印机不支持该字体，将自动调整到最接近的字体。


设置打印机字体命令

设置打印机字体命令 (视图菜单)

设置打印机字体菜单项目会打开 选择字体对话框 ，在那里允许选择用于打印机的各种字体和字体大小。选择的字体和大小将只应用到打印机字体。只有不选中 镜像显示字体 (在 视图菜单 ) 菜单项目才能使选择的打印机字体应用到打印机。

选择的字体可以通过选择 重置字体 菜单项目重置到默认值。


OEM 字符集命令

OEM 字符集命令 (视图菜单)

这个设置用来强制将所有的字体用 OEM 字符集显示 upper ASCII 字符 (假如字体支持的话)。可以正确显示用 ASCII 字符集 (不是用 ANSI (Windows) 字符集) 的带 upper ASCII 字符的 DOS 文件。


镜像显示字体命令

镜像显示字体命令 (视图菜单)

镜像显示字体菜单项目用来指示 UltraEdit 在打印机中使用屏幕中选定的字体。不考虑任何在 设置打印机字体 菜单项目中已经选择的字体。


重置字体命令

重置字体命令 (视图菜单)

重置字体菜单项目用来告诉 UltraEdit 重置用户选择的屏幕和打印机字体到默认设置。所有用户 设置字体 菜单项目中选择的屏幕字体和在 设置打印机字体 菜单项目中选择的打印机字体将丢失。


增大字体命令

增大字体命令 (视图菜单)

这些项目用来让用户放大和缩小文档中的字体，字体大小每次按 1 Pt 增大或缩小。这些设置更改后保持在所有文档中。


缩小字体命令

缩小字体命令 (视图菜单)

这些项目用来让用户放大和缩小文档中的字体，字体大小每次按 1 Pt 增大或缩小。这些设置更改后保持在所有文档中。


设置颜色命令

设置颜色命令（视图菜单）

该菜单项显示“设置颜色”对话框，在此用户可以配置编辑器中各种项目的颜色：

括号加亮（用于自动括号匹配的颜色）

折叠背景（用于折叠装订线背景）

点击颜色块，可以从颜色对话框选择新的颜色。对于背景颜色和书签颜色，只能选用纯色。

背景和书签颜色应用于所有文件。文本颜色用于所有未被语法加亮验证的文件。


显示空格/制表符命令

显示空格/制表符命令 (视图菜单)

这个菜单项目允许用屏幕中可见的字符显示空格、制表符和换行符。它不更改文件，但可以让你很清楚地看到它们之间的差别。

空格显示为: “·”

制表符显示为: “»”

换行符显示为: “¶”

如果没有足够的空间显示制表符“»”，制表符会象普通一样不可见。


用一行显示分页符命令

用一行显示分页符命令 (视图菜单)

这个命令用来告诉 UltraEdit 用交叉屏幕的一行来显示分页符 (在 页面设置 中定义)。这个动作不会修改文件的行号。行号只是根据行终止符来确定。

如果选中这个设置，UltraEdit 会立即在当前行下面绘制一条交叉屏幕的水平直线。所有跟随在分页符后面的文本将从跟随分页符后面的行起始处开始显示。

如果未选中这个选项，分页符将被用其它任何字符打印，文本将在些之前直接显示，下面的字符根据其出现位置进行打印。


设置列标记命令

设置/显示列标记命令 (视图菜单)

这个菜单项目会打开一个对话框，在此允许用户指定显示标记的列号。 可以配置并显示 12 个标记。列标记是用来标识屏幕中列的位置的垂直细线。如果在列 80 指定一个列标记，该标记被放置在第 80 列和第 81 列之间。

列标记可以通过使用每个标记说明旁边的复选框单独启用或禁用。


不滚动标记 1 以左部分命令

不滚动标记 1 以左部分命令 (视图菜单)

UltraEdit 提供 列标记 功能，即在指定列位置显示一条竖线。

这个菜单项目与列标记组合才能工作。当选中 (启用) 这个项目，第一个列标记左边的列被固定，当使用水平滚动条或将鼠标定位到窗口右边强制水平滚动视图时，它不参与滚动，但列标记右边的列将按常规方法进行水平滚动。

如果启用这个功能，标记右边的列将参与水平滚动，但左的列则不参于滚动。在水平滚动生效后，任何用鼠标选择文本的动作或在固定部分点击鼠标主键，会使水平滚动位置被重置，允许你查看或编辑连续的列。

如果第一个列标记被禁用或设为 0，这个功能无效。


显示标尺命令

显示标尺命令 (视图菜单)

这个菜单项目用来切换每个窗口顶部显示的列号标尺。

标尺包含按一定增量增加的列号。对于固定宽度字体，这将显示正确的列标识。对于可变宽度字体，这将根据活动字体的平均字符宽度显示列号。

标尺的颜色可以在 设置颜色对话框 中进行设置。


显示行号命令

显示行号命令 (视图菜单)

这个菜单项目用来切换窗口左边的行号显示。

如果选中这个选项，那么会在窗口的左边的一个固定区域中显示行号。使用的字体根据当前字体自动选择，比用来显示的字体稍微小一些。

行号的颜色可以在设置颜色对话框中进行设置。

要打印带行号的文件，请在 页面设置对话框 (在 文件菜单 ) 下进行适当设置。


行间距命令

行间距命令 (视图菜单)

这些项目提供单倍、1.5 位和双倍间距。允许在文档中的每行文本之间添加另外的间距进行查看和打印。

如果选择了单倍间距，每行以普通字符高度和行间距显示和打印。

如果选择了 1.5 倍间距，每行以 1.5 倍普通字符高度行间距显示和打印。实际字符是普通高度，但分配的行间距增加，另外添加了行之间手写注释的空间。

如果选择了双倍间距，每行以双倍普通字符高度行间距显示和打印。实际字符是普通高度，但分配的行间距增加，另外添加了行之间手写注释的空间。


ASCII 字符表命令

ASCII 字符表命令 (视图菜单)

这个命令会打开一个包含 ASCII 字符表的对话框。

该字符表包含下列栏目:

字符

这个栏用来以选定字体显示字符。字符可以通过使用选择字体按钮进行更改。

十进制 #

这是字符的十进制值，范围从 0 到 255。

十六进制 #

这是字符的十六进制值，范围从 0 到 FF。

名字 #

这是字符已通过验证的名字，只对于前 32 个字符。

控制字符 #

这是字符所象征的通过验证的控制字符，只对于前 32 个字符。

要查看其它字体的字符，请使用选择字体按钮。ASCII 字符表启动时显示的是当前在编辑器中使用的字体。

如果你想在活动文档中插入一些字符，请先选中要插入的字符，并单击插入字符按钮，或在字符表中双击这个字符。


隐藏/显示选区命令

隐藏/显示选区命令 (视图菜单 / 隐藏/显示行子菜单)

这个功能允许用户选择一些行号，并隐藏它们，使它们在屏幕中不可见，如果这些行已经隐藏，则显示它们。

隐藏行

要隐藏行集，先选择你想隐藏的行，然后从菜单项目或用快捷键 (CTRL+ 数字键盘“-”) 调用这个功能。行隐藏后，在编辑窗口的左边的折叠区域中会显示一个“+”。在编辑没有语法加亮的文件时，必须选定高级菜单->配置->普通标签->显示段中的下列配置选项:

启用显示/隐藏行和代码折叠

启用非语法加亮文件的显示/隐藏行功能

一次可以隐藏多个段。文件中所作的更改将更新隐藏区域，大多数情况下这种隐藏行仍将维持原状。在少数场合中 (比如文件排序) 可能会有问题，隐藏的行可能会出现偏移，需要重新隐藏。

点击隐藏行旁边的折叠区域中的“+”会使该部分不再隐藏。这可以在没有选区的情况下，用这个隐藏行功能重新隐藏。在这种情况下，使用最后一次被隐藏的行集，那么显示的内容被再次隐藏。

这个命令可以在 宏 内部使用。

撤销隐藏行

要显示隐藏的行集，点击隐藏行旁边折叠区域中的“+”，或者通过一些其它方法定位，然后视图菜单中的选择隐藏/显示行下的隐藏/显示选区命令。

保存隐藏行

如果用户已配置了保存书签的选项设置，那么隐藏行信息也将保存，并在文件下一次载入时重新载入。


全部折叠命令

全部折叠命令 (视图菜单 / 隐藏/显示行子菜单)

这个命令用来折叠所有在词语文件中的 Indent/Unindent Strings 定义为封装的活动文件中的块。如果是选中的文本则命令将只作用于选定的区域。如果没有选定，则该命令将作用于整个活动的文件。

更多信息，请参见 代码折叠 。


全部展开命令

全部展开命令 (视图菜单 / 隐藏/显示行子菜单)

这个命令用来展开所有在词语文件中的 Indent/Unindent Strings 定义为封装的活动文件中的块。如果是选中的文本则命令将只作用于选定的区域。如果没有选定，则该命令将作用于整个活动的文件。

请注意：调用此命令时，使用 隐藏行命令 隐藏的字符串和折叠的代码段将展开。

更多信息，请参见 代码折叠 。


文件更改检测命令

文件更改检测命令 (视图菜单)

这个命令用来切换活动文件的文件更改检测功能。文件更改检测对于日志文件或任何可能被动态更改的文件非常有用。当选定这个选项后，将定期检查 ( 配置 中的文件处理项目下指定时间间隔)活动文件，并更新已被修改后的文件。

请注意: 视图中的这个命令是灰色的，除非指定了关联的配置项目 - 在强制时间段 (用秒) 内检测文件更改 - 并设置了时间间隔。


自动滚动检测的文件命令

自动滚动检测的文件命令 (视图菜单)

这个命令用来切换已被用 文件更改检测命令 激活检测的所有文件的滚动状态。如果选中，所有被检测的文件将在每次检测文件时自动滚动到显示最后一行位置。在一些动态更新的文件中，比如日志文件，这个命令可以确保在受检测文件被激活时，文件中最新添加的内容总是可见。这个功能类似于 UNIX 的 tail 命令。


总在最前命令

总在最前命令 (视图菜单)

这个命令用来切换是否让 UltraEdit 显示在其它所有应用程序的上面。


全屏模式命令

全屏模式命令 (视图菜单)

这个功能允许用户在整个屏幕中编辑活动文件。工具栏、状态栏和其它窗口通常占用 UltraEdit 应用程序的一部分空间，在这个模式中，这些项目将被隐藏。

在全屏模式中，会显示一个带图像的小窗口，可以让用户切回到普通编辑窗口。另外，想取消全屏模式，还可以使用 ESC 键。

全屏模式取消后，UltraEdit 主窗口和编辑窗口将恢复到先前的状态。


Format menu

格式菜单

格式菜单提供下列命令:

重排段落 | 按一定的列数重排段落
段落[排列 | 排列段落 (向左/向右/居中/填充)
转换 CR/LF 为换行 | 将选定文本中的回车符转换为自动换行
转换换行为 CR/LF | 将整个文件的自动换行转换为硬回车
制表符转换为空格 | 将制表符转换为空格
空格转换为制表符 (全部) | 将所有空格转换为制表符
空格转换为制表符 (行首) | 将行首空格转换为制表符
删除行尾空格 | 删除每行尾部的空格
OEM 到 ANSI | 将 OEM 字符集转换为 ANSI 字符集
ANSI 到 OEM | 将 ANSI 字符集转换为 OEM 字符集
大写 | 将选定文本的字符转换为大写字母
小写 | 将选定文本的字符转换为小写字母
首字母大写 | 将选定文本中单词的第一个字符转换为大写字母
大小写转换 | 将选定文本中的每个字符进行大小写互换
添加缩进 | 打开一个允许在选定的文本行添加缩进的对话框
删除缩进 | 打开一个允许从选定的文本行删除缩进的对话框
插入分页符 | 在光标位置插入一个分页符
HTML 验证 - HTML 精简 | 检查并精简 HTML 文件
HTML 验证 - CSE HTML Validator (及选项) | 运行 CSE HTML Validator，并设置它的选项 重新缩进选区
XML 转换到 CR/LF | 通过插入适当的硬回车来格式化单行 XML
XMLlint 工具 | 调用 XMLlint 分析程序。 有关更多命令的信息及其使用，请参见 http://xmlsoft.org/xmllint.html
重新缩进选择 | 重新缩进活动文件中选定的文本


段落重排命令

段落重排命令 (格式菜单)

这个命令用来格式化当前的段落 (或选定的文本) 到指定的列号边界。该列号和设置在 段落设置/格式化对话框 中指定。段落是根据是否有两个连续的硬回车来决定的 (例如空行)。

段落中所有的硬回车被删除，并重新格式化到适当的列边界。

选用 全选命令 选择整个文件，然后重排，可以重新格式化整个文件。

如果启用了 自动缩进 功能，段落将自动根据段落第一行的设置进行缩进。

段落格式化对话框 中使用的设置将被用于这个命令。


段落设置/格式化对话框

段落设置/格式化对话框 (格式菜单/段落格式化子菜单)

段落格式化允许用户用下列样式排列段落:

向左排列 | 文本将向着左边距排列，并且不扩展到右边距。
居中排列 | 文本将在左边距和右边距之间居中。
向右排列 | 文本将向着右边距排列，并且不扩展到左边距。
填充段落 | 文本将在左边距和右边距之间排列，在单词之间添加空格，以确保排列到两边的边距中。段落的最后一行只向左排列。

可以从菜单调用每个单独的排列命令，也可以从段落设置/格式化对话框调用。

段落设置/重排对话框可以指定用于段落重排的参数。这些参数在使用每个段落重排命令后使用。

这些参数是:

悬挂缩进 | 这个参数只应用到向左排列。如果设置了这个参数，排列将允许指定第二个边距，该边距用于段落中的第二个缩进和连续行。这会使段落中的第一行被用一个设置缩进，段落中的其它行使用其它的设置。如果设置了这个参数，可以在对话框中输入悬挂缩进值。
页边距 - 使用段落左边距 | 这个参数用来告诉 UltraEdit 使用现有的段落左边距进行重排，而不是指定新的边距值。
页边距 - 指定页边距 | 这个设置用来告诉 UltraEdit 使用在对话框中输入的左边距值作为段落重排时的左边距的缩进值。
页边距 - 右边距 | 这个设置用来指定在段落重排时的右边距。这个值是用于放置文本的最后一个列号 (以 1 开始)。

上述的边距设置将用于所有重新格式化命令，包括 段落重排命令 。

段落的所有硬回车被删除，段落根据设置重新格式化。

整个文件可以使用 全选命令 选选择整个文件，然后进行重新格式化。


转换回车符为换行命令

转换回车符为换行命令 (格式菜单)

这个命令用来从允许文本在 UltraEdit 中自动换行的文件中删除 CR/LF (回车/换行) 字符。这个功能会删除所有选定文本中的 CR/LF 字符。如果没有选定文本，这个功能无效。

要从文件中删除所有 CR/LF 字符，先选定整个文件。要执行这个动作，将光标定位在文件起始位置，然后同时按 CTRL+SHIFT+END。

要添加 CR/LF (回车/换行) 字符到文件中，请使用转换换行为回车符命令。


转换换行为回车符命令

转换换行为回车符命令 (格式菜单)

这个命令用来根据显示窗口的宽度或指定的列数任一方式 自动换行 文本，并在文件中写入 CR/LF (回车/换行) 字符。如果在换行位置发现空格，那么单个空格将被删除。这允许文档保存为看上去象自动换行状态、实际在自动换行尾部插入 CR/LF 字符的文件。

当选中这个项目时，将显示一个允许选择换行参数的对话框。按默认，文本将被根据当前视图换行。也就是说，文本将象屏幕显示的一样，在窗口边界处换行。这个对话框允许选择文本换行的列数。在这种情况下，文本将在指定的列或者行中词语分界前面换行。

如果没有选择文本，这个功能作用于整个文件。如果已经选择了文本，那么这个功能只转换选定的区域。

要从文件中删除 CR/LF (回车/换行) 字符，请使用 转换回车符到换行命令 。


转换制表符为空格命令

转换制表符为空格命令 (格式菜单)

这个命令用来转换文件内的所有的制表符到空格。使用 Tab 设置 来确定制表符/制表站的转换方式。执行转换后，格式将保持相同。

如果已经选定/加亮了文件中的部分文本，那么只有选定部分被转换，否则将转换整个文件。

要转换空格到制表符，请使用 转换空格为制表符 (行首) 或 转换空格为制表符 (所有) 命令 。


转换空格为制表符 (所有)命令

转换空格为制表符 (所有) 命令 (格式菜单)

使用这个命令可以将文件中所有空格转换为制表符。这是用 Tab 设置 来确定将转换制表符/制表站方式。

执行转换后格式将保持相同。就是说替换为制表符的空格不足时，并要保持格式相同，空格将在原来位置保留。

如果文件的一部分已经选定/加亮，只转换选定的部分，否则，将转换整个文件。

如果你只想转换行首的空格，请使用 转换空格为制表符 (行首) 命令 。

要将制表符转换为空格，请使用 转换制表符为空格命令 。


转换空格为制表符 (行首) 命令

转换空格为制表符 (行首) 命令 (格式菜单)

使用这个命令将文件中的 (行首) 空格转换为制表符。这是用 Tab 设置 来确定将转换制表符/制表站方式。

这里所说的首位空格是指行首的空格，行中第一个非空格字符之后的空格不会被转换。要转换行中所有的空格，请使用 转换空格为制表符 (所有) 命令 。

执行转换后格式将保持相同。也就是说替换为制表符的空格不足时，并保持格式相同，空格将在原来位置保留。

如果文件的一部分已经选定/加亮，只转换选定的部分，否则，将转换整个文件。

要将制表符转换为空格，请使用 转换制表符为空格命令 。


修剪行尾空格命令

修剪行尾空格命令 (格式菜单)

这个命令用来删除每行行尾的不显示字符 (制表符、空格)。这个功能可以从文件中的每一行行尾删除多余的不会显示出现的字符，完成后，光标返回到原始位置。

普通配置页 中提供当保存文件时自动删除空格的设置。


转为大写字母命令

转为大写字母命令 (格式菜单)

这个命令用来更改所有选定的文本到大写字母。这个功能不限制选定文本的数量，如果选择了 列模式 ，那么只转换选定的列。

快捷键: ALT+F5


转为小写字母命令

转为小写字母命令 (格式菜单)

这个命令用来将所有选定的文本的字母改为小写字母。这里对于选定的文本数量没有限制。如果选择了 列模式 ，只转换选定的列中的文本。

快捷键: CTRL+F5


字首大写命令

字首大写命令 (格式菜单)

这个命令用来将所有选定文本中的词语的第一个字母改为大写，其它字母保持小写。这对于选定的文本数量没有限制。如果选择了 列模式 ，那么只转换选定的列。

快捷键: F5


转换大小写命令

转换大小写命令 (格式菜单)

这个命令用来转换选定文本的大小写。对于选定的字符多少没有限制。如果选定了 列模式 ，那么只转换选定列。

快捷键: SHIFT+F5


添加缩进命令

添加缩进命令 (格式菜单)

添加缩进菜单项目会打开一个对话框，可以让用户指定在每个选定 (加亮) 行的行首添加的空格数。UltraEdit 从第一个加亮行开始添加指定的空格数到每个行的行首，到至少有一个字符选中 (加亮) 的最后一行结束。

将在上述所有确定的行中添加缩进，不考虑是否已经存在缩进。

要删除缩进，请使用 删除缩进 命令 (在 格式菜单 )。


删除缩进命令

删除缩进命令 (格式菜单)

删除缩进菜单项目会打开一个对话框，在那里用户可以指定要从每个选定 (加亮) 行开头删除的空格数或制表符数。如果选中删除所有缩进选择框，UltraEdit 将删除所有选定行开头的缩进。UltraEdit 开始从第一个加亮行开头删除缩进，并在至少有一个字符选中的最后一行结束。

如果未在选定行开头找到缩进，则不更改该行。

要添加缩进，请使用 添加缩进命令 (在 格式菜单 )。


插入分页符命令

插入分页符命令 (格式菜单)

插入分页符命令用来在当前光标位置插入分页符。分页符可以在 页面设置对话框 中进行配置。

当打印文档时，分页符将用换页替换，并继续打印分页符之后的下一页。


HTML 精简命令

HTML 精简命令 (格式菜单/HTML 验证子菜单)

HTML 精简命令是一个极好的 HTML 代码格式化、检查和精简工具。它是由 Dave Raggett 开发，并已集成到 UltraEdit-32 中。你可以在下列地址找到更多有关 HTML 精简的信息: http://tidy.sourceforge.net/ 。

HTML 也可以按 工具工具栏 中的 HTML 精简按钮调用，它会打开 HTML 精简对话框:

要定义一个新的配置文件，在配置文本对象中输入文件路径，或按“...”按钮浏览你想使用的文件。按键盘上的回车键将保存指定的路径。按选项按钮将打开 HTML 精简选项对话框。要获取有关 HTML 精简可用的配置说明，请查阅 http://tidy.sourceforge.net/docs/quickref.html 。

当从格式菜单或按 HTML 精简对话框中的解析按钮时，将运行 HTML 精简。活动文档将被保存，HTML 精简将解析该文件。输出窗口将用于显示找到的任何错误或警告。在输出窗口中的错误或警告的行中双击，会使光标定位到文件中适当的行。

如果选定 HTML 精简对话框中的生成“精简”文档， HTML 精简将生成一个活动文件的修正后版本，UltraEdit 将在新的文件/窗口显示标题为“** HTML Tidy Output **”的文档。“** HTML Tidy Output **"”文件在每次使用 HTML 精简后被覆盖。如果未指定这个选项，活动文件将根据配置选项用修改后的文档覆盖。


CSE HTML 验证命令

CSE HTML 验证命令 (格式菜单/HTML 验证子菜单)

CSE HTML Validator 是一个极好的验证 HTML、XML 和其它文件的工具。通过这些菜单项目，UltraEdit 提供可以直接从 UltraEdit 运行、捕获输出并在输出窗口显示等验证整合。

要使用这个功能，必须在你的系统中安装 Validator。有关 Validator 使用的支持和信息，必须直接来自 CSE HTML Validator 开发者。

要获取更多信息，请查阅:

http://www.htmlvalidator.com/

UltraEdit 提供设置 Validator 配置、选项和作业类型的菜单项目，但不确定 Validator 怎样使用这些功能。


XML 转换到 CR/LFs 命令

XML 转换到 CR/LFs 命令 (格式菜单)

该命令可用来格式重排单行 XML。调用该选项时，编辑器扫描文档并在需要时插入硬回车，将文档格式重排为可读性更好的格式。


重新缩进选区命令

重新缩进选区命令 (格式菜单)

这个命令允许用户重新格式化活动文件中选定的文本。一般被程序员根据 配置 中的缩进设置、以及 语法加亮 中的自动缩进设置 (查阅语法加亮的缩进段获取详细信息) 重新格式化现有的文本。

当执行重新缩进命令时，UltraEdit 将一行行、从选定的第一个行缩进开始重新缩进文件。

如果第一个选定的行缩进小于缩进设置，或在多个缩进设置值之间，那么缩进将取整为匹配缩进值或多个值 (如果缩进值是 4，第一个选定行缩进到 2，那么它将被取整为 0，该行将不进行缩进；如果行缩进到 6，它处于缩进值 4 和 8 之间，那么行将被调整为缩进到 4)。

UltraEdit 不会尝试并确定在缩进命令执行完毕后是否会声明被更改，或在这种情况下字符中的某部分被忽略。但是，如果文件包含预处理程序的条件声明 (#ifdef, #ifndef 等)，UltraEdit 不尝试确定哪些文本有效，哪些文件无效。这可能会导致行调整错误。

要避免带条件声明的问题，建议所有条件段包含相同的打开和关闭条件声明数值。如果条件文本中有“if (test) {”声明，请确保关闭符号 (“}”) 也在条件文本中，这样应该不会有问题。

在某些场合下，它可能希望缩进编译器指示或注释行。UltraEdit 提供这个功能，允许忽略在词语文件中定义的字符。这包含在 语法加亮 段下面。


列菜单

列菜单提供下列命令:

列模式 | 切换列/块模式编辑
插入/填充列 | 在每列中插入指定的文本
删除列 | 删除指定数量的列
剪切列 | 剪切指定数量的列到剪贴板
插入号码 | 指定要在每行中插入的数值范围
列/选区统计 | 统计选定区域中的数字 (列或行)
转换到固定列 | 转换字符分隔的文件到固定列
转换到字符分隔 | 转换固定列到字符分隔格式
向左对齐 | 向左对齐列
居中对齐 | 居中对齐列
向右对齐 | 向右对齐列


列模式命令

列模式命令 (列菜单)

这个命令用来改变文本选择的编辑器操作模式。当选定列模式时，文本根据第一个选定的字符到选定文本的最后一个字符的列位置加亮，在这个模式中选定的文本不会自动包含从开头到结束位置的所有字符，但包含选定文本中的第一个和最后一个字符之间的列中的所有文本。

列模式编辑在选定的文本是一个矩形选区时，有时也可以理解为块模式编辑。

在选定的文本中可以执行 剪切 、 复制 和 粘贴 操作。

列模式编辑需要关闭 自动换行 ，以及编辑器必须选用固定宽度字体。

当列模式启用进，将启用另外的列功能; 插入/填充列 、 删除列 、 剪切列 和 插入号码 。

快捷键: ALT+C


插入/填充列命令

插入/填充列命令 (列菜单)

这个命令会打开一个允许输入文本的对话框。这里输入的文本将被插入到选定行中，如果没有选定行，则在从当前光标位置开始的行到文件最后行的每行中插入。当调用这个命令，文本字符将被插入到每行中的光标位置显示列位置。如果行中这个列的文本不存在，空格“ ”将被附加到该行，以便文本能够正确插入。

如果在调用这个命令时，文本被加亮，加亮文本显示的列将被用指定的文本替换。

选项允许的格式是十进制或十六进制。在任何格式中，将根据设置带或不带首位零进行插入。


删除列命令

删除列命令 (列菜单)

这个命令会弹出一个对话框，允许用户删除指定的列数。选定的每一行中的该列处的字符将被删除，如果文档中没有选区，它将从当前光标位置开始，对下面的每一行进行删除，一直处理到文件最后一行。如果输入的值是“零”，那么在调用这个命令时，将根据加亮的文本进行列删除。这个命令不会在剪贴板保存删除后的文本。


剪切列命令

剪切列命令 (列菜单)

这个命令会打开一个对话框，允许按指定的列数进行删除。选定的每一行中的该列将被删除，如果没有选区，它将从当前光标位置开始的每一行开始删除，一直处理到文件最后一行。如果输入的值是“零”，那么在调用这个命令时，将根据加亮的文本进行列删除。这个命令不会在剪贴板保存删除后的文本。


插入号码命令

插入号码命令 (列菜单)

这个命令用来在选定的每一行中插入连续的数字，如果没有选定的行，则在光标所的在列的每一行插入。这个命令会打开一个对话框，允许输入初始值以及每一行之间的增量。用这个命令在文本文件中插入行号再简单不过了。

如果在调用这个命令时有加亮的文本存在，加亮的文本将被替换为插入的行号。行号所需间隔将根据行号的插入号码、初始值和增量自动计算。所有的号码可以是正或负的非小数点数值。

如果选定了“添加首位零”选项，将在之些号码之前添加零值，以保证号码的宽度与插入的最大号码的宽度值相同 (用字符表示的长度)。如果未选择这个选项，将在尾部添加空格。


列/选区统计命令

列/选区统计命令 (列菜单)

这个命令用来统计所有出现的选定区域内 (列或行) 中的所有数值，并在一个对话框中显示合计数。

一些数值格式可能将逗号或其它字符作为数值的一部分或作为分隔字符 (例如，千以上的数值可能被写作为 1,000)。该对话框允许用户指定任何应该在数值中被忽略的字符，按默认，初始字符是一个逗号 (,)。

统计按钮用来重新计算合计数。它允许修改分隔字符，并重新计算合计数。

合计数值显示在一个可编辑的文本条目框中，允许格式化合计数值，以及复制到剪贴板，在需要的时候粘贴到文档中。


转换到固定列命令

转换到固定列命令 (列菜单)

这个功能允许用户将文件从字符分隔对象转换到固定列。这通常在必须进行列处理、但每排的对象宽度不同、处理比较麻烦时有用。这用来弥补 转换到字符分隔 功能的不足。

这个功能会向用户显示一个带下列控件的对话框:

扫描

按下这个按钮会使编辑器扫描文件 (或第一行) 并确定每个对象的最大对象宽度。这用来确定每个对象必需的最大宽度，并将结果 (逗号分隔) 写入到对象宽度文本框中。

只扫描第一行

这个选项用来告诉编辑器只扫描第一行的对象宽度。

用固定列保持分隔

这个选项说明在转换到固定宽度列时，不删除对象的分隔字符。如果不选中这个选项，转换将删除对象间的分隔字符。

分隔字符

这个选项指定对象之间的分隔字符。如果是一个制表符，则应输入“^t”。在其它所有场合下，应该输入单个字符。编辑器使用这个字符来确定对象分界。

对象宽度

这是用于转换的逗号分隔对象宽度列表。如果有多个对象，那么最后一个将被作为对象宽度用于保留对象宽度使用。如果所有的对象都需要相同宽度，这允许用户设置单个条目。

转换

这个按钮用来根据上述设置执行从字符分隔文本到固定列的转换。整个文件都将被转换。


转换到分隔字符命令

转换到字符分隔命令 (列菜单)

这个功能允许用户将文件从固定对象宽度转换到字符分隔对象。这用来补充 转换到固定列 功能。

这个功能会显示一个带下列选项的对话框:

分隔字符

分隔字符用来指定对象间的分隔字符。如果是一个制表符，则应该输入“^t”。在所有其它场合，应该输入单个字符。当从固定宽度转换到字符分隔时，编辑器用这个字符来分隔对象。

对象宽度

这是转换时使用的逗号分隔列表的对象宽度。如果有多个对象，最后一个条目将作为保留对象宽度使用。如果所有的对象需要相同宽度，这允许用户设置单个条目。

转换

根据上述设置执行从固定列到字符分隔的转换。这个功能将转换整个文件。


向左对齐命令

向左对齐命令 (列菜单)

这个命令用来向左对齐选定列内部的文本。在执行向左对齐命令之前，所有选定区域内的制表符将被转换到适当数量的空格以获取相同的排列。这在向左对齐文本之后防止制表符扩展和文件排列有可能存在的更改是必需的。

这个功能只能在 列模式 中执行。


居中对齐命令

居中对齐命令 (列菜单)

这个命令用来在选定列内部居中对齐文本。选定范围中的所有制表符将被转换为适当的空格数，使它们在对齐之前排列保持一致。这对于在文本对齐后控制有可能发生的制表符展开和文本排列改变是必需的。

这个功能只能工作于 列模式 。


向右对齐命令

向右对齐命令 (列菜单)

这个命令用来向右对齐选定列内部的文本。在执行向右对齐命令之前，所有选定区域内的制表符将被转换到适当数量的空格以获取相同的排列。这在向右对齐文本之后防止制表符扩展和文件排列有可能存在的更改是必需的。

这个功能只能在 列模式 中使用。


宏菜单

宏菜单包含用来记录、运行、载入和/或保存宏的命令。

宏是什么？

宏是已经被“记录”的用于以后按原先顺序执行的键击或动作的序列。宏允许你“记录”击键或动作序列，然后“重放”已经记录的 击键和/或动作。比较典型的使用案例是在每次出现文本时，多次执行一个类似的动作集。

UltraEdit 支持多个宏，并且一个宏可以调用其它宏。

宏可以在编辑器启动时自动载入和执行。 查阅 命令行参数 获取更多信息。

宏菜单提供下列命令:

载入 | 载入一个宏文件
载入并附加到现有的宏 | 载入一个宏文件，并附加到任何已经存在的宏中
全部保存 | 保存所有存在的宏到一个文件
快速录制 | 记录一个宏而不显示输入名字等的对话框
设置自动载入 | 指定在启动时载入的宏
设置文件载入/保存的宏 | 指定当文件载入或保存时要执行的宏
编辑宏 | 编辑一个宏
全部删除 | 删除所有已存在的宏
删除宏/修改属性 | 删除一个宏，或修改它的属性
录制 | 开始记录一个宏
停止录制 | 停止宏记录
再次运行 | 再次运行最后使用的宏
多次运行 | 运行任何宏或多次运行宏
显示宏录制后期处理选项 | 宏记录完成后提示用户使用选项
如果宏未保存则在退出时警告 | 如果编辑时有未保存的宏，则在退出时警告


载入命令

载入命令 (宏菜单)

宏载入命令显示一个从磁盘文件载入以前保存宏集的对话框。这个对话框允许从系统中任何已知文件贮存设备中选择文件。默认的文件名是 ULTRAEDIT.MAC，尽管可以使用任何文件名。

载入选定的文件时 UltraEdit 会进行检查，以确保该文件是 UltraEdit 宏文件。


载入并附加到现有的宏命令

载入并附加到现有的宏命令 (宏菜单)

这个功能允许载入的宏文件附加到内在的宏中，不象宏 载入命令 ，它会在文件载入前删除所有内在的宏。

使用这个功能，会显示从磁盘文件载入以前保存的宏集的对话框，这个对话框允许从已知设备中选择任何文件。出现的默认文件名是 ULTRAEDIT.MAC，但可接受任何文件名。

在选定的文件载入时，先会进行检查，以确保该文件是一个 UltraEdit 宏文件。


全部保存命令

全部保存命令 (宏菜单)

宏的全部保存命令会打开一个对话框，将用 录制命令 录制的宏保存到磁盘文件中。这个对话框允许用户从任何系统中已知的文件贮存设备中选择一个文件。初始默认文件名是 UltraEdit.MAC，尽管可以使用任何文件名。

这个命令只能在宏已经被录制或载入时使用。


快速录制命令

快速录制命令 (宏菜单)

宏的快速录制命令用来“记录”稍后可以重放的键击和动作。当这个命令激活时，菜单上的项目会变成“停止快速录制”。点击这个命令或使用快速录制的快捷方式将停止录制宏。

这个命令与宏的 录制命令 工作方式相同，除了它不提示宏的名字、快捷键等。

在执行这个宏时，不显示取消对话框。在宏的列表中，这将用空名字显示，录制的新宏将覆盖任何现有的快速录制的宏，或用空名录制宏。

这个命令的目的是提供与录制宏命令相同的功能，但可以用单个键击录制和停止录制。

这个宏通过选择宏的 再次运行 或宏的 多次运行命令 ，象普通宏一样执行。


设置自动载入命令

设置自动载入命令 (宏菜单)

宏的设置自动载入命令允许你指定应该在 UltraEdit 启动时自动载入的宏文件。

如果需要，还可以指定执行宏的次数。可以在不执行宏的情况下自动载入一个宏文件。

这个载入宏的方法在启动时不考虑载入宏的 命令行参数 。如果在这里没有指定要载入的宏，则不使用命令行参数设置，如果指定，则被使用。


设置文件载入/保存的宏命令

设置文件载入/保存的宏命令 (宏菜单)

这个命令用来让用户指定在每次文件载入或保存时执行的宏。

显示的对话框中提供下列选项:

宏文件名

指定在文件载入或保存时，包含的要执行宏的宏文件的完整路径和名字。如果要求宏在文件载入或保存时执行，那么它们必须在同一文件中。

载入时执行的宏名

指定在文件载入时要执行的宏的名字。如果指定的宏是在文件载入后执行，则运行于每个已载入的文件。

次数

指定在每个文件中执行文件载指定宏的次数。

保存时执行的宏名

指定在文件保存时要执行的宏的名字。如果指定的宏是在文件保存之前执行，则运行于每个保存的文件。

次数

指定每个文件中执行文件保存指定宏的次数。

注意: 如果用户只想在某个文件类型中执行这些宏，用户可以在宏中进行文件名或扩展名测试，并获取宏中正确的动作。


编辑宏命令

编辑宏命令 (宏菜单)

编辑宏命令允许您创建并编辑新宏，或编辑以前用该命令生成的宏，或者编辑用宏的 录制命令 录制的宏。

在大多数情况下，用宏的 录制命令 录制新宏，然后在需要时进行编辑，这对用户来说更为方便。您只要稍作学习就可以掌握。

命令

宏是可以在以后自动执行以修改文件的一连串命令的组合。对话框左边显示当前进行编辑的宏，和包含可编辑宏命令的编辑窗口。

宏命令必须是预定义命令。这些预定义命令显示在对话框右边。如果用鼠标双击命令，或单击命令左边的箭头，它将添加到宏中。

参数

许多命令带有数字参数。数字参数相当容易理解，例如“GotoLine # #”或“GotoPage #”。 但是象查找和替换、排序等命令，还带有非数字的其它参数。这些其它参数在命令列表的下面列出以方便选用。

创建新宏

要从该对话框创建新宏，请单击新建宏按钮。这将显示 宏定义对话框 ，允许您定义宏名和需要的热键。

新建宏时，四个宏命令将自动添加到宏中：

- Insert Mode 或 OverStrike Mode

- ColumnModeOn 或 ColumnModeOff

- HexOn 或 HexOff

- UnixReOff 或 UnixReOn 或 PerlReOn

根据当前编辑器状态添加这四个命令。其目的是在每次宏执行时建立一个已知的编辑状态。如果宏是以某种模式录制的，并在其它模式中执行，可能会出现不可预知的问题。在宏开头建立宏运行模式可以确保达到预期的结果。这些命令可以根据需要进行修改。

一旦创建了宏，就可以对其进行修改。请注意，许多宏命令可能用到“^c”和“^s”，运行时“^c”将被替换为剪贴板的内容，而“^s”将被替换为当前选择的文本。这样用户可以录制引用特定字符串的宏，并用这两个符号之一进行替换，从而当宏运行时可以动态“指定”字符串。

修改宏

要修改宏，可以在宏编辑框中直接输入命令，或从命令列表中选择命令。命令不区分大小写，但其拼写必须与命令列表中显示的完全一致。

下表显示了可能添加任意参数的命令：

命令 | 参数* | 描述
"" |  | 在引号 ("") 间插入文本。结束引号必须是行中的最后一个非空格字符。插入的字符可能跨越多行。要插入引号 (")，请根据需要将其置于插入文本中，并确保最后一个字符也是引号。要只插入单个引号字符 (")，则该行应该是这样: """ 要插入新行，在起始引号和结束引号之间添加一行。要插入以 1 和 2 开头的两行，命令应该如下所示： "1 2"
AnsiToOem |  | 将文件从 ANSI 转换到 OEM
ASCIIToUnicode |  | 将文件从 ASCII 转换到 Unicode
Bottom |  | 跳到文件末端
ClearClipboard |  | 清除 UltraEdit 内部活动剪贴板内容
Clipboard | 剪贴板号 (0-9) | 选择指定的剪贴板；0 = 指定 Windows 剪贴板，1-9 指定用户剪贴板
CloseFile | 空白 (无参数) Save 在文件关闭前强制保存 NoSave 不对是否首先保存文件做出提示，就关闭文件 | 关闭活动文件
ColumnCenterJustify |  | 居中对齐选定的列
ColumnCut | 要剪切的列编号数值 | 在列模式中剪切选中的列或从当前光标位置到文件末尾的指定数量的列。要剪切选中的列必须使用值“0”。
ColumnDelete | 要删除的列编号数值 | 在列模式中删除选中的列或从当前光标位置到文件末尾的指定数量的列。要删除选中的列必须使用值“0”。
ColumnInsert | 引号 ("") 中的字符串 | 插入引号内的字符串到选定的列
ColumnInsertNum | 开始数字 增量 LeadingZero (可选) HEX (可选) | 在选中列中插入数字。 例如，要在每个选中行的当前列或从当前行到最后一行的当前列中插入以 20 开始的数字，增量为 -1 (= 递减 1)，并带有十六进制符号的前导 0，则应使用以下命令： ColumnInsertNum 20 -1 LeadingZero Hex
ColumnLeftJustify |  | 向左对齐选定的列
ColumnModeOff |  | 关闭列模式
ColumnModeOn |  | 打开列模式
ColumnRightJustify |  | 向右对齐选定的列
Copy |  | 复制选定的文本到剪贴板中
CopyAppend |  | 复制选定的文本并附加到剪贴板
CopyFilePath |  | 复制活动文件路径/名称到剪贴板
Cut |  | 从文件中剪切选定的文本到剪贴板
CutAppend |  | 从文件中剪切选定的文本，并附加到剪贴板
DecryptFilePrompt |  | 显示解密文件对话框，提示用户输入要解密文件的完整路径和解密使用的密码
Delete |  | 删除当前字符或选定的文本
DeleteLine |  | 删除当前行
DeleteToEndofLine |  | 删除从当前光标位置到行尾的内容
DeleteToStartofLine |  | 删除从行首到当前光标位置的内容
DosToMac |  | 转换文件（行结束符）到 MAC 格式
DosToUnix |  | 转换文件（行结束符）到 UNIX 格式
DupeLine |  | 在当标下面插入活动行的副本
Else |  | If ... 命令配套使用的 Else 函数 IfSel ... Else 如果 IfSel 失败则执行这些命令。 EndIf
EncryptFilePrompt |  | 显示加密文件对话框，提示用户输入要加密文件的完整路径和加密使用的密码
EndIf |  | 结束受 If... 语句控制的指令块
EndLoop |  | 结束循环 - 返回循环起始位置 - 参见 Loop 命令
EndSelect |  | 停止选择文本（详细信息请参见 StartSelect）
ExitLoop |  | 退出循环，并转到循环后 (EndLoop 命令之后) 的第一个命令 - 参见 Loop 命令
ExitMacro |  | 在不处理更多命令或返回错误消息的情况下退出宏执行
Find | "" （搜索引号中的字符串） Ascii 说明是十六进制模式中的 ASCII 搜索（可选，仅十六进制模式）MatchCase 说明搜索条件是区分大小写的（可选） MatchWord 说明搜索的字符串只完全匹配整个词语（可选） PreserveCase 如果使用则替换字符串与查找字符串大小写匹配，仅在后接 Replace 命令时可用（可选） RegExp 说明这是一个正则表达式搜索 (可选) Up 说明是用反向搜索（可选） Select 说明应该选定从当前选区/位置到搜索目标结束位置的文本 | 根据参数指定内容查找引号 "" 中的字符串。 一些例子： 查找大小写不限的单个字母字符: Find RegExp "[A-Z]" 仅查找大写的单个字母字符： Find MatchCase RegExp "[A-Z]" 查找单个非 'a' 或 'A' 或 CRLF (UltraEdit 语法) 的字符： Find RegExp "[~a^p]" 查找单个非 'a' 或 LF (Unix/Perl 语法) 的字符： Find MatchCase RegExp "[^a\n]"
FindInFiles | "" （引号中的初始目录字符串） "" （引号中的所属文件/类型字符串） "" （引号中的搜索字符串） FavFiles 如果使用则将搜索限制为文件菜单下收藏的文件中指定的文件（可选） 忽略隐藏的子目录 如果使用则搜索将跳过 Windows 文件系统内定义为“隐藏”的子目录 （可选） MatchCase 说明搜索区分大小写（可选） MatchIfNotFound 如果使用则搜索将返回不包含指定搜索字符串的文件（可选） MatchWord 说明搜索的字符串只完全匹配整个词语 （可选） OpenFiles 说明将搜索限制为当前打开进行编辑的文件（可选） OutputWin 如果使用则将搜索结果返回到输出窗口；如果未使用则将搜索结果返回新的编辑窗口（可选） ProjFiles 如果使用则将搜索限制为指定的活动方案文件（可选） Recursive 如果使用则搜索将贯穿指定搜索目录的所有子目录（可选） RegExp 表示正则表达式（可选） SolFiles 如果使用则将搜索限制为指定的活动解决方案文件（可选，仅限于 UEStudio） Unicode 如果使用则指定的搜索字符串将解析为多字节 Unicode 字符串并执行 Unicode 查找（可选） | 根据参数中的定义搜索指定文件，查找引号 "" 中的字符。格式必须如下： FindInFiles 粗体参数 "初始目录" "文件/类型" "要搜索的字符串" 例如： FindInFiles OutputWin "c:\temp\test\" "*.html" "home" 当在所有打开文件、方案文件或解决方案文件中搜索时，Recursive 参数将被忽略。 当使用 FavFiles、OpenFiles、ProjFiles 或 SolFiles 时，初始目录和文件/类型参数应该为空字符串 "" 。
FromEBCDIC |  | 从 EBCDIC 格式转换文本
GetString | 引号（""）中的字符串用于提示对话框 | 提示用户输入要在文件中的当前位置插入的字符串。这里的“提示”是在宏执行时显示给用户的提示或询问。 GetString "What country do you live in?"
GetValue | 引号 ("") 中的字符串用于提示对话框 | 提示用户输入要在文件中的当前位置插入的值。这里的“提示”是在宏执行时显示给用户的提示或询问。 GetValue "How old are you?"
GotoBookMark | 跳转到的书签索引或 -1 转到下一个书签 | 跳转到下一个/指定的书签。索引从 0 开始。如果用户输入大于实际书签数的索引，则将自动引导到第一个书签（索引 0）。
GotoBookMarkSelect | 跳转到的书签索引或 -1 转到下一个书签 | 跳转到下一个/指定的书签并选择从光标位置到书签的文本。索引从 0 开始。如果用户输入大于实际书签数的索引，则将自动引导到第一个书签（索引 0）。
GotoLine | 要跳转到的行和列的数值 | 跳转到指定的行和列号。使用行号 0 跳转到当前行的指定列。
GotoLineSelect | 要跳转到的行和列的数值 | 跳转到指定的行号和列号并选择从光标位置到行/列的文本。选择文本时使用行号 0 跳转到当前行的指定列。
GotoPage | 要跳往的页码数值 | 跳到指定的页码
GotoPageSelect | 要跳往的页码数值 | 跳到指定的页码，并选中从光标位置到页码间的文本
HexDelete | 指定要删除的字节数的数值 | 从文件中删除指定的字节数
HexInsert | 指定要插入的字节数的数值 | 插入指定的字节数（空格）到文件中
HexOff |  | 关闭十六进制模式 - 切换到文本模式
HexOn |  | 打开十六进制模式
HideShowCollapseAll |  | 折叠活动文档中的所有可折叠行
HideShowExpandAll |  | 展开活动文档中的所有合拢/折叠行
HideShowSelection |  | 隐藏选定的行，如果它是隐藏的，则显示原先隐藏的光标所在位置的行
IfCharGt | "字符" 或数字 | 这用来检查光标位置的字符是否大于指定的字符或指定的数值。检查数值不是检查字符串的值，而是检查相应字符的数值。 IfCharGt " " ... 如果当前字符大于空格则执行这些命令。 ... EndIf IfCharGt 32 ... 如果当前字符的十进制数值大于32（空格）则执行这些命令。 ... EndIf
IfCharIs | "字符串" 或数字 | 这用来检查光标位置处的当前字符是否在指定字符串内，或匹配该十进制数值。 IfCharIs "xyz" ... 如果当前字符是x、y 或 z 则执行这些命令。 ... EndIf IfCharIs 34 ... 如果当前字符的十进制数值是34（双引号）则执行这些命令。 ... EndIf
IfColNum | 数字 | 这用来检查当前光标位置是否是特定的列号。 IfColNum 10 ... 如果当前光标位置是列 10，则执行这些命令。列 1 是首列。 ... EndIf
IfColNumGt | 数字 | 这用来检查当前光标位置是否大于特定列号。 IfColNumGt 10 ... 如果当前光标位置大于列 10，则执行这些命令。列 1 是首列。 ... EndIf
IfEof |  | 这用来检查当前光标位置是否在文件末端。 IfEof ... 如果在文件末端则执行这些命令。 ... EndIf
IfExtIs | "字符串" | 这用来检查活动文件的文件扩展名是否匹配指定的字符串。如果扩展名匹配，则条件满足，将执行 IfextIs 语句后的宏命令。 IfExtIs "txt" ... 如果当前文件扩展名是 txt 则执行这些命令。 ... EndIf
IfFound |  | 这用来检查宏中上一个查找命令返回的结果，如果上一次搜索成功，则执行下一组指令集直到 "EndIf" ： Find "something" IfFound ... 如果找到 "something" 则执行这些命令。 ... EndIf 注意——要在宏执行时避免出现“未找到”消息，请确保宏属性中的“如果查找和替换未找到则继续”选择框中已作相应的设置。
IfFTP |  | 这用来检查当前文件是否为通过 FTP/SFTP 载入的文件，而不是本地/网络文件。 IfFTP ... 如果是 FTP 载入的文件则执行这些命令。 ... EndIf
IfNameIs | "字符串" | 这用来检查活动文件名（而不是路径或扩展名）是否匹配指定的字符串。如果文件名匹配，则条件满足，将执行 IfNameIs 语句后的宏命令。 IfNameIs "test" ... 如果当前文件名是 test （不考虑文件扩展名），则执行这些命令。 ... EndIf
IfNotFound |  | 这用来检查宏中上一个查找命令返回的结果，如果上一次搜索未成功，则执行下一组指令集直到 "EndIf" ： Find "something" IfNotFound ... 如果未找到 "something" 则执行这些命令。 ... EndIf 注意——要在宏执行时避免出现“未找到”消息，请确保宏属性中的“如果查找和替换未找到则继续”选择框中已作相应的设置。
IfSel |  | 这用来检查当前在活动文件内是否有选中的文本。 IfSel ... 如果有选中的文本则执行这些命令。 ... EndIf
InsertLine |  | 在光标当前位置的下面插入空白行
InsertMode |  | 更改输入字符的文本编辑模式为插入模式
InsertPageBreak |  | 在文件中的当前光标位置插入一个换页/分页字符
InvertCase |  | 反转选定文本的大小写
Key | BACKSPACE DEL DOWN ARROW END HOME LEFT ARROW PGDN PGUP RIGHT ARROW UP ARROW Ctrl+END Ctrl+HOME Ctrl+LEFT ARROW Ctrl+RIGHT ARROW | 在宏中插入一个键命令。一般用来在文件中移动光标和退格或删除。“Ctrl+”修饰语可以与普通编辑一起使用，用来修改命令。 对于文本输入，使用 "" 字符串命令，而不是 Key 命令。
Loop | # | 循环执行 # 次，这里的 # 是一个数值。0 表示无限循环。 例如： Loop 10 ... 执行命令 10 次 ... EndLoop
MatchBrace |  | 查找匹配的成对符号，并选中它们之间的文本
MoveLineDown |  | 将活动行从当前位置下移一行
MoveLineUp |  | 将活动行从当前位置上移一行
NewFile |  | 打开一个新的空白文件
NextDocument |  | 切换到下一个文件标签文档
NextWindow |  | 切换到下一个窗口
OemToAnsi |  | 将文件从 OEM 转换到 ANSI
Open | 引号（""）中是文件名 | 打开指定的文件。文件名必须在引号中。文件名中可以使用 "^s" 。UltraEdit 将其取代为活动窗口中当前选中的文本。同样可以使用“^c”且 UltraEdit 会将其替换为剪贴板中的内容。
OverStrikeMode |  | 更改输入字符的文本编辑模式为覆盖模式
Paste |  | 粘贴剪贴板的内容到文件中
PerlReOn |  | 将正则表达式切换为符合 Perl 样式的正则表达式
PlayMacro | 指定宏执行次数的数值 引号（""）中是宏名 | 执行其它宏。先指定执行宏的次数，然后是宏名。宏名必须在引号中且区分大小写，并且宏必须已经存在。
PreviousBookmark |  | 跳到上一个书签
PreviousBookmarkSelect |  | 跳到上一个书签，并选中从光标位置到书签之间的文本
PreviousDocument |  | 切换到上一个文件标签文档
PreviousWindow |  | 切换到上一个窗口
ReIndentSelection |  | 重新缩进活动文件中当前选定的文本
Replace | All 全部替换。 AllFiles 在所有打开文件中替换（必须全部替换）。 SelectText 在选中文本中替换（必须全部替换）。 引号（""）中为替换字符串——用于替换找到的字符串 | 替换命令用指定字符串替换以前找到的字符串。这个命令 必须 跟随在 Find 命令之后。 与查找字符串一样，替换字符串必须在引号中。结束引号必须是行的最后一个非空格字符。 然而替换字符串可能跨越多行，如果行的最后一个非空格字符是引号，则字符串被终止。所有替换命令允许使用的特殊字符，也可以在这里使用。
ReplInFiles | ""（引号中的初始目录字符串） ""（引号中的所属文件/类型字符串） ""（引号中的搜索字符串） ""（下一行引号中的替换字符串） FavFiles 如果使用则将搜索限制为文件菜单中收藏的文件内指定的文件（可选） IgnoreHiddenSubDirs 如果使用则搜索将跳过 Windows 文件系统内定义为 "隐藏" 的子目录 （可选） Log 在输出窗口中创建已更改文件列表（可选） MatchCase 说明搜索区分大小写（可选） MatchWord 说明搜索字符串只完全匹配整个词语（可选） PreserveCase 如果使用则替换字符串与查找字符串大小写匹配（可选） ProjFiles 如果使用则将搜索限制为指定的活动方案文件（可选） Recursive 如果使用则搜索将贯穿指定搜索目录的所有子目录（可选） RegExp 表示正则表达式搜索（可选） SolFiles 如果使用则将搜索限制为指定的活动解决方案文件（可选，仅限于 UEStudio） Unicode 如果使用则指定的搜索和替换字符串将被解析为多字节 Unicode 字符串，并执行 Unicode 替换（可选） | 根据指定的参数搜索整个指定的文件，查找引号 "" 中的字符串，并替换为指定的内容。格式必须象下面一样: ReplInFiles 粗体参数 "初始目录" "文件/类型" "搜索字符串" "替换字符串" “替换字符串”（引号中内容）必须在宏的下一行中指定，而不在 ReplInFiles 命令行中。 例如： ReplInFiles "c:\temp\test\" "*.html" "home" "away" 当在所有打开文件、方案文件或解决方案文件中搜索时，Recursive 参数将被忽略。 当使用 FavFiles、OpenFiles、ProjFiles 或 SolFiles 时，初始目录和文件/类型参数应该为空字符串 "" 。
ReturnToWrap |  | 将硬回车转换为自动换行
RunTool | 引号（""）中的字符串指定要运行的区分大小写的工具菜单名 | 运行一个工具。该工具必须在高级菜单中的工具配置中进行配置。
Save |  | 保存活动文件
SaveAll |  | 保存所有打开的文件
SaveAs | 引号（""）中是文件名 | 将活动文件用指定的文件名保存。文件名必须在引号中。文件名中可以使用 "^s" 。UltraEdit 将其取代为活动窗口中当前选中的文本。同样可以使用“^c”且 UltraEdit 会将其替换为剪贴板中的内容。
SelectAll |  | 选中文件中的所有文本
SelectLine |  | 选中活动行中的所有文本
SelectToBottom |  | 选中从当前位置到文件末端的所有文本
SelectToTop |  | 选中从文件起始到当前位置的所有文本
SelectWord |  | 选中当前词语 (象双击一个词语一样)
SortAsc | IgnoreCase 排序时忽略字符的大小写。 RemoveDup 删除重复行。 Numeric 根据数值排序，而不是根据字符顺序排序。无法和 Alterate 或 Locale 排序一起使用。 Alternate 指定排序应该使用替换排序方法。在替换排序方法中仅可以使用单个排序键。 Locale 指定排序应该针对本地。无法与 Alternate 参数一起使用。 排序键对（数值），每个值之间用空格隔开。 | 用升序方式排序文件或选定的文本。 例如： SortAsc IgnoreCase RemoveDup Numeric 1 -1 0 0 0 0 0 0
SortDes | IgnoreCase 排序时忽略字符的大小写。 RemoveDup 删除重复行。 Numeric 根据数值排序，而不是根据字符顺序排序。无法和 Alterate 或 Locale 排序一起使用。 Alternate 指定排序应该使用替换排序方法。在替换排序方法中仅可以使用单个排序键。 Locale 指定排序应该针对本地。无法与 Alternate 参数一起使用。 排序键对（数值），每个值之间用空格隔开。 | 用降序方式排序文件或选定的文本。 例如： SortDes RemoveDup Locale 0 -1 0 0 0 0 0 0
SpacesToTabs |  | 转换文件内的（前导）空格为制表符
SpacesToTabsAll |  | 转换文件内的（所有）空格为制表符
StartSelect |  | 开始选择。这用来打开选择模式。打开选择模式，移动或放置光标来选择文本。 EndSelect 将停止选择模式。已选文本将保持选中状态直到正常编辑时其他命令导致其不被选中。
TabsToSpaces |  | 转换文件中的所有制表符到空格
Template | 模板号 (#) | 插入指定的模板到文件中
TimeDate |  | 在文件的当前位置插入时间和日期
ToCaps |  | 选定文本中的每个词语首字大写
ToEBCDIC |  | 转换文本到 EBCDIC 格式
ToggleBookmark |  | 在当前行设置或删除书签
ToLower |  | 转换选定的文本到小写字母
Top |  | 跳到文件起始位置
ToUpper |  | 转换选定的文本为大写字母
TrimTrailingSpaces |  | 删除当前文件中每行后面的多余空格
UnicodeToASCII |  | 将文件从 Unicode 转换到 ASCII
UnixMactoDos |  | 将活动文件（行终止符）从 Mac/Unix 转换到 DOS 格式
UnixReOff |  | 切换正则表达式到 UltraEdit 样式的正则表达式（非 Unix）
UnixReOn |  | 切换正则表达式到 Unix 样式的正则表达式
WrapToReturn | 执行换行时所在列的列号（#）。列号为 0 则表示换行发生在窗口边缘。 | 将文件从自动换行转换为硬回车
XMLConvertToCRLF |  | 将单行 XML 文本转换为缩排的 XML 格式
 | * 参数列中的（#）表示应该为该参数输入一个数值。同样，参数列中的（""）表示要在引号间输入字符串。文本描述只是参数的含义。 所有的字符串参数必须是最后一个参数。 |


全部删除命令

全部删除命令 (宏菜单)

这个命令用来删除所有附属的宏。如果在文件保存之前已创建了宏或修改了其中任意一个宏，那么会提示用户是否在删除之前保存宏。


删除宏/修改属性命令

删除宏/修改属性命令 (宏菜单)

这个命令可以用来让用户删除或修改写宏关联的热键。将打开一个显示所有宏的对话框，你可以选择任一宏，并修改热键 (或者可以删除宏)。这里不支持修改宏内容。要获取热键分配的更多信息，请查阅宏的 录制 命令。


录制命令

录制命令 (宏菜单)

使用宏的录制命令开始“记录”在以后可以回放的击键和动作。当选定 停止录制命令 时，录制停止。

这个命令会弹出 宏定义对话框 ，在那里你可以定义宏名，如果需要，还可以定义热键。 在按下确定按钮、该对话框消失后，宏开始录制。

录制宏注意事项:

宏录制功能在启动后会记录所有击键和输入的字符。所有的击键均被记录，包含移动到行尾、文件顶部或底部等组合键。 请注意这种情况的出现，以确保 再次执行 相同的键击是正确的。 正在录制宏时，将在状态栏的第二个窗格中 显示宏正在录制通知。

录制时不会记录鼠标动作和滚动。所有的定位动作应该用键盘执行。

宏还可录制和执行 下一个窗口 和 上一个窗口 命令。

宏录制还支持 查找 和 替换 (查阅 查找 获取可以在宏中使用的特殊字符的信息)。所有执行的查找和替换功能都将被直接记录，除非在执行时使用了剪贴板内容或加亮文本替换的特殊字符。 查阅 查找 获取更多信息。如果文件中所有或任意的“查找”内容被“替换”内容替换，那么在 再次运行 宏时，将执行相同的动作。

在录制宏时，还支持 剪切 、 复制 和 粘贴 。任何这些动作将在 再次运行 时动态执行。也就是说，在录制宏时剪切了一个项目，那么在回放该宏时，根据宏执行时选定的文本，将剪切一个项目。如果宏回放时选定的文本与录制宏时的文本不同，在回放时剪切的文本也是不同的。

现在还支持多个宏，当宏已经存在时，这个命令也可以使用。

现在宏内已支持 十六进制编辑 。

录制宏时，还支持下列命令:

键盘项目 - 输入字符

光标定位

用键盘命令选择文本

剪切、复制、粘贴

查找/替换

十六进制模式切换和编辑

文件打开、关闭、保存

书签

执行宏 - 嵌套执行宏

窗口切换 - 下一个/上一个窗口

插入/覆盖模式切换

Unix/Mac 到 DOS 转换

DOS 到 Unix 转换

DOS 到 MAC 转换

转换换行为回车符

转换回车符为换行


停止录制命令

停止录制命令 (宏菜单)

宏的停止录制命令用来停止捕获用 录制命令 录制的键击和动作。一旦宏开始录制，并且录制过程被这个命令停止，就可以选择宏的 再次运行 或宏的 多次运行命令 来执行宏了。

在宏录制后，可以使用宏的 全部保存命令 保存宏。


再次运行命令

再次运行命令 (宏菜单)

宏的再次运行命令用来再次运行已用宏的 录制命令 录制的宏。每次调用这个命令重新执行宏一次。要多次重复执行宏，请使用宏的 多次运行命令 。

如果没有录制或载入宏，不能使用这个命令。


运行/多次运行命令

运行/多次运行命令 (宏菜单)

宏的运行/多次运行命令用来多次运行已用宏的 录制命令 录制的宏。执行该命令后，会显示一个对话框，提示用户指定一个 1 到 100000 之间的数值，作为宏多次执行的次数。如果只想重新执行宏一次，请使用宏的 再次运行命令 。

如果没有录制或载入宏，不能使用这个命令。


宏录制后期处理选项

宏录制后期处理选项对话框

宏录制后期处理选项对话框主要包含一些可供用户在完成宏的录制后采用的选项。

用于保存的宏文件

如果在录制宏的同时加载宏，则当前加载宏的路径和名称将显示在此。 在这种情况下，将在对话框中显示保存按钮。 如果宏已经加载，按另存为按钮将显示另存为对话框，在此用户可以指定刚录制好的宏应该保存的路径和名称。 一旦指定了宏保存文件，将激活在启动时加载宏文件选项。

在启动时加载宏文件

如果已经在设置宏用于文件加载/保存中指定了宏以便在启动时加载，则在此指定宏的路径和名称。 如果用户需要，保存的宏将被指定用于在启动时加载。 该操作将使用刚录制的宏替换以前指定的宏。

启动时加载宏

如果选中该选项，则刚录制的宏将在启动编辑器时加载。

不再显示该对话框

如果选中该选项，将在宏菜单中取消选中显示宏录制后期处理选项，且该对话框在将来录制宏的时候将不会显示。


如果宏未保存则在退出时警告

如果宏未保存则在退出时警告 (宏菜单)

这是用来说明和确定在 UltarEdit 关闭、载入的新宏和已修改的宏未保存时，是否显示警告。

如果不选中这个选项，将不出现警告。


脚本菜单

脚本菜单包含下列命令：

脚本 | 打开脚本对话框，在此可以加载脚本进行执行。
脚本列表 | 显示或隐藏所有当前加载脚本的列表
运行活动脚本 | 初始化当前正在编辑的 JavaScript 文件。 如果活动文件为 JavaScript 文件，该选项将动态显示在脚本子菜单中。 还可以在“配置”下的键映射中为此定义键盘快捷方式。


高级菜单

高级菜单提供了使用 UltraEdit 和 UEStudio 一些高级性能的功能：

配置 | 提供了带有索引树的“配置”对话框，以便访问分类的配置选项
脚本 | 显示带有“脚本...”标题的子菜单。 点击将打开脚本主题的“配置”对话框。 在下面将动态显示当前添加的脚本。
运行活动脚本 | 初始化当前正在编辑的 JavaScript 文件。 如果活动文件为 JavaScript 文件，该选项将动态显示在脚本子菜单中。 还可以在“配置”下的“键映射”中为此定义键盘快捷方式。
导入设置 | 提供对话框允许用户选择 INI 文件以导入设置
导出设置 | 提供对话框允许用户选择文件夹以导出设置
备份/恢复用户定制 | 显示对话框允许用户选择菜单/工具栏定制设置，以便备份或恢复
设置页面编码/区域 | 显示/修改模板
显示/修改模板 | 提供一个显示/修改用户定义模板的对话框
插入模板 | 插入一个用户定义的模板到活动文件中
私人模板 | 从弹出的子菜单选择已命名的模板插入到活动文件
DOS 命令 | 运行 DOS 命令并捕获它的输出
最后一个 DOS 命令 | 重复执行最后一次运行的 DOS 命令
运行 Windows 程序 | 运行 Windows 程序
打开 UltraEdit-32 的新实例 | 启动 UltraEdit-32 的另一个实例
预备捕获方法 | 切换捕获输出的预备方法
工具配置 | 弹出一个可由用户定义的工具配置对话框
方案工具配置 | 弹出一个用于活动方案的、可由用户定义工具配置的对话框


配置摘要

当从 高级菜单 中选择了配置，将显示一个“配置”对话框，带有分类的配置选项。可以使用对话框左侧的索引树轻松导航这些项目。点击任何主要标题（编辑器、文件处理、编辑器显示、应用程序布局、 * 环境、工具栏/菜单）将展开该区段并可以选择子标题以访问相关选项。

要了解每个设置的作用，请点击“帮助”中的“内容”页面，并双击菜单摘要，双击高级菜单再双击配置。这将在帮助文件的配置对话框里打开索引树的镜像。用户可以扩展帮助中的主要区段：

编辑器

搜索

拼写检查器

文件处理

文件关联

文件类型

编辑器显示

环境

应用程序布局

工具栏/菜单

目录

键映射

通过在标题上双击，并点击下面包括的主题，将提高相关选项的摘要。

* 请注意：IDE配置项目只在 UEStudio 支持，UltraEdit-32 不支持该功能。


高级

高级（配置 - 编辑器）

高级分支位于配置－编辑器之下，有如下的选项：

允许低 ASCII 值输入 (通常是控制代码)

该设置允许在编辑时输入象控制代码等“低值”字符输入。通常这些字符被忽略。

使用较大内部缓存 - 这可以在某些情况下提升处理大文件的性能

该设置确定 UltraEdit 是否应该在它内部操作时使用较大缓存。这可以在处理非常大文件时加速一些操作，但它非常依赖硬件配置。

编辑时使用内存缓存 - 如果有足够内存的话，可以提升处理非常大文件的性能

该设置强制 UltraEdit 使用内存缓冲进行编辑，如果系统有足够的内存，可以增进编辑大文件时的性能。如果编辑非常大的文件，并在内存不足的情况下使用了该设置，会使系统严重变慢。

允许编辑带十六进制 00 的文本文件而不将它们转换到空格

当文件载入到 UltraEdit 时，会检查文件的起始处 7K 的内容。如果包含多于两个的 NULL (十六进制 00)，该文件被视为二进制/十六进制文件。NULL 在 ASCII 文件中是无效的，如果这个选项没有选中 (默认)，在文本模式编辑文件，NULL 将被转换到空格。如果你想在文本模式查看十六进制文件，但不希望使它有任何更改，UltraEdit 应该不转换 NULL 到空格，但如果你在文本模式更改到十六进制文件，将发生改变。

选中这个选项将不考虑这个 NULL (十六进制 00) 到空格的转换，但我们还是推荐不要在文本模式编辑二进制文件。NULL 通常被视为字符的终止字符，在 ASCII 文件中是无效的。使用这个设置可能会引起一些使用 NULL 字符的功能不能工作，尽管不会影响常规编辑。

加载/还原打印机设置

编辑器在加载和关闭时尝试与打印机驱动程序通讯（以保留设置）。如果网络打印机指定为默认打印机且不可用，可能导致启动时编辑器尝试查找网络打印机而产生延时。如果未选中该选项，则编辑器不与打印机通信。

Escape 键隐藏可以看到的输出窗口

如果选中该选项，可以在输出窗口活动时按下 Escape 键将其隐藏。

分组撤销

如果选中该选项，则将按词而不是按字符进行撤销操作。 如果在编辑文档时切换该设置（且撤销缓存由两种设置部分创建），则撤销功能将反映文档创建时所作的设置。 这将造成文件的部分文本按分组字符进行撤销而部分按字符进行撤销。

当应用程序不活动时自动保存修改的文档

如果选中该选项，则聚焦转换到其他应用程序时所有修改的文档将被保存。


自动完成

自动完成（配置－编辑器）

自动完成分支位于配置－编辑器之下，有如下的选项：

不自动完成结构成员 (“.”或“->”之后的项目)

这个设置会使 UltraEdit 不自动完成“.”或“->”之后的关键字。由于 Java 程序员会经常使用自动完成功能，所以将这个设为默认配置。如果这个设置未选中，那么这些项目后面的关键字不会自动修正。

自动显示自动完成对话框

这个设置会自动显示自动完成弹出对话框让用户输入，而不是等待用户特意调用。 默认设置是不选中这个选项 (不显示)。 如果需要，用户可以指定最小字符数，该数字必须在自动完成对话框显示之前输入。


书签

书签（配置 - 编辑器）

书签分支位于配置－编辑器之下，有如下的选项：

保存书签

该选项允许用户在文件关闭时，保存所有带活动书签的文件的书签功能。按默认，不启用这个功能。如果禁用了该选项，UltraEdit 将在下次关闭时删除所有已保存的书签。

版本 11 以前的书签样式

UltraEdit-32 v11.00 之前的版本中，书签在活动文档里用用户配置的背景/前景颜色表示，不同于正常文本使用的颜色。随着 v11.00 的发布，书签即通过高亮显示书签所在行的行号来表示。选择该选项使书签显示返回到老样式。


列模式

列模式（配置 - 编辑器）

列模式分支位于配置－编辑器之下，有如下的选项：

不改写未选定列

如果在列操作时不希望使用改写模式，可以选择该选项。

如果在改写模式则改写

如果选中该选项，列操作将根据插入/改写键盘设置用插入模式 (默认) 或改写/覆盖模式进行操作。这是用插入键进行切换，并在状态栏中显示。如果在改写模式，剪切/删除操作将删除内容，但保留空格，因此列数据不会移位。粘贴操作将覆盖当前位置的数据，不移动列。

总是改写未选定列

如果要求列模式永久使用改写模式，可以选择该选项。


定界符

定界符（配置 - 编辑器）

定界符分支位于配置－编辑器之下，有如下的选项：

指定命令行中的行/列分隔符： /

该设置确定文件名后面的字符，允许用户添加 /xxx 以转到指定行号或列号。如果该字符与文件或路径名相冲突，可以修改为不会在文件名或路径名中出现的字符。

CTRL+双击时使用的左定界符： {}<>'"

CTRL+双击时使用的右定界符： {}<>'"

默认支持通过双击鼠标的主键 (通常是左键) 来进行文本选择。通常选择一个由任意字母数字的字符或下划线“_”组成的单独词汇。

如果按下控制键，同时双击鼠标主键，将选中字符串，而不是单个词语。这在选择文件名、邮件地址等时非常有用。该分隔字符串的字符可以用以上两个选项配置。此功能只作用于单行。

这些字符，一个是在选定文本的左边，一个则在右边。用来停止文本的进一步选取。如果在每个对象中只指定一个空格，那么光标位置的两边都被选定，直到遇到空格。

如果选定文本后按下鼠标右键，弹出菜单顶部会出现一个新的打开文件加亮文字菜单，如果这个文件存在，则打开。


其它

其它（配置 - 编辑器）

其它分支位于配置－编辑器之下，有如下的选项：

禁用拖放

拖放编辑允许用户在常规方式下选择文本，通过用鼠标拖拽它到新的位置。无需键盘交互。如果选择了该选项，它将禁用拖放编辑特性。

按 Home 键总是转到第一列

当选中这个选项，按 home 键后，总是定位到第一列位置。如果未选中，按 home 键将转到第一个非空格字符，除非已经处于这个位置，在这种情况下将转到第一列。

禁用向左箭头键将光标移到上一行

如果光标位于行首，这个设置会导致 UltraEdit 在按下向左箭头键时不会移动到上一行。如果未选择这个选项 (默认)，UltraEdit 允许光移动到上一行末。

取消选择光标位于当前位置

如果选中该选项，使用箭头键盘离开选中的内容将取消选取并将光标移动到当前位置。 如果未选中该选项，光标将总是从选中内容的开头移到结尾。

允许在页边距内用鼠标选择行

这个设置确定是否 UltraEdit 允许在编辑窗口中的左边缘单击/拖曳鼠标来选择行。默认设置是选中的，允许选择。

锁定插入模式键

该设置会使 UltraEdit 锁定插入模式中的插入键，并且不允许切换到改写模式。如果设置了这个选项，列模式就象普通文本编辑一样。默认设置是不激活这个选项。

当没有活动的选择时，启用当前行复制/追加

该设置会使 UltraEdit 在选定适当的菜单项目或使用快捷键时，如果没有选定的文本，将复制/追加活动行到活动剪贴板。默认设置是激活该选项。

选中内容时自动复制到剪贴板

如果选中该选项，则选中时任何被选文本都将自动复制到剪贴板上，覆盖活动剪贴板的当前内容。

在刷新时请不要把焦点移动到功能列表

假如该选项被选择，当功能列表被刷新时，焦点将不会自动从当前文档移动到功能列表(也就是 当 F8被按下)。


新文件创建

新文件创建（配置 - 编辑器）

新文件创建分支位于配置－编辑器之下，有如下的选项：

如果命令行指定的文件不存在则创建新文件

该设置告诉 UltraEdit 如果指定要在命令行中打开的文件不存在，则创建一个新的文件。默认设置是创建新文件。

没有创建其他文件时创建 EDIT 文件

该设置告诉 UltraEdit 在启动时如果没有打开其它文件，将创建一个新的空文档 (EDIT1) 文件。

总是以 UNICODE 创建新文件

该设置会使 UltraEdit 以 UNICODE (16 位) 文件创建所有新文件，不考虑新建文件配置的文件类型 (DOS/UNIX/MAC)。


自动换行/制表符设置

自动换行/制表符设置（配置－编辑器）

自动换行/制表符设置分支位于配置－编辑器之下，有如下的选项：

选择要设置或默认的扩展名

编辑器允许制表符和自动换行设置基于文件的扩展名进行。初始将使用默认值。要添加扩展名类型，点击更改列表将显示一个对话框，允许添加或编辑最多 10 个扩展名类型。用户可以选择或添加文件扩展名（或默认值）到那些应用该页面上指定的所有设置的文件。制表符和自动换行设置将更改以反映显示的扩展名。“默认值”设置用于任何不匹配用户定义扩展名的文件。

自动完成文件

如果需要，可以在此处指定到选定文件扩展名的特定自动完成文件的路径。用户可以直接输入路径或浏览需要的文件。

用空格代替制表符

如果选中该项目，编辑器将 TAB 字符替换为空格，并且下面指定的缩进空格值将确定要使用的空格数。

编辑器允许在编辑时选择制表站，以及用空格自动替换制表符。制表站值指定制表站，而缩进空格指定替换制表符使用的空格数。这允许用户为制表符使用一个设置，而为缩进使用另一个设置。

缩进空格是指当使用 TAB 键时用于缩进的空格数量，这只在设置用空格代替制表符时有效。在这种情况下，制表站值告诉 UltraEdit 在适当的制表站边界展开实际制表符。

如果未选中用空格代替制表符，那么按 tab 键将总是插入一个制表符，并按原先指示的每个制表站值展开。

用户可以用逗号分隔格式定义多个制表站值 (最多 12 个)，例如“4,4,8”。最后一个定义的值将被用于随后的制表符中。在上面的示例中，开头的两个制表符应该等于四个空格，所有随后的制表符应该等于八个空格。

如果用空格替换制表符选项选中，UltraEdit 插入空格代替制表符，但仍用指定的空格数保持制表站宽度。这对于该设置改变之后输入的制表符有效。这些设置不影响文档内现有的制表符。

字体

用户可以指定用于带当前指定扩展名的文件中的字体。请按字体按钮并选择想用的字体。

换行方法

自动换行功能用来在活动窗口的垂直边缘位置或在指定的列将文本自动换行到下一行。

这里有几个自动换行的可选操作模式:

在窗口边缘处换行，不插入硬回车。

在指定列号后换行，不插入硬回车。

在指定列号后换行，插入硬回车。

除这些选项，还有一个附加的选项用来指定是否在输入时自动换行。 如果选定，文件将在输入时换行，否则文本只在被修改才换行。

注意 - 上面的列换行是在单词边缘处换行。这可能会导致不在指定的列处换行，而在小于指定列号处换行。

在指定列后绝对换行。这将严格在指定的列处换行。

这将严格在指定列后换行。 如果设置了在指定列号后换行，并插入一个硬回车，该文件将被自动修改到在列号后换行，并插入适当的硬回车。

另外，可以使用 段落重排 功能将段落在指定列号后换行。

如果活动窗口处于 十六进制模式 ，不能使用该命令。


高级

高级（配置 － 搜索）

高级分支位于配置 - 搜索之下，有以下选项用于“在文件中查找/替换”：

将活动文件的路径作为默认目录

该设置使编辑器使用活动文件路径来设置“在文件中查找/替换”的默认目录。默认情况下，编辑器为其在对话框中使用先前用过的路径。

忽略隐藏的子目录

如果选中该选项，则在文件中查找/替换功能将忽略隐藏目录。

搜索中忽略的子文件夹

可以使用此文本字段来指定应该由“在文件中查找/替换”功能忽略的特定子目录名称。 当指定多个名称时，在此指定的任何名称都应用分号“;”隔开。


搜索

其他（配置 - 搜索）

杂项分之位于配置 - ">搜索之下，有以下选项：

显示简单查找对话框

该选项用来确定是否在查找命令开始执行后显示一个简单查找对话框，带查找下一个和查找上一个按钮。如果选中它，该对话框将在屏幕的顶部显示。

到文件尾后继续查找

该选项决定搜索字符串是否在文件的另一端继续，如果没有找到改字符串。如果设置了该选项，编辑器查找字符串时，将不会在文件尾部返回。编辑器默认的动作是在未找到目标时，继续从文件的另一端搜索。

Unix 样式正则表达式

如果选择了该选项，当在“查找/替换”对话框里选中正则表达式选项时，编辑器将使用 UNIX 样式正则表达式。

查找对话框默认为光标下的文字

当设置这个选项后，UltraEdit 自动用光标位置下的文字作为查找/替换对话框中的初始查找文字。 如果未设置，在有选定文字的情况下使用选定的文字，在没有选定文字的情况下使用上一次查找输入的文字。

查找下一个/上一个查找选定的文字 (不是上一次搜索的文字)

当设置这个选项后，当执行查找下一个/上一个命令时，UltraEdit 将查找选定的文字，而不是以前搜索的文字，除非选择了正则表达式。

在文件默认目录中查找/替换时使用活动文件路径

该设置会使 UltraEdit 将活动文件路径设为在文件中查找/替换的默认目录。按默认，UltraEdit 在这个对话框中使用以前使用的路径。

当转到包含字符串的列表行结果对话框时，设置焦点到编辑窗口

该设置会使用户在列表行包含字符对话框双击时，UltraEdit 优于列表行包含字符对话框，在编辑窗口设置焦点。按默认，已设置这个选项，但一些用户请求在某些场合保留焦点在列表行包含字符对话框中。


自动重置设置

自动重置设置（配置 - 搜索）

自动重置设置分支位于配置 －搜索之下，有如下的选项：

如果对话框中的选项被选为上次执行的搜索，则完成查找或替换操作后，所选的项目将被重置（或取消选中）。 可以指定为自动重置的项目为：

高亮显示所有找到的项目

该选项可以在按查找下一个按钮时高亮显示所有与搜索字符串匹配的字符（显示为选中的文本）。

列出包含字符串的行

这个选项命令 UltraEdit 在活动文档中搜索所有该字符出现的内容，并在对话框中列出。在结果行中的某行双击 (或选中它然后单击转到)，UltraEdit 将转到文件中的该行。

大小写匹配

按默认，搜索是不区分大小写的。这个选项可以使搜索区分大小写。如果已经在文档中执行了搜索，区分大小写的默认选择是根据上一次搜索设置。

只匹配整个词语

默认情况下，搜索没有限定为只匹配整个词语。该选项允许搜索限制为只匹配整个词语。在搜索“a”或“A”而无需搜索所有包含“a”的词语时，该选项非常有用。如果已经在文档中执行了搜索，默认选项将与前一次搜索的选项相同。


设置查找输出格式

设置查找输出格式（配置－搜索）

设置查找输出格式分支位于配置－搜索 下，允许用户配置格式，用于显示在文件中查找命令的输出。

可以使用以下变量指定下面说明的输出项目：

$P 文件路径

$F 要查找的字符串

$L 行号

$S 找到的行号

$C 搜索到字符串的出现次数

$N 已扫描的文件数

单个文件输出

这些选项用于“在文件中搜索”输出中包括的各个文件的显示控制数据。

标题

如果选中该选项，则对于找到的与“在文件中搜索”搜索字符串匹配的内容，将指定的格式用于标题。

找到的行号

如果选中该选项，则执行“在文件中查找”操作找到匹配的内容时，将指定的格式将用于描述行。

文件摘要

如果选中该选项，则将指定的格式用来总结“在文件中查找”输出中包括的每个文件的匹配字符串。

最终输出

这些选项用于“在文件中搜索”输出中包括的各个文件的显示控制数据。

查找摘要

如果选中该选项，则指定格式将用于显示“在文件中查找”操作中找到的所有文件中的匹配总摘要。

按默认按钮将“在文件中查找”输出格式的选项恢复为默认设置。


正则表达式引擎

正则表达式引擎（配置 - 搜索）

正则表达式引擎分支位于“配置 - 搜索”之下，有如下选项：

Perl 兼容正则表达式

如果选中该选项，则编辑器将基于 Boost C++ 库使用 Perl 样式的正则表达式（当在查找/替换对话框里选中正则表达式时）。

UltraEdit 样式正则表达式

如果选中该选项，则编辑器将在查找/替换对话框里选中正则表达式时使用 UltraEdit 样式的正则表达式。

UNIX 样式正则表达式

如果选中该选项，则编辑器将在查找/替换对话框里选中正则表达式时使用 UNIX 样式的正则表达式。


字典

字典（配置 - 拼写检查器）

字典分支位于配置－编辑器之下，允许选择使用的主拼写词典：

Aspell 是连同 UltraEdit-32 和 UEStudio 一起安装的。按默认，Aspell 的可执行文件位于 UltraEdit 安装目录下的 \Aspell\bin\ 子目录。Aspell 的更新版本将定期发布。希望在发送版本之前更新版本的用户可以覆盖 \Aspell\bin\ 子目录下的应用程序。Aspell 可以从 http://aspell.net/win32/ 下载，请点击完整安装程序链接。

用户可以选择显示的任何语言，或者如果还没有选择首选语言，那么将使用用户定义的字典。

添加/删除字典

在 http://aspell.net/win32/ 中有很多字典可供下载。点击需要的字典并安装到安装目录。请注意选择安装到 UltraEdit 安装目录，实际上新字典将安装到\Aspell\dict 子目录中。字典安装后，它就可以在字典面板中进行选择。

添加/删除词语

用户可以添加/删除自己希望的词语。必须在字典面板中选择一个字典。如果已输入一个词语到已添加词语字段，那么按添加按钮，该词语将添加到已添加词语列表。词语可以通过选中后按删除按钮删除。已添加词语列表按每种语言分别保存。


过滤器

过滤器（配置 - 拼写检查器）

过滤器分 支位于配置－编辑器－拼写检查器下，允许您指定过滤器，用以忽略 Aspell 所检查文档中的某些项目。 如果选中“使用过滤器”复选框，则以下选项有效。 （每次仅可以使用一个过滤器。）：

自动检测

该选项可以自动检测文件是否为 HTML 或 Tex 文件，并应用相应的过滤器。

Email

Email 过滤器将忽略带引号的文本。当前不支持忽略报头。

HTML

HTML 过滤器类似于 SGML 过滤器模式，但仅特定用于 HTML。默认情况下，“script”和“style”是 HTML 模式下忽略列表的组成部分。

SGML

SGML 过滤器允许对 SGML、HTML、XHTML 和 XML 文件进行拼写检查。大多数情况下拼写检查器将忽略标签“<tag attrib=value attrib2="a whole sentence">”中的内容。Aspell 支持的 SGML/HTML/XML 是大多数 DTD（文档类型定义）的 轻量扩展集，可以对网页上常见的不合格 HTML 语言进行拼写检查。

URL

URL 过滤器跳过 URL、主机名和电子邮件地址。

nroff

Nroff 过滤器允许对 Nroff 文档的拼写进行检查。 该过滤器模式忽略下列 nroff 语言元素：

  • 注释

  • 要求

  • nroff 寄存器名称（传统双字母名称和 GNU nroff 长名称均可）

  • 以下请求所用的参数：ds、de、nr、do 和 so。

  • 字体开关（\f）和大小开关（\s）的参数转义

  • 扩展字符集的参数 以传统 (\() 和扩展 (\[comp1 comp2 ...]) 西哦女冠是的转义。

Tex

Tex 过滤器将忽略 TeX 命令，以及某些命令的参数和/或选项。默认情况下也忽略了 TeX 注释。

C/C++

C/C++ 过滤器允许您对字符串或注释中的文本进行拼写检查。 该过滤器模式忽略了源代码中拼写错误的检查。


忽略选项

忽略选项（配置 - 拼写检查器）

忽略选项分支位于配置 - 拼写检查器下，用于配置执行拼写检查时使用的选项。 选项可以忽略大小写、重音、所有大写词语、首字母大写的词语、带有数字的词语和带有混合大小写的词语。所有这些选项都可以通过相应的复选框切换。


拼写检查器

其他（配置 - 拼写检查器）

其他分支位于配置 - 拼写检查器下，用于配置执行拼写检查时使用的选项：

启用输入时拼写检查

如果选中该选项，则将在输入文本时自动进行拼写检查。 请注意：默认情况下，UltraEdit 和 UEStudio 将不会在语法高亮的文件中执行该选项。 要更改此设置并支持语法加亮的文件实行“输入时拼写检查”，请将以下内容添加到 wordfile 的语言定义行（如 /L3"HTML" ...）中：

EnableSpellasYouType

在拼写错误的词语旁单击鼠标右键显示拼写建议

如果在选中启用输入时拼写检查后选择该选项，在对标识为拼写错误的词语上单击右键将显示可能的拼写选项。 如果喜欢可以选择仅当按下 CTRL 键，使仅在拼写错误的词语上单击右键并且同时按下 CTRL 键的情况下才显示这些拼写建议。 用户还可以使用显示建议（最大）控件指定显示建议的最大数量。 如果设置为 "-1" 则将不显示所有可用的建议。

建议模式

建议模式可以设置为“ultra”、“fast”、“normal”或“bad-spellers”。

Ultra | 该方法将使用建议的最快方法。目前意味着它将在一个编辑距离间隔内查找同音字，而不进行任何拼写错误分析或使用替换表。在这个模式中，Aspell 大约可以从小的拼错词语测试内核获取 87% 的词语。（更多有关测试内核，Aspell 现在版本与以前版本以及其他拼写检查程序的比较信息，请转到 http://aspell.net/test 。）
Fast | 该方法与“ultra”类似，但其执行输入分析以及使用替换表。拼写错误分析生成的词语是那些列表开头由于排印错误的词语。这个模式可以获取大约与使用超快方法差不多的词语数量。
Normal | 这个方法通常查找两个编辑距离间隔内的同音字，并执行拼写错误分析，除非它被关闭。它慢于“fast”模式，但可以返回更好的建议。在这个模式中，Aspell 自动侦测 93% 拼错的词语。
Bad-Spellers | 这个方法也查找两个编辑距离间隔内的同音字，但它更注重错误拼写，“fast”或“normal”更注重在排印错误和实际错误之间达到较好的平衡。这个模式从不执行拼写错误分析，而返回大量词语给那些真正的拼写不佳的人，他们通常无法给出与实际词汇接近的拼写。如果有拼错的词语，它会列出 100 个或更多相似词语的建议。在这个模式中，Aspell 将侦测大约 98% 的拼错词语。

编码

用户可以从该下拉列表中选择活动字典使用的编码。

短于（数字）个字符的单词免于拼写检查

用户可以指定要进行拼写检查的词语的最短长度（从 1 到 9）。

私人数据目录

在此指定的目录用于保存添加到目录的词语。


高级

高级（配置 － 文件处理）

高级分支位于配置－文件处理之下，有如下的选项：

检查已加载文件的短名字，以防止加载两份同样的文件

该设置强制在打开一个现有的文件时进行短名字匹配检查，以防止打开相一文件两次。在一些服务器，短名字相同会导致 UltraEdit 不能打开文件。禁用这个选项 (不选中) 将导致不进行检查。

保存文件前删除原始文件

当文件保存后，原始文件用新的文件覆盖。一些场合中，一些服务器需要先删除文件后再创建一个新文件。设置这个选项会使文件被删除，并用新文件替换。

当创建备份文件时复制文件而不使用重命名

该设置会影响 UltraEdit 生成备份文件的方式。按默认，UltraEdit 会重命名原始文件到备份文件。这是因为在一些系统中，如果 UltraEdit 重命名原始文件创建备份，该原始文件在重建时不能维持先前存在的文件权限。设置这个选项会导致不进行重命名，保留文件权限。

当复制到临时文件或从临时文件复制时总是创建新文件

当复制到临时文件或从临时文件复制到用户文件时，UltraEdit 不创建一个新文件，只截短老文件、复制文件并设置文件长度。在少数服务器中，它们可能不会象这样，或支持这个选择，但不能正确处理文件长度设置，如果用户删除文件中的一个区段并保存它，会导致保留老文件的残留部分。设置这个选项会导致写入文件前，文件截取到 0 长度。

使用 DDE 进行文件关联 (改变它需要改变该文件关联，以使其生效)

当从 UltraEdit 内部设置文件关联时，通常会使用 DDE 在注册表中设置指定的文件类型。一某些系统中，从资源管理器双击文件时，可能会导致出现错误消息。在这种情况下，请确定未选中使用 DDE 关联可以解决此问题。文件关联将需要这个修改才能生效。


备份

备份（配置－文件处理）

备份分支位于配置－文件处理之下，有如下的选项：

保存时备份文件

如果使用该选项，那么在保存文件时会生成一个备份文件。

不备份 - 在保存文件时，覆盖原始文件，不创建备份文件。

用 .BAK 替换扩展名 - 在保存文件时，原始文件被复制或重命名为相同文件名加“.BAK”扩展名的文件，而不是使用现有的扩展名。 修改后的文件以原始文件名和扩展名保存。

追加 .BAK 到现有的扩展名后面 - 在保存文件时，原始文件被复制或重命名为相同名字和扩展名的备份文件，并在后面添加 .BAK。 (filename.ext.BAK)。

默认备份目录

通常备份文件使用的目录与源文件同一目录。该参数允许所有的备份文件复制到同一备份目录中。如果该项目留空，那么备份将使用源文件使用的目录。

自动保存

这个选项提供在指定时间间隔后保存所有打开的文件的功能。该时间间隔是以分钟为单位配置的。如果时间间隔设为零 (0)，则表示不执行自动保存。

如果选择不自动保存未命名（新）文件，那么自动保存将忽略没有名称的文件（即：使用“新建”命令创建的文件）。如果存在已修改的未命名文件，该选项阻止了另存为对话框出现。

如果选择了不自动保存 FTP 文件，则自动保存将忽略打开编辑的已修改 FTP 文件。

如果用自动保存命令保存，那么只在第一次自动保存时创建了一个 .BAK 文件，以后的保存不会再创建或覆盖 .BAK 文件。


页面编码检测

页面编码检测（配置 - 文件处理）

页面编码检测分支位于配置 - 文件处理之下，有以下选项：

自动检测页面编码

该设置强制编辑器评估是否应以与系统默认页面编码不同的页面编码显示活动文件的内容。

提示接受页面编码（如果未选择，则接受评定的最佳匹配）

该设置仅当启用自动检测页面编码时才活动。如果选中该选项，并且编辑器检测到需要新页面编码，则将显示一个对话框供用户为活动文档选择要使用的亚面编码。如果未选中它，但启用了自动检测页面编码，则将使用评定的最佳匹配页面编码。

如果与系统页面编码不同，则提示更改字体和脚本

如果选中该选项，并选中需要新字体和脚本才能正常显示的新页面编码，则会显示对话框提示此更改。

从 Unicode 转换到 ASCII 时总是使用系统默认页面编码

如果未选择该选项，且已将一个文档从 Unicode 转换到 ASCII，则会提供用户一个对话框选择要更改的页面编码，因为 Unicode 和 ASCII 文件需要不同的页面编码。如果选中它，将使用系统默认页面编码进行转换。


转换

转换（配置－文件处理）

转换分支位于配置－文件处理之下，有如下的选项：

Unix/Mac 文件检测/转换

禁用

侦测文件类型并提示进行更改

自动转换到 DOS 格式

这些选项确定 UltraEdit 是否应该在打开文件时自动检测并转换 UNIX/MAC 文件到 DOS 格式。用户可以随意选择每次发现 UNIX/MAC 文件时，转换前先提示用户。如果不希望检测和转换，可以禁用这个选项。

使用 IBM-500 标准进行 EBCDIC 转换

该设置强制 UltraEdit 使用 IBM-500 标准进行 EBCDIC 转换。UltraEdit 的默认转换是来自已公布的 EBCDIC 字符表，但不提供直接一对一的比较。

在 EBCDIC 转换期间不转换回车符（CR/LF）

该设置是在转换文件到 ASCII 格式时，不考虑 EBCDIC 回车符的转换。EBCDIC 要求进行硬回车 (CR/LF) 转换，但一些用户需要的不是这种情况。

粘贴时转换换行符到目标类型 (UNIX/MAC/DOS)

如果选择了该选项，编辑器将在从剪贴板粘贴时检查目标文档的格式，并在需要时修改剪贴板内容的换行符以匹配目标文件的格式。


DOS/UNIX/MAC 处理

DOS/UNIX/MAC 处理（配置－文件处理）

DOS/UNIX/MAC 处理分支位于配置－文件处理之下，有如下的选项：

新建文件的默认文件类型

DOS

UNIX

MAC

该设置用来确定在 UltraEdit 内部创建新文件时使用的默认文件类型，默认是 DOS 文件。 另外，也可以选择默认的 UNIX 或 MAC 文件类型。

打开快捷方式 (.lnk) 文件，而不是链接指向的文件

禁用

侦测文件类型并提示进行更改

自动转换到 DOS 格式

这些选项确定 UltraEdit 是否应该在打开文件时自动检测并转换 UNIX/MAC 文件到 DOS 格式。用户可以随意选择每次发现 UNIX/MAC 文件时，转换前先提示用户。如果不希望检测和转换，可以禁用这个选项。

仅认可 DOS 终止行 (CR/LF) 为新行进行编辑

该设置会使 UltraEdit 仅识别 DOS 终止行 (CR/LF) 为新行进行编辑。默认地，UltraEdit 会自动识别 UNIX/MAC 的终止行进行显示。


加密

加密（配置 - 文件处理）

加密分支位于配置 - 文件处理 之下，有如下选项：

加密后删除原始文件

该设置决定是否在加密成功后自动删除原始的纯文本文件。

使用 UltraSentry 安全删除原始文件（需要 UltraSentry v2.00a+1 或以后版本）

如果选择该选项，在成功加密后将从后台调用 UltraSentry 以安全删除原始文件。 不仅仅是简单地删除原始文件，该操作将永久性删除原始纯文本文件的内容，并使之不可恢复。 如果未安装 UltraSentry，该选项将变灰而无法选中。

有关集成 UltraSentry 和 UltraEdit 的进一步信息，请单击此处。


文件更改检测

文件更改检测（配置－文件处理）

配置 - 文件处理下的文件更改检测分支提供了选项，在其他用户更新活动文件时（如果一次有多个用户编辑文件），或外部进程更新活动文件时（例如，应用程序或日志文件），可以控制应用程序的行为。 该分支有如下选项：

文件更改检测

禁用

当文件更改时提示更新

自动更新已更改的文件

编辑器自动检测已载入文件在编辑器之外进行的任何更改。默认情况下，选择当文件更改时提示更新，并且当检测到更改时编辑器将提示用户是否重新载入文件（在这种情况下将丢失编辑器中任何未保存的更改）。用户可以选择重新载入文件或忽略更改。

此外，通过设置禁用选项，编辑器能忽略任何文件更改。在这种情况下，编辑器不会检测或提示有文件更改。

如果喜欢，通过设置自动更新已更改文件选项，编辑器可以自动更新已载入文件在编辑器以外进行的更改。在这种情况下，将载入文件，且在编辑器内进行的更改如果未保存将被自动覆盖而没有任何提示。

当发现某个文件已更改并重新载入，将其设为活动文件

该设置指导编辑器将发现的任何已更改并重新载入的文件设为活动文件。默认设置是不设为活动文件。

如果文件已删除则忽略文件更改

该设置指导编辑器在发现已打开文件作了更改时不用通知用户。如果未设置该选项（默认），当启用文件更改检测时编辑器将通知用户文件已删除。

仅当 UltraEdit 获得焦点时才检查文件的更改

如果选择该选项，仅当 UltraEdit 获得焦点时（从其他应用程序或 UltraEdit 内的对话框切换到 UltraEdit）才检查文件的更改。

以强制时间间隔 (秒) 轮询文件更改 (0 禁用)

该设置确定以秒为单位的时间间隔，编辑器按此间隔检查文件更改，该文件的轮询必须已用在视图菜单中的文件更改轮询命令激活。 如果设为“0”，则禁用该功能。

当标记为轮训的文件发现已被更改时，滚动到文件的最后一行（用于尾部记录的日至文件）

该设置强制编辑器滚动到轮训文件的最后一行，使它在文件活动时总是可以在编辑窗口中看到。这类似于 UNIX 中的 tail 命令。


加载

加载（配置－文件处理）

加载分支位于配置－文件处理之下，有如下的选项：

启动时重新加载先前打开的文件

如果选中这个选项，UltraEdit 在关闭时会保存有关打开的文件的信息。这个信息用于在下次启动 UltraEdit 时自动重新载入文件。这可以用来很方便地重新载入上次编辑未完成的文件集。如果该文件是通过 UltraEdit 打印功能调用的，则该文件不会重新载入。

当重新加载方案或上一次打开的文件时，重新加载 FTP 文件

这个设置用来确定 UltraEdit 在重新载入方案/工作区的文件时是否应该重新载入 FTP 文件。一般来说，由于可能会发生连接和载入文件时的时间延迟，UltraEdit 不自动重新载入 FTP 文件。选中该选项后，将保证把 FTP 视为这方面的普通文件处理。

用快捷方式首次打开程序时使用默认目录

通常用“文件打开”命令打开的目录是 UltraEdit 上一次打开文件时的目录。这个目录信息会在 UltraEdit 关闭和重新启动时保留。当设置文件首次打开时从快捷方式使用默认目录选项后，忽略常规动作，并使用进程默认的目录来首次打开文件。这允许用户通过点击调用编辑器的图标或快捷键来指定默认目录。

文件打开对话框默认使用活动文件目录

设置了该选项时，常规动作被忽略并使用当前活动文件目录。它允许用户从已经打开文件的相同目录轻松打开文件，通过激活该文件然后使用“打开文件”（File Open）命令。

请注意：上述两个项目中只能选择一个。

打开快捷方式 (.lnk) 文件，而不是快捷方式指向的文件

该设置会导致编辑器直接打开快捷方式文件修改。默认设置 (不设置这个选项) 会导致 UltraEdit 展开链接打开根文件。

默认打开文件为只读

只读命令是用来切换文件的只读状态。如果设置为只读状态，文件不能被修改。如果设置了此选项，文件将自动以只读模式打开。该动作不会更改文件本身的状态，只是更改其在 UltraEdit 内部修改的能力。

当重新加载当前打开的文件时，记住只读设置

该设置会导致 UltraEdit 重新加载文件时保持文件为只读状态。按默认，当文件重新载入时，文件状态会回复到基本文件状态。这是因为许多用户使用该功能在版本控制系统上，而唯一改变的只有只读状态，并且用户希望在 UltraEdit 内部的状态能一同改变。


其它

其它（配置－文件处理）

其它分支位于配置－文件处理之下，有如下的选项：

当更改菜单设置时改变文件只读属性

该设置告诉 UltraEdit 在菜单设置中的只读更改时，更改文件的只读属性。默认设置 (未选中) 会导致当菜单中更改只读设置时，允许用户更改编辑器状态，以保护或允许文件修改，但不会直接更改实际文件。

编辑时锁定文件写入

该设置会导致编辑器锁定已打开的所有文件。另外，如果文件已经锁定，打开时会用一个对话框提示用户，确认并允许用户以只读模式打开。这个功能可以防止文件在编辑期间被其它程序修改而导致原先所作的修改丢失。

打开或切换方案时关闭全部文件

如果选择该选项，当打开或切换产品时，所有当前打开的文件将关闭，而没有警告提示。如果未选择，用户将被提示是否应关闭打开的文件。


保存

保存（配置－文件处理）

保存分支位于配置－文件处理之下，有如下的选项：

保存时将 UTF-8 BOM 头写入 ALL UTF-8 文件

该设置会指示编辑器在保存文件时写入 UTF-8 BOM（字节次序标记）到所有文件。如果未设置该选项，BOM 写入磁盘时将无法写入文件。它不会删除该文件中已存在的 BOM。

在这个程序内部创建的新文件中写入 UTF-8 BOM (如果上述选项未设置)

该设置会指示编辑器在保存文件时仅写入 UTF-8 BOM 到编辑器内创建的新文件。如果未设置该选项，BOM 写入磁盘时将无法写入文件。它不会删除该文件中已存在的 BOM。

保存文件为输入的格式 (UNIX/MAC/DOS)

这个选项告诉编辑器在保存时自动保存为文件的原始格式 (UNIX/MAC)，除非在打开后已手动转换。

在文件保存时删除行尾空格

这个功能会使 UltraEdit 自动删除文件中每个行末的多余的空格或制表符，并在每次完成文件保存后，将光标定位到原始光标位置。删除行尾空格功能不在没有换行文本行中进行操作。如果文件中的最后一行是用硬回车终止，删除行尾空格将也将同样在该行执行。


临时文件

临时文件（配置－文件处理）

临时文件分支位于配置－文件处理之下，有如下的选项：

使用临时文件编辑（供特大型文件处理）

使用临时文件编辑（正常操作）

不使用临时文件打开文件，但提示每个文件（注意： 编辑是永久性的，可以减少大文件的加载时间）

不使用临时文件打开文件，且不提示（注意： 编辑是永久性的，可以减少大文件的加载时间）

上述有关阈值（KB）： 15000

UltraEdit/UEStudio 可以编辑非常大的文件。而且可以使用相对较少的内存来完成。UltraEdit/UEStudio 是一个基于磁盘的编辑器，一次只加载文件的小部分到内存中。通常该编辑器会复制要编辑的文件为一个临时文件，在编辑会话结束时，重新复制到原始文件后删除该临时文件。

要加速大文件的编辑，该配置分支允许指定不使用临时文件的情况下进行编辑。这将节省复制文件到临时文件所需的时间。当编辑若干兆字节的文件时，这样做比较有利。

警告 - 如果选定这个选项，所有的更改将是永久性的！

每次用户打开文件时，会显示一个对话框，警告用户这个设置已启用。这可以通过选择不带提示不用临时文件打开文件的选项来禁用。

“阈值”字段允许用户指定加载大于或等于该值的文件，而不创建临时文件。小于该值的文件正常加载，并创建一个临时文件。将该值设为 0，表示所有的文件加载时均不创建临时文件。“阈值”字段只有在设置“不使用临时文件打开文件”选项时才适用。

另外，当在大文件中导航时，禁用行号选项可以改进执行性能，因为需要较少的磁盘访问来跟踪行号。

UltraEditt/UEStudio 允许编辑大于 4GB (最高达 2^64-1 大小) 的文件。

关闭文档时使用 UltraSentry 来擦除临时文件

如果选定该选项，文档关闭时将自动调用 UltraSentry 来擦除临时文件。 它将永久删除临时文件的内容并使其无法恢复，而不是仅删除临时文件的句柄。如果未安装 UltraSentry，该选项将被抑制且无法选择该选项。


Unicode/UTF-8 检测

Unicode/UTF-8 检测（配置－文件处理）

Unicode/UTF-8 检测分支位于配置－文件处理之下，有如下的选项：

自动检测 UTF-8 文件

该选项指示 UltraEdit 在打开时自动检测 UTF-8 文件。

无 BOM 情况下检测 Unicode(UTF-16) 文件

该选项指示 UltraEdit 在打开时自动检测 UTF-16 文件，即使它们不包含标准 UTF-16 BOM (HEX FF FE)。

重新加载时禁用十六进制文件格式自动检测

该设置是在重新载入文件时，忽略文件头 3K 字节的 NULL 字符的默认检查动作。如果选中这个选项，原先在重装载入时应该以十六进制/二进制格式显示的文件，将以选定的模式显示而不考虑文件的内容。

检测使用 Escaped Unicode 的 ASCII/ANSI 文件

该选项指示编辑器自动检测使用 Escaped Unicode 的 ASCII/ANSI 文件（如：\u0020）。


文件关联

文件关联（配置）

文件关联分支位于配置之下，允许用户将编辑器与选定的文件类型建立关联：

该对话框显示当前与编辑器关联的文件类型的列表，以及编辑器认为用户可能希望与之建立关联的文件类型列表。用户可以用该对话框添加或删除文件关联。

文件关联是用于让 Windows 资源管理器确定当使用双击文件或执行资源管理器中的打开命令时，使用哪个应用程序打开这种类型的文件。

列表中显示的关联显示所有当前与编辑器关联的文件类型。用户可以选择该列表中的任何项目，用删除按钮删除关联。

要添加文件关联，用户可以从文件类型/扩展名下拉列表中选择一个项目，或输入一个新的扩展名，然后点击添加按钮。可以修改任何已添加的文件类型的描述。

当关联添加后，如果该文件类型存在老的关联程序，编辑器会先进行保存，如果以后使用这个对话框删除了文件关联，编辑器会将它恢复到关联以前状态。

与资源管理器集成

如果选中该选项，UltraEdit/UEStudio 选项将添加到 Windows 资源管理器的上下文（右键）菜单中。


文件类型

文件类型（配置）

文件类型分支位于配置之下，允许出现在 打开文件 和 文件另存为对话框 中的文件类型列表如下进行配置：

可以配置最多 10 个文件类型。这些文件类型将按它们在这个页面中显示的顺序显示在文件操作对话框中。

每个文件类型的配置由文件名和文件描述组成，文件名可以 (大多数情况下需要这么做) 包含通配符，并且可以包含多个文件扩展名，这些扩展名之间用分号“;”隔开 (例如 "*.c;*.cpp")。文件描述是一个描述文件类型的文本对象。

这个对话框还提供默认按钮，可以用来重置文件类型到初始设置状态。


高级

高级（配置 － 显示）

高级分支位于配置－显示之下，有如下的选项：

该设置可以改善 Windows XP 下的 ClearType 字体显示问题

该设置不会实际启用 ClearType，但它可以改进一些 Windows XP 环境下在使用 UltraEdit/UEStudio 的 ClearType 时显示的一些问题。

覆盖默认编辑窗口尺寸

创建新文档时，自动调整大小到适应编辑器的尺寸。该选项使用特定的值覆盖此自动调整大小。请注意如果编辑器的尺寸比指定的高度和宽度小，新文档将使用旧的自动大小调整方式。


代码折叠

代码折叠（配置 - 编辑器显示）

代码折叠分支位于配置－编辑器显示之下，有如下的选项：

启用隐藏/显示行和代码折叠

该设置允许用户隐藏/显示选定的文本，以及折叠/展开代码块。如果未选中该选项，编辑窗口中不出现折叠符号，折叠功能被禁用。

启用非语法加亮文件的显示/隐藏行 (必须已经设置上述选项)

该设置允许使用视图菜单命令对非语法加亮文件的文本隐藏，以及折叠/展开。如果这个选项未先中，非语法加亮文件编辑器窗口的折叠符号不可见，折叠功能被禁用。


光标/插入记号

光标/插入记号（配置 - 编辑器显示）

光标/插入记号分支位于配置－编辑器显示之下，有如下的选项：

普通光标/插入记号类型

竖线

下划线光标

该设置确定在编辑器中光标/插入记号正常显示的方式。

替换光标/插入记号类型

替换模式用块字符，插入模式用普通字符。

翻转 - 替换模式用普通字符，插入模式用块字符。

禁用块字符，总是使用普通字符。

该设置决定编辑器中的“替换模式”设置如何影响光标/插入记号类型。

允许位置超出行尾

该选项允许光标位置超过行中的文本结束位置。

下划线是用于 Ctrl 左右箭头的词语间隔

如果选中该选项，则光标将在按下 CTRL+左/右光标键出现 "_" 时停止。 默认设置为未选中该选项。请注意该选项选择的设置能够影响包含导航操作的宏/脚本的功能。

按 Ctrl+左/右光标键光标停止在名称为大小写混合样式的变量

如果选中该选项，则按下 CTRL+左/右光标键光标将在大小写混合单词的大写字符时停止。


格式化

格式化（配置 － 编辑器显示）

格式化分支位于配置－编辑器显示之下，有如下的选项：

自动缩进新行

该项目切换自动行缩进状态。当启用自动行缩进时，UltraEdit 自动缩进行，以匹配上一行的缩进。缩进的方法是在文档中插入空格。

另外，UltraEdit 支持特定语言的缩进和伸出。这可以在某些字符/字符串后添加缩进，用来缩进代码块，或在关闭字符/字符串后 伸出。请参见 语法加亮 下的缩进段以获取详细信息。

该选项只能用于 插入模式 ，不能在 覆盖模式 中使用。

自动缩进换行

如果选中该选项，则编辑器将在换行处自动缩进以便与上一行的缩进匹配。

当转换/格式重排段落时在连字符 (-) 处断开

该设置确定 UltraEdit 是否应该在格式重排行时在连字符处断开。默认设置为 UltraEdit 在连字符处断开。如果这个设置未选中，UltraEdit 在遇到连字号时不换行。

当换行设置为在指定列号添加硬回车时，粘贴后段落格式重排

该设置会使 UltraEdit 在自动换行设置设为在指定列号后插入硬回车（CR/LF）换行的情况下，粘贴后自动段落重排。UltraEdit 默认是执行这个动作，不选中这个选项将禁用这个功能。


十六进制编辑显示

十六进制编辑显示（配置－编辑器显示）

十六进制编辑显示分支位于配置－编辑器显示之下，有如下的选项：

每行十六进制字符数

该设置定义每行显示的十六进制字符数。一但更改了这个值，UltraEdit 必须重新启动才能生效。


其它

其他（配置 － 编辑器显示）

其他分支位于配置 － 编辑器显示之下，有如下的选项：

编辑器颜色首选项

点击设置颜色按钮启动设置颜色对话框。

换行前最大列数

该设置用来设置在换行（软换行）前，UltraEdit 内部允许的最大列。默认值是 4096 列，但最大只允许 20,000 列。设置太高时有些显卡驱动程序可能会有问题。

数字显示中如同新行一样统计换行的行数

该设置会导致编辑器以不同的行号显示换行。默认情况下不设置该选项。

禁用行号

如果选中该选项，行号将不在编辑器里显示，且显示行号选项将在视图菜单里被抑制。

从列 1 开始标尺编号

该设置会导致编辑器标尺数值以 1 开始。如果未选中这个选项 (默认)，UltraEdit 的标尺以 0 开始。

在方案列表里显示完整路径

如果选中该选项，“文件树视图”（UEStudio 里的工作区管理器）将显示方案文件的完整路径，而非仅仅文件名。


语法加亮

语法加亮（配置 － 编辑器显示）

语法加亮分支位于配置－编辑器显示之下，允许用户配置语法加亮选项：

语法加亮可以识别预定词语，并用不同颜色显示它们。该功能对于程序员来说尤其有用，并且对那些想用不同颜色显示文档中词语的用户也非常有用。

提供二十种语言或可识别的词语集支持。下列词语组的每个词语集都可以配置为不同的颜色：

普通文本（无法识别的词语）

出现在注释行或块注释中的词语

块注释的代用集

字符串

数值（必须以数字（0-9）开头）

最多八组不同的可识别词语

配置对话框允许选择用于不同语言和颜色组的颜色。同时也允许用户指定用于加亮的“词语文件”的位置。

可以任意设置前景/文本颜色和背景的颜色组。默认情况下，背景使用显示普通文本时指定的背景（自动背景颜色被选中）。只有在未选中的情况下才能激活背景颜色。

可以点击文本描述旁边的彩色框更改每种颜色。当点击时，将出现一个允许选择新颜色的对话框。

另外，对每种颜色组（普通文本除外）都有各种粗体、斜体和下划线的字体样式。每个颜色组均可以单独选择。某些设置了下划线的字体可能无法总是正确显示，而对于粗体，非固定宽度字体的间距也可能不正确。

自动更正关键字复选框用来启用或禁用自动更正功能。

注意 - 加亮功能是通过文件扩展名决定的（详情如下）。文件扩展名修改必须在相应语言中的“词语文件”中定义。

用户可以如下配置预定义词语：

UltraEdit 读取一个配置文件（默认文件是“WORDFILE.TXT”），来配置语法加亮。每次编辑器启动时读取该文件。该文件的大小不能超过 372KB。该文件语法如下所示：

语言定义

用 /Ln 指定的词语集或语言，这里的 n 是 1 到 20 之间的值。它必须位于行首。语言的描述或名字可以直接在 /Ln 后面的引号中指定。当设置语言颜色时，则显示该描述（如果有）。描述应该不大于 24 个字符。

行注释

用于以字符串“Line Comment = ”及其后的注释字符指定行注释的注释字符。允许五个字符，如果小于五个字符，那么最后一个字符必须后接一个空格。

第二套行注释可以用字符串“Line Comment Alt = ”及其后的注释字符指定。允许五个字符，如果小于五个字符，那么最后一个字符必须后接一个空格。

在某些情况下，可能需要以一个空格作为行注释的一部分，可以用另外一个方法来描述行注释。这种可选的方法是，用户以下列语法指定使用的字符数：

"Line Comment Num = xCC "

这里的 x 用来指定字符数 (1 到 5)，直接跟随其后的字符用于行注释，在上面的示例中，x 应该是 3，行注释应该是“CC ”（请注意 CC 后面的空格）。

此外，有时需要将限定词用于行注释，这样注释仅在某列出现时有效，或在某些字符之后有效（当然，更多情况下如果跟随在某些字符之后，它们常常是无效的）。为能够达到此目的，这里提供两个额外的行注释命令：

"Line Comment Preceding Chars = […]"

and

"Line Comment Valid Columns = [1-7,10]"

“行注释前导字符”（Line Comment Preceding Chars）的默认值为所有字符都有效。因此，该项目将包括那些在代字号后面无效的字符，如…[~a-z]中一样。这表明该注释如果紧跟字符范围 a-z 之内则该注释无效。在方括号之间的任何符号都有效。

“行注释有效列”（Line Comment Valid Columns）是当其未定义时所有的列都有效。如果定义了它，则只有指定的行才有效。可以有最多 10 个列范围，或以逗号分隔的指定列，如…[1-7, 10] 中一样。这表明注释符号在列 1 到 7，或在列 10 都有效。

块注释

用于块注释的字符也可以配置（即 /* … */ 表示 ‘C’）。它们的格式为“Block Comment On = ”和“Block Comment Off = ”，每种格式后接最多 19 个定义注释标志符的字符。为与先前版本兼容，将 ‘/*’ 和 ‘*/’ 用于以 ‘.C’ 作为扩展名之一的文件类型。它可以被覆盖。块注释的第一个字符可以为空格。

如果定义了“Block Comment On = ”而未定义“Block Comment Off = ”，则注释将在行尾停止。它有效地实现块注释也能用于行注释。

此外，可以为需要的语言定义另一套块注释。这对于 ASP 尤其有用，可以在为 ASP 块添加高亮显示之外允许保持 HTML 注释。

另一套块注释的格式为“Block Comment On Alt = ”和“Block Comment Off Alt = ”，每种格式后接最多 19 个定义注释标志符的字符。块注释的第一个字符可以为空格。

如果定义了“Block Comment On Alt”而未定义“Block Comment Off Alt”，则注释将在行尾停止。它有效地实现块注释也能用于行注释。

UltraEdit/UEStudio 默认情况下会在遇到单个块注释结尾字符串时结束任何块注释。 要使 UltraEdit/UEStudio 将所有块注释开始字符串与所有块注释结束字符串确切匹配，需要指定内嵌块注释命令。 通过添加 NestBlockComments 命令到语言定义行（即 /L3"HTML" NestBlockComments ...）来实现。

文件扩展名/类型

语法加亮取决于文件名或扩展名。更常见的是使用扩展名，而指定扩展名用于该语言时应使用以下字符串："File Extensions = " 且每个扩展名以空格分开。 在此指定的文件扩展名不区分大小写。

文件扩展名是文件名中最后一个点之后的内容。 “File Extensions = ”声明之后可以接多达 97 B 的内容。 如果在此指定的一系列文件扩展名超过 97 B，则无法解析。

用户可以将指定文件扩展名的最后替换为 "*"，从而指定语言为语法加亮的默认设置。 该设置也将用于高亮显示未保存的文件或没有指定扩展名保存的文件的文件类型。

要指定一个文件名（而非文件扩展名）用于确定语言，应该使用以下字符串："File Names = " 且每个名称以空格分开。 必须包括扩展名，即："File Names = ThisFileName.xml" “File Names = ”声明之后可以接多达 125 B 的内容。

文件名/文件扩展名注意事项

在同一个词语文件中使用文件名和文件扩展名选项需要注意以下事项：

1. 文件名选项不能指定包含空格的名称。

2. 文件名选项不能与文件扩展名选项组合使用。

3. 如果使用文件名选项定义了一种语言，使用文件扩展名选项定义相同词语文件中的另一种语言，且两个定义有重叠部分，则使用文件名选项定义的语言必须具备较少的语言数量，例如：

示例 1 - 无法工作：

/L6"XML General" XML_LANG Noquote ...File Extensions = XML XUL XSD XSL XSLT

/L12"XML Special" XML_LANG Noquote ...File Names = ThisIsJustAFile.xml

示例 2 - 可以工作：

/L6"XML Special" XML_LANG Noquote ...File Names = ThisIsJustAFile.xml

/L12"XML General" XML_LANG Noquote ...File Extensions = XML XUL XSD XSL XSLT

颜色选区

指定颜色代码可以通过添加一行，并在该行首带有 /Cn，其中 n 是 1 到 8 的颜色索引。该区段的描述或名称可以紧跟 /Cn 之后在引号中指定。如果有此描述，则在设置该语言的颜色时将显示此描述。描述可以多达 24 个字符。

所有指定的信息保持有效，直到用新命令信息覆盖。

下面的示例指定了第一个语言用于带有 'C', 'CPP', 'H' 或 'HPP' 的文件。这些词语使用的颜色为第一个可选的颜色，且注释字符为 //。

/L1"C/C++" Line Comment = // Block Comment On = /* Block Comment Off = */ File Extensions = CPPC H HPP

/C1

auto

break

case char const continue chr$

default do double

大小写区分

如果该语言不区分大小写，可以在命令行添加关键字“Nocase”，即：

/L1 Line Comment = // Nocase File Extensions = CPPC H HPP

字符串

使用很多编程语言时，单引号和双引号之内的字符视为文字字符串，词语和注释识别应予忽略。这是 UltraEdit 的默认行为。有些语言（如 HTML 等）不希望此类行为。为帮助此类语言，可以在命令行添加关键字“Noquote”来覆盖默认行为，即：

/L1 Noquote File Extensions = HTM

UltraEdit 现在支持可配置的字符用于引号字符串。默认用于字符串的字符时单引号 (') 和双引号 (")。它们可以用关键字 "String Chars = " 后接最多两个字符来覆盖。仅当需要使用不同于默认的符号时才需要此操作。如果，例如希望对字符串仅使用双引号时，则可以使用类似下面的行：

/L1"C/C++" Line Comment = // Block Comment On = /* Block Comment Off = */ String Chars = " File Extensions = CPPC H HPP

请注意“String Chars”部分。

此外，如果定义的字符串有两个字符（或使用默认）且希望对每个字符串类型使用不同的颜色，即可用某一颜色组在一行里自行包含该字符（即：双引号）。这将覆盖由该字符包围的字符串使用的可配置颜色。

/L1"C/C++" Line Comment = // Block Comment On = /* Block Comment Off = */ String Chars = '" File Extensions = CPPC H HPP

/C1

auto

break

"

…

上面的示例中，所有以双引号 (") 包围的字符串将使用颜色组 C1 着色，而以 (') 包围的字符串将为字符串使用默认颜色。

换码符

在很多语言里有一个专门指定的字符用来引用“换码符”。它用于覆盖正常的字符串字符（及其它字符）。如果某字符串定义为自身包含通常用于定义字符串的引号字符，则语法加亮将该引号解释为字符串的结束。如果该引号符以“换码符”引导，则该引号符将被正确处理为字符串的一部分，而非其尾部。

换码符定义如下：

/L1"C/C++" Escape Char = \ …

在此例子里，换码符定义为反斜线。

关键字

请注意所有以相同字符开头的词语可能都在同一行或分布在多行里，而如果它们分布在多行，必须一个跟着另外一个，中间没有空行或其它行。

如果该语言区分大小写，字母“A”与“a”不同，且以“A”开头的单词必须与“a”开头的词在不同的行。如果该语言不区分大小写，以“A”开头的单词必须与“a”开头的词在相同的行。

以子字符串开头的关键字

在一些语言里会出现希望加亮以特定子字符串开头的关键字，而完整的单词未知。UltraEdit 提供的能力可以定义子字符串，这些子字符串用于确定单词是否应加亮。如果是，它将相应地加亮。

子字符串应定义为与任何其它关键字集相同，而包含子字符串的行应以“** ”开头且所有子字符串应在同一行，如：

** aaa bbb

以上示例将加亮任何以“aaa”或“bbb”开头的词。

以 '/' 开头的词

因为 UltraEdit 使用 '/' 作为命令字符，要加亮的字符需要特殊处理。要加亮以 '/' 开头的词，该行应以 '// ' 开头并后接关键字，如：

// /我的关键字 /另一个关键字

针对 HTML

HTML 在很大程度上与其它语言不同，为更好地帮助用 UltraEdit 编辑 HTML 文件，添加了 "HTML_LANG" 关键字。如果有这个关键字，特殊字符 '<' 和 '/' 可以按需要置于任何关键字之前，无需所有带特殊（'<' 和 '/'）字符的关键字都在同一行。这种情况下，通常要求以相同字母（a-z 等）开头的词必须在同一行或连续的行里。

以下示例为 HTML 的词语文件片段：

/L3"HTML" Line Comment = // HTML_LANG Block Comment On = <!-- Block Comment Off = --> File Extensions = HTM HTML

/C1

<A </A> <ADDRESS> </ADDRESS> <APPLET </APPLET>

<B> </B> <BASE <BASEFONT <BGSOUND <BIG> </BIG> <BLINK> </BLINK> <BLOCKQUOTE> </BLOCKQUOTE>

<CAPTION> </CAPTION> <CENTER> </CENTER> <CITE> </CITE> <CODE> </CODE>

以后将为 HTML 提供其它的增强。

针对 FORTRAN

FORTRAN 在注释方面与其它语言有很大不同，为更好地帮助用 UltraEdit 编辑 FORTRAN 文件，添加了关键字“FORTRAN_LANG”。如果有这个关键字，UltraEdit 将第一列里的 'C', 'c' 或 '*' 视为行注释指示符，而该行的其它部分加亮显示为已注释掉。

以下示例为 FORTRAN 的词语文件片段：

/L4"Fortran" FORTRAN_LANG File Extensions = FOR FTN

/C1

…

注意：也可以使用任何正常注释标记（行注释、块注释）。

针对 LaTex/Tex

TeX/LaTeX 与其它语言有很大不同，每个命令以 '\' 开头。为更好地帮助用 UltraEdit 编辑 TeX/LaTeX 文件，添加了关键字“LATEX_LANG”。如果有这个关键字，UltraEdit 将对语法加亮有特殊的处理，以允许用 '\' 正确地处理和加亮词语，以及连续的词语。

这还允许识别的词语置于词语文件中，而无法所有词语在同一行。如果词语以 '\' 开头，则第二个字符用来确定该词语应该在哪一行。所有以 '\a' 开头的词应该与其它以 '\a' 或 'a' 开头的词在同一行。同样地，所有以 '\b' 开头的词应该与其它以 '\b' 或 'b' 开头的词在同一行，但与那些以 '\a' 等开头的词在不同的行。

以下示例为 TeX/LaTeX 的词语文件片段：

/L4"TeX/LaTeX" LATEX_LANG File Extensions = TEX LATEX

/C1

…

注意：也可以使用任何正常注释标记（行注释、块注释）。

分界符

以便其匹配特定语言的词汇集。除了 HTML 中的 '<' 和 '>' 字符，作为定界符的字符不能也是词语的一部分；即，无法将 @ 符号视为单词的一部分，而它是词语间的定界符。（以后的增强可能允许这样）。

对于 4.1 以上版本，UltraEdit 允许用户配置定界符。为保障兼容性，如果用户不指定特定语言的定界符，则保留现有定界符。每种语言可能有自己的定界符集。如果正在使用默认，需要配置语言的定界符。

要指定定界符，请在词语文件里添加如下一个新行：

/Delimiters = ~!@$%^&*()_-+=|\/{}[]:;"'<> ,.?/

请注意这些定界符应包含空格和制表符，如果希望将它们视为定界符。该行必须以“/Delimiters =”开头。

可以分配定界符到颜色区段。如果有作为定界符的字符，例如 '+'，且希望使用严格颜色组将其着色，则可以添加该字符到颜色区段下的自己的行，它将保留其识别为定界符，并以适当的颜色加亮显示。定界符可以包含在关键字的开始，并相应进行加亮，但不能包含于关键字当中。如果需要“复合”关键字，或包含两个区段之间定界符的关键字，则定界符将需要从“定界符”列表中删除，否则该关键字的两个部分将需要分别定义以正确加亮。

函数定义字符串

UltraEdit 允许用户在活动文档或全部方案文档中显示函数列表。对于不同语言，函数的定义可能不同，有必要允许它按照语言来配置。

这是通过修改“wordfile”并定义 UltraEdit 为每个语言使用的字符串来实现的。该字符串将被 UltraEdit 用作 正则表达式 搜索字符串以查找函数。

默认情况下，正则表达式字符串使用 UltraEdit 风格的正则表达式。如果需要可以使用兼容 Perl 的正则表达式用于函数字符串，需要添加以下内容：

/Regexp Type = Perl

现在每种语言可以定义多达六个函数字符串，允许指定更多函数/过程格式。

要指定函数字符串，请为特定语言添加类似下面的行：

/Function String = "%[a-zA-Z]*)"

或

/Function String 1 = "…"

…

/Function String 5 = "…"

要搜索的字符串必须使用引号。需要时，可以指定在函数列表里仅显示结果字符串的一部分。要这样做，请使用 正则表达式 下定义的带标记表达式，并将表达式中要显示于 "^(" 和 "^)" 之间的部分封闭起来，如：

/Function String = "%[a-zA-Z]+^(*^))"

该示例将忽略第一个词语并显示该行的其余部分。

缩进

UltraEdit 针对特定语言提供自动缩进，以缩进代码块或取消缩进代码块。

为缩进特定语言，请在特定语言区段下添加类似下面的行：

/Indent Strings = "{"

可以在括号里指定任何数量的词语（每个词语/字符串必须在独立的一组引号内 ""）。如果缩进字符串出现在一行的任何地方，它将用于缩进（除非它出现在加引号的/注释的文本之内）。缩进是从前一行的缩进处开始的下一个制表站（如同按下了一个制表符键）。

为减少缩进特定语言，请在特定语言区段下添加类似下面的行：

/Unindent Strings = "}"

可以在括号里指定任何数量的词语（每个词语/字符串必须在独立的一组引号内 ""）。如果缩进字符串出现在一行的任何地方，它将用于缩进（除非它出现在加引号的/注释的文本之内）。如果包含字符串的行缩进少于前一行则不会出现缩进，否则匹配的字符/词语将减少缩进到前一个制表站且新行缩进到同一点。

对于缩进某些注释掉的行或编译器指令，可能不需要重新缩进文件。可以通过指定不应缩进的行来避免。要这样做，请添加类似下面的行到词语文件里相应的语言区段：

/Ignore Strings SOL = "#" "//"

可以在括号里指定任何数量的词语（每个词语/字符串必须在独立的一组引号内 ""）。为使词语匹配，必须使其成为行的第一个字符。如果某行与此匹配，则不会缩进它，而下一行的缩进将执行，好像该行不存在。

括号匹配

在词语文件里每种语言都有打开/关闭 BRACE 的字符串。 它扩展并增强了 括号匹配命令 在 搜索菜单 里的功能，以及在“语法加亮”对话框里启用的自动括号匹配。

要定义打开括号，请在特定语言区段下添加类似下面的行：

/Open Brace Strings = "{" "(" "["

或

/Open Brace Strings = "If" "For" "Select Case" "Else" "ElseIf"

要定义关闭括号，请在特定语言区段下添加类似下面的行：

/Close Brace Strings = "}" ")" "]"

或

/Close Brace Strings = "End If" "Next" "End Select" "End If" "ElseIf"

请注意：打开和关闭括号字符串必须在位置上匹配它们的列表，使其能按要求工作。如果 "{" 定义为第一个打开括号字符串，则 "}" 应定义为第一个关闭括号字符串。 这些字符串必须是唯一的字符串。 例如，“endcase”无法用于“casex”和“casez”的关闭括号。

如果未定义打开/关闭括号字符串，则 UltraEdit 在执行括号匹配时使用标准字符组，如在以前的版本中一样。

标记字符

有时可能希望加亮两个字符之间的所有字符。UltraEdit 提供“标记字符”，将 UltraEdit 高亮显示的字符串的开头和结束部分进行标记。在这两个字符之间的所有字符都被高亮显示。

为给特定语言定义标记字符，请在特定语言区段下添加类似下面的行：

/Marker Characters = "ab"

其中“a”是要高亮显示的字符串的第一个字符，而“b”是最后一个字符。请注意，一行内的所有字符将高亮显示，包括空格。如果该行为注释或字符串，它将被忽略。 标记字符可以使用字母，但不能使用空格（空格/制表符）。

此外，跨越定义多达 4 对字符以高亮显示其中内容，如：

/Marker Characters = "abcdefgh"

其中以 'a' 开始并以 'b' 结束的字符串高亮显示为以 'c' 开头并以 'd' 结尾的字符串等等。

加亮显示字符串的颜色是可配置的。要指定颜色，请在相应颜色区段下添加这两个字符，如同它们是一个词，类似 "ab"、"cd" 等等。

打开/关闭折叠字符串

UltraEdit 对打开和关闭折叠字符串有多种语言的默认值。如果在 Wordfile 内没有指定字符串，将使用默认值。否则，使用指定的字符串用于折叠。

/Open Fold Strings = "{"

/Close Fold Strings = "}"

忽略折叠字符串

在特定情况下，Fold 逻辑需要忽略包含字符串的某些行。 如果在源代码的一行中发现忽略折叠字符串，

（在行注释或块注释之外），则 fold 逻辑将忽略任何在该行打开或关闭折叠的字符串。 忽略折叠字符串选择没有提供

默认设置。

/Ignore Fold Strings = "Exit Function"

打开/关闭注释折叠字符串

UltraEdit 提供了仅在注释行中或注释块中识别的打开和关闭折叠字符串的方法。 打开和关闭注释折叠字符串没有提供默认设置。

/Open Comment Fold Strings = "#Region"

/Close Comment Fold Strings = "#End Region"

多行字符串

UltraEdit 对多种语言的多行字符串的高亮显示功能提供默认设置。 如果在 wordfile 中没有指定字符串，则使用默认设置。 否则，将以下其中一个字符串添加到语言定义行（即 /L8 PHP ...中）

EnableMLS

DisableMLS

字符串字母前缀

UltraEdit 支持通过在语言定义行指定字符串前缀字符来指定字符串字母格式。 例如，在 C# .NET 2.0 中，字符串字母前缀可以定义如下：

String Literal Prefix = @

在此情况下，字符串字母之前的 @ 表示反斜线不是真正用于输入路径字母的转义字符。 为了说明，一下两种声明是等同的：

"c:\\data\\"

@"c:\data\"

@"..." 中唯一特殊的字符为 "，如果要内嵌只需重复即可。

语言标记

UltraEdit 已改进了句法高亮显示，现在它可以在同一文档内支持多种语言。这是针对 HTML 类型文件的。为实现此功能，我们添加了额外的语言指示器，需要将其添加到 wordfile.txt 文件，以表示包括在另一种语言中的语言类型。我们的默认 wordfile 文件已具有这些修改。

例如：

如果一个 HTML 文件包含 PHP，那么该句法高亮显示的区域必须存在于主 wordfile 文件内，且 PHP 区域应该在定义行内包含：PHP_LANG

明确的语言标记已被添加到了默认 wordfile 内支持以下语言：

C_LANG // C/C++

COBOL_LANG // Cobol

FORTRAN_LANG // Fortran

PASCAL_LANG // Pascal

PERL_LANG // Perl

PLB_LANG // Plb

VB_LANG // Visual Basic

VBSCRIPT_LANG // Vb Script

ASP_LANG // ASP

CSHARP_LANG // C Sharp

CSS_LANG // CSS

LATEX_LANG // TeX / LaTeX

HTML_LANG // HTML

JAVA_LANG // Java

JSCRIPT_LANG // Javascript

ECMA_LANG // Ecma / Ecmascript

PHP_LANG // PHP

MATLAB_LANG // MATLAB

PUREBASIC_LANG // PureBasic

PYTHON_LANG // Python

SQL_LANG // SQL

XML_LANG // XML

XSL_LANG // XSL

MASM_LANG // Microsoft Assembler

AASM_LANG // AT&T Assembler

NASM_LANG // Netwide Assembler

目前，UltraEdit 用上述语言标记在同一文档内正确地高亮显示多语言。未来 UltraEdit 可能进一步在 wordfile 内使用这些语言标记。

注意：注意： 如果 wordfile 文件包含多处 HTML_LANG 语言标记，则必须进行改正，否则某些语言可能无法正确地高亮显示。UltraEdit 在同一 wordfile 内只允许语言标记（即： C_LANG, COBOL_LANG, HTML_LANG）出现一次。

下列文件扩展名被移动到默认 wordfile 的 HTML 区域：php, asp, 和 jsp。这是为了在文档的外部语言级上帮助改正 HTML 高亮显示，即使在该文件内未指定任何 <HTML> 语言标记。文件的所有 php, asp, 和 jsp 区域都在语言开始和结束标记（例如<? 和 ?> ）的基础上正确地得以高亮显示，然而“查看方式”将以 HTML 类型显示该文件。

智能提示支持

向 wordfile 中添加样式关键字以便标识智能提示支持的颜色组。 当前

样式元素的使用非常有限，但在将来的提高中会扩展其使用。 完整的样式元素列表如下：

STYLE_KEYWORD // Keyword

STYLE_FUNCTION // Function

STYLE_EXTENSION // Extensions

STYLE_IDENTIFIER // Identifier

STYLE_OPERATOR // Operator

STYLE_METHOD // Methods

STYLE_EVENT // Events

STYLE_STATEMENT // Statements

STYLE_TAG // Tag

STYLE_VARIABLE // Variable

STYLE_ATTRIBUTE // Attributes

STYLE_ELEMENT // Element

STYLE_COMMAND // Command

新文件高亮显示为

使用该功能的下拉菜单，用户可以从活动 wordfile 中定义的语言列表为语法加亮设置默认语言。 该语言将用来作为未保存文件的默认语言。

拼写检查

默认情况下，UltraEdit 和 UEStudio 将不会在语法加亮文件中执行“输入时拼写检查”。 要更改此设置并允许对语法加亮的文件实行“输入时拼写检查”，请将以下内容添加到 wordfile 的语言定义行（如 /L3"HTML" ...）中：

EnableSpellasYouType

相应的拼写检查选项也必须在配置中选中以便支持。

用户可以修改该文件。


高级

高级（配置 － 应用程序布局）

高级分支位于配置－应用程序布局之下，有如下的选项：

使用注册表进行设置 (不是 INI 文件) - 它不会将现有项目移到注册表中

这些设置使编辑器从注册表检索并保存所有设置。编辑器确定要使用的 INI 文件后将在读取任何其他值之前检查该值。如果设置该选项则编辑器将保存所有设置到注册表。

老式窗口列表

如果选中该选项，则打开的文件将根据其打开的顺序动态地排列在窗口菜单的底部。 如果未选中，则打开的文件将在此列出，但其顺序将根据上次活动文件的顺序而变化。

在资源管理器视图中显示卷标

如果选中该选项，文件树视图的浏览器视图中将显示卷标而不仅仅是驱动器的字母。

在资源管理器视图中显示已注册的文件类型图标

如果选择该选项，将在文件树视图的资源管理器视图中使用系统注册的图标而不是一般文件类型的图标。

INI 文件位置

这里显示了 ltraEdit-32 或 UEStudio 当前实例使用的 INI 文件的完整路径。 用户无法编辑该文本，但可以在需要时方便地查找到 INI 文件。


文件标签

文件标签（配置 - 应用程序布局）

文件标签分支位于配置 － 应用程序布局之下，有如下的选项：

双击标签将关闭文件

如果选中该选项，双击一个打开的文件标签将关闭关联的文件。默认选择该选项。

当前标签关闭后移动到最近的左侧标签

如果选中该选项，则活动文件关闭后焦点将切换到最近的左侧标签。 如果未选择该选项，则活动文件关闭后焦点将切换到与上一个活动文件相关联的标签。

打开文件时排序标签

如果选中该选项，则每次打开文件时文件标签将按字母顺序自动排序。

扁平按钮标签

如果选中该选项，则打开文件标签的显示将从“经典”文件标签列表变为和每个打开文件相关联的一组按钮。

用户可调整的停靠标签

如果选中该选项，将以默认形式在单行中显示打开文件标签． 当显示的文件标签数量超过应用程序宽度时，在文件标签行的末尾将显示两个箭头，用来在文件标签列表中前后移动以选择要编辑的文件。 必须重新启动应用程序以使更改生效。

可以在打开文件标签和编辑窗口之间的边界上单击并向下拖拽以腾出足够的空间显示多个标签行。 如果此后最小化／最大化了应用程序，则文件标签将显示在多行上，而不会显示箭头控件。

用户可以在打开文件标签左侧显示的垂直栏上单击（参见下面的图像），并将它拖拽到编辑器内部的新停靠位置，或根据它所处的位置使它成为非停靠对话框。 双击非停靠文件标签的标题栏使其返回停靠位置。

固定的自动调整标签

如果选中该选项，打开文件标签将显示在自我调整的自动排序列表中。 当文件标签数量超过应用程序宽度时，它们将自动显示在多行上。 选中该选项时不可能解除文件标签的停靠状态，且不能将其拖拽到新停靠位置。 在此唯一可用的选项是右键单击文件标签并从上下文菜单中选择底部标签，从而在编辑窗口下显示文件标签。 必须重新启动应用程序以使更改生效。

按文件类型显示标签颜色

如果选中该选项，文件标签将包含彩色符号表明文件类型。 用户可以通过双击颜色行然后添加扩展名（如“*.html”）的方式为文件类型指定表中可用的颜色。 其他扩展名可以紧接在第一个扩展名之后，之间使用分号“;”隔开（如“*.php;*.php3;*.html;*.js”）。 如果喜欢，用户可以为个别文件而非文件扩展名指定颜色，如“ResolveLine.cpp”。


其它

其它（配置 - 应用程序布局）

其它分支位于配置－应用程序布局之下，有如下的选项：

允许程序多次打开

多次程序打开项目确定在 UltraEdit 已经打开、程序已被调用的情况下，是否可以继续打开 UltraEdit 窗口。如果禁用了这个选项，那么只允许打开单个 UltraEdit 程序实例，其它另外的请求只会将先打开的应用程序窗口用新载入的文件在其它原先打开的文件之上激活。

关闭最后一个文件后最小化

如果选中这个选项，当所有打开的文件关闭时，UltraEdit 将最小化。

最小化到系统托盘 (非任务栏)

如果选中这个选项，UltraEdit 最小化时在系统托盘区显示图标，而不是在任务栏。

总是以最大化状态打开编辑器

这个设置确定 UltraEdit 是否应该总是以最大化状态打开它的主窗口。默认设置是 UltraEdit 记住上一次窗口设置。如果选中这个选项，UltraEdit 将以最大化状态打开主窗口。

仅在文档文件中显示文件名

这个设置允许用户指定 UltraEdit 只在编辑器窗口的标题栏显示文件名，不显示路径。如果这个选项未选中，将显示文件名和路径 (默认)。如果选中这个选项，只显示文件名。

总是在最前显示 CHM 用户帮助文件

这个设置允许用户强制 UltraEdit 在打开帮助文件时，总是在顶级窗口显示用户定义的 CHM 帮助文件。

在启动时检查并显示文件关联

这个设置会导致每次启动 UltraEdit 时显示文件关联对话框。如果这个选项未选中，文件关联只能在高级菜单中的文件关联分支 －>配置 - 文件处理中进行更改。

动画显示配置对话框

该设置动画显示“高级”菜单下的和（在 UEStudio 中）“方案设置”下的配置对话框。


定制

定制 (配置 - 工具栏/菜单)

定制分支位于配置－工具栏/菜单之下，有如下的选项：

定制工具栏

按下该按钮将提供“工具栏配置”对话框，包含两个分别标签为工具栏和命令的窗格，并带有大按钮检查框和新工具栏的文本输入字段以及扩展位图。对话框中还包含上、下、左、右箭头按钮。 这些项目和它们的功能描述如下：

工具栏/命令配置面板

已被指定的工具栏显示在工具栏面板，并在资源管理器界面已分配了项目。 点击工具栏左边的“-”折叠工具栏，点击“+”展开工具栏显示所含的所有项目。如果在工具栏选中一个项目，按上/下箭头移动工具栏列表中的项目。但不能使用上/下箭头将一个项目从某个工具栏移动到邻近的工具栏中。

命令面板显示当前可在工具栏中使用的所有功能。要从命令面板将一个项目移动到工具栏面板，点击你想移动的命令项目，然后按对话框中部的左箭头来添加选定的项目。选定的工具栏项目将直接添加到工具栏面板中的当前选定项目的下面。如果工具栏面板中没有任何选定的项目，该项目将被添加到列出的第一个工具栏顶部。在添加项目后，你可以在工具栏内部使用上/下箭头重新配置。

新建工具栏

要创建一个新工具栏，在新建工具栏字段中输入工具栏的名字 (例如，测试工具栏)，然后按新建工具栏字段右边的左箭头按钮。这将添加一个新的空工具栏到工具栏列表的底部。工具栏可以通过选中后按对话框中部的右箭头按钮来删除。

Ext.Bmp

如果需要，可以为工具栏项目分配一个新的位图 (象用户工具) 显示在工具栏中。要添加位图，先选择命令窗格中的工具栏项目，并将它添加到上面描述的适当工具栏。在工具栏窗格选中该项目，并在扩展位图字段中指定你想作为该工具项目图像的位图。如果知道该位图的路径，你可以直接指定，并按回车，将这个位图分配给选定的工具栏项目。如果不能确定位图的位置，你可以按“...”按钮浏览位图，然后按回车，将这个位图分配给选定的工具栏项目。

扩展位图

如果你愿意，可以指定与工具栏项目关联的新的位图 (象用户工具栏)，让它们在工具栏中显示。

管理工具栏

按下该按钮提供“工具栏配置”对话框。

定制菜单

按下该按钮将显示“菜单配置”对话框，包含两个窗格标签为菜单和命令连同新建菜单/子菜单文本条目对象组成。 如果选择了在菜单上使用检查标记，将显示选定菜单项目的检查标记，而不是按下的菜单图标。该选项有助于解决残疾人士使用的屏幕阅读器中发现的一些问题。同时对话框中还包含上/下和左/右箭头以及一个编辑按钮。所有这些项目和它们的功能描述如下：

菜单/命令配置面板

当前活动菜单以当前在资源管理器界面中分配的项目显示在菜单面板。每个菜单或子菜单标题的名字左边有一条带矩形框的行终止符。双击标题将展开或折叠包含的项目。

如果选中了一个菜单标题或项目，并按下编辑按钮，则可以修改菜单或项目的名字。按键盘上的回车键将保存修改后菜单项目，按确定按钮将提交更改，并使其在菜单中反映。

当选中一个菜单标题，使用上/下和左/右箭头，可以将整个菜单移动到一个新的位置。当选中一个菜单项目，那么按上/下按钮，可以将该项目移动到当前菜单内部的新位置。菜单项目可以被移动到当前菜单的顶端和底端。如果菜单项目是子菜单的一部分，它不能被移动到子菜单的外部。如果菜单项目是主菜单的一部分，将它上下移动，它会“跳过”遇到的子菜单。

命令面板显示所有菜单中使用的当前可用的功能。要从命令窗格移动一个项目到菜单窗格，在希望移动的命令项目上点击，并按下对话框中心的向左箭头来添加选定的项目。选定的菜单项目将直接添加到当前菜单窗格中选定项目的下面。如果菜单窗格中没有选中的项目，该项目将被添加到第一个列出的菜单的顶部。一旦添加了一个项目，它们可以使用上/下箭头在菜单内部重新定位到你所想的位置。

新建菜单

要创建一个新菜单/子菜单，在新建菜单字段中输入菜单/子菜单名 (例如“Test1”)，然后按新建菜单字段右边的左箭头。这将添加一个新的空菜单到菜单列表的底部。菜单可以通过先选中，然后按对话框中心的向右箭头按钮来删除。

可配置菜单的数据默认存储于 %APPDATA% 目录中，在 uedit32.mnu 文件的 IDM Comp\UltraEdit 下。（对于 UEStudio 它位于 UEStudio 目录下而非 UltraEdit 目录）。

定制弹出菜单

按下该按钮将提供“弹出菜单配置”对话框，它除了它允许用户配置右键单击上下文菜单里显示的内容以外，其它功能与上述的“菜单配置”对话框完全相同。

管理菜单

按下该按钮提供“菜单配置”对话框。


HTML 工具栏

HTML 工具栏（配置 - 工具栏/菜单）

HTML 工具栏分支位于配置 - 工具栏/菜单之下，它提供的界面可供用户定制在 HTML 工具栏 里选中 HTML 按钮时插入的 HTML 文本。

当从工具栏行选中按钮时，与该按钮关联的文本将显示在编辑窗口内，用户可以修改该文本并保存以定制按下所选 HTML 按钮时插入的内容。默认情况下，预定义区段中的 HTML 选项将被选中，且默认按钮将插入符合 HTML 4 标准的文本。如果选择 XHTML 选项，默认按钮将插入符合 XHTML 标准的文本。

用户可以使定制位图与“空白”工具栏按钮相关联，并指定按下这些按钮时应该插入的文本。用户可以在文本区域使用“!”以指定在活动文档中插入元素时光标所在的位置，模板支持该功能。例如，输入 "<td>|</td>" 将在指定 HTML 元素间显示光标或任何当前选中的文本。在模板文本中使用"\n" 表示换行。如果需要使用制表符，用户应该在打开 HTML 工具栏配置对话框之前将实际的制表符复制到 Windows 剪贴板，然后将其粘贴到模板文本中。

如果按下修改实际的 HTML 工具栏按钮，将显示带所选定制 HTML 工具栏的工具栏配置对话框。


Web 搜索

Web 搜索（配置 - 工具栏/菜单）

Web 搜索分支位于配置 - 工具栏/菜单下， 它为用户提供了一个接口，从而能够在使用 Web 搜索 工具栏执行文本搜索时，定制搜索的字符串 。

通过这一接口，用户可以对执行搜索的“门户网站”进行本地化（如果需要）。 例如，位于德国的用户可能希望在“www.google.de”上搜索，而不是通过 Google 的美国门户网站“www.google.com”搜索。 要实现这一目的，可将“Google”搜索字符串更改为：

http://www.google.de/search?q=$K

在所有例子中，“$K”表示执行搜索时在编辑器中所选的字符串。 如果需要，按下相关的默认按钮可以恢复每个选项的默认搜索字符串，然后按应用或确定保存更改。

用户还可以根据需要定义要添加到工具栏中的定制搜索按钮。 有关执行该操作的更多信息，请访问 http://www.ultraedit.com/index.php?name=Powertips#ue，然后查看将 Yahoo!、Google、Wikipedia 等与 UltraEdit 集成主题。


管理

管理（配置 - 工具栏/菜单）

管理分支位于配置－工具栏/菜单之下，有如下的选项：

管理工具栏

按下该按钮提供工具栏配置对话框。它包含可用工具栏列表、文本输入字段用于命名新工具栏以及下列按钮：

另存为 - 以新指定的名称保存活动工具栏

删除 - 删除当前选定的工具栏

重置 - 重置活动工具栏到其默认状态

全部重置 - 重置全部活动工具栏到其默认状态

关闭- 关闭对话框

管理菜单

按下该按钮提供菜单配置对话框。它包含可用菜单列表、文本输入字段用于命名新菜单以及下列按钮：

另存为 - 以新指定的名称保存活动菜单

删除 - 删除当前选定的菜单

重置 - 重置活动菜单到其默认状态

全部重置 - 重置全部活动菜单到其默认状态

关闭- 关闭对话框


其它

其它（配置 - 工具栏/菜单）

其它分支位于配置－工具栏/菜单之下，有如下的选项：

方案菜单在主菜单

该选项用来配置在编辑器的主菜单栏包含“方案”菜单。如果不选中这个选项，“方案”菜单只是“文件”菜单的一个子菜单。

在“文件”菜单显示最近打开的文件列表

该选项用来配置在文件菜单中出现最近打开文件列表，而不是作为“文件”菜单的子菜单。 如果不选中这个选项，最近文件列表作为“文件”菜单的子菜单出现。

文件菜单中的最近打开文件数

这可以设置出现在文件菜单中用来快速打开文件的最近打开文件的数量。

退出时清除文档和方案历史记录

如果选择了该选项，则“文件”菜单中的 最近打开文件 列表和 最近打开方案/工作区 列表将在退出时自动清除。

清除历史记录（删除文档和方案历史记录）

如果按下该按钮，则“文件”菜单中的 最近打开文件 列表和 最近打开方案/工作区 列表将立即清除。


目录

目录（配置）

目录分支位于配置之下，允许配置编辑器使用的默认目录。支持以下选项：

默认保存目录 | 设置用 另存为命令 保存文件的默认目录
宏默认目录 | 设置载入和保存宏的默认目录
模板目录 | 设置模板贮存的目录
默认打开目录 | 设置用 打开命令 打开文件的默认目录
默认方案文件目录 | 设置用 新建方案/工作区命令 创建新方案的默认目录

默认保存目录

通常 另存为命令 使用的目录是根据上一次文件打开使用的目录变化的，可能是任意目录。

该目录可以用指定的当使用 另存为命令 时总是使用的默认目录代替。如果该项目留空，那么默认目录是进程的默认目录。


键映射

键映射（配置）

键映射分支位于配置下，允许用户重新分配由 UltraEdit/UEStudio 提供的默认键映射，以满足用户的特殊需要：

该对话框显示编辑器内部可以由用户选择键映射组合的命令列表。在任何一个命令中点击将显示现有的键分配情况（如果有）以及在列表下面显示命令的描述。如果选中分类复选框，则命令将按字母表顺序分类。如果未选中，则逻辑上命令将根据菜单顺序分类。

要添加或更改命令的键分配:

1) 从命令列表中选择要修改的命令。

2) 在按下新（多个）键输入窗口范围内点击鼠标，或按 TAB 使其聚焦。

3) 输入要用来调用该命令的新键分配 - 将捕获并显示组合键。用户在每个字段中可以使用多达三个键（如“Ctrl+Shift+T”）进行多键分配。

4) 点击分配按钮将新键分配给命令。如果该命令已经分配了一个键，会询问您是否想删除，并用新的分配键替换。

弦

用户可以使用按新（多个）键下的文本字段来定义“弦”。例如：

Ctrl+R

M

当快速连续按下“CTRL+R 和 M”时可以用于切换书签。

可以设置多键延时值以给用户一定的时间输入多键的快捷键而不是处理多键的前面部分。

要删除键分配:

1) 从命令列表中选择要修改的命令。

2) 从已有键列表中选择现有的键分配。

3) 点击删除按钮，该键分配将被删除。

要重置键分配到默认值:

1) 点击默认按钮，这些键分配将被重置到默认状态。 将会提示用户来确认这个操作。

包含用户键映射的文件

键映射文件存储在（并在编辑器启动时搜索）与 INI 文件 相同的目录中。文件名与 INI 文件相同，扩展名是 .KBD，即 UEDIT32.KBD 或 UESTUDIO.KBD。

Tab 键从“新建”输入中移动焦点

如果选中该选项，则焦点位于“新键”输入字段时按 TAB 键，则焦点将从该字段中移出而不是在选中命令的映射中包含“TAB”。

在编辑器中显示键映射

按下此按钮后，UltraEdit/UEStudio 使用的当前已配置的所有键盘快捷键列表将写入文件，格式为“[编辑器名称].快捷键”。 其中包括标准键盘快捷键、菜单快捷键和宏快捷键。 如果选中按键归类，则该列表将按照每项功能的快捷键进行归类。如果选中按 ID 归类，则该列表将按照命令名称进行归类。如果需要可以打印列表以供参考。


FTP

FTP (配置)

FTP 分支位于配置之下，有如下的选项：

在用户选择的文件里存储 FTP 帐户和设置

使用该选项能够允许用户指定用于保存 FTP 帐户选项的文件。 用户可以在提供的文本框中直接定义该文件，或浏览选择已经存在的文件。 如果未选中该选项，则 FTP 帐户信息将不会像平常一样保存在 INI 文件中。

在浏览器视图里显示 FTP 帐户

如果选中该选项，则 FTP 帐户将显示在资源管理器标签下的文件树视图/工作空间管理器。 该帐户的跟将列为最高目录并可以扩展，以便显示该帐户下的文件/文件夹。

在输出窗口显示FTP日志

如果这个选项被选择显示所有命令的FTP日志发送数据和从FTP服务器接受的数据在输出窗口里将被显示。 这能够提供有用的诊断信息，并且这个窗口内容能够被使用剪贴板复制。


脚本

脚本（配置）

脚本分支位于配置之下，有如下的选项：

显示输出

该选项可以用于指定脚本运行时输出窗口是否应该关闭。


高级

高级（配置－IDE－智能提示）

高级分支位于配置－IDE－智能提示之下，有如下的选项与 UEStudio 的自动完成有关：

自动显示符号列表

如果选中该选项，将在保存指定的字符数字后自动显示自动完成框（包括符号）。

词语结束后插入智能空格

如果选中该选项，将在插入已接受的词后自动插入空格。

自动完成单符号列表

如果选中该选项且自动完成列表中包含与输入字符指定标准匹配的唯一项目，则自动完成列表中的项目将自动插入而无需提示用户。

禁用该功能

如果用户需要，可以为在注释块或字符串中出现的字符串禁用以上选择的设置（由相关词语文件中的字符串字符设置定义）。


函数提示

函数提示（配置 － IDE － 智能提示）

函数提示分支位于配置 － IDE － 智能提示之下，有如下的选项：

自动显示（重新显示提示：Ctrl + Shift + Space）

参数列表显示的函数提示在输入带有参数列表开放字符（例如开放的圆括号）的名称时自动显示。按下 Ctrl+Shift+Space 可以重新显示它。

使用函数列表的函数提示数据（如果存在）

如果选中该选项，则 UEStudio 中内置的语法分析器将用于标识活动文件中的函数，而不使用在词语文件中定义的函数字符串。要分析的文件必须是活动方案中的一部分，且文件扩展名必须在配置 - IDE - 语法分析器中定义以便操作正确。如果文件类型和扩展名未在语法分析器分支中指定，则 UEStudio 将无法自动分析函数，而将使用词语文件中的函数字符串定义。


其它

其它（配置－IDE－智能提示）

其它分支位于配置－IDE－智能提示之下，有如下的选项：

自动在“[(”后插入“])”

如果选中该选项，将输入一个打开的括号时立即插入另一个封闭括号，即 [ ] 和 ( )，并将光标置于两个括号中间。

自动在“{”后插入“}”

如果选中该选项，将输入一个打开的括号时立即插入另一个封闭括号，即 { }，并将光标置于两个括号中间。

自动插入时智能替换“}”

如果选中该选项，UEStudio 将在输入“{”后自动插入“}”。该功能将先检查输入的“{”是用来定义初始集合还是函数,（基于 C/C++ 语法）。如果是用来定义函数，将插入行终止符，并在下一行的当前缩进位置插入“}”。如果输入的“{”用来初始化数据集合，则将添加“}”作为下一个字符并将光标移至括号中间，与在“}”后自动插入“{” ">选项的功能相同。

Insert () when complete function

如果选中该选项，将在完成函数名时自动插入“()”符号。函数的认可基于工作区管理器“标签”选项卡中全局 -> 函数显示的名称区域。

将“..”改为“->”

如果选中该选项，然后在任何文件中输入“..”将生成“->”。这是典型的“C/C++”语法，用于指针指向结构成员，而不是直接引用结构或结构成员（即“struct.member”）。

自动在新行中插入行注释字符

如果选中该选项，当用户在注释行中编辑内容并切换到新行时，新行将自动成为注释行。 这允许用户书写多行注释而无需停下来插入行注释字符。


语法分析器

语法分析器（配置－IDE－智能提示）

语法分析器分支位于配置－IDE－智能提示之下，有如下的选项：

保存时自动重新解析文档

选择该选项时，UEStudio 将自动重新解析保存的文档，以提供项目到智能提示列表中。

解析无扩展名文件为

用户可以指定某个文件扩展名默认用于解析未用扩展名保存的文件。

对于符号不使用缓存

该选项将强制 UEStudio 在活动方案里不为符号使用高速缓存。 默认不选择该选项。 仅当磁盘空间很低时才选择该选项。

缓存位于 %APPDATA% 目录下。如果没有使用缓存，则语法分析器无法基于可依靠的检查（文件更新或更改时）不得不在每次都重新解析所有内容。因此鉴于性能原因，推荐使用缓存。

清除缓存

该按钮可以用于强制 UEStudio 清除高速缓存。


快速提示

快速提示（配置－IDE－智能提示）

快速提示为正在输入的单词显示一个建议，依据先前在文档里找到的以同样字符开头的词。找到的第一个单词，从光标位置向后扫描到文档顶部，就是建议的单词。

快速提示分支位于配置 － IDE － 智能提示之下，有如下的选项：

显示提示“x”毫秒

该选项设置为毫秒，并控制一条智能提示项目无需用户交互可以显示多久。

向后扫描“x”个字符（设置 chars=0 来禁用快速提示）

该选项设置为字符显示，并控制 UEStudio 将从当前光标位置返回读取多少字符，以填充“智能提示”列表。 它默认设置为 100,000 字符。

以制表符/回车结束

该选项控制可以使用何键来接受建议的单词（TAB 或 ENTER）。


调试器

调试器（配置 - IDE）

调试器分之位于配置－IDE 下，包含用于下载 Debugging Tools for Windows 的选项。在此对话框中显示的下载项目将直接从 microsoft.com 上下载。 更多信息，请参考 http://www.microsoft.com/whdc/devtools/debugging/default.mspx。

Debugging Tools for Windows 是一组可扩展的工具，用于调试 Microsoft® Windows® 系列操作系统的设备驱动程序。Debugging Tools for Windows 支持以下调试：

• 应用程序、服务、驱动程序和 Windows 内核。

• 本地 32 位的 x86、本地 Intel Itanium 和本地 x64 平台。

• Microsoft Windows NT 4.0、Windows 2000、Windows XP、Microsoft Windows Server 2003 和 Windows Longhorn/Vista。

• 用户模式程序和内核模式程序。

• 活动目标和垃圾文件。

• 本地和远程目标。

系统要求

Windows 的 32 位版本调试工具的系统要求如下：

• 32 位或 64 位的 Microsoft Windows Server 2003、32 位或 64 位 Windows XP、Windows 2000、Windows NT 4.0 或 Windows Longhorn/Vista。

• Microsoft Internet Explorer 5.0 或更高版本。

• 大约 25 MB 硬盘可用空间。

除了 Debugging Tools for Windows，有效的调试还需要：

• Windows Driver Development Kit (DDK) 中的特殊调试例程、宏和全局变量。可以在驱动程序的代码中使用这些例程以便发送消息给调试程序，并设置断点帮助调试。

• 访问 Windows 符号文件。如果在调试时可以访问 Internet，可以将您调试程序的符号路径设置为指向 Windows symbol Server。 如果在调试时无法访问 Internet，可以事先从 Microsoft 网站上下载符号。

Debugging Tools for Windows 包含 WinDbg，一款具有图形界面和控制台界面的强大调试程序，以及基于控制台的调试程序 NTSD、CDB 和 KD。

下载 Debugging Tools for Windows [1]

请注意：最好选择 32 位的 Debugging Tools for Windows，除非您使用 64 位处理器调试应用程序。如果是这种情况，应使用 64 位的封装。请选择适合您需要的项目并按下载按钮。

要准备测试会话

1. 如果您要调试内核模式的代码，请将主机设置为运行调试程序，目标计算机运行正被调试的代码。在两个串行端口之间使用 IEEE 1394 数据线或标准数据线连接两台计算机。

2. 在主机上下载并安装最新版本的 Debugging Tools for Windows。还可以从 Windows DDK、平台 SDK 或客户支持诊断 CD 中安装该工具。

3. 使用 Windows Symbol Server 访问主机上的符号文件。

下载 Windows Symbol Packages [2]

如果需要 Windows 下个版本的整个符号集，codenamed "Longhorn/Vista"、 Windows Server 2003、Windows XP 或 Windows 2000，可以下载符号封装并在计算机上安装。

符号下载封装按处理器类型（x86、Itanium 和 x64）和版本类型（零售版和正式版）列出。几乎所有用户都需要零售版本的符号。 如果您正在使用其他调试信息调试 Windows 的特殊版本，则应下载正式版本的符号。

Windows XP 和 Windows Server™ 2003 不需要本地的符号以便调试本地版本的产品。每个 Windows XP 和 Windows Server 2003 符号下载封装可以用于调试所有的本地版本。

每个 x86 符号封装需要 750 兆字节（MB）或更多的硬盘空间，每个 Itanium 符号封装需要 560 MB 或更多空间，每个 x64 符号封装需要的空间大于等于 640 MB。鉴于下载封装的大小和需要的临时文件，推荐您在下载并安装每个符号封装时至少留出 1 GB 的可用硬盘空间。

要使用 Microsoft Symbol Server

1. 确保您已经安装了最新版本的 Debugging Tools for Windows。

2. 启动调试会话。

3. 确定保存下载符号的位置（“downstream store”）。可以是本地驱动器或 UNC 路径。

4. 按以下设置调试器符号路径，将您的 downstream store 路径替换为 DownstreamStore。

SRV*DownstreamStore*http://msdl.microsoft.com/download/symbols

例如，要将符号下载到 c:\websymbols，应将以下内容添加到符号路径中：

SRV*c:\websymbols*http://msdl.microsoft.com/download/symbols

WinDbg [3]

WinDbg 通过图形用户界面和基于文本的界面提供源代码级别的调试。 WinDbg 使用 Microsoft Visual Studio 用于源代码级别调试中的符号格式调试。它可以访问模块中的符合 Codeview (.pdb) 符号文件的任何公共函数的名称和变量。

WinDbg 可以查看源代码，设置断点、查看变量（包括 C++ 对象）、堆栈追踪和内存。它包含的命令窗口可以列出大量无法从下拉菜单中使用的命令。对于内核模式的调试，WinDbg 通常需要两条计算机（主机计算机和目标计算机）。它还允许您远程调试用户模式代码。

作为WinDbg默认调试器

如果选中该选项，将使用 WinDbg 作为默认的调试器。

启用事后调试

该选项可以用来调试已经在输出的失败的程序。


Parser1

语法分析器（配置－IDE）

语法分析器分支位于配置－IDE 之下，其提供的表格用于定义与已承认的语法分析器相关联的扩展名。

查找（语法分析器/Ext)

查找（语法分析器/Ext）文本框可以用来在已承认的语法分析器或已处理的扩展名中搜索匹配。如果搜索语法分析器时，应输入以下内容，即"Fortran". 如果搜索支持的扩展名，则应 在此之前添加“.”，即".jav". 查找到匹配的项目时，其中的文本字段是交互的，语法分析器中相应的行将高亮显示。用户可以在语法分析器行中双击以修改与该语法分析器相关联的扩展名。

如果需要，可以按默认按钮恢复所有语法分析器的默认扩展名。

请注意： 无法添加 IDE 当前不认可的语法分析器。该界面仅支持定义与已认可的语法分析器相关联的扩展名。


设置代码页/位置

设置代码页/位置 (高级菜单)

这个命令允许用户设置用于某些编译器内部函数的代码页和位置。

初始选择是显示当前的设置。在所有以前的版本中，使用“默认”位置和代码页。这是默认值，除非用户指定了其它设置。

如果选择了“默认”，这将应用于代码页和位置两者。

如果选择了“系统默认”，则在再次调用该对话框时，对话框显示实际系统默认值。

代码页选择用于转换到 Unicode，或从 Unicode 转换。位置选择特定用于 分类函数 。


显示/修改模板命令

显示/修改模板命令 (高级菜单)

使用这个命令显示编辑模板的对话框。 模板是一个可以在以后自动重新调用并插入到文件的预定义文本。

你最多可以定义 50 个模板。 最前面的 20 个模板可以在以后用热键 Alt+0 到 Alt+9 以及 Shift+Alt+0 到 Shift+Alt+9 重新调用，所有的模板可以用插入模板对话框重新调用。

每个模板可以随意给它指定名字，如果定义了名字，那么在插入模板时，它会显示在工具栏的工具提示中和模板列表中。

模板贮存在默认目录或在“高级”菜单“配置”选项的目录分支中指定的目录。

模板可以包含在模板重新调用时被转换的特殊文本字符，这些特殊字符是:

[DATE_DMY]

转换为“日/月/年”格式的当前日期。

[DATE_MDY]

转换为“月/日/年”格式的当前日期。

[DATE_TEXT]

转换为以文本显示日期格式的当前日期。

[TIME]

转换为 24 小时制的当前时间。

^

用来指定模板插入后光标所处位置。

[FULL_FILE_NAME]

转换为活动文档的完整路径和文件名。

[FILE_PATH]

转换为活动文档的驱动器和路径。

[FILE_NAME]

转换为活动文档的根文件名。

[FILE_EXTENSION]

转换为带有“.”的活动文档的文件扩展名，如“.txt”。

[FILE_EXTENSION_NP]

转换为不带“.”的活动文档的文件扩展名，如“txt”。

[$REPLACE$]

用活动文档中选定文本替换。当用模板插入时，选区将被转换为大写字母。

[$replace$]

用活动文档中选定文本替换。当用模板插入时，将保留选区当前的大小写。

注意 - ^ 这里所涉及的字符“^”不是控制键 + 值。

另外，对于扩展的日期和时间格式，UltraEdit 支持下列增强功能:

时间

在你的模板中用下列语法指定 USER TIME 格式:

对于本地时间，使用下列标记:

[TIME_USER]...这里是时间格式字符...[TIME_USER_END]

对于本地时间，使用下列标记:

[TIME_USER_SYS]...这里是时间格式字符...[TIME_USER_SYS_END]

时间格式字符象下面这样定义:

如果你在格式字符中用空格分隔元素，这些空格将在模板中以相同位置出现。字母必须是大写或小写，如上所示（例如“ss”而非“SS”）。格式字符中的用单引号标记关闭的字符串将出现在模板中相同位置，不会作任何改变。

字符串 | 含义
h | 没有首位零的单数字小时，12 小时制
hh | 带首位零的单数字小时，12 小时制
H | 没有首位零的单数字小时，24 小时制
HH | 带首位零的单数字小时，24 小时制
m | 不带首位零的单数字分钟数
mm | 带首位零的单数字分钟数
s | 不带首位零的单数字秒数
ss | 带首位零的单数字秒数
t | 单字符表示的上下午时间，象 A 或 P
tt | 多字符表示的上下午时间，如 AM 或 PM

例如，要获取时间字符

"11:29:40 PM"

使用下列的格式字符:

"hh':'mm':'ss tt"

这些字符必须在标记之间，例如:

[TIME_USER]hh':'mm':'ss tt[TIME_USER_END]

日期

在你的模板中用下列语法指定 USER DATE 格式：

对于本地日期，使用下列标记:

[DATE_USER]...这里是日期格式字符...[DATE_USER_END]

对于系统日期，使用下列标记:

[DATE_USER_SYS]...这里是日期格式字符...[DATE_USER_SYS_END]

日期格式字符定义如下:

使用下列元素构建格式字符。如果你在格式字符中用空格分隔元素，这些空格将在模板中以相同位置出现。该文字必须是与表中显示的一样用大写或小写 (例如“MM”不能是“mm”)。格式字符中的用单引号标记关闭的字符串将出现在模板中相同位置，不会作任何改变。

字符串 | 含义
d | 不带首位零的单数字表示的每月中的天。
dd | 带首位零的单数字表示的每月中的天。
ddd | 用三个文字缩写表示的星期中的天。
dddd | 每星期中的天的全名。
M | 不带首位零的单数字表示的月份。
MM | 带首位零的单数字表示的月份。
MMM | 用三个字母缩写表示的月份。
MMMM | 用全名表示的月份。
y | 年份中的最后两个数字，但年份小于 10 则不带首位零。
yy | 年份中的最后两个数字，但年份小于 10 附带首位零。
yyyy | 完整四个数字表示的年份。

例如，要获取日期字符

"Wed, Aug 31 94"

使用下列的格式字符:

"ddd',' MMM dd yy"

这些字符必须在标记之间，例如:

[DATE_USER]ddd',' MMM dd yy[DATE_USER_END]


插入模板命令

插入模板命令 (高级菜单)

这个命令用来插入一个模板。这会显示一个对话框，允许你从模板列表中选择你想插入的模板。

你可以使用热键 Alt+0 到 Alt+9 以及 Shift+Alt+0 到 Shift+Alt+9 来代替这个菜单命令。


DOS 命令

DOS 命令 (高级菜单)

这个命令用来从 UltraEdit 内部运行 DOS 命令，并捕获命令执行结果，自动在命令完成后用 UltraEdit 显示。

执行这个命令时，会打开一个对话框，在那里可以指定命令 (用浏览按钮) 以及指定命令的工作目录 (工作目录只在 UltraEdit-32 中支持)。

指定的命令行应该是要执行的文件的完整路径，除非它是系统命令 (比如“DIR”)，或者它位于 Windows 目录以及 Windows 系统目录。

工作目录应该是工作目录的完整路径，如果不需要则留空。

为了能更灵活地运行程序，可以使用一个特殊的命令行序列，在执行过程中用活动文件名替换，并传递给要执行的程序，例如:

你设置了运行一个编译器的命令，并想用你当前正在进行编辑的文件中调用编译器。但你想在将文件更改为新名字后仍能调用编译器。编译器是 c:\comp\compiler。

在对话框中指定下列命令:

c:\comp\compiler %F

当这个命令执行时，%F 被替换为活动窗口中文件的完整路径、文件名和扩展名，该文件将在命令执行之前保存。

下列命令可以传递完整文件名中的一部分:

%P 仅路径 (“C:\project\test\”)

%N 仅文件名 (“test”)

%E 仅扩展名 (“.c”)

%P%N%E 等于 %F，就是上述示例中的 (“C:\project\test\test.c”)。

注意 - 如果 %f、%p、%n、%e 是小写字母，文件名以长文件名传递，应该加上引号，例如“%f”或“%p%n”等。如果 %F、%P、%N、%E 是大写字母，传递的文件名和路径将被转换为“8.3”短文件名格式，以获取与 DOS 程序最大程度的兼容。

另外还有下列命令可用:

%R 可以用于方案的完整路径/名字 (%r 表示长文件名，%R 表示短文件名)

%RP 可以用于完整的方案路径 (%rp 表示长文件名，%RP 表示短文件名)

%RN 只用于方案名字 (%rn 表示长文件名，%RN 表示短文件名)

%modify% 在某些场合下，可能每次在工具运行时需要修改命令行参数。要进行修改，在命令行中添加 %modify%，那么运行工具时将显示一个对话框，用户可以修改命令行或不修改取消运行。

%sel% 这是用来让 UltraEdit 添加来自活动文档的加亮/选定的文本到命令行中，替换 %sel% 参数。

%Env: 允许用户在命令中使用环境变量。环境变量直接跟随在 %Env: 后面，UltraEdit 会用匹配的环境变量内容替换。

%line% 这是用来让 UltraEdit 添加光标所处的行号到命令行中，替换 %line% - 1 表示第一行。

%col% 这是用来让 UltraEdit 添加光标所处的列号到命令行中，替换 %col% - 1 表示第一列。

命令输出将被捕获，并于命令完成后在窗口中显示。

DOS 程序的输出有时会被操作系统缓存，这个进程在运行时，需要交互的程序中可能不能正确工作，因为不会修正时在屏幕中出现提示，用户可能会对此感到惊讶。

总是捕获输出结果。如果程序没有生成控制台屏幕输出，捕获的输出可能是空的，UltraEdit 将显示一个空的窗口。

如果选中了显示 DOS 窗口选择框，命令执行时将显示一个 DOS 窗口，否则，DOS 窗口是隐藏的。

注意 - 如果捕获输出不能正确工作，或命令不能正确运行，你可以尝试 预备捕获方法 (在 高级菜单 ) 命令。

最后运行的 DOS 命令用来在不弹出对话框的情况下，重复最后一次 DOS 命令对话框中指定的命令。


运行 Windows 程序命令

运行 Windows 程序命令 (高级菜单)

这个命令用来在 UltraEdit 内部执行一个 Windows 程序，不捕获输出。

这个命令会打开一个对话框，在那里允许指定命令 (用浏览按钮) 和指定工作目录 (工作目录仅在 UltraEdit-32 中支持)。

指定的命令行应该是要执行的文件的完整路径，除非它在 Windows 目录，或在 Windows 系统目录。

工作目录应该是工作目录的完整路径，如果不需要则留空。

为使更灵活地运行程序，允许使用一个特殊的命令行序列，将活动文件名插入到命令行中，并传递给要执行的程序。例如:

你设置了一个要运行编译器的命令，你想用当前正在编辑的文件调用编译器。如果你想将文件改名后仍可以调用编译器。编译器是 c:\comp\compiler。

在对话框中指定下列命令:

c:\comp\compiler %F

当执行这个命令时，%F 将被用活动窗口的文件名替换。该文件将在命令执行之前被保存。

下列命令可以用来传递完整文件名中的一部分:

%P 只有路径 ("C:\project\test\")

%N 只有文件名 ("test")

%E 只有扩展名 (".c")

上述示例中的 %P%N%E 等于 %F，就是 (“C:\project\test\test.c”)。

注意 - 如果 %f、%p、%n、%e 是小写字母，文件名以长文件名传递，并且应该放置在引号中，例如 "%f" 或 "%p%n" 等。如果 %F、%P、%N、%E 是大写字母，文件名和路径将被转换为“8.3”这样的短文件名，然后传递给程序，以与 DOS 程序最大程度的兼容。

另外还有下列命令可用:

%R 可以用于方案的完整路径/名字 (%r 表示长文件名，%R 表示短文件名)

%RP 可以用于完整的方案路径 (%rp 表示长文件名，%RP 表示短文件名)

%RN 只用于方案名字 (%rn 表示长文件名，%RN 表示短文件名)

%modify% 在某些场合下，可能每次在工具运行时需要修改命令行参数。要进行修改，在命令行中添加 %modify%，那么运行工具时将显示一个对话框，用户可以修改命令行或不修改取消运行。

%sel% 这是用来让 UltraEdit 添加来自活动文档的加亮/选定的文本到命令行中，替换 %sel% 参数。

%Env: 允许用户在命令中使用环境变量。环境变量跟随直接跟随在 %Env: 后面，UltraEdit 会用匹配的环境变量内容替换。

%line% 这是用来让 UltraEdit 添加光标所处的行号到命令行中，替换 %line% - 1 表示第一行。

%col% 这是用来让 UltraEdit 添加光标所处的列号到命令行中，替换 %col% - 1 表示第一列。

要运行一个 DOS 程序，请使用 DOS 命令。


预备捕获方法命令

预备捕获方法命令 (高级菜单)

这个命令用来更改从 UltraEdit 内部运行 DOS 或控制台应用程序的捕获输出的方法。在 Windows 95 中，一些应用程序不能正确运行，或使用标准方法不能正确捕获输出。

它们之间的主要差异是预备捕获方法不在 DOS 窗口显示正在执行的命令输出。

这个方法可以解决一些用户查看的问题。


工具配置命令

工具配置命令 (高级菜单)

UltraEdit-32/UEStudio 允许用户配置高达十个用于执行用户选择命令的菜单项目。同时还可以在方案工具配置菜单项目中添加另外十个配置活动方案的工具。

这些命令可以是任何 DOS 或 Windows 命令，设置后出现在 高级菜单 的较下位置。

当选定工具配置菜单项目，将会出现一个对话框，允许用户指定用户选择的各自命令行和动作。任何工具更改都可以保存，通过按下确定或应用按钮。 工具配置对话框排列不同的选项，使命令、选项和输出选项卡下用户定义的工具更易于管理。 每个选项卡提供当前指定工具的配置的各种相关设置。 这三个选项卡视图中都包括 插入、复制和删除按钮以及工具列表视图 [5]，可以使用它们来重新排列当前定义的工具列表。

命令选项卡

该选项卡在“工具配置”对话框里，用于创建新工具或为现有工具修改定义的选项。 用户也可以在此重新排列工具列表，而此处作出的更改将反映到“高级”菜单底部列出的工具中。

创建一个新工具

如果在工具列表窗格 [5] 里列出任何工具，可以选择一个工具并按下“插入”按钮来创建新工具。 它将在选中项目之上的列表中添加新工具。 以下选项可以定义用于命令选项卡之下的工具：

菜单项目名 [1]

这是出现在 高级菜单 的项目名称，并同时将在工具列表窗格 [5]中反映出来。

命令行

这是工具运行时将被实际调用的命令行 [2]。 如果需要，它可以包含 "%f" 这个参数会被替换为活动文件的完整路径和文件名。如果文件已被更改，则会先保存该文件。

例如，你可以设置一个运行某个编译器，并且你想将当前正在编辑的文件作为参数调用编译器。如果你已经更改了文件，但想用将新文件作为参数调用编译器，该编译器是 c:\comp\compiler。

在对话框中指定下列命令:

c:\comp\compiler "%f"

当该命令执行时， %F 将被替换为活动窗口文件的完整路径、文件名和扩展名。该文件将在命令执行前保存。

要使用完整带路径的文件名某部分，可以使用下列命令:

%P 只有路径 ("C:\project\test\")

%N 只有文件名 ("test")

%E 只有扩展名 (".c")

%P%N%E 等于 %F，就是上述的 ("C:\project\test\test.c")。

注意 - 如果 %f, %p, %n, %e 是小写，且文件应解析为长文件名，那么应该放置在引号内，例如 "%f" 或 "%p%n" 等。如果 %F, %P, %N, %E 是大写，文件名和路径将转换为“8.3”短文件名格式，以便与 DOS 程序能兼容。

另外还可以使用下列命令:

%R 这可以用作为方案的完整路径/名字 (%r 表示长名，%R 表示短名)

%RP 这可以用作为方案的完整路径 (%rp 表示长名， %RP 表示短名)

%RN 这只能用作为方案名 (%rn 表示长名，%RN 表示短名)

%modify% 在某些场合中，可以需要每次在运行工具时修改命令行参数。 要达到这个目的，在命令行中添加 %modify%，那么当工具运行时，将显示一个对话框，让用户修改命令行或不修改取消运行。

%sel% 这用来告诉 UltraEdit 将活动文档中加亮/选定的文本添加到命令行中，来替换 %sel%。

%Env: 这允许用户在命令中运行一个环境变量。该环境变量直接跟随在 %Env 后面：UltraEdit 会将它替换为匹配的环境变量内容。 请注意：该命令不要求“结尾”百分比记号“%”。

%line% 这用来告诉 UltraEdit 添加光标处的行号到命令行中，来替换 %line% - 1 为第一行。

%col% 这用来告诉 UltraEdit 添加光标处的列号到命令行中，来替换 %col% - 1 为第一列。

工作目录

这是选定命令的工作目录 [3]。如果可用，该进程将用它作为工作目录启动。象上面一样， %p 可以用于指定路径。 应该注意的是，UltraEdit 对工作目录有特殊的处理方式，在指定工作目录时不能使用引号（即在此种情况下应该使用 %p 而不是 "%p"）。

如果使用引号指定工作目录，用户将有可能看到“创建过程错误 267”的消息，表示指定的工作目录无效。

工具栏/位图图标 (文件路径)

这个选项 [4] 允许用户为工具栏中当前选定的工具指定位图或图标文件。浏览按钮允许用户浏览位图或图标文件。位图或图标将按比较缩放到适合工具栏大小。每个文件应该包含单一位图或图标。 如果未定义它，将使用默认工具图标。

工具列表窗格

所有定义的工具都将列于工具列表窗格 [5] 内，而用户可以重新排列工具，通过选择它们并使用向上和向下按钮来移动列表中选定的工具。

选项标签

在“工具配置”对话框里的这个选项用于定义当前选定工具的选项。 包括以下选项。

程序类型选择

可以在此配置程序类型 [1]。 重要： DOS 程序或 Windows 程序的选择应匹配该工具调用的程序类型。

保存活动文件

如果选中保存活动文件 [2] 这个选项，UltraEdit 将在运行工具前保存活动文件，否则，它将不保存 (除非已选中先保存所有文件选项)。

先保存所有文件

如果选中 先保存所有文件 [2] 这个选项，那么UltraEdit 将在运行工具前保存所有打开的文件。

工具列表窗格

所有定义的工具都将列于工具列表窗格 [3] 内，而用户可以重新排列工具，通过选择它们并使用向上和向下按钮来移动列表中选定的工具。

输出选项卡

在“工具配置”对话框里的这个选项用于定义当前选定工具的输出选项。 包括以下选项。

命令输出 (仅 DOS 命令)[1]

DOS 命令输出可以随意捕获为一个文件。 DOS 命令输出有四个选项:

1) 追加到现有文件 (如果文件不存在，则创建一个新文件)

2) 替换现有文件

3) 创建新文件

4) 输出到列表框 ( 输出窗口 )。

这个列表框允许用户双击捕获输出的一行，编辑器将尝试打开相关的文件，并在找到时转到指定行位置。

如果选中显示 DOS 窗口，将在命令执行时显示一个 DOS 窗口，否则， DOS 窗口是隐藏的。

如果未选中捕获输出检查框，则不会捕获该工具的输出或任何相关错误输出。

因为一些命令可以配置，某些用户很可能在其它命令替换现有文件（或附加到文件）时，总是希望一些命令创建新文件。对此，每个捕获模式(附加、替换、新建)都将在文件不存在时创建一个新文件，并且每次命令运行时，如果可以，或者选择了创建一个新文件，那么将附加或替换在捕获模式中指定的文件。

选定的文字替换为

它 [2] 用来说明在工具完成后，当前选定内容将用捕获的输出内容或剪贴板内容替换 (或者在没有选定内容的情况下，在光标位置处插入)，或者没有选择替换，输出内容将以普通显示。

注意 - 如果捕获输出不能正确工作，或命令不能正确执行，你可以尝试运行 备用捕获方法 命令 (从 高级菜单 ) (只能用于 32 位版本)。

工具列表窗格

工具列表窗格 [3] 显示当前配置的命令。点击该列表里的命令将加载该命令相关的参数然后修改。要保留更改，用户必须按下“确定”或“应用”来保存任何工具配置更改。

如果你单击一个项目，然后可以按删除按钮将它删除。

输出窗口

如果配置的工具在输出窗口中出错（如编译器），如果用户双击错误列表，UltraEdit-32 和 UEStudio 将打开引用的文件并转到指定的行。 要支持这一功能，必须按以下格式引用文件 [完整路径(列编号):错误消息] 如：

C:\Development Path\ProjectDev\EditWindow.c(341):未定义的变量 "GeneralError"

要求

DOS 命令根据不同的操作系统，必须要有某些文件存在:

Windows 95, 98, Me 要求 Windows 目录下必须要有 COMMAND.COM 文件。

Windows NT, 2000, XP 必须在路径中指定 CMD.EXE。


窗口菜单

窗口菜单提供下列命令，可以让用户在应用程序窗口排列文件的多个视图:

复制窗口副本 | 创建一个活动文档的窗口的副本
层叠 | 用交迭样式排列窗口
水平平铺 | 用非交迭水平平铺方式排列窗口
垂直平铺 | 用非交迭垂直平铺方式排列窗口
下一个窗口 | 激活下一个窗口
上一个窗口 | 激活上一个窗口
排列图标 | 排列最小化窗口的图标
下一个文件标签 | 根据左右标签顺序提升下一个文件到顶部
上一个文件标签 | 根据左右标签顺序提升上一个文件到顶部
分割窗口 | 在活动文档内部创建一个窗格副本，允许用户同时在两个单独的位置编辑活动文档
最小化所有窗口 | 最小化所有打开的文档
关闭所有文件 | 关闭所有打开的文档
输出窗口 | 显示或隐藏输出窗口
在浏览器显示文件 | 将活动文件提交到浏览器打开
同步滚动 | 同步垂直滚动所有非最小化窗口
窗口 1, 2, ... | 转到指定的窗口


复制窗口副本命令

复制窗口副本命令 (窗口菜单)

这个命令用来打开一个与活动窗口内容相同的新的窗口副本。你可以打开多个文档窗口同时显示文件的其它部分。如果你在其中一个窗口中更改了内容，所有包含同一文档的窗口将映射这些更改。当你打开一个窗口副本时，它变成活动窗口，并显示在所有其它打开窗口的上端。


层叠命令

层叠命令 (窗口菜单)

这个命令用来以交迭样式排列多个打开的窗口。


水平平铺命令

水平平铺命令 (窗口菜单)

这个命令表示用非交迭样式垂直排列多个打开的窗口。


垂直平铺命令

垂直平铺命令 (窗口菜单)

使用这个命令表示按并排方式排列多个已打开窗口。


下一个窗口命令

下一个窗口命令 (窗口菜单)

这个命令用来切换到下一个打开的文档窗口。UltraEdit 依照你打开窗口的顺序来确定哪一个是下一个窗口。

快捷键: CTRL+F6 或 CTRL+TAB


上一个窗口命令

上一个窗口命令 (窗口菜单)

这个命令用来切换到上一个打开的文档窗口。UltraEdit 根据你打开窗口的顺序来确定哪一个窗口为上一个窗口。

快捷键: SHIFT+CTRL+F6 或 CTRL+SHIFT+TAB


排列图标命令

排列图标命令 (窗口菜单)

使用这个命令在主窗口底部排列最小化窗口的图标。如果主窗口底部是一个已打开的文档窗口，那么一些或所有图标可能不可见，因为它们排列在这个文档窗口的后面。


关闭所有文件命令

关闭所有文件命令 (窗口菜单)

这个命令用来关闭所有文件。UltraEdit 建议你在关闭之前先保存文档中的更改。如果不保存关闭文档，那么最后一次保存后的所有更改将丢失。在关闭无标题文档之前，UltraEdit 会显示 另存为对话框 ，建议你命名并保存文档。


在浏览器显示文件命令

在浏览器显示文件命令 (窗口菜单)

这个功能允许将活动文件在默认的 WWW 浏览器中显示。要使这个功能能正常工作，用户必须已经安装了一个 WWW 浏览器，并且文件类型/扩展名必须在资源管理器/文件管理器中注册。

当选中这个命令后，UltraEdit 先创建一个文件的临时副本，并用这个文件调用默认浏览器。当原始文件关闭后，或者如果用户用相同文件再次调用，该临时文件被删除。

这个功能利用与扩展名关联的默认应用程序来显示文件。如果扩展名未与浏览器建立关联，该文件不能在浏览器中显示。


同步滚动命令

同步滚动命令 (窗口菜单)

如果启用了这个功能，UltraEdit 将在任何一个窗口作垂直滚动时同步滚动所有未最小化的窗口。这可以用来同时查看两个 (或多个) 文件，而不需要分别进行滚动。

当用户点击垂直滚动条进行滚动，或点击垂直滚动条上的上/下箭头，窗口将一起滚动。

另外，如果用户使用 Ctrl+Up/Down 进行滚动，窗口也将一起滚动。

如果用户使用光标键重新定位文件，窗口则不共同滚动，这允许用户在不影响其它文件的情况下更改某个文件中的视图位置。

拖动垂直滚动条上的滑杆进行滚动，将会尝试共同滚动窗口，可是这种方法在大文件中不能保持文件同步。


1, 2 ... 命令

1, 2 ... 命令 (窗口菜单)

UltraEdit 会在窗口菜单底部显示一个当前打开文档的列表。当前活动窗口文档名前面会有一个选中的标记。从这个列表中选择一个文档可以激活这个文档的窗口。


帮助菜单

帮助菜单提供下列命令:

索引 | 打开帮助主题的索引
使用帮助 | 提供使用帮助的一般说明
添加帮助文件 | 添加另外的帮助文件到帮助菜单中
在线论坛 | 打开浏览器进入 ultraedit.com 上的用户论坛
IDM 产品 | 在浏览器里提供本地页面，介绍全部 IDM 产品并提供下载链接
检查更新 | 检查是否有当前使用版本的升级/hotfix 可用
注册 | 提供注册该应用程序的对话框
关于 | 显示该应用程序的版本号


索引命令

索引命令 (帮助菜单)

这个命令用来显示帮助文件的打开屏幕，从打开屏幕中你可以一步步跳到使用 UltraEdit 说明和各种参考信息类型。

在打开帮助文件后，你可以点击内容按钮就可以返回到打开屏幕。


添加帮助文件命令

添加帮助文件命令 (帮助菜单)

这个菜单项目允许你添加 Windows 帮助文件到 UltraEdit 帮助菜单中，添加后可以直接从编辑器内部引用。

你可以添加 5 个以内的帮助文件，并且可以直接出现在帮助菜单中。当选择这个项目时，会弹出一个对话框，让用户输入帮助文件名和路径，或浏览帮助文件。另外，你可以输入帮助文件的菜单项目名，用它来识别帮助菜单中添加的帮助文件。

如果在编辑器内打开的文档内容中选择了一些文本，用户可以按 F1 来查看用户配置的帮助文件列表来搜索选定的字符。你也可以选择用打开文档中选定的文本让用户从帮助菜单选择适当的帮助文件，搜索匹配选区内容的相应主题。

如果在帮助文档中找到相应内容，将显示该主题。如果未找到，将显示与之最匹配的主题的搜索对话框。

用户帮助文件可以是 Windows 帮助文件 (.HLP) 或编译后的 HTML 文件 (.CHM) 文件。


使用帮助命令

使用帮助命令 (帮助菜单)

这个命令用来获取有关使用帮助文件的说明。


关于命令

关于命令 (帮助菜单)

使用这个命令可以显示你当前使用的 UltraEdit 的版权信息和版本号。


选择编译器对话框

请注意: 下面描述的项目和选项只能用于 UEStudio，下列信息不能用于 UltraEdit-32。

这个对话框可以选择用于活动方案的编辑器。选择编译器对话框可以从 构建菜单 调用，或按 构建工具栏 。请注意: 这个功能只在 UEStudio 中支持。

要配置用于这个编译器的选项，按编辑配置按钮。这将展开活动对话框，显示编译器配置编辑器。

在编辑器中，注释用“#”开头，段用“[”和“]”包含，并且必须放置在行首。要保存修改后的文件，按保存配置按钮。如果你已经打开了一个方案，那么将配置设为本地按钮将被激活，它用于贮存方案的配置。

当该工具执行时，UEStudio 先在方案目录中搜索本地配置，如果没有找到，UEStudio 将搜索 \configs 目录。如果你需要使用修改后的配置文件，但只想对于某些方案使用，将配置设为本地按钮可以用于保存修改后的配置文件到磁盘中。如果你不需要本地配置，取消选中这个按钮，带配置信息的文件将自动从磁盘中删除。

在配置文件中必须要有基本段，因为没有它们，构建功能不能工作。它们是: Settings、General、Build 和 MakeCommands。作为 Settings 段的子设置，它们可以是 SettingsInfo 和 SettingsReps。大概 Variables、Environment 和 FileGroups 段也将被用于附加到源文件工具的一些段中。当你写入配置文件时，你会使用某些方案变量。方案变量用“$”或其它在 General 段设置的字符开头。

方案变量是: $P、$Pp、$Pn。

$P - 是方案的完整路径 (例如 C:\Projects\Application\Application.prj)，$Pp - 是不带名字的路径，$Pn 是不带扩展名的方案名字。$Pe 现在没有使用，因为方案的扩展名总是“.prj”。这些是全局变量，可以在任何构建/编译命令中使用。

下列是可以用于 BUILD 段的变量，它们是: $T、$Tp、$Tn。

$T - 是目标文件的完整路径 (例如 C:\Prjs\App\Out\App.exe)，$Tp 是一个路径，$Tn 是上述情况中的名字。

$O、$Op、$On、$Oe。

$O 是输出文件的完整路径。在 BUILD 段中，它可能等于目标路径。这是在 Build 段中的“Out”键值。$Op 是一个路径，$On 是不带扩展名的文件名，$Oe 是扩展名。可以使用的最后一个变量是 $R。它是键 DebugFlag 或 ReleaseFlag 的值，用来根据你使用的模式构建方案。

下面是可以用于 COMPILE 段或工作于单个文件的工具段的变量。

它们是: $I、$Ip、$In、$Ie。

$I 是输入文件的完整路径，$Ip 是一个路径，$In 是不带扩展名的文件名，$Ie 是扩展名。

$O、$Op、$On、$Oe。

$O 是输出文件的完整路径，它是段中键“Out”的值。$Op 是一个路径，$On 是不带扩展名的文件名，$Oe 是扩展名。可以使用的最后一个变量是 $R。它是键 DebugFlag 或 ReleaseFlag 的值，用来根据你使用的模式构建方案。

配置文件中有 12 个不同的段:

段 | 描述
[Settings] | 所有当你打开贮存的方案设置对话框进行查看的键
[SettingsInfo] | 包含有关方案键的简短信息
[SettingsReps] | SettingsReps 表示“设置替换”。SettingsReps 可以用于创建简单的配置
[Variables] | 可以用于简化配置文件的内容
[Environment] | 在这个段声明的变量也可以从其它段以 $(name) 进行访问，但不贮存在环境中
[General] | 主编辑器的段。它包含必须设置的基本键，以及不一定要设置的可选键。
[MakeCommands] | 象在 PACKER、PROFILER 或 PETOOLS 中，你想在指定的目标文件中使用的工具键 (大多数编译器在这个段包含两个键: RUN 和 DEBUG)
[InsertFiles] | 在这里指定的文件和文件组将被添加到 BUILD 进程
[FileGroups] | 用于与在这里指定的目的相同的文件组，大多数编译器带有由在这里指定的编译器生成的对象组，这些对象用于链接器命令。
[GroupFormats] | 这是已设置的生成的组中对象的格式
[Build] | 当你点击构建按钮时，这些命令将执行
[.EXT] | 如果源文件已打开，并点击了编译按钮，这些指定的命令将执行


[Settings] 编辑器段

当你打开方案设置对话框时，可以查看贮存在这个段中的所有键。键条目的格式是: Key=value 或 Key=value1|value2|value3。

如果你注意上述第一个示例，你可以看到在“方案设置”对话框只在键中附加了一个值。如果你注意了第二个示例，值被添加到键中的列表，第一个值将被设为键的值，当你点击向下指示箭头的小按钮，你可以从列表中选择其它值的其中之一:

这个段中的值必须是:

目标 | 如果你不想用相同的默认名字创建方案，这个键必须是空的
工作目录 | 默认为“.”，表示当前目录。当目标运行时将设置这个目录。
命令行声明 | 默认为空，如果你不想使用在所有方案中使用相同的声明，建议留空

所有这些变量可以在其它段中通过输入 $(KeyName) 使用。当编译器或链接器执行后，$(KeyName) 将被用这个值替换。这个段连接到下两个段， SettingsInfo 和 SettingsReps 。


[SettingsInfo] 编译器段

这个段包含有关活动方案的键的简短信息。如果你在方案设置窗口选择了一个键，将在窗口的底部显示简短的帮助。键名使用 设置 中相同的名字，例如 key = if you set "value1" short memory model will be used... 那么这些文本将在键列表下面的方案设置窗口中显示。


[SettingsReps] 编译器段

SettingsReps (设置替换) 可以很方便地创建配置。例如，如果你想用 Turbo C 编译器设置内存模式，你必须使用选项 -mt、-ms 等。你可以在 设置 中创建象这样的键: MemoryModel=-mt|-ms|-mm，但如果在设置中创建一个这样的键: MemoryModel=Small|Tiny|Medium 和在 SettingsReps 中创建这样的键: MemoryModel=Tiny=-mt|Small=-ms|Medium=-mm 会更加容易理解。然后如果你选择了“方案设置”中的“精简”，$(MemoryModel) 将在编译器命令中被替换为“-mt”。


[Variables] 编译器段

变量可以简化配置文件的内容。所有这里设置键的格式是: key=value。你可以在其它段以 $(key) 调用。这里可以从注册表键获取值，格式是: $(HKEY_???\PathToKey\KeyName)。你可以使用 LOCAL_MACHINE、CURRENT_USER 和其它注册表主键来替换“???”。


[Environment] 编译器段

这个段声明的变量可以从其它段以 $(name) 进行访问， 但所有这些变量将被贮存在环境中。大多数编译器使用环境变量贮存路径，象 INCLUDE、LIB 等。如果你需要在这个段中使用其它环境变量的值，请使用 %NAME% 等: PATH=C:\COMPILER\BIN;%PATH%。使用这种格式的 %VARIABLE% 只在这个段中有效。在其它段中，你必须从 Variables 段访问环境变量。


[General] 编译器段

[General] 段是主编译器段。它包含必须设置的基本键和不一定要设置的可选键。

基本键是:

键 | 用法
TargetExt = .EXT | 当“方案设置”第一次运行时使用。UEStudio 用这个键生成目标名
ReleaseOut = Release | 如果你设置的构建模式处于发布模式，请在这里设置将要用于贮存所有对象和目标文件的目录的名字
DebugOut = Debug | 如果你的构建模式处于调试模式，请在这里设置将用于贮存所有对象和目标文件的目录的名字。
Excludes = $(Excluded Files) | 设置文件组的名字。所有贮存在这个组中的文件将在构建时执行。

可选键是:

键 | 用法
UseFullPaths = 0/1 | 如果设为“1”，UEStudio 会在所有源代码文件中使用完整路径
UseDosNames = 0/1 | 如果你的编译器工作于 DOS 模式，不能解析长文件名，则应该设为“1”
RemoveDot = 0/1 | 如果设为“1”，用“.\”开头的路径将删除“.\”
ConvertBS = 0/1 | 如果想在文件路径中用“/”替换“\”，则应该设为“1”。如果你使用 GCC 制作工具，可以用于 GCC 编译器。
MakeTool = \Compiler\Bin\make.exe | UEStudio 在构建进程中使用它自己制作的工具，但你也可以使用其它制作工具。如果在这里设置了你想使用的制作工具，那么将使用你定义的工具。 UEStudio 可以用许多制作工具生成可编译的 makefiles。
GrabOut = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (a.)
GrabErr = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (b.)
HideTools = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (c.)
EasyCapture = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (d.)
UseStatusBarFont = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (e.)
ShowCmdLine = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (f.)
SetCurSel = 0/1 | 如果设置了该键，UEStudio 在“全局设置”中用它来替换选项 (g.)

保留选项键，例如 .CPP=.C. 在 [.EXT] 段 解析。


[MakeCommands] 编译器段

大多数编译器的这个段中包含两个键: RUN 和 DEBUG。 象 PACKER、PROFILER 或 PETOOLS 等用于目标文件的工具键应该在这里指定。所有在 MakeCommands 段定义的键将在你点击 工具栏 中的命令按钮后显示。

这个段的格式是: Key = NameOfSection。如果已经设置了键，配置文件中必须添加名为 NameOfSection 的段。

[NameOfSection]

新建 [NameOfSection] 段中可以设置下列键:

键 | 用法
Title = TitleDisplayedInMenu | 将用这里的文本替换“菜单命令中的“NameOfSection”。象 $T 全局变量，例如，可以在这里使用 Title = Execute $T。
Depends = $T | 如果在这里设置了执行的命令，则必须创建文件名或全局变量表示的文件名。
CmdX = tool [options] [files] | 在这里定义要执行的命令。可以执行许多工具。第一个必须是 Cmd0，如果希望定义更多的工具，那么添加为 Cmd1、Cmd2 等。
ShowWindow = 0/1 | 如果设为“0”，工具将在隐藏模式中执行。
DisplayConsole = 0/1 | 如果希望工作于 DOS/CONSOLE 模式，应该设为“1”。


[InsertFiles] 编译器段

在这里指定的所有文件和文件组将被添加到构建进程中。你可以在这里使用两个键类型: 一个添加单个文件到构建中 fileX= ，另一个添加文件组到构建中 groupX=，这里有两种情况 X = 0~n。

groupX 组的内容可以包含用“\n”(换行)、“\t”(制表符) 或用“ ”(空格) 分隔的文件。如果在 Settings 段 中使用键“Files”，并且这个键的内容是“file1.lib file2.lib file3.lib”(用空格隔开) 以及键 incFiles = $(Files) 也设置在 InsertFiles 段中，那么文件“file1.lib”、“file2.lib”和“file3.lib”将被以单个文件添加到构建进程 (作为来自方案的源代码文件)。将这些文件集合起来“视作”文件组中名为 groupX 的文件。这个功能可以用于 FileGroups 段 。


[FileGroups] 编译器段

在这里可以指定用于相同目的文件组。大多数编译器有在这里指定的编译器生成的对象组，这些对象将在链接器命令中使用。这里指定的键的格式是: FGNAME= .EXT1;.EXT2;Group;groupX;group-r;group-o;.

组名可以是任何内容，例如 FGOBJ、FGRES、FGASM 等。键的内容用分号“;”隔开，它们是:

键 | 用法
.EXT1, .EXT2 | 所有带扩展名 .EXT1 和 .EXT2 的文件将被作为键名添加在指定的组中。
Group | 方案组，例如“资源文件”。所有独立于它们的扩展名的文件将被添加到这个组。
groupX | 例如 group0、group1 等。用 InsertFiles 段 指定的组。所有来自这个组的文件将被添加到这里指定的组 (FGXX)。
group-r | 如果这个键添加到 FG 组，所有来自根目录的文件 (例如不在组中) 将被添加到在这个段定义的组中。
group-o | 如果这是添加到 FG 组的内容，所有生成的文件 (在构建进程期间创建的文件) 将被添加到这个组。

所有在这里指定的组的内容可以在构建或编译器段中的 Cmd 命令中的一个 $FGNAME 中输入。例如，如果在这里添加了组 FGOBJ=.obj;，并且 $FGOBJ 在链接器命令中写入，那么将在 makefile 中创建一个名为 FG??? 的对象组，这里的 ??? 是用 UEStudio 在生成 makefile 时自动生成的数值。


[GroupFormats] 编译器段

这个段用于设置生成的组的格式。某些编译器不允许用空格隔开文件说明，必须用一个前缀。对于 Borland 编译器，如果你想创建一个库，你必须用前缀“+”将方案添加到库中: TLIB LIBRARY.LIB +FILE1.OBJ +FILE2.OBJ +FILE3.OBJ。

示例: 如果你在段“fileGroups”中创建组 FGO=.obj，在这里你设置了键 FGO=+%s，将生成一个含 FGO=+file1.obj +file2.obj 等内容的组。

在特殊情况下，你可能需要为第一个文件设置一个格式，对其余的文件设置其它格式。

示例: 你的链接器期待用“,”隔开的对象文件，但“,”必须只在对象文件之间: "LINK OBJ1.A,OBJ2.A,OBJ3.A EXE"。如果你需要这么做，添加到 FileGroups 的一个段 FGA = .A;，以及在 GroupFormats 段添加两个键: FGA0=%s FGA=,%s 这里的 %s 解析为文件名。

如果方案中只有一个文件，这些设置可以确保将使用第一个 FGA0 格式 (格式不带“,”)，如果你有其它文件，将使用 FGA。你还可以在第一个文件必须设置前缀时使用: "LINK /objs:ob1,obj2,obj3"。在这种情况下，你应该设置 FGA0=/obj:%s 和 FGA=,%s。如果某些组在这里没有格式设置，那么将使用默认设置 (%s)。


[Build] 编译器段

Build 段是一个执行段 - 执行某些任务，并工作于文件组的段。当你点击构建时，将执行在这里输入的命令。

这个段的格式与 MakeCommands 段 的格式相同。在 BUILD 的子段中，你必须设置五个基本键 Out、Depends、ReleaseFlag、DebugFlag 和 Cmd0。你还可以设置一些可选键 (Cmd1 ~ CmdN)，这些键用来指示 UEStudio 创建“响应”文件:

键 | 用法
Out = $T | 从这个值生成“输出文件名”。UEStudio 解析为在这里定义的命令执行后，将生成这个文件。
Depends = $FGO | 包含将被用于制作目标的文件的组名，这是必须设置的。对于大多数编译器，这里可设置为 $FGO，这里的 $FGO 是用编译器生成的文件组 (.OBJ)
CmdX = LINK $O $FGO | Cmd0 ~ CmdN - 是生成方案目标的命令。你可以使用在 选择编译器对话框 主题下的 Build 段描述的全局变量
file@0=[respname.ext] Options1|Options2|Options3|Options4 等 | 一些编译器使用响应文件。这是可以用来输入所有编译器选项的文件。这个文件的名字作为用于编译器的一个参数，象 LINK @RESP，这里的 RESP 是包含传递到链接器参数的文本文件。如果你象这里显示的一样设置这个段的键，UEStudio 可以为你制作这些响应文件。如果你创建了这些的键，UEStudio 将创建一个名为“respname.ext”的响应文件，这个文件包含带选项的行，这里的 Options1 是第一行，Options2 是第二行，以此类推。你可以使用所有可以用于传统 CmdX 命令的选项作为这些选项。


[.EXT] 编译器段

.EXT 段是一个执行段 - 一个不执行其它事情、且工作于单个文件的段。如果你打开了源代码文件并点击了编译按钮，将执行这里输入的命令。

这不是一个名为 .EXT 的段，但更适合源代码文件扩展名 (例如“.c”) 作为段。在单个配置文件中，可以是没有、或有一个及多个这样的段。它根据编译器使用的源代码文件类型数确定。

在这里使用的键的格式与在 构建段 基本相同，但有一个差异。这个差异就是 Out 键你可以不设置 $T，例如 $In.obj，这里的 $In 表示源代码文件的名字，在 Cmd0~CmdN 中，你可以使用 $O，这里的 $O 将是“somefile.obj”。

某些象 C 和 Asm 这样的编译器，使用 INCLUDE 文件来贮存函数和变量声明，如果这个 include 文件被修改，源代码文件必须重新编译。因此你必须告诉 UEStudio 怎样在源代码中搜索 include 文件。这里有一些键可以帮你设置这个选项:

键 | 用户法
IncFiles = 0/1 | 如果设为“1”，UEStudio 将搜索你源代码文件中的 include 文件
CaseSensitive = 0/1 | 表示你源代码文件中的字母是否区分大小写 (1)
IncDirs = .;$(INCLUDE); | 大多数编译器在特殊目录中贮存系统的 include 文件，比如象 INCLUDE 或 INC，因此你必须告诉 UEStudio 必须在哪里搜索这些文件。推荐你将第一个路径设为“.”，作为优先搜索源代码的目录
IncKeyWords=#include; | 编译器的预处理程序用于包含可能在这里列出文件的一个或多个关键字
Comments = /*.*/.//.eol. | 在这里设置多行注释括号和单行注释括号 大多数编译器都支持注释。注释是源代码的一部分，不会被编译。因此它不一定要搜索 include 文件。 注释括号必须是成对的。单行注释就象: ";.eol." 或 "//.eol." where ".eol." 表示 "to the end-of-line"。注释括号是用点“.”分隔。不要在注释括号和“.”之间插入空格!

如果你的编译器可以用相同选项工作于一个以上的文件类型，不需要为所有这些扩展名创建一个段，改为只创建一个段，例如 [.C]，并在 [General] 段 添加这样的键: .CPP=.C 或 .ASM=.C。


添加新的编译器

UEStudio 默认支持使用 50 多种编译器和汇编程序。当然，可能有必要添加当前不支持使用的编译器。

添加新的编译器

编译器配置文件类似典型的 INI 文件，由区段、键及其值组成。每个配置都仅能用来创建一个“目标”（应用程序、库、动态库），所以在大多数情况下编译器需要多个配置，而这就是为什么每个编译器都有其自己的内部有配置文件的目录。

添加新编译器的第一步是在UES_PATH\Configs\ 下创建一个新目录。该目录最好的名字是要添加的编译器名。为了仅供演示，我们将为Alpha 编译器创建一份配置。

要开始创建新的配置，请在 UEStudio 里打开新文件。为进行演示，我们将使用Win32 应用程序。请注意完成配置文件之后，添加的目录和文件名将用来填充 UEStudio 中的编译器列表：

有些区段必需，有些区段可选并扩充构建系统的整体功能。 当在 选择编译器对话框 里按下编辑配置按钮时，配置文件的内容将用来填充 UEStudio 里显示的编译器配置。第一个同时最主要的区段是常规，因此我们需要创建新区段——[General]。

[General] 配置选项

如前所述，它们是“按目标”配置，因此第一个需要创建的键是 TargetExt 键。对 Windows/DOS 应用程序该键的值将为“.exe”。对静态库该值将是“.lib”，对 GCC 编译器为“.a”，而对动态库为“.dll”。可以在此设置任意扩展名，而编译器将以该扩展名来构建应用程序。

所有“生成的”文件（对象文件等）存储于独立的目录以保持方案环境清洁。每个配置支持两种模式： release 和 debug。此处可以设置两个键： ReleaseOut和DebugOut，但至少应设置ReleaseOut。如果没有设置DebugOut，它将使用与ReleaseOut 里相同的值。默认值为 Release 和 Debug，但可以按需要设置。

如果编译器/链接器仅能使用“完整路径”（不接受到文件的相对路径），则要创建新的键UseFullPaths并设置值为“1”。如果为不接受长文件名的 DOS 编译器创建了设置，还需要创建UseDosNames 键，并设置值为“1”。

有时方案可以包含不兼容的文件，但用户可能不希望编译它们。（例如，如果它们未完成，或在构建之前有无法修复的错误。）这些文件可以移动到指定的文件夹，而 UEStudio 的构建系统不会将它们传递到编译器/链接器。该文件夹可以有除了“External Dependencies”之外的任何名字。这个名字为 UEStudio 构建系统保留，并且在构建过程中自动创建/删除，因此强烈建议“不要”使用该方案文件夹存储任何用户文件。 要指定该特殊文件夹的名称，请创建新键Excludes并设置这个特殊方案文件夹的名字，例如“Excluded Files”。

有些编译器需要在与源文件相同的目录下有对象文件，因为它们仅接受不带路径参数的文件名（源文件的名称）。 当构建系统生成传递到编译器的文件的相对路径时，这些路径总是以目录名开始，并且当输出目录与源目录相同时，这些路径以“.\”开头。但在编译器仅接受文件名的情况下，UEStudio 无法传递路径，所以需要创建新键RemoveDot值为“1”。

如果使用的编译器仅接受类似 Unix 的路径（带有正斜杠“/”）而非典型的 DOS/WIN （带反斜杠“\”），则应创建ConvertBS键值为“1”。 这将确保在路径里使用“/”，而不是“\”。 示例常规区段现在看起来是这样：

[General]

TargetExt = .EXT

DebugOut = Debug

ReleaseOut = Release

Excludes = $(Excluded Files)

命令配置选项

命令区段告诉 UEStudio 如何构建应用程序或编译文件。还有其它不太重要的命令区段，但可以设置它们来配置其它工具与该方案/源/目标文件合作。这些区段里最重要的是[Build]区段。 该区段必须是每个配置的一部分。

该区段的基本键是Out。它告诉 UEStudio 应该使用定义的命令来创建什么。在所有配置里，键Out的值应设置为“$T”。所有命令区段都支持以$ 开头的特殊值。 这些值在每个配置文件开头的注释区段里进行了描述，但最重要的值是作为目标文件的$T，作为方案文件的$P，以及作为输出文件的$O。 每个命令区段都可以引用这些文件中的一个。在[Build]区段，它是为Out键设置的值，而在[Compile]区段它是为输入文件 -$I设置的值。

创建输出文件（在 [Build]区段的目标文件里）取决于其它文件，因此需要创建带有适当值的Depends键。 对于[Build]区段，它可以为对象文件列表——例如$FGO。如前所述，每个配置都能“处理”两种构建模式——release和debug。如果需要使用该特性，必须创建两个特殊键： ReleaseFlag和DebugFlag。这些键必须为[Build]区段和所有编译器区段设置。大多数编译器支持这两种模式。在debug模式里它们将所有重要信息添加到对象/可执行程序中，以便调试代码。在release模式（制造用途）里，不包括该信息。 这些键的值在编译器命令里得到“扩充”，而在这些命令里使用了$R特殊值（链接器的 release/debug 设置）。

命令键应该已创建。每个命令区段里必须至少包含一条命令。它们设置为键 Cmd0,Cmd1,Cmd2 等等。在大多数情况下只需要设置一条命令，但需要时可以使用更多命令。 示例 [Build] 区段现在看起来是这样：

[Build]

Out = $T

Depends = $FGO

DebugFlag = /debug

Cmd0 = linker $R -out $O -input $FGO

示例：假定目标文件为“Application.EXE”，DebugFlag为“/debug”，ReleaseFlag未设置，而该方案仅包含一个源文件“example.cpp”，则在构建期间 Cmd0命令将看起来类似：

"compiler /debug -out Application.EXE -input example.obj”

在 debug 模式和当设置 release模式时同样的不带“/debug”。

如果正在使用的编译器不支持长命令行，但支持“响应文件”（包含命令行选项的文件），UEStudio 可以为您生成这些响应文件。可以通过更改file@ 之后的索引来创建更多的响应文件，以便那些包含如何创建响应文件的键使用类似“file@0”、“file@1”之类的名称。这些键的值含有要创建的响应文件名信息及参数（编译器/连接器选项），因此该值可能为“[filename.ext] option1 option2”。还可以在此指定文件组和其它变量。如果选项需要包含在响应文件的多行内，需要在选项之间使用“|”。如果响应文件和对象需要位于分隔的行内（不与其它编译器选项一起），则可以使用以下键来扩充示例[Build]区段：

file@0 = [myresp.file] -out $O | -input $FGO

Cmd0 = linker $R @myresp.file

使用定义的 [General]和[Build]区段，可以定义其它编译器区段。 这些区段不是必需，但在大多数情况下这些区段是编译器配置的一部分，所以进行了描述。例如，创建 C 编辑器的时候，需要创建至少一个编辑器的名为[.C]的区段。需要时可以定义多配置来描述如何处理源文件。如果使用的编译器以同样的方式处理多个源文件（即：.C, .Cpp,.Cxx），所以这些扩展名（[.C],[.Cpp],[.Cxx]）不需要新的区段；而可以在[General]区段设置键告诉 UEStudio 使用哪个编译器区段。例如，行：

.CPP = .C

可以添加到[General]区段，而 UEStudio 将为所有“.C”和“.CPP”文件使用[.C]区段。编译器区段（我们示例中的[.C]）将包括[Build]区段里描述的所有键，只是值不同。这些区段里可能使用$I，它是到源文件的完整路径（例如“application.cpp”）。还可以使用所有包含路径的特殊键来获取仅名称、路径或扩展名。 例如，$Ip仅包含源文件中的路径，$In仅包含名称，而$Ie仅包含扩展名。（同样的方法可以应用到$P、$T和$O。）因此示例编译器区段可以包含以下键和值：

[.C]

Out = $In.obj

Depends = $I

DebugFlag = /debug

Cmd0 = compiler $R -out $O -input $I

该区段可能还包含有关引用文件（include file）的键，以便 UEStudio 在处理引用“引用文件”的源文件时能使用这些键和相关符号。这些键的第一个是IncFiles它告诉 UEStudio 该文件可能包含引用文件。默认地，仅在当前目录搜索引用文件。接下来可以定义键IncDirs而其值将知道要搜索的目录列表。此处使用的格式应与环境变量 PATH（用“;”分隔的目录）使用的格式相同，且此处可以设置值 “$(INCLUDE)”。设置为 "$(something)" 的值是在[Variables]区段里设置的变量和引用键（如下所述）。接下来要指定的是用来定义引用文件的关键字。在 C/C++ 语言里为#include，在 NASM 里为%include，而在微软的汇编程序里仅为include。 如果这些关键字区分大小写，则必须添加键CaseSensitive值为“1”。

大多数源文件还支持注释 – 行和/或块。注释未编译，所以在注释里定义的引用文件将忽略。 如果编译器支持注释，应该在此添加键Comments。使用的格式应为：

StartingSymbolOfComment[dot]EndingSymbolOfComment[dot]

行结尾（用于行注释）必须指定为“eol”。因为每个注释区块都有开始和结尾符号，它们必须总是成对定义。 因此示例[.C]区段可能包括下列键：

IncFiles = 1

CaseSensitive = 0

IncDirs = .;$(INCLUDE);

IncKeyWords = include;

Comments = //.eol./*.*/.

[FileGroups] 和 [GroupFormats] 配置选项

值$FGO（一个文件组列表）用于[Build]区段中。用户可以按需要定义任意数量的文件组 – 包括所有方案文件和构建期间生成的文件（例如对象文件）。要定义文件组，请创建名为[FileGroups]的新区段，并包括键FGO。用来创建文件组的文件扩展名可以设置为一个值或方案文件夹名称或特殊组。当前的示例中，该值可能是“.obj”。多数情况下对象文件仅作为文件列表传递到链接器。但有时可能要求特殊格式来传递对象（或源）文件到链接器（其它工具），在这些情况下可以定义区段[GroupFormats]。

如果链接器需要传递对象文件到命令行，如“a + Name1.obj + Name2.obj”等，应该添加键到[GroupFormats]区段以告诉 UEStudio 需要什么格式。 例如键FGO将有值“+ %s”。很少情况下可能出现列表的第一个文件不需要特殊格式，或需要与其它所有文件不同的格式。这种情况下可以指定一组对象文件，它们应传递到链接器的命令行，对象之间以“,”分隔，并以“/obj”开头。新区段类似：

[FileGroups]

FGO = .obj;

[GroupFormats]

FGO = , %s

FGO0 = /obj: %s（<= 添加零到 FG 定义，以应用此格式到该组的第一个文件）

[InsertFiles] 配置选项

有些编译器需要在每次构建应用程序时链接特殊文件。一个解决方案是在每次创建新方案时添加这些文件（例如对象将启动代码）。更简单的解决方案是在配置文件里定义这些文件，而这些配置文件总是“实际上”添加到该方案（仅在构建期间）。 如果需要这样做，请创建新区段[InsertFiles]。可以使用两种类型的键来定义这些文件 -file0到fileX并且到独立文件的完整/相对路径应设置为一个值，或“group0”到“groupX”且值为以空格分隔的文件列表，例如“lib1.lib lib2.lib”等等。还可以在[FileGroups]区段使用这些“组”，如上所述。例如，如果需要[InsertFiles]区段中定义的“group0”的库列表，并要添加到对象文件列表中，则我们修改的FGO键在[FileGroups]区段将为：

[FileGroups]

FGO = .obj;group0;

[Variable] 和 [Environment] 配置选项

在大多数键和区段里可以定义和使用任何变量 – 几乎任何看起来合理的地方。（一个例外是TargetExt键在[General]区段里 – 该值不能为“变量”。）可以定义变量的主区段名为[Variable]。例如，可以在此设置键CPATH，其值可以设置为到编译器的完整路径。然后该变量可用于其它区段，如$(CPATH)。大多数编译器还需要设置一些环境变量，如INCLUDE,LIB 等等。区段[Environment]用于该用途。 此处定义的键将在构建过程中添加到正常环境中。可能需要在一些情况下使用环境变量的原始值，如PATH（以添加路径到编译器），并应使用“当前”路径。然后该值可以设置为 “$(CPATH);%PATH%”。请注意原始值（仅在该区段中）可以指定为 “%KEY%”，如同典型环境变量中一样。 在这两个区段里，都可能需要包括注册表中的信息，并且 UEStudio 支持它。 需要使用上述变量句法，并应以HKEY开始，如同在$(HKEY_CURRENT_USER\MyCompiler\Path)中一样。该值将从HKEY_CURRENT_USER键，“目录”MyCompiler和键Path 中进行扩充。如果希望在注册表路径MyCompiler 里使用“默认键”，则应使用$(HKEY_CURRENT_USER\MyCompiler\@)。

[Settings], [SettingsInfo] 和 [SettingsReps] 配置选项

当对编译器配置文件直接进行更改，且未按下使配置成为本地按钮时，这些更改将为全局性的（对于所有方案）。有些特殊区段允许修改选项，通过 GUI -[Settings],[SettingsInfo] 和[SettingsReps]。

[Settings]是最重要的区段，并且此处定义的所有键都与方案一同保存，因此这些值可以在 UEStudio 里修改而不改变编译器的配置文件。 使用这些区段，可以创建“普通”配置文件，提供同样的选项给所有方案（例如所有 Windows 应用程序），并可以在此指定需要为可配置的项目。如果键Compiler Options已在[Settings]区段中创建，且使用了空字符串作为值，则该键将默认为空，但当此处设置了值时，该值将用于希望指定$(Compiler Options) 的任何地方。

如果有预定义的值（例如创建了键Warning Level），可以在此设置他们，而这些键的值可以指定为“w1|w2|w3”。如此处所示，这些值以“|”分隔。该列表的第一个值将用作默认值，即这里的“w1”。在此从 UEStudio 内部进行的每个更改（不直接修改配置文件）都将与方案一同保存。因此，如果点击该键，则Warning Level从 UEStudio 内部启用，且这三个值都将被选中。

从“仅错误”、“标准”、“作为错误警告”里进行选择将更容易。为此定义了[SettingsReps]区段。 现在[Settings]区段里的键Warning Level可以设置为“Errors only|Standard|Warnings as Errors”，并且在[SettingsReps]区段里键Warning Level可以设置为“Errors only=w1|Standard=w2|Warnings as Errors=w3”，UEStudio 将替换所有这些“基于文字”的选项为合适的命令行选项。

可能还需要以指定的形式传递选项到编译器。例如，如果链接器命令行需要以参数资源脚本添加，则可以创建ResourceScript键到[Settings]区段中，在链接器命令行它看起来类似“/rscript:$(Resource Script)”。如果总是需要设置Resource Script不会出现任何问题，但如果不是，则会在Resource Script设置为空字符串时导致错误，且它会以“/rscript:”传递到链接器命令行。

反之，Resource Script键可以在[SettingsReps]区段里设置，值为“@/rscript:%s”。以“@”开头将告诉 UEStudio 它是一个“格式”，因此如果该键未设置，不会传递任何东西到链接器，而如果设置了该键，则将传递“/rscript:Script.ext”或该值到那一行。

为了无需用户记住所有可能的位置，可以创建区段来存储与键有关的信息。选择键时，该信息将在 UEStudio 里的编辑器选项对话框里显示。可以创建区段[SettingsInfo]而其中列出的键名称将与它们在[Settings]和[SettingsReps]区段里的相同，这些键的值将为键的描述。新的[Settings]区段现在类似：

[Settings]

Target =

Working Directory =.

Warning Level = Errors only|Standard|Warnings as Errors

[SettingsReps]

Warning Level = Errors only=w1|Standard=w2|Warnings as Errors=w3

[SettingsInfo]

Target = 此处供您指定目标文件的名称

Working Directory = 该目录（如果设置）将用来运行应用程序

Warning Level = 可以在此为编译器设置警告级别

在上述[Settings]区段里有两个键是编译器配置里每个[Settings]区段的一部分，而且其中一个 -Target是必须的。建议保持它为空白，如果这样，目标名称将从方案名称和在[General]区段里定义的TargetExt生成。


UEStudio 的 CVS

UEStudio 在 方案菜单 中包含 VS（Concurrent Versions System，并发版本系统）界面。请注意：该功能在 UltraEdit-32 中不支持。

请注意，UEStudio 身不提供 CVS 服务器，但已经配置了一个与 CVS 服务器交互的方法。

CVS 是一个开源的、透明网络程序，允许开发者遵循源代码各种开发版本原则进行开发。CVS 不保持多个源代码版本，但保留单个副本和所有所作更改的记录。当开发者想要一个文件的特殊开发版本时，CVS 将根据它的记录重建该版本。

通过 CVS 进行源代码文件校验的帐号可以用 CVS 管理器对话框 进行创建/修改。UEStudio 含下列 CVS 相关功能的支持：

* 校验 | 从信息库校验模块
* 提交 | 提交工作副本到信息库
* 差异 | 检查相同文件两个版本间的差异
* 更新 | 从信息库更新工作副本
* 导入 | 导入新的模块到信息库
* 导出 | 校验排除 CVS 信息的模块
* 帐号/设置 | 运行 CVS 管理器对话框


怎样禁用“无临时文件”提示？

按默认，如果在不创建临时文件的情况下编辑文件，会显示一个确认对话框，说明不创建备份，所有的更改是永久性的。如果你想禁用这个对话框，在 普通配置页 的文件处理项目段中选择“不使用临时文件打开文件，也不提示”。


可以怎样在不创建空文件的情况下打开 UltraEdit？

如果你不指定任何文件，只打开 UltraEdit，请检查以确保 普通配置页 中的文件处理项目下“在没有打开其它文件的情况下，打开时创建新的 EDIT 文件”选项未选定。默认设置是在 UltraEdit 启动时，如果没有文件被打开，则创建一个新文件。

同时，当尝试打开一个不存在的文件时，默认设置是用指定的名字创建一个新的空白文件。如果你不希望出现这种情况，请确保 普通配置页 中的载入/保存/转换项目中的“如果在命令行中指定的文件不存在则创建一个新文件”选项未选中。


怎样可以控制新建文件格式？

普通配置页 中的编辑段中有一个选项，允许指定用 UltraEdit 创建的建文件的默认格式。在“新建文件的默认文件类型”下，你可以选择“DOS”、“Unix”或“MAC”，则新文件将使用适当的行终止符创建。


怎样可以删除包含特殊字符的行？

你可以用正则表示式 全部替换 命令替换行中包含的字符。

要执行这个操作，你应该先进行查找:

查找: %*YOUR STRING*^p

替换为: (随便什么文字)

帮助文件中的 正则表达式 段有进一步的说明。


怎样使用其它比较应用程序？

按默认，在文件菜单中选择比较文件命令，可调用 UltraEdit 自身附带的比较工具。如果你喜欢其它的比较应用程序，你可以在 uedit32.ini 文件 (通常在 Windows/Winnt 目录) 中的 [Settings] 段下添加下列设置:

Compare EXE = "EXE 文件路径和名字"

这个设置允许用户指定其它文件比较程序，用于替换 UltraEdit 提供的标准工具。如果设置了这个选项，UltraEdit 将使用该 EXE 文件来替换它自己的工具。要传递给工具的命令行参数将是要比较的文件的名字 (带路径)。


我应该怎样删除空行？

要删除空行，你可以使用正则表达式来替换，象下面:

查找什么: ^p$

替换为: (没有任何文字)

这个动作会使直接在行首后面的硬回车用空内容替换，就象删除它们的效果一样。


怎样可以从工具栏删除分隔线？

要删除分隔线，将图标拖放到分隔线左边，覆盖分隔线。


我应该怎样才能打印语法加亮？

从 文件菜单 ,中选择“打印设置/配置”，然后选择“ 页面设置 ”。在这里你可以看到“打印语法加亮”的选项。


怎样修改文件打开对话框中的文件类型？

在高级菜单中点击配置，并点击 文件类型 标签。这个页面允许配置在 文件打开 和 文件另存为 对话框中出现的文件类型列表。你可以配置 10 个以下的文件类型。这些文件类型的第一个扩展名将显示在文件操作对话框，其它文件类型用与这个页面中相同顺序显示。


我应该怎样进行多行替换？

你可以用“^p”作为 CR/LF 来执行这个操作 - UltraEdit 会将 ^p 解释成硬回车。你也可以在搜索和替换字符中分别用“^c”和“^s”来表示剪贴板内容或选定的文本。你可以用这个方法复制/选择 30,000 字节以下的字符串。


在哪里可以找到其它的 UltraEdit 的词语文件？

许多词语文件、宏、自动更正文件和标签列表可以从我们的网站下载: http://www.ultraedit.com/index.php?name=Content&pa=showpage&pid=40#wordfiles 。


为什么会在有连字符的词语中换行？

这是 UltraEdit 在段落重排时遇到连字符单词的默认动作。如果你不想让带连字符的单词被破坏，你应该确保未选中 普通配置页 编辑段中的“当转换/段落重排时在连字符 (-) 处断开”。


为什么 UltraEdit 会重排粘贴的段落？

如果你已经将 自动换行 设置设为“在指定列号后换行，插入 CR/LF”，粘贴后将会重排段落，以保持换行正确。如果你确保未选中 普通配置页 下的“当换行设置为在指定列号添加硬回车时，粘贴后重排段落”，则不会出现这种情况。

如果 自动换行 设置设为在指定列号后换行，并插入硬回车 (CR/LF)，这个设置会导致编辑器在执行粘贴命令后自动重排段落。UltraEdit 默认使用这个动作，只有确保未选中这个选项才会改变这种现象。


为什么我的 IntelliMouse 不能在 UltraEdit 中使用？

UltraEdit 内置了 IntelliMouse 的支持。如果你在运行 UltraEdit 时禁用 IntelliMouse 设备，可能会有好处。IntelliMouse 设备允许你这么做，并且允许 UltraEdit 用鼠标控制交互操作。


为什么修剪尾部空格在最后一行不能执行？

修剪尾部空格 功能需要一个换行才能在指定的文本行中进行操作。如果你文件中的文本最后一行用硬回车终止，修剪尾部空格功能也可以在该行中执行。


为什么 notepad.exe 被覆盖？

在某些 Win2K/XP 安装中，比如象康柏，在硬盘中放置了一个 I386 子目录使系统可以使用即插即用设备。这个目录还包含一个 notepad.ex_ 文件，该文件将用来覆盖新的 notepad.exe 文件，就象在恢复时插入 CD ROM 一样。如果不象自述文件中说得那样，不安全设备对话框不出现，可以说这是个意外。重命名该文件为 notepad.ex_.bak 可以解决这个问题。

同样，XP 用户必须复制新的 notepad.exe 到 c:/windows 和 c:/windows/system32 中。

如果已经出现这个情况，并且你的系统中没有 dllcache 目录，打开资源管理器并转到工具 -> 文件夹选项 -> 查看，确保“隐藏受保存的操作系统文件 (推荐)”选项未选中，然后转到 WINNT\system32\dllcache 目录，并重命名老的 notepad.exe 文件到 notepad.exe.bak 或类似的名字，然后你可以在 WINNT 和 WINNT\system32 目录替换 notepad.exe 了。


为什么标尺以 "0" 开始？

为什么标尺以“0”开始？

该标尺就象普通标尺一样，在开始位置显示“0”，允许用户测量给出的位置之前的列数。如果你想查看列号，它已经在状态栏中有关位置中显示。象普通 Windows 应用程序，这些显示模式和测量，我认为，这是个标准的方法。但大多数应用程序不包含这两者。


为什么不能复制和粘贴？

UltraEdit 支持多个剪贴板，我怀疑你激活了一个用户剪贴板。

剪贴板可以从编辑菜单激活，在编辑器中右键点击弹出菜单中选择要用的剪贴板，或按 Ctrl+0 - Ctrl+9，Ctrl+0 是标准剪贴板。活动剪贴板的状态显示在状态栏中的行/列号后面，并用逗号隔开。CW 表示 Windows 剪贴板，C1-9 表示用户剪贴板。


为什么打开大文件需要这么长的时间？

UltraEdit 可以处理超过 4GB 的文件。UltraEdit 是基于磁盘进行编辑的，这意味着每次只在内存中载入文件的一小部分，因此它不使用所有的内存，并停止其它应用程序的运行。但是，它会生成一个文件的临时副本来达到这个目的，这对于大文件需要一些时间。

在 高级菜单 和 配置 区域中有两个选项可以考虑。

1) 禁用行号 - 选中这个选项来禁用大文件的行号显示功能，尽管它会使文件查询更快一点。

2) 不使用临时文件打开文件 - 这个选项用来告诉 UltraEdit 不创建文件的临时副本。这么做会使它直接编辑原始文件，并且所作的更改是永久性的。一些用户对于大文件可以使用这个选项。你可以设置这个选项的极限值，使它只在文件大小超过你规定的数值后使用这个选项。

另外，你可以禁用配置中自动从 Unix 转换到 DOS 功能 (如果已经启用)。


为什么会有延时启动 UltraEdit 的情况？

UltraEdit 在载入和关闭时会尝试与打印机设备通信。如果你的默认打印机是网络打印机，可能会导致出现这个情况。

请编辑 uedit32.ini (默认位置是在 Windows/Winnt 目录) 中的下列设置:

[Print Settings] ;;- 注意，这个不一定有
Restore Settings = 0


许可协议 - 未注册

有限保证

本程序以“现状”提供，且没有任何明示或暗示的担保，包括但不限于销售或最终特殊用途。作者对您使用该软件引起的损坏不承担责任，包括使用该软件时造成的间接或直接损害，即使已被告知这种损害的可能性。

您承诺您已经阅读了这份许可，明了并同意与我们之款中间协议条的全部和特有的声明，之后任何建议或预先协定，口头或书面，以及我们之间任何与这份许可的内容有关的通信。

UltraEdit/UltraEdit-32 是共享软件，可以在不修改的情况下提供给用户评估。该共享软件目的是根据“先试用后购买”的原则向私人电脑用户提供高质量的软件，如果您以后想继续使用该产品，必须付款。

如果您认为该程序有用，并希望在试用期满后继续使用，必须进行注册 (查阅注册说明获取详细信息)。该注册费许可一个用户在一台电脑中使用一份 UltraEdit 和/或 Ultraedit-32。注册后，所有用户都将获得一份最新发布的程序，并根据相关许可协议享有权利和义务。

所有的用户必须在第一次使用后 45 天内注册并购买正版软件，或者放弃使用。站点许可和多用户许可请联系：info@ultraeditchina.com，或访问网站： http://www.ultraeditchina.com 。

任何发布这个产品获取报酬均需联系 IDM Computer Solutions, Inc. 及其相应代理公司获取授权许可文件。

您可以分发该软件给朋友和同事，但必须包含原始发布版本中的所有文件。如果您的朋友和同事认为这个软件不错，请鼓励他们进行注册。

本许可协议受中华人民共和国法律和国际公约的保护。

本许可协议如与英文版License Agreement之间存在任何歧义，以英文版为准。


许可协议 - 已注册

这是您 (个人或团体) 和 IDM Computer Solutions, Inc 之间的法律协议。您一旦购买安装、复制或以其他方式使用该软件，即表示您同意接受本协议各项条款的约束。

软件许可

1. 许可承诺。如果您属于上述定义的正版软件产品用户，这份许可协议 (许可) 允许您使用单个副本，或多个副本，包括在线提供的用户说明或电子表单 (软件)。该软件作为单一产品许可给单用户、多用户的用户组许可和站点许可。这份协议明确规定每个软件均需获取许可，不管是单用户，或用户组成员。多用户许可提供指定数量的用户同时使用这个软件。我们提供共同使用一个副本的用户许可，但必须有明确授权，并支付了普通许可费用之外的附加费用。这个软件的每个用户必须为单用户许可、或多用户许可中的其中之一。当将这个软件载入到电脑的临时存贮器 (比如 RAM) 或安装到永久存贮器 (比例硬盘)，说明该软件已在使用。 这个软件可以安装到网络中，但必须保证该位置有适当的限制，并且限制为注册用户使用。

2. 著作权。 软件的所有物理副本属注册用户所有，但软件的使用受上述条款限制 (许可承诺)。该软件受中华人民共和国法律和国际公约保护。所有的知识产权属 IDM Computer Solutions, Inc. 所有。您不能复制软件附属的可打印内容 (如果有)，也不能复制任何在线提供的用户说明或电子表单副本，除非您是上述 (许可承诺) 指定的合法注册用户专用。您不得以任何形式重新发布提供给您的注册码，这些形式包括纸张形式、电子形式或贮存在文件 ULTRAEDT.REG、UEDIT32.REG、ULTRAEDT.INI、ULEDIT32.INI 内容或任何其它形式。

本“软件产品”（包括但不限于本“软件”中所含的任何图像、照片、动画、录像、录音、音乐、文字和附加程序）、随附的印刷材料、及本“软件”的任何副本的产权和著作权，均由 IDM Computer Solutions, Inc. 拥有。您必须在本“软件”的所有副本上包含所有的版权标识。

3. 其它限制。 这里提供的显示您验证码的注册通知和这份许可，是您有权在此使用该软件的证据，必须由您保留。您不能出租或租赁该软件。您不能进行反向工程、反编译或分解该软件。

有限保证

有限保证。本协议提供您自购买日期起一年的免费升级。

免责声明。 上述担保，无论是明示或暗喻的，为担保的全部内容，包括对特殊应用目的的商品性和适应性担保。在适用法律所允许的最大范围内，IDM Computer Solutions, Inc. 或其代理商、销售人绝不就因使用或不能使用本“软件”所引起的或有关的任何间接的、意外的、直接的、非直接的、特殊的、惩罚性的或其它任何损害赔偿（包括但不限于因人身伤害或财产损坏而造成的损害赔偿，因利润损失、营业中断、商业信息的遗失而造成的损害赔偿，因未能履行包括诚信或相当注意在内的任何责任致使隐私泄露而造成的害赔偿，因疏忽而造成的损害赔偿，或因任何金钱上的损失或任何其损它损失而造成的损害赔偿）承担赔偿责任，即使 IDM Computer Solutions, Inc. 或其任何代理商、销售人事先被告知该损害发生的可能性。即使补救措施未能达到预定目的，本损害赔偿排除条款将仍然有效。

本许可协议受中华人民共和国法律和国际公约的保护。

本许可协议如与英文版License Agreement之间存在任何歧义，以英文版为准。


技术支持

如果你已经注册并购买了一个许可，你可以免费获取 UltraEdit-32 支持。你可以邮寄你的问题/建议到：

support@idmcomp.com


Sales

销售
 Previous Topic

要获取有关许可价格的最新信息，请联系我们: info@ultraeditchina.com。


加速键对话框

UEStudio 里的加速键对话框提供了一个编辑活动方案加速键的简捷方式。在“文件树型视图”里选择了“加速键”资源项目并从上下文菜单里选择了“打开”选项时，即调用出“加速键”对话框。它将以表格提供加速键，列出 ID、按键和类型。“快捷键”对话框包括以下按钮：

确定 | 保存更改并关闭对话框
取消 | 关闭对话框而不保存更改
新建加速键 | 提供“属性”对话框以定义新的加速键
属性 | 如果选择了加速键，该按钮提供“属性”对话框
删除 | 从列表中删除已选的加速键

属性对话框

“加速键”属性对话框用于修改选定资源的属性或定义新资源的属性。

使用该对话框用户可以定义下列项目：

ID | 活动加速键关联的名称
键 | 用于调用加速键的按键
辅助键 | 伴随主键的附加键，用于组成加速键。默认情况下，当加速键符合菜单项时，系统高亮显示菜单项目。 可以使用不翻转选项来防止高亮显示个别的加速键。
类型 | 可以为 ASCII 或虚拟键


Add/Modify Environment Variables

Add/Modify Environment Variables (Workspace Manager context menu)

When a yellow folder (indicating an actual folder on a drive, and not a "Group" folder) is selected under the Project tab in the Workspace Manager, the last item presented in the context menu is Add to Environment. Selecting this option presents the Add/Modify Environment Variable dialog:

It may be necessary at times to specify additional INCLUDE, LIB, PATH, or SRC directories for use with the specified compiler for the active project. This dialog may be used to select a folder on the drive and designate it accordingly for the compiler settings for the active project.

* Please note: This feature is only supported in UEStudio, and not in UltraEdit-32.


艺术样式格式对话框

这个对话框用于配置要用于自动重新缩进和重排格式 C/C++/Java 源代码文件的设置。该对话框可以通过工具工具栏中的艺术样式按钮打开。 用于艺术样式的缩进空格数 ，是基于“配置-自动换行/制表符设置”中根据活动文件扩展名定义的缩进空格值。

按重排格式按钮将选中的选项/设置应用于活动文件。

缩进

可以使用下列缩进选项:

控件 | 功能
class | 缩进 class 的块，使“class”块中的“public:”、“protected:”和“private:”标头首行缩进 class Foo { public: Foo(); virtual ~Foo(); }; 成为： class Foo { public: Foo(); virtual ~Foo(); };
switch | 缩进“switch”块，使 switch 块中的“case X:”标头缩进 switch (foo) { case 1: a += 2; break; default: a += 3; break; } 成为： switch (foo) { case 1: a += 2; break; default: a += 2; break; }
case | 缩进“case X:”，使它们与其下面的命令行齐平 switch (foo) { case 1: { a += 2; break; } default: { a += 2; break; } } 成为： switch (foo) { case 1: { a += 2; break; } default: { a += 2; break; } }
括号 | 添加额外的缩进到括号中 if (isFoo) { bar(); } else { anotherBar(); } 成为： if (isFoo) { bar(); } else { anotherBar(); }
块 | 添加额外的缩进到整个块 if (isFoo) { bar(); } else anotherBar(); 成为： if (isFoo) { bar(); } else anotherBar();
标签 | 添加额外的缩进到标签中，使它们比当前缩进少一个缩进，而非与左边齐平 (默认)。 int foo() { while (isFoo) { ... goto error; error: ... } } 成为： int foo() { while (isFoo) { ... goto error; error: ... } }
命名空间 | 添加额外的缩进到命名空间 namespace foospace { class Foo { public: Foo(); virtual ~Foo(); }; } 成为： namespace foospace { class Foo { public: Foo(); virtual ~Foo(); }; }
最大缩进 | 相对于上一行在连续语句中设置缩进的最大空格数
最小缩进 | 当标头是多行结构时，设置添加的最小缩进。这个缩进有助于将标头从下面的命令语句中分开。这个选项的默认设置是当前缩进的两倍。 // default setting makes this non-bracketed code clear if (a < b || c > d) foo++; // but creates an exaggerated indent in this bracketed code if (a < b || c > d) { foo++; } 变成 (当 min indent 设为 0): // setting makes this non-bracketed code less clear if (a < b || c > d) foo++; // but makes this bracketed code prettier if (a < b || c > d) { foo++; }
预处理程序 | 缩进多行预处理程序定义。应该用制表符 -> 空格得到正确结果。虽然很好用，这个选项不能在模糊预处理程序定义 下获得奇迹般的结果。
制表符 -> 空格 | 转换制表符为单个空格
填充空行 | 用上一行的空白区域填充空行

格式化

可以使用下列的格式化选项:

控件 | 选项 | 功能
括号 | 附加 | 在块语句之前添加括号 (例如 Java / K&R 样式)。 if (isFoo) { bar(); } else { baz(); }
 | break | 括号从块语句之间换行 (例如 ANSI C / C++ style)。 if (isFoo) { bar(); } else { baz(); }
 | break-closing-headers | 直接从引导关闭括号处换行关闭标头 (例如“else”、“catch” ...)。 if (isFoo) { bar(); } else { anotherBar(); } 成为： if (isFoo) { bar(); } else { anotherBar(); }
 | linux | 从类/函数声明的括号换行，但在块命令 语句之前添加括号。 namespace foospace { int Foo() { if (isBar) { bar(); return 1; } else return 0; } }
中断块 | 默认 (无选择) | 在标头块周围添加空行 (例如“if”、“while”...)。 isFoo = true; if (isFoo) { bar(); } else { anotherBar(); } isBar = false; 成为： isFoo = true; if (isFoo) { bar(); } else { anotherBar(); } isBar = false;
 | 全部 | 在标头块周围添加空行 (例如“if”、“while”...)。将关闭标头块 (例如“else”、“catch”) 作为独立块。 isFoo = true; if (isFoo) { bar(); } else { anotherBar(); } isBar = false; 成为： isFoo = true; if (isFoo) { bar(); } else { anotherBar(); } isBar = false;
Break Else If |  | 换行“else if()”标头组合到单独行。 if (isFoo) { bar(); } else if (isBar()) { anotherBar(); } 成为： if (isFoo) { bar(); } else if (isBar()) { anotherBar(); }
添加空格 | 全部 | 在操作符和圆括号内插入空格 if (isFoo) a = bar((b-c)*a,*d--); 成为： if (isFoo) a = bar( ( b - c ) * a, *d-- );
 | oper | 仅在操作符两旁插入空格 if (isFoo) a = bar((b-c)*a,*d--); 成为： if (isFoo) a = bar((b - c) * a, *d--);
 | paren | 仅在圆括号两旁插入空格 if (isFoo) a = bar((b-c)*a,*d--); 成为： if (isFoo) a = bar( ( b-c )*a, *d-- );
保持单行状态。 |  | 不换行单行内的复合语句和多重语句 if (isFoo) { isFoo = false; cout << isFoo << endl; } 保持不变。 if (isFoo) DoBar(); 保持不变。
保持单行块 |  | 不换行单行的块 if (isFoo) { isFoo = false; cout << isFoo << endl; } 保持不变。

样式

可以从样式下拉框选择五个样式中的一个 (ansi、kr、linux、gnu、java）。

ansi | namespace foospace { int Foo() { if (isBar) { bar(); return 1; } else return 0; } }
kr (Kernighan&Ritchie) | namespace foospace { int Foo() { if (isBar) { bar(); return 1; } else return 0; } }
linux (括号从类/函数声明处断开，但连接 到命令行，并将缩进设为 8 个空格) | namespace foospace { int Foo() { if (isBar) { bar(); return 1; } else return 0; } }
gnu | namespace foospace { int Foo() { if (isBar) { bar(); return 1; } else return 0; } }
java | class foospace { int Foo() { if (isBar) { bar(); return 1; } else return 0; } }

模式

c | 缩进 C、C++ 或 C# 文件
java | 缩进 Java 文件


自动恢复命令

为防止 UltraEdit/UEStudio 或操作系统的崩溃，任何打开编辑的文件且带有未保存的更改都将保存为临时文件。当重新启动应用程序时，将显示“自动恢复”对话框提示用户崩溃时的已修改但未保存的临时文件列表。用户可以从该列表选择项目，并按下恢复已选文件按钮或不要恢复按钮。

请注意： 在正常编辑过程中 UltraEdit/UEStudio 创建一个临时文件来跟踪已编辑文件上进行的修改。该信息用于支持“自动恢复”选项。如果已更改配置设置，使临时文件不用于编辑，则“自动恢复”选项不再可用。


自动完成

UltraEdit 提供在输入时自动完成词语输入的功能。

这里有四个方面进行自动完成:

- 当调用时，所有来自 语法加亮 的关键字可以在列表中使用 (如果文件使用了语法加亮)。

- 显示在 函数列表 中的函数将显示自动完成列表。

- 在编辑标签的配置中，用户指定用于提供自动完成字符的文件。在这种场合中，每个词语或句子需要一行 (允许指定完整的句子/段落)。

- UltraEdit 将在活动文件中反向搜索从光标位置 50K 的词语量，如果遇到有部分匹配的词语，则会显示。

按默认，自动完成功能用 Ctrl+Space 调用。当调用这个功能时，会显示一个带有可能匹配的词语/短语的列表框。如果有适当的词语存在，该词语将被加亮。输入另外的字符将会更改为更适合匹配当前输入内容的词语。

用户可以使用光标键更改选择的词语，在任何时候可以使用 TAB、SPACE 或 ENTER 键选择要使用的词语。执行后会使 UltraEdit 用选定的词语/短词替换部分输入的词语 (如果出现的话)。

快捷键: CTRL+Space


自动更正 (语法加亮)

如果启用了 语法加亮 ，UltraEdit 将自动 (可选) 根据词语文件中的关键字检查每个词语，如果词语匹配 (除词语的大小写之外) UltraEdit 将更正该词语，并匹配词语文件中词语的大小写。

要在当前文件中能使用这个功能，文件必须用语法加亮功能加亮，在词语文件中指定的语言必须没有指定“Nocase”命令。


批处理生成器对话框

批处理生成器是供公司里的主程序设计师或只需要创建方案的工程师使用的工具。该对话框还同时支持多个方案。

使用此工具用户可以创建方案列表，它们都在一个“工作区”里并且可以一步之内生成它们。 例如，如果使用自己的库创建方案，可以如下创建方案列表： Lib1, Lib2, App1, App2, App3, 等等。首先，将创建或更新这些库，然后是依赖这些库的应用程序。

方案可以添加到列表 [1] 或从其中删除，通过按下添加方案或删除按钮 [4]。当方案添加到该列表时，将在 Build [2] 栏里显示“模式”，应用程序或库将在该模式中生成。任何“批处理构建”命令（构建、重建、清除或停止 [3]）都可以应用到方案列表。

在“批处理生成器”对话框里的文件菜单可以用于加载并保存“批处理生成器”列表。


Boost Software License

Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and accompanying documentation covered by this license (the "Software") to use, reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works of the Software, unless such copies or derivative works are solely in the form of machine-executable object code generated by a source language processor.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.


拼写检查对话框

如果有一个词语与不在字典对象中定义的词语不匹配，好象拼写错误，会弹出希望引起你注意的拼写检查对话框。你可以使用这个对话框指定是否忽略或更改词语。

更改为对象: 包含在你选择更改或全部更改按钮时，用来替换拼写错误词语的词语。你可以用自行输入的方法在更改为对象中输入一个词语，或你可以从建议列表中选择一个建议更改的词语。

忽略按钮: 跳过认为拼写错误的词语。如果在以后出现相同的认为拼写错误的词语，它会重新报告。

更改按钮: 用更改为对象中的词语替换找到的认为拼写错误的词语。该命令只替换这个词语，如果你想替换以后出现的相同的词语，请选择全部更改按钮。

全部忽略按钮: 跳过认为拼写错误的词语。如果出现的认为拼写错误的词语实际上是正确的，你可以使用这个按钮。如果该词语是你经常使用的词语，你希望永久忽略，请用添加按钮将它添加到字典中。

全部更改按钮: 用更改为对象中的词语替换全部出现的认为拼写错误的同一词语。如果你只想替换当前的一个，请使用更改按钮。

添加按钮: 使报告拼写错误的词语添加到在“添加词语到列表”中选定的字典。如果你经常使用的拼写正确的词语被认为是拼写错误 (例如你朋友的名字)，请使用添加按钮。如果该词语不是经常使用，你可以改为选择忽略或全部忽略按钮来替换。

取消按钮: 停止当前的拼写检查操作。

选项按钮: 显示配置对话框中的 拼写检查 标签。


选择字体对话框

UltraEdit 可以选择屏幕和打印机字体。如果选中 镜像显示字体 (在 视图菜单 ) 菜单项目，那么选择的屏幕字体也应用于打印机。如果不选中这个项目，那么打印机字体可以独立于屏幕字体，单独进行选择。

当从 视图菜单 中选择字体时，会打开一个字体对话框。这个对话框在选择了 设置字体 或 设置打印机字体 时均会出现。

字体对话框提供一个已安装的字体列表供你选用。如果该选定的字体用于打印机，只能选用可用于打印机的字体。你还可以从对话框中选择字体大小。

另外，使用 OEM 固定点阵字体选项允许用户指定一个内部 Windows OEM 固定点阵字体，替换普通的已安装的字体。


颜色选择器对话框

颜色选择对话框是一个非常灵活的工具，它可以用来插入不同格式的颜色的数值: 十进制、十六进制、HTML 和 RGB (红、绿、蓝)。

“颜色选择器”对话框包含下列项目:

填色工具

">“颜色选择器”左上方的填色工具可以用来将颜色导入到对话框中。单击“填色”并将其拖至任何项目的上方，则相应的颜色值将导入对话框。

颜色块

颜色块在“颜色选择器”对话框的左上角。单击这个块会弹出标准的 Windows 颜色对话框，在此可以选择基本颜色或自定义颜色。不管是在颜色对话框中选择了标准颜色，还是创建了自定义颜色，在按下“颜色”对话框中的“确定”按钮后，“颜色/纯色”字段中显示的颜色将被拾取。

RRGGBB 文本字段

如果您熟悉标准 RGB 颜色代码，可以直接在这个对象中输入颜色代码来指定颜色。指定的颜色会立即在颜色块中反映。如果用十六进制格式定义了一种颜色，这应该是六位数的文字字符 (例如 F08FFF)。

颜色选择下拉菜单

在下拉菜单中提供用于 Web 开发的 72 种默认颜色列表，选择其中的一种颜色将自动更改十六进制/RRGGBB 对象中反映的值。这可以帮助你快速选取用于开发的颜色。

RGB 文本字段

在红、蓝、绿颜色块旁边是文本字段，在此可以直接输入这些颜色值（从 0 到 255）。每个文本字段的上/下箭头可以用来修改颜色值。要同时增加/减小这三种颜色值，使用 RGB 文本字段下面的“-”和“+”按钮。

最近的颜色

接近颜色按钮用来从下拉菜单中列出的默认颜色中选取与当前定义颜色最接近的颜色。颜色块将更改为反映该颜色，格式字段中的颜色字段也被更改，颜色名在下拉框中列出。

交换红色/蓝色

按下这个按钮将交换当前指定颜色的红和蓝颜色值。这个更改通过颜色选择器反映出来。

输出

用户可以通过选用适当的按钮将颜色值用十进制、十六进制、HTML 或 RGB 格式插入。 按下编辑器按钮将输出发送到活动编辑窗口，按剪贴板按钮将输出发送到活动剪贴板。如果选择了使用引号选项，那么插入的值将被附上双引号。（请注意，一般用于 C 宏中的 RGB 颜色值不能附上双引号，此操作在上下文中不适用。）

仅显示 Web 颜色

除了显示颜色的浏览器不同，很少有颜色显示相同。 如果选中仅显示 Web 颜色，则在“选择颜色”对话框中仅显示“浏览器安全”颜色。

关闭

按关闭按钮将关闭“颜色选择器”对话框并返回编辑窗口。


命令行参数

UltraEdit 支持用命令行参数打开指定的文件。UltraEdit 允许在一个命令行中指定多个文件。在这里指定的所有文件将在 UltraEdit 启动时打开。命令行中的文件名应该用空格 (" ") 隔开。对于长文件名，应该包含在引号 "" 中。

另外，UltraEdit 支持两个用命令行打开的方法：

通配符 UltraEdit 接受任何打开文件中使用的 正常通配符规格，例如“*.c”表示打开所有带“.c”扩展名的文件。

包含要打开文件的文件列表 你可以在命令行中通过使用“/f”参数来指定 文件名中包含要打开文件的列表。在这种情况下，UltraEdit 将读取命令行中的每一行文件，并尝试打开每个文件。当使用“/f”参数时，命令行中指定的文件只能包含文件名，并且每个文件名必须在单独的一行。

UltraEdit 接受命令行中的“/r”参数，表示用只读方式打开文件。

当一个文件被删除时，默认情况下 UltraEdit 会通知用户文件已被删除。在某些场合下可能不希望收到这个通知。 如果在命令行中添加“/n”，用命令行打开指定文件出现这种情况时，该通知将被禁用。这不会影响已经打开的文件，或在此之前打开的文件。

要指定在文件打开后光标所处位置的行数或列数，可以在文件名后面直接跟随行和列数，并与文件名用“/”字符隔开，如下：

filename/5/2 这表示在打开文件时，光标位置处于第五行、第二列。你也可以只指定行号，而不指定列号。

在以前的版本中，分隔符“/”是用逗号，但这可以作为有效的文件名字符，所以已作修改。如果它还是 要使用逗号或其它字符，可以将下面的一行添加到 INI 文件中：

LineColumnChar= ,

这里的逗号可以是除冒号“:”之外的任何字符，但 UltraEdit 有可能不能打开包含这个字符的文件。

另外，命令行可以在文件名后面包含 –lx 或 –cx (用空格隔开)，这里的 x 是行或列数，可以在每个文件名之后。 这是一个新的方法，应该在文件名后面用空格隔开使用，如果文件名在引号中，它应该在引号之后，并与引号用空格隔开。

UltraEdit 接受命令行中的“/P”或“/p”参数。 这是用来告诉 UltraEdit 自动打印命令行中的文件，并在文件打印后退出。

UltraEdit 接受命令行中的“/O1”或“/O0”参数。 这是用来告诉 UltraEdit 如果指定了“/O1”，则强制使用 OEM 字符集；如果使用了“/O0”，则强制不使用 OEM 字符集。

要指定是否应该使用新的或已有的 UltraEdit 实例打开指定文件，可以使用以下标记：

/foi 用来在原来的实例中打开文件，如 uedit32 /foi "c:\temp\test.txt"

/fni 用来在新的实例中打开文件，如 uedit32 /fni "c:\temp\test.txt"

UltraEdit 允许使用 INI 文件由用户指定 UltraEdit 设置。 如果命令行包含“/I=filename”，则使用该 INI 文件。

例如：/i=c:\windows\uedit32.ini

文件名必须直接跟随在 /i= 后面。 它可以是一个带空格的长名字，在这种情况下，它必须包含在引号中。

获取更多有关 INI 设置信息，请查阅 INI 文件选择 。

UltraEdit 允许从命令行自动调用 宏 ，你可以在命令行中添加下列语法:

/M,E,5=“宏文件的完整路径/宏名”

/M 用来指定宏命令

,E 指定在宏执行之后，文件应该保存，并且退出编辑器，这是一个可选的参数。

,5 指定宏执行的次数。这是一个可选参数，如果没有指定，用命令行载入文件时宏将运行一次。如果命令行中未指定文件，宏将不会执行，除非指定了执行次数。

在引号中指定宏文件名。如果文件中包含多个宏，可以在宏名后面跟随的名字中包含斜杠 (/) (可选)，如果未指定宏名，将使用文件中的第一个宏。

UltraEdit 允许从命令行调用脚本，你可以在命令行中添加下列语法:

/s,e="full path to script file"

例如：/s,e="c:\working files\myscript.js"

,e 表示执行脚本后，编辑器应该退出，这是可选参数。 请注意：如果需要保存已修改的文件，则需在已执行的脚本中处理。

文件路径/名称必须紧跟在 /s= 之后。 它可以是包含空格的长名称，但必须在引号中。

有时从其它应用程序启动 UltraEdit，可能需要用已经打开的文件名并定位到指定行或列的方式来调用。在这种情况下，可以在命令行中添加“/a”参数，这样 UlteaEdit 不会显示询问文件是否应该重新 载入的提示并放弃更改。如果没有这个参数，将询问用户是否应该重新载入文件和放弃更改。

最后，命令行中可以包含“-f”参数，表示 UltraEdit 在指定的文件中执行查找命令。这必须是命令行中的最后一个参数。要在这个参数中添加扩展参数，它会使用 UltraEdit 内部最后一次执行查找命令时使用的参数，例如，区分大小写、正则表达式等。格式应该是：

uedit32 c:\temp\test.txt -fdog

这会使 UltraEdit 打开文件“test.txt”并搜索文件中的第一个出现的“dog”字符。


编译器选项对话框

编译器选项对话框用于配置在活动方案中使用的选定的编译器。这只能用于 UEStudio。

按默认按钮可以恢复选定编译器的默认设置。双击配置面板中的一个项目将弹出一个对话框，在那里可以设置该选项的值。按默认，方案目录下的调试和分布目录将被用于调试和分布构建。如果需要，用户可以指定其它目录，但这些将是相对于方案目录的。


上下文帮助命令

上下文帮助命令用来获取某些 UltraEdit 项目的帮助。当你选择工具栏上的上下文帮助按钮后，鼠标指针将变成一个箭头和问号。那么在 UltraEdit 窗口某处点击，比如象其它工具栏上的按钮，将会显示你点击的项目的帮助主题。

快捷键: SHIFT+F1


DDE 支持

UltraEdit 支持下列 DDE 命令。它们是全部“系统”主题的一部分。

命令: | 功能:
[open("文件名")] | 打开指定的文件。文件名后面可以是保存的宏运行、在行号定位等任何普通命令行参数。
[save()] | 保存活动文档。
[print("文件名")] | 打印指定的文件。
[printto("文件名","打印机名","打印机设备","端口")] | 在指定的打印机打印指定的文件，给出打印机名、打印机设备和端口。

这些命令必须严格匹配如上所示。

下面的例子是使用 DDE open 命令打开一个文件并运行一个宏:

[open("filename" /M,E,1="宏文件的完整路径/宏名")]


对话框设计模式

兼容的方案加载到 UEStudio 时， 资源编辑器工具栏 活动。如果从方案资源里选择了对话框，且在编辑器里打开了它的源，则“测试”工具条按钮活动。当点击该按钮时，将打开活动对话框的预览。它会显示活动对话框从方案应用程序里调用时，如何进行描绘。

加载预览对话框时，其默认状态为设计模式打开。右键单击预览对话框里的任意位置（不包括特定控件上），都将显示以下的上下文菜单：

设计模式关闭/打开 | 切换“设计模式”状态，它可以在预览和编辑模式之间转换
重新绘制窗口 | 重新绘制预览对话框，基于修改的对话框源
插入控件 | 提供子菜单，可以从中选择项目插入到活动对话框中
保存并退出 | 保存全部当前更改到对话框源并关闭预览对话框
退出 | 不保存更改关闭预览对话框

如果打开设计模式并选择了特定的控件，右键单击将显示以下的上下文菜单：

设计模式关闭/打开 | 切换“设计模式”状态，它可以在预览和编辑模式之间转换
重新绘制控件 | 重新绘制选定的控件，基于修改的对话框源
删除控件 | 从预览对话框删除选定的控件
保存并退出 | 保存全部当前更改到对话框源并关闭预览对话框
退出 | 不保存更改关闭预览对话框

* 请注意：这些功能仅在 UEStudio 中支持，UltraEdit-32 不支持这些功能。


Diff 命令

当在“工作区管理器” 方案面板中选中高级 Diff/比较（上下文菜单中的 CVS 子菜单里）时，将出现 CVS Diff 对话框。CVS Diff 对话框支持下列选项：

可以从帐户下拉菜单中选择需要的帐户。如果 CVS 帐户不存在，请按下修改按钮启动 VCS Manager 对话框，在此用户可以添加/删除帐户。

>

默认情况下，选中与当前版本的差异复选框。选中时，禁用第一个修改字段。如果没有选中该复选框，则用户可以为 diff 指定两个不同的修改版本。如果第二个修改字段留空，则以 HEAD 或最近的修改版本执行 diff。

>

用户可以在附加 Diff 参数字段中指定附加的 diff 参数。这些是命令行参数，应当知道 UEStudio 已经不直接支持它们了。该选项对于不适用于 Subversion 帐户。

>

默认情况下，未选中使用外部比较选项。如果未选中该选项，CVS 引擎将执行 diff 并将结果写入 UEStudio 的编辑窗口。如果选中该选项，指定和 CVS 使用的比较应用程序将用来执行 diff。 如果用户熟悉比较应用程序的命令行参数，则这些参数可以在外部比较参数字段中进行指定。

* 请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持该功能。


双击选择

UltraEdit 允许通过双击鼠标的主键 (通常是左键) 来进行文本选择。一般可以选定由文字数字式字符或下划线组成的一个单词。

如果在鼠标主键双击的同时按下 CTRL 键，则选定一个字符串，而不只是一个单词。这在选择文件名、邮件地址等内容时非常有用。定界字符串的字符可以在 普通配置页 中配置。这个功能只能工作于单行中。

你可以在配置中分别选择用于左边分界的字符和用于右边分界的字符，指定的字符用来停止文本的进一步选取。如果在每个对象中只选定一个空格，那么光标位置旁边的所有文本将被选定，直到遇到一个空格。

如果有选定的文本，那么右键点击弹出的菜单项目顶部会出现一个“打开 "加亮文字"”的菜单项，如果选择了这个菜单项，就会打开该文件 (如果存在的话)。

如果在两个空格之间双击鼠标主键，那么将选定所有邻近的空格 (不超过行末)。


Editor

Editor (Configuration - Display)

The Editor branch under Configuration - Display has the following options:

Number of HEX characters per line: 16

This setting defines the number of HEX characters to be shown in each line of the display. The editor must be restarted once this value is changed.

Maximum columns before line wraps: 20000

This setting sets the maximum columns allowed within the editor before it wraps the line (soft wrap). The default is 4096 columns but a maximum of 20,000 is allowed. Some video drivers have a problem when this is set too high.

Start ruler numbering at column 1

This setting causes the editor to start the ruler at 1. If this option is not selected (default) the editor starts the ruler at 0.

Count wrapped lines as new lines in number display

This setting causes the editor to show wrapped lines with different line numbers. By default this is not set.

Enable show/hide lines and code folding

This setting permits hiding/showing selected text and folding/expanding code blocks. If this is not selected the folding gutter will not be visible in the edit window and folding is disabled.

Enable show/hide lines for non-syntax-highlighted files (above must also be set)

This setting permits text to be hidden in non-syntax-highlighted files and expanded/collapsed using the View menu commands. If this is not selected the folding gutter will not be visible in the edit window in non-syntax-highlighted files and folding is disabled.

Cursor/Caret Type

Normal: Vertical bar in insert mode/block caret in overstrike

Always a vertical bar

Inverted: Block caret in insert mode/vertical bar in overstrike

This setting determines the type of cursor/caret used in the editor. If set to Normal, in Insert Mode the caret will be a vertical bar and in Overstrike Mode the caret will be a block caret. If set to Always a vertical bar the block caret is disabled. If set to Inverted the caret type will be reversed such that in Insert Mode the caret will be a block caret and in Overstrike Mode the caret will be a vertical bar.


文件关联 (启动对话框)

什么是文件关联？

当在资源管理器、桌面以及贯穿整个系统的相关项目中双击一个文件，操作系统 (OS) 会检查是否已经有应用程序配置为这些文件的默认编辑器/查看器。如果有应用程序已被设置为该文件类型的编辑器/查看器，该文件将被用指定的应用程序打开。这个操作是用“文件关联”功能来完成的。在这里会询问你是否对某些文件类型建立关联，你可以将 UltraEdit 作为这些文件类型的默认编辑器/查看器。

在启动时检查

当 UltraEdit 启动时，它会检查某些文件类型的文件关联，如果该文件没有与 UltraEdit 建立关联，会显示一个对话框，在这里可以选择是否用 UltraEdit 关联这些文件。用户可以通过点击取消按钮忽略，或选中你想与 UltraEdit 建立关联的文件类型，并点击确定按钮来建立关联。

对话框底部有一个选项，允许用户选择是否不再显示这个对话框。

任何文件类型的文件关联可以用 文件关联对话框 (在 高级菜单 的配置下) 进行更改。


文件更改侦测设置

UltraEdit 会自动侦测在 UltraEdit 内部载入的文件是否被 UltraEdit 外部的其它程序更改。

按默认，当侦测到文件被更改时，UltraEdit 会提示用户是否重新载入文件 (如果重新载入，文件在 UltraEdit 中所作的更将丢失)。用户可以选择重新载入文件，或忽略更改。

UltraEdit 通过在 普通配置页 中设置“禁用文件更改侦测”选项，提供忽略侦测任何文件更改的功能。这是可选的。在这种情况下，UltraEdit 将不侦测文件更改，或任何文件更改提示。

通过在 普通配置页 中设置“自动更新已更改的文件”选项，提供自动更新已被外部编辑器更改的文件的功能。这是可选的。在这种情况下，文件将被重新载入，UltraEdit 中所作的未保存的更改将在不提示情况下被自动覆盖。


文件打开对话框

下列选项允许您指定要打开的文件：

查找范围

指定您想查找文件或文件夹的位置。点击箭头选择其它位置，或在工具栏点击向上移动一层目录。

下面的框中列出选定位置中的项目。要打开一个文件，在打开对话框双击要打开文件的文件名。

文件名

提供输入您想打开的文件名字的区域。要快速查找您先前打开过的文件，点击下拉列表中的文件名（如果有）。

如果您想搜索一个文件，可以使用星号 (*) 作为通配符。例如，可以输入 *.* 查看所有文件列表。还可以输入文件的完整路径，例如 C:\Mydocs\Letter.doc。

文件类型

列出要显示的文件类型

格式

指定文件打开的格式。用户可以选择页面编码或特定的 Unicode 格式显示文件。

以只读方式打开

表示您可以阅读该文件但无法对其进行更改。

交换数据流

交换数据流允许文件与多个数据流相关联。例如，类似 text.txt 的文件可以具有名称为 text.txt:secret.txt（格式为 filename:ads）的 ADS，只能通过已知 ADS 名称或专门的目录浏览程序访问。

交换流在原始文件大小中不易觉察，但在删除原始文件（即 text.txt）或将该文件复制/移动到不支持 ADS 的分区（如 FAT 分区，软盘或网络共享）时会丢失。虽然 ADS 是一项有用的功能，但如果在遗忘或未删除的未知情况下会轻易吞食硬盘空间。

该功能仅在如果文件位于 NTFS 驱动器上时支持。

我的最近使用的文档

显示最近打开过的文件和文件夹

桌面

显示桌面上的文件、文件夹、程序快捷方式和其它项目

我的电脑

显示与这台电脑连接的磁盘驱动器和硬件

网上邻居

显示网站快捷方式、网络电脑和 ftp 站点

UltraEdit 允许从文件列表中一次选择多个文件并打开（除了在 Windows NT 中使用 UltraEdit-32，* 参考以下内容）。要选择多个文件，先从文件列表中选择第一个文件，然后按下 CTRL 键，选择列表中的其它文件。当所有文件选定后，点击“确定”按钮，所有选定的文件将被同时打开。

还可以通过从文件管理器拖放到 UltraEdit 窗口的方式打开文件。（释放鼠标按钮）。

*Windows NT (版本 4.0 之前) 的普通操作不允许选择长文件名，以及从打开对话框进行多重选择。为方便操作，打开对话框一般只允许选择单个长文件名的文件。但如果在文件打开对话框调用时按下 SHIFT 键，则可以选择多个短文件名的文件。


FTP 帐户对话框

FTP 帐户管理器

这对话框允许用户FTP帐户被配置。 这个帐户被用于 FTP 打开, FTP 另存为 和FTP 浏览命令。

帐户指定将被用于连接到的服务器和将被连接的服务器的用户。

增加帐户 按钮允许您指定一个新的帐户名。 帐户的修改您可以从帐户列表里选择。 如果对帐户做了任何修改都会被提示，该修改是否应该被保留。

删除帐户 按钮将从帐户列表里立刻删除激活的或被选择的帐户。

The 默认帐户 按钮设置激活的或被选择的帐户作为指定的默认帐户,是通过跟随在列表帐户名后面的星号"*" 指定的。

The FTP 帐户管理器有选项，通过在以下五个不同标签被组织在一起: 常规, 服务器, 高级, 代理, 和 SSH/SSL.

常规 标签包括以下配置选项:

帐户

这是为配置的帐户将使用的名字。 当修改被保存，这个名字将出现于在配置选项左边列表里。

协议

这下拉框允许用户选择用户指定下面传输协议之一:

FTP | 创建非安全的FTP 连接。
SFTP | 创建安全的使用SSH2协议的FTP (SFTP)连接。
FTPS - 仅控制 | 创建在标准FTP协议下用SSL层的安全的FTP (FTPS)连接。这种方法仅将控制隧道加密。
FTPS - 控制 + 数据 | 创建在标准FTP协议下用SSL层的安全的FTP (FTPS)连接。 这种方法将控制和数据隧道加密。
FTPS - Implicit | 创建在标准FTP协议下用SSL层的安全的FTP (FTPS)连接。 这种方法是旧FTPS方法并且一般不推荐, 但是它仍支持一些服务器。

所有的SFTP/FTPS传输被加密并且解密算法通过和服务器协商。 假如他们中任何设置传输对话框 显示"lock"字符显示传输是安全的。

Server

这是您希望连接的ftp站点例如ftp://ftp.idmcomp.com. 这也可能登录 ftp.idmcomp.com. 假如在表单里xxxx.xxxx.xxxx.xxxx首选IP 地址可能被登录

端口

对于FTP/SFTP协议，UltraEdit/UEStudio使用这个端口。 默认FTP是21,SFTP是22. 假如必要，这个端口可以被修改。

用户名

这是登录到服务器上使用的用户名。

密码

这是登录到服务器上使用的密码。 这应该是用户名的密码，如所提供的站点管理，或者为匿名在网络上联接主机[服务器]的操作典型的是用户的电子邮件。

保存密码

这个复选框确定UltraEdit/UEStudio是否为以后做参考将保存密码。 否则，将提示用户需求输入密码。 注： 如果密码被保存在系统里存储。 然而它被加密，加密机制是不复杂，并且不应该依靠作为安全方法。

用户帐户

当登录时，这在Host服务器允许用户指定帐户。 这仅要求一些服务器。

连接限制

这个设置限制FTP客户用服务器将建立并发连接的数量。 例如，如果用户通过FTP选择10个文件打开或保存，但是连接极限设置到4， 选择的文件传输接近4或少于4，直到传输所有选择的文件。

初始化目录

这是初始化目录连接到在FTP服务器。 没有需要这。 如果这没有指定， UltraEdit将记住每次用户连接到服务器帐户的最后目录。

初始化本地目录

当连接FTP服务器时，使用初始化本地目录。 FTP浏览选项仅被使用， 这个没有被要求。 假如没有被指定, UltraEdit 将默认到用户的文档文件夹(也就是在Windows XP的我的文档和在Windows Vista的文档)。

Server标签包括下面配置选项:

Server类型

为多数FTP服务器默认自动或Unix应该没有问题工作。 然而这提供与需要特殊句柄的服务器的连接。 支持的服务器列表预计增长。 目前支持:

Auto

AIX

VAX/VMS

UNIX

AIX

Stratus VOS - "全路径主字符" 应该设置成 "%" 并且"路径/节点分隔字符" 应该设置成 ">".

File Name Only - 这发生第一个字段返回并且并且显示它作为文件名。

BS2000

MVS

OS9000

AS400

HP3000/VeSoft Security

Tandem Guardian

会话名

对于当前的帐户，这个字段过去习惯于定义为会话名 。 这仅使用于HP3000 帐户。

登录后发送

在这个字段输入的任何值在连接到服务器后将立即传给FTP服务器。

LIST命令过滤器

当发出LIST命令时，LIST命令过滤器确定从服务器检索什么。 在多数FTP服务器上，如果您通过" - al" 您将收到一个完整的列表包括隐含文件。 您能也通过通配符。 例如" *.txt" 将列出所有txt文件。 注意有些服务器(VMS, MVS,等等)不句柄象Unix或Linux服务器的过滤器arguments。

全路径主字符

这允许用户忽略在服务器上一个文件的全路径上的主字符(通常“/")。

路径/节点分隔符号

这允许用户忽略在服务器上的目录或节点之使用字符(通常“/")。

名字索引

这个字段被用于指定存放文件的名字的列数。 这个值的默认是"-1" 并且不应该改变，除非您确信应该使用这个值。

大小索引

这个字段被用于指定存放文件的名字的列数。 这个值的默认是"-1" 并且不应该改变，除非您确信应该使用这个值。

使用MDTM和大小

如果修改过的时间和大小的文件没有正确返回，这个被选择的选项强制这些值在目录列表里返回的每个文件正确 地要求。 选择此项可能将减速FTP过程。

被动传输

因为FTP是port-hopping协议(也就是：当通讯时数据隧道使用任意端口), 许多防火墙能够理解FTP协议并且允许二次数据连接。然而假如控制连接使用任何方法被加密，防火墙不能能够从控制连接的数据连接得到端口号(由于被加密并且防火墙不能解密。因此许多防火墙网络清除FTP连接，SFTP/FTPS连接或者完全失败或者要求使用被动模式。

使用服务器返回的IP地址

这个值当被动传输选项被选择时仅使用。 当连接到服务器时，选择这个选项强制帐户使用防火墙指定的IP地址。 请注意： 如果您不控制服务器您连接对或不能确信的它的内容，有选择这个选项相关的安全风险。

高级标签包括下面配置选项:

本地复制目录

当文件被保存时，这允许用户指定一个本地复制应该自动地保存文件在哪里。 如果这是空白的本地复制没有发生。如果这不是空的， 当FTP保存发生(没有另存为)文件的拷贝在被指定的目录里被保存。 如果另一个文件存在相同的名字它将不用警告被覆盖。 本地复制优先于FTP保存。

如果没保存会话缓存密码

如果这个被选择帐户的密码一旦在这期间输入被缓存，UltraEdit将运行并且不需要被再次输入。 如果密码不正确地输入，需要进入帐户对话框改变和删除它并且清理缓存。

默认传输类型

用户可以指定 ASCII或者二进制 作为默认传输类型。 ASCII 造成文件为不同系统之间的行终止适当地被转换。 二进制 造成文件按字节传输没有转换。 依赖于FTP服务器/客户端, ASCII传输可能把文件误当成7-bit传输。 因为这个原因，二进制被作为首选传输类型。

显示过滤器

当连接到FTP服务器后，过滤目录列表返回已存在的两个选项:

远程 - 使用LIST命令

假如这个选项被选择，使用列表命令，来自FTP服务器的目录列表返回过滤将在FTP服务器上被执行。结果可能被使用标准通配符过滤。例如 "*.txt" 显示所有txt文件。注意有些服务器(VMS, MVS, etc)不能处理filter像Unix/Linux服务器。

本地 - Perl规则表达式

假如这个选项被选择，来自FTP服务器的目录列表返回过滤将在本地系统上被执行。并且是从FTP服务器返回仅解析的数据，在FTP日志有记录。这个选项将使用Perl正则表达式确定应该返回过滤表达式应该怎样解析，并且应该返回什么数据。

The Proxy 标签包括以下配置选项:

使用代理

这个允许Proxy设置和配置这个帐户通过指定的代理连接。 如果直接连接到互联网不允许使用代理设置。 如果在局域网通过代理连接，设定代理设置将是必要的。

代理服务器

这是用来使用作为代理的服务器的名字(或者 IP 地址)。 假如您不知道这个名字，请与您的系统管理员协商。

代理端口

这是用于FTP/SFTP协议UltraEdit/UEStudio使用的端口。 默认FTP是21端口，SFTP是22端口。 假如需要这个可以被更改。

代理用户

这是用户名被用作登录代理。 假如您不知道这个名字，请与您的系统管理员协商。

代理密码

这是密码被用作登录代理。 假如您不知道这个名字，请与您的系统管理员协商。

代理类型

这个下拉框被用作指定当前FTP帐户使用的Proxy类型。 T下面Proxy类型被现在支持:

SOCKS4

SOCKS4A

SOCKS5

WEB Proxy

Relay

Windows (Internet Explorer)

FTP User

FTP Site

FTP Open

请注意不是所有的代理对每个协议都有效。

SSH/SSL标签包括以下配置选项:

认证

这允许用户指定服务器使用的认证类型。 下面方法被支持:

仅密码 | 这要求提供用户名/密码和使用非公共密钥/私密钥配对或者SSL证书。
仅公共密钥/SSL证书 | 这要求用户使用公共密钥/私密钥配对或者SSL证书。 私钥/SSL证书的位置必须在私密钥/SSL证书路径里指定。
密码 & 公共密钥/SSL证书 | 这允许用户指定公钥/私钥或者SSL证书并且/或者用户名/密码。
密钥要求密码 | 假如这个选项被选择，在常规标签下的用户名字段必须被填上。

如果使用这种方法要求密钥, 密钥要求密码 选项允许用户表明私钥是被保护的密码。 如果这是实际情形，每次会话将提示用户输入密码，或者在改变帐户设置以后。

认证方法必须通过服务器支持。 对于SFTP,密钥应该使用OpenSSH 格式。 对于FTPS, 应该使用在PEM或PFX格式里加载的证书。

允许压缩

假如这个选项被选择, 当传输到服务器/从服务器传输，数据被压缩。 依赖于服务器配置，这可能提高传输速度。


INI File Selection and Advanced Settings

INI 文件选择和高级设置

UltraEdit/UEStudio 用 INI 文件保存多数配置。 它允许用户在不同配置下选择 INI 文件，并且允许用户在其它网络工作站中使用 UltraEdit/UEStudio 时保持 UltraEdit/UEStudio 的基本设置。

UltraEdit-32 默认使用的 INI 文件是 UEDIT32.INI，UESTUDIO 则使用的是 UESTUDIO.INI。

请注意，INI 设置是区分大小写的。

告诉 UltraEdit 要使用哪个 INI 文件

如果不考虑默认的动作，你可以使用命令行参数、环境变量或添加一个 INI 文件到包含 UltraEdit 的目录。

规则如下：

先检查命令行。如果命令行包含 "/I=filename"”，那么将使用这个 INI 文件。

例如：/i=c:\windows\uedit32.ini

文件名必须直接跟随在 /i= 后面。 它可以是一个带空格的长名字，在这种情况下，它必须包含在引号中。

如果没有找到命令行参数，将检查环境变量。 请注意，环境变量指定包含 INI 文件的目录，不带 INI 文件的文件名本身。 环境变量名是 UEINIDIR。 如果定义了环境变量，UltraEdit 会尝试使用这个包含默认 INI 文件名的目录。 对于 UEStudio, 环境变量名称为 UESINIDIR。如果已定义，UEStudio 常试使用该目录和默认的 INI 文件名。

最后，UltraEdit 会在与正在运行的 EXE 文件的同一目录寻找 INI 文件。如果那里没有 INI 文件，UltraEdit 将检查 Windows 目录下面的与老版本兼容的 INI 文件，如果还是没有找到，将使用 %APPDATA% 文件夹。

高级 INI 设置

另外有一些 INI 设置还没有提供可以在程序中进行设置的用户界面，比如，你不能在 UltraEdit 中使用一个对话框或菜单功能直接更改这些设置，这些还没有提供给支持用户请求。

*** 请注意 - 这些项目的大多数可以直接在“高级菜单 - 配置”中直接进行设置。 ***

这些应该总是添加到 [Settings] 下面。

AllowZeros = 1

这个设置允许用户在没有将 NULLS (十六进制 00) 转换到空格的文本模式中编辑包含 NULLS 的文件。NULLS 通常被视为字符终止符，一般在 ASCII 文件中无效。使用这个设置可能会导致一些遇到 NULL 的功能不能正确动作，但应该不会影响普通编辑。

Auto Reformat = 1

如果自动换行设置设为在指定的列号用硬回车 (CR/LF) 插入换行，这个设置会使编辑器在粘贴命令执行后段落重排。UltraEdit 默认执行这个动作，将这个值设为 0 则禁用这个功能。

Caret Char = "一些字符"

这个设置允许在查找/替换中使用其它字符来代替脱字符“^”。该字符应包含在引号中，推荐你使用竖线字符“|”，或其它类似的非公共字符。

Caret Type= 0,1,2

这个设置用来确定脱字符的类型。如果设为 0 (默认)，在插入模式中，脱字符将是一个竖线，在覆盖模式中，则显示一个块脱字符。如果设为 1，那么禁用块脱字符。如果设为 2，脱字符类型将颠倒，在插入模式中，脱字符将是一个块脱字符，在覆盖模式中则使用竖线。

Change Read Only = 1

这个设置用来确定在 编辑菜单 使用更改只读状态时是否确实改变文件的真实属性。如果设为 0 (默认)，则只更改编辑状态内部的只读状态，如果设为 1，则同时更改文件的属性。

Column Overstrike = 1

将这个设置设为 1，列操作根据键盘的插入/覆盖键设置来确定插入模式 (默认) 覆盖模式操作方式。这可以用 Insert 键进行切换，并在状态栏中显示。

如果在覆盖模式，剪切/删除操作将删除内容，但保留空格，因此列数据不能移位。粘贴操作将覆盖当前位置的数据，且不移动列的位置。

如果你在列模式编辑中将覆盖模式作为首选项，你可以将 INI 值设为 2。

Compare EXE = "EXE 文件完整路径"

这个设置允许用户指定其它文件比较程序，来替换 UltraEdit 提供的标准工具。UltraEdit 将用这个工具来替换它自带的工具。工具的命令行参数只能是要比较的文件的文件名 (带路径)。

ConvertKBDInput = 1

这个设置用来指示 UltraEdit 如果选择了 OEM 字体的情况下，从 ANSI 到 OEM 转换键盘输入。默认设置是不执行任何转换。

Create New File = 1

这个设置告诉 UltraEdit 如果在命令行打开的指定文件不存在，则创建一个新文件。默认设置是创建新文件。将这个设置设为 0 会使 UltraEdit 不创建新文件。

Default File Type = 0, 1 或 2

这个设置确定在 UltraEdit 内部创建的新文件的文件类型。默认 (0) 表示创建 DOS 文件。将这个选项设为 1 表示创建 UNIX 文件，2 表示 MAC 文件。

Delete Before Save = 1

这个设置命令 UltraEdit 在保存文件前删除原始文件。在一些场合下用户可能会在特别情况要求这么做，一般不需要设置。

DisableFlatToolBar = 1

这个设置在 Windows 95 和 Windows NT 4.0 以及高版本的操作系统中禁用“平直”样式工具栏。如果使用这个设置，工具栏将用凸起的按钮显示，按钮间用分隔线分隔显示。

DontUseRename = 1

这个设置影响 UltraEdit 生成备份文件的方式。原因是在一些系统中，如果 UltraEdit 用重命名来备份原始文件的话，在重新创建时不能维持原先存在的文件权限。

这个设置告诉命令 UltraEdit 复制原始文件到备份，而不是重命名它。这个动作比重命名慢，但可以维持文件权限。

Ignore File Delete = 1

这个设置用来命令当 UltraEdit 发现在编辑器打开的文件已被删除时不通知用户。如果这个选项未设置 (默认)，并且文件更改侦测已启用 (在配置中)，UltraEdit 将在文件被删除后通知用户。

Large File Buffers = 1

这个设置确定 UltraEdit 是否应该在执行某些操作时使用较大缓冲。这可以在处理非常大文件时加速一些操作，但它非常依赖硬件配置。

Lock File = 1

这个设置会导致编辑器锁定已打开的所有文件。另外，如果文件已经锁定，打开时会用一个对话框提示用户，确认并允许用户以只读模式打开。这个功能可以防止文件在编辑期间被其它程序修改而导致原先所作的修改丢失。

Make Changed Files Active = 1

这个设置告诉 UltraEdit 发现文件已更改并重新载入后，使该文件处于活动状态。默认设置 0 表示不激活文件。

Max Columns =

这个设置用来设置在换行 (软换行) 前，UltraEdit 内部允许的最大列。默认值是 4096 列，但最大只允许 20,000 列。设置太高时一些显示驱动程序可能会有问题。

New File = 0

这个设置会使 UltraEdit 在不带其它文件的情况下打开时，不创建一个新的空文件。默认设置是如果启动时没有自动打开的文件则创建一个新的文档文件。

No Temp Confirm = 0

这个设置会禁用不生成临时文件打开文件时的询问确认的对话框。

NoLeftCursorToPrevLine = 1

如果光标位于行首，这个设置会导致 UltraEdit 在按下向左箭头键时不会移动到上一行。默认设置是 UltraEdit 在这种场合下，允许光移动到上一行末。

One Based Ruler = 1

这个设置会使编辑器标尺用 1 开始。默认设置 0 会使 UltraEdit 的标尺以 0 开头。

Open Link Files = 1

这个设置会导致编辑器直接打开快捷方式文件。默认设置 (不设置这个选项) 会导致 UltraEdit 展开链接打开根文件。

Open Maximized = 1

这个设置确定 UltraEdit 是否应该总是以最大化状态打开它的主窗口。默认设置是 UltraEdit 记住上一次窗口设置。如果这个选项设为 1，UltraEdit 将以最大化状态打开主窗口。

ReformatBreakHyphens = 0

这个设置确定 UltraEdit 是否应该在重新格式化行时在连字符处断开。默认是在连字符处断开。 如果这个设置设为 0，UltraEdit 在遇到连字号时不换行。

Reload FTP Files = 1

这个设置确定 UltraEdit 在重新载入方案/工作区中的文件时是否也应该重新载入 FTP 文件。一般来说，由于可能会发生连接和载入文件时的时间延迟，UltraEdit 不自动重新载入 FTP 文件。这个选项设为 1，UltraEdit 在这一点上，将 FTP 视作为普通文件处理。

Show Tag Descriptions = 1

这个设置确定 UltraEdit 是否应该在标签列表显示标签的描述。默认标签是显示的。如果这个值设为 0，标签将不显示。

Temp File Dir = "directory"

这个设置允许用户指定放置编辑时 UltraEdit 创建的临时文件的目录。通常不用设置这个选项，但如果编辑大文件，并且临时目录中没有足够的空间贮存 UltraEdit 创建的临时文件时，可以使用这个设置。

TitleNameOnly = 0

这个设置允许用户指定 UltraEdit 只在编辑器窗口的标题栏显示文件名，不显示路径。如果这个选项未选中，将显示文件名和路径 (默认)。如果这个选项设为 1，则只显示文件名。

UIType = 2

这个设置允许用户指定 UltraEdit 使用“老样式” (版本 9 之前) 的菜单和工具栏。按默认，这个选项未设置。要使用老样式工具栏和菜单，则应该设置这个选项。这起先是为了一些使用屏幕阅读程序的用户，与最新的菜单不兼容。另外还可以提高 UltraEdit 载入时的性能。如果选定这个选项，UltraEdit 将只支持单工具栏，并且不支持菜单配置。

Use DDE Associations = 0

当从 UltraEdit 内部设置文件关联时，通常会使用 DDE 在注册表中设置指定的文件类型。在某些系统中，从资源管理器双击文件时，可能会导致出现错误消息。在这种情况下，使用 DDE Associations = 0 可以解决此问题。文件关联将需要这个修改才能生效。

Use Registry = 1

这个设置会使编辑器将所有设置保存到注册表，并从注册表查找设置。UltraEdit 在读取其它值之前，先会检查使用中的 INI 文件中的这个值。如果设置了这个选项，UltraEdit 强制所有的设置贮存到注册表中。


插入文字字符

这个命令允许在文件中插入文字字符 (象 Control C)。按 Ctrl+I 告诉 UltraEdit 要直接插入到文件的下一个字符不进行任何转换。

这通常用于插入打印机或其它设置可能需要的控制代码。

例如:

Ctrl+I 后面按 Ctrl+C 在文件中插入一个 Control C 字符

Ctrl+I 后面按 ESC 在文件中插入一个 escape 字符

快捷键: Ctrl+I


大文件处理

UltraEdit 允许编辑非常大的文件。但它占用的内存数量并不高。UltraEdit 是一个基于磁盘的编辑器，一次只载入文件的小部分到内存中。通常 UltraEdit 会复制要编辑的文件到临时文件，并在编辑结束后复制回原始文件。要加速大文件的编辑速度，可以在 普通配置页 中指定不使用临时文件进行编辑。这个选项会缩短复制文件到临时文件所需要的时间。这对于编辑兆字节文件非常有优势。

警告 - 如果选中这个选项，所有的更改是永久性的!

会显示一个对话框，在每次打开文件时警告用户这个设置已启用。这个选项可以用 普通配置页 中的“编辑时使用临时文件”来禁用。

“极限”对象用来让用户指定当载入等于或大于这个值的文件时不创建临时文件。小于这个值的文件将用常规方法载入，创建一个临时文件。将这个值设为零表示所有的文件载入均不创建临时文件。“极限”对象只能在设置了“不使用临时文件打开文件”选项时才能使用。

另外，在处理大文件时，禁用行号选项可以改进程序性能，它不需要频繁的访问来跟踪行号。

UltraEdit 允许编辑大于 4GB (大小在 2^64-1 以下) 的文件。


最新版本

最新版本的 UltraEdit/UltraEdit-32 可以在下面几个地方找到:

下列网站:

http://www.idmcomp.com/ 和 http://www.ultraedit.com/

在 CompuServe 的 WINUSER 论坛，有未来升级的官方分布和在线支持资源。搜索 ULTRAEDIT.ZIP 和 UEDIT32.ZIP。

Windows Users Group Network (WUGNET)，CIS 中的 Windows 用户的最老最大的独立支持资源论坛 (WINUSER)，有接近 1,000,000 的注册用户，是用户组、开发人员和 Microsoft 作为首要共享软件资源在 CompuServe 和 Internet 发布。

其它 Internet 上的一些站点，包括 CICA 等。


宏定义对话框

当从宏 录制命令 或从 编辑宏命令 创建一个新宏时，会打开宏定义对话框。

在那里你可以命名宏，并给宏分配一个热键。 按确定按钮后，如果是从宏录制命令调用，则开始执行宏录制命令。

热键分配允许用户指定用来自动调用该宏的组合键。 如果选择的键分配已经被 UltraEdit 使用，键分配将覆盖 UltraEdit 的键分配。

焦点位于热键字段时按任何组合键可以为宏指定热键。用户还可以根据需要在弦字段指定弦。 弦与指定的热键一起用于调用宏。

输入名字或分配热键/弦不是必需项。

为使宏可以更快速执行，你可能不希望出现这个对话框，可以通过取消“显示这个宏的取消对话框”选项来禁用。

在宏执行期间，查找和替换命令可能会导致搜索字符未找到。在这种情况下默认的动作是停止宏执行。对于一些宏，在执行全部替换命令时不希望停止宏的执行。在这种情况下，请选中“如果未找到要替换的内容则继续”选项。


多次打开程序

多次打开程序 (普通配置页)

多次打开程序项目确定在 UltraEdit 的一个副本已经在运行的情况下，是否允许再次运行另外的 UltraEdit 程序。如果启用这个选项，那么每次调用 UltraEdit 均会打开一个 UltraEdit 的窗口，并激活最后一次打开的窗口。


.NET Framework 代码保护器对话框

这个对话框用于配置 .NET 可执行文件的代码保护选项，以防止被一些用户反编译工作代码。按“...”按钮将弹出选择 .NET 可执行文件的对话框，用户可以浏览要保护的 .NET 可执行文件。

在选定要保护的可执行文件项目中，可以随意选择下列选项。


新建文件夹对话框

新建文件夹对话框允许用户指定要添加到活动方案的文件夹设置。

文件夹字段指定要添加到活动方案中的本地文件夹的完整路径。如果选中组复选框，则所有其他项目被抑制，且添加的文件夹仅作为方案内部组织的位置标志符，且不涉及本地系统上的实际文件夹。

筛选字段指定在已添加的文件夹中显示的文件扩展名。

如果选中链接文件夹到 FTP/SFTP 地址，则可以使用以下选项：

FTP/SFTP 帐号字段指定与已添加的文件夹相关联的帐号。已添加的文件夹将作为远程服务器上指定文件夹的镜像。

远程路径字段指定远程服务器上与已添加文件夹相关的目录的路径.

最大递归层次字段用于指定特定远程文件夹的子目录数目，此远程文件夹将包含于已添加的文件夹中。

服务器时钟脉冲相位差设置涉及本地/远程文件同步。用户可以在时间戳里指定不同的秒数，用于同步方案文件夹与远程文件夹时，本地文件/文件夹和应该忽略的远程文件/文件夹之间的秒数。这将在某系统的时间不准确时，允许本地和远程系统之间的时区差异，以及一些小差别。


下一个窗口命令 (文档控制菜单)

这个命令用来切换到下一个打开的窗口。UltraEdit 依照你打开窗口的顺序来确定哪一个是下一个窗口。

快捷键: CTRL+F6


上一个窗口命令 (文档控制菜单)

使用这个命令切换到上一个打开的文档窗口。UltraEdit 依照你打开窗口的顺序来确定哪一个是上一个打开的窗口。

快捷键: SHIFT+CTRL+F6


打印对话框

下列选项可以让你指定文档打印方式:

打印机

这是活动打印机以及打印机连接。选择设置选项更改打印机和打印机连接。

设置

显示 打印设置对话框 ，使你可以选择打印机和打印机连接。

打印范围

指定你想打印的页面:

全部 打印整个文档。

选定范围 打印当前选定的文本。

页码范围 打印你在“从”和“到”对象中指定的页面范围。

份数

指定你想打印上述页面范围的份数。

自动分页

按页码顺序打印副本，而不是每个单独的多页副本打印。

打印质量

选择打印质量，一般较低质量的打印可以减少生成的时间。


打印预览工具栏

打印预览工具栏向你提供下列选项:

打印

打开打印对话框，开始进行打印。

下一页

预览下一个打印页面。

上一页

预览上一个打印页面。

一页/两页

同时预览一页或两页打印页面。

放大

放大预览页面，可以更清楚地看清打印内容。

缩小

缩小预览页面，可以更全面审视打印页面。

关闭

从打印预览视图返回到编辑窗口。


打印进度对话框

UltraEdit 正在向打印机输出期间显示的正在打印对话框。页码表示打印的进度。

要中断打印，按取消按钮。


打印设置对话框

可以用下列选项选择目标打印机和它的连接。

打印机

选择你想使用的打印机。可以选择默认打印机或指定的打印机，即选择框中显示的已安装的打印机。你可以使用 Windows 控制面板来安装打印机，并配置端口。

方向

选择纵向或横向打印。

纸张大小

选择要打印文档的纸张的大小。

纸张来源

一些打印机提供多盘不同的纸张来源。在这里指定纸张来源。

选项

显示一个对话框，你可以在那里选择有关你已经选定的打印机类型的另外打印选项。

网络...

选择这个按钮连接到网络位置，给它分配一个新的驱动器卷标。


方案转换对话框

这个对话框可以用于将一个现有的 Visual Studio 方案/工作区/解决方案转换到 UEStudio 方案格式。请注意: 这个功能只在 UEStudio 中支持，UltraEdit-32 不支持这个功能。

用户按“...”按钮可以浏览选择要用 UEStudio 进行处理的 Visual Studio 方案、工作区或解法文件。

如果选定了打印转换后的方案/工作区，那么选定的项目将在转换后在 UEStudio 中打开。如果在资源管理器进行查看，转换后的方案将用“.prw”扩展名列出。


方案设置对话框

方案设置对话框用于配置活动方案的选项。

UltraEdit-32 方案设置对话框

UEStudio 方案设置对话框

方案目录

UltraEdit / UEStudio 允许指定方案目录。如果可能的话，UltraEdit 将使用相对路径。如果没有这个可能，在文件添加到方案中时将使用绝对路径。

在某些情况下，这有利于组合多个文件集到单个方案内部。UltraEdit 提供将这些文件组合到一个已命名的组中的功能。这些组在需要的情况下可以添加或删除，文件可以添加到每个组。

可选词语文件

可选词语文件条目框允许用户指定在方案激活时，用于 语法加亮 的其它词语文件。如果路径是完整路径，它将是一个词语文件的绝对路径，否则路径应该是相对于方案目录或方案文件（根据上面的设置）的相对路径。

CTAGS 文件

CTAGS 文件条目框允许用户指定用于存储 CTAGS 函数的文件。该选项也可以选择为在方案载入时创建 CTAG 文件。如果选中该项目，UltraEdit-32 将在方案载入时自动创建 CTAGS 标签文件。这些选项仅在选中传统 Ctags 支持（UltraEdit 风格）复选框时可用。

文件夹选项

选定时，包含文件夹中的子文件夹选项会使 UltraEdit 在文件夹添加到方案时，递归包含所有的子文件夹。如果指定了过滤(例如 *.c)，那么只有匹配扩展名的文件将被视为方案的一部分。如果在文件树视图中的文件夹指定了过滤，那么该过滤将只应用到选定的文件夹，并不考虑在方案设置对话框中设置的方案定义的过滤。

* 可编译

该选择框用设置/更改编译器按钮、编译器选项按钮和构建模式下拉框激活。如果未选定，这些项目不能被修改，并且在方案载入时不激活 构建工具栏 （只能用于 UEStudio）。

* 设置/更改编译器

按下此按钮打开 选择编译器对话框 ，这可以用来选择活动方案的编译器，并配置编译器设置。

* 编译器选项

按下此按钮打开 编译器选项对话框 ，这可以用来配置在这个活动方案中使用的选定的编译器。

* 构建模式

活动方案的构建模式可以使用构建模式下拉框设为调试或发布。这也可以在 构建工具栏 中进行修改。

* 版本控制支持

要激活 CVS 提交 和 更新 命令 (在 方案菜单 的 CVS 子菜单顶部)，必需选定这个选择框。如果未选择这个选项，以及未指定方案的 CVS 模块目录，那么顶部的两个选项将不可用，活动方案的 CVS 选项将不能进行配置。如果未选定这个选项，在点击一个文件时，文件树视图中的 CVS 的上下文菜单选项将不能用。

* 管理 VCS 模块

按下此按钮将显示 VCS 管理对话框，在此可以指定 CVS/子版本账户的设置。

* 在方案文件中保存版本控制帐户信息

如果选中该选项，则方案中每个选中的模块将在方案文件中保存账户信息，作为保存在 INI 文件中的实际账户信息的备份。

* CVS 模块目录

用户可以在这里指定用于活动方案的 CVS 模块路径。如果这是首选项，按浏览按钮可以用于浏览模块目录。

在文件夹里包括子文件夹

选中这个设置后，当方案中添加一个文件夹，会使所有子文件夹和适当的文件被添加到方案中。如果设置，在任何时候引用方案文件，文件的递归搜索将同时执行于主文件夹下的子文件夹。

过滤

过滤项目是用来让用户指定将应用到文件夹组部分的文件的文件过滤。当文件夹更新时，只有匹配过滤的文件被添加到组中。

选择方案调试器

该下拉列表允许用户使用外部调试器或集成的 WinDbg。如果选中外部调试器，则启动外部调试器但不支持集成的调试。这用于尚未集成到 UEStudio 中的调试器。如果选中集成的 WinDbg作为方案调试器（当前仅用于使用 Microsoft C/C++ 编译器构建的方案），则在 UEStudio 中支持集成的调试。

如果 WinDbg 尚未下载且未安装，则可以从配置的 IDE/调试器分支中下载。

工作目录

工作目录字段可以指定活动方案使用的调试器的工作目录。必须指定工作目录的完整路径。

程序参数

程序参数字段用于指定传递给当前正在调试的进程的参数。

符号路径

符号路径字段用于指定活动方案使用的符号的路径。用户可以浏览到使用中符号保存的路径，而无需需要时直接指定。 必须指定该目录的完整路径。可以指定多个路径，使用分号“;”隔开。

* 请注意：这些项目仅在 UEStudio 中包含，在 UltraEdit-32 中不支持。


方案模板

UEStudio 默认支持几种不同的方案模板，可以使用“方案模板”对话框里的图标来创建。默认模板的简短摘要如下：

Windows 应用程序

窗口应用程序是可执行的应用程序（.EXE），调用 Win32 API，而非调用 MFC 类。UEStudio 将为程序创建工作区和方案文件，然后可以在上面添加自己的代码。

控制台应用程序

控制台应用程序使用“控制台 API”函数来开发，它提供了控制台窗口下的字符模式支持。 UEStudio 将为程序创建工作区和方案文件，然后可以在上面添加自己的元素。

对话框应用程序

对话框应用程序基于对话框窗口。这些与 Visual Studio 向导里面相同。

动态链接库

动态链接库是二进制文件（调用 Win32 API，而非调用 MFC 类），作为函数共享库可以同时用于多个应用程序。UEStudio 将为程序创建工作区和方案文件，然后可以在上面添加自己的代码。

静态库

静态库是一个文件，包含对象及其函数和数据，它们在构建可执行文件时链接到该程序中。 可以链接静态库到基于 MFC 的程序，或链接到以 C 或 C++ 编写的非-MFC 的 for Windows 程序， 它会调用 Win32 API，而非调用 MFC 类。

实用程序方案（空白/用户定义方案）

创建空白方案（或用户定义模板）时，未向该方案添加任何文件。空白方案不生成任何预定的输出文件，例如 .LIB, .DLL 或 .EXE。空白方案可以作为容器用于构建无需链接步骤的文件。可以将空白方案用作子方案的主方案，并且空白方案可以导出 MAKEFILE。


Regular Expressions (Perl Style)

UltraEdit/UEStudio now support Perl style regular expressions using the Boost C++ Libraries. The Perl regular expression syntax is based on that used by the programming language Perl.

Perl Regular Expression Syntax

In Perl regular expressions, all characters match themselves except for the following special characters:

.[{()\*+?|^$

Wildcard

The single character '.' when used outside of a character set will match any single character.

Anchors

A '^' character shall match the start of a line.

A '$' character shall match the end of a line.

Marked sub-expressions

A section beginning ( and ending ) acts as a marked sub-expression. Whatever matched the sub-expression is split out in a separate field by the matching algorithms. Marked sub-expressions can also repeated, or referred to by a back-reference.

Alternation

The | operator will match either of its arguments, so for example: abc|def will match either "abc" or "def".

Parenthesis can be used to group alternations, for example: ab(d|ef) will match either of "abd" or "abef".

Empty alternatives are not allowed (these are almost always a mistake), but if you really want an empty alternative use (?:) as a placeholder, for example:

"|abc" is not a valid expression, but

"(?:)|abc" is and is equivalent, also the expression:

"(?:abc)??" has exactly the same effect.

Character sets

A character set is a bracket-expression starting with [ and ending with ], it defines a set of characters, and matches any single character that is a member of that set.

A bracket expression may contain any combination of the following:

Single characters

For example [abc], will match any of the characters 'a', 'b', or 'c'.

Character ranges

For example [a-c] will match any single character in the range 'a' to 'c'. By default, for POSIX-Perl regular expressions, a character x is within the range y to z, if it collates within that range; this results in locale specific behavior.

Negation

If the bracket-expression begins with the ^ character, then it matches the complement of the characters it contains, for example [^a-c] matches any character that is not in the range a-c.

Character classes

An expression of the form [[:name:]] matches the named character class "name", for example [[:lower:]] matches any lower case character. The following character class names are always supported:

Name | POSIX-standard | Description
alnum | Yes | Any alpha-numeric character.
alpha | Yes | Any alphabetic character.
blank | Yes | Any whitespace character that is not a line separator.
cntrl | Yes | Any control character.
d | No | Any decimal digit
digit | Yes | Any decimal digit.
graph | Yes | Any graphical character.
l | No | Any lower case character.
lower | Yes | Any lower case character.
print | Yes | Any printable character.
punct | Yes | Any punctuation character.
s | No | Any whitespace character.
space | Yes | Any whitespace character.
unicode | No | Any extended character whose code point is above 255 in value.
u | No | Any upper case character.
upper | Yes | Any upper case character.
w | No | Any word character (alphanumeric characters plus the underscore).
word | No | Any word character (alphanumeric characters plus the underscore).
xdigit | Yes | Any hexadecimal digit character.

Escapes

Any special character preceded by an escape shall match itself. The following escape sequences are also supported:

Escapes matching a specific character

The following escape sequences are all synonyms for single characters:

Escape | Character
\a | '\a'
\e | 0x1B
\f | \f
\n | \n
\r | \r
\t | \t
\v | \v
\b | \b (but only inside a character class declaration).
\cX | An ASCII escape sequence - the character whose code point is X % 32
\xdd | A hexadecimal escape sequence - matches the single character whose code point is 0xdd.
\x{dddd} | A hexadecimal escape sequence - matches the single character whose code point is 0xdddd.
\0ddd | An octal escape sequence - matches the single character whose code point is 0ddd.
\N{name} | Matches the single character which has the symbolic name name. For example \N{newline} matches the single character \n.

"Single character" character classes

Any escaped character x, if x is the name of a character class shall match any character that is a member of that class, and any escaped character X, if x is the name of a character class, shall match any character not in that class. The following are supported by default:

Escape sequence | Equivalent to
\d | [[:digit:]]
\l | [[:lower:]]
\s | [[:space:]]
\u | [[:upper:]]
\w | [[:word:]]
\D | [^[:digit:]]
\L | [^[:lower:]]
\S | [^[:space:]]
\U | [^[:upper:]]
\W | [^[:word:]]

Word Boundaries

The following escape sequences match the boundaries of words:

\< | Matches the start of a word.
\> | Matches the end of a word.
\b | Matches a word boundary (the start or end of a word).
\B | Matches only when not at a word boundary.

For further information/options please see the Boost Libraries Perl Regular Expression syntax pages.

Use, modification and distribution are subject to the Boost Software License, Version 1.0. (See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt).


正则表达式

UltraEdit 允许在 搜索菜单 下面列出的大多数搜索和替换功能中使用正则表达式。

正则表达式允许在一次操作中执行多个组合搜索和替换功能。

这里有两个可以使用的语法集。下面的第一个表显示用于早期 UltraEdit 的原始 UltraEdit 语法。第二个表显示可选的“Unix”样式的正则表达式。这可以从配置段启用。

正则表达式 (UltraEdit 语法):

符号 | 功能
% | 匹配行首 - 表示搜索字符串必须在行首，但不包括任何选定的结果字符中的行终止字符。
$ | 匹配行尾 - 表示搜索字符串必须在行尾，但不包括任何选定的结果字符中的行终止字符。
? | 匹配任何除换行符的字符。
* | 匹配任何除换行符外所出现的任意数量的字符。
+ | 匹配一个或多个前面的字符/表达式。必须找到至少一个出现的字符。不匹配重复的换行符。
++ | 0 次或多次匹配前面的字符/表达式。不匹配重复的换行符。
^b | 匹配一个分页符。
^p | 匹配一个换行符 (CR/LF) (段落) (DOS 文件)
^r | 匹配一个换行符 (仅 CR) (段落) (MAC 文件)
^n | 匹配一个换行符 (仅 LF) (段落) (UNIX 文件)
^t | 匹配一个制表符
[ ] | 匹配任何括号中的单个字符或范围
^{A^}^{B^} | 匹配表达式 A 或 B
^ | 忽略其后的正则表达式字符
^(*^) | 在表达式加上括号或标签在替换命令中使用。正则表达式中可以有 9 个表达式标签，数字根据它们在正则表达式中的次序确定数字。 相应的替换表达式是 ^x，x 的范围是 1-9。例如: 如果 ^(h*o^) ^(f*s^) 匹配“hello folks”，那么^2 ^1 表示将用“folks hello”替换它。

注意 - ^ 这里涉及的字符“^”不是控制键 + 值。

例如:

m?n 匹配“man”、“men”、“min”，但不匹配“moon”。

t*t 匹配“test”、“tonight”和“tea time”中的“tea t”部分，但不匹配“tea

time” (“tea ”和“time”之间有换行)。

Te+st 匹配“test”、“teest”、“teeeest”等，但不匹配“tst”。

[aeiou] 匹配每个元音小写字母

[,.?] 匹配文字“,”、“.”或“?”。

[0-9a-z] 匹配任何数字或小写字母

[~0-9] 匹配除数字外的任何字符 (~ 表示不匹配其后的内容)

你可以搜索象下面一样的表达式 A 或 B:

"^{John^}^{Tom^}

这将搜索 John 或 Tom。在两个表达式之间应该没有任何其它内容。

你可以在同一次搜索象下面一样组合 A 或 B 和 C 或 D:

"^{John^}^{Tom^} ^{Smith^}^{Jones^}"

这将搜索后面跟随了 Smith 或 Jones 的 John 或 Tom。

下面的表显示“Unix”样式的正则表达式语法。

正则表达式 (Unix 语法):

符号 | 功能
\ | 表示下一个字符有特殊含义。“n”表示匹配字符“n”，“\n”匹配一换行符。看下面的例子 (\d、\f、\n 等)。
^ | 匹配/停驻行首。
$ | 匹配/停驻行尾。
* | 匹配前面的字符 0 次或多次。
+ | 匹配前面的字符一次或多次。不匹配重复的换行符。
. | 匹配任何除换行符之外的单个字符。不匹配重复的换行符。
(表达式) | 在表达式加上括号或标签在替换命令中使用。正则表达式中可以有 9 个表达式标签，数字根据它们在正则表达式中的次序确定数字。 相应的替换表达式是 ^x，x 的范围是 1-9。例如: 如果 ^(h*o^) ^(f*s^) 匹配“hello folks”，那么^2 ^1 表示将用“folks hello”替换它。
[xyz] | 字符集，匹配任何括号间的字符。.
[^xyz] | 排除字符集。匹配任何不在括号间的字符。
\d | 匹配一个数字字符。等同于 [0-9]。
\D | 匹配一个非数字字符，等同于 [^0-9]。
\f | 匹配一个换页符。
\n | 匹配一个换行符。
\r | 匹配一个回车符。
\s | 匹配任何包含空格、制表符等不会显示的字符，但不匹配换行符。
\S | 匹配任何非空白区域 (显示字符) 的字符，但不匹配换行符。
\t | 匹配一个制表符。
\v | 匹配一个垂直制表符。
\w | 匹配任何包含下划线的词语。
\W | 匹配任何非词语的字符。
\p | 匹配 CR/LF (等同于 \r\n)，用来匹配 DOS 行终止符。

注意 - ^ 这里所涉及的字符“^”不是控制键 + 值。

例如:

m.n 匹配“man”、“men”、“min”，但不匹配“moon”。

Te+st 匹配“test”、“teest”、“teeeest”等，但不匹配“tst”。

Te*st 匹配“test”、“teest”、“teeeest”等，还有“tst”。

[aeiou] 匹配每个元音小写字母

[,.?] 匹配文字“,”、“.”或“?”。

[0-9a-z] 匹配任何数字或小写字母

[^0-9] 匹配除数字外的任何字符 (~ 表示不匹配其后的内容)

你可以象下面一样的表达式 A 或 B 进行搜索:

"(John|Tom)"

这将搜索 John 或 Tom。在两个表达式之间应该没有任何其它内容。

你可以在同一次搜索象下面一样组合 A 或 B 和 C 或 D:

"(John|Tom) (Smith|Jones)"

这将搜索 Smith 或 Jones 以及跟随在后面的 John 或 Tom。

如果在查找/替换中没有选择使用正则表达式，在替换对象中下列特殊字符同样有效:

符号 | 功能
^^ | 匹配字符“^”
^s | 表示活动文件窗口中选定 (加亮) 的文字。
^c | 表示剪贴表的内容。
^b | 匹配一个分页符。
^p | 匹配一个换行符 (CR/LF) (段落) (DOS 文件)
^r | 匹配一个换行符 (仅 CR) (段落) (MAC 文件)
^n | 匹配一个换行符 (仅 LF) (段落) (UNIX 文件)
^t | 匹配一个制表符

注意 - ^ 这里所涉及的字符“^”不是控制键 + 值。


启动时重新载入打开文件

如果选中这个选项，UltraEdit 在关闭时会保存有关打开文件的信息。这个信息用于下次打开 UltraEdit 时自动载入上次打开的文件。这可以非常方便地重新载入经常使用的文件。如果 UltraEdit 只是在打印时自动调用文件，那么该文件不会重新打开。


另存为对话框

可以用下列选项指定希望保存文件的名字和位置：

保存在

指定您想查找文件或文件夹的位置。点击箭头选择其它位置，或在工具栏点击向上移动一层目录。

下面的框中列出了选定位置的项目。要用现有的文件名保存文件，在保存对话框中双击要保存的文件名。

文件名

提供让用户输入想保存文件名字的区域。要快速查找您先前打开过的文件，点击下拉列表中的文件名（如果有）。

如果您想搜索一个文件，可以使用星号 (*) 作为通配符。例如，可以输入 *.* 查看所有文件列表。还可以输入文件的完整路径，例如 C:\Mydocs\Letter.doc。

如果要保存一个文件，不能在文件名中使用问号 (?) 或星号。如果使用了问号或星号并点击保存，文件不会保存，并且该对话框将不会关闭。

另存为类型

指定您要保存的文件类型： *.*

行终止符

指定保存时在文件中使用的行终止符。您可以选择 DOS/UNIX/MAC 格式的行终止符。

格式

指定文件保存的格式。可以选择下列选项：

ANSI/ASCII、UTF-8、UTF-16、UTF-8-无 BOM、UTF-16-无 BOM、UTF-16 - Big Endian、UTF-16 - Big Endian-无 BOM、Unicode ASCII Escaped

交换数据流

交换数据流允许文件与多个数据流相关联。例如，类似 text.txt 的文件可以具有名称为 text.txt:secret.txt（格式为 filename:ads）的 ADS，只能通过已知 ADS 名称或专门的目录浏览程序访问。

交换流在原始文件大小中不易觉察，但在删除原始文件（即 text.txt）或将该文件复制/移动到不支持 ADS 的分区（如 FAT 分区，软盘或网络共享）时会丢失。虽然 ADS 是一项有用的功能，但如果在遗忘或未删除的未知情况下会轻易吞食硬盘空间。

该功能仅在如果文件位于 NTFS 驱动器上时支持。

我的最近使用的文档

显示最近打开过的文件和文件夹

桌面

显示桌面上的文件、文件夹、程序快捷方式和其它项目

我的电脑

显示与这台电脑连接的磁盘驱动器和硬件

网上邻居

显示网站快捷方式、网络电脑和 ftp 站点


保存书签

在文件关闭时，如果该文件内有活动书签，那么 UltraEdit 提供保存书签的功能。按默认，这个功能未启用。这可以通过在 普通配置页 设置“保存书签”选项来启用这个功能。

如果禁用了这个选项，UltraEdit 将在下次关闭时删除所有保存的书签。


脚本

脚本对话框

脚本对话框（可从脚本菜单访问）显示了已添加到列表中可以在编辑器内使用的脚本列表。

按添加按钮将显示“打开”对话框，在此用户可以选择要添加到列表的 JavaScript 文件 (*.js)，还可以指定在“脚本”对话框的脚本描述字段中显示一段简短的说明。 对于已经添加到列表中的脚本，双击描述可以激活该字段对描述进行编辑。

如果在列表中选择脚本并按编辑按钮，则打开选中的脚本进行编辑。 如果在列表中选择脚本并按移除按钮，则选中的脚本将从列表中移除，但并不从系统中删除。 将光标悬停在脚本名称上方，将在工具提示中显示脚本的完整路径。

如果用户点击与已添加脚本相关联的热键或弦字段，则可以直接在该字段内键入用于调用该脚本的一组键。

要保存所作的更改，则应按确定按钮。

有关 UltraEdit/UEStudio 中支持脚本的完整命令列表，请点击这里。

有关 UltraEdit/UEStudio 中有关脚本的演示和指南，请点击这里。


滚动条

在文档窗口的右边和下边显示。滚动条内部的滚动框说明在文档中的水平和垂直位置。你可以使用鼠标滚动到文档的其它部分。

水平滚动条用于在当前文档内部定位。垂直滚动条用于改变文件的水平查看范围。

如果选定了 自动换行 模式，则不显示水平滚动条。


滚动

UltraEdit 支持几种滚动的方法，具体如下:

垂直滚动

垂直滚动用下列方法的其中之一执行:

垂直滚动条

IntelliMouse 支持

Ctrl+上/下箭头，以一行为单位上下滚动

水平滚动

水平滚动条


选择文本

UltraEdit 提供几个选择 (加亮) 文本的方法。最常用的方法是使用 Shift 键和光标键来选定按下 Shift 键和鼠标位置的文本。

另外，还有几个其它的方法可以很方便地选择文本范围。

如果已经选定了选区，在当前选区执行下列操作的同时按下 Shift 键，将扩展选区到执行下列命令后的光标位置，如果没有选定选区，则会选中该区域之间的文本:

找下一个/上一个

转到

转到书签

在执行命令时应该按下 Shift 键，而不是显示对话框中的命令时按下。例如，使用 Ctrl+G 显示 转到对话框 ，然后点击确定按钮执行转到动作，那么当点击确定时按下 Shift 键，而不是按 Ctrl+G 显示对话框的时候。


显示列标记 1/2

显示列标记 1/2 (视图菜单)

这些菜单用来打开或关闭用 设置列标记命令 配置的列标记的显示状态。


静寂安装

UltraEdit 的安装通常是不带参数执行 uesetup.exe 进行的，会显示整个安装过程，允许用户选择适当的位置和选项。

当完成后，创建一个 install.sss 文件。

在某些场合中，可能希望执行静寂安装 UltraEdit，允许在无人值守的情冲下自动安装，这可以使用下列参数:

uesetup /s

在普通环境下，这将执行带默认设置的静寂安装。需要从 WWW 下载的文件被下载到 uesetup.exe 文件的相同目录，以避免提示 WWW 下载。

要定制静寂安装，先正常运行 uesetup，选择适当的安装选项。在完成后，复制创建的 install.sss 到包含 uesetup.exe 的目录，并重命名到 uesetup.sss，以后在任何时候使用静寂安装时将使用这个文件指定的安装选项。


SSH/Telnet 账户管理器

该对话框允许对用户的 SSH/Telnet 账户进行配置。该账户用于 SSH/Telnet 命令。

帐号用来指定要链接的服务器和在连接到服务器时使用的用户标识。

添加帐号按钮允许你指定一个新的帐号名称。帐号可以从帐号列表中选择，并进行修改。 如果在帐号中作了任何修改，将会显示一个提示，询问您是否保留更改。

删除帐号按钮可以立即将活动/选中的帐号从帐号列表中删除。

设置默认帐号按钮可以将活动/选中的帐户设置为默认，通过在列表中的帐户名称前添加星号“*”。

SSH/Telnet 帐户管理器的选项位于五个不同的选项卡中：常规、高级、代理服务器、验证和终端。

常规选项卡包含以下配置选项：

帐号

这是配置的帐号使用的名称。 保存更改时该名称将出现在配置选项左边的列表中。

协议

该下拉菜单允许用户选择帐号使用 SSH 或 Telnet 协议。 如果选择 SSH，则要求 UltraEdit/UEStudio 仅使用验证选项卡中指定的 SECURE SHELL 协议。所有传送的数据均被加密，并且加密算法已与服务器约定。如果设置了这个选项，传输对话框将显示一个“锁”符号，表示传输是安全的。

服务器

表示要连接到的服务器，如 ultraedit.com。如果喜欢，可以采用 xxxx.xxxx.xxxx.xxxx 形式的 IP 地址输入。

端口

这是 UltraEdit/UEStudio 用于 SSH/Telnet 协议的端口。SSH 的默认端口是 22，Telnet 的默认端口是 23。如果需要可以进行更改。

用户名

这是用来登录服务器的用户名。

密码

这是与用户名一道用于登录到服务器的密码。该密码为站点管理员提供的用户名的密码。

保存密码

该复选框决定 UltraEdit/UEStudio 是否保存密码以便以后使用。如果否，则在需要时提示用户输入密码。注意：如果保存密码则密码保存在系统中。尽管密码是加密的，但 加密机制非常简单且不应作为一种安全的方法。

高级选项卡包含以下配置选项：

保持活动超时

该选项指定可发送给服务器的连接测试包的时间间隔，单位为秒。

自动断开超时

该选项指定了在终止不活动的会话前 UltraEdit-32/UEStudio 应该等待的时间间隔，单位为秒。

远程命令

该选项可以用来指定成功完成后将自动执行的命令。 命令执行后，最终的会话将自动断开。

代理服务器选项卡包含以下配置选项：

使用代理服务器

可以启用代理服务器设置并配置该帐户连接到指定的代理服务器。 如果直接连接到 Internet 则不应启用代理服务器设置。如果在 LAN 中通过代理服务器连接则需要设置代理服务器。

代理服务器类型

这是用于 SSH/Telnet 账户的代理服务器类型。 用户可以选择以下代理服务器类型之一：

HTTP - (CONNECT)

Relay

SOCKS4

SOCKS5

Windows - (Internet Explorer)

代理服务器端口

这是 UltraEdit/UEStudio 用于 SSH/Telnet 协议的端口。SSH 的默认端口是 22，Telnet 的默认端口是 23。如果需要可以进行更改。

代理服务器用户名

这是用来登录代理服务器的用户名。

代理服务器密码

这是与用户名一道用于登录到代理服务器的密码。该密码为站点管理员提供的用户名的密码。

验证选项卡包含以下配置选项：

验证

允许用户指定用于服务器的协议和验证类型。支持下列协议：

自动 | 如果选中该选项，则首先尝试使用 SSH2 连接。 如果服务器不支持，则将使用 SSH1 连接。
SSH1 | 如果指定该选项，则将仅使用 SSH1 连接到服务器。
SSH2 | 如果指定该选项，则将仅使用 SSH2 连接到服务器。

支持以下验证类型：

仅密码 | 需要提供用户名/密码，不需要公共/私人密钥对使用。
仅公共密钥 | 需要使用公共/私人密钥对。 私人密钥位置必须在私人密钥路径中指定。
密码和公共密钥 | 允许用户指定公共/私人密码和/或用户名/密码。
密钥需要密码短语 | 这允许用户指出已用密码短语保护私钥。如果在此情况下，将在每个会话中或更改账户设置后提示用户输入密码。
私人密钥路径 | 用户可以浏览或手动指定到现有私人密钥的路径。 服务器必须支持该验证方法。 使用的密钥应该是 OpenSSH 格式，也可以是 RSA 或 DSA 类型的密钥。

终端选项卡包含以下配置选项：

终端类型

该选项用于指定远程服务器上设置的终端类型（环境变量）。 可以留空。

终端仿真

该下拉列表允许用户指定可以用于会话的终端仿真。 支持以下选项：

VT100

Linux

无

前景颜色

用户可以点击颜色块指定终端的前景颜色。

背景颜色

用户可以点击颜色块指定终端的背景颜色。

字体设置

点击该按钮将显示标准的 Windows 字体对话框，在此用户可以选择要使用的字体。

回滚日志

该字段可以用于指定用户在现有日志中回滚的行数。 用户可以用鼠标滚轮、pageup/pagedown 键盘或滚动条进行滚动。

ANSI 支持

与服务器建立连接后，转义序列与数据指定颜色、样式和其他格式信息一起传递。 该设置允许用户指定在 SSH/Telnet 客户端窗口中显示的格式信息。

完整 ANSI | 如果选中该选项，则客户端将尝试显示所有内容。
剔除颜色 | 如果选中该选项，则客户端将尝试显示所有内容除了服务器传递的颜色。
剔除 ANSI | 如果选中该选项，则客户端将仅尝试显示服务器传递的文本和空格。


状态栏

状态栏显示在 UltraEdit 窗口的底部。 要显示或隐藏状态栏，使用状态栏命令（在 视图菜单）。

状态栏内容 (从左到右)

帮助提示

状态栏的左边范围是用来显示使用箭头键盘在菜单命令中移动时对应的菜单动作描述。 这个范围同样还显示鼠标在工具栏按钮按下、释放前的按钮动作描述。 如果查看工具栏按钮命令描述之后，想不执行这个命令，那么将鼠标从该工具栏按钮位置离开后释放。

行/列号

行/列号 在单个面板中显示文件中光标位置的行号 (如果启用) 和列号。

状态栏中在用逗号隔开的行号和列号后面显示活动剪贴板。

在十六进制模式模式，它以十六进制和十进制显示光标位置。

跟随在行/列标识后面的是活动剪贴板标识。 C0 表示启用标准 Windows 剪贴板，C1-C9 表示启用了用户剪贴板中的一个 (查阅剪贴板)。

文件类型

文件类型显示文件是否是 DOS 文件、UNIX 文件或 MAC 文件。 文件类型 (DOS/UNIX/MAC) 前面的“U8-”表示文件是 UTF-8 格式。 文件类型 (DOS/UNIX/MAC) 前面的“U-”说明文件是 Unicode 格式。 文件类型 (DOS/UNIX/MAC) 前面的“UBE-”说明文件是 Unicode (Big Endian) 格式。 文件类型 (DOS/UNIX/MAC) 前面的“UESC-”说明文件是 Unicode Escaped ASCII 格式。

日期/时间

活动文件最后修改的日期和时间 (先于这次编辑)。 对于新文件，显示的是创建日期和时间。 日期格式从系统短日期设置中读取。 这可以通过控制面板的区域设置进行配置。

日期/时间

活动文件的文件大小。 用 UltraEdit 写入任何更改到磁盘时，该文件大小被更新。

状态标识

状态栏的右边范围说明使用哪种输入模式：

指示符 | 描述
覆盖 | 状态标识
大写 | 按下了 Caps Lock 键


字符串对话框

UEStudio 里的字符串对话框提供了一个编辑活动方案字符串表的简捷方式。在“文件树型视图”里选择了“字符串表”资源项目并从上下文菜单里选择了“打开”选项时，即调用出“字符串”对话框。它将以表格提供加速键，列出 ID 和按键。“字符串”对话框包括以下按钮：

确定 | 保存更改并关闭对话框
取消 | 关闭对话框而不保存更改
新建字符串 | 提供字符串属性对话框以定义新的字符串。字符串属性对话框允许用户指定两个项目： ID 和文本。
属性 | 如果选择了字符串，该按钮提供“字符串属性”对话框
删除 | 从列表中删除已选的字符串


样式构建对话框

样式构建对话框可以用于生成网页中的元素的样式。这个对话框不能设置所有 CSS2 可用的选项，它可以设置大多数公共选项 (背景、字体/文本、边距/填充/位置)。. 按下背景、字体/文本或边缘/位置按钮将出现不同的、与这些选项相关的设置。

如果你想从国际万维网联盟 (W3C) 查找完整的 CSS3 说明，请点击 CSS2 在线说明按钮。这将打开你的系统中的默认浏览器连接到相关站点，在那里你可以查找 CSS2 的最新信息和帮助说明。

如果你不想直接写入生成后的样式到编辑窗口，你可以从 CSS2 在线说明按钮下面的下拉框中选择“剪贴板”，所有生成后的样式将被复制到剪贴板。

公共设置

对于三个样式设置的任意一个 (背景、字体/文本、边缘/位置)，你可以直接用这些设置影响将要用于生成样式的格式。如果选择了展开选择框，所有的项目将被展开 (例如: MARGIN-TOP:A; MARGIN-LEFT:B; 等)。如果你未选中这个选择框，将使用这样的格式: MARGIN: A B C D 来保留一些空格。

如果选择了小写字母选择框，所有属性将被用小写字母插入，而不是大写格式。

如果选择了使用引号选择框，那么所有插入的设置将被附上引号。

背景

这个对话框可以用于创建下列背景样式属性设置:

background-color

background-image

background-repeat

background-attachment

background-position

字体/文本

这个对话框可以用于创建下列字体/文本样式属性设置:

font

font-stretch

text-align

text-decoration

text-indent

text-transform

color

边缘/位置

这个对话框可以用于创建下列边距/位置样式属性设置:

margin-top

margin-right

margin-bottom

margin-left

padding-top

padding-right

padding-bottom

padding-left

position

z-index

top

left

height

width

page-break-before

page-break-inside

page-break-after

要获取这些属性和可能存在的其它设置，请查阅 http://www.w3.org/TR/REC-CSS2/propidx.html 。

要获取样式描述的完整列表，请查阅 http://www.w3.org/TR/REC-CSS2/descidx.html 。


标签列表修改 (标签列表上下文菜单)

这个对话框允许修改 标签列表 。

标签是一个简单的短字符，这个功能一般用于“HTML 标签”。

使用标签列表的目的是提供一种不需要进行输入、用使用的标签/字符插入到文档的简单方法。

文件名对象必须填写。这是用于贮存标签的文件。可以创建一个新文件，或按浏览按钮选择已有的标签列表文件。

标签可以分割到关联的组。至少需要有一个组存在才能添加标签，这可以用新建组按钮定义。

每个标签可以有起始和结束标签。在提供的框中输入的标签可以用添加标签按钮插入到标签列表中，可用于替换选定的标签。

点击列表中一个已有的标签，填写起始标签和结束标签对象框可以很方便地进行修改。

当添加了一个新组或选择了其它组，将会出现一个提示，询问是否保存所有的更改。


标题栏

"UltraEdit - <filename>"

标题栏位于窗口顶部。它包含应用程序和文档名字。

要移动窗口，只要拖放标题栏即可。注意: 你还可以拖放标题栏来移动对话框。

标题栏可以包含下列元素:

应用程序控制菜单按钮

文档控制菜单按钮

最大化按钮

最小化按钮

应用程序名字

文档名字

恢复按钮


垂直滚动

垂直滚动按下列方法之一执行:

垂直滚动条

IntelliMouse 支持

Ctrl+上/下箭头，向上或向下滚动一行