农历日期支持库

农历日期支持库 帮助手册20080813版 返回支持库手册 返回首页

目前所支持的日期范围为1902-2047年，以后会进一步扩充。自辛丑年正月初一[1901-2-19]至戊辰年冬月廿七[2048-12-31]期间的所有日期，均已与万年历逐一核对，可放心使用。

操作系统支持： Windows

命令类别：

农历日期处理

窗口组件数据类型：

农历日期框

农历月历

其它数据类型：

天干

地支

属相

节气

常量表

例程列表：

例程名称 | 下载 | 说明
农历日期查询 | 农历日期查询.e | 演示农历日期相关的查询、转换和处理
农历月历框例程. | 农历月历框.e | 大连大有吴涛易语言软件开发有限公司出品 演示农历月历框直接画在窗口上.

适用版本，农历日期支持库 （1.5#0版）


农历日期处理

农历日期处理 类别 跳至：农历日期支持库

农历转公历 | 公历转农历 | 取农历月总天数 | 取农历年总天数
取农历闰月 | 取农历节气 | 取年属相 | 取天干地支
取六十甲子 | 取四柱 | 取四柱序号 | 取六十甲子纳音
格式化日期 | 取交节气时刻 | 取属相 |


农历转公历 命令 操作系统支持：Windows 所属对象：农历日期处理

农历转公历 命令 操作系统支持：Windows 所属类别：农历日期处理

将转换后的日期写入最后一个参数中。如果执行失败，返回“假”，此时转换结果无效。

语法： 逻辑型 农历转公历 （农历年，农历月，农历日，是否闰月，转换后公历日期）

参数名 | 描 述
农历年 | 必需的；整数型。
农历月 | 必需的；整数型。
农历日 | 必需的；整数型。
是否闰月 | 必需的；逻辑型。如果指定的月份并非闰月，此值将被忽略（一律视为假）。
转换后公历日期 | 必需的；日期时间型，参数数据只能提供变量。

例程:

说明:

以农历日期取出公历日期。

参见:例程


公历转农历 命令 操作系统支持：Windows 所属类别：农历日期处理

将转换后的日期写入最后一个参数中。如果执行失败，返回“假”，此时转换结果无效。

语法： 逻辑型 公历转农历 （公历日期，转换后农历年，转换后农历月，转换后农历日，转换后是否闰月）

参数名 | 描 述
公历日期 | 必需的；日期时间型。
转换后农历年 | 必需的；整数型，参数数据只能提供变量。
转换后农历月 | 必需的；整数型，参数数据只能提供变量。
转换后农历日 | 必需的；整数型，参数数据只能提供变量。
转换后是否闰月 | 必需的；逻辑型，参数数据只能提供变量。

例程:

说明:

以公历日期取出农历日期。


取农历月总天数 命令 操作系统支持：Windows 所属类别：农历日期处理

失败返回0。

语法： 整数型 取农历月总天数 （农历年，农历月，是否闰月）

参数名 | 描 述
农历年 | 必需的；整数型。
农历月 | 必需的；整数型。
是否闰月 | 必需的；逻辑型。如果指定的月份并非闰月，此值将被忽略（一律视为假）。

例程:

说明:

通过公历日期，取出这个时间的农历月总天数，和农历年总天数。


取农历年总天数 命令 操作系统支持：Windows 所属类别：农历日期处理

失败返回0。

语法： 整数型 取农历年总天数 （农历年）

参数名 | 描 述
农历年 | 必需的；整数型。

例程:

说明:

通过公历日期，取出这个时间的农历月总天数，和农历年总天数。


取农历闰月 命令 操作系统支持：Windows 所属类别：农历日期处理

返回某年闰月月份，1到12，没有闰月则返回0。失败返回-1。

语法： 整数型 取农历闰月 （农历年）

参数名 | 描 述
农历年 | 必需的；整数型。

例程:

说明:

通过农历年取出农历闰月，提供农历的日期信息取出节气名称和属相名称，最后参数返回节气序号。


取农历节气 命令 操作系统支持：Windows 所属类别：农历日期处理

返回指定农历日期的节气文本，如果该日期不是节气或执行失败，返回值为空白文本。本命令同时在最后一个参数中写入节气序号。

语法： 文本型 取农历节气 （农历年，农历月，农历日，是否闰月，［节气序号］）

参数名 | 描 述
农历年 | 必需的；整数型。
农历月 | 必需的；整数型。
农历日 | 必需的；整数型。
是否闰月 | 必需的；逻辑型。如果指定的月份并非闰月，此值将被忽略（一律视为假）。
节气序号 | 可选的；整数型，参数数据只能提供变量。如果提供本参数，其中将存放取得的节气序号1-24，不是节气为0，失败为-1。节气1-24依次代表：小寒,大寒,立春,雨水,惊蛰,春分；清明,谷雨,立夏,小满,芒种,夏至；小暑,大暑,立秋,处暑,白露,秋分；寒露,霜降,立冬,小雪,大雪,冬至。

例程:

说明:

通过农历年取出农历闰月，提供农历的日期信息取出节气名称和属相名称，最后参数返回节气序号。


取年属相 命令 操作系统支持：Windows 所属类别：农历日期处理

返回指定农历年份的属相文本，失败返回空文本。本命令同时在最后一个参数中写入属相序号。注意：本命令只取普通意义上的年属相（即该年立春之后的属相），若要严格区分立春前后，请使用另一命令“取属相”。

语法： 文本型 取年属相 （农历年，［属相序号］）

参数名 | 描 述
农历年 | 必需的；整数型。
属相序号 | 可选的；整数型，参数数据只能提供变量。如果提供本参数，其中将存放取得的属相序号。序号1-12依次代表：鼠，牛，虎，兔，龙，蛇，马，羊，猴，鸡，狗，猪。

例程:

说明:

通过农历年取出农历闰月，提供农历的日期信息取出节气名称和属相名称，最后参数返回节气序号。


取天干地支 命令 操作系统支持：Windows 所属类别：农历日期处理

根据指定的天干和地支序号，返回相应的天干和地支文本。如果天干序号不合法，返回值中不包含天干文本；如果地支序号不合法，返回值中不包含地支文本。

语法： 文本型 取天干地支 （天干序号，地支序号）

参数名 | 描 述
天干序号 | 必需的；整数型。序号1-10依次代表：甲乙丙丁戊己庚辛壬癸。本参数也可为0，表示不取天干文本。
地支序号 | 必需的；整数型。序号1-12依次代表：子丑寅卯辰巳午未申酉戌亥。本参数也可为0，表示不取地支文本。

例程:

说明:

取天干地支,是用天干地支的序号，取出这样的年的年柱。


取六十甲子 命令 操作系统支持：Windows 所属类别：农历日期处理

取六十甲子之一。如，参数为1返回“甲子”，参数为2返回“乙丑”，……，参数为60返回“癸亥”。参数小于1或大于60，将返回空文本。

语法： 文本型 取六十甲子 （六十花甲序号）

参数名 | 描 述
六十花甲序号 | 必需的；整数型。序号1-60依次代表： 甲子,乙丑,丙寅,丁卯,戊辰,己巳,庚戌,辛未,壬申,癸酉； 甲戌,乙亥,丙子,丁丑,戊寅,己卯,庚辰,辛巳,壬午,癸未； 甲申,乙酉,丙戌,丁亥,戊子,己丑,庚寅,辛卯,壬辰,癸巳； 甲午,乙未,丙申,丁酉,戊戌,己亥,庚子,辛丑,壬寅,癸卯； 甲辰,乙巳,丙午,丁未,戊申,己酉,庚戌,辛亥,壬子,癸丑； 甲寅,乙卯,丙辰,丁巳,戊午,己未,庚申,辛酉,壬戌,癸亥。

例程:

说明:

根据六十甲子的序号取出六十甲子的名称，六十甲子纳音是以六十甲子的名称取出的名称。


取四柱 命令 操作系统支持：Windows 所属类别：农历日期处理

获取指定公历日期的年柱、月柱、日柱、时柱（各为用天干地支表示的文本），分别写入后面四个参数中。注：与本支持库中的其它命令和方法不同，本命令和“取柱序号()”命令在内部计算时，以“立春”作为年与年之间的分界点，以“立春”“惊蛰”等节气作为月与月之间的分界点，以23点作为日与日之间的分界点。

语法： 逻辑型 取四柱 （公历日期，［年柱］，［月柱］，［日柱］，［时柱］）

参数名 | 描 述
公历日期 | 必需的；日期时间型。
年柱 | 可选的；文本型，参数数据只能提供变量。
月柱 | 可选的；文本型，参数数据只能提供变量。
日柱 | 可选的；文本型，参数数据只能提供变量。
时柱 | 可选的；文本型，参数数据只能提供变量。

例程:

说明:

取柱把公历日期的四柱的名称取出。柱序号是四柱的每个的六十甲子的索引值。


取四柱序号 命令 操作系统支持：Windows 所属类别：农历日期处理

获取指定公历日期的年柱、月柱、日柱、时柱之六十花甲序号（各为1到60之间的数字，可用“取六十花甲()”命令取得其对应的天干地支文本），分别写入后面四个参数中。注：与本支持库中的其它命令和方法不同，本命令和“取柱()”命令在内部计算时，以“立春”作为年与年之间的分界点，以“立春”“惊蛰”等节气作为月与月之间的分界点，以23点作为日与日之间的分界点。

语法： 逻辑型 取四柱序号 （公历日期，［年柱］，［月柱］，［日柱］，［时柱］）

参数名 | 描 述
公历日期 | 必需的；日期时间型。
年柱 | 可选的；整数型，参数数据只能提供变量。
月柱 | 可选的；整数型，参数数据只能提供变量。
日柱 | 可选的；整数型，参数数据只能提供变量。
时柱 | 可选的；整数型，参数数据只能提供变量。

例程:

说明:

取柱把公历日期的四柱的名称取出。柱序号是四柱的每个的六十甲子的索引值。


取六十甲子纳音 命令 操作系统支持：Windows 所属类别：农历日期处理

返回空文本（执行失败时）或以下文本之一：海中金，山头火，泉中水，沙中金，佛灯火，大溪水，炉中火，涧下水，屋上土，山下火，天河水，沙中土，大林木，城墙土，霹雳火，平地木，大驿土，天上火，路边土，白蜡金，松柏木，壁上土，钗钏金，石榴木，剑锋金，杨柳木，长流水，金泊金，桑松木，大海水。

语法： 文本型 取六十甲子纳音 （六十甲子文本）

参数名 | 描 述
六十甲子文本 | 必需的；文本型。以天干地支表示的六十甲子文本，如“甲子”“乙丑”等。

例程:

说明:

根据六十甲子的序号取出六十甲子的名称，六十甲子纳音是以六十甲子的名称取出的名称。


格式化日期 命令 操作系统支持：Windows 所属类别：农历日期处理

返回格式化后的日期文本。

语法： 文本型 格式化日期 （公历日期，［格式化文本］）

参数名 | 描 述
公历日期 | 必需的；日期时间型。用于描述要显示的农历日期格式。
格式化文本 | 可选的；文本型。其中可以包含以下格式化字符：%Y,%S,%M,%D,%y,%m,%d，其各自代表的意义如下： %Y：以干支表示的农历年份，如“甲辰”； %S：属相，如“龙”； %M：农历月，如“正月”； %D：农历日，如“初一”； %y：阳历年份，如“2004”； %m：阳历月份，如“10”； %d：阳历日，如“1”； 如果本参数被省略或为空，则默认显示格式为“%Y年(%S)%M%D %y-%m-%d”。

例程:

说明:

格式化日期，将一些日期相关信息包括在一起的时间信息


取交节气时刻 命令 操作系统支持：Windows 所属类别：农历日期处理

返回指定公历年份（1880-2079）中指定节气的交节日期和时间，精确到秒（由于(内行人)众所周知的原因，难免有些误差）。如果执行失败，返回100年1月1日0时0分0秒。

语法： 日期时间型 取交节气时刻 （公历年份，节气序号）

参数名 | 描 述
公历年份 | 必需的；整数型。
节气序号 | 必需的；整数型。序号1-24依次代表：立春,雨水,惊蛰,春分,清明,谷雨；立夏,小满,芒种,夏至,小暑,大暑；立秋,处暑,白露,秋分,寒露,霜降；立冬,小雪,大雪,冬至,小寒,大寒。可以使用枚举类型“节气”中的常量如“#节气.立春”。

例程:

说明:

以农历日期取出公历日期。


取属相 命令 操作系统支持：Windows 所属类别：农历日期处理

返回指定日期时间的属相文本，失败返回空文本。本命令同时在最后一个参数中写入属相序号。注意：在立春时刻（精确到秒）前后，返回值是不同的。

语法： 文本型 取属相 （公历日期，［属相序号］）

参数名 | 描 述
公历日期 | 必需的；日期时间型。
属相序号 | 可选的；整数型，参数数据只能提供变量。如果提供本参数，其中将存放取得的属相序号。序号1-12依次代表：鼠，牛，虎，兔，龙，蛇，马，羊，猴，鸡，狗，猪。

例程:

说明:

通过农历年取出农历闰月，提供农历的日期信息取出节气名称和属相名称，最后返回指定日期时间的属相文本。


农历日期框

农历日期框 窗口组件 操作系统支持：Windows 跳至：农历日期支持库

属性：

公历日期 | 农历年 | 农历月 | 农历日
是否闰月 | 主视图 | 农历年份 | 农历月份
农历日份 | 属相 | 节气 | 星期
农历本月天数 | 农历本年天数 | 格式化文本 | 显示文本

方法：

置农历日期 | 置公历日期 | 增减日期 | 打开选择窗口
关闭选择窗口 |  |  |

自有事件：

日期被选择 | 日期被悬停 | 选择窗口打开 | 选择窗口关闭
日期被改变 |  |  |


公历日期 属性 操作系统支持：Windows 所属对象：农历日期框

公历日期 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：日期时间型；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历年 属性 操作系统支持：Windows 所属对象：农历日期框

农历年 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历月 属性 操作系统支持：Windows 所属对象：农历日期框

农历月 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历日 属性 操作系统支持：Windows 所属对象：农历日期框

农历日 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


是否闰月 属性 操作系统支持：Windows 所属对象：农历日期框

是否闰月 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：逻辑型；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


主视图 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；如果以农历为主视图，则选择窗口中的日期显示（包括年月的划分）以农历思维为主，公历为辅；否则以公历为主，农历为辅。

可供选择的属性值：
0、农历
1、公历

例程:

说明:

主视图设置选择窗口的日期选择下拉列表的日期方式。


农历年份 属性 操作系统支持：Windows 所属对象：农历日期框

农历年份 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历月份 属性 操作系统支持：Windows 所属对象：农历日期框

农历月份 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历日份 属性 操作系统支持：Windows 所属对象：农历日期框

农历日份 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


属相 属性 操作系统支持：Windows 所属对象：农历日期框

属相 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


节气 属性 操作系统支持：Windows 所属对象：农历日期框

节气 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；只读；空文本表示当天不是节气。

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


星期 属性 操作系统支持：Windows 所属对象：农历日期框

星期 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；只读；1表示星期一，2表示星期二，……，7表示星期日。

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历本月天数 属性 操作系统支持：Windows 所属对象：农历日期框

农历本月天数 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；只读；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


农历本年天数 属性 操作系统支持：Windows 所属对象：农历日期框

农历本年天数 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：整数型；只读；

例程:

说明:

公历日期是农历日期框的当前的公历日期，和农历年份月
份日份，农历年月日是以序号代表的属性，和这天所在的农历月的天数，星期是以序号表示，1表示星期一。


格式化文本 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；用于描述要显示的农历日期格式。其中可以包含以下格式化字符：%Y,%S,%M,%D,%y,%m,%d，其各自代表的意义如下： %Y：以干支表示的农历年份，如“甲辰”； %S：属相，如“龙”； %M：农历月，如“正月”； %D：农历日，如“初一”； %y：阳历年份，如“2004”； %m：阳历月份，如“10”； %d：阳历日，如“1”；如果本属性为空，则默认显示格式为“%Y年(%S)%M%D %y-%m-%d”。

例程:

说明:

格式化农历日期框的农历日期的显示格式，他和显示文本配合使用。


显示文本 属性 所属对象：农历日期框 操作系统支持：Windows

数据类型：文本型；只读；显示于窗口组件中的文本。该文本为依据“格式化文本”属性格式化后的日期信息。

例程:

说明:

格式化农历日期框的农历日期的显示格式，他和显示文本配合使用。


置农历日期 命令 操作系统支持：Windows 所属类别：农历日期框

置农历日期 方法 操作系统支持：Windows 所属对象：农历日期框

语法： 逻辑型 农历日期框．置农历日期 （农历年，农历月，农历日，［是否闰月］）

参数名 | 描 述
农历年 | 必需的；整数型。
农历月 | 必需的；整数型。
农历日 | 必需的；整数型。
是否闰月 | 可选的；逻辑型。如果本参数省略，默认为“假”。

例程:

说明:

农历日期框的当前农历日期。


置公历日期 方法 操作系统支持：Windows 所属对象：农历日期框

根据年月日参数，设置公历日期。提示：如果有“日期时间型”数据，可直接赋值给农历日期框的“公历日期”属性。

语法： 逻辑型 农历日期框．置公历日期 （公历年，公历月，公历日）

参数名 | 描 述
公历年 | 必需的；整数型。
公历月 | 必需的；整数型。
公历日 | 必需的；整数型。

例程:

说明:

以公历的方式置农历日期框的当前日期。


增减日期 命令 操作系统支持：Windows 所属类别：农历日期框

增减日期 方法 操作系统支持：Windows 所属对象：农历日期框

在当前日期的基础上增减指定天数。

语法： 逻辑型 农历日期框．增减日期 （要增减的天数）

参数名 | 描 述
要增减的天数 | 必需的；整数型，初始值为“1”。大于零表示增加日期，小于零表示减小日期。

例程:

说明:

增减农历日期框的日期，单位为天，偏移值为负数代表向后退。


打开选择窗口 命令 操作系统支持：Windows 所属类别：农历日期框

打开选择窗口 方法 操作系统支持：Windows 所属对象：农历日期框

打开日期选择窗口。

语法： 无返回值 农历日期框．打开选择窗口 （）

例程:

说明:

弹出日历框


关闭选择窗口 方法 操作系统支持：Windows 所属对象：农历日期框

关闭日期选择窗口。

语法： 无返回值 农历日期框．关闭选择窗口 （）

例程:

说明:

关闭农历日期框的日期选择窗口。


日期被选择 事件 操作系统支持：Windows 所属对象：农历日期框

日期被选择 事件 所属对象：农历日期框 操作系统支持：Windows

当用户单击了日期选择窗口中的某个日期时产生本事件。可在事件处理子程序中读取组件的相关属性（公历日期/农历年/农历月/农历日/是否闰月）以获取用户选择的日期。

语法： 无返回值 _农历日期框_日期被选择 （）

例程:

说明:

通过农历年取出农历闰月，提供农历的日期信息取出节气名称和属相名称，最后参数返回节气序号。


日期被悬停 事件 操作系统支持：Windows 所属对象：农历日期框

日期被悬停 事件 所属对象：农历日期框 操作系统支持：Windows

当用户用鼠标指向日期选择窗口中的某个日期时产生本事件。

语法： 无返回值 _农历日期框_日期被悬停 （农历年，农历月，农历日，是否闰月）

参数名 | 描 述
农历年 | 整数型；
农历月 | 整数型；
农历日 | 整数型；
是否闰月 | 逻辑型；

例程:

说明:

在农历日期框的日期选择窗口弹出后，鼠标在日期上停留时就会引发这个事件。


选择窗口打开 事件 操作系统支持：Windows 所属对象：农历日期框

选择窗口打开 事件 所属对象：农历日期框 操作系统支持：Windows

当选择窗口打开时产生本事件。

语法： 无返回值 _农历日期框_选择窗口打开 （）

例程:

说明:

在农历日期框的日期选择窗口打开的时候，便会引发这个事件。


选择窗口关闭 事件 操作系统支持：Windows 所属对象：农历日期框

选择窗口关闭 事件 所属对象：农历日期框 操作系统支持：Windows

当选择窗口关闭时产生本事件。

语法： 无返回值 _农历日期框_选择窗口关闭 （）

例程:

说明:

在农历日期框的日期选择窗口销毁的时候，便会引发这个事件。


日期被改变 事件 操作系统支持：Windows 所属对象：农历日期框

日期被改变 事件 所属对象：农历日期框 操作系统支持：Windows

当日期改变时（用户选择了日期/通过属性设置日期/通过方法设置日期）产生本事件。可在事件处理子程序中读取组件的相关属性（公历日期/农历年/农历月/农历日/是否闰月）以获取被改变后的日期。

语法： 无返回值 _农历日期框_日期被改变 （）

例程:

说明:

当农历日期框的当前日期被改变时就会引发这个事件。


农历月历

农历月历 窗口组件 操作系统支持：Windows 跳至：农历日期支持库

属性：

公历日期 | 农历年 | 农历月 | 农历日
是否闰月 | 主视图 | 农历年份 | 农历月份
农历日份 | 属相 | 节气 | 星期
农历本月天数 | 农历本年天数 | 格式化文本 | 日期文本
是否显示表头 |  |  |

方法：

置农历日期

置公历日期

增减日期

自有事件：

日期被选择

日期被悬停

日期被改变

日期被右击


公历日期 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：日期时间型；仅年月日部分有效，时间部分将被自动重置为23:59:59。

例程:

说明:

公历日期是农历月历是当前的公历日期，仅年月日部分有效，时间部分将被自动重置为23:59:59。


农历年 属性 所属对象：农历日期 操作系统支持：Windows

农历年 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

农历日期框中的年份


农历月 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

农历日期框中的月份


农历日 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

农历日期框中的日期


是否闰月 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：逻辑型；

例程:

说明:

农历月历月份是否为闰月


主视图 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；如果以农历为主视图，则选择窗口中的日期显示（包括年月的划分）以农历思维为主，公历为辅；否则以公历为主，农历为辅。

可供选择的属性值：
0、农历
1、公历

  例程:

说明:

主视图设置选择窗口的日期选择下拉列表的日期方式。


农历年份 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

农历日期是农历月历的当前的农历年份，月份，日份。


农历年份 属性 所属对象：农历月历 操作系统支持：Windows

农历月份 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

农历日期是农历月历的当前的农历年份，月份，日份。


农历年份 属性 所属对象：农历月历 操作系统支持：Windows

农历日份 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

农历日期是农历月历的当前的农历年份，月份，日份。


属相 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：文本型；只读；

例程:

说明:

农历月历年份的属相


节气 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：文本型；只读；空文本表示当天不是节气。

例程:

说明:

取出农历中该天是否是节气。如：2004年的腊月二十六，节气为：立春。


星期 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；只读；1表示星期一，2表示星期二，……，7表示星期日。

例程:

说明:

取出该天的星期。（不计公历或农历）


农历本月天数 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；只读；

例程:

说明:

取出该农历年中该月的天数。如：2005年的二月份，为30天。


农历本年天数 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：整数型；只读；

例程:

说明:

该年的农历年天数。如：2004是闰二月的闰年，为384天。


格式化文本 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：文本型；用于描述要“日期文本”属性的农历日期格式。其中可以包含以下格式化字符：%Y,%S,%M,%D,%y,%m,%d，其各自代表的意义如下： %Y：以干支表示的农历年份，如“甲辰”； %S：属相，如“龙”； %M：农历月，如“正月”； %D：农历日，如“初一”； %y：阳历年份，如“2005”； %m：阳历月份，如“10”； %d：阳历日，如“1”；如果本属性为空，则默认显示格式为“%Y年(%S)%M%D %y-%m-%d”。

例程:

说明:

格式化日期是农历月历的当前的农历日期的格式。


日期文本 属性 所属对象：农历月历 操作系统支持：Windows

日期文本 属性 所属对象：农历月历 操作系统支持：Windows 数据类型：

文本型；只读；该文本为依据“格式化文本”属性格式化后的日期信息。

例程:

说明:

所属：文本型。该命令可取出当前农历月历的农历日期的年月日，和公历的年月日。


是否显示表头 属性 所属对象：农历月历 操作系统支持：Windows

数据类型：逻辑型；

语法： 逻辑型 农历月历．是否显示表头 = 真

例程:

说明:

农历月历显示时的视觉效果。真为显示表头，假则为不显示。


置农历日期 方法 操作系统支持：Windows 所属对象：农历月历

语法： 逻辑型 农历月历．置农历日期 （农历年，农历月，农历日，［是否闰月］）

参数名 | 描 述
农历年 | 必需的；整数型。
农历月 | 必需的；整数型。
农历日 | 必需的；整数型。
是否闰月 | 可选的；逻辑型。如果本参数省略，默认为“假”。

例程:

说明:

把当前的农历月历更改成新的农历日期。


置公历日期 方法 操作系统支持：Windows 所属对象：农历月历

根据年月日参数，设置公历日期。提示：如果有“日期时间型”数据，可直接赋值给农历月历的“公历日期”属性。

语法： 逻辑型 农历月历．置公历日期 （公历年，公历月，公历日）

参数名 | 描 述
公历年 | 必需的；整数型。
公历月 | 必需的；整数型。
公历日 | 必需的；整数型。

例程:

说明:

以公历的方式置农历月历的当前日期。


增减日期 方法 操作系统支持：Windows 所属对象：农历月历

在当前日期的基础上增减指定天数。

语法： 逻辑型 农历月历．增减日期 （要增减的天数）

参数名 | 描 述
要增减的天数 | 必需的；整数型，初始值为“1”。大于零表示增加日期，小于零表示减小日期。

例程:

说明:

增减农历月历的日期，单位为天，偏移值为负数代表向后退。


日期被选择 事件 所属对象：农历月历 操作系统支持：Windows

当用户单击了日期选择窗口中的某个日期时产生本事件。可在事件处理子程序中读取组件的相关属性（公历日期/农历年/农历月/农历日/是否闰月）以获取用户选择的日期。

语法： 无返回值 _农历月历_日期被选择 （）

例程:

说明:

当农历月历的日期被选择时，本事件被触发。


日期被悬停 事件 所属对象：农历月历 操作系统支持：Windows

当用户用鼠标指向农历月历中的某个日期时产生本事件。

语法： 无返回值 _农历月历_日期被悬停 （农历年，农历月，农历日，是否闰月）

参数名 | 描 述
农历年 | 整数型；
农历月 | 整数型；
农历日 | 整数型；
是否闰月 | 逻辑型；

例程:

说明:

鼠标在农历月历的日期上停留时，就会引发这个事件。


日期被改变 事件 所属对象：农历月历 操作系统支持：Windows

当日期改变时（用户选择了日期/通过属性设置日期/通过方法设置日期）产生本事件。可在事件处理子程序中读取组件的相关属性（公历日期/农历年/农历月/农历日/是否闰月）以获取被改变后的日期。

语法： 无返回值 _农历月历_日期被改变 （）

例程:

说明:

当农历月历的当前日期被改变时就会引发这个事件。


日期被右击 事件 所属对象：农历月历 操作系统支持：Windows

当鼠标右键单击当月日期时产生本事件。

语法： 无返回值 _农历月历_日期被右击 （农历年，农历月，农历日，是否闰月）

参数名 | 描 述
农历年 | 整数型；
农历月 | 整数型；
农历日 | 整数型；
是否闰月 | 逻辑型；

例程:

说明:

当农历月历的当前日期被右击时就会引发这个事件。


天干

天干 枚举常量集合类型 操作系统支持：Windows 跳至：农历日期支持库

成员 | 描 述
甲 | 常量值为 1 。
乙 | 常量值为 2 。
丙 | 常量值为 3 。
丁 | 常量值为 4 。
戊 | 常量值为 5 。
己 | 常量值为 6 。
庚 | 常量值为 7 。
辛 | 常量值为 8 。
壬 | 常量值为 9 。
癸 | 常量值为 10 。

参见： 基本数据类型


地支

地支 枚举常量集合类型 操作系统支持：Windows 跳至：农历日期支持库

成员 | 描 述
子 | 常量值为 1 。
丑 | 常量值为 2 。
寅 | 常量值为 3 。
卯 | 常量值为 4 。
辰 | 常量值为 5 。
巳 | 常量值为 6 。
午 | 常量值为 7 。
未 | 常量值为 8 。
申 | 常量值为 9 。
酉 | 常量值为 10 。
戌 | 常量值为 11 。
亥 | 常量值为 12 。

参见： 基本数据类型


属相

属相 枚举常量集合类型 操作系统支持：Windows 跳至：农历日期支持库

成员 | 描 述
鼠 | 常量值为 1 。
牛 | 常量值为 2 。
虎 | 常量值为 3 。
兔 | 常量值为 4 。
龙 | 常量值为 5 。
蛇 | 常量值为 6 。
马 | 常量值为 7 。
羊 | 常量值为 8 。
猴 | 常量值为 9 。
鸡 | 常量值为 10 。
狗 | 常量值为 11 。
猪 | 常量值为 12 。

参见： 基本数据类型


节气

节气 枚举常量集合类型 操作系统支持：Windows 跳至：农历日期支持库

成员 | 描 述
立春 | 常量值为 1 。
雨水 | 常量值为 2 。
惊蛰 | 常量值为 3 。
春分 | 常量值为 4 。
清明 | 常量值为 5 。
谷雨 | 常量值为 6 。
立夏 | 常量值为 7 。
小满 | 常量值为 8 。
芒种 | 常量值为 9 。
夏至 | 常量值为 10 。
小暑 | 常量值为 11 。
大暑 | 常量值为 12 。
立秋 | 常量值为 13 。
处暑 | 常量值为 14 。
白露 | 常量值为 15 。
秋分 | 常量值为 16 。
寒露 | 常量值为 17 。
霜降 | 常量值为 18 。
立冬 | 常量值为 19 。
小雪 | 常量值为 20 。
大雪 | 常量值为 21 。
冬至 | 常量值为 22 。
小寒 | 常量值为 23 。
大寒 | 常量值为 24 。

参见： 基本数据类型


常量 | 常量值 | 描 述
#支持库代号 | “CnCalendar” |


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。