文本语音转换支持库

文本语音转换支持库 帮助手册20080818版 返回支持库手册 返回首页

提供对文本转换成语音输出的支持,并且提供对语音识别的支持。注意使用本支持库的计算机系统中必须安装微软的语音引擎组件包，该组件包可以在微软或者是大有吴涛公司的网站上获得。微软公司的下载网址是“http://www.microsoft.com/speech/download/sdk51/”,注意SpeechSDK51和SpeechSDK51LangPack两个文件都要下载安装。大有吴涛公司的下载网址是“http://www.dywt.com.cn/edown/”。如果系统中已经安装Microsoft Office XP或者是以上的版本，就不用再安装上述的语音引擎组件包。

操作系统支持： Windows

窗口组件数据类型：

语音识别

其它数据类型：

机读文本

文本语音常量

例程名称 | 下载 | 说明
语音控制 | 语音控制.e | 本程序演示了用语音控制并执行相应程序。

适用版本，文本语音转换支持库 （1.1#3版）


语音识别

语音识别 功能型窗口组件 操作系统支持：Windows 跳至：文本语音转换支持库

该控件提供语音识别功能。

方法：

创建

释放

训练

加入常用

自有事件：

识别到语音


创建 (语音识别)

创建 方法 操作系统支持：Windows 所属对象：语音识别

创建语音识别引擎，该引擎提供语音识别的功能.成功返回真，失败返回假。

语法： 逻辑型 语音识别．创建 （识别引擎，作用域）

参数名 | 描 述
识别引擎 | 必需的；整数型。本参数应提供由“创建”命令所要求的识别引擎常量。该参数为0代表创建中文识别引擎,为1代表创建英文识别引擎。
作用域 | 必需的；整数型。本参数提供由“创建”命令所要创建的识别系统的作用范围常量。该参数为0代表系统作用域，指的是无论识别程序是否拥有系统焦点该识别程序都能进行语音识别。该参数为1代表程序作用域，指的是只有在识别程序拥有系统焦点的时候该识别程序才能进行语音识别。

例程：

说明：

创建一个与系统中安装的语音引擎的连接，如果系统中没有语音引擎，创建将会失败。如果你的系统中没有安装可以去微软或者是大有吴涛公司的网站上获得。微软公司的下载网址是“http://www.microsoft.com/speech/download/sdk51/”,注意SpeechSDK51和SpeechSDK51LangPack两个文件都要下载安装。大有吴涛公司的下载网址是“http://www.dywt.com.cn/edown/”。如果系统中已经安装Microsoft Office XP或者是以上的版本，就不用再安装上述的语音引擎组件包。

参见：例程


释放 (语音识别)

释放 方法 操作系统支持：Windows 所属对象：语音识别

释放已经创建的语音识别引擎.成功返回真，失败返回假。

语法： 逻辑型 语音识别．释放 （）

例程：

说明：

释放与系统中语音引擎的连接，如果想再次操作语音识别，必须重新使用创建命令来创建。


训练 (语音识别)

训练 方法 操作系统支持：Windows 所属对象：语音识别

通过训练可以提高系统语音识别引擎的识别精确度，训练越多，识别系统对训练人的语音辨认越好，退出程序后，该训练结果仍然保留。

语法： 逻辑型 语音识别．训练 （）

例程：

说明：

执行训练程序，使声音辨认更准确，在使用训练命令之前必须先创建，如果不创建，无法使用训练命令。


加入常用 (语音识别)

加入常用 方法 操作系统支持：Windows 所属对象：语音识别

该方法在识别系统中加入常用的字词或者句子，在识别的过程中，这些字词或者句子更加容易被系统识别。该方法的执行结果仅仅对该识别程序有效,如果要重新设置常用的字词或者句子,直接再次调用该方法即可。成功返回真，失败返回假。

语法： 逻辑型 语音识别．加入常用 （字词句数组）

参数名 | 描 述
字词句数组 | 必需的；文本型。参数数据只能提供数组数据。本参数提供由“加入常用”命令所要求的字词句数组。该数组是字符型的数组，其中的元素可以是单个的字或者是词汇，也可以是较长的句子。

例程：

说明：

把一些常用关键词加入到常用语句中，这样更容易辨认，常用语句属于数组形式的，必须把所有常用语句先加入到数组，然后一次性加入常用。


识别到语音 (语音识别)

识别到语音 事件 所属对象：语音识别 操作系统支持：Windows

在外部发出一段语音后,如果系统识别到当前的语音,则触发该事件。

语法： 无返回值 _语音识别_识别到语音 （识别文本）

参数名 | 描 述
识别文本 | 必需的；文本型。参数值指示当前识别系统识别到的文本。

例程：

说明：

当你在对麦克风说话的时候，就会触发这个事件，识别文本参数就是这个事件接收到的你说的话，通过识别文本的内容，我们可以做我们需要的操作。


机读文本

机读文本 普通类型 操作系统支持：Windows 跳至：文本语音转换支持库

该数据类型提供文本数据转换成语音或声音文件输出。

方法：

创建 | 释放 | 文本到语音 | 输出声音文件
停止发音 | 暂停发音 | 恢复发音 | 设置声音大小
设置语速 | 列举语音库 | 设置语音库 |

参见： 基本数据类型


创建 (机读文本)

创建 方法 操作系统支持：Windows 所属对象：机读文本

启动系统安装的发音引擎。

语法： 无返回值 机读文本．创建 （）

例程：

说明：

创建与系统安装的语音引擎的连接，如果系统中没有按装语音引擎，连接将会失败。如果你的系统中没有按装可以去微软或者是大有吴涛公司的网站上获得。微软公司的下载网址是“http://www.microsoft.com/speech/download/sdk51/”,注意SpeechSDK51和SpeechSDK51LangPack两个文件都要下载安装。大有吴涛公司的下载网址是“http://www.dywt.com.cn/edown/”。如果系统中已经安装Microsoft Office XP或者是以上的版本，就不用再安装上述的语音引擎组件包。


释放 (机读文本)

释放 方法 操作系统支持：Windows 所属对象：机读文本

关闭已经启动的发音引擎。

语法： 无返回值 机读文本．释放 （）

例程：

说明：

释放于系统语音引擎的连接，在释放之后如果想继续操作语音引擎，必须重新使用创建命令来创建连接。


文本到语音 (机读文本)

文本到语音 方法 操作系统支持：Windows 所属对象：机读文本

通过已经启动的发音引擎，把文本或者文件转换成为语音输出，成功返回真，失败返回假。

语法： 逻辑型 机读文本．文本到语音 （数据类别，发音数据）

参数名 | 描 述
数据类别 | 必需的；整数型。本参数应提供由“文本到语音”命令所要求的数据类别常量。0 为字符串；1 为文本文件名；2 为XML文件名。
发音数据 | 必需的；文本型。本参数提供“文本到语音”命令所要求的发声数据。该参数的内容以第一个参数的值来确定，对应关系参见参数“数据类别”的详细解释。

例程：

说明：

可以使一段文本变成语音读出来，我们使用音箱就可以直接听到，需要注意：如果开始选择的语音库是中文，那么只能读出中文，如果文本当中出现英文，只能变成字母一个一个读出，不能读出单词，如果选择的是英文语音库，那么碰到中文的部分他就会忽略不去读的。


输出声音文件 (机读文本)

输出声音文件 方法 操作系统支持：Windows 所属对象：机读文本

通过已经启动的发音引擎，把文本或者文件转换成为语音输出到指定WAV文件，成功返回真，失败返回假。该方法采用同步的执行方式。

语法： 逻辑型 机读文本．输出声音文件 （数据类别，发音数据，保存文件名）

参数名 | 描 述
数据类别 | 必需的；整数型。本参数应提供由“输出声音文件”命令所要求的数据类别常量。0 为字符串；1 为文本文件名；2 为XML文件名。
发音数据 | 必需的；文本型。本参数提供“输出声音文件”命令所要求的发声数据。该参数的内容以第一个参数的值来确定，对应关系参见参数“数据类别”的详细解释。
保存文件名 | 必需的；文本型。本参数提供“输出声音文件”命令所要求的保存声音文件的全名称。

例程：

说明：

把数据变成wav文件保存，具体数据看第一个参数，如果是文本文件名，就会把这个文件中的文本转换，如果是字符串，就把相应的文本字符串转换，比如说某某编辑框.内容，就属于字符串。如果是XML文件名，就转换XML文件的内容。

参见： 例程


停止发音 (机读文本)

停止发音 方法 操作系统支持：Windows 所属对象：机读文本

停止发音，成功返回真，失败返回假。

语法： 逻辑型 机读文本．停止发音 （）

例程：

说明：

停止读文本，如果再次开始将会从开头开始读。


暂停发音 (机读文本)

暂停发音 方法 操作系统支持：Windows 所属对象：机读文本

暂停发音，成功返回真，失败返回假。

语法： 逻辑型 机读文本．暂停发音 （）

例程：

说明：

暂停读文本，暂停后如果使用恢复发音，将从暂停处继续读。


恢复发音 (机读文本)

恢复发音 方法 操作系统支持：Windows 所属对象：机读文本

恢复发音，成功返回真，失败返回假。

语法： 逻辑型 机读文本．恢复发音 （）

例程：

说明：

恢复通过暂停发音暂停的发音。停止的发音不能恢复。


设置声音大小 (机读文本)

设置声音大小 方法 操作系统支持：Windows 所属对象：机读文本

根据参数设置声音大小，成功返回真，失败返回假。

语法： 逻辑型 机读文本．设置声音大小 （声音大小）

参数名 | 描 述
声音大小 | 必需的；整数型。本参数应提供由“设置声音大小”命令所要求的声音大小数值。该参数的范围是0到100之间。

例程：

说明：

设置机读文本声音的大小，推荐使用滑块条来调节，灵活性比较高。


设置语速 (机读文本)

设置语速 方法 操作系统支持：Windows 所属对象：机读文本

根据参数设置语速快慢，成功返回真，失败返回假。

语法： 逻辑型 机读文本．设置语速 （语速快慢）

参数名 | 描 述
语速快慢 | 必需的；整数型。本参数应提供由“设置语速”命令所要求的语速快慢数值。该参数的范围是从-10到10之间。

例程：

说明：

调节机读文本的朗读速度，由于滑块条的最小位置是0，而机读文本的语速从-10到10，所以我们把滑块条长度设置为20，让选择位置-10。


列举语音库 (机读文本)

列举语音库 方法 操作系统支持：Windows 所属对象：机读文本

返回当前系统所安装的所有语音库的名称。

语法： 文本型数组 机读文本．列举语音库 （）

例程：

说明：

列出所有的系统中的语音库，由于返回的是文本数组，所以用循环全部读出来。

参见： 例程


设置语音库 (机读文本)

设置语音库 方法 操作系统支持：Windows 所属对象：机读文本

设置当前发音的语音库为参数名称的语音库，成功返回真，失败返回假。

语法： 逻辑型 机读文本．设置语音库 （语音库名称）

参数名 | 描 述
语音库名称 | 必需的；文本型。本参数应提供由“设置语音库”命令所要求的语音库的名称。

例程：

说明：

设置当前发音的语音库，注意：如果当前正在有文本在朗读，设置语音库对当前阅读的文本是无效的，必须停止重新阅读才可以。

参见： 例程


文本语音常量

文本语音常量 枚举常量集合类型 操作系统支持：Windows 跳至：文本语音转换支持库

提供文本语音支持库中所要使用的常量枚举值。

成员 | 描 述
字符串 | 常量值为 0 。
文本文件名 | 常量值为 1 。
XML文件名 | 常量值为 2 。
中文识别 | 常量值为 0 。
英文识别 | 常量值为 1 。
系统作用域 | 常量值为 0 。
程序作用域 | 常量值为 1 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

  1. 字节型。可容纳 0 到 255 之间的数值。

  2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

  3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

  4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

  5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

  6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

  7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

  8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

  9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

  10. 字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

  11. 子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。