超级菜单支持库

超级菜单支持库 帮助手册20080808版 返回支持库手册 返回首页

该支持库实现了对超级菜单组件的支持。

操作系统支持： Windows

窗口组件数据类型：

超级菜单

例程列表：

例程名称 | 下载 | 说明
超级菜单演示程序 | 超级菜单演示程序.e | 演示如何使用超级菜单组件

适用版本，超级菜单支持库 （1.6#2版）


超级菜单

超级菜单 功能型窗口组件 操作系统支持：Windows 跳至：超级菜单支持库

该组件实现了对菜单的美化和增强。

属性：

配色方案 | 底色 | 文本颜色 | 禁止文本颜色
点燃颜色 | 渐变条颜色1 | 渐变条颜色2 | 菜单条点燃颜色1
菜单条点燃颜色2 | 点燃区边框颜色 | 分割条颜色 | 菜单项图片组
菜单项图片索引 | 菜单项字体 |  |

方法：

置菜单项图片

置侧条图片

自有事件：

被点燃

被关闭


配色方案 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定超级菜单所使用的配色方案。选择“自定义”可以自行设置相关颜色。

可供选择的属性值：
0、自定义
1、蓝色
2、灰色
3、雅绿
4、粉红
5、青春
6、古朴

例程：

说明：

通过“配色方案”属性可以获得和设置当前菜单的配色方案。超级菜单支持库中共自带5种预设方案，自定义方案用于自定义更改菜单颜色属性。

参见：例程1


背景颜色 属性 所属对象：超级菜单 操作系统支持：Windows

底色 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定菜单的背景颜色。

例程：

说明：

通过“底色”属性可以获得和更改菜单的背景色。当更改后，超级菜单的“配色方案”属性将被自动置为“自定义”。


文本颜色 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定菜单的文本颜色。

例程：

说明：

通过“文本颜色”属性获取和设置菜单的文本颜色。


禁止文本颜色 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定菜单项为禁止状态时的文本颜色。

例程：

说明：

通过“禁止文本颜色”属性设置和获取菜单在禁止时菜单文本的颜色。


点燃颜色 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定当菜单项被选定（高亮显示）时所用的颜色。

例程：

说明：

通过“点燃颜色”属性设置和获取菜单在点燃时的颜色。


渐变条颜色1 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定显示在每个菜单左边的渐变条最左边的颜色。

例程：

说明：

通过“渐变条颜色 1”属性设置菜单条欲渐变颜色。


渐变条颜色2 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定显示在每个菜单左边的渐变条最右边的颜色。

例程：

说明：

通过“渐变条颜色 2”属性设置从“渐变条颜色 1”属性的颜色渐变到“渐变条颜色 2”属性的颜色。


菜单条点燃颜色1 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定当菜单条上的项目被点燃（高亮显示）时渐变区域最上边的颜色。

例程：

说明：

通过“菜单条点燃颜色 1”属性获得和设置菜单条（顶级菜单）被点燃时的点燃欲渐变颜色。


菜单条点燃颜色2 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定当菜单条上的项目被点燃（高亮显示）时渐变区域最下边的颜色。

例程：

说明：

通过“菜单条点燃颜色 2”属性设置和获取当菜单条点燃时从“菜单条点燃颜色 1”渐变到“菜单条点燃颜色 2”的颜色。


点燃区边框颜色 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定菜单项被点燃时，渐变区域的边框颜色。

例程：

说明：

通过“点燃区边框颜色”属性设置和获得当菜单被点燃时，被点燃菜单的边框的颜色。


分割条颜色 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：整数型；本属性指定菜单分割条的颜色。

例程：

说明：

通过“分割条颜色”属性设置和获得菜单中分割条的颜色。


菜单项图片组 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：字节集；本属性为各个菜单项提供标志图片。请尽量使用单个图片大小为16×15像素的图片组，否则可能影响显示效果。

例程：

说明：

通过“图片组”属性设置和获取“超级菜单”组件中图片组的内容。本属性用于设置菜单上显示的小图片。


菜单项图片索引 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：字节集；本属性分别指定每个菜单项所使用的标志图片。

例程：

说明：

通过“图片索引”属性设置和获得菜单显示图片的索引。本属性用于指定菜单所显示的图片索引号。


菜单项字体

菜单项字体 属性 所属对象：超级菜单 操作系统支持：Windows

数据类型：字体； 指定菜单项的文本字体。

例程：

说明：

设置或取得菜单项目的字体属性。


置菜单项图片 方法 操作系统支持：Windows 所属对象：超级菜单

设置某个菜单项的标志图片。

语法： 无返回值 超级菜单．置图片 （欲置图标的菜单项，图片索引）

参数名 | 描 述
欲置图标的菜单项 | 必需的；菜单。注意，目前不支持顶级菜单图片。
图片索引 | 必需的；整数型。该参数对应于本组件的“图片组”属性中的一个图片。－1代表没有图片。

例程：

说明：

通过“置图片”命令设置指定菜单的图片索引。


置侧条图片 方法 操作系统支持：Windows 所属对象：超级菜单

设置某个菜单或子菜单的侧条图片。

语法： 无返回值 超级菜单．置侧条图片 （父菜单项， 图片数据， ［图片高度自适应］）

参数名 | 描 述
父菜单项 | 必需的； 菜单。如果该菜单项下有子菜单，则参数2指定的图片将作为其侧条图片；如果该菜单项下无子菜单，本命令无效。
图片数据 | 必需的； 字节集。参数值可以为 .JPG、.GIF、.BMP、.DIB、.ICO、.CUR 等等被支持格式的图片数据、图片资源。空字节集代表删除图片。
图片高度自适应 | 可选的； 逻辑型。在显示时，是否自动缩放图片的高度以适应菜单的高度。如果为空则默认为“假”。

例程

说明：

设置菜单侧边的图片。

参见：例程


被点燃 事件 所属对象：超级菜单 操作系统支持：Windows

当一个菜单项被点燃时引发该事件。

语法： 无返回值 _超级菜单_被点燃 （被点燃的菜单项）

参数名 | 描 述
被点燃的菜单项 | 菜单；

例程：

说明：

当菜单被点燃时，将触发此事件。


被关闭 事件 所属对象：超级菜单 操作系统支持：Windows

当所有弹出的菜单被关闭（从屏幕上消失）时引发该事件。

语法： 无返回值 _超级菜单_被关闭 （）

例程：

说明：

当弹出式菜单被关闭时，将触发此事件。