电话语音支持库

电话语音支持库 帮助手册20080811版 返回支持库手册 返回首页

本支持库实现了对电话的控制。需要Windows2000以上,DirectX9以上版本支持。如果使用传真功能,需安装Windows的“传真服务”附件。语音文件必须为WAV格式（PCM, 8.000kHz, 16位, 单声道,）。有些功能需要调制解调器的支持(如：语音，传真等),需要本地网络的支持(如：来电显示等)。

操作系统支持： Windows

窗口组件数据类型：

电话控制

其它数据类型：

按键中断

线路类型

声音文件

播放数字类型

适用版本，电话语音支持库 （1.2#4版）


电话控制

电话控制 功能型窗口组件 操作系统支持：Windows 跳至：电话控制

本支持库实现了对电话的控制。

属性：

线路总数 | 线路名称 | 线路号 | 线路类型
错误信息 |  |  |

方法：

呼叫 | 断开 | 应答 | 播放
录音 | 停止 | 检测按键 | 产生按键
保持 | 转接 | 收集按键 | 初始化
清除 | 设置声音文件 | 播放数字 | 初始化传真
发送传真 | 开启接收传真 | 清除传真 |

自有事件：

接通 | 振铃 | 来电显示 | 断开
检测按键 | 收集按键完毕 | 播放完毕 | 录音完毕
保持 | 振铃之前 |  |


线路总数 属性 数据类型：整数型；

线路总数 属性 数据类型：整数型； 所属对象：电话控制

返回系统中可用的线路的总数；本属性只可读。

语法： 对象.线路总数 = 整数型

例程：

说明：

可以取得系统中可以使用的电话线路的数量。

参见：例程


线路总数 属性 数据类型：整数型；

线路名称 属性 数据类型：文本型； 所属对象：电话控制

返回当前线路名称；本属性只可读。

语法： 对象.线路名称 = 文本型

例程：

说明：

可以取得系统中当前正在使用的电话线路的名称。

参见：例程


线路号 属性 数据类型：整数型；

线路号 属性 数据类型：整数型； 所属对象：电话控制

设置或返回当前线路号。范围从1----线路总数；本属性在设计时不可用，在运行时可读可写。

语法： 对象.线路号 = 整数型

例程：

说明：

当前正在使用的线路号。

参见：例程


线路类型 属性 数据类型：整数型；

线路类型 属性 数据类型：整数型； 所属对象：电话控制

设置或返回当前线路类型。可以为“线路类型”数据类型中的常量值。

设计时不可用。

语法： 对象.线路类型 = 整数型

例程：

说明：

设置使用的电话线路的类型。设置的类型见：数据类型常量

参见：例程


线路类型 属性 数据类型：整数型；

错误信息 属性 数据类型：文本型； 所属对象：电话控制

返回最后一条错误信息；本属性只可读。

语法： 对象.错误信息 = 文本型

例程：

说明：

取得使用时出现的错误的信息。

参见：例程


呼叫 方法 操作系统支持：Windows 所属对象：电话控制

用当前线路呼叫指定终端，终端类型包括电话号码，IP地址，主机名。

语法： 逻辑型 电话控制．呼叫 （终端号码，等待时间）

参数名 | 描 述
终端号码 | 必需的；文本型。本参数为对方的电话号码或IP地址或主机名。
等待时间 | 必需的；整数型，初始值为“60”。本参数为要等待的时间(秒)，如果超出时间对方无应答则自动挂断。默认为60秒，最长等待时间为120秒。

例程：

说明：

本方法用来连接对方的电话。

参见：例程


断开 方法 操作系统支持：Windows 所属对象：电话控制

断开当前的呼叫。

语法： 整数型 电话控制．断开 （）

例程：

说明：

本方法用来切断与对方的连接。

参见：例程


应答 方法 操作系统支持：Windows 所属对象：电话控制

应答呼叫。本方法必须在“振铃”事件后调用。

语法： 逻辑型 电话控制．应答 （）

例程：

说明：

本方法是接听电话用的。 如果不用本方法，那么只是电话线路被接通，而电话没有被接通。

参见：例程 涉及到的语音文件


播放 方法 操作系统支持：Windows 所属对象：电话控制

播放一个语音文件,放音完毕后会产生“放音完毕”事件。

语法： 逻辑型 电话控制．播放 （文件名，中断）

参数名 | 描 述
文件名 | 必需的；文本型。要播放的文件名称。如果不指路径则为当前目录。
中断 | 必需的；整数型。是否可以按键中断播放,可以为“按键中断”数据类型中的常量。

例程：

说明：

本方法用来播放一个语音文件。

参见：例程 涉及到的语音文件


录音 方法 操作系统支持：Windows 所属对象：电话控制

录音完毕后会产生“录音完毕”事件。

语法： 逻辑型 电话控制．录音 （文件名，中断，时间）

参数名 | 描 述
文件名 | 必需的；文本型。存放录音文件的名称。如果不指路径为当前目录。
中断 | 必需的；整数型。是否可以按键中断播放,可以为“按键中断”数据类型中的常量。
时间 | 必需的；整数型。录音的时间（秒）。

例程：

说明：

本方法用来录制对方的声音。

参见：例程 涉及到的语音文件


停止 方法 操作系统支持：Windows 所属对象：电话控制

停止当前的播放或录音。

语法： 逻辑型 电话控制．停止 （）

例程：

说明：

本方法用来停止当前的播放或录音操作。

参见：例程 涉及到的语音文件


检测按键 方法 操作系统支持：Windows 所属对象：电话控制

开启或关闭“检测按键”事件。

语法： 逻辑型 电话控制．检测按键 （是否检测按键）

参数名 | 描 述
是否检测按键 | 必需的；逻辑型。真为开启检测按键，假为关闭检测按键。

例程：

说明：

本方法用来判断对方单个的按键。在“检测按键”事件中可以取得按下的按键值。

参见：例程 涉及到的语音文件


产生按键 方法 操作系统支持：Windows 所属对象：电话控制

在当前线路产生一串按键。等同于在话机上按键。

语法： 逻辑型 电话控制．产生按键 （按键文本）

参数名 | 描 述
按键文本 | 必需的；文本型。包括一系列按键的字符串。可用的字符包括1，2，3，4，5，6，7，8，9，0，*，# 以及英文的逗号“,” 。逗号的作用是延迟两个相临按键之间的间隔 。

例程：

说明：

本方法用来模拟对方的按键。

参见：例程 涉及到的语音文件


保持 方法 操作系统支持：Windows 所属对象：电话控制

保持当前的呼叫状态。

语法： 逻辑型 电话控制．保持 （是否保持）

参数名 | 描 述
是否保持 | 必需的；逻辑型。真为保持状态假为解除保持。

暂时无法使用


转接 方法 操作系统支持：Windows 所属对象：电话控制

把当前通话转接到指定终端。

语法： 逻辑型 电话控制．转接 （终端号码）

参数名 | 描 述
终端号码 | 必需的；文本型。本参数为对方的电话号码或IP地址或主机名。

暂时无法使用


收集按键 方法 操作系统支持：Windows 所属对象：电话控制

收集一串按键，收集按集完毕后会产生“收集按键完毕”事件。

语法： 逻辑型 电话控制．收集按键 （按键个数，终止按键，按键时间1，按键时间2）

参数名 | 描 述
按键个数 | 必需的；整数型。表示要收集的按键的个数。
终止按键 | 必需的；字节型。表示终止收集的按键。
按键时间1 | 必需的；整数型。等待第一个按键所用的最长时间(秒)。
按键时间2 | 必需的；整数型。代表各按键之间的最大时间间隔(秒)。

例程：

说明：

本方法用来收集对方的一串按键，并触发“收集按键完毕”事件。

参见：例程 涉及到的语音文件


初始化 方法 操作系统支持：Windows 所属对象：电话控制

初始化本支持库,使用本支持库之前必须调用此方法。

语法： 逻辑型 电话控制．初始化 （）

例程：

说明：

本方法用来启动电话控制组件。

参见：例程 涉及到的语音文件


清除 方法 操作系统支持：Windows 所属对象：电话控制

与初始化对应，清除本支持库所有资源。

语法： 逻辑型 电话控制．清除 （）

例程：

说明：

要关闭程序时，必须使用本方法清除支持库占有的内存资源。

参见：例程 涉及到的语音文件


设置声音文件 方法 操作系统支持：Windows 所属对象：电话控制

设置声音文件，为“播放数字”方法做准备。

语法： 逻辑型 电话控制．设置声音文件 （声音类型，文件名）

参数名 | 描 述
声音类型 | 必需的；整数型。可以为“声音文件”数据类型中的常量值。
文件名 | 必需的；文本型。本参数用来表示某个“声音类型”对应的文件名。

例程：

说明：

要播放自定义的声音文件时，必须用本方法设置要播放的声音文件。

参见：例程 涉及到的语音文件


播放数字 方法 操作系统支持：Windows 所属对象：电话控制

根据“设置声音文件”方法中设置的文件或以支持库默认的声音播放指定的数字。

语法： 逻辑型 电话控制．播放数字 （数字，播放类型，声音类型，间隔时间）

参数名 | 描 述
数字 | 必需的；双精度小数型。本参数用来表示要播放的数字。
播放类型 | 必需的；整数型。可为“播放数字类型”数据类型中的常量值。
声音类型 | 必需的；整数型。1 为 自定义; 2 为 默认女声; 3 为 默认男声; 如为1(自定义),要在调用此方法之前调用“设置声音文件”来设置自定义声音。
间隔时间 | 必需的；整数型。每播放一个数字中间间隔的时间(秒)。

例程：

说明：

本方法用来将数字转换成声音文件播放出来。

参见：例程 涉及到的语音文件


初始化传真 方法 操作系统支持：Windows 所属对象：电话控制

初始化传真设备。

语法： 逻辑型 电话控制．初始化传真 （设备号）

参数名 | 描 述
设备号 | 必需的；整数型，初始值为“1”。系统传真的设备号，默认为1,是系统的第一个传真设备。

例程：

说明：

本方法用来启动传真设备。

参见：例程


发送传真 方法 操作系统支持：Windows 所属对象：电话控制

发送传真。

语法： 逻辑型 电话控制．发送传真 （电话号码，文件名）

参数名 | 描 述
电话号码 | 必需的；文本型。本参数为对方的电话号码。
文件名 | 必需的；文本型。本参数为要发送的文件。

例程：

说明：

本方法用来发送传真。

参见：例程


开启接收传真 方法 操作系统支持：Windows 所属对象：电话控制

开启接收传真,当接收传真开启后有电话打过来时会自动接受传真。

语法： 逻辑型 电话控制．开启接收传真 （是否开启接收传真）

参数名 | 描 述
是否开启接收传真 | 必需的；逻辑型。真为开启接收传真,假为关闭接收传真。

例程：

说明：

本方法用来设定是否接受传真。

参见：例程


清除传真 方法 操作系统支持：Windows 所属对象：电话控制

与传真初始化对应，清除所有传真资源。

语法： 逻辑型 电话控制．清除传真 （）

例程：

说明：

本方法用来清除所有传真资源。

参见：例程


编辑内容被改变 事件 所属对象：组合框 操作系统支持：Windows

接通 事件 所属对象：电话控制 操作系统支持：Windows

当线路接通时触发此事件

语法： 无返回值 _电话控制_接通 （）

例程：

说明：

当向外拨打电话时，电话线路连通了就会触发此事件； 当有电话打进时，接听电话或“应答”后才会触发此事件。

参见：例程


接通 事件 所属对象：电话控制 操作系统支持：Windows

振铃 事件 所属对象：电话控制 操作系统支持：Windows

当有电话呼入的时候每次振铃都将产生此事件，出现振铃事件后就可以调用“应答”方法应答呼叫。

语法： 无返回值 _电话控制_振铃 （次数）

参数名 | 描 述
次数 | 整数型；参数值表示振铃的次数。

例程：

说明：

当有电话打入，电话铃声响起时就会触发此事件。

参见：例程 涉及到的语音文件


来电显示 事件 所属对象：电话控制 操作系统支持：Windows

当来电号码被捕获的时候，将产生此事件。

语法： 无返回值 _电话控制_来电显示 （来电号码）

参数名 | 描 述
来电号码 | 文本型；参数值指示来电的号码。

例程：

说明：

只有支持来电显示功能的调制解调器才能触发此事件。

参见：例程 涉及到的语音文件


断开 事件 所属对象：电话控制 操作系统支持：Windows

当呼叫被断开时,将产生此事件。

语法： 无返回值 _电话控制_断开 （）

例程：

说明：

当电话线路被断开就会触发此事件。

注：本事件有时不能触发。

参见：例程


检测按键 事件 所属对象：电话控制 操作系统支持：Windows

当通话一方按下话机上的按键时产生此事件。可以用“检测按键”方法来启动或关闭检测按键事件。

语法： 无返回值 _电话控制_检测按键 （键值）

参数名 | 描 述
键值 | 字节型；参数值指示被检测到的按键。

例程：

说明：

当需要判断对方的按键时，用“检测按键”方法来触发此事件。

另：“*”键值是42，“#” 键值是35，0--9键值是48—57.其它键值可以自己测定一下。

参见：例程 涉及到的语音文件


收集按键完毕 事件 所属对象：电话控制 操作系统支持：Windows

收集按键完毕后产生此事件。

语法： 无返回值 _电话控制_收集按键完毕 （按键串，事件触发原因）

参数名 | 描 述
按键串 | 文本型；参数值指示收集到的按键。
事件触发原因 | 整数型；1: 收集的按键已达到了指定的个数;2: 指定的用于结束收集的按键被检测到了;3: 在等待第一个按键时超时;4: 在等待第一个以后的按键时超时。

例程：

说明：

在使用“收集按键”方法后才会触发此事件。

参见：例程 涉及到的语音文件


播放完毕 事件 所属对象：电话控制 操作系统支持：Windows

当播放语音完毕后产生此事件。

语法： 无返回值 _电话控制_播放完毕 （文件名）

参数名 | 描 述
文件名 | 文本型；本参数用来表示播放完的那个文件的文件名。

例程：

说明：

当播放语音文件完毕后就会触发此事件。

参见：例程 涉及到的语音文件


录音完毕 事件 所属对象：电话控制 操作系统支持：Windows

当录音完毕后产生此事件。

语法： 无返回值 _电话控制_录音完毕 （）

例程：

说明：

当录音完毕后就会触发此事件。

参见：例程 涉及到的语音文件


保持 事件 所属对象：电话控制 操作系统支持：Windows

当前呼叫的状态变为保持时触发此事件。

语法： 无返回值 _电话控制_保持 （）

暂时无法使用


振铃之前 事件 所属对象：电话控制 操作系统支持：Windows

当振铃之前触发此事件，可以在此事件用“开启接收传真”方法接收传真。

语法： 无返回值 _电话控制_振铃之前 （）

例程：

说明：

在电话响铃之前就会触发此事件。

参见：例程 涉及到的语音文件


按键中断

按键中断 枚举常量集合类型 操作系统支持：Windows 跳至：电话控制

本数据类型包括了按键中断的常量。

成员 | 描 述
不可中断 | 常量值为 -2 。在录音或放音时不可中断。
任意键中断 | 常量值为 -1 。在录音或放音时按任意键中断。
按0键中断 | 常量值为 0 。在录音或放音时按0键中断。
按1键中断 | 常量值为 1 。在录音或放音时按1键中断。
按2键中断 | 常量值为 2 。在录音或放音时按2键中断。
按3键中断 | 常量值为 3 。在录音或放音时按3键中断。
按4键中断 | 常量值为 4 。在录音或放音时按4键中断。
按5键中断 | 常量值为 5 。在录音或放音时按5键中断。
按6键中断 | 常量值为 6 。在录音或放音时按6键中断。
按7键中断 | 常量值为 7 。在录音或放音时按7键中断。
按8键中断 | 常量值为 8 。在录音或放音时按8键中断。
按9键中断 | 常量值为 9 。在录音或放音时按9键中断。

参见：基本数据类型


线路类型

线路类型 枚举常量集合类型 操作系统支持：Windows 跳至：电话控制

本数据类型包括了线路类型的常量。

成员 | 描 述
电话 | 常量值为 1 。
主机 | 常量值为 2 。
IP | 常量值为 3 。

参见：基本数据类型


声音文件

声音文件 枚举常量集合类型 操作系统支持：Windows 跳至：电话控制

本数据类型包括了定义声音文件的常量。

成员 | 描 述
零 | 常量值为 0 。
一 | 常量值为 1 。
二 | 常量值为 2 。
三 | 常量值为 3 。
四 | 常量值为 4 。
五 | 常量值为 5 。
六 | 常量值为 6 。
七 | 常量值为 7 。
八 | 常量值为 8 。
九 | 常量值为 9 。
十 | 常量值为 10 。
百 | 常量值为 11 。
千 | 常量值为 12 。
万 | 常量值为 13 。
亿 | 常量值为 14 。
元 | 常量值为 15 。
角 | 常量值为 16 。
分 | 常量值为 17 。
点 | 常量值为 18 。
负 | 常量值为 19 。

参见：基本数据类型


播放数字类型

播放数字类型 枚举常量集合类型 操作系统支持：Windows 跳至：电话控制

本数据类型包括了“播放数字类型”的常量。

成员 | 描 述
数字 | 常量值为 1 。
金额 | 常量值为 2 。

参见：基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。