通用对象支持库

通用对象支持库 帮助手册20080815版 返回支持库手册 返回首页

目前提供“快速文本对象”“快速字节集对象”等通用对象数据类型，分别实现对“文本”“字节集”等易语言基本数据类型的包装。除了易用性，本库还特别注重大批量数据添加删除时的操作效率。

操作系统支持： Windows、Linux

命令类别：

命令分类

其它数据类型：

快速文本对象

快速字节集对象

适用版本，通用对象支持库 （1.0#1版）


快速文本对象

快速文本对象 普通类型 操作系统支持：Windows、Linux 跳至：通用对象支持库

提供对文本数据的相关操作。在大批量数据操作时，相对于“文本型”有较高的执行效率。

方法：

取长度 | 取文本 | 置文本 | 清除文本
添加 | 插入 | 删除字符 | 寻找文本
倒找文本 | 替换文本 | 替换子文本 | 分割文本
到大写 | 到小写 | 到全角 | 到半角
删首空 | 删尾空 | 删首尾空 | 删全部空
从文件读 | 写到文件 | 取缓冲区 | 释放缓冲区
置可用内存 | 置内存增量 |  |

参见： 基本数据类型


取长度 (快速文本对象)

取长度 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

返回本对象文本中的字符个数（每个汉字视为两个字符）。

语法： 整数型 快速文本对象．取长度 （）

例程：

说明：

获取对象的长度。

参见：例程


取文本 (快速文本对象)

取文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

取本对象中的全部或部分文本。

语法： 文本型 快速文本对象．取文本 （［起始位置］， ［字符数］）

参数名 | 描 述
起始位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
字符数 | 可选的； 整数型。如果本参数被省略，默认为从“起始位置”到文本结尾的字符个数。

例程：

说明：

获取对象的文本内容。


置文本 (快速文本对象)

置文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将参数数据转换为文本并设置为本对象文本。

语法： 逻辑型 快速文本对象．置文本 （数据， ... ）

参数名 | 描 述
数据 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数类型支持各种基本数据类型及其数组数据。

例程：

说明：

设置对象的文本内容。


清除文本 (快速文本对象)

清除文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

语法： 逻辑型 快速文本对象．清除文本 （）

例程：

说明：

将对象的内容清空。


添加 (快速文本对象)

添加 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将参数转换成文本并添加到本对象文本的末尾。

语法： 逻辑型 快速文本对象．添加 （欲添加的数据， ... ）

参数名 | 描 述
数据 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数类型支持各种基本数据类型及其数组数据。

例程：

说明：

向对象加入文本内容。


插入 (快速文本对象)

插入 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将参数数据转换为文本后插入本对象文本中的指定位置之前。

语法： 逻辑型 快速文本对象．插入 （［插入位置］， 欲插入的数据， ... ）

参数名 | 描 述
插入位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
欲插入的数据 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数类型支持各种基本数据类型及其数组数据。

例程：

说明：

向对象中插入文本。


删除字符 (快速文本对象)

删除字符 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

删除文本中从指定字符开始的指定个数的字符（包括起始删除位置处的字符）。

语法： 逻辑型 快速文本对象．删除字符 （起始删除位置， 欲删除的字符数）

参数名 | 描 述
起始删除位置 | 必需的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。
欲删除的字符数 | 必需的； 整数型。如果参数值为-1，表示删除从“起始删除位置”开始到文本结尾的所有字符。

例程：

说明：

删除对象中的文本。


寻找文本 (快速文本对象)

寻找文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

寻找指定文本在本对象文本中从“起始寻找位置”开始第一次出现时的位置索引（>0），未找到则返回-1。

语法： 整数型 快速文本对象．寻找文本 （欲寻找的文本， ［起始寻找位置］， 是否区分大小写）

参数名 | 描 述
欲寻找的文本 | 必需的； 文本型。
起始寻找位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
是否区分大小写 | 必需的； 逻辑型，初始值为“真”。

例程：

说明：

在对象中寻找指定的文本。


倒找文本 (快速文本对象)

倒找文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

在本对象文本中从“起始寻找位置”开始向文本开头方向寻找指定文本第一次出现时的位置索引（相对于文本头），未找到则返回-1。

语法： 整数型 快速文本对象．倒找文本 （欲寻找的文本， ［起始寻找位置］， 是否区分大小写）

参数名 | 描 述
欲寻找的文本 | 必需的； 文本型。
起始寻找位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
是否区分大小写 | 必需的； 逻辑型，初始值为“真”。

例程：

说明：

在对象中倒找指定的文本。


替换文本 (快速文本对象)

替换文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

语法： 逻辑型 快速文本对象．替换文本 （起始替换位置， 替换长度， ［替换为文本］）

参数名 | 描 述
起始替换位置 | 必需的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。
替换长度 | 必需的； 整数型。
替换为文本 | 可选的； 文本型。如果本参数被省略，则删除文本中的指定部分。

例程：

说明：

在对象中进行替换文本的操作。


替换子文本 (快速文本对象)

替换子文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

在本对象文本中查找指定文本，并将其替换为其它文本。返回替换成功次数。

语法： 整数型 快速文本对象．替换子文本 （被替换文本， ［替换为文本］， ［起始替换位置］， ［最大替换次数］， 是否区分大小写）

参数名 | 描 述
被替换文本 | 必需的； 文本型。
替换为文本 | 可选的； 文本型。如果本参数被省略，则表示将删除被替换文本。
起始替换位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
最大替换次数 | 可选的； 整数型。如果为-1，表示不限制替换次数。如果本参数被省略，默认为-1。
是否区分大小写 | 必需的； 逻辑型，初始值为“真”。

例程：

说明：

在对象中进行替换子文本的操作。


分割文本 (快速文本对象)

分割文本 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

语法： 文本型数组 快速文本对象．分割文本 （［用作分割的文本］， ［要返回的子文本数目］）

参数名 | 描 述
用作分割的文本 | 可选的； 文本型。如果被省略，则默认使用半角逗号“,”字符作为分隔符。如果是一个长度为零的文本，则返回的数组仅包含一个成员，其内容是本对象中的文本。
要返回的子文本数目 | 可选的； 整数型。如果为-1，表示不限制替换次数。如果本参数被省略，默认为-1。

例程：

说明：

分割对象中的文本。


到大写 (快速文本对象)

到大写 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将本对象文本中的全部或部分英文字母变为大写字母。

语法： 逻辑型 快速文本对象．到大写 （［起始字符位置］， ［字符个数］）

参数名 | 描 述
起始字符位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
字符个数 | 可选的； 整数型。如果本参数被省略，默认为从参数“起始字符位置”开始到文本结尾的字符个数。

例程：

说明：

将对象中的小写字母都变成大写。


到小写 (快速文本对象)

到小写 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将本对象文本中的全部或部分英文字母变为小写字母。

语法： 逻辑型 快速文本对象．到小写 （［起始字符位置］， ［字符个数］）

参数名 | 描 述
起始字符位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字符，2表示第二个字符，依次类推；位置索引也可以为负值，-1表示最后一个字符，-2表示倒数第二个字符，依次类推。如果本参数被省略，默认为1。
字符个数 | 可选的； 整数型。如果本参数被省略，默认为从参数“起始字符位置”开始到文本结尾的字符个数。

例程：

说明：

将对象中的大写字母都变成小写。


到全角 (快速文本对象)

到全角 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将本对象文本中的所有半角字符变为全角。

语法： 逻辑型 快速文本对象．到全角 （）

例程：

说明：

将对象中的文本都变成全角格式。


到半角 (快速文本对象)

到半角 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将本对象文本中的所有全角字符变为半角。

语法： 逻辑型 快速文本对象．到半角 （）

例程：

说明：

将对象中的文本都变成半角格式。


删首空 (快速文本对象)

删首空 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

删除本对象文本中首部所有全角或半角空格。

语法： 逻辑型 快速文本对象．删首空 （）

例程：

说明：

去掉对象中文本的前面的空格。


删尾空 (快速文本对象)

删尾空 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

删除本对象文本中尾部所有全角或半角空格。

语法： 逻辑型 快速文本对象．删尾空 （）

例程：

说明：

去掉对象中文本的后面的空格。


删首尾空 (快速文本对象)

删首尾空 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

删除本对象文本中首部和尾部所有全角或半角空格。

语法： 逻辑型 快速文本对象．删首尾空 （）

例程：

说明：

去掉对象中文本的前面和后面的空格。


删全部空 (快速文本对象)

删全部空 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

删除本对象文本中所有全角或半角空格（包括首部、尾部及中间）。

语法： 逻辑型 快速文本对象．删全部空 （）

例程：

说明：

去掉对象中文本的全部空格。


从文件读 (快速文本对象)

从文件读 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

从指定的文本文件中读取其所有文本到本对象中。

语法： 逻辑型 快速文本对象．从文件读 （文件名）

参数名 | 描 述
文件名 | 必需的； 文本型。请提供包含完整路径的文本名称。

例程：

说明：

从文件中读入文本内容到本对象中。


写到文件 (快速文本对象)

写到文件 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

将本对象中的所有数据写入指定的文件中。如果该文件不存在，则自动创建；如果该文件已经存在，其原有内容将被直接覆盖！。

语法： 逻辑型 快速文本对象．写到文件 （文件名）

参数名 | 描 述
文件名 | 必需的； 文本型。请提供包含完整路径的文本名称。

例程：

说明：

将对象中的文本写到文件中。


取缓冲区 (快速文本对象)

取缓冲区 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

为高级用户提供，初级用户无需掌握；
返回指定大小的缓冲区内存首地址。如果不能获取足够大小的缓冲区，将返回0。可以向该缓冲区直接写入文本数据，但事后必须调用“释放缓冲区()”以调整本对象内部状态。向缓冲区写入数据时请注意不要写到缓冲区之外。

语法： 整数型 快速文本对象．取缓冲区 （［缓冲区大小］）

参数名 | 描 述
缓冲区大小 | 可选的； 整数型。应大于零并小于“最大可用内存”。如果本参数被省略，默认为当前文本长度。

例程：

说明：

为对象获取内存缓冲区。


释放缓冲区 (快速文本对象)

释放缓冲区 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

为高级用户提供，初级用户无需掌握；
本方法只是调整内部状态，并不修改内部文本。另请参考“取缓冲区()”中的说明。

语法： 逻辑型 快速文本对象．释放缓冲区 （）

例程：

说明：

将对象获取的内存缓冲区释放。


置可用内存 (快速文本对象)

置可用内存 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

为高级用户提供，初级用户无需掌握；
设置本对象内部使用的最小可用内存和最大可用内存。使用本方法可以优化内存使用，但因为内部已经有适当的初始值，普通用户不必调用本方法。

语法： 逻辑型 快速文本对象．置可用内存 （［最小可用内存］， ［最大可用内存］）

参数名 | 描 述
最小可用内存 | 可选的； 整数型。单位为字节。如果本参数被省略，则保持现有“最小可用内存”数值不变。其内部初始值为10240字节，约10K。
最大可用内存 | 可选的； 整数型。单位为字节。如果本参数被省略，则保持现有“最大可用内存”数值不变。其内部初始值为2147483647字节，约2G。

例程：

说明：

为对象设置可以使用的内存范围。


置内存增量 (快速文本对象)

置内存增量 方法 操作系统支持：Windows、Linux 所属对象：快速文本对象

为高级用户提供，初级用户无需掌握；
设置本对象内部使用的内存增量值。所谓“内存增量”，即每次需要申请内存时在所需内存的基础上增加的内存数量（多申请出来的内存可供后续操作使用，从而减少了申请内存的次数，提高了执行效率）。正确使用本方法可以优化内存使用并提高执行效率，但因为内部已经有适当的初始值，普通用户不必调用本方法。

语法： 逻辑型 快速文本对象．置内存增量 （内存增量）

参数名 | 描 述
内存增量 | 必需的； 整数型。单位为字节。如果此值过小，可能导致数据操作效率降低；如果此值过大，可能导致消耗较多内存。内部初始值为10240字节，约10K。

例程：

说明：

在对象获取内存缓冲区时，设置内存的增量。


快速字节集对象

快速字节集对象 普通类型 操作系统支持：Windows、Linux 跳至：通用对象支持库

提供对字节集数据的相关操作。在大批量数据操作时，相对于“字节集”有较高的执行效率。

方法：

取长度 | 取字节集 | 置字节集 | 清除字节集
添加 | 插入 | 删除字节 | 取字节
寻找字节集 | 倒找字节集 | 替换字节集 | 替换子字节集
分割字节集 | 从文件读 | 写到文件 | 取缓冲区
释放缓冲区 | 置可用内存 | 置内存增量 |

参见： 基本数据类型


取长度 (快速字节集对象)

取长度 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

单位为字节(byte)。

语法： 整数型 快速字节集对象．取长度 （）

例程：

说明：

获取对象的长度。


取字节集 (快速字节集对象)

取字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

取本对象中的全部或部分字节集。

语法： 字节集 快速字节集对象．取字节集 （［起始位置］， ［字节数］）

参数名 | 描 述
起始位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。如果本参数被省略，默认为1。
字节数 | 可选的； 整数型。如果本参数被省略，默认为从“起始位置”到字节集结尾的字节数。

例程：

说明：

获取对象中的字节集内容。


置字节集 (快速字节集对象)

置字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

语法： 逻辑型 快速字节集对象．置字节集 （数据， ... ）

参数名 | 描 述
数据 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数类型支持各种基本数据类型及其数组数据。

例程：

说明：

设置对象中的字节集内容。


清除字节集 (快速字节集对象)

清除字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

语法： 逻辑型 快速字节集对象．清除字节集 （）

例程：

说明：

清除对象中的字节集内容。


添加 (快速字节集对象)

添加 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

语法： 逻辑型 快速字节集对象．添加 （欲添加的数据， ... ）

参数名 | 描 述
欲添加的数据 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数类型支持各种基本数据类型及其数组数据。

例程：

说明：

向对象的尾部加入字节集内容。


插入 (快速字节集对象)

插入 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

在指定的插入位置之前插入指定的字节集数据。

语法： 逻辑型 快速字节集对象．插入 （插入位置， 欲插入的数据， ... ）

参数名 | 描 述
插入位置 | 必需的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。
欲插入的数据 | 必需的； 可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数类型支持各种基本数据类型及其数组数据。

例程：

说明：

向对象中插入字节集内容。


删除字节 (快速字节集对象)

删除字节 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

删除字节集中从指定字节开始的指定个数的字节（包括起始删除位置处的字节）。

语法： 逻辑型 快速字节集对象．删除字节 （起始删除位置， 欲删除的字节数）

参数名 | 描 述
起始删除位置 | 必需的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。
欲删除的字节数 | 必需的； 整数型。

例程：

说明：

删除对象中的字节。


取字节 (快速字节集对象)

取字节 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

取指定位置处的字节值。

语法： 字节型 快速字节集对象．取字节 （位置索引）

参数名 | 描 述
位置索引 | 必需的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。

例程：

说明：

获取对象中的字节值。


寻找字节集 (快速字节集对象)

寻找字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

寻找指定数据在本对象数据中从“起始寻找位置”开始第一次出现时的位置索引，未找到则返回-1。

语法： 整数型 快速字节集对象．寻找字节集 （欲寻找的数据， ［起始寻找位置］）

参数名 | 描 述
欲寻找的数据 | 必需的； 通用型。参数类型支持各种基本数据类型。
起始寻找位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。如果本参数被省略，默认为1。

例程：

说明：

在对象中寻找指定字节集内容。


倒找字节集 (快速字节集对象)

倒找字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

在本对象数据中从“起始寻找位置”开始向数据开头方向寻找指定数据第一次出现时的位置索引（相对数据开头），未找到则返回-1。

语法： 整数型 快速字节集对象．倒找字节集 （欲寻找的数据， ［起始寻找位置］）

参数名 | 描 述
欲寻找的数据 | 必需的； 通用型。参数类型支持各种基本数据类型。
起始寻找位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。默认为-1，即从数据结尾开始向前寻找。

例程：

说明：

倒找对象中的字节集内容。


替换字节集 (快速字节集对象)

替换字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

将本对象数据中从指定位置开始指定长度的数据替换为新的数据。

语法： 逻辑型 快速字节集对象．替换字节集 （起始替换位置， 替换长度， ［替换为字节集］）

参数名 | 描 述
起始替换位置 | 必需的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。
替换长度 | 必需的； 整数型。
替换为字节集 | 可选的； 通用型。参数类型支持各种基本数据类型。如果本参数被省略，则删除字节集中的指定部分。

例程：

说明：

替换对象中的字节集内容。


替换子字节集 (快速字节集对象)

替换子字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

在本对象数据中查找“被替换数据”，并将其替换为“替换为数据”。返回实际替换次数。

语法： 整数型 快速字节集对象．替换子字节集 （被替换数据， ［替换为数据］， ［起始替换位置］， ［最大替换次数］）

参数名 | 描 述
被替换数据 | 必需的； 通用型。参数类型支持各种基本数据类型。
替换为数据 | 可选的； 通用型。参数类型支持各种基本数据类型。如果本参数被省略，则表示将删除被替换数据。
起始替换位置 | 可选的； 整数型。位置索引可以为正值，1表示第一个字节，2表示第二个字节，依次类推；位置索引也可以为负值，-1表示最后一个字节，-2表示倒数第二个字节，依次类推。如果本参数被省略，默认为1。
最大替换次数 | 可选的； 整数型。如果本参数被省略，或值为-1，表示不限制替换次数。

例程：

说明：

替换对象中的子字节集内容。


分割字节集 (快速字节集对象)

分割字节集 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

语法： 字节集数组 快速字节集对象．分割字节集 （［用作分隔的字节集］， ［要返回的子文本数目］）

参数名 | 描 述
用作分隔的字节集 | 可选的； 字节集。如果被省略，则默认使用字节 0 作为分隔符。如果是一个长度为零的文本，则返回的数组仅包含一个成员，其内容是本对象中的文本。
要返回的子文本数目 | 可选的； 整数型。如果为-1，表示不限制替换次数。如果本参数被省略，默认为-1。

例程：

说明：

分割对象中的字节集内容。


从文件读 (快速字节集对象)

从文件读 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

从指定的文件中读取其所有数据到本对象中。

语法： 逻辑型 快速字节集对象．从文件读 （文件名）

参数名 | 描 述
文件名 | 必需的； 文本型。请提供包含完整路径的文本名称。

例程：

说明：

将文件中的字节集数据读入本对象中。


写到文件 (快速字节集对象)

写到文件 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

将本对象中的数据写入指定的文件中。如果该文件不存在，则自动创建；如果该文件已经存在，其原有内容将被直接覆盖！。

语法： 逻辑型 快速字节集对象．写到文件 （文件名）

参数名 | 描 述
文件名 | 必需的； 文本型。请提供包含完整路径的文本名称。

例程：

说明：

将对象中的字节集数据写到文件中。


取缓冲区 (快速字节集对象)

取缓冲区 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

为高级用户提供，初级用户无需掌握；
返回指定大小的缓冲区内存首地址，该地址同时也是内部数据指针。如果不能获取足够大小的缓冲区，将返回0。可以向该缓冲区直接写入数据，注意写入数据时请不要写到缓冲区之外。如果改变了缓冲区中数据的长度，必须及时调用“释放缓冲区()”。

语法： 整数型 快速字节集对象．取缓冲区 （［缓冲区大小］）

参数名 | 描 述
缓冲区大小 | 可选的； 整数型。应大于零并小于“最大可用内存”。如果本参数被省略，默认为当前数据长度。

例程：

说明：

获取使用对象时的内存缓冲区。


释放缓冲区 (快速字节集对象)

释放缓冲区 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

为高级用户提供，初级用户无需掌握；
告知对象“最新的、经外界修改过的”数据长度。另请参考“取缓冲区()”中的说明。

语法： 逻辑型 快速字节集对象．释放缓冲区 （数据长度）

参数名 | 描 述
数据长度 | 必需的； 整数型。经外界修改后的数据长度。

例程：

说明：

释放使用对象时的内存缓冲区。


置可用内存 (快速字节集对象)

置可用内存 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

为高级用户提供，初级用户无需掌握；
设置本对象内部使用的最小可用内存和最大可用内存。使用本方法可以优化内存使用，但因为内部已经有适当的初始值，普通用户不必调用本方法。

语法： 逻辑型 快速字节集对象．置可用内存 （［最小可用内存］， ［最大可用内存］）

参数名 | 描 述
最小可用内存 | 可选的； 整数型。单位为字节。如果本参数被省略，则保持现有“最小可用内存”数值不变。其内部初始值为10240字节，约10K。
最大可用内存 | 可选的； 整数型。单位为字节。如果本参数被省略，则保持现有“最大可用内存”数值不变。其内部初始值为2147483647字节，约2G。

例程：

说明：

设置使用对象时的内存范围。


置内存增量 (快速字节集对象)

置内存增量 方法 操作系统支持：Windows、Linux 所属对象：快速字节集对象

为高级用户提供，初级用户无需掌握；
设置本对象内部使用的内存增量值。所谓“内存增量”，即每次需要申请内存时在原来的基础上增加的内存数量（多申请出来的内存可供后续操作使用，从而减少了申请内存的次数，提高了执行效率）。正确使用本方法可以优化内存使用并提高执行效率，但因为内部已经有适当的初始值，普通用户不必调用本方法。

语法： 逻辑型 快速字节集对象．置内存增量 （内存增量）

参数名 | 描 述
内存增量 | 必需的； 整数型。单位为字节。如果此值过小，可能导致数据操作效率降低；如果此值过大，可能导致消耗较多内存。内部初始值为10240字节，约10K。

例程：

说明：

设置在对象获取内存缓冲区时内存的增量。


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


命令分类

命令分类 类别 跳至：通用对象支持库