数据操作支持库一

数据操作支持库一 帮助手册20080813版 返回支持库手册 返回首页

本支持库实现了数据压缩解压、数据完整性校验、数据加解密支持。

操作系统支持： Windows、Linux

命令类别：

数据压缩解压

数据完整性校验

数据加解密

常量表

例程列表：

例程名称 | 下载 | 说明
保证文件不被更改 | 保证文件不被更改.e | 本程序用作演示"取数据摘要"命令的使用方法,并且具有实用价值.
RSA数字签名钥匙有效性测试 | 数字签名钥匙测试.e | 本程序用作测试指定的RSA钥匙是否可用，同时演示了数字签名和签名验证的使用方法。

适用版本，数据操作支持库一 （1.0#50版）


数据压缩解压

数据压缩解压 类别 跳至：数据操作支持库一


压缩数据

压缩数据 命令 操作系统支持：Windows、Linux 所属类别：数据压缩解压

压缩一段字节集数据，返回被压缩后的结果字节集。如果压缩失败，返回空字节集。

语法： 字节集 压缩数据 （字节集数据）

参数名 | 描 述
字节集数据 | 必需的；字节集。为命令提供所需的字节集数据。

例程

说明

压缩原数据结果返回被操作的数据中，使表示图象框的图片赋予被操作的数据变量地址的内容。

参见：例程1


解压数据

解压数据 命令 操作系统支持：Windows、Linux 所属类别：数据压缩解压

解压一个内含被压缩数据的字节集，返回被解压后的结果字节集。如果压缩失败，返回空字节集。注意解压后的数据也有可能是空字节集。

语法： 字节集 解压数据 （字节集数据）

参数名 | 描 述
字节集数据 | 必需的；字节集。为命令提供所需的字节集数据。

例程

说明

解压数据被操作的数据返回结果最后装入表示图像框的图片数据中。（解压次数不得超出压缩次数）


数据完整性校验

数据完整性校验 类别 跳至：数据操作支持库一


取数据摘要

取数据摘要 命令 操作系统支持：Windows、Linux 所属类别：数据完整性校验

返回一段字节集数据的MD5数据摘要编码文本。不同数据的MD5码都不一样，因此本命令可以用作保证重要数据不会被篡改。

语法： 文本型 取数据摘要 （字节集数据）

参数名 | 描 述
字节集数据 | 必需的；字节集。为命令提供所需的字节集数据。

例程

说明

使用最原始的数据摘要文件与当前取出数据摘要文件进行比较，如果不同，说明源文本被修改过。


数字签名

数字签名 命令 操作系统支持：Windows、Linux 所属类别：数据完整性校验

使用RSA非对称密钥算法对指定字节集数据进行签署，支持32到4096之间任意合法的RSA位数，返回签署后的结果文本。 附一、电子签名系统简要实现方法： 首先给所有具有签署权利的人员授予不同的RSA钥匙，RSA钥匙由“公钥”、“私钥”、“公共模数”三部分组成，为了生成符合要求的随机密钥，可以下载使用 http://dywt.com.cn/RSATool2v14.rar 第三方工具软件（内有操作说明）。然后将所有人员的“公钥”和“公共模数”成对向外公布，“私钥”由被授予人员自行妥善保管。 被授权人员使用“私钥”和“公共模数”对指定数据进行签署，然后将签署后的结果文本随同被签署数据一起发送，接收者收到后，使用该签署者公开的“公钥”和“公共模数”及签署结果文本对被签署数据进行验证，如验证通过则说明该数据必定是此签署者所认可的，且没有经过任何篡改。 附二、数字签名用作软件注册系统的实现步骤： 1、欲注册用户提供注册信息（如硬件代码、用户姓名等）； 2、软件作者使用自己的私钥对该注册信息进行数字签署得到签署结果文本； 3、将此签署结果文本作为注册钥匙文件发送给用户； 4、在用户端的软件使用相同的用户信息、注册钥匙文件及软件作者的公钥进行签名验证，如果通过表明已经注册，否则表示未注册。使用本方法在私钥未泄露的前提下，可以绝对避免破解者做出软件的注册机。

语法： 文本型 数字签名 （待签署字节集数据，签署者私钥文本，签署者公共模数）

参数名 | 描 述
待签署字节集数据 | 必需的；字节集。
签署者私钥文本 | 必需的；文本型。为十六进制数值文本。
签署者公共模数 | 必需的；文本型。为十六进制数值文本。

例程：

说明：

获得签名结果。

参见： 例程1


签名验证

签名验证 命令 操作系统支持：Windows、Linux 所属类别：数据完整性校验

使用指定公钥和签署结果文本对被签署字节集数据进行验证，如验证通过则说明该字节集数据必定是此公钥拥有者（即签署者）所认可的，且签署后未经任何篡改。验证通过返回真，否则返回假。

语法： 逻辑型 签名验证 （待验证被签署字节集，签署结果文本，签署者公钥文本，签署者公共模数）

参数名 | 描 述
待验证被签署字节集 | 必需的；字节集。
签署结果文本 | 必需的；文本型。必须为“数字签名”命令所返回的结果。
签署者公钥文本 | 必需的；文本型。为十六进制数值文本。
签署者公共模数 | 必需的；文本型。为十六进制数值文本。

例程：

说明：

根据签名的有效性，显示不同信息。


数据加解密

数据加解密 类别 跳至：数据操作支持库一


加密数据

加密数据 命令 操作系统支持：Windows、Linux 所属类别：数据加解密

使用DES算法加密一段字节集数据，返回加密后的结果字节集。如果失败，返回空字节集。

语法： 字节集 加密数据 （字节集数据，密码文本，［加密算法］）

参数名 | 描 述
字节集数据 | 必需的；字节集。为命令提供所需的字节集数据。
密码文本 | 必需的；文本型。
加密算法 | 可选的；整数型。指定具体使用的加密算法，可以为以下常量值之一：1: #DES算法； 2: #RC4算法。加密和解密必须使用相同的算法，有关算法的具体说明请参阅有关文献。如果本参数被省略，则默认值为1，即DES算法。

例程

说明

文本框中的数据，用加密数据返回字节数据中。


解密数据

解密数据 命令 操作系统支持：Windows、Linux 所属类别：数据加解密

解密一段使用DES算法加密的字节集数据，返回解密后的结果字节集。注意本命令并不对密码文本进行校验，如果密码提供错误，将返回错误的结果。如果失败，返回空字节集。

语法： 字节集 解密数据 （字节集数据，密码文本，［加密算法］）

参数名 | 描 述
字节集数据 | 必需的；字节集。为命令提供所需的字节集数据。
密码文本 | 必需的；文本型。
加密算法 | 可选的；整数型。指定具体使用的加密算法，可以为以下常量值之一：1: #DES算法； 2: #RC4算法。加密和解密必须使用相同的算法，有关算法的具体说明请参阅有关文献。如果本参数被省略，则默认值为1，即DES算法。

例程

说明

解密数据后的数据是字节，把它们转换为文本格式放入文本框中。


数据操作支持库一 - 常量表

常量 | 常量值 | 描 述
#DES算法 | 1 |
#RC4算法 | 2 |