数据库操作支持库

数据库操作支持库 帮助手册20080814版 返回支持库手册 返回首页

本支持库用来访问各种类型数据库。由于本库是架构在ADO基础上的，因此请确保您的系统或者程序使用的系统装有ADO 2.10.3711.9或以上版本。当前最新版本是MDAC_TYP2.8，其中包括了ADO，如果需要，可到微软网站上下载（下载参考地址：http://www.microsoft.com/downloads/details.aspx?displaylang=zh-cn&FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c）。

操作系统支持： Windows

窗口组件数据类型：

数据库连接

记录集

常量表

例程名称 | 下载 | 说明
球员管理 | 球员管理.e 球员数据库.mdb | 本程序用作演示ADO数据库操作支持库的使用方法。

适用版本，数据库操作支持库 （1.6#0版）


数据库连接

数据库连接 功能型窗口组件 操作系统支持：Windows 跳至：数据库操作支持库

本类型用来打开大多数数据库，起到数据库连接的作用。连接后，使用"数据库操作"类型来操作数据库表。

属性：

最后错误

是否已连接

对象提供者

引擎版本

方法：

连接 | 连接Access | 连接SQLServer | 关闭
执行SQL | 取得权限 | 设置权限 | 设超时时间
取超时时间 | 开始事务 | 保存事务 | 回滚事务


最后错误 属性 所属对象：数据库连接 操作系统支持：Windows

数据类型：文本型；只读；获取最后错误文本。

例程

说明

如果在对数据库操作时出错，错误信息会保存在本属性中。

参考：例程1 下载数据库


是否已连接 属性 所属对象：数据库连接 操作系统支持：Windows

数据类型：逻辑型；只读；是否已经连接。

例程

说明

通过该属性可以得知是否与数据库相连，已连接本属性为真，否则为假。


对象提供者 属性 所属对象：数据库连接 操作系统支持：Windows

数据类型：文本型；只读；对象提供者名称。

例程

说明

本属性用于查看提供连接服务的ODBC对象名。


引擎版本 属性 所属对象：数据库连接 操作系统支持：Windows

数据类型：文本型；只读；数据引擎版本。

例程

说明

本属性用于取得所连接的数据库的引擎版本。


连接 方法 操作系统支持：Windows 所属对象：数据库连接

连接到数据源，如果连接成功返回"真"，失败返回"假"。

语法： 逻辑型 数据库连接．连接 （连接文本）

参数名 | 描 述
连接文本 | 必需的；文本型。本参数提供连接时使用的连接文本。

例程

说明

通过“连接”命令连接数据源。


连接Access 方法 操作系统支持：Windows 所属对象：数据库连接

连接Access数据库，如果连接成功返回"真"，失败返回"假"。

语法： 逻辑型 数据库连接．连接Access （文件名，密码）

参数名 | 描 述
文件名 | 必需的；文本型。本参数提供Access数据库文件的完整路径名。
密码 | 必需的；文本型，初始值为“”。本参数提供Access数据库的访问密码。可以为空，若为空，表示Access数据库没有密码。

例程

说明

通过“连接Access”命令连接已存在的Access 数据库。


连接SQLServer 方法 操作系统支持：Windows 所属对象：数据库连接

连接SQL Server数据库，如果连接成功返回"真"，失败返回"假"。

语法： 逻辑型 数据库连接．连接SQLServer （服务器名，数据库名，用户名，密码）

参数名 | 描 述
服务器名 | 必需的；文本型。本参数提供 SQL SERVER 服务器名。
数据库名 | 必需的；文本型。
用户名 | 必需的；文本型。
密码 | 必需的；文本型。

例程

说明

通过“连接SQLServer”命令连接SQLServer服务器。

参考：例程1 下载SQLServer数据库备份文件


关闭 方法 操作系统支持：Windows 所属对象：数据库连接

断开当前数据库连接，成功返回"真"，失败返回"假"。

语法： 逻辑型 数据库连接．关闭 （）

例程

说明

通过“关闭”命令断开与数据库的连接。如果对数据库操作完毕时必须使用此命令来断开连接，否则与数据库的连接仍将持续一段时间，这样会造成服务器额外的负担。


执行SQL 方法 操作系统支持：Windows 所属对象：数据库连接

执行指定的查询、SQL 语句、存储过程等，执行成功返回真，否则返回假。

语法： 逻辑型 数据库连接．执行SQL （SQL语句）

参数名 | 描 述
SQL语句 | 必需的；文本型。本参数提供要执行的SQL语句。有关SQL语句的具体内容请参看SQL的专业手册。

例程

说明

通过“执行SQL”命令来使用SQL语句对已连接的数据库进行操作。


连接Access 方法 操作系统支持：Windows 所属对象：数据库连接

取得权限 方法 操作系统支持：Windows 所属对象：数据库连接

取得访问及相关权限，并返回一个整数代表用户连接当前的权限。该整数为以下常量值之一或之和：0、#未知权限； 1、#只读权限； 2、#只写权限； 3、#读写权限； 4、#独占读权限； 8、#独占写权限； 12、#独占权限；16、#共享权限。

语法： 整数型 数据库连接．取得权限（）

例程

说明

通过“取得权限”命令获取已连接的数据库里您所拥有的权限。


连接Access 方法 操作系统支持：Windows 所属对象：数据库连接

设置权限 方法 操作系统支持：Windows 所属对象：数据库连接

设置访问及相关权限，并返回一个逻辑型值，如果设置成功，即返回真，如果设置不成功，即返回假。

语法： 逻辑型 数据库连接．设置权限 （要设置的模式）

参数名 | 描 述
要设置的模式 | 必需的；整数型。要设置的模式为以下常量值之一或之和：0、#未知权限； 1、#只读权限； 2、#只写权限； 3、#读写权限； 4、#独占读权限； 8、#独占写权限； 12、#独占权限；16、#共享权限。

例程

说明

通过“取得权限”命令获取已连接的数据库里您所拥有的权限。


设超时时间 方法 操作系统支持：Windows 所属对象：数据库连接

设置超时时间，以毫秒为单位，1000毫秒为1秒钟，若时间超出，会取消相关命令，并弹出信息提示框。

语法： 逻辑型 数据库连接．设超时时间 （要设置的时间）

参数名 | 描 述
要设置的时间 | 必需的；整数型。本参数指定准备设置的时间（毫秒）。

例程

说明

通过“设超时时间”来设置连接数据库的超时时间。


取超时时间 方法 操作系统支持：Windows 所属对象：数据库连接

取得连接超时时间，以毫秒为单位，1000毫秒为1秒钟。

语法： 整数型 数据库连接．取超时时间 （）

例程

说明

通过“取超时时间”命令取出连接数据库的超时时间。


开始事务 方法 操作系统支持：Windows 所属对象：数据库连接

开始新事务，返回一个整数型值，该数值表示当前事务嵌套的层数，譬如如果返回1，则表明为顶层事务。

语法： 整数型 数据库连接．开始事务 （）

例程

说明

通过“开始事务”命令开始事务并记录一个事务还原点。


保存事务 方法 操作系统支持：Windows 所属对象：数据库连接

保存任何更改并结束当前事务，返回一个逻辑值，如果保存事务成功返回真，否则返回假。

语法： 逻辑型 数据库连接．保存事务 （）

例程

说明

通过“保存事务”来保存一个新的事务还原点。


回滚事务 方法 操作系统支持：Windows 所属对象：数据库连接

取消当前事务中所作的任何更改并结束事务，返回一个逻辑值，如果操作成功返回真，否则返回假。

语法： 逻辑型 数据库连接．回滚事务 （）

例程

说明

通过“回滚事务”命令回滚到前次保存事务的还原点时状态。其实就是将上次还原点到当前所做的操作取消。注意，有时数据库会自动记录事务还原点。


记录集

记录集 功能型窗口组件 操作系统支持：Windows 跳至：数据库操作支持库

本类型用来打开并操作记录集，与"数据库连接"对象配合使用。

属性：

是否已打开 | 操作状态 | 记录数量 | 字段数量
首记录前 | 尾记录后 | 当前位置 |

方法：

置连接 | 取连接 | 打开 | 打开并排序
打开并过滤 | 关闭 | 添加 | 更新
删除 | 写文本 | 写双精度 | 写单精度
写整数 | 写逻辑值 | 写日期时间 | 写字节集
读文本 | 读双精度 | 读单精度 | 读整数
读逻辑值 | 读日期时间 | 读字节集 | 保存到XML
保存到ADTG | 到首记录 | 到尾记录 | 到下一条
到前一条 | 移到 | 取字段名 | 取字段属性
取字段定义长度 | 取字段实际长度 | 取字段类型 | 字段是否为空
查找 | 查找下一个 | 过滤记录 |


是否已打开 属性 所属对象：记录集 操作系统支持：Windows

数据类型：逻辑型；只读；判断是否已经打开。

例程

说明

本属性用来判断是否已经打开了数据表，或是否成功打开数据表。


操作状态 属性 所属对象：记录集 操作系统支持：Windows

数据类型：整数型；只读；取得当前操作状态，更新成功。

例程

说明

本属性用与获取记录集的操作状态。


记录数量 属性 所属对象：记录集 操作系统支持：Windows

数据类型：整数型；只读；取得记录的数量。

例程

说明

本属性用于获取已连接数据库已打开的表的记录数量。


字段数量 属性 所属对象：记录集 操作系统支持：Windows

数据类型：整数型；只读；取得字段的数量。

例程

说明

通过本属性可获得已连接的表中的字段数量。


首记录前 属性 所属对象：记录集 操作系统支持：Windows

数据类型：逻辑型；只读；判断当前记录指针是否已在首记录前。

例程

说明

本属性用于判断当前记录集指针是否在第一个记录前。


尾记录后 属性 所属对象：记录集 操作系统支持：Windows

数据类型：逻辑型；只读；判断当前记录指针是否已在记录尾后。

例程

说明

本属性用于判断当前记录集指针是否在尾记录后。


当前位置 属性 所属对象：记录集 操作系统支持：Windows

数据类型：整数型；只读；当前记录在记录集中的位置,0为第一条记录。

例程

说明

本属性用于获取当前记录集指针位置。


置连接 方法 操作系统支持：Windows 所属对象：记录集

设置数据库连接。

语法： 逻辑型 记录集．置连接 （连接）

参数名 | 描 述
连接 | 必需的；数据库连接。本参数提供要设置的数据库连接对象。

例程

说明

通过“置连接”命令，将记录集与数据库连接相连。


取连接 方法 操作系统支持：Windows 所属对象：记录集

取得数据库连接。

语法： 数据库连接 记录集．取连接 （）

例程

说明

通过“取连接”命令来取得记录集已连接的数据库连接。


打开 方法 操作系统支持：Windows 所属对象：记录集

打开数据库表，用于具体指定是操作哪一个表，返回一个逻辑值，如果打开表成功返回真，否则返回假。必须使用数据库连接组件先进行数据库连接，再用“置连接”方法连接到本对象，最后才能打开表。

语法： 逻辑型 记录集．打开 （命令文本，命令类型）

参数名 | 描 述
命令文本 | 必需的；文本型。本参数可以提供数据库中的某一个数据表名或SQL语句。
命令类型 | 必需的；整数型。本参数提供指定命令文本的类型，可以为以下常量或数值之一：1、#SQL语句； 2、#数据表名。

例程

说明

通过“打开”命令来打开已连接数据库中的数据表。


打开并排序 方法 操作系统支持：Windows 所属对象：记录集

打开数据表，并且以指定条件排序。返回一个逻辑型值，如果排序成功返回真，否则返回假。

语法： 逻辑型 记录集．打开并排序 （表名，排序条件）

参数名 | 描 述
表名 | 必需的；文本型。本参数提供数据库表的名称。
排序条件 | 必需的；文本型。本参数指定排序条件，ASC为升序，DESC为降序例如让学生姓名字段按照升序排，成绩字段按照降序排，那排序条件可以为 "学生姓名 ASC,成绩 DESC"。

例程

说明

通过“打开并排序”命令来打开一个数据表并将它排序。

注意：如果在打开之前曾经打开过其他表并使用过过滤记录命令，或使用过打开并过滤命令，请再次使用过滤记录并将过滤记录的参数留空（“”）已清除过滤条件，或使用打开并过滤命令将过滤条件设空（“”），否则将打开失败。


打开并过滤 方法 操作系统支持：Windows 所属对象：记录集

用指定过滤条件打开一个表。

语法： 逻辑型 记录集．打开并过滤 （表名，过滤条件）

参数名 | 描 述
表名 | 必需的；文本型。数据库表名。
过滤条件 | 必需的；文本型。过滤的条件，例如："文本字段 = 'abc' and 整数字段 > 1"。

例程

说明

通过“打开并过滤”命令打开已连接数据库中的指定表，并按照指定条件过滤。


关闭 方法 操作系统支持：Windows 所属对象：记录集

关闭当前打开的数据库表，打开一个数据表并使用后必须进行关闭操作。

语法： 无返回值 记录集．关闭 （）

例程

说明

通过“关闭”命令关闭已打开的数据表，要想再次对数据表进行操作，请再次使用打开等命令。


添加 方法 操作系统支持：Windows 所属对象：记录集

添加一个新的空记录，返回一个逻辑值。如果添加成功返回真，否则返回假。

语法： 逻辑型 记录集．添加 （）

例程

说明

通过“添加”命令向已打开的数据表中添加一条空记录。


更新 方法 操作系统支持：Windows 所属对象：记录集

更新记录，刷新显示，返回一个逻辑值。如果更新成功返回真，否则返回假。

语法： 逻辑型 记录集．更新 （）

例程

说明

通过“更新”命令来确认对数据库所做的更改，使用这一命令后事务记录点也将被更新到当前状态。


删除 方法 操作系统支持：Windows 所属对象：记录集

删除记录，返回一个逻辑值。如果删除成功返回真，否则返回假，选项可为删除当前记录，或全部记录。

语法： 逻辑型 记录集．删除 （删除选项）

参数名 | 描 述
删除选项 | 必需的；整数型。本参数为以下常量或数值之一：1、删除当前记录； 3、删除全部记录。

例程

说明

通过“删除”命令删除已打开的数据表中的指定数据。


写文本 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入文本。返回一个逻辑型值，如果写成功返回真，否则返回假。

语法： 逻辑型 记录集．写文本 （序号或字段名，文本）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
文本 | 必需的；文本型。本参数提供所要写入的文本。

例程

说明

通过“写文本”命令将文本写入已打开的数据表的当前记录指定文本类型字段。


写双精度 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入双精度值。返回一个逻辑型值，如果写成功返回真，否则返回假。

语法： 逻辑型 记录集．写双精度 （序号或字段名，双精度）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
双精度 | 必需的；双精度小数型。本参数提供要写入的双精度小数值。

例程

说明

通过“写双精度”命令将双精度小数写入已打开的数据表中当前记录的双精度类型的字段。


写单精度 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入单精度值。返回一个逻辑型值，如果写成功返回真，否则返回假。

语法： 逻辑型 记录集．写单精度 （序号或字段名，单精度）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
单精度 | 必需的；小数型。本参数提供要写入的单精度小数值。

例程

说明

通过“写单精度”命令将单精度小数写入已打开的数据表中当前记录的单精度小数类型的字段中。


写整数 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入整型值。返回一个逻辑型值，如果写成功返回真，否则返回假。

语法： 逻辑型 记录集．写整数 （序号或字段名，整型）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
整型 | 必需的；整数型。本参数提供要写入的整型值。

例程

说明

通过“写整数”命令将整数数据写入已打开的数据表中的当前记录的整数字段。


写逻辑值 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入逻辑型数据。返回一个逻辑型值，如果写成功返回真，否则返回假。

语法： 逻辑型 记录集．写逻辑值 （序号或字段名，逻辑）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
逻辑 | 必需的；逻辑型。本参数提供要写入的逻辑型值。

例程

说明

通过“写逻辑值”命令将逻辑值写入已打开的数据表的当前记录的逻辑字段中。


写日期时间 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入日期型数据。返回一个逻辑型值，如果写入成功返回真，否则返回假。

语法： 逻辑型 记录集．写日期时间 （序号或字段名，日期时间，日期时间类型）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
日期时间 | 必需的；日期时间型。本参数提供要写入的日期型数据。
日期时间类型 | 必需的；整数型，初始值为“0”。本参数提供要写入的日期时间型数据的类型，为以下常量值之一：0、#日期时间型；1、#日期型；2、#时间型。注意：如果该值不为以上常量那么将使用#日期时间型。

例程

说明

通过“写日期时间”命令将日期时间型数据写入已打开数据表的当前记录的日期时间型字段。

参见：例程1 下载数据库


重装入位图 方法 操作系统支持：Windows 所属对象：页面

写字节集 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名写入字节集数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．写字节集 （序号或字段名， 数据）

参数名 | 描 述
序号或字段名 | 必需的； 通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
数据 | 必需的； 字节集。本参数将写入读取的数据。

例程:

说明:

使用“记录集”对象的“写字节集”命令，将图片框中的图片写入数据库。

参见:例程


读文本 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取文本数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．读文本 （序号或字段名，文本变量）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
文本变量 | 必需的；文本型，参数数据只能提供变量。本参数提供要读取到的文本变量。

例程

说明

通过“读文本”命令将已打开数据表中的当前记录的文本型字段的内容读入到文本型变量中。


读双精度 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取双精度数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．读双精度 （序号或字段名，双精度变量）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
双精度变量 | 必需的；双精度小数型，参数数据只能提供变量。本参数提供要读取到的双精度变量。

例程

说明

通过“读双精度”命令将已打开的数据表中当前记录的双精度字段读入双精度型变量中。


读单精度 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取单精度数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．读单精度 （序号或字段名，单精度变量）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
单精度变量 | 必需的；小数型，参数数据只能提供变量。本参数提供要读取到的单精度变量。

例程

说明

通过“读单精度”命令将已打开数据表中当前记录的单精度字段中的内容读入单精度小数型变量。


读整数 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取长整型数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．读整数 （序号或字段名，整型变量）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
整型变量 | 必需的；整数型，参数数据只能提供变量。本参数提供要读取到的整型变量。

例程

说明

通过“读整数”命令将已打开数据表中当前记录的整数字段内容读入整数型变量中。


读逻辑值 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取逻辑型数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．读逻辑值 （序号或字段名，逻辑变量）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
逻辑变量 | 必需的；逻辑型，参数数据只能提供变量。本参数提供要读取到的逻辑变量。

例程

说明

通过“读逻辑值”命令将已打开的数据表中当前记录的逻辑型字段中的内容读入逻辑型变量中。


读日期时间 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取日期数据到变量中。返回一个逻辑型值，如果读出成功返回真，否则返回假。

语法： 逻辑型 记录集．读日期时间 （序号或字段名，日期变量）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
日期变量 | 必需的；日期时间型，参数数据只能提供变量。本参数提供要读取到的日期变量。

例程

说明

通过“写日期时间”命令将日期时间型数据写入已打开数据表的当前记录的日期时间型字段。


读字节集 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名读取字节集数据到变量中。返回一个逻辑型值，如果读成功返回真，否则返回假。

语法： 逻辑型 记录集．读字节集 （序号或字段名， 数据）

参数名 | 描 述
序号或字段名 | 必需的； 通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。
数据 | 必需的； 字节集，参数数据只能提供变量。本参数提供要读入的数据。

例程:

说明:

通过“记录集”对象的“读字节集”命令，将数据库中的字节集数据读出，并显示在图片框中。

参见:例程


保存到XML 方法 操作系统支持：Windows 所属对象：记录集

将数据库表保存到XML文本文件，以作为交换通用数据表，返回一个逻辑值，如果保存XML文件成功返回真，否则返回假。

语法： 逻辑型 记录集．保存到XML （XML文件名）

参数名 | 描 述
XML文件名 | 必需的；文本型。本参数提供要写出到的XML文件名。

例程

说明

通过“保存到XML”命令可以将已打开的数据表汇总所有内容和结构保存为XML格式。


保存到ADTG 方法 操作系统支持：Windows 所属对象：记录集

将数据库表用专用的"Advanced Data Tablegram"格式保存。返回一个逻辑值，如果保存ADTG文件成功返回真，否则返回假。

语法： 逻辑型 记录集．保存到ADTG （ADTG文件名）

参数名 | 描 述
ADTG文件名 | 必需的；文本型。本参数提供要写出到的ADTG文件名。

例程

说明

通过“保存ADTG”命令将已打开数据表中所有内容和结构保存为ADTG文件。


到首记录 方法 操作系统支持：Windows 所属对象：记录集

移动到表的第一条记录，返回一个逻辑值，如果移动成功返回真，否则返回假。操作本命令之前要确保数据库及表打开。

语法： 逻辑型 记录集．到首记录 （）

例程

说明

通过“到首记录” 命令将已打开数据表的记录指针移到第一个位置。


到尾记录 方法 操作系统支持：Windows 所属对象：记录集

移动到表的最后一条记录，返回一个逻辑值，如果移动成功返回真，否则返回假。操作本命令之前要确保数据库及表打开。

语法： 逻辑型 记录集．到尾记录 （）

例程

说明

通过“到尾记录”命令将已打开数据表的记录指针移到最后一条记录的位置。


到下一条 方法 操作系统支持：Windows 所属对象：记录集

移动到下一条记录，返回一个逻辑值，如果移动成功返回真，否则返回假。操作本命令之前要确保数据库及表打开。

语法： 逻辑型 记录集．到下一条 （）

例程

说明

通过“到下一条”命令将已打开数据表的记录指针向下移一条记录。


到前一条 方法 操作系统支持：Windows 所属对象：记录集

移动到前一条记录，返回一个逻辑值，如果移动成功返回真，否则返回假。操作本命令之前要确保数据库及表打开。

语法： 逻辑型 记录集．到前一条 （）

例程

说明

通过“到前一条”命令将已打开数据表的数据指针向前移一条记录。


移到 方法 操作系统支持：Windows 所属对象：记录集

移到指定记录。

语法： 逻辑型 记录集．移到 （目标记录号）

参数名 | 描 述
目标记录号 | 必需的；整数型。本参数提供目标记录号值，该值从 0 开始。

例程

说明

通过“移到”命令将已打开数据表的记录指针移到指定位置。


取字段名 方法 操作系统支持：Windows 所属对象：记录集

取得指定序号字段的名称，返回一个文本型值，为字段名称文本。

语法： 文本型 记录集．取字段名 （字段序号）

参数名 | 描 述
字段序号 | 必需的；整数型。本参数提供当前表中指定字段的序号值，从 0 开始。

例程

说明

通过“取字段名”命令取得指定字段的字段名。


取字段属性 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名取得字段属性，返回一个整数值。为以下常量值之一或之和： 2、#字段被延迟； 4、#字段可写入； 8、#写入无法确定； 16、#定长数据； 32、#允许空值； 64、#可以读空值； 128、#二进制类型； 256、#持久标识符； 512、#包含标记； 4096、#字段被缓存。

语法： 整数型 记录集．取字段属性 （序号或字段名）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。

例程

说明

通过“取字段属性”命令获取字段属性。


取字段定义长度 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名取得字段定义长度，本命令返回一个整数值。

语法： 整数型 记录集．取字段定义长度 （序号或字段名）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。

例程

说明

通过“取字段定义长度”命令取出指定字段最大数据长度。


取字段实际长度 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名取得字段实际长度，返回一个整数型值。

语法： 整数型 记录集．取字段实际长度 （序号或字段名）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。

例程

说明

通过“取字段实际长度”命令取出指定字段的实际长度。


取字段类型 方法 操作系统支持：Windows 所属对象：记录集

通过序号或字段名取得字段类型，返回以下常量值之一： 20、#超长整数字段； 128、#二进制字段； 11、#逻辑型字段； 8、#宽文本字段； 129、#字符型字段； 6、#货币型字段； 7、#日期型字段； 133、#数据库日期型字段； 134、#时间型字段； 135、#时间戳字段； 14、#数值型字段； 5、#双精度字段； 0、#空白型字段； 10、#错误码字段； 72、#标识型字段； 9、#IDispatch字段； 3、#整数型字段； 13、#IUnknown字段； 205、#超变长二进制字段； 201、#超变长文本字段； 203、#超变长宽文本字段； 131、#数字型字段； 4、#单精度字段； 2、#短整数字段； 16、#有符号字节字段； 21、#无符号超长整数字段； 19、#无符号整数字段； 18、#无符号短整数字段； 17、#字节型字段； 132、#自定义型字段； 204、#变长二进制字段； 200、#变长文本字段； 12、#变体型字段； 202、#变长宽文本字段； 130、#宽文本字段。

语法： 整数型 记录集．取字段类型 （序号或字段名）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。

例程

说明

通过“取字段类型”命令获得已打开数据表中指定字段的类型。


字段是否为空 方法 操作系统支持：Windows 所属对象：记录集

判断指定字段是否为空。返回一个逻辑型值，如果为空即为真，否则为假。

语法： 逻辑型 记录集．字段是否为空 （序号或字段名）

参数名 | 描 述
序号或字段名 | 必需的；通用型。本参数提供字段的序号或者字段名，只能为数值或文本型，序号值从 0 开始。

例程

说明

通过“字段是否为空”命令，可以判断指定字段是否为空。


查找 方法 操作系统支持：Windows 所属对象：记录集

查找满足条件的记录，返回一个逻辑型值，如果找到记录即返回真，并停留在满足条件的记录上，否则返回假。找到第一个满足条件的记录后，以后可以用"查找下一个"方法继续进行查找。

语法： 逻辑型 记录集．查找 （查找条件，查找方向）

参数名 | 描 述
查找条件 | 必需的；文本型。本参数提供在数据表中查找的条件。
查找方向 | 必需的；整数型。本参数指定在数据表中查找的方向。可以为以下数值或常量之一：1、正向搜索； 2、反向搜索。

例程

说明

通过“查找”命令来查找已打开数据表中符合条件的记录。


查找下一个 方法 操作系统支持：Windows 所属对象：记录集

查找下一个满足条件的记录。此命令用于"查找"命令之后使用，可继续按查找命令找到下一个满足条件的记录。返回一个逻辑型值，如果找到返回真，否则返回假。

语法： 逻辑型 记录集．查找下一个 （）

例程

说明

通过“查找下一个”命令查找满足条件的下一个记录。


过滤记录 方法 操作系统支持：Windows 所属对象：记录集

过滤出满足条件的记录，返回一个逻辑型值，如果过滤成功返回真，否则返回假。

语法： 逻辑型 记录集．过滤记录 （过滤条件）

参数名 | 描 述
过滤条件 | 必需的；文本型。本参数提供过滤的条件。

例程

说明

通过“过滤记录”命令将满足指定条件的记录取出。


常量 | 常量值 | 描 述
#未知权限 | 0 | 表明权限尚未设置或无法确定。
#只读权限 | 1 | 表明访问权限为只读。
#只写权限 | 2 | 表明访问权限为只写。
#读写权限 | 3 | 表明访问权限为读或写。
#独占读权限 | 4 | 防止其他用户使用读权限打开连接。
#独占写权限 | 8 | 防止其他用户使用写权限打开连接。
#独占权限 | 12 | 防止其他用户使用任何权限打开连接。
#共享权限 | 16 | 不拒绝其他任何用户使用任何权限打开连接。
#SQL语句 | 1 | 指示命令文本为普通的SQL语句。
#数据表名 | 2 | 指示命令文本为数据表名，系统将自动生成SQL语句查询返回该表中的所有行。
#删除当前记录 | 1 |
#删除全部记录 | 3 |
#字段被延迟 | 2 | 指示字段被延迟, 即不从拥有整个记录的数据源检索字段值, 仅在显式访问这些字段时才进行检索。
#字段可写入 | 4 | 指示可以写入该字段。
#写入无法确定 | 8 | 指示提供者无法确定是否可以写入该字段。
#定长数据 | 16 | 指示该字段包含定长数据。
#允许空值 | 32 | 指示该字段接受 Null 值。
#可以读空值 | 64 | 指示可以从该字段读取 Null 值。
#二进制类型 | 128 | 指示该字段为长二进制字段。例如: 可以保存图像文件。
#持久标识符 | 256 | 指示字段包含持久的行标识符, 该标识符无法被写入,并且除了对行进行标识(如记录号、唯一标识符等)外不存在有意义的值。
#包含标记 | 512 | 指示该字段包含用来跟踪更新的某种时间或日期标记。
#字段被缓存 | 4096 | 指示提供者缓存了字段值, 并已完成随后对缓存的读取。
#超长整数字段 | 20 | 8字节带符号的整数。
#二进制字段 | 128 | 二进制值。
#逻辑型字段 | 11 | 布尔型值。
#宽文本字段1 | 8 | 以零字符结尾的 Unicode 字符串。
#字符型字段 | 129 | 字符串值 (ASCII)。
#货币型字段 | 6 | 货币值.货币数字的小数点位置固定、小数点右侧有四位数字。该值保存为 8 字节范围为10,000 的带符号整型值。
#日期型字段 | 7 | 日期值。日期按双精度型数值来保存，数字全部表示从 1899 年 12 月 30 开始的日期数。小数部分是一天当中的片段时间。
#数据库日期型字段 | 133 | 日期值。日期按 yyyymmdd 的方式保存。
#时间型字段 | 134 | 时间值 (hhmmss)。
#时间戳字段 | 135 | 时间戳 (yyyymmddhhmmss 加 10 亿分之一的小数)。
#数值型字段 | 14 | 具有固定精度和范围的精确数值。
#双精度字段 | 5 | 双精度浮点值。
#空白型字段 | 0 | 未指定值。
#错误码字段 | 10 | 32位错误代码。
#标识型字段 | 72 | 全局唯一的标识符 (GUID)。
#IDispatch字段 | 9 | OLE 对象上 Idispatch 接口的指针。
#整数型字段 | 3 | 4 字节的带符号整型。
#IUnknown字段 | 13 | OLE 对象上 IUnknown 接口的指针。
#超变长二进制字段 | 205 | 超长的可变长度二进制值。
#超变长文本字段 | 201 | 超长的可变长度字符串值。
#超变长宽文本字段 | 203 | 宽字符的长字符串值。
#数字型字段 | 131 | 具有固定精度和范围的精确数字值。
#单精度字段 | 4 | 单精度浮点值。
#短整数字段 | 2 | 2 字节带符号整型。
#有符号字节字段 | 16 | 1 字节带符号整型。
#无符号超长整数字段 | 21 | 8 字节不带符号整型。
#无符号整数字段 | 19 | 4 字节不带符号整型。
#无符号短整数字段 | 18 | 2 字节不带符号整型。
#字节型字段 | 17 | 1字节不带符号整型。
#自定义型字段 | 132 | 用户自定义数据类型字段。
#变长二进制字段 | 204 |
#变长文本字段 | 200 |
#变体型字段 | 12 | 自动变体型。
#变长宽文本字段 | 202 | 以零字符结尾的可变长 Unicode 字符串。
#宽文本字段2 | 130 | 以零字符结尾的 Unicode 字符串。
#正向搜索 | 1 | 向前搜索。
#反向搜索 | -1 | 向后搜索。