EXCEL2000支持库

EXCEL2000支持库 帮助手册20080805版 返回支持库手册 返回首页

本库用来操作MS EXCEL 2000/XP/2003或以上版本,您的机器中必须装有Excel2000或以上版本 。

操作系统支持： Windows

窗口组件数据类型：

Excel程序

Excel工作簿

Excel图表

例程名称 | 下载 | 说明
EXCEL2000例程 | eExcel图表制作.e | 本程序演示了Excel图表制作的使用方法。

适用版本，EXCEL2000支持库 （1.0#7版）


Excel程序

Excel程序 功能型窗口组件 操作系统支持：Windows 跳至：EXCEL2000支持库

本对象用来创建并操作Excel程序。

属性：

左 | 顶 | 宽 | 高
标题 | 位置 | 显示 | 允许事件
版本 | 打印机 | 全屏显示 | 默认字体名
默认字体大小 | 显示比例 | 是否已创建 |

方法：

创建 | 释放 | 取程序对象 | 退出
激活窗口 | 模拟按键 |  |

自有事件：

工作簿打开 | 工作簿激活 | 工作簿取消激活 | 工作簿即将关闭
工作簿即将保存 | 工作簿即将打印 | 建新表格 | 表格激活
表格取消激活 |  |  |


内容 属性 数据类型：文本型；

左 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

本属性以磅为单位返回或设置Excel程序的左坐标。

语法： 对象.左 = 双精度小数型

应用对象：

Excel程序

例程

说明：

重新设置Excel程序窗口的位置和大小。

参见：例程


左 属性 所属对象：Excel程序 操作系统支持：Windows

顶 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

本属性以磅为单位返回或设置Excel程序的顶坐标。

语法： 对象.顶 = 双精度小数型

应用对象：

Excel程序

例程

说明：

重新设置Excel程序窗口的位置和大小。


顶 属性 所属对象：Excel程序 操作系统支持：Windows

宽 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

本属性以磅为单位返回或设置Excel程序的宽度。

语法： 对象.宽 = 双精度小数型

应用对象：

Excel程序

例程

说明：

重新设置Excel程序窗口的位置和大小。


宽 属性 所属对象：Excel程序 操作系统支持：Windows

高 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

本属性以磅为单位返回或设置Excel程序的高度。

语法： 对象.高 = 双精度小数型

应用对象：

Excel程序

例程

说明：

重新设置Excel程序窗口的位置和大小。


高 属性 所属对象：Excel程序 操作系统支持：Windows

标题 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：文本型；设计时不可用

本属性返回或设置Excel程序窗口的标题。

语法： 对象.标题 = 文本型

应用对象：

Excel程序

例程

说明：

设置Excel程序窗口的标题。


标题 属性 所属对象：Excel程序 操作系统支持：Windows

位置 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：整数型；设计时不可用

返回或者设置指定窗口的状态。该整数为以下常量值之一：-4137、#Excel窗口最大化；-4140、#Excel窗口最小化；-4143、#Excel窗口正常。

语法： 对象.位置 = 整数型

应用对象：

Excel程序

例程

说明：

设置Excel程序窗口的位置。


位置 属性 所属对象：Excel程序 操作系统支持：Windows

显示 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用

返回或者设置Excel程序窗口是否可见。

语法： 对象.显示 = 逻辑型

应用对象：

Excel程序

例程

说明：

设置Excel程序窗口的可见性。Excel程序被创建后，窗口是隐藏的。


显示 属性 所属对象：Excel程序 操作系统支持：Windows

允许事件 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用

返回或者设置Excel程序是否允许接收事件响应。

语法： 对象.允许事件 = 逻辑型

应用对象：

Excel程序

例程

说明：

允许Excel程序接收事件响应。


允许事件 属性 所属对象：Excel程序 操作系统支持：Windows

版本 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：文本型；只读

返回Excel程序当前版本。

语法： 对象.版本

应用对象：

Excel程序

例程

说明：

取得当前使用的Excel程序的版本号。


版本 属性 所属对象：Excel程序 操作系统支持：Windows

打印机 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置活动打印机的名称。

语法： 对象.打印机

应用对象：

Excel程序

例程

说明：

取得当前使用的Excel程序的打印机名称。不过在设置打印机名称的时候有可能出错。


打印机 属性 所属对象：Excel程序 操作系统支持：Windows

全屏显示 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用

返回或设置Excel程序是否是全屏显示模式。

语法： 对象.全屏显示 = 逻辑型

应用对象：

Excel程序

例程

说明：

如果当前使用的Excel程序是全屏显示的，就让其缩小显示；如果当前使用的Excel程序不是全屏显示的，就让其全屏显示。


全屏显示 属性 所属对象：Excel程序 操作系统支持：Windows

默认字体名 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置Excel程序默认字体名。

语法： 对象.默认字体名 = 文本型

应用对象：

Excel程序

例程

说明：

设置当前Excel程序使用的默认的字体名。


默认字体名 属性 所属对象：Excel程序 操作系统支持：Windows

默认字体大小 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：整数型；设计时不可用

返回或设置Excel程序默认字体大小。

语法： 对象.默认字体大小 = 整数型

应用对象：

Excel程序

例程

说明：

设置当前使用的Excel程序默认字体的大小。


默认字体大小 属性 所属对象：Excel程序 操作系统支持：Windows

显示比例 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：整数型；设计时不可用

以百分数的形式（100 表示正常大小，200 表示双倍大小，如此类推）返回或者设置窗口内容的显示大小。。

语法： 对象.显示比例 = 整数型

应用对象：

Excel程序

例程

说明：

显示Excel程序的表格内容与Excel程序窗口对比大小。必须要在表格或图表都设置完后再设置显示比例。


显示比例 属性 所属对象：Excel程序 操作系统支持：Windows

是否已创建 属性 所属对象：Excel程序 操作系统支持：Windows

数据类型：逻辑型；设计时不可用

返回Excel程序是否已被创建。

语法： 对象.是否已创建

应用对象：Excel程序

例程

说明：

判断Excel程序是否已经被创建。


创建 方法 操作系统支持：Windows 所属对象：Excel程序

创建Excel程序对象，本对象原有内容将被释放。成功返回真，否则返回假。

注意：在支持库的任何操作前，必须要先使用本方法创建。

语法： 逻辑型 Excel 程序．创建 （）

例程

说明：

创建一个新的Excel程序。Excel程序被创建后，程序窗口是隐藏的，可以显示出来。本子程序

在创建Excel程序后，让其显示出来，并且模拟按下“F1”键，打开Excel程序帮助窗口。


释放 方法 操作系统支持：Windows 所属对象：Excel程序

将当前正在使用的EXCEL程序对象释放。再次使用的时候需再次创建。

语法： 无返回值 Excel 程序．释放 （）

例程

说明：

一旦取得一个EXCEL程序的对象，在不再使用该对象的情况下，一定要释放

这个程序对象，否则将占用内存资源。


取程序对象 方法 操作系统支持：Windows 所属对象：Excel程序

获取Excel提供的Application对象，与3.7版的"对象"兼容，可交互操作。

语法： 对象 Excel 程序．取程序对象 （）

例程

说明：

获取Excel程序的对象。在不用的时候一定要清除。


退出 方法 操作系统支持：Windows 所属对象：Excel程序

退出Excel程序。

语法： 无返回值 Excel 程序．退出 （）

例程

说明：

退出EXCEL程序。


激活程序 方法 操作系统支持：Windows 所属对象：Excel程序

激活窗口 方法 操作系统支持：Windows 所属对象：Excel程序

激活Excel程序窗口。可能有时不起作用。本命令为初级对象成员命令。

语法： 无返回值 Excel 程序．激活窗口 （）

例程

说明：

创建Excel程序并显示出来，即激活了Excel程序窗口。


模拟按键 方法 操作系统支持：Windows 所属对象：Excel程序

将击键发送给活动的Excel程序。

语法： 无返回值 Excel 程序．模拟按键 （键值，等待）

参数名 | 描 述
键值 | 必需的；文本型。要发送的键或者组合键，以文本方式表示。参数可指定任何单个键或与 ALT、 CTRL 或 SHIFT 的组合键（或者这些键的组合）。每个键可用一个或多个字符表示。例如，"a" 表示字符 a，或者 "{ENTER}" 表示 ENTER 键。
等待 | 必需的；逻辑型，初始值为“假”。如果为 "真" 则 Microsoft Excel 等待击键处理完后再将控制返回到宏；如果为 "假"，或者省略该参数，则宏继续执行而无须等待击键处理完毕。

例程

说明：

在Excel程序下模拟按下“F1”键，打开Excel程序帮助。

将击键发送给活动的Excel程序。在非活动状态下无效。


工作簿打开 事件 所属对象：Excel程序 操作系统支持：Windows

当打开一个工作簿时产生此事件。

语法： 无返回值 _Excel 程序_工作簿打开 （工作簿对象）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。

例程

说明：

打开一个Excel文件，就触发此事件，运行此事件下的程序。


工作簿激活 事件 所属对象：Excel程序 操作系统支持：Windows

当激活任一工作簿时产生此事件。

语法： 无返回值 _Excel 程序_工作簿激活 （工作簿对象）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。

例程

说明：

激活一个工作簿，就触发此事件，运行此事件下程序。


工作簿取消激活 事件 所属对象：Excel程序 操作系统支持：Windows

当打开的工作簿由活动转为非活动状态时产生此事件。

语法： 无返回值 _Excel 程序_工作簿取消激活 （工作簿对象）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。

例程

说明：

将一个工作簿关闭，就触发此事件，运行此事件下的程序。


工作簿即将关闭 事件 所属对象：Excel程序 操作系统支持：Windows

当任一打开的工作簿要关闭时立即产生此事件。

语法： 无返回值 _Excel 程序_工作簿即将关闭 （工作簿对象，取消关闭）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。
取消关闭 | 逻辑型；传址；当事件产生时为假。如果该事件过程将本参数设为真，则该过程执行结束之后不关闭工作簿。

例程

说明：

关闭一个工作簿前，就触发此事件，运行此事件下的程序。当本子程序的参数“取消关闭”为真时，将不进行Excel工作簿的关闭操作。


工作簿即将保存 事件 所属对象：Excel程序 操作系统支持：Windows

在保存任一打开工作簿之前产生此事件。

语法： 无返回值 _Excel 程序_工作簿即将保存 （工作簿对象，另存为，取消）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。
另存为 | 逻辑型；如果显示“另存为”对话框则为真。
取消 | 逻辑型；传址；当事件产生时为假。如果该事件过程将本参数设为真，则该过程执行结束之后不保存工作簿。

例程

说明：

将当前工作簿保存在程序运行目录下，就触发此事件，运行此事件下程序。


工作簿即将打印 事件 所属对象：Excel程序 操作系统支持：Windows

在打印任一打开的工作簿之前产生此事件。

语法： 无返回值 _Excel 程序_工作簿即将打印 （工作簿对象，取消）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。
取消 | 逻辑型；传址；当事件产生时为假。如果该事件过程将本参数设为真，则该过程执行结束之后不打印工作簿。

例程

说明：

打印一个工作簿，就触发此事件，运行此事件下程序。当本子程序的参数“取消”为真时，就不进行打印操作。


建新表格 事件 所属对象：Excel程序 操作系统支持：Windows

在任何打开的工作簿中新建工作表时产生此事件。

语法： 无返回值 _Excel 程序_建新表格 （工作簿对象，表格对象）

参数名 | 描 述
工作簿对象 | 对象；提供Excel的Workbook对象，与3.7版的"对象"兼容。
表格对象 | 对象；提供Excel的Worksheet对象，与3.7版的"对象"兼容。

例程

说明：

在一个打开的工作簿中新建表格，就触发此事件，运行此事件下程序。新增加的表格位于当前所选择的表格的前面。


表格激活 事件 所属对象：Excel程序 操作系统支持：Windows

当激活任何一张表时产生此事件。

语法： 无返回值 _Excel 程序_表格激活 （表格对象）

参数名 | 描 述
表格对象 | 对象；提供Excel的Worksheet对象，与3.7版的"对象"兼容。

例程

说明：

激活一个表格，就触发此事件，运行此事件下程序。


表格取消激活 事件 所属对象：Excel程序 操作系统支持：Windows

当任一工作表由活动状态转为非活动状态时产生此事件。

语法： 无返回值 _Excel 程序_表格取消激活 （表格对象）

参数名 | 描 述
表格对象 | 对象；提供Excel的Worksheet对象，与3.7版的"对象"兼容。

例程

说明：

当一个表格被激活的同时，前一个表格就被取消了激活。


Excel工作簿

Excel工作簿 功能型窗口组件 操作系统支持：Windows 跳至：EXCEL2000支持库

本对象用来操作工作簿、行列等Excel中常见操作。

属性：

内容 | 内容格式 | 表格名 | 表格序号
表格数量 | 背景图 | 默认宽度 | 默认高度
首单元格 | 尾单元格 | 是否缩进 | 缩进量
水平对齐方式 | 垂直对齐方式 | 是否适应列宽 | 是否自动换行
阅读顺序 | 列宽 | 行高 | 字体
字体加粗 | 字体颜色 | 字体倾斜 | 字体名
字体阴影 | 字体大小 | 字体穿透线 | 字体下标
字体上标 | 字体下标线 |  |

方法：

置程序 | 释放 | 运行宏 | 取工作簿集对象
取工作簿对象 | 取表格集对象 | 取表格对象 | 取单元格对象
打开 | 关闭 | 保存 | 打印预览
打印 | 激活表格 | 激活工作簿 | 新增表格
删除表格 | 移动表格 | 添加图片 | 清空
合并 | 解除合并 | 选定 | 自动调整
置单元格边框 |  |  |


图表类型 属性 所属对象：Excel图表 操作系统支持：Windows

内容 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置当前单元格的内容。

语法： 对象. 内容 = 文本型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


内容格式 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置当前单元格内容的格式，具体格式请参见Excel程序。

语法： 对象. 内容格式 = 文本型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。内容格式“us$”是美国标准格式


表格名 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置当前选定的表格的名称。

语法： 对象.表格名 = 文本型

应用对象：

Excel工作簿

例程

说明：

取得表格的数量，依次给每个表格取一个名字。


表格名 属性 所属对象：Excel工作簿 操作系统支持：Windows

表格序号 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型：整数型；设计时不可用

返回或设置当前选定或待选定的表格的序号。

语法： 对象.表格序号 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。表格序号指定当前要选择第几个表格，表格序号从左到右依次排列。


表格数量 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型：整数型；只读

返回工作簿中表格的数量。

语法： 对象.表格数量

应用对象：

Excel工作簿

例程

说明：

取得表格的数量。如图：可以根据表格的数量依次设置表格名。


背景图 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 文本型；设计时不可用

设置背景图的图片文件名。

注意：该属性为只写属性

语法： 对象.背景图 = 文本型

应用对象：

Excel工作簿

例程

说明：

打开图片对话框浏览图片，设置表格的背景图。


默认宽度 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 双精度小数型；只读

返回指定工作表所有列的标准列宽（默认值）。

语法： 对象.默认宽度

应用对象：

Excel工作簿

例程

说明：

取得表格所有列的默认列宽。


默认高度 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 双精度小数型；只读

返回指定工作表所有行的标准列宽（默认值）。

语法： 对象.默认高度

应用对象：

Excel工作簿

例程

说明：

取得表格所有行的标准高宽。


首单元格 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 文本型；设计时不可用

返回或设置首单元格位置，例如"A1"，注意：如果要读、写或设置单元格必须先设置首单元格和尾单元格的位置，且首单元格必须在尾单元格前设置。

语法： 对象.首单元格 = 文本型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


尾单元格 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 文本型；设计时不可用

返回或设置尾单元格位置，例如"A1"，注意：如果要读、写或设置单元格必须先设置首单元格和尾单元格的位置，且首单元格必须在尾单元格前设置。

语法： 对象.尾单元格 = 文本型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


是否缩进 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格是否缩进。

语法： 对象.是否缩进 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

设置单元格缩进量，即单元格内容的前面空几个空格。


缩进量 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置单元格的缩进量，可为从 0 至 15 的整数。

语法： 对象.缩进量 = 整数型

应用对象：

Excel工作簿

例程

说明：

设置单元格的缩进量。


水平对齐方式 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置水平对齐方式，该整数为以下常量值之一：-4108、#水平居中；7、#水平跨列居中；-4117、#水平分散对齐；5、#水平填充 ；1、#水平常规对齐；-4130、#水平两端对齐；-4131 、#水平居左；-4152、#水平居右。

语法： 对象.水平对齐方式 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


垂直对齐方式 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置垂直对齐方式，该整数为以下常量值之一：-4107、#垂直靠下；-4108、#垂直居中；-4117、#垂直分散对齐；-4130、#垂直两端对齐；-4160、#垂直靠上。

语法： 对象.垂直对齐方式 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


是否适应列宽 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格是否自动适应列宽。

语法： 对象.是否适应列宽 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

设置单元格内容自动适应单元格宽度。


是否自动换行 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格是否自动换行。

语法： 对象.是否自动换行 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

如果单元格内容长度在大于单元格宽度时，单元格内容自动换行。


阅读顺序 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置单元格的阅读顺序，该整数为以下常量值之一：-5002、#按内容;-5003、#从左到右;-5004、#从右到左。

语法： 对象.阅读顺序 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


列宽 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置单元格列宽。

语法： 对象.列宽 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


行高 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置单元格行高。

语法： 对象.行高 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


字体 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型：整数型；只读；注意：该属性不可读写。


粗 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体加粗 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体是否为粗。

语法： 对象.字体加粗 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


颜色 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体颜色 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置单元格字体颜色。

语法： 对象.字体颜色 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


倾斜 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体倾斜 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体是否倾斜。

语法： 对象.字体倾斜 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


字体名 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 文本型；设计时不可用

返回或设置单元格字体名。

语法： 对象.字体名 = 文本型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


阴影 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体阴影 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体阴影。

语法： 对象.字体阴影 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。


大小 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体大小 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 整数型；设计时不可用

返回或设置单元格字体大小。

语法： 对象.字体大小 = 整数型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。设置单元格字体的大小。


穿透线 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体穿透线 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体是否使用穿透线。

语法： 对象.字体穿透线 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。设置单元格字体具有穿透线。


下标 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体下标 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体是否使用下标。

语法： 对象.字体下标 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

设置单元格字体使用下标。


上标 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体上标 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体是否使用上标。

语法： 对象.字体上标 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

将单元格“a1”到“k1”合并成一个单元格，设置里面的内容。设置单元格字体使用上标。


下标线 属性 所属对象：Excel工作簿 操作系统支持：Windows

字体下标线 属性 所属对象：Excel工作簿 操作系统支持：Windows

数据类型： 逻辑型；设计时不可用

返回或设置单元格字体是否使用下标线。

语法： 对象.字体下标线 = 逻辑型

应用对象：

Excel工作簿

例程

说明：

设置单元格字体使用下标线。


置程序 方法 操作系统支持：Windows 所属对象：Excel工作簿

设置Excel工作簿程序，在使用本对象前，一定要确保已经使用本方法设置了Excel工作簿程序。

语法： 逻辑型 Excel 工作簿．置程序 （Excel程序对象）

参数名 | 描 述
Excel程序对象 | 必需的；窗口。本参数提供要设置的Excel程序对象。

例程

说明：

设置Excel工作簿程序。


清除 方法 操作系统支持：Windows 所属对象：Excel工作簿

释放 方法 操作系统支持：Windows 所属对象：Excel工作簿

将本对象释放。再次使用的时候需再次使用"置程序"方法。

语法： 无返回值 Excel 工作簿．释放 （）

例程

说明：

释放Excel工作簿对象。当取得一个对象后，一定要释放，如果不释放，它就一直占据内存资源。


运行宏 方法 操作系统支持：Windows 所属对象：Excel工作簿

运行Excel文件中的“宏”指令。

语法： 逻辑型 Excel 工作簿．运行宏 （宏名，… ）

参数名 | 描 述
宏名 | 必需的；可扩充的；文本型。宏名。

例程

说明：

打开包含“宏”的Excel文件，再根据“宏”的名称运行“宏”。

如果对“宏”的概念不是很清楚，请查阅微软Excel中的帮助文件


取工作簿集对象 方法 操作系统支持：Windows 所属对象：Excel工作簿

获取Excel提供的Workbooks对象，与3.7版的"对象"兼容。

语法： 对象 Excel 工作簿．取工作簿集对象 （）

例程

说明：

获取Excel提供的工作簿集对象。取得的对象不用时一定要清除。


取工作簿对象 方法 操作系统支持：Windows 所属对象：Excel工作簿

获取Excel提供的Workbook对象，与3.7版的"对象"兼容。

语法： 对象 Excel 工作簿．取工作簿对象 （）

例程

说明：

获取Excel提供的工作簿对象。取得的对象不用时一定要清除。


取表格集对象 方法 操作系统支持：Windows 所属对象：Excel工作簿

获取Excel提供的Worksheets对象，与3.7版的"对象"兼容。

语法： 对象 Excel 工作簿．取表格集对象 （）

例程

说明：

获取Excel提供的表格集对象。取得的对象不用时一定要清除。


取表格对象 方法 操作系统支持：Windows 所属对象：Excel工作簿

获取Excel提供的Worksheet对象，与3.7版的"对象"兼容。

语法： 对象 Excel 工作簿．取表格对象 （）

例程

说明：

获取Excel提供的表格对象。取得的对象不用时一定要清除。


取单元格对象 方法 操作系统支持：Windows 所属对象：Excel工作簿

获取Excel提供的Range对象，与3.7版的"对象"兼容。

语法： 对象 Excel 工作簿．取单元格对象 （）

例程

说明：

获取Excel提供的单元格对象。取得的对象不用时一定要清除。


打开 方法 操作系统支持：Windows 所属对象：Excel工作簿

打开一个Excel2000支持打开的文件。

语法： 逻辑型 Excel 工作簿．打开 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。要打开的Excel文件名。

例程

说明：

浏览文件夹，打开一个Excel文件。


关闭 方法 操作系统支持：Windows 所属对象：Excel工作簿

关闭Excel文件中的一个工作簿。

语法： 无返回值 Excel 工作簿．关闭 （）

例程

说明：

Excel工作簿被关闭， Excel程序还在。


保存 方法 操作系统支持：Windows 所属对象：Excel工作簿

用一个新的文件名及默认格式来保存指定文档。

语法： 无返回值 Excel 工作簿．保存 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。要保存的Excel文件名。

例程

说明：

保存一个Excel文档。默认保存为XLS文件


打印预览 方法 操作系统支持：Windows 所属对象：Excel工作簿

以打印效果显示。

语法： 无返回值 Excel 工作簿．打印预览 （）

例程

说明：

在打印前用来查看打印效果。


打印 方法 操作系统支持：Windows 所属对象：Excel工作簿

打印当前文档。

语法： 无返回值 Excel 工作簿．打印 （开始页号，终止页号，打印份数，打印预览，活动打印机，输出文件，逐份打印，输出文件名）

参数名 | 描 述
开始页号 | 必需的；整数型，初始值为“-1”。打印的开始页号。
终止页号 | 必需的；整数型，初始值为“-1”。打印的终止页号。
打印份数 | 必需的；整数型，初始值为“1”。要打印的份数。
打印预览 | 必需的；逻辑型，初始值为“真”。如果为真则Microsoft Excel 打印指定对象之前进行打印预览。如果为假，或者省略此参数则立即打印该对象。
活动打印机 | 必需的；文本型，初始值为“”。设置活动打印机的名称。
输出文件 | 必需的；逻辑型，初始值为“假”。如果为真则打印输出到文件。如果没有指定输出文件名，则Microsoft Excel将提示用户输入要输出文件的文件名。
逐份打印 | 必需的；逻辑型，初始值为“假”。如果为真则逐份打印每份副本。
输出文件名 | 必需的；文本型，初始值为“”。如果将输出文件设置为 真，则本参数指定要打印到的文件名。

例程

说明：

打印一个Excel文件。要注意打印机的名字。


激活表格 方法 操作系统支持：Windows 所属对象：Excel工作簿

激活单个表格。

语法： 无返回值 Excel 工作簿．激活表格 （）

例程

说明：

激活当前选择的表格。


激活工作簿 方法 操作系统支持：Windows 所属对象：Excel工作簿

激活工作簿。有时不好用。

语法： 无返回值 Excel 工作簿．激活工作簿 （）

例程

说明：

在运行“宏”以后，激活当前工作簿。


新增表格 方法 操作系统支持：Windows 所属对象：Excel工作簿

添加新的表格。

语法： 无返回值 Excel 工作簿．新增表格 （）

例程

说明：

在当前所选择的第二个表格的前面添加新的表格。


删除表格 方法 操作系统支持：Windows 所属对象：Excel工作簿

删除当前的表格，对应表格序号。

语法： 无返回值 Excel 工作簿．删除表格 （）

例程

说明：

删除当前激活的表格。


移动表格 方法 操作系统支持：Windows 所属对象：Excel工作簿

将指明的表移到工作簿的另一位置。

语法： 无返回值 Excel 工作簿．移动表格 （表格序号）

参数名 | 描 述
表格序号 | 必需的；通用型，初始值为“38109040”。表格序号或名称。

例程

说明：

将当前所选择的表格移动到第二个位置上。


添加图片 方法 操作系统支持：Windows 所属对象：Excel工作簿

在已存在的文件中创建图片。

语法： 无返回值 Excel 工作簿．添加图片 （Filename，链接到文件，一起保存，左坐标，顶坐标，宽度，高度）

参数名 | 描 述
Filename | 必需的；文本型。要创建的 OLE 对象的源文件。
链接到文件 | 必需的；逻辑型，初始值为“假”。若指定为真，就建立图片与其源文件之间的链接。若指定为假，就使图片成为与其源文件的相互独立的复制品。
一起保存 | 必需的；逻辑型，初始值为“真”。若为真，则将链接图片和插入图片的文档一起保存；若为假，则只在文档中保存链接信息。如果链接到文件为假，则本参数必须为真。
左坐标 | 必需的；小数型。以磅为单位给出图片左坐标。
顶坐标 | 必需的；小数型。以磅为单位给出图片顶坐标。
宽度 | 必需的；小数型。以磅为单位给出图片的宽度。
高度 | 必需的；小数型。以磅为单位给出图片的高度。

例程

说明：

在当前的表格里添加图片，图片的位置，大小可以自己设定。


清空 方法 操作系统支持：Windows 所属对象：Excel工作簿

清空单元格。

语法： 无返回值 Excel 工作簿．清空 （）

例程

说明：

清空所选择的单元格的内容。


合并 方法 操作系统支持：Windows 所属对象：Excel工作簿

合并单元格。

语法： 无返回值 Excel 工作簿．合并 （）

例程

说明：

合并所选择的若干个单元格为一个单元格。


解除合并 方法 操作系统支持：Windows 所属对象：Excel工作簿

解除合并单元格。

语法： 无返回值 Excel 工作簿．解除合并 （）

例程

说明：

解除合并的单元格。


选定 方法 操作系统支持：Windows 所属对象：Excel工作簿

单元格选定。

语法： 无返回值 Excel 工作簿．选定 （）

例程

说明：

选定单元格。如果不设置选定，光标自动指向“a1，a1”的单元格。


自动调整 方法 操作系统支持：Windows 所属对象：Excel工作簿

单元格自动调整。

语法： 无返回值 Excel 工作簿．自动调整 （）

例程

说明：

自动调整所选择的单元格区域里各单元格的高度和宽度。


置单元格边框 方法 操作系统支持：Windows 所属对象：Excel工作簿

向单元格区域添加边框。

语法： 无返回值 Excel 工作簿．置单元格边框 （线条样式，边框粗细，RGB颜色）

参数名 | 描 述
线条样式 | 必需的；整数型，初始值为“1”。边框的线条样式。可为下列 XlLineStyle 常量之一：#连续线= 1, #划线= -4115, #点划线= 4, #点点划线= 5, #点线= -4118, #双线= -4119, #斜点划线= 13, #无样式= -4142。
边框粗细 | 必需的；整数型，初始值为“2”。边框的粗细。可为下列 XlBorderWeight 常量之一：#毛发= 1, #中等= -4138, #粗= 4, #细= 2。
RGB颜色 | 必需的；整数型，初始值为“0”。以 RGB 值指定边框的颜色。

例程

说明：

设置单元格区域边框的属性。


Excel图表

Excel图表 功能型窗口组件 操作系统支持：Windows 跳至：EXCEL2000支持库

本对象用来生成Excel中的图表。

属性：

图表类型 | 标题 | X轴标题 | Y轴标题
左 | 顶 | 宽 | 高
绘制方式 | Y轴首 | Y轴尾 | X轴首
X轴尾 |  |  |

方法：

置表格 | 释放 | 取图表对象 | 设置系列
添加 |  |  |


左 属性 所属对象：Excel程序 操作系统支持：Windows

图表类型 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：整数型；设计时不可用

返回或设置图表类型，为51~112的数字,具体请参见Excel开发文档的XlChartType 常量。这里列出一些常量供大家参考：

51、#簇状柱形图；52、#三维簇状柱形图；53、#百分比堆积柱形图；54、#三维堆积柱形图；55、#三维堆积柱形图；56、#三维百分比堆积柱形图；57、#簇状条形图；58、#堆积条形图；60、#三维簇状条形图；61、#三维堆积条形图；62、#三维百分比堆积条形图；63、#堆积折线图；64、#百分比堆积折线图；65、#数据点折线图；66、#堆积数据点折线图；67、#百分比堆积数据点折线图；68、#复合饼图；69、#分离型饼图；70、#三维分离型饼图；71、#复合柱饼图；72、#平滑线散点图；73、#无数据点平滑线散点图；74、#折线散点图；75、#无数据点折线散点图；76、#堆积面积图；77、#百分比堆积面积图；78、#三维堆积面积图；79、#三维百分比堆积面积图；80、#分离型圆环图；81、#数据点雷达图；82、#填充雷达图；92、#簇状柱形圆柱图；93、#堆积柱形圆柱图；94、#百分比堆积柱形圆柱图；95、#百分比堆积条形圆柱图；96、#堆积条形圆柱图；97、#百分比堆积条形圆柱图；98、#三维柱形圆柱图；99、#簇状柱形圆锥图；100、#堆积柱形圆锥图；101、#百分比堆积柱形圆锥图；102、#簇状条形圆锥图；103、#堆积条形圆锥图；104、#百分比堆积条形圆锥图；105、#三维柱形圆锥图；106、#簇状柱形棱锥图；107、#堆积柱形棱锥图；108、#百分比堆积柱形棱锥图；109、#堆积条形棱锥图；111、#百分比堆积条形棱锥图；112、#三维柱形棱锥图；-4100、#三维柱形图；4、#折线图；-4101、#xl3DLine；5、#饼图；-4169、#散点图；-4098、#三维面积图；1、#面积图；-4120、#圆环图；-4151、#雷达图；。

语法： 对象. 图表类型 = 整数型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表类型为簇状柱形图。


标题 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置图表标题。

语法： 对象.标题 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表的标题。


X轴标题 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置图表X轴标题。

语法： 对象. X轴标题 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表 X轴标题，用来表示X 轴上数值的含义。


Y轴标题 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置图表Y轴标题。

语法： 对象.Y轴标题 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表 Y轴标题，用来表示Y 轴上数值的含义。


左 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

返回或设置图表在表格中的左坐标。

语法： 对象. 左 = 双精度小数型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表的左边在表格中的坐标。


顶 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

返回或设置图表在表格中的顶坐标。

语法： 对象.顶 = 双精度小数型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表的顶边在表格中的坐标。


宽 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

返回或设置图表在表格中的宽度。

语法： 对象.宽 = 双精度小数型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表在表格中的宽度。


高 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：双精度小数型；设计时不可用

返回或设置图表在表格中的高度。

语法： 对象. 高 = 双精度小数型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表在表格中的高度。


绘制方式 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：整数型；设计时不可用

返回或设置图表的绘制方式，该整数为以下常量值之一：1、#按行绘制；2、#按列绘制；。

语法： 对象. 绘制方式 = 整数型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置图表的绘制方式。


Y轴首 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置Y轴首位置,例如："A1"。

语法： 对象. Y轴首 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置Y轴第一个设置的数值对应在表格中的位置。


Y轴尾 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置Y轴尾位置,例如："A1"。

语法： 对象. Y轴尾 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置Y轴最后一个设置的数值对应在表格中的位置。


X轴首 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置X轴首位置,例如："A1"。

语法： 对象. X轴首 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式

设置X轴第一个设置的数值对应在表格中的位置。


X轴尾 属性 所属对象：Excel图表 操作系统支持：Windows

数据类型：文本型；设计时不可用

返回或设置X轴尾位置,例如："A1"。

语法： 对象. X轴尾 = 文本型

应用对象：

Excel图表

例程

说明：

本子程序先设置Excel图表在表格中的位置，再设置图表上显示的数值，最后设置图表的标题和类型，以及绘制图表的方式。

设置X轴最后一个表示的数值对应在表格中的位置。


置表格 方法 操作系统支持：Windows 所属对象：Excel图表

设置表格，成功返回真，失败返回假，注意：在使用本对象的任何方法及属性前必须先使用本方法。

语法： 无返回值 Excel 图表．置表格 （工作簿）

参数名 | 描 述
工作簿 | 必需的；报表。本参数提供要设置的工作簿对象。

例程

说明：

在设置表格的图表程序前，必须要先创建Excel程序，再设置Excel工作簿（即表格的数值内容），最后才能设置图表。


清除 方法 操作系统支持：Windows 所属对象：Excel图表

释放 方法 操作系统支持：Windows 所属对象：Excel图表

将本对象释放。再次使用的时候需再次置程序。

语法： 无返回值 Excel 图表．释放 （）

例程

说明：

释放取得的图表对象。如果不释放，该对象将始终占据内存资源。


取图表对象 方法 操作系统支持：Windows 所属对象：Excel图表

获取Excel提供的Chart对象，与3.7版的"对象"兼容。

语法： 无返回值 Excel 图表．取图表对象 （）

例程

说明：

获取 Excel图表的对象，在不使用的情况下一定要清除。


设置系列 方法 操作系统支持：Windows 所属对象：Excel图表

设置一个系列的系列名和系列标志。

语法： 逻辑型 Excel 图表．设置系列 （系列ID，系列名，数据标签）

参数名 | 描 述
系列ID | 必需的；整数型。系列的标识。
系列名 | 必需的；文本型。系列的名称。
数据标签 | 必需的；整数型。数据的标签。

例程

说明：

根据表格中指定位置的数值，设置一系列图表的数据，在图表中显示出来。


添加 方法 操作系统支持：Windows 所属对象：Excel图表

在填写完一个图表的各属性后，用本方法来正式添加图表到表格中。

语法： 逻辑型 Excel 图表．添加 （）

例程

说明：

根据图表属性的设置，添加图表，显示图表的数据。