高级表格

高级表格 帮助手册20080731版 返回支持库手册 返回首页

本支持库实现了对高级表格的支持。

操作系统支持： Windows

窗口组件数据类型：

高级表格

其它数据类型：

表格常量

例程列表：

例程名称 | 下载 | 说明
表格例程 | 高级表格.e | 本例程演示了有关表格操作方面的基本内容,您可以将她进一步开发以获得更强的功能。

适用版本，高级表格支持库 （1.5#0版）


高级表格

高级表格 窗口组件 操作系统支持：Windows 跳至：高级表格支持库

提供对表格操作的支持。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
表格线颜色 | 背景颜色 | 文字颜色 | 点燃色
显示表格线 | 允许调整行高 | 允许调整列宽 | 行高
列宽 | 行数 | 列数 | 表头行数
表头列数 | 是否可编辑 | 显示打印对话框 | 允许选择块
显示打印按钮 | 表头背景颜色 | 打印页码 | 打印日期
回车键功能 | 表头可单击 | 选择整行 | 选择区背景
打印缩放至页宽 | 表格线宽度 | 选择区文字颜色 |

方法：

置光标 | 选择区域 | 全部选择 | 取光标行号
取光标列号 | 取选择起始行 | 取选择起始列 | 取选择终止行
取选择终止列 | 置数据 | 取数据 | 剪切选定文本
复制选定文本 | 粘贴 | 显示斑马线 | 取字体名
置字体名 | 取字体尺寸 | 置字体尺寸 | 取字体属性
置字体属性 | 取单元格文字颜色 | 置单元格文字颜色 | 取单元格背景颜色
置单元格背景颜色 | 置对齐方式 | 打印 | 打印预览
清空下拉列表 | 添加下拉列表内容 | 置列类型 | 置行高
置列宽 | 取行高 | 取列宽 | 置日期格式
置货币前缀 | 置图片显示方式 | 删除行 | 删除列
插入行 | 插入列 | 置计算公式 | 置单元格小数位数
置自动换行 | 插入下拉列表项 | 置打印表头 | 加线条
删线条 | 置边距 | 取边距 | 置密码方式
取密码方式 | 置只读方式 | 取只读方式 | 存到文件
从文件读 | 清空数据 | 合并 | 分解
打印到打印机 | 取列类型 | 清空单元格数据 | 取单元格行高
取单元格列宽 | 置打印页边距 | 置累加公式 | 取对齐方式
刷新单元格 | 删除累加公式 |  |

自有事件：

光标位置改变 | 将被编辑 | 结束编辑 | 行高被改变
列宽被改变 | 被单击 | 列表项被选择 |

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动
可否被编辑 |  |  |


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


表格线颜色 (高级表格)

表格线颜色 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得表格线的颜色。

参见:例程


背景颜色 (表格)

背景颜色 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的背景颜色。


文字颜色 (表格)

文字颜色 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的文本颜色。


点燃色 (表格)

点燃色 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；指定是焦点所在单元格文字颜色。

例程:

说明:

本属性可以设置或取得高级表格的点燃颜色。


显示表格线 (表格)

显示表格线 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；指定是否显示表格线。

可供选择的属性值：
0、不显示
1、横线
2、纵线
3、表格线

例程:

说明:

本属性可以设置或取得高级表格的表格线的类型。


允许调整行高 (表格)

允许调整行高 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定是否禁止操作者调整表格行高。

例程:

说明:

本属性可以设置或判断高级表格是否可以调整行高。


允许调整列宽 (表格)

允许调整列宽 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定是否禁止操作者调整表格列宽。

例程:

说明:

本属性可以设置或判断高级表格是否可以调整列宽。


行高 (表格)

行高 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的行的高度。


列宽 (表格)

列宽 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的列的宽度。


行数 (表格)

行数 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的行数。


列数 (表格)

列数 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的列数。


表头行数 (表格)

表头行数 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的表头的行数。


表头列数 (表格)

表头列数 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的表头的列数。


是否可编辑 (表格)

是否可编辑 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定操作者是否可编辑表格内容。

例程:

说明:

本属性可以设置或判断高级表格是否可以进行编辑操作。


显示打印对话框 (表格)

显示打印对话框 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定打印前是否显示打印对话框。

例程:

说明:

本属性可以设置或判断高级表格打印时是否显示打印对话框。


允许选择块 (表格)

允许选择块 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定是否可以选择多个单元格。

例程:

说明:

本属性可以设置或判断高级表格是否可以选择区域。


显示打印按钮 (表格)

显示打印按钮 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定打印预览时是否禁止打印按钮。

例程:

说明:

本属性可以设置或判断高级表格打印时是否显示打印按钮。


表头背景颜色 (表格)

表头背景颜色 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的表头背景颜色。


打印页码 (表格)

打印页码 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；指定是否打印页码及位置。

可供选择的属性值：
0、不打印
1、左部
2、中部
3、右部

例程:

说明:

本属性可以设置或判断高级表格是否打印页码。


打印日期 (表格)

打印日期 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；指定是否打印日期及位置。

可供选择的属性值：
0、不打印
1、左部
2、中部
3、右部

例程:

说明:

本属性可以设置或判断高级表格打印时是否打印日期。


回车键功能 (表格)

回车键功能 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；指定回车键的用途。

可供选择的属性值：
0、编辑切换
1、跳到下一列
2、跳到下一行

例程:

说明:

本属性可以设置或取得高级表格中回车键的用途。


表头可单击 (表格)

表头可单击 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定是否可以单击表头。

例程：

说明：

本属性可以设置或判断高级表格的表头是否可以被单击。

参见：例程


选择整行 (表格)

选择整行 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：逻辑型；指定单击单元格时是否选择整行。

例程：

说明：

本属性可以设置或判断高级表格是否可以整行选择。

参见：例程


选择区背景 (表格)

选择区背景 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性可以设置或取得高级表格选择区域的背景颜色。

参见：例程


打印缩放至页宽 属性 所属对象：表格 操作系统支持：Windows

打印缩放至页宽 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性可以设置或判断高级表格打印时是否缩放高级表格的大小。

参见：例程


表格线宽度 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

例程:

说明:

本属性可以设置或取得高级表格的表格线的宽度。


选择区文字颜色 (高级表格)

选择区文字颜色 属性 所属对象：高级表格 操作系统支持：Windows

数据类型：整数型；

  例程:

说明:

本属性可以设置或取得高级表格的选择区的文字颜色。


置光标 (表格)

置光标 方法 操作系统支持：Windows 所属对象：高级表格

将光标移动到指定的单元格上。

语法： 无返回值 高级表格．置光标 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

设置光标，将光标移到参数指定的行列。


选择区域 (高级表格)

选择区域 方法 操作系统支持：Windows 所属对象：高级表格

选择指定区域的单元格。

语法： 无返回值 高级表格．选择区域 （起始行，起始列，［终止行］，［终止列］）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。

例程:

说明:

“允许选择块”属性为真时，本方法才有效。


全部选择 (表格)

全部选择 方法 操作系统支持：Windows 所属对象：高级表格

选择所有单元格。

语法： 无返回值 高级表格．全部选择 （）

例程:

说明:

将表格中的单元格全部选中。


取光标行号 (表格)

取光标行号 方法 操作系统支持：Windows 所属对象：高级表格

返回当前光标所在单元格的行号，失败返回-1。

语法： 整数型 高级表格．取光标行号 （）

例程:

说明:

取得当前光标所在的行号。不论有无表头，光标行列号都从0开始。


取光标列号 (表格)

取光标列号 方法 操作系统支持：Windows 所属对象：高级表格

返回当前光标所在单元格的列号，失败返回-1。

语法： 整数型 高级表格．取光标列号 （）

例程:

说明:

取得当前光标所在的列号。不论有无表头，光标行列号都从0开始。


取选择起始行 (表格)

取选择起始行 方法 操作系统支持：Windows 所属对象：高级表格

被选择的区域起始于光标所在行。

语法： 整数型 高级表格．取选择起始行 （）

例程:

说明:

从整块被选择的单元格区域中，取出起始行的行号。


取选择起始列 (表格)

取选择起始列 方法 操作系统支持：Windows 所属对象：高级表格

被选择的区域起始于光标所在列。

语法： 整数型 高级表格．取选择起始列 （）

例程:

说明:

从整块被选择的单元格区域中，取出起始列的列号。


取选择终止行 (表格)

取选择终止行 方法 操作系统支持：Windows 所属对象：高级表格

被选择的区域终止于光标所在行。

语法： 整数型 高级表格．取选择终止行 （）

例程:

说明:

从整块被选择的单元格区域中，取出终止行的行号。


取选择终止列 (表格)

取选择终止列 方法 操作系统支持：Windows 所属对象：高级表格

被选择的区域终止于光标所在列。

语法： 整数型 高级表格．取选择终止列 （）

例程:

说明:

从整块被选择的单元格区域中，取出终止列的列号。


置数据 (表格)

置数据 方法 操作系统支持：Windows 所属对象：高级表格

设置指定单元格的值。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置数据 （行号，列号，数据类型，数据）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。
数据类型 | 必需的；整数型。指定要置入的数据类型，为以下常量值之一： 1: #表格常量.文本型； 5: #表格常量.选择型； 6: #表格常量.图片型；。
数据 | 必需的；通用型。要置入单元格的数据：如类型为图片型，则为字节集数据或图片文件名；如类型为选择型，则真为选中，假为取消选中。

例程:

说明:

设置指定单元格的数据。


取数据 (表格)

取数据 方法 操作系统支持：Windows 所属对象：高级表格

取得指定单元格的数据。单元格类型为图片型，返回字节集；单元格类型为选择型，选中返回真、未选中返回假；其它类型返回文本型。

语法： 通用型 高级表格．取数据 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取出某单元格的数据。


剪切选定文本 (表格)

剪切选定文本 方法 操作系统支持：Windows 所属对象：高级表格

将当前光标所在单元格的内容剪切到剪切板。

语法： 无返回值 高级表格．剪切选定文本 （）

例程:

说明:

剪切高级表格选定的文本。


复制选定文本 (表格)

复制选定文本 方法 操作系统支持：Windows 所属对象：高级表格

将当前光标所在单元格的内容复制到剪切板。

语法： 无返回值 高级表格．复制选定文本 （）

例程:

说明:

复制高级表格中的选定文本。


粘贴 (表格)

粘贴 方法 操作系统支持：Windows 所属对象：高级表格

将剪切板的内容粘贴到指定单元格。

语法： 无返回值 高级表格．粘贴 （）

例程:

说明:

向高级表格粘贴数据。


显示斑马线 (表格)

显示斑马线 方法 操作系统支持：Windows 所属对象：高级表格

用不同的颜色显示奇偶行或列。

语法： 无返回值 高级表格．显示斑马线 （行列，奇数行列颜色，偶数行列颜色）

参数名 | 描 述
行列 | 必需的；整数型。指定斑马线的类型，为以下常量值之一： 1: #表格常量.行斑马线； 2: #表格常量.列斑马线； 。
奇数行列颜色 | 必需的；整数型。奇数行或列的背景颜色。
偶数行列颜色 | 必需的；整数型。偶数行或列的背景颜色。

例程:

说明:

设置相邻行列之间的颜色显示。


取字体名 (表格)

取字体名 方法 操作系统支持：Windows 所属对象：高级表格

返回高级表格中指定单元格在显示时所使用字体的名称。失败返回空。

语法： 文本型 高级表格．取字体名 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得指定单元格中文本的字体名称。


置字体名 (表格)

置字体名 方法 操作系统支持：Windows 所属对象：高级表格

设置高级表格中指定区域在显示时所使用字体的名称。成功返回真、失败返回假。

语法： 逻辑型 高级表格．置字体名 （起始行，起始列，［终止行］，［终止列］，字体名）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
字体名 | 必需的；文本型。表格文字的显示字体。

例程:

说明:

设置指定区域中文本的字体名称。


取字体尺寸 (表格)

取字体尺寸 方法 操作系统支持：Windows 所属对象：高级表格

返回高级表格中指定单元格在显示时所使用字体的尺寸，单位为0.1毫米。失败返回 -1。

语法： 整数型 高级表格．取字体尺寸 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得指定单元格中字体的大小。


置字体尺寸 (表格)

置字体尺寸 方法 操作系统支持：Windows 所属对象：高级表格

设置高级表格中指定区域在显示时所使用字体的尺寸。成功返回真、失败返回假。

语法： 逻辑型 高级表格．置字体尺寸 （起始行，起始列，［终止行］，［终止列］，字体尺寸）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
字体尺寸 | 必需的；整数型。表格文字的显示尺寸。

例程:

说明:

设置指定区域中字体的大小。


取字体属性 (表格)

取字体属性 方法 操作系统支持：Windows 所属对象：高级表格

返回高级表格中指定单元格在显示时所使用字体的属性。返回值为以下常量值之一或之和：1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。失败返回 -1。

语法： 整数型 高级表格．取字体属性 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得指定单元格中字体的显示属性。


置字体属性 (表格)

置字体属性 方法 操作系统支持：Windows 所属对象：高级表格

设置高级表格中指定区域在显示时所使用字体的属性。成功返回真、失败返回假。

语法： 逻辑型 高级表格．置字体属性 （起始行，起始列，［终止行］，［终止列］，字体属性）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
字体属性 | 必需的；整数型，初始值为“0”。可以为以下常量值之一或之和： 1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。

例程:

说明:

设置指定区域中字体的显示属性。


取单元格文字颜色 (表格)

取单元格文字颜色 方法 操作系统支持：Windows 所属对象：高级表格

返回高级表格中指定单元格在显示时所使用文字的颜色。失败返回 -1。

语法： 整数型 高级表格．取单元格文字颜色 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得指定单元格中文本的颜色。


置单元格文字颜色 (表格)

置单元格文字颜色 方法 操作系统支持：Windows 所属对象：高级表格

设置高级表格中指定区域在显示时所使用文字的颜色。成功返回真、失败返回假。

语法： 逻辑型 高级表格．置单元格文字颜色 （起始行，起始列，［终止行］，［终止列］，文字颜色）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
文字颜色 | 必需的；整数型。表格文字的显示颜色。

例程:

说明:

设置指定区域中文本的颜色。


取单元格背景颜色 (表格)

取单元格背景颜色 方法 操作系统支持：Windows 所属对象：高级表格

返回高级表格中指定单元格在显示时所使用的背景颜色。失败返回 -1。

语法： 整数型 高级表格．取单元格背景颜色 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得指定单元格的背景颜色。


置单元格背景颜色 (表格)

置单元格背景颜色 方法 操作系统支持：Windows 所属对象：高级表格

设置高级表格中指定区域在显示时所使用的背景颜色。成功返回真、失败返回假。

语法： 逻辑型 高级表格．置单元格背景颜色 （起始行，起始列，［终止行］，［终止列］，背景颜色）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
背景颜色 | 必需的；整数型。单元格的背景颜色。

例程:

说明:

设置指定区域的背景颜色。


置对齐方式 (表格)

置对齐方式 方法 操作系统支持：Windows 所属对象：高级表格

设置高级表格中指定区域在显示时所使用的对齐方式。成功返回真、失败返回假。

语法： 逻辑型 高级表格．置对齐方式 （起始行，起始列，［终止行］，［终止列］，对齐方式）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
对齐方式 | 必需的；整数型。高级表格文字的对齐方式，可以为以下常量值之一: 1、#表格常量.左对齐； 2、#表格常量.居中对齐； 3、#表格常量.右对齐。

例程:

说明:

设置指定区域的对齐方式。


打印 (表格)

打印 方法 操作系统支持：Windows 所属对象：高级表格

打印高级表格单元的数据。

语法： 无返回值 高级表格．打印 （）

例程:

说明:

打印高级表格的数据。


打印预览 (表格)

打印预览 方法 操作系统支持：Windows 所属对象：高级表格

语法： 字节集 高级表格．打印预览 （）

例程:

说明:

预览要打印的高级表格。


清空下拉列表 (表格)

清空下拉列表 方法 操作系统支持：Windows 所属对象：高级表格

删除所有的下拉列表项。

语法： 无返回值 高级表格．清空下拉列表 （）

例程:

说明:

将列表型单元格的内容清空。


添加下拉列表内容 (表格)

添加下拉列表内容 方法 操作系统支持：Windows 所属对象：高级表格

设置单元格类型为列表型之前应先添加下拉列表内容。

语法： 无返回值 高级表格．添加下拉列表内容 （列表内容）

参数名 | 描 述
列表内容 | 必需的；文本型。表格所包含的下拉列表框的列表内容。

例程:

说明:

向列表型单元格中加入内容。


置列类型 (高级表格)

置列类型 方法 操作系统支持：Windows 所属对象：高级表格

设置列的数据类型。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置列类型 （列号，单元格类型）

参数名 | 描 述
列号 | 必需的；整数型。列号从0开始。
列类型 | 必需的；整数型。列的数据输入类型，值为以下常量值之一: 1、#表格常量.文本型； 2、#表格常量.数值型； 3、#表格常量.日期型；4、#表格常量.列表型； 5、#表格常量.选择型； 6、#表格常量.图片型；7、#表格常量.货币型。

例程:

说明:

设置高级表格中某一列的数据的类型。


置行高 (表格)

置行高 方法 操作系统支持：Windows 所属对象：高级表格

设置指定行的高度。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置行高 （行号，高度）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
高度 | 必需的；整数型。表格行的高度。

例程:

说明:

设置高级表格中某一行的高度。


置列宽 (表格)

置列宽 方法 操作系统支持：Windows 所属对象：高级表格

设置指定列的宽度。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置列宽 （列号，列宽）

参数名 | 描 述
列号 | 必需的；整数型。列号从0开始。
列宽 | 必需的；整数型。表格列的宽度。

例程:

说明:

设置高级表格中某一列的宽度。


取行高 (表格)

取行高 方法 操作系统支持：Windows 所属对象：高级表格

取得指定行的高度。成功返回行高、失败返回 -1。

语法： 整数型 高级表格．取行高 （行号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。

例程:

说明:

取得某一行的高度。


取列宽 (表格)

取列宽 方法 操作系统支持：Windows 所属对象：高级表格

取得指定列的宽度。成功返回列宽，失败返回 -1。

语法： 整数型 高级表格．取列宽 （列号）

参数名 | 描 述
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得某一列的宽度。


置日期格式 (表格)

置日期格式 方法 操作系统支持：Windows 所属对象：高级表格

设置日期显示格式。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置日期格式 （列号，日期格式）

参数名 | 描 述
列号 | 必需的；整数型。需要置日期格式的列号。
日期格式 | 必需的；整数型。日期格式的类型，值为以下常量值之一: 1、#表格常量.长日期格式； 2、#表格常量.短日期格式1； 3、#表格常量.短日期格式2； 4、#表格常量.短日期格式3、5、#表格常量.美式格式1； 6、#表格常量.美式格式2； 7、#表格常量.美式格式3； 8、#表格常量.美式格式4。

例程:

说明:

设置高级表格中某一列显示的日期的格式。


置货币前缀 (表格)

置货币前缀 方法 操作系统支持：Windows 所属对象：高级表格

设置货币型单元格的显示前缀。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置货币前缀 （列号，货币类型，［自定义前缀］）

参数名 | 描 述
列号 | 必需的；整数型。需要置货币前缀的列号。
货币类型 | 必需的；整数型。货币型单元格的货币类型，值为以下常量值之一: 1、#人民币； 2、#美元； 3、#欧元；4、#英镑；5、#自定义货币。
自定义前缀 | 可选的；文本型。货币型单元格的显示前缀，仅当货币类型为自定义货币时有效。如果本参数被省略，默认值为空。

例程:

说明:

设置高级表格的货币前缀字符。


置图片显示方式 (表格)

置图片显示方式 方法 操作系统支持：Windows 所属对象：高级表格

设置图片型单元格的显示方式。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置图片显示方式 （列号，显示方式）

参数名 | 描 述
列号 | 必需的；整数型。需要置图片显示方式的列号。
显示方式 | 必需的；整数型。图片型单元格的显示方式，值为以下常量值之一: 1、#表格常量.平铺； 2、#表格常量.拉伸； 3、#表格常量.居中；4、#表格常量.左上角；5、#表格常量.适合大小。

例程:

说明:

设置图片的显示方式。


删除行 (表格)

删除行 方法 操作系统支持：Windows 所属对象：高级表格

删除指定的高级表格行。成功返回真，失败返回假。

语法： 逻辑型 高级表格．删除行 （行号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。

例程:

说明:

删除高级表格某行。


删除列 (表格)

删除列 方法 操作系统支持：Windows 所属对象：高级表格

删除指定的高级表格列。成功返回真，失败返回假。

语法： 逻辑型 高级表格．删除列 （列号）

参数名 | 描 述
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

删除高级表格某一列。


插入行 (表格)

插入行 方法 操作系统支持：Windows 所属对象：高级表格

在指定的位置插入空行，如果未指定位置，则在高级表格尾部插入空行。成功返回真，失败返回假。

语法： 逻辑型 高级表格．插入行 （［行标题名］，［行号］）

参数名 | 描 述
行标题名 | 可选的；文本型。指定插入空行的行标题名。
行号 | 可选的；整数型。插入空行的位置。

例程:

说明:

在指定行的前面添加一行。


插入列 (表格)

插入列 方法 操作系统支持：Windows 所属对象：高级表格

在指定的位置插入空列，如果未指定位置，则在高级表格右部插入空列。成功返回真，失败返回假。

语法： 逻辑型 高级表格．插入列 （［列标题名］，［列号］）

参数名 | 描 述
列标题名 | 可选的；文本型。指定插入空列的列标题名。
列号 | 可选的；整数型。插入空列的位置。

例程:

说明:

在指定列的前面添加一列。


置计算公式 (表格)

置计算公式 方法 操作系统支持：Windows 所属对象：高级表格

指定高级表格中任意两个数字列可以进行简单的数学计算后将结果赋予表格中的另一列。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置计算公式 （列号1，列号2，计算操作符，结果列）

参数名 | 描 述
列号1 | 必需的；整数型。指定自动计算的第一列，该列必须为数值型或货币型。
列号2 | 必需的；整数型。指定自动计算的第二列，该列必须为数值型或货币型。
计算操作符 | 必需的；整数型。指定自动计算的操作符，值为以下常量值之一：1、#表格常量.加；2、#表格常量.减；3、#表格常量.乘；4、#表格常量.除。
结果列 | 必需的；整数型。指定自动计算的结果列，该列必须为数值型或货币型。

例程:

说明:

设置高级表格中列与列之间的计算关系。


置单元格小数位数 (表格)

置单元格小数位数 方法 操作系统支持：Windows 所属对象：高级表格

指定单元格数字的小数位数，只对数值型和货币型单元格有效。

语法： 逻辑型 高级表格．置单元格小数位数 （列号，小数位数）

参数名 | 描 述
列号 | 必需的；整数型。需要置小数位数的列号。
小数位数 | 必需的；整数型。指定数值或货币类型数据的小数位数。

例程:

说明:

设置单元格的小数位数。数值型和货币型单元格有效。


置自动换行 (表格)

置自动换行 方法 操作系统支持：Windows 所属对象：高级表格

指定单元格数据的换行方式。

语法： 逻辑型 高级表格．置自动换行 （起始行，起始列，［终止行］，［终止列］，是否自动换行）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
是否自动换行 | 必需的；逻辑型，初始值为“真”。单元格内容自动换行标记。真为自动换行、假为单行显示。

例程:

说明:

指定高级表格的文字是否折行,只支持中文。


插入下拉列表项 (表格)

插入下拉列表项 方法 操作系统支持：Windows 所属对象：高级表格

插入指定列的下拉列表项；该列必须为列表型。成功返回真、失败返回假。

语法： 逻辑型 高级表格．插入下拉列表项 （列号，列表项）

参数名 | 描 述
列号 | 必需的；整数型。需要插入下拉列表项的列号。
列表项 | 必需的；文本型。

例程:

说明:

向列表型单元格中加入列表项。


置打印表头 (表格)

置打印表头 方法 操作系统支持：Windows 所属对象：高级表格

指定高级表格打印时的表头名称及字体。成功返回真，失败返回假。

语法： 逻辑型 高级表格．置打印表头 （表头名称，字体名称，字体尺寸，是否为粗体，对齐方式）

参数名 | 描 述
表头名称 | 必需的；文本型。高级表格打印时的表头名称。
字体名称 | 必需的；文本型。高级表格打印时的表头字体名称。如果本参数被省略，默认值为黑体。
字体尺寸 | 必需的；整数型，初始值为“20”。高级表格打印时的表头字体尺寸。字体尺寸为0-100之间的整数。如果本参数被省略，默认值为20。
是否为粗体 | 必需的；逻辑型，初始值为“真”。如果本参数被省略，默认值为真。
对齐方式 | 必需的；整数型，初始值为“2”。高级表格打印时表头的对齐方式，可以为以下常量值之一: 1、#表格常量.左对齐； 2、#表格常量.居中对齐； 3、#表格常量.右对齐。如果本参数被省略，默认值为2。

例程:

说明:

设置打印时表头的字体属性。


加线条 (表格)

加线条 方法 操作系统支持：Windows 所属对象：高级表格

为指定的单元格添加线条。

语法： 无返回值 高级表格．加线条 （行号，列号，［斜线种类］）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。
斜线种类 | 可选的；整数型。需要添加的斜线类型。可以为以下常量值之一：1、#单斜线； 2、#双斜线； 3、#交叉线。如果本参数被省略，默认值为1。

例程:

说明:

在指定的单元格中加入线条。


删线条 (表格)

删线条 方法 操作系统支持：Windows 所属对象：高级表格

将指定单元格中的线条去除。

语法： 无返回值 高级表格．删线条 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

删除指定单元格的线条。


置边距 (表格)

置边距 方法 操作系统支持：Windows 所属对象：高级表格

设置指定单元格在表现其中数据时至其单元格边框之间的空白距离，单位为0.1毫米。

语法： 无返回值 高级表格．置边距 （起始行，起始列，［终止行］，［终止列］，边距）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
边距 | 必需的；整数型，初始值为“9”。如果本参数被省略，默认值为9。

例程:

说明:

设置单元格中的文本与单元格边框的距离。


取边距 (表格)

取边距 方法 操作系统支持：Windows 所属对象：高级表格

返回指定单元格在表现其中数据时至其单元格边框之间的空白距离，单位为0.1毫米。

语法： 整数型 高级表格．取边距 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取得单元格中的文本与单元格边框的距离。


置密码方式 (表格)

置密码方式 方法 操作系统支持：Windows 所属对象：高级表格

如设置值为真，则指定单元格在表现时以密码字符呈现。

语法： 无返回值 高级表格．置密码方式 （起始行，起始列，［终止行］，［终止列］，设置值）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
设置值 | 必需的；逻辑型。

例程:

说明:

设置指定区域的文本以密码方式显示。


取密码方式 (表格)

取密码方式 方法 操作系统支持：Windows 所属对象：高级表格

返回指定单元格在表现时是否使用密码方式。

语法： 逻辑型 高级表格．取密码方式 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

判断指定的单元格的文本显示方式是否是密码方式。


置只读方式 (表格)

置只读方式 方法 操作系统支持：Windows 所属对象：高级表格

如设置值为真，则指定单元格在表现时只能读取而不能写入。

语法： 无返回值 高级表格．置只读方式 （起始行，起始列，［终止行］，［终止列］，设置值）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。
设置值 | 必需的；逻辑型。

例程:

说明:

设置指定区域的单元格的访问方式为只读方式。


取只读方式 (表格)

取只读方式 方法 操作系统支持：Windows 所属对象：高级表格

返回指定单元格在表现时是否只读。

语法： 逻辑型 高级表格．取只读方式 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

判断指定单元格的访问方式是否是只读方式。


存到文件 (表格)

存到文件 方法 操作系统支持：Windows 所属对象：高级表格

将高级表格中所有现有数据保存到指定文件中。成功返回真，失败返回假。

语法： 逻辑型 高级表格．存到文件 （表格文件名）

参数名 | 描 述
表格文件名 | 必需的；文本型。

例程:

说明:

高级表格自身的保存功能。


从文件读 (表格)

从文件读 方法 操作系统支持：Windows 所属对象：高级表格

将指定文件内的数据写入到高级表格中。成功返回真，失败返回假。

语法： 逻辑型 高级表格．从文件读 （表格文件名）

参数名 | 描 述
表格文件名 | 必需的；文本型。

例程:

说明:

高级表格自身的读取功能。


清空数据 (表格)

清空数据 方法 操作系统支持：Windows 所属对象：高级表格

将所有单元格的内容清空。该操作将清除高级表格所有的数据及属性，请谨慎操作。

语法： 无返回值 高级表格．清空数据 （）

例程:

说明:

清空高级表格中所有数据。


合并 (表格)

合并 方法 操作系统支持：Windows 所属对象：高级表格

组合高级表格中指定范围内的单元格，使之以一个单元格的形式表现。

语法： 无返回值 高级表格．合并 （起始行，起始列，［终止行］，［终止列］）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为0。
终止列 | 可选的；整数型。如果本参数被省略，默认值为0。

例程:

说明:

合并高级表格的选择的区域。合并后的内容以起始的行列内容为准。


分解 (表格)

分解 方法 操作系统支持：Windows 所属对象：高级表格

分解高级表格中指定的已经组合的单元格，行列参数指向被组合单元格内的任何一个单元格即可。

语法： 无返回值 高级表格．分解 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从0开始。
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

分解已经合并的单元格。


打印到打印机 (表格)

打印到打印机 方法 操作系统支持：Windows 所属对象：高级表格

打印高级表格。

语法： 无返回值 高级表格．打印到打印机 （打印机对象）

参数名 | 描 述
打印机对象 | 必需的；打印机。

例程:

说明:

将高级表格与打印机对象相关联，可以调用打印机中的方法应用到高级表格中。


取列类型 (高级表格)

取列类型 方法 操作系统支持：Windows 所属对象：高级表格

取得指定列的数据类型。返回值为以下常量值之一: 0、失败； 1、#表格常量.文本型； 2、#表格常量.数值型； 3、#表格常量.日期型； 4、#表格常量.列表型； 5、#表格常量.选择型； 6、#表格常量.图片型； 7、#表格常量.货币型。

语法： 整数型 高级表格．取列类型 （列号）

参数名 | 描 述
列号 | 必需的；整数型。列号从0开始。

例程:

说明:

取出某一列的类型，初始不为任何类型。


清空单元格数据 方法 操作系统支持：Windows 所属对象：表格

清空单元格数据 方法 操作系统支持：Windows 所属对象：高级表格

清除指定区域的单元格的内容。

语法： 逻辑型 高级表格．清空单元格数据 （起始行，起始列，［终止行］，［终止列］）

参数名 | 描 述
起始行 | 必需的；整数型。
起始列 | 必需的；整数型。
终止行 | 可选的；整数型。如果本参数被省略，默认值为起始行。
终止列 | 可选的；整数型。如果本参数被省略，默认值为起始列。

例程:

说明:

清空用户所指定的单元格里的内容。


清空单元格数据 方法 操作系统支持：Windows 所属对象：表格

取单元格行高 方法 操作系统支持：Windows 所属对象：高级表格

取得指定单元格的高度。成功返回单元格高度、失败返回 -1。

语法： 整数型 高级表格．取单元格行高 （［行号］，［列号］）

参数名 | 描 述
行号 | 可选的；整数型。行号从0开始。如省略，则为当前焦点所在单元格行号。
列号 | 可选的；整数型。列号从0开始。如省略，则为当前焦点所在单元格列号。

例程:

说明:

取得指定单元格的高度。


清空单元格数据 方法 操作系统支持：Windows 所属对象：表格

取单元格列宽 方法 操作系统支持：Windows 所属对象：高级表格

取得指定单元格的宽度。成功返回单元格宽度，失败返回 -1。

语法： 整数型 高级表格．取单元格列宽 （［行号］，［列号］）

参数名 | 描 述
行号 | 可选的；整数型。行号从0开始。如省略，则为当前焦点所在单元格行号。
列号 | 可选的；整数型。列号从0开始。如省略，则为当前焦点所在单元格列号。

例程:

说明:

取得指定单元格的宽度。


置打印页边距 方法 操作系统支持：Windows 所属对象：高级表格

设置打印页边距。

语法： 无返回值 高级表格．置打印页边距 （页边距类型，设置值）

参数名 | 描 述
页边距类型 | 必需的；整数型。需要设置的页边距类型。可以为以下常量值之一：1、#表格常量.左边距； 2、#表格常量.右边距； 3、#表格常量.上边距；4、#表格常量.下边距； 5、#表格常量.页眉； 6、#表格常量.页脚； 7、#表格常量.表头与表格间隔；。
设置值 | 必需的；整数型。要设置的页边距值，单位为0.1毫米。

例程:

说明:

设置打印页边距。


置累加公式 方法 操作系统支持：Windows 所属对象：高级表格

设置纵向单元格累加公式。

语法： 逻辑型 高级表格．置累加公式 （列号，起始行，终止行，［结果行］）

参数名 | 描 述
列号 | 必需的；整数型。要设置累加公式的列号。
起始行 | 必需的；整数型。
终止行 | 必需的；整数型。
结果行 | 可选的；整数型。如果本参数被省略，默认值为终止行的下一行。

例程

说明

设置高级表格中纵向数值列的累加计算。

参考：例程1


取对齐方式 方法 操作系统支持：Windows 所属对象：高级表格

取表格中指定单元格在显示时所使用的对齐方式。返回以下值之一：1、左对齐； 2、居中对齐； 3、右对齐； -1、失败。

语法： 整数型 高级表格．取对齐方式 （行号， 列号）

参数名 | 描 述
行号 | 必需的； 整数型。行号从0开始。
列号 | 必需的； 整数型。列号从0开始。

例程:

说明:

获取单元格的对齐方式。


刷新单元格 方法 操作系统支持：Windows 所属对象：高级表格

刷新表格单元格。主要用于计算公式结果单元格的刷新。

语法： 无返回值 高级表格．刷新单元格 （）

例程

说明

刷新显示单元格。

参考：例程1


删除累加公式 方法 操作系统支持：Windows 所属对象：高级表格

删除指定列的单元格累加公式。

语法： 逻辑型 高级表格．删除累加公式 （列号）

参数名 | 描 述
列号 | 必需的； 整数型。要删除累加公式的列号，列号从0开始。-1表示删除所有累加公式。

例程

说明

删除指定列的累加公式。

参考：例程1


光标位置改变 (高级表格)

光标位置改变 事件 所属对象：高级表格 操作系统支持：Windows

当操作者更改了当前被选择区域的行列数时会产生本事件。

语法： 无返回值 _高级表格_光标位置改变 （）

例程:

说明:

光标位置改变时引发此事件。


将被编辑 (高级表格)

将被编辑 事件 所属对象：高级表格 操作系统支持：Windows

当高级表格将被编辑前产生本事件。

语法： 无返回值 _高级表格_将被编辑 （）

例程:

说明:

在进入编辑状态就会触发将被编辑事件，结束编辑状态时，触发结束编辑事件


结束编辑 (高级表格)

结束编辑 事件 所属对象：高级表格 操作系统支持：Windows

当高级表格编辑结束之后产生此事件。

语法： 无返回值 _高级表格_结束编辑 （）

例程:

说明:

在进入编辑状态就会触发将被编辑事件，结束编辑状态时，触发结束编辑事件。


行高被改变 (高级表格)

行高被改变 事件 所属对象：高级表格 操作系统支持：Windows

当操作者调整了高级表格行行高时即产生此事件。

语法： 无返回值 _高级表格_行高被改变 （行号）

参数名 | 描 述
行号 | 整数型；行高被改变的表格行号。

例程:

说明:

单元的行高改变时触发。


列宽被改变 (表格)

列宽被改变 事件 所属对象：高级表格 操作系统支持：Windows

当操作者调整了表格列列宽时即产生此事件。

语法： 无返回值 _高级表格_列宽被改变 （列号）

参数名 | 描 述
列号 | 整数型；列宽被改变的表格列号。

例程:

说明:

单元列宽改变时触发此事件。


被单击 事件 所属对象：高级表格 操作系统支持：Windows

当操作者单击表格时即产生此事件，关于表格的鼠标点击事件都应在此事件中处理。

语法： 无返回值 _高级表格_被单击 （横向位置， 纵向位置）

参数名 | 描 述
横向位置 | 整数型； 指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型； 指示鼠标在当前所处窗口组件中的纵向位置。

例程:

说明:

本事件只接收鼠标的左键点击事件。


列表项被选择 事件 所属对象：高级表格 操作系统支持：Windows

当操作者选择列表型单元格中的列表项时产生此事件。

语法： 无返回值 _高级表格_列表项被选择 （行号， 列号， 被选择文本）

参数名 | 描 述
行号 | 整数型； 行高被改变的表格行号。
列号 | 整数型； 列宽被改变的表格列号。
被选择文本 | 文本型； 当前被选择文本。

例程

说明

列表型单元格的内容被选择时触发此事件。

参考：例程1


复制选定文本 (表格)

可否被编辑 事件 操作系统支持：Windows 所属对象：高级表格

在某单元格“将被编辑”事件之前产生本事件。如果本事件返回假，表示不允许该单元格进入编辑状态，这种情况下不会有后续的“将被编辑”事件。本事件并不能阻止“不进入编辑状态而修改单元格内容”的行为，如按下DEL或Ctrl+V键

语法： 此事件的用户处理子程序所需返回数据的类型为“逻辑型（bool）”

例程:

说明:

高级表格可否被编辑，可在此事件中返回假以阻止当前选中单元格进入编辑状态。


表格常量

表格常量 枚举常量集合类型 操作系统支持：Windows 跳至：高级表格

提供表格支持库中所要使用的常量枚举值。

成员 | 描 述
行斑马线 | 常量值为 1 。
列斑马线 | 常量值为 2 。
左对齐 | 常量值为 1 。
居中对齐 | 常量值为 2 。
右对齐 | 常量值为 3 。
文本型 | 常量值为 1 。
数值型 | 常量值为 2 。
日期型 | 常量值为 3 。
列表型 | 常量值为 4 。
选择型 | 常量值为 5 。
图片型 | 常量值为 6 。
货币型 | 常量值为 7 。
长日期格式 | 常量值为 1 。
短日期格式1 | 常量值为 2 。
短日期格式2 | 常量值为 3 。
短日期格式3 | 常量值为 4 。
美式格式1 | 常量值为 5 。
美式格式2 | 常量值为 6 。
美式格式3 | 常量值为 7 。
美式格式4 | 常量值为 8 。
人民币 | 常量值为 1 。
美元 | 常量值为 2 。
欧元 | 常量值为 3 。
英镑 | 常量值为 4 。
自定义货币 | 常量值为 5 。
平铺 | 常量值为 1 。
拉伸 | 常量值为 2 。
居中 | 常量值为 3 。
左上角 | 常量值为 4 。
适合大小 | 常量值为 5 。
加 | 常量值为 1 。
减 | 常量值为 2 。
乘 | 常量值为 3 。
除 | 常量值为 4 。
单斜线 | 常量值为 1 。
双斜线 | 常量值为 2 。
交叉线 | 常量值为 3 。
左边距 | 常量值为 1 。
右边距 | 常量值为 2 。
上边距 | 常量值为 3 。
下边距 | 常量值为 4 。
页眉 | 常量值为 5 。
页脚 | 常量值为 6 。
表头与表格间隔 | 常量值为 7 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。

参见：例程