图形图像支持库 - 格式

图像格式转换支持库 帮助手册20080815版 返回支持库手册 返回首页

本库用来转换图象格式，目前暂时支持打开的格式有:JPEG/BMP24/TIFF/PNG/PCX/PCD,如果在使用中出现错误或者异常,请您将出错时候的相关图像文件和出错描述等信息,通过电子邮件或者其他方式发给我公司,谢谢！。

操作系统支持： Windows

命令类别：

图像转换

例程名称 | 下载 | 说明
图片格式转换 | 图片格式转换.e | 演示把指定格式的图片转换到其他格式图片的使用方法

适用版本，图像格式转换支持库 （1.0#4版）


图像转换

图像转换 类别 跳至：图形图像支持库 - 格式1.0版


转换到JPEG 命令 操作系统支持：Windows 所属类别：图像转换

转换到JPG 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为JPEG文件，支持大部分JPEG压缩选项。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。 目前可以读取如下源格式的图像并转换到JPEG格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到JPG （源文件名，目标文件名，灰度还是真彩，图像品质，是否使用优化编码，是否柔化）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，用文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。
灰度还是真彩 | 必需的；逻辑型，初始值为“假”。参数值等于真为8位灰度图，等于假为24位真彩图，默认值为假。
图像品质 | 必需的；整数型，初始值为“75”。参数值在 1 到 100 之间，否则为错！默认为 75 。
是否使用优化编码 | 必需的；逻辑型，初始值为“真”。同等质量的JPEG图像文件，优化编码是压缩比最好的，默认值为真。
是否柔化 | 必需的；整数型，初始值为“0”。参数值在 0 到 100 之间，否则为错！0 为无柔化。在压缩比很大的JPEG文件中，适当的柔化可以改善图像质量。默认值为 0 。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．jpg”，则通过“转换到JPG”命令将bmp等图片格式转换为jpg格式。

参考：例程1


转换到BMP 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为24位的BMP文件。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。 目前可以读取如下源格式的图像并转换到BMP格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到BMP （源文件名，目标文件名）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．bmp”，则通过“转换到BMP”命令将jpg等图片格式转换为bmp图片格式。


转换到TIFF 命令 操作系统支持：Windows 所属类别：图像转换

转换到TIF 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为TIFF文件。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。 目前可以读取如下源格式的图像并转换到TIFF格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到TIF （源文件名，目标文件名，灰度还是真彩）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。
灰度还是真彩 | 必需的；逻辑型，初始值为“假”。参数值等于真为8位灰度图，等于假为24位真彩图，默认值为假。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．tif”，通过“转换到TIF”命令，将bmp等图片格式转换为tif图片格式。


转换到PNG 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为24位的PNG文件。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。目前可以读取如下源格式的图像并转换到PNG格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到PNG （源文件名，目标文件名，目标文件的颜色位数）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。
目标文件的颜色位数 | 必需的；整数型，初始值为“24”。该参数目前只能为数值 24 (目前仅支持 24 位颜色)。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．png”，则通过“转换到PNG”命令将bmp等图片格式转换为png图片格式。


转换到PPM 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为PPM文件，目前支持文本模式和二进制模式。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。 目前可以读取如下源格式的图像并转换到PPM格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到PPM （源文件名，目标文件名，保存模式）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。
保存模式 | 必需的；逻辑型，初始值为“真”。参数值为真则保存为二进制模式，为假则保存为文本模式，默认参数值为真。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．ppm”，则通过“转换到PPM”命令将bmp等图片格式转换为ppm图片格式。


转换到PGM 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为PGM文件，目前支持文本模式和二进制模式。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误 目前可以读取如下源格式的图像并转换到PGM格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到PGM （源文件名，目标文件名，保存模式）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。
保存模式 | 必需的；逻辑型，初始值为“真”。参数值为真则保存为二进制模式，为假则保存为文本模式，默认参数值为真。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．pgm”，则通过“转换到PGM”命令将bmp等图片格式转换为pgm格式。


转换到PBM 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为PBM文件，目前支持文本模式。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。 目前可以读取如下源格式的图像并转换到PBM格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到PBM （源文件名，目标文件名）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．pbm”，则通过“转换为PBM”命令，将bmp等图片格式转换为pbm格式。


转换到PCX 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为24位的PCX文件。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误 目前可以读取如下源格式的图像并转换到PCX格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到PCX （源文件名，目标文件名）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．pcx”，则通过“转换为PCX”命令，将bmp等图片格式转换为pcx格式。


转换到PICS 命令 操作系统支持：Windows 所属类别：图像转换

转换到PIC 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为24位的PICS文件。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。 目前可以读取如下源格式的图像并转换到PICS格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到PIC （源文件名，目标文件名）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．pics”，则通过“转换为PICS”命令，将bmp等图片格式转换为pics格式。


转换到SGI 命令 操作系统支持：Windows 所属类别：图像转换

将本库支持读取的图像文件转换为24位的SGI文件。成功返回 1 ，失败返回一个小于等于零的数值，具体为： 0: 未知错误； -1: 文件不存在； -2: 系统资源不足； -3: 该文件格式不被支持； -4: 编码时出错； -6: 编码时系统资源不足； -7: 编码参数错误。目前可以读取如下源格式的图像并转换到SGI格式：标准JPEG（全部格式）、BMP（目前仅支持24位BMP）、TIFF（单页图像所有格式）、PNG（32位及32位以下）、PCX（8位和24位，RLE压缩）、PCD（取第三幅）。

语法： 整数型 转换到SGI （源文件名，目标文件名）

参数名 | 描 述
源文件名 | 必需的；文本型。可以是本支持库支持的任意文件格式，请提供文件全名(包含路径)。
目标文件名 | 必需的；文本型。参数值指定转换后保存到的目标文件名。

例程

说明

使用文本操作命令将欲保存文件的扩展名取出，如果扩展名为“．sgi”，则通过“转换到SGI”命令，将bmp等图片格式转换为sgi格式。