扩展界面支持库三

扩展界面支持库三 帮助手册20080812版 返回支持库手册 返回首页

操作系统支持： Windows

窗口组件数据类型：

卷帘式菜单

高级选择夹

常量表

例程列表：

例程名称 | 下载 | 说明
菜单底图效果 | 菜单底图效果.e | 演示使用了菜单底图后的界面效果
卷帘式菜单 | 卷帘式菜单.E | 实现了类似与OICQ界面的菜单功能

适用版本，扩展界面支持库三 （2.6#1版）


卷帘式菜单

卷帘式菜单 窗口组件 操作系统支持：Windows 跳至：扩展界面支持库三

属性：

项目 | 项目图标图片组 | 项目列表图片组 | 背景颜色
排列方式 | 现行选中菜单 | 现行选中项目 | 菜单底色
菜单下按色 | 菜单悬停色 | 菜单选中色 | 菜单文本色
菜单下按文本色 | 菜单悬停文本色 | 菜单选中文本色 | 项目文本色
项目悬停文本色 | 项目选中文本色 | 亮边框色 | 暗边框色
菜单字体 | 项目字体 | 菜单高度 | 菜单滚动速度
平面 | XP风格 | 闪烁选中项目 | 菜单图标图片组
菜单背景图片组 | 显示菜单文本 | 显示菜单图标 |

方法：

加入菜单 | 加入项目 | 删除菜单 | 删除项目
取菜单数 | 取项目数 | 取菜单名称 | 取项目名称
置菜单名称 | 置项目名称 | 取菜单数值 | 取项目数值
置菜单数值 | 置项目数值 | 取项目图片 | 置项目图片
清除 | 加入组件菜单 | 置菜单图标 | 取菜单图标
置菜单底图 | 取菜单底图 | 菜单是否已禁止 | 禁止菜单
项目是否已禁止 | 禁止项目 | 菜单是否已隐藏 | 隐藏菜单
项目是否已隐藏 | 隐藏项目 | 取菜单提示文本 | 置菜单提示文本
取项目提示文本 | 置项目提示文本 |  |

自有事件：

项目被选择 | 菜单被改变 | 项目名称被改变 | 菜单名称被改变
菜单被单击 | 菜单被右击 | 项目被右击 | 项目被双击

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动


项目 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字节集；

例程：

说明：

本属性用于更改和获取卷帘菜单中的菜单和项目。

参见：例程1


项目图标图片组 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字节集；当“排列方式”属性为“0.图标方式”时项目使用的图标。

例程：

说明：

通过本属性用于设置和获取当排列方式为图标方式时显示的图标组。

参见：例程1


项目列表图片组 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字节集；当“排列方式”属性为“1.列表方式”时项目使用的图标。

例程：

说明：

本属性用于设置和获取当排列方式属性为列表方式时显示的图标组。

参见：例程1


背景颜色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于获取和更改卷帘菜单的背景颜色。

参见：例程1


排列方式 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、图标方式
1、列表方式

例程：

说明：

通过本属性设置和获取当前项目在卷帘菜单中的排列方式。

参见：例程1


现行选中菜单 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；序号从0开始。如果没有现行选中菜单，该属性值为-1。

例程：

说明：

本属性用于获取和更改当前选中的菜单。

参见：例程1


现行选中项目 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；序号从0开始。如果没有现行选中项目，该属性值为-1。

例程：

说明：

本属性用于更改和获取当前选中的项目。

参见：例程1


菜单底色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于获得和设置菜单的底色。

参见：例程1


菜单下按底色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

菜单下按色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获取菜单按下时菜单的颜色。

参见：例程1


菜单悬停底色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

菜单悬停色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获取当鼠标悬停于菜单上时菜单的颜色。

参见：例程1


菜单选中色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于在自定义XP样式时获取和更改菜单选中时的颜色。

参见：例程1


菜单文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获得菜单中文本的颜色。

参见：例程1


菜单下按文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于获得和设置菜单按下时菜单中的文字颜色。

参见：例程1


菜单悬停文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获取菜单在悬停时菜单中文字的颜色。

参见：例程1


菜单选中文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于在自定义XP风格时获取和更改菜单被选中时的文本颜色。

参见：例程1


项目文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获取项目的文本颜色。

参见：例程1


项目悬停文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获取项目悬停时文本的颜色。

参见：例程1


项目选中文本色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于在自定义XP风格时获取和更改项目被选中时的文本颜色。

参见：例程1


亮边框色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于设置和获取亮边框颜色。

参见：例程1


暗边框色 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；如果为“平面”模式，使用该颜色作为边框色。

例程：

说明：

本属性用于设置和获取暗边框颜色。

参见：例程1


菜单字体 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字体；

例程：

说明：

本属性用于设置和获取菜单文字的字体。

参见：例程1


项目字体 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字体；

例程：

说明：

本属性用于设置和获取项目的字体。

参见：例程1


菜单高度 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

本属性用于获取和设置菜单的高度。

参见：例程1


菜单滚动速度 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；值越大滚动快，0表示没有滚动效果。此值必须大于菜单高度。

例程：

说明：

本属性用于控制菜单滚动快慢。数值越大速度越快。

参见：例程1


平面 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

本属性用于设置是否使用平面风格。

参见：例程1


XP风格 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无
1、蓝色XP风格
2、绿色XP风格
3、银色XP风格
4、自定义

例程：

说明：

本属性用于美化界面，其中自定义式可以根据菜单底色等颜色设置属性自定XP风格的菜单。

参见：例程1


闪烁选中项目 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

本属性用于设置菜单中项目被选中时是否自动闪烁。

参见：例程1


菜单图标图片组 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字节集；

例程：

说明：

通过“菜单图标图片组”属性，可对要置为菜单图标的图片进行设置。

参见：例程1


菜单背景图片组 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：字节集；

例程：

说明：

通过“菜单背景图片组”属性来设置将要置为菜单底图的图片。

参见：例程1


显示菜单文本 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

通过“显示菜单文本”属性控制有菜单背景图片时，是否显示菜单的文本。

参见：例程1


显示菜单图标 属性 所属对象：卷帘式菜单 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

通过“显示菜单图标”属性来控制当有菜单背景图片时是否依然显示菜单图标。

参见：例程1


加入菜单 方法 操作系统支持：Windows 所属对象：卷帘式菜单

加入一个新的菜单。

语法： 逻辑型 卷帘式菜单．加入菜单 （菜单名称，［菜单索引］，［菜单数值］）

参数名 | 描 述
菜单名称 | 必需的；文本型。
菜单索引 | 可选的；整数型。指定将加入的菜单所在位置。如果本参数省略，表示在所有菜单的最后加入菜单。
菜单数值 | 可选的；整数型。指定与该菜单相关联的附加数值，供用户自己使用。如果本参数省略，默认为0。

例程：

说明：

通过“加入菜单”命令向卷帘式菜单中加入一个新菜单。

参见：例程1


加入项目 方法 操作系统支持：Windows 所属对象：卷帘式菜单

在指定菜单中加入一个新的项目。调用本方法前，指定的菜单必须已经存在。

语法： 逻辑型 卷帘式菜单．加入项目 （项目名称，［菜单索引］，［项目索引］，［图片索引］，［项目数值］）

参数名 | 描 述
项目名称 | 必需的；文本型。
菜单索引 | 可选的；整数型。指定在哪个菜单中插入项目。索引从 0 开始。如果本参数省略，表示在当前菜单中插入项目。
项目索引 | 可选的；整数型。指定项目插入的位置。索引从 0 开始。如果本参数省略，表示在指定菜单（前一个参数）的最后插入项目。
图片索引 | 可选的；整数型。指定该项目所使用的图片。索引从 0 开始。如果本参数省略，默认为-1，表示不使用图片。
项目数值 | 可选的；整数型。指定与该项目相关联的附加数值，供用户自己使用。如果本参数省略，默认为0。

例程：

说明：

通过“加入项目”命令向当前菜单中加入一个新项目。

参见：例程1


删除菜单 方法 操作系统支持：Windows 所属对象：卷帘式菜单

删除指定的菜单。

语法： 逻辑型 卷帘式菜单．删除菜单 （菜单索引）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。

例程：

说明：

通过“删除菜单”命令删除当前菜单。

参见：例程1


删除项目 方法 操作系统支持：Windows 所属对象：卷帘式菜单

删除指定菜单中的指定项目。

语法： 逻辑型 卷帘式菜单．删除项目 （项目索引， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。如果为-1，表示要删除指定菜单中的所有项目。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“删除项目”命令删除当前项目。

参见：例程1


取菜单数 方法 操作系统支持：Windows 所属对象：卷帘式菜单

获取菜单的个数。

语法： 整数型 卷帘式菜单．取菜单数 （）

例程：

说明：

通过“取菜单数”命令获得控件中菜单的总数。

参见：例程1


取项目数 方法 操作系统支持：Windows 所属对象：卷帘式菜单

获取当前菜单中的项目个数。

语法： 整数型 卷帘式菜单．取项目数 （［菜单索引］）

参数名 | 描 述
菜单索引 | 可选； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“取项目数”命令获取当前菜单的项目总数。

参见：例程1


取菜单名称 方法 操作系统支持：Windows 所属对象：卷帘式菜单

获取指定菜单的名称文本。

语法： 文本型 卷帘式菜单．取菜单名称 （菜单索引）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。

例程：

说明：

通过“取菜单名称”命令获取当前菜单的菜单名称。

参见：例程1


取项目名称 方法 操作系统支持：Windows 所属对象：卷帘式菜单

获取指定菜单中的指定项目的名称文本。

语法： 文本型 卷帘式菜单．取项目名称 （项目索引， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“取项目名称”命令获得当前项目的名称。

参见：例程1


置菜单名称 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单的名称文本。调用本方法将引发“菜单名称被改变”事件。

语法： 逻辑型 卷帘式菜单．置菜单名称 （菜单索引，菜单名称）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。
菜单名称 | 必需的；文本型。

例程：

说明：

通过“置菜单名称”命令更改当前菜单的名称。

参见：例程1


置项目名称 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单中的指定项目的名称文本。调用本方法将引发“项目名称被改变”事件。

语法： 逻辑型 卷帘式菜单．置项目名称 （项目索引， 项目名称， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。
项目名称 | 必需的； 文本型。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“置项目名称”命令更改当前的项目名称。

参见：例程1


取菜单数值 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单的数值。失败返回 0。

语法： 整数型 卷帘式菜单．取菜单数值 （［菜单索引］）

参数名 | 描 述
菜单索引 | 可选的；整数型。索引从 0 开始。如果本参数省略，表示取当前菜单的数值。

例程：

说明：

通过“取菜单数值”命令获取当前菜单的数值。

参见：例程1


取项目数值 方法 操作系统支持：Windows 所属对象：卷帘式菜单

获取指定菜单中的指定项目的数值。失败返回 0。

语法： 整数型 卷帘式菜单．取项目数值 （项目索引， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“取项目数值”命令获取当前项目的数值。

参见：例程1


置菜单数值 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单的数值。

语法： 逻辑型 卷帘式菜单．置菜单数值 （菜单索引，菜单数值）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。
菜单数值 | 必需的；整数型。

例程：

说明：

通过“置菜单数值”更改当前菜单的数值。

参见：例程1


置项目数值 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单中指定项目的数值。

语法： 整数型 卷帘式菜单．置项目数值 （项目索引， 项目数值， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。
项目数值 | 必需的； 整数型。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“置项目数值”命令更改当前项目的数值。

参见：例程1


取项目图片 方法 操作系统支持：Windows 所属对象：卷帘式菜单

获取指定菜单中指定项目的图片索引。

语法： 整数型 卷帘式菜单．取项目图片 （项目索引， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“取项目图片”命令获取当前项目的图片索引。

参见：例程1


置项目图片 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单中指定项目的图片索引。

语法： 整数型 卷帘式菜单．置项目图片 （项目索引， 图片索引， ［菜单索引］）

参数名 | 描 述
项目索引 | 必需的； 整数型。索引从 0 开始。
图片索引 | 必需的； 整数型。
菜单索引 | 可选的； 整数型。索引从 0 开始。如果本参数被省略，默认为当前选中菜单的索引。

例程：

说明：

通过“置项目图片”命令更改当前项目的图片索引。

参见：例程1


清除 方法 操作系统支持：Windows 所属对象：卷帘式菜单

删除所有菜单以及所有项目。

语法： 整数型 卷帘式菜单．清除 （）

例程：

说明：

通过“清除”命令将卷帘式菜单内的所有菜单和项目删除。

参见：例程1


加入组件菜单 方法 操作系统支持：Windows 所属对象：卷帘式菜单

在指定位置添加新的菜单，该菜单可容纳普通窗口组件（而不能再容纳普通项目）。

语法： 逻辑型 卷帘式菜单．加入组件菜单 （菜单名称，窗口组件，［菜单索引］，［菜单数值］）

参数名 | 描 述
菜单名称 | 必需的；文本型。
窗口组件 | 必需的；通用型。指定要加入的窗口组件。该窗口组件将被自动调整大小，以便恰好放置于菜单中。建议使用容器类窗口组件，如“分组框”“图片框”“外形框”等，容器类窗口组件中再可放其它组件。即使被加入的组件“可视”属性为“假”，必要时也会被显示出来。如果加入的是窗口，将自动取消其标题栏并禁止最大化、最小化和关闭。
菜单索引 | 可选的；整数型。指定将加入的菜单所在位置。如果本参数省略，表示在所有菜单的最后加入菜单。
菜单数值 | 可选的；整数型。指定与该菜单相关联的附加数值，供用户自己使用。如果本参数省略，默认为0。

例程：

说明：

通过“加入组件菜单”命令将窗口组件以新菜单加入卷帘式菜单。

参见：例程1


置菜单图标 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单的图标。

语法： 整数型 卷帘式菜单．置菜单图标 （菜单索引，图标索引）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。如果为-1，表示统一设置现有所有菜单的图标。
图标索引 | 必需的；整数型。

例程：

说明：

通过“置菜单图标”命令设置在菜单上显示的图标，如果参数“菜单索引”为“-1”时，表示所有菜单均同样设置。

参见：例程1


取菜单图标 方法 操作系统支持：Windows 所属对象：卷帘式菜单

返回指定菜单的图标。

语法： 整数型 卷帘式菜单．取菜单图标 （菜单索引）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。

例程：

说明：

通过“取菜单图标”命令获取指定菜单的当前图标索引值。

参见：例程1


置菜单底图 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单的背景图片。

语法： 逻辑型 卷帘式菜单．置菜单底图 （菜单索引，［正常图片索引］，［选中图片索引］，［正常加亮图片索引］，［选中加亮图片索引］）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。如果为-1，表示统一设置现有所有菜单的背景图片。
正常图片索引 | 可选的；整数型。索引从0开始。如果本参数省略，默认为-1，表示不指定图片。
选中图片索引 | 可选的；整数型。索引从0开始。如果本参数省略，默认为-1，表示不指定图片。
正常加亮图片索引 | 可选的；整数型。索引从0开始。如果本参数省略，默认为-1，表示不指定图片。
选中加亮图片索引 | 可选的；整数型。索引从0开始。如果本参数省略，默认为-1，表示不指定图片。

例程：

说明：

通过“置菜单底图”命令设置指定菜单的背景图片。如果参数“菜单索引”为“-1”，那么所有菜单将被置为同样样式。

参见：例程1


取菜单底图 方法 操作系统支持：Windows 所属对象：卷帘式菜单

取指定菜单的背景图片。取得的图片索引值将写入后面四个参数中，索引值从0开始。

语法： 整数型 卷帘式菜单．取菜单底图 （菜单索引，［正常图片索引］，［选中图片索引］，［正常加亮图片索引］，［选中加亮图片索引］）

参数名 | 描 述
菜单索引 | 必需的；整数型。索引从 0 开始。
正常图片索引 | 可选的；整数型，参数数据只能提供变量。
选中图片索引 | 可选的；整数型，参数数据只能提供变量。
正常加亮图片索引 | 可选的；整数型，参数数据只能提供变量。
选中加亮图片索引 | 可选的；整数型，参数数据只能提供变量。

例程：

说明：

通过“取菜单底图”命令获取指定菜单的当前样式的图片索引。取出的各项图片索引会赋值给参数。

参见：例程1


单是否已禁止 方法 操作系统支持：Windows 所属对象：卷帘式菜单

菜单是否已禁止 方法 操作系统支持：Windows 所属对象：卷帘式菜单

判断指定菜单是否已被禁止。如果菜单已被禁止，返回“真”，否则返回“假”。如果指定菜单不存在，直接返回“假”。

语法： 逻辑型 卷帘式菜单．菜单是否已禁止 （菜单索引）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。

例程：

说明：

通过“菜单是否已禁止”命令判断指定菜单是否已经被禁止。

参见：例程1


禁止菜单 方法 操作系统支持：Windows 所属对象：卷帘式菜单

禁止或取消禁止指定菜单。被禁止的菜单不接受鼠标点击，外观上也与正常菜单有所区别。

语法： 逻辑型 卷帘式菜单．禁止菜单 （菜单索引， 禁止吗）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
禁止吗 | 必需的； 逻辑型。如果本参数为“真”，表示禁止菜单；如果本参数为“假”，表示取消禁止菜单。

例程：

说明：

通过“禁止菜单”命令来禁止操作指定菜单。该菜单中的项目及该菜单的事件将不会被触发。

参见：例程1


项目是否已禁止 方法 操作系统支持：Windows 所属对象：卷帘式菜单

判断指定项目是否已被禁止。如果项目已被禁止，返回“真”，否则返回“假”。如果指定项目不存在，直接返回“假”。

语法： 逻辑型 卷帘式菜单．项目是否已禁止 （菜单索引， 项目索引）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
项目索引 | 必需的； 整数型。索引从 0 开始。

例程：

说明：

通过“项目是否已禁止”命令判断指定菜单中的指定项目是否已被禁止。

参见：例程1


禁止项目 方法 操作系统支持：Windows 所属对象：卷帘式菜单

禁止或取消禁止指定项目。被禁止的项目不接受鼠标点击，外观上也与正常项目有所区别。

语法： 逻辑型 卷帘式菜单．禁止项目 （菜单索引， 项目索引， 禁止吗）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
项目索引 | 必需的； 整数型。索引从 0 开始。
禁止吗 | 必需的； 逻辑型。如果本参数为“真”，表示禁止项目；如果本参数为“假”，表示取消禁止项目。

例程：

说明：

通过“禁止项目”命令禁止指定菜单中的指定项目，使该项目的所有事件失效。

参见：例程1


菜单是否已隐藏 方法 操作系统支持：Windows 所属对象：卷帘式菜单

判断指定菜单是否已被隐藏。如果菜单已被隐藏，返回“真”，否则返回“假”。如果指定菜单不存在，直接返回“假”。

语法： 逻辑型 卷帘式菜单．菜单是否已隐藏 （菜单索引）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。

例程：

说明：

通过“菜单是否已隐藏”命令判断指定菜单是否已被隐藏。

参见：例程1


隐藏菜单 方法 操作系统支持：Windows 所属对象：卷帘式菜单

隐藏或取消隐藏指定菜单。被隐藏的菜单不可见，且不可被设置为当前菜单。

语法： 逻辑型 卷帘式菜单．隐藏菜单 （菜单索引， 隐藏吗）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
隐藏吗 | 必需的； 逻辑型。如果本参数为“真”，表示隐藏菜单；如果本参数为“假”，表示取消隐藏菜单。

例程：

说明：

通过“隐藏菜单”命令使指定菜单不可视。

参见：例程1


项目是否已隐藏 方法 操作系统支持：Windows 所属对象：卷帘式菜单

判断指定项目是否已被隐藏。如果项目已被隐藏，返回“真”，否则返回“假”。如果指定项目不存在，直接返回“假”。

语法： 逻辑型 卷帘式菜单．项目是否已隐藏 （菜单索引， 项目索引）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
项目索引 | 必需的； 整数型。索引从 0 开始。

例程：

说明：

通过“项目是否已隐藏”命令判断指定菜单中指定项目是否处于隐藏状态。

参见：例程1


隐藏项目 方法 操作系统支持：Windows 所属对象：卷帘式菜单

隐藏或取消隐藏指定项目。

语法： 逻辑型 卷帘式菜单．隐藏项目 （菜单索引， 项目索引， 隐藏吗）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
项目索引 | 必需的； 整数型。索引从 0 开始。
隐藏吗 | 必需的； 逻辑型。如果本参数为“真”，表示隐藏项目；如果本参数为“假”，表示取消隐藏项目。

例程：

说明：

通过“隐藏项目”命令隐藏或取消隐藏指定菜单中指定的项目。

参见：例程1


取菜单提示文本 (卷帘式菜单)

取菜单提示文本 方法 操作系统支持：Windows 所属对象：卷帘式菜单

取指定菜单的提示文本。

语法： 文本型 卷帘式菜单．取菜单提示文本 （菜单索引）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。

例程

说明

取指定菜单的提示文本。

参考： 例程1


置菜单提示文本 (卷帘式菜单)

置菜单提示文本 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定菜单的提示文本。

语法： 逻辑型 卷帘式菜单．置菜单提示文本 （菜单索引， 提示文本）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
提示文本 | 必需的； 文本型。

例程

说明

设置指定菜单的提示文本。

参考： 例程1


取项目提示文本 (卷帘式菜单)

取项目提示文本 方法 操作系统支持：Windows 所属对象：卷帘式菜单

取指定项目的提示文本。

语法： 文本型 卷帘式菜单．取项目提示文本 （菜单索引， 项目索引）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
项目索引 | 必需的； 整数型。索引从 0 开始。

例程

说明

取指定项目的提示文本。

参考： 例程1


置项目提示文本 (卷帘式菜单)

置项目提示文本 方法 操作系统支持：Windows 所属对象：卷帘式菜单

设置指定项目的提示文本。

语法： 逻辑型 卷帘式菜单．置项目提示文本 （菜单索引， 项目索引， 提示文本）

参数名 | 描 述
菜单索引 | 必需的； 整数型。索引从 0 开始。
项目索引 | 必需的； 整数型。索引从 0 开始。
提示文本 | 必需的； 文本型。

例程

说明

设置指定项目的提示文本。

参考： 例程1


项目被选择 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户单击控件中的图标按钮时产生本事件。

语法： 无返回值 _卷帘式菜单_项目被选择 （菜单索引，项目索引）

参数名 | 描 述
菜单索引 | 必需的；整数型。
项目索引 | 必需的；整数型。

例程：

说明：

当卷帘式菜单中的项目被选择时，本事件将被触发。

参见：例程1


菜单被改变 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户单击控件中的分组按钮时产生本事件。

语法： 无返回值 _卷帘式菜单_菜单被改变 （菜单索引）

参数名 | 描 述
菜单索引 | 整数型；

例程：

说明：

当卷帘式菜单中的菜单被改变，既现行选中菜单被改变时，本事件将被触发。

参见：例程1


项目名称被改变 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户修改项目名称时产生本事件。返回假表示不允许修改，返回真或不返回值表示允许修改。

语法： 逻辑型 _卷帘式菜单_项目名称被改变 （项目文本）

参数名 | 描 述
项目文本 | 文本型；

例程：

说明：

当项目的名称将被改变时，本事件将触发。如果返回假，那么项目的名称将不被改变。

参见：例程1


菜单名称被改变 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户修改菜单名称时产生本事件。返回假表示不允许修改，返回真或不返回值表示允许修改。

语法： 逻辑型 _卷帘式菜单_菜单名称被改变 （菜单文本）

参数名 | 描 述
菜单文本 | 文本型；

例程：

说明：

当菜单名称将被改变时，本事件触发。如果返回假，将不会更改菜单的名称。

参见：例程1


菜单被单击 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户单击菜单时产生本事件。

语法： 无返回值 _卷帘式菜单_菜单被单击 （菜单索引）

参数名 | 描 述
菜单索引 | 整数型；

例程：

说明：

当卷帘式菜单中的菜单被单击时会触发此事件。

参见：例程1


菜单被右击 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户用鼠标右键单击菜单时产生本事件。

语法： 无返回值 _卷帘式菜单_菜单被右击 （菜单索引）

参数名 | 描 述
菜单索引 | 整数型；

例程：

说明：

当卷帘式菜单被右击时会触发此事件。

参见：例程1


项目被右击 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户用鼠标右键单击项目时产生本事件。

语法： 无返回值 _卷帘式菜单_项目被右击 （菜单索引， 项目索引）

参数名 | 描 述
菜单索引 | 整数型；
项目索引 | 整数型；

例程：

说明：

当卷帘式菜单中的项目被右击时会触发此事件。

参见：例程1


项目被双击 (卷帘式菜单)

项目被双击 事件 所属对象：卷帘式菜单 操作系统支持：Windows

当用户用鼠标左键双击项目时产生本事件。

语法： 无返回值 _卷帘式菜单_项目被双击 （菜单索引， 项目索引）

参数名 | 描 述
菜单索引 | 整数型；
项目索引 | 整数型；

例程：

说明：

当卷帘式菜单中的项目被双击时会触发此事件。

参见：例程1


高级选择夹

高级选择夹 容器型窗口组件 操作系统支持：Windows 跳至：扩展界面支持库三

不能接受输入焦点；

属性：

表头方向 | 允许多行表头 | 字体 | 子夹管理
现行子夹 | 隐藏表头 | 隐藏自身 | 子夹头高度
界面风格 | 表头样式 | 标题对齐方式 | 图标图片组
背景图片组 | 滚动按钮图片组 | 表头底色渐变 | 正常表头底色
点燃表头底色 | 选中表头底色 | 页面底色 | 边框颜色
正常标题颜色 | 点燃标题颜色 | 选中标题颜色 | 背景颜色
竖排子夹名称 | 显示隐藏子夹 | 启用禁止子夹 | 指定渐变起始色
正常渐变起始色 | 点燃渐变起始色 | 选中渐变起始色 | 页面区左边
页面区顶边 | 页面区宽度 | 页面区高度 |

方法：

加入子夹 | 删除子夹 | 取子夹数目 | 取子夹名称
置子夹名称 | 取子夹图标 | 置子夹图标 | 取子夹数值
置子夹数值 | 取子夹头底色 | 置子夹头底色 | 取子夹头底图
置子夹头底图 | 取子夹提示文本 | 置子夹提示文本 | 取子夹头区域
禁止子夹 | 子夹是否被禁止 | 隐藏子夹 | 子夹是否被隐藏

自有事件：

子夹被改变 | 将改变子夹 | 子夹头被单击 | 子夹头被点燃
子夹头被右击 |  |  |

基本事件：

鼠标左键被按下 | 鼠标左键被放开 | 被双击 | 鼠标右键被按下
鼠标右键被放开 | 鼠标位置被移动 | 获得焦点 | 失去焦点
按下某键 | 放开某键 | 字符输入 | 滚轮被滚动


表头方向 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、上
1、下
2、左
3、右

例程

说明：

设置高级选择夹的表头的方向

参见：例程


允许多行表头 属性 所属对象：新选择夹 操作系统支持：Windows

允许多行表头 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型；

例程

说明：

在选择夹宽度不足以完全显示所有子夹表头的标题时，用到此属性，可以更直观的看到所有子夹。

参见：例程


字体 属性 所属对象：新选择夹 操作系统支持：Windows

字体 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：字体；

例程

说明

设置高级选择夹的字体

参见：例程


子夹管理 属性 所属对象：新选择夹 操作系统支持：Windows

子夹管理 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：字节集；

例程

编辑子夹时的界面

说明：

如图所示：在选择夹中编辑了三个子夹，名称分别为“全中文”，“全可视”，“易语言”。

本属性只有设计时可用； 编辑各子夹的名称。

参见：例程


现行子夹 属性 所属对象：新选择夹 操作系统支持：Windows

现行子夹 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；本属性指定现行被选中子夹的索引，索引值从 0 开始。

将整数型数据赋值到指定对象的现行子夹属性中

语法： 对象.现行子夹 = 整数型

例程

说明：

本属性设计时不可用；本属性指定现行被选中子夹的索引，索引值从 0 开始。

参见：例程


隐藏表头 属性 所属对象：新选择夹 操作系统支持：Windows

隐藏表头 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型

例程

说明：

隐藏高级选择夹的表头

参见：例程


隐藏自身 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型；如果被属性为“真”，则整个控件背景以“背景颜色”填充，基本上让用户感觉不到选择夹控件的存在。

例程

说明

隐藏高级选择夹自身。

参见：例程


子夹头高度 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

例程

说明

设置高级选择夹的表头高度

参见：例程


界面风格 属性 所属对象：新选择夹 操作系统支持：Windows

界面风格 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、自定义风格
1、蓝色XP风格
2、绿色XP风格
3、银色XP风格

例程

说明：

设置高级选择夹的风格

参见：例程


表头样式 属性 所属对象：新选择夹 操作系统支持：Windows

表头样式 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；仅当自定义风格时有效。

可供选择的属性值：
0、矩形
1、梯形

例程

说明：

设置高级选择夹的表头样式

参见：例程


标题对齐方式 属性 所属对象：新选择夹 操作系统支持：Windows

标题对齐方式 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、居中
1、左对齐

例程

说明：

设置高级选择夹表头标题的对齐方式

参见：例程


图标图片组 属性 所属对象：新选择夹 操作系统支持：Windows

图标图片组 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：字节集；指定显示于子夹头中的图标图片。

例程

说明：

为高级选择夹添加图片组数据

参见：例程


背景图片组 属性 所属对象：新选择夹 操作系统支持：Windows

背景图片组 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：字节集；指定显示于子夹头中的背景图片。

例程：

说明：

为高级选择夹添加图片组数据

参见：例程


滚动按钮图片组 属性 所属对象：新选择夹 操作系统支持：Windows

滚动按钮图片组 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：字节集；自动使用其中的前8个图片，依次作为“左按钮正常”“左按钮点燃”“左按钮按下”“左按钮禁止”“右按钮正常”“右按钮点燃”“右按钮按下”“右按钮禁止”时的背景图片。图片组中单个图片的宽度和高度最好相等且在10到20象素之间为宜。如果本属性为空，将使用默认的滚动按钮背景图片(13x13)。

例程：

说明：

为高级选择夹添加图片组数据

参见：例程


表头底色渐变 属性 所属对象：新选择夹 操作系统支持：Windows

表头底色渐变 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型；

例程：

说明：

使高级选择夹的表头颜色渐变

参见：例程


正常表头底色 属性 所属对象：新选择夹 操作系统支持：Windows

正常表头底色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；子夹头未被选中也未被点燃时的背景颜色。

例程：

说明：

设置子夹头未被选中也未被点燃时的背景颜色

参见：例程


点燃表头底色 属性 所属对象：新选择夹 操作系统支持：Windows

点燃表头底色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；子夹头被点燃(鼠标指向子夹头区域)时的背景颜色。

例程：

说明：

设置子夹头被点燃(鼠标指向子夹头区域)时的背景颜色

参见：例程


选中表头底色 属性 所属对象：新选择夹 操作系统支持：Windows

选中表头底色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；子夹头被选中时的背景颜色。

例程：

说明：

设置子夹头被选中时的背景颜色

参见：例程


页面底色 属性 所属对象：新选择夹 操作系统支持：Windows

页面底色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型

例程

说明

设置高级选择夹的页面底色

参考：例程


边框颜色 属性 所属对象：新选择夹 操作系统支持：Windows

边框颜色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

例程

说明

设置高级选择夹的边框颜色

参考：例程


正常标题颜色 属性 所属对象：新选择夹 操作系统支持：Windows

正常标题颜色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；子夹未被选中也未被点燃时的标题文本颜色。

例程

说明

设置高级选择夹的正常标题颜色

参考：例程


点燃标题颜色 属性 所属对象：新选择夹 操作系统支持：Windows

点燃标题颜色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；子夹被点燃(鼠标指向子夹头区域)时的标题文本颜色。

例程

说明

设置高级选择夹的点燃标题颜色

参考：例程


选中标题颜色 属性 所属对象：新选择夹 操作系统支持：Windows

选中标题颜色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；子夹被选中时的标题文本颜色。

例程

说明

设置高级选择夹的选中标题颜色

参考：例程


背景颜色 属性 所属对象：新选择夹 操作系统支持：Windows

背景颜色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

例程

说明

设置高级选择夹的背景颜色

参考：例程


竖排子夹名称 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型； 是否使用类似于古籍中的竖排文本显示模式。本属性仅当表头在左右方向时有效。

例程

说明

高级选择夹表头文字竖排显示。

参见：例程


显示隐藏子夹 属性 所属对象：新选择夹 操作系统支持：Windows

显示隐藏子夹 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型；指定“在运行模式下”是否显示“所有被隐藏的”子夹(头)。在设计模式下，为方便用户操作，始终显示被隐藏的子夹。

例程

说明

这条命令需要和隐藏子夹命令配合使用

参考：例程


启用禁止子夹 属性 所属对象：新选择夹 操作系统支持：Windows

启用禁止子夹 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型；指定“在运行模式下”是否启用“所有被禁止的”子夹(头)。如果本属性为假，则运行模式下被禁止的子夹不响应鼠标单击事件。在设计模式下，为方便用户操作，始终启用被禁止的子夹。

例程

说明

这条命令需要和禁止子夹命令配合使用

参考：例程


指定渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：逻辑型；仅当“界面风格”属性为“0. 自定义风格”且“表头底色渐变”属性为真时有效。

例程：

说明：

指定渐变起始色为真或为假，注意，仅当“界面风格”属性为“0. 自定义风格”且“表头底色渐变”属性为真时有效。

参见:例程


指定渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

正常渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

改变正常渐变起始色，注意，仅当“界面风格”属性为“0. 自定义风格”且“表头底色渐变”属性为真时有效。

参见:例程


指定渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

点燃渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

改变点燃渐变起始色，注意，仅当“界面风格”属性为“0. 自定义风格”且“表头底色渐变”属性为真时有效。

参见:例程


指定渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

选中渐变起始色 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；

例程：

说明：

改变选中渐变起始色，注意，仅当“界面风格”属性为“0. 自定义风格”且“表头底色渐变”属性为真时有效。

参见:例程


页面区左边 属性 所属对象：新选择夹 操作系统支持：Windows

页面区左边 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；只读；相对组件自身窗口区域而言。

例程

说明

这个属性为只读属性，不能设置

参考：例程


页面区顶边 属性 所属对象：新选择夹 操作系统支持：Windows

页面区顶边 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；只读；相对组件自身窗口区域而言。

例程

说明

这个属性为只读属性，不能设置

参考：例程


页面区宽度 属性 所属对象：新选择夹 操作系统支持：Windows

页面区宽度 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；只读；

例程

说明

这个属性为只读属性，不能设置

参考：例程


页面区高度 属性 所属对象：新选择夹 操作系统支持：Windows

页面区高度 属性 所属对象：高级选择夹 操作系统支持：Windows

数据类型：整数型；只读；

例程

说明

这个属性为只读属性，不能设置

参考：例程


加入子夹 方法 操作系统支持：Windows 所属对象：高级选择夹

加入一个新的子夹。如果执行成功，返回新子夹的索引(子夹索引从0开始)，失败则返回-1。

语法： 整数型 高级选择夹．加入子夹 （子夹标题， ［子夹索引］， ［正常图标］， ［点燃图标］， ［选中图标］）

参数名 | 描 述
子夹标题 | 必需的； 文本型。
子夹索引 | 可选的； 整数型。指定欲加入的子夹所在位置。如果本参数省略或超出索引范围，将在所有子夹的最后加入新子夹。索引从0开始。
正常图标 | 可选的； 整数型。对应“图标图片组”属性中的图片索引，在正常情况下（子夹未被点燃也未被选中）显示在标题文本前面。如果省略或值为-1，表示不使用图标。
点燃图标 | 可选的； 整数型。对应“图标图片组”属性中的图片索引，在子夹被点燃（鼠标悬停）时显示在标题文本前面。如果省略或值为-1，将使用正常图标。
选中图标 | 可选的； 整数型。对应“图标图片组”属性中的图片索引，在子夹被选中时显示在标题文本前面。如果省略或值为-1，将使用正常图标。

例程

说明

加入新的子夹。

参见：例程


删除子夹 方法 操作系统支持：Windows 所属对象：高级选择夹

删除指定位置处的“动态加入的”子夹。注意：本方法只能删除使用“加入子夹()”动态加入的子夹，而不能删除在设计期加入的子夹。

语法： 逻辑型 高级选择夹．删除子夹 （子夹索引）

参数名 | 描 述
子夹索引 | 必需的； 整数型。指定欲删除的“动态加入的”子夹。子夹索引从0开始。

例程

说明

删除动态加入的子夹。

参见：例程1


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

取子夹数目 方法 操作系统支持：Windows 所属对象：高级选择夹

语法： 整数型 新选择夹．取子夹数目 （）

例程：

说明：

就是取出高级选择夹的所有子夹数目。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

取子夹名称 方法 操作系统支持：Windows 所属对象：高级选择夹

语法： 文本型 新选择夹．取子夹名称 （子夹索引）

参数名 | 描 述
子夹索引 | 必需的；整数型。子夹索引从0开始。

例程：

说明：

就是取出高级选择夹的子夹名称。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

置子夹名称 方法 操作系统支持：Windows 所属对象：高级选择夹

语法： 逻辑型 新选择夹．置子夹名称 （子夹索引，子夹名称）

参数名 | 描 述
子夹索引 | 必需的；整数型。子夹索引从0开始。
子夹名称 | 必需的；文本型。

例程：

说明：

就是改高级选择夹的某个子夹名称。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

取子夹图标 方法 操作系统支持：Windows 所属对象：高级选择夹

获取指定子夹的图标索引。

语法： 整数型 新选择夹．取子夹图标 （子夹索引，［正常图标］，［点燃图标］，［选中图标］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲取其图标的子夹。子夹索引从0开始。
正常图标 | 可选的；整数型，参数数据只能提供变量。用于接收正常图标在“图标图片组”属性中的图片索引。
点燃图标 | 可选的；整数型，参数数据只能提供变量。用于接收点燃图标在“图标图片组”属性中的图片索引。
选中图标 | 可选的；整数型，参数数据只能提供变量。用于接收选中图标在“图标图片组”属性中的图片索引。

例程：

说明：

就是取出高级选择夹的某个现行子夹的图标。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

置子夹图标 方法 操作系统支持：Windows 所属对象：高级选择夹

为指定子夹设置图标。

语法： 整数型 新选择夹．置子夹图标 （子夹索引，［正常图标］，［点燃图标］，［选中图标］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲设置图标的子夹。子夹索引从0开始。
正常图标 | 可选的；整数型。对应“图标图片组”属性中的图片索引，在正常情况下（子夹未被点燃也未被选中）显示。如果省略或值为-1，表示不使用图标。
点燃图标 | 可选的；整数型。对应“图标图片组”属性中的图片索引，在子夹被点燃（鼠标悬停）时显示。如果省略或值为-1，将使用正常图标。
选中图标 | 可选的；整数型。对应“图标图片组”属性中的图片索引，在子夹被选中时显示。如果省略或值为-1，将使用正常图标。

例程：

说明：

就是改高级选择夹的现行子夹的图标。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

取子夹数值 方法 操作系统支持：Windows 所属对象：高级选择夹

读取指定子夹中的自定义数值，该数值应事先以“置子夹数值()”写入。

语法： 整数型 新选择夹．取子夹数值 （子夹索引，［数值一］，［数值二］，［数值三］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲取其数值的子夹。子夹索引从0开始。
数值一 | 可选的；整数型，参数数据只能提供变量。用于接收数值一。
数值二 | 可选的；整数型，参数数据只能提供变量。用于接收数值二。
数值三 | 可选的；整数型，参数数据只能提供变量。用于接收数值三。

例程：

说明：

就是取出高级选择夹的现行子夹的数值。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

置子夹数值 方法 操作系统支持：Windows 所属对象：高级选择夹

为指定子夹头设置自定义数值。该数值仅供用户在程序运行期使用。

语法： 整数型 新选择夹．置子夹数值 （子夹索引，［数值一］，［数值二］，［数值三］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲设置其数值的子夹。子夹索引从0开始。
数值一 | 可选的；整数型。如果省略，默认为0。
数值二 | 可选的；整数型。如果省略，默认为0。
数值三 | 可选的；整数型。如果省略，默认为0。

例程：

说明：

就是改写高级选择夹的现行子夹的数值。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

取子夹头底色 方法 操作系统支持：Windows 所属对象：高级选择夹

读取指定子夹的子夹头底色。

语法： 整数型 新选择夹．取子夹头底色 （子夹索引，［正常底色］，［点燃底色］，［选中底色］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲取其子夹头底色的子夹。子夹索引从0开始。
正常底色 | 可选的；整数型，参数数据只能提供变量。用于接收正常底色。
点燃底色 | 可选的；整数型，参数数据只能提供变量。用于接收点燃底色。
选中底色 | 可选的；整数型，参数数据只能提供变量。用于接收选中底色。

例程：

说明：

就是取出高级选择夹的现行子夹头的底色。

参见：例程


子夹被改变 事件 所属对象：新选择夹 操作系统支持：Windows

置子夹头底色 方法 操作系统支持：Windows 所属对象：高级选择夹

为指定子夹的子夹头设置底色。每个子夹都可以分别设置不同的子夹头底色。没有调用本方法设置底色的子夹，将使用“子夹头正常底色”“子夹头点燃底色”“子夹头选中底色”等属性所指定的颜色。

语法： 整数型 新选择夹．置子夹头底色 （子夹索引，正常底色，［点燃底色］，［选中底色］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲设置其子夹头底色的子夹。子夹索引从0开始。
正常底色 | 必需的；整数型。在子夹未被点燃也未被选中时显示。
点燃底色 | 可选的；整数型。在子夹被点燃（鼠标在子夹头区域）时显示。如果省略，则显示正常底色。
选中底色 | 可选的；整数型。在子夹被选中时显示。如果省略，则显示正常底色。

例程：

说明：

就是改高级选择夹的现行子夹头的底色。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

取子夹头底图 方法 操作系统支持：Windows 所属对象：高级选择夹

获取指定子夹头的背景图片索引。

语法： 整数型 新选择夹．取子夹头底图 （子夹索引，［正常底图］，［点燃底图］，［选中底图］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲取其背景图片的子夹。子夹索引从0开始。
正常底图 | 可选的；整数型，参数数据只能提供变量。用于接收正常底图在“背景图片组”属性中的图片索引。
点燃底图 | 可选的；整数型，参数数据只能提供变量。用于接收点燃底图在“背景图片组”属性中的图片索引。
选中底图 | 可选的；整数型，参数数据只能提供变量。用于接收选中底图在“背景图片组”属性中的图片索引。

例程：

说明：

就是取高级选择夹的现行子夹头的底图。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

置子夹头底图 方法 操作系统支持：Windows 所属对象：高级选择夹

为指定子夹头设置背景图片。

语法： 整数型 新选择夹．置子夹头底图 （［子夹索引］，［正常底图］，［点燃底图］，［选中底图］）

参数名 | 描 述
子夹索引 | 可选的；整数型。指定欲设置背景图片的子夹。子夹索引从0开始。如果省略，或值为-1，将为所有现有子夹设置子夹头底图。
正常底图 | 可选的；整数型。对应“背景图片组”属性中的图片索引，在正常情况下（子夹未被点燃也未被选中）显示。如果省略或值为-1，表示不使用底图。
点燃底图 | 可选的；整数型。对应“背景图片组”属性中的图片索引，在子夹被点燃（鼠标悬停）时显示。如果省略或值为-1，将使用正常底图。
选中底图 | 可选的；整数型。对应“背景图片组”属性中的图片索引，在子夹被选中时显示。如果省略或值为-1，将使用正常底图。

例程：

说明：

就是改高级选择夹的现行子夹头的底图。

参见：例程


取子夹提示文本 (高级选择夹)

取子夹提示文本 方法 操作系统支持：Windows 所属对象：高级选择夹

取指定子夹的提示文本。

语法： 文本型 高级选择夹．取子夹提示文本 （子夹索引）

参数名 | 描 述
子夹索引 | 必需的； 整数型。指定欲取其提示文本的子夹。子夹索引从0开始。

例程

说明

取指定子夹的提示文本。

参考： 例程1


置子夹提示文本 (高级选择夹)

置子夹提示文本 方法 操作系统支持：Windows 所属对象：高级选择夹

设置指定子夹的提示文本。

语法： 逻辑型 高级选择夹．置子夹提示文本 （子夹索引， 提示文本）

参数名 | 描 述
子夹索引 | 必需的； 整数型。指定欲设置其提示文本的子夹。子夹索引从0开始。
提示文本 | 必需的； 文本型。

例程

说明

设置指定子夹的提示文本。

参考： 例程1


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

取子夹头区域 方法 操作系统支持：Windows 所属对象：高级选择夹

获取指定子夹的子夹头区域，如果“子夹索引”参数省略或值为-1，则取表头区域。结果将写入后面四个参数中。

语法： 整数型 新选择夹．取子夹头区域 （子夹索引，［左边］，［顶边］，［宽度］，［高度］）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲取其图标的子夹。子夹索引从0开始。
左边 | 可选的；整数型，参数数据只能提供变量。相对于窗口客户区域。
顶边 | 可选的；整数型，参数数据只能提供变量。相对于窗口客户区域。
宽度 | 可选的；整数型，参数数据只能提供变量。
高度 | 可选的；整数型，参数数据只能提供变量。

例程：

说明：

就是取出高级选择夹的现行子夹头的左边位置、顶边位置、宽度、高度。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

禁止子夹 方法 操作系统支持：Windows 所属对象：高级选择夹

禁止或取消禁止指定子夹。被禁止的子夹将不接受鼠标点击，但可以通过“现行子夹”属性将其设置为当前子夹。

语法： 逻辑型 新选择夹．禁止子夹 （［子夹索引］，是否禁止）

参数名 | 描 述
子夹索引 | 可选的；整数型。指定欲禁止的子夹。子夹索引从0开始。如果本参数被省略或值为-1，表示禁止当前子夹。
是否禁止 | 必需的；逻辑型，初始值为“真”。指定禁止还是取消禁止子子夹。

例程：

说明：

就是禁止单击高级选择夹的子夹。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

子夹是否被禁止 方法 操作系统支持：Windows 所属对象：高级选择夹

查询指定子夹是否被禁止。

语法： 逻辑型 新选择夹．子夹是否被禁止 （［子夹索引］）

参数名 | 描 述
子夹索引 | 可选的；整数型。指定欲禁止的子夹。子夹索引从0开始。如果本参数被省略或值为-1，表示针对当前子夹。

例程：

说明：

就是判断高级选择夹的某个子夹是否被禁止。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

隐藏子夹 方法 操作系统支持：Windows 所属对象：高级选择夹

隐藏或取消隐藏指定子夹。注意：1、把“显示隐藏子夹”属性设置为“真”，仍然可将“被隐藏的子夹”显示出来；2、不允许隐藏当前子夹。

语法： 逻辑型 新选择夹．隐藏子夹 （子夹索引，是否隐藏）

参数名 | 描 述
子夹索引 | 必需的；整数型。指定欲隐藏的子夹。
是否隐藏 | 必需的；逻辑型，初始值为“真”。指定隐藏还是取消隐藏子子夹。

例程：

说明：

就是隐藏高级选择夹的某个子夹。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

子夹是否被隐藏 方法 操作系统支持：Windows 所属对象：高级选择夹

查询指定子夹是否被隐藏，返回上一次针对该子夹调用“隐藏子夹”所设置的值。

语法： 逻辑型 新选择夹．子夹是否被隐藏 （［子夹索引］）

参数名 | 描 述
子夹索引 | 可选的；整数型。子夹索引从0开始。如果本参数被省略或值为-1，表示针对当前子夹。

例程：

说明：

就是判断高级选择夹的某个子夹是否被隐藏。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

当子夹被改变时产生本事件。

语法： 无返回值 _新选择夹_子夹被改变 （）

例程：

说明：

就是说当子夹被改变以后就执行下列代码。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

将改变子夹 事件 所属对象：高级选择夹 操作系统支持：Windows

当将要改变子夹时产生本事件，注意此时还没有切换到新的子夹。事件参数“子夹索引”标识了将要被切换到的子夹。如果返回“假”表示不允许切换到新的子夹，返回“真”或不返回值表示允许切换。

语法： 逻辑型 _新选择夹_将改变子夹 （子夹索引）

参数名 | 描 述
子夹索引 | 整数型；

例程：

说明：

就是说当子夹没被改变，但将被改变的时候，就执行下列代码。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

子夹头被单击 事件 所属对象：高级选择夹 操作系统支持：Windows

当用户单击子夹头时产生本事件，注意此时还没有切换到新的子夹。事件参数“子夹索引”标识了被单击的子夹。

语法： 无返回值 _新选择夹_子夹头被单击 （子夹索引）

参数名 | 描 述
子夹索引 | 整数型；

例程：

说明：

就是说当选择夹的子夹被单击以后就执行下列代码。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

子夹头被点燃 事件 所属对象：高级选择夹 操作系统支持：Windows

当鼠标第一次移动到子夹头区域时产生本事件。事件参数“子夹索引”标识了被点燃的子夹。

语法： 无返回值 _新选择夹_子夹头被点燃 （子夹索引）

参数名 | 描 述
子夹索引 | 整数型；

例程：

说明：

就是说当鼠标移动到选择夹的子夹上以后就执行下列代码。

参见：例程


子夹被改变 事件 所属对象：高级选择夹 操作系统支持：Windows

子夹头被右击 事件 所属对象：高级选择夹 操作系统支持：Windows

当用户用鼠标右键单击子夹头时产生本事件。事件参数“子夹索引”标识了被右击的子夹。

语法： 无返回值 _新选择夹_子夹头被右击 （子夹索引）

参数名 | 描 述
子夹索引 | 整数型；

例程：

说明：

就是说当选择夹的子夹被右键单击以后就执行下列代码。

参见：例程


常量 | 常量值 | 描 述
#支持库代号 | “iext3” | 文本型


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。

参见：例程