互联网支持库

互联网支持库 帮助手册20080811版 返回支持库手册 返回首页

本支持库用作实现对常用互联网际协议的支持，如SMTP、HTTP、FTP等。

操作系统支持： Windows

命令类别：

邮件发送

HTTP及FTP操作

拨号上网

例程列表：

例程名称 | 下载 | 说明
下载HTTP文件 | 下载HTTP文件.e | 本程序能够将指定HTTP地址处的网页下载到本地后阅读,演示了互联网支持库中的HTTP类命令及超文本浏览框的使用方法.
拨号上网 | 拨号上网.e | 本程序演示了如何在程序中直接拨号上网.
易之FTP | 易之FTP.e | 本程序演示了互联网支持库中的FTP类命令和扩展界面支持库一中的报表型超级列表框的使用方法.
易邮件发送器 | 易邮件发送器.e | 本程序用作演示邮件发送类命令的使用方法。

适用版本，互联网支持库 （1.0#51版）


邮件发送

邮件发送 类别 跳至：互联网支持库


连接发信服务器 命令 所属类别：邮件发送

连接发信服务器 命令 操作系统支持：Windows 所属类别：邮件发送

连接到指定的SMTP邮件发送服务器，成功返回真，失败返回假。

语法： 逻辑型 连接发信服务器 （发信邮件服务器地址，［端口号］，［用户名］，［密码］，［最长等待时间］）

参数名 | 描 述
发信邮件服务器地址 | 必需的；文本型。指定用作发送邮件的SMTP邮件服务器地址。
端口号 | 可选的；整数型。指定欲连接到SMTP邮件服务器上的端口号，如果本参数被省略，默认值为标准 25 端口。
用户名 | 可选的；文本型。指定在SMTP邮件服务器上的用户帐号名称，如果本参数被省略，默认值为空文本，即无需登录。
密码 | 可选的；文本型。指定在SMTP邮件服务器上的用户帐号密码，如果本参数被省略，默认值为空文本，即无需登录。
最长等待时间 | 可选的；整数型。指定在发信过程中等待SMTP邮件服务器响应的最大时间，单位为毫秒，如果本参数被省略，默认值为 2000 毫秒。

例程

说明：

根据邮件的服务器地址，端口，用户名，密码连接邮件服务器。

参见：例程


断开发信服务器 命令 所属类别：邮件发送

断开发信服务器 命令 操作系统支持：Windows 所属类别：邮件发送

断开通过“连接发信服务器”命令建立的到SMTP邮件发送服务器的连接。

语法： 无返回值 断开发信服务器 （）

例程

说明：

断开与发信服务器的连接。

参见：例程


添加附件文件 命令 所属类别：邮件发送

添加附件文件 命令 操作系统支持：Windows 所属类别：邮件发送

添加指定的文件附件到即将发送的邮件中，成功返回真，失败返回假。

语法： 逻辑型 添加附件文件 （欲添加的附件文件）

参数名 | 描 述
欲添加的附件文件 | 必需的；文本型。

例程

说明：

通过附加对话框选择要添加到邮件中的文件。

参见：例程


添加附件数据 命令 所属类别：邮件发送

添加附件数据 命令 操作系统支持：Windows 所属类别：邮件发送

添加附件数据到即将发送的邮件中，成功返回真，失败返回假。

语法： 逻辑型 添加附件数据 （欲添加的附件数据，附件标题）

参数名 | 描 述
欲添加的附件数据 | 必需的；字节集。
附件标题 | 必需的；文本型。

例程

说明：

用读入文件命令读入的字节集文件，放入到附件数据中。

参见：例程


清除所有附件 命令 所属类别：邮件发送

清除所有附件 命令 操作系统支持：Windows 所属类别：邮件发送

清除所有使用“添加附件文件”和“添加附件数据”命令添加到即将发送邮件中的附件数据。

语法： 无返回值 清除所有附件 （）

  例程

说明：

清除所有附带在邮件上的数据和文件。

参见：例程


发送邮件 命令 所属类别：邮件发送

发送邮件 命令 操作系统支持：Windows 所属类别：邮件发送

发送邮件到指定信箱，注意邮件中包含所有使用“添加附件文件”和“添加附件数据”命令添加的附件。成功返回空文本，失败返回具体错误信息文本。

语法： 文本型 发送邮件 （主题，正文，收信人邮件地址，［抄送邮件地址］，［暗送邮件地址］，发信人邮件地址，［回复邮件地址］）

参数名 | 描 述
主题 | 必需的；文本型。
正文 | 必需的；文本型。
收信人邮件地址 | 必需的；文本型。可以为地址列表并包括友好名称，示例如：“吴涛〈fly@eyuyan.com〉;易语言俱乐部〈club@eyuyan.com〉” 或：“fly@eyuyan.com;club@eyuyan.com”都可以，多地址之间用逗号或分号分隔，友好名称后的邮件地址用半角尖括号括住。
抄送邮件地址 | 可选的；文本型。地址格式等同于“收信人邮件地址”，如果本参数被省略，默认为空文本。
暗送邮件地址 | 可选的；文本型。地址格式等同于“收信人邮件地址”，如果本参数被省略，默认为空文本。
发信人邮件地址 | 必需的；文本型。只能为单个邮件地址，可以包括友好名称，示例如：“吴涛〈fly@eyuyan.com〉”或“fly@eyuyan.com”。
回复邮件地址 | 可选的；文本型。指定收件人回复此邮件的地址。如果被省略，默认为与发信人邮件地址相同。

例程

说明：

连接服务器，发送电子邮件

参见：例程


HTTP及FTP操作

HTTP及FTP操作 类别 跳至：互联网支持库

置代理服务器 | HTTP读文件 | 连接FTP服务器 | 断开FTP服务器
FTP文件下载 | FTP文件上传 | FTP删除文件 | FTP文件改名
FTP创建目录 | FTP删除目录 | FTP置现行目录 | FTP取现行目录
FTP目录列表 |  |  |


置代理服务器 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

设置在以后HTTP及FTP互联网操作中所使用代理服务器的名称。

语法： 无返回值 置代理服务器 （［代理服务器名称］）

参数名 | 描 述
代理服务器名称 | 可选的；文本型。如果要取消代理服务器设置，请提供空文本。如果本参数被省略，默认值为空文本。

例程

说明

通过“置代理服务器”命令来设置代理服务器和取消使用代理服务器。

参考：例程1


HTTP读文件 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

获取互联网上指定HTTP地址处的网页或数据文件，返回文件内容字节集。

语法： 字节集 HTTP读文件 （HTTP文件地址）

参数名 | 描 述
HTTP文件地址 | 必需的；文本型。本参数指定欲读取文件在互联网上的HTTP地址（即URL）。

例程

说明

通过“HTTP读文件”命令读出http://www.dywt.com.cn/net/licheng.txt，写入到文本内容中。

参考：例程1


连接FTP服务器 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

连接到互联网上指定地址处的FTP服务器。在进行所有FTP操作之前必须首先成功连接FTP服务器。成功返回真，失败返回假。

语法： 逻辑型 连接FTP服务器 （FTP服务器地址，［用户名］，［密码］，［端口号］，［是否使用被动语义］）

参数名 | 描 述
FTP服务器地址 | 必需的；文本型。本参数指定FTP服务器在互联网上的地址。
用户名 | 可选的；文本型。本参数提供用作通过FTP服务器用户验证的用户名称，如果被省略，默认值为匿名用户名“anonymous”。
密码 | 可选的；文本型。本参数提供用作通过FTP服务器用户验证的密码，如果被省略，默认值为空文本。
端口号 | 可选的；整数型。本参数提供欲连接到FTP服务器上的端口号，如果被省略，默认值为标准端口 21 。
是否使用被动语义 | 可选的；逻辑型。如果本参数被省略，默认值为假。

例程

说明

通过“连接FTP服务器”命令来连接指定的FTP地址。通常FTP的端口号都是21。

参考：例程1


断开FTP服务器 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

断开通过“连接FTP服务器”命令建立的到互联网上FTP服务器的连接，本命令执行后不能再进行FTP操作。

语法： 无返回值 断开FTP服务器 （）

例程

说明

通过“断开FTP服务器”命令断开与已连接的FTP服务器的连接。如果要再次操作FTP需要使用“连接FTP服务器”命令从新连接。

参考：例程1


FTP文件下载 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作将FTP服务器上的指定文件下载到本地，成功返回真，失败返回假

FTP文件下载 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

将FTP服务器上的指定文件下载到本地，成功返回真，失败返回假。

语法： 逻辑型 FTP文件下载 （欲下载的FTP文件，本地文件名，［是否使用ASCII码方式］）

参数名 | 描 述
欲下载的FTP文件 | 必需的；文本型。本参数指定在FTP服务器上欲下载文件的路径。
本地文件名 | 必需的；文本型。本参数指定被下载文件的本地保存位置。
是否使用ASCII码方式 | 可选的；逻辑型。指定是否使用ASCII编码方式传递文件数据。如果本参数被省略，默认值为假，即使用二进制方式传送。

例程

说明

通过“FTP文件下载”命令从已连接的FTP服务器下载指定文件,将下载的文件保存为和“保存文件对话框”的“文件名”属性相同的文件名。

参考：例程1


FTP文件上传 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

将本地文件上传到FTP服务器上的指定位置，成功返回真，失败返回假。

语法： 逻辑型 FTP文件上传 （欲上传的本地文件，保存文件名，［是否使用ASCII码方式］）

参数名 | 描 述
欲上传的本地文件 | 必需的；文本型。本参数指定欲上传到FTP服务器上本地文件的路径。
FTP文件路径 | 必需的；文本型。本参数指定上传到FTP服务器上文件的保存文件名。
是否使用ASCII码方式 | 可选的；逻辑型。指定是否使用ASCII编码方式传递文件数据。如果本参数被省略，默认值为假，即使用二进制方式传送。

例程

说明

使用打开文件对话框打开一个文件，通过“FTP文件上传”命令将此文件上传到已连接的FTP服务器的当前目录下。

参考：例程1


FTP删除文件 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

删除FTP服务器上的指定文件。成功返回真，失败返回假。

语法： 逻辑型 FTP删除文件 （欲删除的FTP文件）

参数名 | 描 述
欲删除的FTP文件 | 必需的；文本型。本参数指定在FTP服务器上欲删除文件的路径。

例程

说明

通过“FTP删除文件命令”删除已连接FTP服务器的当前目录下的文件名为和通过“文件列表框”的“取标题”命令返回的文本相同的文件名。

参考：例程1


FTP文件改名 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

更改FTP服务器上指定文件的名称。成功返回真，失败返回假。

语法： 逻辑型 FTP文件改名 （欲改名的FTP文件，新文件名称）

参数名 | 描 述
欲改名的FTP文件 | 必需的；文本型。本参数指定FTP服务器上欲改名文件的路径。
新文件名称 | 必需的；文本型。本参数指定欲改为的文件名称。

例程

说明

通过“FTP文件改名”命令将已连接的FTP服务器的当前目录下的文件名和使用取标题取回的文本相同的文件更名为与文件列表框的结束编辑文本相同的名称。

参考：例程1


FTP创建目录 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

在FTP服务器上指定位置处创建新的目录。成功返回真，失败返回假。

语法： 逻辑型 FTP创建目录 （FTP目录路径）

参数名 | 描 述
FTP目录路径 | 必需的；文本型。

例程

说明

通过“FTP创建目录”命令在已连接的FTP服务器的当前目录中创建一个目录名和“新目录名”变量中保存的文本相同的新目录。

参考：例程1


FTP删除目录 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

删除FTP服务器上的指定目录。成功返回真，失败返回假。

语法： 逻辑型 FTP删除目录 （FTP目录路径）

参数名 | 描 述
FTP目录路径 | 必需的；文本型。

例程

说明

通过“FTP删除目录”命令删除已连接的FTP服务器的当前目录下的目录名为使用“文件列表框”的“取标题”命令返回的目录名。

参考：例程1


FTP置现行目录 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

设置FTP服务器上的当前目录，设置后可以在其他FTP命令中使用相对路径来指定文件。成功返回真，失败返回假。

语法： 逻辑型 FTP置现行目录 （FTP目录路径）

参数名 | 描 述
FTP目录路径 | 必需的；文本型。

例程

说明

通过“FTP置现行目录”命令设置已连接的FTP当前目录为使用“文件列表框”的“取标题”命令返回的文本。

参考：例程1


FTP取现行目录 命令 操作系统支持：Windows 所属类别：所属类别：HTTP及FTP操作

返回FTP服务器上的当前目录。成功返回目录路径，失败返回空文本。

语法： 文本型 FTP取现行目录 （）

例程

说明

通过“FTP取先行目录”命令取得已连接的FTP服务器的当前目录保存在当前目录变量中。

参考：例程1


FTP目录列表 命令 操作系统支持：Windows 所属类别：HTTP及FTP操作

返回FTP服务器上指定目录内的所有匹配文件和子目录信息。成功返回被找到的文件和子目录的数目，失败返回 0 。

语法： 整数型 FTP目录列表 （欲列出的文件，［欲列出文件的属性］，［存放文件名的数组变量］，［存放文件属性的数组变量］，［存放文件尺寸的数组变量］，［存放文件时间的数组变量］）

参数名 | 描 述
欲列出的文件 | 必需的；文本型。可以包含路径，可以使用多字符 (*) 和单字符 (?) 通配符来指定多重文件及目录。
欲列出文件的属性 | 可选的；整数型。参数值可以为以下常量值或其和： 1、#只读文件； 2、#隐藏文件； 4、#系统文件； 16、#子目录； 32、#存档文件 。通过将这些常量值加起来可以一次设置多个文件属性。如果省略本参数，默认为搜寻所有子目录和文件。
存放文件名的数组变量 | 可选的；文本型，参数数据只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件和子目录名称。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为所找到的文件数目。如果本参数被省略，默认值为空。
存放文件属性的数组变量 | 可选的；整数型，参数数据只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件的属性，并与文件名数组成员一一对应。此属性值由以下常量或其和构成： 1、#只读文件； 2、#隐藏文件； 4、#系统文件； 16、#子目录；32、#存档文件 。要判断是否设置了某个属性，在返回值与想要得知的属性值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示设置了这个属性值。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为所找到的文件数目。如果本参数被省略，默认值为空。
存放文件尺寸的数组变量 | 可选的；整数型，参数数据只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件的尺寸，并与文件名数组成员一一对应。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为所找到的文件数目。如果本参数被省略，默认值为空。
存放文件时间的数组变量 | 可选的；日期时间型，参数数据只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件的最后修改时间，并与文件名数组成员一一对应。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为所找到的文件数目。如果本参数被省略，默认值为空。

例程

说明

通过“FTP目录列表”命令取出所有文件（包括目录）的信息，分别存放在对应的变量中。

参考：例程1


拨号上网

拨号上网 类别 跳至：互联网支持库


取拨号连接数 命令 所属类别：拨号上网

取拨号连接数 命令 操作系统支持：Windows 所属类别：拨号上网

返回用户在Windows系统中已建立的拨号连接配置数目。

语法： 整数型 取拨号连接数 （）

例程

说明：

取得系统中的拨号连接的数量。

参见：例程


取连接名称 命令 所属类别：拨号上网

取连接名称 命令 操作系统支持：Windows 所属类别：拨号上网

返回指定拨号连接配置的名称。

语法： 文本型 取连接名称 （拨号网络索引）

参数名 | 描 述
拨号网络索引 | 必需的；整数型。指定获取哪一个拨号网络配置信息，索引值从 0 开始，最大值为“取拨号连接数”命令的返回值减一。

例程

说明：

根据取得的拨号连接的数量，依次取得拨号连接数对应的名称，放到配置组合框中，以备调用。

参见：例程


取用户帐号 命令 所属类别：拨号上网

取用户帐号 命令 操作系统支持：Windows 所属类别：拨号上网

返回指定拨号连接配置所使用的用户帐号名称。

语法： 文本型 取用户帐号 （拨号网络索引）

参数名 | 描 述
拨号网络索引 | 必需的；整数型。指定获取哪一个拨号网络配置信息，索引值从 0 开始，最大值为“取拨号连接数”命令的返回值减一。

例程

说明：

根据配置组合框的现行选中的项目索引取得用户的帐号。

参见：例程


拨号 命令 所属类别：拨号上网

拨号 命令 操作系统支持：Windows 所属类别：拨号上网

开始拨号并试图建立网络连接。成功返回真，失败返回假。注意如果“是否等待连接完毕”参数为假，则即使本命令返回真，也并不意味着马上就可以使用该网络连接，必须等到“是否已在线”命令返回真时才可以。如果“是否等待连接完毕”参数为真，则本命令会一直等待到连接操作执行完毕后才会返回。另外，建议在执行本命令前调用“是否已在线”命令查看当前是否已经连接到网络上，如果已经连接，则不需要再执行本命令。

语法： 逻辑型 拨号 （电话号码，用户帐号，帐号密码，［是否等待连接完毕］，［状态标签］）

参数名 | 描 述
电话号码 | 必需的；文本型。指定欲拨出的电话号码，如果欲使用已经存在的用户拨号网络配置中的电话号码，请使用“@n”格式文本，其中n为指定拨号网络配置的索引数值，从0开始。如：拨号 (“@0”, ...) 即使用第一个拨号网络配置中的电话号码拨号。
用户帐号 | 必需的；文本型。指定用户帐号名称。
帐号密码 | 必需的；文本型。指定用户帐号的密码。
是否等待连接完毕 | 可选的；逻辑型。指定命令是否一直等到连接完毕（成功或失败）后才返回，如果本参数为真，则“状态标签”参数无效。如果本参数被省略，默认值为假。
状态标签 | 可选的；标签。如果提供了一个已经存在的标签型窗口单元并且“是否等待连接完毕”参数为假，拨号过程中的状态文本将即时显示到该标签上。如果本参数被省略，默认值为空。

例程

说明：

根据电话号码，用户名，帐号密码等拨号上网。在拨号前，应该先判断网络是否已连接上；拨号后要想知道是否已连接上，必须让“是否等待连接完毕”参数为真。

参见：例程


是否已在线 命令 所属类别：拨号上网

是否已在线 命令 操作系统支持：Windows 所属类别：拨号上网

如果当前已经存在可用的网络连接(即已连接到网络上)，返回真，否则返回假。

语法： 逻辑型 是否已在线 （）

例程

说明：

判断网络是否已经连接。

参见：例程


挂断 命令 所属类别：拨号上网

挂断 命令 操作系统支持：Windows 所属类别：拨号上网

挂断当前拨号网络连接。一旦不再需要拨号网络连接，就可以使用本命令将连接断开。

语法： 无返回值 挂断 （）

例程

说明：

断开当前的网络连接。

参见：例程