系统核心支持库

系统核心支持库 帮助手册20080812版 返回支持库手册 返回首页

本支持库是易语言的核心库，为系统本身和每个易程序提供必需的功能支持。

操作系统支持： Windows、Linux

命令类别：

流程控制 | 算术运算 | 逻辑比较 | 位运算
变量操作 | 数组操作 | 环境存取 | 拼音处理
文本操作 | 字节集操作 | 数值转换 | 时间操作
磁盘操作 | 文件读写 | 系统处理 | 媒体播放
程序调试 | 其他 | 数据库 | 网络通信
控制台操作 |  |  |

窗口组件数据类型：

窗口 | 编辑框 | 图片框 | 外形框
画板 | 分组框 | 标签 | 按钮
选择框 | 单选框 | 组合框 | 列表框
选择列表框 | 横向滚动条 | 纵向滚动条 | 进度条
滑块条 | 选择夹 | 影像框 | 日期框
月历 | 驱动器框 | 目录框 | 文件框
颜色选择器 | 超级链接框 | 调节器 | 通用对话框
时钟 | 打印机 | 数据报 | 客户
服务器 | 端口 | 表格 | 数据源
通用提供者 | 数据库提供者 | 图形按钮 | 外部数据库
外部数据提供者 |  |  |

其它数据类型：

菜单 | 字体 | 字段信息 | 打印设置信息
对象 | 变体型 | 变体类型 |

常量表...

例程列表：

例程名称 | 下载 | 说明
ACCESS数据库备注及二进制字段读写示例 | ACCESS数据库备注及二进制字段读写.e | 本程序演示了对ACCESS数据库的备注及二进制字段内容进行读写的方法. 注意:本程序用作示范相关编程技术,仅仅用作阅读.由于您的计算机上不包含相应的附属文件,因此执行将不会成功.
MP3 播放者 | mp3播放者.e | 本程序能够自动搜寻并播放指定驱动器内内所有的 MP3 音乐文件。
一步一步跟我学写易程序一 | 一步一步跟我学写易程序一.e 学生情况.edb 学生情况.EDT 一步一步跟我学写易程序一.doc | 本程序通过一个简单的学生管理程序来演示如何学写易程序。
一步步跟我学写易程序二 | 一步一步跟我学写易程序二.e 学生情况.edb 学生情况.EDT 密码.edb 系统日志.edb 一步一步跟我学写易程序二.doc | 本程序通过一个简单的学生管理程序来演示如何学写易程序，是一步一步<<跟我学写易程序一>>的后续程序。
位运算类命令演示 | 位操作类命令.e | 演示所有位运算类命令的使用方法
超级方块 | 俄罗斯方块.e | 这是一个由吴涛编写的专业级俄罗斯方块游戏，共有 15 关，要打通这 15 关绝对不容易。它一定会让你流连忘返！另外：运行前请将想在游戏过程中听的所有 MIDI 音乐文件放到与此程序相同的目录中。
全面操作MS_Access数据库 | 全面操作Access数据库.e MSAccess.mdb | 本程序演示如何在易语言中借助“外部数据库”控件，通过ODBC操纵Microsoft Access数据库。支持记录的查询、排序、删除、添加、更新，及创建、删除表的操作。本程序同时为用户提供了一个良好的SQL语言的学习环境。 具体教程请见随系统附带的"ACCESS数据库使用详解.doc"文件. 作者：Liigo 2002/4/1 Liigo@chinaren.com http://Liigo.yeah.net
加解密工具 | 加解密工具.e | 本程序用作测试“打开加密文件”命令，并且具有实际应用价值。
向导 | 动态显示单元群.e | 演示了在同一位置动态显示数个单元群的技术。
变量操作类命令演示 | 变量操作命令.e | 演示所有变量操作类命令的使用方法
图形按钮示例 | 图形按钮.e | 本程序演示了如何创建图形按钮
好友录 | 好友录.e | 本程序使用易语言数据库功能编写了一个简单的好友管理程序，里面使用了数据库的增加、删除、查找、定位等功能，你可以进一步完善她。
学生管理系统 | 学生管理系统.e base.grd 体育.edb 体育.edt 化学.edb 化学.edt 历史.edb 历史.edt 地理.edb 地理.edt 学生.edb 学生.edt 政治.edb 政治.edt 数学.edb 数学.edt 物理.edb 物理.edt 生物.edb 生物.edt 英文.edb 英文.edt 计算机.edb 计算机.edt 语文.edb 语文.edt 音乐.edb 音乐.edt | 本程序通过一个较实用的学生管理系统来说明数据库程序的编写方法,内含报表的查询、打印、打印预览功能的实现。
基于连接的客户机测试 | 客户机测试.e |
托盘图标支持演示 | 托盘图标.e | 在本例程中可以学习到如何在系统托盘中加入并控制自己的图标。
拼音处理类命令演示 | 拼音类命令.e | 演示所有拼音处理类命令的使用方法
数据报测试 | 数据报.e | 使用方法：在多台机器上同时运行本程序，它们之间可以相互通信或广播。
数据绑定演示 | 数据绑定.e people.edb people.edt | 本例程序演示数据绑定的使用方法
数组操作类命令演示 | 数组类命令.e | 演示所有数组操作类命令的使用方法
文本操作类命令演示 | 文本操作命令.e | 演示所有文本操作类命令的使用方法
新年快乐 | 新年好.e | 一个具有图片外形的窗口，其外形图片在“#图片1”资源中。
语法示例 | 易语言手册例程.e | 本例程用于与易语言手册配合阅读以快速掌握易语言语法。
基于连接的服务器测试 | 服务器测试.e |
图片浏览 | 查看图片.e | 在本例程中可以学习到驱动器框、目录框、文件框、图片框单元的使用方法。
欢迎使用易语言 | 欢迎.e | 本例程为欢迎用户使用易语言的封面程序。在其中可以学习到 GIF 动画、背景音乐、底图、画板单元、时钟单元的使用方法。
流程控制类命令演示 | 流程类命令.e | 演示所有流程控制类命令的使用方法
爆炸 | 爆炸.e | 具有爆炸外形的窗口
环境存取类命令演示 | 环境类命令.e | 演示所有环境存取类命令的使用方法
通信端口测试 | 端口通讯.e |
第一个程序 | 第一个程序.e | 本例程为在学习易语言手册时用户所编写的第一个易程序。初级用户可以在此基础上进行练习，比如改变文字颜色、字体大小等等。
算术运算类命令演示 | 算术类命令.e | 演示所有算术运算类命令的使用方法
随机图形及右键弹出菜单 | 绘画.e | 在本例程序中可以学习到图形的绘画方法及右键弹出菜单的使用方法。
聊天室客户端 | 聊天室客户.e | 此为聊天室的客户端程序，运行本程序后需要首先连接到已经在运行聊天室服务端的机器上。
聊天室服务端 | 聊天室服务器.e | 此为聊天室的服务端程序，用作进行客户群的管理和消息分发。
脸 | 脸.e | 注意它的眼睛！
数值表计算 | 计算.e | 本例程能够对一系列数值进行汇总、求平均值、排序。在其中可以学习到编辑框、列表框单元的使用方法及文本文件的读写方法。
记事本 | 记事本.e | 本例程为一个实用的记事本软件，其功能超过了Windows系统自带的记事本。在其中可以学习到文件的操作方法、编辑框及多窗口的使用方法。
保护自己的软件 | 软件注册.e | 这是使用硬盘特征字来保护自己软件的例子。
速度密码 | 速度密码.e | 要想速度密码复核通过，不光密码要相符，输入速度也要一致哟。
逻辑比较类命令演示 | 逻辑类命令.e | 演示所有逻辑比较类命令的使用方法

适用版本，系统核心支持库 （4.5#63版）


流程控制

流程控制 类别 跳至：系统核心支持库


如果 命令 所属类别：流程控制

如果 命令 　英文命令：ife　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否改变程序的执行位置，如果提供的逻辑参数值为真，程序继续顺序向下执行，否则跳转到左侧箭头线指向的命令处去执行。

语法： 无返回值 如果 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

如果命令的条件参数必须为逻辑型，可以为一个或多个逻辑型条件语句组成，多个逻辑型条件语句之间可以用“或”或者“且”连接，

如果符合如果编辑框.内容 ＝ “你好易语言”的条件，就执行如果编辑框.内容 ＝ “欢迎使用易语言，谢谢您的支持，我们会做的更好：）”的命令，否则，就会直接运行如果编辑框.内容 ＝ “请在编辑框输入：你好易语言”。

注：可用或者、并且命令连接多个条件

例1：如果 (条件1 ＝条件2 且 条件3 ＝条件4)

例2：如果 (条件1 ＝条件2 或 条件3 ＝条件4)

参见：例程


如果真 命令 所属类别：流程控制

如果真 命令 　英文命令：if　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否改变程序的执行位置，如果提供的逻辑参数值为真，程序继续顺序向下执行，否则跳转到左侧箭头线指向的命令处去执行。同“如果”命令相比，本命令没有为假时的程序部分。

语法： 无返回值 如果真 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

如果真命令和如果命令相似，如果真的条件也必须是逻辑型，可以用“或者”“并且”连接多个条件。

此段语句运行时，如果编辑框中的的内容不为空，就运行如果真命令下面的所有命令，即改变编辑框的一系列属性，

最后将编辑框的内容改为“欢迎使用易语言” ；如果如果真命令中的条件不成立，就不运行如果真命令中的语句。

注：如果真语句的条件，可以用或者、并且连接多个条件

例：如果真（条件1=条件2 或 条件2≠条件3）

例：如果真（条件1=条件2 且 条件2≠条件3）

参见：例程


判断 命令 所属类别：流程控制

判断 命令 　英文命令：switch　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否改变程序的执行位置，如果提供的逻辑参数值为真，程序继续顺序向下执行，否则跳转到下一分支处去继续判断。

语法： 无返回值 判断 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

此命令和如果命令可以互换，用法和如果命令相似，条件必须是逻辑型，可以多条件

判断边框改变选择框的选中条件为真的时候，就运行判断标签.边框 ＝ 6，判断标签的边框就成为了渐变镜框式，判断边框改变选择框的选中条件不为真的时候，则运行判断标签.边框 ＝ 5，判断标签的边框就变成了单线边框式。

注：判断语句的条件，可以用或、且连接多个条件

例：判断（条件1=条件2 或 条件2≠条件3）

例：判断（条件1=条件2 且 条件2≠条件3）

参见：例程


判断循环首 命令 所属类别：流程控制

判断循环首 命令 　英文命令：while　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令根据提供的逻辑参数的值，来决定是否进入循环。如果提供的逻辑参数值为真，程序顺序执行下一条命令进入循环，否则跳转到本命令所对应的“判断循环尾”命令的下一条命令处以跳出循环。

语法： 无返回值 判断循环首 （条件）

参数名 | 描 述
条件 | 必需的；逻辑型。本条件值的结果决定下一步程序执行位置。

例程

说明：

判断循环首的条件是逻辑型，是在判断循环首中判断，先判断再循环，符合条件，就循环执行以下代码，不符合条件就停止循环。

注意：此命令编写时，只需要输入pdxhs()，就会自动出现：不用单独输入判断循环尾。

参见：例程


循环判断首 命令 所属类别：流程控制

循环判断首 命令 　英文命令：DoWhile　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

执行本命令后将顺序执行下一条命令进入程序循环。

语法： 无返回值 循环判断首 （）

例程

说明：

此命令和判断循环首命令相似，不同在于，此命令是先循环再判断，是在循环尾部判断，

如果条件成立，则跳到循环判断首，顺序执行循环中的命令。

参见：例程


计次循环首 命令 所属类别：流程控制

计次循环首 命令 　英文命令：counter　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

执行本命令将把循环体内的命令重复执行指定的次数。提供的整数参数值决定将重复执行的次数。

语法： 无返回值 计次循环首 （循环次数，［已循环次数记录变量］）

参数名 | 描 述
循环次数 | 必需的；整数型。本数值指定执行计次循环体内所有命令的次数，必须大于等于零。
已循环次数记录变量 | 可选的；整数型，参数数据只能提供变量。本数值型变量用作记录当前循环首已经被进入过的次数（从 1 开始），程序可以直接取用此变量中的值。

例程

说明：

第一个参数，给出将要循环的次数，是整数型，第二个参数可选的，可以给出一个整数型的变量，用来记录已经循环的次数。

例程中是将10以内的整数显示在编辑框中，整数之间用“；”隔开，首先运行计次循环首 (10, 循环次数变量)的命令，此命令规定此循环循环10次，把循环的次数记录在了循环次数变量中，这样，第一次循环，循环次数变量就是1，编辑框的内容就是“1；“，第二次循环，循环次数变量就是2，由于每次循环，编辑框的内容都加上编辑框上次的内容，所以编辑框的内容就是“1；2；”，依此类推。编辑框最后就显示为“1；2；3；4；5；6；7；8；9；10；”这样的用“；”号隔开的10个数字。

参考：例程


变量循环首 命令 所属类别：流程控制

变量循环首 命令 英文命令：for 操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

执行本命令将利用变量对循环体内的命令进行循环执行。第一次执行此命令时将使用“变量起始值”参数初始化“循环变量”参数所指定的变量。每次（包括第一次）执行到此命令处都将判断循环变量内的值是否已经超过“变量目标值”参数所指定的值，如已超过，则跳转到对应的“变量循环尾”命令的下一条命令处继续执行，否则顺序执行下一条语句继续进行循环。

语法： 无返回值 变量循环首 （变量起始值，变量目标值，变量递增值，［循环变量］）

参数名 | 描 述
变量起始值 | 必需的；整数型，初始值为“1”。定义循环变量的起始数值。
变量目标值 | 必需的；整数型。定义循环变量的目标数值，在循环首部如果发现变量值已超出此目标值时将跳出循环。
变量递增值 | 必需的；整数型，初始值为“1”。每次执行到循环尾部时都将把此值加入到循环变量中去，此值可为正数或负数，如为正数则递增，为负数则递减。
循环变量 | 可选的；整数型，参数数据只能提供变量。本数值型变量将用作控制循环执行次数，在循环尾部将自动递增或递减该变量内的数值。如果被省略，命令将自动使用内部临时变量。

例程

说明：

此命令可以在变量内进行循环，并能把每次内部循环的值取出。变量起始值：是进行内部变量循环的起始值，并用这个参数的值初始化循环变量，即循环刚开始时循环变量的值；变量目标值：是变量起始值最终达到的数值，当到达变量目标值时，循环结束；变量递增值：它的初始值是1，可以按照需要规定它的值，是变量起始值向变量目标值递增时每次所要增加的数值；循环变量：可以省略，如果省略，将自动使用内部临时变量，它记录了递增的过程，是记录变量起始值向变量目标值每次递增后的数值。

注意：循环变量不同于计次循环首中“已循环次数记录变量“，它的初始值可以自定义，循环刚开始时，循环变量的初始值是由变量起始值决定的，变量起始值的数值，就是循环变量的初始值。

此段代码，可以求出100到200之间所有偶数的和，循环开始时，循环变量的初始值是100，这是由第一个参数变量起始值决定的，每次循环，循环变量的值都递增2，即偶数，然后求和变量每次循环都把循环变量的值相加，直到循环变量的值到达200，循环结束，求和变量得出的就是100到200之间的偶数和。

参见：例程


到循环尾 命令 所属类别：流程控制

到循环尾 命令 　英文命令：continue　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令转移当前程序执行位置到当前所处循环体的循环尾语句处。

语法： 无返回值 到循环尾 （）

例程

说明：

这个命令可以在循环中，直接运行到循环尾（循环判断尾；判断循环尾；计次循环尾）。

此例是用画板显示1-10的整数，但不包括2和4，在循环中，如果符合循环次数变量= 2 或 循环次数变量 ＝ 4条件，就运行到循环尾 ()的命令，直接跳到计次循环尾 ()，也就不运行显示画板.滚动写行 (循环次数变量)命令，跳过了2和4这两个数。

参见：例程


跳出循环 命令 所属类别：流程控制

跳出循环 命令 　英文命令：break　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令转移当前程序执行位置到当前所处循环体循环尾语句的下一条语句处。

语法： 无返回值 跳出循环 （）

例程

说明：

跳出循环命令，是要终止一个循环的使用，在一定条件下，想停止一个循环的运行，

就可以使用跳出循环命令，此循环就会停止，继续运行循环尾句下面的语句。

如果是双重循环，即一个循环里面还有另一个循环，那么用跳出循环命令只是终止跳出循环命令所在的那个循环。

参见：例程


返回 命令 所属类别：流程控制

返回 命令 　英文命令：return　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令转移当前程序执行位置到调用本子程序语句的下一条语句处,并可根据需要返回一个值到子程序调用处。

语法： 无返回值 返回 （［返回到调用方的值］）

参数名 | 描 述
返回到调用方的值 | 可选的；通用型。

例程

说明：

返回命令使用比较普遍，返回命令不但可以返回给调用方各种类型的数据，也可以终止一系列代码的运行。

当然，返回命令可以返回任何通用型的数据，下有3例：

例：返回（100）

返回一段整数

例：返回 ([1998年11月12日])

返回一段日期时间型数据

例：返回 ({ 201 })

返回一段字节集

参考：例程


结束 命令 所属类别：流程控制

结束 命令 　英文命令：end　操作系统支持：Windows、Linux、Unix　　所属类别：流程控制

本命令结束当前易程序的运行。

语法： 无返回值 结束 （）

例程

说明：

结束命令，可以用来结束当前的易程序的运行，可以用做结束程序或关闭程序，需要注意的是，结束命令是结束当前的整个程序，而不是一个窗口的结束，结束易程序中的单个窗口，可以用销毁（）命令。

参考：例程


算术运算

算术运算 类别 跳至：系统核心支持库

相乘 | 相除 | 整除 | 求余数
相加 | 相减 | 负 | 取符号
取绝对值 | 取整 | 绝对取整 | 四舍五入
求次方 | 求平方根 | 求正弦 | 求余弦
求正切 | 求反正切 | 求自然对数 | 求反对数
是否运算正确 | 置随机数种子 | 取随机数 |


相乘 命令 所属类别：算术运算

相乘 命令 　英文命令：mul　操作系统支持：Windows、Linux、Unix 所属类别：算术运算

返回两个数值的乘积，运算符号为“*”或“×”。

语法： 双精度小数型 相乘 （被乘数，乘数，… ）

参数名 | 描 述
被乘数 | 必需的；双精度小数型。
乘数 | 必需的；可扩充的；双精度小数型。

例程

说明：

将被乘数编辑框的内容和乘数编辑框的内容转换到数值型，然后将两个转换后的数值相乘，

再把返回的数值型数据转换到文本型，放入相乘标签的标题中。

参见：例程


相除 命令 所属类别：算术运算

相除 命令 　英文命令：div　操作系统支持：Windows、Linux、Unix 所属类别：算术运算

返回两个数值的商，运算符号为“/”或“÷”。

语法： 双精度小数型 相除 （被除数，除数，… ）

参数名 | 描 述
被除数 | 必需的；双精度小数型。
除数 | 必需的；可扩充的；双精度小数型。

例程

说明：

先将被除数编辑框的内容和除数编辑框的内容转换到数值型，再将两个转换的内容相除，

把返回的数值转换到文本型，放入相除标签的标题中。

参见：例程


整除 命令 所属类别：算术运算

整除 命令 　英文命令：IDiv　操作系统支持：Windows、Linux 所属类别：算术运算

求出两个数值的商，并返回其整数部分，运算符号为“\”。

语法： 双精度小数型 整除 （被除数，除数，… ）

参数名 | 描 述
被除数 | 必需的；双精度小数型。
除数 | 必需的；可扩充的；双精度小数型。

例程

说明：

得到的结果是两个数值的商，去掉小数部分后剩下的整数部分的值。小数部分全部去掉，不四舍五入。

将被除数编辑框的内容和除数编辑框的内容转换到数值型，再将两个转换后的数值整除，

将返回的数值型数据转换到文本型，放入整除标签的标题中。

参见：例程


求余数 命令 所属类别：算术运算

求余数 命令 　英文命令：mod　操作系统支持：Windows、Linux 所属类别：算术运算

求出两个数值的商，并返回余数部分，运算符号为“%”或“Mod”。

语法： 双精度小数型 求余数 （被除数，除数，… ）

参数名 | 描 述
被除数 | 必需的；双精度小数型。
除数 | 必需的；可扩充的；双精度小数型。

例程

说明：

当计算到被除数小于除数时，就不再计算，剩余的被除数就是余数。

参见：例程


相加 命令 所属类别：算术运算

相加 命令 　英文命令：add　操作系统支持：Windows、Linux、Unix 所属类别：算术运算

运算符号为“+”，用途为：1、返回两个数值的和；2、将两个文本首尾连接起来，返回连接后的文本；3、将两个字节集首尾连接起来，返回连接后的字节集。

语法： 通用型 相加 （被加数或文本或字节集，加数或文本或字节集，… ）

参数名 | 描 述
被加数或文本或字节集 | 必需的；通用型。
加数或文本或字节集 | 必需的；可扩充的；通用型。

例程

说明：

注：数值相加，返回两个数值的和。

注：文本相加，将两个文本首尾连接起来，返回连接后的文本。

注：字节集相加，将两个字节集首尾连接起来，返回连接后的字节集。

参见：例程


相减 命令 所属类别：算术运算

相减 命令 　英文命令：sub　操作系统支持：Windows、Linux、Unix 所属类别：算术运算

返回两个数值的差，运算符号为“-”。

语法： 双精度小数型 相减 （被减数，减数，… ）

参数名 | 描 述
被减数 | 必需的；双精度小数型。
减数 | 必需的；可扩充的；双精度小数型。

例程

说明：

将被减数编辑框的内容和减数编辑框的内容转换到数值型，再将两个数值相减。

把返回的内容转换成文本型，放入相减标签的标题中。

参见：例程


负 命令 所属类别：算术运算

负 命令 　英文命令：neg　操作系统支持：Windows、Linux、Unix 所属类别：算术运算

反转一个数值的正负符号并返回反转后的值，运算符号为“-”（放在表达式首）。

语法： 双精度小数型 负 （数值）

参数名 | 描 述
数值 | 必需的；双精度小数型。

例程

说明：

把数值编辑框的内容转换到数值型，然后取它的负值，再转换到文本型，放到负数标签的标题中。

参见：例程


取符号 命令 所属类别：算术运算

取符号 命令 　英文命令：sgn　操作系统支持：Windows、Linux 所属类别：算术运算

返回一个整数，如果小于零，表明给定数值为负；如果等于零，表明给定数值为零；如果大于零，表明给定数值为正。

语法： 整数型 取符号（欲取其符号的数值）

参数名 | 描 述
欲取其符号的数值 | 必需的；双精度小数型。

例程

说明：

根据返回的整数值判断数值得正负号。

将数值编辑框的内容转换到数值型，把转换后的数值取其符号，

再把返回的整数型数据转换到文本型，放入取符号标签的标题中。

参见：例程


取绝对值 命令 所属类别：算术运算

取绝对值 命令 　英文命令：abs　操作系统支持：Windows、Linux 所属类别：算术运算

如果所提供数值为字节型，则将直接返回该数值。

语法： 双精度小数型 取绝对值 （欲取其绝对值的数值）

参数名 | 描 述
欲取其绝对值的数值 | 必需的；双精度小数型。

例程

说明：

本命令是把数值的符号都换成正号，零的绝对值是零。

先把数值编辑框的内容转换到数值型，将转换后的数值编辑框的内容取其绝对值，

再把返回的数值转换到文本型，放入到取绝对值标签的标题中。

参见：例程


取整 命令 所属类别：算术运算

取整 命令 　英文命令：int　操作系统支持：Windows、Linux 所属类别：算术运算

返回一个小数的整数部分。本命令与“绝对取整”命令不相同之处为：如果给定小数为负数，则本命令返回小于或等于该小数的第一个负整数，而“绝对取整”命令则会返回大于或等于该小数的第一个负整数。例如，本命令将 -7.8 转换成 -8，而“绝对取整”命令将 -7.8 转换成 -7。

语法： 整数型 取整 （欲取整的小数）

参数名 | 描 述
欲取整的小数 | 必需的；双精度小数型。

例程

说明：

本命令返回，在小于或等于给定数值的所有数值中，最大的整数值。

在正数的情况下，取整与绝对取整相同。

先把数值编辑框的内容转换到数值型，再把转换后的数值编辑框的内容取整，

再把返回的数值转换到文本型，放入到取整标签的标题中。

参见：例程


绝对取整 命令 所属类别：算术运算

绝对取整 命令 　英文命令：fix　操作系统支持：Windows、Linux 所属类别：算术运算

返回一个小数的整数部分。本命令与“取整”命令不相同之处为：如果给定小数为负数，则本命令返回大于或等于该小数的第一个负整数，而“取整”命令则会返回小于或等于该小数的第一个负整数。例如，本命令将 -7.8 转换成 -7，而“取整”命令将 -7.8 转换成 -8。

语法： 整数型 绝对取整 （欲取整的小数）

参数名 | 描 述
欲取整的小数 | 必需的；双精度小数型。

例程

说明：

将一个数值的小数部分去掉，只保留整数部分。不四舍五入。

参见：例程


四舍五入 命令 所属类别：算术运算

四舍五入 命令 　英文命令：round　操作系统支持：Windows、Linux 所属类别：算术运算

返回按照指定的方式进行四舍五入运算的结果数值。

语法： 双精度小数型 四舍五入 （欲被四舍五入的数值，［被舍入的位置］）

参数名 | 描 述
欲被四舍五入的数值 | 必需的；双精度小数型。
被舍入的位置 | 可选的；整数型。如果大于0，表示小数点右边应保留的位数；如果等于0，表示舍入到整数；如果小于0，表示小数点左边舍入到的位置。例如：四舍五入 (1056.65, 1) 返回 1056.7； 四舍五入 (1056.65, 0) 返回 1057； 四舍五入 (1056.65, -1) 返回 1060。如果省略本参数，则默认为0。

例程

说明：

把数值编辑框的内容转换到数值型，把舍位编辑框的内容转换到整数型，

把转换后的数值编辑框的内容四舍五入，舍入的位置就是舍位编辑框的内容，

再把舍入后的数值转换到文本型，放入到四舍五入标签的标题中。

参见：例程


求次方 命令 所属类别：算术运算

求次方 命令 　英文命令：pow　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定数值的指定次方。

语法： 双精度小数型 求次方 （欲求次方数值，次方数）

参数名 | 描 述
欲求次方数值 | 必需的；双精度小数型。参数值指定欲求其某次方的数值。
次方数 | 必需的；双精度小数型。参数值指定对欲求次方数值的运算指数。

例程

说明：

先把底数编辑框的内容和次方编辑框的内容转换到数值型，根据底数编辑框的内容和次方编辑框的内容求次方，

再把所得的数值转换到文本型，放入求次方标签的标题中。

参见：例程


求平方根 命令 所属类别：算术运算

求平方根 命令 　英文命令：sqr　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定参数的平方根。

语法： 双精度小数型 求平方根 （欲求其平方根的数值）

参数名 | 描 述
欲求其平方根的数值 | 必需的；双精度小数型。参数值如果小于零将导致计算错误。

例程

说明：

将数值编辑框的内容转换到数值型，把转换后的数据求平方根，

再把返回的双精度小数型数据转换到文本型，放入求平方根标签的标题中。

参见：例程


求正弦 命令 所属类别：算术运算

求正弦 命令 　英文命令：sin　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定角的正弦值。

语法： 双精度小数型 求正弦 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。所使用单位为弧度。为了将角度转换成弧度，请将角度乘以 #pi / 180。为了将弧度转换成角度，请将弧度乘以 180 / #pi。如果参数值大于等于 2 的 63 次方，或者小于等于 -2 的 63 次方，将导致计算溢出。

例程

说明：

将数值编辑框的内容转换到双精度小数型，再将转换后的数值乘以#pi除以180后求正弦，

把返回的双精度小数型数据转换到文本型，放入求正弦标签的标题中。

参见：例程


求余弦 命令 所属类别：算术运算

求余弦 命令 　英文命令：cos　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定角的余弦值。

语法： 双精度小数型 求余弦 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。所使用单位为弧度。为了将角度转换成弧度，请将角度乘以 #pi / 180。为了将弧度转换成角度，请将弧度乘以 180 / #pi。如果参数值大于等于 2 的 63 次方，或者小于等于 -2 的 63 次方，将导致计算溢出。

例程

说明：

将数值编辑框的内容转换到双精度小数型，在将转换后的数值乘以#pi除以 180后求余弦，

将返回的双精度小数型数据转换到文本型，放入求余弦标签的标题中。

参见：例程


求正切 命令 所属类别：算术运算

求正切 命令 　英文命令：tan　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定角的正切值。

语法： 双精度小数型 求正切 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。所使用单位为弧度。为了将角度转换成弧度，请将角度乘以 #pi / 180。为了将弧度转换成角度，请将弧度乘以 180 / #pi。如果参数值大于等于 2 的 63 次方，或者小于等于 -2 的 63 次方，将导致计算溢出。

例程

说明：

先把角度编辑框的内容转换到双精度小数型，再把转换后内容乘以 #pi 除以 180后求正切，

再把返回的数值转换到文本型，放入到求正切标签的标题中。

参见：例程


求反正切 命令 所属类别：算术运算

求反正切 命令 　英文命令：atn　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定数的反正切值。

语法： 双精度小数型 求反正切 （欲求其反正切值的数值）

参数名 | 描 述
欲求其反正切值的数值 | 必需的；双精度小数型。

例程

说明：

先把角度编辑框的内容转换到双精度小数型，求反正切；得到的数值是弧度，

再把返回的弧度乘以 #pi 除以180的角度值转换到文本型放入到求反正切标签的标题中。

参见：例程


求自然对数 命令 所属类别：算术运算

求自然对数 命令 　英文命令：log　操作系统支持：Windows、Linux 所属类别：算术运算

返回指定参数的自然对数值。自然对数是以 e 为底的对数。常量 #e 的值大约是 2.718282。

语法： 双精度小数型 求自然对数 （欲求其自然对数的数值）

参数名 | 描 述
欲求其自然对数的数值 | 必需的；双精度小数型。

例程

说明：

先把数值编辑框的内容转换到双精度小数型，将转换后的内容求自然对数，

再把返回的数值转换到文本型，放入到求自然对数标签的标题中。

参见：例程


求反对数 命令 所属类别：算术运算

求反对数 命令 　英文命令：exp　操作系统支持：Windows、Linux 所属类别：算术运算

返回 e（自然对数的底）的某次方。

语法： 双精度小数型 求反对数 （欲求其反对数的数值）

参数名 | 描 述
欲求其反对数的数值 | 必需的；双精度小数型。如果参数值超过 709.782712893，将导致计算溢出。

例程

说明：

将数值编辑框的内容转换到双精度小数型。再把转换后的数值求反对数，

把返回的数值转换到文本型，放入求反对数标签的标题中。

参见：例程


是否运算正确 命令 所属类别：算术运算

是否运算正确 命令 　英文命令：IsCalcOK　操作系统支持：Windows、Linux 所属类别：算术运算

对“求次方”、“求平方根”、“求正弦值”、“求余弦值”、“求正切值”、“求反正切值”、“求自然对数”、“求反对数”等等数学运算命令所计算出来的双精度结果数值进行校验，如果该数值正确有效，返回真。如果该数值是运算错误或运算溢出后的结果，返回假。

语法： 逻辑型 是否运算正确 （欲校验的计算结果）

参数名 | 描 述
欲校验的计算结果 | 必需的；双精度小数型。

例程

说明：

将数值编辑框的内容转换到双精度小数型，再把转换后的数值求正切，判断返回的数值是否运算正确。

参见：例程


置随机数种子 命令 所属类别：算术运算

置随机数种子 命令 　英文命令：randomize　操作系统支持：Windows、Linux 所属类别：算术运算

为随机数生成器初始化一个种子值，不同的种子值将导致“取随机数”命令返回不同的随机数系列。

语法： 无返回值 置随机数种子 （［欲置入的种子数值］）

参数名 | 描 述
欲置入的种子数值 | 可选的；整数型。如果省略本参数，将默认使用当前计算机系统的时钟值。

例程

说明：

把数值编辑框的内容转换到整数型，再用转换后的内容置随机数种子。

注：多运行几次取随机数，你会发现一个现象，每次取的数值是有规律的，所以我们要设置一个随机数的种子，种子不一样，取出的随机数也不一样，但是这还是很麻烦，需要每次手动调整随机数种子，这里推荐用现行时间作为种子，因为时间是不会重复的，所以，随机数出现的规律也不会重复。

注：如不使用 置随机数种子，默认用1作为随机数种子

参见：例程


取随机数 命令 所属类别：算术运算

取随机数 命令 　英文命令：rnd　操作系统支持：Windows、Linux 所属类别：算术运算

返回一个指定范围内的随机数值。在使用本命令取一系列的随机数之前，应该先使用“置随机数种子”命令为随机数生成器初始化一个种子值。

语法： 整数型 取随机数 （［欲取随机数的最小值］，［欲取随机数的最大值］）

参数名 | 描 述
欲取随机数的最小值 | 可选的；整数型。参数必须大于或等于零。本参数如果被省略，默认为 0 。
欲取随机数的最大值 | 可选的；整数型。参数必须大于或等于零。本参数如果被省略，默认为无限。

例程

说明：

将最小值编辑框的内容和最大值编辑框的内容转换到整数型，在两个数值之间取随机数，

将返回的整数型数值转换到文本型，放入取随机数标签的标题中。

参见：例程


逻辑比较

逻辑比较 类别 跳至：系统核心支持库


等于 命令 所属类别：逻辑比较

等于 命令 操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值与比较值相同时返回真，否则返回假，运算符号为“=”或“==”。

语法： 逻辑型 等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。
比较值 | 必需的；通用型。比较值的数据类型必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较，条件成立，第一个信息框显示。

也可以用一个逻辑变量保存（真或假），如下两行：

逻辑变量＝（被比较编辑框.内容 ＝比较编辑框.内容）

信息框（逻辑变量，0，）

信息框将显示真或假。

参见：例程


不等于 命令 所属类别：逻辑比较

不等于 命令 操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值与比较值不相同时返回真，否则返回假，运算符号为“<>”或“!=”或“≠”。

语法： 逻辑型 不等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。
比较值 | 必需的；通用型。比较值的数据类型必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较，条件成立，第一个信息框显示。

也可以用一个逻辑变量保存（真或假），如下两行：

逻辑变量＝（被比较编辑框.内容 <> 比较编辑框.内容）

信息框（逻辑变量，0，）

信息框将显示真或假。

参见：例程


小于 命令 所属类别：逻辑比较

小于 命令 操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值小于比较值时返回真，否则返回假，运算符号为“<”。

语法： 逻辑型 小于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较，条件成立，第一个信息框显示。

数值文本比较:如，'123' 和 '45' 比较，信息框将显示 '45' 大于或等于 '123'，

因为第一位的'1'和'4'比较，'4'的代码大于'1'的代码，所以'45'大。

英文字母比较：如,'ab'和'cd'比较，'cd'大于或等于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写字母代码）。

关于代码大小请参阅ASCⅡ码。

参见：例程


大于 命令 所属类别：逻辑比较

大于 命令 操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值大于比较值时返回真，否则返回假，运算符号为“>”。

语法： 逻辑型 大于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较，条件成立，第一个信息框显示。

数值文本比较:如，'123' 和 '45' 比较，信息框将显示 '45' 大于 '123'，

因为第一位的'1'和'4'比较，'4'的代码大于'1'的代码，所以'45'大。

英文字母比较：如,'ab'和'cd'比较，'cd'大于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写字母代码）。

关于代码的大小请参阅ASCⅡ码。

参见：例程


小于或等于 命令 所属类别：逻辑比较

小于或等于 命令 操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值小于或等于比较值时返回真，否则返回假，运算符号为“<=”或“≤”。

语法： 逻辑型 小于或等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较，其中一个条件成立（或者小于或者等于），第一个信息框显示。

数值文本比较: 如，'123' 和 '45' 比较，信息框将显示 '45' 大于 '123'，

因为第一位的'1'和'4'比较，'4'大于'1'，所以'45'大；

英文字母比较：如,'ab'和'cd'比较，'cd'大于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写代码）。

关于代码的大小请参阅ASCⅡ码。

参见：例程


大于或等于 命令 所属类别：逻辑比较

大于或等于 命令 操作系统支持：Windows、Linux　　所属类别：逻辑比较

被比较值大于或等于比较值时返回真，否则返回假，运算符号为“>=”或“≥”。

语法： 逻辑型 大于或等于 （被比较值，比较值）

参数名 | 描 述
被比较值 | 必需的；通用型。被比较值的数据类型可以为数值型、日期时间型、文本型。
比较值 | 必需的；通用型。比较值的数据类型可以为数值型、日期时间型、文本型，且必须与“被比较值”一致或者可以相互转换。

例程

说明：

此例程为两个文本进行比较，其中一个条件成立（或者小于或者等于），第一个信息框显示。

数值文本比较:如，'123' 和 '45' 比较，信息框将显示 '45' 大于或等于'123'，

因为第一位的'1'和'4'比较，'4'大于'1'，所以'45'大。

英文字母比较：如,'ab'和'cd'比较，'cd'大于或等于'ab',

因为'c'的代码大于'a'的代码（注：大写字母代码小于小写代码）。

关于代码的大小请参阅ASCⅡ码。

参见：例程


近似等于 命令 所属类别：逻辑比较

近似等于 命令 英文命令：like 操作系统支持：Windows、Linux　　所属类别：逻辑比较

当比较文本在被比较文本的首部被包容时返回真，否则返回假，运算符号为“?=”或“≈”。

语法： 逻辑型 近似等于 （被比较文本，比较文本）

参数名 | 描 述
被比较文本 | 必需的；文本型。
比较文本 | 必需的；文本型。

例程

说明：

此例程为两个文本进行比较，条件成立，第一个信息框显示。

比较值必须包含在被比较值里，如：被比较值 '11234',比较值'11'。

参见：例程


并且 命令 所属类别：逻辑比较

并且 命令 英文命令：and 操作系统支持：Windows、Linux　　所属类别：逻辑比较

如果所提供的两个参数逻辑值都为真则返回真，否则返回假，运算符号为“&&”或“And”或“且”。

语法： 逻辑型 并且 （逻辑值一，逻辑值二，… ）

参数名 | 描 述
逻辑值一 | 必需的；逻辑型。
逻辑值二 | 必需的；可扩充的；逻辑型。

例程

说明:

如果真 用来判断鼠标位置是否发生改变，改变了，就将鼠标位置保存到两个整数型变量里。

如果 用来判断鼠标是否在启动窗口内，在启动窗口内，启动窗口的底色为红色，在启动窗口外，底色为绿色。

参见：例程


或者 命令 所属类别：逻辑比较

或者 命令 英文命令：or 操作系统支持：Windows、Linux　　所属类别：逻辑比较

如果所提供的两个参数逻辑值中任意有一个为真则返回真，否则返回假，运算符号为“||”或“Or”或“或”。

语法： 逻辑型 或者 （逻辑值一，逻辑值二，… ）

参数名 | 描 述
逻辑值一 | 必需的；逻辑型。
逻辑值二 | 必需的；可扩充的；逻辑型。

例程

说明：

如果真 用来判断鼠标在启动窗口内的位置，鼠标只要在启动窗口的边缘（可自行设定区域大小）移动，

程序就会逐依执行下面的判断语句，有一个判断条件成立，判断条件里的信息框就会显示相对应的内容。

判断 用来判断鼠标相对具体的位置（左边，右边（左边+宽度），顶边，底边（顶边+高度））。

参见：例程


取反 命令 所属类别：逻辑比较

取反 命令 英文命令：not 操作系统支持：Windows、Linux　　所属类别：逻辑比较

如果参数值为真则返回假，如果参数值为假则返回真。

语法： 逻辑型 取反 （被反转的逻辑值）

参数名 | 描 述
被反转的逻辑值 | 必需的；逻辑型。

例程

说明：

逻辑变量为逻辑型，子菜单.选中 为逻辑型。在此例程中，逻辑变量保存 子菜单.选中 的反值（真的反值为假），

然后将逻辑变量保存的真或假，赋值给 子菜单.选中。

如果 用来判断逻辑变量保存的值，以显示不同的信息提示用户的操作。

参见：例程


位运算

位运算 类别 跳至：系统核心支持库


位取反 命令 所属类别：位运算

位取反 命令 　英文命令：bnot　操作系统支持：Windows、Linux 所属类别：位运算

将指定数值每一个比特位的值取反后返回。

语法： 整数型 位取反 （欲取反的数值）

参数名 | 描 述
欲取反的数值 | 必需的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

将数值编辑框的内容转换到整数型，再将转换后的数值位取反，把返回的整数型数据转换到文本型，放入位取反标签的标题中。

参见：例程


位与 命令 所属类别：位运算

位与 命令 　英文命令：band　操作系统支持：Windows、Linux 所属类别：位运算

如两个数值有某共同比特位为1，则返回值的对应位也为1，否则为0。返回计算后的结果。

语法： 整数型 位与 （位运算数值一，位运算数值二，… ）

参数名 | 描 述
位运算数值一 | 必需的；整数型。
位运算数值二 | 必需的；可扩充的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

将位运算编辑框的内容和位运算数值编辑框的内容转换到整数型，把转换后的数据位与，再把返回的整数型数据转换到文本型，放入位与标签的标题中。

参见：例程


位或 命令 所属类别：位运算

位或 命令 　英文命令：bor　操作系统支持：Windows、Linux 所属类别：位运算

如两个数值中有一个数值的某一比特位不为零，则返回值的对应位就为1，否则为0。返回计算后的结果。

语法： 整数型 位或 （位运算数值一，位运算数值二，… ）

参数名 | 描 述
位运算数值一 | 必需的；整数型。
位运算数值二 | 必需的；可扩充的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

将位运算编辑框的内容和位运算数值编辑框的内容转换到整数型，再将两个转换后的数值位或，把返回的整数型数值放入位或标签的标题中。

参见：例程


位异或 命令 所属类别：位运算

位异或 命令 　英文命令：bxor　操作系统支持：Windows、Linux 所属类别：位运算

如两个数值对应比特位的值不相等，则返回值的对应位就为1，否则为0。返回计算后的结果。

语法： 整数型 位异或 （位运算数值一，位运算数值二，… ）

参数名 | 描 述
位运算数值一 | 必需的；整数型。
位运算数值二 | 必需的；可扩充的；整数型。

例程

说明：

关于位运算的原理，请参阅相关的二进制算法。

将位运算编辑框的内容和位运算数值编辑框的内容转换到整数型，再将转换后的数值位异或，把返回的整数型数据转换到文本型，放入位异或标签的标题中。

参见：例程


左移

左移 命令 操作系统支持：Windows、Linux 所属类别：位运算

将某整数的数据位左移指定位数，返回移动后的结果。

语法： 整数型 左移 （欲移动的整数， 欲移动的位数）

参数名 | 描 述
欲移动的整数 | 必需的； 整数型。
欲移动的位数 | 必需的； 整数型。

例程：

说明：

将某整数的数据位左移指定位数。

参见：例程1


右移

右移 命令 操作系统支持：Windows、Linux 所属类别：位运算

将某整数的数据位右移指定位数，返回移动后的结果。

语法： 整数型 右移 （欲移动的整数， 欲移动的位数）

参数名 | 描 述
欲移动的整数 | 必需的； 整数型。
欲移动的位数 | 必需的； 整数型。

例程：

说明：

将某整数的数据位右移指定位数。

参见：例程1


合并整数

合并整数 命令 操作系统支持：Windows、Linux 所属类别：位运算

将第一个整数的低16位放置到结果整数的低16位，将第二个整数的低16位放置到结果整数的高16位，以此合并成一个整数，并返回合并后的结果。

语法： 整数型 合并整数 （用作合并的整数1， 用作合并的整数2）

参数名 | 描 述
用作合并的整数1 | 必需的； 整数型。
用作合并的整数2 | 必需的； 整数型。

例程：

说明：

并成一个整数，并返回合并后的结果。

参见：例程1


合并短整数

合并短整数 命令 操作系统支持：Windows、Linux 所属类别：位运算

将第一个整数的低8位放置到结果短整数的低8位，将第二个整数的低8位放置到结果短整数的高8位，以此合并成一个短整数，并返回合并后的结果。

语法： 短整数型 合并短整数 （用作合并的整数1， 用作合并的整数2）

参数名 | 描 述
用作合并的整数1 | 必需的； 整数型。
用作合并的整数2 | 必需的； 整数型。

例程：

说明：

合并成一个短整数，并返回合并后的结果。

参见：例程1


变量操作

变量操作 类别 跳至：系统核心支持库


赋值 命令 所属类别：变量操作

赋值 命令 　英文命令：set　操作系统支持：Windows、Linux、Unix 所属类别：变量操作

将指定的常数、常数集、常量、资源、对象或者变量赋于到指定的变量或变量数组中去。运算符号为“=”。

语法： 无返回值 赋值 （被赋值的变量或变量数组，用作赋于的值或资源）

参数名 | 描 述
被赋值的变量或变量数组 | 必需的；通用型，参数数据只能提供变量及变量数组。
用作赋于的值或资源 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。

例程

说明：

将指定的常数、常数集、常量、资源、对象或者变量赋予到指定的变量或变量数组中去。运算符号为“=”。

参见：例程


连续赋值 命令 所属类别：变量操作

连续赋值 命令 　英文命令：store　操作系统支持：Windows、Linux、Unix 所属类别：变量操作

将指定的常数、常数集、常量、资源、对象或者变量赋予到一系列变量或变量数组中去。

语法： 无返回值 连续赋值 （用作赋于的值或资源，被赋值的变量或变量数组，… ）

参数名 | 描 述
用作赋于的值或资源 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。
被赋值的变量或变量数组 | 必需的；可扩充的；通用型，参数数据只能提供变量及变量数组。

例程

说明：

将指定的常数、常数集、常量、资源、对象或者变量分别赋予到一系列不同的变量或变量数组中去。

注：理论上第二个参数可以扩展无限个

参见：例程


数组操作

数组操作 类别 跳至：系统核心支持库


重定义数组 命令 所属类别：数组操作

重定义数组 命令 　英文命令：ReDim　所属类别：数组操作

本命令可以重新定义指定数组的维数及各维的上限值。

语法： 无返回值 重定义数组 （欲重定义的数组变量，是否保留以前的内容，数组对应维的上限值，… ）

参数名 | 描 述
欲重定义的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
是否保留以前的内容 | 必需的；逻辑型，初始值为“假”。
数组对应维的上限值 | 必需的；可扩充的；整数型。

例程：

说明：

重新定义数组的各项属性。

注：

如果需要保留以前内容需要在第2个参数中为“真”。

参见：例程


取数组成员数 命令 所属类别：数组操作

取数组成员数 命令 　英文命令：GetAryElementCount　所属类别：数组操作

取指定数组变量的全部成员数目，如果该变量不为数组，返回-1，因此本命令也可以用作检查指定变量是否为数组变量。

语法： 整数型 取数组成员数 （欲检查的变量）

参数名 | 描 述
欲检查的变量 | 必需的；通用型，参数数据只能提供变量及变量数组。参数值指定欲检查其成员数目的数组变量或者欲检查其是否为数组的变量。

例程：

说明：

显示数组变量的当前成员的个数，

在数组成员编辑框里显示数组的当前成员个数。

参见：例程


取数组下标 命令 所属类别：数组操作

取数组下标 命令 　英文命令：UBound　所属类别：数组操作

返回指定数组维可用的最大下标（最小下标固定为1）。如果给定变量不为数组变量或指定维不存在，返回 0 。

语法： 整数型 取数组下标 （欲取某维最大下标的数组变量，［欲取其最大下标的维］）

参数名 | 描 述
欲取某维最大下标的数组变量 | 必需的；通用型，参数数据只能提供变量及变量数组。
欲取其最大下标的维 | 可选的；整数型。1 表示第一维，2 表示第二维，如此类推。如果省略本参数，默认值是 1。

例程：

说明：

显示数组变量的可用最大下标。

在数组下标编辑框里显示数组的第一维的可用的最大下标和第二维的可用的最大下标。

参见：例程


复制数组 命令 所属类别：数组操作

复制数组 命令 　英文命令：CopyAry　所属类别：数组操作

将数组数据复制到指定的数组变量，该数组变量内的所有数据和数组维定义信息将被全部覆盖。

语法： 无返回值 复制数组 （复制到的数组变量，待复制的数组数据）

参数名 | 描 述
复制到的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
待复制的数组数据 | 必需的；通用型，参数数据只能提供数组数据。

例程:

说明：

将数组数据复制到指定的数组变量，该数组变量内的所有数据和数组维定义信息将被全部覆盖。

复制成功后，两个数组（源数组、目的数组）的结构（成员数）和数组的内容将完全一样。

参见：例程


加入成员 命令 所属类别：数组操作

加入成员 命令 　英文命令：AddElement　所属类别：数组操作

将数据加入到指定数组变量的尾部，并通过重新定义数组维数自动增加其成员数目。数组变量如为多维数组，加入完毕后将被转换为单维数组。

语法： 无返回值 加入成员 （欲加入成员的数组变量，欲加入的成员数据）

参数名 | 描 述
欲加入成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
欲加入的成员数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值所指定成员数据的数据类型必须能够与第一个参数所指定的数组变量相匹配。

例程：

说明：

在数组变量里加入一个成员。成员加入在数组的最后面。

参见：例程


插入成员 命令 所属类别：数组操作

插入成员 命令 　英文命令：InsElement　所属类别：数组操作

将数据插入到指定数组变量的指定位置，并通过重新定义数组维数自动增加其成员数目。数组变量如为多维数组，插入完毕后将被转换为单维数组。

语法： 无返回值 插入成员 （欲插入成员的数组变量，欲插入的位置，欲插入的成员数据）

参数名 | 描 述
欲插入成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
欲插入的位置 | 必需的；整数型。位置值从 1 开始，如果小于 1 或大于第一个参数所指定数组变量的成员数目 + 1，将不会插入任何数据。
欲插入的成员数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值所指定成员数据的数据类型必须能够与第一个参数所指定的数组变量相匹配。

例程：

说明：

将数据插入到指定数组变量的指定位置，并通过重新定义数组维数自动增加其成员数目。数组变量如为多维数组，插入完毕后将被转换为单维数组。

在数组的第一个位置插入成员和它的值。

参见：例程


删除成员 命令 所属类别：数组操作

删除成员 命令 　英文命令：RemoveElement　所属类别：数组操作

删除指定数组变量中的成员，并通过重新定义数组维数自动减少其成员数目。数组变量如为多维数组，删除完毕后将被转换为单维数组。返回所实际删除的成员数目。

语法： 整数型 删除成员 （欲删除成员的数组变量，欲删除的位置，［欲删除的成员数目］）

参数名 | 描 述
欲删除成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。
欲删除的位置 | 必需的；整数型。位置值从 1 开始，如果小于 1 或大于第一个参数所指定数组变量的成员数目，将不会删除任何数据。
欲删除的成员数目 | 可选的；整数型。本参数如果被省略，默认为 1 。

例程：

说明：

删除数组里的第二个成员。被删除成员以后的其它成员的位置依次向前进一位。

参见：例程


清除数组 命令 所属类别：数组操作

清除数组 命令 　英文命令：RemoveAll　所属类别：数组操作

删除指定数组变量中的所有成员，释放这些成员所占用的存储空间，重新定义该变量为单维 0 成员数组变量。

语法： 无返回值 清除数组 （欲删除成员的数组变量）

参数名 | 描 述
欲删除成员的数组变量 | 必需的；通用型，参数数据只能提供变量数组。

例程：

说明：

删除所指定的数组变量内的所有成员。

执行成功后数组内的成员将全部被删除，数组的成员数变为0

参见：例程


数组排序 命令 所属类别：数组操作

数组排序 命令 　英文命令：SortAry　所属类别：数组操作

对指定数值数组变量内的所有数组成员进行快速排序，不影响数组的维定义信息，排序结果存放回该数组变量。

语法： 无返回值 数组排序 （数值数组变量，［排序方向是否为从小到大］）

参数名 | 描 述
数值数组变量 | 必需的；通用型，参数数据只能提供变量数组。
排序方向是否为从小到大 | 可选的；逻辑型。如果参数值为真，排序方向为从小到大，否则为从大到小。如果本参数被省略，默认值为真。

例程

说明：

把数组按成员的数值大小排序，如果第2个参数是“真”，则按从小到大排序，否则反之.。

参见：例程


数组清零 命令 所属类别：数组操作

数组清零 命令 　英文命令：ZeroAry　操作系统支持：Windows、Linux 所属类别：数组操作

将指定数值数组变量内的所有成员值全部设置为零，不影响数组的维定义信息。

语法： 无返回值 数组清零 （数值数组变量）

参数名 | 描 述
数值数组变量 | 必需的；通用型，参数数据只能提供变量数组。

例程：

说明：

把数组内所有成员的值设为0。只对数值型数组有效。

参见：例程


环境存取

环境存取 类别 跳至：系统核心支持库

取命令行 | 取运行目录 | 取执行文件名 | 读环境变量
写环境变量 |  |  |


取命令行 命令 操作系统支持：Windows、Linux 所属类别：环境存取

取命令行 命令 　英文命令：GetCmdLine　操作系统支持：Windows、Linux 所属类别：环境存取

本命令可以取出在启动易程序时附加在其可执行文件名后面的所有以空格分隔的命令行文本段。

语法： 无返回值 取命令行 （存放被取回命令行文本的数组变量）

参数名 | 描 述
存放被取回命令行文本的数组变量 | 必需的；文本型，参数数据只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入在启动易程序时附加在其可执行文件名后面的以空格分隔的命令行文本段。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为命令行文本段数。

例程

说明

通过“取命令行”命令程序启动时的附加参数，根据不同参数自动进入相应的操作窗口。

“取命令行”命令的最经典的例子就是易语言自带的实用程序“数据库管理器”。看一下易语言主菜单“数据库”下的三个子菜单项“结构编辑器”“记录编辑器”“设置数据库密码”，实际上调用的都是同一个程序（tools\dbmanger.exe），只是进入不同的窗口。

参考：例程1 调用例程


取运行目录 命令 操作系统支持：Windows 所属类别：环境存取

取运行目录 命令 　英文命令：GetRunPath　操作系统支持：Windows 所属类别：环境存取

取当前被执行的易程序文件所处的目录。

语法： 文本型 取运行目录 （）

例程

说明

通过“取运行目录”命令取出本程序所在的目录。

参考：例程1


取执行文件名 命令 操作系统支持：Windows 所属类别：环境存取

取执行文件名 命令 　英文命令：GetRunFileName　操作系统支持：Windows 所属类别：环境存取

取当前被执行的易程序文件的名称。

语法： 文本型 取执行文件名 （）

例程

说明

通过“取执行文件名”命令可以获取本程序的名称。

参考：例程1


读环境变量 命令 操作系统支持：Windows、Linux 所属类别：环境存取

读环境变量 命令 　英文命令：GetEnv　操作系统支持：Windows、Linux 所属类别：环境存取

返回文本，它关连于一个操作系统环境变量。成功时返回所取得的值，失败则返回空文本。

语法： 文本型 读环境变量 （环境变量名称）

参数名 | 描 述
环境变量名称 | 必需的；文本型。

例程

说明

通过“读环境变量”命令读取指定的环境变量。

想要查看环境变量请按照下面的顺序操作：

WIN2000以上版本：在“我的电脑”上右击→属性→点高级选项卡中的环境变量按钮进入环境变量设置。

WIN9X/ME：在MSDOS下输入SET命令查看。

参考：例程1


写环境变量 命令 操作系统支持：Windows、Linux 所属类别：环境存取

写环境变量 命令 　英文命令：PutEnv　操作系统支持：Windows、Linux 所属类别：环境存取

修改或建立指定的操作系统环境变量。成功返回真，失败返回假。

语法： 逻辑型 写环境变量 （环境变量名称，欲写入内容）

参数名 | 描 述
环境变量名称 | 必需的；文本型。
欲写入内容 | 必需的；文本型。

例程

说明

通过“写环境变量”命令更改已存在的环境变量。

想要查看环境变量请按照下面的顺序操作：

WIN2000以上版本：在“我的电脑”上右击→属性→点高级选项卡中的环境变量按钮进入环境变量设置。

WIN9X/ME：在MSDOS下输入SET命令查看。

参考：例程1


拼音处理

拼音处理 类别 跳至：系统核心支持库


取所有发音 命令 操作系统支持：Windows 所属类别：拼音处理

取所有发音 命令 　英文命令：GetAllPY　操作系统支持：Windows 所属类别：拼音处理

返回包含指定汉字所有拼音编码的文本数组（支持多音字），目前仅支持国标汉字。返回的数组结果可以用“复制数组”命令保存到同类型数组变量。

语法： 文本型数组 取所有发音 （欲取其拼音的汉字）

参数名 | 描 述
欲取其拼音的汉字 | 必需的；文本型。只取用文本首部的第一个汉字，如果该文本首部不为国标汉字，命令将返回一个成员数目为 0 的空文本数组。

例程

说明

通过“取所有发音”命令来获取指定汉字的所有读音。

参考：例程1


取发音数目 命令 操作系统支持：Windows 所属类别：拼音处理

取发音数目 命令 　英文命令：GetPYCount　操作系统支持：Windows 所属类别：拼音处理

返回指定汉字的发音数目。

语法： 整数型 取发音数目 （欲取其发音数目的汉字）

参数名 | 描 述
欲取其发音数目的汉字 | 必需的；文本型。只取用文本首部的第一个汉字，如果该文本首部不为国标汉字，命令将返回 0。

例程

说明

通过“取发音数目”命令获取指定汉字的发音数目。

参考：例程1


取拼音 命令 操作系统支持：Windows 所属类别：拼音处理

取拼音 命令 　英文命令：GetPY　操作系统支持：Windows 所属类别：拼音处理

返回包含指定汉字的指定拼音编码的文本。如果该指定拼音编码不存在，将返回空文本。目前仅支持国标汉字。多音字的第一个发音为常用音。

语法： 文本型 取拼音 （欲取其拼音编码的汉字，欲取拼音编码的索引）

参数名 | 描 述
欲取其拼音编码的汉字 | 必需的；文本型。只取用文本首部的第一个汉字，如果该文本首部不为国标汉字，命令将返回一个空文本。
欲取拼音编码的索引 | 必需的；整数型，初始值为“1”。应该在 1 到该汉字的发音数目之间。汉字的发音数目数目可以使用“取发音数目”命令取得。

例程

说明

通过“取拼音”命令取得指定汉字的读音。

参考：例程1


取声母 命令 操作系统支持：Windows 所属类别：拼音处理

取声母 命令 　英文命令：GetSM　操作系统支持：Windows 所属类别：拼音处理

返回包含指定汉字指定拼音编码的声母部分文本。如果指定拼音编码不存在或该汉字此发音无声母，将返回空文本。目前仅支持国标汉字。

语法： 文本型 取声母 （欲取其拼音编码的汉字，欲取拼音编码的索引）

参数名 | 描 述
欲取其拼音编码的汉字 | 必需的；文本型。只取用文本首部的第一个汉字，如果该文本首部不为国标汉字，命令将返回一个空文本。
欲取拼音编码的索引 | 必需的；整数型，初始值为“1”。应该在 1 到该汉字的发音数目之间。汉字的发音数目可以使用“取发音数目”命令取得。

例程

说明

通过“取声母”命令获取指定汉字的声母。

参考：例程1


取韵母 命令 操作系统支持：Windows 所属类别：拼音处理

取韵母 命令 　英文命令：GetYM　操作系统支持：Windows 所属类别：拼音处理

返回包含指定汉字指定拼音编码的韵母部分文本。如果指定拼音编码不存在，将返回空文本。目前仅支持国标汉字。

语法： 文本型 取韵母 （欲取其拼音编码的汉字，欲取拼音编码的索引）

参数名 | 描 述
欲取其拼音编码的汉字 | 必需的；文本型。只取用文本首部的第一个汉字，如果该文本首部不为国标汉字，命令将返回一个空文本。
欲取拼音编码的索引 | 必需的；整数型，初始值为“1”。应该在 1 到该汉字的发音数目之间。汉字的发音数目可以使用“取发音数目”命令取得。

例程

说明

通过“取韵母”命令取得指定汉字的韵母。

参考：例程1


发音比较 命令 操作系统支持：Windows 所属类别：拼音处理

发音比较 命令 　英文命令：CompPY　操作系统支持：Windows 所属类别：拼音处理

比较两个文本的发音，如果发音相同返回真，否则返回假。对于文本中的非国标汉字部分，将仅进行简单的值比较。

语法： 逻辑型 发音比较 （待比较文本一，待比较文本二，是否支持南方音，［是否为模糊比较］）

参数名 | 描 述
待比较文本一 | 必需的；文本型。
待比较文本二 | 必需的；文本型。
是否支持南方音 | 必需的；逻辑型，初始值为“真”。为真则支持南方音。如果支持南方音，比较时将认为所有相近的发音都相同。如： n 和 l、 z 和 zh、 ie 和 ue 等等。
是否为模糊比较 | 可选的；逻辑型。本参数为真时，当待比较文本一的发音在待比较文本二的首部被包容时即认为比较通过。如果被省略，默认值为假。

例程

说明

通过“发音比较”命令比较两个汉字的发音。

参考：例程1


输入字比较 命令 操作系统支持：Windows 所属类别：拼音处理

输入字比较 命令 　英文命令：CompPYCode　操作系统支持：Windows 所属类别：拼音处理

将一个拼音输入字文本与另外一个普通文本比较，如果两者相符，返回真，否则返回假。

语法： 逻辑型 输入字比较 （待比较拼音输入字，待比较普通文本，是否支持南方音，［拼音输入字类别］）

参数名 | 描 述
待比较拼音输入字 | 必需的；文本型。拼音输入字有以下三类： 一、首拼及全拼类： 如：“jsj”匹配“计算机”，同时“jisuanji”也匹配“计算机”。系统自动判别该输入字具体是首拼方式还是全拼方式； 二、双拼类： 如：“jisrji”匹配“计算机”，双拼编码的方案与 Windows 系统下的双拼输入法一致； 三、自动判别类： 使用此类别需在拼音输入字的首部加一个半角字符用作判别：分号 (“;”) 代表首拼及全拼类，冒号 (“:”) 代表双拼类，如既不为分号也不为冒号，则默认为首拼及全拼类。如“jsj”、“;jsj”、“;jisuanji”、“:jisrji”都匹配“计算机”。 另：书写拼音输入字时的一些规则： 一、为了匹配目标文本中的大小写英文字母，请在相应位置处使用对应的大写英文字母。如：“jsjA”匹配“计算机a”、“计算机A”； 二、为了匹配目标文本中的半角数字，请在相应位置处使用该数字。如：“jsj1”匹配“计算机1”； 三、为了匹配目标文本中的汉字符号或不知道发音的汉字，请在相应位置处使用该汉字。如：“j算j1”匹配“计算机1”； 四、拼音输入字内不能包含除了“_”以外的所有其他半角符号。
待比较普通文本 | 必需的；文本型。
是否支持南方音 | 必需的；逻辑型，初始值为“真”。为真则支持南方音。如果支持南方音，比较时将认为所有相近的发音都相同。如： n 和 l、 z 和 zh、 ie 和 ue 等等。
拼音输入字类别 | 可选的；整数型。参数值可以为以下常量之一： 1、#首拼及全拼； 2、#双拼； 3、#自动判别。 如果省略本参数，默认为“#自动判别”。

例程

说明

通过“输入字比较”命令拼音是否与指定汉字读音相同。

参考：例程1


文本操作

文本操作 类别 跳至：系统核心支持库

取文本长度 | 取文本左边 | 取文本右边 | 取文本中间
字符 | 取代码 | 寻找文本 | 倒找文本
到大写 | 到小写 | 到全角 | 到半角
到文本 | 删首空 | 删尾空 | 删首尾空
删全部空 | 文本替换 | 子文本替换 | 取空白文本
取重复文本 | 文本比较 | 分割文本 | 指针到文本


取文本长度 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取文本长度 命令 　英文命令：len　操作系统支持：Windows、Linux 所属类别：文本操作

取文本型数据的长度，不包含结束0。

语法： 整数型 取文本长度 （文本数据）

参数名 | 描 述
文本数据 | 必需的；文本型。参数值指定欲检查其长度的文本数据。

例程

说明

通过“取文本长度”命令获取指定文本的长度。注意，一个汉字的长度为2。

例如：取文本长度 (“易语言eyuyan”) 的返回值为12（“易语言”三个字的长度为6）。

参考：例程1


取文本左边 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取文本左边 命令 　英文命令：left　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定文本中从左边算起指定数量的字符。

语法： 文本型 取文本左边 （欲取其部分的文本，欲取出字符的数目）

参数名 | 描 述
欲取其部分的文本 | 必需的；文本型。
欲取出字符的数目 | 必需的；整数型。

例程

说明

通过“取文本左边”命令获取一段文本从左数起指定长度的文本。

参考：例程1


取文本右边 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取文本右边 命令 　英文命令：right　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定文本中从右边算起指定数量的字符。

语法： 文本型 取文本右边 （欲取其部分的文本，欲取出字符的数目）

参数名 | 描 述
欲取其部分的文本 | 必需的；文本型。
欲取出字符的数目 | 必需的；整数型。

例程

说明

通过“取文本右边”命令从右起取出4个字符（两个汉字）。

参考：例程1


取文本中间 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取文本中间 命令 　英文命令：mid　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定文本中从指定位置算起指定数量的字符。

语法： 文本型 取文本中间 （欲取其部分的文本，起始取出位置，欲取出字符的数目）

参数名 | 描 述
欲取其部分的文本 | 必需的；文本型。
起始取出位置 | 必需的；整数型。1为首位置，2为第2个位置，如此类推。
欲取出字符的数目 | 必需的；整数型。

例程

说明

通过“取文本中间”命令从一段文本中的指定位置起取出指定数量的字符。

参考：例程1


字符 命令 操作系统支持：Windows、Linux 所属类别：文本操作

字符 命令 　英文命令：chr　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含有与指定字符代码相关的字符。

语法： 文本型 字符 （欲取其字符的字符代码）

参数名 | 描 述
欲取其字符的字符代码 | 必需的；字节型。

例程

说明

通过“字符”命令将键代码转换为字符。

例如：键代码65代表字符A。

参考：例程1


取代码 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取代码 命令 　英文命令：asc　操作系统支持：Windows、Linux 所属类别：文本操作

返回文本中指定位置处字符的代码。如果指定位置超出文本长度，返回0。

语法： 整数型 取代码 （欲取字符代码的文本，［欲取其代码的字符位置］）

参数名 | 描 述
欲取字符代码的文本 | 必需的；文本型。
欲取其代码的字符位置 | 可选的；整数型。1为首位置，2为第2个位置，如此类推。如果本参数被省略，默认为首位置。

例程

说明

通过“取代码”命令得到一段文本中第一个字符的代码。

参考：例程1


寻找文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

寻找文本 命令 　英文命令：InStr　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个整数值，指定一文本在另一文本中最先出现的位置，位置值从 1 开始。如果未找到，返回-1。

语法： 整数型 寻找文本 （被搜寻的文本，欲寻找的文本，［起始搜寻位置］，是否不区分大小写）

参数名 | 描 述
被搜寻的文本 | 必需的；文本型。
欲寻找的文本 | 必需的；文本型。
起始搜寻位置 | 可选的；整数型。位置值从 1 开始。如果本参数被省略，默认为 1 。
是否不区分大小写 | 必需的；逻辑型，初始值为“假”。为真不区分大小写，为假区分。

例程

说明

通过“寻找文本”命令从一段文本中寻找指定文本的第一个出现位置。

参考：例程1


倒找文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

倒找文本 命令 　英文命令：InStrRev　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个整数值，指定一文本在另一文本中最后出现的位置，位置值从 1 开始。如果未找到，返回-1。

语法： 整数型 倒找文本 （被搜寻的文本，欲寻找的文本，［起始搜寻位置］，是否不区分大小写）

参数名 | 描 述
被搜寻的文本 | 必需的；文本型。
欲寻找的文本 | 必需的；文本型。
起始搜寻位置 | 可选的；整数型。位置值从 1 开始。如果本参数被省略，默认为从被搜寻文本的尾部开始。
是否不区分大小写 | 必需的；逻辑型，初始值为“假”。为真不区分大小写，为假区分。

例程

说明

通过“倒找文本”命令从指定文本中的指定起始位置开始从右向左寻找指定文本在这段文本中的位置。

参考：例程1


到大写 命令 操作系统支持：Windows、Linux 所属类别：文本操作

到大写 命令 　英文命令：UCase　操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的小写英文字母变换为大写，返回变换后的结果文本。

语法： 文本型 到大写 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到大写”命令将一段小写字母文本转换为大写格式。

例如：“Abcde” 转换为大写格式后为“ABCDE”。

参考：例程1


到小写 命令 操作系统支持：Windows、Linux 所属类别：文本操作

到小写 命令 　英文命令：LCase　操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的大写英文字母变换为小写，返回变换后的结果文本。

语法： 文本型 到小写 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到小写”命令将一段文本全部转换为小写。

例如：

“到小写（”ABcd”）”将返回“abcd”；

“到小写（”ABcd易语言”）”将返回“abcd易语言”； 注：对汉字没有影响。

参考：例程1


到全角 命令 操作系统支持：Windows、Linux 所属类别：文本操作

到全角 命令 　英文命令：QJCase　操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的半角字母、空格或数字变换为全角，返回变换后的结果文本。

语法： 文本型 到全角 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到全角”命令将指定文本转换为全角。

参考：例程1


到半角 命令 操作系统支持：Windows、Linux 所属类别：文本操作

到半角 命令 　英文命令：BJCase　操作系统支持：Windows、Linux 所属类别：文本操作

将文本中的全角字母、空格或数字变换为半角，返回变换后的结果文本。

语法： 文本型 到半角 （欲变换的文本）

参数名 | 描 述
欲变换的文本 | 必需的；文本型。

例程

说明

通过“到半角”命令将一段全角文本转换为半角。

参考：例程1


到文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

到文本 命令 　英文命令：str　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，代表指定数值、逻辑值或日期时间被转换后的结果。如果为文本数据，将被直接返回。

语法： 文本型 到文本 （待转换的数据）

参数名 | 描 述
待转换的数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值只能为数值、逻辑值、字节集、日期时间或数值型数组。

例程

说明

通过“到文本”命令将其他数据类型的数据转换为文本型。

参考：例程1


删首空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

删首空 命令 　英文命令：LTrim　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了首部全角或半角空格的指定文本。

语法： 文本型 删首空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删首空”命令将一段文本中文本前面的空格去掉。

参考：例程1


删尾空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

删尾空 命令 　英文命令：RTrim　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了尾部全角或半角空格的指定文本。

语法： 文本型 删尾空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删尾空”命令将一段文本中文字后面所有空格删掉。

参考：例程1


删首尾空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

删首尾空 命令 　英文命令：trim　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了首部及尾部全角或半角空格的指定文本。

语法： 文本型 删首尾空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删首尾空”命令将一段文本中文字前和文字后的空格全部删除。

参考：例程1


删全部空 命令 操作系统支持：Windows、Linux 所属类别：文本操作

删全部空 命令 　英文命令：TrimAll　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含被删除了所有全角或半角空格的指定文本。

语法： 文本型 删全部空 （欲删除空格的文本）

参数名 | 描 述
欲删除空格的文本 | 必需的；文本型。

例程

说明

通过“删全部空”命令将一段文本中的空格全部删除。

例如：“　　这里 既有全角　空格， 也有半角 空格。 ”删除全部空格后的结果是：“这里既有全角空格，也有半角空格。”。

参考：例程1


文本替换 命令 操作系统支持：Windows、Linux 所属类别：文本操作

文本替换 命令 　英文命令：ReplaceText　操作系统支持：Windows、Linux 所属类别：文本操作

将指定文本的某一部分用其它的文本替换。

语法： 文本型 文本替换 （欲被替换的文本，起始替换位置，替换长度，［用作替换的文本］）

参数名 | 描 述
欲被替换的文本 | 必需的；文本型。
起始替换位置 | 必需的；整数型。替换的起始位置，1为首位置，2为第2个位置，如此类推。
替换长度 | 必需的；整数型。
用作替换的文本 | 可选的；文本型。如果本参数被省略，则删除文本中的指定部分。

例程

说明

通过“文本替换”命令将编辑框内容中的前两个字符（从第1个字符起取2个字符）替换为“★★”。

注意一个汉字要算作两个字符。

参考：例程1


子文本替换 命令 操作系统支持：Windows、Linux 所属类别：文本操作

子文本替换 命令 　英文命令：RpSubText　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，该文本中指定的子文本已被替换成另一子文本，并且替换发生的次数也是被指定的。

语法： 文本型 子文本替换 （欲被替换的文本，欲被替换的子文本，［用作替换的子文本］，［进行替换的起始位置］，［替换进行的次数］，是否区分大小写）

参数名 | 描 述
欲被替换的文本 | 必需的；文本型。
欲被替换的子文本 | 必需的；文本型。
用作替换的子文本 | 可选的；文本型。如果本参数被省略，默认为空文本。
进行替换的起始位置 | 可选的；整数型。参数值指定被替换子文本的起始搜索位置。如果省略，默认从 1 开始。
替换进行的次数 | 可选的；整数型。参数值指定对子文本进行替换的次数。如果省略，默认进行所有可能的替换。
是否区分大小写 | 必需的；逻辑型，初始值为“真”。为真区分大小写，为假不区分。

例程

说明

将编辑框的内容中的"aa"替换成"11"，从第2位开始替换，替换2次。

如果编辑框中的内容是“aabcaadefaaghaa”，则替换后的结果是“aabc★def★ghaa”。

参考：例程1


取空白文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取空白文本 命令 　英文命令：space　操作系统支持：Windows、Linux 所属类别：文本操作

返回具有指定数目半角空格的文本。

语法： 文本型 取空白文本 （重复次数）

参数名 | 描 述
重复次数 | 必需的；整数型。

例程

说明

通过“取空白文本”命令获取指定数目的空白文本（空格）。

参考：例程1


取重复文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

取重复文本 命令 　英文命令：string　操作系统支持：Windows、Linux 所属类别：文本操作

返回一个文本，其中包含指定次数的文本重复结果。

语法： 文本型 取重复文本 （重复次数，待重复文本）

参数名 | 描 述
重复次数 | 必需的；整数型。
待重复文本 | 必需的；文本型。该文本将用于建立返回的文本。如果为空，将返回一个空文本。

例程

说明

通过“取重复文本”命令取得指定数量相同内容的文本。

例如：“取重复文本（3，”A”）”将返回“AAA”；

“取重复文本（2，”Abc”）”将返回“AbcAbc”。

参考：例程1


文本比较 命令 操作系统支持：Windows、Linux 所属类别：文本操作

文本比较 命令 　英文命令：StrComp　操作系统支持：Windows、Linux 所属类别：文本操作

如果返回值小于0，表示文本一小于文本二；如果等于0，表示文本一等于文本二；如果大于0，表示文本一大于文本二。如果比较时区分大小写，也可以使用比较运算符进行同样的操作。

语法： 整数型 文本比较 （待比较文本一，待比较文本二，是否区分大小写）

参数名 | 描 述
待比较文本一 | 必需的；文本型。
待比较文本二 | 必需的；文本型。
是否区分大小写 | 必需的；逻辑型，初始值为“真”。为真区分大小写，为假不区分。

例程

说明

通过“文本比较”命令比较两个文本ASCII码值大小。

参考：例程1


分割文本 命令 操作系统支持：Windows、Linux 所属类别：文本操作

分割文本 命令 　英文命令：split　操作系统支持：Windows、Linux 所属类别：文本操作

将指定文本进行分割，返回分割后的一维文本数组。

语法： 文本型数组 分割文本 （待分割文本，［用作分割的文本］，［要返回的子文本数目］）

参数名 | 描 述
待分割文本 | 必需的；文本型。如果参数值是一个长度为零的文本，则返回一个空数组，即没有任何成员的数组。
用作分割的文本 | 可选的；文本型。参数值用于标识子文本边界。如果被省略，则默认使用半角逗号字符作为分隔符。如果是一个长度为零的文本，则返回的数组仅包含一个成员，即完整的“待分割文本”。
要返回的子文本数目 | 可选的；整数型。如果被省略，则默认返回所有的子文本。

例程

说明

通过“分割文本”命令将一段文本通过指定文本分割。

参考：例程1


指针到文本 命令 操作系统支持：Windows 所属类别：文本操作

指针到文本 命令 　英文命令：pstr　操作系统支持：Windows 所属类别：文本操作

为高级用户提供，初级用户无需掌握；
返回指定内存指针所指向地址处的文本，注意调用本命令前一定要确保所提供的内存指针真实有效，且指向一个以零字符结束的文本串。本命令的最佳使用场合就是在易语言回调子程序和易语言DLL公开子程序用作获取外部数据。

语法： 文本型 指针到文本 （内存文本指针）

参数名 | 描 述
内存文本指针 | 必需的；整数型。本参数提供指向一个以零字符结束的文本串内存指针值。

例程

说明

在动态链接库（DLL）内部的子程序中，通过“指针到文本”读取指针（此处为变量“欲取的拼音”）所指向的文本。

注：标准DLL是不能直接传递文本数据的，需借助于“指针”。

参考：例程1 例程2


字节集操作

字节集操作 类别 跳至：系统核心支持库

取字节集长度 | 到字节集 | 取字节集数据 | 取字节集左边
取字节集右边 | 取字节集中间 | 寻找字节集 | 倒找字节集
字节集替换 | 子字节集替换 | 取空白字节集 | 取重复字节集
分割字节集 | 指针到字节集 |  |


取字节集长度 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取字节集长度 命令 　英文命令：BinLen　操作系统支持：Windows、Linux 所属类别：字节集操作

取字节集型数据的长度。

语法： 整数型 取字节集长度 （字节集数据）

参数名 | 描 述
字节集数据 | 必需的；字节集。参数值指定欲检查其长度的字节集数据。

例程

说明

通过“取字节集长度”命令获取图片框中图片数据的大小。

参考：例程1


到字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

到字节集 命令 　英文命令：ToBin　操作系统支持：Windows、Linux 所属类别：字节集操作

将指定数据转换为字节集后返回转换结果。

语法： 字节集 到字节集 （欲转换为字节集的数据）

参数名 | 描 述
欲转换为字节集的数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值只能为基本数据类型数据或数值型数组。

例程

说明

通过“到字节集命令”将其他数据类型转换为字节集类型。

参考：例程1


取出字节集中指定位置指定数据类型的数据

取字节集数据 命令 　英文命令：GetBinElement　操作系统支持：Windows、Linux 所属类别：字节集操作

取出字节集中指定位置指定数据类型的数据。

语法： 通用型 取字节集数据 （欲取出其中数据的字节集， 欲取出数据的类型， ［起始索引位置］）

参数名 | 描 述
欲取出其中数据的字节集 | 必需的； 字节集。
欲取出数据的类型 | 必需的； 整数型。参数值可以为以下常量： 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型； 9、#子程序指针型； 10、#文本型。转换后的数据将自动进行有效性校验及转换处理。
起始索引位置 | 可选的； 整数型。指定从字节集的什么地方开始取数据，索引值从1开始。如果被省略，默认为数值1。如果为本参数提供一个整数型变量，则命令执行后将自动修改该变量内容，将其索引值移动到下一个读入位置。如果移动后到达字节集的末尾，将修改该变量的内容为-1。

例程

说明

取出字节集中指定位置指定数据类型的数据。

参考：例程1


取字节集左边 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取字节集左边 命令 　英文命令：BinLeft　操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定字节集中从左边算起指定数量的字节。

语法： 字节集 取字节集左边 （欲取其部分的字节集，欲取出字节的数目）

参数名 | 描 述
欲取其部分的字节集 | 必需的；字节集。
欲取出字节的数目 | 必需的；整数型。

例程

说明

通过“取字节集左边”命令从指定字节集中左起取得指定字节大小的字节集。

参考：例程1


取字节集右边 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取字节集右边 命令 　英文命令：BinRight　操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定字节集中从右边算起指定数量的字节。

语法： 字节集 取字节集右边 （欲取其部分的字节集，欲取出字节的数目）

参数名 | 描 述
欲取其部分的字节集 | 必需的；字节集。
欲取出字节的数目 | 必需的；整数型。

例程

说明

通过“取字节集右边”命令，从指定字节集中右起取出指定字节长度的字节集。

参考：例程1


取字节集中间 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取字节集中间 命令 　英文命令：BinMid　操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定字节集中从指定位置算起指定数量的字节。

语法： 字节集 取字节集中间 （欲取其部分的字节集，起始取出位置，欲取出字节的数目）

参数名 | 描 述
欲取其部分的字节集 | 必需的；字节集。
起始取出位置 | 必需的；整数型。1为首位置，2为第2个位置，如此类推。
欲取出字节的数目 | 必需的；整数型。

例程

说明

通过“取字节集中间”命令，从指定字节集中指定位置起取出指定字节大小的字节集。

参考：例程1


寻找字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一字节集在另一字节集中最先出现的位置，位置值从 1 开始。如果未找到，返回 -1。

语法： 整数型 寻找字节集 （被搜寻的字节集，欲寻找的字节集，［起始搜寻位置］）

参数名 | 描 述
被搜寻的字节集 | 必需的；字节集。
欲寻找的字节集 | 必需的；字节集。
起始搜寻位置 | 可选的；整数型。1为首位置，2为第2个位置，如此类推，如果被省略，则“寻找字节集”命令默认从首部开始，“倒找字节集”命令默认从尾部开始。

例程

说明

通过“寻找字节集”命令在指定字节集中由前向后寻找符合条件的字节集。

参考：例程


倒找字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

返回一字节集在另一字节集中最后出现的位置，位置值从 1 开始。如果未找到，返回 -1。

语法： 整数型 倒找字节集 （被搜寻的字节集，欲寻找的字节集，［起始搜寻位置］）

参数名 | 描 述
被搜寻的字节集 | 必需的；字节集。
欲寻找的字节集 | 必需的；字节集。
起始搜寻位置 | 可选的；整数型。1为首位置，2为第2个位置，如此类推，如果被省略，则“寻找字节集”命令默认从首部开始，“倒找字节集”命令默认从尾部开始。

例程

说明

通过“倒找字节集”命令从指定字节集中由后向前寻找指定字节集。

参考：例程


字节集替换 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

字节集替换 命令 　英文命令：RpBin　操作系统支持：Windows、Linux 所属类别：字节集操作

将指定字节集的某一部分用其它的字节集替换，然后返回替换后的结果。

语法： 字节集 字节集替换 （欲替换其部分的字节集，起始替换位置，替换长度，［用作替换的字节集］）

参数名 | 描 述
欲替换其部分的字节集 | 必需的；字节集。
起始替换位置 | 必需的；整数型。替换的起始位置，1为首位置，2为第2个位置，如此类推。
替换长度 | 必需的；整数型。
用作替换的字节集 | 可选的；字节集。如果本参数被省略，则删除字节集中的指定部分。

例程

说明

通过“字节集替换”命令将指定字节集中指定起始位置指定长度的字节集替换。

参考：例程1


子字节集替换 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

子字节集替换 命令 　英文命令：RpSubBin　操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，该字节集中指定的子字节集已被替换成另一子字节集，并且替换发生的次数也是被指定的。

语法： 字节集 子字节集替换 （欲被替换的字节集，欲被替换的子字节集，［用作替换的子字节集］，［进行替换的起始位置］，［替换进行的次数］）

参数名 | 描 述
欲被替换的字节集 | 必需的；字节集。
欲被替换的子字节集 | 必需的；字节集。
用作替换的子字节集 | 可选的；字节集。如果省略本参数，则默认为空字节集。
进行替换的起始位置 | 可选的；整数型。被替换子字节集的起始搜索位置。如果省略，默认从1开始。
替换进行的次数 | 可选的；整数型。对子字节集进行替换的次数。如果省略，默认进行所有可能的替换。

例程

说明

通过“子字节集替换”命令将指定字节集中的字节集替换。

参考：例程1


取空白字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取空白字节集 命令 　英文命令：SpaceBin　操作系统支持：Windows、Linux 所属类别：字节集操作

返回具有特定数目 0 字节的字节集。

语法： 字节集 取空白字节集 （零字节数目）

参数名 | 描 述
零字节数目 | 必需的；整数型。

例程

说明

通过“取空白字节集”命令获得指定长度的空字节集。

参考：例程1


取重复字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

取重复字节集 命令 　英文命令：bin　操作系统支持：Windows、Linux 所属类别：字节集操作

返回一个字节集，其中包含指定次数的字节集重复结果。

语法： 字节集 取重复字节集 （重复次数，待重复的字节集）

参数名 | 描 述
重复次数 | 必需的；整数型。
待重复的字节集 | 必需的；字节集。该字节集将用于建立返回的字节集。如果为空，将返回一个空字节集。

例程

说明

通过“取重复字节集”命令获取指定数量的相同字节集。

参考：例程1


分割字节集 命令 操作系统支持：Windows、Linux 所属类别：字节集操作

分割字节集 命令 　英文命令：SplitBin　操作系统支持：Windows、Linux 所属类别：字节集操作

将指定字节集进行分割，返回分割后的一维字节集数组。

语法： 字节集数组 分割字节集 （待分割字节集，［用作分割的字节集］，［要返回的子字节集数目］）

参数名 | 描 述
待分割字节集 | 必需的；字节集。如果参数值是一个长度为零的字节集，则返回一个空数组，即没有任何成员的数组。
用作分割的字节集 | 可选的；字节集。用于标识子字节集边界。本参数如果被省略，则默认使用字节 0 作为分隔符。
要返回的子字节集数目 | 可选的；整数型。如果被省略，则默认返回所有的子字节集。

例程

说明

通过“分割字节集”命令将指定字节集按表示字节集分割。

参考：例程1


指针到字节集 命令 操作系统支持：Windows 所属类别：字节集操作

指针到字节集 命令 　英文命令：pbin　操作系统支持：Windows 所属类别：字节集操作

为高级用户提供，初级用户无需掌握；
返回指定内存指针所指向地址处的一段数据，注意调用本命令前一定要确保所提供的内存地址段真实有效。本命令的最佳使用场合就是在易语言回调子程序和易语言DLL公开子程序用作获取外部数据。

语法： 字节集 指针到字节集 （内存数据指针，内存数据长度）

参数名 | 描 述
内存数据指针 | 必需的；整数型。本参数提供指向一个内存地址的指针值。
内存数据长度 | 必需的；整数型。本参数提供该内存地址处所需获取的数据长度。

例程

说明

在动态链接库（DLL）内部的子程序中，通过“指针到字节集”命令获取指针（此处为“图标”变量）所指向的字节集。

注：标准DLL是不能直接传递字节集数据的，需借助于“指针”。

参考：例程1


数值转换

数值转换 类别 跳至：系统核心支持库


到数值 命令 操作系统支持：Windows、Linux 所属类别：数值转换

到数值 命令 　英文命令：val　操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为双精度小数。

语法： 双精度小数型 到数值 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的；通用型。

例程

说明

编辑框中的内容为文本型，如果需要计算编辑框中的内容或者把其它非数值型数据放入到数值型数据中，就需要用到数值命令把这些数据转换到数值型。

参考：例程1


数值到大写 命令 操作系统支持：Windows、Linux 所属类别：数值转换

数值到大写 命令 　英文命令：UNum　操作系统支持：Windows、Linux 所属类别：数值转换

将数值转换为简体或繁体的大写形式，返回转换后的文本。

语法： 文本型 数值到大写 （欲转换形式的数值，是否转换为简体）

参数名 | 描 述
欲转换形式的数值 | 必需的；双精度小数型。
是否转换为简体 | 必需的；逻辑型，初始值为“假”。如果参数值为假，则转换为繁体。

例程

说明

通过“数值到大写”命令将数值型数据转换为中文数字（大写）。

参考：例程1


数值到金额 命令 操作系统支持：Windows、Linux 所属类别：数值转换

数值到金额 命令 　英文命令：NumToRMB　操作系统支持：Windows、Linux 所属类别：数值转换

将数值转换为金额的简体或繁体大写形式，返回转换后的文本。

语法： 文本型 数值到金额 （欲转换形式的数值，是否转换为简体）

参数名 | 描 述
欲转换形式的数值 | 必需的；双精度小数型。
是否转换为简体 | 必需的；逻辑型，初始值为“假”。如果参数值为假，则转换为繁体。

例程

说明

通过“数值到金额”命令将数值转换为货币格式格式。

参考：例程1


数值到格式文本 命令 操作系统支持：Windows、Linux 所属类别：数值转换

数值到格式文本 命令 　英文命令：NumToText　操作系统支持：Windows、Linux 所属类别：数值转换

返回一个文本，代表指定数值被格式转换后的结果。

语法： 文本型 数值到格式文本 （欲转换为文本的数值，［小数保留位数］，是否进行千分位分隔）

参数名 | 描 述
欲转换为文本的数值 | 必需的；双精度小数型。
小数保留位数 | 可选的；整数型。如果大于0，表示小数点右边应四舍五入保留的位数；如果等于0，表示舍入到整数；如果小于0，表示小数点左边舍入到的位置。例如：数值到格式文本 (1056.65, 1, 假) 返回 “1056.7”； 数值到格式文本 (1056.65, 0, 假) 返回 “1056”； 数值到格式文本 (1056.65, -1, 假) 返回 “1060”。如果省略本参数，则默认为保留所有实际存在的小数位。
是否进行千分位分隔 | 必需的；逻辑型，初始值为“假”。如果参数值为真，数值文本的每个千分位上都将被自动插入一个逗号进行分隔。

例程

说明

通过“数值到格式文本”命令将数值转换为指定格式的文本。

参考：例程1


取十六进制文本 命令 操作系统支持：Windows、Linux 所属类别：数值转换

取十六进制文本 命令 　英文命令：hex　操作系统支持：Windows、Linux 所属类别：数值转换

返回一个文本，代表指定数值的十六进制形式。

语法： 文本型 取十六进制文本 （欲取进制文本的数值）

参数名 | 描 述
欲取进制文本的数值 | 必需的；整数型。

例程

说明

通过“取十六进制文本”命令将一个十进制数值转换为十六进制文本。

参考：例程1


取八进制文本 命令 操作系统支持：Windows、Linux 所属类别：数值转换

取八进制文本 命令 　英文命令：oct　操作系统支持：Windows、Linux 所属类别：数值转换

返回一个文本，代表指定数值的八进制形式。

语法： 文本型 取八进制文本 （欲取进制文本的数值）

参数名 | 描 述
欲取进制文本的数值 | 必需的；整数型。

例程

说明

通过“取八进制文本”命令将一个十进制数值转换为八进制文本。

参考：例程1


到字节

到字节 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的字节值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为字节。

语法： 字节型 到字节 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为字节。

参见：例程1


到短整数

到短整数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的短整数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为短整数。

语法： 短整数型 到短整数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为短整数。

参见：例程1


到整数

到整数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的整数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为整数。

语法： 整数型 到整数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为整数。

参见：例程1


到长整数

到长整数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的长整数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为长整数。

语法： 长整数型 到长整数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为长整数。

参见：例程1


到小数

到小数 命令 操作系统支持：Windows、Linux 所属类别：数值转换

返回包含于文本内的小数值，文本中是一个适当类型的数值，支持全角书写方式。本命令也可用作将其他类型的数据转换为小数。

语法： 小数型 到小数 （待转换的文本或数值）

参数名 | 描 述
待转换的文本或数值 | 必需的； 通用型。

例程：

说明：

本命令也可用作将其他类型的数据转换为小数。

参见：例程1


时间操作

时间操作 类别 跳至：系统核心支持库

到时间 | 增减时间 | 取时间间隔 | 取某月天数
时间到文本 | 取时间部分 | 取年份 | 取月份
取日 | 取星期几 | 取小时 | 取分钟
取秒 | 指定时间 | 取现行时间 | 置现行时间
取日期 | 取时间 |  |


到时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

到时间 命令 　英文命令：ToTime　操作系统支持：Windows、Linux 所属类别：时间操作

将指定文本转换为时间并返回。如果给定文本不符合书写格式要求或者时间值错误导致不能进行转换，将返回100年1月1日。如果给定参数本身就是时间数据，将直接返回该时间。

语法： 日期时间型 到时间 （欲转换的文本）

参数名 | 描 述
欲转换的文本 | 必需的；通用型。文本内容应按以下格式之一提供，年份后的时间部分可以省略： 1、1973年11月15日12时30分25秒 2、1973/11/15 12:30:25 3、1973/11/15/12/30/25 4、1973/11/15/12:30:25 5、1973-11-15-12-30-25 6、1973-11-15-12:30:25 7、19731115123025

例程：

说明：

首先将编辑框中输入的时间转换成日期时间型的数据，然后用“取月份”命令将月份取出，并显示在“显示结果编辑框”中。时间操作类命令很多都是对日期时间型数据进行操作，所以可以将一个通用型数据用“到时间”命令转换成日期时间型数据，然后再使用其它命令进行操作。

参见：例程1


增减时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

增减时间 命令 　英文命令：TimeChg　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个时间，这一时间被加上或减去了一段间隔。如果改变后的时间无效，将自动靠近最近的有效时间。

语法： 日期时间型 增减时间 （时间，被增加部分，增加值）

参数名 | 描 述
时间 | 必需的；日期时间型。
被增加部分 | 必需的；整数型。参数值指定增加或减少时间的哪一部分，可以为以下常量： 1、#年份； 2、#季度； 3、#月份； 4、#周； 5、#日； 6、#小时； 7、#分钟； 8、#秒。
增加值 | 必需的；整数型。相对于被增加部分的增加或减少数值。

例程

说明

用一个调节钮组件来控制编辑框中的时间，当上调节钮被按下，编辑框中时间的“日”部分就增加1，下调节钮被按下，编辑框中时间“日”部分就减1。用“增减时间”命令控制时间增减，会按照日期时间的特点自动改变年月日，例如当“日”部分超过本月最后一天，“月份”部分会自动进位。

参见：例程1


取时间间隔 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取时间间隔 命令 　英文命令：TimeDiff　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个数值，表示“时间1”减去“时间2”之后的间隔数目。注意：每个星期以星期天为第一天。

语法： 双精度小数型 取时间间隔 （时间1，时间2，取间隔部分）

参数名 | 描 述
时间1 | 必需的；日期时间型。
时间2 | 必需的；日期时间型。
取间隔部分 | 必需的；整数型。参数值指定取时间间隔的单位，可以为以下常量： 1、#年份； 2、#季度； 3、#月份； 4、#周； 5、#日； 6、#小时； 7、#分钟； 8、#秒。

例程：

说明：

程序运行后，“当前时间标签”显示出当前时间，在“目的时间编辑框”中输入一个时间，通过“取时间间隔”命令，取出2个时间相差多少天，并显示在“显示结果标签”中。

参见：例程1


取某月天数 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取某月天数 命令 　英文命令：GetDaysOfSpecMonth　操作系统支持：Windows、Linux 所属类别：时间操作

返回指定月份所包含的天数。如果给定的月份无效，返回0。

语法： 整数型 取某月天数 （年份，月份）

参数名 | 描 述
年份 | 必需的；整数型。参数值从 100 到 9999。
月份 | 必需的；整数型。参数值从 1 到 12。

例程

说明

取出所指定的年度月份有多少天，并用信息框显示。

参见：例程1


时间到文本 命令 操作系统支持：Windows、Linux 所属类别：时间操作

时间到文本 命令 　英文命令：TimeToText　操作系统支持：Windows、Linux 所属类别：时间操作

将指定时间转换为文本并返回。

语法： 文本型 时间到文本 （欲转换到文本的时间，［转换部分］）

参数名 | 描 述
欲转换到文本的时间 | 必需的；日期时间型。
转换部分 | 可选的；整数型。参数值可以为以下常量： 1、#全部转换； 2、#日期部分； 3、#时间部分。如果省略了本参数，默认为“#全部转换”。

例程

说明

用“时间到文本”命令，将指定时间的日期部分转换成文本数据，显示在新日期标签中。

参见：例程1


取时间部分 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取时间部分 命令 　英文命令：TimePart　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个包含已知时间指定部分的整数。

语法： 整数型 取时间部分 （欲取其部分的时间，欲取的时间部分）

参数名 | 描 述
欲取其部分的时间 | 必需的；日期时间型。
欲取的时间部分 | 必需的；整数型。参数值可以为以下常量： 1、#年份； 2、#季度； 3、#月份； 4、#自年首周数； 5、#日； 6、#小时； 7、#分钟； 8、#秒； 9、#星期几； 10、#自年首天数。其中：自年首周数、自年首天数均从 1 开始。

例程

说明

“当前时间编辑框”中显示当前时间，用“取时间部分”命令将其“小时”部分取出，显示在“取出结果编辑框”中。

参见：例程1


取年份 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取年份 命令 　英文命令：year　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 100 到 9999 之间的整数，表示指定时间中的年份。

语法： 整数型 取年份 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

当前编辑框中显示出当前的时间，用“取年份”命令将其“年份”部分取出，并显示在“取出编辑框”中。

参见：例程1


取月份 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取月份 命令 　英文命令：month　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 1 到 12 之间的整数，表示指定时间中的月份。

语法： 整数型 取月份 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

用“取月份”命令将现行时间的“月份”部分取出，并显示在编辑框中。

参见：例程1


取日 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取日 命令 　英文命令：day　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 1 到 31 之间的整数，表示一个月中的某一日。

语法： 整数型 取日 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

将“现行时间编辑框”中的日期转换成日期时间型数据，然后用“取日”命令将编辑框中日期的“日”部分取出，并将结果转换成文本型数据，显示在编辑框中。

参见：例程1


取星期几 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取星期几 命令 　英文命令：WeekDay　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 1 到 7 之间的整数，表示一个星期中的某一日。星期日为 1，星期一为 2，依此类推。

语法： 整数型 取星期几 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

用“取现行时间”命令取出当前的系统时间，然后用“取星期几”命令取出当前日期为星期几，并显示在标签中。

参见：例程1


取小时 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取小时 命令 　英文命令：hour　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 0 到 23 之间的整数，表示一天中的某一小时。

语法： 整数型 取小时 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

将当前时间的“小时”部分取出来，显示在编辑框中。

参见：例程1


取分钟 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取分钟 命令 　英文命令：minute　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 0 到 59 之间的整数，表示一小时中的某一分钟。

语法： 整数型 取分钟 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

将“现行时间编辑框”中的时间文本转换成日期时间型数据，通过“取分钟”命令将“分钟部分取出”，并显示在“显示分钟编辑框”中。

参见：例程1


取秒 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取秒 命令 　英文命令：second　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个值为 0 到 59 之间的整数，表示一分钟中的某一秒。

语法： 整数型 取秒 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

在时钟周期事件子程序中将现行时间的“秒”部分取出，并显示在编辑框中。

参见：例程1


指定时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

指定时间 命令 　英文命令：GetSpecTime　操作系统支持：Windows、Linux 所属类别：时间操作

返回包含指定年、月、日、小时、分、秒的时间。如果指定了无效时间，将自动使用最相近的有效时间代替。

语法： 日期时间型 指定时间 （年，［月］，［日］，［小时］，［分钟］，［秒］）

参数名 | 描 述
年 | 必需的；整数型。
月 | 可选的；整数型。如果本参数被省略，默认为 1 月。
日 | 可选的；整数型。如果本参数被省略，默认为 1 日。
小时 | 可选的；整数型。如果本参数被省略，默认为 0 时。
分钟 | 可选的；整数型。如果本参数被省略，默认为 0 分钟。
秒 | 可选的；整数型。如果本参数被省略，默认为 0 秒。

例程

说明

点击不同的按钮指定不同的时间，“指定错误时间”按钮将指定一个无效的时间，所以“指定时间”命令会自动使用最相近的有效时间代替，标签会显示2004年2月29日12时20分30秒。该命令的参数除年份外都是可选的，所以可以指定任意部分的时间。

参见：例程1


取现行时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取现行时间 命令 　英文命令：now　操作系统支持：Windows、Linux 所属类别：时间操作

返回当前系统日期及时间。

语法： 日期时间型 取现行时间 （）

例程

说明

时钟运行后，将每秒种取一次现行时间，并显示在标签中。本命令取出的时间是系统的现行时间，改变系统时间，取出的时间也会随着改变。

参见：例程1


置现行时间 命令 操作系统支持：Windows 所属类别：时间操作

置现行时间 命令 　英文命令：SetSysTime　操作系统支持：Windows 所属类别：时间操作

设置当前系统日期及时间。成功返回真，失败返回假。

语法： 逻辑型 置现行时间 （欲设置的时间）

参数名 | 描 述
欲设置的时间 | 必需的；日期时间型。

例程

说明

点击按钮后就将当前系统时间设置为“日期框”显示的时间。如果要直接设置当前时间为指定日期，需要在参数中填写日期时间型数据，填写方法如下：

参见：例程1


取日期 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取日期 命令 　英文命令：GetDatePart　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个日期时间型数据的日期部分，其小时、分钟、秒被固定设置为0时0分0秒。

语法： 日期时间型 取日期 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

取出现行时间中的日期部分，显示在编辑框中。如果只需要日期中的年月日部分，用“取日期”命令是非常方便的，但要注意命令的返回值是一个日期时间型的数据。

参见：例程1


取时间 命令 操作系统支持：Windows、Linux 所属类别：时间操作

取时间 命令 　英文命令：GetTimePart　操作系统支持：Windows、Linux 所属类别：时间操作

返回一个日期时间型数据的时间部分，其年、月、日被固定设置为2000年1月1日。

语法： 日期时间型 取时间 （时间）

参数名 | 描 述
时间 | 必需的；日期时间型。

例程

说明

用“取时间”命令取出“取现行时间”命令返回的现行时间的时、分、秒部分。

参见：例程1


磁盘操作

磁盘操作 类别 跳至：系统核心支持库

取磁盘总空间 | 取磁盘剩余空间 | 取磁盘卷标 | 置磁盘卷标
改变驱动器 | 改变目录 | 取当前目录 | 创建目录
删除目录 | 复制文件 | 移动文件 | 删除文件
文件更名 | 文件是否存在 | 寻找文件 | 取文件时间
取文件尺寸 | 取文件属性 | 置文件属性 | 取临时文件名
读入文件 | 写到文件 |  |


取磁盘总空间 命令 操作系统支持：Windows 所属类别：磁盘操作

取磁盘总空间 命令 　英文命令：GetDiskTotalSpace　操作系统支持：Windows 所属类别：磁盘操作

返回以 1024 字节（KB）为单位的指定磁盘全部空间。如果失败，返回-1。

语法： 整数型 取磁盘总空间 （［磁盘驱动器字符］）

参数名 | 描 述
磁盘驱动器字符 | 可选的；文本型。类似“A”、“B”、“C”等，只取用给定文本的第一个字符。如果本参数被省略，默认使用当前驱动器。

例程

说明

“取磁盘总空间”命令取出“驱动器”组件指定的驱动器的磁盘空间，并存放在“磁盘空间”变量中，然后用信息框显示磁盘的空间。

参见 例程1


取磁盘剩余空间 命令 操作系统支持：Windows 所属类别：磁盘操作

取磁盘剩余空间 命令 　英文命令：GetDiskFreeSpace　操作系统支持：Windows 所属类别：磁盘操作

返回以 1024 字节（KB）为单位的指定磁盘现行剩余空间。如果失败，返回-1。

语法： 整数型 取磁盘剩余空间 （［磁盘驱动器字符］）

参数名 | 描 述
磁盘驱动器字符 | 可选的；文本型。类似“A”、“B”、“C”等，只取用给定文本的第一个字符。如果本参数被省略，默认使用当前驱动器。

例程

说明

首先将磁盘的剩余空间取出，并存放在“剩余空间”变量中。然后判断，如果磁盘的剩余空间大于102400k，就复制文件到目标磁盘；如果磁盘剩余空间不足就弹出信息框提示。

参见 例程1


取磁盘卷标 命令 操作系统支持：Windows 所属类别：磁盘操作

取磁盘卷标 命令 　英文命令：GetDiskLabel　操作系统支持：Windows 所属类别：磁盘操作

返回指定磁盘的卷标文本。

语法： 文本型 取磁盘卷标 （［磁盘驱动器字符］）

参数名 | 描 述
磁盘驱动器字符 | 可选的；文本型。类似“A”、“B”、“C”等，只取用给定文本的第一个字符。如果本参数被省略，默认使用当前驱动器。

例程

说明

用“取磁盘卷标”命令将指定磁盘的卷标取出，并存放在“磁盘卷标”变量中，然后用信息框显示该盘的磁盘卷标。

参见 例程1


置磁盘卷标 命令 操作系统支持：Windows 所属类别：磁盘操作

置磁盘卷标 命令 　英文命令：SetDiskLabel　操作系统支持：Windows 所属类别：磁盘操作

设置指定磁盘的卷标文本。成功返回真，失败返回假。

语法： 逻辑型 置磁盘卷标 （［磁盘驱动器字符］，欲置入的卷标文本）

参数名 | 描 述
磁盘驱动器字符 | 可选的；文本型。类似“A”、“B”、“C”等，只取用给定文本的第一个字符。如果本参数被省略，默认使用当前驱动器。
欲置入的卷标文本 | 必需的；文本型。

例程

说明

将磁盘卷标设置为“输入卷标编辑框”中的内容，并将返回的逻辑值存放在“是否设置成功”变量中，然后用信息框显示设置是否成功。

参见 例程1


改变驱动器 命令 操作系统支持：Windows 所属类别：磁盘操作

改变驱动器 命令 　英文命令：ChDrive　操作系统支持：Windows 所属类别：磁盘操作

改变当前的缺省驱动器。成功返回真，失败返回假。

语法： 逻辑型 改变驱动器 （欲改变到的驱动器）

参数名 | 描 述
欲改变到的驱动器 | 必需的；文本型。参数值指明一个存在的驱动器。类似“A”、“B”、“C”等，只取用给定文本的第一个字符。如果使用零长度的文本，则当前的驱动器不会改变。

例程

说明

将当前的缺省驱动器改为“驱动器框”组件指定的驱动器，信息框显示是否改变成功。

参见 例程1


改变目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

改变目录 命令 　英文命令：ChDir　操作系统支持：Windows、Linux 所属类别：磁盘操作

改变当前的目录，但不会改变缺省驱动器位置。成功返回真，失败返回假。

语法： 逻辑型 改变目录 （欲改变到的目录）

参数名 | 描 述
欲改变到的目录 | 必需的；文本型。参数值指明哪个目录将成为新的缺省目录，可能会包含驱动器。如果没有指定驱动器，则在当前的驱动器上改变缺省目录。

例程

说明

先在“改变前目录编辑框”中显示系统默认的当前目录，然后用浏览文件夹选择要改变到的目录，将选择的目录名存放在“改变的目录名”变量中，用“改变目录”命令将当前目录改变成在浏览文件夹中选择的文件，然后用“改变后目录编辑框”显示出改变后的当前目录。

参见 例程1


取当前目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

取当前目录 命令 　英文命令：CurDir　操作系统支持：Windows、Linux 所属类别：磁盘操作

返回一个文本，用来代表当前的目录。如果失败，返回空文本。

语法： 文本型 取当前目录 （）

例程

说明

用信息框显示出系统的当前目录。系统的当前目录是可变的，可以使用“改变目录”命令改变（参见：改变目录）。

参见 例程1


创建目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

创建目录 命令 　英文命令：MkDir　操作系统支持：Windows、Linux 所属类别：磁盘操作

创建一个新的目录。成功返回真，失败返回假。

语法： 逻辑型 创建目录 （欲创建的目录名称）

参数名 | 描 述
欲创建的目录名称 | 必需的；文本型。

例程

说明

按钮被点击后弹出一个“浏览文件夹”对话框，选择一个路径后，将该路径存放在“创建目录路径”变量中，然后和“目录名编辑框”中的内容组成了要创建文件夹的完整路径名，并用“创建目录”命令创建它，将创建结果存放在“是否创建成功”变量中，最后用信息框显示是否创建成功。

要注意的是，该命令只能能创建所有父目录都存在的文件夹，如果其中有一级子目录不存在将会创建失败。

参见 例程1


删除目录 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

删除目录 命令 　英文命令：RmDir　操作系统支持：Windows、Linux 所属类别：磁盘操作

删除一个存在的目录。成功返回真，失败返回假。

语法： 逻辑型 删除目录 （欲删除的目录名称）

参数名 | 描 述
欲删除的目录名称 | 必需的；文本型。该目录应实际存在，如果目录中存在文件或子目录，将被一并删除，因此使用本命令请千万慎重。

例程

说明

使用浏览文件夹选择要删除的目录，并将目录名存放在“欲删除的目录”变量中，然后弹出信息框询问是否删除，如果点击“是钮”，则执行“删除目录”命令删除选中的文件夹，并用信息框显示是否删除成功。

参见 例程1


复制文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

复制文件 命令 　英文命令：FileCopy　操作系统支持：Windows、Linux 所属类别：磁盘操作

成功返回真，失败返回假。

语法： 逻辑型 复制文件 （被复制的文件名，复制到的文件名）

参数名 | 描 述
被复制的文件名 | 必需的；文本型。
复制到的文件名 | 必需的；文本型。

例程

说明

“选择复制文件”按钮被单击后弹出通用对话框，在通用对话框中选择要复制的文件，并将被选择的文件名显示在“被复制文件名编辑框”中；“复制文件”按钮被单击后，弹出浏览文件夹，选择复制到文件的目录，被选择的目录加“文件名编辑框”中的文件名，组成了复制到文件的全路径文件名，最后用信息框显示是否复制成功。

该命令的两个参数都必须是全路径文件名。

参见 例程1


移动文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

移动文件 命令 　英文命令：FileMove　操作系统支持：Windows、Linux 所属类别：磁盘操作

将文件从一个位置移动到另外一个位置。成功返回真，失败返回假。

语法： 逻辑型 移动文件 （被移动的文件，移动到的位置）

参数名 | 描 述
被移动的文件 | 必需的；文本型。
移动到的位置 | 必需的；文本型。

例程

说明

打开通用对话框1，选择一个文件，用取文本长度和倒找文本配合使用，得到该文件不带路径的名字，放入选择文件按钮.标题中；使用浏览文件夹，得到所移动到的新的目录；最后将该文件移动到新的地方。本命令只是路径改变，文件名没变。

参见 例程1


删除文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

删除文件 命令 　英文命令：kill　操作系统支持：Windows、Linux 所属类别：磁盘操作

成功返回真，失败返回假。

语法： 逻辑型 删除文件 （欲删除的文件名）

参数名 | 描 述
欲删除的文件名 | 必需的；文本型。

例程

说明

打开通用对话框1，选定一个文件，会弹出一个确认取消钮信息框，如果点击确认，则刚才选择的文件被删除，并弹出信息框提示是否删除成功。

参见 例程1


文件更名 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

文件更名 命令 　英文命令：name　操作系统支持：Windows、Linux 所属类别：磁盘操作

重新命名一个文件或目录。成功返回真，失败返回假。

语法： 逻辑型 文件更名 （欲更名的原文件或目录名，欲更改为的现文件或目录名）

参数名 | 描 述
欲更名的原文件或目录名 | 必需的；文本型。
欲更改为的现文件或目录名 | 必需的；文本型。

例程

说明

打开通用对话框1，选定一个文件，将文件名放入“原文件名编辑框”中；“文件更名”按钮被单击后，浏览文件夹，选择一个路径，并将该路径存放在“文件目录”变量中，然后根据目标编辑框中的内容变更文件名称。信息框显示是否变更成功。

该命令如果给目标文件名与原文件名相同的路径，会将原文件更名，如果是不同的目录，则命令会复制并更名原文件。

参见 例程1


文件是否存在 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

文件是否存在 命令 　英文命令：IsFileExist　操作系统支持：Windows、Linux 所属类别：磁盘操作

判断指定的磁盘文件是否真实存在。如存在返回真，否则返回假。

语法： 逻辑型 文件是否存在 （欲测试的文件名称）

参数名 | 描 述
欲测试的文件名称 | 必需的；文本型。

例程

说明

该程序和“复制文件”命令例程基本相同，只是在复制文件的时候，使用“文件是否存在”命令，加入了对文件是否存在的判断，如果目录中有和复制文件相同文件名的文件就弹出信息框询问是否覆盖，如果选择“是”则覆盖同名文件，如果选择“否”则不覆盖。程序其他部分解释，参见：复制文件。

参见 例程1


寻找文件 命令 操作系统支持：Windows 所属类别：磁盘操作

寻找文件 命令 　英文命令：dir　操作系统支持：Windows 所属类别：磁盘操作

返回一个文本，用以表示所找到的文件名或目录名，它必须与所要求的名称格式或文件属性相匹配。支持使用多字符 (*) 和单字符 (?) 通配符来指定多重文件。在某子程序中第一次调用本命令时，必须指定“欲寻找文件”参数，否则将返回空文本 (“”)。在第一次调用以后如果想得到其它匹配的文件名，再一次调用本命令，且不要提供欲寻找文件名参数。如果已没有合乎条件的文件，本命令会返回一个空文本。一旦返回值为空文本，要再次调用本命令时，就必须指定“欲寻找文件”参数。不必访问完所有当前匹配的文件名，就可以使用一个新的“欲寻找文件”进行新的寻找。

语法： 文本型 寻找文件 （［欲寻找的文件或目录名称］，［欲寻找文件的属性］）

参数名 | 描 述
欲寻找的文件或目录名称 | 可选的；文本型。可以使用多字符 (*) 和单字符 (?) 通配符来指定多重文件。在非首次寻找文件时，参数值必须为空或被省略。
欲寻找文件的属性 | 可选的；整数型。参数值可以为以下常量值或其和： 1、#只读文件； 2、#隐藏文件； 4、#系统文件； 16、#子目录； 32、#存档文件 。通过将这些常量值加起来可以一次设置多个文件属性。如果省略本参数，默认为搜寻除子目录外的所有文件。

例程

说明

点击“显示文件”按钮后，弹出浏览文件夹对话框，选择一个文件夹后将选择的文件夹存放在“文件目录”变量中，然后运行“寻找文件”命令，寻找目录下的*.*文件，并用“判断循环首”命令循环找出该目录下的所有*.*文件，并添加到了列表框中。注意非首次寻找相同条件文件时，“寻找文件”命令的第一个参数必须省略填写。

参见 例程1


取文件时间 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

取文件时间 命令 　英文命令：FileDateTime　操作系统支持：Windows、Linux 所属类别：磁盘操作

返回指定文件被创建或最后修改后的日期和时间。如果该文件不存在，将返回100年1月1日。

语法： 日期时间型 取文件时间 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

使用通用对话框选择一个要取出最后修改时间的文件，“取文件时间”命令将时间取出后存放在“文件时间”变量中，最后用信息框显示出文件被修改的时间。

参见 例程1


取文件尺寸 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

取文件尺寸 命令 　英文命令：FileLen　操作系统支持：Windows、Linux 所属类别：磁盘操作

返回一个文件的长度，单位是字节。如果该文件不存在，将返回 -1。

语法： 整数型 取文件尺寸 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

用通用对话框选择一个要取得文件大小的文件，用“取文件尺寸”命令取出该文件大小，并存放在“文件尺寸”变量中，然后用编辑框显示出该文件的大小。

参见 例程1


取文件属性 命令 操作系统支持：Windows 所属类别：磁盘操作

取文件属性 命令 　英文命令：GetAttr　操作系统支持：Windows 所属类别：磁盘操作

返回一个文件或目录的属性。此属性值由以下常量或其和构成： 1、#只读文件； 2、#隐藏文件； 4、#系统文件； 16、#子目录；32、#存档文件。要判断是否设置了某个属性，在返回值与想要得知的属性值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示设置了这个属性值。如果取文件属性失败，将返回 -1。

语法： 整数型 取文件属性 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

通过“取文件属性”命令取出文件属性，并存放在“文件属性”变量中，然后根据返回的数值，判断该文件为何种类型的文件。

参见 例程1


置文件属性 命令 操作系统支持：Windows所属类别：磁盘操作

置文件属性 命令 　英文命令：SetAttr　操作系统支持：Windows所属类别：磁盘操作

为一个文件设置属性信息。成功返回真，失败返回假。

语法： 逻辑型 置文件属性 （欲设置其属性的文件名称，欲设置为的属性值）

参数名 | 描 述
欲设置其属性的文件名称 | 必需的；文本型。
欲设置为的属性值 | 必需的；整数型。参数值可以为以下常量值或其和： 1、#只读文件； 2、#隐藏文件； 4、#系统文件； 32、#存档文件 。通过将这些常量值加起来可以一次设置多个文件属性。

例程

说明

组合框中的项目为可以设置的文件属性，每个项目都对应一个该属性的数值，在通用对话框中选择一个欲设置属性的文件，将要设置文件属性的对应数值存放在“欲设置的文件属性”变量中，然后使用“置文件属性”命令设置文件属性。

参见 例程1


取临时文件名 命令 操作系统支持：Windows 所属类别：磁盘操作

取临时文件名 命令 　英文命令：GetTempFileName　操作系统支持：Windows 所属类别：磁盘操作

返回一个在指定目录中确定不存在的 .TMP 全路径文件名称。

语法： 文本型 取临时文件名 （［目录名］）

参数名 | 描 述
目录名 | 可选的；文本型。如果省略本参数，默认将使用系统的标准临时目录。

例程

说明

取出临时文件名，并存放在“临时文件名”变量中，然后用编辑框显示出临时文件名。

参见 例程1


读入文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

读入文件 命令 　英文命令：ReadFile　操作系统支持：Windows、Linux 所属类别：磁盘操作

返回一个字节集，其中包含指定文件的所有数据。

语法： 字节集 读入文件 （文件名）

参数名 | 描 述
文件名 | 必需的；文本型。

例程

说明

将指定的文件读入到变量或者控件中以便调用，读入后的文件和原文件不发生关系，该文件的一切修改对原文件不会有任何影响。

参见 例程1


写到文件 命令 操作系统支持：Windows、Linux 所属类别：磁盘操作

写到文件 命令 　英文命令：WriteFile　操作系统支持：Windows、Linux 所属类别：磁盘操作

本命令用作将一个或数个字节集顺序写到指定文件中，文件原有内容被覆盖。成功返回真，失败返回假。

语法： 逻辑型 写到文件 （文件名，欲写入文件的数据，… ）

参数名 | 描 述
文件名 | 必需的；文本型。
欲写入文件的数据 | 必需的；可扩充的；字节集。

例程

说明

将控件或变量中的内容写到指定的文件，如果文件存在，原文件中内容将被覆盖。

参见 例程1


文件读写

文件读写 类别 跳至：系统核心支持库

打开文件 | 打开内存文件 | 关闭文件 | 关闭所有文件
锁住文件 | 解锁文件 | 移动读写位置 | 移到文件首
移到文件尾 | 读入字节集 | 写出字节集 | 读入文本
写出文本 | 读入一行 | 写文本行 | 读入数据
写出数据 | 是否在文件尾 | 取读写位置 | 取文件长度
插入字节集 | 插入文本 | 插入文本行 | 删除数据
打开加密文件 |  |  |


打开文件 命令 操作系统支持：Windows、Linux 所属类别：文件读写

打开文件 命令 　英文命令：open　操作系统支持：Windows、Linux 所属类别：文件读写

打开一个普通文件，以对文件进行输入或输出。成功返回被打开文件的文件号，失败返回 0。

语法： 整数型 打开文件 （欲打开的文件名称，［打开方式］，［共享方式］）

参数名 | 描 述
欲打开的文件名称 | 必需的；文本型。
打开方式 | 可选的；整数型。参数值说明对文件的操作方式，如果省略本参数，默认为“#读写”。方式值可以为以下常量之一： 1、#读入：从指定文件读入数据，如果该文件不存在则失败； 2、#写出：写出数据到指定文件，如果该文件不存在则失败； 3、#读写：从文件中读入数据或者写出数据到文件，如果该文件不存在则失败； 4、#重写：写出数据到指定文件。如果该文件不存在则先创建一个新文件，如果已经存在就先清除其中的所有数据； 5、#改写：写出数据到指定文件。如果该文件不存在则创建一个新文件，如果已经存在就直接打开； 6、#改读：从文件中读入数据或者写出数据到文件。如果该文件不存在则创建一个新文件，如果已经存在就直接打开。
共享方式 | 可选的；整数型。参数值指定限制其它进程操作此文件的方式。如果省略本参数，默认为“#无限制”。方式值可以为以下常量之一： 1、#无限制：允许其它进程任意读写此文件； 2、#禁止读：禁止其它进程读此文件； 3、#禁止写：禁止其它进程写此文件； 4、#禁止读写：禁止其它进程读写此文件。

例程

说明

打开通用对话框取得一个文本文件的文件名，用“打开文件”命令打开该文件，并将返回的文件号存放在“文件号”变量中，最后用“读入文本”命令读入该文件的内容显示在编辑框中。

“打开文件”命令返回的文件号，是很多文件读写类命令需要使用到的。

参见：例程


打开内存文件 命令 操作系统支持：Windows 所属类别：文件读写

打开内存文件 命令 　英文命令：OpenMemFile　操作系统支持：Windows 所属类别：文件读写

建立一个内存文件，以计算机内存为存储介质对数据进行文件式的快速输入或输出。成功返回被打开文件的文件号，失败返回 0。

语法： 整数型 打开内存文件 （）

例程

说明

取得内存文件的文件号，将“输入文本编辑框”的内容写到内存文件，然后读出写出后的内存文件，并显示在编辑框中。对内存文件的操作，都使用了“打开内存文件”命令返回的文件号。

参见：例程


关闭文件 命令 操作系统支持：Windows、Linux 所属类别：文件读写

关闭文件 命令 　英文命令：close　操作系统支持：Windows、Linux 所属类别：文件读写

关闭用各种打开命令打开的文件关闭被打开的各种类型文件。

语法： 无返回值 关闭文件 （欲关闭的文件号）

参数名 | 描 述
欲关闭的文件号 | 必需的；整数型。参数值指明欲关闭的文件号，该文件号由“打开文件”命令所返回。

例程

说明

使用“打开文件”命令打开一个文件后，可以使用“关闭文件”命令关闭这个文件。在一个文件不需要再进行任何操作的时候最好关闭它。

打开文件部分代码解释，参见打开文件。

参见：例程


关闭所有文件 命令 操作系统支持：Windows、Linux 所属类别：文件读写

关闭所有文件 命令 　英文命令：reset　操作系统支持：Windows、Linux 所属类别：文件读写

关闭所有现行被打开的文件。

语法： 无返回值 关闭所有文件 （）

例程

说明

打开多个文件后，可以使用“关闭所有文件”命令，将当前已经打开的所有文件都关闭。可以在程序关闭前，使用该命令将程序运行过程中打开的文件都进行关闭。

参见：例程


锁住文件 命令 操作系统支持：Windows 所属类别：文件读写

锁住文件 命令 　英文命令：lock　操作系统支持：Windows 所属类别：文件读写

在有若干个进程访问同一个文件的环境中，使用本命令拒绝其它用户对被打开文件中的某个区域进行读写访问。成功返回真，失败返回假。

语法： 逻辑型 锁住文件 （欲加锁或解锁的文件号，欲加锁或解锁的位置，欲加锁或解锁的长度，［加锁重试时间］）

参数名 | 描 述
欲加锁或解锁的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲加锁或解锁的位置 | 必需的；整数型。位置值从 0 开始。
欲加锁或解锁的长度 | 必需的；整数型。
加锁重试时间 | 可选的；整数型。本参数指定加锁失败后反复进行重试的毫秒数。如果被省略，默认为 0 ，即一旦失败立即返回。如果参数值提供为 -1 ，则反复进行重试，直到加锁成功为止。

例程

说明

打开一个文件后，将其进行加锁，信息框显示是否加锁成功，加锁成功后其他用户将不能使用“打开文件”命令打开该文件。

注意加锁成功后，在没解锁的情况下再次加锁会失败，可以使用“解锁文件”命令解除文件的锁定。

参见：例程


解锁文件 命令 操作系统支持：Windows 所属类别：文件读写

解锁文件 命令 　英文命令：Unlock　操作系统支持：Windows 所属类别：文件读写

解除由“锁住文件”命令对文件所进行的锁定。成功返回真，失败返回假。注意：本命令调用时所提供的参数值必须与调用“锁住文件”命令时所提供的参数值完全一致。

语法： 逻辑型 解锁文件 （欲加锁或解锁的文件号，欲加锁或解锁的位置，欲加锁或解锁的长度）

参数名 | 描 述
欲加锁或解锁的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲加锁或解锁的位置 | 必需的；整数型。位置值从 0 开始。
欲加锁或解锁的长度 | 必需的；整数型。

例程

说明

对文件加锁后可以使用“解锁文件”命令解除文件的锁定，要注意解锁的长度要和加锁长度相同才会成功。

参见：例程


移动读写位置 命令 操作系统支持：Windows、Linux 所属类别：文件读写

移动读写位置 命令 　英文命令：FSeek　操作系统支持：Windows、Linux　　　所属类别：文件读写

在被打开的文件中，设置下一个读或写操作的位置。成功返回真，失败返回假。

语法： 逻辑型 移动读写位置 （欲进行操作的文件号，［起始移动位置］，移动距离）

参数名 | 描 述
欲进行操作的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
起始移动位置 | 可选的；整数型。参数值指定从文件中开始移动的位置。可以为以下常量之一：1、#文件首； 2、#文件尾； 3、#现行位置。如果本参数被省略，默认值为“#文件首”。
移动距离 | 必需的；整数型。参数值指定相对于起始移动位置的移动长度。

例程

说明

打开一个文本文件，移动其读写位置，然后插入文本。每次移动读写位置，插入的文本位置都有所不同。

参见：例程


移到文件首 命令 操作系统支持：Windows、Linux 所属类别：文件读写

移到文件首 命令 　英文命令：SeekToBegin　操作系统支持：Windows、Linux　　　所属类别：文件读写

在被打开的文件中，设置下一个读或写操作的位置到文件首。成功返回真，失败返回假。

语法： 逻辑型 移到文件首 （欲进行操作的文件号）

参数名 | 描 述
欲进行操作的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。

例程

说明

使用“移到文件首”命令将当前读写位置移动到文件首后，可以使用“插入文本”命令在文件首位置插入文本。

在读入文本的时候也是从当前读写位置开始读，所以读入文本前也使用了“移到文件首”命令，可以显示出当前文件的全部。

参见：例程


移到文件尾 命令 操作系统支持：Windows、Linux 所属类别：文件读写

移到文件尾 命令 　英文命令：SeekToEnd　操作系统支持：Windows、Linux　　　所属类别：文件读写

在被打开的文件中，设置下一个读或写操作的位置到文件尾。成功返回真，失败返回假。

语法： 逻辑型 移到文件尾 （欲进行操作的文件号）

参数名 | 描 述
欲进行操作的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。

例程

说明

使用“移到文件尾”命令将当前读写位置移动到文件尾，然后使用“插入文本”按钮在文件尾插入文本，并显示出插入文本后的结果。

参见：例程


读入字节集 命令 操作系统支持：Windows、Linux 所属类别：文件读写

读入字节集 命令 　英文命令：ReadBin　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作从文件中当前读写位置读取并返回一段字节集数据，实际读入长度（即返回的字节集的尺寸）可能会小于欲读入长度。如果读入失败，将返回一个空字节集并且自动将当前文件读写位置移到文件尾部。

语法： 字节集 读入字节集 （欲读入数据的文件号，欲读入数据的长度）

参数名 | 描 述
欲读入数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲读入数据的长度 | 必需的；整数型。

例程

说明

使用通用对话框取得一个图片文件的文件名，使用“读入字节集”命令读入该图片，并存放在“字节集变量”中，然后用画板显示出该图片。

参见：例程


写出字节集 命令 操作系统支持：Windows、Linux 所属类别：文件读写

写出字节集 命令 　英文命令：WriteBin　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作写出一段或数段字节集数据到文件中当前读写位置处。成功返回真，失败返回假。

语法： 逻辑型 写出字节集 （欲写出数据的文件号，欲写出的字节集数据，… ）

参数名 | 描 述
欲写出数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的字节集数据 | 必需的；可扩充的；字节集。

例程

说明

将一个图片文件打开，点击“写出文件”按钮，将资源表中的一个图片资源写到打开的文件中。注意该命令是在当前读写位置开始写出。

参见：例程


读入文本 命令 操作系统支持：Windows、Linux 所属类别：文件读写

读入文本 命令 　英文命令：ReadText　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作从文件中当前读写位置读取并返回一段文本数据，实际读入长度（即返回文本的尺寸）可能会小于欲读入长度。如果该数据中存在字节 0 或 26（文本结束标志），将仅返回该字节之前的数据。如果读入失败，将返回一个空文本并且自动将当前文件读写位置移到文件尾部。

语法： 文本型 读入文本 （欲读入文本数据的文件号，［欲读入文本数据的长度］）

参数名 | 描 述
欲读入文本数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲读入文本数据的长度 | 可选的；整数型。如果本参数被省略，默认读入文件中的所有文本数据。

例程

说明

使用“打开文件”命令打开一个文本文件，并用“读入文本”命令将该文件显示在编辑框中。注意“读入文本”命令是从当前读写位置读起。

参见：例程


写出文本 命令 操作系统支持：Windows、Linux 所属类别：文件读写

写出文本 命令 　英文命令：WriteText　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作写出一段或数段文本数据到文件中当前读写位置处。成功返回真，失败返回假。

语法： 逻辑型 写出文本 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

打开一个文本文件，显示在编辑框中，然后使用“写出文本”命令，在当前读写位置写出一段文本，并显示写出后的文本。

参见：例程


读入一行 命令 操作系统支持：Windows、Linux 所属类别：文件读写

读入一行 命令 　英文命令：ReadLine　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作从文件中当前读写位置读取并返回一行文本数据，行末的回车及换行符将被抛弃。如果读入失败，将返回一个空文本并且自动将当前文件读写位置移到文件尾部。

语法： 文本型 读入一行 （欲读入文本数据的文件号）

参数名 | 描 述
欲读入文本数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。

例程

说明

打开一个文本文件，并显示在“打开文件编辑框”中，点击“读入一行”按钮后，可以将该文本文件的第一行读入，并显示在“读入一行编辑框”中。

参见：例程


写文本行 命令 操作系统支持：Windows、Linux 所属类别：文件读写

写文本行 命令 　英文命令：WriteLine　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作写出一行或多行文本数据到文件中当前读写位置处，每行的尾部将被自动加上回车及换行符。成功返回真，失败返回假。

语法： 逻辑型 写文本行 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

使用“打开按钮”打开一个文本文件并显示在编辑框中，然后使用“写文本行”按钮在该文件首行插入3行文本。该命令插入的整行文本，可以自动在行尾加换行符。

参见：例程


读入数据 命令 操作系统支持：Windows、Linux 所属类别：文件读写

读入数据 命令 　英文命令：read　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令应该与“写出”命令配合使用，用作从文件中当前读写位置读取格式数据到指定的一系列变量或数组变量中。成功返回真，失败返回假。

语法： 逻辑型 读入数据 （欲读入数据的文件号，存放所读入数据的变量，… ）

参数名 | 描 述
欲读入数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
存放所读入数据的变量 | 必需的；可扩充的；通用型，参数数据只能提供变量及变量数组。如果变量的数据类型为用户自定义或库定义数据类型，命令将会失败。

例程

说明

打开一个文本文件，并用“读入数据”命令读入该文本文件的数据，然后用编辑框显示出来。该命令可以读入通用型的数据，会将数据自动进行转换，例如读入字节集型数据，给一个文本变量存放，则命令会自动将字节集数据转换成文本型后进行存放。

参见：例程


写出数据 命令 操作系统支持：Windows、Linux 所属类别：文件读写

写出数据 命令 　英文命令：write　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令应该与“读入”命令配合使用，用作写出一系列变量或数组变量的格式数据到文件中当前读写位置处。成功返回真，失败返回假。具体各种数据类型数据的写出格式为： 1、数值型、逻辑型、日期时间型、子程序指针型： 为其所对应的实际数据； 2、文本型：为文本数据 + 字节 0 ； 3、字节集型： 为字节集数据长度（整数） + 字节集实际数据； 4、以上各种数据类型的数组型数据： 为非数组情况下数据格式的顺序排列。

语法： 逻辑型 写出数据 （欲写出数据的文件号，欲写出的数据，… ）

参数名 | 描 述
欲写出数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的数据 | 必需的；可扩充的；通用型，参数数据可以同时提供数组或非数组数据。如果被写出数据的数据类型为用户自定义或库定义数据类型，命令将会失败。

例程

说明

打开一个文本文件并显示在“打开文件编辑框”中；点击“写出数据按钮”后，会将“写出数据编辑框”中的内容写到被打开文件的当前读写位置中，并用信息框显示是否成功，然后显示写出后的文本内容。注意该命令可以写出一个通用型的数据。

参见：例程


是否在文件尾 命令 操作系统支持：Windows、Linux 所属类别：文件读写

是否在文件尾 命令 　英文命令：feof　操作系统支持：Windows、Linux　　　所属类别：文件读写

如果指定被打开文件的读写位置已经处于该文件数据的尾部，则返回真，否则返回假。

语法： 逻辑型 是否在文件尾 （文件号，［是否为判断文本已读完］）

参数名 | 描 述
文件号 | 必需的；整数型。参数值指明欲操作的文件号，该文件号必须由“打开文件”命令所返回。
是否为判断文本已读完 | 可选的；逻辑型。如果本参数值为真而且下一即将读入的字节为字节值 0 或 26 等文本终止标记符或者当前读写位置已处于该文件数据的尾部，命令将返回真。如果本参数被省略或为假，将不进行此检查。

例程

说明

打开一个文本文件，显示在编辑框中，并用信息框显示当前的读写位置是否在文件尾。

参见：例程


取读写位置 命令 操作系统支持：Windows、Linux 所属类别：文件读写

取读写位置 命令 　英文命令：loc　操作系统支持：Windows、Linux　　　所属类别：文件读写

返回指定被打开文件的当前读/写位置，位置值从 0 开始。如果给定文件号无效或失败，返回 -1 。

语法： 整数型 取读写位置 （文件号）

参数名 | 描 述
文件号 | 必需的；整数型。参数值指明欲操作的文件号，该文件号必须由“打开文件”命令所返回。

例程

说明

打开一个文件后，使用“显示读写位置”按钮可以弹出信息框，显示当前的读写位置，还可以使用“移动读写位置”按钮来改变当前的读写位置。

参见：例程


取文件长度 命令 操作系统支持：Windows、Linux 所属类别：文件读写

取文件长度 命令 　英文命令：lof　操作系统支持：Windows、Linux　　　所属类别：文件读写

返回指定被打开文件的尺寸，该尺寸以字节为单位。如果给定文件号无效或失败，返回 -1 。

语法： 整数型 取文件长度 （文件号）

参数名 | 描 述
文件号 | 必需的；整数型。参数值指明欲操作的文件号，该文件号必须由“打开文件”命令所返回。

例程

说明

打开一个mp3文件，使用“取文件长度”命令取出该mp3文件的长度，并存放在“文件长度”变量中，预计mp3每秒钟可以播放16007个字节，所以通过取文件长度可以计算出mp3的播放时间，最后用标签显示出计算的结果。

参见：例程


插入字节集 命令 操作系统支持：Windows、Linux 所属类别：文件读写

插入字节集 命令 　英文命令：InsBin　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作插入一段或数段字节集数据到文件中当前读写位置处。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 插入字节集 （欲写出数据的文件号，欲写出的字节集数据，… ）

参数名 | 描 述
欲写出数据的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的字节集数据 | 必需的；可扩充的；字节集。

例程

说明

打开一个midi音乐文件，midi音乐文件是字节集型的数据，然后使用“插入字节集”命令，将资源表中的一个midi文件和打开的文件合并。合并成功后可以使用播放软件试听一下。

参见：例程


插入文本 命令 操作系统支持：Windows、Linux 所属类别：文件读写

插入文本 命令 　英文命令：InsText　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作插入一段或数段文本数据到文件中当前读写位置处。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 插入文本 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

使用“插入文本”命令在打开的文件首插入“插入内容编辑框”中的内容。“插入文本”命令插入内容后，会将当前读写位置移动到插入内容的首部。

参见：例程


插入文本行 命令 所属类别：文件读写

插入文本行 命令 　英文命令：InsLine　所属类别：文件读写

本命令用作插入一段或数段文本行到文件中当前读写位置处。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 插入文本行 （欲写出文本的文件号，欲写出的文本，… ）

参数名 | 描 述
欲写出文本的文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲写出的文本 | 必需的；可扩充的；通用型。参数值如果不为文本类型数据，将自动进行转换，如果无法转换（即数据类型为字节集、子程序指针、库或用户自定义数据类型），则不写出此数据。

例程

说明

使用“插入文本行”命令在打开的文件首插入“插入内容编辑框”中的内容。每次插入文本都会自动换行。“插入文本行”命令插入内容后，会将当前读写位置移动到插入内容的首部。

参见：例程


删除数据 命令 操作系统支持：Windows、Linux 所属类别：文件读写

删除数据 命令 　英文命令：RemoveData　操作系统支持：Windows、Linux　　　所属类别：文件读写

本命令用作在文件中当前读写位置处删除一段字节数据，文件后面的数据顺序前移。该文件被打开时必须给予可读权限。成功返回真，失败返回假。

语法： 逻辑型 删除数据 （文件号，欲删除数据的字节数）

参数名 | 描 述
文件号 | 必需的；整数型。该文件号由“打开文件”命令所返回。
欲删除数据的字节数 | 必需的；整数型。

例程

说明

打开一张图片并显示在图片框中。使用“删除数据”按钮将图片中的数据删除，然后显示删除后的文件内容。

参见：例程


打开加密文件 命令 操作系统支持：Windows 所属类别：文件读写

打开加密文件 命令 　英文命令：CryptOpen　操作系统支持：Windows　　　所属类别：文件读写

打开一个以指定密码加密的文件，以对此文件进行快速安全访问，支持大尺寸文件。成功返回被打开文件的文件号，失败返回 0。

语法： 整数型 打开加密文件 （欲打开的文件名称，［打开方式］，［共享方式］，［文件密码］，［明文区长度］）

参数名 | 描 述
欲打开的文件名称 | 必需的；文本型。
打开方式 | 可选的；整数型。参数值说明对文件的操作方式，如果省略本参数，默认为“#读写”。方式值可以为以下常量之一： 1、#读入：从指定文件读入数据，如果该文件不存在则失败； 2、#写出：写出数据到指定文件，如果该文件不存在则失败； 3、#读写：从文件中读入数据或者写出数据到文件，如果该文件不存在则失败； 4、#重写：写出数据到指定文件。如果该文件不存在则先创建一个新文件，如果已经存在就先清除其中的所有数据； 5、#改写：写出数据到指定文件。如果该文件不存在则创建一个新文件，如果已经存在就直接打开； 6、#改读：从文件中读入数据或者写出数据到文件。如果该文件不存在则创建一个新文件，如果已经存在就直接打开。
共享方式 | 可选的；整数型。参数值指定限制其它进程操作此文件的方式。如果省略本参数，默认为“#无限制”。方式值可以为以下常量之一： 1、#无限制：允许其它进程任意读写此文件； 2、#禁止读：禁止其它进程读此文件； 3、#禁止写：禁止其它进程写此文件； 4、#禁止读写：禁止其它进程读写此文件。
文件密码 | 可选的；文本型。如果即将打开的文件中不存在任何数据（即为空文件或将创建的新文件），本参数指定保护该文件时所将使用的密码，以后所有写入该文件中的数据都将使用此密码加密后写入。建议密码长度最少为6个字符以上，并且最好混合使用汉字、字母、数字、符号，以保证密码本身的安全性。如果即将打开的文件中已经存在数据，本参数提供访问此已有数据时所需要的正确密码，如果此数据没有加密，请提供空文本以表示不需要密码。注意系统不会去校验密码的正确性，如果提供错误的密码，读写已有文件数据将得到错误的结果，请千万注意。因此如果需要校验密码是否正确，请在加密后的文件中保存正确的密码文本或密码文本的数据摘要信息（见数据操作支持库一中的“取数据摘要”命令），然后在打开加密文件后读出该信息对密码进行验证。系统所使用的加密算法是国际标准的RC4算法，可以保证数据的安全性。如果本参数被省略，则默认为空文本，即无密码。
明文区长度 | 可选的；整数型。本参数指定从文件首部开始不希望被加密部分的长度，系统在读写此区域内的数据时，不会使用密码对其进行加解密操作。此参数用作将加密文件分为明文区和密文区两部分，以方便某些应用程序同时保存一些明文数据。注意当打开已有加密数据的文件时，此参数值必须与新建此加密文件时所提供的参数值一致，否则会造成数据访问错误。如果本参数被省略，则默认值为0，即没有明文区。

例程

说明

打开已经被加密的文件，如果密码错误，将打开失败，注：加密文件可以通过本命令创建。

参见：例程


系统处理

系统处理 类别 跳至：系统核心支持库

运行 | 取剪辑板文本 | 置剪辑板文本 | 剪辑板中可有文本
清除剪辑板 | 取屏幕宽度 | 取屏幕高度 | 取鼠标水平位置
取鼠标垂直位置 | 取颜色数 | 输入框 | 信息框
鸣叫 | 取启动时间 | 置等待鼠标 | 恢复鼠标
延时 | 取文本注册项 | 取数值注册项 | 取字节集注册项
写注册项 | 删除注册项 | 注册项是否存在 | 取默认底色
快照 | 读配置项 | 写配置项 | 取配置节名
取操作系统类别 | 多文件对话框 |  |


运行 命令 操作系统支持：Windows、Linux 所属类别：系统处理

运行 命令 　英文命令：run　操作系统支持：Windows、Linux 所属类别：系统处理

本命令运行指定的可执行EXE文件或者外部命令。如果成功，返回真，否则返回假。

语法： 逻辑型 运行 （欲运行的命令行，是否等待程序运行完毕，［被运行程序窗口显示方式］）

参数名 | 描 述
欲运行的命令行 | 必需的；文本型。
是否等待程序运行完毕 | 必需的；逻辑型，初始值为“假”。
被运行程序窗口显示方式 | 可选的；整数型。参数值可以为以下常量之一：1、#隐藏窗口； 2、#普通激活； 3、#最小化激活； 4、#最大化激活； 5、#普通不激活； 6、#最小化不激活。如果省略本参数，默认为“普通激活”方式。

例程：

说明：

运行计算器程序。

参见： 例程


取剪辑板文本 命令 操作系统支持：Windows 所属类别：系统处理

取剪辑板文本 命令 　英文命令：GetClipBoardText　操作系统支持：Windows 所属类别：系统处理

返回存放于当前 Windows 系统剪辑板中的文本。如果当前剪辑板中无文本数据，将返回空文本。

语法： 文本型 取剪辑板文本 （）

例程：

说明：

如果剪辑板中有文本，此命令取出，并显示在编辑框中。

参见： 例程


置剪辑板文本 命令 操作系统支持：Windows 所属类别：系统处理

置剪辑板文本 命令 　英文命令：SetClipBoardText　操作系统支持：Windows 所属类别：系统处理

将指定文本存放到当前 Windows 系统剪辑板中去，剪辑板中的原有内容被覆盖。成功返回真，失败返回假。

语法： 逻辑型 置剪辑板文本 （准备置入剪辑板的文本）

参数名 | 描 述
准备置入剪辑板的文本 | 必需的；文本型。

例程：

说明：

将 置文本编辑框的内容设置到系统的剪辑板。

参见： 例程


剪辑板中可有文本 命令 操作系统支持：Windows 所属类别：系统处理

剪辑板中可有文本 命令 　英文命令：IsHaveTextInClip　操作系统支持：Windows 所属类别：系统处理

如果当前 Windows 系统剪辑板中有文本数据，则返回真，否则返回假。

语法： 逻辑型 剪辑板中可有文本 （）

例程：

说明：

判断当前剪辑板中是否有文本型数据，并通过返回的逻辑值判断。

参见： 例程


清除剪辑板 命令 操作系统支持：Windows 所属类别：系统处理

清除剪辑板 命令 　英文命令：ClearClipBoard　操作系统支持：Windows 所属类别：系统处理

清除当前 Windows 系统剪辑板中的所有数据。

语法： 无返回值 清除剪辑板 （）

例程：

说明：

清除剪辑板中的文本数据。

参见： 例程


取屏幕宽度 命令 操作系统支持：Windows 所属类别：系统处理

取屏幕宽度 命令 　英文命令：GetScreenWidth　操作系统支持：Windows 所属类别：系统处理

返回屏幕当前显示区域的宽度，单位为像素点。

语法： 整数型 取屏幕宽度 （）

例程：

说明：

取出计算机的屏幕宽度。如果屏幕分辩率设置为1024*768，取出的屏幕宽度为1024；如果设置为1152*864，其屏幕宽度为1152。

参见： 例程


取屏幕高度 命令 操作系统支持：Windows 所属类别：系统处理

取屏幕高度 命令 　英文命令：GetScreenHeight　操作系统支持：Windows 所属类别：系统处理

返回屏幕当前显示区域的高度，单位为像素点。

语法： 整数型 取屏幕高度 （）

例程：

说明：

取出计算机的屏幕高度。如果屏幕分辩率设置为1024*768，取出的屏幕高度为768；如果设置为1152*864，其屏幕高度为864。

参见： 例程


取鼠标水平位置 命令 操作系统支持：Windows 所属类别：系统处理

取鼠标水平位置 命令 　英文命令：GetCursorHorzPos　操作系统支持：Windows 所属类别：系统处理

返回鼠标指针的当前水平位置，单位为像素点，相对于屏幕左边。

语法： 整数型 取鼠标水平位置 （）

例程：

说明：

使用时钟，不停的取出鼠标在屏幕上的横向坐标，并显示。

参见： 例程


取鼠标垂直位置 命令 操作系统支持：Windows 所属类别：系统处理

取鼠标垂直位置 命令 　英文命令：GetCursorVertPos　操作系统支持：Windows 所属类别：系统处理

返回鼠标指针的当前垂直位置，单位为像素点，相对于屏幕顶边。

语法： 整数型 取鼠标垂直位置 （）

例程：

说明：

使用时钟，不停的取出鼠标在屏幕上的纵向坐标，并显示。

参见： 例程


取颜色数 命令 操作系统支持：Windows 所属类别：系统处理

取颜色数 命令 　英文命令：GetColorCount　操作系统支持：Windows 所属类别：系统处理

返回当前显示方式所提供的最大颜色显示数目。

语法： 整数型 取颜色数 （）

例程：

说明：

取出系统设置的颜色质量的位数，只支持16位。设置位置在桌面属性的设置窗口中。

参见： 例程


输入框 命令 操作系统支持：Windows 所属类别：系统处理

输入框 命令 　英文命令：InputBox　操作系统支持：Windows 所属类别：系统处理

在一对话框中显示提示，等待用户输入正文并按下按钮。如果用户在确认输入后（按下“确认输入”按钮或回车键）退出，返回真，否则返回假。

语法： 逻辑型 输入框 （［提示信息］，［窗口标题］，［初始文本］，存放输入内容的变量，［输入方式］）

参数名 | 描 述
提示信息 | 可选的；文本型。如果提示信息包含多行，可在各行之间用回车符 (即“字符 (13)”)、换行符 (即“字符 (10)”) 或回车换行符的组合 (即：“字符 (13) + 字符 (10)”) 来分隔。如果提示信息太长或行数过多，超过部分将不会被显示出来。
窗口标题 | 可选的；文本型。参数值指定显示在对话框标题栏中的文本。如果省略，默认为文本“请输入：”。
初始文本 | 可选的；文本型。参数值指定初始设置到对话框输入文本框中的内容。
存放输入内容的变量 | 必需的；通用型，参数数据只能提供变量。参数值所指定的变量可以为数值或文本型，用于以不同的数据类型取回输入内容。
输入方式 | 可选的；整数型。参数值可以为以下常量值： 1、#输入文本； 2、#输入整数； 3、#输入小数； 4、#输入密码。如果省略本参数，默认为“#输入文本”。

例程：

说明：

用编辑框显示输入框输入的文本数据。

参见： 例程


信息框 命令 操作系统支持：Windows 所属类别：系统处理

信息框 命令 　英文命令：MsgBox　操作系统支持：Windows 所属类别：系统处理

在对话框中显示信息，等待用户单击按钮，并返回一个整数告诉用户单击哪一个按钮。该整数为以下常量值之一： 0、#确认钮； 1、#取消钮； 2、#放弃钮； 3、#重试钮； 4、#忽略钮； 5、#是钮； 6、#否钮。如果对话框有“取消”按钮，则按下 ESC 键与单击“取消”按钮的效果相同。

语法： 整数型 信息框 （提示信息，按钮，［窗口标题］）

参数名 | 描 述
提示信息 | 必需的；通用型。提示信息只能为文本、数值、逻辑值或日期时间。如果提示信息为文本且包含多行，可在各行之间用回车符 (即“字符 (13)”)、换行符 (即“字符 (10)”) 或回车换行符的组合 (即：“字符 (13) + 字符 (10)”) 来分隔。
按钮 | 必需的；整数型，初始值为“0”。参数值由以下几组常量值组成，在将这些常量值相加以生成参数值时，每组值只能取用一个数字（第五组除外）： 第一组（描述对话框中显示按钮的类型与数目）： 0、#确认钮； 1、#确认取消钮； 2、#放弃重试忽略钮； 3、#取消是否钮； 4、#是否钮； 5、#重试取消钮 第二组（描述图标的样式）： 16、#错误图标； 32、#询问图标； 48、#警告图标； 64、#信息图标 第三组（说明哪一个按钮是缺省默认值）： 0、#默认按钮一； 256、#默认按钮二； 512、#默认按钮三； 768、#默认按钮四 第四组（决定如何等待消息框结束）： 0、#程序等待； 4096、#系统等待 第五组（其它）： 65536、#位于前台； 524288、#文本右对齐
窗口标题 | 可选的；文本型。参数值指定显示在对话框标题栏中的文本。如果省略，默认为文本“信息：”。

例程：

说明：

信息框是用户与程序联系的一个通道，通过用户的选择，信息框返回按钮索引值，程序通过索引值执行相应的程序代码，完成用户选择的功能。信息框也可以用来调试程序。

参见： 例程


鸣叫 命令 操作系统支持：Windows 所属类别：系统处理

鸣叫 命令 　英文命令：beep　操作系统支持：Windows 所属类别：系统处理

通过计算机媒体设备或者喇叭发出一个声音。

语法： 无返回值 鸣叫 （）

例程：

参见： 例程


取启动时间 命令 操作系统支持：Windows 所属类别：系统处理

取启动时间 命令 　英文命令：GetTickCount　操作系统支持：Windows 所属类别：系统处理

返回自 Windows 系统启动后到现在为止所经历过的毫秒数。

语法： 整数型 取启动时间 （）

例程：

说明：

取出自 Windows 系统启动后到现在为止所经历过的时间。

参见： 例程


置等待鼠标 命令 操作系统支持：Windows 所属类别：系统处理

置等待鼠标 命令 　英文命令：SetWaitCursor　操作系统支持：Windows 所属类别：系统处理

本命令设置现行鼠标的形状为沙漏形，用作在即将长时间执行程序前提示操作者。

语法： 无返回值 置等待鼠标 （）

例程：

说明：

设置鼠标成沙漏状，等待5秒后恢复原状。

参见： 例程


恢复鼠标 命令 操作系统支持：Windows 所属类别：系统处理

恢复鼠标 命令 　英文命令：RestroeCursor　操作系统支持：Windows 所属类别：系统处理

本命令恢复现行鼠标的原有形状，用作与“置等待鼠标”命令配对使用。

语法： 无返回值 恢复鼠标 （）

例程：

说明：

按下空格键，设置鼠标等待；按下回车键，鼠标恢复。

参见： 例程


延时 命令 操作系统支持：Windows 所属类别：系统处理

延时 命令 　英文命令：sleep　操作系统支持：Windows 所属类别：系统处理

本命令暂停当前程序的运行并等待指定的时间。

语法： 无返回值 延时 （欲等待的时间）

参数名 | 描 述
欲等待的时间 | 必需的；整数型。本参数指定欲暂停程序执行的时间，单位为毫秒。

例程：

说明：

两秒后程序自动结束。

参见： 例程


取文本注册项 命令 操作系统支持：Windows 所属类别：系统处理

取文本注册项 命令 　英文命令：GetTextRegItem　操作系统支持：Windows 所属类别：系统处理

在 Windows 注册表中返回指定的文本类型注册表项值。如欲读取注册项默认值，请在项目名后加“\”号，如“test\”。与“取文本注册表项”命令不同的是本命令可以取任意位置处的注册表项。

语法： 文本型 取文本注册项 （根目录，全路径注册项名，［默认文本］）

参数名 | 描 述
根目录 | 必需的；整数型。可以为以下常量值之一： 1、#根类； 2、#现行设置； 3、#现行用户； 4、#本地机器； 5、#所有用户。
全路径注册项名 | 必需的；文本型。
默认文本 | 可选的；文本型。如果指定的注册表项不存在，将返回此默认文本。如果指定的注册表项不存在且本参数被省略，将返回一个长度为 0 的空文本。

例程：

说明

在注册表中，REG-SZ类型是文本型。

取得在现行用户下设置的文本型注册项，并用信息框显示。

注：

1、#根类……………HKEY_CLASSES_ROOT
2、#现行设置………HKEY_CURRENT_CONFIG
3、#现行用户………HKEY_CURRENT_USER
4、#本地机器………HKEY_LOCAL_MACHINE
5、#所有用户………HKEY_USERS。

参见： 例程


取数值注册项 命令 操作系统支持：Windows 所属类别：系统处理

取数值注册项 命令 　英文命令：GetNumRegItem　操作系统支持：Windows 所属类别：系统处理

在 Windows 注册表中返回指定的数值类型注册表项值。如欲读取注册项默认值，请在项目名后加“\”号，如“test\”。与“取数值注册表项”命令不同的是本命令可以取任意位置处的注册表项。

语法： 整数型 取数值注册项 （根目录，全路径注册项名，［默认数值］）

参数名 | 描 述
根目录 | 必需的；整数型。可以为以下常量值之一： 1、#根类； 2、#现行设置； 3、#现行用户； 4、#本地机器； 5、#所有用户。
全路径注册项名 | 必需的；文本型。
默认数值 | 可选的；整数型。如果指定的注册表项不存在，将返回此默认数值。如果指定的注册表项不存在且本参数被省略，将返回数值 0。

例程：

说明：

在注册表中，REG-DWORD类型是数值型。

取得现行用户下设置的数值型注册项，并用信息框显示。

注：

1、#根类……………HKEY_CLASSES_ROOT
2、#现行设置………HKEY_CURRENT_CONFIG
3、#现行用户………HKEY_CURRENT_USER
4、#本地机器………HKEY_LOCAL_MACHINE
5、#所有用户………HKEY_USERS。

参见： 例程


取字节集注册项 命令 操作系统支持：Windows 所属类别：系统处理

取字节集注册项 命令 　英文命令：GetBinRegItem　操作系统支持：Windows 所属类别：系统处理

在 Windows 注册表中返回指定的字节集类型注册表项值。如欲读取注册项默认值，请在项目名后加“\”号，如“test\”。与“取字节集注册表项”命令不同的是本命令可以取任意位置处的注册表项。

语法： 字节集 取字节集注册项 （根目录，全路径注册项名，［默认字节集］）

参数名 | 描 述
根目录 | 必需的；整数型。可以为以下常量值之一： 1、#根类； 2、#现行设置； 3、#现行用户； 4、#本地机器； 5、#所有用户。
全路径注册项名 | 必需的；文本型。
默认字节集 | 可选的；字节集。如果指定的注册表项不存在，将返回此默认字节集。如果指定的注册表项不存在且本参数被省略，将返回空字节集。

例程：

说明：

在注册表中，REG-BINARY类型是字节集型。

取得在现行用户下设置的字节集型注册项。字节集是字节的集合，是字节的数组形式。用计次循环将每个字节依次取出来，用编辑框显示。

注：

1、#根类……………HKEY_CLASSES_ROOT
2、#现行设置………HKEY_CURRENT_CONFIG
3、#现行用户………HKEY_CURRENT_USER
4、#本地机器………HKEY_LOCAL_MACHINE
5、#所有用户………HKEY_USERS。

参见： 例程


写注册项 命令 操作系统支持：Windows 所属类别：系统处理

写注册项 命令 　英文命令：SaveRegItem　操作系统支持：Windows 所属类别：系统处理

在 Windows 注册表中保存或建立指定的注册表项。如欲写入注册项默认值，请在项目名后加“\”号，如“test\”。成功返回真，否则返回假。与“写注册表项”命令不同的是本命令可以写任意位置处的注册表项。

语法： 逻辑型 写注册项 （根目录，全路径注册项名，欲写入值）

参数名 | 描 述
根目录 | 必需的；整数型。可以为以下常量值之一： 1、#根类； 2、#现行设置； 3、#现行用户； 4、#本地机器； 5、#所有用户。
全路径注册项名 | 必需的；文本型。
欲写入值 | 必需的；通用型。参数值指定欲写入到指定注册表项中的值，只能为数值、文本或者字节集，否则命令将失败。

例程：

说明：

如果对注册表不是太明白，不要对注册表的数据进行改动。

建立一个新的注册项。通过判断返回值显示不同的信息框。

注：

1、#根类……………HKEY_CLASSES_ROOT
2、#现行设置………HKEY_CURRENT_CONFIG
3、#现行用户………HKEY_CURRENT_USER
4、#本地机器………HKEY_LOCAL_MACHINE
5、#所有用户………HKEY_USERS。

参见： 例程


删除注册项 命令 操作系统支持：Windows 所属类别：系统处理

删除注册项 命令 　英文命令：DeleteRegItem　操作系统支持：Windows 所属类别：系统处理

在 Windows 注册表中删除指定注册表项或注册表目录。如欲删除注册项默认值，请在项目名后加“\”号，如“test\”。成功返回真，否则返回假。与“删除注册表项”命令不同的是本命令可以删除任意位置处的注册表项或目录。注意在删除目录之前必须先删除该目录下所有的项目。

语法： 逻辑型 删除注册项 （根目录，全路径注册项名）

参数名 | 描 述
根目录 | 必需的；整数型。可以为以下常量值之一： 1、#根类； 2、#现行设置； 3、#现行用户； 4、#本地机器； 5、#所有用户。
全路径注册项名 | 必需的；文本型。

例程：

说明：

如果对注册表不太了解，不要删除注册表里的数据，否则严重时操作系统将崩溃。

删除注册表中的项目，通过判断不同的返回值，显示不同的信息框。

注：

1、#根类……………HKEY_CLASSES_ROOT
2、#现行设置………HKEY_CURRENT_CONFIG
3、#现行用户………HKEY_CURRENT_USER
4、#本地机器………HKEY_LOCAL_MACHINE
5、#所有用户………HKEY_USERS。

参见： 例程


注册项是否存在 命令 操作系统支持：Windows 所属类别：系统处理

注册项是否存在 命令 　英文命令：IsRegItemExist　操作系统支持：Windows 所属类别：系统处理

如果指定注册表项存在，返回真，否则返回假。如欲检查注册项是否有默认值，请在项目名后加“\”号，如“test\”。

语法： 逻辑型 注册项是否存在 （根目录，全路径注册项名）

参数名 | 描 述
根目录 | 必需的；整数型。可以为以下常量值之一： 1、#根类； 2、#现行设置； 3、#现行用户； 4、#本地机器； 5、#所有用户。
全路径注册项名 | 必需的；文本型。

例程：

说明：

如果对注册表有疑问，请参阅注册表相关知识。

判断某一项注册项是否存在。通过返回值，显示不同的信息框。

注：

1、#根类……………HKEY_CLASSES_ROOT
2、#现行设置………HKEY_CURRENT_CONFIG
3、#现行用户………HKEY_CURRENT_USER
4、#本地机器………HKEY_LOCAL_MACHINE
5、#所有用户………HKEY_USERS。

参见：例程


取默认底色 命令 操作系统支持：Windows 所属类别：系统处理

取默认底色 命令 　英文命令：GetBackColor　操作系统支持：Windows 所属类别：系统处理

取回Windows系统的默认窗口背景颜色。

语法： 整数型 取默认底色 （）

例程：

说明：

将标签的背景颜色设置为默认颜色值。

参见: 例程


快照 命令 操作系统支持：Windows 所属类别：系统处理

快照 命令 　英文命令：GetWinPic　操作系统支持：Windows 所属类别：系统处理

为高级用户提供，初级用户无需掌握；
捕获指定窗口或屏幕上所有现有显示内容，返回相应图片数据。如果失败，返回空字节集。

语法： 字节集 快照 （［窗口句柄］，［输出宽度］，［输出高度］）

参数名 | 描 述
窗口句柄 | 可选的；整数型。指定欲捕获其显示内容的窗口。如果被省略，默认为捕获屏幕显示内容。
输出宽度 | 可选的；整数型。指定图片的输出宽度。如果小于0，参数值指定的是最终图片输出宽度相对于所取得图片宽度的百分比（最小为10%）；如果等于0，则按图片原宽度输出；如果大于0，指定输出图片的绝对宽度。如果本参数被省略，默认值为0。
输出高度 | 可选的；整数型。指定图片的输出高度。如果小于0，参数值指定的是最终图片输出高度相对于所取得图片高度的百分比（最小为10%）；如果等于0，则按图片原高度输出；如果大于0，指定输出图片的绝对高度。如果本参数被省略，默认值为0。

例程：

说明：

将窗口句柄所指定的窗口范围捕捉成图片，输出的大小可以指定。并用图片框显示。

参见: 例程


读配置项 命令 操作系统支持：Windows 所属类别：系统处理

读配置项 命令 　英文命令：GetKeyText　操作系统支持：Windows 所属类别：系统处理

读取指定配置文件中指定项目的文本内容。

语法： 文本型 读配置项 （配置文件名，节名称，配置项名称，［默认文本］）

参数名 | 描 述
配置文件名 | 必需的；文本型。指定配置文件的名称，通常以.ini作为文件名后缀。
节名称 | 必需的；文本型。包含欲读入配置项所处节的名称。
配置项名称 | 必需的；文本型。参数值指定欲读入配置项在其节中的名称。
默认文本 | 可选的；文本型。如果指定配置项不存在，将返回此默认文本。如果指定配置项不存在且本参数被省略，将返回空文本。

例程：

说明：

配置文件与注册表功能类似。

在临时目录里建立配置文件，并写入配置项，同时显示在编辑框中。然后读取此配置项，用信息框显示。

参见: 例程


写配置项 命令 操作系统支持：Windows 所属类别：系统处理

写配置项 命令 　英文命令：SetKeyText　操作系统支持：Windows 所属类别：系统处理

将指定文本内容写入指定配置项中或者删除指定的配置项或节，如果指定配置文件不存在，将会自动创建。成功返回真，失败返回假。

语法： 逻辑型 写配置项 （配置文件名，节名称，［配置项名称］，［欲写入值］）

参数名 | 描 述
配置文件名 | 必需的；文本型。指定配置文件的名称，通常以.ini作为文件名后缀。
节名称 | 必需的；文本型。包含欲写入配置项所处节的名称。
配置项名称 | 可选的；文本型。参数值指定欲写入配置项在其节中的名称。如果参数值被省略，则删除指定节及其下的所有配置项。
欲写入值 | 可选的；文本型。参数值指定欲写入到指定配置项中的文本。如果参数值被省略，则删除所指定配置项。

例程：

说明：

配置文件与注册表功能类似

写配置项到指定的文件。然后用编辑框显示配置文件的内容。

参见: 例程


取配置节名 命令 操作系统支持：Windows 所属类别：系统处理

取配置节名 命令 　英文命令：GetSectionNames　操作系统支持：Windows 所属类别：系统处理

返回指定配置文件中所有已有节名的文本数组。

语法： 文本型数组 取配置节名 （配置文件名）

参数名 | 描 述
配置文件名 | 必需的；文本型。指定配置文件的名称，通常以.ini作为文件名后缀。

例程：

说明：

取得配置文件中所有小节的名称。

首先写配置项到配置文件，并将文件显示在编辑框中。然后取出配置节名，使用信息框显示。

参见: 例程


取操作系统类别 命令 操作系统支持：Windows 所属类别：系统处理

取操作系统类别 命令 　英文命令：GetSysVer　操作系统支持：Windows 所属类别：系统处理

返回当前操作系统的版本类别。返回值为以下值之一：0、未知； 1、Windows 32S； 2、Windows 9X (包含Win95、Win98、WinME等)； 3、Windows NT (包含WinNT、Win2000、WinXP等)； 4、Linux。

语法： 整数型 取操作系统类别 （）

例程：

说明：

取得代表系统版本类别的数值，通过判断弹出不同信息框，提示取出的系统版本类别。

参见: 例程


多文件对话框 命令 操作系统支持：Windows 所属类别：系统处理

显示一个文件打开对话框，允许用户选择或输入多个所需要打开的已存在文件，返回用户所选择或输入后的结果文本数组。如果用户未输入或按“取消”按钮退出，则返回一个成员数为0的空文本数组。

语法： 文本型数组 多文件对话框 （［标题］， ［过滤器］， ［初始过滤器］， ［初始目录］， ［不改变目录］）

参数名 | 描 述
标题 | 可选的； 文本型。指定文件打开对话框的标题，如果被省略，则默认为“请输入欲打开的文件：”。
过滤器 | 可选的； 文本型。过滤器文本由单个或多个成对的文本串组成，每对文本串的第一个描述显示形式，如：“文本文件（*.txt）”；第二个指定实际的过滤匹配符，如：“*.txt”，所有各文本串之间用“|”号隔开。如果被省略，则默认没有过滤器。
初始过滤器 | 可选的； 整数型。如果上一参数提供了有效的过滤器文本，则本参数用作指定初始的过滤器，0为第一个过滤器。如果被省略，则默认值为0。
初始目录 | 可选的； 文本型。指定当打开对话框时所自动跳转到的目录，如果被省略，则默认为当前目录。
不改变目录 | 可选的； 逻辑型。指定在对话框关闭后是否自动返回到进入对话框前的文件目录，如果被省略，则默认值为假。

例程

说明：

显示一个文件打开对话框，允许用户选择或输入多个所需要打开的已存在文件，返回用户所选择或输入后的结果文本数组。

参见：例程


媒体播放

媒体播放 类别 跳至：系统核心支持库


播放音乐 命令 操作系统支持：Windows 所属类别：媒体播放

播放音乐 命令 　英文命令：PlayMusic　操作系统支持：Windows 所属类别：媒体播放

可以播放 .WAV、.MID 声音文件或相应格式的字节集声音数据、声音资源。成功返回真，失败返回假。

语法： 逻辑型 播放音乐 （欲播放的音乐，［是否循环播放］）

参数名 | 描 述
欲播放的音乐 | 必需的；通用型。参数值可以为 .WAV、.MID 声音文件名称或相应格式的字节集声音数据、声音资源。
是否循环播放 | 可选的；逻辑型。为真表示指定音乐将被循环播放，否则仅只播放一次。如果本参数被省略，默认为仅播放一次。

例程：

说明：

选择一个以 .WAV .MID 为后缀的文件，并将文件路径显示在编辑框中。通过返回值的判断弹出不同信息框。

参见：例程1


停止播放 命令 操作系统支持：Windows 所属类别：媒体播放

停止播放 命令 　英文命令：PlayStop　操作系统支持：Windows 所属类别：媒体播放

停止正在播放的音乐。

语法： 无返回值 停止播放 （）

例程

说明

停止正在播放的音乐。再次播放将从头开始。

参见：例程1


播放MID 命令 操作系统支持：Windows 所属类别：媒体播放

播放MID 命令 　英文命令：PlayMID　操作系统支持：Windows 所属类别：媒体播放

可以自动连续播放多个 MIDI 声音文件（注意不支持 WAV ）或相应格式的字节集声音数据、声音资源。

语法： 无返回值 播放MID （［播放次数］，［间隔时间］，欲播放的 MIDI 音乐，… ）

参数名 | 描 述
播放次数 | 可选的；整数型。为 -1 表示指定音乐将被循环播放，否则仅只播放指定的次数。如果本参数被省略，默认值为 1 。
间隔时间 | 可选的；整数型。指定 MIDI 音乐之间的播放间隔时间，单位为 0.1 秒。如果本参数被省略，默认值为 0 。
欲播放的 MIDI 音乐 | 必需的；可扩充的；通用型，参数数据可以同时提供数组或非数组数据。参数值可以为 MIDI 声音文件名称或相应格式的字节集声音数据、声音资源。

例程：

说明：

前四行代码，使用户选择正确的文件类型。用编辑框显示声音文件的路径，包括以 .MID 为后缀的文件名称。

通过此命令的返回值判断播放音乐是否成功，并调用相对的信息框。

参见：例程1


播放MP3 命令 操作系统支持：Windows 所属类别：媒体播放

播放MP3 命令 　英文命令：PlayMP3　操作系统支持：Windows 所属类别：媒体播放

可以自动连续播放多个 MP3 音乐文件。

语法： 无返回值 播放MP3 （［播放次数］，欲播放的 MP3 文件名，… ）

参数名 | 描 述
播放次数 | 可选的；整数型。为 -1 表示指定音乐将被循环播放，否则仅只播放指定的次数。如果本参数被省略，默认值为 1 。
欲播放的 MP3 文件名 | 必需的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。

例程：

说明：

选择一个以 .MP3 为后缀的文件名的路径，并显示在编辑框中。通过返回值的判断弹出不同的信息框。

参见：例程1


同步播放MP3

同步播放MP3 命令 操作系统支持：Windows 所属类别：媒体播放

播放一次指定的MP3音乐文件，在播放过程中，会自动给指定标签组件发送反馈事件通知，以同步提供当前播放进度百分比。

语法： 无返回值 同步播放MP3 （欲播放的MP3文件名， ［起始播放位置］， ［欲通知的反馈标签］， ［保留参数］）

参数名 | 描 述
欲播放的MP3文件名 | 必需的； 文本型。
起始播放位置 | 可选的； 整数型。指定MP3的起始播放百分比位置，此值范围应在0-100之间。如果被省略，默认值为零，即从首部起始播放。
欲通知的反馈标签 | 可选的； 标签。如果本参数提供了有效的标签组件，在MP3播放过程中，会同步不断地给该组件发送反馈事件通知，该事件的第一个参数提供现行播放百分比位置，为0-100之间。MP3播放完毕后，将固定收到一个播放百分比参数为100的事件通知。
保留参数 | 可选的； 文本型。

例程

说明：

播放一次指定的MP3音乐文件。

参见：例程


暂停播放MP3

暂停播放MP3 命令 操作系统支持：Windows 所属类别：媒体播放

如果当前正在播放由“播放MP3”或“同步播放MP3”命令所指定的MP3音乐，则将其暂停。

语法： 无返回值 暂停播放MP3 （）

例程

说明：

如果当前正在播放由“播放MP3”或“同步播放MP3”命令所指定的MP3音乐，则将其暂停。

参见：例程


继续播放MP3

继续播放MP3 命令 操作系统支持：Windows 所属类别：媒体播放

如果当前由“播放MP3”或“同步播放MP3”命令所播放MP3音乐已经被暂停，则继续播放。

语法： 无返回值 继续播放MP3 （）

例程

说明：

如果当前由“播放MP3”或“同步播放MP3”命令所播放MP3音乐已经被暂停，则继续播放。

参见：例程


取MP3播放状态

取MP3播放状态 命令 操作系统支持：Windows 所属类别：媒体播放

返回当前由“播放MP3”或“同步播放MP3”命令所播放MP3音乐的播放状态： 0：已经被停止或未播放； -1：正在播放但被暂停； 1：正在播放。

语法： 整数型 取MP3播放状态 （）

例程

说明：

0：已经被停止或未播放； -1：正在播放但被暂停； 1：正在播放。

参见：例程


程序调试

程序调试 类别 跳至：系统核心支持库


输出调试文本 命令 所属类别：程序调试

输出调试文本 命令　英文命令：OutputDebugText　操作系统支持：Windows、Linux　　所属类别：程序调试

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
使用本命令可以在 E 调试系统中的“输出”窗体内输出指定的文本行以帮助调试，该文本之前被自动加上一个星号，之后被自动加上回车换行符。“输出调试文本”命令支持通用数据类型。

语法： 无返回值 输出调试文本 （准备输出的调试文本信息，… ）

参数名 | 描 述
准备输出的调试文本信息 | 必需的；可扩充的；文本型。

例程：

参见：例程1


暂停 命令 所属类别：程序调试

暂停 命令　　英文命令：stop　操作系统支持：Windows、Linux　　所属类别：程序调试

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
可以在子程序中的任何地方放置此命令，使用此命令，就相当于在程序代码中设置断点。

语法： 无返回值 暂停 （）

例程：

说明：

运行程序单击按钮弹出第一个信息框，使用暂停中断程序，只有再次按“F5”键才会弹出第二个信息框。

.

参见：例程1


检查 命令 所属类别：程序调试

检查 命令 　　英文命令：assert　操作系统支持：Windows、Linux　　所属类别：程序调试

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
执行本命令时，如果给定参数的条件值被计算后结果为假，易程序的执行将被暂停且警示。可以在子程序中的任何地方放置此命令，使用此命令，就相当于在程序代码中设置条件断点。

语法： 无返回值 检查 （被校验的条件）

参数名 | 描 述
被校验的条件 | 必需的；逻辑型。如果此条件不能成立，即参数值为假，易程序的执行将被暂停且警示。

例程：

说明：

执行本命令时，如果给定参数的条件值被计算后结果为假，易程序的执行将被暂停且警示。

一般用于检查程序错误。

参见：例程1


是否为调试版 命令 所属类别：程序调试

是否为调试版 命令 　英文命令：IsDebugVer　操作系统支持：Windows、Linux　　所属类别：程序调试

如果当前 EXE 易程序执行文件为易语言编辑环境调试运行程序时编译出来的调试版本，返回真。否则表明为发布版本，返回假。

语法： 逻辑型 是否为调试版 （）

例程

说明

判断当前运行的程序是否为调试版本。

参见：例程1


其他

其他 类别 跳至：系统核心支持库

载入 | 选择 | 多项选择 | 是否为空
是否已创建 | 取数据类型尺寸 | 取颜色值 | 取事件组件
事件转移 | 复制窗口组件 | 处理事件 | 载入图片
卸载图片 | 取硬盘特征字 | 取系统语言 | 写到内存
DLL命令调用转向 | 置错误提示管理 | 置DLL装载目录 |


载入 命令 所属类别：其他

载入 命令 　英文命令：LoadWin　操作系统支持：Windows 所属类别：其他

载入指定的窗口，根据窗口的“可视”属性决定是否显示它。成功返回真，失败返回假。

语法： 逻辑型 载入 （欲载入的窗口，［父窗口］，是否采用对话框方式）

参数名 | 描 述
欲载入的窗口 | 必需的；窗口。参数值指定欲载入的窗口。
父窗口 | 可选的；窗口。参数值指定欲载入窗口的父窗口，此窗口必须已经被载入。如果本参数被省略，表示无父窗口。如果窗口具有父窗口，其位置将永远位于父窗口的上面；当父窗口被关闭时，窗口将自动被关闭；当父窗口被禁止时，窗口将自动被禁止。
是否采用对话框方式 | 必需的；逻辑型，初始值为“真”。参数值指定用户在对被载入窗口进行操作的同时是否允许同时对其他窗口进行操作。如果本参数值为真： 1、即使被载入窗口的“可视”属性为假，在载入后也立即显示； 2、本命令一直等待到该窗口被销毁后才返回。

例程：

说明：

载入子窗口，通过选择框的选中状态设置被弹出窗口的弹出方式。当以对话框方式载入不可视窗口时，不再强制显示并等待，而直接返回，然后可以通过设置该窗口的可视属性为真来显示该对话框.

参见：例程


选择 命令 所属类别：其他

选择 命令 　英文命令：iif　操作系统支持：Windows、Linux、Unix 所属类别：其他

根据所提供参数的值，返回两部分中的其中一个。

语法： 通用型 选择 （用作选择的逻辑值，待选择项一，待选择项二）

参数名 | 描 述
用作选择的逻辑值 | 必需的；逻辑型。如果该值为真，将返回第一个待选择项，否则将返回第二个待选择项。
待选择项一 | 必需的；通用型。如果给定逻辑值为真，命令将返回本选择项。
待选择项二 | 必需的；通用型。如果给定逻辑值为假，命令将返回本选择项。

例程：

说明：

在此命令中使用条件语句，取出符合逻辑条件的数据。

连续按下按钮，保存的变量会递增。 在递增时用[选择]中的条件语句判断，如果条件成立取待选项一，否则取待选项二。

参见：例程


多项选择 命令 所属类别：其他

多项选择 命令 　英文命令：choose　操作系统支持：Windows、Linux、Unix 所属类别：其他

从参数列表项目中选择并返回一个值。

语法： 通用型 多项选择 （索引值，待选择项数据，… ）

参数名 | 描 述
索引值 | 必需的；整数型。命令会根据本索引值来返回选择项列表中的某个值。如果索引值是 1，则命令会返回列表中的第 1 个选择项。如果索引值是 2，则会返回列表中的第 2 个选择项，以此类推。如果索引值小于 1 或者大于最大可选择项，将会产生运行错误。
待选择项数据 | 必需的；可扩充的；通用型。

例程：

说明：

根据索引变量的值，取出对应位置的值。

参见：例程


是否为空 命令 所属类别：其他

是否为空 命令 　英文命令：IsMissing　操作系统支持：Windows、Linux、Unix 所属类别：其他

返回一个逻辑值，指出在调用子程序时是否为指定参数提供了数据（该参数必定有“可空”标志），如未提供，返回真，否则返回假。

语法： 逻辑型 是否为空 （欲测试的参数变量）

参数名 | 描 述
欲测试的参数变量 | 必需的；通用型，参数数据只能提供变量及变量数组。

例程：

说明：

分别使用两个事件程序调用一个子程序，并提供不同的参数。根据不同的选择值弹出不同的信息。

参见：例程


是否已创建 命令 所属类别：其他

是否已创建 命令 　英文命令：IsCreated　操作系统支持：Windows 所属类别：其他

如果指定的窗体或窗体单元有效且已经被载入或创建，返回真，否则返回假。对于窗体菜单项主键，如果其所处窗体已经被载入，命令将返回真，否则返回假。

语法： 逻辑型 是否已创建 （欲被检查的窗体或窗体主键）

参数名 | 描 述
欲被检查的窗体或窗体主键 | 必需的；通用型。

例程：

说明：

首先载入子窗口，然后使用信息框显示此命令的返回值。

参见：例程


取数据类型尺寸 命令 所属类别：其他

取数据类型尺寸 命令 　英文命令：GetDataTypeSize　操作系统支持：Windows 所属类别：其他

取指定数据类型的数据尺寸，该数据类型不能为文本、字节集、库或用户自定义数据类型。

语法： 整数型 取数据类型尺寸 （欲取其尺寸的数据类型）

参数名 | 描 述
欲取其尺寸的数据类型 | 必需的；整数型。参数值可以为以下常量： 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型； 9、#子程序指针型。

例程：

说明：

由于此命令参数的常量可以用整数数值代表，而组合框项目从0 开始，所以取出组合框选中项相对应的项目加1。

参见：例程


取颜色值 命令 所属类别：其他

取颜色值 命令 　英文命令：rgb　操作系统支持：Windows 所属类别：其他

返回一个整数，用来表示一个红绿蓝颜色值。

语法： 整数型 取颜色值 （红色，绿色，蓝色）

参数名 | 描 述
红色 | 必需的；整数型。数值范围从 0 到 255，表示颜色中的红色成份。
绿色 | 必需的；整数型。数值范围从 0 到 255，表示颜色中的绿色成份。
蓝色 | 必需的；整数型。数值范围从 0 到 255，表示颜色中的蓝色成份。

例程：

说明：

首先判断编辑框获得焦点时是否放开回车键，条件成立取出编辑框中按规定格式设置的颜色值，然后用取出的颜色值设置启动窗口的底色。

参见：例程


取事件组件 命令 所属类别：其他

取事件组件 命令 　英文命令：GetEventUnit　操作系统支持：Windows 所属类别：其他

返回一个有效的组件型数据，指定当前所正在处理的事件是从何组件实际产生的。本命令主要用于在事件处理子程序中动态确定事件的来源。注意：只能在处理事件的过程首部使用本命令，如果在其它情况下使用，将产生运行时错误。

语法： 通用型 取事件组件 （）

例程：

说明：

程序运行复制一个按钮组件，无论按下被复制按钮或按下复制出的按钮都会触发“_被复制按钮_被单击”事件子程序。

注：此命令必须有多个组件触发此命令才有效。

参见：例程


事件转移 命令 所属类别：其他

事件转移 命令 　英文命令：EventPost　操作系统支持：Windows 所属类别：其他

设置将第一个组件上产生的所有事件转交由第二个同窗体同类型组件的事件处理子程序去处理，就好象此事件是在第二个单元上实际发生的一样。本命令可用来设置用同一事件处理子程序处理来自多个同类型组件的事件。使用时可与“取事件组件”命令、对象的“标记”属性等相配合。设置成功返回真，失败返回假。

语法： 逻辑型 事件转移 （［组件一］，［组件二］）

参数名 | 描 述
组件一 | 必需的；通用型。参数值指定欲将其事件转移的组件。如果该参数值指定的不是窗体内的组件，而是窗体本身，则不考虑“单元二”参数的设置情况，直接取消被指定窗口上所有组件事件转移设置。
组件二 | 可选的；通用型。参数值指定组件件转移到的目的组件须与主键一的类型相同且在同一窗体内，否则命令会失败。如果本参数被省略，将取消主键一的原有事件转移设置。

例程：

说明：

按下“事件转移到按钮”，其事件没有被转移，然后取出事件组件的标记，根据标记知道被单击的按钮。

由于另一个按钮事件已经被转移到“事件转移到按钮”，所以按下另一个按钮后，程序将调用“_事件转移到按钮_被单击”事件子程序。

参见：例程


复制窗口组件 命令 所属类别：其他

复制窗口组件 命令 　英文命令：CopyWinUnit　操作系统支持：Windows 所属类别：其他

复制创建与指定窗口组件设计状态完全一致的新组件。该被复制组件将放在原组件的下面，其事件被自动转移到原组件上。如果复制时被复制窗体组件所在的窗口尚未被载入，那么复制出来的窗口主键也不会被立即创建，而会等到其所在窗口将来被载入时一并创建。并且此时复制出来的窗体组件将永久存在，就好象是用户在设计窗体时所加入的一样，不会因为其所在窗口被销毁而被抛弃；如果复制时被复制窗体组件所在的窗口已经被载入，该单元会被立即创建，但此时无论该单元的“可视”属性是真还是假，创建后的组件将不会被显示，以便于用户进行属性调整。此时复制出来的窗体组件为临时存在，在其所在窗口被销毁后，此窗体组件将被抛弃，下次再载入原窗口时此窗体组件将不复存在。成功返回真，失败返回假。

语法： 逻辑型 复制窗口组件 （欲被复制的窗口组件，存放新创建组件的变量）

参数名 | 描 述
欲被复制的窗体组件 | 必需的；通用型。参数值不能为窗体本身、窗体菜单项组件、选择夹窗口组件。
存放新创建组件的变量 | 必需的；通用型，参数数据只能提供变量。该变量数据类型必须与被复制窗口组件数据类型完全一致，否则命令会失败。

例程：

说明：

每复制出一个组件，首先移动，然后设置可视属性为真。如果没有移动，各组件将重叠为一个组件；如果未设置可视属性为真，各组件将隐藏。

注：复制窗口组件执行之后的新生组件的位置为默认原窗口组件的位置，而且复制组件不可视。

参见：例程


处理事件 命令 所属类别：其他

处理事件 命令 　英文命令：DoEvents　操作系统支持：Windows 所属类别：其他

暂时转让控制权，以便让 Windows 操作系统有机会处理其它的如用户键盘或鼠标输入等事件。直到操作系统处理并发送完程序队列中的所有事件后，命令才会返回。

语法： 无返回值 处理事件 （）

例程：

说明：

循环10000次，用编辑框显示当前循环数，通过判断选择框的选中状态，使程序根据条件选择执行“处理事件（）”命令。

参见：例程


载入图片 命令 所属类别：其他

载入图片 命令 　英文命令：LoadPic　操作系统支持：Windows 所属类别：其他

载入指定图片，以供画板、打印机等对象的“画图片”、“取图片宽度”、“取图片高度”之类成员命令使用。如成功则返回被载入图片的图片号，失败返回 0。

语法： 整数型 载入图片 （欲被载入的图片）

参数名 | 描 述
欲被载入的图片 | 必需的；通用型。参数值可以为 .JPG、.GIF、.BMP、.DIB、.ICO、.CUR 等等被支持格式的图片数据、图片资源或图片文件名。

例程：

说明：

将图片载入内存中，并取得图片句柄。

参见：例程


卸载图片 命令 所属类别：其他

卸载图片 命令 　英文命令：UnloadPic　操作系统支持：Windows 所属类别：其他

卸载被载入的图片，图片被卸载后不能再被使用。如果某图片被载入后未被卸载，在易程序退出时将自动被卸载。

语法： 无返回值 卸载图片 （图片号）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。

例程：

说明：

使用“画板.画图片（）”命令后，把内存中的图片卸载掉。.

参见：例程


取硬盘特征字 命令 所属类别：其他

取硬盘特征字 命令 　英文命令：GetHDiskCode　所属类别：其他

返回电脑中第一个物理硬盘的物理特征字，该特征字是仅硬件相关的，也就是说与任何软件系统都无关（包括操作系统）。用户可以使用此特征字来限制自己的程序仅在某一台计算机上运行，以保护自己软件的版权。本命令可以在任何 Windows 系统版本下运行。命令执行后如果返回 0 ，表示此次取硬盘特征字失败。由于有可能是因为暂时的 I/O 冲突造成，因此失败后可以等待一段随机时间后再试（可以参看例程）。如果重复尝试四五次后仍然失败，表明该硬盘无法取出特征字。

语法： 整数型 取硬盘特征字 （）

说明：

用取硬盘特征字命令的返回值保存到特征字保存变量。例：

注：局域网无法测出硬盘特征字。

参见：例程


取系统语言 命令 所属类别：其他

取系统语言 命令 　英文命令：GetSysLang　操作系统支持：Windows 所属类别：其他

返回当前系统运行时环境所支持的语言版本类型，为以下常量值之一： 1、GBK中文； 2、英文； 3、BIG5中文； 4、日文。

语法： 整数型 取系统语言 （）

例程：

说明：

使用信息框显示系统运行时语言版本类型。

参见：例程1


写到内存 命令 操作系统支持：Windows 所属类别：其他

写到内存 命令 　英文命令：WriteMem　操作系统支持：Windows 所属类别：其他

为高级用户提供，初级用户无需掌握；
将数据写出到指定的内存区域，注意调用本命令前一定要确保所提供的内存区域真实有效。本命令的最佳使用场合就是在易语言回调子程序和易语言DLL公开子程序中用作对外输出数据。

语法： 无返回值 写到内存 （欲写到内存的数据，内存区域指针，［内存区域尺寸］）

参数名 | 描 述
欲写到内存的数据 | 必需的；通用型，参数数据可以同时提供数组或非数组数据。参数值只能为基本数据类型数据或字节数组。
内存区域指针 | 必需的；整数型。本参数提供欲写向内存区域首地址的指针值。
内存区域尺寸 | 可选的；整数型。本参数提供该内存区域的有效尺寸，如果欲写出数据超出此尺寸值，将被自动切除。参数值如果为 -1 ，则表示此内存区域尺寸不受限制。如果本参数被省略，则默认值为 -1。

例程：

说明：

将文本写到指定内存区域。

参见：例程1 例程2 相关dll


DLL命令调用转向 命令 操作系统支持：Windows 所属类别：其他

为高级用户提供，初级用户无需掌握；
本命令用来设置下次程序中执行任意一条DLL命令时所使用的DLL库文件名和在DLL库文件中的调用命令名，此设置将覆盖该被调用DLL命令在程序设计时所提供的原始值。注意本命令仅对一次调用有效，即在程序执行一次任一DLL命令后，本命令的设置值将自动取消，不再对后续DLL命令调用起作用。可以通过本命令来实现对非固定DLL库文件中的DLL命令调用。命令执行成功返回真，如果指定DLL库文件不存在或该库文件中不存在所指定的调用命令名，则返回假。

语法： 逻辑型 DLL命令调用转向 （［DLL库文件名］，［调用命令名］）

参数名 | 描 述
DLL库文件名 | 可选的；文本型。指定欲调用DLL命令所处的DLL库全路径文件名，如果本参数为空文本或被省略，则取消上次调用本命令时所设置的信息，使其不再影响程序中对DLL命令的调用。
调用命令名 | 可选的；文本型。指定欲调用DLL命令在其所处DLL库文件中的名称。如果本参数为空文本或被省略，则当程序中下次调用DLL命令时将使用其程序设计时所提供的原始命令名。最好为本参数提供一个有效的调用命令名，这样做可以事先检查该调用命令名是否存在。

例程：

说明：

使调用的DLL命令所产生的功能效果转移到自己定义的DLL命令上，即自己定义的DLL命令具有与调用的DLL命令相同的作用。

注意本命令仅对一次调用有效，再次使用必须再次调用本方法。


置错误提示管理

置错误提示管理 命令 操作系统支持：Windows 所属类别：其他

为高级用户提供，初级用户无需掌握；
本命令用来设置当运行时如果产生了导致程序崩溃的严重错误时用来对该错误进行详细提示的子程序地址，如果未进行此项设置，发生严重错误时运行时环境将自动提示该错误的详细信息并直接退出。

语法： 无返回值 置错误提示管理 （［用作进行错误提示的子程序］）

参数名 | 描 述
用作进行错误提示的子程序 | 可选的； 子程序指针。注意该子程序必须接收两个参数，第一个参数为整数型，用作接收错误代码，第二个参数为文本型，用作接收详细错误文本。同时该子程序必须返回一个逻辑值，返回真表示已经自行处理完毕，系统将不再显示该错误信息，返回假表示由系统来继续显示该错误信息。以上设置必须完全正确，否则结果不能预测，另外，还请注意以下几点： 1、该错误提示子程序不要再引发新的错误； 2、在进入该错误提示子程序后，系统将自动关闭事件消息通知处理机制，也就是说任何事件将无法得到响应； 3、无论如何，当该子程序调用退出后，系统将自动将整个应用程序关闭。 如果省略本参数，系统将恢复错误提示的默认处理方式。

例程：

说明：

本命令用来设置当运行时如果产生了导致程序崩溃的严重错误时用来对该错误进行详细提示的子程序地址，如果未进行此项设置，发生严重错误时运行时环境将自动提示该错误的详细信息并直接退出。

参见：例程1


置DLL装载目录

置DLL装载目录 命令 操作系统支持：Windows 所属类别：其他

为高级用户提供，初级用户无需掌握；
本命令用来设置当程序中执行到DLL命令时装载其DLL库文件的优先装载路径，即系统将优先到该路径下去装载指定的DLL文件。本命令所设置结果对所有DLL命令设置中的未指定全路径的DLL库文件装载均有影响，且在程序运行期间全程有效。命令执行后返回系统在本次设置以前的值。

语法： 文本型 置DLL装载目录 （［DLL装载目录］）

参数名 | 描 述
DLL装载目录 | 可选的； 文本型。本参数指定系统对DLL命令配置中DLL库文件的优先装载路径，如果被省略，则默认值为空文本。

例程

说明：

设置当程序中执行到DLL命令时装载其DLL库文件的优先装载路径，

使调用的DLL命令所产生的功能效果转移到自己定义的DLL命令上，即自己定义的DLL命令具有与调用的DLL命令相同的作用。

注意本命令仅对一次调用有效，再次使用必须再次调用本方法。


数据库

数据库 类别 跳至：系统核心支持库

是否支持多用户 | 取错误码 | 取错误信息 | 创建
打开 | 替换打开 | 置当前库 | 取当前库
关闭 | 全部关闭 | 取库文件名 | 是否已打开
取记录数 | 取创建时间 | 取字段数 | 取字段名
改字段名 | 取字段类型 | 取字段尺寸 | 新建索引
置当前索引 | 取当前索引 | 更新索引 | 取索引数
取索引名 | 取索引字段 | 置加锁重试时间 | 锁住数据库
解锁数据库 | 锁住增删 | 解增删锁 | 锁住记录
解锁记录 | 全部解锁 | 取平均值 | 求和
取最大值 | 取最小值 | 取最大时间 | 取最小时间
计算数目 | 复制结构 | 复制记录 | 计算排序
排序 | 分类计算 | 添加 | 加记录
加空记录 | 替换 | 修改 | 删除
是否已删除 | 恢复删除 | 彻底删除 | 清空
读 | 写 | 读字段 | 写字段
附加字节集 | 附加备注 | 索引查找 | 查找
到首记录 | 到尾记录 | 跳过 | 取记录号
跳到 | 取标签 | 记录是否存在 | 标签跳转
首记录前 | 尾记录后 | 写出缓存 | 写出所有缓存
编辑 | 是否已加密 | 置数据库密码 | 密码输入框
复制密码 |  |  |


是否支持多用户 命令 所属类别：数据库

是否支持多用户 命令 　英文命令：MutiUser　所属类别：数据库

检查本支持库所提供的数据库功能是否支持多用户同时对数据库操作。如果支持，返回真，否则返回假。

语法： 逻辑型 是否支持多用户 （）

例程：

说明：

是否支持多用户命令，是检查当前的数据库，是否支持多用户同时进行操作，在检查数据库前，要先把待检查的数据库打开，如果本数据库支持多用户则返回真，否则，返回假。

用存放返回值的变量存放是否支持多用户命令的返回值，最后，用信息框查看本命令的返回值。如果此数据库支持多用户，信息框会显示“真”，否则，显示“假”。

参见：例程1 数据库下载


取错误码 命令 所属类别：数据库

取错误码 命令 　英文命令：GetErrCode　所属类别：数据库

如果执行某数据库命令失败，在其后执行本命令可以取回非 0 的数据库错误码值。如果该数据库命令执行成功，执行本命令将返回 0 。

语法： 整数型 取错误码 （）

例程：

说明：

首先把要操作的数据库打开，然后执行“写（）”命令，程序将改写“改写字段编辑框”中输入的字段，改写内容为“改写内容编辑框”中的内容。如果改写成功，会弹出信息框显示“写入数据成功”；如果改写失败，会弹出信息框提示失败，将本次操作的错误码和错误信息取出，并显示在信息框中，这样用户就可以知道操作数据库失败的错误原因。

参见：例程1 数据库下载


取错误信息 命令 所属类别：数据库

取错误信息 命令 　英文命令：GetErrMsg　所属类别：数据库

如果执行某数据库命令失败，在其后执行本命令可以取回错误信息文本。如果该数据库命令执行成功，执行本命令将返回空文本。

语法： 文本型 取错误信息 （）

例程：

说明：

首先把要操作的数据库打开，然后执行“写（）”命令，程序将改写“改写字段编辑框”中输入的字段名，改写内容为“改写内容编辑框”的内容。如果改写成功，会弹出信息框显示“写入数据成功”；如果改写失败，会弹出信息框提示失败，将本次操作的错误码和错误信息取出，并显示在信息框中，这样用户就可以知道操作数据库失败的错误原因。

参见：例程1 数据库下载


创建 命令 所属类别：数据库

创建 命令 　英文命令：create　所属类别：数据库

创建指定的数据库文件，如果该数据库文件存在，将被覆盖。成功返回真，失败返回假。

语法： 逻辑型 创建 （欲创建数据库的文件名，字段信息表）

参数名 | 描 述
欲创建数据库的文件名 | 必需的；文本型。
字段信息表 | 必需的；字段信息，参数数据只能提供数组数据。参数数组值中顺序指定本数据库中所有字段的信息。

例程：

说明：

首先判断“字段名称编辑框”是否为空，然后判断“字段类型组合框”是否有选项。如果都有内容，则将欲添加的字段的名称和类型存放在“临时字段信息”变量中，程序中已经将对应数据类型的常量值添加到了组合框的“项目数值”属性中，所以程序中使用组合框的“取项目数值”方法，就可以正确的定义创建字段的类型。由于字段信息型数据中的“最大文本长度”只有在字段类型为文本型时才有效，所以判断“字段类型组合框”是否选中了“文本型”选项，如果欲创建的字段为文本型，则设置“最大文本长度”。然后将“临时字段信息”变量的内容加入到“字段信息表”变量中，并用“已添加字段列表框”显示已经添加过的字段。点击“创建数据库”按钮后，使用“创建（）”命令创建设计好结构的数据库，创建后将列表框和“字段信息表”变量清空。

这里要注意，创建数据库中的字段名不可以重复，如果字段名重复会导致创建数据库失败。

参见：例程1


打开 命令 所属类别：数据库

打开 命令 　英文命令：use　所属类别：数据库

打开指定的数据库文件。成功返回真，并自动将当前数据库设置为此数据库，失败返回假。

语法： 逻辑型 打开 （数据库文件名，［在程序中使用的别名］，［是否只读］，［共享方式］，［保留参数1］，［数据库密码］，［索引文件表］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。
在程序中使用的别名 | 可选的；文本型。别名为在后面的程序中引用本数据库时可使用的另一个名称。欲引用一个已经被打开的数据库可以使用该数据库本身的名称（数据库名称为数据库文件名的无路径和后缀部分。譬如 c:\my documents\gz.edb ，其数据库名称为 gz ），也可以使用在此处所指定的别名。别名主要用作避开重复的数据库名称或者简化对长数据库名的引用。数据库名称与别名皆不区分大小写，在查找数据库时，系统将优先查找别名。如果本参数被省略，默认为没有别名。
是否只读 | 可选的；逻辑型。参数值说明是否仅对数据库进行读操作，如果省略本参数，默认为假。
共享方式 | 可选的；整数型。参数值指定在多用户环境中限制其它用户操作此数据库的方式。如果省略本参数，默认为“#无限制”。方式值可以为以下常量之一： 1、#无限制：允许其它用户任意操作此数据库； 2、#禁止读：禁止其它用户读此数据库； 3、#禁止写：禁止其它用户写此数据库； 4、#禁止读写：独占使用此数据库，禁止其它用户的任何操作。
保留参数1 | 可选的；文本型。本参数仅用作保留参数位置。
数据库密码 | 可选的；文本型。本参数提供访问数据库时所需要的密码，如果该数据库没有被加密，请提供空文本。注意“?”（即单个问号）是一个特殊的密码文本，它要求系统当发现所欲打开的数据库具有密码保护时，自动弹出一个密码输入框提示用户输入正确的密码。如果用户在该输入框中取消输入或连续三次输入了错误密码，打开命令将失败，且执行“取错误码”命令将返回-78。如果本参数被省略，默认为空文本。
索引文件表 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定本数据库的所有索引文件，它们将被同步打开，以便得到及时更新。

例程：

说明：

首先使用数组变量存放欲打开的索引文件名，然后使用打开命令打开数据库，并同时打开索引。如果数据库打开成功，则使用一个记次循环将所有记录的姓名字段内容显示在列表框中。

注意：在对任何易语言数据库进行操作前，都要使用“打开（）”命令将数据库打开，成功打开后才能操作数据库，在操作完毕候，要将数据库关闭；指定打开数据库同时打开索引文件，如果索引文件打开失败，数据库也将打开失败。

参考：例程1 数据库下载 索引1下载 索引2下载


替换打开 命令 所属类别：数据库

替换打开 命令 　英文命令：ruse　所属类别：数据库

打开指定的数据库文件。成功返回真，并自动关闭当前数据库后将当前数据库设置为此数据库，失败返回假。

语法： 逻辑型 替换打开 （数据库文件名，［在程序中使用的别名］，［是否只读］，［共享方式］，［保留参数1］，［数据库密码］，［索引文件表］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。
在程序中使用的别名 | 可选的；文本型。别名为在后面的程序中引用本数据库时可使用的另一个名称。欲引用一个已经被打开的数据库可以使用该数据库本身的名称（数据库名称为数据库文件名的无路径和后缀部分。譬如 c:\my documents\gz.edb ，其数据库名称为 gz ），也可以使用在此处所指定的别名。别名主要用作避开重复的数据库名称或者简化对长数据库名的引用。数据库名称与别名皆不区分大小写，在查找数据库时，系统将优先查找别名。如果本参数被省略，默认为没有别名。
是否只读 | 可选的；逻辑型。参数值说明是否仅对数据库进行读操作，如果省略本参数，默认为假。
共享方式 | 可选的；整数型。参数值指定在多用户环境中限制其它用户操作此数据库的方式。如果省略本参数，默认为“#无限制”。方式值可以为以下常量之一： 1、#无限制：允许其它用户任意操作此数据库； 2、#禁止读：禁止其它用户读此数据库； 3、#禁止写：禁止其它用户写此数据库； 4、#禁止读写：独占使用此数据库，禁止其它用户的任何操作。
保留参数1 | 可选的；文本型。本参数仅用作保留参数位置。
数据库密码 | 可选的；文本型。本参数提供访问数据库时所需要的密码，如果该数据库没有被加密，请提供空文本。注意“?”（即单个问号）是一个特殊的密码文本，它要求系统当发现所欲打开的数据库具有密码保护时，自动弹出一个密码输入框提示用户输入正确的密码。如果用户在该输入框中取消输入或连续三次输入了错误密码，打开命令将失败，且执行“取错误码”命令将返回-78。如果本参数被省略，默认为空文本。
索引文件表 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定本数据库的所有索引文件，它们将被同步打开，以便得到及时更新。

例程：

说明：

启动窗口创建完毕后，就将运行目录下的“数据库1”打开，可以在“选择组合框”中选择要替换打开的数据库，当点击“替换打开”按钮后，如果当前数据库不是组合框中选择的数据库，则使用“替换打开（）”命令将当前数据库关闭后，打开组合框中选择的数据库。

参见：例程1 数据库下载1 数据库下载2


置当前库 命令 所属类别：数据库

置当前库 命令 　英文命令：select　所属类别：数据库

本命令选择一个已经被打开的数据库为当前数据库，大部分数据库操作命令都针对当前数据库，譬如：记录指针的移动、字段的读写等等。如果指定数据库不存在或者尚未被打开，命令将返回假，否则返回真。

语法： 逻辑型 置当前库 （数据库别名或名称）

参数名 | 描 述
数据库别名或名称 | 必需的；文本型。参数值指定一个已经被打开的数据库。

例程：

说明：

使用“置当前库（）”命令将当前库设置为组合框中所选数据库，并使用记次循环命令将当前库所有记录的“年龄”显示在列表框中。

注意：易语言中大部分对易数据库进行操作的命令都是针对当前数据库的，所以当打开多个数据库时，对指定数据库操作前要先设置该数据库为当前数据库，然后再使用其他命令进行操作。

参见：例程1 数据库下载1 数据库下载2


取当前库 命令 所属类别：数据库

取当前库 命令 　英文命令：dbf　所属类别：数据库

返回当前数据库的别名，如不存在别名，则返回其名称。如果未设置当前数据库，将返回空文本。

语法： 文本型 取当前库 （）

例程：

说明：

使用“取当前库()”命令，将当前数据库名取出，显示在“当前库编辑框中”。在改变当前库后，也使用“置当前库()”命令显示当前数据库名。

参见：例程1 数据库下载


关闭 命令 所属类别：数据库

关闭 命令 　英文命令：CloseDBF　所属类别：数据库

本命令关闭已经被打开的指定数据库。如果没有提供数据库名称，默认为关闭当前数据库。如果当前数据库被关闭，当前数据库状态值将被设置为空，此时可重新使用“置当前库”命令来进行相应设置。

语法： 无返回值 关闭 （［数据库别名或名称］）

参数名 | 描 述
数据库别名或名称 | 可选的；文本型。参数值如果被省略，默认为关闭当前数据库。

例程：

说明：

启动窗口创建完毕后打开2个数据库，按下“关闭当前库”按钮后，“关闭()”命令将关闭当前数据库；按下“关闭指定库”按钮后，会弹出一个输入框，使用输入框来输入欲关闭的数据库名。注意：“关闭”命令可以关闭当前数据库，也可以关闭指定数据库。

参见：例程1 数据库下载1 数据库下载2


全部关闭 命令 所属类别：数据库

全部关闭 命令 　英文命令：CloseAll　所属类别：数据库

本命令关闭当前已经被打开的所有数据库。

语法： 无返回值 全部关闭 （）

例程：

说明：

启动窗口创建完毕和“打开数据库”按钮被按下都会打开2个数据库，“全部关闭”按钮被按下后，会运行“全部关闭()”命令，当前所有被打开的数据库都将被关闭，标签会显示当前“没有打开数据库”。当启动窗口将被销毁前也会运行“全部关闭()”命令，在程序结束运行前将打开的数据库全部关闭。

参见：例程1 数据库下载1 数据库下载2


取库文件名 命令 所属类别：数据库

取库文件名 命令 　英文命令：GetDBF　所属类别：数据库

返回当前数据库的全路径文件名。如果当前数据库不存在，返回空文本。

语法： 文本型 取库文件名 （）

例程：

说明：

启动窗口创建完毕后，打开2个数据库，并将打开数据库的全路径文件名存放再数组变量“已打开数据库名”中，当点击“显示库文件名”按钮，就将已经打开数据库的全路径文件名显示在列表框中，并显示出当前数据库名。

参见：例程1 数据库下载


是否已打开 命令 所属类别：数据库

是否已打开 命令 　英文命令：used　所属类别：数据库

如果指定数据库文件已经被打开，返回真，否则返回假。

语法： 逻辑型 是否已打开 （欲测试的数据库文件名）

参数名 | 描 述
欲测试的数据库文件名 | 必需的；文本型。

例程：

说明：

当运行“全部关闭()”命令后，使用“是否已关闭 ()”命令来判断被关闭命令是否确实被关闭，如果都被关闭，则“当前打开库标签” 显示 “当前没有被打开数据库”。

参见：例程1 数据库下载


取记录数 命令 所属类别：数据库

取记录数 命令 　英文命令：RecCount　所属类别：数据库

返回当前数据库的记录数目。如果没有设置当前数据库或者失败，将返回 0 。

语法： 整数型 取记录数 （）

例程：

说明：

当数据库打开成功，使用“取记录数()”命令，取出当前数据库中的记录数，使用该记录数来规定“记次循环()”命令的循环次数，通过循环，所有记录的“姓名”字段内容就显示在了列表框中。

参见：例程1　 数据库下载1 数据库下载2


取创建时间 命令 所属类别：数据库

取创建时间 命令 　英文命令：DateCreated　所属类别：数据库

返回当前数据库被创建的时间。

语法： 日期时间型 取创建时间 （）

例程：

说明：

本命令，可以把当前数据库的创建时间取出并返回，返回的是日期时间型的数据，使用时要注意数据类型之间的转换。

例程中，使用用编辑框显示出数据库1的创建时间，首先打开运行目录下的数据库1，然后用取创建时间命令取出数据库1的创建时间，由于本命令返回的是一个日期时间型的数据，所以用编辑框显示时，用了“到文本( )”命令，将日期时间型的数据，转换成文本型数据显示出来。

参见：例程1 数据库下载


取字段数 命令 所属类别：数据库

取字段数 命令 　英文命令：FCount　所属类别：数据库

返回当前数据库中字段的数目。

语法： 整数型 取字段数 （）

例程：

说明：

使用2个“记次循环”将所有记录所及有字段的内容添加到“超级列表框”中的指定列中，第二个记次循环的循环次数，使用“取字段数”命令取出，有几个字段就循环几次，每次循环就向超级列表框的指定列添加对应字段的内容。

参见：例程1 数据库下载


取字段名 命令 所属类别：数据库

取字段名 命令 　英文命令：GetFieldName　所属类别：数据库

返回当前数据库中指定字段的名称。如果指定字段不存在，将返回空文本。

语法： 文本型 取字段名 （字段名称或位置）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。

例程：

说明：

首先使用“取字段数()”命令取出数据库中的字段数，并规定循环的次数为该字段数，然后在记次循环中使用“取字段名()”命令将每个字段的字段名依次取出，并显示在列表框中。

参见：例程1 数据库下载


改字段名 命令 所属类别：数据库

改字段名 命令 　英文命令：ModiFieldName　所属类别：数据库

修改当前数据库中指定字段的名称。本命令只有当数据库的共享打开方式为“#禁止读写”时才有效。成功返回真，失败返回假。

语法： 逻辑型 改字段名 （字段名称或位置，字段的新名称）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。
字段的新名称 | 必需的；文本型。

例程：

说明：

启动窗口创建完毕后，将数据库中所有字段名显示在“字段名列表框”中，当列表框中的项目被双击后，弹出输入框，输入框中输入的内容存放在“改后字段名”变量中，当点击输入框中“确认输入”按钮后，便将列表框中指定字段的内容改成输入框中输入的字段名。

在列表框加入项目的同时，将项目数值设置为对应字段在数据库中的位置索引（字段和列表项目通过项目数值相联系），所以在修改字段名时，“改字段名()”命令的“字段名称或位置”参数，直接填写列表框现行选中项的项目数值即可。

参见：例程1 数据库下载


取字段类型 命令 所属类别：数据库

取字段类型 命令 　英文命令：GetFieldType　所属类别：数据库

返回当前数据库中指定字段的类型，字段类型值为以下常量值之一： 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型； 10、#文本型； 11、#字节集型； 12、#备注型。如果指定字段不存在，将返回 0 。

语法： 整数型 取字段类型 （字段名称或位置）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。

例程：

说明：

使用记次循环，将数据库中所有字段的字段名、字段类型和字段尺寸取出，并显示在超级列表框中，注意：“取字段类型 ()”命令返回的是一个整数值，所以可以参照上面命令的解释来判断返回值的实际意义。

参见：例程1 数据库下载


取字段尺寸 命令 所属类别：数据库

取字段尺寸 命令 　英文命令：FSize　所属类别：数据库

返回当前数据库中指定字段在记录中所占的尺寸。如果指定字段不存在，将返回 0 。注意：备注型和字节集型字段将返回 4 。

语法： 整数型 取字段尺寸 （字段名称或位置）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。

例程：

说明：

使用记次循环，将数据库中所有字段的字段名、字段类型和字段尺寸取出，并显示在超级列表框中。循环中使用“取字段尺寸()”命令，将所有字段所占尺寸取出来，该命令返回指定字段在记录中所占的尺寸。

参见：例程1 数据库下载


新建索引 命令 所属类别：数据库

新建索引 命令 　英文命令：CreateIndex　所属类别：数据库

在当前数据库中创建并打开一个索引文件。索引的存在将降低对数据库记录的更新速度，所以除非是较大的数据库（最起码在一千条记录以上），否则一般不用使用索引。成功返回真，失败返回假。

语法： 逻辑型 新建索引 （欲创建索引文件的名称，［索引类型］，［索引选项］，［索引块尺寸］，被索引字段的名称，… ）

参数名 | 描 述
欲创建索引文件的名称 | 必需的；文本型。
索引类型 | 可选的；整数型。参数值可以为以下常量值之一，如果被省略，默认为“#通常索引”： 1、#通常索引； 2、#读音索引： 在文本型索引字段中，所有汉字根据标准读音建立索引； 3、#南方读音索引： 在文本型索引字段中，所有汉字根据南方读音建立索引（南方读音不区分卷舌音和平舌音）。
索引选项 | 可选的；整数型。参数值可以为以下常量值之一或者之和： 1、#不区分大小写：文本型索引字段中不区分英文字母的大小写； 2、#忽略所有空格：文本型索引字段中忽略所有的全、半角空格。如果本参数被省略，默认为 0 。
索引块尺寸 | 可选的；整数型。参数值指定索引文件记录索引项时所使用索引块的大小，以 512 字节为单位，最大值为 10 。如果本参数被省略，默认值为 1 。仅在大型数据库中需要建立大索引块的索引文件，一般情况下使用默认值即可。
被索引字段的名称 | 必需的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有被索引字段的名称，支持以数组方式直接提供多个字段。

例程：

说明：

启动窗口创建完毕后，就将数据库中所有字段添加到组合框中。当组合框中的项目被选中，就将选中的字段名添加到数组变量“索引字段表”中，并将该字段名添加到列表框中，并删除组合框中已经选择的项目（由于添加索引的字段不可以重复），当点击“新建索引”按钮，就新建一个索引，索引字段为“索引字段表”中添加过的字段。

参见：例程1 数据库下载


置当前索引 命令 所属类别：数据库

置当前索引 命令 　英文命令：SetIndexTo　所属类别：数据库

为当前数据库指定当前索引，在进行索引查找时将使用当前索引。如果指定索引不存在，将返回假。

语法： 逻辑型 置当前索引 （索引名称）

参数名 | 描 述
索引名称 | 必需的；文本型。索引名称为索引文件名的无后缀部分。譬如“sy.enx”索引文件，其索引名称为“sy”。

例程：

说明：

在打开数据库的同时，打开2个索引文件，并添加到组合框中，当组合框的项目被选择，则使用“置当前索引()”命令，设置当前索引为组合框中选择的索引，并使用列表框显示当前索引的索引字段。这里要注意，置当前索引时，只需给出该索引省略扩展名和路径的文件名即可。

参见：例程1 数据库下载 索引1下载 索引2下载


取当前索引 命令 所属类别：数据库

取当前索引 命令 　英文命令：ndx　所属类别：数据库

返回当前数据库的当前索引名称。如果未设置当前数据库或无当前索引，返回空文本。

语法： 文本型 取当前索引 （）

例程：

说明：

当打开2个索引后，使用“取当前索引()”命令取出当前索引，并使用标签显示。当改变当前索引时，使用同样方法使用标签显示当前索引。

参见：例程1 数据库下载 索引1下载


更新索引 命令 所属类别：数据库

更新索引 命令 　英文命令：reindex　所属类别：数据库

通过完全重建来更新当前数据库的当前索引。成功返回真，失败返回假。

语法： 逻辑型 更新索引 （）

例程：

说明：

打开数据库的同时，打开2个索引文件。“更新索引”按钮被单击后，运行“更新索引()”命令，成功更新索引后，将当前打开的索引显示在列表框中。

参见：例程1 数据库下载 索引1下载


取索引数 命令 所属类别：数据库

取索引数 命令 　英文命令：GetIndexCount　所属类别：数据库

返回当前数据库中已经被打开索引的数目。

语法： 整数型 取索引数 （）

例程：

说明：

启动窗口创建完毕后，打开数据库1，同时打开2个索引文件。当点击“显示索引”按钮，使用“取索引数()”命令将当前打开的索引数取出，并用该数值规定“记次循环首()”命令的循环次数，在循环中使用“取索引名()”命令依次将每个索引的名字取出，并添加到列表框中。

参见：例程1 数据库下载 索引1下载 索引2下载


取索引名 命令 所属类别：数据库

取索引名 命令 　英文命令：GetIndexName　所属类别：数据库

返回当前数据库中指定索引的名称。如果指定位置处不存在索引，将返回空文本。

语法： 文本型 取索引名 （索引位置）

参数名 | 描 述
索引位置 | 必需的；整数型。参数值指定索引在当前数据库内所有被打开索引中的位置，从 1 开始。

例程：

说明：

启动窗口创建完毕后，打开数据库1，同时打开2个索引文件。当点击“显示索引”按钮，使用“取索引数()”命令将当前打开的索引数取出，并用该数值规定“记次循环首()”命令的循环次数，在循环中使用“取索引名()”命令依次将每个索引的名字取出，并添加到列表框中。

参见：例程1 数据库下载 索引1下载 索引2下载


取索引字段 命令 所属类别：数据库

取索引字段 命令 　英文命令：GetIndexField　所属类别：数据库

返回当前数据库中指定索引内所有被索引字段的名称数组。如果指定位置处不存在索引，将返回空数组。

语法： 文本型数组 取索引字段 （索引位置）

参数名 | 描 述
索引位置 | 必需的；整数型。参数值指定索引在当前数据库内所有被打开索引中的位置，从 1 开始。

例程：

说明：

当组合框中项目被选择，则使用“取索引字段()”命令，将组合框中所选索引的索引字段取出，并存放在数组变量“索引字段”中，然后使用记次循环，将该索引文件的索引字段显示在列表框中。

参见：例程1 数据库下载 索引1下载


置加锁重试时间 命令 所属类别：数据库

置加锁重试时间 命令 　英文命令：SetLockTimeout　所属类别：数据库

本命令设置对数据库进行加锁时，如果该位置已经被其他用户锁住或者正在被其他用户访问，系统反复重试加锁的时间。当你的数据库可能被多用户同时访问时，必须在程序首使用本命令设置一个合适的时间值。一般情况下，可以设置为 60 秒，或者根据所处网络的传输和通畅速度来具体设置。

语法： 无返回值 置加锁重试时间 （［加锁重试时间］）

参数名 | 描 述
加锁重试时间 | 可选的；整数型。参数值可以为以下值之一： 1、 大于 0 的值。用于指定具体的重试间隔时间，单位为秒； 2、 0 。不重试，第一次加锁失败后立即返回错误（系统初始值）； 3、 -1。一直重试，直到加锁成功。如果本参数被省略，默认值为 0 。

例程：

说明：

本命令可以在数据库加锁失败后自动重试加锁，只到加锁成功为止。

当点击“置数据库密码按钮”，首先判断数据库是否已经加密，如果是加密数据库首先弹出输入框提示输入密码，然后打开数据库，如果打开数据库成功，则判断如果“重试时间编辑框”中的内容不为空，则使用“置加锁重试时间()”命令设置加锁重试时间，然后对数据库进行加密，如果加密失败并设置了加锁重试时间，则会自动重试加密。

参见：例程1 数据库下载


锁住数据库 命令 所属类别：数据库

锁住数据库 命令 　英文命令：LockDBF　所属类别：数据库

本命令执行后独占锁住整个当前数据库，拒绝其它用户的任何访问。成功返回真，失败返回假。

语法： 逻辑型 锁住数据库 （）

例程：

说明：

程序运行后打开数据库，当按下“锁住数据库”按钮，使用“锁住数据库()”命令对数据库进行加锁。并用信息框提示是否加锁成功。

可以使用“测试按钮”来测试当前数据库是否允许多个程序访问，该按钮被按下后会自动导出并运行另一个易程序，并访问该数据库。

注意：“锁住数据库()”命令也可多次对数据库进行加锁，多次加锁后，解锁的次数也要相同才能成功解锁。

参见：例程1 数据库下载

相关参见：解锁数据库


解锁数据库 命令 所属类别：数据库

解锁数据库 命令 　英文命令：UnlockDBF　所属类别：数据库

本命令解除“锁住数据库”命令对当前数据库加的锁。成功返回真，失败返回假。

语法： 逻辑型 解锁数据库 （）

例程：

说明：

程序运行后打开数据库，当按下“解锁数据库”按钮，使用“解锁数据库()”命令对数据库进行解锁。并用信息框提示是否解锁成功。

可以使用“测试按钮”来测试当前数据库是否允许多个程序访问，该按钮被按下后会自动导出并运行另一个易程序，并访问该数据库。

注意：“锁住数据库()”命令可多次对数据库进行加锁，多次加锁后，解锁的次数也要相同才能成功解锁。

参见：例程1 数据库下载

相关参见：锁住数据库


锁住增删 命令 所属类别：数据库

锁住增删 命令 　英文命令：LockCount　所属类别：数据库

本命令执行后独占锁住对当前数据库的增删操作，其它用户可以读写已存在的任何记录，但是不能对数据库记录进行增删。也就是说：不能执行改变数据库记录数目的任何操作。注意：由于“删除”命令仅在记录上加上删除标志，并不实际删除记录，所以不在被加锁的范围内。成功返回真，失败返回假。

语法： 逻辑型 锁住增删 （）

例程：

说明：

程序运行后，打开数据库，然后使用列表框显示所有记录的姓名字段内容，“记录数标签”显示出当前的记录数。按下“锁住增删”按钮后，会对当前数据库加增删锁，并用信息框显示是否加锁成功。

可以使用“测试按钮”来测试增删锁的效果，“测试按钮”按下后，会写出并运行另一个易程序，该易程序可以对数据库进行增删操作，可以在锁住和解锁增删后，使用这个导出的易程序进行测试。

注意：在成功加了增删锁后，其他程序打开该数据库的时就会失败，除非成功解锁增删后，其他程序才能打开该数据库。

参见：例程1 数据库下载

相关参见：解增删锁


解增删锁 命令 所属类别：数据库

解增删锁 命令 　英文命令：UnlockCount　所属类别：数据库

本命令解除“锁住增删”命令对当前数据库加的锁。成功返回真，失败返回假。

语法： 逻辑型 解增删锁 （）

例程：

说明：

程序运行后，打开数据库，然后使用列表框显示所有记录的姓名字段内容，“记录数标签”显示出当前的记录数。按下“解增删锁”按钮后，会对当前数据库解除增删锁，并用信息框显示是否解锁成功。

可以使用“测试按钮”来测试增删锁的效果，“测试按钮”按下后，会写出并运行另一个易程序，该易程序可以对数据库进行增删操作，可以在锁住和解锁增删后，使用这个导出的易程序进行测试。

注意：在成功加了增删锁后，其他程序打开该数据库的时就会失败，除非成功解锁增删后，其他程序才能打开该数据库。

参见：例程1 数据库下载


锁住记录 命令 所属类别：数据库

锁住记录 命令 　英文命令：LockRec　所属类别：数据库

本命令执行后可以锁住指定的一个或多个记录。成功返回真，失败返回假。

语法： 逻辑型 锁住记录 （记录号，… ）

参数名 | 描 述
记录号 | 必需的；可扩充的；整数型。参数值指定的记录号从 1 开始。

例程：

说明：

程序运行后，打开数据库1，并使用“未锁记录列表框”显示所有记录的“姓名”字段内容，列表框每加入一个记录，便将该记录对应的记录号设置为对应项目的项目数值。当点击“锁住记录”按钮，首先通过项目数值，将当前记录指针跳到选中记录位置，然后使用“锁住记录 ()”命令对该记录进行加锁，并将该记录添加到“被锁记录列表框”中，同时从“未锁记录列表框”中将该项删除。

当点击“删除记录按钮”，会将2个列表框的当前选中的记录删除，并弹出信息框显示是否删除成功。

要注意的是，锁住记录后，使用“删除()”命令给记录加删除标记是可以成功的，要彻底删除被锁记录才会失败。

参见：例程1 数据库下载

相关参见：解锁记录


解锁记录 命令 所属类别：数据库

解锁记录 命令 　英文命令：UnlockRec　所属类别：数据库

本命令解除“锁住记录”命令对记录所加的锁。成功返回真，失败返回假。

语法： 逻辑型 解锁记录 （记录号，… ）

参数名 | 描 述
记录号 | 必需的；可扩充的；整数型。参数值指定的记录号从 1 开始。

例程：

说明：

程序运行后，打开数据库1，并使用“未锁记录列表框”显示所有记录的“姓名”字段内容，列表框每加入一个记录，便将该记录对应的记录号设置为对应项目的项目数值。当点击“解锁记录”按钮，首先通过项目数值，将当前记录指针跳到被选中记录位置，然后使用“解锁记录 ()”命令解除记录的加锁效果，并将该记录添加到“未锁记录列表框”中，同时从“被锁记录列表框”中将该项删除。

当点击“删除记录按钮”，会将2个列表框的当前选中的记录删除，并弹出信息框显示是否删除成功。

要注意的是，锁住记录后，使用“删除()”命令给记录加删除标记是可以成功的，要彻底删除被锁记录才会失败。

参见：例程1 数据库下载


全部解锁 命令 所属类别：数据库

全部解锁 命令 　英文命令：UnlockAll　所属类别：数据库

本命令解除由“锁住数据库”、“锁住增删”、“锁住记录”等命令对当前数据库加上的所有锁。成功返回真，失败返回假。

语法： 逻辑型 全部解锁 （）

例程：

说明：

程序运行后打开数据库1，“加锁按钮”被单击后，运行3种加锁命令对数据库进行加锁，3种加锁都成功后弹出信息框，“全部解锁按钮”被单击后，运行“全部解锁()”命令，全部解锁成功后，会解除这3种加锁命令所加的锁。加锁前后可以使用“测试按钮”调出另一个易程序进行测试。

参见：例程1 数据库下载

相关参见：锁住数据库　锁住增删　锁住记录


取平均值 命令 所属类别：数据库

取平均值 命令 　英文命令：avg　所属类别：数据库

本命令根据当前数据库计算并返回某数值型表达式的平均值，命令执行后当前记录指针保持不变。

语法： 双精度小数型 取平均值 （计算表达式，［记录条件］）

参数名 | 描 述
计算表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

取平均值命令，可以将当前数据库中指定字段的每条记录的平均值取出，并且可以将当前数据库某个字段中，符合一定条件的记录的平均值取出。

例程中，“_取平均值_被单击”子程序下运行的取平均值命令只将字段名为“年龄”的所有记录的平均值取出，而“_取平均值1_被单击”子程序中的取平均值命令是将所有年龄大于12的记录的年龄平均值取出。本命令的参数：计算表达式和记录条件就可以用上例中的方法表示。

参见：例程1 数据库下载


求和 命令 所属类别：数据库

求和 命令 　英文命令：sum　所属类别：数据库

本命令根据当前数据库计算并返回某数值型表达式的和，命令执行后当前记录指针保持不变。

语法： 双精度小数型 求和 （计算表达式，［记录条件］）

参数名 | 描 述
计算表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

首先打开一个数据库，本例中的求和命令是把符合年龄<30的所有记录的年龄之和求出，并用信息框显示出计算结果。

参见：例程1 数据库下载

相关参见：取平均值，取最大值，取最小值


取最大值 命令 所属类别：数据库

取最大值 命令 　英文命令：max　所属类别：数据库

本命令根据当前数据库计算并返回某数值型表达式的最大值，当前记录指针被移动到具有最大值的记录。

语法： 双精度小数型 取最大值 （计算表达式，［记录条件］）

参数名 | 描 述
计算表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

程序运行后打开数据库1，“取最大值”按钮被单击后，使用“取最大值()”命令将数据库中年龄字段的最大值取出，并显示在编辑框中。

参见：例程1 数据库下载

相关参见：取平均值　取最小值　求和


取最小值 命令 操作系统支持：Windows 所属类别：数据库

取最小值 命令 　英文命令：min　操作系统支持：Windows 所属类别：数据库

本命令根据当前数据库计算并返回某数值型表达式的最小值，当前记录指针被移动到具有最小值的记录。

语法： 双精度小数型 取最小值 （计算表达式，［记录条件］）

参数名 | 描 述
计算表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

程序中，使用“取最小值()”命令将年龄字段的最小值取出，并显示在信息框中。

参见：例程1 数据库下载

相关参见：取最大时间　取平均值　取最大值　求和


取最大时间 命令 所属类别：数据库

取最大时间 命令 　英文命令：MaxTime　所属类别：数据库

本命令根据当前数据库计算并返回某日期时间型表达式的最大值，当前记录指针被移动到具有最大值的记录。

语法： 日期时间型 取最大时间 （计算表达式，［记录条件］）

参数名 | 描 述
计算表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

本命令将指定日期时间型字段中，日期时间最大的记录取出，数据库指针自动移动到找到的记录上。

程序中，首先打开数据库，当“取最大时间”按钮被按下，使用“取最大时间()”命令将数据库中“出生日期”字段中最大的时间取出，并转换成文本显示在编辑框中。

参见：例程1 数据库下载

相关参见：取最小时间，取平均值，取最大值，取最小值，求和


取最小时间 命令 所属类别：数据库

取最小时间 命令 　英文命令：MinTime　所属类别：数据库

本命令根据当前数据库计算并返回某日期时间型表达式的最小值，当前记录指针被移动到具有最小值的记录。

语法： 日期时间型 取最小时间 （计算表达式，［记录条件］）

参数名 | 描 述
计算表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

本命令是将指定日期时间型字段中的所有记录或符合记录条件的记录的最小值取出。

程序中，首先打开数据库，当“取最小时间”按钮被按下，使用“取最小时间()”命令将数据库中“出生日期”字段中最小的时间取出，并转换成文本显示在编辑框中。

参见：例程1 数据库下载

相关参见：取最大时间 取平均值 取最大值 取最小值 求和


计算数目 命令 所属类别：数据库

计算数目 命令 　英文命令：count　所属类别：数据库

本命令返回当前数据库中指定范围记录的数目。命令执行后当前记录指针保持不变。

语法： 整数型 计算数目 （［记录条件］）

参数名 | 描 述
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。

例程：

说明：

是将符合记录条件的记录的数目取出并返回。

本例是将所有年龄字段中，年龄大于20的记录的数目取出来，并用信息框查看找到了几个记录。

参见：例程1 数据库下载


复制结构 命令 所属类别：数据库

复制结构 命令 　英文命令：CopyStructTo　所属类别：数据库

复制当前数据库的结构到另外一个数据库。命令执行后当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 复制结构 （数据库文件名，［字段范围］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。本参数指定欲复制到的数据库文件，该数据库必须不存在或者尚未被打开。如果已经存在，将会被覆盖。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲复制字段的名称。如果被省略，默认为所有字段。

例程：

说明：

程序运行后，打开数据库1，并用编辑框显示出当前数据库名，当点击“复制结构”按钮，将数据库1的“年龄”和“姓名”字段复制到“复制数据库1”中，然后打开该数据库，并弹出数据库记录编辑器对该数据库进行编辑，编辑后关闭该数据库。

注意，“复制结构()”命令只对数据库的字段结构进行复制，并不会复制数据库记录。

参见：例程1 数据库下载

相关参见：复制记录


复制记录 命令 所属类别：数据库

复制记录 命令 　英文命令：CopyTo　所属类别：数据库

复制当前数据库的记录到另外一个数据库。命令执行后当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 复制记录 （数据库文件名，［记录条件］，［字段范围］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。本参数指定欲复制到的数据库文件，该数据库必须不存在或者尚未被打开。如果已经存在，将会被覆盖。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲复制字段的名称。如果被省略，默认为所有字段。

例程：

说明：

程序运行后，打开数据库1，并用“原记录列表框”显示数据库1中的“姓名”字段内容。当“复制记录”按钮被单击，则使用“复制记录()”命令将数据库1中，年龄大于20记录的“年龄”、“性别”和“姓名”字段内容复制到数据库2中，复制成功后，打开该数据库，并使用“复制后列表框”显示出复制后数据库的“姓名”字段内容。

参见：例程1 数据库下载

相关参见：复制结构


计算排序 命令 所属类别：数据库

计算排序 命令 　英文命令：csort　所属类别：数据库

根据指定数值表达式的计算值排序复制当前数据库的记录到另外一个数据库。命令执行后当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 计算排序 （数据库文件名，排序表达式，［排序方向］，［记录条件］，［字段范围］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。本参数指定欲复制到的数据库文件，该数据库必须不存在或者尚未被打开。如果已经存在，将会被覆盖。
排序表达式 | 必需的；条件语句型。本参数所指定的表达式内必须使用了当前数据库的字段，表达式所返回数据的类型必须为数值型。
排序方向 | 可选的；逻辑型。本参数的值如果为真或者被省略，将按照从小到大的顺序排序，否则为从大到小。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲复制字段的名称。如果被省略，默认为所有字段。

例程：

说明：

程序运行后，打开数据库1，并将数据库1的“年龄”字段内容显示在“排序前列表框”中。当“计算排序”按钮被单击，则使用“计算排序()”命令，对数据库1中的记录按“年龄”字段的从大到小顺序重新排列数据库记录，并将排序后的结果存放在“临时数据库”中，成功排序后打开排序后的数据库，并将该数据库中“年龄”字段的内容显示在“排序后列表框”中。

显示排序后数据库完毕，使用了“关闭()” 命令将其关闭。关闭当前库后，当前数据库为空，所以在排序前还使用了“置当前库()”命令设置当前要排序的数据库，这样多次排序也不会出现错误了。

参见：例程1 数据库下载

相关参照：取平均值 复制记录


排序 命令 所属类别：数据库

排序 命令 　英文命令：sort　所属类别：数据库

根据指定字段排序复制当前数据库的记录到另外一个数据库。命令执行后当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 排序 （数据库文件名，排序字段，［排序方向］，［记录条件］，［字段范围］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。本参数指定欲复制到的数据库文件，该数据库必须不存在或者尚未被打开。如果已经存在，将会被覆盖。
排序字段 | 必需的；文本型，参数数据可以同时提供数组或非数组数据。本参数的数据可以为字段名文本或者字段名文本数组（用作同时指定多个字段）。
排序方向 | 可选的；逻辑型，参数数据可以同时提供数组或非数组数据。本参数的数据可以为一个逻辑值或者逻辑值数组（用作同时为多个字段指定排序方向）。如果逻辑值为真，对应字段将按照从小到大的顺序排序，否则为从大到小。如果本参数被省略，默认为全部按照从小到大的顺序排序。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲复制字段的名称。如果被省略，默认为所有字段。

例程：

说明：

程序运行后，打开数据库1，并将数据库1的“年龄”字段内容显示在“排序前列表框”中。当“排序”按钮被单击，则使用“排序()”命令，对数据库1中的记录按“年龄”字段的从小到大顺序重新排列数据库记录，并将排序后的结果存放在“排序数据库”中，成功排序后打开排序后的数据库，并将该数据库中“年龄”字段的内容显示在“排序后列表框”中。

显示排序后数据库完毕，使用了“关闭()” 命令将其关闭。关闭当前库后，当前数据库为空，所以在排序前还使用了“置当前库()”命令设置当前要排序的数据库，这样多次排序也不会出现错误了。

参见：例程1 数据库下载


分类计算 命令 所属类别：数据库

分类计算 命令 　英文命令：total　所属类别：数据库

对当前数据库进行分类计算，将结果输出到另外一个数据库。注意所有的备注或字节集字段内容将不会被输出到目的数据库中。 命令执行后当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 分类计算 （数据库文件名，分类字段，［计算方法］，［记录条件］，［字段范围］，… ）

参数名 | 描 述
数据库文件名 | 必需的；文本型。本参数指定欲复制到的数据库文件，该数据库必须不存在或者尚未被打开。如果已经存在，将会被覆盖。
分类字段 | 必需的；文本型，参数数据可以同时提供数组或非数组数据。本参数的数据可以为字段名文本或者字段名文本数组（用作同时指定多个字段）。
计算方法 | 可选的；整数型。参数值可以为以下常量之一： 1、#取平均值； 2、#求和； 3、#取最大值； 4、#取最小值。 如果本参数被省略，默认为“#求和”。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为当前数据库中的所有记录，否则将仅限于满足此条件的记录。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲复制字段的名称。如果被省略，默认为所有字段。

例程：

说明：

程序中，使用“分类计算()”命令对数据库1进行分类计算，分类字段为“年龄”，计算方法为“取平均值”，分类计算成功后，打开分类计算后的数据库，并将该数据库中年龄字段内容显示在列表框中。

参见：例程1 数据库下载


添加 命令 所属类别：数据库

添加 命令 　英文命令：AppendFrom　所属类别：数据库

将指定数据库中的记录添加到当前数据库。命令执行后当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 添加 （数据库别名或名称，［记录条件］，［字段范围］，… ）

参数名 | 描 述
数据库别名或名称 | 必需的；文本型。本参数指定一个已打开数据库，命令将从该数据库中获取欲添加的记录数据。
记录条件 | 可选的；条件语句型。如果本参数被省略，默认为添加指定数据库中的所有记录，否则仅添加指定数据库中满足此条件的记录。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲添加字段的名称。如果被省略，默认添加所有同名字段。

例程：

说明：

程序运行后打开2个数据库，并将数据库2的姓名字段内容添加到“添加前列表框中”，当“添加”按钮被单击，则运行“添加”命令，将数据库1中年龄大于30的记录都添加数据库2中，并用“添加后列表框”显示出添加后数据库2中的姓名字段内容。

参见：例程1 数据库下载1 数据库下载2


加记录 命令 所属类别：数据库

加记录 命令 　英文命令：Append　所属类别：数据库

本命令在当前数据库的尾部添加一条记录，并将当前记录指针移动到该记录处。成功返回真，失败返回假。

语法： 逻辑型 加记录 （［记录数据］，… ）

参数名 | 描 述
记录数据 | 可选的；可扩充的；通用型。本参数的每一个参数值用作为记录中对应位置处的一个字段提供数据。如果某参数值被省略，则对应位置处字段的内容被设置为初始值。

例程：

说明：

例程中，当“加记录”按钮被单击，首先判断“性别编辑框”中的内容，如果是“男”则让“添加性别”变量为真，如果是“女”则让“添加性别”变量为假，然后使用“加记录()”命令向数据库1中添加记录，性别字段内容为“添加性别”变量的内容，其他记录的内容为对应编辑框中的内容，添加记录时要注意数据类型的转换，添加内容的数据类型要和对应字段的数据类型相同。

参见：例程1 数据库下载

相关参见：加空记录　修改


加空记录 命令 所属类别：数据库

加空记录 命令 　英文命令：AppendBlank　所属类别：数据库

本命令在当前数据库的尾部添加一条空记录，并将当前记录指针移动到该记录上。成功返回真，失败返回假。

语法： 逻辑型 加空记录 （）

例程：

说明：

程序运行后，打开数据库1，点击“加空记录”按钮后，就使用“加空记录()”命令，在数据库的尾部添加一条空记录，并用“记录数标签”显示出当前的记录数，然后使“修改记录”按钮的禁止为假，这样在添加一条空记录后就可以对其内容进行修改了。在“_修改记录按钮_被单击”子程序中，使用了“修改()”命令对添加的空记录的内容进行修改。

参见：例程1 数据库下载

相关参见：加记录　修改


替换 命令 所属类别：数据库

替换 命令 　英文命令：replace　所属类别：数据库

本命令替换当前数据库中的记录数据，当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 替换 （［替换范围］，字段名称或替换数据，… ）

参数名 | 描 述
替换范围 | 可选的；条件语句型。如果本参数被省略，默认为替换当前记录数据，否则替换所有满足此条件记录的数据。如果欲在所有记录内进行替换，请直接将逻辑值“真”赋予本参数。
字段名称或替换数据 | 必需的；可扩充的；通用型。本参数的每一对参数值顺序指定欲被替换字段的名称及其相应的替换值。替换值的数据类型必须与所对应字段的数据类型一致或可互相转换，否则命令会失败。

例程：

说明：

本命令可以将符合某个条件的记录的指定字段的值替换成指定内容。

本段代码是将数据库1中，姓名是“马”的记录的“年龄”字段改成50，并使用信息框显示是否替换成功，替换成功后弹出记录编辑器，可以查看替换后的结果。

参见：例程1 数据库下载


修改 命令 所属类别：数据库

修改 命令 　英文命令：modify　所属类别：数据库

本命令一次性修改当前数据库中当前记录内多个字段的内容，当前记录指针保持不变。成功返回真，失败返回假。

语法： 逻辑型 修改 （［修改数据］，… ）

参数名 | 描 述
修改数据 | 可选的；可扩充的；通用型。本参数的每一个参数值用作替换当前记录中对应位置处的一个字段。如果某参数值被省略，则对应位置处字段的内容将保持不变。

例程：

说明：

例程中，当添加了一条空记录后，“修改记录”按钮的禁止则为假。当“修改记录”按钮被单击，首先判断“性别编辑框”中的内容，如果是“男”则让“添加性别”变量为真，如果是“女”则让“添加性别”变量为假，然后使用“修改()”命令对当前添加的空记录内容进行修改，性别字段内容为“添加性别”变量的内容，其他记录的内容为对应编辑框中的内容，修改记录时要注意数据类型的转换，修改内容的数据类型要和对应字段的数据类型相同。

注意：修改命令可以对当前数据库的任意记录的内容进行修改，可以使用“跳过()”或“跳到()”命令将当前记录指针移动到指定记录后，对其进行修改。

参见：例程1 数据库下载


删除 命令 所属类别：数据库

删除 命令 　英文命令：delete　所属类别：数据库

标记删除当前数据库中的当前记录或者指定范围内的记录，当前记录指针位置保持不变。注意：此命令并不实际删除记录，仅仅只加上删除标记，记录依旧存在并可以读写。成功返回真，失败返回假。

语法： 逻辑型 删除 （［记录范围］）

参数名 | 描 述
记录范围 | 可选的；条件语句型。如果本参数被省略，默认为删除或恢复删除当前记录，否则删除或恢复删除所有满足此条件的记录。如果欲删除或恢复删除全部记录，请直接将逻辑值“真”赋予本参数。

例程：

说明：

程序运行后打开数据库1，程序中新建了一个“显示记录”子程序，用来显示当前记录内容，并用“是否被删除标签”显示当前记录是否被删除，当“删除按钮”被单击，使用“删除()”命令给当前记录加上删除标记，并调用“显示记录”子程序，显示当前被加删除标记的记录。

参见：例程1 数据库下载

相关参见：彻底删除　是否已删除　恢复删除


是否已删除 命令 所属类别：数据库

是否已删除 命令 　英文命令：IsDeleted　所属类别：数据库

如果当前数据库的当前记录已经被“删除”命令加上删除标记，返回真，否则返回假。

语法： 逻辑型 是否已删除 （）

例程：

说明：

在“显示记录”子程序中，使用“是否已删除()”命令，判断当前记录是否已被加了删除标记，并使用“是否被删除标签”显示出当前记录是否被加上了删除标记。

参见：例程1 数据库下载

相关参见：删除　彻底删除　恢复删除


恢复删除 命令 所属类别：数据库

恢复删除 命令 　英文命令：recall　所属类别：数据库

去掉当前数据库中当前记录或者指定范围内记录的删除标记，当前记录指针位置保持不变。成功返回真，失败返回假。

语法： 逻辑型 恢复删除 （［记录范围］）

参数名 | 描 述
记录范围 | 可选的；条件语句型。如果本参数被省略，默认为删除或恢复删除当前记录，否则删除或恢复删除所有满足此条件的记录。如果欲删除或恢复删除全部记录，请直接将逻辑值“真”赋予本参数。

例程：

说明：

程序运行后打开数据库1，程序中新建了一个“显示记录”子程序，用来显示当前记录内容，并用“是否被删除标签”显示当前记录是否被删除，当“恢复删除按钮”被单击，使用“恢复删除()”命令取消当前记录的删除标记，并调用“显示记录”子程序，显示当前被取消删除标记的记录。

参见：例程1 数据库下载

相关参见：删除　是否已删除　彻底删除


彻底删除 命令 所属类别：数据库

彻底删除 命令 　英文命令：pack　所属类别：数据库

将当前数据库中所有被加上删除标记的记录从数据库中彻底清除，当前记录指针位置将被移动到数据库首记录。记录被彻底删除后将不复存在，并且无法恢复。注意执行本命令将重组数据库记录，因此速度比较慢。成功返回真，失败返回假。

语法： 逻辑型 彻底删除 （）

例程：

说明：

程序运行后打开数据库1，程序中新建了一个“显示记录”子程序，用来显示当前记录内容，并用“是否被删除标签”显示当前记录是否被删除。当“彻底删除按钮”被单击，如果当前记录有删除标记，则“彻底删除()”命令将当前记录彻底删除；如果当前记录没有删除标记，则“彻底删除()”命令没有效果。命令运行后调用“显示记录”子程序，显示当前记录指针处的记录。

参见：例程1 数据库下载

相关参见：删除　是否已删除　恢复删除


清空 命令 所属类别：数据库

清空 命令 　英文命令：zap　所属类别：数据库

彻底清除当前数据库中的所有记录。成功返回真，失败返回假。

语法： 逻辑型 清空 （）

例程：

说明：

程序运行后，打开数据库1，并使用“记录数标签”显示出当前数据库中的记录数，当“清空”按钮被单击，弹出有是否钮的信息框，询问是否删除，如果点击“是钮”，则使用“清空()”命令将数据库中的所有记录全部删除，并用信息框显示是否删除成功。

参见：例程1 数据库下载


读 命令 所属类别：数据库

读 命令 　英文命令：r　所属类别：数据库

返回当前数据库中当前记录处指定字段的数据内容，所返回数据的类型等同于字段的类型。如果指定字段不存在，将产生运行时错误。执行本命令后使用“取错误码”命令可以判断是否读入成功。

语法： 通用型 读 （字段名称或位置）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。

例程：

说明：

程序中新建了“读记录”子程序，在子程序中使用了“读()”命令，将所有子段的内容读出并显示在对应的编辑框中。程序运行后打开数据库1，并调用“读记录”子程序显示当前记录，在“上一记录”和“下一记录”被单击并使用“跳过()”命令后，调用“读记录”子程序来显示上一记录或下一记录的内容。

参见：例程1 数据库下载

相关参见：读字段


写 命令 所属类别：数据库

写 命令 　英文命令：w　所属类别：数据库

将数据写入到当前数据库中当前记录处的指定字段内。成功返回真，失败返回假。

语法： 逻辑型 写 （字段名称或位置，［欲写入数据］）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。
欲写入数据 | 可选的；通用型。本参数数据的类型必须与所对应字段的数据类型一致或可互相转换。如果本参数被省略，则初始化对应字段中的内容，具体为：数值字段被初始化为零，逻辑字段被初始化为假，日期字段被初始化为 1899 年 12 月 30 日，文本及备注字段被初始化为空文本（“”），字节集字段被初始化为空字节集。

例程：

说明：

在“改写记录”按钮被单击后，判断性别编辑框中的内容，如果为“男”则“改写性别”变量为真，如果为“女”则“改写性别”变量为假。然后使用“写()”命令，将对应编辑框中的内容写到对应的字段中，如果都改写成功则弹出信息显示“改写记录成功”，如果其中有哪个字段内容改写失败，则弹出信息框提示。

参见：例程1 数据库下载


读字段 命令 所属类别：数据库

读字段 命令 　英文命令：ReadField　所属类别：数据库

返回指定数据库中当前记录处指定字段的数据内容，所返回数据的类型等同于字段的类型。如果指定字段不存在，将产生运行时错误。本命令与“读”命令的不同之处为本命令可以从非当前数据库中读取字段。执行本命令后使用“取错误码”命令可以判断是否读入成功。

语法： 通用型 读字段 （字段名称或位置，［数据库别名或名称］）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。
数据库别名或名称 | 可选的；文本型。参数值指定一个已经被打开的数据库，该数据库内包含所欲读取的字段。如果被省略，默认为当前数据库。

例程：

说明：

程序运行后打开2个数据库，并用“当前库标签”显示当前数据库，当“选择组合框”的项目被选中，则用“读字段()”命令，读出被选择的数据库当前记录的“姓名”字段内容。“读字段()”命令和“读()”命令的不同在于“读字段()”命令可以读出非当前数据库的记录。

参见：例程1 数据库下载1 数据库下载2

相关参见：读


写字段 命令 所属类别：数据库

写字段 命令 　英文命令：WriteField　所属类别：数据库

将数据写入到指定数据库中当前记录处的指定字段内。成功返回真，失败返回假。本命令与“写”命令的不同之处为本命令可以写入非当前数据库中的字段。

语法： 逻辑型 写字段 （字段名称或位置，［数据库别名或名称］，［欲写入数据］）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。
数据库别名或名称 | 可选的；文本型。参数值指定一个已经被打开的数据库，该数据库内包含所欲写入的字段。如果被省略，默认为当前数据库。
欲写入数据 | 可选的；通用型。本参数数据的类型必须与所对应字段的数据类型一致或可互相转换。如果本参数被省略，则初始化对应字段中的内容，具体为：数值字段被初始化为零，逻辑字段被初始化为假，日期字段被初始化为 1899 年 12 月 30 日，文本及备注字段被初始化为空文本（“”），字节集字段被初始化为空字节集。

例程：

说明：

程序运行后打开2个数据库，并用“当前库标签”显示出当前的数据库，当“改写按钮”被单击，则使用“写字段()”命令将组合框中选择的数据库的姓名字段内容改写成“改写编辑框”中的内容，改写成功则弹出信息框提示。“写字段()”命令可以改写非当前数据库的指定字段内容。

参见：例程1 数据库下载1 数据库下载2

相关参见：写


附加字节集 命令 所属类别：数据库

附加字节集 命令 　英文命令：AppendBin　所属类别：数据库

将字节集数据添加到当前记录处指定字节集型字段的尾部。成功返回真，失败返回假。

语法： 逻辑型 附加字节集 （字段名称或位置，欲添加的字节集数据，… ）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。
欲添加的字节集数据 | 必需的；可扩充的；字节集。

例程：

说明：

本命令可是对指定记录处的字节集型的数据进行操作，将一个字节集型的数据添加到其尾部。

例中，先创建数据库，有一个字段名为“第一个字段”的字节集型的字段，并在这个字段上加入了{1，1，1，1，1，1}的字节集型的记录，然后用附加字节集命令，向这个字段的尾部加入一个{2，2，2，2，2，2}的字节集型的数据，最后，“第一个字段”中的这个记录就会变成是{1，1，1，1，1，1，2，2，2，2，2，2}。

参见：例程1


附加备注 命令 所属类别：数据库

附加备注 命令 　英文命令：AppendMemo　所属类别：数据库

将文本数据添加到当前记录处指定备注型字段的尾部。成功返回真，失败返回假。

语法： 逻辑型 附加备注 （字段名称或位置，欲添加的文本数据，… ）

参数名 | 描 述
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。
欲添加的文本数据 | 必需的；可扩充的；文本型。

例程：

说明：

启动窗口创建后，创建一个临时数据库，数据库有一个备注型字段，并添加一条记录，让“显示编辑框”显示出当前记录的内容。当“附加备注”按钮被单击，使用“附加备注()”命令，在当前记录的尾部附加一段文本，并用“显示编辑框”显示出附加后的记录内容。

参见：例程1


索引查找 命令 所属类别：数据库

索引查找 命令 　英文命令：seek　所属类别：数据库

本命令在当前数据库中使用其当前索引来快速寻找某一记录，寻找从当前记录位置（包括当前记录）处开始。注意为命令所提供的欲搜寻值参数的数目必须与被索引字段的数目一致。如成功找到返回真，并且将当前记录指针移至所找到的记录。如出错或未找到则返回假，当前记录指针位置保持不变。

语法： 逻辑型 索引查找 （欲搜寻值，… ）

参数名 | 描 述
欲搜寻值 | 必需的；可扩充的；通用型。本参数数据的类型必须与索引字段表中对应位置处字段的类型一致。

例程：

说明：

启动窗口创建完毕后，打开数据库1，同时打开数据库1年龄字段的索引—“索引1．enx” 。当“查找按钮”被单击，则使用“判断循环首()”命令，在判断循环首中使用“索引查找()”命令，查找年龄等于“查找编辑框”中内容的记录。如果找到记录，即“索引查找()”命令返回真，则开始循环，当“索引查找()”命令返回假则循环结束，在循环中将找到的记录“姓名”字段显示列表框中，并跳到下一条记录继续查找，这样就可以找到所有符合条件的记录。

索引查找在记录非常多的情况下比“查找()”命令查找的速度更快。

参见：例程1 数据库下载 索引1下载


查找 命令 所属类别：数据库

查找 命令 　英文命令：locate　所属类别：数据库

本命令从当前数据库中当前记录位置处（包括当前记录）开始寻找符合给定条件的记录。如成功找到返回真，并且将当前记录指针移至所找到的记录。如出错或未找到则返回假，当前记录指针位置保持不变。

语法： 逻辑型 查找 （查找条件）

参数名 | 描 述
查找条件 | 必需的；条件语句型。参数值指定欲查找记录应该满足的条件。

例程：

说明：

程序中，当“查找按钮”被单击，则使用“判断循环首()”命令，在循环首中使用“查找()”命令，查找年龄字段大于“条件编辑框”内容的记录，如果找到记录即“查找()”命令返回真，则在循环中将该记录显示在列表框中，并跳到下一条记录，继续寻找符合条件的记录，当查找不到符合条件的记录，则循环停止。

在查找前还使用了“到循环首()”命令将当前记录指针跳到循环首，这样每次都可以找到数据库中符合条件的所有记录。

注意：“查找()”命令也可以查找符合多条件的记录，例如：查找 (读 (“年龄”) ＝ 12 或者 读（“姓名”=“张”）)例如：查找 (读 (“年龄”) ＝ 12 并且 读（“姓名“）=“张”)，参见：或者 并且。

参见：例程1 数据库下载


到首记录 命令 所属类别：数据库

到首记录 命令 　英文命令：GoTop　所属类别：数据库

将当前数据库中当前记录指针移动到数据库的第一条记录上。

语法： 无返回值 到首记录 （）

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，显示当前记录。当“首记录”按钮被单击，使用“到首记录()”命令，将当前记录指针跳到首记录处，然后调用“显示记录”子程序，显示首记录内容。

参见：例程1 数据库下载

相关参见：到尾记录


到尾记录 命令 所属类别：数据库

到尾记录 命令 　英文命令：GoBottom　所属类别：数据库

将当前数据库中当前记录指针移动到数据库的最后一条记录上。成功返回真，失败返回假。

语法： 逻辑型 到尾记录 （）

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，显示当前记录。当“尾记录”按钮被单击，使用“到尾记录()”命令，将当前记录指针跳到尾记录处，然后调用“显示记录”子程序，显示尾记录内容。

参见：例程1 数据库下载

相关参见：到首记录


跳过 命令 所属类别：数据库

跳过 命令 　英文命令：skip　所属类别：数据库

将当前数据库中当前记录指针向前或者向后移动数条记录。成功返回真，失败返回假。

语法： 逻辑型 跳过 （［欲跳过的记录数］）

参数名 | 描 述
欲跳过的记录数 | 可选的；整数型。参数值如果为负数，则向前移动，否则向后移动。如果本参数被省略，默认值为 1 ，即向后移动一条记录。

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，用来显示当前记录。当“上一记录”按钮被单击，则使用“跳过()”命令，在参数中填写-1，当前记录指针会跳到上一跳记录，在跳到上一记录后还使用“首记录前()”命令进行判断，如果当前记录指针是在首记录的前面，则运行“到首记录()”命令，将当前记录指针跳回首记录，这样避免了编辑框中显示首记录前的内容。

“_下一记录按钮_被单击”子程序代码相似，是使用“跳过()”命令将当前记录指针向后跳过一条记录，然后判断当前记录指针是否在尾记录的后面。

注意：“跳过()”命令还可以跳过多个记录，在参数中填入要跳过的记录数即可。

参见：例程1 数据库下载

相关参见：跳到


取记录号 命令 所属类别：数据库

取记录号 命令 　英文命令：RecNO　所属类别：数据库

返回当前数据库中当前记录指针所指向记录的记录号。如果当前记录指针在首记录前，返回 0 ；如果在尾记录后，返回值为记录总数加一。

语法： 整数型 取记录号 （）

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，显示当前记录。在“显示记录”子程序中，使用了“取记录号()”命令，让“记录号标签”显示出当前记录指针所在的记录号。

参见：例程1 数据库下载


跳到 命令 所属类别：数据库

跳到 命令 　英文命令：goto　所属类别：数据库

改变当前数据库中的当前记录指针到指定的记录号。成功返回真，失败返回假。

语法： 逻辑型 跳到 （欲跳到的记录号）

参数名 | 描 述
欲跳到的记录号 | 必需的；整数型。参数值所指定的记录号从 1 开始，即首记录的记录号为 1 ，依此类推。

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，用来显示当前记录。当“跳到”按钮被单击，则弹出输入框，输入框中输入欲跳到的记录号后，则使用“跳到()”命令，将当前记录指针跳到所输入的记录号处。

参见：例程1 数据库下载

相关参见：跳过


取标签 命令 所属类别：数据库

取标签 命令 　英文命令：GetBookmark　所属类别：数据库

在数据库的存在期间，同一数据库内任何时候任何一条记录（包括已经被实际删除的记录）都有一个唯一的非 0 正整数标签值，使用本命令可以取回当前数据库当前记录的这一标签值。此标签值可以用来在记录间跳转或者在多用户环境中查看记录是否已经被其它用户实际删除。如果命令执行失败，将返回 0 。

语法： 整数型 取标签 （）

例程：

说明：

程序运行后打开数据库1，并使用“取标签()”命令将标签值取出，并显示在“显示标签”中；然后使用“取记录号()”命令将当前记录的记录号取出，并显示在“记录号标签”中。当“上一记录按钮”和“下一记录按钮”被单击，则将当前记录指针向前或向后跳过一条记录，并显示出当前记录的标签值和记录号。

注意：有时候同一记录的标签值和记录号相同，但很多情况下他们的值是不同的，所以不能混淆。

参见：例程1 数据库下载


记录是否存在 命令 所属类别：数据库

记录是否存在 命令 　英文命令：IsRecExist　所属类别：数据库

如果当前数据库中存在具有指定标签值的记录，命令返回真，否则返回假。本命令可以用作在多用户环境中检查某记录是否被其它用户实际删除。

语法： 逻辑型 记录是否存在 （记录的标签值）

参数名 | 描 述
记录的标签值 | 必需的；整数型。

例程：

说明：

启动窗口创建完毕后，打开数据库1并用“显示标签值标签”显示出当前记录的标签值，当“记录是否存在按钮”被单击，则弹出输入框，用来输入标签值，并将输入的标签值存放在“标签值”变量中，然后使用“记录是否存在()”命令判断指定标签值的记录是否存在，如果存在则使用“跳转标签()”命令将当前记录跳到该标签值的记录上，并用编辑框显示出该记录的“姓名”字段内容。

参见：例程1 数据库下载

相关参见：取标签


标签跳转 命令 所属类别：数据库

标签跳转 命令 　英文命令：GotoBookmark　所属类别：数据库

使用本命令可以改变当前数据库中的当前记录指针到具有指定标签的记录。如成功找到返回真，并且将当前记录指针移至该记录。如出错或未找到则返回假，当前记录指针位置保持不变。

语法： 逻辑型 标签跳转 （记录的标签值）

参数名 | 描 述
记录的标签值 | 必需的；整数型。

例程：

说明：

启动窗口创建完毕后，打开数据库1并用“显示标签值标签”显示出当前记录的标签值，当“记录是否存在按钮”被单击，则弹出输入框，用来输入标签值，并将输入的标签值存放在“标签值”变量中，然后使用“记录是否存在()”命令判断指定标签值的记录是否存在，如果存在则使用“跳转标签()”命令将当前记录跳到该标签值的记录上，并用编辑框显示出该记录的“姓名”字段内容。

参见：例程1 数据库下载

相关参见：跳到


首记录前 命令 所属类别：数据库

首记录前 命令 　英文命令：bof　所属类别：数据库

如果当前数据库的当前记录指针已在首记录的前面，返回真，否则返回假。

语法： 逻辑型 首记录前 （）

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，用来显示当前记录。当“上一记录”按钮被单击，则使用“跳过()”命令跳到上一条记录，然后使用“首记录前()”命令进行判断，如果当前记录指针是在首记录的前面，则运行“到首记录()”命令，将当前记录指针跳回首记录，这样避免了编辑框中显示首记录前的内容。

参见：例程1 数据库下载


尾记录后 命令 所属类别：数据库

尾记录后 命令 　英文命令：eof　所属类别：数据库

如果当前数据库的当前记录指针已在尾记录的后面，返回真，否则返回假。

语法： 逻辑型 尾记录后 （）

例程：

说明：

程序中新建了一个“显示记录”子程序，用来将当前记录的所有字段显示在对应的编辑框中。程序运行后打开数据库1并调用“显示记录”子程序，用来显示当前记录。当“下一记录”按钮被单击，则使用“跳过()”命令跳到下一条记录，然后使用“尾记录后()”命令进行判断，如果当前记录指针是在尾记录的后面，则运行“到尾记录()”命令，将当前记录指针跳回尾记录，这样避免了编辑框中显示尾记录后的内容。

参见：例程1 数据库下载

相关参见：到尾记录 跳过


写出缓存 命令 所属类别：数据库

写出缓存 命令 　英文命令：flush　所属类别：数据库

为了加快对数据库数据的存取速度，对数据库所进行的写操作将首先被保存在写缓存区内，等候一段时间后才会被自动写入到数据库文件中。使用本命令可以将当前数据库停留在写缓存区内的数据立即写入数据库磁盘文件中，以确保对当前数据库进行的所有写操作都真实地反映到了数据库文件中。一般情况下无需使用本命令。

语法： 无返回值 写出缓存 （）

例程：

说明：

打开数据库1后，运行“写出缓存()”命令，运行后对数据库进行写的操作会有所加快，所以要进行大量的写的操作前，可以先运行“写出缓存()”命令。

参见：例程1 数据库下载


写出所有缓存 命令 所属类别：数据库

写出所有缓存 命令 　英文命令：FlushAll　所属类别：数据库

将所有数据库停留在写缓存区内的数据都立即写入到对应的数据库磁盘文件中。一般情况下无需使用本命令。

语法： 无返回值 写出所有缓存 （）

例程：

说明：

本命令不是一个常用命令，这是它的命令格式。

参见：例程1 数据库下载


编辑 命令 所属类别：数据库

编辑 命令 　英文命令：edit　所属类别：数据库

提供一个对话框，用作查看或编辑修改当前数据库的记录，起始位置从当前记录开始。本命令退出后当前记录指针被移动到首记录。

语法： 无返回值 编辑 （［标题］，［编辑方式］，［字段范围］，… ）

参数名 | 描 述
标题 | 可选的；文本型。本参数指定对话框的标题，如果被省略，默认为“数据库记录编辑”。
编辑方式 | 可选的；整数型。可以为 0 或者以下常量值的组合： 1、#禁止修改； 2、#禁止添加； 4、#禁止删除； 8、#禁止自动判断（注：在默认情况下，系统将自动判断当前字节集字段的内容是否为图片或者声音，然后以对应的方式显示。使用本常量值可以禁止此功能）。 如果被省略，默认值为 0 。
字段范围 | 可选的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。本参数的各参数值顺序指定所有欲编辑字段的名称。如果被省略，默认为所有字段。

例程：

说明：

命令运行后，就如同调用了易语言用的数据库记录编辑器。可以将想要编辑的字段等信息添入参数。

程序运行后，打开数据库1，当“编辑”按钮被单击，则会使用“编辑()”命令弹出数据库记录编辑器，来对数据库1的记录进行查看和编辑。

参见：例程1 数据库下载


是否已加密 命令 所属类别：数据库

是否已加密 命令 　英文命令：IsEncrypted　所属类别：数据库

如果需要提供密码才能访问指定的数据库文件（即已经被加密），返回真，否则返回假。

语法： 逻辑型 是否已加密 （数据库文件名）

参数名 | 描 述
数据库文件名 | 必需的；文本型。

例程：

说明：

当点击“置数据库密码按钮”，首先使用“是否已加密()”命令判断数据库是否已经加密，如果是加密数据库首先弹出输入框提示输入密码，然后打开数据库，如果打开数据库成功，则判断如果“重试时间编辑框”中的内容不为空，则设置加锁重试时间，然后对数据库进行加密。

参见：例程1 数据库下载


置数据库密码 命令 所属类别：数据库

置数据库密码 命令 　英文命令：SetPassword　所属类别：数据库

本命令用作设置或修改当前数据库的访问密码，注意数据库文件必须可写。成功返回真，失败返回假。

语法： 逻辑型 置数据库密码 （［新密码文本］）

参数名 | 描 述
新密码文本 | 可选的；文本型。建议密码长度最少为6个字符以上，并且最好混合使用汉字、字母、数字、符号，以保证密码本身的安全性。注意不能为“?”（即单个问号），此密码文本被保留用作其他用途。如果为空文本，表示无密码。如果本参数被省略，则默认为空文本。

例程：

说明：

当点击“置数据库密码按钮”，首先判断数据库是否已经加密，如果是加密数据库首先弹出输入框提示输入密码，然后打开数据库，如果打开数据库成功，则判断如果“重试时间编辑框”中的内容不为空，则设置加锁重试时间，然后使用“置数据库密码()”命令对数据库进行加密。注意，当加密成功后，关闭加密后的数据库，如果再次打开该数据库，则要正确输入数据库密码才能打开数据库。

参见：例程1 数据库下载


密码输入框 命令 所属类别：数据库

密码输入框 命令 　英文命令：InputDBPwd　所属类别：数据库

本命令用作输入数据库的访问密码，如果用户在确认输入后（按下“确认”按钮或回车键）退出，返回真，否则返回假。

语法： 逻辑型 密码输入框 （存放所输入密码的变量，［已重试次数］）

参数名 | 描 述
存放所输入密码的变量 | 必需的；文本型，参数数据只能提供变量。
已重试次数 | 可选的；整数型。本参数提供已经重试输入密码的次数，用作在对话框中显示剩余次数（允许总次数恒定为3次）。如果本参数被省略，则默认值为0。

例程：

说明：

“打开数据库”按钮被单击后，首先判断数据库是否加密，如果是加密数据库，则弹出密码输入框，将输入的密码存放在“存放密码的变量”中，然后使用“打开()”命令打开该加密数据库，使用“存放密码的变量”来填写打开命令的“数据库密码”参数。

参见：例程1 数据库下载


复制密码 命令 所属类别：数据库

复制密码 命令 　英文命令：CopyPassword　所属类别：数据库

本命令可以将当前数据库的访问密码设置为等同于其他已打开数据库，注意数据库文件必须可写。成功返回真，失败返回假。

语法： 逻辑型 复制密码 （数据库别名或名称）

参数名 | 描 述
数据库别名或名称 | 必需的；文本型。参数值指定一个已经被打开的数据库。

例程：

说明：

程序运行后打开2个加密数据库，“加密码数据库1”和“加密码数据库2”，当前数据库是“加密码数据库2”，当“复制密码”按钮被单击，则运行“复制密码()”命令，将当前数据库的密码“2222”设置成“加密码数据库1”的密码，并使用信息框显示是否复制密码成功。

参见：例程1 数据库下载1 数据库下载2


网络通信

网络通信 类别 跳至：系统核心支持库


取主机名 命令 所属类别：网络通信

取主机名 命令 　英文命令：GetHostName　所属类别：网络通信

返回本机的主机名，用作在网络通讯中标志本机地址。

语法： 文本型 取主机名 （）

例程：

参见：例程1


通信测试 命令 所属类别：网络通信

通信测试 命令 　英文命令：ping　所属类别：网络通信

测试与指定主机是否能够正常通讯。返回被测试主机的通讯响应时间。如果无法通讯或者测试失败，返回 -1。

语法： 整数型 通信测试 （被测试主机地址，［最长等待时间］）

参数名 | 描 述
被测试主机地址 | 必需的；文本型。可以为主机名、IP地址等。
最长等待时间 | 可选的；整数型。指定最长等待被测试主机响应的时间，单位为毫秒。超过此时间即认为无法与被测试主机通讯。如果省略本参数，则默认为 10 * 1000 毫秒，即 10 秒。

例程：

说明：

在窗口标题中显示本机被测试的通信相应时间。

参见：例程1


转换为主机名 命令 所属类别：网络通信

转换为主机名 命令 　英文命令：IPToHostName　操作系统支持：Windows 所属类别：网络通信

将指定的 IP 地址转换为其主机名。如果失败返回空文本。

语法： 文本型 转换为主机名 （欲转换IP地址）

参数名 | 描 述
欲转换IP地址 | 必需的；文本型。

例程：

参见：例程1


转换为IP地址 命令 所属类别：网络通信

转换为IP地址 命令 　英文命令：HostNameToIP　操作系统支持：Windows 所属类别：网络通信

将指定的主机名转换为其 IP 地址。如果失败返回空文本。

语法： 文本型 转换为IP地址 （欲转换主机名）

参数名 | 描 述
欲转换主机名 | 必需的；文本型。

例程：

参见：例程1


控制台操作

控制台操作 类别 跳至：系统核心支持库


标准输出 命令 操作系统支持：Windows、Linux 所属类别：控制台操作

标准输出 命令 　英文命令：fputs　操作系统支持：Windows、Linux 所属类别：控制台操作

在标准输出设备或标准错误设备上输出指定的内容，注意本命令只能在控制台程序中使用。

语法： 无返回值 标准输出 （［输出方向］，欲输出内容，… ）

参数名 | 描 述
输出方向 | 可选的；整数型。本参数提供内容所输出到的设备，可以为以下常量值之一： 1、#标准输出设备； 2、#标准错误设备。如果省略本参数，默认为“#标准输出设备”。
欲输出内容 | 必需的；可扩充的；通用型。本参数只能为文本、数值、逻辑值或日期时间。如果内容为文本且包含多行，可在各行之间用回车符 (即“字符 (13)”)、换行符 (即“字符 (10)”) 或回车换行符的组合 (即：“字符 (13) + 字符 (10)”) 来分隔。

例程:

说明：

在控制台窗口中输出信息或接收信息。必须在菜单“程序”—>“程序配置”中，将程序设为Windows控制台程序或Linux控制台程序方可看到运行效果。

参见：例程1


标准输入 命令 操作系统支持：Windows、Linux 所属类别：控制台操作

标准输入 命令 　英文命令：fgets　操作系统支持：Windows、Linux 所属类别：控制台操作

在标准输入设备上请求输入最多包含1020个字符的一行文本，返回用户所输入的内容。注意本命令只能在控制台程序中使用。

语法： 文本型 标准输入 （［是否回显］）

参数名 | 描 述
是否回显 | 可选的；逻辑型。本参数决定输入时是否显示所输入字符，为假不显示，为真显示。如果被省略，默认值为真，即回显。可以通过将本参数设置为假以输入密码等特殊信息。

例程：

说明：

接收两个按提示输入的文本，通过条件判断两个文本是否相同，并提示是否错误。

最后一个“标准输入（）”命令相当于使用延时命令，只有按回车键后程序才会结束。

参见：例程1


窗口

窗口 容器型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

本类型对象的方法被除开功能型外所有的窗口组件共享。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
标题 | 边框 | 底色 | 底图
底图方式 | 背景音乐 | 播放次数 | 控制按钮
最大化按钮 | 最小化按钮 | 位置 | 可否移动
图标 | 回车下移焦点 | Esc键关闭 | F1键打开帮助
帮助文件名 | 帮助标志值 | 在任务条中显示 | 随意移动
外形 | 总在最前 | 保持标题条激活 |

方法：

取窗口句柄 | 销毁 | 获取焦点 | 可有焦点
取用户区宽度 | 取用户区高度 | 禁止重画 | 允许重画
重画 | 部分重画 | 取消重画 | 刷新显示
移动 | 调整层次 | 弹出菜单 | 发送信息
投递信息 | 取标记组件 | 置外形图片 | 激活
置托盘图标 | 弹出托盘菜单 | 置父窗口 |

自有事件：

创建完毕 | 可否被关闭 | 将被销毁 | 位置被改变
尺寸被改变 | 被激活 | 被取消激活 | 空闲
首次激活 | 托盘事件 | 被显示 | 被隐藏

基本事件：


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


标题 属性 所属对象：窗口 操作系统支持：Windows

标题 属性 操作系统支持：Windows

数据类型：文本型；本属性指定窗口的标题文本。

例程

说明

本属性用于获取和设置窗口标题栏中的标题。

参考：例程


边框 属性 所属对象：窗口 操作系统支持：Windows

边框 属性 操作系统支持：Windows

数据类型：整数型；本属性指定窗口边框的类型。

可供选择的属性值：
0、无边框
1、普通可调边框
2、普通固定边框
3、窄标题可调边框
4、窄标题固定边框
5、镜框式可调边框
6、镜框式固定边框

例程

说明

设置窗口当前边框样式为边框组合框现行选中的项目。

参考：例程


底色 属性 所属对象：窗口 操作系统支持：Windows

底色 属性 操作系统支持：Windows

数据类型：整数型；本属性指定窗口背景的颜色。

例程

说明

设置窗口的背景颜色为背景颜色选择器所选择的颜色。

参考：例程


底图 属性 所属对象：窗口 操作系统支持：Windows

底图 属性 操作系统支持：Windows

数据类型：字节集；本属性指定显示在窗口背景上的图片。

例程

说明

本属性用于获取和设置窗口背景图片。

参考：例程


底图方式 属性 所属对象：窗口 操作系统支持：Windows

底图方式 属性 操作系统支持：Windows

数据类型：整数型；如果设定了底图，本属性指定窗口背景上底图的显示方式。

可供选择的属性值：
0、图片居左上
1、图片平铺
2、图片居中

例程

说明

更改窗口底图在窗口上显示的方式为改变底图方式组合框现行选中的项目。

参考：例程


背景音乐 属性 所属对象：窗口 操作系统支持：Windows

背景音乐 属性 操作系统支持：Windows

数据类型：字节集；本属性指定当窗口调入时自动开始播放的音乐。

例程

说明

通过背景音乐对话框读入音乐文件，设置窗口的背景音乐。

参考：例程


播放次数 属性 所属对象：窗口 操作系统支持：Windows

播放次数 属性 操作系统支持：Windows

数据类型：整数型；本属性指定背景音乐的播放次数。

可供选择的属性值：
0、循环播放
1、仅播放一次
2、不播放

例程

说明

设置窗口背景音乐的播放方式。

参考：例程


控制按钮 属性 所属对象：窗口 操作系统支持：Windows

控制按钮 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设置是否显示窗口上的所有控制按钮及窗口控制菜单。

例程

说明

本属性用于显示和隐藏控制按钮（最小化，关闭和最大化/还原）。

参考：例程


最大化按钮 属性 所属对象：窗口 操作系统支持：Windows

最大化按钮 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设置是否显示窗口右上角的最大化或还原按钮。

例程

说明

本属性用于当窗口的控制按钮属性为“真”时，控制最大化按钮是否可用。

参考：例程


最小化按钮 属性 所属对象：窗口 操作系统支持：Windows

最小化按钮 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设置是否显示窗口右上角的最小化按钮。

例程

说明

本属性用于当窗口的控制按钮属性为“真”时控制最小化按钮是否可用。

参考：例程


位置 属性 所属对象：窗口 操作系统支持：Windows

位置 属性 操作系统支持：Windows

数据类型：整数型；本属性设置窗口的位置及状态。注意如果欲设置为“最大化”，“边框”属性必须不为固定类边框。

可供选择的属性值：
0、通常
1、居中
2、最小化
3、最大化

例程

说明

本属性用于设置窗口当前在屏幕中显示的状态。

参考：例程


可否移动 属性 所属对象：窗口 操作系统支持：Windows

可否移动 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设置窗口位置能否被移动。

例程

说明

本属性用于设置在按住窗口的标题栏时是否可以移动窗口。

参考：例程


图标 属性 所属对象：窗口 操作系统支持：Windows

图标 属性 操作系统支持：Windows

数据类型：字节集；本属性设置窗口左上角所显示的图标。

例程

说明

本属性用于设置窗口标题栏中的图标。

参考：例程


回车下移焦点 属性 所属对象：窗口 操作系统支持：Windows

回车下移焦点 属性 操作系统支持：Windows

数据类型：逻辑型；本属性如果设置为真，运行时当用户在本窗口上按下回车键后，将自动将当前焦点转移到下一个组件。本属性如果设置为假，当用户在本窗口上按下回车键后，将等同于按下具有“默认”属性的按钮。

例程

说明

本属性用于更改是否允许按下回车下移焦点（焦点在窗口中的组件之间移动，移动的顺序按照组件被创建的顺序，

即组件被拖动到窗口上的顺序）。

参考：例程


Esc键关闭 属性 所属对象：窗口 操作系统支持：Windows

Esc键关闭 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设置运行时用户是否可以用 Esc 键关闭本窗口。

例程

说明

本属性用于设置是否启用按下“Esc键”关闭窗口。

参考：例程


F1键打开帮助 属性 所属对象：窗口 操作系统支持：Windows

F1键打开帮助 属性 操作系统支持：Windows

数据类型：逻辑型；本属性设置运行时用户是否可以用 F1 键打开有关本窗口的帮助信息。

例程

说明

本属性用于设置是否启用“F1键打开帮助”功能。如果启用当在开启此属性的窗口中按下F1键时，

就会打开“帮助文件名”所指向的帮助文件。

参考：例程


帮助文件名 属性 所属对象：窗口 操作系统支持：Windows

帮助文件名 属性 操作系统支持：Windows

数据类型：文本型；指定欲打开帮助文件的名称，如果没有指定帮助文件，将使用默认帮助文件名称，即本易程序的文件名称（不含其后缀）＋“.hlp”后缀。

例程

说明

本属性用与指定“F1键打开帮助”属性所打开帮助的文件名。

参考：例程


帮助标志值 属性 所属对象：窗口 操作系统支持：Windows

帮助标志值 属性 操作系统支持：Windows

数据类型：整数型；用于在帮助文件中指定相应的帮助标志数值。本属性如果为零，则显示帮助主题。

例程

说明

本属性用于在窗口打开的帮助设置标志位置。

注：标志位置由编写帮助文件时定义。

参考：例程


在任务条中显示 属性 所属对象：窗口 操作系统支持：Windows

在任务条中显示 属性 操作系统支持：Windows

数据类型：逻辑型；设置本窗口是否出现在 Windows 系统的任务条中。

例程

说明

本属性只能在设计时设置，不能动态改动 。

参考：例程


随意移动 属性 所属对象：窗口 操作系统支持：Windows

随意移动 属性 操作系统支持：Windows

数据类型：逻辑型；设置当用户在窗口上任何位置按下鼠标左键后是否进入窗口整体移动模式。注意如果本属性设置为真，则在本窗口及其中所有不能接收输入焦点的子组件上均不能再接收到“鼠标左键被按下”和“鼠标左键被放开”事件。

例程

说明

设置窗口的整体移动模式。

注：随意移动指拖动窗口中的任何地方（除标题栏外）都可以移动窗口。

参考：例程


外形 属性 所属对象：窗口 操作系统支持：Windows

外形 属性 操作系统支持：Windows

数据类型：整数型；设置窗口的外形。

可供选择的属性值：
0、矩形
1、椭圆
2、圆角矩形
3、环
4、正三角
5、倒三角
6、左三角
7、右三角
8、平行四边形
9、五边形
10、六边形
11、梯形
12、菱形
13、五角星
14、十字星
15、闪电形
16、爆炸形1
17、爆炸形2
18、燕尾
19、折角矩形
20、左箭头
21、右箭头
22、上箭头
23、下箭头
24、左右箭头
25、上下箭头
26、十字箭头
27、丁字箭头
28、燕尾箭头
29、五边形箭头

例程

说明

本属性用于设置窗口的形状。

参考：例程


总在最前 属性 所属对象：窗口 操作系统支持：Windows

总在最前 属性 操作系统支持：Windows

数据类型：逻辑型；设置本窗口永远位于其它窗口的前面。

例程

说明

本属性用于设置是否将窗口位置总是放在最前(z轴方向)。

参考：例程


保持标题条激活 属性 所属对象：窗口 操作系统支持：Windows

保持标题条激活 属性 操作系统支持：Windows

数据类型：逻辑型；如果希望本窗口在非激活状态下其标题条仍然与激活状态时相同，请设置本属性为真。

例程

说明

一个窗口在激活状态下标题条的颜色是明亮的，在非激活状态下标题条的颜色蒙上了一层灰白色。

本属性就是用于是否将窗口标题条总是设置为激活状态，即标题条的颜色总是明亮的。

参考：例程


取窗口句柄 方法 操作系统支持：Windows 所属对象：窗口

取窗口句柄 方法 　英文命令：GetHWnd　操作系统支持：Windows 所属对象：窗口

为高级用户提供，初级用户无需掌握；
取出本窗口或窗口组件的窗口句柄（即HWND）。

语法： 整数型 窗口组件．取窗口句柄 （）

例程

说明

通过“取窗口句柄”命令获取指定窗口的句柄。窗口每次创建都被系统赋予一个新的句柄。

句柄：在计算机中，所有的数据都是由一系列二进制数值所表示的，像窗口，文件，图片等大型的作为一个整体

的数据，系统自动赋予一个名字来命名它，这个名字就是句柄。窗口句柄就是窗口在系统中的名字。

本方法适用于所有组件。

参考：例程


销毁 方法 操作系统支持：Windows 所属对象：窗口

销毁 方法 　英文命令：destroy　操作系统支持：Windows 所属对象：窗口

通过PostMessage间接实现。销毁本窗口或窗口组件。窗口被销毁后，所有在载入本窗口之后对本窗口及其内窗口组件所进行的修改或设置都将被抛弃。窗口被销毁后如想再次使用必须重新装载。

语法： 无返回值 窗口组件．销毁 （）

例程

说明

通过“销毁”命令关闭一个窗口。

本方法适用于所有组件。

参考：例程


获取焦点 方法 操作系统支持：Windows 所属对象：窗口

获取焦点 方法 　英文命令：SetFocus　操作系统支持：Windows 所属对象：窗口

将焦点移动到窗口组件。如果对窗口使用本方法，窗口将自动把焦点转移到第一个有能力保留焦点的窗口组件上去。

语法： 无返回值 窗口组件．获取焦点 （）

例程

说明

通过“获取焦点”命令激活指定窗口。

本方法适用于所有组件。

参考：例程


可有焦点 方法 操作系统支持：Windows 所属对象：窗口

可有焦点 方法 　英文命令：IsFocus　操作系统支持：Windows 所属对象：窗口

如果当前窗口组件具有焦点，则返回真，否则返回假。

语法： 逻辑型 窗口组件．可有焦点 （）

例程

说明

通过“可有焦点”命令判断指定窗口是否拥有焦点。

本方法适用于所有组件。

参考：例程


取用户区宽度 方法 操作系统支持：Windows 所属对象：窗口

取用户区宽度 方法 　英文命令：GetClientWidth　操作系统支持：Windows 所属对象：窗口

返回窗口或窗口组件用户区域的宽度，单位为像素点。对窗口而言，用户区域为窗口区域减去标题栏、菜单栏、边框后的区域；对窗口组件而言，用户区域等同于其窗口组件区域。

语法： 整数型 窗口组件．取用户区宽度 （）

例程

说明

通过“取用户区宽度”命令获取用户区宽度。

本方法适用于所有组件。

参考：例程


取用户区高度 方法 操作系统支持：Windows 所属对象：窗口

取用户区高度 方法 　英文命令：GetClientHeight　操作系统支持：Windows 所属对象：窗口

返回窗口或窗口组件用户区域的高度，单位为像素点。对窗口而言，用户区域为窗口区域减去标题栏、菜单栏、边框后的区域；对窗口组件而言，用户区域等同于其窗口组件区域。

语法： 整数型 窗口组件．取用户区高度 （）

例程

说明

通过“取用户区高度”命令获取用户区高度。

本方法适用于所有组件。

参考：例程


禁止重画 方法 操作系统支持：Windows 所属对象：窗口

禁止重画 方法 　英文命令：LockWindowUpdate　操作系统支持：Windows 所属对象：窗口

禁止窗口或窗口组件重画，以避免当频繁进行操作时引起闪烁。注意调用本命令后必须调用“允许重画”命令进行恢复。

语法： 无返回值 窗口组件．禁止重画 （）

例程

说明

通过“禁止重画”命令禁止系统对指定窗口或窗口组件重画。

本方法适用于所有组件。

参考：例程


允许重画 方法 操作系统支持：Windows 所属对象：窗口

允许重画 方法 　英文命令：UnlockWindowUpdate　操作系统支持：Windows 所属对象：窗口

重新允许被禁止的窗口或窗口组件重画。

语法： 无返回值 窗口组件．允许重画 （）

例程

说明

通过“允许重画”命令允许系统对指定窗口的重画。

本方法适用于所有组件。

参考：例程


重画 方法 操作系统支持：Windows 所属对象：窗口

重画 方法 　英文命令：invalidate　操作系统支持：Windows 所属对象：窗口

通知 Windows 系统本窗口或窗口组件上的显示内容需要在以后被全部重画。

语法： 无返回值 窗口组件．重画 （）

例程

说明

通过“重画”命令手动对指定窗口进行重画。

本方法适用于所有组件。

参考：例程


部分重画 方法 操作系统支持：Windows 所属对象：窗口

部分重画 方法 　英文命令：InvalidateRect　操作系统支持：Windows 所属对象：窗口

通知 Windows 系统本窗口或窗口组件上的显示内容需要在以后被部分重画。

语法： 无返回值 窗口组件．部分重画 （欲重画区域的左边，欲重画区域的顶边，欲重画区域的宽度，欲重画区域的高度）

参数名 | 描 述
欲重画区域的左边 | 必需的；整数型。单位为像素点，相对于用户区域的左边。
欲重画区域的顶边 | 必需的；整数型。单位为像素点，相对于用户区域的顶边。
欲重画区域的宽度 | 必需的；整数型。单位为像素点。
欲重画区域的高度 | 必需的；整数型。单位为像素点。

例程

说明

通过“部分重画”命令对指定窗口内指定区域进行重画。

本方法适用于所有组件。

参考：例程


取消重画 方法 操作系统支持：Windows 所属对象：窗口

取消重画 方法 　英文命令：validate　操作系统支持：Windows 所属对象：窗口

通知 Windows 系统本窗口或窗口组件不再需要被重画，保留现有的全部显示内容。

语法： 无返回值 窗口组件．取消重画 （）

例程

说明

通过“取消重画”命令取消对指定窗口的重画。

本方法适用于所有组件。

参考：例程


刷新显示 方法 操作系统支持：Windows 所属对象：窗口

刷新显示 方法 　英文命令：UpdateWindow　操作系统支持：Windows 所属对象：窗口

如果本窗口或窗口组件上的显示内容需要被全部或部分重画，则立即进行重画更新，否则不进行任何操作直接返回。

语法： 无返回值 窗口组件．刷新显示 （）

例程

说明

通过“刷新显示”命令刷新显示指定窗口。

本方法适用于所有组件。

参考：例程


移动 方法 操作系统支持：Windows 所属对象：窗口

移动 方法 　英文命令：move　操作系统支持：Windows 所属对象：窗口

改变窗口或窗口组件的位置或尺寸。

语法： 无返回值 窗口组件．移动 （［左边］，［顶边］，［宽度］，［高度］）

参数名 | 描 述
左边 | 可选的；整数型。单位为像素点。如被省略则不改变左边原位置。
顶边 | 可选的；整数型。单位为像素点。如被省略则不改变顶边原位置。
宽度 | 可选的；整数型。单位为像素点。如被省略或等于 -1 ，则不改变原宽度。
高度 | 可选的；整数型。单位为像素点。如被省略或等于 -1 ，则不改变原高度。

例程

说明

通过“移动”命令更改指定窗口的位置和大小。

本方法适用于所有组件。

参考：例程


调整层次 方法 操作系统支持：Windows 所属对象：窗口

调整层次 方法 　英文命令：ZOrder　操作系统支持：Windows 所属对象：窗口

改变窗口或窗口组件的现行所处层次。

语法： 无返回值 窗口组件．调整层次 （［欲调整到的层次］）

参数名 | 描 述
欲调整到的层次 | 可选的；整数型。可以为以下常量之一： 1、#顶层； 2、#底层； 3、#最高层； 4、#次高层。如果被省略，默认为“#顶层”。

例程

说明

通过“调整层次”命令，更改窗口或组件的Z轴（前后）位置。

本方法适用于所有组件。

参考：例程


弹出菜单 方法 操作系统支持：Windows 所属对象：窗口

弹出菜单 方法 　英文命令：PopupMenu　操作系统支持：Windows 所属对象：窗口

用于在窗口上的当前鼠标位置或指定坐标位置显示弹出式菜单，如果调用对象为窗口组件，则自动使用其所在的窗口。

语法： 无返回值 窗口组件．弹出菜单 （欲弹出的菜单，［水平显示位置］，［垂直显示位置］）

参数名 | 描 述
欲弹出的菜单 | 必需的；菜单。指定菜单内必须包含有子菜单，且所处窗口必须与调用对象窗口一致。
水平显示位置 | 可选的；整数型。单位为像素点，相对于屏幕左边。如果被省略，将自动使用当前鼠标位置。
垂直显示位置 | 可选的；整数型。单位为像素点，相对于屏幕顶边。如果被省略，将自动使用当前鼠标位置。

例程

说明

通过“弹出菜单”命令在指定位置弹出菜单，欲弹出的菜单必须已存在。

本方法适用于所有组件。

参考：例程


发送信息 方法 操作系统支持：Windows 所属对象：窗口

发送信息 方法 　英文命令：SendMessage　操作系统支持：Windows 所属对象：窗口

将指定信息发送到窗口或窗口组件，并等待且取回信息反馈值。

语法： 整数型 窗口组件．发送信息 （信息值，参数1，参数2）

参数名 | 描 述
信息值 | 必需的；整数型。
参数1 | 必需的；整数型，初始值为“0”。
参数2 | 必需的；整数型，初始值为“0”。

例程

说明

通过“发送信息”命令向指定窗口发送消息。具体消息值的含义请参阅与窗口消息相关的内容。

本方法适用于所有组件。

参考：例程


投递信息 方法 操作系统支持：Windows 所属对象：窗口

投递信息 方法 　英文命令：PostMessage　操作系统支持：Windows 所属对象：窗口

将指定信息发送到窗口或窗口组件，不等待直接返回。

语法： 无返回值 窗口组件．投递信息 （信息值，参数1，参数2）

参数名 | 描 述
信息值 | 必需的；整数型。
参数1 | 必需的；整数型，初始值为“0”。
参数2 | 必需的；整数型，初始值为“0”。

例程

说明

通过“投递信息”向指定窗口发送一条消息，但与“发送消息”不同的是它不会返回信息。

本方法适用于所有组件。

参考：例程


取标记组件 方法 操作系统支持：Windows 所属对象：窗口

取标记组件 方法 　英文命令：GetSpecTagUnit　操作系统支持：Windows 所属对象：窗口

返回当前窗口中具有指定标记数值文本的组件。如果不存在，将产生运行时错误。

语法： 通用型 窗口组件．取标记组件 （欲寻找组件的标记数值）

参数名 | 描 述
欲寻找组件的标记数值 | 必需的；整数型。即该组件的“标记”属性文本的数值形式。

例程

说明

本命令就是根据各组件标记属性中的数值文本取得拥有该数值得组件的名称。

注意：各组件的数值相互间不能重复。

本方法适用于所有组件。

参考：例程


置外形图片 方法 操作系统支持：Windows 所属对象：窗口

置外形图片 方法 　英文命令：SetShapePic　操作系统支持：Windows 所属对象：窗口

使用图片来设置窗口的外形，注意图片类型不能为图标及鼠标指针。另外，图片的轮廓应该尽量简单，以免影响窗口的刷新速度。如果调用对象为窗口组件，将自动使用其所在的窗口。成功返回真，失败返回假。

语法： 逻辑型 窗口组件．置外形图片 （图片数据，［透明颜色］）

参数名 | 描 述
图片数据 | 必需的；通用型。参数值可以为 .JPG、.GIF、.BMP、.DIB 等等被支持格式的图片数据、图片资源或图片文件名。
透明颜色 | 可选的；整数型。指定图片中透明部分的颜色。如果被省略，默认为白色。

例程

说明

通过“置外形图片”命令将窗口外形设置为一副图片的一部分，是外形属性的扩展。

本方法适用于所有组件。

参考：例程


激活 方法 操作系统支持：Windows 所属对象：窗口

激活 方法 　英文命令：Activate　操作系统支持：Windows 所属对象：窗口

激活窗口。

语法： 无返回值 窗口组件．激活 （）

例程

说明

通过“激活”命令将指定窗口激活。

本方法适用于所有组件。

参考：例程


置托盘图标 方法 操作系统支持：Windows 所属对象：窗口

置托盘图标 方法 　英文命令：SetTrayIcon　操作系统支持：Windows 所属对象：窗口

设置本程序在系统托盘中的图标。

语法： 无返回值 窗口组件．置托盘图标 （［图标数据］，［提示信息］）

参数名 | 描 述
图标数据 | 可选的；通用型。参数值可以为图标字节集数据、图标资源或图标文件名。如果省略本参数，默认为清除已有的本程序图标。
提示信息 | 可选的；文本型。本参数指定当鼠标移动到图标上后显示的提示信息。如果省略本参数，默认为空文本。

例程

说明

通过“置托盘图标”命令向任务栏添加一个图标。

本方法适用于所有组件。

参考：例程


弹出托盘菜单 方法 操作系统支持：Windows 所属对象：窗口

弹出托盘菜单 方法 　英文命令：PopupTrayMenu　操作系统支持：Windows 所属对象：窗口

在当前鼠标位置弹出指定菜单，本命令一般用作支持托盘菜单的弹出。

语法： 无返回值 窗口组件．弹出托盘菜单 （欲弹出的菜单）

参数名 | 描 述
欲弹出的菜单 | 必需的；菜单。指定菜单内必须包含有子菜单，且所处窗口必须与调用对象窗口一致。

例程

说明

通过“弹出托盘菜单”命令，在鼠标所在处弹出指定菜单。

本方法适用于所有组件。

参考：例程


置父窗口 (窗口)

置父窗口 方法 操作系统支持：Windows 所属对象：窗口

设置指定窗口或窗口组件为本对象窗口或窗口组件的父窗口。

语法： 无返回值 窗口组件．置父窗口 （父窗口或窗口组件）

参数名 | 描 述
父窗口或窗口组件 | 必需的； 通用型。参数值提供欲设置为本对象窗口组件父窗口的窗口或窗口组件。

例程

参见：例程1


创建完毕 事件 所属对象：窗口 操作系统支持：Windows

当窗口及其中的所有组件均被创建后在显示之前产生此事件，用户可以在响应此事件期间做一些初始化工作。本事件为该窗口的第一个事件。

语法： 无返回值 _窗口_创建完毕 （）

例程

说明

当窗口载入后窗口和窗口中所有组件均创建完毕后，此事件被触发。

参考：例程


可否被关闭 事件 所属对象：窗口 操作系统支持：Windows

在窗口被关闭之前产生此事件，用于询问窗口可否被关闭。如果返回假则不允许窗口被关闭，返回真或不返回值允许关闭。

语法： 逻辑型 _窗口_可否被关闭 （）

例程

说明

当按下窗口控制按钮中的“×”键时，此事件被触发。通过此事件可以决定是否关闭此窗口。

参考：例程


将被销毁 事件 所属对象：窗口 操作系统支持：Windows

当窗口将被销毁前产生此事件。窗口被销毁后所有对此窗口及其内部组件的修改都将被作废。

语法： 无返回值 _窗口_将被销毁 （）

例程

说明

本事件在事件拥有者将被销毁时触发，正常情况下不管在此事件进行任何操作均不能决定是否销毁。

参考：例程


位置被改变 事件 所属对象：窗口 操作系统支持：Windows

当窗口的位置被改变时产生此事件。

语法： 无返回值 _窗口_位置被改变 （）

例程

说明

当事件拥有者在屏幕中的位置被改变，此事件将被触发。

参考：例程


尺寸被改变 事件 所属对象：窗口 操作系统支持：Windows

当窗口的尺寸被改变后产生此事件。

语法： 无返回值 _窗口_尺寸被改变 （）

例程

说明

当本事件的拥有者的大小被改变时，此事件被触发。

参考：例程


被激活 事件 所属对象：窗口 操作系统支持：Windows

当窗口转换为激活状态时产生此事件。

语法： 无返回值 _窗口_被激活 （）

例程

说明

当此事件的拥有者被激活时，此事件被触发。

注意：窗口被创建后，就会马上触发此事件。

参考：例程


被取消激活 事件 所属对象：窗口 操作系统支持：Windows

当窗口转换为非激活状态时产生此事件。

语法： 无返回值 _窗口_被取消激活 （）

例程

说明

当此事件的拥有者从激活状态被取消了激活，本事件被触发。

参考：例程


空闲 事件 所属对象：窗口 操作系统支持：Windows

当系统正处于空闲状态时产生此事件，用户可以在响应此事件时做一些后台处理工作。如果事件处理子程序返回假或者不返回值，在此次空闲期间系统将不再产生空闲事件（可以降低 CPU 占用率）。如果返回真，系统将继续产生空闲事件。

语法： 逻辑型 _窗口_空闲 （已空闲时间）

参数名 | 描 述
已空闲时间 | 整数型；指示自系统本次进入空闲状态后到现在所经过的空闲时间，单位为毫秒。用户程序在空闲状态下所进行的大工作量操作最好等到此值较大时进行。

例程

说明

当事件的拥有者在没有操作的情况下，此事件将被触发。如果返回“真”则不停的检测是否在空闲状态。注意！在不停的检测是否空闲时会占用大量CPU，在进行操作后返回“假”来关闭（当下次操作结束后仍会触发次事件）检测以减少CPU占用。

参考：例程


首次激活 事件 所属对象：窗口 操作系统支持：Windows

当窗口创建完毕后被首次激活显示时产生此事件，在此事件及此事件后用户可以开始在窗口内的画板组件上写出内容。

语法： 无返回值 _窗口_首次激活 （）

例程

说明

当此事件的拥有者首次被激活时，此事件将被触发。

注：此事件将只被触发一次。

参考：例程


托盘事件 事件 所属对象：窗口 操作系统支持：Windows

当用户用鼠标单击或双击本窗口对象“置托盘图标”方法所设置的图标后即产生本事件。

语法： 无返回值 _窗口_托盘事件 （操作类型）

参数名 | 描 述
操作类型 | 整数型；指示用户操作类型，可能为的值为：1、#左键单击；2、#左键双击；3、#右键单击。

例程

说明

当此事件拥有者使用过“置托盘图标”命令设置过托盘图标，当使用鼠标点击托盘图标既会触发此事件。

参考：例程


被显示 事件 所属对象：窗口 操作系统支持：Windows

当窗口被显示时产生此事件。

语法： 无返回值 _窗口_被显示 （）

例程

说明

当此事件的拥有者被显示时，此事件被触发。

参考：例程


被隐藏 事件 所属对象：窗口 操作系统支持：Windows

当窗口被隐藏时产生此事件。

语法： 无返回值 _窗口_被隐藏 （）

例程

说明

当此事件的拥有者被隐藏时，此事件被触发。

参考：例程


编辑框

编辑框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
内容 | 边框 | 文本颜色 | 背景颜色
字体 | 隐藏选择 | 最大允许长度 | 是否允许多行
滚动条 | 对齐方式 | 输入方式 | 密码遮盖字符
转换方式 | 调节器方式 | 调节器底限值 | 调节器上限值
起始选择位置 | 被选择字符数 | 被选择文本 | 数据源
数据列 |  |  |

方法：

加入文本

自有事件：

内容被改变 调节钮被按下

基本事件：


内容 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：文本型；

例程

说明

本属性用于更改编辑框中显示的内容。

参考：例程1


边框 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

例程

说明

本属性用于更改和取得当前编辑框的边框样式。

参考：例程1


文本颜色 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；

例程

说明

本属性用于更改和获取编辑框中文字的颜色。

参考：例程1


背景颜色 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；

例程

说明

本属性用于取得和更改编辑框的背景颜色。

参考：例程1


字体 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：字体；

例程

说明

本属性用于更改编辑框内文字的字体。

参考：例程1


隐藏选择 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：逻辑型；本属性指定失去输入焦点后是否还显示当前被选择的区域。

例程

说明

本属性用于设置当指定编辑框失去焦点后，是否以选中样式显示编辑框中被选中的内容。

参考：例程1


最大允许长度 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；本属性设置最大允许输入到本组件中的字符数目，如为0则输入字符数目不受限制。

例程

说明

本命令用于取得和设定编辑框中最多允许写入多少字节的内容。

参考：例程1


是否允许多行 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：逻辑型；本属性设置本组件是否允许输入多行文本。

例程

说明

本属性用于设置和获取指定编辑框是否使用多行显示。

参考：例程1


滚动条 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；滚动条只有在多行方式下才有效。

可供选择的属性值：
0、无
1、横向滚动条
2、纵向滚动条
3、横向及纵向滚动条

例程

说明

本属性用于设置指定编辑框有无滚动条和滚动条方式。

参考：例程1


对齐方式 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、左对齐
1、居中
2、右对齐

例程

说明

通过本属性可以设置编辑框中文字的对齐方式。

参考：例程1


输入方式 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、通常方式
1、只读方式
2、密码输入
3、整数文本输入
4、小数文本输入
5、输入字节
6、输入短整数
7、输入整数
8、输入长整数
9、输入小数
10、输入双精度小数
11、输入日期时间

例程

说明

本属性用于定义在指定编辑框中所允许输入的内容和显示方式。

参考：例程1


密码遮盖字符 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：文本型；本属性设置当输入方式为“密码输入”时输入字符后显示在输入框中的替代字符。

例程

说明

本属性用于当编辑框的输入方式为密码输入时，替换编辑框中内容的字符。

参考：例程1


转换方式 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无
1、大写->小写
2、小写->大写

例程

说明

本属性用于是否将编辑框中的字母自动转换为指定格式。

参考：例程1


调节器方式 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；调节器只有在单行方式下才有效。

可供选择的属性值：
0、无调节器
1、自动调节器
2、手动调节器

例程

说明

本属性用于设置指定编辑框的调节器方式。手动方式即需在编辑框的调节器被按下事件中处理。自动调节器即自动增减1。

参考：例程1


调节器底限值 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；只有在自动调节器方式下才有效。

例程

说明

本属性用于当调节器方式为自动调节器时限制调节器调节最小值。

参考：例程1


调节器上限值 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；只有在自动调节器方式下才有效。

例程

说明

本属性用于当编辑框的调节器方式为自动调节时，指定自动调节的最大值。

参考：例程1


起始选择位置 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；返回或设置所选择文本的起始点；0 为位置 1 ，1 为位置 2，如此类推。如果没有文本被选中，则指出光标位置。如果设置位置时使用值 -1，则将当前光标位置移动到文本尾部。

例程

说明

本属性用于指定要选择内容的第一个位置。

参考：例程1


被选择字符数 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：整数型；返回或设置所选择的字符数。如果设置字符数时使用值 -1，则选择文本框内的所有字符。

例程

说明

本属性用于指定和获取从起始选择位置开始需要选中的字符数。

参考：例程1


被选择文本 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：文本型；设计时不可用；返回或替换当前所选择的文本。

例程

说明

设置编辑框的被选区的替换文本。（就算选中后覆盖也不会从新选中）

参考：例程1


数据源 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：文本型；指定提供数据的数据源组件名。

例程

说明

本属性用于和指定数据源绑定以便获取和更改数据库。

参见：例程 数据库下载


数据列 属性 所属对象：编辑框 操作系统支持：Windows

数据类型：文本型；指定数据源中的数据列，可以是列名或以1开始的列序号文本。

例程

说明

本属性用于和数据源中的指定字段进行绑定，以便读取和更改数据库。

参见：例程 数据库下载


加入文本 方法 操作系统支持：Windows 所属对象：编辑框

加入文本 方法 　英文命令：AddText　操作系统支持：Windows 所属对象：编辑框

将指定文本加入到编辑框内容的尾部。

语法： 无返回值 编辑框．加入文本 （欲加入文本，… ）

参数名 | 描 述
欲加入文本 | 必需的；可扩充的；文本型。

例程

说明

通过“加入文本”命令，向指定编辑框中加入指定文本。

参考：例程1


内容被改变 事件 所属对象：编辑框 操作系统支持：Windows

当编辑框的内容被修改后即产生此事件。

语法： 无返回值 _编辑框_内容被改变 （）

例程

说明

当本事件的拥有者中的内容被改变时，此事件被触发。

参考：例程1


调节钮被按下 事件 所属对象：编辑框 操作系统支持：Windows

只有调节器方式为“手动调节器”时才会产生此事件。

语法： 无返回值 _编辑框_调节钮被按下 （按钮值）

参数名 | 描 述
按钮值 | 整数型；如果按下的是调节器的向上箭头按钮，参数值为 1，否则为 -1。

例程

说明

当本事件的拥有者的调节按钮被按下时，此事件被触发。

参考：例程1


图片框

图片框 容器型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 背景颜色 | 图片 | 显示方式
播放动画 | 数据源 | 数据列 |

基本事件：


边框 属性 所属对象：图片框 操作系统支持：Windows

边框 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

例程

说明

设置图片框的边框样式为边框样式组合框现行选中的项目。

参考：例程


背景颜色 属性 所属对象：图片框 操作系统支持：Windows

背景颜色 属性 操作系统支持：Windows

数据类型：整数型；

例程

说明

设置图片框的背景颜色为背景颜色选择器所选择的颜色。

参考：例程


图片 属性 所属对象：图片框 操作系统支持：Windows

图片 属性 操作系统支持：Windows

数据类型：字节集；

本属性指定显示在图片框上的图片。

例程

说明

打开图片通用对话框，浏览文件夹，选择要显示的图片文件，将其读入到图片框的图片中。

参考：例程


显示方式 属性 所属对象：图片框 操作系统支持：Windows

显示方式 属性 操作系统支持：Windows

数据类型：整数型；如果设定了图片，本属性指定图片框上图片的显示方式。

可供选择的属性值：
0、图片居左上
1、缩放图片
2、图片居中

例程

说明

设置图片在图片框中的显示方式为显示方式组合框现行选中的项目。

参考：例程


播放动画 属性 所属对象：图片框 操作系统支持：Windows

播放动画 属性 操作系统支持：Windows

数据类型：逻辑型；当图片为 GIF 动画格式时，通过改变此属性可控制其播放或停止。如在设计时置本属性为真，运行时动画在图片框被创建后即自动开始播放。

例程

说明

本属性用于设置是否在图片框中播放GIF动画。

参考：例程


数据源 属性 所属对象：图片框 操作系统支持：Windows

数据源 属性 操作系统支持：Windows

数据类型：文本型；指定提供数据的数据源组件名。

例程

说明

本属性用于和数据源绑定，以便读取和更改数据库中的图片。

参考：例程 所涉及的数据库 所涉及的数据库扩展


数据列 属性 所属对象：图片框 操作系统支持：Windows

数据列 属性 操作系统支持：Windows

数据类型：文本型；指定数据源中的字节集或图片数据列，可以是列名或以1开始的列序号文本。

例程

说明

本属性用于与数据库交互图片数据，指定要显示的是那一个字段的图片数据。

参考：例程


外形框

外形框 容器型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
背景颜色 | 外形 | 线条效果 | 线型
线宽 | 线条颜色 | 填充颜色 |

基本事件：


背景颜色 属性 所属对象：外形框 操作系统支持：Windows

背景颜色 属性 操作系统支持：Windows

数据类型：整数型；

例程

说明

设置外形框的背景颜色为背景颜色选择器所选择的颜色。

参考：例程


外形 属性 所属对象：外形框 操作系统支持：Windows

外形 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、矩形
1、正方形
2、椭圆
3、圆
4、圆角矩形
5、圆角正方形
6、横向线
7、纵向线

例程

说明

本属性用于设置外形框的形状。

参考：例程


线条效果 属性 所属对象：外形框 操作系统支持：Windows

线条效果 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、通常
1、凹入
2、凸出

例程

说明

本属性用于设置外形框的线条效果。

参考：例程


线型 属性 所属对象：外形框 操作系统支持：Windows

线型 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无
1、直线
2、划线
3、点线
4、点划线
5、双点划线

例程

说明

本属性用于设置外形框的边框线的类型。

参考：例程


线宽 属性 所属对象：外形框 操作系统支持：Windows

线宽 属性 操作系统支持：Windows

数据类型：整数型；注意：仅在线条效果为“通常”且线型为“直线”时才有效。

例程

说明

改变外形框的边框线的宽度。

参考：例程


线条颜色 属性 所属对象：外形框 操作系统支持：Windows

线条颜色 属性 操作系统支持：Windows

数据类型：整数型；注意：仅在线条效果为“通常”时才有效。

例程

说明

设置外形框的边框线条的颜色为线条颜色选择器所选择的颜色。

参考：例程


填充颜色 属性 所属对象：外形框 操作系统支持：Windows

填充颜色 属性 操作系统支持：Windows

数据类型：整数型；注意：仅在外形不为线条时才有效。

例程

说明

设置外形框内的填充颜色为填充颜色选择器所选择的颜色。

参考：例程


画板

画板 容器型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

默认不接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 画板背景色 | 底图 | 底图方式
自动重画 | 绘画单位 | 画笔类型 | 画出方式
画笔粗细 | 画笔颜色 | 刷子类型 | 刷子颜色
文本颜色 | 文本背景颜色 | 字体 | 画板宽度
画板高度 |  |  |

方法：

取设备句柄 | 清除 | 取点 | 画点
画直线 | 画椭圆 | 画弧线 | 画弦
画饼 | 画矩形 | 画渐变矩形 | 填充矩形
画圆角矩形 | 翻转矩形区 | 画多边形 | 置写出位置
写文本行 | 滚动写行 | 写出 | 定位写出
取宽度 | 取高度 | 画图片 | 取图片宽度
取图片高度 | 复制 | 取图片 | 单位转换

自有事件：

绘画

基本事件：


边框 属性 所属对象：画板 操作系统支持：Windows

边框 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

例程

说明

本属性用于设置画板边框样式。

参考：例程


画板背景色 属性 所属对象：画板 操作系统支持：Windows

画板背景色 属性 操作系统支持：Windows

数据类型：整数型；注意如果“自动重画”属性为真，则不支持透明色。

例程

说明

本属性用于设置和获取画板背景颜色。

参考：例程


底图 属性 所属对象：画板 操作系统支持：Windows

底图 属性 操作系统支持：Windows

数据类型：字节集；本属性指定显示在画板背景上的图片。

例程

说明

通过底图对话框，读入图片文件，设置画板的底图。。

参考：例程


底图方式 属性 所属对象：画板 操作系统支持：Windows

底图方式 属性 操作系统支持：Windows

数据类型：整数型；如果设定了底图，本属性指定画板背景上底图的显示方式。

可供选择的属性值：
0、图片居左上
1、图片平铺
2、图片居中

例程

说明

本属性用于底图在画板中的显示方式。本属性在运行时更改无效。

参考：例程


自动重画 属性 所属对象：画板 操作系统支持：Windows

自动重画 属性 操作系统支持：Windows

数据类型：逻辑型；如果本属性设置为真，系统将自动把所有在画板上进行的绘画操作的结果保存到内存中，当以后需要重画时，系统简单地把所保存的绘画结果复制到画板上，而不再产生“绘画”事件。采用本属性需要消耗一定数量的内存。

例程

说明

本属性用于设置画板是否自动重画。如果不使用自动重画，画板一旦被隐藏或被其他窗口遮住后再次显示，画板中的内容将无法看见。

参考：例程


绘画单位 属性 所属对象：画板 操作系统支持：Windows

绘画单位 属性 操作系统支持：Windows

数据类型：整数型；本属性指定绘画时所使用的单位，坐标系的 X 轴从左到右，Y 轴从上到下。

可供选择的属性值：
0、像素点
1、0.1毫米
2、0.01毫米
3、0.01英寸
4、0.001英寸
5、1/1440英寸

例程

说明

本属性用于指定画板在使用绘画命令时所使用的绘画单位。

参考：例程


画笔类型 属性 所属对象：画板 操作系统支持：Windows

画笔类型 属性 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、空笔
1、直线
2、划线
3、点线
4、点划线
5、双点划线
6、内直线

例程

说明

本属性用于设置画板绘画时的画笔类型。

参考：例程


画出方式 属性 所属对象：画板 操作系统支持：Windows

画出方式 属性 操作系统支持：Windows

数据类型：整数型；有关各种画出方式的说明为： 0、黑色：始终画出黑色；1、非或笔：或笔的相反；2、与非笔：背景色以及画笔反相二者共有颜色的组合；3、非复制笔：复制笔的相反；4、与笔非：画笔以及已有颜色反相二者共有颜色的组合；5、反转：已有颜色的反相；6、异或笔：画笔的颜色以及已有颜色的组合，只取其一；7、非与笔：与笔的相反；8、与笔：画笔和已有二者共有颜色的组合；9、非异或笔：异或笔的相反；10、无操作：原有保持不变。该设置实际上关闭画笔；11、或非笔：已有颜色与画笔颜色反相的组合；12、复制笔（缺省值）：画笔颜色；13、或笔非：画笔颜色与已有颜色的反相的组合；14、或笔：画笔颜色与已有颜色的组合；15、白色：始终画出白色。

可供选择的属性值：
0、黑色
1、非或笔
2、与非笔
3、非复制笔
4、与笔非
5、反转
6、异或笔
7、非与笔
8、与笔
9、非异或笔
10、无操作
11、或非笔
12、复制笔
13、或笔非
14、或笔
15、白色

例程

说明

本属性用于设置使用绘画命令在画板中的画出方式。

参考：例程


画笔粗细 属性 所属对象：画板 操作系统支持：Windows

画笔粗细 属性 操作系统支持：Windows

数据类型：整数型；使用现行绘画单位，如果为0，表示画笔的粗细为一个像素点。注意：当画笔类型为划线、点线、点划线、双点划线时，本属性无效，画笔宽度始终为一个像素点。

例程

说明

本属性用于设置在画板中绘画的花笔粗细。

参考：例程


画笔颜色 属性 所属对象：画板 操作系统支持：Windows

画笔颜色 属性 操作系统支持：Windows

数据类型：整数型；

例程

说明

本属性用于设置在画板中绘图的画笔颜色.

参考：例程


刷子类型 属性 所属对象：画板 操作系统支持：Windows

刷子类型 属性 操作系统支持：Windows

数据类型：整数型；各种格式刷子将使用当前文本背景颜色作为刷子背景颜色。

可供选择的属性值：
0、空刷子
1、颜色刷子
2、右斜线
3、直交叉线
4、斜交叉线
5、左斜线
6、横线
7、竖线
8、5%色点
9、10%色点
10、20%色点
11、25%色点
12、30%色点
13、40%色点
14、50%色点
15、60%色点
16、70%色点
17、75%色点
18、80%色点
19、90%色点
20、浅色上对角线
21、浅色下对角线
22、深色上对角线
23、深色下对角线
24、宽上对角线
25、宽下对角线
26、浅色竖线
27、浅色横线
28、窄竖线
29、窄横线
30、深色竖线
31、深色横线
32、上对角虚线
33、下对角虚线
34、横虚线
35、竖虚线
36、小纸屑
37、大纸屑
38、之字形
39、波浪线
40、对角砖形
41、横向砖形
42、纺织物
43、方格呢
44、草皮
45、虚格线
46、点式菱形
47、瓦形
48、棚架
49、球体
50、小网格
51、大网格
52、小棋盘
53、大棋盘
54、空心菱形
55、实心菱形

例程

说明

本属性用于设置在画板中绘画时的刷子类型。

参考：例程


刷子颜色 属性 所属对象：画板 操作系统支持：Windows

刷子颜色 属性 操作系统支持：Windows

数据类型：整数型；

例程

说明

本命令用于获取和设置在画板中绘画图形的刷子颜色。

参考：例程


文本颜色 属性 所属对象：画板 操作系统支持：Windows

文本颜色 属性 操作系统支持：Windows

数据类型：整数型；

例程

说明

本属性用于更改使用画板的“写文本行”命令写出文字的颜色。

参考：例程


文本背景颜色 属性 所属对象：画板 操作系统支持：Windows

文本背景颜色 属性 操作系统支持：Windows

数据类型：整数型；

例程

说明

本属性用于设置使用“写文本行”在画板中写出的文本的背景颜色。

参考：例程


字体 属性 所属对象：画板 操作系统支持：Windows

字体 属性 操作系统支持：Windows

数据类型：字体；

例程

说明

本属性用于设置使用“写文本行命令”在画板中写出的文字的字体。

参考：例程


画板宽度 属性 所属对象：画板 操作系统支持：Windows

画板宽度 属性 操作系统支持：Windows

数据类型：整数型；只读；本属性提供了目前画板的宽度，使用现行绘画单位。属性值等于“画板”窗口组件的用户区域宽度。

例程

说明

本属性用于取得画板可用宽度。画板宽度=宽度-边框宽度。

参考：例程


画板高度 属性 所属对象：画板 操作系统支持：Windows

画板高度 属性 操作系统支持：Windows

数据类型：整数型；只读；本属性提供了目前画板的高度，使用现行绘画单位。属性值等于“画板”窗口组件的用户区域高度。

例程

说明

本属性用于获取画板高度。画板高度=高度-边框高度。

参考：例程


取设备句柄 方法 操作系统支持：Windows 所属对象：画板

取设备句柄 方法 　英文命令：GetHDC　操作系统支持：Windows 所属对象：画板

为高级用户提供，初级用户无需掌握；
如当前用户程序正在处理本画板所产生的“绘画”事件，则返回画板所对应的设备句柄（即HDC），否则返回 0。

语法： 整数型 画板．取设备句柄 （）

例程

说明

通过“取设备句柄”命令获取指定画板的设备场景句柄。“取设备句柄”命令只在绘画事件子程序中好用。

参考：例程


清除 方法 操作系统支持：Windows 所属对象：画板

清除 方法 　英文命令：cls　操作系统支持：Windows 所属对象：画板

清除画板上指定区域的内容并将当前文本写出位置移动到被清除区左上角。

语法： 无返回值 画板．清除 （［清除区左上角横坐标］，［清除区左上角纵坐标］，［清除区宽度］，［清除区高度］）

参数名 | 描 述
清除区左上角横坐标 | 可选的；整数型。使用当前绘画单位，相对于画板左上角。如果被省略，默认为 0 。
清除区左上角纵坐标 | 可选的；整数型。使用当前绘画单位，相对于画板左上角。如果被省略，默认为 0 。
清除区宽度 | 可选的；整数型。使用当前绘画单位。如果被省略，默认为清除区左边到画板右边之间的宽度。
清除区高度 | 可选的；整数型。使用当前绘画单位。如果被省略，默认为清除区顶边到画板底边之间的高度。

例程

说明

通过“清除”命令将画板中指定区域清空。

参考：例程


取点 方法 操作系统支持：Windows 所属对象：画板

取点 方法 　英文命令：GetPixel　操作系统支持：Windows 所属对象：画板

返回画板上指定点的颜色值。如果失败，将返回 -1。

语法： 整数型 画板．取点 （点横坐标，点纵坐标）

参数名 | 描 述
点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“取点”命令获取画板中指定像素点的颜色值。

参考：例程


画点 方法 操作系统支持：Windows 所属对象：画板

画点 方法 　英文命令：SetPixel　操作系统支持：Windows 所属对象：画板

语法： 无返回值 画板．画点 （点横坐标，点纵坐标，欲画入点的颜色值）

参数名 | 描 述
点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
欲画入点的颜色值 | 必需的；整数型。

例程

说明

通过“画点”命令向画板的指定位置画一个指定颜色的点。

参考：例程


画直线 方法 操作系统支持：Windows 所属对象：画板

画直线 方法 　英文命令：LineTo　操作系统支持：Windows 所属对象：画板

使用画笔在画板上画出一条直线。

语法： 无返回值 画板．画直线 （起始点横坐标，起始点纵坐标，结束点横坐标，结束点纵坐标）

参数名 | 描 述
起始点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
起始点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
结束点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
结束点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“画直线”命令在画板中画一条直线。

参考：例程


画椭圆 方法 操作系统支持：Windows 所属对象：画板

画椭圆 方法 　英文命令：ellipse　操作系统支持：Windows 所属对象：画板

语法： 无返回值 画板．画椭圆 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“画椭圆”命令在画板上画一个指定大小的椭圆。

参考：例程


画弧线 方法 操作系统支持：Windows 所属对象：画板

画弧线 方法 　英文命令：ArcTo　操作系统支持：Windows 所属对象：画板

使用画笔在画板上画出一条弧线。

语法： 无返回值 画板．画弧线 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标，弧线起始点横坐标，弧线起始点纵坐标，弧线终止点横坐标，弧线终止点纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点横坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点纵坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点横坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点纵坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“画弧线”命令在画板中画出指定样式的弧线。

参考：例程


画弦 方法 操作系统支持：Windows 所属对象：画板

画弦 方法 　英文命令：chord　操作系统支持：Windows 所属对象：画板

语法： 无返回值 画板．画弦 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标，弧线起始点横坐标，弧线起始点纵坐标，弧线终止点横坐标，弧线终止点纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点横坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点纵坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点横坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点纵坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“画弦”命令在画板中画弦。

参考：例程


画饼 方法 操作系统支持：Windows 所属对象：画板

画饼 方法 　英文命令：pie　操作系统支持：Windows 所属对象：画板

语法： 无返回值 画板．画饼 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标，弧线起始点横坐标，弧线起始点纵坐标，弧线终止点横坐标，弧线终止点纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点横坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点纵坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点横坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点纵坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“画饼”命令在画板中画指定样式的饼。

参考：例程


画矩形 方法 操作系统支持：Windows 所属对象：画板

画矩形 方法 　英文命令：DrawRect　操作系统支持：Windows 所属对象：画板

使用画笔在画板上画出一个矩形，矩形的内部使用刷子填充。

语法： 无返回值 画板．画矩形 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“画矩形”命令在画板中画指定大小的矩形图象。

参考：例程


画渐变矩形 方法 操作系统支持：Windows 所属对象：画板

画渐变矩形 方法 　英文命令：DrawJBRect　操作系统支持：Windows 所属对象：画板

语法： 无返回值 画板．画渐变矩形 （矩形区域左边，矩形区域顶边，矩形区域宽度，矩形区域高度，［渐变方向］，首渐变颜色，其它渐变颜色，… ）

参数名 | 描 述
矩形区域左边 | 必需的；整数型。
矩形区域顶边 | 必需的；整数型。
矩形区域宽度 | 必需的；整数型。
矩形区域高度 | 必需的；整数型。
渐变方向 | 可选的；整数型。参数值可以为以下常量值之一： 1、#从上到下； 2、#从左到右； 3、从左上到右下； 4、从右上到左下； 5、从下到上； 6、从右到左； 7、从右下到左上； 8、从左下到右上。 如果本参数被省略，默认为“#从左到右”。
首渐变颜色 | 必需的；整数型。
其它渐变颜色 | 必需的；可扩充的；整数型。

例程

说明

通过“画渐变矩形”命令在画板中画指定大小的渐变矩形。

参考：例程


填充矩形 方法 操作系统支持：Windows 所属对象：画板

填充矩形 方法 　英文命令：FillRect　操作系统支持：Windows 所属对象：画板

将画板上指定的矩形区域用当前刷子填充。

语法： 无返回值 画板．填充矩形 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“填充矩形”命令在画板中画一个填充矩形。

参考：例程


画圆角矩形 方法 操作系统支持：Windows 所属对象：画板

画圆角矩形 方法 　英文命令：RoundRect　操作系统支持：Windows 所属对象：画板

使用画笔在画板上画出一个圆角矩形，圆角矩形的内部使用刷子填充。

语法： 无返回值 画板．画圆角矩形 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标，圆角宽度，［圆角高度］）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
圆角宽度 | 必需的；整数型。使用当前绘画单位。
圆角高度 | 可选的；整数型。使用当前绘画单位。如果省略本参数，默认与圆角宽度相等。

例程

说明

通过“画圆角矩形”命令在画板中画一个指定样式的圆角矩形。

参考：例程


翻转矩形区 方法 操作系统支持：Windows 所属对象：画板

翻转矩形区 方法 　英文命令：InvertRect　操作系统支持：Windows 所属对象：画板

将画板上指定矩形区域的颜色翻转过来。

语法： 无返回值 画板．翻转矩形区 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“翻转矩形区”命令将画板中指定区域的设备场景翻转。

参考：例程


画多边形 方法 操作系统支持：Windows 所属对象：画板

画多边形 方法 　英文命令：polygon　操作系统支持：Windows 所属对象：画板

如果所画的多边形没有闭合，将自动闭合。

语法： 无返回值 画板．画多边形 （多边形顶点，［顶点数目］）

参数名 | 描 述
多边形顶点 | 必需的；整数型，参数数据只能提供数组数据。本参数数组顺序记录多边形各顶点的横向及纵向坐标值。使用当前绘画单位，相对于画板或打印纸左上角。
顶点数目 | 可选的；整数型。本参数指定多边形顶点的总数目。如果被省略，默认为数组中所记录的顶点数目。

例程

说明

通过“画多边型”命令在画板中画出多个顶点相连组成的多边型。

参考：例程


置写出位置 方法 操作系统支持：Windows 所属对象：画板

置写出位置 方法 　英文命令：SetWritePos　操作系统支持：Windows 所属对象：画板

设置下次使用“写文本行”或“写出”命令输出数据时的位置。

语法： 无返回值 画板．置写出位置 （［横向写出位置］，［纵向写出位置］）

参数名 | 描 述
横向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行横向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。
纵向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行纵向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

通过“置写出位置”命令设置使用“写文本行”命令写出文本的位置。

注：在“置写出位置”之前已写出的文本无效。

参考：例程


写文本行 方法 操作系统支持：Windows 所属对象：画板

写文本行 方法 　英文命令：WriteLine　操作系统支持：Windows 所属对象：画板

在当前写出位置写出指定的文本、数值、逻辑值或日期时间，并将现行写出位置调整到下行行首。

语法： 无返回值 画板．写文本行 （［欲写出数据］，… ）

参数名 | 描 述
欲写出数据 | 可选的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。如果本参数被省略，则写出一个空行。

例程

说明

通过“写文本行”命令向画板中写出一段指定文本。

参考：例程


滚动写行 方法 操作系统支持：Windows 所属对象：画板

滚动写行 方法 　英文命令：sprint　操作系统支持：Windows 所属对象：画板

在当前写出位置写出指定的文本、数值、逻辑值或日期时间，并将现行写出位置调整到下行行首。如果现行画板高度无法容纳当前所要写出的行，则自动向上滚动画板内容。

语法： 无返回值 画板．滚动写行 （［欲写出数据］，… ）

参数名 | 描 述
欲写出数据 | 可选的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。如果本参数被省略，则写出一个空行。

例程

说明

通过“滚动写行”命令向画板中写入一行指定文本，本命令与“写文本行”不同的是，当画板中已满时“滚动写行”命令会自动滚屏。

参考：例程


写出 方法 操作系统支持：Windows 所属对象：画板

写出 方法 　英文命令：write　操作系统支持：Windows 所属对象：画板

在当前写出位置处写出指定的文本、数值、逻辑值或日期时间。自动调整现行写出位置到所写出数据的末位置。

语法： 无返回值 画板．写出 （［欲写出数据］，… ）

参数名 | 描 述
欲写出数据 | 可选的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。如果本参数被省略，则写出一个空行。

例程

说明

通过“写出”命令向画板中写出一段文本。与“写文本行”命令不同的是，“写出”命令并不会自动换行。

参考：例程


定位写出 方法 操作系统支持：Windows 所属对象：画板

定位写出 方法 　英文命令：say　操作系统支持：Windows 所属对象：画板

在指定写出位置处写出指定的文本、数值、逻辑值或日期时间，不改变现行写出位置。

语法： 无返回值 画板．定位写出 （［横向写出位置］，［纵向写出位置］，欲写出数据，… ）

参数名 | 描 述
横向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行横向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。
纵向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行纵向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。
欲写出数据 | 必需的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。

例程

说明

通过“定位写出”命令在画板中指定位置写出一段文本。

参考：例程


取宽度 方法 操作系统支持：Windows 所属对象：画板

取宽度 方法 　英文命令：GetWidth　操作系统支持：Windows 所属对象：画板

返回指定数据的写出宽度，使用当前绘画单位。

语法： 整数型 画板．取宽度 （欲取其宽度或高度的数据）

参数名 | 描 述
欲取其宽度或高度的数据 | 必需的；通用型。参数值只能为文本、数值、逻辑值或日期时间。

例程

说明

通过“取宽度”命令取得指定文本在画板中画出时所占用的宽度。

参考：例程


取高度 方法 操作系统支持：Windows 所属对象：画板

取高度 方法 　英文命令：GetHeight　操作系统支持：Windows 所属对象：画板

返回指定数据的写出高度，使用当前绘画单位。

语法： 整数型 画板．取高度 （欲取其宽度或高度的数据）

参数名 | 描 述
欲取其宽度或高度的数据 | 必需的；通用型。参数值只能为文本、数值、逻辑值或日期时间。

例程

说明

通过“取高度”命令取得指定文本在画板中画出时所占高度。

参考：例程


画图片 方法 操作系统支持：Windows 所属对象：画板

画图片 方法 　英文命令：DrawPic　操作系统支持：Windows 所属对象：画板

语法： 无返回值 画板．画图片 （图片号，图片左边画出位置，图片顶边画出位置，［图片画出宽度］，［图片画出高度］，［图片画出方法］）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。
图片左边画出位置 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
图片顶边画出位置 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
图片画出宽度 | 可选的；整数型。如果本参数被省略，则使用图片本身的宽度。使用当前绘画单位。
图片画出高度 | 可选的；整数型。如果本参数被省略，则使用图片本身的高度。使用当前绘画单位。
图片画出方法 | 可选的；整数型。本参数定义在将图像绘制到对象（画板 / 打印机）上时对图像执行的位操作。对“图标”类型图片无效。可以为以下常量值之一或者其它自定义操作码： 1、#拷贝； 2、#翻转拷贝； 3、#位异或； 4、#位或； 5、#位与本参数也可以指定透明色，但必须是负颜色数值。如： 画板1.画图片 (图片号, 0, 0, , , －取颜色值 (255, 255, 255)) 此语句的作用就是在画板上画出图片中除白色外的所有颜色。如果省略本参数，默认为“#拷贝”。

例程

说明

通过“画图片”命令将指定图片画到画板中。

参考：例程


取图片宽度 方法 操作系统支持：Windows 所属对象：画板

取图片宽度 方法 　英文命令：GetPicWidth　操作系统支持：Windows 所属对象：画板

返回指定图片的宽度，使用当前绘画单位。

语法： 整数型 画板．取图片宽度 （图片号）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。

例程

说明

通过“取图片宽度”命令获得指定图片的宽度。

参考：例程


取图片高度 方法 操作系统支持：Windows 所属对象：画板

取图片高度 方法 　英文命令：GetPicHeight　操作系统支持：Windows 所属对象：画板

返回指定图片的高度，使用当前绘画单位。

语法： 整数型 画板．取图片高度 （图片号）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。

例程

说明

通过“取图片高度”命令获取指定图片的高度。

参考：例程


复制 方法 操作系统支持：Windows 所属对象：画板

复制 方法 　英文命令：copy　操作系统支持：Windows 所属对象：画板

将源画板（本命令的调用画板对象）中指定区域的内容快速复制到目的画板中的指定位置，使用源和目的画板各自的当前绘画单位。如果源画板当前不可视，其“自动重画”属性必须为真。

语法： 无返回值 画板．复制 （［欲复制区域的左边］，［欲复制区域的顶边］，［欲复制区域的宽度］，［欲复制区域的高度］，［复制到的目的画板］，［欲复制到位置左边］，［欲复制到位置顶边］，［复制方法］）

参数名 | 描 述
欲复制区域的左边 | 可选的；整数型。如果本参数被省略，默认值为 0 。使用源画板的当前绘画单位。
欲复制区域的顶边 | 可选的；整数型。如果本参数被省略，默认值为 0 。使用源画板的当前绘画单位。
欲复制区域的宽度 | 可选的；整数型。如果本参数被省略，默认等同于源画板的宽度。使用源画板的当前绘画单位。
欲复制区域的高度 | 可选的；整数型。如果本参数被省略，默认等同于源画板的高度。使用源画板的当前绘画单位。
复制到的目的画板 | 可选的；画板。如果本参数被省略，默认为复制到源画板对象。
欲复制到位置左边 | 可选的；整数型。如果本参数被省略，默认值为 0 。使用目的画板的当前绘画单位。
欲复制到位置顶边 | 可选的；整数型。如果本参数被省略，默认值为 0 。使用目的画板的当前绘画单位。
复制方法 | 可选的；整数型。本参数定义在将画板内容复制到目的画板上时对图像执行的位操作。可以为以下常量值之一或者其它自定义操作码： 1、#拷贝； 2、#翻转拷贝； 3、#位异或； 4、#位或； 5、#位与。 如果省略本参数，默认为“#拷贝”。

例程

说明

通过“复制”命令将一个画板中指定区域的内容复制到另一个画板中指定区域。

参考：例程


取图片 方法 操作系统支持：Windows 所属对象：画板

取图片 方法 　英文命令：GetPic　操作系统支持：Windows 所属对象：画板

返回画板上所有现有显示内容的图片数据。如果失败，返回空字节集。

语法： 字节集 画板．取图片 （［输出宽度］，［输出高度］）

参数名 | 描 述
输出宽度 | 可选的；整数型。指定图片的输出宽度。如果小于0，参数值指定的是最终图片输出宽度相对于所取得图片宽度的百分比（最小为10%）；如果等于0，则按图片原宽度输出；如果大于0，指定输出图片的绝对宽度。如果本参数被省略，默认值为0。
输出高度 | 可选的；整数型。指定图片的输出高度。如果小于0，参数值指定的是最终图片输出高度相对于所取得图片高度的百分比（最小为10%）；如果等于0，则按图片原高度输出；如果大于0，指定输出图片的绝对高度。如果本参数被省略，默认值为0。

例程

说明

通过“取图片”命令将画板中的图片输出为指定宽度和大小的图片。

参考：例程


单位转换 (画板)

单位转换 方法 操作系统支持：Windows 所属对象：画板

将像素单位座标值转换到画板的当前绘画单位，或将画板的当前绘画单位座标值转换到像素单位。

语法： 整数型 画板．单位转换 （欲转换的座标值， 欲转换座标值的类型）

参数名 | 描 述
欲转换的座标值 | 必需的； 整数型。提供欲转换的横向或纵向座标值。
欲转换座标值的类型 | 必需的； 整数型。可以为以下常量值之一： 1：#横向绘画单位； 2：#纵向绘画单位； 3：#横向像素单位； 4：#纵向像素单位。 根据所提供的类型值，将进行相反的单位转换，即将绘画单位转换到像素单位，将像素单位转换到绘画单位。

例程

说明：

将像素单位座标值转换到画板的当前绘画单位，或将画板的当前绘画单位座标值转换到像素单位。

参见：例程


绘画 事件 所属对象：画板 操作系统支持：Windows

当画板中的全部或一部分区域需要被重新绘制时即产生此事件。用户程序在响应此事件期间在画板上所进行的任何绘制操作均被限制在“需重画区”参数所指定的区域内。

语法： 无返回值 _画板_绘画 （重画区左边，重画区上边，重画区右边，重画区下边）

参数名 | 描 述
重画区左边 | 整数型；本参数提供目前画板中需要更新的矩形区域的左边，使用现行绘画单位，用作提高绘画速度，一般情况下可以不处理。
重画区上边 | 整数型；本参数提供目前画板中需要更新的矩形区域的顶边，使用现行绘画单位，用作提高绘画速度，一般情况下可以不处理。
重画区右边 | 整数型；本参数提供目前画板中需要更新的矩形区域的右边，使用现行绘画单位，用作提高绘画速度，一般情况下可以不处理。
重画区下边 | 整数型；本参数提供目前画板中需要更新的矩形区域的底边，使用现行绘画单位，用作提高绘画速度，一般情况下可以不处理。

例程

说明

当本事件的拥有者重画或内容被改变时，会触发此事件。

参考：例程


分组框

分组框 容器型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
标题 | 对齐方式 | 文本颜色 | 背景颜色
字体 |  |  |

基本事件：


标题 属性 数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

应用对象：

窗口、分组框、标签、按钮、选择框、单选框、超级链接框、通用对话框、菜单、超文本浏览框、透明标签、超级按钮

例程：

说明：

设置分组框标题文本。

参见：例程


对齐方式 属性 数据类型：整数型；

将整数型数据赋值到指定对象的对齐方式属性中

语法： 对象.对齐方式 = 整数型

应用对象：

分组框

可供选择的属性值：
0、左边
1、居中
2、右边

例程：

说明：

设置分组框标题的显示位置。

参见：例程


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

编辑框、画板、分组框、标签、选择框、单选框、组合框、列表框、月历、驱动器框、文件框、超级链接框、打印机、树型框、超级列表框、透明标签

例程：

说明：

设置分组框标题文本颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

编辑框、图片框、外形框、分组框、标签、选择框、单选框、组合框、列表框、月历、驱动器框、目录框、文件框、超级链接框、表格、树型框、状态条、工具条、超级列表框、高级影像框、分隔条、超级编辑框

例程：

说明：

设置分组框背景颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

编辑框、组合框、分组框

例程：

说明：

加粗分组框标题字体。

参见：例程


标签

标签 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
标题 | 效果 | 边框 | 渐变边框宽度
渐变边框颜色1 | 渐变边框颜色2 | 渐变边框颜色3 | 字体
文本颜色 | 背景颜色 | 底图 | 底图方式
渐变背景方式 | 渐变背景颜色1 | 渐变背景颜色2 | 渐变背景颜色3
横向对齐方式 | 是否自动折行 | 纵向对齐方式 | 数据源
数据列 |  |  |

方法：

调用反馈事件

自有事件：

反馈事件

基本事件：


标题 属性 数据类型：文本型；

将文本型 数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

应用对象：

窗口

例程:

说明：

设置标签的标题文本。

参见：例程


效果 属性 数据类型：整数型；

将整数型数据赋值到指定对象的效果属性中

语法： 对象.效果 = 整数型

应用对象：

标签

可供选择的属性值：
0、通常
1、凹入
2、凸出
3、阴影

例程：

说明：

设置标签标的显示效果。

参见：例程


边框 属性 数据类型：整数型；

本属性指定对象边框的类型。

语法： 对象.边框 = 整数型

应用对象：

窗口、编辑框、图片框、画板、标签、列表框、选择列表框、进度条、滑块条、日期框、月历、目录框、文件框、超级链接框、树型框、超级列表框、超级编辑框

例程：

说明：

设置标签显示边框类型。

参见：例程


渐变边框宽度 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变边框宽度属性中

语法： 对象.渐变边框宽度 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在边框为渐变镜框式的时候才有效。本属性用来设置标签的渐变边框的宽度。

参见：例程 例程2


渐变边框颜色1 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变边框颜色1属性中

语法： 对象.渐变边框颜色1 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在边框为渐变镜框式的时候才有效。本属性用来描绘标签的边框外观。颜色选择器对应一种渐变颜色，3种颜色交互成渐变状。

参见：例程 例程2


渐变边框颜色1 属性 数据类型：整数型；

渐变边框颜色2 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变边框颜色2属性中

语法： 对象.渐变边框颜色2 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在边框为渐变镜框式的时候才有效。本属性用来描绘标签的边框外观。颜色选择器对应一种渐变颜色，3种颜色交互成渐变状。

参见：例程 例程2


渐变边框颜色1 属性 数据类型：整数型；

渐变边框颜色3 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变边框颜色3属性中

语法： 对象.渐变边框颜色3 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在边框为渐变镜框式的时候才有效。本属性用来描绘标签的边框外观。颜色选择器对应一种渐变颜色，3种颜色交互成渐变状。

参见：例程 例程2


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

编辑框、组合框

例程：

说明：

加粗编辑框中文本内容的字体。

参见：例程


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

编辑框、画板、分组框、标签、选择框、单选框、组合框、列表框、月历、驱动器框、文件框、超级链接框、打印机、树型框、超级列表框、透明标签

例程：

说明：

设置标签标题的文本颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

编辑框、图片框、外形框、分组框、标签、选择框、单选框、组合框、列表框、月历、驱动器框、目录框、文件框、超级链接框、表格、树型框、状态条、工具条、超级列表框、高级影像框、分隔条、超级编辑框

例程：

说明：

设置标签背景颜色。

参见：例程


底图 属性 数据类型：字节集；

本属性指定显示在对象背景上的图片。

语法： 对象.底图 = 字节集

应用对象：

窗口、画板、标签

例程：

说明：

设置标签底图。

参见：例程


效果 属性 数据类型：整数型；

底图方式 属性 数据类型：整数型；

将整数型数据赋值到指定对象的底图方式属性中

语法： 对象. 底图方式 = 整数型

应用对象：

标签

可供选择的属性值：
0、图片居左上
1、图片平铺
2、图片居中

例程：

说明：

本属性设置标签底图的显示形式。

参见：例程


渐变背景方式 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变背景方式属性中

语法： 对象.渐变背景方式 = 整数型

应用对象：

标签

可供选择的属性值：
0、无渐变背景
1、从上到下
2、从左到右
3、从左上到右下
4、从右上到左下
5、从下到上
6、从右到左
7、从右下到左上
8、从左下到右上

例程：

说明：

本属性只有在未设定底图的前提下才有效。让标签的背景呈3种颜色的交互状。

利用组合框的项目索引设置渐变背景方式。

参见：例程 例程2


渐变背景颜色1 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变背景颜色1属性中

语法： 对象.渐变背景颜色1 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在有渐变背景的前提下才有效。将颜色选择器中选中的颜色赋给渐变背景颜色2，使标签的背景呈3种颜色的交互状。

参见：例程 例程2


渐变背景颜色1 属性 数据类型：整数型；

渐变背景颜色2 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变背景颜色2属性中

语法： 对象.渐变背景颜色2 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在有渐变背景的前提下才有效。将颜色选择器中选中的颜色赋给渐变背景颜色2，使标签的背景呈3种颜色的交互状。

参见：例程 例程2


渐变背景颜色1 属性 数据类型：整数型；

渐变背景颜色3 属性 数据类型：整数型；

将整数型数据赋值到指定对象的渐变背景颜色3属性中

语法： 对象.渐变背景颜色3 = 整数型

应用对象：

标签

例程：

说明：

本属性只有在有渐变背景的前提下才有效。将颜色选择器中选中的颜色赋给渐变背景颜色3，使标签的背景呈3种颜色的交互状。

参见：例程 例程2


横向对齐方式 属性 数据类型：整数型；

设置对象内容的横向对齐方式。

可供选择的属性值：
0、左对齐
1、居中
2、右对齐

语法： 对象.横向对齐方式 = 整数型

应用对象：

标签、按钮、选择框、单选框、透明标签

例程：

说明：

设置标签标题文本的横向对齐方式。

参见：例程


是否自动折行 属性 数据类型：逻辑型；

本属性设定当文本内容超出右界后是否自动转到下一行显示。

语法： 对象.是否自动折行 = 逻辑型

应用对象：

标签、透明标签

例程：

说明：

设置标签的标题文字可以自动折行。

参见：例程


纵向对齐方式 属性 数据类型：整数型；

如果选用自动折行则本属性无效。

可供选择的属性值：
0、顶对齐
1、居中
2、底对齐

语法： 对象.纵向对齐方式 = 整数型

应用对象：

标签、按钮、选择框、单选框、透明标签

例程：

说明：

设置标签标题文字的纵向对齐方式。

参见：例程


数据源 属性 数据类型：文本型；

指定提供数据的数据源组件名。

语法： 对象.数据源 = 文本型

应用对象：

编辑框、图片框、标签、选择框、组合框、列表框、日期框、表格

例程：

说明：

设置标签的数据源。

参见：例程 用到的数据库


数据列 属性 数据类型：文本型；

指定数据源中的数据列，可以是列名或以1开始的列序号文本。

语法： 对象.数据列 = 文本型

应用对象：

编辑框、图片框、标签、选择框、组合框、列表框、日期框

例程：

说明：

连接数据库中指定的字段，并显示。

参见：例程 用到的数据库


调用反馈事件 方法 操作系统支持：Windows 所属对象：标签

产生标签的反馈事件，以调用此标签的“反馈事件”用户事件处理子程序，可以用作在多线程处理中将控制权转移到程序主线程上去执行。返回用户事件处理子程序所返回的值，如果没有相应的事件处理子程序或采用投递方式传递事件消息，将返回零。

语法： 整数型 标签．调用反馈事件 （［参数一］，［参数二］，［事件传递方式］）

参数名 | 描 述
参数一 | 可选的；整数型。为反馈事件所携带的第一个参数，如果被省略，默认值为零。
参数二 | 可选的；整数型。为反馈事件所携带的第二个参数，如果被省略，默认值为零。
事件传递方式 | 可选的；逻辑型。为真则采用发送方式传递事件消息，此时本命令将一直等待到“反馈事件”用户事件处理子程序处理完毕后才返回，为假则采用投递方式传递事件消息，此时本命令将直接返回且不等待用户事件处理子程序处理完毕（用户事件处理子程序将在空闲时被调用）。如果本参数被省略，默认采用发送方式传递事件。

例程:

说明:

要在线程中销毁组件必须调用标签的反馈事件来处理，否则系统将非法操作。

参见：例程


反馈事件 事件 所属对象：标签 操作系统支持：Windows

本事件用作与外部DLL交互，事件子程序处理完毕后可以根据需要决定是否返回值。

语法： 整数型 _标签_反馈事件 （参数一，参数二）

参数名 | 描 述
参数一 | 整数型；反馈事件所带过来的第一个参数。
参数二 | 整数型；反馈事件所带过来的第二个参数。

例程：

说明：

要在线程中销毁组件必须调用标签的反馈事件来处理，否则系统将非法操作。

参见：例程


按钮

按钮 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
图片 | 类型 | 标题 | 横向对齐方式
纵向对齐方式 | 字体 |  |

自有事件：

被单击

基本事件：


图片 属性 数据类型：字节集；

本属性指定显示在对象上的图片。

语法： 对象.图片 = 字节集

应用对象：

图片框、按钮、选择框、单选框

例程：

说明：

设置按钮背景显示的图片——将图片常量所指定的图片资源数据赋值给按钮的“图片”属性。

按钮的“图片”属性可以直接在属性面板中设置。

参见：例程


横向对齐方式 属性 数据类型：整数型；

类型 属性 数据类型：整数型；

将整数型数据赋值到指定对象的类型属性中

当在窗口上按下Enter键时，如果没有将窗口的“回车下移输入点”属性设置为真，则等同于按下了具有“默认”类型的按钮。因此具有“默认”类型的按钮在同一窗口上应当只有一个。“通常”类型的按钮无对应的操作默认键。

可供选择的属性值：
0、通常
1、默认

语法： 对象.类型 = 整数型

应用对象：

按钮

例程：

说明：

一般情况下，都使用“通常”类型，“默认”类型只是多了一个默认回车键的功能，而在同一窗体里只能有一个“默认”类型的按钮。

通常使用属性面板设置该属性的值。

参见：例程


标题 属性 数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

应用对象：

窗口、分组框、标签、按钮、选择框、单选框、超级链接框、通用对话框、菜单、超文本浏览框、透明标签、超级按钮

例程：

说明：

设置按钮标题文字。

参见：例程


横向对齐方式 属性 数据类型：整数型；

设置对象内容的横向对齐方式。

可供选择的属性值：
0、左对齐
1、居中
2、右对齐

语法： 对象.横向对齐方式 = 整数型

应用对象：

标签、按钮、选择框、单选框、透明标签

例程：

说明：

设置按钮标题文字的横向对齐设置为“右对齐”。

参见：例程


纵向对齐方式 属性 数据类型：整数型；

如果选用自动折行则本属性无效。

可供选择的属性值：
0、顶对齐
1、居中
2、底对齐

语法： 对象.纵向对齐方式 = 整数型

应用对象：

标签、按钮、选择框、单选框、透明标签

例程：

说明：

设置按钮标题文字的纵向对齐方式设置为“底对齐”。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

编辑框、组合框

例程：

说明：

加粗按钮标题字体文字。

参见：例程


被单击 事件 所属对象：按钮 操作系统支持：Windows

当单击按钮后即产生此事件。

语法： 无返回值 _按钮_被单击 （）

例程：

说明：

只有鼠标左键单击按钮时触发此事件。

参见：例程


选择框

选择框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
图片 | 按钮形式 | 平面 | 标题
标题居左 | 横向对齐方式 | 纵向对齐方式 | 文本颜色
背景颜色 | 字体 | 选中 | 数据源
数据列 |  |  |

自有事件：

被单击

基本事件：


图片 属性 数据类型：字节集；

本属性指定显示在对象上的图片。

语法： 对象.图片 = 字节集

例程：

说明：

设置和清除选择框背景图片。

参见：例程


按钮形式 属性 数据类型：逻辑型；

将对象的外形改称按钮形式。

语法： 对象.按钮形式 = 逻辑型

例程：

说明：

设置选择框外形形式。

参见：例程


平面 属性 数据类型：逻辑型；

将对象的样式改为平面样式。

语法： 对象.平面 = 逻辑型

例程：

说明：

设置选择框显示样式。

参见：例程


标题 属性 数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

例程：

说明：

设置选择框标题文字。

参见：例程


标题居左 属性 数据类型：逻辑型；

把对象的标题放置在左边。

语法： 对象.标题居左 = 逻辑型

例程：

说明：

设置选择框标题文字到左边。

参见：例程


横向对齐方式 属性 数据类型：整数型；

设置对象内容的横向对齐方式。

可供选择的属性值：
0、左对齐
1、居中
2、右对齐

语法： 对象.横向对齐方式 = 整数型

例程：

说明：

设置选择框的横向对齐方式。

参见：例程


纵向对齐方式 属性 数据类型：整数型；

如果选用自动折行则本属性无效。

可供选择的属性值：
0、顶对齐
1、居中
2、底对齐

语法： 对象.纵向对齐方式 = 整数型

例程：

说明：

设置选择框的纵向对齐方式。

参见：例程


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

例程：

说明：

设置选择框标题文字的文本颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

例程：

说明：

设置选择框背景颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程：

说明：

加粗选择框标题文字字体。

参见：例程


选中 属性 数据类型：逻辑型；

选中对象。

语法： 对象.选中 = 逻辑型

例程：

说明：

设置选择框的选中状态。

参见：例程


数据源 属性 数据类型：文本型；

指定提供数据的数据源组件名。

语法： 对象.数据源 = 文本型

例程：

说明：

设置选择框的数据库路径。

参见：例程 数据库下载


数据列 属性 数据类型：文本型；

指定数据源中的数据列，可以是列名或以1开始的列序号文本。

语法： 对象.数据列 = 文本型

例程：

说明：

连接数据库逻辑型字段。

参见：例程 数据库下载


被单击 事件 所属对象：选择框 操作系统支持：Windows

当单击选择框后即产生此事件。

语法： 无返回值 _选择框_被单击 （）

例程：

说明：

只要鼠标左键点击，就触发此事件。

根据选中状态弹出不同信息框。

参见：例程


单选框

单选框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
图片 | 按钮形式 | 平面 | 标题
标题居左 | 横向对齐方式 | 纵向对齐方式 | 文本颜色
背景颜色 | 字体 | 选中 |

自有事件：

被单击

基本事件：


图片 属性 数据类型：字节集；

本属性指定显示在对象上的图片。

语法： 对象.图片 = 字节集

例程：

说明：

设置单选框的背景图片。

参见：例程


按钮形式 属性 数据类型：逻辑型；

将对象的外形改称按钮形式。

语法： 对象.按钮形式 = 逻辑型

例程：

说明：

设置单选框外形形式。

参见：例程


平面 属性 数据类型：逻辑型；

将对象的样式改为平面样式。

语法： 对象.平面 = 逻辑型

例程：

说明：

设置单选框的显示样式。

参见：例程


标题 属性 数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

例程：

说明：

设置单选框标题文本。

参见：例程


标题居左 属性 数据类型：逻辑型；

把对象的标题放置在左边。

语法： 对象.标题居左 = 逻辑型

例程：

说明：

设置单选框标题文本到左边。

参见：例程


横向对齐方式 属性 数据类型：整数型；

设置对象内容的横向对齐方式。

可供选择的属性值：
0、左对齐
1、居中
2、右对齐

语法： 对象.横向对齐方式 = 整数型

例程：

说明：

设置单选框标题文本横向对齐方式。

参见：例程


纵向对齐方式 属性 数据类型：整数型；

如果选用自动折行则本属性无效。

可供选择的属性值：
0、顶对齐
1、居中
2、底对齐

语法： 对象.纵向对齐方式 = 整数型

例程：

说明：

设置单选框标题文本的纵向对齐方式。

参见：例程


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

例程：

说明：

设置单选框标题的文本颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

例程：

说明：

设置单选框背景颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程：

说明：

设置单选框标题文字字体。

参见：例程


选中 属性 数据类型：逻辑型；

选中对象。

语法： 对象.选中 = 逻辑型

例程：

说明：

设置单选框的选中状态。

参见：例程


被单击 事件 所属对象：单选框 操作系统支持：Windows

当单击单选框后即产生此事件。

语法： 无返回值 _单选框_被单击 （）

例程：

说明：

只要鼠标对单选框进行点击，就触发此事件。

参见：例程


组合框

组合框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
类型 | 内容 | 最大文本长度 | 起始选择位置
被选择字符数 | 被选择文本 | 自动排序 | 行间距
文本颜色 | 背景颜色 | 字体 | 现行选中项
列表项目 | 项目数值 | 数据源 | 数据列

方法：

取顶端可见项目 | 置顶端可见项目 | 取项目数 | 取项目数值
置项目数值 | 取项目文本 | 置项目文本 | 加入项目
插入项目 | 删除项目 | 清空 | 选择

自有事件：

列表项被选择 | 编辑内容被改变 | 将弹出列表 | 列表被关闭
双击选择 |  |  |

基本事件：


类型 属性 所属对象：组合框

类型 属性 数据类型：整数型；

可供选择的属性值：
0、可编辑列表式
1、可编辑下拉式
2、不可编辑下拉式

语法： 对象.类型 = 整数型

例程：

说明：

根据按钮标题的提示，设置组合框的显示类型。

参见：例程


内容 属性 数据类型：文本型；

本属性指定对象的内容。

语法： 对象.内容 = 文本型

例程：

说明：

选中组合框项目与此内容相同的项目。

参见：例程


最大文本长度 属性 所属对象：组合框

最大文本长度 属性 数据类型：整数型；

本属性指定在下拉列表框的编辑部分所允许输入的最大文本长度，为0表示没有限制。当类型为“不可编辑下拉式”时，本属性无效。

语法： 对象.内容 = 整数型

例程：

说明：

设置组合框内容的长度。

注：类型为“不可编辑下拉式”时，本属性无效。

参见：例程


起始选择位置 属性 数据类型：整数型；

返回或设置所选择文本的起始点；0 为位置 1 ，1 为位置 2，如此类推。如果没有文本被选中，则指出光标位置。如果设置位置时使用值 -1，则将当前光标位置移动到文本尾部。

语法： 对象.起始选择位置 = 整数型

例程：

说明：

设置组合框内容的起始选择位置。被选择字符数量半角为1，全角为2。

参见：例程


被选择字符数 属性 所属对象：组合框

被选择字符数 属性 数据类型：整数型；

本返回或设置所选择的字符数。如果设置字符数时使用值 -1，则选择所有文本。当类型为“不可编辑下拉式”时，本属性无效。

语法： 对象.被选择字符数 = 整数型

例程：

说明：

选中组合框文本的数量。一个全角字符为2 ，一个半角字符为1。

注：类型为“不可编辑下拉式”时，本属性无效。

参见：例程


被选择文本 属性 数据类型：文本型；

设计时不可用；返回或替换当前所选择的文本。

语法： 对象.被选择文本 = 文本型

例程：

说明：

显示组合框的被选择文本。

参见：例程


自动排序 属性 数据类型：逻辑型；

设定对象的内容是否需要排序，默认为“假”，即不自动排序。

语法： 对象.自动排序 = 逻辑型

例程：

说明：

设置组合框的自动排序属性。

参见：例程


行间距 属性 数据类型：整数型；

设置对象内容的行之间的距离。

语法： 对象.行间距 = 整数型

例程：

说明：

设置组合框各项目之间的距离。

参见：例程


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

例程：

说明：

设置组合框内容的文本颜色。

本属性只有类型为不可编辑下拉式才有效。

参见：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

例程：

说明：

设置组合框背景的颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程：

说明：

设置组合框内容的字体。

参见：例程


现行选中项 属性 数据类型：整数型；

本属性指定对象中现行被选中的列表项目的位置，位置值从 0 开始， -1 表示现行没有被选中的列表项。

语法： 对象.现行选中项 = 整数型

例程：

说明：

通过现行选中项目的索引，设置标签背景颜色的排列方式。

参见：例程


列表项目 属性 数据类型：字节集；

本属性指定各列表项目。

语法： 对象.列表项目 = 整数型

例程：

说明：

首先保存列表项目到文件，清空列表项目后从新读入列表项目。

参见：例程


项目数值 属性 所属对象：列表框 操作系统支持：Windows

项目数值 属性 操作系统支持：Windows

数据类型：字节集型；本属性指定与各列表项目相关联的数值，该数值在程序中可以被取出或修改。

例程：

说明：

取出当前选中项目的项目数值。

参见：例程


数据源 属性 数据类型：文本型；

指定提供数据的数据源组件名。

语法： 对象.数据源 = 文本型

例程：

说明：

连接指定的数据提供者。数据源属性必需连接有数据源组件，数据源组件的数据库提供者必需连接数据库提供者组件，数据库提供者组件的数据库文件名属性必需有一个有效的数据库文件路径。

参见：例程 数据库下载


数据列 属性 数据类型：文本型；

指定数据源中的数据列，可以是列名或以1开始的列序号文本。

语法： 对象.数据列 = 文本型

例程：

说明：

连接指定数据库的字段。数据源属性必需连接有数据源组件，数据源组件的数据库提供者必需连接数据库提供者组件，数据库提供者组件的数据库文件名属性必需有一个有效的数据库文件路径。

参见：例程


取顶端可见项目 方法 所属对象：组合框

取顶端可见项目 方法 　英文命令：GetTopIndex　所属对象：组合框

返回组合框列表部分中当前最顶端可见项目的索引。0 为项目一，1 为项目二，如此类推。失败返回 -1 。

语法： 整数型 组合框．取顶端可见项目 （）

例程：

说明：

取得组合框的顶端可见项目的索引。

注：组合框的类型必须为可编辑列表式，否则本方法无效。

参见：例程


置顶端可见项目 方法 所属对象：组合框

置顶端可见项目 方法 　英文命令：SetTopIndex　所属对象：组合框

设置组合框列表部分中当前最顶端的可见项目，必要时将自动滚动组合框的列表部分。成功返回真，失败返回假。

语法： 逻辑型 组合框．置顶端可见项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

设置组合框的顶端可见项目。

注：组合框的类型必须为可编辑列表式，否则此方法无效。

参见：例程


取项目数 方法 所属对象：组合框

取项目数 方法 　英文命令：GetCount　所属对象：组合框

语法： 整数型 组合框．取项目数 （）

例程：

说明：

取出组合框的项目数，用信息框显示出来。

参见：例程


取项目数值 方法 所属对象：组合框

取项目数值 方法 　英文命令：GetItemData　所属对象：组合框

返回与指定项目相关联的数值。如果指定项目不存在，将返回 -1 。

语法： 整数型 组合框．取项目数值 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取出组合框项目的数值，例程中所取得的是组合框当前选中项目的数值。

参见：例程


置项目数值 方法 所属对象：组合框

置项目数值 方法 　英文命令：SetItemData　所属对象：组合框

设置与指定项目相关联的数值。成功返回真，失败返回假。

语法： 逻辑型 组合框．置项目数值 （项目索引，欲置入的项目数值）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目数值 | 必需的；整数型。该项目数值与指定项目相关联。

例程：

说明：

设置组合框项目数值。

参见：例程


取项目文本 方法 所属对象：组合框

取项目文本 方法 　英文命令：GetItemText　所属对象：组合框

返回指定项目的文本。如果指定项目不存在，将返回空文本。

语法： 文本型 组合框．取项目文本 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

使用信息框显示取出的项目文本。

参见：例程


置项目文本 方法 所属对象：组合框

置项目文本 方法 　英文命令：SetItemtext　所属对象：组合框

设置指定项目的文本。成功返回真，失败返回假。

语法： 逻辑型 组合框．置项目文本 （项目索引，欲置入的项目文本）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目文本 | 必需的；文本型。

例程：

说明：

修改组合框项目文本。

参见：例程


加入项目 方法 所属对象：组合框

加入项目 方法 　英文命令：AddString　所属对象：组合框

加入指定项目到组合框列表部分的尾部，成功返回加入后该项目所处的位置，失败返回 -1 。

语法： 整数型 组合框．加入项目 （欲加入项目的文本，［与欲加入项目相关的数值］）

参数名 | 描 述
欲加入项目的文本 | 必需的；文本型。
与欲加入项目相关的数值 | 可选的；整数型。如果省略本参数，默认值为 0。

例程：

说明：

添加项目。

参见：例程


插入项目 方法 所属对象：组合框

插入项目 方法 　英文命令：InsertString　所属对象：组合框

插入指定项目到组合框列表部分的指定位置处，成功返回插入后该项目所处的位置，失败返回 -1 。

语法： 整数型 组合框．插入项目 （欲插入的位置，欲插入项目的文本，［与欲插入项目相关的数值］）

参数名 | 描 述
欲插入的位置 | 必需的；整数型。0 为项目位置一，1 为项目位置二，如此类推。
欲插入项目的文本 | 必需的；文本型。
与欲插入项目相关的数值 | 可选的；整数型。如果省略本参数，默认值为 0。

例程：

说明：

在组合框指定位置插入一个新项目。

参见：例程


删除项目 方法 所属对象：组合框

删除项目 方法 　英文命令：DeleteString　所属对象：组合框

删除组合框列表部分指定位置处的项目。成功返回真，失败返回假。

语法： 逻辑型 组合框．删除项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

删除组合框中的指定项目。

参见：例程


清空 方法 所属对象：组合框

清空 方法 　英文命令：zap　所属对象：组合框

删除组合框列表部分中的所有项目。

语法： 无返回值 组合框．清空 （）

例程：

说明：

清除组合框的所有项目。

参见：例程


选择 方法 所属对象：组合框

选择 方法 　英文命令：iif　所属对象：组合框

在所有项目中寻找首部包含指定文本的项目，如找到，则选中它，并返回该项目的位置索引，否则返回 -1。

语法： 整数型 组合框．选择 （欲选择的项目文本）

参数名 | 描 述
欲选择的项目文本 | 必需的；文本型。

例程：

说明：

选中指定项目名称的项目。

参见：例程


列表项被选择 事件 所属对象：组合框 操作系统支持：Windows

语法： 无返回值 _组合框_列表项被选择 （）

例程：

说明：

只要列表框中的表项被选择，就触发此事件。

参见：例程


编辑内容被改变 事件 所属对象：组合框 操作系统支持：Windows

语法： 无返回值 _组合框_编辑内容被改变 （）

例程：

说明：

只要组合框中的内容一被改变，就触发此事件。

组合框不可编辑时，无法触发此事件。

参见：例程


将弹出列表 事件 所属对象：组合框 操作系统支持：Windows

在将弹出组合框的列表部分之前产生此事件。在处理此事件时，可以即时填充组合框中的列表项目。

语法： 无返回值 _组合框_将弹出列表 （）

例程：

说明：

只要组合框上的下拉按钮被按下，就触发此事件。

参见：例程


列表被关闭 事件 所属对象：组合框 操作系统支持：Windows

在关闭被弹出的组合框列表部分后产生此事件。

语法： 无返回值 _组合框_列表被关闭 （）

例程：

说明：

只要列表框中的下拉菜单被收回，就触发此事件。

参见：例程


双击选择 事件 所属对象：组合框 操作系统支持：Windows

当使用鼠标左键在某列表项目上双击时产生此事件。

语法： 无返回值 _组合框_双击选择 （）

例程：

说明：

只要组合框中的表项被双击，就触发此事件，运行此事件下的代码。

注：只有在“可编辑下拉式”和“可编辑列表式”时才会触发此事件。

参见：例程


列表框

列表框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 自动排序 | 多列 | 行间距
文本颜色 | 背景颜色 | 字体 | 允许选择多项
现行选中项 | 列表项目 | 项目数值 | 数据源
数据列 |  |  |

方法：

取顶端可见项目 | 置顶端可见项目 | 取项目数 | 取项目数值
置项目数值 | 取项目文本 | 置项目文本 | 取已选择项目数
取所有被选择项目 | 是否被选择 | 选择项目 | 取焦点项目
置焦点项目 | 加入项目 | 插入项目 | 删除项目
清空 | 选择 |  |

自有事件：

列表项被选择 双击选择

基本事件：


边框 属性 数据类型：整数型；

本属性指定对象边框的类型。

语法： 对象.边框 = 整数型

例程：

说明：

设置列表框边框样式。

参见：例程


自动排序 属性 数据类型：逻辑型；

设定对象的内容是否需要排序，默认为“假”，即不自动排序。

语法： 对象.自动排序 = 逻辑型

例程：

说明：

设置列表框的自动排序属性。

参见：例程


多列 属性 数据类型：逻辑型；

设定对象内容的排列方式。

语法： 对象.多列 = 逻辑型

例程：

说明：

改变列表框的排列方式。

参见：例程


行间距 属性 数据类型：整数型；

设置对象内容的行之间的距离。

语法： 对象.行间距 = 整数型

例程：

说明：

设置列表框各项目的行间距离。

参见：例程


文本颜色 属性 数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

例程：

说明：

设置列表框项目文本的颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

例程：

说明：

设置列表框的背景颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程：

说明：

设置列表框项目文本的字体。

参见：例程


允许多项选择 属性 数据类型：逻辑型；

本属性指定是否允许用户同时选择对象中的多个选项。

语法： 对象.允许多项选择 = 逻辑型

例程：

说明：

设置列表框多项选择的权限。

参见：例程


现行选中项 属性 数据类型：整数型；

本属性指定对象中现行被选中的列表项目的位置，位置值从 0 开始， -1 表示现行没有被选中的列表项。

语法： 对象.现行选中项 = 整数型

例程：

说明：

选中列表框指定的项目。

参见：例程


列表项目 属性 数据类型：字节集；

本属性指定各列表项目。

语法： 对象.列表项目 = 整数型

例程：

说明：

取出选择列表框的列表项目信息。

参见：例程


数据源 属性 数据类型：文本型；

指定提供数据的数据源组件名。

语法： 对象.数据源 = 文本型

例程：

说明：

设置列表框连接的数据源。数据源属性必需连接有数据源组件，数据源组件的数据库提供者必需连接数据库提供者组件，数据库提供者组件的数据库文件名属性必需有一个有效的数据库文件路径。将此例程与数据库文件保存到 C 盘目录下运行。

参见：例程 数据库下载


数据列 属性 数据类型：文本型；

指定数据源中的数据列，可以是列名或以1开始的列序号文本。

语法： 对象.数据列 = 文本型

例程：

说明：

指定列表框的数据列名称。数据源属性必需连接有数据源组件，数据源组件的数据库提供者必需连接数据库提供者组件，数据库提供者组件的数据库文件名属性必需有一个有效的数据库文件路径。 将此例程与数据库文件保存到 C 盘目录下运行。

注：数据库提供者的文件名属性必需在属性表中设置。而且列表项目是指定数据列的数据库数据。

参见：例程 数据库下载


取顶端可见项目 方法 所属对象：列表框

取顶端可见项目 方法 　英文命令：GetTopIndex　所属对象：列表框

返回列表框中当前最顶端可见项目的索引。0 为项目一，1 为项目二，如此类推。失败返回 -1 。

语法： 整数型 列表框．取顶端可见项目 （）

例程：

说明：

取出列表框中显示在最顶端的项目索引。

参见：例程


置顶端可见项目 方法 所属对象：列表框

置顶端可见项目 方法 　英文命令：SetTopIndex　所属对象：列表框

设置列表框中当前最顶端的可见项目，必要时将自动滚动列表框。成功返回真，失败返回假。

语法： 逻辑型 列表框．置顶端可见项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

设置列表框的指定项目为顶端可见项目。

参见：例程


取项目数 方法 所属对象：列表框

取项目数 方法 　英文命令：GetCount　所属对象：列表框

语法： 整数型 列表框．取项目数 （）

例程：

说明：

取出列表框中的项目数量。

参见：例程


取项目数值 方法 所属对象：列表框

取项目数值 方法 　英文命令：GetItemData　所属对象：列表框

返回与指定项目相关联的数值。如果指定项目不存在，将返回 -1 。

语法： 整数型 列表框．取项目数值 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

使用编辑框显示破选中项目的项目数值。

参见：例程


置项目数值 方法 所属对象：列表框

置项目数值 方法 　英文命令：SetItemData　所属对象：列表框

设置与指定项目相关联的数值。成功返回真，失败返回假。

语法： 逻辑型 列表框．置项目数值 （项目索引，欲置入的项目数值）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目数值 | 必需的；整数型。该项目数值与指定项目相关联。

例程：

说明：

给指定项目设置项目数值。

参见：例程


取项目文本 方法 所属对象：列表框

取项目文本 方法 　英文命令：GetItemText　所属对象：列表框

返回指定项目的文本。如果指定项目不存在，将返回空文本。

语法： 文本型 列表框．取项目文本 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取出列表框指定项目的文本。

参见：例程


置项目文本 方法 所属对象：列表框

置项目文本 方法 　英文命令：SetItemtext　所属对象：列表框

设置指定项目的文本。成功返回真，失败返回假。

语法： 逻辑型 列表框．置项目文本 （项目索引，欲置入的项目文本）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目文本 | 必需的；文本型。

例程：

说明：

修改指定项目的文本。

参见：例程


取已选择项目数 方法 所属对象：列表框

取已选择项目数 方法 　英文命令：GetSelCount　所属对象：列表框

返回已被选择项目的数目。

语法： 整数型 列表框．取已选择项目数 （）

例程：

说明：

取出被选择项目的数量，并用信息框显示。

参见：例程


取所有被选择项目 方法 所属对象：列表框

取所有被选择项目 方法 　英文命令：GetSelItems　所属对象：列表框

返回一个整数数组，內含所有当前被选择项目的位置索引。如果当前没有被选择项目，返回空数组。

语法： 整数型数组 列表框．取所有被选择项目 （）

例程：

说明：

取得所有被选择的项目位置索引，放到数组中，并用信息框显示。

注：数组自动扩充，不需要提供成员，只需要提供0成员数组即可。

参见：例程


是否被选择 方法 所属对象：列表框

是否被选择 方法 　英文命令：IsSelected　所属对象：列表框

如果指定项目被选择，则返回真，否则返回假。

语法： 逻辑型 列表框．是否被选择 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

判断列表框指定项目是否被选择。

参见：例程


选择项目 方法 所属对象：列表框

选择项目 方法 　英文命令：select　所属对象：列表框

选择或取消选择指定项目。成功返回真，失败返回假。

语法： 逻辑型 列表框．选择项目 （欲选择或取消选择的项目索引，［欲置入的项目选择状态］）

参数名 | 描 述
欲选择或取消选择的项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目选择状态 | 可选的；逻辑型。如果省略本参数或者参数值为真，则选择该项目，否则取消对该项目的选择。

例程：

说明：

选择列表框的指定项目。

参见：例程


取焦点项目 方法 所属对象：列表框

取焦点项目 方法 　英文命令：GetCaretIndex　所属对象：列表框

本命令仅在多选列表框中使用，用作返回当前焦点项目的位置索引。如果在单选列表框中使用本命令，将返回当前被选择项目的位置索引。

语法： 整数型 列表框．取焦点项目 （）

例程：

说明：

取出列表框当前焦点所在项目的位置索引。

参见：例程


置焦点项目 方法 所属对象：列表框

置焦点项目 方法 　英文命令：SetCaretIndex　所属对象：列表框

本命令仅在多选列表框中使用，用作设置当前焦点项目。如果在单选列表框中使用本命令，将设置当前被选择项目。成功返回真，失败返回假。

语法： 逻辑型 列表框．置焦点项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

设置列表框的焦点项目。

参见：例程


加入项目 方法 所属对象：列表框

加入项目 方法 　英文命令：AddString　所属对象：列表框

加入指定项目到列表框的尾部，成功返回加入后该项目所处的位置，失败返回 -1 。

语法： 整数型 列表框．加入项目 （欲加入项目的文本，［与欲加入项目相关的数值］）

参数名 | 描 述
欲加入项目的文本 | 必需的；文本型。
与欲加入项目相关的数值 | 可选的；整数型。如果省略本参数，默认值为 0。

例程：

说明：

在列表框的尾部加一个新项目。

参见：例程


插入项目 方法 所属对象：列表框

插入项目 方法 　英文命令：InsertString　所属对象：列表框

插入指定项目到列表框的指定位置处，成功返回插入后该项目所处的位置，失败返回 -1 。

语法： 整数型 列表框．插入项目 （欲插入的位置，欲插入项目的文本，［与欲插入项目相关的数值］）

参数名 | 描 述
欲插入的位置 | 必需的；整数型。0 为项目位置一，1 为项目位置二，如此类推。
欲插入项目的文本 | 必需的；文本型。
与欲插入项目相关的数值 | 可选的；整数型。如果省略本参数，默认值为 0。

例程：

说明：

在列表框指定位置插入项目。

参见：例程


删除项目 方法 所属对象：列表框

删除项目 方法 　英文命令：DeleteString　所属对象：列表框

删除列表框指定位置处的项目。成功返回真，失败返回假。

语法： 逻辑型 列表框．删除项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

删除列表框中指定项目。

参见：例程


清空 方法 所属对象：列表框

清空 方法 　英文命令：zap　所属对象：列表框

删除列表框中的所有项目。

语法： 无返回值 列表框．清空 （）

例程：

说明：

清除列表框所有项目。

参见：例程


选择 方法 所属对象：列表框

选择 方法 　英文命令：iif　所属对象：列表框

在所有项目中寻找首部包含指定文本的项目，如找到，则选中它，并返回该项目的位置索引，否则返回 -1 。本命令仅在单选列表框中使用，如果在多选列表框中使用，将返回 -1 。

语法： 整数型 列表框．选择 （欲选择的项目文本）

参数名 | 描 述
欲选择的项目文本 | 必需的；文本型。

例程：

说明：

选中与输入编辑框相同内容的文本。

注：本方法只能在单选状态下使用。

参见：例程


列表项被选择 事件 所属对象：列表框 操作系统支持：Windows

如果当前所选择的列表项或区域被改变即产生此事件。

语法： 无返回值 _列表框_列表项被选择 （）

例程：

说明：

只要列表框中的选项被选中，就触发此事件。

参见：例程


双击选择 事件 所属对象：列表框 操作系统支持：Windows

当使用鼠标左键在某列表项目上双击时产生此事件。

语法： 无返回值 _列表框_双击选择 （）

例程：

说明：

只要列表框中的项目被双击，就触发此事件。

参见：例程


选择列表框

选择列表框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 自动排序 | 多列 | 行间距
单选 | 字体 | 现行选中项 | 列表项目
项目数值 |  |  |

方法：

取顶端可见项目 | 置顶端可见项目 | 取项目数 | 取项目数值
置项目数值 | 取项目文本 | 置项目文本 | 加入项目
插入项目 | 删除项目 | 清空 | 选择
是否被选中 | 选中项目 | 是否被允许 | 允许

自有事件：

列表项被选择 选中状态被改变 双击选择

基本事件：


边框 属性 数据类型：整数型；

本属性指定对象边框的类型。

语法： 对象.边框 = 整数型

例程：

说明：

设置选择列表框的边框样式。

参见：例程


自动排序 属性 数据类型：逻辑型；

设定对象的内容是否需要排序，默认为“假”，即不自动排序。

语法： 对象.自动排序 = 逻辑型

例程：

说明：

设置选择列表框自动排序属性。

参见：例程


多列 属性 数据类型：逻辑型；

设定对象内容的排列方式。

语法： 对象.多列 = 逻辑型

例程：

说明：

改变选择列表框的多列方式。

参见：例程


行间距 属性 数据类型：整数型；

设置对象内容的行之间的距离。

语法： 对象.行间距 = 整数型

例程：

说明：

设置选择列表框各项目之间的行间距离。

参见：例程


单选 (选择列表框)

单选 属性 数据类型：逻辑型；

本属性指定是否只允许选择一项列表项。

语法： 对象.单选 = 逻辑型

例程：

说明：

设置选择列表框的选择样式。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

例程：

说明：

设置选择列表框项目文本的字体。

参见：例程


现行选中项 属性 数据类型：整数型；

本属性指定对象中现行被选中的列表项目的位置，位置值从 0 开始， -1 表示现行没有被选中的列表项。

语法： 对象.现行选中项 = 整数型

例程：

说明：

取得选择列表框中指定的项目索引。

参见：例程


列表项目 属性 数据类型：字节集；

本属性指定各列表项目。

语法： 对象.列表项目 = 整数型

例程：

说明：

保存选择列表框的列表项目信息。

参见：例程


取顶端可见项目 方法 所属对象：选择列表框

取顶端可见项目 方法 　英文命令：GetTopIndex　所属对象：选择列表框

返回列表框中当前最顶端可见项目的索引。0 为项目一，1 为项目二，如此类推。失败返回 -1 。

语法： 整数型 选择列表框．取顶端可见项目 （）

例程：

说明：

取得当前顶端可见项目的索引。

参见：例程


置顶端可见项目 方法 所属对象：选择列表框

置顶端可见项目 方法 　英文命令：SetTopIndex　所属对象：选择列表框

设置列表框中当前最顶端的可见项目，必要时将自动滚动列表框。成功返回真，失败返回假。

语法： 逻辑型 选择列表框．置顶端可见项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

设置选择列表框的顶端可见项目。

参见：例程


取项目数 方法 所属对象：选择列表框

取项目数 方法 　英文命令：GetCount　所属对象：选择列表框

语法： 整数型 选择列表框．取项目数 （）

例程：

说明：

取得选择列表框的项目数量。

参见：例程


取项目数值 方法 所属对象：选择列表框

取项目数值 方法 　英文命令：GetItemData　所属对象：选择列表框

返回与指定项目相关联的数值。如果指定项目不存在，将返回 -1 。

语法： 整数型 选择列表框．取项目数值 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取得选择列表框指定项目的项目数值。

参见：例程


置项目数值 方法 所属对象：选择列表框

置项目数值 方法 　英文命令：SetItemData　所属对象：选择列表框

设置与指定项目相关联的数值。成功返回真，失败返回假。

语法： 逻辑型 选择列表框．置项目数值 （项目索引，欲置入的项目数值）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目数值 | 必需的；整数型。该项目数值与指定项目相关联。

例程：

说明：

设置选择列表框某项的项目数值。

参见：例程


取项目文本 方法 所属对象：选择列表框

取项目文本 方法 　英文命令：GetItemText　所属对象：选择列表框

返回指定项目的文本。如果指定项目不存在，将返回空文本。

语法： 文本型 选择列表框．取项目文本 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

取得某一项的项目文本。

参见：例程


置项目文本 方法 所属对象：选择列表框

置项目文本 方法 　英文命令：SetItemtext　所属对象：选择列表框

设置指定项目的文本。成功返回真，失败返回假。

语法： 逻辑型 选择列表框．置项目文本 （项目索引，欲置入的项目文本）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目文本 | 必需的；文本型。

例程：

说明：

设置某项的项目文本。

参见：例程


加入项目 方法 所属对象：选择列表框

加入项目 方法 　英文命令：AddString　所属对象：选择列表框

加入指定项目到列表框的尾部，成功返回加入后该项目所处的位置，失败返回 -1 。

语法： 整数型 选择列表框．加入项目 （欲加入项目的文本，［与欲加入项目相关的数值］）

参数名 | 描 述
欲加入项目的文本 | 必需的；文本型。
与欲加入项目相关的数值 | 可选的；整数型。如果省略本参数，默认值为 0。

例程：

说明：

在项目最后加入新项目。

参见：例程


插入项目 方法 所属对象：选择列表框

插入项目 方法 　英文命令：InsertString　所属对象：选择列表框

插入指定项目到列表框的指定位置处，成功返回插入后该项目所处的位置，失败返回 -1 。

语法： 整数型 选择列表框．插入项目 （欲插入的位置，欲插入项目的文本，［与欲插入项目相关的数值］）

参数名 | 描 述
欲插入的位置 | 必需的；整数型。0 为项目位置一，1 为项目位置二，如此类推。
欲插入项目的文本 | 必需的；文本型。
与欲插入项目相关的数值 | 可选的；整数型。如果省略本参数，默认值为 0。

例程：

说明：

在选择列表框的任意位置拆入新项目。

参见：例程


删除项目 方法 所属对象：选择列表框

删除项目 方法 　英文命令：DeleteString　所属对象：选择列表框

删除列表框指定位置处的项目。成功返回真，失败返回假。

语法： 逻辑型 选择列表框．删除项目 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

删除选择列表框上指定位置的项目。

参见：例程


清空 方法 所属对象：选择列表框

清空 方法 　英文命令：zap　所属对象：选择列表框

删除列表框中的所有项目。

语法： 无返回值 选择列表框．清空 （）

例程：

说明：

清除所有项目。

参见：例程


选择 方法 所属对象：选择列表框

选择 方法 　英文命令：iif　所属对象：选择列表框

在所有项目中寻找首部包含指定文本的项目，如找到，则选中它，并返回该项目的位置索引，否则返回 -1。

语法： 整数型 选择列表框．选择 （欲选择的项目文本）

参数名 | 描 述
欲选择的项目文本 | 必需的；文本型。

例程：

说明：

选择指定文本文项目。

参见：例程


是否被选中 方法 所属对象：选择列表框

是否被选中 方法 　英文命令：IsChecked　所属对象：选择列表框

如果与指定项目对应的选择框被选中，则返回真，否则返回假。

语法： 逻辑型 选择列表框．是否被选中 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

判断某项目是否被选择。

参见：例程


选中项目 方法 所属对象：选择列表框

选中项目 方法 　英文命令：SetCheck　所属对象：选择列表框

选中或取消选中与指定项目对应的选择框。成功返回真，失败返回假。

语法： 逻辑型 选择列表框．选中项目 （欲选择或取消选择的项目索引，［欲置入的项目选择状态］）

参数名 | 描 述
欲选择或取消选择的项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
欲置入的项目选择状态 | 可选的；逻辑型。如果省略本参数或者参数值为真，则选择该项目，否则取消对该项目的选择。

例程：

说明：

选中或取消指定项目。

参见：例程


是否被允许 方法 所属对象：选择列表框

是否被允许 方法 　英文命令：IsEnabled　所属对象：选择列表框

如果与指定项目对应的选择框被允许操作，则返回真，否则返回假。

语法： 逻辑型 选择列表框．是否被允许 （项目索引）

参数名 | 描 述
项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。

例程：

说明：

判断指定项目是否允许操作。

参见：例程


允许 方法 所属对象：选择列表框

允许 方法 　英文命令：enable　所属对象：选择列表框

允许或禁止对指定项目进行选择操作。成功返回真，失败返回假。

语法： 逻辑型 选择列表框．允许 （欲允许或禁止操作的项目索引，［允许或禁止］）

参数名 | 描 述
欲允许或禁止操作的项目索引 | 必需的；整数型。0 为项目一，1 为项目二，如此类推。
允许或禁止 | 可选的；逻辑型。如果省略本参数或者参数值为真，则允许该项目，否则禁止对该项目进行选中操作。

例程：

说明：

允许指定项目破选择操作。

参见：例程


列表项被选择 事件 所属对象：选择列表框 操作系统支持：Windows

如果当前所选择的列表项被改变即产生此事件。

语法： 无返回值 _选择列表框_列表项被选择 （）

例程：

说明：

只要选择列表框中的项目被选中，就触发此事件。

参见：例程


选中状态被改变 事件 所属对象：选择列表框 操作系统支持：Windows

语法： 无返回值 _选择列表框_选中状态被改变 （）

例程：

说明：

只要选择列表框中的选中项目被改变，就触发此事件。

参见：例程


双击选择 事件 所属对象：选择列表框 操作系统支持：Windows

当使用鼠标左键在某列表项目上双击时产生此事件。

语法： 无返回值 _选择列表框_双击选择 （）

例程：

说明：

只要选择列表框中的项目被双击，就触发此事件。

参见：例程


横向滚动条

横向滚动条 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

默认不接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
最小位置 | 最大位置 | 页改变值 | 行改变值
位置 | 允许拖动跟踪 |  |

自有事件：

位置被改变

基本事件：


最小位置 属性 数据类型：整数型；

最小位置 属性 所属对象：横向滚动条 操作系统支持：Windows

数据类型：整数型；

指定对象的起始点的最小数值。本属性的默认值为1，一般不必改动。

语法： 对象.最小位置 = 整数型

应用对象：横向滚动条

例程

说明：

将横向滚动条的最小位置设定为5。横向滚动条只是起点的位置发生改变，本身的位置没变。

参见：例程 例程2


最大位置 属性 数据类型：整数型；

最大位置 属性 所属对象：横向滚动条 操作系统支持：Windows

数据类型：整数型；

设定对象终点的最大值。

语法： 对象.最大位置 = 整数型

应用对象：

横向滚动条

例程

说明：

将横向滚动条的最大位置设定为5。只是横向滚动条的终点位置发生改变，本身位置没变。

参见：例程 例程2


页改变值 属性 数据类型：整数型；

页改变值 属性 所属对象：横向滚动条 操作系统支持：Windows

数据类型：整数型；

本属性指定当用户在滚动条的空隙处单击后滚动条位置的增减数值。

语法： 对象.页改变值 = 整数型

应用对象：

横向滚动条

例程

说明：

将横向滚动条的页改变值设定为2。即在每次空隙处单击后，横向滚动条的位置移动2位。

参见：例程 例程2


行改变值 属性 数据类型：整数型；

行改变值 属性 所属对象：横向滚动条 操作系统支持：Windows

数据类型：整数型；

本属性指定当用户按下滚动条的左右箭头按钮后滚动条位置的增减数值。

语法： 对象.行改变值 = 整数型

应用对象：

横向滚动条

例程

说明：

将横向滚动条的行改变值设定为2。即当单击横向滚动条两边的箭头时，滚动条的位置改变2位。

参见：例程 例程2


位置 属性 数据类型：整数型；

位置 属性 所属对象：横向滚动条 操作系统支持：Windows

数据类型：整数型；

指定对象的现行位置。

语法： 对象.位置 = 整数型

应用对象：

横向滚动条

例程

说明：

在横向滚动条被拖动的情况下，将横向滚动条当前的位置显示出来。

参见：例程 例程2


允许拖动跟踪 属性 数据类型：逻辑型；

允许拖动跟踪 属性 所属对象：横向滚动条 操作系统支持：Windows

数据类型：逻辑型；

本属性设定当用户拖动滚动条的位置盒的过程中是否产生位置改变事件。

语法： 对象.允许拖动跟踪 = 逻辑型

应用对象：

横向滚动条

例程

说明：

横向滚动条的允许拖动跟踪为假时，当拖动滚动条的鼠标放开以后才触发“位置被改变”事件。

横向滚动条的允许拖动跟踪为真时，当滚动条的位置发生改变就触发“位置被改变”事件，与鼠标放不放开无关。

参见：例程 例程2


位置被改变 事件 所属对象：横向滚动条 操作系统支持：Windows

语法： 无返回值 _横向滚动条_位置被改变 （）

例程

说明：

只要拖动滚动条，就触发此事件，运行此事件下的代码。

参见：例程


纵向滚动条

纵向滚动条 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

默认不接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
最小位置 | 最大位置 | 页改变值 | 行改变值
位置 | 允许拖动跟踪 |  |

自有事件：

位置被改变

基本事件：


最小位置 属性 数据类型：整数型；

最小位置 属性 所属对象：纵向滚动条 操作系统支持：Windows

数据类型：整数型；

指定对象的起始点的最小数值。

语法： 对象.最小位置 = 整数型

应用对象：

纵向滚动条

例程

说明：

将纵向滚动条的最小位置设定为5。纵向滚动条只是起点的位置发生改变，本身的位置没变。

参见：例程


最大位置 属性 数据类型：整数型；

最大位置 属性 所属对象：纵向滚动条 操作系统支持：Windows

数据类型：整数型；

设定对象终点的最大值。

语法： 对象.最大位置 = 整数型

应用对象：

纵向滚动条

例程

说明：

将纵向滚动条的最大位置设定为5。只是纵向滚动条的终点位置发生改变，本身位置没变。

参见：例程1


页改变值 属性 数据类型：整数型；

页改变值 属性 所属对象：纵向滚动条 操作系统支持：Windows

数据类型：整数型；

本属性指定当用户在滚动条的空隙处单击后滚动条位置的增减数值。

语法： 对象.页改变值 = 整数型

应用对象：

纵向滚动条

例程

说明：

将纵向滚动条的页改变值设定为2。即在每次空隙处单击后，纵向滚动条的位置移动2位

参见：例程


行改变值 属性 数据类型：整数型；

行改变值 属性 所属对象：纵向滚动条 操作系统支持：Windows

数据类型：整数型；

本属性指定当用户按下滚动条的左右箭头按钮后滚动条位置的增减数值。

语法： 对象.行改变值 = 整数型

应用对象：

纵向滚动条

例程

说明：

将纵向滚动条的行改变值设定为2。即当单击纵向滚动条两边的箭头时，滚动条的位置改变2位

参见：例程


位置 属性 数据类型：整数型；

位置 属性 所属对象：纵向滚动条 操作系统支持：Windows

数据类型：整数型；

指定对象的现行位置。

语法： 对象.位置 = 整数型

应用对象：

纵向滚动条

例程

说明：

在纵向滚动条被拖动的情况下，将纵向滚动条当前的位置显示出来。

参见：例程 例程2


允许拖动跟踪 属性 数据类型：逻辑型；

允许拖动跟踪 属性 所属对象：纵向滚动条 操作系统支持：Windows

数据类型：逻辑型；

本属性设定当用户拖动滚动条的位置盒的过程中是否产生位置改变事件。

语法： 对象.允许拖动跟踪 = 逻辑型

应用对象：

纵向滚动条

例程

说明：

纵向滚动条的允许拖动跟踪为假时，当拖动滚动条的鼠标放开以后才触发“位置被改变”事件。

纵向滚动条的允许拖动跟踪为真时，当滚动条的位置发生改变就触发“位置被改变”事件，与鼠标放不放开无关。

参见：例程


位置被改变 事件 所属对象：纵向滚动条 操作系统支持：Windows

语法： 无返回值 _纵向滚动条_位置被改变 （）

例程

说明：

当滚动条按钮的位置改变时，修改图片框的大小，图中舞女的身形也随之缩放。

参见：例程


进度条

进度条 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 方向 | 显示方式 | 最小位置
最大位置 | 位置 |  |

基本事件：


边框 属性 数据类型：整数型；

边框 属性 所属对象：进度条 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 = 整数型

应用对象：

进度条

例程

说明：

设置进度条的边框样式为边框样式组合框当前选中的项目。

参见：例程


方向 属性 所属对象：进度条 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、横向
1、纵向

语法： 对象.方向 = 整数型

应用对象：

进度条

例程

说明：

改变进度条的方向。

参见：例程


显示方式 属性 数据类型：整数型；

显示方式 属性 所属对象：进度条 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的显示方式属性中

语法： 对象.显示方式 = 整数型

应用对象：

进度条

可供选择的属性值：
0、分块
1、连续

例程

说明：

本属性只影响进度条控件的外观。

例程中，首先指定进度的方式，然后调用一个子程序“演示进度（）”。在子程序内部，通过一个“计次循环”让进度条逐渐进展。为了看得清楚，在每一轮循环内延时50毫秒（0.05秒）。

参见：例程


最小位置 属性 数据类型：整数型；

最小位置 属性 所属对象：进度条 操作系统支持：Windows

数据类型：整数型；

指定对象的起始点的最小数值。

语法： 对象.最小位置 = 整数型

应用对象：

进度条

例程

说明：

将进度条的最小位置设定为5。进度条只是起点的位置发生改变，本身的位置没变。

参见：例程


最大位置 属性 数据类型：整数型；

最大位置 属性 所属对象：进度条 操作系统支持：Windows

数据类型：整数型；

设定对象终点的最大值。

语法： 对象.最大位置 = 整数型

应用对象：

进度条

例程

说明：

将进度条的最大位置设定为5。只是进度条的终点位置发生改变，本身位置没变。

参见：例程


位置 属性 数据类型：整数型；

位置 属性 所属对象：进度条 操作系统支持：Windows

数据类型：整数型；

指定对象的现行位置。

语法： 对象.位置 = 整数型

应用对象：

进度条

例程

说明：

在位置时钟的控制下，进度条的位置发生改变，将进度条当前的位置显示出来

参见：例程


滑块条

滑块条 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
边框 | 方向 | 刻度类型 | 单位刻度值
允许选择 | 首选择位置 | 选择长度 | 页改变值
行改变值 | 最小位置 | 最大位置 | 位置

自有事件：

位置被改变

基本事件：


边框 属性 数据类型：整数型；

边框 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 = 整数型

应用对象：

滑块条

例程

说明：

设置滑块条的边框样式为边框样式组合框当前选中的项目。

参见：例程


方向 属性 所属对象：进度条 操作系统支持：Windows

方向 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、横向
1、纵向

语法： 对象.方向 = 整数型

应用对象：

滑块条

例程

说明：

改变滑块条的方向。

参见：例程


刻度类型 属性 数据类型：整数型；

刻度类型 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的刻度类型属性中

语法： 对象.刻度类型 = 整数型

应用对象：

滑块条

可供选择的属性值：
0、无
1、上/左
2、下/右
3、双向

例程

说明：

设置滑块条的刻度类型为刻度类型组合框当前选中的项目。

参见：例程


单位刻度值 属性 数据类型：整数型；

单位刻度值 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的单位刻度值属性中

语法： 对象.单位刻度值= 整数型

应用对象：

滑块条

例程

说明：

本属性是对滑块条刻度大小的定义。让滑块条上每一个刻度代表5个位置。。

参见：例程


允许选择 属性 数据类型：逻辑型；

允许选择 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的允许选择属性中

语法： 对象.允许选择 = 逻辑型

应用对象：

滑块条

例程

说明：

当我们要选择一段刻度并且要显示出来时，用到本属性。首先允许选择必须为真，再根据位置，选择显示的长度。

参见：例程


允许选择 属性 数据类型：逻辑型；

首选择位置 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的首选择位置属性中

语法： 对象. 首选择位置 = 整数型

应用对象：

滑块条

例程

说明：

只有允许选择为真时，本属性才有效。当我们要选择一段刻度并且要显示出来时，用到本属性。首先允许选择必须为真，再根据起始位置，选择显示的长度。

参见：例程


允许选择 属性 数据类型：逻辑型；

选择长度 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的选择长度属性中

语法： 对象.选择长度 = 整数型

应用对象：

滑块条

例程

说明：

只有允许选择为真时，本属性才有效。当我们要选择一段刻度并且要显示出来时，用到本属性。首先允许选择必须为真，再根据位置，选择显示得长度。

参见：例程


页改变值 属性 数据类型：整数型；

页改变值 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

本属性指定当用户在空隙处单击后滑块条位置的增减数值。

语法： 对象.页改变值 = 整数型

应用对象：

滑块条

例程

说明：

将滑块条的页改变值设定为2。即在空隙处单击滑块条后，滑块的位置改变2个。

参见：例程


行改变值 属性 数据类型：整数型；

行改变值 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

本属性指定当用户拖动滑块时滑块条位置的每次增减数值。

语法： 对象.行改变值 = 整数型

应用对象：

滑块条

例程

说明：

将滑块条的行改变值设定为5。即在拖动滑块条时，滑块条位置改变的大小。

参见：例程


最小位置 属性 数据类型：整数型；

最小位置 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

指定对象的起始点的最小数值。

语法： 对象.最小位置 = 整数型

应用对象：

滑块条

例程

说明：

将滑块条的最小位置设定为5。滑块条只是起点的位置发生改变，本身的位置没变。

参见：例程


最大位置 属性 数据类型：整数型；

最大位置 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

设定对象终点的最大值。

语法： 对象.最大位置 = 整数型

应用对象：

滑块条

例程

说明：

将滑块条的最大位置设定为5。滑块条只是终点的位置发生改变，本身的位置没变。

参见：例程


位置 属性 数据类型：整数型；

位置 属性 所属对象：滑块条 操作系统支持：Windows

数据类型：整数型；

指定对象的现行位置。

语法： 对象.位置 = 整数型

应用对象：

滑块条

例程

说明：

在位置时钟的控制下，滑块条的位置发生改变，将滑块条当前的位置显示出来。

参见：例程


位置被改变 事件 所属对象：滑块条 操作系统支持：Windows

语法： 无返回值 _滑块条_位置被改变 （）

例程

说明：

只要滑块条的位置被改变，就触发此事件，运行此事件下的代码。

参见：例程


选择夹

选择夹 容器型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
表头方向 | 允许多行表头 | 字体 | 子夹管理
现行子夹 | 隐藏自身 | 是否填充背景 | 背景颜色

方法：

取子夹数目 取子夹名称 置子夹名称

自有事件：

被单击 将改变子夹 子夹被改变

基本事件：


表头方向 属性 数据类型：整数型；

表头方向 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的表头方向属性中

语法： 对象.表头方向 = 整数型

应用对象：

选择夹

可供选择的属性值：
0、上
1、下
2、左
3、右

例程

说明：

设置选择夹表头的方向。本属性最好在设计界面时设置。

参见：例程


允许多行表头 属性 数据类型：逻辑型；

允许多行表头 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的允许多行表头属性中

语法： 对象.允许多行表头 = 逻辑型

应用对象：

选择夹

例程

说明：

在选择夹宽度不足以完全显示所有子夹表头的标题时，用到此属性，可以更直观的看到所有子夹。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

选择夹等许多组件

例程

说明：

将选择夹的字体的加粗属性设置为“真”。

参见：例程


现行子夹 属性 数据类型：整数型；

子夹管理 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：字节集型；

应用对象：

选择夹

例程

编辑子夹时的界面：

编辑子夹完毕后，选择夹显示的结果

说明：

如图所示：在选择夹中编辑了三个子夹，名称分别为“全中文”，“全可视”，“易语言”。

本属性只有设计时可用； 编辑各子夹的名称。

参见：例程


现行子夹 属性 数据类型：整数型；

现行子夹 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的现行子夹属性中

语法： 对象.现行子夹 = 整数型

应用对象：

选择夹

例程

说明：

本属性设计时不可用；本属性指定现行被选中子夹的索引，索引值从 0 开始。

参见：例程


隐藏自身 属性 数据类型：逻辑型；

隐藏自身 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的隐藏自身属性中

语法： 对象.隐藏自身 = 逻辑型

应用对象：

选择夹

例程

说明：

本属性可以用来动态切换数个同一位置处子夹的显示。此时选择夹本身不会被显示，但用户可以通过改变其“现行子夹”属性来显示指定子夹内的所有子单元。注意在设计时为方便用户定位子单元，表头方向始终为下。

注：设置此属性时，必须在设计时进行。在程序中动态改动，不能隐藏子夹。

参见：例程


是否填充背景 (选择夹)

是否填充背景 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：逻辑型； “隐藏自身”属性为真时如将本属性设置为假，可能会引起选择夹内一些子组件的刷新问题，此时将此属性设置为真并指定一个合适的背景颜色即可解决此问题。

  例程

说明：

“隐藏自身”属性为真时如将本属性设置为假，可能会引起选择夹内一些子组件的刷新问题，此时将此属性设置为真并指定一个合适的背景颜色即可解决此问题。

参见：例程


背景颜色 (选择夹)

背景颜色 属性 所属对象：选择夹 操作系统支持：Windows

数据类型：整数型； 用作填充被隐藏选择夹的背景的颜色。

  例程

说明：

用作填充被隐藏选择夹的背景的颜色。

参见：例程


取子夹数目 方法 所属对象：选择夹

取子夹数目 方法 　英文命令：GetCount　所属对象：选择夹 操作系统支持：Windows

取得组件中有多少个子单元。

语法： 整数型 选择夹.取子夹数目 （）

例程

说明：

取得选择夹中所有子夹的数量。

参见：例程


取子夹名称 方法 所属对象：选择夹

取子夹名称 方法 　英文命令：GetName　所属对象：选择夹 操作系统支持：Windows

语法： 文本型 选择夹．取子夹名称 （子夹索引）

参数名 | 描 述
子夹索引 | 必需的；整数型。1 代表子夹一，2 代表子夹二，如此类推。

例程

说明：

注：现行子夹的索引值从0开始。本命令中的子夹索引从1开始。

所以本命令的参数必须是现行子夹加上1，这样取得的名称才不致出错。

参见：例程


置子夹名称 方法 所属对象：选择夹

置子夹名称 方法 　英文命令：SetName　所属对象：选择夹 操作系统支持：Windows

置入成功返回真，否则返回假。

语法： 逻辑型 选择夹．置子夹名称 （子夹索引，欲置入的子夹名称）

参数名 | 描 述
子夹索引 | 必需的；整数型。1 代表子夹一，2 代表子夹二，如此类推。
欲置入的子夹名称 | 必需的；文本型。

例程

说明：

注：现行子夹的索引值从0开始。本命令中的子夹索引从1开始。

所以本命令的参数1必须是现行子夹加上1，这样才与子夹索引一致。

参见：例程


被单击 事件 所属对象：选择夹 操作系统支持：Windows

当在选择夹上单击后产生此事件。

语法： 无返回值 _选择夹_被单击 （）

例程

说明：

必须点击表头，才触发此事件，运行此事件下的代码。

注：如果有_选择夹_将改变子夹 （）和_选择夹_子夹被改变 （）两个事件中任何一个与此事件同时存在，只有单击当前子夹才有效，单击其他子夹无效。

参见：例程


将改变子夹 事件 所属对象：选择夹 操作系统支持：Windows

当现行被选择子夹即将被改变时产生此事件。返回假中止此改变，返回真或不返回值则允许此改变。

语法： 逻辑型 _选择夹_将改变子夹 （）

例程

说明：

必须点击表头，才触发此事件，运行此事件下的代码。

本事件发生在将要改变却还没改变当前子夹的情况下。

参见：例程


子夹被改变 事件 所属对象：选择夹 操作系统支持：Windows

当现行被选择子夹已经被改变时产生此事件。

语法： 无返回值 _选择夹_子夹被改变 （）

例程

说明：

必须点击表头，才触发此事件，运行此事件下的代码。

本事件发生在子夹改变后。

参见：例程


影像框

影像框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
文件名 | 居中播放 | 透明背景 | 播放
播放次数 |  |  |

基本事件：


播放 属性 数据类型：逻辑型；

文件名 属性 所属对象：影像框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的文件名属性中

语法： 对象.文件名 = 文本型

应用对象：

影像框

例程

说明：

例程中通过影像文件对话框打开AVI文件，居中播放AVI文件，只播放一次。

本属性只是用来设置播放的影像文件的名称。

参见：例程


居中播放 属性 数据类型：逻辑型；

居中播放 属性 所属对象：影像框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的居中播放属性中

语法： 对象.居中播放 = 逻辑型

应用对象：

影像框

例程

说明：

例程中通过影像文件对话框打开AVI文件，居中播放AVI文件，只播放一次。

本属性只是用来设置在播放时，图象在影像框中的位置。

参见：例程


透明背景 属性 数据类型：逻辑型；

透明背景 属性 所属对象：影像框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的透明背景属性中

语法： 对象.透明背景 = 逻辑型

应用对象：

影像框

例程

说明：

例程中通过影像文件对话框打开AVI文件，居中播放AVI文件，只播放一次。

本属性只是用来设置在播放时，图象背景是否透明。效果不是很明显。

参见：例程


播放 属性 数据类型：逻辑型；

播放 属性 所属对象：影像框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的播放属性中

语法： 对象.播放 = 逻辑型

应用对象：

影像框

例程

说明：

例程中通过影像文件对话框打开AVI文件，居中播放AVI文件，只播放一次。

本属性只是用来设置是否播放影音文件。

参见：例程


播放次数 属性 数据类型：整数型

播放次数 属性 所属对象：影像框 操作系统支持：Windows

数据类型：整数型

本属性指定影像文件的播放次数。如为 -1，则无限次地循环播放

语法： 对象.播放次数 = 整数型

应用对象：

影像框

例程

说明：

例程中通过影像文件对话框打开AVI文件，居中播放AVI文件，只播放一次。

指定影像文件播放一次。

参见：例程


日期框

日期框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
允许编辑 | 附件类型 | 今天 | 最小日期
最大日期 | 字体 | 边框 | 数据源
数据列 |  |  |

自有事件：

选择日期被改变

基本事件：


附件类型 属性 数据类型：整数型；

允许编辑 属性 所属对象：日期框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的允许编辑属性中

语法： 对象.允许编辑 = 逻辑型

应用对象：

日期框

例程

说明：

本属性用来指定是否可以在日期显示框中输入改变日期。

参见：例程


附件类型 属性 数据类型：整数型；

附件类型 属性 所属对象：日期框 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的附件类型属性中

语法： 对象.附件类型 = 整数型

应用对象：

日期框

可供选择的属性值：
0、下拉月历
1、调节器

例程

说明：

本属性用来定义日期框的显示类型。设置日期框的显示类型为附件类型组合框现行选中的项目。

参见：例程


今天 属性 操作系统支持：Windows

今天 属性 操作系统支持：Windows 所属对象：日期框

数据类型：日期时间型；指定或读取现行日期，如果不设定，则自动取现行日期。

语法： 对象.今天 = 日期时间型

应用对象：

日期框

例程

说明：

选择日期框中的日期为今天的日期。

参见：例程


最小日期 属性 操作系统支持：Windows

最小日期 属性 操作系统支持：Windows 所属对象：日期框

数据类型：日期时间型；

语法： 对象.最小日期 = 日期时间型

应用对象：

日期框

例程

说明：

用日期框组件举例，将日期框的最小显示时间设置成2004年1月1日，

将日期框的最大显示时间设置成2004年12月31日。设置成功后，

日期框将只能显示2004年这一年内的日期。

参见：例程


最小日期 属性 操作系统支持：Windows

最大日期 属性 操作系统支持：Windows 所属对象：日期框

数据类型：日期时间型；

语法： 对象.最大日期 = 日期时间型

应用对象：

日期框

例程

说明：

用日期框组件举例，将日期框的最小显示时间设置成2004年1月1日，

将日期框的最大显示时间设置成2004年12月31日。设置成功后，

日期框将只能显示2004年这一年内的日期。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

日期框等许多组件

例程

说明：

将日期框的字体的加粗属性设置为“真”。

参见：例程


边框 属性 数据类型：整数型；

边框 属性 所属对象：日期框 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 = 整数型

应用对象：

日期框

例程

说明：

设置日期框的边框样式为边框样式组合框当前选中的项目

参见：例程


数据源 属性 数据类型：文本型；

数据源 属性 所属对象：日期框 操作系统支持：Windows

数据类型：文本型；

指定提供数据的数据源组件名。

语法： 对象.数据源 = 文本型

应用对象：

日期框

例程

说明：

设置日期框的数据源，用来连接数据库的，并将数据库中的某一字段的日期型数据写入日期框中。

参见：例程 数据库下载


数据列 属性 数据类型：文本型；

指定数据源中的数据列，可以是列名或以1开始的列序号文本。

语法： 对象.数据列 = 文本型

应用对象：

日期框

例程

说明：

设置日期框的数据源，用来连接数据库的，并将数据库中的某一字段的日期型数据写入日期框中。

参见：例程 数据库下载


选择日期被改变 事件 所属对象：日期框 操作系统支持：Windows

当现行被选择的日期被改变后产生此事件。

语法： 无返回值 _日期框_选择日期被改变 （）

例程

说明：

当前被选择的日期发生改变，就触发此事件，运行此事件下的代码。

参见：例程


月历

月历 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
不显示今天 | 不圈注今天 | 开始星期首日 | 显示星期序号
滚动月数 | 今天 | 最小日期 | 最大日期
允许选择多天 | 最多选择天数 | 首选择日 | 尾选择日
字体 | 文本颜色 | 背景颜色 | 内背景颜色
标题颜色 | 标题背景颜色 | 非本月颜色 | 边框

自有事件：

选择日期被改变

基本事件：


不显示今天 属性 数据类型：逻辑型；

不显示今天 属性 所属对象：月历 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的不显示今天属性中

语法： 对象.不显示今天 = 逻辑型

应用对象：

月历

例程

说明：

本属性规定在月历框架内的下面，是否显示今天的日期。

参见：例程


不圈注今天 属性 数据类型：逻辑型；

不圈注今天 属性 所属对象：月历 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的不圈注今天属性中

语法： 对象.不圈注今天 = 逻辑型

应用对象：

月历

例程

说明：

本属性规定在月历框架内，是否用红色圈注今天的日期。

参见：例程


开始星期首日 属性 数据类型：整数型；

开始星期首日 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的开始星期首日属性中

语法： 对象.开始星期首日 = 整数型

应用对象：

月历

可供选择的属性值：
0、星期一
1、星期二
2、星期三
3、星期四
4、星期五
5、星期六
6、星期日

例程

说明：

本属性规定在月历中，当前显示月历中开始的星期是星期几。

参见：例程


显示星期序号 属性 数据类型：逻辑型；

显示星期序号 属性 所属对象：月历 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的显示星期序号属性中

语法： 对象.显示星期序号 = 逻辑型

应用对象：

月历

例程

说明：

本属性规定在月历中，是否显示每个星期在这一年当中的排列号。

参见：例程


滚动月数 属性 数据类型：整数型；

滚动月数 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的滚动月数属性中

语法： 对象.滚动月数 = 整数型

应用对象：

月历

例程

说明：

本属性规定在月历中，当按下滚动按钮改变当前显示的月份时，一次跳过的月份的数目。

改变后，每次跳过2个月。

参见：例程


今天 属性 操作系统支持：Windows

今天 属性 操作系统支持：Windows 所属对象：月历

数据类型：日期时间型；指定或读取现行日期，如果不设定，则自动取现行日期。

语法： 对象.今天 = 日期时间型

应用对象：

月历

例程

说明：

在今天标签中显示现在的时间。

参见：例程


最小日期 属性 操作系统支持：Windows

最小日期 属性 所属对象：月历 操作系统支持：Windows

数据类型：日期时间型；

语法： 对象.最小日期 = 日期时间型

应用对象：

月历

例程

说明：

将月历的最小显示时间设置成2004年1月1日，将月历的最大显示时间设置成2004年12月31日。

设置成功后，月历将只能显示2004年这一年内的时间。

参见：例程


最小日期 属性 操作系统支持：Windows

最大日期 属性 所属对象：月历 操作系统支持：Windows

数据类型：日期时间型；

语法： 对象.最大日期 = 日期时间型

应用对象：

月历

例程

说明：

将月历的最小显示时间设置成2004年1月1日，将月历的最大显示时间设置成2004年12月31日。

设置成功后，月历将只能显示2004年这一年内的时间。

参见：例程


允许选择多天 属性 数据类型：逻辑型；

允许选择多天 属性 所属对象：月历 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的允许选择多天属性中

语法： 对象.允许选择多天 = 逻辑型

应用对象：

月历

例程

说明：

本属性规定在月历中，每次是否可以多选几天，选择的日期必须是相连的。

首先允许选择多天，指定可多选天数3天；再设置选择的第一天的日期和选择的最后一天的日期。

参见：例程


最多选择天数 属性 数据类型：整数型；

最多选择天数 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的最多选择天数属性中

语法： 对象.最多选择天数 = 整数型

应用对象：

月历

例程

说明：

本属性规定在月历中，每次是否可以多选几天，选择的日期必须是相连的。

首先允许选择多天，指定可多选天数3天；再设置选择的第一天的日期和选择的最后一天的日期。

参见：例程


首选择日 属性 数据类型：日期时间型；

首选择日 属性 所属对象：月历 操作系统支持：Windows

数据类型：日期时间型；

将日期时间型数据赋值到指定对象的首选择日属性中

语法： 对象.首选择日 = 日期时间型

应用对象：

月历

例程

说明：

本属性规定在月历中，每次是否可以多选几天，选择的日期必须是相连的。

首先允许选择多天，指定可多选天数3天；再设置选择的第一天的日期和选择的最后一天的日期。

参见：例程


尾选择日 属性 数据类型：日期时间型；

尾选择日 属性 所属对象：月历 操作系统支持：Windows

数据类型：日期时间型；

将日期时间型数据赋值到指定对象的尾选择日属性中

语法： 对象.尾选择日 = 日期时间型

应用对象：

月历

例程

说明：

本属性规定在月历中，每次是否可以多选几天，选择的日期必须是相连的。

首先允许选择多天，指定可多选天数3天；再设置选择的第一天的日期和选择的最后一天的日期。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

月历等许多组件

例程

说明：

将月历的字体的加粗属性设置为“真”。

参见：例程


文本颜色 属性 数据类型：整数型；

文本颜色 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

月历

例程

说明：

设置月历的文本颜色为文本颜色选择器的颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

背景颜色 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

月历

例程

说明：

设置月历的背景颜色为背景颜色选择器的颜色。

参见：例程


内背景颜色 属性 数据类型：整数型；

内背景颜色 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的内背景颜色属性中

语法： 对象.内背景颜色 = 整数型

应用对象：

月历

例程

说明：

本属性指定用来实际显示月历部分的背景颜色。设置月历的内背景颜色为内背景颜色选择器的颜色。

参见：例程


标题颜色 属性 数据类型：整数型；

标题颜色 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的标题颜色属性中

语法： 对象.标题颜色 = 整数型

应用对象：

月历

例程

说明：

本属性指定用来显示月历标题的颜色。设置月历的标题颜色为标题颜色选择器的颜色。

参见：例程


标题背景颜色 属性 数据类型：整数型；

标题背景颜色 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的标题背景颜色属性中

语法： 对象.标题背景颜色 = 整数型

应用对象：

月历

例程

说明：

本属性指定用来显示月历标题背景的颜色。设置月历的标题背景颜色为标题背景颜色选择器的颜色。

参见：例程


非本月颜色 属性 数据类型：整数型；

非本月颜色 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的非本月颜色属性中

语法： 对象.非本月颜色 = 整数型

应用对象：

月历

例程

说明：

本属性指定用来显示月历中不是本月的日期的颜色。设置月历的非本月颜色为非本月颜色选择器的颜色。

参见：例程


边框 属性 数据类型：整数型；

边框 属性 所属对象：月历 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 = 整数型

应用对象：

月历

例程

说明：

设置月历的边框类型为边框样式组合框现行选中的项目。

参见：例程


选择日期被改变 事件 所属对象：月历 操作系统支持：Windows

当现行被选择的日期或区域被改变后产生此事件。

语法： 无返回值 _月历_选择日期被改变 （）

例程

说明：

当前被选择的日期发生改变，就触发此事件，运行此事件下的代码。

参见：例程


驱动器框

驱动器框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
驱动器 | 类型 | 文本颜色 | 背景颜色
字体 |  |  |

自有事件：

驱动器被改变

基本事件：


驱动器 属性 数据类型：文本型；

驱动器 属性 所属对象：驱动器框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的驱动器属性中

语法： 对象.驱动器 = 文本型

应用对象：

驱动器框

例程

说明：

本属性设计时不可用，只能读取。在驱动器标签中显示所选中的驱动器符。

参见：例程


类型 属性 数据类型：整数型；

类型 属性 所属对象：驱动器框 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的类型属性中

语法： 对象.类型 = 整数型

应用对象：

驱动器框

可供选择的属性值：
0、全部驱动器
1、可抽取式驱动器
2、固定驱动器
3、光盘驱动器
4、网络驱动器
5、内存虚拟驱动器

例程

说明：

本属性设置在驱动器框中所显示的驱动器类型。类型1为软盘驱动器，类型2为硬盘驱动器，类型3为光盘驱动器，类型4为网络驱动器，即主机带若干子机的形式，类型5为内存虚拟驱动器，即在内存中建立的驱动器。

参见：例程


文本颜色 属性 数据类型：整数型；

文本颜色 属性 所属对象：驱动器框 操作系统支持：Windows

数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

驱动器框

例程

说明：

设置驱动器框的文本颜色为文本颜色选择器所选择的颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

背景颜色 属性 所属对象：驱动器框 操作系统支持：Windows

数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

驱动器框

例程

说明：

设置驱动器框的背景颜色为背景颜色选择器所选择的颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

驱动器框等许多组件

例程

说明：

将驱动器框的字体的加粗属性设置为“真”。

参见：例程


驱动器被改变 事件 所属对象：驱动器框 操作系统支持：Windows

语法： 无返回值 _驱动器框_驱动器被改变 （）

例程

说明：

只要驱动器盘符发生改变，就触发此事件，运行此事件下的代码。

参见：例程


目录框

目录框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
目录 | 边框 | 背景颜色 | 字体

自有事件：

目录被改变

基本事件：


目录 属性 操作系统支持：Windows

目录 属性 所属对象：目录框 操作系统支持：Windows

数据类型：文本型；设计时不可用；

语法： 对象.目录 = 文本型

应用对象：

目录框

例程

说明：

在目录框的目录背改变后，取得所改变的目录，在目录编辑框中显示出来。

参见：例程


边框 属性 数据类型：整数型；

边框 属性 所属对象：目录框 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 = 整数型

应用对象：

目录框

例程

说明：

设置目录框的边框样式为边框样式组合框当前选中的项目。

参见：例程


背景颜色 属性 数据类型：整数型；

背景颜色 属性 所属对象：目录框 操作系统支持：Windows

数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

目录框

例程

说明：

设置目录框的背景颜色为目录框背景颜色选择器的颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

目录框等许多组件

例程

说明：

将目录框的字体的加粗属性设置为“真”。

参见：例程


目录被改变 事件 所属对象：目录框 操作系统支持：Windows

语法： 无返回值 _目录框_目录被改变 （）

例程

说明：

只要目录框中的目录被重新选择，就触发此事件，运行此事件下的代码。

可以根据目录框的目录属性，取得所选择的目录的路径。

参见：例程


文件框

文件框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
目录 | 被选择文件 | 允许选择多项 | 通配符
通常 | 存档 | 只读 | 系统
隐藏 | 最小日期 | 最大日期 | 边框
文本颜色 | 背景颜色 | 字体 |

自有事件：

选择文件被改变 双击选择

基本事件：


目录 属性 操作系统支持：Windows

目录 属性 操作系统支持：Windows 所属对象：文件框

数据类型：文本型；设计时不可用；

语法： 对象.目录 = 文本型

应用对象：

文件框

例程

说明：

选择文件框中的文件，显示所选择的文件所在的目录。

参见：例程


被选择文件 属性 数据类型：文本型；

被选择文件 属性 所属对象：文件框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的被选择文件属性中

语法： 对象.被选择文件 = 文本型

应用对象：

文件框

例程

说明：

本属性只能读取；记录所有现行被选择的文件，注意不包含路径。如果有多个文件被选择，各文件名之间用分号“;”隔开。

利用浏览文件夹寻找要显示的目录,放到文件框的目录中,文件框就自动显示目录中的文件，选择一个文件,用信息框把它显示出来.

参见：例程


允许选择多项 属性 数据类型：逻辑型；

允许选择多项 属性 所属对象：文件框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的允许选择多项属性中

语法： 对象.允许选择多项 = 逻辑型

应用对象：

文件框

例程

说明：

本属性设置能否选择多个文件。

参见：例程


通配符 属性 数据类型：文本型；

通配符 属性 所属对象：文件框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的通配符属性中

语法： 对象.通配符 = 文本型

应用对象：

文件框

例程

说明：

本属性设置允许进入文件框的文件的类型。可以同时指定多个通配符，各通配符

之间用分号“;”隔开。例程中，用浏览文件夹得到的目录下的文件后缀名包含输入的内容。

参见：例程


通常 属性 数据类型：逻辑型；

通常 属性 所属对象：文件框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的通常属性中

语法： 对象.通常 = 逻辑型

应用对象：

文件框

例程

说明：

本属性设置允许进入文件框的文件的类型。指定是否允许没有设置存档、只读、系统、

隐藏文件属性的文件进入。例程中，用浏览文件夹得到的目录下的文件是所有文件。

参见：例程


存档 属性 数据类型：逻辑型；

存档 属性 所属对象：文件框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的存档属性中

语法： 对象.存档 = 逻辑型

应用对象：

文件框

例程

说明：

本属性设置允许进入文件框的文件的类型。指定是否允许设置了存档文件属性的文件进入。

例程中，用浏览文件夹得到的目录下的所有文件。

参见：例程


只读 属性 操作系统支持：Windows

只读 属性 所属对象：文件框 操作系统支持：Windows

数据类型：逻辑型；指定是否允许设置了只读文件属性的文件进入。

语法： 对象.只读 = 逻辑型

应用对象：

文件框

例程

说明：

本属性设置允许进入文件框的文件的类型。指定是否允许设置了只读文件属性的文件进入。

例程中，用浏览文件夹得到的目录下的所有文件。

参见：例程


系统 属性 数据类型：逻辑型；

系统 属性 所属对象：文件框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的系统属性中

语法： 对象.系统 = 逻辑型

应用对象：

文件框

例程

说明：

本属性设置允许进入文件框的文件的类型。指定是否允许设置了系统文件属性的文件进入。

例程中，用浏览文件夹得到的目录下的所有文件。

参见：例程


隐藏 属性 数据类型：逻辑型；

隐藏 属性 所属对象：文件框 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的隐藏属性中

语法： 对象.隐藏 = 逻辑型

应用对象：

文件框

例程

说明：

本属性设置允许进入文件框的文件的类型。指定是否允许设置了隐藏文件属性的文件进入。

例程中，用浏览文件夹得到的目录下的所有文件。

参见：例程


最小日期 属性 操作系统支持：Windows

最小日期 属性 所属对象：文件框 操作系统支持：Windows

数据类型：日期时间型；指定允许进入的文件的最小日期

语法： 对象.最小日期 = 日期时间型

应用对象：

文件框

例程

说明：

这里所说的日期是文件被创建时的日期。

指定允许进入的文件被创建的最小日期和最大日期。即在2004年6月中创建的文件能在

文件框中显示出来，其它事件创建的文件不能显示。

参见：例程


最小日期 属性 操作系统支持：Windows

最大日期 属性 所属对象：文件框 操作系统支持：Windows

数据类型：日期时间型；

语法： 对象.最大日期 = 日期时间型

应用对象：

文件框

例程

说明：

这里所说的日期是文件被创建时的日期。

指定允许进入的文件被创建的最小日期和最大日期。即在2004年6月中创建的文件能在

文件框中显示出来，其它事件创建的文件不能显示。

参见：例程


边框 属性 数据类型：整数型；

边框 属性 所属对象：文件框 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

语法： 对象.边框 = 整数型

应用对象：

文件框

例程

说明：

设置文件框的边框类型为边框样式组合框现行选中的项目。

参见：例程


文本颜色 属性 数据类型：整数型；

文本颜色 属性 所属对象：文件框 操作系统支持：Windows

数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

文件框

例程

说明：

设置文件框的文本颜色为文件框文本颜色选择器所选择的颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

背景颜色 属性 所属对象：文件框 操作系统支持：Windows

数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

文件框

例程

说明：

设置文件框的背景颜色为文件框背景颜色选择器所选择的颜色。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

文件框等许多组件

例程

说明：

将文件框的字体的加粗属性设置为“真”。

参见：例程


选择文件被改变 事件 所属对象：文件框 操作系统支持：Windows

语法： 无返回值 _文件框_选择文件被改变 （）

例程

说明：

只要文件框中的文件被重新选择，就触发此事件，运行此事件下的代码。

参见：例程


双击选择 事件 所属对象：文件框 操作系统支持：Windows

当使用鼠标左键在某列表项目上双击时产生此事件。

语法： 无返回值 _文件框_双击选择 （）

例程

说明：

只要文件框中的文件被鼠标双击选择，就触发此事件，运行此事件下的代码。

参见：例程


颜色选择器

颜色选择器 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
颜色 | 允许透明 |  |

自有事件：

颜色被改变

基本事件：


颜色 属性 数据类型：整数型；

颜色 属性 所属对象：颜色选择器 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的颜色属性中

语法： 对象.颜色 = 整数型

应用对象：

颜色选择器

例程

说明：

将颜色选择器当前选择的颜色赋予颜色标签的背景颜色。。

参见：例程


允许透明 属性 数据类型：逻辑型；

允许透明 属性 所属对象：颜色选择器 操作系统支持：Windows

数据类型：逻辑型；

将逻辑型数据赋值到指定对象的允许透明属性中

语法： 对象.允许透明 = 逻辑型

应用对象：

颜色选择器

例程

说明：

本属性指定颜色选择器是否允许透明色。在传递颜色值过程中，有一种无色值，即透明色。

如果允许，颜色选择器中就包含透明色；不允许就没有透明色。

参见：例程


颜色被改变 事件 所属对象：颜色选择器 操作系统支持：Windows

语法： 无返回值 _颜色选择器_颜色被改变 （）

例程

说明：

只要颜色选择器的颜色被选择，就触发此事件，运行此事件下的代码。

参见：例程


超级链接框

超级链接框 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
标题 | 类型 | 电子信箱地址 | Internet地址
文本颜色 | 访问后的颜色 | 热点颜色 | 背景颜色
边框 | 字体 |  |

方法：

跳转

基本事件：


标题 属性 数据类型：文本型；

标题 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

应用对象：

超级链接框

例程

说明：

设置超级链接框的标题是易语言网址HTTP://www.dywt.com.cn.，然后让超级链接框

的Internet地址为易语言网址，最后跳转连接网页。

参见：例程


类型 属性 数据类型：整数型；

类型 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的类型属性中

语法： 对象.类型 = 整数型

应用对象：

超级链接框

例程

说明：

本属性设置在超级链接框中，连接的是网址还是邮件地址。

例程中设置超级链接框的标题是易语言网址HTTP://www.dywt.com.cn.，然后让超级链接框

的Internet地址为易语言网址，最后跳转连接网页。

参见：例程


电子信箱地址 属性 数据类型：文本型；

电子信箱地址 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的电子信箱地址属性中

语法： 对象.电子信箱地址 = 文本型

应用对象：

超级链接框

例程

说明：

本属性指定超级链接框的标题中，只能存放E-mail地址。

参见：例程


Internet地址 属性 数据类型：文本型；

Internet地址 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：文本型；

将文本型数据赋值到指定对象的Internet地址属性中

语法： 对象. Internet地址 = 文本型

应用对象：

超级链接框

例程

说明：

本属性指定超级链接框的标题中，只能存放网址。

例程中设置超级链接框的标题是易语言网址HTTP://www.dywt.com.cn.，然后让超级链接框

的Internet地址为易语言网址，最后跳转连接网页。

参见：例程


文本颜色 属性 数据类型：整数型；

文本颜色 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：整数型；

改变对象的文本颜色。

语法： 对象.文本颜色 = 整数型

应用对象：

超级链接框

例程

说明：

设置超级链接框标题的颜色为文本颜色选择器选择的颜色。

参见：例程


访问后的颜色 属性 数据类型：整数型；

访问后的颜色 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的访问后的颜色属性中

语法： 对象.访问后的颜色 = 整数型

应用对象：

超级链接框

例程

说明：

本属性设置在访问完网页后，超级链接框的标题中文本的颜色。

设置超级链接框访问网页后的颜色为访问后颜色选择器选择的颜色。

参见：例程


热点颜色 属性 数据类型：整数型；

热点颜色 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：整数型；

将整数型数据赋值到指定对象的热点颜色属性中

语法： 对象.热点颜色 = 整数型

应用对象：

超级链接框

例程

说明：

本属性设置鼠标移动到组件上时的文本显示颜色。

设置超级链接框的热点颜色为热点颜色选择器选择的颜色。

参见：例程


背景颜色 属性 数据类型：整数型；

背景颜色 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：整数型；

设定对象的背景颜色。

语法： 对象.背景颜色= 整数型

应用对象：

超级链接框

例程

说明：

设置超级链接框的背景颜色为背景颜色选择器选择的颜色。

参见：例程


边框 属性 数据类型：整数型；

边框 属性 所属对象：超级链接框 操作系统支持：Windows

数据类型：整数型；

本属性指定对象边框的类型。

可供选择的属性值：
0、无边框
1、凹入式
2、凸出式
3、浅凹入式
4、镜框式
5、单线边框式

  语法： 对象.边框 = 整数型

应用对象：

超级链接框

例程

说明：

设置超级链接框的边框类型为边框样式组合框现行选中的项目。

参见：例程


字体 属性 数据类型：字体；

设置对象的字体属性。

语法： 对象.字体. 角度 = 整数型

对象.字体. 加粗 = 逻辑型

对象.字体. 倾斜 = 逻辑型

对象.字体. 删除线 = 逻辑型

对象.字体. 下划线 = 逻辑型

对象.字体. 字体大小 = 整数型

对象.字体. 字体名称 = 文本型

应用对象：

超级链接框等许多组件

例程

说明：

将超级链接框的字体的加粗属性设置为“真”。

参见：例程


跳转 方法 操作系统支持：Windows 所属对象：超级链接框

跳转 方法 　英文命令：goto　操作系统支持：Windows 所属对象：超级链接框

跳转到指定的邮件或 Internet 地址。

语法： 无返回值 超级链接框．跳转 （）

例程

说明：

例程中设置超级链接框的标题是易语言网址HTTP://www.dywt.com.cn.，然后让超级链接框

的Internet地址为易语言网址，最后跳转连接网页。

参见：例程


调节器

调节器 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
方向 | 热点跟踪 |  |

自有事件：

调节钮被按下

基本事件：


方向 属性 所属对象：进度条 操作系统支持：Windows

方向 属性 所属对象：调节器 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、横向
1、纵向

语法： 对象.方向 = 整数型

应用对象：

调节器

例程

说明：

改变调节器的方向。

参见：例程


热点跟踪 属性 所属对象：超级列表框

热点跟踪 属性 所属对象：调节器 操作系统支持：Windows

数据类型：逻辑型；

本属性指定当鼠标移动到组件上时是否显示热点状态。

语法： 对象.热点跟踪 = 逻辑型

应用对象：

调节器

例程

说明：

热点跟踪就是当鼠标移动到组件上时，组件发亮显示。

当鼠标移动到调节器组件上时显示的热点状态不是很明显，请仔细看。

参见：例程


调节钮被按下 事件 所属对象：调节器 操作系统支持：Windows

语法： 无返回值 _调节器_调节钮被按下 （按钮值）

参数名 | 描 述
按钮值 | 整数型；如果按下的是调节器的向上箭头按钮，参数值为 1，否则为 -1。

例程

说明：

只要调节器的调节按钮一被按下，就触发此事件，运行此事件下的代码。

在此事件下还可以分向上按钮（按钮值为1）和向下按钮（按钮值为-1）两种情况。

参见：例程


通用对话框

通用对话框 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
类型 | 标题 | 文件名 | 过滤器
初始过滤器 | 初始目录 | 默认文件后缀 | 创建时提示
文件必须存在 | 文件覆盖提示 | 目录必须存在 | 不改变目录
字体颜色 | 加粗 | 倾斜 | 删除线
下划线 | 字体名称 | 字体大小 | 帮助文件名
帮助命令 | 帮助标志值 |  |

方法：

打开


类型 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、打开文件
1、保存文件
2、字体选择
3、打开帮助

例程

说明

改变通用对话框的类型，使通用对话框起到不同的作用。

参见：例程


标题 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；

仅适用于打开文件和保存文件对话框。

例程

说明

改变通用对话框的标题，在通用对话框打开后就可以看到变化。

参见：例程


文件名 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；

从本属性中读取的文件名包括驱动器符和全路径目录，同时本属性也用作初始对话框中的文件名编辑框。

例程

说明

打开通用对话框成功之后，会返回完整路径的文件名，本属性也可以在初始时设定，打开通用对话框是，对话框就可以直接指向该文件。

参见：例程


过滤器 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；

过滤器文本由单个或多个成对的文本串组成，每对文本串的第一个描述显示形式，如：“文本文件（*.txt）”；第二个指定实际的过滤匹配符，如：“*.txt”，所有各文本串之间用“|”号隔开。

例程

说明

通过设置过滤器，来过滤不需要显示的文件，如果需要设置多后缀名文件，可以用“；”来分隔，如：图片文件|*.bmp;*.jpg;*.gif

参见：例程


初始过滤器 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：整数型；

指定初始的过滤器，0为第一个过滤器。

例程

说明

如果需要打开多种类型文件，可以设置多重类型过滤器，在打开文件时，通过选择初始过滤器来选择当前需要使用的过滤器。

参见：例程


初始目录 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；

指定当打开对话框时所自动跳转到的目录。

例程

说明

设置通用对话框的初始目录，设置后，打开通用对话框，对话框就会直接指向该目录。

参见：例程


默认文件后缀 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；

指定当用户没有输入文件的后缀名称时所自动使用的文件后缀名称。

例程

说明

在类型为保存文件时，设置默认文件后缀，如果文件名没有指定后缀名，通用对话框就会给该文件名加上指定的默认后缀名。

参见：例程


创建时提示 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

当类型为打开文件对话框时，如果用户指定了一个不存在的文件名称，是否提示用户即将创建它。

例程

说明

如果创建时提示为“真”，在打开文件是，如果选定的文件名不存在，通用对话框将提示是否需要新创建这个文件。

参见：例程


文件必须存在 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

当类型为打开文件对话框时，是否允许用户指定一个不存在的文件。

例程

说明

如果文件必须存在设置为“真”，在打开文件时，如果文件不存在，将不能打开。

参见：例程


文件覆盖提示 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

当类型为保存文件对话框时，如果用户指定了一个已经存在的文件，是否询问用户确定覆盖此文件。

例程

说明

如果文件覆盖提示设置为“真”在类型为保存文件时，如果文件已经存在，将出现提示。

参见：例程


目录必须存在 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；是否允许用户指定一个不存在的目录。

例程

说明

如果目录必须存在设置为“真”如果选择的目录不存在，将不能打开。注：使用该属性时，文件必须存在属性应设置为“假”。

参见：例程


不改变目录 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

在对话框关闭后是否自动返回到进入对话框时的文件目录。

例程

说明

将通用对话框的不改变目录属性设为“真”，程序不结束运行的情况下，每次打开通用对话框都将打开上次关闭通用对话时的目录。

参见：例程


字体颜色 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：整数型；

例程

说明

通用对话框类型为字体选择时，用本属性来设置通用对话框的字体颜色。

参见：例程


加粗 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

例程

说明

将通用对话框的加粗属性设为“真”，将通用对话框类型设置为“字体选择”，当通用对话框弹出后，字体选择对话框的默认字体将有加粗属性。

参见：例程


倾斜 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

例程

说明

将通用对话框的倾斜属性设为“真”，将通用对话框类型设置为“字体选择”，当通用对话框弹出后，字体选择对话框的默认字体将有斜体属性。

参见：例程


删除线 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

例程

说明

将通用对话框的删除线属性设为“真”，将通用对话框类型设置为“字体选择”，当通用对话框弹出后，字体选择对话框的默认字体将有删除线属性。

参见：例程


下划线 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：逻辑型；

例程

说明

将通用对话框的下划线属性设为“真”，将通用对话框类型设置为“字体选择”，当通用对话框弹出后，字体选择对话框的默认字体将有下划线属性。

参见：例程


字体名称 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；如果不指定字体名称和字体大小，将自动使用标准的Windows图形字体。如果指定了字体大小但没有指定字体名称，将自动使用“宋体”。

例程

说明

将通用对话框的字体名称属性设为“隶书”，通用对话框类型设置为“字体选择”，当通用对话框弹出后，字体选择对话框的默认字体为“隶书”。

参见：例程


字体大小 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：整数型；

单位为1/72英寸，如果不指定字体名称和字体大小，将自动使用标准的Windows图形字体。

例程

说明

将通用对话框的字体大小属性设为“50”，将通用对话框类型设置为“字体选择”，当通用对话框弹出后，字体选择对话框的默认字体大小为“50”。

参见：例程


帮助文件名 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：文本型；

指定欲打开帮助文件的名称，如果没有指定帮助文件，将使用默认帮助文件名称，即本易程序的文件名称（不含其后缀）＋“.hlp”后缀。

例程

说明

如果通用对话框类型为大开帮主文件，本属性设置通用对话框需要打开的帮助文件的名称。本属性需要给完整路径，如果没有指定帮助文件，将使用默认帮助文件名称，即本易程序的文件名称（不含其后缀）＋“.hlp”后缀。

参见：例程


帮助命令 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、显示帮助主题
1、显示指定标志信息
2、弹出指定标志信息
3、确定帮助已显示
4、显示帮助软件使用方法
5、退出帮助

例程

说明

按照不同方式来操作帮助文件。

参见：例程


帮助标志值 属性 所属对象：通用对话框 操作系统支持：Windows

数据类型：整数型；

仅在帮助命令为“显示指定标志信息”和“弹出指定标志信息”时才有效，用于指定相应的帮助标志数值。

例程

说明

使用通用对话框打开一个帮助，通过设定标志值来直接操作该标志位置的帮助。

参见：例程


打开 方法 操作系统支持：Windows 所属对象：通用对话框

打开 方法 　英文命令：use　操作系统支持：Windows 所属对象：通用对话框

打开当前类型的对话框，返回一个逻辑值。对于类型为“打开文件”、“保存文件”、“字体选择”的对话框，如果为真，表示用户已通过该对话框输入了有效数据，否则表示用户取消了该对话框，且没有输入任何有效数据。对于类型为“打开帮助”的对话框，如打开帮助成功则返回真，否则返回假。

语法： 逻辑型 通用对话框．打开（）

例程

说明

使用通用对话框打开一个文本文件，如果点击了通用对话框的“打开”按钮，则通用对话框返回真，编辑框将显示出打开的文本文件内容。

参见：例程


时钟

时钟 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
时钟周期 |  |  |

自有事件：

周期事件


时钟周期 属性 数据类型：整数型；

将整数型数据赋值到指定对象的时钟周期属性中

语法： 对象.时钟周期 = 整数型

应用对象：

时钟

例程

说明

点击“时钟是否运行”按钮后进行判断，如果时钟周期为0，即没运行，则规定时钟周期为1000；如果时钟周期不为0则，则设置时钟周期为0，即停止时钟运行。在时钟周期事件下用标签显示当前的系统时间。

参见：例程1


周期事件 事件 所属对象：时钟 操作系统支持：Windows

每当经过了指定的时钟周期，将产生此事件。

语法： 无返回值 _时钟_周期事件 （）

例程

说明

在时钟的周期事件中，如果时钟周期为1000，则每秒钟取现在的系统时间，转换成文本，放到标签的标题中。如果为0就停止取时间的操作。

参见：例程1


打印机

打印机 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
绘画单位 | 画笔类型 | 画出方式 | 画笔粗细
画笔颜色 | 刷子类型 | 刷子颜色 | 文本颜色
文本背景颜色 | 字体 | 打印作业名 | 打印份数
多份打印方式 | 最小页号 | 最大页号 | 首页页号
末页页号 | 打印选择区 | 左边空 | 顶边空
右边空 | 底边空 | 当前页号 | 已打印份数
打印区宽度 | 打印区高度 | 打印被中止 |

方法：

取设备句柄 | 开始打印 | 结束打印 | 取消打印
换页 | 开始下一份 | 画点 | 画直线
画椭圆 | 画弧线 | 画弦 | 画饼
画矩形 | 画渐变矩形 | 填充矩形 | 画圆角矩形
画多边形 | 置写出位置 | 写文本行 | 写出
定位写出 | 取宽度 | 取高度 | 画图片
取图片宽度 | 取图片高度 | 置自定义纸张类型 | 删除自定义纸张类型
取自定义纸张大小 | 取所有纸张类型 | 单位转换 |


绘画单位 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性指定绘画时所使用的单位，坐标系的 X 轴从左到右，Y 轴从上到下。

可供选择的属性值：
0、像素点
1、0.1毫米
2、0.01毫米
3、0.01英寸
4、0.001英寸
5、1/1440英寸

例程

说明

将打印机的绘画单位设置为“0.1毫米”。

参见：例程1


画笔类型 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；

可供选择的属性值：
0、空笔
1、直线
2、划线
3、点线
4、点划线
5、双点划线
6、内直线

例程

说明

设置画笔类型为“直线”。

参见：例程1


画出方式 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；有关各种画出方式的说明为： 0、黑色：始终画出黑色；1、非或笔：或笔的相反；2、与非笔：背景色以及画笔反相二者共有颜色的组合；3、非复制笔：复制笔的相反；4、与笔非：画笔以及已有颜色反相二者共有颜色的组合；5、反转：已有颜色的反相；6、异或笔：画笔的颜色以及已有颜色的组合，只取其一；7、非与笔：与笔的相反；8、与笔：画笔和已有二者共有颜色的组合；9、非异或笔：异或笔的相反；10、无操作：原有保持不变。该设置实际上关闭画笔；11、或非笔：已有颜色与画笔颜色反相的组合；12、复制笔（缺省值）：画笔颜色；13、或笔非：画笔颜色与已有颜色的反相的组合；14、或笔：画笔颜色与已有颜色的组合；15、白色：始终画出白色。

可供选择的属性值：
0、黑色
1、非或笔
2、与非笔
3、非复制笔
4、与笔非
5、反转
6、异或笔
7、非与笔
8、与笔
9、非异或笔
10、无操作
11、或非笔
12、复制笔
13、或笔非
14、或笔
15、白色

例程

说明

将画笔方式设置为2，即与非笔。

参见：例程1


画笔粗细 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；使用现行绘画单位，如果为0，表示画笔的粗细为一个像素点。注意：当画笔类型为划线、点线、点划线、双点划线时，本属性无效，画笔宽度始终为一个像素点。

例程

说明

设置画笔粗细为5，则打印机画出时的线条粗细为5个像素。

参见：例程1


画笔颜色 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；

例程

说明

使用颜色选择器选择打印机的画笔颜色。

参见：例程1


刷子类型 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；各种格式刷子将使用当前文本背景颜色作为刷子背景颜色。

可供选择的属性值：
0、空刷子
1、颜色刷子
2、右斜线
3、直交叉线
4、斜交叉线
5、左斜线
6、横线
7、竖线
8、5%色点
9、10%色点
10、20%色点
11、25%色点
12、30%色点
13、40%色点
14、50%色点
15、60%色点
16、70%色点
17、75%色点
18、80%色点
19、90%色点
20、浅色上对角线
21、浅色下对角线
22、深色上对角线
23、深色下对角线
24、宽上对角线
25、宽下对角线
26、浅色竖线
27、浅色横线
28、窄竖线
29、窄横线
30、深色竖线
31、深色横线
32、上对角虚线
33、下对角虚线
34、横虚线
35、竖虚线
36、小纸屑
37、大纸屑
38、之字形
39、波浪线
40、对角砖形
41、横向砖形
42、纺织物
43、方格呢
44、草皮
45、虚格线
46、点式菱形
47、瓦形
48、棚架
49、球体
50、小网格
51、大网格
52、小棋盘
53、大棋盘
54、空心菱形
55、实心菱形

例程

说明

开始打印后，设置打印机的画笔类型为颜色刷子，设置刷子颜色为蓝色，然后在纸上打印出一个蓝色的矩形。

参见：例程1


刷子颜色 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；

例程

说明

开始打印，然后设置画笔类型为蓝色，设置刷子颜色为蓝色，则打印机会打出一个蓝色的矩形。

参见：例程1


文本颜色 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；

例程

说明

将编辑框中的内容以蓝色打印出来。

参见：例程1


文本背景颜色 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；

例程

说明

设置文本背景颜色为黑色，文本颜色为白色，然后打印，可以打印出黑底白字的文档。

参见：例程1


字体 属性 所属对象：打印机 操作系统支持：Windows

数据类型：字体；

例程

说明

开始打印后，设置字体的一些属性，打印出“宋体”、“5号字”、“倾斜”、“加粗”的字。还可以设置字体的“角度”、“删除线”、“下划线”。

参见：例程1


打印作业名 属性 所属对象：打印机 操作系统支持：Windows

数据类型：文本型；在打印过程中，本属性的内容将显示在由系统自动提供的打印状态对话框及 Windows 打印管理器中。如果为空，默认为“未命名打印作业”。

例程

说明

打印开始前，将打印编辑框中的前10个字符设置为打印作业名。

参见：例程1


打印份数 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性用作为打印设置对话框中的打印份数编辑框提供初始值，当用户从打印设置对话框中确认返回后，属性值提供用户所实际设置的需要打印份数。需了解的是：如果被选定打印机硬件支持多份拷贝功能，无论用户设置打印份数为多少，打印设置对话框永远返回 1 ，多份打印被转交给打印机硬件去自动完成。如果在进入打印设置对话框前置属性值为 -1 ，表明现行易程序不支持多份打印，此时系统会自动检查当前所选择打印机硬件，如果该打印机硬件支持多份拷贝，将允许用户指定打印份数并启用硬件多份拷贝功能，否则不允许，打印设置对话框返回后属性值保持不变。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

打印前设置打印份数为“打印份数编辑框”中输入的打印份数。

参见：例程1


多份打印方式 属性 所属对象：打印机 操作系统支持：Windows

数据类型：逻辑型；本属性用作为打印设置对话框中“份数”组中的“分页”选择框提供初始值，当用户从打印设置对话框中确认返回后，属性值提供用户所实际设置的值。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

将打印机的多份打印方式设置为真，则打印设置对话框中“份数”组中的“分页”选择框将默认被选择。

参见：例程1


最小页号 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性用作为打印设置对话框提供最小页号值，如果在进入打印设置对话框前置属性值为 -1 ，打印设置对话框中将不允许用户设置页打印范围。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

将打印的页数范围设置为2个编辑框规定的页数范围之间。

参见：例程1


最大页号 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性用作为打印设置对话框提供最大页号值。如果置为 -1 ，表示最大页号不受限制。如果“最小页号”属性值被置为 -1 ，本属性无意义。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

将打印机打印的页数范围，规定为2个编辑框规定的范围之间。

参见：例程1


首页页号 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性用作为打印设置对话框中的首打印页页号编辑框提供初始值，当用户从打印设置对话框中确认返回后，属性值提供用户所实际设置的首打印页号，此值将在“最小页号”属性值及“最大页号”属性值之间。但如果用户选择了全部打印或者打印选择区，本属性值将为 -1 。如果“最小页号”属性值被置为 -1 ，本属性无意义。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

将打印的首页页号设置为5，如果最小页号属性小于5，并没有设置全部打印时，会将第一个打印页设置为第5页。

参见：例程1


末页页号 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性用作为打印设置对话框中的末打印页页号编辑框提供初始值，如果置为 -1 ，表示不提供。当用户从打印设置对话框中确认返回后，属性值提供用户所实际设置的末打印页号，此值将在“首页页号”属性值及“最大页号”属性值之间。但如果用户选择了全部打印或者打印选择区，本属性值将为 -1 。如果“最小页号”属性值被置为 -1 ，本属性无意义。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

将末页页号设置为2，在最小页号和最大页号之间。

参见：例程1


打印选择区 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性用作为打印设置对话框中“选择的范围”选择框提供初始值，为 1 表示真，为 0 表示假。当用户从打印设置对话框中确认返回后，属性值提供用户所实际设置的值。如果在进入打印设置对话框前置属性值为 -1 ，打印设置对话框中将不允许用户选取该选择框。如果使用“开始打印”方法进入打印时没有调用打印设置对话框，本属性值保持不变。

例程

说明

将打印选择区属性设置为1，即为真，则打印设置对话框中的“选择的范围”选择框默认被选中。

参见：例程1


左边空 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性指定打印时打印纸左边所留空白的尺寸，使用现行绘画单位，由系统自动提供支持。

例程

说明

开始打印后，将左边空属性设置为100，则打印出的内容左边都空出100个像素的距离。

参见：例程1


顶边空 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性指定打印时打印纸顶边所留空白的尺寸，使用现行绘画单位，由系统自动提供支持。

例程

说明

将顶边空属性设置为100，则打印出的内容的顶边都空出100个像素的位置。

参见：例程1


右边空 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性指定打印时打印纸右边所留空白的尺寸，使用现行绘画单位，由系统自动提供支持。

例程

说明

将打印机的右边空属性设置为100，则打印出的内容，右边都空出100个像素的位置。

参见：例程1


底边空 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；本属性指定打印时打印纸底边所留空白的尺寸，使用现行绘画单位，由系统自动提供支持。

例程

说明

将底边空属性设置为100，则打印出的内容，底边都空出100像素的距离。

参见：例程1


当前页号 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；只读；本属性提供现行打印页的页号，由系统自行维护。页号值从“首页页号”属性值开始，如果“最小页号”属性值被置为 -1 ，页号值从 1 开始。在以下情况下属性值被自动增一： 1、使用“写文本行”方法打印一行文本并且要打印文本行的高度当前页容纳不下（此时将会首先自动换页）； 2、使用“换页”方法。本属性仅在打印作业过程中有效。

例程

说明

用时钟不断取出当前打印的页数，用编辑框显示出来。

参见：例程1


已打印份数 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；只读；本属性提供现行所已经打印的份数（含当前份），由系统自行维护。在调用“开始下一份”方法后，本属性值被自动加一。

例程

说明

用编辑框显示出当前已打印份数。

参见：例程1


打印区宽度 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；只读；本属性提供了打印纸实际可打印区域宽度减去左右边空后的值，使用现行绘画单位，仅在打印作业过程中有效。

例程

说明

打印开始后，信息框显示出当前打印出宽度，并提示是否重新设置。

参见：例程1


打印区高度 属性 所属对象：打印机 操作系统支持：Windows

数据类型：整数型；只读；本属性提供了打印纸实际可打印区域高度减去上下边空后的值，使用现行绘画单位，仅在打印作业过程中有效。

例程

说明

开始打印后，信息框显示打印区高度，并提示是否更改设置。

参见：例程1


打印被中止 属性 所属对象：打印机 操作系统支持：Windows

数据类型：逻辑型；只读；如果在打印时使用了系统所提供的打印状态对话框，并且在打印过程中用户已经选择中止打印取消了打印作业（系统自动支持），本属性值为真，否则为假。易程序在进行打印的过程中一旦发现本属性值为真，应该退出此过程。

例程

说明

当打印的时候，打印被终止了，弹出信息框提示。

参见：例程1


取设备句柄 方法 操作系统支持：Windows 所属对象：打印机

取设备句柄 方法 　英文命令：GetHDC　操作系统支持：Windows 所属对象：打印机

为高级用户提供，初级用户无需掌握；
如当前用户程序正在进行打印作业，则返回对应的打印机设备句柄（即HDC），否则返回 0。

语法： 整数型 打印机．取设备句柄 （）

例程

说明

开始打印后用信息框显示出打印机的设备句柄。

参见：例程1


开始打印 方法 操作系统支持：Windows 所属对象：打印机

开始打印 方法 　英文命令：StartDoc　操作系统支持：Windows 所属对象：打印机

返回真表示已经成功地进入了打印作业，进入打印作业后文本写出位置将被重置为 0 。如果执行本命令时已经在打印作业中或者用户在打印设置对话框中选择了取消，返回假。进入打印后必须调用“结束打印”或者“取消打印”方法来退出打印。进入打印前易程序进行的所有打印绘画操作都将被忽略。

语法： 逻辑型 打印机．开始打印 （［是否调用打印设置对话框］， ［是否显示打印状态对话框］， ［纸张］， ［纸张方向］， ［纸张宽度］， ［纸张高度］）

参数名

描 述

是否调用打印设置对话框

可选的； 逻辑型。指定在进入打印之前是否先调用打印设置对话框对打印机及相关打印参数进行设置。如省略本参数，默认为真。如果参数值为假，将自动使用 Windows 系统默认打印机，但如果取 Windows 系统默认打印机失败，仍然会调用打印设置对话框。

是否显示打印状态对话框

可选的； 逻辑型。指定在打印过程中是否显示由系统自动提供的打印状态对话框。用户如果在该打印状态对话框中选择了取消打印，系统将自动中止并取消该打印作业，并置“打印被中止”属性值为真。如省略本参数，默认为真。

纸张

可选的； 通用型。指定所使用的打印纸类型。可以为以下常量值之一： -1、自定义纸张（必须在后面参数中指定自定义纸张的大小）； 0、#默认纸； 1、#A3纸(297x420毫米)； 2、#A4纸(210x297毫米)； 3、#A5纸(148x210毫米)； 4、#B4纸(250x354毫米)； 5、#B5纸(182x257毫米)； 6、#四开(215x275毫米)； 7、#十六开(146x215毫米)； 8、#三十二开(97x151毫米)； 9、#信纸(216x279毫米)； 10、#法律用纸(216x355毫米)； 11、#行政用纸(184x266毫米)； 12、#声明(140x216毫米)； 13、#小报(279x432毫米)； 14、#笔记(216x279毫米)； 15、#帐本(432x279毫米)； 16、#对开纸(216x330毫米)。 除了以上基本类型纸张，还支持以下扩展类型，这些类型值和其所对应纸张宽度与高度（单位毫米）列表如下： 1001: 216x279 1002: 279x432 1003: 432x279 1004: 216x355 1005: 140x216 1006: 184x267 1007: 297x420 1008: 210x297 1010: 148x210 1011: 257x364 1012: 182x257 1013: 216x330 1014: 215x275 1015: 254x355 1016: 279x432 1017: 216x279 1018: 98x225 1019: 105x241 1020: 114x263 1021: 121x279 1022: 127x292 1023: 432x558 1024: 558x863 1025: 863x1117 1026: 110x220 1027: 162x229 1028: 324x458 1029: 229x324 1030: 114x162 1031: 114x229 1032: 250x353 1033: 176x250 1034: 176x125 1035: 110x230 1036: 98x190 1037: 92x165 1038: 378x279 1039: 216x305 1040: 216x330 1041: 250x353 1042: 100x148 1043: 228x279 1044: 254x279 1045: 381x279 1046: 220x220 1049: 241x305 1050: 241x381 1051: 305x457 1052: 235x322 1053: 216x279 1054: 210x297 1055: 241x305 1056: 227x356 1057: 305x487 1058: 216x322 1059: 210x330 1060: 148x210 1061: 182x257 1062: 322x445 1063: 174x235 1064: 201x276 1065: 420x594 1066: 297x420 1067: 322x445 1068: 200x148 1069: 105x148 1070: 240x332 1071: 216x277 1072: 120x235 1073: 90x205 1074: 279x216 1075: 420x297 1076: 297x210 1077: 210x148 1078: 364x257 1079: 257x182 1080: 148x100 1081: 148x200 1082: 148x105 1083: 332x240 1084: 277x216 1085: 235x120 1086: 205x90 1087: 128x182 1088: 182x128 1089: 305x279 1090: 105x235 1091: 235x105 1092: 188x260 1093: 130x184 1094: 140x203 1095: 102x165 1096: 102x176 1097: 125x176 1098: 110x208 1099: 110x220 1100: 120x230 1101: 160x230 1102: 120x309 1103: 229x324 1104: 324x458 1105: 260x188 1106: 184x130 1107: 203x140 1108: 165x102 1109: 176x102 1110: 176x125 1111: 208x110 1112: 220x110 1113: 230x120 1114: 230x160 1115: 309x120 1116: 324x229 1117: 458x324 注意如果所选择纸张得不到打印机的支持，打印机将会自动选择最接近的纸张。此外，在Windows NT/2000/XP系统下，还可以为本参数指定自定义纸张名称文本（必需已经存在，可通过“置自定义纸张类型”方法进行动态添加或修改）；在Windows 95/98/me系统下，如果为本参数提供了自定义纸张名称，则本参数被忽略。如省略本参数，默认为“#默认纸”。

纸张方向

可选的； 整数型。指定打印纸的放置方向。可以为以下常量值之一： 0、#纵向； 1、#横向。如省略本参数，默认为“#纵向”。

纸张宽度

可选的； 整数型。指定自定义纸张的宽度，单位为0.1毫米。只有当前面的“纸张”参数给定值为-1时，本参数才有作用且必须提供具体值。

纸张高度

可选的； 整数型。指定自定义纸张的高度，单位为0.1毫米。只有当前面的“纸张”参数给定值为-1时，本参数才有作用且必须提供具体值。

例程

说明

用开始打印方法，打印“打印编辑框”中的内容，进入打印后，一定要执行“结束打印”或“取消打印”方法来退出打印状态，否则程序会一直不停的搜集打印内容。

参见：例程1


结束打印 方法 操作系统支持：Windows 所属对象：打印机

结束打印 方法 　英文命令：EndDoc　操作系统支持：Windows 所属对象：打印机

如果当前已经进入了打印作业，调用本命令可完成此作业。结束打印后易程序进行的后续打印绘画操作都将被忽略。

语法： 无返回值 打印机．结束打印 （）

例程

说明

开始打印后，将打印的内容都输入后，要执行“结束打印”方法来结束打印状态。

参见：例程1


取消打印 方法 操作系统支持：Windows 所属对象：打印机

取消打印 方法 　英文命令：AbortDoc　操作系统支持：Windows 所属对象：打印机

如果当前已经进入了打印作业，调用本命令可立即中止且取消该作业。如果操作系统的打印管理器正在处理该打印作业（打印管理器正在运行并且允许后台打印），那么该作业将被删除且使打印机不接收任何信息。如果打印管理器不是正在处理该作业（没有选用后台打印），部分或全部数据可能在此之前已发送到打印机。此时，打印机驱动程序将尽可能使打印机立即复位并终止该作业。取消打印后易程序进行的后续打印绘画操作都将被忽略。

语法： 无返回值 打印机．取消打印 （）

例程

说明

开始打印后，如果打印的图片超出的用户区宽度，则取消当前的打印。

参见：例程1


换页 方法 操作系统支持：Windows 所属对象：打印机

换页 方法 　英文命令：NewPage　操作系统支持：Windows 所属对象：打印机

调用本命令使打印机完成当前页的打印，文本写出位置被重置为 0 ，并走纸到下一页左上角。如果换页成功返回真，否则将自动取消打印并返回假。

语法： 逻辑型 打印机．换页 （）

例程

说明

将“打印编辑框”中的内容打印完毕后，换到下一页开始打印“换页打印编辑框”中的内容。

参见：例程1


开始下一份 方法 操作系统支持：Windows 所属对象：打印机

开始下一份 方法 　英文命令：NewCopy　操作系统支持：Windows 所属对象：打印机

调用本命令后将结束在当前页上的打印作业，并将当前打印份数加一，当前页号置回到首页页号，以进入下一份拷贝的打印。如果成功返回真，失败将自动取消打印并返回假。

语法： 逻辑型 打印机．开始下一份 （）

例程

说明

打印编辑框中文本后，就开始下一份相同内容的打印。

参见：例程1


画点 方法 操作系统支持：Windows 所属对象：打印机

画点 方法 　英文命令：SetPixel　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画点 （点横坐标，点纵坐标，欲画入点的颜色值）

参数名 | 描 述
点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
欲画入点的颜色值 | 必需的；整数型。

例程

说明

打印出随机取出的100个点。

参见：例程1


画直线 方法 操作系统支持：Windows 所属对象：打印机

画直线 方法 　英文命令：LineTo　操作系统支持：Windows 所属对象：打印机

使用画笔在画板上画出一条直线。

语法： 无返回值 打印机．画直线 （起始点横坐标，起始点纵坐标，结束点横坐标，结束点纵坐标）

参数名 | 描 述
起始点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
起始点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
结束点横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
结束点纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

使用打印机，打印出一条直线。

参见：例程1


画椭圆 方法 操作系统支持：Windows 所属对象：打印机

画椭圆 方法 　英文命令：ellipse　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画椭圆 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

使用打印机打印出一个椭圆。

参见：例程1


画弧线 方法 操作系统支持：Windows 所属对象：打印机

画弧线 方法 　英文命令：ArcTo　操作系统支持：Windows 所属对象：打印机

使用画笔在画板上画出一条弧线。

语法： 无返回值 打印机．画弧线 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标，弧线起始点横坐标，弧线起始点纵坐标，弧线终止点横坐标，弧线终止点纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点横坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点纵坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点横坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点纵坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

使用打印机打印出一个弧线。

参见：例程1


画弦 方法 操作系统支持：Windows 所属对象：打印机

画弦 方法 　英文命令：chord　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画弦 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标，弧线起始点横坐标，弧线起始点纵坐标，弧线终止点横坐标，弧线终止点纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点横坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点纵坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点横坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点纵坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

用打印机打印出一个弦。

参见：例程1


画饼 方法 操作系统支持：Windows 所属对象：打印机

画饼 方法 　英文命令：pie　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画饼 （椭圆左上角横坐标，椭圆左上角纵坐标，椭圆右下角横坐标，椭圆右下角纵坐标，弧线起始点横坐标，弧线起始点纵坐标，弧线终止点横坐标，弧线终止点纵坐标）

参数名 | 描 述
椭圆左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
椭圆右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点横坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线起始点纵坐标 | 必需的；整数型。弧线从椭圆中心点至此起始点的直线与椭圆圆弧相交处开始绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点横坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。
弧线终止点纵坐标 | 必需的；整数型。弧线在椭圆中心点至此终止点的直线与椭圆圆弧相交处结束绘制。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

使用打印机打印出一个饼形图。

参见：例程1


画矩形 方法 操作系统支持：Windows 所属对象：打印机

画矩形 方法 　英文命令：DrawRect　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画矩形 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。

例程

说明

用打印机打印出一个矩形。

参见：例程1


画渐变矩形 方法 操作系统支持：Windows 所属对象：打印机

画渐变矩形 方法 　英文命令：DrawJBRect　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画渐变矩形 （矩形区域左边，矩形区域顶边，矩形区域宽度，矩形区域高度，［渐变方向］，首渐变颜色，其它渐变颜色，… ）

参数名 | 描 述
矩形区域左边 | 必需的；整数型。
矩形区域顶边 | 必需的；整数型。
矩形区域宽度 | 必需的；整数型。
矩形区域高度 | 必需的；整数型。
渐变方向 | 可选的；整数型。参数值可以为以下常量值之一： 1、#从上到下； 2、#从左到右； 3、从左上到右下； 4、从右上到左下； 5、从下到上； 6、从右到左； 7、从右下到左上； 8、从左下到右上。 如果本参数被省略，默认为“#从左到右”。
首渐变颜色 | 必需的；整数型。
其它渐变颜色 | 必需的；可扩充的；整数型。

例程

说明

使用打印机打印出一个由白色渐变到黑色的矩形。

参见：例程1


填充矩形 方法 操作系统支持：Windows 所属对象：打印机

填充矩形 方法 　英文命令：FillRect　操作系统支持：Windows 所属对象：打印机

将画板上指定的矩形区域用当前刷子填充。

语法： 无返回值 打印机．填充矩形 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

使用打印机打印出一个绿色的矩形。

参见：例程1


画圆角矩形 方法 操作系统支持：Windows 所属对象：打印机

画圆角矩形 方法 　英文命令：RoundRect　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画圆角矩形 （矩形左上角横坐标，矩形左上角纵坐标，矩形右下角横坐标，矩形右下角纵坐标，圆角宽度）

参数名 | 描 述
矩形左上角横坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
矩形左上角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
矩形右下角横坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
矩形右下角纵坐标 | 必需的；整数型。使用当前绘画单位，相对于打印纸左上角。
圆角宽度 | 必需的；整数型。使用当前绘画单位。

例程

说明

使用打印机打印一个圆角矩形。

参见：例程1


画多边形 方法 操作系统支持：Windows 所属对象：打印机

画多边形 方法 　英文命令：polygon　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画多边形 （多边形顶点，［顶点数目］）

参数名 | 描 述
多边形顶点 | 必需的；整数型，参数数据只能提供数组数据。本参数数组顺序记录多边形各顶点的横向及纵向坐标值。使用当前绘画单位，相对于画板或打印纸左上角。
顶点数目 | 可选的；整数型。本参数指定多边形顶点的总数目。如果被省略，默认为数组中所记录的顶点数目。

例程

说明

使用打印机打印出一个三角形。

参见：例程1


置写出位置 方法 操作系统支持：Windows 所属对象：打印机

置写出位置 方法 　英文命令：SetWritePos　操作系统支持：Windows 所属对象：打印机

设置下次使用“写文本行”或“写出”命令输出数据时的位置。

语法： 无返回值 打印机．置写出位置 （［横向写出位置］，［纵向写出位置］）

参数名 | 描 述
横向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行横向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。
纵向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行纵向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。

例程

说明

打印前置写出位置1000、1000，当开始打印时，将从打印纸上，坐标1000、1000的位置开始打印。

参见：例程1


写文本行 方法 操作系统支持：Windows 所属对象：打印机

写文本行 方法 　英文命令：WriteLine　操作系统支持：Windows 所属对象：打印机

在当前写出位置写出指定的文本、数值、逻辑值或日期时间，并将现行写出位置调整到下行行首。支持自动换页。

语法： 无返回值 打印机．写文本行 （［欲写出数据］，… ）

参数名 | 描 述
欲写出数据 | 可选的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。如果本参数被省略，则写出一个空行。

例程

说明

将编辑框中的内容打印出来。

参见：例程1


写出 方法 操作系统支持：Windows 所属对象：打印机

写出 方法 　英文命令：write　操作系统支持：Windows 所属对象：打印机

在当前写出位置处写出指定的文本、数值、逻辑值或日期时间。自动调整现行写出位置到所写出数据的末位置。

语法： 无返回值 打印机．写出 （［欲写出数据］，… ）

参数名 | 描 述
欲写出数据 | 可选的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。如果本参数被省略，则写出一个空行。

例程

说明

在打印编辑框中内容前，首先打印出当前的时间和天气。

参见：例程1


定位写出 方法 操作系统支持：Windows 所属对象：打印机

定位写出 方法 　英文命令：say　操作系统支持：Windows 所属对象：打印机

在指定写出位置处写出指定的文本、数值、逻辑值或日期时间，不改变现行写出位置。

语法： 无返回值 打印机．定位写出 （［横向写出位置］，［纵向写出位置］，欲写出数据，… ）

参数名 | 描 述
横向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行横向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。
纵向写出位置 | 可选的；整数型。如果本参数被省略，则使用现行纵向写出位置。使用当前绘画单位，相对于画板或打印纸左上角。
欲写出数据 | 必需的；可扩充的；通用型。参数值只能为文本、数值、逻辑值或日期时间。

例程

说明

在打印纸的0、1000的位置打印出当前时间。定位写出方法可以在打印纸的任意位置打印数据。

参见：例程1


取宽度 方法 操作系统支持：Windows 所属对象：打印机

取宽度 方法 　英文命令：GetWidth　操作系统支持：Windows 所属对象：打印机

返回指定数据的写出宽度，使用当前绘画单位。如果调用本命令时尚未进入打印，将返回 0 。

语法： 整数型 打印机．取宽度 （欲取其宽度或高度的数据）

参数名 | 描 述
欲取其宽度或高度的数据 | 必需的；通用型。参数值只能为文本、数值、逻辑值或日期时间。

例程

说明

在打印前用信息框显示编辑框中文本的宽度。

参见：例程1


取高度 方法 操作系统支持：Windows 所属对象：打印机

取高度 方法 　英文命令：GetHeight　操作系统支持：Windows 所属对象：打印机

返回指定数据的写出高度，使用当前绘画单位。如果调用本命令时尚未进入打印，将返回 0 。

语法： 整数型 打印机．取高度 （欲取其宽度或高度的数据）

参数名 | 描 述
欲取其宽度或高度的数据 | 必需的；通用型。参数值只能为文本、数值、逻辑值或日期时间。

例程

说明

打印前使用信息框显示编辑框中内容的高度。

参见：例程1


画图片 方法 操作系统支持：Windows 所属对象：打印机

画图片 方法 　英文命令：DrawPic　操作系统支持：Windows 所属对象：打印机

语法： 无返回值 打印机．画图片 （图片号，图片左边画出位置，图片顶边画出位置，［图片画出宽度］，［图片画出高度］，［图片画出方法］）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。
图片左边画出位置 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
图片顶边画出位置 | 必需的；整数型。使用当前绘画单位，相对于画板或打印纸左上角。
图片画出宽度 | 可选的；整数型。如果本参数被省略，则使用图片本身的宽度。使用当前绘画单位。
图片画出高度 | 可选的；整数型。如果本参数被省略，则使用图片本身的高度。使用当前绘画单位。
图片画出方法 | 可选的；整数型。本参数定义在将图像绘制到对象（画板 / 打印机）上时对图像执行的位操作。对“图标”类型图片无效。可以为以下常量值之一或者其它自定义操作码： 1、#拷贝； 2、#翻转拷贝； 3、#位异或； 4、#位或； 5、#位与本参数也可以指定透明色，但必须是负颜色数值。如： 画板1.画图片 (图片号, 0, 0, , , －取颜色值 (255, 255, 255)) 此语句的作用就是在画板上画出图片中除白色外的所有颜色。如果省略本参数，默认为“#拷贝”。

例程

说明

使用画图片方法，打印出通用对话框中选择的一张图片。

参见：例程1


取图片宽度 方法 操作系统支持：Windows 所属对象：打印机

取图片宽度 方法 　英文命令：GetPicWidth　操作系统支持：Windows 所属对象：打印机

返回指定图片的宽度。如果调用本命令时尚未进入打印，使用像素点为单位，否则使用当前绘画单位。

语法： 整数型 打印机．取图片宽度 （图片号）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。

例程

说明

使用取图片宽度的方法，使打印出的图片和原图片宽度相同。

参见 例程1


取图片高度 方法 操作系统支持：Windows 所属对象：打印机

取图片高度 方法 　英文命令：GetPicHeight　操作系统支持：Windows 所属对象：打印机

返回指定图片的高度。如果调用本命令时尚未进入打印，使用像素点为单位，否则使用当前绘画单位。

语法： 整数型 打印机．取图片高度 （图片号）

参数名 | 描 述
图片号 | 必需的；整数型。参数值必须为调用“载入图片”命令所返回的图片号。

例程

说明

使用“取图片高度”的方法，使打印出的图片和原图片相同高度。

参见 例程1


置自定义纸张类型 (打印机)

置自定义纸张类型 方法 操作系统支持：Windows 所属对象：打印机

为高级用户提供，初级用户无需掌握；
添加或修改自定义纸张类型。本方法仅在Windows NT/2000/XP下有效，且要求具有打印机驱动的完全控制权限。注意：太小或太大的纸张大小和页边距，可能不被特定的打印所支持。本方法所设置的自定义纸张类型，可用于“开始打印()”的第三个参数“纸张类型”。添加或修改后的自定义纸张类型可以在“当前默认打印机驱动所属计算机”的“开始-设置-打印机和传真-文件-服务器属性”中看到（仅限Windows NT/2000/XP系统）。

语法： 逻辑型 打印机．置自定义纸张类型 （自定义纸张类型名称， 纸张宽度， 纸张高度， ［上边距］， ［下边距］， ［左边距］， ［右边距］）

参数名 | 描 述
自定义纸张类型名称 | 必需的； 文本型。
纸张宽度 | 必需的； 整数型。单位为 0.1 毫米。
纸张高度 | 必需的； 整数型。单位为 0.1 毫米。
上边距 | 可选的； 整数型。单位为 0.1 毫米。如果本参数被省略，默认为0。
下边距 | 可选的； 整数型。单位为 0.1 毫米。如果本参数被省略，默认为0。
左边距 | 可选的； 整数型。单位为 0.1 毫米。如果本参数被省略，默认为0。
右边距 | 可选的； 整数型。单位为 0.1 毫米。如果本参数被省略，默认为0。

例程：

注意：

太小或太大的纸张大小和页边距，可能不被特定的打印所支持。

参见：例程1


删除自定义纸张类型 (打印机)

删除自定义纸张类型 方法 操作系统支持：Windows 所属对象：打印机

为高级用户提供，初级用户无需掌握；
删除指定自定义纸张类型。本方法仅在Windows NT/2000/XP下有效，且要求具有打印机驱动的完全控制权限。

语法： 逻辑型 打印机．删除自定义纸张类型 （自定义纸张类型名称）

参数名 | 描 述
自定义纸张类型名称 | 必需的； 文本型。

例程：

说明：

删除指定自定义纸张类型

参见：例程1


取自定义纸张大小 (打印机)

取自定义纸张大小 方法 操作系统支持：Windows 所属对象：打印机

为高级用户提供，初级用户无需掌握；
取指定自定义纸张类型的纸张大小及边距，并写入后面的六个参数中。如果指定的自定义纸张类型不存在，返回“假”。本方法仅在Windows NT/2000/XP下有效，且要求具有打印机驱动的完全控制权限。

语法： 逻辑型 打印机．取自定义纸张大小 （自定义纸张类型名称， ［纸张宽度］， ［纸张高度］， ［上边距］， ［下边距］， ［左边距］， ［右边距］）

参数名 | 描 述
自定义纸张类型名称 | 必需的； 文本型。
纸张宽度 | 可选的； 整数型，参数数据只能提供变量。单位为 0.1 毫米。
纸张高度 | 可选的； 整数型，参数数据只能提供变量。单位为 0.1 毫米。
上边距 | 可选的； 整数型，参数数据只能提供变量。单位为 0.1 毫米。
下边距 | 可选的； 整数型，参数数据只能提供变量。单位为 0.1 毫米。
左边距 | 可选的； 整数型，参数数据只能提供变量。单位为 0.1 毫米。
右边距 | 可选的； 整数型，参数数据只能提供变量。单位为 0.1 毫米。

例程：

说明：

取指定自定义纸张类型的纸张大小及边距，并写入后面的六个参数中。

参见：例程1


取所有纸张类型 (打印机)

取所有纸张类型 方法 操作系统支持：Windows 所属对象：打印机

为高级用户提供，初级用户无需掌握；
取当前默认打印机所支持的所有纸张类型（包括系统定义纸张类型和自定义纸张类型），返回一维文本数组，其中存放了的各纸张类型的名称。本方法仅在Windows NT/2000/XP下有效。

语法： 文本型数组 打印机．取所有纸张类型 （）

例程：

说明：

取当前默认打印机所支持的所有纸张类型（包括系统定义纸张类型和自定义纸张类型），返回一维文本数组，其中存放了的各纸张类型的名称。本方法仅在Windows NT/2000/XP下有效。

参见：例程1


单位转换 (打印机)

单位转换 方法 操作系统支持：Windows 所属对象：打印机

将像素单位座标值转换到当前绘画单位，或将当前绘画单位座标值转换到像素单位。注意在执行本方法之前，必须已经开始打印。

语法： 整数型 打印机．单位转换 （欲转换的座标值， 欲转换座标值的类型）

参数名 | 描 述
欲转换的座标值 | 必需的； 整数型。提供欲转换的横向或纵向座标值。
欲转换座标值的类型 | 必需的； 整数型。可以为以下常量值之一： 1：#横向绘画单位； 2：#纵向绘画单位； 3：#横向像素单位； 4：#纵向像素单位。 根据所提供的类型值，将进行相反的单位转换，即将绘画单位转换到像素单位，将像素单位转换到绘画单位。

例程

说明

将像素单位和绘画单位相互转换。

参见：例程1


数据报

数据报 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

数据报是一种不可靠、小数据量的网络数据交互方式。如果传递的数据量过大，有可能会失败，最好不要超过 127 字节。如需要大数据量或者可靠数据传送方式，请使用基于连接的其它网络组件。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
端口 |  |  |

方法：

发送数据 取回数据

自有事件：

数据到达


端口 属性 数据类型：整数型

指定监听数据到达的端口号，可以是大于 0 小于 32767 的任何自定数值。

语法： 对象.端口 = 整数型

应用对象：

数据报、服务器

例程

说明

把数据报端口设置成32009

参见：例程


发送数据 方法 所属对象：数据报

发送数据 方法 　英文命令：send　所属对象：数据报

发送数据到指定主机上的指定端口。成功返回真，失败返回假。

语法： 逻辑型 数据报．发送数据 （［接收主机地址］，接收主机端口号，欲发送数据）

参数名 | 描 述
接收主机地址 | 可选的；文本型。可以为主机名、IP地址等。如果省略本参数或者提供空文本，则在指定端口广播欲发送数据。
接收主机端口号 | 必需的；整数型。
欲发送数据 | 必需的；通用型。欲发送数据必须是系统基本数据类型。

例程

说明

向端口32009广播“请接收”。

参见：例程


取回数据 方法 所属对象：数据报

取回数据 方法 　英文命令：recv　所属对象：数据报

取回所接收到的数据。本命令必须在“数据到达”事件的处理子程序中使用。

语法： 字节集 数据报．取回数据（）

例程

说明

信息框显示出数据报收到的数据。本命令必须在“数据到达”事件的处理子程序中使用。

参见：例程


数据到达 事件 所属对象：数据报

当有数据到达后，会产生本事件。在本事件的处理子程序中调用“取回数据”方法即可取回本次所收到的数据。

语法： 无返回值 _数据报_数据到达 （）

例程

说明

用信息框显示出接收到的数据。在本事件的处理子程序中调用“取回数据”方法即可取回本次所收到的数据。

参见：例程


客户

客户 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

客户是基于连接的网络数据交换的客户方组件，用作向另一方的服务器端组件发送数据。基于连接的数据交换是一种可靠的、允许大数据量的网络数据交互方式。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针

方法：

连接 断开连接 发送数据 取回数据

自有事件：


连接 方法 所属对象：客户

连接 方法 　英文命令：connect　所属对象：客户

连接到指定主机上的指定端口，该主机上的该端口必须已经被某一服务器组件监听。成功返回真，失败返回假。

语法： 逻辑型 客户．连接 （服务器地址，服务器端口号）

参数名 | 描 述
服务器地址 | 必需的；文本型。可以为主机名、IP地址等。
服务器端口号 | 必需的；整数型。该端口必须已经被服务器组件监听。

例程

说明

连接本地机器的服务器。连接成功返回“真”，连接失败返回“假”。

参见：例程


断开连接 方法 所属对象：客户

断开连接 方法 　英文命令：CloseConnect　所属对象：客户

断开与服务器的已有连接。

语法： 无返回值 客户．断开连接（）

例程

说明

点击“断开连接按钮”后，断开与当前服务器的连接。

参见：例程


发送数据 方法 所属对象：客户

发送数据 方法 　英文命令：send　所属对象：客户

在成功建立与服务器的连接后，发送数据到服务器端组件。成功返回真，失败返回假。

语法： 逻辑型 客户．发送数据 （欲发送数据）

参数名 | 描 述
欲发送数据 | 必需的；通用型。欲发送数据必须是系统基本数据类型。

例程

说明

如果连接本地服务器成功，向服务器发送消息“易语言”，用信息框显示是否发送成功

参见：例程


取回数据 方法 所属对象：客户

取回数据 方法 　英文命令：recv　所属对象：客户

取回所接收到的数据。本命令必须在“数据到达”事件的处理子程序中使用。

语法： 字节集 客户．取回数据（）

例程

说明

当客户接收到信息就用信息框显示。本命令必须在“数据到达”事件的处理子程序中使用。

参见：例程


数据到达 事件 所属对象：客户

当服务器端将数据发送过来后，会产生本事件。在本事件的处理子程序中调用“取回数据”方法即可取回本次所收到的数据。

语法： 无返回值 _客户_数据到达 （）

例程

说明

收到数据后，用信息框显示收到的数据。

参见：例程


连接断开 事件 所属对象：客户

当连接被服务器端断开后，会产生本事件。

语法： 无返回值 _客户_连接断开 （）

例程

说明

当客户1与服务器连接断开时，弹出 信息框显示“连接已断开”的。

参见：例程


服务器

服务器 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

服务器是基于连接的网络数据交换的服务方组件，用作在指定端口监视来自客户方的数据。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
端口 |  |  |

方法：

取回数据 取回客户 发送数据 断开客户

自有事件：


端口 属性 数据类型：整数型

指定监听数据到达的端口号，可以是大于 0 小于 32767 的任何自定数值。

语法： 对象.端口 = 整数型

应用对象：

端口、数据报、服务器

例程

说明

单击“改端口按钮”后就将服务器端口改为“32760”。

参见：例程


取回数据 方法 所属对象：服务器

取回数据 方法 　英文命令：recv　所属对象：服务器

取回所接收到的数据。本命令必须在“数据到达”事件的处理子程序中使用。

语法： 字节集 服务器．取回数据（）

例程

说明

当服务器收到数据，就让信息框显示出收到的数据。

参见：例程


取回客户 方法 所属对象：服务器

取回客户 方法 　英文命令：GetClient　所属对象：服务器

当接收到“客户进入”或者“客户离开”事件时，在该事件的处理子程序中可调用本方法取回对应的客户地址（IP地址 + 端口）。

语法： 文本型 服务器．取回客户（）

例程

说明

当客户进入时，把客户的IP+端口号保存到“客户地址”变量中，方便其他子程序调用。该命令必须在“客户进入”或者“客户离开”事件子程序中使用。

参见：例程


发送数据 方法 所属对象：服务器

发送数据 方法 　英文命令：send　所属对象：服务器

向指定已经连接进来的客户发送数据。成功返回真，失败返回假。

语法： 逻辑型 服务器．发送数据 （接收客户，欲发送数据，［最长等待时间］）

参数名 | 描 述
接收客户 | 必需的；文本型。为调用“取回客户”方法所返回的客户地址文本。
欲发送数据 | 必需的；通用型。欲发送数据必须是系统基本数据类型。
最长等待时间 | 可选的；整数型。指定等待发送成功的最长时间，单位为秒。如果省略本参数，默认为无限等待。

例程

说明

当服务器有客户进入，就取得客户地址并存放在变量中，并发送一个数据。

参见：例程


断开客户 方法 所属对象：服务器

断开客户 方法 　英文命令：CloseClient　所属对象：服务器

断开与指定客户之间的连接。

语法： 无返回值 服务器．断开客户 （欲断开客户）

参数名 | 描 述
欲断开客户 | 必需的；文本型。为调用“取回客户”方法所返回的客户地址文本。

例程

说明

当有客户进入，就弹出一个信息框询问是否与该客户断开连接，如果点击“是”，则断开与进入客户的连接。

参见：例程


数据到达 事件 所属对象：服务器

当有数据到达后，会产生本事件。在本事件的处理子程序中调用“取回数据”方法即可取回本次所收到的数据。

语法： 无返回值 _服务器_数据到达 （）

例程

说明

当服务器收到数据，则弹出信息框显示所收到的数据内容。在本事件的处理子程序中调用“取回数据”方法即可取回本次所收到的数据。

参见：例程


客户进入 事件 所属对象：服务器

当有新客户连接入本服务器组件后，会产生本事件。在本事件的处理子程序中调用“取回客户”方法即可取回此新客户的地址（IP地址 + 端口）。

语法： 无返回值 _服务器_客户进入 （）

例程

说明

当有客户进入，则弹出信息框显示进入客户的IP地址及端口。

参见：例程


客户离开 事件 所属对象：服务器

当有已连接客户断开与本服务器组件的连接后，会产生本事件。在本事件的处理子程序中调用“取回客户”方法即可取回此客户的地址（IP地址 + 端口）。

语法： 无返回值 _服务器_客户离开 （）

例程

说明

当有客户离开时，弹出信息框，并显示离开客户的IP地址及端口。

参见：例程


端口

端口 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

端口组件提供对端口的直接读写操作。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
端口号 | 波特率 | 数据位数 | 停止位数
奇偶校验 | 事件字符 | 等待时间 | 自动启动
奇偶校验方案 | 流控制方案 | Rts流控制 | Dtr流控制

方法：

启动 停止 发送数据 信号操作

自有事件：


端口号 属性 所属对象：端口

指定监听数据到达的端口号，可以是大于 0 小于 32767 的任何自定数值。

语法： 对象.端口 = 整数型

应用对象：

数据报、服务器

例程

说明

当按下“改端口按钮”时，将端口组件的“端口号”属性设置为32766。

参见：例程


波特率 属性 所属对象：端口

数据类型：整数型；

指定通信端口所使用的波特率，比较常用的波特率有：110, 300, 600, 1200, 2400, 4800, 9600, 14400, 19200, 38400, 56000, 57600, 115200, 128000, 256000。

例程

说明

按下“改波特率”按钮，就将端口组件的波特率属性设置为32766。一般情况下，两个用于通讯的机器设备要求波特率要一致。这就好比是音乐节拍，如果两者节拍不一致，那么就不会起到共鸣的作用。波特率也是这样。

参见：例程


数据位数 属性 所属对象：端口

数据类型：整数型；

  所对应的可操作数据的位数

例程

说明

按下按钮就将端口的数据位数定为4。该属性可以为以下值之一：4、5、6、7、8。数据位数一般不用改。

参见：例程


停止位数 属性 所属对象：端口

数据类型：整数型；

可以为以下值之一：1: 1位; 2: 1.5位; 3: 2位。

例程

说明

将当前端口的停止位数设置为2位。

参见：例程


奇偶校验 属性 所属对象：端口

数据类型：逻辑型；

指定通信时对数据是否进行奇偶校验。

例程

说明

将端口设置奇偶校验。通信时会对数据进行奇偶校验。

参见：例程


事件字符 属性 所属对象：端口

数据类型：文本型；

指定用作触发事件的字符。只使用文本的首字符，为空表示不支持事件字符。

例程

说明

将端口1的事件字符设为“易语言”，并用信息框显示。

参见：例程


等待时间 属性 所属对象：端口

数据类型：整数型；指定在进行端口读写操作时最长等待时间。单位毫秒。

例程

说明

将端口的最长等待时间设为2秒钟。通讯时如果超过等待时间，将返回错误的信息。

参见：例程


自动启动 属性 所属对象：端口

数据类型：逻辑型；

在对端口进行操作之前必须首先启动，本属性指定当组件被载入时是否自动启动。

例程

说明

弹出信息框询问端口是否自动启动。

参见：例程


奇偶校验方案 属性 所属对象：端口

数据类型：整数型；

指定通信时所使用的具体奇偶校验位方案。

可供选择的属性值：
0、无
1、奇校验
2、偶校验
3、标志校验
4、空白校验

例程

说明

设置端口的奇偶校验方案为“空白校验”。

参见：例程


流控制方案 属性 所属对象：端口

数据类型：整数型；指定通信时所使用的流控制方案。

可供选择的属性值：
0、无
1、CtsRts
2、CtsDtr
3、DsrRts
4、DsrDtr
5、XonXoff

例程

说明

将端口的流程控制方案设置为4，即DsrDtr方案。

参见：例程


Rts 流控制 属性 所属对象：端口

数据类型：整数型；指定通信时是否启用Rts流控制。

可供选择的属性值：
0、默认
1、禁止
2、启用

例程

说明

将Rts流控制设置为2，即启用Rts流控制。

参见：例程


Dtr 流控制 属性 所属对象：端口

数据类型：整数型；指定通信时是否启用Dtr流控制。

可供选择的属性值：
0、默认
1、禁止
2、启用

例程

说明

将端口的Dtr 流控制2，即启用Dtr流控制。

参见：例程


启动 方法 所属对象：端口

启动 方法 　英文命令：start　所属对象：端口

启动或重新启动对指定端口的操作。在对端口进行操作之前必须首先启动，如在端口启动后又更改了端口属性必须重新启动。成功返回真，失败返回假。

语法： 逻辑型 端口．启动（）

例程

说明

启动端口，并用信息框显示是否启动成功。如果端口设置了自动启动属性，则端口会自动启动。

参见：例程


停止 方法 所属对象：端口

停止 方法 　英文命令：stop　所属对象：端口

关闭已经启动的指定端口。

语法： 无返回值 端口．停止（）

例程

说明

关闭端口，并用信息框提示已关闭。

参见：例程


发送数据 方法 所属对象：端口

发送数据 方法 　英文命令：send　所属对象：端口

从端口发送指定的数据。成功返回真，失败返回假。

语法： 逻辑型 端口．发送数据 （欲发送数据）

参数名 | 描 述
欲发送数据 | 必需的；通用型。欲发送数据必须是系统基本数据类型。

例程

说明

当窗口创建完毕便启动端口，按下发送按钮，端口将发送数据“易语言”。收到数据的端口，将会处理“数据到达”事件子程序中的代码。

参见：例程


信号操作 方法 所属对象：端口

信号操作 方法 　英文命令：Signal　所属对象：端口

本命令可以设置或清除通讯端口上指定信号的状态。成功返回真，失败返回假。

语法： 逻辑型 端口．信号操作 （操作类型，欲操作信号类型）

参数名 | 描 述
操作类型 | 必需的；整数型。本参数可以为以下常量值之一： 1: #清除信号； 2: #发送或置位。
欲操作信号类型 | 必需的；整数型。本参数可以为以下常量值之一： 1: #DTR信号； 2: #RTS信号； 3: #Break信号。

例程

说明

窗口创建完毕便启动端口，按下“信号操作”按钮，发送一个RTS信号，收到信号的端口，将处理“收到信号”事件子程序中的代码。

参见：例程


收到信号 事件 所属对象：端口

当通信端口的信号状态发生改变时，会产生本事件。

语法： 无返回值 _端口_收到信号 （信号类型）

参数名 | 描 述
信号类型 | 整数型；指示具体检测到信号状态的类型，为以下值之一： 1：BREAK 信号； 2：CTS 上升沿信号； 3：DSR 上升沿信号； 4：ERR 信号； 5：RING 信号； 6：RLSD 上升沿信号； 7：事件字符到达； 8：CTS 下降沿信号； 9：DSR 下降沿信号； 10：RLSD 下降沿信号。

例程

说明

收到信号后，就弹出信息框并显示收到信号的类型。

参见：例程


数据到达 事件 所属对象：端口

每当通信端口接收到一个数据字节，就会产生本事件。

语法： 无返回值 _端口_数据到达 （数据字节值）

参数名 | 描 述
数据字节值 | 整数型；指示所接收到的数据字节值。

例程

说明

收到数据后，就弹出信息框并显示收到数据字节值。

参见：例程


表格

表格 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
数据源 | 表格线颜色 | 背景颜色 | 缩放比
允许选择块 | 显示标尺 | 显示空表格线 | 禁止调整行高
禁止调整列宽 | 允许粘贴扩展 |  |

方法：

置光标 | 选择 | 全部选择 | 取光标行号
取光标列号 | 取选择行数 | 取选择列数 | 等宽缩放
全部复制 | 复制 | 粘贴到光标处 | 粘贴
打印 | 打印预览 |  |

自有事件：

光标位置改变 | 选择行列数改变 | 内容被改变 | 行高被改变
列宽被改变 | 尺寸被扩展 |  |

基本事件：


数据源 属性 所属对象：表格

数据源 属性 数据类型：文本型；

指定提供数据的数据源组件名。

语法：对象.数据源＝文本型

例程：

说明：

设置“表格”的数据源为“数据源”，然后设置“数据源”的数据提供者为“通用提供者”，这样就将3个组件联系起来。

参见：例程1


数据源 属性 所属对象：表格

表格线颜色 属性 数据类型：整数型；

语法：对象.表格线颜色＝整数型

例程：

说明：

将表格的“表格线颜色”设置为黑色。

参见：例程1


背景颜色 属性 数据类型：整数型

语法：对象.背景颜色＝逻辑型

例程：

说明：

设置表格背景颜色为浅灰。

参见：例程1


数据源 属性 所属对象：表格

缩放比 属性 数据类型：整数型；

指定显示表格时所使用的缩放百分比，值在 20 到 1000 之间。

语法：对象.缩放比＝整数型

例程：

说明：

设置表格的显示大小为百分之一百五十。

参见：例程1


数据源 属性 所属对象：表格

允许选择块 属性 数据类型：逻辑型；

指定是否允许用户多行多列选择组件单元格区域。

语法： 对象.允许选择块 = 逻辑型

例程：

说明：

设置表格的允许选择块为假，则用户不能选择多个单元格。

参见：例程1


数据源 属性 所属对象：表格

显示标尺 属性 数据类型：逻辑型

语法：对象.显示标尺＝逻辑型

例程：

说明：

设置表格是否显示标尺。

参见：例程1


数据源 属性 所属对象：表格

显示空表格线 属性 数据类型：逻辑型；

指定是否用虚线显示空表格线。

语法：对象.显示空表格线＝逻辑型

例程：

说明：

设置表格是否显示空表格线。

参见：例程1


数据源 属性 所属对象：表格

禁止调整行高 属性 数据类型：逻辑型；

指定是否禁止操作者调整表格行高。

语法：对象.禁止调整行高＝逻辑型

例程：

说明：

设置表格的行高不可调。

参见：例程1


数据源 属性 所属对象：表格

禁止调整列宽 属性 数据类型：逻辑型；

指定是否禁止操作者调整表格列宽。

语法：对象.禁止调整列宽＝逻辑型

例程：

说明：

程序中设置表格的列宽不可调。

参见：例程1


数据源 属性 所属对象：表格

允许粘贴扩展 属性 数据类型：逻辑型 ；

指定当粘贴表格数据时，如果现行表格尺寸无法容纳，是否允许自动扩展。

语法：对象.允许粘贴扩展＝逻辑型

例程：

说明：

程序中设置表格在粘帖时可以自动扩展。

参见：例程1


置光标 方法 所属对象：表格

置光标 方法 　英文命令：SetCaret　所属对象：表格

语法： 无返回值 表格．置光标 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

将表格光标移动到编辑框中输入的行号列号所对应的单元格上。

参见：例程1


选择 方法 所属对象：表格

选择 方法 　英文命令：Select　所属对象：表格

语法： 无返回值 表格．选择 （行号，列号，［行数］，［列数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

从表格当前选择的行列向后选中5行5列，“选择()”方法选中单元格和用鼠标选中效果相同。

参见：例程1


全部选择 方法 所属对象：表格

全部选择 方法 　英文命令：SelectAll　所属对象：表格

语法： 无返回值 表格．全部选择 （）

例程：

说明：

选择表格全部区域。

参见：例程1


取光标行号 方法 所属对象：表格

取光标行号 方法 　英文命令：CaretRow　所属对象：表格

语法： 整数型 表格．取光标行号 （）

例程：

说明：

将表格中光标所选的行号取出，并存放在“光标行号变量”中，并用信息框显示该行号。

如选择多行，将取出起始选择单元格的行号。

参见：例程1


取光标列号 方法 所属对象：表格

取光标列号 方法 　英文命令：CaretCol　操作系统支持：Windows 所属对象：表格

语法： 整数型 表格．取光标列号 （）

例程：

说明：

将表格中光标所选的列的列号取出，并存放在“光标列号变量”中，并用信息框显示该列号。

如选择多列，将取出起始选择单元格的列号。

参见：例程1


取选择行数 方法 所属对象：表格

取选择行数 方法 　英文命令：SelectRows　所属对象：表格

被选择的行区域起始于光标所在行。

语法： 整数型 表格．取选择行数 （）

例程：

说明：

取出表格当前被选中的行数，保存在“选择行数变量”中，并用信息框显示选择行数。

参见：例程1


取选择列数 方法 所属对象：表格

取选择列数 方法 　英文命令：SelectCols　所属对象：表格

被选择的列区域起始于光标所在列。

语法： 整数型 表格．取选择列数 （）

例程：

说明：

取出表格当前被选中的列数，保存在“选择列数变量”中，并用信息框显示选择列数。

参见：例程1


等宽缩放 方法 所属对象：表格

等宽缩放 方法 　英文命令：InWin　所属对象：表格

将表格内容缩放到与表格窗口等宽显示。

语法： 无返回值 表格．等宽缩放 （）

例程：

说明：

缩放表格中内容和表格组件等宽。

参见：例程1


全部复制 方法 所属对象：表格

全部复制 方法 　英文命令：CopyAll　所属对象：表格

复制所有表格数据到剪贴板。

语法： 无返回值 表格．全部复制 （）

例程：

说明：

复制所有表格数据到剪贴板中，复制后可以使用表格“粘贴()”的方法，将剪贴板的内容导出。

参见：例程1


复制 方法 所属对象：表格

复制 方法 　英文命令：Copy　所属对象：表格

复制指定区域表格数据到剪贴板。

语法： 无返回值 表格．复制 （行号，列号，［行数］，［列数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

将表格中光标所选区域复制到剪贴板中，复制后可以使用表格“粘贴()”的方法，将剪贴板的内容导出。

参见：例程1


粘贴到光标处 方法 所属对象：表格

粘贴到光标处 方法 　英文命令：PasteToCaret　所属对象：表格

粘贴剪贴板中的表格数据到当前光标处。

语法： 无返回值 表格．粘贴到光标处 （）

例程：

说明：

将复制到剪贴板的内容，粘贴到表格光标所在的处。

参见：例程1


粘贴 方法 所属对象：表格

粘贴 方法 　英文命令：Paste　所属对象：表格

粘贴剪贴板中的表格数据到指定位置。

语法： 无返回值 表格．粘贴 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

使用“粘贴()”方法，通过设置粘贴位置，将复制到剪贴板的内容，粘贴到表格光标所在的处。

参见：例程1


打印 方法 所属对象：表格

打印 方法 　英文命令：Print　所属对象：表格

打印表格数据到打印机。注意欲设置打印份数等打印设置信息请到与表格相连接的数据源中设置。成功返回空文本，失败(不包含操作者中断打印)返回非空错误文本。

语法： 文本型 表格．打印 （［是否显示进度框］，［打印作业标题］）

参数名 | 描 述
是否显示进度框 | 可选的；逻辑型。指定在打印的同时是否显示打印进度框，操作者可以在进度框内中止打印。如果本参数被省略，默认值为真。
打印作业标题 | 可选的；文本型。本参数指定打印时显示在打印机状态窗口中的文档名称。如果参数被省略，默认值为“报表”。

例程：

说明：

文本变量为文本型，保存“打印()”方法返回的文本，并用信息框显示该文本。

参见：例程1


打印预览 方法 所属对象：表格

打印预览 方法 　英文命令：PrintPreview　操作系统支持：Windows 所属对象：表格

语法： 无返回值 表格．打印预览 （）

例程：

说明：

预览打印后的效果。

参见：例程1


光标位置改变 事件 所属对象：表格 操作系统支持：Windows

当操作者改变了光标位置后会产生本事件。

语法： 无返回值 _表格_光标位置改变 （）

例程：

说明：

表格被选择单元格被改变，信息框就被弹出。

参见：例程1


光标位置改变 事件 所属对象：表格 操作系统支持：Windows

选择行列数改变 事件 所属对象：表格 操作系统支持：Windows

当操作者更改了当前被选择区域的行列数时会产生本事件。

语法： 无返回值 _表格_选择行列数改变 （）

例程：

说明：

表格被选择行数或列数改变，信息框就被弹出。

参见：例程1


光标位置改变 事件 所属对象：表格 操作系统支持：Windows

内容被改变 事件 所属对象：表格 操作系统支持：Windows

当操作者修改了单元格内容时即产生此事件。

语法： 无返回值 _表格_内容被改变 （行号，列号，行数，列数）

参数名 | 描 述
行号 | 整数型；参数值记录内容被改变的单元格区首行号。
列号 | 整数型；参数值记录内容被改变的单元格区首列号。
行数 | 整数型；参数值记录内容被改变的表格行数目。
列数 | 整数型；参数值记录内容被改变的表格列数目。

例程：

说明：

表格的单元格内容被改变，信息框就被弹出。

参见：例程1


光标位置改变 事件 所属对象：表格 操作系统支持：Windows

行高被改变 事件 所属对象：表格 操作系统支持：Windows

当操作者调整了表格行行高时即产生此事件。

语法： 无返回值 _表格_行高被改变 （行号）

参数名 | 描 述
行号 | 整数型；参数值记录行高被改变的表格行号。

例程：

说明：

表格的行高被改变，信息框将被弹出。

只有通过显示的标尺手动改变，才能触发此事件。

参见：例程1


光标位置改变 事件 所属对象：表格 操作系统支持：Windows

列宽被改变 事件 所属对象：表格 操作系统支持：Windows

当操作者调整了表格列列宽时即产生此事件。

语法： 无返回值 _表格_列宽被改变 （列号）

参数名 | 描 述
列号 | 整数型；参数值记录列宽被改变的表格列号。

例程：

说明：

表格的列宽被改变，信息框将被弹出。

只有通过显示的标尺手动改变，才能触发此事件。

参见：例程1


光标位置改变 事件 所属对象：表格 操作系统支持：Windows

尺寸被扩展 事件 所属对象：表格 操作系统支持：Windows

当操作者粘贴来自剪贴板的表格单元数据时，如果为了容纳该数据自动扩展了表格尺寸，即产生此事件。

语法： 无返回值 _表格_尺寸被扩展 （）

例程：

说明：

表格被自动添加行或列，信息框就被弹出。

参见：例程1


数据源

数据源 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

数据源提供对各种来源数据的统一操作接口。数据源组件各个按钮的含义分别是：到首记录、到上一记录、到下一记录、到尾记录、添加新记录、删除当前记录。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
数据提供者 | 只读 | 允许添加 | 允许删除

方法：

到首记录 | 到尾记录 | 跳过 | 跳到
取记录号 | 取表头行数 | 置表头行数 | 取表头列数
置表头列数 | 取行高 | 置行高 | 取列宽
置列宽 | 取类型 | 置类型 | 取文本色
置文本色 | 取背景色 | 置背景色 | 取字体名
置字体名 | 取字体尺寸 | 置字体尺寸 | 取字体属性
置字体属性 | 取边距 | 置边距 | 取文本输入格式
置文本输入格式 | 取对齐方式 | 置对齐方式 | 取密码方式
置密码方式 | 取文本 | 置文本 | 取数据
置数据 | 合并 | 分解 | 是否被合并
加线条 | 删线条 | 是否有线条 | 清除
置初始属性 | 初始尺寸 | 取行数 | 取列数
插入行 | 添加行 | 删除行 | 插入列
删除列 | 添加 | 存到字节集 | 从字节集读
存到文件 | 从文件读 | 单元格到字节集 | 字节集到单元格
单元格到文件 | 文件到单元格 | 刷新 | 保存更改
打印设置 | 取打印设置 | 置打印设置 | 取打印页宽
取打印页高 | 取只读方式 | 置只读方式 |

自有事件：

当前记录改变 添加记录 删除记录

基本事件：


置光标 方法 所属对象：表格

数据提供者 属性 数据类型：文本型； 操作系统支持：Windows

指定本数据源所基于的数据提供者组件名，所有数据存取操作都将通过数据提供者实际完成。

语法：对象.数据提供者＝文本型

例程：

说明：

指定提供数据给数据源1的数据提供者。

参见：例程1


置光标 方法 所属对象：表格

只读 属性 数据类型：逻辑型； 操作系统支持：Windows

指定是否允许操作者修改数据源内的数据，注意本属性并不限制在程序中直接修改数据。

语法：对象.只读＝逻辑型

例程：

说明：

数据源1的只读属性被设置为假，允许修改。

参见：例程1


置光标 方法 所属对象：表格

允许添加 属性 数据类型：逻辑型； 操作系统支持：Windows

指定是否允许操作者添加记录到数据源内，注意本属性并不限制在程序中直接添加记录。

语法：对象.允许添加＝逻辑型

例程：

说明：

允许添加数据源数据。

使用数据源时，通常将其可视设置为假，不直接使用数据源组件；此属性只是将数据源组件的添加钮禁止。

参见：例程1


置光标 方法 所属对象：表格

允许删除 属性 数据类型：逻辑型； 操作系统支持：Windows

指定是否允许操作者删除数据源内的记录，注意本属性并不限制在程序中直接删除记录。

语法：对象.允许删除＝逻辑型

例程：

说明：

允许删除数据源数据。

使用数据源时，通常将其可视设置为假，不直接使用数据源组件；此属性只是将数据源组件的删除钮禁止。

参见：例程1


到首记录 方法 所属对象：数据源

到首记录 方法 　英文命令：GoTop　操作系统支持：Windows 所属对象：数据源

将数据源中当前记录指针移动到第一条记录上。

语法： 无返回值 数据源．到首记录 （）

例程：

说明：

将数据源1的记录指针移到第一条记录上。

参见：例程1


到尾记录 方法 所属对象：数据源

到尾记录 方法 　英文命令：GoBottom　操作系统支持：Windows 所属对象：数据源

将数据源中当前记录指针移动到最后一条记录上。

语法： 无返回值 数据源．到尾记录 （）

例程：

说明：

将数据源1的记录指针移到最后一条记录上。

参见：例程1


跳过 方法 所属对象：数据源

跳过 方法 　英文命令：skip　操作系统支持：Windows 所属对象：数据源

将数据源中当前记录指针向前或者向后移动数条记录。

语法： 无返回值 数据源．跳过 （［欲跳过的记录数］）

参数名 | 描 述
欲跳过的记录数 | 可选的；整数型。参数值如果为负数，则向前移动，否则向后移动。如果本参数被省略，默认值为 1 ，即向后移动一条记录。

例程：

说明：

选择单元格时应该用数据源1.跳到（表格1.取光标行号（））,将记录指针移到被选择单元格位置处，然后用跳过命令，使被选择单元格与记录指针同步。

参见：例程1


跳到 方法 所属对象：数据源

跳到 方法 　英文命令：goto　操作系统支持：Windows 所属对象：数据源

改变数据源中的当前记录指针到指定的记录号。

语法： 无返回值 数据源．跳到 （欲跳到的记录号）

参数名 | 描 述
欲跳到的记录号 | 必需的；整数型。参数值所指定的记录号从 1 开始，即首记录的记录号为 1 ，依此类推。

例程：

说明：

将数据源1的记录指针移到编辑框1中输入的记录号上，然后可以对其进行读写。

参见：例程1


取记录号 方法 所属对象：数据源

取记录号 方法 　英文命令：RecNO　操作系统支持：Windows 所属对象：数据源

返回数据源当前记录指针所指向记录的记录号。记录号从1开始。如果当前记录指针无效，所返回记录号为0。

语法： 整数型 数据源．取记录号 （）

例程：

说明：

使用数据源的“跳到()”方法，将记录指针移动表格的行号对应的记录上，然后用信息框显示数据源的当前记录号。

参见：例程1


取表头行数 方法 所属对象：数据源

取表头行数 方法 　英文命令：GetFixedRowCount　操作系统支持：Windows 所属对象：数据源

返回当以表格的形式表现数据源中的数据时表头所占的行数。表头行在表格中显示时不会滚动，在打印时会自动打印在每一页的顶部。

语法： 整数型 数据源．取表头行数 （）

例程：

说明：

使用“取表头行数()”方法，将取数据源1的表头行数并存放在“表头行数变量”中，然后用信息框显示表头行数。

参见：例程1


置表头行数 方法 所属对象：数据源

置表头行数 方法 　英文命令：SetFixedRowCount　操作系统支持：Windows 所属对象：数据源

设置当以表格的形式表现数据源中的数据时表头所占的行数。表头行在表格中显示时不会滚动，在打印时会自动打印在每一页的顶部。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置表头行数 （［表头行数］）

参数名 | 描 述
表头行数 | 可选的；整数型。参数值如果为-1，则自动调整由于单元格组合而产生的行格式错误。如果本参数被省略，默认值为-1。

例程：

说明：

设置数据源的表头行数，如果数据源的提供者为数据库提供者，该设置无效。

参见：例程1


取表头列数 方法 操作系统支持：Windows 所属对象：数据源

取表头列数 方法 　英文命令：GetFixedColCount　操作系统支持：Windows 所属对象：数据源

返回当以表格的形式表现数据源中的数据时表头所占的列数。表头列在表格中显示时不会滚动。

语法： 整数型 数据源．取表头列数 （）

例程：

说明：

将数据源的表头列数取出，存放在“表头列数变量”中，并用信息框显示表头列数。

参见：例程1


置表头列数 方法 所属对象：数据源

置表头列数 方法 　英文命令：SetFixedColCount　操作系统支持：Windows 所属对象：数据源

设置当以表格的形式表现数据源中的数据时表头所占的列数。表头列在表格中显示时不会滚动。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置表头列数 （［表头列数］）

参数名 | 描 述
表头列数 | 可选的；整数型。参数值如果为-1，则自动调整由于单元格组合而产生的列格式错误。如果本参数被省略，默认值为-1。

例程：

说明：

将数据源的表头列数设置为“表头列数编辑框”中输入的列数，不支持此特性的数据提供者，该命令无效。

参见：例程1


取行高 方法 所属对象：数据源

取行高 方法 　英文命令：GetRowHeight　操作系统支持：Windows 所属对象：数据源

返回数据源中指定行在表现时的高度，单位为0.1毫米。

语法： 整数型 数据源．取行高 （行号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。

例程：

说明：

取得数据源中指定行的行高，行高单位为0.1毫米，并不是屏幕上的像素单位。

参见：例程1


置行高 方法 所属对象：数据源

置行高 方法 　英文命令：SetRowHeight　操作系统支持：Windows 所属对象：数据源

设置数据源中数据行在表现时的高度，单位为0.1毫米。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置行高 （行号，［行数］，高度）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
高度 | 必需的；整数型。单位0.1毫米。

例程：

说明：

设置数据源的行高，单位为0.1毫米，并不是屏幕上的像素单位。

参见：例程1


取列宽 方法 所属对象：数据源

取列宽 方法 　英文命令：GetColWidth　操作系统支持：Windows 所属对象：数据源

返回数据源中指定列在表现时的宽度，单位为0.1毫米。

语法： 整数型 数据源．取列宽 （列号）

参数名 | 描 述
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取数据源的指定列列宽，并存放在“列框变量”中，然后用编辑框显示取出的列宽。

参见：例程1


置列宽 方法 所属对象：数据源

置列宽 方法 　英文命令：SetColWidth　操作系统支持：Windows 所属对象：数据源

设置数据源中数据列在表现时的宽度，单位为0.1毫米。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置列宽 （列号，［列数］，宽度）

参数名 | 描 述
列号 | 必需的；整数型。列号从1开始。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
宽度 | 必需的；整数型。单位0.1毫米。

例程：

说明：

设置数据源的列宽，单位为0.1毫米，并不是屏幕的像素单位。

参见：例程1


取类型 方法 所属对象：数据源

取类型 方法 　英文命令：GetType　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格的数据类型。返回值为以下常量值之一： 1、#文本； 2、#图片文件名； 3、#图片数据； 4、#字节集数据。

语法： 整数型 数据源．取类型 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得数据源指定位置的数据类型，存放在“类型变量”中，最后用信息框显示出来，行列号从1开始。

参见：例程1


置类型 方法 所属对象：数据源

置类型 方法 　英文命令：SetType　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格的数据类型。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置类型 （行号，列号，［行数］，［列数］，［类型］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
类型 | 可选的；整数型。可以为以下常量值之一： 1、#文本； 2、#图片文件名； 3、#图片数据； 4、#字节集数据。如果本参数被省略，默认值为“#文本”。

例程：

说明：

设置数据源行列的类型，行列号从1开始。

参见：例程1


取文本色 方法 所属对象：数据源

取文本色 方法 　英文命令：GetTextColor　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时的文本颜色。

语法： 整数型 数据源．取文本色 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得数据源某行列的文本颜色，行列号从1开始。

参见：例程1


置文本色 方法 所属对象：数据源

置文本色 方法 　英文命令：SetTextColor　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现时的文本颜色。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置文本色 （行号，列号，［行数］，［列数］，［文本颜色］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
文本颜色 | 可选的；整数型。如果本参数被省略，默认值为黑色。

例程：

说明：

设置数据源行列的文本颜色，行列号从1开始。

参见：例程1


取背景色 方法 所属对象：数据源

取背景色 方法 　英文命令：GetBackground　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时的背景颜色。

语法： 整数型 数据源．取背景色 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得数据源某行列的背景颜色，行列号从1开始。

参见：例程1


置背景色 方法 所属对象：数据源

置背景色 方法 　英文命令：SetBackground　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现时的背景颜色。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置背景色 （行号，列号，［行数］，［列数］，［背景颜色］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
背景颜色 | 可选的；整数型。如果本参数被省略，默认值为透明色。

例程：

说明：

设置表格行列的背景色，行列号从1开始。

参见：例程1


取字体名 方法 所属对象：数据源

取字体名 方法 　英文命令：GetFontName　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时所使用字体的名称。

语法： 文本型 数据源．取字体名 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格某行列的字体名称，行列号从1开始。

参见：例程1


置字体名 方法 所属对象：数据源

置字体名 方法 　英文命令：SetFontName　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现时所使用字体的名称。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置字体名 （行号，列号，［行数］，［列数］，［字体名称］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
字体名称 | 可选的；文本型。如果本参数被省略，默认值为“宋体”。

例程：

说明：

设置表格行列的字体，行列号从1开始。

参见：例程1


取字体尺寸 方法 所属对象：数据源

取字体尺寸 方法 　英文命令：GetFontSize　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时所使用字体的尺寸，单位为0.1毫米。

语法： 整数型 数据源．取字体尺寸 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

设置表格行列的字体尺寸，行列号从1开始。

参见：例程1


置字体尺寸 方法 所属对象：数据源

置字体尺寸 方法 　英文命令：SetFontSize　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现时所使用字体的尺寸，单位为0.1毫米。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置字体尺寸 （行号，列号，［行数］，［列数］，［字体尺寸］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
字体尺寸 | 可选的；整数型。如果本参数被省略，默认值为40。

例程：

说明：

设置表格行列字体的尺寸，行列号从1开始。

参见：例程1


取字体属性 方法 所属对象：数据源

取字体属性 方法 　英文命令：GetFontAttr　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时所使用字体的属性。返回值为以下常量值之一或之和： 1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。

语法： 整数型 数据源．取字体属性 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格行列的字体属性，行列号从1开始。

参见：例程1


置字体属性 方法 所属对象：数据源

置字体属性 方法 　英文命令：SetFontAttr　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现时所使用字体的属性。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置字体属性 （行号，列号，［行数］，［列数］，［字体属性］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
字体属性 | 可选的；整数型。可以为以下常量值之一或之和： 1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。如果本参数被省略，默认值为0。

例程：

说明：

设置表格行列的字体属性，行列号从1开始。

参见：例程1


取边距 方法 所属对象：数据源

取边距 方法 　英文命令：GetExtra　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现其中数据时至其单元格边框之间的空白距离，单位为0.1毫米。

语法： 整数型 数据源．取边距 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

说明：

说明：

取得表格行列的边距，行列号从1开始。

参见：例程1


置边距 方法 所属对象：数据源

置边距 方法 　英文命令：SetExtra　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现其中数据时至其单元格边框之间的空白距离，单位为0.1毫米。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置边距 （行号，列号，［行数］，［列数］，［边距］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
边距 | 可选的；整数型。如果本参数被省略，默认值为9。

例程：

说明：

设置表格行列的边距，行列号从1开始。

参见：例程1


取文本输入格式 方法 所属对象：数据源

取文本输入格式 方法 　英文命令：GetInputType　操作系统支持：Windows 所属对象：数据源

返回数据源中某文本型单元格的输入格式。当新的数据通过输入方式更新到该单元格内之前，将首先自动根据此格式转换。返回值为以下常量值之一： 0、#通常型； 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型。

语法： 整数型 数据源．取文本输入格式 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格行列的文本输入格式，行列号从1开始。

参见：例程1


置文本输入格式 方法 所属对象：数据源

置文本输入格式 方法 　英文命令：SetInputType　操作系统支持：Windows 所属对象：数据源

设置数据源中某文本型单元格的输入格式。当新的数据通过输入方式更新到该单元格内之前，将首先自动根据此格式转换。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置文本输入格式 （行号，列号，［行数］，［列数］，［输入格式］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
输入格式 | 可选的；整数型。可以为以下常量值之一： 0、#通常型； 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型。 如果本参数被省略，默认值为“#通常型”。

例程：

说明：

设置表格行列的文本输入格式，行列号从1开始。

参见：例程1


取对齐方式 方法 所属对象：数据源

取对齐方式 方法 　英文命令：GetAlignMode　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时所使用的对齐方式。返回值为以下常量值之一： 1、#上左； 2、#上中； 3、#上右； 4、#中左； 5、#中中； 6、#中右； 7、#下左； 8、#下中； 9、#下右； 10、#缩放图片； 11、#居中图片； 12、#缩放居中图片； 13、#平铺图片； 14、#缩放平铺图片。

语法： 整数型 数据源．取对齐方式 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格行列的对齐方式，行列号从1开始。

参见：例程1


置对齐方式 方法 所属对象：数据源

置对齐方式 方法 　英文命令：SetAlignMode　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格在表现时所使用的对齐方式。注意如果数据源所使用的数据提供者不支持某些属性，该属性将被忽略。

语法： 无返回值 数据源．置对齐方式 （行号，列号，［行数］，［列数］，［对齐方式］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
对齐方式 | 可选的；整数型。可以为以下常量值之一：1、#上左； 2、#上中； 3、#上右； 4、#中左； 5、#中中； 6、#中右； 7、#下左； 8、#下中； 9、#下右； 10、#缩放图片； 11、#居中图片； 12、#缩放居中图片； 13、#平铺图片； 14、#缩放平铺图片。 其中 10 到 14 对齐方式仅对图片型单元格有效。如果本参数被省略，默认值为“#上左”。

例程：

说明：

设置表格行列的对齐方式，行列号从1开始。

参见：例程1


取密码方式 方法 所属对象：数据源

取密码方式 方法 　英文命令：GetPwdMode　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时是否使用密码方式。

语法： 逻辑型 数据源．取密码方式 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格某行列是否为密码方式，行列号从1开始。

参见：例程1


置密码方式 方法 所属对象：数据源

置密码方式 方法 　英文命令：SetPwdMode　操作系统支持：Windows 所属对象：数据源

如设置值为真，则数据源中指定单元格在表现时以密码字符呈现。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置密码方式 （行号，列号，［行数］，［列数］，设置值）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
设置值 | 必需的；逻辑型。

例程：

说明：

设置表格行列输入方式为密码方式，密码方式输入文本显示为“***”

参见：例程1


取文本 方法 所属对象：数据源

取文本 方法 　英文命令：GetText　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格的文本内容。

语法： 文本型 数据源．取文本 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格光标所在行列的文本，并用信息框显示，行列号从1开始。

参见：例程1


置文本 方法 所属对象：数据源

置文本 方法 　英文命令：SetText　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格的文本内容，注意该单元格类型必须为“#文本”或“#图片文件名”。

语法： 无返回值 数据源．置文本 （行号，列号，文本或图片文件名）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
文本或图片文件名 | 必需的；文本型。

例程：

说明：

设置表格某行列的文本，行列号从1开始。

参见：例程1


取数据 方法 所属对象：数据源

取数据 方法 　英文命令：GetData　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格的图片或字节集数据内容。

语法： 字节集 数据源．取数据 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得数据源某行列的数据，行列号从1开始。

参见：例程1


置数据 方法 所属对象：数据源

置数据 方法 　英文命令：SetData　操作系统支持：Windows 所属对象：数据源

设置数据源中指定单元格的图片或字节集数据内容，注意该单元格类型必须为“#图片数据”或“#字节集数据”。

语法： 无返回值 数据源．置数据 （行号，列号，数据）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
数据 | 必需的；字节集。

例程：

说明：

将读入的数据设置为表格光标所在行列的数据，行列号从1开始。

参见：例程1


合并 方法 所属对象：数据源

合并 方法 　英文命令：Cmb　操作系统支持：Windows 所属对象：数据源

组合数据源中指定范围内的单元格，使之以一个单元格的形式表现。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．合并 （行号，列号，［行数］，［列数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

将表格中几行几列合并成一个大行列，注意，合并后的行列号不变，比如说1，2，3中1，2行合并成一行，合并后并不是变成1，2行，而是1，3行，第二行合并到第一行中，但是第三行的行号是不会变的。

参见：例程1


分解 方法 所属对象：数据源

分解 方法 　英文命令：Split　操作系统支持：Windows 所属对象：数据源

分解数据源中指定的已经组合的单元格，行列参数指向被组合单元格内的任何一个单元格即可。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．分解 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

分解合并的单元格。

注：单个单元格分解无效，在代码里，选择的单元格必须包括在一个已被合并的单元格里。

参见：例程1


是否被合并 方法 所属对象：数据源

是否被合并 方法 　英文命令：HasCmb　操作系统支持：Windows 所属对象：数据源

如果数据源中指定单元格与周边指定单元格有组合关系，返回真，否则返回假。

语法： 逻辑型 数据源．是否被合并 （行号，列号，周边单元格）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
周边单元格 | 必需的；整数型。可以为以下常量值之一： 1、#左单元格； 2、#上单元格； 3、#右单元格； 4、#下单元格。

例程：

说明：

判断被选中的表格行列是否已被合并。

参见：例程1


加线条 方法 所属对象：数据源

加线条 方法 　英文命令：AddLine　操作系统支持：Windows 所属对象：数据源

为数据源中指定范围内单元格添加线条。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．加线条 （行号，列号，［行数］，［列数］，［线条类型］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
线条类型 | 可选的；整数型。可以为以下常量值之一或之和：1、#左边框； 2、#上边框； 4、#右边框； 8、#下边框； 16、#水平线； 32、#垂直线； 64、#单斜线； 128、#双斜线； 256、#交叉线。 如果本参数被省略，默认值为“#左边框 + #上边框 + #右边框 + #下边框”。

例程：

说明：

为表格行列设置线条，行列号从1开始。

参见：例程1


删线条 方法 所属对象：数据源

删线条 方法 　英文命令：RemoveLine　操作系统支持：Windows 所属对象：数据源

将数据源中指定范围内单元格内的线条去除。注意如果数据源所使用的数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．删线条 （行号，列号，［行数］，［列数］，［线条类型］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
线条类型 | 可选的；整数型。可以为以下常量值之一或之和：1、#左边框； 2、#上边框； 4、#右边框； 8、#下边框； 16、#水平线； 32、#垂直线； 64、#单斜线； 128、#双斜线； 256、#交叉线。 如果本参数被省略，默认值为“#左边框 + #上边框 + #右边框 + #下边框”。

例程：

说明：

删除表格中行列的线条，如单元格线条类型与指定线条类型不一致，单元格线条将无法被删除。

参见：例程1


是否有线条 方法 所属对象：数据源

是否有线条 方法 　英文命令：HasLine　操作系统支持：Windows 所属对象：数据源

如果数据源中指定单元格有指定线条，返回真，否则返回假。

语法： 逻辑型 数据源．是否有线条 （行号，列号，线条类型）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
线条类型 | 必需的；整数型。可以为以下常量值之一或之和：1、#左边框； 2、#上边框； 4、#右边框； 8、#下边框； 64、#单斜线； 128、#双斜线； 256、#交叉线。

例程：

说明：

首先使用“是否有线条()”方法判断当前表格是否有线条，如果有线条再进行删除线条的操作。

参见：例程1


清除 方法 所属对象：数据源

清除 方法 　英文命令：cls　操作系统支持：Windows 所属对象：数据源

清除数据源中指定范围内单元格内容为空文本。

语法： 无返回值 数据源．清除 （行号，列号，［行数］，［列数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

清除表格中被选择行列的文本，行列号从1开始。

参见：例程1


置初始属性 方法 所属对象：数据源

置初始属性 方法 　英文命令：SetInitData　操作系统支持：Windows 所属对象：数据源

设置在数据源中初始或者添加新单元格时默认的单元格初始属性。

语法： 无返回值 数据源．置初始属性 （［类型］，［文本颜色］，［背景颜色］，［字体名称］，［字体尺寸］，［字体属性］，［边距］，［对齐方式］，［输入格式］，［添加边框线］）

参数名 | 描 述
类型 | 可选的；整数型。可以为以下常量值之一： 1、#文本； 2、#图片文件名； 3、#图片数据； 4、#字节集数据。如果本参数被省略，默认值为“#文本”。
文本颜色 | 可选的；整数型。如果本参数被省略，默认值为黑色。
背景颜色 | 可选的；整数型。如果本参数被省略，默认值为透明色。
字体名称 | 可选的；文本型。如果本参数被省略，默认值为“宋体”。
字体尺寸 | 可选的；整数型。如果本参数被省略，默认值为40。
字体属性 | 可选的；整数型。可以为以下常量值之一或之和： 1、#粗体； 2、#斜体； 4、#下划线； 8、#删除线。如果本参数被省略，默认值为0。
边距 | 可选的；整数型。如果本参数被省略，默认值为9。
对齐方式 | 可选的；整数型。可以为以下常量值之一：1、#上左； 2、#上中； 3、#上右； 4、#中左； 5、#中中； 6、#中右； 7、#下左； 8、#下中； 9、#下右； 10、#缩放图片； 11、#居中图片； 12、#缩放居中图片； 13、#平铺图片； 14、#缩放平铺图片。 其中 10 到 14 对齐方式仅对图片型单元格有效。如果本参数被省略，默认值为“#上左”。
输入格式 | 可选的；整数型。可以为以下常量值之一： 0、#通常型； 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型。 如果本参数被省略，默认值为“#通常型”。
添加边框线 | 可选的；逻辑型。指定是否在单元格周围添加边框线。如果本参数被省略，默认值为假。

例程：

说明：

只对在置初始属性后添加的行或列有效。程序中使用“置初始属性()”方法，设置了初始的一系列属性后使用“添加行()”方法添加了一行。

参见：例程1


初始尺寸 方法 所属对象：数据源

初始尺寸 方法 　英文命令：InitSize　操作系统支持：Windows 所属对象：数据源

初始数据源中数据的行列数，注意数据源中所有原有数据将被清除。注意某些数据提供者可能不支持此方法。成功返回真，失败返回假。

语法： 逻辑型 数据源．初始尺寸 （［行数］，［列数］）

参数名 | 描 述
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

设置数据源1的初始行数和初始列数。逻辑变量为逻辑型，保存真或假。

此命令与

通用提供者1.初始行数＝2

通用提供者1.初始列数＝2

相似。

参见：例程1


取行数 方法 所属对象：数据源

取行数 方法 　英文命令：GetRowCount　操作系统支持：Windows 所属对象：数据源

返回数据源中现行数据行数。

语法： 整数型 数据源．取行数 （）

例程：

说明：

取得数据源中的现有行数，并用信息框显示。

参见：例程1


取列数 方法 所属对象：数据源

取列数 方法 　英文命令：GetColCount　操作系统支持：Windows 所属对象：数据源

返回数据源中现行数据列数。

语法： 整数型 数据源．取列数 （）

例程：

说明：

取得数据源中现有的列数，并用信息框显示。

参见：例程1


插入行 方法 所属对象：数据源

插入行 方法 　英文命令：InsertRow　操作系统支持：Windows 所属对象：数据源

在数据源中指定位置处插入新数据行。注意某些数据提供者可能不支持在中间插入行。成功返回真，失败返回假。

语法： 逻辑型 数据源．插入行 （行号，［行数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

在表格光标所在行前插入一行，行列号从1开始。

参见：例程1


添加行 方法 所属对象：数据源

添加行 方法 　英文命令：AppendRow　操作系统支持：Windows 所属对象：数据源

在数据源中最后一行后插入新数据行。成功返回真，失败返回假。

语法： 逻辑型 数据源．添加行 （［行数］）

参数名 | 描 述
行数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

在表格最后位置添加行1行，可以一次添加多行。

参见：例程1


删除行 方法 所属对象：数据源

删除行 方法 　英文命令：RemoveRow　操作系统支持：Windows 所属对象：数据源

在数据源中指定位置处删除数据行。成功返回真，失败返回假。

语法： 逻辑型 数据源．删除行 （行号，［行数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

删除表格指定行开始向后的指定行数，行号从1开始。

参见：例程1


插入列 方法 所属对象：数据源

插入列 方法 　英文命令：InsertCol　操作系统支持：Windows 所属对象：数据源

在数据源中指定位置处插入新数据列。成功返回真，失败返回假。

语法： 逻辑型 数据源．插入列 （列号，［列数］）

参数名 | 描 述
列号 | 必需的；整数型。列号从1开始。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

在表格光标所在列插入一列或多列，列号从1开始。

参见：例程1


删除列 方法 所属对象：数据源

删除列 方法 　英文命令：RemoveCol　操作系统支持：Windows 所属对象：数据源

在数据源中指定位置处删除数据列。成功返回真，失败返回假。

语法： 逻辑型 数据源．删除列 （列号，［列数］）

参数名 | 描 述
列号 | 必需的；整数型。列号从1开始。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

从表格光标所在列开始向后删除指定数量的列，列号从1开始。

参见：例程1


添加 方法 所属对象：数据源

添加 方法 　英文命令：AppendFrom　操作系统支持：Windows 所属对象：数据源

将指定其它数据源或者数据提供者中的数据添加到本数据源的尾部。成功返回真，失败返回假。

语法： 逻辑型 数据源．添加 （数据源或数据提供者，［首行行号］，［欲添加行数］）

参数名 | 描 述
数据源或数据提供者 | 必需的；通用型。本参数指定欲添加其数据到数据源中的其它数据源或数据提供者。
首行行号 | 可选的；整数型。指定欲添加数据首行的行号。如果本参数被省略，默认值为1。
欲添加行数 | 可选的；整数型。指定欲添加数据行的行数。如果参数值为-1，则添加首行后的所有数据行。如果本参数被省略，默认值为-1。

例程：

说明：

将指定数据库中的数据填加到表格中，用信息框显示是否添加成功。

参见：例程1


存到字节集 方法 所属对象：数据源

存到字节集 方法 　英文命令：SaveDS　操作系统支持：Windows 所属对象：数据源

将数据源中所有现有数据保存在字节集中返回。如果失败，将返回空字节集。

语法： 字节集 数据源．存到字节集 （）

例程：

说明：

将数据源中的数据存放到字节集变量“字节集变量2”中。

参见：例程1


从字节集读 方法 所属对象：数据源

从字节集读 方法 　英文命令：LoadDS　操作系统支持：Windows 所属对象：数据源

将指定字节集内的数据源数据写入到数据源中，数据源内所有原有数据将被清除。成功返回真，失败返回假。

语法： 逻辑型 数据源．从字节集读 （数据源数据）

参数名 | 描 述
数据源数据 | 必需的；字节集。

例程：

说明：

将字节集变量保存的数据源数据写到数据源1中，字节集变量为字节集。

参见：例程1


存到文件 方法 所属对象：数据源

存到文件 方法 　英文命令：SaveDSFile　操作系统支持：Windows 所属对象：数据源

将数据源中所有现有数据保存到指定文件中。成功返回真，失败返回假。

语法： 逻辑型 数据源．存到文件 （数据源数据文件名）

参数名 | 描 述
数据源数据文件名 | 必需的；文本型。

例程：

说明：

将数据源中的数据保存到文件中，扩展名可以自定义，成功保存后清空数据源。

参见：例程1


从文件读 方法 所属对象：数据源

从文件读 方法 　英文命令：LoadDSFile　操作系统支持：Windows 所属对象：数据源

将指定文件内的数据源数据写入到数据源中，数据源内所有原有数据将被清除。成功返回真，失败返回假。

语法： 逻辑型 数据源．从文件读 （数据源数据文件名）

参数名 | 描 述
数据源数据文件名 | 必需的；文本型。

例程：

说明：

将保存的数据源数据文件读入到数据源中，用信息框显示是否读入成功。

参见：例程1


单元格到字节集 方法 所属对象：数据源

单元格到字节集 方法 　英文命令：SaveDSCell　操作系统支持：Windows 所属对象：数据源

将数据源中指定范围内单元格数据保存在字节集中返回。如果失败，将返回空字节集。

语法： 字节集 数据源．单元格到字节集 （行号，列号，［行数］，［列数］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。

例程：

说明：

将数据源中指定位置的数据读入到字节集变量中。

参见：例程1


字节集到单元格 方法 所属对象：数据源

字节集到单元格 方法 　英文命令：LoadDSCell　操作系统支持：Windows 所属对象：数据源

将指定字节集内的单元格数据写入到数据源中指定位置。成功返回真，失败返回假。

语法： 逻辑型 数据源．字节集到单元格 （行号，列号，单元格数据，［自动扩展］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
单元格数据 | 必需的；字节集。
自动扩展 | 可选的；逻辑型。本参数指定如果数据源内的数据行列数无法容纳即将读入的数据，是否自动扩展。如果本参数被省略，默认值为真。

例程：

说明：

将指定的字节集变量读入到光标所在的单元格中去。

参见：例程1


单元格到文件 方法 所属对象：数据源

单元格到文件 方法 　英文命令：SaveDSCellFile　操作系统支持：Windows 所属对象：数据源

将数据源中指定范围内单元格数据保存到指定文件中。成功返回真，失败返回假。

语法： 逻辑型 数据源．单元格到文件 （行号，列号，［行数］，［列数］，数据源数据文件名）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
数据源数据文件名 | 必需的；文本型。

例程：

说明：

将指定单元格内容保存到文件中，并用信息框显示是否保存成功。如：数据源1.单元格到文件（2，2，2，2，“C:\a.txt”）

参见：例程1


文件到单元格 方法 所属对象：数据源

文件到单元格 方法 　英文命令：LoadDSCellFile　操作系统支持：Windows 所属对象：数据源

将指定文件内的单元格数据写入到数据源中指定位置。成功返回真，失败返回假。

语法： 逻辑型 数据源．文件到单元格 （行号，列号，单元格数据文件名，［自动扩展］）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
单元格数据文件名 | 必需的；文本型。
自动扩展 | 可选的；逻辑型。本参数指定如果数据源内的数据行列数无法容纳即将读入的数据，是否自动扩展。如果本参数被省略，默认值为真。

例程：

说明：

把保存在文件中的数据读入到单元格中。

参见：例程1


刷新 方法 所属对象：数据源

刷新 方法 　英文命令：Refrush　操作系统支持：Windows 所属对象：数据源

通知所有基于本数据源的数据处理者，使其自动从数据源重新获取并显示数据。

语法： 无返回值 数据源．刷新 （）

例程：

说明：

将数据源的数据重新载入到数据处理者并显示。

参见：例程1


保存更改 方法 所属对象：数据源

保存更改 方法 　英文命令：SaveChange　操作系统支持：Windows 所属对象：数据源

通知所有基于本数据源的数据处理者，使其自动将处理或更改后的数据写回到数据源中。

语法： 无返回值 数据源．保存更改 （）

例程：

说明：

数据源的数据处理者为所有可以连接数据源的控件。

参见：例程1


打印设置 方法 所属对象：数据源

打印设置 方法 　英文命令：SetupPrinter　操作系统支持：Windows 所属对象：数据源

调用对话框设置数据的打印配置信息。当操作者按确认按钮退出对话框时返回真，否则返回假。

语法： 逻辑型 数据源．打印设置 （）

例程：

说明：

使用数据源打开打印设置对话框，来设置打印信息。

参见：例程1


取打印设置 方法 所属对象：数据源

取打印设置 方法 　英文命令：GetPrintInf　操作系统支持：Windows 所属对象：数据源

返回打印数据源数据时所将使用的设置信息。

语法： 打印设置信息 数据源．取打印设置 （）

例程：

说明：

取数据源1的打印时的设置信息；设置信息变量为打印设置信息，保存打印设置信息。

参见：例程1


置打印设置 方法 所属对象：数据源

置打印设置 方法 　英文命令：SetPrintInf　操作系统支持：Windows 所属对象：数据源

设置打印数据源数据时所将使用的设置信息。成功返回真，失败返回假。

语法： 逻辑型 数据源．置打印设置 （打印设置信息）

参数名 | 描 述
打印设置信息 | 必需的；打印设置信息。

例程：

说明：

打印设置信息变量为打印设置信息，保存的是欲设置的打印外观，用数据源的“置打印设置()”方法设置当前的打印设置为“设置信息”变量中的内容。

参见：例程1


取打印页宽 方法 所属对象：数据源

取打印页宽 方法 　英文命令：GetPageWidth　操作系统支持：Windows 所属对象：数据源

返回打印数据源数据时所将使用打印纸的正文区域宽度，单位为0.1毫米。注意：1、此宽度不包含页边距；2、“打印设置”命令执行后，如果操作者改变了纸张类型，此值将自动改变。

语法： 整数型 数据源．取打印页宽 （）

例程：

说明：

取数据源1的打印时的页宽，存放在“数值变量”中，并用信息框显示。

参见：例程1


取打印页高 方法 所属对象：数据源

取打印页高 方法 　英文命令：GetPageHeight　操作系统支持：Windows 所属对象：数据源

返回打印数据源数据时所将使用打印纸的正文区域高度，单位为0.1毫米。注意：1、此宽度不包含页边距；2、“打印设置”命令执行后，如果操作者改变了纸张类型，此值将自动改变。

语法： 整数型 数据源．取打印页高 （）

例程：

说明：

取数据源1的打印时的页高，存放在“数值变量”中，并用信息框显示出来。

参见：例程1


取只读方式 方法 所属对象：数据源

取只读方式 方法 　英文命令：GetReadOnly　操作系统支持：Windows 所属对象：数据源

返回数据源中指定单元格在表现时是否只读。

语法： 逻辑型 数据源．取只读方式 （行号，列号）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。

例程：

说明：

取得表格光标所在行是否为只读方式。

参见：例程1


置只读方式 方法 所属对象：数据源

置只读方式 方法 　英文命令：SetReadOnly　操作系统支持：Windows 所属对象：数据源

如设置值为真，则数据源中指定单元格在表现时只能读取而不能写入。注意： 1、如果数据处理者不支持此特性，则本属性无效； 2、如果数据提供者不支持此特性，本命令将被忽略。

语法： 无返回值 数据源．置只读方式 （行号，列号，［行数］，［列数］，设置值）

参数名 | 描 述
行号 | 必需的；整数型。行号从1开始。
列号 | 必需的；整数型。列号从1开始。
行数 | 可选的；整数型。如果本参数被省略，默认值为1。
列数 | 可选的；整数型。如果本参数被省略，默认值为1。
设置值 | 必需的；逻辑型。

例程：

说明：

将表格光标所在的记录的读写方式设置为只读。

参见：例程1


内容被改变 事件 所属对象：编辑框

当前记录改变 事件 所属对象：数据源 操作系统支持：Windows

当操作者按下移动记录按钮移动了当前记录指针后，会产生本事件。

语法： 无返回值 _数据源_当前记录改变 （）

例程：

说明：

数据源1当前记录指针被移动，信息框将被弹出。

只有将数据源可视设置为真，通过手动移动，才能触发此事件。

参见：例程1


内容被改变 事件 所属对象：编辑框

添加记录 事件 所属对象：数据源 操作系统支持：Windows

当操作者按下添加记录按钮添加了新记录后，会产生本事件。

语法： 无返回值 _数据源_添加记录 （）

例程：

说明：

数据源1添加新的记录后，信息框将被弹出。

只有将数据源可视设置为真，通过手动添加，才能触发此事件。

参见：例程1


内容被改变 事件 所属对象：编辑框

删除记录 事件 所属对象：数据源 操作系统支持：Windows

当操作者按下删除记录按钮删除了当前记录后，会产生本事件。

语法： 无返回值 _数据源_删除记录 （）

例程：

说明：

数据源1删除记录后，信息框将被弹出。

只有将数据源可视设置为真，通过手动删除，才能触发此事件。

参见：例程1


通用提供者

通用提供者 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

通用提供者用作为数据源提供对数据的通常存取操作。使用内存作为数据的存储仓库，全面支持所有数据操作接口。因此必要时可以将其它类型数据提供者内的数据转移到此类型中，以全面发挥数据源对数据的操纵能力。

属性：


置光标 方法 所属对象：表格

初始行数 属性 数据类型：整数型；

语法：对象.初始行数＝整数型

例程：

说明：

设置通用提供者所连接数据源的初始行数为20行。

参见：例程1


置光标 方法 所属对象：表格

初始列数 属性 数据类型：整数型；

语法：对象.初始列数＝整数型

例程：

说明：

设置通用提供者1所连接数据源的初始列数为3列。

参见：例程1


数据库提供者

数据库提供者 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

数据库提供者用作为数据源提供对数据库的存取操作。它使用数据库作为数据的存储仓库，不支持以下数据操作接口： 1、置行高； 2、置类型； 3、置文本色； 4、置背景色； 5、置字体名； 6、置字体尺寸； 7、置字体属性； 8、置边距； 9、置文本输入格式； 10、置对齐方式； 11、置密码方式； 12、合并； 13、分解； 14、加线条； 15、删线条； 16、初始尺寸时同时改变列数； 17、在中间插入行； 18、插入列； 19、删除列。 如果想对数据进行以上操作，应该先将数据通过数据源导出到通用提供者中。

属性：


置光标 方法 所属对象：表格

数据库文件名 属性 数据类型：文本型；

语法：对象.数据库文件名＝文本型

例程：

说明：

设置数据库要打开的易数据库文件名为通用对话框打开的文件名。

参见：例程1


置光标 方法 所属对象：表格

字节集字段处理 属性 数据类型：整数型；

本属性指定对字节集类型字段的处理方式。

可供选择的属性值：
0、跳过
1、视为图片数据
2、视为字节集数据

语法：对象.字节集字段处理＝整数型

例程：

说明：

设置“字节集字段处理”属性为0，则遇到数据类型为字节集的字段，将被跳过，不进行读写。

参见：例程1


置光标 方法 所属对象：表格

数据库密码 属性 数据类型：文本型；

本属性提供访问数据库时所需要的密码。

语法：对象.数据库密码＝文本型

例程：

说明：

提供访问服务器时需要的密码。

数据库提供者1.数据库密码＝“123”

参见：例程1


图形按钮

图形按钮 窗口组件 操作系统支持：Windows 跳至：系统核心支持库

不能接受输入焦点；

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
类型 | 选中 | 正常图片 | 点燃图片
按下图片 | 禁止图片 | 透明颜色 |

自有事件：

被单击

基本事件：


类型 属性 所属对象：图形按钮

数据类型：整数型；

可供选择的属性值：
0、按钮
1、选择框

例程

说明

点击图形按钮后，如果图形按钮类型为“按钮”则设置类型为“选择框”，如果为“选择框”则设置为按钮。

注意，当为“按钮”型，则图形按钮的“选中”属性不可以使用，如果为“选择框”类型，则图形按钮的“点燃图片”属性不可以使用。

参见：例程1


选中 属性 数据类型：逻辑型；

选中对象。

语法： 对象.选中 = 逻辑型

应用对象：

选择框、单选框、图形按钮、菜单、超级按钮

说明：

将选择框的选中属性设置为“真”。

参见：例程1


正常图片 属性 数据类型：字节集型；

将字节集型数据赋值到指定对象的正常图片属性中

语法： 对象.正常图片 = 字节集型

应用对象：

图形按钮

例程

说明

使用通用对话框改变图形按钮的正常图片。

参见：例程1


点燃图片 属性 操作系统支持：Windows

数据类型：字节集；当类型为按钮时，本属性指定当鼠标移动到按钮上时所显示图片(不支持ICO或CUR图片数据)。

语法： 对象.点燃图片 = 字节集型

应用对象：

图形按钮、超级按钮

例程

说明

给图形按钮的点燃图片属性一个图片资源中的一个图片。设置后，当鼠标放在图形按钮上时，则会显示点燃图片。

参见：例程1


按下图片 属性 数据类型：字节集型；

将字节集型数据赋值到指定对象的按下图片属性中

语法： 对象.按下图片 = 字节集型

应用对象：

图形按钮

例程

说明

使用通用对话框给图形按钮更换按下图片，当图形按钮被按下时会显示按下图片。

参见：例程1


禁止图片 属性 所属对象：图形按钮 操作系统支持：Windows

禁止图片 属性 操作系统支持：Windows

数据类型：字节集；本属性指定当按钮被禁止后所显示图片(不支持ICO或CUR图片数据)。

语法： 对象.禁止图片 = 字节集型

应用对象：

图形按钮、超级按钮

例程

说明

给图形按钮禁止图片属性一张图片，当图形按钮被禁止后，将会显示这张图片。

参见：例程1


透明颜色 属性 操作系统支持：Windows

数据类型：整数型；指定所有图片中透明部分的颜色。如果为“#默认色”常量值，则表示无透明色。

语法： 对象.透明颜色 = 整数型

应用对象：

图形按钮、高级影像框

例程

说明

图形按钮正常图片为一张白色背景的图片，设置图片按钮的透明颜色为白色，则该图片的背景将变成透明。

参见：例程1


被单击 事件 所属对象：图形按钮 操作系统支持：Windows

当单击按钮后即产生此事件。

语法： 无返回值 _图形按钮_被单击 （）

例程

说明

当图形按钮被单击，则弹出信息框显示“欢迎使用易语言”。

参见：例程1


外部数据库

外部数据库 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

本组件提供通过ODBC对外部数据库直接操作的方法。

方法：

打开 | 关闭 | 取连接文本 | 启动事务
回滚事务 | 提交事务 | 查询 | 重新查询
关闭记录集 | 首记录前 | 尾记录后 | 到首记录
到尾记录 | 到前一记录 | 到后一记录 | 读
执行 | 打开MDB数据库 | 打开SQL数据库 |


打开 方法 所属对象：外部数据库

打开 方法 　英文命令：open　操作系统支持：Windows 所属对象：外部数据库

打开指定的ODBC数据源以供以后操作。成功返回真，失败返回假。

语法： 逻辑型 外部数据库．打开 （［ODBC数据源连接文本］，［是否只读］）

参数名 | 描 述
ODBC数据源连接文本 | 可选的；文本型。指定指向ODBC数据源的连接文本，如果为空，则激活ODBC数据源选择对话框。如果参数被省略，默认值为空。
是否只读 | 可选的；逻辑型。指定是否以只读方式打开。如果参数被省略，默认值为假。

例程：

说明：

打开指定的ＯＤＢＣ连接，如果参数为空，则激活ＯＤＢＣ数据源选择对话框。

参见：例程1 MSAccess.mdb 例程2


关闭 方法 所属对象：外部数据库

关闭 方法 　英文命令：close　操作系统支持：Windows 所属对象：外部数据库

关闭当前被打开的数据库。

语法： 无返回值 外部数据库．关闭 （）

例程：

说明：

关闭被打开的数据库。

参见：例程1 MSAccess.mdb 例程2


取连接文本 方法 所属对象：外部数据库

取连接文本 方法 　英文命令：GetConnect　操作系统支持：Windows 所属对象：外部数据库

返回当前被打开数据库的ODBC数据源连接文本。失败返回空文本。

语法： 文本型 外部数据库．取连接文本 （）

例程：

说明：

如果连接了数据库，可以用本命令取得连接后的文本。

参见：例程1 MSAccess.mdb 例程2


启动事务 方法 所属对象：外部数据库

启动事务 方法 　英文命令：BeginTrans　操作系统支持：Windows 所属对象：外部数据库

启动当前被打开数据库的事务，成功返回真，失败返回假。

语法： 逻辑型 外部数据库．启动事务 （）

例程：

说明：

进行事务控制的主要流程如下：

“启动事务”

……

进行多项数据库操作，一旦有一项失败则“回滚事务”，使数据恢复到“启动事务”之前的状态。

……

所有数据库操作全部成功完成，则“提交事务”。

参见：例程 Access数据库


回滚事务 方法 所属对象：外部数据库

回滚事务 方法 　英文命令：RollbackTrans　操作系统支持：Windows 所属对象：外部数据库

回滚当前被打开数据库的事务，所有在上一次事务提交前对数据库所作的修改均被取消。

语法： 无返回值 外部数据库．回滚事务 （）

例程：

说明：

进行事务控制的主要流程如下：

“启动事务”

……

进行多项数据库操作，一旦有一项失败则“回滚事务”，使数据恢复到“启动事务”之前的状态。

……

所有数据库操作全部成功完成，则“提交事务”。

参见：例程 Access数据库


提交事务 方法 所属对象：外部数据库

提交事务 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

提交当前被打开数据库的事务。

语法： 无返回值 外部数据库．提交事务 （）

例程：

说明：

进行事务控制的主要流程如下：

“启动事务”

……

进行多项数据库操作，一旦有一项失败则“回滚事务”，使数据恢复到“启动事务”之前的状态。

……

所有数据库操作全部成功完成，则“提交事务”。

参见：例程 Access数据库


查询 方法 所属对象：外部数据库

查询 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

对当前被打开数据库进行数据查询，成功返回结果记录集句柄，失败返回0。注意当不再使用此记录集时，必须使用“关闭记录集”命令将其关闭。

语法： 整数型 外部数据库．查询 （查询类SQL语句）

参数名 | 描 述
查询类SQL语句 | 必需的；文本型。本参数提供用作查询的SELECT语句。

例程：

说明：

根据SQL查询语句来查询数据库记录，成功返回记录集句柄。

参见：例程1 MSAccess.mdb 例程2


重新查询 方法 所属对象：外部数据库

重新查询 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

对指定的记录集进行重新查询，并将其当前记录指针重定位到首记录。成功返回真，失败返回假。

语法： 逻辑型 外部数据库．重新查询 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

对指定的记录集进行重新查询。

参见：例程1 MSAccess.mdb 例程2


关闭记录集 方法 所属对象：外部数据库

关闭记录集 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

关闭指定的记录集。

语法： 无返回值 外部数据库．关闭记录集 （［记录集句柄］）

参数名 | 描 述
记录集句柄 | 可选的；整数型。指定欲关闭记录集的句柄，记录集句柄由“查询”命令返回。如果参数值为0，则关闭所有记录集。如果参数被省略，默认值为0。

例程：

说明：

通过查询等命令返回的记录集，在不使用的时候用本命令来关闭。

参见：例程1 MSAccess.mdb 例程2


首记录前 方法 所属对象：外部数据库

首记录前 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

如果指定记录集的当前记录指针已在首记录的前面，返回真，否则返回假。

语法： 逻辑型 外部数据库．首记录前 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

判断当前记录指针时候在首记录前面。

参见：例程1 MSAccess.mdb 例程2


尾记录后 方法 所属对象：外部数据库

尾记录后 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

如果指定记录集的当前记录指针已在尾记录的后面，返回真，否则返回假。

语法： 逻辑型 外部数据库．尾记录后 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

判断当前记录指针是否在尾记录之后。

参见：例程1 MSAccess.mdb 例程2


到首记录 方法 所属对象：外部数据库

到首记录 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

将指定记录集的当前记录指针移动到第一条记录上。

语法： 无返回值 外部数据库．到首记录 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

将指定记录集指针移动到首记录上。

参见：例程1 MSAccess.mdb 例程2


到尾记录 方法 所属对象：外部数据库

到尾记录 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

将指定记录集的当前记录指针移动到最后一条记录上。

语法： 无返回值 外部数据库．到尾记录 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

将指定记录集的指针移动到尾记录上。

参见：例程1 MSAccess.mdb 例程2


到前一记录 方法 所属对象：外部数据库

到前一记录 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

将指定记录集的当前记录指针向前移动一条记录。

语法： 无返回值 外部数据库．到前一记录 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

将指定记录集的记录指针向前移动一个记录。

参见：例程1 MSAccess.mdb 例程2


到后一记录 方法 所属对象：外部数据库

到后一记录 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

将指定记录集的当前记录指针向后移动一条记录。

语法： 无返回值 外部数据库．到后一记录 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。

例程：

说明：

将指定的记录集记录指针向后移动一个记录。

参见：例程1 MSAccess.mdb 例程2


读 方法 所属对象：外部数据库

读 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

返回指定记录集的当前记录处指定字段的数据内容，所返回数据的类型与字段SQL类型对照表如下： 返回数据类型 字段SQL类型 ------------------------------------------------- 逻辑型 BIT 字节型 TINYINT 短整数型 SMALLINT 整数型 INTEGER 单精度型 REAL 双精度型 FLOAT、DOUBLE 日期时间型 DATE、TIME、TIMESTAMP 文本型 NUMERIC、DECIMAL、BIGINT、CHAR、VARCHAR、LONGVARCHAR 字节集型 BINARY、VARBINARY、LONGVARBINARY 如果因为找不到指定字段而导致读入失败将返回空文本，如果因为其他原因而读入失败将返回对应该字段类型的空数据，即：逻辑型返回假，日期时间型返回100年1月1日，文本型返回空文本，字节集型返回空字节集，其它所有数值型返回0。 另外，由于ODBC的支持特性，如果不移动记录指针，只能对当前记录上各字段的内容读入一次。因此，如果需要持续使用所读出的数据，请使用变量将其保存。 注：写入字段数据请用“UPDATE”SQL语句实现。

语法： 通用型 外部数据库．读 （记录集句柄，字段名称或位置）

参数名 | 描 述
记录集句柄 | 必需的；整数型。指定欲操作记录集的句柄。记录集句柄由“查询”命令返回。
字段名称或位置 | 必需的；通用型。参数值可以为一个字段名称文本或者一个字段位置数值，字段位置数值从 1 开始。

例程：

说明：

读取当前记录集指针所在位置的记录。

参见：例程1 MSAccess.mdb 例程2


执行 方法 所属对象：外部数据库

执行 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

执行指定的非查询类SQL语句，SQL语句中的列名（尤其是中文列名）可用中括号括住。如果SQL语句中涉及到备注或者字节集型字段，请在相应位置加上问号，然后再加上对应的文本型或字节集型数据参数，参数数目必须与问号的数目一致。例如，修改数据表student中编号为100的学生像片的语句为： 外部数据库1.执行 (“update student set picture = ? where no = 100”, 像片数据)。 成功返回真，失败返回假。

语法： 逻辑型 外部数据库．执行 （非查询类SQL语句，［文本或字节集］，… ）

参数名 | 描 述
非查询类SQL语句 | 必需的；文本型。本参数提供非查询类SQL语句（无结果集返回），如修改、删除、添加等等。
文本或字节集 | 可选的；可扩充的；通用型。本参数仅用作为SQL语句中的备注或字节集型SQL参数（用问号标识其位置）提供相应数据，必须为文本或者字节集型（与SQL参数类型对应）。如果SQL语句中没有包含SQL参数，则应该省略本参数。

例程：

说明：

执行SQL语句中的非查询类命令。

参见：例程1 MSAccess.mdb 例程2


打开MDB数据库 方法 所属对象：外部数据库

打开MDB数据库 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

本命令是针对 ACCESS MDB 数据库的特定打开方法，通过自建 ODBC 连接文本来打开 MDB 数据库。调用本命令后无需再调用“打开”命令。成功返回真，失败返回假。

语法： 逻辑型 外部数据库．打开MDB数据库 （MDB数据库文件名，［用户名］，［密码］，［是否只读］，［保留参数］）

参数名 | 描 述
MDB数据库文件名 | 必需的；文本型。本参数提供即将打开数据库的文件名。
用户名 | 可选的；文本型。本参数提供打开数据库所需要的用户名，如果省略本参数，默认为不需要。
密码 | 可选的；文本型。本参数提供打开数据库所需要的密码，如果省略本参数，默认为不需要。
是否只读 | 可选的；逻辑型。指定是否以只读方式打开。如果参数被省略，默认值为假。
保留参数 | 可选的；整数型。本参数保留用作以后使用。

例程：

说明：

打开指定的ACCESS的MDB数据库文件。

参见：例程1


打开SQL数据库 方法 所属对象：外部数据库

打开SQL数据库 方法 　英文命令：SetCaret　操作系统支持：Windows 所属对象：外部数据库

本命令是针对 SQL SERVER 数据库的特定打开方法，通过自建 ODBC 连接文本来打开 SQL SERVER 数据库。调用本命令后无需再调用“打开”命令。成功返回真，失败返回假。

语法： 逻辑型 外部数据库．打开SQL数据库 （服务器名称，［用户名］，［密码］，［数据库名称］，［是否只读］，［保留参数］）

参数名 | 描 述
服务器名称 | 必需的；文本型。本参数提供 SQL SERVER 服务器的名称或其客户端别名。
用户名 | 可选的；文本型。本参数提供登录服务器所需要的用户名，如果省略本参数，默认为不需要。
密码 | 可选的；文本型。本参数提供登录服务器所需要的密码，如果省略本参数，默认为不需要。
数据库名称 | 可选的；文本型。本参数提供即将打开数据库的名称。如果省略本参数，则使用该用户的默认数据库。
是否只读 | 可选的；逻辑型。指定是否以只读方式打开。如果参数被省略，默认值为假。
保留参数 | 可选的；整数型。本参数保留用作以后使用。

例程：

说明：

打开SQL SERVER 数据库，服务器名称可以为路径或者IP地址或者主机名称。

参见：例程1 MSAccess.mdb


外部数据提供者

外部数据提供者 功能型窗口组件 操作系统支持：Windows 跳至：系统核心支持库

外部数据提供者用作为数据源提供对外部ODBC数据库的存取操作。它使用外部数据库作为数据的存储仓库，不支持备注和长字节集类型字段，不支持以下数据操作接口： 1、置行高； 2、置类型； 3、置文本色； 4、置背景色； 5、置字体名； 6、置字体尺寸； 7、置字体属性； 8、置边距； 9、置文本输入格式； 10、置对齐方式； 11、置密码方式； 12、合并； 13、分解； 14、加线条； 15、删线条； 16、初始尺寸时同时改变列数； 17、在中间插入行； 18、插入列； 19、删除列。 如果想对数据进行以上操作，应该先将数据通过数据源导出到通用提供者中。 另外，在支持数据源的“插入行”接口时，将直接插入空白行数据，所以如果目的数据表在某字段上建立了主键索引、强制不为空等类似列约束条件时，将导致插入失败。

属性：


置光标 方法 所属对象：表格

连接文本 属性 数据类型：文本型；

本属性指定用作打开数据库的ODBC连接文本。

语法：对象.连接文本＝文本型

应用对象：

外部数据提供者

例程

说明

设置外部数据库的连接文本，然后用外部数据库组件打开这个数据库。

取连接文本方法：

1．必须有外部数据库文件。如： Access(*.mdb)数据库文件。

2．鼠标点击组件属性框的连接文本属性，如下图：

弹出下图窗口,输入名称，单击“新建”

弹出下图，选择 ；按照提示安装

弹出下图窗口，单击“选择”，

选择要连接的数据库，如下图：

最后一直按“确定”。

参见：例程1 MSAccess.mdb 例程2


查询SQL 属性 数据类型：文本型；

本属性用作指定数据库中的数据表名或者用作查询记录集的SELECT类SQL语句。

语法：对象. 查询SQL=文本型

应用对象：

外部数据提供者

例程

说明

赋值给外部数据库提供者的“查询SQL”属性一段SELECT查询语句。

参见：例程1 MSAccess.mdb 例程2


菜单

菜单 普通类型 操作系统支持：Windows 跳至：系统核心支持库

用作指定某一个菜单项目。

属性：

标题 选中 禁止 可视

自有事件：

被选择


标题 属性 数据类型：文本型；

将文本型数据赋值到指定对象的标题文本。

语法： 对象.标题 = 文本型

例程：

说明：

设置菜单的标题。

参见：例程1


选中 属性 数据类型：逻辑型；

选中对象。

语法： 对象.选中 = 逻辑型

例程：

说明：

将菜单的选中属性设置为“真”。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

例程：

说明：

设置菜单的禁止属性为真。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

例程：

说明：

设置菜单的可视属性。

参见：例程1


被选择 事件 所属对象：菜单 操作系统支持：Windows

当菜单项被用户选择后即产生此事件。

语法： 无返回值 _菜单_被选择 （）

例程：

说明：

只要菜单一被选择，就出发此事件，例程如下：

参见：例程


字体

字体 普通类型 操作系统支持：Windows 跳至：系统核心支持库

成员 | 描 述
角度 | 整数型；以 1 / 10 度为单位。
加粗 | 逻辑型；
倾斜 | 逻辑型；
删除线 | 逻辑型；
下划线 | 逻辑型；
字体大小 | 整数型；初始值为 9 。单位为点（1 / 72 英寸）。
字体名称 | 文本型；初始值为“宋体”。

参见： 基本数据类型


字段信息

字段信息 普通类型 操作系统支持：Windows 跳至：系统核心支持库

成员 | 描 述
名称 | 文本型；名称文本的长度必须在 16 个字符以内。
类型 | 整数型；可以为以下常量值之一： 1、#字节型； 2、#短整数型； 3、#整数型； 4、#长整数型； 5、#小数型； 6、#双精度小数型； 7、#逻辑型； 8、#日期时间型； 10、#文本型； 11、#字节集型； 12、#备注型。
最大文本长度 | 整数型；初始值为 20 。本成员仅当字段类型为“文本型”时才有效，用作指定文本的最大可能长度，其值范围必须在 1 到 512 之间。如果字段类型不为“文本型”，本成员将被忽略。

参见： 基本数据类型


打印设置信息

打印设置信息 普通类型 操作系统支持：Windows 跳至：系统核心支持库

成员 | 描 述
纸张类型 | 整数型；初始值为 0 。本成员设置打印纸类型，可以为以下常量值之一： 0、#默认纸； 1、#A3纸(297x420毫米)； 2、#A4纸(210x297毫米)； 3、#A5纸(148x210毫米)； 4、#B4纸(250x354毫米)； 5、#B5纸(182x257毫米)； 6、#四开(215x275毫米)； 7、#十六开(146x215毫米)； 8、#三十二开(97x151毫米)； 9、#信纸(216x279毫米)； 10、#法律用纸(216x355毫米)； 11、#行政用纸(184x266毫米)； 12、#声明(140x216毫米)； 13、#小报(279x432毫米)； 14、#笔记(216x279毫米)； 15、#帐本(432x279毫米)； 16、#对开纸(216x330毫米)。 除了以上基本类型纸张，还支持以下扩展类型，这些类型值和其所对应纸张宽度与高度（单位毫米）列表如下： 1001: 216x279 1002: 279x432 1003: 432x279 1004: 216x355 1005: 140x216 1006: 184x267 1007: 297x420 1008: 210x297 1010: 148x210 1011: 257x364 1012: 182x257 1013: 216x330 1014: 215x275 1015: 254x355 1016: 279x432 1017: 216x279 1018: 98x225 1019: 105x241 1020: 114x263 1021: 121x279 1022: 127x292 1023: 432x558 1024: 558x863 1025: 863x1117 1026: 110x220 1027: 162x229 1028: 324x458 1029: 229x324 1030: 114x162 1031: 114x229 1032: 250x353 1033: 176x250 1034: 176x125 1035: 110x230 1036: 98x190 1037: 92x165 1038: 378x279 1039: 216x305 1040: 216x330 1041: 250x353 1042: 100x148 1043: 228x279 1044: 254x279 1045: 381x279 1046: 220x220 1049: 241x305 1050: 241x381 1051: 305x457 1052: 235x322 1053: 216x279 1054: 210x297 1055: 241x305 1056: 227x356 1057: 305x487 1058: 216x322 1059: 210x330 1060: 148x210 1061: 182x257 1062: 322x445 1063: 174x235 1064: 201x276 1065: 420x594 1066: 297x420 1067: 322x445 1068: 200x148 1069: 105x148 1070: 240x332 1071: 216x277 1072: 120x235 1073: 90x205 1074: 279x216 1075: 420x297 1076: 297x210 1077: 210x148 1078: 364x257 1079: 257x182 1080: 148x100 1081: 148x200 1082: 148x105 1083: 332x240 1084: 277x216 1085: 235x120 1086: 205x90 1087: 128x182 1088: 182x128 1089: 305x279 1090: 105x235 1091: 235x105 1092: 188x260 1093: 130x184 1094: 140x203 1095: 102x165 1096: 102x176 1097: 125x176 1098: 110x208 1099: 110x220 1100: 120x230 1101: 160x230 1102: 120x309 1103: 229x324 1104: 324x458 1105: 260x188 1106: 184x130 1107: 203x140 1108: 165x102 1109: 176x102 1110: 176x125 1111: 208x110 1112: 220x110 1113: 230x120 1114: 230x160 1115: 309x120 1116: 324x229 1117: 458x324 注意如果所选择纸张得不到打印机的支持，打印机将会自动选择最接近的纸张。
纸张方向 | 整数型；初始值为 0 。本成员设置打印纸的放置方向，可以为以下常量值之一： 0、#纵向； 1、#横向。
左边距 | 整数型；初始值为 230 。本成员设置正文打印区到打印纸左边缘的距离，单位为0.1毫米。
上边距 | 整数型；初始值为 230 。本成员设置正文打印区到打印纸上边缘的距离，单位为0.1毫米。
右边距 | 整数型；初始值为 230 。本成员设置正文打印区到打印纸右边缘的距离，单位为0.1毫米。
下边距 | 整数型；初始值为 230 。本成员设置正文打印区到打印纸下边缘的距离，单位为0.1毫米。
页号位置 | 整数型；初始值为 0 。本成员设置是否打印页号及页号的打印位置。可以为以下常量值之一： 0、无页号；1、#上左页号； 2、#上中页号； 3、#上右页号； 4、#下左页号； 5、#下中页号； 6、#下右页号。
打印份数 | 整数型；初始值为 1 。本成员设置打印时共打印的份数。
首页打印页号 | 整数型；初始值为 1 。本成员设置打印时首页的打印页号。
是否打印到文件 | 逻辑型；初始值为假。本成员设置是否将打印数据输出到指定文件。
打印文件名 | 文本型；如果设置为打印到文件，本成员指定数据输出到的文件名。
自动填充 | 逻辑型；初始值为假。本成员设置是否自动重复尾数据空行填充尾页空白。注意如果“每页打印行数”成员值大于零，本成员无效。
自动添加表格线 | 逻辑型；初始值为假。本成员设置打印时是否自动为单元格添加边框线。
奇偶页方式 | 整数型；初始值为 0 。本成员可为以下常量值之一： 0、#全部页； 1、#仅打印奇数页； 2、#仅打印偶数页。
打印范围方式 | 整数型；初始值为 0 。本成员可为以下常量值之一： 0、#全部页； 1、#页范围； 2、#行范围。
起始打印位置 | 整数型；初始值为 1 。如果打印范围方式为“页范围”，本成员记录首页页号（页号从1开始）；如果打印范围方式为“行范围”，本成员记录首行行号；如果打印范围方式为“全部页”，本成员无效。
结束打印位置 | 整数型；初始值为 0 。如果打印范围方式为“页范围”，本成员记录末页页号（页号从1开始）；如果打印范围方式为“行范围”，本成员记录末行行号；如果打印范围方式为“全部页”，本成员无效。如果本成员值为 0 ，则将一直打印到所有数据行结束。
每页打印行数 | 整数型；初始值为 0 。本成员设置每页打印行数(不包含表头行),如果为0则表示根据页高自动判别。
打印缩放比 | 整数型；初始值为 0 。指定打印时所使用的缩放百分比，值为 -1、-2 或 20 到 1000 之间。其含义如下： -1：#缩放到纸宽。即自动压缩或扩张到纸张宽度打印； -2：#限定到纸宽。即：如果欲打印数据宽度超过纸张宽度，则自动压缩到纸张宽度，否则原样打印； 20 - 1000：直接指定打印缩放百分比； 如果指定为0，则默认为100。

参见： 基本数据类型


对象

对象 普通类型 操作系统支持：Windows 跳至：系统核心支持库

提供对微软公司 COM 对象的支持，注意对象在超出其作用域后会自动被释放，例如：假设对象存在于子程序局部变量中，当子程序调用退出时，该对象会被自动释放。

方法：

创建 | 获取 | 清除 | 是否为空
是否相等 | 读文本属性 | 读数值属性 | 读逻辑属性
读日期属性 | 读对象型属性 | 读属性 | 写属性
方法 | 通用方法 | 文本方法 | 数值方法
逻辑方法 | 日期方法 | 对象型方法 | 创建图片对象
创建字体对象 | 取回图片 | 取回字体 | 取错误
查看 | 取接口 |  |

参见： 基本数据类型


创建 方法 操作系统支持：Windows 所属对象：对象

创建 方法 　英文命令：create　操作系统支持：Windows 所属对象：对象

创建指定类型的 COM 对象，本对象中的原有内容将被释放。成功返回真，否则返回假。

语法： 逻辑型 对象．创建 （对象类型，［类型库文件名］）

参数名 | 描 述
对象类型 | 必需的；文本型。本参数指定对象的类型文本，譬如“Word.Application”、“Excel.Application”、“{000209FF-0000-0000-C000-000000000046}”等均可。
类型库文件名 | 可选的；文本型。如果需要通过类型库才能访问指定对象，可在本参数中提供其类型库或类型库数据所在文件名。注意如果没有提供文件路径，且在当前目录下无法找到该文件，系统将自动进行搜索。如果省略本参数，默认为不需要类型库文件。

例程：

说明：

创建一个系统中存在的com对象的链接，系统中必须存在此对象，否则创建将失败。

参见：例程1


获取 方法 操作系统支持：Windows 所属对象：对象

获取 方法 　英文命令：GetObject　操作系统支持：Windows 所属对象：对象

获取当前操作系统中已经存在的指定类型 COM 对象，本对象中的原有内容将被释放。成功返回真，否则返回假。

语法： 逻辑型 对象．获取 （对象类型）

参数名 | 描 述
对象类型 | 必需的；文本型。本参数指定对象的类型文本，譬如“Word.Application”、“Excel.Application”、“{000209FF-0000-0000-C000-000000000046}”等均可。

例程：

说明：

获取一个com对象，如果原先保存com对象的变量中有com对象，原先的com对象将被释放，获取的com对象必须为系统中存在的对象，否则将失败。

参见：例程1


清除 方法 操作系统支持：Windows 所属对象：对象

清除 方法 　英文命令：cls　操作系统支持：Windows 所属对象：对象

将本对象的内容释放并清空。如果不调用本方法，则对象在退出其作用区域时会自动被释放。例如：假设对象存在于子程序局部变量中，当子程序调用退出时，该对象会被自动释放。

语法： 无返回值 对象．清除 （）

例程：

说明：

清除已经载入的对象。保存com对象的变量空间将被释放。

参见：例程1


是否为空 方法 操作系统支持：Windows 所属对象：对象

是否为空 方法 　英文命令：IsMissing　操作系统支持：Windows 所属对象：对象

如果本对象的内容为空，返回真，否则返回假。

语法： 逻辑型 对象．是否为空 （）

例程：

说明：

查看一个com对象变量是否为空，如果为空，说明对象创建失败或没有这个对象。

参见：例程1


是否相等 方法 操作系统支持：Windows 所属对象：对象

是否相等 方法 　英文命令：IsEqual　操作系统支持：Windows 所属对象：对象

如果本对象的内容与指定对象的内容相等，返回真，否则返回假。

语法： 逻辑型 对象．是否相等 （欲检查的对象）

参数名 | 描 述
欲检查的对象 | 必需的；对象。本参数指定欲检查其内容是否相等的对象。

例程：

说明：

查看一个com对象变量与指定的com对象变量是否相同。

参见：例程1


读文本属性 方法 操作系统支持：Windows 所属对象：对象

读文本属性 方法 　英文命令：GetTextProperty　操作系统支持：Windows 所属对象：对象

读取并返回本对象的指定文本类型属性值，如果失败将返回空文本，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 文本型 对象．读文本属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

读取指定对象的文本型属性，并返回文本。

参见：例程1


读数值属性 方法 操作系统支持：Windows 所属对象：对象

读数值属性 方法 　英文命令：GetNumProperty　操作系统支持：Windows 所属对象：对象

读取并返回本对象的指定数值类型属性值，如果失败将返回数值0，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 双精度小数型 对象．读数值属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

读取指定对象的数值属性，并返回数值。

参见：例程1


读逻辑属性 方法 操作系统支持：Windows 所属对象：对象

读逻辑属性 方法 　英文命令：GetBoolProperty　操作系统支持：Windows 所属对象：对象

读取并返回本对象的指定逻辑型属性值，如果失败将返回假，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 逻辑型 对象．读逻辑属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

读取指定对象的逻辑属性，并返回逻辑值。

参见：例程1


读日期属性 方法 操作系统支持：Windows 所属对象：对象

读日期属性 方法 　英文命令：GetDateProperty　操作系统支持：Windows 所属对象：对象

读取并返回本对象的指定日期时间型属性值，如果失败将返回100年1月1日，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 日期时间型 对象．读日期属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

读取指定对象的日期型值，并返回日期型数据。

参见：例程1


读对象型属性 方法 操作系统支持：Windows 所属对象：对象

读对象型属性 方法 　英文命令：GetObjectProperty　操作系统支持：Windows 所属对象：对象

读取并返回本对象的指定对象属性值，如果失败将返回内容为空的对象，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 对象 对象．读对象型属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

如果读取得对象为一个集合，将返回指定的一个对象。

参见：例程1


读属性 方法 操作系统支持：Windows 所属对象：对象

读属性 方法 　英文命令：GetProperty　操作系统支持：Windows 所属对象：对象

读取并返回本对象的指定属性值，本方法可以用作读取任意类型的属性。如果失败将返回类型值为空的变体型对象，且紧跟其后执行“取错误”方法将返回非空文本，否则将返回包含对应数据类型数据的变体型对象。

语法： 变体型 对象．读属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

读取任意类型对象，并返回相应得值。

参见：例程1


写属性 方法 操作系统支持：Windows 所属对象：对象

写属性 方法 　英文命令：SetProperty　操作系统支持：Windows 所属对象：对象

设置本对象指定属性的值，如果失败，返回假，并且紧跟其后执行“取错误”方法将返回非空文本。

语法： 逻辑型 对象．写属性 （属性名称，［参数数据］，… ）

参数名 | 描 述
属性名称 | 必需的；文本型。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供读写属性所需要的所有数据。如果读写该属性不需要任何参数，请保持本参数为空。

例程：

说明：

设置一个对象的属性。

参见：例程1


方法 方法 操作系统支持：Windows 所属对象：对象

方法 方法 　英文命令：RunMethod　操作系统支持：Windows 所属对象：对象

执行本对象的指定方法并忽略其返回值，如果失败，紧跟其后执行“取错误”方法将返回非空文本。

语法： 无返回值 对象．方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

执行对象中的一个方法。

参见：例程1


通用方法 方法 操作系统支持：Windows 所属对象：对象

通用方法 方法 　英文命令：RunVariantMethod　操作系统支持：Windows 所属对象：对象

执行本对象的指定方法并返回一个变体型对象值，该对象内记录该方法的返回数据。本命令可以用作执行返回任何数据类型数据的方法，如果该方法没有返回数据，所返回变体型对象的类型值将为空。如果失败，将返回一个类型值为空的变体型对象，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 变体型 对象．通用方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

如果所执行对象有返回值，本命令执行对象，并返回该对象返回值类型的数据。

参见：例程1


文本方法 方法 操作系统支持：Windows 所属对象：对象

文本方法 方法 　英文命令：RunTextMethod　操作系统支持：Windows 所属对象：对象

执行本对象返回文本类型数据的方法，如果失败将返回空文本，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 文本型 对象．文本方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

如果所执行对象返回值为文本型，使用本命令执行。

参见：例程1


数值方法 方法 操作系统支持：Windows 所属对象：对象

数值方法 方法 　英文命令：RunNumMethod　操作系统支持：Windows 所属对象：对象

执行本对象返回数值类型数据的方法，如果失败将返回数值0，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 双精度小数型 对象．数值方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

如果执行对象返回值为数值型，用本命令执行。

参见：例程1


逻辑方法 方法 操作系统支持：Windows 所属对象：对象

逻辑方法 方法 　英文命令：RunBoolMethod　操作系统支持：Windows 所属对象：对象

执行本对象返回逻辑型数据的方法，如果失败将返回假，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 逻辑型 对象．逻辑方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

如果执行对象返回值为逻辑性，用本命令。

参见：例程1


日期方法 方法 操作系统支持：Windows 所属对象：对象

日期方法 方法 　英文命令：RunDateMethod　操作系统支持：Windows 所属对象：对象

执行本对象返回日期时间型数据的方法，如果失败将返回100年1月1日，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 日期时间型 对象．日期方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

如果执行对象返回值为日期型，是用本命令。

参见：例程1


对象型方法 方法 操作系统支持：Windows 所属对象：对象

对象型方法 方法 　英文命令：RunObjectMethod　操作系统支持：Windows 所属对象：对象

执行本对象返回对象型数据的方法，如果失败将返回内容为空的对象，且紧跟其后执行“取错误”方法将返回非空文本。

语法： 对象 对象．对象型方法 （方法名称，［参数数据］，… ）

参数名 | 描 述
方法名称 | 必需的；文本型。本参数提供欲调用方法的名称。
参数数据 | 可选的；可扩充的；通用型。本参数及本参数后的所有扩展参数提供调用方法所需要的所有数据。如果该方法不需要任何参数，请保持本参数为空。

例程：

说明：

如果要使用的对象为某对象的方法，用本命令调入，保存在相应变量中。

参见：例程1


创建图片对象 方法 操作系统支持：Windows 所属对象：对象

创建图片对象 方法 　英文命令：CreatePicDispObj　操作系统支持：Windows 所属对象：对象

为指定图片数据创建对应的 COM 图片对象，本对象中的原有内容将被释放。成功返回真，否则返回假。

语法： 逻辑型 对象．创建图片对象 （图片数据）

参数名 | 描 述
图片数据 | 必需的；字节集。本参数提供欲用作创建图片对象的图片数据。

例程：

说明：

为一个指定的图片数据，创建相对应的com对象。

参见：例程1


创建字体对象 方法 操作系统支持：Windows 所属对象：对象

创建字体对象 方法 　英文命令：CreateFontDispObj　操作系统支持：Windows 所属对象：对象

为指定字体数据创建对应的 COM 字体对象，本对象中的原有内容将被释放。成功返回真，否则返回假。

语法： 逻辑型 对象．创建字体对象 （字体数据）

参数名 | 描 述
字体数据 | 必需的；字体。本参数提供欲用作创建字体对象的字体数据。

例程：

说明：

为指定的字体数据创建对应的com对象。

参见：例程1


取回图片 方法 操作系统支持：Windows 所属对象：对象

取回图片 方法 　英文命令：GetPic　操作系统支持：Windows 所属对象：对象

如果本对象为 COM 图片对象，则取回其具体图片数据。成功返回图片数据字节集，失败返回空字节集。

语法： 字节集 对象．取回图片 （）

例程：

说明：

如果调用的对象为图片对象，用本命令可以取回对象的图片。

参见：例程1


取回字体 方法 操作系统支持：Windows 所属对象：对象

取回字体 方法 　英文命令：GetFont　操作系统支持：Windows 所属对象：对象

如果本对象为 COM 字体对象，则取回其具体字体数据。如果失败，紧跟其后执行“取错误”方法将返回非空文本。

语法： 字体 对象．取回字体 （）

例程：

说明：

如果调用的对象为字体对象，可以用本命令取回字体。

参见：例程1


取错误 方法 操作系统支持：Windows 所属对象：对象

取错误 方法 　英文命令：GetErrorText　操作系统支持：Windows 所属对象：对象

当读写对象属性、执行对象方法或取回字体时，紧跟该语句后执行本方法可以检查其是否执行成功。如果成功，本命令将返回空文本，如果失败，本命令将返回一个描述具体错误信息的非空文本。

语法： 文本型 对象．取错误 （）

例程：

说明：

如果使用其它调用对象命令出现错误，可以用本命令取回错误信息。

参见：例程1


查看 方法 操作系统支持：Windows 所属对象：对象

查看 方法 　英文命令：ViewObjInf　操作系统支持：Windows 所属对象：对象

仅在易程序的调试版本中被执行，在发布版本中将被直接跳过；
通过对话框的方式查看本对象的调用格式信息，便于编写相关程序。

语法： 无返回值 对象．查看 （）

例程：

说明：

查看一个对象的结构。

参见：例程1


取接口 (对象)

取接口 方法 操作系统支持：Windows 所属对象：对象

获取指定对象或者OCX窗口组件中的指定接口，本对象中的原有内容将被释放。成功返回真，失败返回假。

语法： 逻辑型 对象．取接口 （对象或窗口组件， ［接口标志符］）

参数名 | 描 述
对象或窗口组件 | 必需的； 通用型。本参数提供欲获取其接口对象的对象数据，其数据类型为以下之一：1、COM包装库封装出来的对象型数据类型； 2、核心支持库中的“对象”数据类型(即本数据类型)； 3、COM包装库封装出来的OCX窗口组件数据类型。
接口标志符 | 可选的； 文本型。可以在本参数中指定欲获取接口的具体名称或其全球唯一标志符(GUID)，如“IDataSourceControl”、{B62EE548-2B65-43BE-9F39-E2B71742578A}等。如果本参数被省略，则默认取出对象的基本接口。


变体型

变体型 普通类型 操作系统支持：Windows 跳至：系统核心支持库

提供对COM接口中Variant数据类型(即VB中的Any数据类型)的支持，它可以容纳文本、数值、逻辑值、日期时间值、COM对象型数据类型，还可以容纳这些数据类型以及“变体型”数据类型本身的数组。

方法：

清除 | 取类型 | 取数组成员数 | 取文本
取数值 | 取逻辑值 | 取日期 | 取对象
取变体型 | 赋值 | 创建数组 | 置类型
取字节集 |  |  |

参见： 基本数据类型


清除 方法 操作系统支持：Windows 所属对象：变体型

清除 方法 　英文命令：cls　操作系统支持：Windows 所属对象：变体型

将本对象的内容释放并清空。如果不调用本方法，则对象在退出其作用区域时会自动被释放。例如：假设对象存在于子程序局部变量中，当子程序调用退出时，该对象会被自动释放。

语法： 无返回值 变体型．清除 （）

例程：

说明：

清除一个变体型变量中的内容。

参见：例程1


取类型 方法 操作系统支持：Windows 所属对象：变体型

取类型 方法 　英文命令：GetType　操作系统支持：Windows 所属对象：变体型

取回当前变体型对象的数据类型。

语法： 变体类型 变体型．取类型 （）

例程：

说明：

取出变体型变量中的数据类型。

参见：例程1


取数组成员数 方法 操作系统支持：Windows 所属对象：变体型

取数组成员数 方法 　英文命令：GetAryElementCount　操作系统支持：Windows 所属对象：变体型

如果本对象中存放的是数组数据，执行本方法将返回其成员数目，如果不是数组数据，执行本方法将返回 -1 。

语法： 整数型 变体型．取数组成员数 （）

例程：

说明：

取出变体型变量数组的数组成员数量。

参见：例程1


取文本 方法 操作系统支持：Windows 所属对象：变体型

取文本 方法 　英文命令：GetText　操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的文本数据，如果当前数据的数据类型不为文本型，将自动进行转换，如果转换失败将返回空文本。

语法： 文本型 变体型．取文本 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

如果变体型变量中成员为文本型，可以用本命令取出变量的内容。

参见：例程1


取数值 方法 操作系统支持：Windows 所属对象：变体型

取数值 方法 　英文命令：GetNum　操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的数值数据，如果当前数据的数据类型不为数值或错误值型，将自动进行转换，如果转换失败将返回 0 。

语法： 双精度小数型 变体型．取数值 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

如果变体型变量中的内容为数值型，可以用本命令取出变量中的内容。

参见：例程1


取逻辑值 方法 操作系统支持：Windows 所属对象：变体型

取逻辑值 方法 　英文命令：GetBool　操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的逻辑值数据，如果当前数据的数据类型不为逻辑型，将自动进行转换，如果转换失败将返回假。

语法： 逻辑型 变体型．取逻辑值 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

取出变体型变量中的逻辑值。

参见：例程1


取日期 方法 操作系统支持：Windows 所属对象：变体型

取日期 方法 　英文命令：GetDatePart　操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的日期时间值数据，如果当前数据的数据类型不为日期时间型，将自动进行转换，如果转换失败将返回100年1月1日。

语法： 日期时间型 变体型．取日期 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

取出变体型变量中的日期值。

参见：例程1


取对象 方法 操作系统支持：Windows 所属对象：变体型

取对象 方法 　英文命令：GetObject　操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的COM对象型数据，如果当前数据的数据类型不为COM对象型，将返回空COM对象。

语法： 对象 变体型．取对象 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

取出变体型变量中的对象。

参见：例程1


取变体型 方法 操作系统支持：Windows 所属对象：变体型

取变体型 方法 　英文命令：GetVariant　操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的变体型数据类型数据，如果当前数据的数据类型不为变体型，将自动进行转换。

语法： 变体型 变体型．取变体型 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

取出变体型变量中的变体型数据。

参见：例程1


赋值 方法 操作系统支持：Windows 所属对象：变体型

赋值 方法 　英文命令：set　操作系统支持：Windows 所属对象：变体型

设置本对象的内容，成功返回真，失败返回假。

语法： 逻辑型 变体型．赋值 （［欲写入数据］，［成员索引］）

参数名 | 描 述
欲写入数据 | 可选的；通用型，参数数据可以同时提供数组或非数组数据。参数值可以为文本、数值、逻辑值、日期时间值、COM对象型数据类型或者这些数据类型及“变体型”数据类型本身的数组形式。如果本参数被省略，则将对象清空。
成员索引 | 可选的；整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

例程：

说明：

设置变体型变量的内容。

参见：例程1


创建数组 方法 操作系统支持：Windows 所属对象：变体型

创建数组 方法 　英文命令：CreateArray　操作系统支持：Windows 所属对象：变体型

创建指定类型和指定成员数的空白数组，对象中的原有内容将被清空，成功返回真，失败返回假。

语法： 逻辑型 变体型．创建数组 （成员类型，成员数目）

参数名 | 描 述
成员类型 | 必需的；整数型。指定所创建数组成员的数据类型，为以下数值之一： 1: 字节型； 2: 短整数型； 3: 整数型； 4: 小数型； 5: 双精度小数型； 6: 文本型； 7: 逻辑型； 8: 日期型； 9: 对象型； 10: 变体型。
成员数目 | 必需的；整数型。指定所创建数组成员的数目。

例程：

说明：

创建一个变体型变量数组。

参见：例程1


置类型 (变体型)

置类型 方法 操作系统支持：Windows 所属对象：变体型

清除当前变体型对象中的原有内容，并改变它的数据类型，成功返回真，失败返回假。

语法： 逻辑型 变体型．置类型 （欲设置的类型）

参数名 | 描 述
欲设置的类型 | 必需的； 变体类型。参数值提供欲设置的变体类型。

  例程：

说明：

清除当前变体型对象中的原有内容，并改变它的数据类型

参见：例程1


取字节集 (变体型)

取字节集 方法 操作系统支持：Windows 所属对象：变体型

返回本对象中或本对象数组成员中的字节集数据，如果当前数据的数据类型不为字节集型，将自动进行转换，如果转换失败将返回空字节集。

语法： 字节集 变体型．取字节集 （［成员索引］）

参数名 | 描 述
成员索引 | 可选的； 整数型。如果当前对象内为数组型数据，且欲对数组内的某个成员进行操作，则可以在此参数中指定其引用索引值，该索引值从 1 开始。除开上述情况外，请省略本参数。

  例程：

说明：

取变体型变量中的字节集数据, 如果当前数据的数据类型不为字节集型，将自动进行转换，如果转换失败将返回空字节集。

参见：例程1


变体类型

变体类型 枚举常量集合类型 操作系统支持：Windows 跳至：系统核心支持库

提供变体型中所能够容纳数据类型的枚举值。

成员 | 描 述
未知 | 常量值为 -1 。
空 | 常量值为 0 。
数值型 | 常量值为 1 。
文本型 | 常量值为 2 。
逻辑型 | 常量值为 3 。
日期型 | 常量值为 4 。
对象型 | 常量值为 5 。
错误值型 | 常量值为 6 。
数值型数组 | 常量值为 7 。
文本型数组 | 常量值为 8 。
逻辑型数组 | 常量值为 9 。
日期型数组 | 常量值为 10 。
对象型数组 | 常量值为 11 。
错误值型数组 | 常量值为 12 。
变体型数组 | 常量值为 13 。

参见： 基本数据类型


鼠标左键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键按下此事件的拥有者时，触发此事件。注意：当窗口的随意移动属性设为“真”时此事件将不会触发。

参考：例程1


鼠标左键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标左键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在次事件的拥有者上放开时，此事件被触发。注意：如果窗口的随意移动属性设为“真”时，此事件不会触发。

参考：例程1


被双击 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_被双击 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标左键在此事件的拥有者上双击时，此事件触发。

参考：例程1


鼠标右键被按下 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被按下 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在本事件的拥有者上按下时，此触发事件。

参考：例程1


鼠标右键被放开 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标右键被放开 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标右键在此事件的拥有者上放开时，触发此事件。

参考：例程1


鼠标位置被移动 系统基本事件 操作系统支持：Windows、Linux、Unix

处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_鼠标位置被移动 （横向位置，纵向位置，功能键状态）

参数名 | 描 述
横向位置 | 整数型；指示鼠标在当前所处窗口组件中的横向位置。
纵向位置 | 整数型；指示鼠标在当前所处窗口组件中的纵向位置。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当鼠标在此事件的拥有者上移动时，触发此事件。

参考：例程1


获得焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象获得输入焦点时产生本事件。所谓“输入焦点”，即当前用户按键操作所对应的目标对象。譬如：用户正在编辑框中输入文本，那么此编辑框就具有输入焦点，因为它将获得目前用户所进行的所有按键操作。所谓“获得”或者“失去”输入焦点，即当前用户按键操作所对应的目标对象发生转移。譬如：现在用户正在编辑框1中输入文本，突然使用鼠标或其它方法切换到了编辑框2上去继续输入。那么此时，编辑框1就“失去”了输入焦点，编辑框2就“得到”了输入焦点，因为在此以后用户所进行的所有按键操作都将被编辑框2所获得。

语法： 无返回值 _窗口组件_获得焦点 （）

例程

说明

当此事件的拥有者获得焦点时，此事件被触发。

参考：例程1


失去焦点 系统基本事件 操作系统支持：Windows、Linux、Unix

当对象失去输入焦点时产生本事件。

语法： 无返回值 _窗口组件_失去焦点 （）

例程

说明

当此事件的拥有者失去焦点时，此事件被触发。

参考：例程1


按下某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户按下一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此按键事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_按下某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上按下键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


放开某键 系统基本事件 操作系统支持：Windows、Linux、Unix

此事件当用户放开以前按下的一个键时发生。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_放开某键 （键代码，功能键状态）

参数名 | 描 述
键代码 | 整数型；为键常量值，如：“#F1键”、“#回车键” 等等。具体所有的键常量见库常量表。
功能键状态 | 整数型；用于查看在按下本键的同时各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程

说明

当在此事件的拥有者上放开键盘，此事件将被触发。

注：在拥有者上，既拥有焦点。

参考：例程1


字符输入 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户按下和松开一个字符键时发生此事件。字符键包括任何可打印的键盘字符及回车（Enter）和退格（BackSpace）键。在用户事件处理子程序中，将事件处理完毕后可返回一个字符代码，用于替换将继续传递到所属对象上字符键事件中的字符代码；如果返回 0 ，则取消此事件，不再将此字符输入事件传递到所属对象上去；如果事件处理完毕后没有返回值，则将本字符键事件继续原样传递到所属对象上去。

语法： 整数型 _窗口组件_字符输入 （字符代码）

参数名 | 描 述
字符代码 | 整数型；表明所按下的字符键所对应的字符代码，可以使用“字符”命令取出所对应的具体字符。

例程

说明

当在此事件的拥有者上输入字符时，此事件将被触发。

注：所谓在拥有者上，是指拥有焦点；字符是指键盘上的数字键和字母键+回车和退格键。

参考：例程1


滚轮被滚动 系统基本事件 操作系统支持：Windows、Linux、Unix

当用户滚动鼠标滚轮时产生本事件。处理本事件的子程序如果返回假，则取消本事件，不再将此事件传递到所属对象上去；如果不返回值或返回真，则将此事件继续传递到所属对象上去。

语法： 逻辑型 _窗口组件_滚轮被滚动 （滚动距离，功能键状态）

参数名 | 描 述
滚动距离 | 整数型；表明鼠标滚轮所滚动的距离，大于零表示向前滚动，小于零表示向后滚动。
功能键状态 | 整数型；用于查看各功能键是否被同时按下。可以为以下常量值或其和： 1、#Ctrl键状态； 2、#Shift键状态； 4、#Alt键状态。要判断是否同时按下了某个功能键，在此参数的值与想要得知的功能键的状态常量值之间使用“位与”命令进行比较。如果所得的结果不为零，则表示同时按下了此功能键。

例程:

说明:

只有获取焦点后才能产生本事件。

参见：例程


常量 | 常量值 | 描 述
#引号 | “"” | 半角双引号。
#左引号 | ““” | 全角左双引号。
#右引号 | “”” | 全角右双引号。
#换行符 | “字符（13）+字符（10）” | 一个回车符（13）和一个换行符（10）的组合。
#pi | 3.1415926535 |
#e | 2.718282 |
#黑色 | 0 | 常用颜色值。
#藏青 | 8388608 |
#墨绿 | 32768 |
#深青 | 8421376 |
#红褐 | 128 |
#紫红 | 8388736 |
#褐绿 | 32896 |
#浅灰 | 12632256 |
#灰色 | 8421504 |
#蓝色 | 16711680 |
#绿色 | 65280 |
#艳青 | 16776960 |
#红色 | 255 |
#品红 | 16711935 |
#黄色 | 65535 |
#白色 | 16777215 |
#蓝灰 | 16744576 |
#藏蓝 | 14692440 |
#嫩绿 | 57472 |
#青绿 | 8445952 |
#黄褐 | 24768 |
#粉红 | 16754943 |
#嫩黄 | 55512 |
#银白 | 15527148 |
#紫色 | 16711824 |
#天蓝 | 16746496 |
#灰绿 | 8429696 |
#青蓝 | 12607488 |
#橙黄 | 33023 |
#桃红 | 8409343 |
#芙红 | 12615935 |
#深灰 | 6316128 |
#透明 | -16777216 |
#隐藏窗口 | 1 |
#普通激活 | 2 |
#最小化激活 | 3 |
#最大化激活 | 4 |
#普通不激活 | 5 |
#最小化不激活 | 6 |
#读入 | 1 |
#写出 | 2 |
#读写 | 3 |
#重写 | 4 |
#改写 | 5 |
#改读 | 6 |
#无限制 | 1 |
#禁止读 | 2 |
#禁止写 | 3 |
#禁止读写 | 4 |
#文件首 | 1 |
#文件尾 | 2 |
#现行位置 | 3 |
#只读文件 | 1 |
#隐藏文件 | 2 |
#系统文件 | 4 |
#子目录 | 16 |
#存档文件 | 32 |
#无属性文件 | 128 |
#字节型 | 1 |
#短整数型 | 2 |
#整数型 | 3 |
#长整数型 | 4 |
#小数型 | 5 |
#双精度小数型 | 6 |
#逻辑型 | 7 |
#日期时间型 | 8 |
#子程序指针型 | 9 |
#文本型 | 10 |
#年份 | 1 |
#季度 | 2 |
#月份 | 3 |
#周 | 4 |
#自年首周数 | 4 |
#日 | 5 |
#小时 | 6 |
#分钟 | 7 |
#秒 | 8 |
#星期几 | 9 |
#自年首天数 | 10 |
#确认钮 | 0 | “信息框”命令使用。
#确认取消钮 | 1 |
#放弃重试忽略钮 | 2 |
#取消是否钮 | 3 |
#是否钮 | 4 |
#重试取消钮 | 5 |
#错误图标 | 16 |
#询问图标 | 32 |
#警告图标 | 48 |
#信息图标 | 64 |
#默认按钮一 | 0 |
#默认按钮二 | 256 |
#默认按钮三 | 512 |
#默认按钮四 | 768 |
#程序等待 | 0 |
#系统等待 | 4096 |
#位于前台 | 65536 |
#文本右对齐 | 524288 |
#取消钮 | 1 |
#放弃钮 | 2 |
#重试钮 | 3 |
#忽略钮 | 4 |
#是钮 | 5 |
#否钮 | 6 |
#首拼及全拼 | 1 |
#双拼 | 2 |
#自动判别 | 3 |
#Ctrl键状态 | 1 |
#Shift键状态 | 2 |
#Alt键状态 | 4 |
#键0 | 48 | 按键代码值。
#键1 | 49 |
#键2 | 50 |
#键3 | 51 |
#键4 | 52 |
#键5 | 53 |
#键6 | 54 |
#键7 | 55 |
#键8 | 56 |
#键9 | 57 |
#A键 | 65 |
#B键 | 66 |
#C键 | 67 |
#D键 | 68 |
#E键 | 69 |
#F键 | 70 |
#G键 | 71 |
#H键 | 72 |
#I键 | 73 |
#J键 | 74 |
#K键 | 75 |
#L键 | 76 |
#M键 | 77 |
#N键 | 78 |
#O键 | 79 |
#P键 | 80 |
#Q键 | 81 |
#R键 | 82 |
#S键 | 83 |
#T键 | 84 |
#U键 | 85 |
#V键 | 86 |
#W键 | 87 |
#X键 | 88 |
#Y键 | 89 |
#Z键 | 90 |
#F1键 | 112 |
#F2键 | 113 |
#F3键 | 114 |
#F4键 | 115 |
#F5键 | 116 |
#F6键 | 117 |
#F7键 | 118 |
#F8键 | 119 |
#F9键 | 120 |
#F10键 | 121 |
#F11键 | 122 |
#F12键 | 123 |
#F13键 | 124 |
#F14键 | 125 |
#F15键 | 126 |
#F16键 | 127 |
#Break键 | 3 |
#退格键 | 8 |
#Tab键 | 9 |
#回车键 | 13 |
#Shift键 | 16 |
#Ctrl键 | 17 |
#Alt键 | 18 |
#Pause键 | 19 |
#CapsLock键 | 20 |
#NumLock键 | 144 |
#ScrollLock键 | 145 |
#Esc键 | 27 |
#空格键 | 32 |
#PageUp键 | 33 |
#PageDown键 | 34 |
#Home键 | 36 |
#End键 | 35 |
#左光标键 | 37 |
#上光标键 | 38 |
#右光标键 | 39 |
#下光标键 | 40 |
#Ins键 | 45 |
#Del键 | 46 |
#分号键 | 186 |
#等号键 | 187 |
#逗号键 | 188 |
#减号键 | 189 |
#圆点键 | 190 |
#除号键 | 191 |
#反撇号键 | 192 |
#左中括号键 | 219 |
#右中括号键 | 221 |
#斜杠键 | 220 |
#单引号键 | 222 |
#顶层 | 1 | 在窗口 Z 顺序的最前面。
#底层 | 2 | 在窗口 Z 顺序的最后面。
#最高层 | 3 | 在所有现行窗口的最前面并一直保持此位置。
#次高层 | 4 | 在最高层窗口的下面但在其他窗口的前面。
#全部转换 | 1 |
#日期部分 | 2 |
#时间部分 | 3 |
#输入文本 | 1 |
#输入整数 | 2 |
#输入小数 | 3 |
#拷贝 | 1 |
#翻转拷贝 | 2 |
#位异或 | 3 |
#位或 | 4 |
#位与 | 5 |
#从上到下 | 1 |
#从左到右 | 2 |
#从左上到右下 | 3 |
#从右上到左下 | 4 |
#从下到上 | 5 |
#从右到左 | 6 |
#从右下到左上 | 7 |
#从左下到右上 | 8 |
#字节集型 | 11 | 可以存储大量的不定长字节数据。
#备注型 | 12 | 文本型的扩充，可以存储大量的不定长文本数据。
#通常索引 | 1 |
#读音索引 | 2 |
#南方读音索引 | 3 |
#不区分大小写 | 1 |
#忽略所有空格 | 2 |
#取平均值 | 1 |
#求和 | 2 |
#取最大值 | 3 | 取最大数值及日期。
#取最小值 | 4 | 取最小数值及日期。
#禁止修改 | 1 | 如果禁止修改，则自动禁止添加和删除。
#禁止添加 | 2 |
#禁止删除 | 4 |
#禁止自动判断 | 8 |
#根类 | 1 |
#现行设置 | 2 |
#现行用户 | 3 |
#本地机器 | 4 |
#所有用户 | 5 |
#单击左键 | 1 |
#双击 | 2 |
#单击右键 | 3 |
#默认色 | -16777216 |
#文本 | 1 |
#图片文件名 | 2 |
#图片数据 | 3 |
#字节集数据 | 4 |
#上左 | 1 |
#上中 | 2 |
#上右 | 3 |
#中左 | 4 |
#中中 | 5 |
#中右 | 6 |
#下左 | 7 |
#下中 | 8 |
#下右 | 9 |
#缩放图片 | 10 |
#居中图片 | 11 |
#缩放居中图片 | 12 |
#平铺图片 | 13 |
#缩放平铺图片 | 14 |
#粗体 | 1 |
#斜体 | 2 |
#下划线 | 4 |
#删除线 | 8 |
#通常型 | 0 |
#左边框 | 1 |
#上边框 | 2 |
#右边框 | 4 |
#下边框 | 8 |
#水平线 | 16 |
#垂直线 | 32 |
#单斜线 | 64 |
#双斜线 | 128 |
#交叉线 | 256 |
#左单元格 | 1 |
#上单元格 | 2 |
#右单元格 | 3 |
#下单元格 | 4 |
#无页号 | 0 |
#上左页号 | 1 |
#上中页号 | 2 |
#上右页号 | 3 |
#下左页号 | 4 |
#下中页号 | 5 |
#下右页号 | 6 |
#全部页 | 0 |
#仅打印奇数页 | 1 |
#仅打印偶数页 | 2 |
#页范围 | 1 |
#行范围 | 2 |
#纵向 | 0 |
#横向 | 1 |
#默认纸 | 0 |
#A3纸 | 1 | 297 x 420 毫米。
#A4纸 | 2 | 210 x 297 毫米。
#A5纸 | 3 | 148 x 210 毫米。
#B4纸 | 4 | 250 x 354 毫米。
#B5纸 | 5 | 182 x 257 毫米。
#四开 | 6 | 215 x 275 毫米。
#十六开 | 7 | 146 x 215 毫米。
#三十二开 | 8 | 97 x 151 毫米。
#信纸 | 9 | 216 x 279 毫米。
#法律用纸 | 10 | 216 x 355 毫米。
#行政用纸 | 11 | 184 x 266 毫米。
#声明 | 12 | 140 x 216 毫米。
#小报 | 13 | 279 x 432 毫米。
#笔记 | 14 | 216 x 279 毫米。
#帐本 | 15 | 432 x 279 毫米。
#对开纸 | 16 | 216 x 330 毫米。
#输入密码 | 4 |
#缩放到纸宽 | -1 |
#限定到纸宽 | -2 |
#常量 | 0 |
#资源 | 1 |
#清除信号 | 1 |
#发送或置位 | 2 |
#DTR信号 | 1 |
#RTS信号 | 2 |
#Break信号 | 3 |
#GBK中文 | 1 |
#英文 | 2 |
#BIG5中文 | 3 |
#标准输出设备 | 1 |
#标准错误设备 | 2 |


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格 数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1