XML解析支持库

XML解析支持库 帮助手册20080821版 返回支持库手册 返回首页

提供对W3C标准XML文件的读写支持。目前本支持库仅支持W3C标准的XML文件,不支持DTD和采用Unicode字符集编码的XML文件，XML中二进制数据的保存方式为BASE64编码形式,不支持采用CDATA块中保存二进制数据。

操作系统支持： Windows、Linux

命令类别：

匹配通配符

其它数据类型：

XML树

适用版本，XML解析支持库 （1.5#2版）


匹配通配符

匹配通配符 类别 跳至：XML解析支持库

匹配通配符


匹配通配符 命令 操作系统支持：Windows、Linux 所属类别：匹配通配符

该方法第一个参数包含通配符（*,?），通配符“*”代表零个或多个任意字符，通配符“?”代表一个任意字符，第二个参数是一个不包含通配符的常量字符串，该方法得到匹配字符串和常量字符串的比较结果。比较相等返回真，不等返回假。

语法： 逻辑型 匹配通配符 （匹配文本，常量文本）

参数名 | 描 述
匹配文本 | 必需的；文本型。包含通配符的文本。
常量文本 | 必需的；文本型。不包含通配符的普通文本。

例程:

说明:

可以使用通配符来代替某些文字，通配符使用方式等同DOS下通配符的使用。

参考：例程1


XML树

XML树 普通类型 操作系统支持：Windows、Linux 跳至：XML解析支持库

该数据类型提供对W3C标准XML文件的读写支持。

方法：

新建 | 导入 | 导出 | 释放
取根节点名 | 取子节点数 | 取子节点名 | 取节点值
取二进制值 | 取全部属性名 | 取属性值 | 插入节点
插入属性 | 删除节点 | 删除属性 | 修改节点名
修改节点值 | 修改二进制值 | 修改属性名 | 修改属性值
批量删除节点 | 批量取节点值 | 批量修改节点值 | 取根节点名文本
取子节点个数 | 取所有子节点名 | 取节点值文本 | 取节点值字节集
取属性个数 | 取所有属性名 | 取属性值文本 | 取XML数据

参见： 基本数据类型


新建 方法 操作系统支持：Windows、Linux 所属对象：XML树

在内存中创建一个新的XML的解析树。如果XML树已经创建，则自动释放当前XML树，然后执行新建操作。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．新建 （根节点名）

参数名 | 描 述
根节点名 | 必需的；文本型。本参数提供所要新建解析树根节点的名称。

例程:

说明:

在内存中创建一个新的树结构。


导入 方法 操作系统支持：Windows、Linux 所属对象：XML树

打开已存在的XML文件，根据该文件的内容建立一个XML树。如果XML树已经创建，则自动释放当前XML树，然后执行导入操作。该方法执行成功返回真，执行失败返回假。该方法对XML文件进行必要的语法检查，如果发现非法的数据格式，该方法将执行失败，返回假。

语法： 逻辑型 XML树．导入 （XML文件名）

参数名 | 描 述
XML文件名 | 必需的；文本型。本参数提供“导入”命令所要求的XML文件的名称。该文件名可以是绝对路径名，也可以是相对路径名。

例程:

说明:

将一个已有的XML树文件导入到内存中，导入内存之后的树结构和导入的文件没有任何关联，当内存中的树结构被改变，导入的文件不会被改变。


导出 方法 操作系统支持：Windows、Linux 所属对象：XML树

保存当前的XML树到XML文件。如果文件已经存在，则覆盖原有文件。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．导出 （XML文件名，［字符集属性］）

参数名 | 描 述
XML文件名 | 必需的；文本型。本参数应提供由“导出”命令所要求的XML文件的名称。该文件名可以是绝对路径名，也可以是相对路径名。
字符集属性 | 可选的；文本型。本参数应提供由“导出”命令所要求XML文件的字符集属性。如果该参数为空，则采用默认的字符集属性，默认的字符集属性为GB2312。

例程:

说明:

将内存中的树结构保存到文件中，文件扩展名为XML。


释放 方法 操作系统支持：Windows、Linux 所属对象：XML树

释放当前XML树，释放后该XML树将不再可用。如果XML树在离开作用域前没有释放，系统会自动释放XML树。

语法： 无返回值 XML树．释放 （）

例程:

说明:

将内存中创建的XML树结构释放掉。


取根节点名 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得当前解析树根节点的名称。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取根节点名 （根节点名称）

参数名 | 描 述
根节点名称 | 必需的；文本型，参数数据只能提供变量。本参数作为“取根节点名”命令的填充参数。“取根节点名”命令执行完毕后，该参数的内容为当前解析树根节点的名称。如果命令执行失败，该参数的值无意义。

例程:

说明:

取得XML树的根节点名称。


取子节点数 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的所有子节点的个数。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取子节点数 （节点全路径，子节点个数）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
子节点个数 | 必需的；整数型，参数数据只能提供变量。本参数作为“取子节点数”命令的填充参数。“取子节点数”命令执行完毕后，该参数内容为子节点的个数。如果命令执行失败，该参数的值无意义。

例程:

说明:

取得XML树结构某节点下子节点的数量。


取子节点名 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的所有子节点名称。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取子节点名 （节点全路径，子节点名称数组）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
子节点名称数组 | 必需的；文本型，参数数据只能提供变量数组。本参数作为“取子节点名”命令的填充参数。“取子节点名”命令执行完毕后，该参数内容为所有子节点名称组成的数组。如果命令执行失败，该参数的值无意义。

例程:

说明:

取出XML树结构某节点下子节点的名称，由于子节点可以为多个，所以参数二需要提供0成员数组。


取节点值 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的值。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取节点值 （节点全路径，节点值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
节点值 | 必需的；文本型，参数数据只能提供变量。本参数作为“取节点值”命令的填充参数。“取节点值”命令执行完毕后，该参数的内容为节点的值。如果命令执行失败，该参数的值无意义。

例程:

说明:

取得XML树结构某节点下的节点值。


取二进制值 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的二进制数据的值。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取二进制值 （节点全路径，二进制节点值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
二进制节点值 | 必需的；字节集，参数数据只能提供变量。本参数作为“取二进制值”命令的填充参数。“取二进制值”命令执行完毕后，该参数内容为节点的二进制值。如果命令执行失败，该参数的值无意义。

例程:

说明:

取得XML树结构某节点下节点的二进制值。


取全部属性名 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的所有属性的名称。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取全部属性名 （节点全路径，属性名称数组）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
属性名称数组 | 必需的；文本型，参数数据只能提供变量数组。本参数作为“取全部属性名”命令的填充参数。“取全部属性名”命令执行完毕后，该参数内容为节点的所有属性名称组成的数组。如果命令执行失败，该参数的值无意义。

例程:

说明:

取得XML树结构某节点下节点的所有属性名称。


取属性值 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的特定属性的值。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．取属性值 （节点全路径，属性名，属性值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
属性名 | 必需的；文本型。本参数提供“取属性值”命令所需要的节点属性的名称。该参数也可以是属性的索引，例如“@1”表示节点的第一个属性。
属性值 | 必需的；文本型，参数数据只能提供变量。本参数作为“取属性值”命令的填充参数。“取属性值”命令执行完毕后，该参数内容为节点属性的值。如果命令执行失败，该参数的值无意义。

例程:

说明:

取得XML树结构某节点下节点的属性值。


插入节点 方法 操作系统支持：Windows、Linux 所属对象：XML树

新建一个节点，并把该参数节点作为该新节点的父节点，然后插入到XML树中。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．插入节点 （父节点全路径，新节点名，新节点值）

参数名 | 描 述
父节点全路径 | 必需的；文本型。本参数为要插入节点的父节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
新节点名 | 必需的；文本型。本参数提供“插入节点”命令所需要的新插入节点的名称。
新节点值 | 必需的；文本型。本参数作为“插入节点”命令所需要的新插入节点的值。

例程:

说明:

在XML树结构某节点下插入新的节点。


插入属性 方法 操作系统支持：Windows、Linux 所属对象：XML树

在参数节点中插入一个新的属性，并给属性付值。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．插入属性 （节点全路径，新属性名，属性值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
新属性名 | 必需的；文本型。本参数提供“插入属性”命令欲插入的节点新属性的名称。
属性值 | 必需的；文本型。本参数作为“插入属性”命令欲插入的节点新属性的值。

例程:

说明:

在XML树结构中某节点插入节点值，如果该节点不存在，插入将失败。


删除节点 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会删除给定节点和他的所有子节点，该方法不允许删除根节点。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．删除节点 （节点全路径）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。

例程:

说明:

删除指定节点，该节点下的字节点将被全部删除，该命令不能删除根节点。


删除属性 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会删除给定节点的指定属性。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．删除属性 （节点全路径，属性名）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
属性名 | 必需的；文本型。本参数提供“删除属性”命令欲删除属性的名称。该参数也可以是属性的索引，例如“@1”表示节点的第一个属性。

例程:

说明:

删除指定节点的属性。


修改节点名 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会修改指定节点的名称。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．修改节点名 （节点全路径，新节点名）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
新节点名 | 必需的；文本型。本参数提供“修改节点名”命令欲修改节点的新名称。

例程:

说明:

修改XML树结构某节点下节点的名称。


修改节点值 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会修改指定节点的值。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．修改节点值 （节点全路径，新节点值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
新节点值 | 必需的；文本型。本参数提供“修改节点值”命令欲修改节点的新值。

例程:

说明:

修改XML树结构某节点下节点的节点值。


修改二进制值 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会修改指定节点的值为二进制的值。注意该方法指定的二进制数据不应太大，否则该支持库将无法解析。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．修改二进制值 （节点全路径，新节点二进制值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
新节点二进制值 | 必需的；字节集。本参数提供“修改二进制值”命令欲修改节点的新的二进制值。

例程:

说明:

修改XML树结构某节点下节点的二进制值。


修改属性名 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会修改指定节点的属性名称。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．修改属性名 （节点全路径，属性名，新属性名）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
属性名 | 必需的；文本型。本参数提供“修改属性名”命令欲修改的节点属性名。该参数也可以是属性的索引，例如“@1”表示节点的第一个属性。
新属性名 | 必需的；文本型。本参数提供“修改属性名”命令欲修改节点的新属性名。

例程:

说明:

修改XML树结构某节点下节点的属性名称。


修改属性值 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法会修改指定节点的属性值。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．修改属性值 （节点全路径，属性名，新属性值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。
属性名 | 必需的；文本型。本参数提供“修改属性值”命令欲修改节点的属性名。该参数也可以是属性的索引，例如“@1”表示节点的第一个属性。
新属性值 | 必需的；文本型。本参数提供“修改属性值”命令欲修改节点的新属性值。

例程:

说明:

修改指定节点的属性值。


批量删除节点 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法要删除节点的路径参数可以支持通配符（*,?），该方法会删除所有符合路径条件的节点和该节点的子节点，该方法不允许删除根节点。注意索引形式的路径参数不支持通配符。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．批量删除节点 （节点全路径）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。注意该参数支持通配符（*，？），在路径中使用节点名称的时候可以在节点名称中使用通配符，使用索引的时候不支持通配符。

例程:

说明:

通过使用通配符批量删除节点，该命令不能删除根节点。


批量取节点值 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法要取值节点的路径参数可以支持通配符（*,?），该方法会取所有符合路径条件的节点的值。注意索引形式的路径参数不支持通配符。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．批量取节点值 （节点全路径，批量节点值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。注意该参数支持通配符（*，？），在路径中使用节点名称的时候可以在节点名称中使用通配符，使用索引的时候不支持通配符。
批量节点值 | 必需的；文本型，参数数据只能提供变量数组。本参数作为“批量取节点值”命令的填充参数。“批量取节点值”命令执行完毕后，该参数内容为节点值的数组。如果命令执行失败，该参数的值无意义。

例程:

说明:

通过使用通配符批量取得节点的节点值。


批量修改节点值 方法 操作系统支持：Windows、Linux 所属对象：XML树

该方法要修改节点的路径参数可以支持通配符（*,?），该方法会修改所有符合路径条件的节点的值。注意索引形式的路径参数不支持通配符。该方法执行成功返回真，执行失败返回假。

语法： 逻辑型 XML树．批量修改节点值 （节点全路径，新节点值）

参数名 | 描 述
节点全路径 | 必需的；文本型。本参数为节点在解析树中的全路径，格式有两种形式，一种为通过“/”字符把节点名称的串联起来，例如“根节点/子节点/叶子节点”，另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”，另外这两种形式可以混合使用，例如“根节点/@1/@2”。注意该参数支持通配符（*，？），在路径中使用节点名称的时候可以在节点名称中使用通配符，使用索引的时候不支持通配符。
新节点值 | 必需的；文本型。本参数作为“批量修改节点值”命令欲修改节点的新值。如果命令执行失败，该参数的值无意义。

例程:

说明:

通过使用通配符批量修改节点的节点值。


取根节点名文本 (XML树)

取根节点名文本 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得当前解析树根节点的名称文本。

语法： 文本型 XML 树．取根节点名文本 （［执行结果］）

参数名 | 描 述
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得当前解析树根节点的名称文本。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取子节点个数 (XML树)

取子节点个数 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的所有子节点的个数。

语法： 整数型 XML 树．取子节点个数 （节点全路径， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得参数节点的所有子节点的个数。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取所有子节点名 (XML树)

取所有子节点名 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得由参数节点的所有子节点名称组成的文本数组。

语法： 文本型数组 XML 树．取所有子节点名 （节点全路径， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得由参数节点的所有子节点名称组成的文本数组。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取节点值文本 (XML树)

取节点值文本 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点值文本。

语法： 文本型 XML 树．取节点值文本 （节点全路径， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得参数节点值文本。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取节点值字节集 (XML树)

取节点值字节集 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的二进制数据值。

语法： 字节集 XML 树．取节点值字节集 （节点全路径， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得参数节点的二进制数据值。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取属性个数 (XML树)

取属性个数 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得由参数节点的属性个数。

语法： 整数型 XML 树．取属性个数 （节点全路径， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得由参数节点的属性个数。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取所有属性名 (XML树)

取所有属性名 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得由参数节点的所有属性名称组成的文本数组。

语法： 文本型数组 XML 树．取所有属性名 （节点全路径， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得由参数节点的所有属性名称组成的文本数组。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取属性值文本 (XML树)

取属性值文本 方法 操作系统支持：Windows、Linux 所属对象：XML树

取得参数节点的特定属性值文本。

语法： 文本型 XML 树．取属性值文本 （节点全路径， 属性名， ［执行结果］）

参数名 | 描 述
节点全路径 | 必需的； 文本型。本参数为节点在解析树中的全路径，格式有两种形式：一种为通过“/”字符把节点名称串联起来，例如“根节点/子节点/叶子节点”；另一种是采用索引的形式，索引的最小值为1，表示它是它父节点的第几个子节点，然后在索引前面加上@符号，例如“@1/@2/@1”。这两种形式可以混合使用，例如“根节点/@1/@2”。
属性名 | 必需的； 文本型。本参数提供“取属性值”命令所需要的节点属性的名称。该参数也可以是属性的索引，例如“@1”表示节点的第一个属性。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取得参数节点的特定属性值文本。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


取XML数据 (XML树)

取XML数据 方法 操作系统支持：Windows、Linux 所属对象：XML树

取当前XML树的全部数据，并转换为字节集后返回。如果执行失败，返回值为空字节集。本方法所返回的数据与“导出到文件()”所写入文件的数据完全等同。

语法： 字节集 XML 树．取XML数据 （［字符集属性］， ［执行结果］）

参数名 | 描 述
字符集属性 | 可选的； 文本型。指定欲使用的XML字符集属性。如果省略本参数，则采用默认的字符集属性“GB2312”。
执行结果 | 可选的； 逻辑型，参数数据只能提供变量。如果提供本参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

例程

说明

取当前XML树的全部数据，并转换为字节集后返回。如果执行失败，返回值为空字节集。本方法所返回的数据与“导出到文件()”所写入文件的数据完全等同。如果提供第二个参数，其中将存放本方法的执行结果——成功为“真”，失败为“假”。

参考： 例程1


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 4 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。