MySql支持库

MySql支持库 帮助手册20080820版 返回支持库手册 返回首页

本支持库实现对MySql数据库的支持，在使用本支持库前请学习MYSQL相关知识，如果出错可以通过“取错误文本”查看出错信息。

操作系统支持： Windows、Linux

命令类别：

MySql支持库

其它数据类型：

字段信息类型

表更改信息类型

常量表...

适用版本，MySql支持库 （2.1#3版）


MySql支持库

MySql支持库 类别 跳至：MySql支持库

连接MySql | 断开MySql | 执行SQL语句 | 取记录集
释放记录集 | 读字段值 | 取记录集行数 | 到下一行
到指定行 | 到首行 | 到尾行 | 取字段总数
序号到字段名 | 字段名到序号 | 查找记录 | 增加记录
更新记录 | 删除记录 | 取字段宽度 | 取字段属性
取服务器版本 | 取客户端版本 | 创建库 | 删除库
查找库 | 取库名列表 | 创建表 | 修改表
删除表 | 查找表 | 取表名列表 | 创建用户
删除用户 | 查找用户 | 取用户列表 | 修改用户
建立索引 | 删除索引 | 取错误文本 | 开始事务
保存事务 | 回滚事务 | 到MYSQL文本 | 写字节集字段
字段是否为空 | 选择库 | 关闭MySql |

参见：基本数据类型


连接MySql 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

连接到MySql服务器,返回一个MySql句柄。

语法： 整数型 连接MySql （MySql服务器地址，用户名，密码，数据库名，端口）

参数名 | 描 述
MySql服务器地址 | 必需的；文本型。您想要连接的MySql服务器的地址,如果为空字符串("")或字符串"localhost"，是到本地主机的一个连接。
用户名 | 必需的；文本型。您的用户名,如果为空字符串(""),为当前用户。
密码 | 必需的；文本型。您的密码,如果为空字符串(""),USER表中存在空字段是可用。
数据库名 | 必需的；文本型。您想要连接的服务器,如果为空字符串("")默认数据库。
端口 | 必需的；整数型。您想要连接的MySql服务器的端口,如果为0则为默认端口。

例程：

说明：

连接MySql服务器，如果都为空则连接本地主机。

参见: 例程.e


断开MySql 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

断开一个MySql连接。

语法： 无返回值 断开MySql （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。调用 连接MySql 的返回值,如果为0则断开最后建立的连接。

例程：

说明：

断开与一个MySql的连接，由于MySql可以同时连接多个，使用断开命令对其它连接的MySql没有影响。

参见: 例程.e


执行SQL语句 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

为高级用户提供，初级用户无需掌握；执行一条SQL语句,执行成功返回真,失败返回假.如果执行成功可以通过 获得记录集 命令得到记录集句柄。

语法： 逻辑型 执行SQL语句 （MySql句柄，Sql语句）

参数名 | 描 述
MySql句柄 | 必需的；整数型。调用 连接MySql 的返回值。
Sql语句 | 必需的；文本型。查询数据库的SQL语句,如Select,Updata,Insert,Delete等等语句.详细信息请参考相关SQL语言书籍.它分为二种查询格式详见查询类型。

例程：

说明：

用来执行SQL语句，一般连接数据库之后，都用本命令执行查询，来更新数据库资料。

参见: 例程.e


获得记录集 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取记录集 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

得到查询后的记录的集合(简称：记录集).返回记录集句柄.当使用完记录集后要通过“释放记录集”命令来释放记录集。

语法： 整数型 取记录集 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

对数据库进行完查找等命令之后必须用本命令取得查找后的记录集以便操作。

参见: 例程.e


释放记录集 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

释放记录集。

语法： 无返回值 释放记录集 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。

例程：

说明：

使用取记录集命令取得的记录集，使用本命令来释放，在确定该记录集不需要使用的时候，尽量都用本命令释放。

参见: 例程.e


读字段值 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

读记录集中当前行的字段内容,字段索引从0开始.读取成功返回真,失败返回假.如果读取成功将把字段中的数据写入结果变量。

语法： 逻辑型 读字段值 （记录集句柄，字段，结果变量）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
字段 | 必需的；通用型。本参数指定您想要读取的字段，可以是字段名称或是字段序号。
结果变量 | 必需的；通用型，参数数据只能提供变量。本参数是存放返回结果的变量,如果字段类型为#MYSQL日期型或#MYSQL时间型或#MYSQL年份型时系统会转换为易语言中的日期时间型，如：字段为#MYSQL时间型，值为“23:33:34”，通过本命令得到的日期时间型变量的值为“2000-1-1 23:33:34”,如果字段为空时返回0或空字符串或空字节集。可以通过“字段是否为空”命令确定。

例程:

说明：

读取MySql数据库中字段的内容。本命令只读取所在行的记录，如果想全部读出，请在循环中使用。

参见: 例程.e


取记录集行数 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

获取记录集的行数。

语法： 长整数型 取记录集行数 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。

例程：

说明：

取得某记录集中所有纪录的行数，在使用本命令之前，必须用取记录集取回需要的记录集句柄。

参见: 例程.e


到下一行 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

将当前记录指针向下移动一行,成功返回真,失败返回假。

语法： 逻辑型 到下一行 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。

例程：

说明：

将当前记录指针移动到下一行，如果该行为最后一行，使用本命令将失败。

参见: 例程.e


到指定行 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

将当前记录指针移动到指定行,移动成功返回真,失败返回假。

语法： 逻辑型 到指定行 （记录集句柄，记录位置）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
记录位置 | 必需的；长整数型。本参数是准备移动到的新记录号，记录号值从 0 开始。

例程：

说明：

将当前记录指针移动到指定的行位置，如果指定的行不存在，本命令将失败。

参见: 例程.e


到首行 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

将当前记录指针移动到记录集首记录,移动成功返回真,失败返回假。

语法： 逻辑型 到首行 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。

例程：

说明：

将当前记录指针移动到纪录的首行位置，如果当前指针已经在首行，使用本命令移动一样会成功。

参见: 例程.e


到尾行 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

将当前记录指针移动到记录集尾记录,移动成功返回真,失败返回假。

语法： 逻辑型 到尾行 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。

例程：

说明：

将当前记录指针移动到记录尾行的位置，如果指针已经在尾行，只用本命令也会成功。

参见: 例程.e


取字段总数 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得记录集的字段总数,返回字段总数。

语法： 整数型 取字段总数 （记录集句柄）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。

例程：

说明：

取得记录集中字段的总数，记录集中的字段数量可能和数据库中不一样，具体根据使用的SQL命令不同，返回的也不同。

参见: 例程.e


序号到字段名 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

通过序号得到字段名,如果成功返回真,结果变量为得到的字段名,失败返回假,结果变量无效。

语法： 逻辑型 序号到字段名 （记录集句柄，序号，结果变量）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
序号 | 必需的；整数型。本参数是字段的序号。
结果变量 | 必需的；文本型，参数数据只能提供变量。本参数是存放返回的字段名的变量。

例程：

说明：

根据序号取得字段的名称，序号从0开始。

参见: 例程.e


字段名到序号 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

通过字段名得到序号,如果成功返回真,结果变量为得到的序号,失败返回假,结果变量无效。

语法： 逻辑型 字段名到序号 （记录集句柄，字段名，结果变量）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
字段名 | 必需的；文本型。本参数是字段的名称。
结果变量 | 必需的；整数型，参数数据只能提供变量。本参数是存放返回的序号的变量。

例程：

说明：

通过字段名取得该字段的序号，序号从0开始。

参见: 例程.e


查找记录 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

查找满足条件的记录,返回记录集句柄.注意执行这条语句后不需要再执行 返回记录集 命令。

语法： 整数型 查找记录 （MySql句柄，表名，字段名，查找条件，排序条件）

参数名 | 描 述
MySql句柄 | 必需的；整数型。调用 连接MySql 的返回值。
表名 | 必需的；文本型。您要查询的表的名称。
字段名 | 必需的；文本型。您要查询的表中字段的名称,可以使用逗号连接多个字段,如果为*号则表示查询所有字段. 例子1 单个字段 name 例子2 多个字段 name,email,id 例子3 所有字段 *。
查找条件 | 必需的；文本型。您要查询的条件.例子1 如果您要查找name的值为jack的记录 name='jack' 例子2 如果您要查找name的值为jack并且id的值为2的记录 name='jack' and id=2 例子3 如果您要查找name的值为jack或者id的值为2的记录 name='jack' or id=2。
排序条件 | 必需的；文本型。排序的条件 排序条件,ASC为升序,DESC为降序 例子 要对name字段进行降序排序 name DESC 。

例程：

说明：

根据查找条件查找纪录，查找条件返回记录集句柄，根据这个句柄操作查找的结果，不需要在使用取记录集来取得记录集句柄了。

参见: 例程.e


增加记录 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

写入信息到新记录的指定字段,执行成功返回真,失败返回假。

语法： 逻辑型 增加记录 （MySql句柄，表名，赋值语句）

参数名 | 描 述
MySql句柄 | 必需的；整数型。调用 连接MySql 的返回值。
表名 | 必需的；文本型。您要写入新记录的表的名称。
赋值语句 | 必需的；文本型。您要执行的赋值语句.例子 增加一条记录并且为字段name与email赋予值jack与jack@126.com name='jack',email='jack@126.com'。

例程：

说明：

在记录集的尾部增加一条新记录，字节集类型记录不能使用该命令增加。

参见: 例程.e


更新记录 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

更新指定字段的数据,更新成功返回真,失败返回假。

语法： 逻辑型 更新记录 （MySql句柄，表名，赋值语句，条件）

参数名 | 描 述
MySql句柄 | 必需的；整数型。调用 连接MySql 的返回值。
表名 | 必需的；文本型。您要更新数据的表的名称。
赋值语句 | 必需的；文本型。您要执行的赋值语句.例子 为已有记录的字段name与email赋予新值sun与sun@126.com name='sun',email='sun@126.com'。
条件 | 必需的；文本型。查找符合条件的记录.如果为' '(空格)那么将更新所有记录.例子 当字段name的内容jack时更新记录 name=jack。

例程：

说明：

修改数据库中某字段的内容，根据参数提供的条件修改，所以可以根据参数大批量修改。

参见: 例程.e


删除记录 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

删除一条记录,删除成功返回真,失败返回假。

语法： 逻辑型 删除记录 （MySql句柄，表名，条件）

参数名 | 描 述
MySql句柄 | 必需的；整数型。调用 连接MySql 的返回值。
表名 | 必需的；文本型。您要进行删除操作的表的名称。
条件 | 必需的；文本型。删除符合条件的记录.如果为' '(空格)将删除所有记录.例子 当字段name的内容为jack时删除记录 name=jack。

例程：

说明：

根据提供的条件来删除相应记录，如果条件给空，将删除所有记录。

参见: 例程.e


取字段宽度 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得指定字段的宽度,出错返回-1。

语法： 整数型 取字段宽度 （记录集句柄，字段序号）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
字段序号 | 必需的；整数型。本参数是您要取的宽度的字段的序号。

例程：

说明：

取得某字段名称的宽度，不如说字段名为“name”取出的字段宽度就为4，如果字段名为中文，一个中文占两个宽度。

参见: 例程.e


取字段属性 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得字段的属性,返回与字段类型常量向对应的值,出错返回-1。

语法： 整数型 取字段属性 （记录集句柄，字段名或字段序号）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
字段名或字段序号 | 必需的；通用型。本参数是您要取得属性的字段的名称或序号。

例程：

说明：

取得某字段的类型，参数二可以为字段名称或者字段序号，序号从0开始。

参见:例程.e


取服务器版本 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得MYSQL服务器的版本信息并设置结果变量,成功返回真,失败返回假。

语法： 逻辑型 取服务器版本 （MySql句柄，结果变量）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
结果变量 | 必需的；文本型，参数数据只能提供变量。本参数存放调用本命令后的结果。

例程：

说明：

取得服务器端MySql数据库的版本信息。

参见: 例程.e


取客户端版本 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得MYSQL客户端的版本信息并设置结果变量,成功返回真,失败返回假。

语法： 逻辑型 取客户端版本 （结果变量）

参数名 | 描 述
结果变量 | 必需的；文本型，参数数据只能提供变量。本参数存放调用本命令后的结果。

例程：

说明：

取得用户当前使用的MySql数据库的客户端版本。

参见: 例程.e


创建库 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

创建一个数据库.成功返回真,失败返回假。

语法： 逻辑型 创建库 （MySql句柄，库名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
库名 | 必需的；文本型。本参数是将用创建的库的名称。

例程：

说明：

创建一个新的数据库，创建库文件之前用户必须确定有足够的权限，否则不能创建。如果需要用中文名创建，中文名称必须用``括起来，如：`中文名`“ `”这个符号为键盘上“1”旁边的按键。

参见:例程.e


删除库 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

删除一个数据库.成功返回真,失败返回假。

语法： 逻辑型 删除库 （MySql句柄，库名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
库名 | 必需的；文本型。本参数是将要删除的库的名称。

例程：

说明：

删除一个数据库，在进行操作之前必须确定有足够的权限，否则操作将失败。

参见:例程.e


查找库 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

查找一个数据库.找到返回真,没找到返回假。

语法： 逻辑型 查找库 （MySql句柄，库名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
库名 | 必需的；文本型。本参数是将要查找的库的名称。

例程：

说明：

查找一个数据库是否存在，在查找之前确认有足够的权限，否则操作将失败。

参见:例程.e


取库名列表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得数据库名称的列表.成功返回真,失败返回假.结果可以通过“取记录集”取得。

语法： 逻辑型 取库名列表 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

查找一共有多少数据库，在查找之前确认有足够的权限，否则将失败。

参见:例程.e


创建表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

创建一个表；成功返回真,失败返回假。

语法： 逻辑型 创建表 （MySql句柄，表名，字段信息表）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是将要创建的表的名称。
字段信息表 | 必需的；窗口，参数数据只能提供数组数据。本参数是由字段信息类型组成的数组，这个数组中最多有一个类型为#字段附加类型的元素。

例程：

说明：

在指定库中创建一个表，在创建之前确认有足够的权限，否则将失败。如果需要用中文名创建，中文名称必须用``括起来，如：`中文名`“ `”这个符号为键盘上“1”旁边的按键。

参见:例程.e


修改表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

修改一个表；成功返回真,失败返回假。

语法： 逻辑型 修改表 （MySql句柄，表名，更改信息表，字段信息，修改类型）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是将要修改表的表名。
更改信息表 | 必需的；报表。本参数记录了新表的相关信息。
字段信息 | 必需的；窗口。本参数在修改类型为#增加字段或#修改字段时使用。
修改类型 | 必需的；整数型。本参数是#增加字段，#修改字段#，#删除字段，#增加索引，#删除索引，#增加主键，#删除主键其中之一。

例程：

说明：

修改数据库中的表，在修改之前确认有足够的权限，否则操作将失败。

参见: 例程.e


删除表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

删除一个表；成功返回真,失败返回假。

语法： 逻辑型 删除表 （MySql句柄，表名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是将要删除的表的表名。

例程：

说明：

删除数据库中的表，在操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


查找表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

查找一个表,找到返回真,没找到返回假。

语法： 逻辑型 查找表 （MySql句柄，表名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是将要查找的表的表名。

例程：

说明：

查找数据库中的表，在操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


取表名列表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得当前数据库中所有表的名称列表.成功返回真,失败返回假.结果可以通过“取记录集”取得。

语法： 逻辑型 取表名列表 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

取得数据库中所有表的详细信息，在操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


创建用户 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

创建一个用户。成功返回真,失败返回假。具体规则请参见MYSQL相关手册。

语法： 逻辑型 创建用户 （MySql句柄，主机，用户名，密码，库名，表名，权限）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
主机 | 必需的；文本型。本参数是与新用户相关联的主机名,如果为空则为所有主机。
用户名 | 必需的；文本型。本参数是新用户名。
密码 | 必需的；文本型。本参数是用户的密码。
库名 | 必需的；文本型。本参数是新用户所操作的库,如果为空或“*”,则为所有库。
表名 | 必需的；文本型。本参数是新用户所操作的表,当库名不为空或“*”时本参数可以为空或“*”即所有表。
权限 | 必需的；整数型。本参数是新用户对库或表的操作权限。如果为空则为无权限。

例程：

说明：

创建一个用户，在操作之前确认有足够的权限，否则操作将失败。如果需要用中文名创建，中文名称必须用``括起来，如：`中文名`“ `”这个符号为键盘上“1”旁边的按键。

参见:例程.e


删除用户 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

删除一个用户.成功返回真,失败返回假。

语法： 逻辑型 删除用户 （MySql句柄，用户名，主机）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
用户名 | 必需的；文本型。本参数是将要删除用户的名字。
主机 | 必需的；文本型。本参数是与用户名相关联的主机名。

例程：

说明：

删除一个用户，在操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


查找用户 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

查找一个用户.成功返回真,失败返回假。

语法： 逻辑型 查找用户 （MySql句柄，用户名，主机）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
用户名 | 必需的；文本型。本参数是欲查找的用户名。
主机 | 必需的；文本型。本参数是与用户名相关联的主机名。

例程：

说明：

查找一个用户，在操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


取用户列表 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

取得用户名列表.成功返回真,失败返回假.结果可以通过“取记录集”取得。

语法： 逻辑型 取用户列表 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值

例程：

说明：

取得用户名列表，操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


修改用户 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

修改一个用户.成功返回真,失败返回假。

语法： 逻辑型 修改用户 （MySql句柄，用户名，主机名，库名，表名，权限）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
用户名 | 必需的；文本型。本参数是将要修改的用户名。
主机名 | 必需的；文本型。本参数是与新用户相关联的主机名。
库名 | 必需的；文本型。本参数是用户操作的新库,如果为空或“*”,则为所有库。
表名 | 必需的；文本型。本参数是用户操作的新表,当库名不为空或“*”时本参数可以为空或“*”即所有表。
权限 | 必需的；整数型。本参数是用户的新权限。如果为空则无任何权限。

例程：

说明：

修改用户名，操作之前确认有足够的权限，否则操作将失败。

参见:例程.e


建立索引 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

建立一个索引.成功返回真,失败返回假。

语法： 逻辑型 建立索引 （MySql句柄，表名，列名，索引名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是将要建立索引的表。
列名 | 必需的；文本型。本参数是将要建立索引使用的列（字段）名。
索引名 | 必需的；文本型。本参数是将要建立的索引名。

例程：

说明：

为一个字段创建一个索引，索引必须为文本，不能为文本型数字，比如：“1”否则将失败。

参见:例程.e


删除索引 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

删除一个索引.成功返回真,失败返回假。

语法： 逻辑型 删除索引 （MySql句柄，表名，索引名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是将要删除的索引所在的表。
索引名 | 必需的；文本型。本参数是将要删除的索引。

例程：

说明：

删除一个索引，该索引必须存在，否则将删除失败。

参见:例程.e


取错误文本 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

有错误发生返回真,并填充错误信息,没错误发生返回假。

语法： 逻辑型 取错误文本 （MySql句柄，错误信息）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
错误信息 | 必需的；文本型，参数数据只能提供变量。本参数为错误信息字符串。

例程：

说明：

如果MySql数据库执行错误，可以用本命令取回执行错误的文本信息。

参见:例程.e


开始事务 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

开始一件事务.成功返回真,失败返回假. 注意 事务不可以用于MyISAM数据表类型,但是返回值为真.关于数据表类型设置请参考相关MYSQL资料。

语法： 逻辑型 开始事务 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

开始纪录一个事务。事务是对数据库所做的一系列改变。我们完成一项任务往往需要多步操作，而当其中一步出错后，以前的所有操作应取消，这时我们必需使用事务。首先开始事务，开始执行所有操作，当所有操作全部结束时，我们就保存事务。当发生错误时，我们就回滚事务。

参见:例程.e


保存事务 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

保存一件事务.成功返回真,失败返回假. 注意 事务不可以用于MyISAM数据表类型,但是返回值为真.关于数据表类型设置请参考相关MYSQL资料。

语法： 逻辑型 保存事务 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

保存从开始事务到现在的操作。事务是对数据库所做的一系列改变。我们完成一项任务往往需要多步操作，而当其中一步出错后，以前的所有操作应取消，这时我们必需使用事务。首先开始事务，开始执行所有操作，当所有操作全部结束时，我们就保存事务。当发生错误时，我们就回滚事务。

参见:例程.e


回滚事务 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

回滚一件事务.成功返回真,失败返回假. 注意 事务不可以用于MyISAM数据表类型,但是返回值为真.关于数据表类型设置请参考相关MYSQL资料。

语法： 逻辑型 回滚事务 （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

回滚保存事务保存的事务。事务是对数据库所做的一系列改变。我们完成一项任务往往需要多步操作，而当其中一步出错后，以前的所有操作应取消，这时我们必需使用事务。首先开始事务，开始执行所有操作，当所有操作全部结束时，我们就保存事务。当发生错误时，我们就回滚事务。

参见:例程.e


到MYSQL文本 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

从易语言中的数据类型转换到可以被MYSQL识别的文本。可以将易语言中的时间，逻辑型到MYSQL中相应数据类型，转换成功返回MYSQL可以识别的文本，失败返回空文本。

语法： 文本型 到MYSQL文本 （易语言类型数据，时间类型）

参数名 | 描 述
易语言类型数据 | 必需的；通用型。本参数是易语言中时间日期型或逻辑型的数据。
时间类型 | 必需的；整数型，初始值为“12”。本参数是要转换到MYSQL的时间与日期类的类型常量，如#MYSQL日期型，#MYSQL日期型，#MYSQL日期与时间型，#MYSQL年份型。注意:当“易语言类型数据”为日期时间型时，本参数有效。

例程：

说明：

将易语言的时间数据类型转换到MySql认可的时间数据类型。

参见:例程.e


写字节集字段 命令 操作系统支持：Windows、Linux、Linux 所属类别：MySql支持库

写字节集字段 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

写字节集字段。本命令只用于写字段类型为字节集的字段,注意:一次写入数据的大小MYSQL做了限制，如果需要改动请参考相应MYSQL手册，对MYSQL服务器进行调整。

语法： 逻辑型 写字节集字段 （MySql句柄，表名，字段名，条件，字节集）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
表名 | 必需的；文本型。本参数是您要更新数据的表的名称。
字段名 | 必需的；文本型。本参数是待写入字段名称，注意此字段的字段类型必须是字节集。
条件 | 必需的；文本型。本参数是查找符合条件的记录.如果为“”空字符串那么将更新所有记录.例如当字段name的内容“jack”时更新记录: name='jack'。
字节集 | 必需的；字节集。本参数是待读入的字节集。

例程：

说明：

将一个字节集数据写入到字节集字段中，条件如果不填，将增加一个字段把数据写入，如果条件为“”将更新所有字段，否则根据条件来更新相应字段。

参见:例程.e


字段是否为空 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

判断记录集中当前行的某个字段是否为空，不为空返回真，为空返回假。

语法： 逻辑型 字段是否为空 （记录集句柄，字段）

参数名 | 描 述
记录集句柄 | 必需的；整数型。本参数是调用“取记录集”命令的返回值。
字段 | 必需的；通用型。本参数指定您想要读取的字段，可以是字段名称或是字段序号。

例程：

说明：

通过判断记录集中某字段是否为空，进行不同操作。

参见:例程.e


选择库 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

选择一个数据库为当前用户默认使用的数据库，成功返回真，失败返回假。

语法： 逻辑型 选择库 （MySql句柄，库名）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。
库名 | 必需的；文本型。本参数为要选择的数据库名。

例程：

说明：

决定当前操作的库。

参见:例程.e


关闭MySql 命令 操作系统支持：Windows、Linux 所属类别：MySql支持库

让数据库服务器关闭。连接的用户必须有shutdown权限，成功返回真，失败返回假。

语法： 逻辑型 关闭MySql （MySql句柄）

参数名 | 描 述
MySql句柄 | 必需的；整数型。本参数是调用“连接MySql”命令的返回值。

例程：

说明：

可以让服务器关闭，回来可取得成功消息。

参见:例程.e


字段信息类型

字段信息类型 普通类型 操作系统支持：Windows、Linux 跳至：MySql支持库

成员 | 描 述
类型 | 整数型；初始值为 1 。本结构的类型 #字段基本类型 或 #字段附加类型 为#字段基本类型时主键与索引将被忽略.为#字段附加类型时,除主键与索引外其它元素将被忽略。
字段名 | 文本型；字段名，如果为中文字段名请在字段名两边加“`”,如：`姓名`。
字段类型 | 整数型；字段的类型,详细类型说明,请参见本支持库定义的字段类型常量。
列内容为空 | 逻辑型；如果为真则列内容能为空,如果为假则列内容不能为空。
列数据默认值 | 文本型；列内容的默认值,如果没有默认值为空字符串。
自增量标记 | 逻辑型；如果为真则当前字段具有自增量属性,即在插入新数据时该字段会在原有最大值的基础上自动增加1,设置次属性.详细介绍请参考MYSQL手册。
附加类型信息 | 整数型；附加与字段的属性,其值为 #最大长度 #无符号 #以0填充 #二进制 .可以把属性相加.如 #无符号+#以0填充.属性具体含义请参见MYSQL手册。
附加内容 | 文本型；如果附加类型信息具有 #最大长度 类型那么这个参数为最大长度,如果字段类型为 #枚举 或 #集合 那么这个参数为枚举或集合的取值范围,如果本结构类型为 #字段附加类型,并且为索引。那么本成员变量为索引名。
主键 | 文本型；设置为主键的字段名,如“fieldname”.为#附加类型时有效,没有表中只可以有一个主键,具体作用请参见MYSQL手册。
索引 | 文本型；设置为索引的字段名可以有多个，通过“,”分割,如“fieldname1,fieldname2,fieldname3”.为#附加类型时有效,具体作用请参见MYSQL手册。

参见： 基本数据类型


表更改信息类型

表更改信息类型 普通类型 操作系统支持：Windows、Linux 跳至：MySql支持库

成员 | 描 述
字段名 | 文本型；当修改类型为#修改字段时使用本成员作为旧字段名.当为#删除字段时本成员为准备删除的字段名。
字段信息 | 文本型；当修改类型为#增加索引时本成员作为索引使用的字段。如果需要使用多个字段可以通过“,“分割。如”fieldname1,fieldname2,fieldname3“。
索引名 | 文本型；当修改类型为#增加索引或#删除索引时本成员作为索引名使用。
主键名 | 文本型；当修改类型为#增加主键时本成员作为主键名使用。

参见：基本数据类型


常量 | 常量值 | 描 述
#字段基本类型 | 1 |
#字段附加类型 | 2 |
#增加字段 | 1 |
#修改字段 | 2 |
#删除字段 | 3 |
#增加索引 | 4 |
#删除索引 | 5 |
#增加主键 | 6 |
#删除主键 | 7 |
#最大长度 | 1 |
#无符号 | 2 |
#以0填充 | 4 |
#二进制 | 8 |
#MYSQL未压缩浮点数型 | 0 | 未压缩浮点数，不能无符号。行为如同一个文本型：“未压缩”意味着数字作为一个字符串被存储，值的每一位使用一个字符。值的最大范围与DOUBLE相同。
#MYSQL字节型 | 101 | 一个字节。有符号的范围是-128到127，无符号的范围是0到255。
#MYSQL逻辑型 | 102 | 逻辑型，一个字节。
#MYSQL短整型 | 2 | 短整型，有符号的范围是-32768到32767，无符号的范围是0到65535。
#MYSQL整型 | 3 | 整型，有符号的范围是-2147483648到2147483647，无符号的范围是0到4294967295。
#MYSQL浮点型 | 4 | 浮点型，不能无符号。允许的值是-3.402823466E+38到-1.175494351E-38，0 和1.175494351E-38到3.402823466E+38。
#MYSQL双精度浮点型 | 5 | 双精度浮点型，不能无符号。允许的值是-1.7976931348623157E+308到-2.2250738585072014E-308、 0和2.2250738585072014E-308到1.7976931348623157E+308。
#MYSQL时间戳记型 | 7 | 时间戳记，范围是'1970-01-01 00:00:00'到2037年的某时。MySQL以YYYYMMDDHHMMSS、YYMMDDHHMMSS、YYYYMMDD或YYMMDD格式来显示时间戳记的值。
#MYSQL长整型 | 8 | 长整型，有符号的范围是-9223372036854775808到9223372036854775807，无符号的范围是0到18446744073709551615。
#MYSQL24整型 | 9 | 24整型，有符号的范围是-8388608到8388607，无符号的范围是0到16777215。
#MYSQL日期型 | 10 | 日期，支持的范围是'1000-01-01'到'9999-12-31'。MySQL以'YYYY-MM-DD'格式来显示日期值，但是允许你使用字符串或数字把值赋给类型为日期的列。
#MYSQL时间型 | 11 | 时间，范围是'-838:59:59'到'838:59:59'。MySQL以'HH:MM:SS'格式来显示时间值，但是允许你使用字符串或数字把值赋给类型为时间的列。
#MYSQL日期与时间型 | 12 | 日期与时间，支持的范围是'1000-01-01 00:00:00'到'9999-12-31 23:59:59'。MySQL以'YYYY-MM-DD HH:MM:SS'格式来显示日期与时间的值，但是允许你使用字符串或数字把值赋给属性是日期与时间的列。
#MYSQL年份型 | 13 | 年，允许的值是1901到2155，和0000（4位年格式），如果你使用2位，1970-2069( 70-69)。MySQL以YYYY格式来显示年的值，但是允许你把使用字符串或数字值赋给属性是年的列。
#MYSQL短字节集 | 25201 | 短字节集，最大长度为255(2^8-1)个字符。
#MYSQL短备注型 | 25202 | 短备注，最大长度为255(2^8-1)个字符。
#MYSQL备注型 | 25203 | 备注，最大长度为65535(2^16-1)个字符。
#MYSQL字节集型 | 25204 | 字节集，最大长度为65535(2^16-1)个字符。
#MYSQL长字节集型 | 25205 | 长字节集，最大长度为16777215(2^24-1)个字符。
#MYSQL长备注型 | 25206 | 长备注，最大长度为16777215(2^24-1)个字符。
#MYSQL巨字节集型 | 25207 | 巨字节集，最大长度为4294967295(2^32-1)个字符。
#MYSQL巨备注型 | 25208 | 巨备注，最大长度为4294967295(2^32-1)个字符。
#MYSQL变长文本型 | 253 | 变长文本型，一个变长字符串。
#MYSQL枚举型 | 25401 | 枚举，一个仅有一个值的字符串对象，这个值式选自与值列表'value1'、'value2', ...,或NULL。一个枚举最多能有65535不同的值。
#MYSQL集合型 | 25402 | 集合，能有零个或多个值的一个字符串对象，其中每一个必须从值列表'value1', 'value2', ...选出。一个集合最多能有64个成员。
#MYSQL文本型 | 25403 | 文本型，一个定长字符串。
#字节与逻辑型 | 1 | 字节与逻辑型，不能用与定义字段，可以使用他来判断字段类型。
#备注与字节集型 | 252 | 备注与字节集型，不能用与定义字段，可以使用他来判断字段类型。
#枚举与集合型 | 254 | 枚举与集合型，不能用与定义字段，可以使用他来判断字段类型。
#无任何权限 | 0 |
#查询权限 | 1 |
#增加权限 | 2 |
#更改权限 | 4 |
#删除权限 | 8 |
#索引权限 | 16 |
#改变表权限 | 32 |
#创建表或库或索引权限 | 64 |
#删除表或库权限 | 128 |
#备注表或库权限 | 256 |
#重新装载服务器权限 | 215 |
#关闭服务器权限 | 1024 |
#服务器进程管理权限 | 2048 |
#服务器文件存取权限 | 4096 |
#所有权限 | 8192 |

参见：基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。