网络传送支持库

网络传送支持库 帮助手册20080827版 返回支持库手册 返回首页

本支持库实现对多种协议断点续传下载与FTP上传的支持，并提供了丰富的设置方式。当前版本支持HTTP，FTP，MMS多线程下载及断点续传，以及对RTSP协议的单线程下载及断点续传。用户可以根据各自的主机及网络情况进行设置,本支持库可以运行在linux下.详细情况参见例程。注意：当前版本使用了影射文件模式，并且是一次全部影射的方法。所以最大传送不超过一次影射文件的长度。

操作系统支持： Windows、Linux

命令类别：

全局命令

其它数据类型：

下载对象 | FTP上传对象 | FTP辅助对象 | 任务参数
传送常量 |  |  |

适用版本，网络传送支持库 （2.0#3版）


全局命令

全局命令 类别 跳至：网络传送支持库


网络通讯设置 命令 操作系统支持：Windows、Linux 所属类别：全局命令

初始化下载支持库，进行基本设置。

语法： 逻辑型 网络通讯设置 （写入文件大小，重连时间，重连次数）

参数名 | 描 述
写入文件大小 | 必需的；整数型，初始值为“20480”。本参数指定每次写入文件的指定大小，默认为20480。
重连时间 | 必需的；整数型，初始值为“0”。出错时连接服务器间隔时间，默认为0。
重连次数 | 必需的；整数型，初始值为“0”。出错时重复连接服务器次数，默认为0。

例程:

说明:

他是设置FTP的上传下载和速度的指令。

参见:例程


设重试时间 命令 操作系统支持：Windows、Linux 所属类别：全局命令

设置重新尝试连接的时间。

语法： 无返回值 设重试时间 （重试时间）

参数名 | 描 述
重试时间 | 必需的；整数型，初始值为“5000”。尝试重新连接的时间。

例程:

说明:

设置重新尝试连接的时间。注意重试时间为毫秒。


设重试时间 命令 操作系统支持：Windows、Linux 所属类别：全局命令

取总下载速度 命令 操作系统支持：Windows、Linux 所属类别：全局命令

获得所有任务的下载速度。本命令为初级命令。

语法： 〈整数型〉 取总下载速度 （）

例程:

说明:

获得所有下载任务的速度总和。


下载对象

下载对象 普通类型 操作系统支持：Windows、Linux 跳至：网络传送支持库

方法：

增加新任务 | 停止指定任务 | 继续下载任务 | 增加线程
减少线程 | 限制速度 | 取下载速度 | 取已下载长
取任务数据 | 取重试次数 | 取对象信息 | 取线程信息
取任务数据项 | 取本地文件路径 | 设新文件名 |

参见： 基本数据类型


增加新任务 方法 操作系统支持：Windows、Linux 所属对象：下载对象

增加一个下载文件的任务,当前支持HTTP，FTP协议。”本地文件路径“不能是已经存在的文件。成功返回真，失败返回假注意：默认线程原则上没有限制。但使用时应根据具体情况设置。否则不但起不到提高速度的作用还会影响系统的稳定。

语法： 逻辑型 下载对象．增加新任务 （配置信息）

参数名 | 描 述
配置信息 | 必需的；任务参数。配置任务相关信息。

例程:

说明:

FTP下载对象增加任务，如果当前有任务会停止现有任务。FTP上传对象设置上传任务，这个任务只可一次一个任务。


停止指定任务 方法 操作系统支持：Windows、Linux 所属对象：下载对象

停止一个下载文件的任务,当前支持HTTP，FTP协议。支持阻塞与非阻塞方式，详细信息见参数。成功返回真，失败返回假。

语法： 逻辑型 下载对象．停止指定任务 （任务信息，执行方式）

参数名 | 描 述
任务信息 | 必需的；字节集，参数数据只能提供变量。本参数是用于保存下载任务的相关信息的。
执行方式 | 必需的；整数型，初始值为“1”。本参数是用于用户确定函数执行的方式，1 表示阻塞方式即直到所有停止工作全部做完后返回，如果在指定的时间段内还没有全部结束则强制杀死线程并返回，这个时间段为”线程等待超时“ * 当前线程数2 表示非阻塞方式即结束操作由系统在后台处理，直接返回默认为1 阻塞方式。

例程:

说明:

停止制定的ftp下载任务。参数一返回任务的信息


继续下载任务 方法 操作系统支持：Windows、Linux 所属对象：下载对象

继续一个下载文件的任务,当前支持HTTP，FTP协议。成功返回真，失败返回假注意：继续下载时默认线程数不是根据任务参数中的默认线程数进行设置的，而是根据任务信息中的没有完成的断点信息的数量进行设置的。断点的数量则是根据任务自本次运行以前开启的线程的总数减去已经完成下载任务的线程数获得的。

语法： 逻辑型 下载对象．继续下载任务 （配置信息，任务信息）

参数名 | 描 述
配置信息 | 必需的；任务参数。配置任务相关信息。
任务信息 | 必需的；字节集。本参数是通过“停止任务”命令所获得的任务信息。

例程:

说明:

FTP的下载任务继续上次的下载新的任务。参数二由结束任务或取任务信息取得


增加线程 方法 操作系统支持：Windows、Linux 所属对象：下载对象

增加一个下载线程,如果最大块的长度小于接收大小的2倍时将不能开启新线程注意：下载线程原则上可以无限增加，但是请您根据您的实际情况谨慎使用。不要过多或过与频繁的增加线程，否则不但不能提高效率，相反会影响系统的稳定。

语法： 逻辑型 下载对象．增加线程 （）

例程:

说明:

增减FTP下载的线程数。


减少线程 方法 操作系统支持：Windows、Linux 所属对象：下载对象

减少一个下载线程, 当只有一个下载线程工作时，将不能结束这个线程。

语法： 逻辑型 下载对象．减少线程 （）

例程:

说明:

减少FTP下载任务的线程数。


限制速度 方法 操作系统支持：Windows、Linux 所属对象：下载对象

限制下载速度。

语法： 逻辑型 下载对象．限制速度 （速度）

参数名 | 描 述
速度 | 必需的；整数型。限制后的速度。

例程:

说明:

限制FTP的下载的速度，首先取得FTP的现下载速度。


取下载速度 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得下载速度，本命令获得的速度为即时速度。如，每间隔1秒调用一次本命令，那么获得的值表示1秒内收到的数据间隔2秒则表示2秒内收到的数据。

语法： 整数型 下载对象．取下载速度 （）

例程:

说明:

限制FTP的下载的速度，首先取得FTP的现下载速度。


取已下载长 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得任务已下载大小。

语法： 整数型 下载对象．取已下载长 （）

例程:

说明:

文件传送的回调中取得ftp的已完成的长度和重试次数。


取任务数据 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得任务数据，在指定的时间内执行本命令来取得任务数据。如果下载任务出现异常，可以通过“继续下载任务”来继续任务。

语法： 逻辑型 下载对象．取任务数据 （任务数据）

参数名 | 描 述
任务数据 | 必需的；字节集，参数数据只能提供变量。本参数是用于保存下载任务的相关信息的。

例程:

说明:

取得FTP的下载任务的当前的任务的信息。


取重试次数 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得重试次数。

语法： 整数型 下载对象．取重试次数 （）

例程:

说明:

文件传送的回调中取得ftp的已完成的长度和重试次数。


取对象信息 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得下载对象信息,通常用于多个对象使用相同的日志或交互回调函数时，在日志或交互回调函数中确定对象，如果失败返回-1。

语法： 整数型 下载对象．取对象信息（）

  例程:

说明：

在回调函数中，用本方法取得下载或上传对象的信息与回调函数中的“对象信息”参数比较，从而确定本消息属于哪个对象。

参见：例程


取线程信息 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得线程信息，通常用于多个对象使用相同的日志或交互回调函数时，在日志或交互回调函数中确定线程。

语法： 逻辑型 下载对象．取线程信息 （线程信息数组）

参数名 | 描 述
线程信息数组 | 必需的；整数型，参数数据只能提供变量及变量数组。本参数是用于保存线程信息数组。

例程:

说明：

使用本方法取得某个下载对象使用的线程。

参见：例程


取任务数据项 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得通过“停止指定任务”命令返回的任务信息中的各类数据。失败返回-1。

语法： 整数型 下载对象．取任务数据项 （任务数据，数据类型，类型参数）

参数名 | 描 述
任务数据 | 必需的；字节集。本参数是通过“停止任务”命令所获得的任务数据。
数据类型 | 必需的；整数型。需要获得的任务信息的类型。如果”类型参数“作为指定具体断点序号使用，那么它从1开始不大于断点个数,1 待下载文件总长度，2 已下载总长度,3 断点个数,4 指定断点开始下载位置,类型参数为序号,5 指定断点待下载长度,类型参数为序号,6 指定断点已下载长度,类型参数为序号。
类型参数 | 必需的；整数型，初始值为“0”。根据”数据类型“参数的不同而不同。当需要查询的信息类型没有指定本参数的意义时，本参数无意义。

例程:

说明：

在停止下载任务后，用本方法取得任务信息数据。

参见：例程


取本地文件路径 方法 操作系统支持：Windows、Linux 所属对象：下载对象

获得待下载文件保存在本地的路径。本命令在收到”存在同名文件“消息时使用可以获得已经存在的同名文件的路径本命令在收到“下载上传开始”消息后使用可以获得当前下载的文件保存在本地的准确路径。

语法： 文本型 下载对象．取本地文件路径 （）

例程:

说明：

取得下载文件保存的路径。

参见：例程


设新文件名 方法 操作系统支持：Windows、Linux 所属对象：下载对象

本命令用来设置新的本地文件名。本命令必须是在处理“存在同名文件”这个消息的过程中使用。并且返回 #设置新名。

语法： 逻辑型 下载对象．设新文件名 （新文件名）

参数名 | 描 述
新文件名 | 必需的；文本型。新的本地文件名。

例程:

说明：

本命令用来设置新的本地文件名。本命令必须是在处理“存在同名文件”这个消息的过程中使用。


FTP上传对象

FTP上传对象 普通类型 操作系统支持：Windows、Linux 跳至：网络传送支持库

方法：

上传文件 | 停止上传 | 限制速度 | 取上传速度
取已上传长 | 取重试数 | 设新文件名 | 取对象信息

参见： 基本数据类型


上传文件 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

增加一个上传文件的任务,当前支持FTP协议。成功返回真，失败返回假。

语法： 逻辑型 FTP 上传对象．上传文件 （配置信息）

参数名 | 描 述
配置信息 | 必需的；任务参数。配置任务相关信息。

例程:

说明:

FTP下载对象增加任务，如果当前有任务会停止现有任务。FTP上传对象设置上传任务，这个任务只可一次一个任务。


停止上传 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

停止一个上传文件的任务,当前支持FTP协议。成功返回真，失败返回假。

语法： 逻辑型 FTP 上传对象．停止上传 （）

例程:

说明:

停止当前的FTP上传任务。


限制速度 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

限制上传速度。

语法： 逻辑型 FTP 上传对象．限制速度 （速度）

参数名 | 描 述
速度 | 必需的；整数型。指定上传速度。

例程:

说明:

限制FTP的上传的速度。


取上传速度 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

获得上传速度,本命令获得的速度为即时速度。如，每间隔1秒调用一次本命令，那么获得的值表示1秒内收到的数据间隔2秒则表示2秒内收到的数据。

语法： 整数型 FTP 上传对象．取上传速度 （）

例程:

说明:

获取上传速度。


取已上传长 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

获得任务已上传大小。

语法： 整数型 FTP 上传对象．取已上传长 （）

例程:

说明:

获取已上传到服务器的字节数。


取重试数 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

获得重试次数。

语法： 整数型 FTP 上传对象．取重试数 （）

例程:

说明:

通过“取重试次数”命令获取此次任务执行已重试的次数。


设新文件名 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

本命令用来设置新的上传文件名。

语法： 逻辑型 FTP 上传对象．设新文件名 （新文件名）

参数名 | 描 述
新文件名 | 必需的；文本型，初始值为“newfile”。上传到服务器的文件的新名。

例程:

说明:

如果在上传交互回调函数中收到“发现存在文件消息”，就可以调用“设新文件名”命令并返回常量“改名”就可以将新上传的文件改为新文件名。


取对象信息 方法 操作系统支持：Windows、Linux 所属对象：FTP上传对象

获得FTP上传对象信息,通常用于多个FTP上传对象使用相同的日志或交互回调函数时，在日志或交互回调函数中确定FTP上传对象。

语法： 整数型 FTP 上传对象．取对象信息 （）

例程:

说明:

在交互回调函数中取得FTP上传对象的对象信息以便判断回调函数中触发的对象。


FTP辅助对象

FTP辅助对象 普通类型 操作系统支持：Windows、Linux 跳至：网络传送支持库

方法：

连接FTP服务器 | 断开FTP服务器 | 删除文件 | 文件改名
创建目录 | 删除目录 | 置现行目录 | 取现行目录
取目录列表 | 移动文件 | 执行FTP命令 |

参见： 基本数据类型


连接FTP服务器 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

连接到互联网上指定地址处的FTP服务器。成功返回真，失败返回假。

语法： 逻辑型 FTP 辅助对象．连接FTP服务器 （FTP服务器地址，用户名，密码，端口，［日志回调函数］，［超时］）

参数名 | 描 述
FTP服务器地址 | 必需的；文本型，初始值为“ftp://127.0.0.1/”。本参数指定FTP服务器在互联网上的地址。
用户名 | 必需的；文本型，初始值为“anonymous”。本参数提供用作通过FTP服务器用户验证的用户名称，如果被省略，默认值为匿名用户名“anonymous”。
密码 | 必需的；文本型，初始值为“”。本参数提供用作通过FTP服务器用户验证的密码，如果被省略，默认值为空文本。
端口 | 必需的；整数型，初始值为“21”。本参数提供欲连接到FTP服务器上的端口号，如果被省略，默认值为标准端口 21。
日志回调函数 | 可选的；子程序指针。注册一个回调函数，系统产生日志时会调用此函数通知用户,如果为0则不能接收日志。默认为0回调函数需要有4个参数，第一个参数（整数型），线程信息，可以通过”获得线程信息“获得每个上传或下载对象的线程信息，与本参数比较从而确定发送本消息的对象第二个参数（文本型），消息产生的时间。第三个参数（文本型），消息的正文。第四个参数（整数型），消息类型，参见”下载上传常量集合“。
超时 | 可选的；整数型。登陆过程中数据交互的超时时间,单位为毫秒，如果忽略则默认为2000。

例程：

说明：

通过“连接FTP服务器”命令与FTP服务器建立连接。


断开FTP服务器 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

断开通过“连接FTP服务器”命令建立的到互联网上FTP服务器的连接。

语法： 逻辑型 FTP 辅助对象．断开FTP服务器 （）

例程:

说明:

断开连接的FTP服务器。


删除文件 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

删除FTP服务器上的指定文件。成功返回真，失败返回假。

语法： 逻辑型 FTP 辅助对象．删除文件 （［欲删除的FTP文件］）

参数名 | 描 述
欲删除的FTP文件 | 可选的；文本型。本参数指定在FTP服务器上欲删除文件的路径。

例程:

说明:

删除FTP服务器的现行目录的指定的文件。


文件改名 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

更改FTP服务器上指定文件的名称。成功返回真，失败返回假。

语法： 逻辑型 FTP 辅助对象．文件改名 （［欲改名的FTP文件］，［新文件名称］）

参数名 | 描 述
欲改名的FTP文件 | 可选的；文本型。本参数指定FTP服务器上欲改名文件的路径。
新文件名称 | 可选的；文本型。本参数指定欲改为的文件名称。

例程:

说明:

为ftp服务器 现行目录的某文件重新制定名称。


创建目录 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

在FTP服务器上指定位置处创建新的目录。成功返回真，失败返回假。

语法： 逻辑型 FTP 辅助对象．创建目录 （［FTP目录路径］）

参数名 | 描 述
FTP目录路径 | 可选的；文本型。FTP目录路径。

例程:

说明:

通过“创建目录”命令创建新目录。


删除目录 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

删除FTP服务器上的指定目录。成功返回真，失败返回假。

语法： 逻辑型 FTP 辅助对象．删除目录 （［FTP目录路径］）

参数名 | 描 述
FTP目录路径 | 可选的；文本型。FTP目录路径。

例程:

说明:

删除FTP服务器上的目录。


置现行目录 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

设置FTP服务器上的当前目录，设置后可以在其他FTP命令中使用相对路径来指定文件。成功返回真，失败返回假。

语法： 逻辑型 FTP 辅助对象．置现行目录 （［FTP目录路径］）

参数名 | 描 述
FTP目录路径 | 可选的；文本型。FTP目录路径。

例程:

说明:

设置FTP的当前的工作的目录。


取现行目录 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

返回FTP服务器上的当前目录。成功返回目录路径，失败返回空文本。

语法： 文本型 FTP 辅助对象．取现行目录 （）

例程:

说明:

取得FTP的现工作的目录。


取目录列表 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

返回FTP服务器上指定目录内的所有匹配文件和子目录信息。成功返回被找到的文件和子目录的数目，失败返回 -1失败的原因有可能是FTP服务器的目录结构暂时不被支持。

语法： 整数型 FTP 辅助对象．取目录列表 （［FTP目录路径］，［存放文件名的数组变量］，［存放文件属性的数组变量］，［存放文件尺寸的数组变量］，［存放文件时间的数组变量］）

参数名 | 描 述
FTP目录路径 | 可选的；文本型。FTP目录路径。
存放文件名的数组变量 | 可选的；文本型，参数数据只能提供变量及变量数组。提供参数数据时只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件和子目录名称。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为所找到的文件数目。
存放文件属性的数组变量 | 可选的；整数型，参数数据只能提供变量及变量数组。当前不被支持,留做以后扩展。
存放文件尺寸的数组变量 | 可选的；长整数型，参数数据只能提供变量及变量数组。提供参数数据时只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件的尺寸，并与文件名数组成员一一对应。
存放文件时间的数组变量 | 可选的；日期时间型，参数数据只能提供变量及变量数组。提供参数数据时只能提供变量数组。在命令执行完毕后，本变量数组内被顺序填入所找到的匹配文件的最后修改时间，并与文件名数组成员一一对应。变量数组内原有数据被全部销毁，变量数组的维数被自动调整为所找到的文件数目。

例程:

说明:

通过“取目录列表”命令获取FTP当前目录下所有文件和文件夹的信息。


移动文件 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

移动文件或目录到新的位置。

语法： 逻辑型 FTP 辅助对象．移动文件 （旧文件路径，新文件路径）

参数名 | 描 述
旧文件路径 | 必需的；文本型。旧文件路径。
新文件路径 | 必需的；文本型。新文件路径。

例程:

说明:

通过“移动文件”命令将当前FTP目录中的指定文件移动到指定的目录中。


执行FTP命令 方法 操作系统支持：Windows、Linux 所属对象：FTP辅助对象

为高级用户提供，初级用户无需掌握；
执行一条FTP命令, 返回服务器返回的信息代码。如果执行失败返回0。 本命令只有通过“连接FTP服务器”命令连接到FTP服务器以后才能使用。

语法： 整数型 FTP 辅助对象．执行FTP命令 （FTP命令，［返回命令数据］）

参数名 | 描 述
FTP命令 | 必需的；文本型。欲执行的FTP命令。
返回命令数据 | 可选的；文本型，参数数据只能提供变量。执行FTP命令后服务器返回的命令文本，最大支持返回51200字节。

例程:

说明:

通过“执行FTP命令”可以向FTP发送自定义命令。本命令一般用于支持库命令扩展。


任务参数

任务参数 普通类型 操作系统支持：Windows、Linux 跳至：网络传送支持库

成员 | 描 述
类型 | 整数型；初始值为 1 。指定任务类型 可以为以下常量 #下载 #上传 #覆盖 #续传 #改名 #跳过 #被动选择。
文件地址 | 文本型；初始值为“”。本参数指定欲读取文件在互联网上的地址，即（URL）。
本地文件路径 | 文本型；初始值为“”。本参数指定被下载或待上传文件的本地保存位置，当作为下载文件保存路径使用时。如果没有给定文件名，那必须是一个以“\”结尾的文件路径。系统会根据“文件地址”指定的的文件名作为本地保存的文件名，系统会处理重定向情况。当收到“下载上传开始”消息后可以通过“取本地文件路径”获得包含文件名的文件路径。
用户名 | 文本型；初始值为“Anonymous”。需要身份验证时使用的用户名,当前只用做FTP登陆时使用。
用户密码 | 文本型；初始值为“123”。需要身份验证时使用的密码,当前只用做FTP登陆时使用。
默认线程数 | 整数型；初始值为 1 。任务启动时默认开启的线程数,默认为1。
下载速度 | 整数型；初始值为 0 。本参数用来限制一个任务的下载速度，如果为0则不做限制。默认为0。
连接超时 | 整数型；初始值为 2000 。连接服务器的超时时间，如果过了这个时间服务器还没有回应则返回，如果用户设置了重试次数，那么会进行指定次数的重试。本参数为毫秒，默认为2000。
发送超时 | 整数型；初始值为 2000 。发送数据的超时时间，如果用户设置了重试次数，那么会进行指定次数的重试。单位为毫秒，默认为2000。
接收超时 | 整数型；初始值为 2000 。接收数据的超时时间，如果用户设置了重试次数，那么会进行指定次数的重试。单位为毫秒，默认为2000。
线程等待超时 | 整数型；初始值为 100 。结束线程时等待的时间，单位为毫秒，默认为100。
接收大小 | 整数型；初始值为 20480 。每次接收数据的块大小，通过调节大小可以加快下载速度，但过大会导致意外错误，请根据实际情况调节。本值不能大于初始化库命令中设置的写入文件长度。单位为字节。默认为20480字节。
发送大小 | 整数型；初始值为 1024 。每次发送数据的块大小，通过调节大小可以加快上传速度，但过大会导致意外错误，请根据实际情况调节。单位为字节。默认为1024字节。
日志回调函数 | 子程序指针；注册一个回调函数，系统产生日志时会调用此函数通知用户,如果为0则不能接收日志。默认为0回调函数需要有5个参数，第一个参数（整数型），线程信息，可以通过”取线程信息“获得每个上传或下载对象的线程信息，与本参数比较从而确定发送本消息的对象。第二个参数（文本型），消息产生的时间。第三个参数（文本型），消息的正文。第四个参数（整数型），消息类型，参见”传送常量“第五个参数（整数型），对象信息，可以通过“取对象信息”获得下载或上传对象的信息与本参数比较，从而确定本消息属于哪个对象。
交互回调函数 | 子程序指针；注册一个回调函数，系统产生需要交互的消息时调用此函数，具体消息请参见传送常量中设置的消息常量。如果为0则不接收，默认为0。回调函数需要有5个参数，一个整数型的返回值。返回值根据消息类型的不同而不同，如果没有说明则返回值没有意义。参见具体的消息第一个参数（整数型）消息类型，参见“传送常量。”第二个参数（整数型），线程信息，可以通过”取线程信息“获得每个上传或下载对象的线程信息，与本参数比较从而确定发送本消息的对象第三个参数（整数型）根据消息类型的不同而不同，参见具体的消息第四个参数（整数型）根据消息类型的不同而不同，参见具体的消息第五个参数（整数型），对象信息，可以通过“取对象信息”获得下载或上传对象的信息与本参数比较，从而确定本消息属于哪个对象。
备用文件名 | 文本型；初始值为“”。当类型为“改名“时，本参数为上传时使用的新文件名，默认为空。
传送类型 | 整数型；初始值为 1 。FTP上传或下载时用来区分传送类型。1 为二进制，2 为文本 3 为根据“类型区分串”选择。
类型区分串 | 文本型；初始值为“.exe|.rar|.zip|.gif|.jpg|.mp3|.rm”。FTP上传或下载时用来区分传送类型的字符串。本字符串由多个通过“|”分割的扩展名组成，如果待下载或上传文件的扩展名被包含在本字符串那么上传的类型为二进制模式否则为ASCII码模式,最大长度为512个字节例如：“.exe|.rar|.zip”.遇到带有上述扩展名的文件则起用二进制模式传送注意：本参数只在“传送类型”为3时有效。
代理服务器 | 文本型；目前只支持HTTP GET方式的代理服务器, 格式为 IP地址:端口号 如: 192.168.0.1:80。
引用 | 文本型；用户可以根据实际情况填写，如果不填系统会自动填充。

参见： 基本数据类型


传送常量

传送常量 枚举常量集合类型 操作系统支持：Windows、Linux 跳至：网络传送支持库

本数据类型包括了下载及FTP上传对象用到的常量。

成员 | 描 述
下载 | 常量值为 4096 。下载文件与上传互斥。
上传 | 常量值为 8192 。上传文件与下载互斥。
覆盖 | 常量值为 1 。覆盖已存在的同名文件,如果选择本模式上传过程中如果遇到同名文件不向用户询问，直接按此模式所指示的方式处理，与，被动选择，续传，改名，跳过互斥。
续传 | 常量值为 2 。如果已存在的同名文件小于待上传文件则根据断点位置继续上传,如果选择本模式上传过程中如果遇到同名文件不向用户询问，直接按此模式所指示的方式处理，与被动选择，覆盖，改名，跳过互斥。
改名 | 常量值为 4 。发现已存在的同名文件时使用FTP备用文件名保存，如果选择本模式上传过程中如果遇到同名文件不向用户询问，直接按此模式所指示的方式处理，与被动选择，续传，覆盖，跳过互斥。
跳过 | 常量值为 8 。发现已存在的同名文件则跳过，不做任何操作.如果选择本模式上传过程中如果遇到同名文件不向用户询问，直接按此模式所指示的方式处理，与被动选择，续传，改名，覆盖互斥。
被动选择 | 常量值为 16 。当发现已存在的同名文件时系统将调用“交互回调函数”并发送“发现已存在文件消息”通知用户，用户可根据实际情况返回跳过，改名，覆盖，续传与跳过，续传，改名，覆盖互斥。
发现存在文件 | 常量值为 2 。只有FTP上传对象有效。当发现已存在的同名文件时系统发送本消息通知用户，回调函数的参数3为已存在文件的大小。回调函数的参数4未使用。注意:只有设置为“被动选择”时才会收到本消息。本消息有返回值,可以为以下常量 #跳过，#改名，#覆盖，#续传。
下载上传开始 | 常量值为 3 。开始下载或上传时发送本消息通知用户,回调函数的参数2为下载信息，可以通过”取下载信息“获得每个上传或下载对象的信息，与本参数比较从而确定发送本消息的对象,回调函数的参数3为待下载文件大小。如果是上传则表示待上传文件大小,回调函数的参数4未使用,开始下载或上传时发送本消息通知用户。
下载上传结束 | 常量值为 4 。下载,上传完毕或用户结束下载,上传.回调函数的参数2为下载信息，可以通过”取下载信息“获得每个上传或下载对象的信息，与本参数比较从而确定发送本消息的对象,回调函数的参数3为任务传送的总长度,回调函数的参数4未使用。上传,下载结束后系统进行结束处理后发送本消息通知用户。
新下载线程启动 | 常量值为 5 。执行“增加线程”系统进行相关处理后发送本消息通知用户。
下载线程继续下载 | 常量值为 7 。回调函数的参数3为本线程开始下载位置.回调函数的参数4为本线程结束下载位置。当下载线程完成指定下载任务后会查找是否有其它任务需要下载。比如，被中断的线程没有下载完毕的任务。如果发现存在这样的任务则发送本消息通知用户。
线程正常结束 | 常量值为 8 。回调函数的参数3为结束位置.回调函数的参数4未使用。线程正常结束后系统进行结束处理后发送本消息通知用户。
线程异常结束 | 常量值为 9 。回调函数的参数3为结束位置.回调函数的参数4未使用。线程异常结束后系统进行结束处理后发送本消息通知用户。
收到数据 | 常量值为 16 。回调函数的参数3为接收到数据的大小，此值正常情况下等于接收大小.回调函数的参数4未使用。线程接收到指定大小的数据后发送本消息通知用户。
发送数据 | 常量值为 17 。回调函数的参数3为发送数据的大小，此值正常情况下等于发送大小.回调函数的参数4未使用。线程发送指定大小的数据后发送本消息通知用户。
系统日志 | 常量值为 0 。系统日志。
错误日志 | 常量值为 3 。错误日志。
接收日志 | 常量值为 2 。从服务器接收到数据时发送本类型的日志消息通知用户。
发送日志 | 常量值为 1 。向服务器发送数据时发送本类型的日志消息通知用户。
下载数据范围 | 常量值为 6 。回调函数的参数3为本线程开始下载位置.回调函数的参数4为本线程结束下载位置。收到“新下载线程启动”消息后会收到本消息，本消息说明了新下载线程的下载范围注意：本消息是在与服务器交互完毕后，准备下载数据前产生的，本消息可以用来确定正式开始接收数据。
系统处理 | 常量值为 0 。系统自动改名，如已经存在同名文件“file.exe”，系统将改变待下载文件名为“file(1).exe,如果发现file(1).exe也存在则括号中的数字加1，即file(2).exe。最多支持99个。
结束下载 | 常量值为 1 。当收到“存在同名文件”时使用。用来结束下载线程。
设置新名 | 常量值为 2 。当收到“存在同名文件”时使用。如果返回本值，那么需要在回调函数返回前调用下载对象中的“设新文件名”。
存在同名文件 | 常量值为 18 。当下载对象创建本地文件时，发现已存在的同名文件时系统发送本消息通知用户，回调函数的参数3为已存在文件的大小。回调函数的参数4为待下载文件的大小。本消息有返回值,可以为以下常量 #系统处理，#结束下载，#设置新名。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。