数值计算支持库

数值计算支持库 帮助手册20080828版 返回支持库手册 返回首页

本支持库提供了常用的数值计算方法以及对大数的运算。

操作系统支持： Windows、Linux

其它数据类型：

复数运算 | 矩阵运算 | 傅立叶变换 | 微积分
概要统计 | 联立方程 | 曲线拟合 | 其他计算
大数 |  |  |

适用版本，数值计算支持库 （1.1#0版）


复数运算

复数运算 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型用来处理复数的运算。

方法：

复数相加 | 复数相减 | 复数相乘 | 复数相除
求复数指数 | 求复数长度 | 求复数极角 | 取实数
取虚数 | 置实数 | 置虚数 |

参见： 基本数据类型


复数相加 方法 操作系统支持：Windows、Linux 所属对象：复数运算

求两个复数之和。

语法： 复数运算 复数运算．复数相加 （复数数据1，复数数据2）

参数名 | 描 述
复数数据1 | 必需的；复数运算。该参数提供参与计算的复数数据1，例如：复数1 + 复数2算式，本参数提供复数1。
复数数据2 | 必需的；复数运算。该参数提供参与计算的复数数据2，例如：复数1 + 复数2算式，本参数提供复数2。

例程：

说明：

通过“复数运算”数据类型的“复数相加”命令将两个“复数运算”类型的变量中的数据相加。

参见：例程


复数相减 方法 操作系统支持：Windows、Linux 所属对象：复数运算

求两个复数之差。

语法： 复数运算 复数运算．复数相减 （复数数据1，复数数据2）

参数名 | 描 述
复数数据1 | 必需的；复数运算。该参数提供参与计算的复数数据1，例如：复数1 - 复数2算式，本参数提供复数1。
复数数据2 | 必需的；复数运算。该参数提供参与计算的复数数据2，例如：复数1 - 复数2算式，本参数提供复数2。

例程：

说明：

通过“复数运算”数据类型的命令“复数相减”命令将两个“复数运算”数据类型的变量相减。


复数相乘 方法 操作系统支持：Windows、Linux 所属对象：复数运算

求两个复数乘积。

语法： 复数运算 复数运算．复数相乘 （复数数据1，复数数据2）

参数名 | 描 述
复数数据1 | 必需的；复数运算。该参数提供参与计算的复数数据1，例如：复数1 x 复数2算式，本参数提供复数1。
复数数据2 | 必需的；复数运算。该参数提供参与计算的复数数据2，例如：复数1 x 复数2算式，本参数提供复数2。

例程：

说明：

通过“复数运算”数据类型的“复数相乘”命令将两个复数运算类型的变量相乘（复数1、复数2）。


复数相除 方法 操作系统支持：Windows、Linux 所属对象：复数运算

求两个复数的商。

语法： 复数运算 复数运算．复数相除 （复数数据1，复数数据2）

参数名 | 描 述
复数数据1 | 必需的；复数运算。该参数提供参与计算的复数数据1，例如：复数1 ÷ 复数2算式，本参数提供复数1。
复数数据2 | 必需的；复数运算。该参数提供参与计算的复数数据2，例如：复数1 ÷ 复数2算式，本参数提供复数2。

例程：

说明：

通过“复数运算”数据类型的“复数相除”方法，将两个复数取商。


求复数指数 方法 操作系统支持：Windows、Linux 所属对象：复数运算

计算以e为底，以复数为幂的值。

语法： 复数运算 复数运算．求复数指数 （复数数据）

参数名 | 描 述
复数数据 | 必需的；复数运算。该参数提供需要参与计算的复数数据。

例程:

说明：

通过“求复数指数”命令求复数运算数据类型的复数指数。


求复数长度 方法 操作系统支持：Windows、Linux 所属对象：复数运算

计算一个复数的长度。

语法： 双精度小数型 复数运算．求复数长度 （复数数据）

参数名 | 描 述
复数数据 | 必需的；复数运算。该参数提供需要参与计算的复数数据。

例程：

说明：

通过“求复数长度”命令获取一个复数的长度。


求复数极角 方法 操作系统支持：Windows、Linux 所属对象：复数运算

计算复数的极角。

语法： 双精度小数型 复数运算．求复数极角 （复数数据）

参数名 | 描 述
复数数据 | 必需的；复数运算。该参数提供需要参与计算的复数数据。

例程：

说明：

通过“求复数极角”命令获得复数的极角。


取实数 方法 操作系统支持：Windows、Linux 所属对象：复数运算

获取复数中的实数部分。

语法： 双精度小数型 复数运算．取实数 （）

例程：

说明：

通过“取实数”命令将一个复数运算数据类型的变量中实数部分的数据取出。


取虚数 方法 操作系统支持：Windows、Linux 所属对象：复数运算

获取复数中的虚数部分。

语法： 双精度小数型 复数运算．取虚数 （）

例程：

说明：

通过“取虚数”命令将复数运算数据类型变量中的虚数部分取出。


置实数 方法 操作系统支持：Windows、Linux 所属对象：复数运算

设置复数的实数部分。

语法： 逻辑型 复数运算．置实数 （要设置的数据）

参数名 | 描 述
要设置的数据 | 必需的；双精度小数型。要设置的数据，实数部分。

例程：

说明：

通过“置实数”命令设置复数运算类型变量的实数数据。


置虚数 方法 操作系统支持：Windows、Linux 所属对象：复数运算

设置复数的虚数部分。

语法： 逻辑型 复数运算．置虚数 （要设置的数据）

参数名 | 描 述
要设置的数据 | 必需的；双精度小数型。要设置的数据，虚数部分。

例程：

说明：

通过“置虚数”命令置复数运算类型变量的虚数数据。


矩阵运算

矩阵运算 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型用来处理常见的矩阵运算。

方法：

矩阵相乘 | 矩阵相加 | 实矩阵逆 | 矩阵转置
求矩阵特征 | 矩阵标量乘积 |  |

参见： 基本数据类型


矩阵相乘 方法 操作系统支持：Windows、Linux 所属对象：矩阵运算

计算两个矩阵的乘积，注意：必须保证矩阵1的列数等于矩阵2的行数，如果参数错误或者计算失败，本方法将返回一个1维宽度为1的数组。

语法： 双精度小数型数组 矩阵运算．矩阵相乘 （实数矩阵1，实数矩阵2）

参数名 | 描 述
实数矩阵1 | 必需的；双精度小数型，参数数据只能提供数组数据。参与运算的实数矩阵1。
实数矩阵2 | 必需的；双精度小数型，参数数据只能提供数组数据。参与运算的实数矩阵2。

例程：

说明：

通过“矩阵相乘”命令求两个矩阵的积。

注意：必须保证矩阵1的列数等于矩阵2的行数，如果参数错误或者计算失败，本方法将返回一个1维宽度为1的数组。


矩阵相加 方法 操作系统支持：Windows、Linux 所属对象：矩阵运算

求两个二维矩阵之和，两个矩阵的宽度和高度必须相等，如果参数错误或者计算失败，本方法将返回一个1维宽度为1的数组。

语法： 双精度小数型数组 矩阵运算．矩阵相加 （实数矩阵1，实数矩阵2）

参数名 | 描 述
实数矩阵1 | 必需的；双精度小数型，参数数据只能提供数组数据。参与运算的实数矩阵1。
实数矩阵2 | 必需的；双精度小数型，参数数据只能提供数组数据。参与运算的实数矩阵2。

例程：

说明：

通过“矩阵相加”命令求两个矩阵的和。

注意：两个矩阵的宽度和高度必须相等。


实矩阵逆 方法 操作系统支持：Windows、Linux 所属对象：矩阵运算

计算一个实矩阵的逆，如果参数错误或者计算失败，本方法将返回一个1维宽度为1的数组。

语法： 双精度小数型数组 矩阵运算．实矩阵逆 （实数矩阵，行列式）

参数名 | 描 述
实数矩阵 | 必需的；双精度小数型，参数数据只能提供数组数据。该实数矩阵必须是一个正方型矩阵。
行列式 | 必需的；双精度小数型，参数数据只能提供变量。返回矩阵的行列式。这是作为矩阵求逆函数的副产品被计算出来的。

例程：

说明：

通过“实矩阵逆”将一个实数矩阵求逆。


矩阵转置 方法 操作系统支持：Windows、Linux 所属对象：矩阵运算

计算矩阵的转置,如果参数错误或者计算失败，本方法将返回一个1维宽度为1的数组。

语法： 双精度小数型数组 矩阵运算．矩阵转置 （实数矩阵）

参数名 | 描 述
实数矩阵 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数提供将被转置的矩阵。

例程：

说明：

通过“矩阵转置”命令将一个矩阵转置。


求矩阵特征 方法 操作系统支持：Windows、Linux 所属对象：矩阵运算

用循环Jacobi算法计算一个实对称矩阵的特征值。

语法： 无返回值 矩阵运算．求矩阵特征 （实数矩阵，向量，返回实数矩阵，记数，收敛标志）

参数名 | 描 述
实数矩阵 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为一个正方形实数矩阵。
向量 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是一维数组，列数和第一个参数一样，返回第一个参数矩阵的特征值向量。
返回实数矩阵 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数数组是维数和行列数和第一个参数一样的矩阵，它的列是原始矩阵的eigenvectors。
记数 | 必需的；整数型，参数数据只能提供变量。包含完成迭代的最大迭代次数，它返回完成迭代的实际迭代次数。
收敛标志 | 必需的；逻辑型，参数数据只能提供变量。通过该参数判断是否收敛成功。

例程：

说明：

通过“求矩阵特征”获得矩阵特征。


矩阵标量乘积 方法 操作系统支持：Windows、Linux 所属对象：矩阵运算

计算矩阵和一个标量值的乘积,如果参数错误或者计算失败，本方法将返回一个1维宽度为1的数组。

语法： 双精度小数型数组 矩阵运算．矩阵标量乘积 （实数矩阵，标量操作数）

参数名 | 描 述
实数矩阵 | 必需的；双精度小数型，参数数据只能提供数组数据。提供一个二维数组。
标量操作数 | 必需的；双精度小数型。定义一个标量操作数。

例程：

说明：

通过“矩阵标量乘积”命令计算指定标量与矩阵的积。


傅立叶变换

傅立叶变换 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型用来计算傅立叶变换。

方法：

求傅立叶变换 | 求傅立叶反变换 | 窗口傅立叶 | 二维傅立叶变换
求能谱周期图 |  |  |

参见： 基本数据类型


求傅立叶变换 方法 操作系统支持：Windows、Linux 所属对象：傅立叶变换

采用快速Fourier变换技术(FFT)计算由N个等距样本组成的数据集的Fourier变换。特别说明：1.数据点的个数必须是2的幂，例如32,64,128......,最大为81922.为了保存内存，第一个参数和第二个参数用于输入和输出（记住：在内存中浮点数占4个字节，双精度数占8个字节，因此一个1024个元素的向量要求4K - 8K的字节!)。如果你想保存原始数据，则把他拷贝到另一个向量中。2.把调和转换成频率:为了确定一个波形的主要频率成分，通常需要在一个调和信号上运行FFT。为了从调和数据中计算频率，你需对原始数据集知道样本频率(或两个样本间的周期)。谐波频率可用下述公式计算：频率 = (谐波下标) / (nd_数据点个数 * 样本周期)。

语法： 逻辑型 傅立叶变换．求傅立叶变换 （数据集实值，数据集虚值，数据点数）

参数名 | 描 述
数据集实值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是维数为"数据点数"的向量。假设设本参数是xr[维数]数组，抽样数据集的实值包含从xr[1]起始的数组xr中。它返回数组xr中FFT调和函数的余弦系数 - 其中,xr[1]保存了DC分量,xr[2]保存了第一个谐波,xr[3]保存了谐波，依次类推。系数与采样数据集中数据点的个数有关。对每一调和项a(i) * cos(...)的实际余弦函数用numdat / 2 除。
数据集虚值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是维数为"数据点数"的向量，数据集的假设本参数是yi[维数]数组虚值包含从yi[1]起始的yi中。它返回yi中FFT调和函数的正弦系数 - 其中yi[2]保存第1个谐波，yi[3]保存了第2个谐波，依次类推。系数与采样数据集中数据点个数有关。对调和项a(i)sin(...)的实际正弦系数用numdat / 2 除。
数据点数 | 必需的；整数型。包含了在前两个参数中数据点的个数。

例程:

说明:

加入实数和虚数集，执行‘求傅立叶变换’。如果参数中有数组变量，数组成员数量不会自动增减，必须手动定义，如果定义数量有错误，将计算失败。

参见:例程


求傅立叶反变换 方法 操作系统支持：Windows、Linux 所属对象：傅立叶变换

采用快速Fourier变换技术(FFT)计算由N个等距调和函数组成的数据集的Fourier反变换。特别说明：1.数据点的个数(nd)必须是2的幂，例如32,64,128,......最大为8192。2.为了保存内存，本方法前两个参数xr和yi被用于输入和输出(记注:在内存中浮点数占4字节，双精度数占8字节，因此，一个1024个元素的向量要求4k-8k字节!)。如果你想保留原始数据，把他拷贝到另一个向量中。

语法： 逻辑型 傅立叶变换．求傅立叶反变换 （数据集实值，数据集虚值，数据点数）

参数名 | 描 述
数据集实值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是维数为"数据点数"的向量。假设设本参数是xr[维数]数组，抽样数据集的实值包含从xr[1]起始的数组xr中。它返回数组xr中FFT调和函数的余弦系数 - 其中,xr[1]保存了DC分量,xr[2]保存了第一个谐波,xr[3]保存了谐波，依次类推。系数与采样数据集中数据点的个数有关。对每一调和项a(i) * cos(...)的实际余弦函数用numdat / 2 除。
数据集虚值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是维数为"数据点数"的向量，数据集的假设本参数是yi[维数]数组虚值包含从yi[1]起始的yi中。它返回yi中FFT调和函数的正弦系数 - 其中yi[2]保存第1个谐波，yi[3]保存了第2个谐波，依次类推。系数与采样数据集中数据点个数有关。对调和项a(i)sin(...)的实际正弦系数用numdat / 2 除。
数据点数 | 必需的；整数型。包含了在前两个参数中数据点的个数。

例程:

说明:

求傅立叶反变换。如果参数中有数组变量，数组成员数量不会自动增减，必须手动定义，如果定义数量有错误，将计算失败。

参见:例程


窗口傅立叶 方法 操作系统支持：Windows、Linux 所属对象：傅立叶变换

在谐波分析中使用窗口来减少与光谱泄露有关的不必要的影响，光谱泄露是抽样波形中不连续的结果。因为波形是对一有限时间长度的抽样，因此在波形的端点会产生不连续性。窗口是用于初始数据的加权函数，以减少与有限次观察区间有关的光谱泄露。窗口通常是用一个函数在样本区间中乘以数据，该函数在其中心处为1，在两个端点处为0。特别说明：1.数据点的个数必须是2的幂，即32,64,128......,最大为8192。2.为了保存内存，前两个方法参数均被用于输入和输出(记注：在内存中浮点数占4字节，双精度数占8字节，因此一个1024个元素的向量要求4k~8K字节！)。如果您想保留原始数据，请把它拷贝到另一个向量中。

语法： 逻辑型 傅立叶变换．窗口傅立叶 （数据集实值，数据集虚值，数据点数，抽样数据窗口）

参数名 | 描 述
数据集实值 | 必需的；双精度小数型，参数数据只能提供数组数据。本参数是维数为"数据点数"的向量，设本参数为xr[维数]数组，它包含了从xr[1]处起始的在xr中抽样数据集的实值，并返回带有窗口的xr值。
数据集虚值 | 必需的；双精度小数型，参数数据只能提供数组数据。本参数是维数为"数据点数"的向量，设本参数为yi[维数]数组，它包含了从yi[1]处起始的在yi中的抽样数据集的虚值，并返回带有窗口的yi值。
数据点数 | 必需的；整数型。包含在前两个参数中的数据点个数。
抽样数据窗口 | 必需的；整数型。包含应用于抽样数据的窗口，为以下常量之一：0、#矩形Window；1、#Parzen Window2、#Hanning Window；3、#Welch Window；4、#Hamming Window；5、#Exact Blackman Window。

例程:

说明:

如果参数中有数组变量，数组成员数量不会自动增减，必须手动定义，如果定义数量有错误，将计算失败。

参见:例程


二维傅立叶变换 方法 操作系统支持：Windows、Linux 所属对象：傅立叶变换

采用快速Fourier变换技术(FFT)计算由C x R个等距样本组成的数据集的二维Fourier变换。特别说明：1.行和列(c和r)必须是2的幂，例如2,4,8......128。2.为了保存内存，两个参数数组均被用于输入和输出(记住：在内存中浮点数占4字节，双精度数占8字节，因此，一个有1024个元素的向量要求4K~8K字节!)。如果你想要保留原始数据，把它拷贝到另一个变量中。3.二维FFT占用很多内存。

语法： 逻辑型 傅立叶变换．二维傅立叶变换 （数据集实值，数据集虚值，标志）

参数名 | 描 述
数据集实值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为二维数组，它包含了从数组起始数据中的抽样数据的实值，并返回FFT调和函数的余弦系数。
数据集虚值 | 必需的；双精度小数型，参数数据只能提供数组数据。维数和行列数和前一个参数一样的数组，它包含了从数组起始到本数组中的抽样数据的虚值，并返回FFT调和系数的正弦余数。
标志 | 必需的；逻辑型。"真"表示反变换，"假"表示正变换。

例程:

说明:

如果参数中有数组变量，数组成员数量不会自动增减，必须手动定义，如果定义数量有错误，将计算失败。

参见:例程


求能谱周期图 方法 操作系统支持：Windows、Linux 所属对象：傅立叶变换

计算抽样数据集的能谱周期图。返回每个频率箱的能谱密度，以及每个频率箱的精确频率(以Hz为单位)。特别说明：1.数据点的个数必须是2的幂，例如：32,64,128......,最大为8192。2.为保存内存。两个数组参数均被用于输入和输出。如果你想保留原始数据，则应把它拷贝到另一个变量中。

语法： 逻辑型 傅立叶变换．求能谱周期图 （数据集实值，数据集虚值，时间间隔）

参数名 | 描 述
数据集实值 | 必需的；双精度小数型，参数数据只能提供数组数据。一维数组向量，假设本参数为xr[维数]数组，它包含xr中从xr[1]处起始的抽样数据的实值，并返回原始数据(从xr[1]到xr[numdat/2] - 1的有效数据)的能谱。
数据集虚值 | 必需的；双精度小数型，参数数据只能提供数组数据。维数和大小和前一个参数一样的数组，假设该参数为yi[维数]，它包含从yi中从yi[0]起始的抽样数据的虚值，并返回能谱调和函数(从yi[1]到yi[numdat/2] - 1的有效数据)的频率值。
时间间隔 | 必需的；双精度小数型。包含了前两个参数数据集中样本之间的时间间隔。

例程：

说明：

如果参数中有数组变量，数组成员数量不会自动增减，必须手动定义，如果定义数量有错误，将计算失败。


微积分

微积分 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型用来处理常见的微积分计算。

方法：

离散化数值积分 函数数值积分 一阶微分方程

参见： 基本数据类型


离散化数值积分 方法 操作系统支持：Windows、Linux 所属对象：微积分

计算一个离散化的抽样数据集的数值积分(即通常曲线下的面积)。采用的算法是Simpson 1/3法则和Simpson 3/8法则，与其他方法不同，这个方法可以同时处理偶数次和奇数次观察的数据集。

语法： 双精度小数型 微积分．离散化数值积分 （浮点向量，样本区间，积分下限，积分上限）

参数名 | 描 述
浮点向量 | 必需的；双精度小数型，参数数据只能提供数组数据。一维数组，它保存离散样本集。
样本区间 | 必需的；双精度小数型。定义采样数据集之间的样本区间。
积分下限 | 必需的；整数型。积分的下限，本参数为大于等于0且小于等于"浮点向量"参数数组下标数减1的整数，"积分下限"必须小于"积分上限"。
积分上限 | 必需的；整数型。积分的上限，本参数为大于等于0且小于等于"浮点向量"参数数组下标数减1的整数，"积分下限"必须小于"积分上限"。

例程:

说明:

如果参数中有数组变量，数组成员数量不会自动增减，必须手动定义，如果定义数量有错误，将计算失败。

参见:例程


函数数值积分 方法 操作系统支持：Windows、Linux 所属对象：微积分

计算一个所指定的函数的数值积分(即通常曲线下的面积)。采用的算法是Simpson 1/3法则和Simpson 3/8 法则。

语法： 双精度小数型 微积分．函数数值积分 （样本区间，积分下限，积分上限）

参数名 | 描 述
样本区间 | 必需的；整数型。数据集的样本区间。
积分下限 | 必需的；整数型。积分下限。
积分上限 | 必需的；整数型。积分上限。

例程:

说明:

根据提供数据求得函数曲线下的面积。

参见:例程


一阶微分方程 方法 操作系统支持：Windows、Linux 所属对象：微积分

求解形式如下的一阶微分方程y' = f(x,y)。

语法： 逻辑型 微积分．一阶微分方程 （x已知值，y已知值，要求解的x，容许误差，初始步长，最小步长，y的估值，状态）

参数名 | 描 述
x已知值 | 必需的；双精度小数型。包含x的已知值。
y已知值 | 必需的；双精度小数型。包含y的已知值。
要求解的x | 必需的；双精度小数型。包含要求解的x的值。
容许误差 | 必需的；双精度小数型。保存容许误差(若误差估计<(et * h) / 32，则步长(后一个参数)在函数中使用时加倍，若误差估计>(本参数 * 步长)时，则步长减半。
初始步长 | 必需的；双精度小数型。包含用从已知x值迭代到x的初始步长。
最小步长 | 必需的；双精度小数型。包含最小步长(若步长<本参数，则函数退出。
y的估值 | 必需的；双精度小数型，参数数据只能提供变量。返回y的估值。
状态 | 必需的；逻辑型，参数数据只能提供变量。若x值已被求解，则返回"真"；若在解出步长前已小于最小步长，则返回"假"。

例程:

说明:

Y估值为返回值。

参见:例程


概要统计

概要统计 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型用来计算常见的数据概要统计。

方法：

统计数据概要

参见： 基本数据类型


统计数据概要 方法 操作系统支持：Windows、Linux 所属对象：概要统计

对数据集的每一列计算概要统计 - 最大值、最小值、范围、总和、平均值、方差、标准偏差、众数和平均值的标准误差。

语法： 逻辑型 概要统计．统计数据概要 （原数据，最小值，最大值，范围值，总和，平均值，方差值，标准偏差值，标准误差，众数值）

参数名 | 描 述
原数据 | 必需的；双精度小数型，参数数据只能提供数组数据。必须是二维数组。
最小值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的最小值。
最大值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的最大值。
范围值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的最大值和最小值的差。
总和 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的和。
平均值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的平均值。
方差值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的方差值。
标准偏差值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的标准偏差值。
标准误差 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据平均值的标准误差。
众数值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为宽度和"原数据"高度一样的一维数组，它返回"原数据"中每一列数据的众数值。

例程：

说明

对数据集进行统计计算，如下图：所有的数组成员数不能自动扩充，必须通过手动定义，如果成员数定义错误，计算将会失败。

参考：例程1


联立方程

联立方程 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型用来求解联立方程。

方法：

线性方程组

参见： 基本数据类型


线性方程组 方法 操作系统支持：Windows、Linux 所属对象：联立方程

本函数采用Gauss - Jordan方法求解实型线性方程组。

语法： 逻辑型 联立方程．线性方程组 （x变量系数，y向量，x变量解，x变量系数逆阵，x矩阵行列式）

参数名 | 描 述
x变量系数 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是一个二维正方形数组，数组宽度和高度相等，宽度和高度必须小于等于50，它保存x变量系数的方阵，该参数数组的数据必须提供全部不为0的数值，否则本方法将失败。
y向量 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是列数和前一个参数一样的一维数组。
x变量解 | 必需的；双精度小数型，参数数据只能提供数组数据。列数和第一个参数一样的一维数组。
x变量系数逆阵 | 必需的；双精度小数型，参数数据只能提供数组数据。和第一个参数行列数一样的二维数组，它保存x变量系数矩阵的逆阵。
x矩阵行列式 | 必需的；双精度小数型，参数数据只能提供变量。返回x变量系数矩阵的行列式。

例程：

说明：

求线性方程组的值，如下图：数组变量不能自动扩充，必须手动定义，如果定义数量有错误，将计算失败。

参考：例程1


曲线拟合

曲线拟合 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型提供方法计算曲线拟合。

方法：

二乘曲线拟合 三次多项式方程 三次样条插值

参见： 基本数据类型


二乘曲线拟合 方法 操作系统支持：Windows、Linux 所属对象：曲线拟合

本函数是一个广义最小二乘曲线拟合函数，它对一个相关或不相关变量数据集用线性系数拟合一个多项式。

语法： 逻辑型 曲线拟合．二乘曲线拟合 （独立变量观察值，相关变量观察值，多项式系数，y估值，残差值，标准误差，估计标准误差，r平方值，r值，是否奇异）

参数名 | 描 述
独立变量观察值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是一个一维数组，保存独立变量的观察值。
相关变量观察值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为列数和第一个参数一样的一维数组，它保存相关变量的观察值。
多项式系数 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是列数小于第一个参数的一维数组，它保存拟合多项式的系数，数组第1个成员保存常数，数组第2个成员保存x ^ 1的系数，数组第3个成员保存x ^ 2的系数，依此类推。
y估值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为列数和第一个参数一样的一维数组，它返回用多项式系数计算的y的估值。
残差值 | 必需的；双精度小数型，参数数据只能提供数组数据。返回估计的标准误差。
标准误差 | 必需的；双精度小数型，参数数据只能提供变量。返回估计的标准误差。
估计标准误差 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为列数为和"多项式系数"一样的一维数组，它返回系数估计的标准误差。
r平方值 | 必需的；双精度小数型，参数数据只能提供变量。返回r平方值 - 样本确定系数。
r值 | 必需的；双精度小数型，参数数据只能提供变量。返回r值 - 样本相关系数。
是否奇异 | 必需的；整数型，参数数据只能提供变量。如果曲线拟合矩阵奇异则返回1。

例程：

说明：

求二乘曲线的值，如上面第一个图：数组变量不能自动扩充，必须手动定义，如果定义数量有错误，将计算失败。

参考：例程1


三次多项式方程 方法 操作系统支持：Windows、Linux 所属对象：曲线拟合

本函数对离散数据集拟合一系列三次多项式方程。通过把原始数据点区间上的三次方程应用于插值中要使用的x值，在那个区间上的y值可能被插值。在每个子区间上(sv[i],sv[i+1])，三次样条形如：y的估值 = a[i] + b[i] * (x - xv[i]) + c[i] * (x - sv[i]) ^ 2 + d[i] * (s - sv[i]) ^ 3。

语法： 逻辑型 曲线拟合．三次多项式方程 （x值，y值，3次样条方程系数）

参数名 | 描 述
x值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是一个一维数组，它保存离散数据的x值。
y值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是列数和第一个参数一样的一维数组，它保存离散数据集的y值。
3次样条方程系数 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是列数和第一个参数一样，行数为4的二维数组，它返回每个子区间上三次样条方程的系数。

例程：

说明：

求三次多项式方程的值，如图：数组变量不能自动扩充，必须手动定义，如果定义数量有错误，将计算失败。

参考：例程1


三次样条插值 方法 操作系统支持：Windows、Linux 所属对象：曲线拟合

该函数计算给定一个x值和由"三次多项式方程"计算的三次样条系数矩阵，y值的三次样条插值。

语法： 逻辑型 曲线拟合．三次样条插值 （x值，3次样条方程系数，插值x，y值）

参数名 | 描 述
x值 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数为一维数组，它保存离散数据集的x值。用来确定在计算过程中使用哪个样条区间。
3次样条方程系数 | 必需的；双精度小数型，参数数据只能提供数组数据。该参数是列数和第一个参数一样，行数为4的二维数组。它保存每个子区间的三次样条方程的系数。
插值x | 必需的；双精度小数型。包含在插值中使用的x值。
y值 | 必需的；双精度小数型，参数数据只能提供变量。被计算的y值。

例程:

说明:

求三次样条插值，如图：数组变量不能自动扩充，必须手动定义，如果定义数量有错误，将计算失败。

参考：例程1


其他计算

其他计算 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型提供一些常用的数值、科学计算函数。

方法：

求正切 | 求双曲余弦 | 求双曲正弦 | 求双曲正割
反正切 | 求伽玛 | 求伽玛对数 | 求不完全伽玛
求不完全伽玛2 | 求贝它 | 求不完全贝它 | 求贝塞尔
求修正贝塞尔 | 求修正贝塞尔R | 求高斯误差 | 求误差余
求误差实部 | 求误差虚部 | 求厄密多项式 | 求勒让德方程系数
求拉格尔 | 求雅各比方程 | 求车切多项式 |

参见： 基本数据类型


求正切 方法 操作系统支持：Windows、Linux 所属对象：其他计算

返回指定角的正切值。

语法： 双精度小数型 其他计算．求正切 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。提供欲进行计算的角。

例程：

说明：

求指定角度的正切值。


求双曲余弦 方法 操作系统支持：Windows、Linux 所属对象：其他计算

返回指定角的双曲余弦。

语法： 双精度小数型 其他计算．求双曲余弦 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。提供欲进行计算的角。

例程：

说明：

求指定角度的双曲线余弦。


求双曲正弦 方法 操作系统支持：Windows、Linux 所属对象：其他计算

返回指定角的双曲正弦值。

语法： 双精度小数型 其他计算．求双曲正弦 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。提供欲进行计算的角。

例程：

说明：

求指定角度的双曲正弦。


求双曲正割 方法 操作系统支持：Windows、Linux 所属对象：其他计算

返回指定角的双曲正割值。

语法： 双精度小数型 其他计算．求双曲正割 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。提供欲进行计算的角。

例程：

说明：

返回指定角的双曲正割值。


反正切 方法 操作系统支持：Windows、Linux 所属对象：其他计算

返回指定数的反正切值。

语法： 双精度小数型 其他计算．反正切 （欲进行计算的角）

参数名 | 描 述
欲进行计算的角 | 必需的；双精度小数型。提供欲进行计算的角。

例程：

说明：

返回指定数的反正切值。


求伽玛 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求指定数的伽玛函数。

语法： 双精度小数型 其他计算．求伽玛 （欲求Gamma的值，错误码）

参数名 | 描 述
欲求Gamma的值 | 必需的；双精度小数型。欲求Gamma的值。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求指定数的伽玛函数。


求伽玛对数 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求指定数的伽玛函数的对数。

语法： 双精度小数型 其他计算．求伽玛对数 （欲求Gamma的值）

参数名 | 描 述
欲求Gamma的值 | 必需的；双精度小数型。欲求Gamma的值。

例程：

说明：

求指定数的伽玛函数的对数。


求不完全伽玛 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求指定数的不完全伽玛函数，本函数是定义在所有大于0的实数上的。

语法： 双精度小数型 其他计算．求不完全伽玛 （a，x）

参数名 | 描 述
a | 必需的；双精度小数型。欲求Gamma值的a。
x | 必需的；双精度小数型。欲求Gamma值的x。

例程：

说明：

求指定数的不完全伽玛函数，A＞0, X＞0


求不完全伽玛2 方法 操作系统支持：Windows、Linux 所属对象：其他计算

本函数是定义在所有大于0的实数上的。

语法： 双精度小数型 其他计算．求不完全伽玛2 （a，x）

参数名 | 描 述
a | 必需的；双精度小数型。欲求Gamma值的a。
x | 必需的；双精度小数型。欲求Gamma值的x。

例程：

说明：

A＞0 X＞0


求贝它 方法 操作系统支持：Windows、Linux 所属对象：其他计算

根据指定参数求贝它。

语法： 双精度小数型 其他计算．求贝它 （x，y，错误码）

参数名 | 描 述
x | 必需的；双精度小数型。必须是大于0的参数。
y | 必需的；双精度小数型。必须是大于0的参数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

根据指定参数求贝它。


求不完全贝它 方法 操作系统支持：Windows、Linux 所属对象：其他计算

根据指定参数求贝它。

语法： 双精度小数型 其他计算．求不完全贝它 （a，b，x）

参数名 | 描 述
a | 必需的；双精度小数型。大于0的参数。
b | 必需的；双精度小数型。大于0的参数。
x | 必需的；双精度小数型。任意一个浮点数。

例程：

说明：

根据指定参数求贝它。


求贝塞尔 方法 操作系统支持：Windows、Linux 所属对象：其他计算

通过指定参数求贝塞尔。

语法： 双精度小数型 其他计算．求贝塞尔 （v，x，错误码）

参数名 | 描 述
v | 必需的；双精度小数型。该参数表示次数，必须>= 0。
x | 必需的；双精度小数型。该参数必须>0或者<0
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

通过指定参数求贝塞尔。


求修正贝塞尔 方法 操作系统支持：Windows、Linux 所属对象：其他计算

通过指定参数求修正过的贝塞尔值。

语法： 双精度小数型 其他计算．求修正贝塞尔 （n，y，错误码）

参数名 | 描 述
n | 必需的；双精度小数型。该参数指定多项式的阶，必须>= 0。
y | 必需的；双精度小数型。该参数提供任意浮点数
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

通过指定参数求修正过的贝塞尔值。


求修正贝塞尔R 方法 操作系统支持：Windows、Linux 所属对象：其他计算

通过指定参数求修正过的贝塞尔值。

语法： 双精度小数型 其他计算．求修正贝塞尔R （n，y，错误码）

参数名 | 描 述
n | 必需的；双精度小数型。该参数指定多项式的阶，必须>=0
y | 必需的；双精度小数型。任一浮点值。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

通过指定参数求修正过的贝塞尔值。


求高斯误差 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求指定参数的高斯误差值。

语法： 双精度小数型 其他计算．求高斯误差 （x，错误码）

参数名 | 描 述
x | 必需的；双精度小数型。该参数提供任意不等于0的数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求指定参数的高斯误差值。


求误差余 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求解误差函数的余函数。

语法： 双精度小数型 其他计算．求误差余 （x，错误码）

参数名 | 描 述
x | 必需的；双精度小数型。该参数提供任意一个不等于0的数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求解误差函数的余函数。


求误差实部 方法 操作系统支持：Windows、Linux 所属对象：其他计算

计算误差函数Z = x + iy 的实部。

语法： 双精度小数型 其他计算．求误差实部 （x，y，错误码）

参数名 | 描 述
x | 必需的；双精度小数型。保存复数的实部。
y | 必需的；双精度小数型。保存复数的虚部。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

计算误差函数Z = x + iy 的实部。


求误差虚部 方法 操作系统支持：Windows、Linux 所属对象：其他计算

计算误差函数Z = x + iy的虚部。

语法： 双精度小数型 其他计算．求误差虚部 （x，y）

参数名 | 描 述
x | 必需的；双精度小数型。保存复数的实部。
y | 必需的；双精度小数型。保存复数的虚部。

例程：

说明：

计算误差函数Z = x + iy的虚部。


求厄密多项式 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求解Hermite方程中多项式的第n个根。

语法： 双精度小数型 其他计算．求厄密多项式 （n，x，错误码）

参数名 | 描 述
n | 必需的；整数型。该参数指定多项式次数的整数，必须>=0。
x | 必需的；双精度小数型。保存任意数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求解Hermite方程中多项式的第n个根。


求勒让德方程系数 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求Gauss Legendre方程系数。

语法： 双精度小数型 其他计算．求勒让德方程系数 （n，x，错误码）

参数名 | 描 述
n | 必需的；整数型。指定多项式次数的整数，必须>=0。
x | 必需的；双精度小数型。保存任一数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求Gauss Legendre方程系数。


求拉格尔 方法 操作系统支持：Windows、Linux 所属对象：其他计算

本函数是在下列方程中寻找多项式第n个根的向前方法:Ln(a)(x) = xy'' + (a + 1 - x)y' + ny = 0。

语法： 双精度小数型 其他计算．求拉格尔 （n，a，x，错误码）

参数名 | 描 述
n | 必需的；整数型。该参数是指定多项式次数的一个整数。
a | 必需的；双精度小数型。任一大于-1的数。
x | 必需的；双精度小数型。任意浮点数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

本函数是在下列方程中寻找多项式第n个根的向前方法:Ln(a)(x) = xy'' + (a + 1 - x)y' + ny = 0。


求雅各比方程 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求解雅各比方程。由于雅各比方程中包含特殊符号，因此方程原型无法在此显示，对此表示抱歉。

语法： 双精度小数型 其他计算．求雅各比方程 （n，a，b，x，错误码）

参数名 | 描 述
n | 必需的；整数型。本参数为指定多项式的次数的整数。
a | 必需的；双精度小数型。本参数为任一大于-1的数。
b | 必需的；双精度小数型。本参数为任一大于-1的数。
x | 必需的；双精度小数型。本参数为任一浮点参数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求解雅各比方程。


求车切多项式 方法 操作系统支持：Windows、Linux 所属对象：其他计算

求解n阶的Tchebychev的多项式: Tn(x) = (1 - x ^ 2)y' - xy + n ^ 2 * y = 0。

语法： 双精度小数型 其他计算．求车切多项式 （n，x，错误码）

参数名 | 描 述
n | 必需的；整数型。指定多项式阶的整数。
x | 必需的；双精度小数型。任一数。
错误码 | 必需的；整数型，参数数据只能提供变量。可为以下常量之一：0、#无错误；1、#参数必须是一个不为0的数字；2、#参数不能为负数；3、#多项式序号必须大于0；4、#参数必须大于-1。

例程：

说明：

求解n阶的Tchebychev的多项式: Tn(x) = (1 - x ^ 2)y' - xy + n ^ 2 * y = 0。


大数

大数 普通类型 操作系统支持：Windows、Linux 跳至：数值计算支持库

本类型提供对无限精度大数运算的支持。

方法：

销毁 | 导入文本文件 | 导出文本文件 | 导入文本
导出文本 | 导入数字 | 取类型 | 取长度
取整数长度 | 取小数长度 | 取字符 | 导出字节
导出短整数 | 导出整数 | 导出长整数 | 复制到
取符号 | 是否有小数 | 是否为零 | 等于
大于 | 小于 | 大于等于 | 小于等于
取整数 | 取小数 | 加 | 减
乘 | 除 | 整除 | 求余
取绝对值 | 负 | 四舍五入 | 清除小数
清除整数 | 清除尾导零 | 求正弦 | 求余弦
求正切 | 求余切 |  |

参见： 基本数据类型


销毁 方法 操作系统支持：Windows、Linux 所属对象：大数

删除本对象已存在的数据，使用本方法后，本对象的数据将被变成整数"0"。

语法： 逻辑型 大数．销毁 （）

例程:

说明：

通过“销毁”命令清空大数型变量中的数据。


导入文本文件 方法 操作系统支持：Windows、Linux 所属对象：大数

导入存储数字的文本文件，该文本文件必须仅为存储数字的格式，否则本方法将失败，并返回假，本方法成功返回真，本对象以前存储的数据将被舍弃。

语法： 逻辑型 大数．导入文本文件 （文本文件名，忽略非法字符）

参数名 | 描 述
文本文件名 | 必需的；文本型。以数字为内容的文本文件名，例如："c:\1.txt"。
忽略非法字符 | 必需的；逻辑型，初始值为“真”。如果本参数为真，那么无论文本文件中有多少个非法字符都将被忽略；如果本参数为假，只要文本文件中有非法字符，本方法将失败，并返回假。合法字符包括'0' ~ '9'的数字和'.'号和'-'号，除此之外都为非法字符。注意，以下情况不论本参数是否为真都将视为非法字符，并导致本方法失败：'.'号和'-'号在文本中出现一次以上，并且出现在非法的字符位上，例如以下文本都是非法的：0.0.1；-3212.-33；421...00；000.3123；-00.33。

例程：

说明：

通过“导入文本文件”命令将一个包含数值的文件导入到“大数”数据类型的变量中。


导出文本文件 方法 操作系统支持：Windows、Linux 所属对象：大数

导出本对象当前所存储的数字到文本文件，成功返回真，失败返回假。

语法： 逻辑型 大数．导出文本文件 （文本文件名，覆盖现有）

参数名 | 描 述
文本文件名 | 必需的；文本型。要将数据导出的目的文本文件名，例如："c:\1.txt"。
覆盖现有 | 必需的；逻辑型，初始值为“真”。本参数指明是否覆盖已存在的文件。

例程：

说明：

通过“导出文本文件”命令将“大数”数据类型变量中的数据保存到文件。


导入文本 方法 操作系统支持：Windows、Linux 所属对象：大数

导入存储数字的文本型的数据为本对象的当前数据，该文本型必须为存储合法数字格式的文本，该数字可以是任何长度和精度，本对象以前存储的数据将被舍弃，成功返回真，失败返回假。

语法： 逻辑型 大数．导入文本 （数字文本）

参数名 | 描 述
数字文本 | 必需的；文本型。合法的文本格式的数字数据，可以是任意精度，该数字将被转换成本数据类型特有的数字储存格式，并参与计算。

例程：

说明：

通过“导入文本”命令将文本型数据导入“大数”数据类型的变量中。


导出文本 方法 操作系统支持：Windows、Linux 所属对象：大数

以文本型的格式导出当前本对象所存储的数字数据。

语法： 文本型 大数．导出文本 （）

例程：

说明：

通过“导出文本”命令将“大数”数据类型变量中的数据以文本型输出。


导入数字 方法 操作系统支持：Windows、Linux 所属对象：大数

导入当前易语言支持的所有格式的数字为当前数据类型的数据，以前的数据将被舍弃，成功返回真，失败返回假，注意：如果您导入的数据是小数有可能产生误差。

语法： 逻辑型 大数．导入数字 （数字）

参数名 | 描 述
数字 | 必需的；通用型。该参数可以是易语言兼容的所有数字格式数据，例如:字节型，短整数型，整数型，长整数型，小数型，双精度小数型。

例程：

说明：

通过“导入数字”命令将数值型数据导入“大数”类型变量中。


取类型 方法 操作系统支持：Windows、Linux 所属对象：大数

计算并获取当前本对象所对应易语言的基础数据类型，便于导出数据到易语言基础数字数据类型，返回值为以下常量值之一：0、#非任何类型；1、#字节型；2、#短整数型；3、#整数型；4、#长整数型；5、#小数型；6、#双精度小数型。

语法： 整数型 大数．取类型 （）

例程：

说明：

通过“取类型”命令判断“大数”类型变量中的数据所能转换为易语言中基本数据类型的哪一种。


取长度 方法 操作系统支持：Windows、Linux 所属对象：大数

计算并获取本对象如果转换为文本型数据时，字符的长度。

语法： 整数型 大数．取长度 （）

例程：

说明：

通过“取长度”命令获取“大数”数据类型变量中数据的长度。这里的长度包含负号和小数点。


取整数长度 方法 操作系统支持：Windows、Linux 所属对象：大数

计算并获取本对象如果转换为文本型数据时，整数部分字符的长度。

语法： 整数型 大数．取整数长度 （）

例程：

说明：

通过“取整数长度”命令获取“大数”数据类型变量中数据的整数部分长度。这个长度不包含负号和小数点。


取小数长度 方法 操作系统支持：Windows、Linux 所属对象：大数

计算并获取本对象如果转换为文本型数据时，小数部分字符的长度，注意：尾端0将被忽略。

语法： 整数型 大数．取小数长度 （）

例程：

说明：

通过“取小数长度”命令获取“大数”数据类型变量中小数的长度。这个长度不包含小数点。


取字符 方法 操作系统支持：Windows、Linux 所属对象：大数

获取本对象所表示的数字文本在任意位置的数字字符，指定的序号参数必须大于等于1且小于等于字符串长度。

语法： 字节型 大数．取字符 （字符位置序号）

参数名 | 描 述
字符位置序号 | 必需的；整数型。要获取的字符在整个数字文本中的位置，序号从"1"开始。如果本参数指定的序号在数字文本中不存在，那么本方法将出错。

例程：

说明：

通过“取字符”命令获取“大数”数据类型变量中指定位置的数据的ASCII码值。


导出字节 方法 操作系统支持：Windows、Linux 所属对象：大数

导出本对象到字节数据，注意：本对象当前所存储的数据必须是吻合字节型的数据。

语法： 字节型 大数．导出字节 （）

例程：

说明：

通过“导出字节”命令将“大数”数据类型变量中的数据以字节型导出。


导出短整数 方法 操作系统支持：Windows、Linux 所属对象：大数

导出本对象到短整型数据，注意：本对象当前所存储的数据必须是吻合短整型的数据。

语法： 短整数型 大数．导出短整数 （）

例程：

说明：

通过“导出短整数”命令将“大数”数据类型变量中数据以短整数类型导出。


导出整数 方法 操作系统支持：Windows、Linux 所属对象：大数

导出本对象到整数型数据，注意：本对象当前所存储的数据必须是吻合整数型的数据。

语法： 整数型 大数．导出整数 （）

例程：

说明：

通过“导出整数”命令将“大数”数据类型变量中的数据以整数型导出。


导出长整数 方法 操作系统支持：Windows、Linux 所属对象：大数

导出本对象到长整型数据，注意：本对象当前所存储的数据必须是吻合长整型的数据。

语法： 长整数型 大数．导出长整数 （）

例程：

说明：

通过“导出长整数”命令将“大数”数据类型变量中的数据以长整数类型导出。


复制到 方法 操作系统支持：Windows、Linux 所属对象：大数

复制当前数据到另一个目标存储大数的对象中，目标大数以前所存储的数据将被舍弃。

语法： 逻辑型 大数．复制到 （目标大数）

参数名 | 描 述
目标大数 | 必需的；大数。要复制到的目标大数。

例程：

说明：

通过“复制到”命令将一个“大数”数据类型的变量中的数据复制到另一个“大数”数据类型的变量中。


取符号 方法 操作系统支持：Windows、Linux 所属对象：大数

获取本对象所表示的符号，如果本对象表示正数或0，返回真，如果表示负数，则返回假。

语法： 逻辑型 大数．取符号 （）

例程：

说明：

通过“取符号”命令判断“大数”数据类型变量中所保存的数据是正还是负。


是否有小数 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象是否有存储小数，有则返回真，否则返回假。

语法： 逻辑型 大数．是否有小数 （）

例程：

说明：

通过“是否有小数”命令判断“大数”数据类型变量中所保存的数据中是否有小数。


是否为零 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象当前所存储的数据是否为"0"，如果为"0"，则返回真；否则，返回假。

语法： 逻辑型 大数．是否为零 （）

例程：

说明：

通过“是否为零”命令判断“大数”数据类型变量中所保存的数据是否等于零。


等于 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象和指定对象是否相等。如相等，则返回真；否则，返回假。

语法： 逻辑型 大数．等于 （比较数据）

参数名 | 描 述
比较数据 | 必需的；大数。本参数提供待和本大数数据比较的大数。

例程：

说明：

通过“等于”命令判断“大数”数据类型变量中所保存的数据是否等于另一个“大数”数据类型中的数据。


大于 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象是否大于指定对象。如大于，则返回真；否则，返回假。

语法： 逻辑型 大数．大于 （比较数据）

参数名 | 描 述
比较数据 | 必需的；大数。本参数提供待和本大数数据比较的大数。

例程：

说明：

通过“大于”命令判断“大数”数据类型变量是否大于另一个“大数”数据类型变量中的数据。


小于 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象是否小于指定对象。如小于，则返回真；否则，返回假。

语法： 逻辑型 大数．小于 （比较数据）

参数名 | 描 述
比较数据 | 必需的；大数。本参数提供待和本大数数据比较的大数。

例程：

说明：

通过“小于”命令判断一个“大数”类型变量中的数据是否小于另一个“大数”类型变量中的数据。


大于等于 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象是否大于等于指定对象。如大于等于，则返回真；否则，返回假。

语法： 逻辑型 大数．大于等于 （比较数据）

参数名 | 描 述
比较数据 | 必需的；大数。本参数提供待和本大数数据比较的大数。

例程：

说明：

通过“大于等于”命令判断一个“大数”类型变量中的数据是否大于或者等于另一个“大数”数据类型变量中的数据。


小于等于 方法 操作系统支持：Windows、Linux 所属对象：大数

判断本对象是否小于等于指定对象。如小于等于，则返回真；否则，返回假。

语法： 逻辑型 大数．小于等于 （比较数据）

参数名 | 描 述
比较数据 | 必需的；大数。本参数提供待和本大数数据比较的大数。

例程：

说明：

通过“小于等于”命令判断一个“大数”类型变量中的数据是否小于或者等于另一个“大数”类型变量中的数据。


取整数 方法 操作系统支持：Windows、Linux 所属对象：大数

获取本对象的整数部分，小数部分将被忽略，注意：返回数据的符号和原数据一致。

语法： 大数 大数．取整数 （）

例程：

说明：

通过“取整数”命令取得“大数”数据类型变量中整数部分数据。


取小数 方法 操作系统支持：Windows、Linux 所属对象：大数

获取本对象的小数部分，整数部分将被忽略， 注意：返回数据的符号和原数据一致。

语法： 大数 大数．取小数 （）

例程：

说明：

通过“取小数”命令取出“大数”类型变量中小数部分。取出的数据将是正负号加上0加小数点加小数部分。


加 方法 操作系统支持：Windows、Linux 所属对象：大数

将本对象与指定对象做加法运算，并返回运算后的结果。

语法： 大数 大数．加 （计算数据）

参数名 | 描 述
计算数据 | 必需的；大数。本参数提供待和本数据计算的大数数据。

例程：

说明：

通过“加”命令，将一个“大数”类型变量中的数据与另一个“大数”数据类型变量中的数据相加求和。


减 方法 操作系统支持：Windows、Linux 所属对象：大数

将本对象与指定对象做减法运算，并返回运算后的结果。

语法： 大数 大数．减 （计算数据）

参数名 | 描 述
计算数据 | 必需的；大数。本参数提供待和本数据计算的大数数据。

例程：

说明：

通过“减”命令，将一个“大数”类型变量与另一个“大数”类型变量中的数据相减求差。


乘 方法 操作系统支持：Windows、Linux 所属对象：大数

将本对象与指定对象做乘法运算，并返回运算后的结果。

语法： 大数 大数．乘 （计算数据）

参数名 | 描 述
计算数据 | 必需的；大数。本参数提供待和本数据计算的大数数据。

例程：

说明：

通过“乘”命令将一个“大数”类型变量中的数据与另一个“大数”类型变量中的数据相乘求积。


除 方法 操作系统支持：Windows、Linux 所属对象：大数

将本对象与指定对象做除法运算，并返回运算后的结果。

语法： 大数 大数．除 （计算数据，除法精度）

参数名 | 描 述
计算数据 | 必需的；大数。本参数提供待和本数据计算的大数数据。
除法精度 | 必需的；整数型，初始值为“1”。本参数提供本除法运算结果的精度。

例程：

说明：

通过“除”命令将一个“大数”类型变量与另一个“大数”类型变量中的数据相除求商。


整除 方法 操作系统支持：Windows、Linux 所属对象：大数

将本对象与指定对象做整除运算，并返回运算后的结果。

语法： 大数 大数．整除 （计算数据）

参数名 | 描 述
计算数据 | 必需的；大数。本参数提供待和本数据计算的大数数据。

例程：

说明：

通过“整除”命令进行一个“大数”类型变量中的数据与另一个“大数”类型变量中的数据间的整除运算。


求余 方法 操作系统支持：Windows、Linux 所属对象：大数

将本对象与指定对象做求余运算，并返回运算后的结果。

语法： 大数 大数．求余 （计算数据）

参数名 | 描 述
计算数据 | 必需的；大数。本参数提供待和本数据计算的大数数据。

例程：

说明：

通过“求余”命令计算一个“大数”类型变量中数据与另一个“大数”类型变量相除后的余数。


取绝对值 方法 操作系统支持：Windows、Linux 所属对象：大数

取本对象的绝对值。

语法： 大数 大数．取绝对值 （）

例程：

说明：

通过“取绝对值”命令取得一个“大数”类型变量中数据的绝对值。


负 方法 操作系统支持：Windows、Linux 所属对象：大数

反转一个本对象的正负符号并返回反转后的值。

语法： 逻辑型 大数．负 （）

例程：

说明：

通过“负”命令求一个“大数”数据类型变量中数据的相反数。


四舍五入 方法 操作系统支持：Windows、Linux 所属对象：大数

返回本对象按照指定的方式进行四舍五入运算的结果。

语法： 大数 大数．四舍五入 （舍入位置）

参数名 | 描 述
舍入位置 | 必需的；整数型，初始值为“0”。如果大于0，表示小数点右边应保留的位数；如果等于0，表示舍入到整数；如果小于0，表示小数点左边舍入到的位置。例如：四舍五入 (1056.65, 1) 返回 1056.7； 四舍五入 (1056.65, 0) 返回 1057； 四舍五入 (1056.65, -1) 返回 1060。

例程：

说明：

通过“四舍五入”命令求一个“大数”类型变量中数据的近似值。


清除小数 方法 操作系统支持：Windows、Linux 所属对象：大数

清除本对象的小数部分，成功返回真，失败返回假。

语法： 逻辑型 大数．清除小数 （）

例程：

说明：

通过“清除”小数命令将“大数”类型变量中数据中的小数部分清除掉。清除后的变量中只剩整数。


清除整数 方法 操作系统支持：Windows、Linux 所属对象：大数

清除本对象的整数部分，整数部分将被重置为0，成功返回真，失败返回假。

语法： 逻辑型 大数．清除整数 （）

例程：

说明：

通过“清除”整数命令清除“大数”数据类型变量中的整数部分。清除后变量中内容有符号加“0”加小数点及小数部分。


清除尾导零 方法 操作系统支持：Windows、Linux 所属对象：大数

清除本对象小数部分的尾段0，成功返回真，失败返回假。

语法： 逻辑型 大数．清除尾导零 （）

例程：

说明：

通过“清除尾导零”命令清除“大数”变量中尾部的所有0。


求正弦 方法 操作系统支持：Windows、Linux 所属对象：大数

反回本对象的正弦值，目前支持计算整数的正弦值，小数部分将被忽略。

语法： 大数 大数．求正弦 （计算精度）

参数名 | 描 述
计算精度 | 必需的；整数型，初始值为“3”。指明计算精度，注意：该精度为计算中的除法精度。

例程：

说明：

通过“求正弦”命令计算“大数”类型变量中数据的正弦值。


求余弦 方法 操作系统支持：Windows、Linux 所属对象：大数

反回本对象的余弦值，目前支持计算整数的余弦值，小数部分将被忽略。

语法： 大数 大数．求余弦 （计算精度）

参数名 | 描 述
计算精度 | 必需的；整数型，初始值为“3”。指明计算精度，注意：该精度为计算中的除法精度。

例程：

说明：

通过“求余弦”命令计算“大数”类型变量中数据的余弦值。


求正切 方法 操作系统支持：Windows、Linux 所属对象：大数

反回本对象的正切值， 目前支持计算整数的正切值，小数部分将被忽略。

语法： 大数 大数．求正切 （计算精度）

参数名 | 描 述
计算精度 | 必需的；整数型，初始值为“3”。指明计算精度，注意：该精度为计算中的除法精度。

例程：

说明：

通过“求正切”命令计算“大数”类型变量中数据的正切值。


求余切 方法 操作系统支持：Windows、Linux 所属对象：大数

反回本对象的余切值， 目前支持计算整数的余切值，小数部分将被忽略。

语法： 大数 大数．求余切 （计算精度）

参数名 | 描 述
计算精度 | 必需的；整数型，初始值为“3”。指明计算精度，注意：该精度为计算中的除法精度。

例程：

说明：

通过“求余切”命令计算“大数”类型变量中数据的余切值。


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。