邮件接收支持库

邮件接收支持库 帮助手册20080827版 返回支持库手册 返回首页

本支持库实现了对邮件接收的支持。

操作系统支持： Windows、Linux

命令类别：

邮件接收

其它数据类型：

邮件信息

附件信息

命令类型

适用版本，邮件接收支持库 （1.7#0版）


邮件接收

邮件接收 类别 跳至：邮件接收支持库


连接收信服务器 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

连接到指定的POP3邮件接收服务器，成功返回真，失败返回假。

语法： 逻辑型 连接收信服务器 （收信邮件服务器地址，端口号，用户名，密码，最长等待时间，重试次数）

参数名 | 描 述
收信邮件服务器地址 | 必需的；文本型。指定用作接收邮件的POP3邮件服务器地址。
端口号 | 必需的；整数型，初始值为“110”。指定欲连接到POP3邮件服务器上的端口号，如果本参数被省略，默认值为标准 110 端口。
用户名 | 必需的；文本型。指定在POP3邮件服务器上的用户帐号名称。
密码 | 必需的；文本型。指定在POP3邮件服务器上的用户帐号密码。
最长等待时间 | 必需的；整数型，初始值为“2000”。指定在收信过程中等待POP3邮件服务器响应的最大时间，单位为毫秒，如果本参数被省略，默认值为 2000 毫秒。
重试次数 | 必需的；整数型，初始值为“3”。指定在验证阶段，如果某一项(如：用户名或口令)验证失败后重试的次数。如果本参数被省略，默认值为 3 次。

例程：

说明：

连接到POP3邮件服务器。

注意：在连接到邮件服务器后，如果在一定的时间内不对邮件服务器进行操作，邮件服务器将自动断开连接。

参见：例程


断开收信服务器 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

断开通过“连接收信服务器”命令建立的到POP3邮件接收服务器的连接。

语法： 无返回值 断开收信服务器 （）

例程：

说明：

断开与邮件服务器的连接


获取邮件信息 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

获取目前服务器上邮件的个数和大小。

语法： 逻辑型 获取邮件信息 （个数，大小）

参数名 | 描 述
个数 | 必需的；整数型，参数数据只能提供变量。返回邮件的个数。
大小 | 必需的；整数型，参数数据只能提供变量。返回邮件的总的大小，单位为字节。

例程：

说明：

取得目前邮件服务器上邮件的个数和所有邮件的总大小。


获取邮件大小 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

获取每一封邮件的大小。

语法： 逻辑型 获取邮件大小 （第几封，大小，总数）

参数名 | 描 述
第几封 | 必需的；整数型，初始值为“-1”。指定是第几封邮件,如果此值为-1就表示获取每一封的大小。
大小 | 必需的；整数型，参数数据只能提供变量及变量数组。返回一封或多封邮件的大小。
总数 | 必需的；整数型。本参数在“第几封”为-1时有效,为“获取邮件信息”方法返回的邮件总数。

例程：

说明：

用本命令可以取得每一封邮件的大小。


接收邮件 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

返回“邮件信息”数据类型。

语法： 邮件信息 接收邮件 （第几封）

参数名 | 描 述
第几封 | 必需的；整数型。表示接收第几封邮件。

例程：

说明：

用本命令来接收邮件服务器中的邮件。


取邮件错误信息 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

取到最后一次的错误信息。

语法： 文本型 取邮件错误信息 （）

例程：

说明：

取得在对邮件服务器操作过程中发生的错误原因。


删除邮件 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

将服务器上某封邮件标记为删除。

语法： 逻辑型 删除邮件 （第几封）

参数名 | 描 述
第几封 | 必需的；整数型。表示删除第几封邮件。

例程：

说明：

删除选择的邮件。只是在邮件服务器上做删除标记，不是真的删除；当断开与邮件服务器的连接时，将自动从邮件服务器上删除。


复位邮件 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

将服务器上标记为删除的邮件标记为未删除。

语法： 逻辑型 复位邮件 （）

例程：

说明：

将服务器上标记为删除的邮件恢复为未删除，全部恢复，不是单个恢复。


接收邮件序号 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

此序号对于每个服务器是唯一的，可用来比较邮件是否接收到本地。

语法： 逻辑型 接收邮件序号 （第几封，序号）

参数名 | 描 述
第几封 | 必需的；整数型，初始值为“-1”。指定是第几封邮件,如果此值为-1就表示获取每一封的序号。
序号 | 必需的；文本型，参数数据只能提供变量及变量数组。返回一封或多封邮件的序号。

例程：

说明：

取得每一封邮件在邮件服务器上的序号。


接收邮件前几行 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

从服务器上获取邮件前几行的内容。

语法： 邮件信息 接收邮件前几行 （第几封，共几行）

参数名 | 描 述
第几封 | 必需的；整数型。指定是第几封邮件。
共几行 | 必需的；整数型。指定要获取邮件的前几行内容。

例程：

说明：

本命令也是接收邮件，但是只接收每个邮件的开始部分的内容，具体邮件的内容和邮件的附件都不取出来。


注册邮件接收回调函数 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

注册一个回调函数，主要用于接收邮件时的进度显示。注：此回调函数中不要进行耗时的操作，否则邮件服务器会断开!不要调用邮件接收支持库中和服务器交互的命令，否则可能出现死循环。

语法： 逻辑型 注册邮件接收回调函数 （函数地址）

参数名 | 描 述
函数地址 | 必需的；子程序指针。本参数表示函数的地址，是易语言定义的子程序的地址。为0表示取消注册的回调函数。子程序的参数第一个为“整数型”表示接收邮件命令类型值，是“命令类型”数据类型中的常量值；参数第二个为“整数型”表示接收第几封邮件；参数第三个为“整数型”表示本次接收到的数据量单位为字节。子程序返回值为逻辑型。返回真表示继续接收此邮件，返回假表示不接收此邮件。

例程：

说明：

本命令调用回调函数时要放在接收邮件的前面。每接收一定字节的邮件都要运行一次回调函数，当返回“假”时，只是不接收当次正在接收的一个邮件，其他邮件照常接收。


设置代理服务器 命令 操作系统支持：Windows、Linux 所属类别：邮件接收

设置代理服务器信息。注：此方法要在“连接收信服务器”命令之前调用。

语法： 逻辑型 设置代理服务器 （类型， 地址， 端口， 用户名， 口令）

参数名 | 描 述
类型 | 必需的； 整数型，初始值为“0”。表示代理服务器的类型，0：不用代理，1：HTTP1.1代理，2：SOCKS5代理。
地址 | 必需的； 文本型。表示代理服务器的IP地址。
端口 | 必需的； 整数型。表示代理服务器的端口。
用户名 | 必需的； 文本型。表示代理服务器需要验证的用户名。
口令 | 必需的； 文本型。表示代理服务器需要验证的口令。

例程：

说明：

设置代理服务器接收邮件。


邮件信息

邮件信息 普通类型 操作系统支持：Windows、Linux 跳至：邮件接收支持库

方法：

取发件人地址 | 取主题 | 取日期 | 取文本内容
取附件个数 | 取附件 | 取发件人名称 | 取回复地址
取原始信息 | 取超文本内容 |  |

参见： 基本数据类型


取发件人地址 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取发件人地址 （）

例程：

说明：

根据要显示的邮件的索引，取得邮件的发件人的地址。


取主题 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取主题 （）

例程：

说明：

根据邮件的索引，取得该邮件的主题。


取日期 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 日期时间型 邮件信息．取日期 （）

例程：

说明：

根据邮件的索引，取得邮件发送的日期。


取文本内容 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取文本内容 （）

例程：

说明：

根据邮件的索引，取得邮件的文本内容。


取附件个数 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 整数型 邮件信息．取附件个数 （）

例程：

说明：

取得当前某个邮件中附带的附件的个数。


取附件 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 附件信息数组 邮件信息．取附件 （）

例程：

说明：

取得邮件的附件信息。


取发件人名称 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取发件人名称 （）

例程：

说明：

取得邮件发送人的名称。


取回复地址 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取回复地址 （）

例程：

说明：

取得邮件发送人的回复地址。


取原始信息 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取原始信息 （）

例程：

说明：

取得邮件的原始信息。


取超文本内容 方法 操作系统支持：Windows、Linux 所属对象：邮件信息

语法： 文本型 邮件信息．取超文本内容 （）

例程：

说明：

要浏览超文本内容（HTML文件），就要将文本内容和附带的嵌入式文件放在同一个文件夹中。


附件信息

附件信息 普通类型 操作系统支持：Windows、Linux 跳至：邮件接收支持库

方法：

取大小 | 取类型 | 取文件名 | 取编码方式
取数据 | 取是否嵌入式附件 | 取名称 |

参见： 基本数据类型


取大小 方法 操作系统支持：Windows、Linux 所属对象：附件信息

语法： 整数型 附件信息．取大小 （）

例程：

说明：

根据附件的索引，取得当前某个附件的大小。


取类型 方法 操作系统支持：Windows、Linux 所属对象：附件信息

语法： 文本型 附件信息．取类型 （）

例程：

说明：

取得当前某个附件的文件类型。


取文件名 方法 操作系统支持：Windows、Linux 所属对象：附件信息

语法： 文本型 附件信息．取文件名 （）

例程：

说明：

取得当前邮件附带的某个文件（非嵌入式）的名称。


取编码方式 方法 操作系统支持：Windows、Linux 所属对象：附件信息

语法： 文本型 附件信息．取编码方式 （）

例程：

说明：

取得当前某个附件的编码方式。


取数据 方法 操作系统支持：Windows、Linux 所属对象：附件信息

语法： 字节集 附件信息．取数据 （）

例程：

说明：

取得某个附件的数据，保存成文件。


取是否嵌入式附件 方法 操作系统支持：Windows、Linux 所属对象：附件信息

语法： 逻辑型 附件信息．取是否嵌入式附件 （）

例程：

说明：

判断当前某个附件是否是嵌入式附件。所谓嵌入式附件：在网页中，除了文本内容外，还有图片等其它的内容，这样与文本内容相互混杂的文件即网页的嵌入式附件。而独立于网页之外的文件即是非嵌入式附件。


取名称 方法 操作系统支持：Windows、Linux 所属对象：附件信息

此命令取出的名称用作将嵌入式附件保存到磁盘上的文件名。包含超文本内容中的图片等（注：必需将它们放在同一个目录下）。

语法： 文本型 附件信息．取名称 （）

例程：

说明：

取得当前某个嵌入式附件的名称。


命令类型

命令类型 枚举常量集合类型 操作系统支持：Windows 跳至：邮件接收支持库

本数据类型包括了接收邮件命令的常量。

成员 | 描 述
等待接收数据 | 常量值为 0 。
验证用户名 | 常量值为 1 。
验证口令 | 常量值为 2 。
接收邮件 | 常量值为 3 。
获取邮件信息 | 常量值为 4 。
获取邮件大小 | 常量值为 5 。
删除邮件 | 常量值为 6 。
重置邮件 | 常量值为 7 。
获取邮件序号 | 常量值为 8 。
接收邮件前几行 | 常量值为 9 。
其它 | 常量值为 10 。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。