网络通讯支持库

网络通讯支持库 帮助手册20080827版 返回支持库手册 返回首页

本支持库实现对网络通讯的支持。

操作系统支持： Windows、Linux

命令类别：

网络通讯

其它数据类型：

网络服务器

网络客户端

网络数据报

对方信息

适用版本，网络通讯支持库 （1.1#0版）


网络通讯支持库

网络通讯支持库 类别 跳至：网络通讯支持库


取本机名 命令 操作系统支持：Windows 所属类别：网络通讯支持库

取本机名 命令 操作系统支持：Windows 所属类别：网络通讯

成功返回本地计算机名称，失败返回空字符串。

语法： 文本型 取本机名 （）

例程：

说明：

取得正在使用的计算机的名称。

参见：网络服务器例程 网络客户端例程 网络数据报例程


取本机IP 命令 操作系统支持：Windows 所属类别：网络通讯支持库

取本机IP 命令 操作系统支持：Windows 所属类别：网络通讯

取本机IP,返回IP列表数组。

语法： 文本型数组 取本机IP （）

例程：

说明：

取得正在使用的计算机的IP地址。


网络服务器

网络服务器 普通类型 操作系统支持：Windows、Linux 跳至：网络通讯支持库

方法：

启动 | 停止 | 监听 | 接收
发送 | 断开连接 | 取客户IP | 取客户端口

参见： 基本数据类型


启动 方法 操作系统支持：Windows 所属对象：网络服务器

启动网络服务器，绑定到指定端口，成功返回真，失败返回假。

语法： 逻辑型 网络服务器．启动 （端口）

参数名 | 描 述
端口 | 必需的；整数型。服务器的端口。

例程

说明：

根据端口号启动服务器相应端口，如果启动网络服务器成功，就启动线程，在线程中调用“监听子程序”来监听刚才启动的端口。


停止 方法 操作系统支持：Windows 所属对象：网络服务器

停止网络服务器，释放已绑定端口，成功返回真，失败返回假。

语法： 逻辑型 网络服务器．停止 （）

例程：

说明：

停止网络服务器的运行。


监听 方法 操作系统支持：Windows 所属对象：网络服务器

监听一个端口，等待一个客户端连接,如果设置为无限等待则有连接返回客户端句柄，如果设置等待时间，在等待时间内无连接则返回0，在等待之间之内有连接则返回客户端句柄,出错返回-1。

语法： 整数型 网络服务器．监听 （等待时间）

参数名 | 描 述
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待 其它 具体等待时间（毫秒）。

例程：

说明：

监听启动的端口，如果参数设置为0，则无限等待，本命令监听所有连接被监听端口的用户，如果有客户连接都会返回该客户相应的句柄，该句柄是唯一的，如果有多用户连接，可以把句柄保存在变量数组中，以便以后调用。


接收 方法 操作系统支持：Windows 所属对象：网络服务器

接收来自客户端的数据,出错返回空字节集,每次接受的最大长度为1024个字节。

语法： 字节集 网络服务器．接收 （客户端句柄，等待时间）

参数名 | 描 述
客户端句柄 | 必需的；整数型。通过“网络服务器.监听（）”得到的客户端句柄。
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待， 其它 具体等待时间（毫秒）。

例程

说明

接收来自客户端的数据。


发送 方法 操作系统支持：Windows 所属对象：网络服务器

向指定客户端发送数据。

语法： 逻辑型 网络服务器．发送 （客户端句柄，数据，等待时间）

参数名 | 描 述
客户端句柄 | 必需的；整数型。通过“网络服务器.监听（）”得到的客户端句柄。
数据 | 必需的；通用型。准备发送的数据。
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待 其它 具体等待时间（毫秒）。

例程：

说明：

向客户端发送数据，如果参数为“0”则不发送完毕，程序是不会向下进行的，所以如果是大量的数据，请在线程中发送，并且在发送结束之后，再给客户端发送一个完毕的确认信息。


断开连接 方法 操作系统支持：Windows 所属对象：网络服务器

断开指定客户端连接。

语法： 逻辑型 网络服务器．断开连接 （客户端句柄）

参数名 | 描 述
客户端句柄 | 必需的；整数型。通过“网络服务器.监听（）”得到的客户端句柄。

例程：

说明：

断开与指定客户端的连接，指定客户的句柄是监听命令的返回值。


取客户IP 方法 操作系统支持：Windows 所属对象：网络服务器

成功返回客户端IP地址，失败返回空字符串。

语法： 文本型 网络服务器．取客户IP （客户端句柄）

参数名 | 描 述
客户端句柄 | 必需的；整数型。通过“网络服务器.监听（）”得到的客户端句柄。

例程：

说明：

根据监听命令返回的客户句柄，可以用这个命令来取得客户的IP地址。


取客户端口 方法 操作系统支持：Windows 所属对象：网络服务器

成功返回客户端口号，失败返回-1。

语法： 整数型 网络服务器．取客户端口 （客户端句柄）

参数名 | 描 述
客户端句柄 | 必需的；整数型。通过“网络服务器.监听（）”得到的客户端句柄。

例程：

说明：

通过监听命令返回的客户句柄，使用这个命令取得连接客户是通过什么端口连接服务器的，这个端口是客户机器所开启的端口，并不是我们服务器所监听的端口。


网络客户端

网络客户端 普通类型 操作系统支持：Windows、Linux 跳至：网络通讯支持库

方法：

连接 | 断开 | 接收 | 发送
取本机端口 |  |  |

参见： 基本数据类型


连接 方法 操作系统支持：Windows 所属对象：网络客户端

连接到网络服务器,成功返回真，失败返回假。

语法： 逻辑型 网络客户端．连接 （IP地址，端口）

参数名 | 描 述
IP地址 | 必需的；文本型。待连接服务器的IP地址。
端口 | 必需的；整数型。待连接服务器的端口。

例程：

说明：

根据IP地址和端口号连接到网络服务器。


断开 方法 操作系统支持：Windows 所属对象：网络客户端

断开与网络服务器的连接,成功返回真，失败返回假。

语法： 逻辑型 网络客户端．断开 （）

例程：

说明：

断开与网络服务器的连接，返回真则断开成功，否则断开失败。


接收 方法 操作系统支持：Windows 所属对象：网络客户端

接收来自网络服务器的数据,出错返回空字节集,每次接受的最大长度为1024个字节。

语法： 字节集 网络客户端．接收 （等待时间）

参数名 | 描 述
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待 其它 具体等待时间（毫秒）。

例程：

说明：

接收来自网络服务器的数据。参数为0时则无限等待。


发送 方法 操作系统支持：Windows 所属对象：网络客户端

向指定网络服务器发送数据。

语法： 逻辑型 网络客户端．发送 （数据，等待时间）

参数名 | 描 述
数据 | 必需的；通用型。准备发送的数据。
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待 其它 具体等待时间（毫秒）。

例程：

说明：

向指定网络服务器发送数据。如果参数为0，在数据没有传送完毕之前，程序将无法向下进行，所以最好用启动线程中执行。


取本机端口 命令 操作系统支持：Windows 所属类别：网络通讯支持库

取本机端口 命令 操作系统支持：Windows 所属类别：网络客户端

成功返回本机端口号，失败返回-1。

语法： 整数型 取本机端口 （）

例程：

说明：

取得正在使用的计算机的端口号。


网络数据报

网络数据报 普通类型 操作系统支持：Windows、Linux 跳至：网络通讯支持库

方法：

配置 | 关闭 | 接收 | 发送
取本机端口 |  |  |

参见： 基本数据类型


配置 方法 操作系统支持：Windows 所属对象：网络数据报

配置网络数据报,成功返回真，失败返回假。

语法： 逻辑型 网络数据报．配置 （端口）

参数名 | 描 述
端口 | 必需的；整数型，初始值为“0”。数据报服务器的端口。

例程：

说明：

根据指定的端口来配置数据报，当数据报配置为该端口成功后，数据报就会在该端口等待数据进入。


关闭 方法 操作系统支持：Windows 所属对象：网络数据报

关闭网络数据报，成功返回真，失败返回假。

语法： 逻辑型 网络数据报．关闭 （）

例程：

说明：

关闭网络数据报。


接收 方法 操作系统支持：Windows 所属对象：网络数据报

接收来自网络数据报的数据,出错返回空字节集,每次接受的最大长度为1024个字节。

语法： 字节集 网络数据报．接收 （等待时间，对方信息，是否成功）

参数名 | 描 述
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待 其它 具体等待时间（毫秒）。
对方信息 | 必需的；对方信息，参数数据只能提供变量。获得对方的IP及端口信息。
是否成功 | 可选；逻辑型，可以被省略，提供参数数据时只能提供变量。如果提供本参数，在接收数据成功的情况下，其值将被改写为真，在接收数据失败的情况下，其值将被改写为假。

例程：

说明：

等待接收对方数据报发送的信息，当在规定时间内有信息到达，本条命令即触发，并返回接收到的数据，然后结束本条命令，如果想不停的接收数据，请在线程中调用自身，来完成不停接收数据的功能。


发送 方法 操作系统支持：Windows 所属对象：网络数据报

向指定网络数据报发送数据。

语法： 逻辑型 网络数据报．发送 （对方信息，数据，等待时间）

参数名 | 描 述
对方信息 | 必需的；对方信息。接收方IP及端口信息。
数据 | 必需的；通用型。准备发送的数据。
等待时间 | 必需的；整数型。等待连接的时间范围 0 无限等待，-1 不等待 其它 具体等待时间（毫秒）。

例程：

说明：

向指定网络数据报发送数据。


取本机端口 命令 操作系统支持：Windows 所属类别：网络通讯支持库

取本机端口 命令 操作系统支持：Windows 所属类别：网络数据报

成功返回本机端口号，失败返回-1。

语法： 整数型 取本机端口 （）

例程：

说明：

取得正在使用的计算机的端口号。


对方信息

对方信息 普通类型 操作系统支持：Windows、Linux 跳至：网络通讯支持库

成员 | 描 述
对方IP | 文本型；对方IP。
对方端口 | 整数型；对方端口。

参见： 基本数据类型


系统基本数据类型列表及其说明如下：

1. 字节型。可容纳 0 到 255 之间的数值。

2. 短整数型。可容纳 -32,768 到 32,767 之间的数值，尺寸为 2 个字节。

3. 整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值，尺寸为 4 个字节。

4. 长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值，尺寸为 8 个字节。

5. 小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值，尺寸为 4 个字节。

6. 双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值，尺寸为 8 个字节。

7. 逻辑型。值只可能为“真”或“假”，尺寸为 2 个字节。“真”和“假”为系统预定义常量，其对应的英文常量名称为“true”和“false”。

8. 日期时间型。用作记录日期及时间，尺寸为 8 个字节。

9. 文本型。用作记录一段文本，文本由以字节 0 结束的一系列字符组成。

10.字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换，在程序中允许使用字节数组的地方也可以使用字节集，或者相反。字节数组的使用方法，譬如用中括号对（“[]”）加索引数值引用字节成员，使用数组型数值数据进行赋值等等，都可以被字节集所使用。两者之间唯一的不同是字节集可以变长，因此可把字节集看作可变长的字节数组。

11.子程序指针。用作指向一个子程序，尺寸为 4 个字节。具有此数据类型的容器可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

    在以上的基本数据类型中，字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”，它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如：将整数 257 转换为字节后的结果为 1 ，这是因为值 257 超出了字节型数据的最大上限 255 ，从而产生了溢出。

    另外，通用型数据类型仅在系统内部使用，它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。